首頁

網路分析儀/E5080A

說明

快速入門 | 1. 設定 | 2. 最佳化 | 3. 校準
4. 分析資料 | 5. 列印/儲存 | 系統設定 | 程式設計

重要資訊

修訂記錄 | 韌體版本： A.11.7x/說明版本日期：2016-01-06
VNA 應用程式 | VNA 連接
量測教學課程 | 產品支援/規格
網路分析儀應用說明連結 | YouTube 影片連結

是否還在尋找答案？

將您的問題張貼到 Keysight 論壇

附註：為獲得最佳檢視結果，請使用 Microsoft Internet Explorer 瀏覽這些說明頁面。使用其他瀏覽器時，某些指令碼可能無法正確運作。


重要資訊

請閱讀以下資訊以節省您的寶貴時間和維修費用：

  • 在 Windows 或網路分析儀應用程式啟動期間，請勿按前面板上的任何鍵，也不要旋轉 RPG 按鈕或連線 USB 裝置。否則，可能會導致前面板進入鎖定狀態。 要清除此狀態，請先關閉再重新啟動 VNA（而不是使其休眠）。

  • 防止 VNA 固態磁碟機受損。

  • 遵循正確的 VNA 關機過程。

  • 執行顯示器測試以檢視 VNA 是否符合規格。

  • 檢視您的 VNA 模型的直流電壓損壞級別。

  • 請參見「防止 VNA 受到靜電損壞」

  • 請參見「防止測試連接埠接頭損壞」

  • 發貨時，VNA 未安裝任何病毒防護。如果要將 VNA 連線到網際網路，強烈建議使用防病毒程式。


修訂記錄

  • 第一版：2016 年 01 月 06 日

上次修改時間：

2016 年 01 月 06 日

新主題


設定新的 VNA 使用者

VNA 使用者帳戶和密碼

重要說明： 當 VNA 的電源開啟時，它會自動使用預設的使用者名稱和密碼登入 Windows。您無需登入。 如此可讓所有人都能取得分析儀的完整存取權。您可以採取以下措施來提高 VNA 的安全性。

  • 要求使用者在開啟 VNA 電腦後進行登入 - 瞭解如何啟用此功能

  • 在 VNA 上設定具有不同存取層級的個人帳戶 - 瞭解如何新增或變更使用者帳戶和密碼

請閱讀有關 VNA 的防毒保護資訊

現有的使用者帳戶

新的 VNA 上已存在下列使用者帳戶。

使用者名稱 | 密碼 | 類型 | 描述
Instrument | measure4u | 管理員 | 預設會啟用「自動登入」。
管理員 | Keysight4u! | 內建管理員 | 用於進行使用者維護。
Keysightonly | 不會向使用者公開 | 管理員 | 此帳戶由 Keysight 服務用於進行維修/維護。請勿移除此帳戶。

注意：使用者名稱不區分大小寫。密碼區分大小寫。

附註：VNA 本機原則已設定為每次需要登入時必須重新鍵入使用者名稱（和密碼）。請勿變更 VNA 的本機原則。

新增或變更使用者帳戶、密碼並要求登入

如果分析儀處於安全的環境中，您可以依名稱設定 VNA 使用者，並授予各種存取層級。透過 LAN 遠端控制或存取 VNA 時，這一點尤其重要。

您可以指定一位人員做為管理員，然後將 VNA 設定為允許其他具有較低權限的人員使用。也就是說，其他人員可以登入以使用分析儀，但他們無法執行管理員可以進行的所有管理功能。

附註： 若要連接並安裝新的 ECal 模組，您必須使用管理員帳戶登入。 存取權受限的使用者帳戶將無法載入 ECal 模組驅動程式。瞭解詳情。

暸解有關 Microsoft 使用者帳戶權限的詳細資訊（需要網際網路連線）。

如何新增使用者帳戶並要求登入

按一下開始，然後按一下控制台

按一下使用者帳戶

按一下管理其他帳戶。

注意： 請勿允許沒有密碼的管理員帳戶，即使 Windows 允許這樣做。網際網路病毒會尋找並利用這種情況。

按一下建立新的帳戶。

輸入帳戶名稱。

選取帳戶類型。

按一下建立帳戶。

附註：

標準的使用者帳戶將無法載入 ECal 模組驅動程式。瞭解詳情。

可選： 按一下建立密碼以要求使用者在登入時輸入密碼。

上次修改時間：

2016 年 01 月 06 日

第一版


VNA SSD 復原流程

從 VNA 固態硬碟問題復原

VNA 故障的主要原因是 VNA 固態硬碟 (SSD) 發生問題。這些問題通常是可以預防的（請參閱預防 VNA SSD 問題），並且在很多情況下可以復原。以下措施可使您的停機時間減少數週，並節省更換 VNA SSD 的成本。

本文件現透過 Keysight VNA 支援網站提供，網址為：http://www.keysight.com/find/na.

如果 VNA 確實遇到固態硬碟問題，您將無法存取本說明檔案，但您或許能夠從另一台電腦存取網際網路。


Windows 注意事項

Microsoft Windows 考量事項

在本主題中：

  • VNA 上的 Microsoft Windows

  • LAN 連線

  • 滑鼠設定

  • Windows 佈景主題

  • 列印

VNA 上的 Microsoft Windows

VNA 在出廠時已安裝了 Windows® Embedded Standard 7 作業系統。此作業系統支援 32 位元和 64 位元應用程式。

請務必保護您的硬碟！

VNA 故障的主要原因是 VNA 固態硬碟 (SSD) 發生問題。這些問題通常可以預防，而且在許多情況下都可以復原。暸解有關保護 VNA 的詳細資訊。

使用 USB

VNA 的前面板和後面板上都有 USB 連接埠。USB 的主要優點是可以「熱」連接和中斷連接，而且資料傳輸的速度也較快。也可以透過 USB 連線來使用電子校準模組。

首次將裝置插入 USB 連接埠時將需要等待一段時間。Windows 會報告它正在識別硬體、搜尋正確的驅動程式，然後安裝該驅動程式（如果找到的話）。

以後將相同的裝置重新連接到同一個連接埠時將會更快更容易，但如果將該裝置移至其他 USB 連接埠，則將必須再次等待硬體 ID 和驅動程式的搜尋過程。

瞭解 USB 限制的相關資訊。

LAN 連線

Windows 支援 DHCP 和固定的 IP 位址。另外，LAN 纜線的「熱」連接和中斷連接，以及系統匣區域中 LAN 狀態的視覺指示器，都使得 LAN 連線更為直覺。此外，硬體精靈可協助使用者進行系統硬體設定。

滑鼠設定

依預設，Windows 不允許您將右側的按鈕設定用於執行主要的功能（例如選取和拖曳）。若要變更任何滑鼠屬性，請按一下開始 > 控制台 > 滑鼠。在「滑鼠屬性」對話方塊中，選取任何您想要變更的設定，按一下套用，然後按一下確定。

Windows 佈景主題

在 Keysight Technologies 主題中檢視 VNA 應用程式的效果最佳。若要變更佈景主題，請：

  1. 最小化 VNA 應用程式。

  2. 以滑鼠右鍵按一下桌面，然後按一下個人化

  3. 使用捲軸選取一個佈景主題。

列印

新增印表機應在 VNA 應用程式外部進行。瞭解詳情。

上次修改時間：

2014 年 06 月 30 日

第一版


前面板概觀

按一下影像區域以瞭解更多資訊。

電源開關

用於在開機 (|) 和待機 (O) 狀態之間進行選擇。

瞭解如何開啟和關閉 VNA。

LCD 觸控螢幕

VNA 配備有 12.1 英吋 TFT 彩色觸控感應式 LCD 螢幕，用於顯示軌跡、刻度、設定、軟鍵以及其他與量測相關的資訊。觸控螢幕 LCD 允許透過直接觸摸 LCD 螢幕操作軟鍵。如需有關 LCD 觸控螢幕的詳細資訊，請參閱螢幕顯示概觀。

附註：

不要使用尖銳物件（例如，釘子、鋼筆或螺絲刀）按壓 LCD 觸控螢幕的表面。使用尖頭物件按壓表面會損壞 LCD 螢幕的表面或導致螢幕故障。

有效像素為 99.998 % 及以上。出現低於 0.002 % 的黑色、藍色、綠色或紅色固定點並不表示故障。

旋鈕

旋轉以增加或減少作用中項目的值或調整標記位址。

USB 集線器

USB 集線器包含 4 個 USB 連接埠，用於為 VNA 週邊設備供電。後面板上也有 4 個 USB 連接埠。

限制：所有 8 個 USB 連接埠的總功耗不能高於 4.0 安培。如果超過此限制，將停用所有 USB 連接埠，直到移除一個裝置，並且功耗低於限制。當首次連線時，ECal 模組 8509x 和 N4431 消耗的電流明顯大於其他模組。

附註：

首次 按序號將每個 USB 裝置（ECal 模組、功率感應器等等）連線到特定的 VNA USB 連接埠時，您必須使用管理員帳戶登入到 VNA。瞭解操作方法。

當顯示發現新硬體對話方塊時，請按一下確定來安裝裝置。

在安裝之後，當同一 USB 裝置連線到同一 USB 連接埠時，您可以使用「有限/使用者」帳戶登入到 VNA。

測試連接埠

這些模型都具有 2 個或 4 個測試連接埠。DUT 連線到的連接埠。連接埠數取決於選項。在從測試連接埠輸出訊號時，該測試連接埠上方的藍色 LED 指示燈會點亮。

有關測試連接埠連接器和輸入損壞級別的詳細資訊，請參閱規格。

附註：不要對測試連接埠施加直流電壓或電流。施加直流電壓或電流會導致裝置發生故障。尤其是在電容器保持充電的情況下。在將分析儀完全放電後，將量測樣本 (DUT) 連線到測試連接埠（或連線到測試連接埠的測試固定裝置、電纜等）。測試連接埠的最大直流限值為 35V。

接地端子

將香蕉型插頭連線到此端子，以與 VNA 底盤接地。

硬鍵

INSTRUMENT 鍵

管理 VNA 顯示器上的軌跡和通道。

硬鍵 | 叫用這些軟鍵
[Prev] | 使上一個軌跡/通道/視窗處於作用中狀態。
[Next] | 使下一個軌跡/通道/視窗處於作用中狀態。
[Trace] | 叫用「軌跡」軟鍵功能表，用於管理軌跡。
[Channel] | 叫用「通道」軟鍵功能表，用於管理通道。

RESPONSE 鍵

在資料量測後對量測軌跡執行作業，並控制「資料分析」的所有方面。

硬鍵

叫用這些軟鍵

[Meas]

S 參數

平衡參數

  • 平衡源/拓撲

接收器

波導

輔助輸入

量測概觀

  • 量測類別

  • 轉換

  • 修正

  • 軌跡保持

  • 方程式編輯器

  • 記憶體

  • 時域

[Format]

格式 1

  • 格式

  • 群組延遲孔徑

格式 2

[Scale]

主刻度

  • 自動縮放/速度係數

  • 媒體 -波導/同軸

  • 刻度

  • 參考位準

  • 參考位置

  • 刻度耦合

電延遲

  • 延遲時間

  • 延遲距離

  • 距離單位

  • 速度係數

  • 媒體 -波導/同軸

  • 波導截止頻率

常數

  • 系統 Z0

  • 相位偏移

  • 幅度偏移

  • 幅度斜率

[Math]

主記憶體

  • 資料/記憶體數學運算

  • 顯示資料/記憶體軌跡

分析

  • 轉換

  • 方程式編輯器

  • 軌跡統計

  • 限值測試裝置

  • 限值資料表

時域

  • 變換

  • 時域模式

  • 時域工具列

時間閘控

  • 閘控

  • 閘控類型

  • 閘控形狀

[Avg]

主平均

  • 平均

  • 平均重新啟動

  • IF 頻寬

  • LF Auto BW

平滑

  • 平滑

  • 平滑百分比

  • 平滑點

群組延遲

  • 孔徑百分比

  • 孔徑點

  • 孔徑頻率

[Cal]

主校準

  • 基本校準

  • 校準精靈

  • 校準所有精靈

  • 修正

  • 內插

其他校準

  • 來源功率校準

  • 接收器功率校準

  • 接收器內插

  • 校準偏好設定精靈

連接埠延伸

  • 連接埠延伸

  • 時間

  • 距離

  • 速度

  • 直流損失

  • 自動連接埠延伸

校準集和校準套件

  • 校準集

  • 校準集檢視器

  • 校準套件

  • Ecal 可信度檢查

  • 表現 ECal 模組的特性

  • ECal 記憶體

固定裝置

  • 套用固定裝置

  • 功率補償

  • 2 連接埠取消內嵌

  • N 連接埠取消內嵌

  • 校準平面管理器

固定裝置匹配

  • 套用固定裝置

  • 連接埠匹配

  • 差分連接埠匹配

  • 連接埠 Z 轉換

  • 差分阻抗轉換

  • 共模阻抗轉換

[Marker]

標記 1-7

標記 8-15

標記設定

  • 差量

  • 離散

  • 類型

  • 格式

  • 耦合

  • 標記顯示

  • 標記表格

  • 全部關閉

標記 -> 功能

  • 標記 -> 開始

  • 標記 -> 停止

  • 標記 -> 中心

  • 標記 -> 參考位準

  • 標記 -> 延遲

  • 標記 -> CW 頻率

[Search]

主搜尋

  • 最大值搜尋

  • 最小值搜尋

  • 域

  • 追蹤

峰值

  • 峰值搜尋

  • 閾值

  • 偏離

  • 峰值極性

  • 追蹤

目標

  • 目標搜尋

  • 目標值

  • 轉換

  • 追蹤

多峰值搜尋和目標

  • 多峰值搜尋

  • 峰值閾值

  • 峰值偏離額定值

  • 峰值極性

  • 多目標搜尋

  • 目標值

  • 轉換

  • 追蹤

頻寬和帶阻濾波

  • 頻寬搜尋

  • 標記/峰值 BW 參考

  • BW 位準

  • 帶阻濾波搜尋

  • 標記/峰值帶阻濾波參考

  • 帶阻濾波位準

  • 追蹤

壓縮和飽和度

  • 壓縮搜尋

  • 壓縮級別

  • 飽和度搜尋

  • Pmax 補償

  • 追蹤

正常作業點

  • 正常作業搜尋

  • 補償

  • 接腳偏移

  • 追蹤

STIMULUS 鍵

控制確定量測哪些資料（激勵範圍）以及如何量測資料（掃描類型和觸發）的設定。

硬鍵

叫用這些軟鍵 - 按下瞭解詳細資料

[Freq]

頻率範圍

頻率偏移模式

[Power]

主功率位準

  • 功率位準

  • RF 功率

  • 功率和衰減器

連接埠功率

  • 功率位準

  • 來源狀態

  • 耦合

調整和偏移

  • 斜率

  • 偏移

  • 限制

  • 偏移和限制

[Sweep]

主掃描

  • 點數

  • 掃描類型

掃描定時

  • 掃描時間

  • 駐留時間

  • 掃描延遲

  • 掃描模式

來源類型

  • 頻率偏移

  • 平衡來源/拓撲

  • 偏移 LO

區段表格

  • 區段表格設定

[Trigger]

主觸發

  • 觸發來源

    • 內部

    • 手動

    • 外部

  • 觸發設定

UTILITY 鍵

執行全域 VNA 作業。

硬鍵

叫用這些軟鍵 - 按下瞭解詳細資料

[Save

Recall]

重新叫用

  • 重新叫用狀態

  • 重新叫用順序

  • 重新叫用暫存器

  • 重新叫用校準集

  • 重新叫用資料

儲存狀態

  • 儲存狀態

  • 自動儲存

  • 儲存暫存器

  • 儲存類型

  • 刪除狀態

儲存其他

  • 儲存校準集

  • 儲存軌跡

  • 儲存資料。

  • 儲存螢幕

  • 儲存使用者預設

  • 管理檔案

[Macro/Local]

（尚未實現）

[Undo]

主復原

  • 復原

  • 重做

  • 返回到任務

  • 清除復原記錄

[System]

主系統

  • 顯示工作列

  • 將應用程式移至後面

  • 應用程式縮到最小​​

  • 結束

  • 安全性設定

  • 控制台

  • 管理檔案

系統設定

  • 下一個/上一個鍵

  • 偏好設定

  • SICL / GPIB

  • LAN 狀態

  • 代碼模擬

  • 控制台 (Windows)

  • 系統 Z0

  • 功率表設定

  • 公釐波模組

列印

  • 列印

  • 列印至檔案

  • 頁面設定

  • 列印顏色

說明

  • NA 說明

  • Web 上

  • 錯誤顯示

  • 檢視錯誤記錄檔

  • 關於 NA

服務 1

  • Agile 更新

  • 操作員檢查

  • 系統驗證

  • 調整

服務 2

  • 顯示器測試

  • 前面板測試

  • 後面板/H11 測試

  • 節點監視器

  • 效能測試

服務 3

  • 接收器顯示

  • 檢視 EEPROM 標題

  • 還原 Ecal 記憶體

  • 舊連接埠擴展

  • 喇叭音量

  • 清除復原記錄

  • 接收器溫度

[Help]

啟動此說明檔案。

[Preset]

標準預設

使用者預設

出廠預設

使用者預設設定

確認預設

ENTRY 鍵

硬鍵

叫用這些軟鍵

[OK]

關閉對話方塊，並在對話方塊中輸入任何值。

[Cancel]

關閉對話方塊。

[Back Space]

退格。使游標退後並刪除以前的任何選擇。

[0 to 9]

選取量測設定的值，然後按 Enter 鍵或 T/p - G/n - M/u - k/m 以完成選取。

[T/p]

[G/n]

[M/u]

[k/m]

完成值選取，指派量測單位。

  • T/p (Tera/piko) E12 或 E-12

  • G/n (Giga/Nano) E9 或 E-9

  • M/u (Mega/micro) E6 或 E-6

  • k/m (kilo/milli) E3 或 E-3

[Enter]

輸入您為量測設定選取的值。

[Decimal point]

輸入一個小數點來指定整個數的小數部分。

+/-

如果它是項目中第一個按下的鍵，在正值和負值之間進行加 - 減切換。

導覽鍵

這些鍵允許您在功能表和對話方塊中導覽，並從作用中項目工具列中選取選項。

硬鍵

叫用這些軟鍵

左/右

在功能表中左右移動。

在對話方塊中移動左側標籤和右側標籤。

上/下

在功能表中上下移動。

在對話方塊的行為如下：

  • 修改數值

  • 在下拉式清單中的項中移動

  • 在一組選項按鈕中的選項按鈕中移動

按一下

如按下滑鼠一樣進行選擇。

上次修改時間：

2016 年 01 月 06 日

第一版


螢幕顯示概觀

按一下影像區域以瞭解更多資訊。

變更 VNA 顯示設定

VNA 的顯示是由協力廠商顯示驅動程式控制的。此驅動程式可以產生多種顯示效果，超出了 VNA 量測環境的基本需要。Keysight 不指定這些顯示設定，也不為其提供保固。

警告：VNA 顯示必須保持在 16 位顏色設定，以符合國際排放法規。

還原 VNA 顯示設定

使用外部程式控制 VNA 時，顯示設定可能會出現故障。發生這種情況時，下列作業將還原 VNA 的顯示設定：

  • 按下 [System] > Main（主功能表）> Minimize Application（應用程式縮到最小）。

  • 以滑鼠右鍵按一下桌面，然後按一下個人化。

  • 在「主題」標籤上，選取 Keysight Theme。

另請參閱

  • 關於觸控螢幕

  • 前面板概觀

  • 標記拖動

  • 擴展的滑鼠功能

  • 自訂 VNA 螢幕

  • 瞭解如何測試顯示螢幕

關於觸控螢幕

VNA 配備有 12.1 英吋高解析度彩色觸控感應式 LCD 螢幕，用於顯示軌跡、軟鍵以及其他與量測相關的資訊。藉助觸控螢幕 LCD，直接用手指觸摸 LCD 螢幕即可進行量測設定。

重要說明：

  • 不要使用鋼筆等尖銳物件按壓 LCD 螢幕的表面。這會損壞 LCD 螢幕的表面或導致螢幕故障。

  • 有時，螢幕上的幾個像素可能會顯示為一個藍色、綠色或紅色的固定點。這不是 LCD 螢幕故障，並不影響您的產品效能。

  • 因為 LCD 螢幕不太可能老化。此外，我們不建議在 VNA 上使用螢幕保護程式。

如何校準或開啟|關閉觸控螢幕

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Display] > Display Settings（顯示設定）。

  2. 按一下 Touchscreen（觸控螢幕）將其開啟/關閉。

透過該功能表、偏好設定對話方塊或遠端變更之前，觸控螢幕開啟|關閉設定保持不變。

作用中項目

可讓您輕鬆選取工具。瞭解詳情。

軌跡狀態

提供視窗中每個軌跡的詳細資料。醒目顯示的軌跡表示作用中軌跡。瞭解詳情。

輸入工具列

使用軟鍵時，允許為設定輸入數字值。

標記讀數

提供標記的激勵和回應資訊。瞭解自訂標記讀數區域。請參閱標記拖動。

軟鍵

硬鍵和軟鍵的組合可用於在不使用滑鼠的情況下輕鬆存取所有的 VNA 功能。

SoftTab

這些表示按下標籤將顯示軟鍵。

硬鍵

執行介面作業相當於 VNA 前面板上的 INSTRUMENT 鍵、RESPONSE 鍵、STIMULUS 鍵以及 UTILITY 鍵。瞭解詳情。

視窗編號

提供視窗標識，這對遠端程式設計師很有幫助。

狀態列

提供關於 VNA 狀態所有方面的細節。瞭解詳情。

激勵範圍

顯示掃描範圍的起始和結束值。

軟鍵工具列

這些稱為捷徑圖示，用於快速選取軟鍵上的工具。瞭解詳情。

標記拖動

使用一根手指（觸控螢幕開啟時）或滑鼠即可沿軌跡拖動顯示的標記。瞭解詳情。

擴展的滑鼠功能

  • 滑鼠暫留在一個可點選的物件上時游標變更為「手」。

  • 用滑鼠右鍵按一下「項目」工具列，以啟動滑鼠相容的數字小鍵盤。

對於視窗

  • 用滑鼠右鍵按一下視窗區域，以選取與該視窗相關的選項。

  • 在視窗區域上按兩下，以最大化視窗。要傳回到原始視窗組態，在窗口區域按一下滑鼠右鍵，然後按一下並排。

  • 滑鼠左鍵按一下 X 軸註解，以選取作用中通道/軌跡。

  • 滑鼠右鍵按一下 X 軸註解，然後按一下 開始/停止/中心...，變更激勵屬性。

  • 快速變更「刻度」、「參考位準」和「位置」。瞭解詳細資訊。

  • 滑鼠右鍵按一下 Y 軸註解，然後按一下刻度...來變更刻度。

  • 將軌跡從一個視窗拖動到另一個視窗。按一下或觸摸軌跡或軌跡狀態。 將軌跡拖動到另一個視窗，然後放開滑鼠硬鍵或抬起手指。

對於軌跡

  • 滑鼠左鍵按一下軌跡狀態使其成為選定軌跡。

  • 連按兩下軌跡或軌跡狀態，使軌跡最大化。再次按兩下以返回到原始軌跡組態。請參見程式設計命令。

  • 設定偏好設定以始終擴大作用中軌跡。

  • 設定偏好設定以暫時擴大作用中軌跡。

  • 將軌跡從一個視窗拖動到另一個視窗。按一下或觸摸軌跡或軌跡狀態。 將軌跡拖動到另一個視窗，然後放開滑鼠硬鍵或抬起手指。

對於標記

  • 滑鼠右鍵按一下軌跡或軌跡狀態來新增標記。

  • 滑鼠右鍵按一下標記以選取與該標記相關的選項，例如「標記搜尋」或「功能」。

對於軟鍵

  • 使用觸控螢幕或相鄰按鈕從 8 個動態軟鍵功能表選項中進行選取。

  • 要顯示軟鍵，請按下螢幕上的任何前面板硬鍵啟動軟鍵功能表。

軟鍵註解

項目

描述

功能表...

選取啟動一個對話方塊。

功能表

選取在左側啟動更多相關軟鍵。

上次修改時間：

2016 年 01 月 06 日

第一版


後面板導覽

按一下影像區域以瞭解更多資訊。

風扇

用於控制 VNA 內部溫度的冷卻風扇。此風扇會將分析儀內的熱空氣排出。

線路開關

此開關應始終保持在開啟狀態 ( | )。

注意：請勿使用此開關關閉 (O) 主電源，否則可能會導致 VNA 故障。如需詳細資訊，請參閱線路電源的說明。

線路電源

連接電源線的插座。

附註：若要將裝置連接至電源（電源插座），請使用產品提供的具接地導體的三腳電源線。附接在電源線的插頭（位於該電源線的電源插座端或裝置端）會用作 VNA 的切斷裝置（切斷電源供應的裝置）。在必須切斷電源以避免如觸電之類的危險時，請拔掉電源線插頭（位於該電源線的電源插座端或裝置端）。如需關閉正常使用的主電源的步驟，請參閱電源開關的說明。

請參閱規格

外部參考訊號輸入連接埠 (10MHz Ref In)

在此連接埠偵測到 10 MHz 外部參考訊號時，該訊號將用作儀器頻率參考而不是內部頻率參考。

備註：將外部頻率參考訊號輸入此接頭時，VNA 所發生的量測訊號的相位將自動鎖定為該參考訊號。當輸入訊號不存在時，將自動使用 VNA 內部的頻率參考訊號。當系統所發出訊號的相位鎖定至外部參考訊號時，儀器狀態列上的 ExtRef 會顯示為藍色，未鎖定相位時，則顯示為灰色。

使用選件 1E5（高穩定性頻率參考）時，藉由使用此選件隨附的 BNC(m)-BNC(m) 纜線，可將此接頭連接至高穩定性頻率參考輸出接頭（Ref Oven，僅限選件 1E5）。

規格 | 值
接頭類型 | BNC(f) 接頭
輸入訊號 | 10MHz ± 10ppm，- 3 至 + 10 dBm

請參閱 SCPI 命令，此命令用於偵測此接頭的外部參考訊號。

請參閱規格

內部參考訊號輸出連接埠 (10MHz Ref Out)

此接頭用於輸出 VNA 所發出的內部頻率參考訊號，以使該訊號為其他測試設備所用。藉由將此輸出接頭連接至其他裝置的外部參考訊號輸入連接埠，可將該裝置所發出訊號的相位鎖定至 VNA 的內部參考訊號，並且可在此條件下使用。

規格 | 值
接頭類型 | BNC(f) 接頭
輸出訊號 | 10MHz ± 5ppm、0 dBm ± 3dBm
輸出阻抗（典型值） | 50 ohm

請參閱規格

高穩定性頻率參考輸出連接埠（Ref Oven，僅限選件 1E5）

安裝選件 1E5（高穩定性頻率參考）後，參考訊號便會由此接頭輸出。請參閱規格

規格 | 值
接頭類型 | BNC 接頭，母頭
輸出訊號（典型值） | 10MHz ± 1ppm，最小值 0 dBm

附註：安裝選件 1E5（高穩定性頻率參考）後，藉由使用此選件隨附的 BNC(m)-BNC(m) 纜線，可將此接頭連接至外部參考訊號輸出接頭 (10MHz REF IN)。

輔助輸入連接埠 (AUX IN 1&2)

輔助輸入連接埠用於輸入 DC 訊號以進行 DC 訊號量測。

GPIB（通用介面匯流排）控制器和資訊源/接收器連接埠

VNA 可以是 GPIB 控制器和資訊源/接收器。

透過 GPIB 接頭連接外部控制器，可設定自動量測系統。此 GPIB 接頭僅用於由外部控制器控制 VNA。使用 USB/GPIB 介面可從 VNA 控制其他裝置。您無法透過 GPIB 接頭從 VNA 控制其他裝置。瞭解詳情。

USB (USBTMC) 裝置

透過此連接埠，可以從外部控制器控制 VNA。如需使用 USB 連接埠的量測系統詳細資訊，請參閱遠端控制連接至 VNA 的 SCPI USB 裝置。

規格 | 值
接頭類型 | 通用序列匯流排 (USB) 插孔、B 型（4 個接觸位置），母頭
法規遵循標準 | USBTMC-USB488 和 USB2.0

暸解詳細資訊

VGA 接頭

用於連接外部彩色顯示器（顯示裝置）的端子。將彩色顯示器連接至此端子，可以在外部彩色顯示器上顯示主機 LCD 觸控螢幕上顯示的相同資訊。

USB（通用序列匯流排）集線器

USB 集線器包含 4 個 USB 連接埠，用於為 VNA 週邊設備供電。在前面板上，也有四個 USB 連接埠。

提供的四個 USB 可用於連接至 ECal（電子校準）模組、USB、多埠測試裝置或印表機。將指定的 ECal 模組連接至此連接埠，可進行 ECal 量測。將相容的印表機連接至此連接埠，即可列印 VNA 螢幕上的資訊。

限制：所有 8 個 USB 連接埠的總功耗不能高於 4.0 安培。如果超過此限制，將停用所有 USB 連接埠，直到移除一個裝置，並且功耗低於限制。當首次連線時，ECal 模組 8509x 和 N4431 消耗的電流明顯大於其他模組。請參閱規格。

請參閱首次 USB 連接重要注意事項。

LAN（區域網路）接頭

此端子用於將 VNA 連接至 LAN，如此您便可以從外部 PC 存取此儀器的固態硬碟，或使用 SICL-LAN 或 Telnet 控制此儀器。

此 10/100Base-T 乙太網路連線具有標準的 8 接腳組態，以及在兩個資料速率之間自動選取的功能。

材料處理器 I/O

此端子連接生產線上使用的自動機器（處理器）。請參閱詳細資訊。

量測（外部）觸發輸入

啟用後，此接頭上的訊號將觸發 VNA。

輸入量測觸發訊號的接頭。此接頭可偵測 TTL 訊號從高電位狀態向下轉變成觸發訊號。若要使用此接頭來產生觸發，必須將觸發來源設定為「外部」（硬鍵操作：觸發 > 主功能表 > 觸發來源 > 外部）。

接頭類型：BNC 接頭，母頭。瞭解詳情。

輔助觸發輸出

啟用後，VNA 將在量測之前或量測之後輸出這些接頭上的訊號。瞭解詳情。

固態硬碟 (SSD)

有兩種 SSD 選件。

  • 非卸除式 SSD 選件。

  • 卸除式 SSD 選件

請參閱服務指南以瞭解如何拆卸 SSD。（需要網際網路連線）

請參閱預防 VNA 固態硬碟發生問題

正版證明標籤

顯示 Windows 正版證明資訊的標籤。

序號牌

顯示產品編號、序號和已安裝選件編號的標籤。配件和系統機架選件未列在此標籤中。（第一行中的 CFGxxx 或 ATOxxx 僅用於 Keysight。）

偏壓輸入連接埠

此 BNC 母頭接頭可使外部偏壓施加於測試連接埠。

連接您的 DC 電源供應器，以透過 BNC 接頭將偏壓輸入施加於 VNA 連接埠。

注意：請勿施加超過 35 伏的 DC 電壓。

偏壓輸入連接埠的保險絲

規格 | 描述
保險絲額定值 | 0.5A/125V
零件編號 | 2110-1439

  • 偏壓保險絲的額訂值為 0.5A。您必須確保連接至測試連接埠的裝置接通的電流不會超過 0.5A。例如，如果在偏壓電源接通的情況下將校準 SHORT 連接至測試連接埠，將會發生這種情況。

  • 當偏壓電流高達 200 mA 時，VNA 將符合其所有的 RF 規格。DC 偏壓增加後，已修正的來源匹配和方向性會在 RF 頻率較低時降級。

上次修改時間：

2016 年 01 月 06 日

第一版


開啟和關閉 VNA 電源

本主題介紹以下內容：

  • 如何登出、關閉或重新啟動 VNA

  • 開啟模式

  • 關閉模式

  • 拔下 VNA 的插頭

備註： 在 Windows 或網路分析儀應用程式啟動期間，請勿按下前面板上的任何硬鍵、旋轉 RPG 旋鈕或連接 USB 裝置。否則，可能會導致前面板進入鎖定狀態。如果 VNA 前面板鍵台或 USB 連接埠沒有回應，請關閉或重新啟動 VNA。

登出、關閉或重新啟動 VNA

如何登出、關閉或重新啟動 VNA

  1. 將 VNA 應用程式最小化。

  2. 按一下 Window 開始。

  3. 有一些動作可供選擇：

    • 登出（關閉程式）

    • 關閉

    • 重新啟動（關閉並啟動）

或

  1. 按下前面板上的 VNA 電源按鈕（僅適用於關閉操作）

附註： 只有當 VNA 處於鎖定狀態而且您無法操作滑鼠或鍵台時，才應按住電源按鈕至少四秒鐘。 應避免這種做法！ 以此方式反覆執行關閉操作將會損壞固態硬碟。瞭解有關損壞 VNA 硬碟的詳細資訊。

開啟模式

  • 若要開啟 VNA，請按下電源按鈕。

  • 開啟電源時，電源指示燈將會變成綠色。

關閉模式

  • 在關閉模式下，在關閉 VNA 的電源之前，不會自動儲存目前的儀器狀態。

  • 再次開啟 VNA 的電源時，將會執行完整的系統啟動，而且 VNA 會以預設設定開機。

  • 若要在處於關閉模式之後恢復 VNA 作業，可能需要輸入密碼。瞭解詳情。

  • 為了確保您的量測符合 VNA 指定的效能，請在電源指示燈變為綠色之後讓 VNA 暖機 90 分鐘。

  • 關閉電源時，電源指示燈將會變成橙色。

附註：如果 VNA 處於鎖定狀態而且您無法操作滑鼠或鍵台，請按住電源按鈕至少四秒鐘以關閉 VNA。
應避免這種做法！ 以此方式反覆執行關閉操作將會損壞硬碟。瞭解有關損壞 VNA 硬碟的詳細資訊。

拔下 VNA 的插頭

  • 只有當電源指示燈為橙色（處於休眠或關閉模式）時才可拔下 VNA 的電源線。如果在電源指示燈為綠色（即 VNA 處於開啟狀態）時拔下電源線，則極有可能導致固態硬碟損壞。

  • 拔下電源線之後，指示燈將會繼續保持橙色幾秒鐘的時間。

上次修改時間：

2014 年 08 月 07 日

第一版


VNA 中的軌跡、通道和視窗

VNA 上的軌跡、通道、視窗及資料表

瞭解下列術語的意義至關重要，因為 VNA 上會使用這些術語。

  • 軌跡 - 管理

    • 軌跡最大化

    • 軌跡保持

  • 通道 -管理

  • 視窗 - 管理

  • 資料表 - 管理

其他快速入門主題

軌跡

軌跡是一系列量測的資料點。從理論上來說，軌跡數並沒有限制。不過，實際的限制為視窗數上限乘以每個視窗的軌跡數上限 (24)。如果軌跡數超過每個視窗的軌跡數上限，它將會自動針對該軌跡開啟另一個視窗。

此外，還可以儲存和顯示每個資料軌跡的一個記憶體軌跡。暸解有關數學/記憶體軌跡的詳細資訊。

軌跡設定會影響量測資料的表示法和數學運算。

以下是軌跡設定：

  • 參數

  • 格式和刻度

  • 平滑

  • 修正開啟/關閉

  • 電延遲

  • 相位偏移

  • 軌跡數學運算

  • 標記

  • 時域（選項 010）

管理軌跡

  • 如何新增軌跡

  • 如何選取軌跡

  • 如何刪除軌跡

  • 如何移動軌跡

  • 如何最大化軌跡

  • 如何使軌跡保持最大值或最小值

  • 如何顯示自訂軌跡標題（獨立主題）

  • 如何顯示寬的作用中軌跡 （獨立主題）

如何新增軌跡

只能選取與目前指派給通道的量測位於相同量測類別中的量測。若要選取這些量測以外的量測，請先將適當的量測類別選至新的或現有的通道。瞭解詳細資訊。

必須先選取（作用中）某個軌跡後才能變更其軌跡設定。

如何知道哪個軌跡是作用中的軌跡？

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 針對軌跡 1-8，按下 [Trace] > Trace 1-8（軌跡 1-8）> 按一下左側的 Trace 1-8（軌跡 1-8）小按鈕
    （範例：按一下左側的「軌跡 1」小按鈕，如果它變成綠色，即表示「軌跡 1」是作用中的軌跡，因此新增「軌跡 1」）。

  2. 針對軌跡 9-16，請按下 [Trace] > Trace 9-16（軌跡 9-16）> 按一下左側的 Trace 9-16（軌跡 9-16）小按鈕
    （範例：按一下左側的「軌跡 9」小按鈕，如果它變成綠色，即表示「軌跡 9」是作用中的軌跡，因此新增「軌跡 1」）。

  3. 針對其他軌跡號碼，請按下 [Trace] > Trace Setup（軌跡設定）> Add Trace（新增軌跡），然後選取 New Trace（新建軌跡）、New Trace + Channel（新建軌跡 + 通道）、New Trace + Window（新建軌跡 + 視窗）、New trace + Channel + Window（新建軌跡 + 通道 + 視窗）或 Create Traces...（建立軌跡...）。

  1. 以滑鼠右鍵按一下網格方塊，然後選取 New Trace...（新建軌跡...）。

如何選取軌跡

只能選取與目前指派給通道的量測位於相同量測類別中的量測。若要選取這些量測以外的量測，請先將適當的量測類別選至新的或現有的通道。瞭解詳細資訊。

必須先選取（作用中）某個軌跡後才能變更其軌跡設定。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Trace] > Trace Setup（軌跡設定）> Select（選取）。

  2. 選取對應於所需量測參數的軌跡號碼。

  1. 按一下網格方塊上方的軌跡狀態標籤的任何軌跡。

如何刪除軌跡

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 針對軌跡 1-8，請按下 [Trace] > Trace 1-8（軌跡 1-8）> 按一下左側的 Trace 1-8（軌跡 1-8）小按鈕
    （範例：按一下左側的「軌跡 1」小按鈕，如果它未變成綠色，即表示「軌跡 1」為非作用中的軌跡）。

  2. 針對軌跡 9-16，請按下 [Trace] > Trace 9-16（軌跡 9-16）> 按一下左側的 Trace 9-16（軌跡 9-16）小按鈕
    （範例：按一下左側的「軌跡 9」小按鈕，如果它未變成綠色，即表示「軌跡 9」為非作用中的軌跡）。

  3. 針對其他軌跡號碼，請按下 [Trace] > Trace Setup（軌跡設定）> Delete Trace...（刪除軌跡...），然後選取軌跡號碼。

  1. 以滑鼠右鍵按一下網格方塊上方的軌跡狀態標籤，然後按一下刪除軌跡...。

如何將軌跡移至不同的視窗

您可以將軌跡從一個視窗拖曳至另一個視窗，或者...

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Trace] > Trace Setup（軌跡設定）> Move Trace...（移動軌跡...）。

  2. 在以下對話方塊中選取一個視窗號碼，然後按一下 OK（確定）。

  1. 以滑鼠右鍵按一下網格方塊上方的軌跡狀態標籤的任何軌跡，然後按一下移動軌跡...。

  2. 在以下對話方塊中選取一個視窗號碼，然後按一下 OK（確定）。

移動軌跡對話方塊說明

附註： 一次只能移動「一個」軌跡。

將軌跡 N 移至視窗 - 將選定軌跡轉移至列出的任何視窗。

軌跡最大化

如何最大化作用中的軌跡 - 螢幕顯示畫面上的「唯一」軌跡。所有其他軌跡都會隱藏。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Trace] > Trace Setup（軌跡設定）> Trace Max (ON)（軌跡最大化（開啟））。使用「軌跡最大化（開啟）」時，選取不同的軌跡即可使該軌跡可見。

  2. 若要讓所有軌跡再次可見，請選取 Trace Max (OFF)（軌跡最大化（關閉））。

  1. 以滑鼠右鍵按一下網格方塊上方的軌跡狀態標籤，然後按一下軌跡最大化。

  2. 按兩下作用中的軌跡即可讓所有軌跡再次可見。

軌跡保持

如何使作用中軌跡保持最大值或最小值。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Trace] > Trace Setup（軌跡設定）> Trace Hold（軌跡保持）> OFF（關閉）| Minimum（最小值）| Maximum（最大值）。

  2. Restart（重新啟動）將會重設軌跡。

此功能沒有可用的程式設計

最大值/最小值軌跡保持功能可應用於多種情況下：

  • 此功能適用於任何資料軌跡，但不適用於記憶體軌跡。

  • 變更激勵或任何資料後處理設定時，將會重設軌跡保持資料。這些設定包括：

  • 平滑開啟/關閉。

  • 平滑孔徑。

  • 閘控開啟/關閉。

  • 轉換開啟/關閉。

  • 轉換狀態變更、轉換類型變更。

  • 資料數學函數（資料/記憶體）變更。

  • 公式編輯器狀態變更、公式變更。

  • 參數變更。

  • 格式化變更。

  • 對格式化資料進行最小值/最大值比較。對於史密斯圖和極座標格式，使用絕對資料而不使用相位。

  • 可以重新叫用軌跡保持資料。

  • 資料儲存檔案格式

    • SnP:不儲存軌跡保持資料

    • Citifile、CSV、MDF、PRN：儲存軌跡保持資料

附註： 可以在 VNA 中重新叫用和檢視 Citifile。

  • 使用 SCPI 指令可以取得軌跡保持資料。如果軌跡保持處於作用中狀態，則從遠端介面傳回的資料將成為軌跡保持資料。

通道

通道包含軌跡。通道設定可以決定軌跡資料的量測方式。指派給某個通道的所有軌跡會共用相同的通道設定。以下是通道設定：

  • 頻率範圍

  • 功率位準

  • 校準

  • IF 頻寬

  • 點數

  • 掃描設定

  • 平均

  • 觸發（某些設定屬於全域設定）

管理通道

如何選取通道

必須先選取（作用中）某個通道後才能變更其設定。

若要使某個通道處於作用中狀態，可在該通道中選取軌跡，或者在該通道中按一下某個軌跡的軌跡狀態按鈕。

如何新增通道

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Channel] > Channel 1-8（通道 1-8）> 按一下左側的 Channel 1-8（通道 1-8）小按鈕
    （範例：按一下左側的「通道 1」小按鈕，如果它變成綠色，即表示「通道 1」是作用中的通道，因此新增「通道 1」）。

  2. 針對其他通道號碼，請按下 [Channel] > Channel Setup（通道設定）> Add Channel（新增通道），然後選取 New Trace + Channel（新建軌跡 + 通道）或 New Trace + Channel + Window（新建軌跡 + 通道 + 視窗）。

此功能沒有可用的程式設計

如何刪除通道

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Channel] > Channel 1-8（通道 1-8）> 按一下左側的 Channel 1-8（通道 1-8）小按鈕
    （範例：按一下左側的「通道 1」小按鈕，如果它未變成綠色，即表示「通道 1」為非作用中通道）。

  2. 針對其他通道號碼，請按下 [Channel] > Channel Setup（通道設定）> Delete Channel（刪除通道），然後選取通道。

Windows

視窗可用於檢視軌跡。

  • VNA 可以在畫面上顯示無限數量的視窗，但具有以下限制：

    • COM 屬性視窗數上限會傳回 1000（「無限」不是一個數字）。

    • SCPI 狀態暫存器最多只能追蹤 576 個軌跡的狀態。

  • 每個視窗最多可以包含 24 個軌跡。

  • 視窗與通道完全無關。

  • 請參閱自訂 VNA 畫面，以瞭解如何進行其他視窗設定。

以下是一個包含兩個軌跡的視窗。如視窗底部的註解所述，兩個軌跡都使用相同的通道 1 設定。

VNA 會在視窗的左下角顯示視窗號碼。下圖顯示的是視窗 5。

管理視窗

如何進行各種視窗設定

新增、關閉、並排、重疊顯示、最小化、最大化

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Window 1-8（視窗 1-8）> 按一下左側的 Window 1-8（視窗 1-8）小按鈕
    （範例：按一下左側的「視窗 1」小按鈕，如果它變成綠色，即表示「視窗 1」是作用中的視窗，因此新增「視窗 1」）。

  2. 針對其他視窗，請按下 [Display] > Window Setup（視窗設定）> Add Window（新增視窗），然後選取 New Window（新建視窗）、New Trace + Window（新建軌跡 + 視窗）或 New Trace + Channel + Window（新建軌跡 + 通道 + 視窗）。

  1. 以滑鼠右鍵按一下網格方塊的任何區域，然後選取 新建視窗。

如何刪除視窗

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Window 1-8（視窗 1-8）> 按一下左側的 Window 1-8（視窗 1-8）小按鈕
    （範例：按一下左側的「視窗 1」小按鈕，如果它未變成綠色，即表示「視窗 1」為非作用中視窗）。

  2. 針對其他視窗，請按下 [Display] > Window Setup（視窗設定）> Delete Window（刪除視窗），然後選取視窗。

  1. 以滑鼠右鍵按一下網格方塊的任何區域，然後選取關閉視窗。

視窗最大化

如何最大化作用中的視窗 - 螢幕顯示畫面上的「唯一」視窗。所有其他視窗都會隱藏。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Window Setup（視窗設定）> Window Max (ON)（視窗最大化（開啟））。使用「視窗最大化（開啟）」，選取不同的軌跡即可使該視窗可見。

  2. 若要讓所有視窗再次可見，請選取 Window Max (OFF)（視窗最大化（關閉））。

  1. 以滑鼠右鍵按一下網格方塊的任何區域，然後選取最大化。

資料表

資料表用於將 VNA 視窗分組，還用於快速重新叫用。標籤式資料表可讓您輕鬆快速地切換多項顯示設定。

可透過標籤式資料表執行的功能和動作

    • 新增/刪除/選取資料表

    • 將視窗移至資料表

    • 資料表數目上限 > 50

    • 可對非作用中資料表上的軌跡/通道執行量測

    • 輕鬆設定每個視窗的通道

    • 輕鬆設定每個資料表的通道

管理資料表

如何新增資料表

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Sheet Setup（資料表設定）> Add Sheet（新增資料表）。

  2. 然後選取 New Sheet（新建資料表）、New Trace + Sheet（新建軌跡 + 資料表）或 New Trace + Channel + Sheet（新建軌跡 + 通道 + 資料表）。

無

如何刪除資料表

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Sheet Setup（資料表設定）> Delete Sheet（刪除資料表）。

  2. 然後選取資料表。

無

如何檢視資料表

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Sheet Setup（資料表設定）> Sheet（資料表）。

  2. 然後選取資料表。

  1. 按一下資料表標籤。

如何變更資料表標題

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Sheet Setup（資料表設定）> Sheet Title...（資料表標題...）。

  2. 在快顯的「資料表標題」方塊中，輸入標題並按一下「確定」。

無

如何變更資料表配置

這是資料表自動配置選項，用於更快進行選取，而不是用於單獨選取軌跡、通道、視窗和資料表。提供 4 個自動配置選項。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Sheet Setup（資料表設定）> Sheet Layout（資料表配置）。

  2. 然後選取 1 Sheet（1 個資料表）、1 Trace per Sheet（每個資料表對應 1 個軌跡）、1 Channel per Sheet（每個資料表對應 1 個通道）或 1 Window per Sheet（每個資料表對應 1 個視窗）。

無

上次修改時間：

2016 年 01 月 06 日

第一版


「快速入門」對話方塊

「快速入門」是一個簡單的精靈，可協助進行一般量測的設定。此功能可讓使用者從一組預先設定的量測配置中進行選擇。

如何開啟「快速入門」對話方塊

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Setup] > Main（主功能表）> Quick Start...（快速入門...）。

量測包含以下三個步驟。

步驟 1：快速入門對話方塊

您可以針對一般量測選取配置範本。

S 參數量測

平衡量測

其他量測

如果啟用 「在新通道中建立」核取方塊，將會建立新的通道和視窗。

如果停用「在新通道中建立」核取方塊，則在選取範本後，將會使用作用中的通道進行新的量測。如果作用中軌跡與其他通道上的軌跡一起顯示在一個視窗中，則將會刪除該軌跡，並開啟新的視窗進行新的量測。

如果啟用「顯示史密斯圖」核取方塊，則視窗中的作用中軌跡將會變為顯示史密斯圖。

如果停用「顯示史密斯圖」核取方塊，則視窗中的作用中軌跡不會發生任何變化。

步驟 2：「激勵設定」對話方塊

此步驟可用於設定量測的激勵值。

S 參數與平衡

所需選項：

無

如果在步驟 1 中選取了以下任何一個量測，將會出現「頻率掃描設定」對話方塊。

  • S 參數量測

  • 平衡量測

  • 無比例接收器量測

輸入：

  • 開始/停止頻率

  • 掃描類型： 線性或對數頻率

  • 功率

  • IF 頻寬

  • 點數

瞭解有關 S 參數量測、差異（平衡）量測及無比例接收器量測的詳細資訊。

功率

所需選項：

無

如果在步驟 1 中選取了任何一個功率掃描量測，將會出現「功率掃描設定」對話方塊。

輸入：

  • 開始/停止功率

  • CW 頻率

  • IF 頻寬

  • 點數

暸解有關功率掃描量測的詳細資訊。

接收器頻率偏移

所需選項：

009

如果在步驟 1 中選取了任何一個頻率偏移量測 (FOM)，將會出現「頻率偏移設定」對話方塊。

輸入：

  • 來源開始/停止

  • 接收器開始/停止

  • 功率

  • IF 頻寬

  • 點數

暸解有關 FOM 的詳細資訊。

時域

所需選項：

010

如果在步驟 1 中選取了任何一個時域量測，將會出現「時域設定」對話方塊。

輸入：

  • 開始/停止時間

  • 轉換模式（如果選取 LPF 轉換模式，「時域設定」對話方塊會自動選取開始頻率。）

  • 開始/停止頻率

  • 功率

  • IF 頻寬

  • 點數

暸解有關時域量測的詳細資訊。

混頻器

所需選項：

009

如果在步驟 1 中選取了任何一個 SMC 量測，將會出現「混頻器快速設定」對話方塊。

輸入：

  • 公式：輸出 = 輸入 - LO，輸出 = 輸入 + LO，輸出 = LO - 輸入

  • 輸入、LO 和輸出頻率及設定。

暸解有關 SMC 量測的詳細資訊。

步驟 3：「校準精靈」對話方塊（可選）

如果啟用「校準此設定」核取方塊，則當使用「確定」按鈕關閉「激勵設定」對話方塊時，將會出現「校準精靈」對話方塊。

如果停用「校準此設定」核取方塊，則將不會出現「校準精靈」對話方塊。

「校準精靈」的功能如下：

  • 智慧型校準精靈

  • SMC 校準精靈

上次修改時間：

2016 年 01 月 06 日

第一版


基本量測順序

下列程序可用於設定所有 VNA 量測：

步驟 1. 設定量測
重設分析儀、建立量測狀態，以及調整顯示畫面。

步驟 2. 最佳化量測
使用技巧和功能改善量測的準確度與效能。

步驟 3. 執行量測校準
透過執行校準來減少量測錯誤。

步驟 4. 分析資料
使用標記、數學運算及限值測試分析量測結果。

步驟 5. 列印、儲存或呼叫資料
儲存或列印量測資料。


連接指南

VNA 連接指南

VNA 做為 PC

  • VNA 使用者帳戶和密碼

  • 使用 VNC 控制 VNA 使用者介面

GPIB 程式設計

  • 設定 GPIB、SCPI 及 SICL

控制外部裝置

  • 設定外部裝置

  • E5092 測試裝置控制

  • 介面控制功能


VNA 偏好設定

VNA 偏好設定是指預設或 VNA 關閉後仍然存在的設定。VNA 偏好設定會列在此頁面上，並具有指向提供詳細資訊的位置的連結。

如何設定 VNA 偏好設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

偏好設定對話方塊說明

VNA 偏好設定會在預設和系統重新開機後保留下來。

勾選方塊時，下列敘述正確（除非另有說明）。

平均：預設時設定兩點群組延遲孔徑 - 將群組延遲孔徑設為 2 個點。 瞭解詳情。

平均： 預設時設定兩點群組延遲孔徑（預設） - 將群組延遲孔徑設定為 11 個點。

校準：校準期間始終使用內部觸發 - 僅使用內部觸發來源

校準： 校準期間始終使用內部觸發（預設）- 使用其他觸發來源

此設定僅影響使用 SCPI 執行的校準。從使用者介面執行的校準始終提供儲存為已命名校準集的選項。

校準：（僅限 SCPI）自動儲存至使用者校準集 - 始終將已完成的校準自動儲存至自動命名的使用者校準集。注意：這會導致系統產生大量已儲存的使用者校準集。瞭解詳情。

校準：（僅限 SCPI）自動儲存至使用者校準集（預設）- 依預設，將已完成的校準儲存至校準暫存器，而非使用者校準集。

同時選取上下校準集選項時會出現下列訊息：

"校準：自動儲存偏好設定衝突」

校準：(SCPI) 自動儲存至使用者校準集（上面）- 或 -校準：(SCPI) 自動儲存至目前校準集（下面）

取消勾選其中一項。

此設定僅影響使用 SCPI 執行的校準。從使用者介面執行的校準始終提供儲存為已命名校準集的選項。

校準：(SCPI) 自動儲存至目前校準集 - 始終將已完成的校準自動儲存至指定通道上目前選取的校準集，該校準集可能是通道校準暫存器。如果通道尚未選取校準集，則校準將儲存至具有自動產生的名稱的全新使用者校準集。

校準：(SCPI) 自動儲存至目前校準集（預設）- 不會將已完成的校準自動儲存至指定通道上目前選取的校準集。

校準：對於頻率偏移，請使用主頻率 - 未使用測試裝置執行毫米波量測時使用。

校準：對於頻率偏移，請使用主頻率（預設）- 未使用測試裝置執行公釐波量測時不要使用。

顯示：所選軌跡會短暫變更寬度 - 所選軌跡會短暫變更寬度，以提高可見性。

顯示：所選軌跡會短暫變更寬度（預設）- 所選軌跡不會短暫變更寬度。

顯示：所選軌跡更寬 - 作用中（已選取）軌跡始終更寬。

顯示：所選軌跡更寬 - 所選軌跡為較窄的預設大小。

顯示：觸控螢幕開啟（預設）- 可透過觸控螢幕進行選取。

顯示：觸控螢幕開啟 - 無法透過觸控螢幕進行選取。

外部裝置：預設和重新叫用時停用（預設）- 預設 VNA 或重新叫用儀器狀態時會停用外部裝置。

外部裝置：預設和重新叫用時停用 - 預設 VNA 或重新叫用儀器狀態時，外部裝置仍處於作用中狀態。

暸解有關外部裝置的詳細資訊。

限制：使用紅色繪製失敗的軌跡區段 - 使用紅色繪製失敗的區段。

限制：使用紅色繪製失敗的軌跡區段（預設）- 使用紅色繪製失敗的資料點（點）。

限制：使用紅色繪製限制線（預設）- 限制線為紅色。

限制：使用紅色繪製限制線 - 限制線顏色與軌跡顏色相同。

限制：測試最近的量測點（預設）- 當量測點的激勵不同於限制測試點時，使用最近的限制測試點來判定通過/失敗。

限制：測試最近的量測點 - 僅在限制測試點的激勵上判定通過/失敗。

標記：標記的耦合控制開啟|關閉狀態- 如果耦合的通道處於開啟狀態，且為一條軌跡開啟了標記，則會為與原始軌跡耦合的所有軌跡開啟具有相同標記編號的標記。

標記：標記的耦合控制開啟|關閉狀態 - 如果耦合的通道處於開啟狀態，且為一條軌跡開啟了標記，則其他軌跡上的其他標記不會受到影響。

標記：預設時，耦合方法為通道- 選取預設時，耦合方法設定為「通道」。

標記：預設時，耦合方法為通道 - 選取預設時，耦合方法設定為「全部」。

標記：預設時，耦合標記為開啟狀態- 選取預設時，耦合標記設定為「開啟」。

標記：預設時，耦合標記為開啟狀態 - 選取預設時，耦合標記設定為「關閉」。

標記：程式設計將標記 10 視為參考 - 包括 10 作為其標記編號引數的標記程式設計指令將作用於參考標記（而不是通用標記 10）。

標記：程式設計將標記 10 視為參考（預設）- 包括 10 作為其標記編號引數的標記程式設計指令將作用於通用標記 10（而不是參考標記）。

標記：將單一標記用於標記搜尋（預設）- 將一個標記用於標記搜尋。會顯示子標記，並用於頻寬、帶阻搜尋。此模式與 E5071C 相容。

標記：將單一標記用於標記搜尋 - 將多個標記用於標記搜尋。

記憶體：資料計算 8510 模式 - 模擬 Keysight 8510 資料處理鏈，因為它與軌跡計算和記憶體相關。瞭解詳情。

記憶體：資料計算 8510 模式（預設）- 標準的 VNA 資料處理鏈。

功率：預設時開啟功率（預設）- 儀器預設將始終開啟來源功率。

功率：預設時開啟功率 - 當目前來源功率設定為關閉時，預設後，來源功率仍保持關閉狀態。當目前功率設定為開啟時，預設後，來源功率將仍然保持開啟狀態。

功率：將來源位準不正確事件報告為錯誤 - 啟用將來源位準不正確事件報告為錯誤。瞭解詳情。

功率：將來源位準不正確事件報告為錯誤 - 停用將來源位準不正確事件報告為錯誤。（預設）

預設：確認預設 - 按下硬鍵上的 [Preset] 按鈕時立即預設 VNA 韌體（只需硬鍵）。

預設：確認預設（預設）- 按下 [Preset] > Preset（預設）時立即預設 VNA 韌體（需要硬鍵和軟鍵）。

預設：預設時顯示「快速入門」對話方塊 - 按下 [Preset] 時顯示「快速入門」對話方塊。

預設：預設時顯示「快速入門」對話方塊 - 按下 [Preset] 時不顯示「快速入門」對話方塊。

重新叫用：軟鍵順序為最近使用的順序 - 重新叫用最近使用的軟鍵順序。

重新叫用：軟鍵順序為最近使用的順序（預設）- 不重新叫用最近使用的軟鍵順序。

縮放：預設時耦合縮放到視窗 - 按下 [Preset] 時縮放耦合設定為視窗。

縮放：預設時耦合縮放到視窗（預設）- 按下 [Preset] 時縮放耦合設定為「關閉」。

掃掠：預設時將掃描模式設定為「步進」（預設）- 按下 [Preset] 時，掃描模式始終設定為「步進」。

掃描：預設時將掃掠模式設定為步進式- 按下 [Preset] 時，掃掠模式並非始終設為步進式。

掃描：僅針對自動掃掠模式使用斜波掃掠 - 自動掃掠模式僅套用於斜波掃掠。

掃掠：僅針對自動掃掠模式使用斜波掃掠 - 自動掃掠模式不僅僅套用於斜波掃掠。

系統：啟用聲音（預設）- 儀器喇叭開啟。

系統：啟用聲音 - 儀器喇叭關閉。

系統：使用鍵盤導覽軟鍵 - 啟用鍵盤瀏覽軟鍵。

系統：使用鍵盤導覽軟鍵（預設）- 停用鍵盤瀏覽軟鍵。

更多按鈕會啟動包含預先定義之偏好設定的對話方塊：

資料儲存...

定義資料儲存 - 儘管未明確叫用偏好設定，所有這些設定在關閉後仍會保留下來。瞭解詳情。

功率限制...

偏移和限制 - 設定功率限制和偏移。深入暸解。

透明度...

對話方塊透明度 - 一些 VNA 對話方塊可透過不同透明度檢視。瞭解詳情。

語言...

說明 - 設定內建說明的語言（英文或其他當地語系化語言）。瞭解詳情。

使用者預設...

使用者預設 - 指定預設時 VNA 將使用的儀器狀態檔案。瞭解詳情。

頁面設定...

頁面設定 - 標準印表機設定（紙張、方向、視窗、通道設定表和軌跡屬性表）在 VNA 關閉後不會保留下來。

所有其他設定在 VNA 關閉後會保留下來。瞭解詳情。

顯示顏色...

顯示顏色 - 將 VNA 顯示項目設定為自訂顏色。瞭解詳情。

列印顏色...

列印顏色 - 將 VNA 列印項目設定為自訂顏色。瞭解詳情。

儘管它們稱為偏好設定，但下列設定在 VNA 關閉後不會保留下來。

校準 | UI 設定
校準期間執行 ECal 模組方向？ | ECal 精靈
指定方向關閉時的 ECal 連接埠對應 | ECal 精靈
校準期間顯示或隱藏自訂校準視窗 | 校準視窗（僅限遠端指令）

上次修改時間：

2016 年 01 月 06 日

第一版


VNC

使用 VNC 控制 VNA 使用者介面

VNC（虛擬網路運算）可讓您從任何 PC 控制 VNA 的使用者介面。VNA 的顯示畫面會出現在所連接的 PC 顯示畫面上。滑鼠和鍵盤控制可以從 VNA 與 PC 進行（雖然不是同時）。

附註： 若要取得類似功能，可使用 Windows 遠端桌面。如需詳細資訊，請參閱 Windows 說明檔。

VNA 和 PC 都必須連線至相同的網路。在使用 VNC 時，VNA 的回應能力取決於網際網路連線的速度。

每部 VNA 在出廠時都已安裝了 VNC。不過，您必須將 VNC 軟體下載並安裝到 PC 上。

以下程序可以協助您設定 VNC，以便從 PC 檢視和控制 VNA 應用程式。

在 VNA 上，執行 VNC Server

若要執行此作業，請：

  1. 按一下「檢視」，然後按一下「最小化應用程式」。

  2. 依序按一下開始、所有程式、TightVNC、Tight VNC Server（應用程式模式）、啟動 VNC Server。

  • 當伺服器正在執行時， [image] 圖示會顯示在顯示畫面的右下角。如果未顯示，請按一下向上箭頭以展開圖示清單。

  • 首次執行 VNC Server 時，您必須先設定密碼，以控制從遠端 PC 進行的存取。

在 PC 上，執行 VNC Viewer

若要執行此作業，請：

  1. 從 http://www.tightvnc.com/ 下載 TightVNC 並將其安裝在 PC 上。

  2. 在 PC 桌面上，依序按一下開始、程式集、TightVNC、TightVNC Viewer

  3. 當系統提示輸入主機名稱時，請鍵入 VNA 的完整電腦名稱或 IP 位址。

  4. 當系統提示輸入密碼時，請鍵入您在 VNA 上設定 VNC 時所設定的密碼。

上次修改時間：

2014 年 07 月 25 日

第一版


LXI 合規性

LXI 和 VXI 合規性

VNA 產品符合 LXI 和 VXI 規範。

LXI

請造訪 http://www.lxistandard.org/，暸解有關 LXI 的詳細資訊

VXI

請造訪 http://www.vxi.org/，暸解有關 VXI 的詳細資訊

LAN 狀態

當 LAN 連線與 VNA 配合使用時，「LAN 狀態」對話方塊可讓您查看 IP 位址和其他 LAN 連線屬性。

如何檢視 LAN 狀態

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [System] > System Setting（系統設定）> Lan Status...（Lan 狀態...）。

  1. 以滑鼠右鍵按一下狀態列上的 LCL（或 RMT）圖示。

  2. 選取 Lan 狀態...。

LAN 狀態對話方塊說明

指示器 顯示 LAN 連線的目前狀態。

正常 - 表示 VNA LAN 已做好通訊準備。

識別 - 表示遠端電腦已使用 Web 介面或 LXIDeviceIDState COM 屬性在 VNA 上叫用 LXI 識別作業。

錯誤 - 表示 VNA LAN 介面未連線至網際網路。

IP 位址 - 顯示 VNA 目前的 IPv4 位址。

IPv6 連結本機位址 - 顯示 VNA 目前的 IPv6 位址。

電腦名稱 - 顯示 VNA 的完整電腦名稱。瞭解如何進行變更。 如果您看到此處列出 IP 位址，這表示未在網路設定中指定任何 DNS 伺服器。

MAC 位址 - 顯示 VNA 電腦的唯一位址。也稱為主機 ID。

LAN 重設 - 提供 LAN 組態初始化 (LCI) 機制。按下後可將下列設定還原為原廠預設狀態：

  • IP 位址設定 (DHCP)：已啟用

  • ICMP Ping 回應程式：已啟用

  • 用於設定的 Web 密碼：將密碼重設為「Keysight」。

Web 伺服器軟體

如果您的 VNA 符合 LXI 類別 C 規範（見上文），則可以透過網際網路連線使用網頁瀏覽器連線至 VNA。

若要執行此作業，請在上述對話方塊指示正常狀況時：

  1. 在網頁瀏覽器中鍵入 http://<您的 VNA 電腦名稱>。例如，若要連線至上述對話方塊中的虛擬 VNA，請鍵入：http://WINDOWS-R4KD3IH

  2. 您將會看到包含連線連結的歡迎畫面。

上次修改時間：

2016 年 01 月 06 日

第一版


對話方塊透明度

大多數 VNA 對話方塊可以各種透明度顯示。如此可讓您在進行對話方塊設定時，透過對話方塊檢視 VNA 軌跡。

如何設定透明度層級

使用滑鼠

  1. 在標籤式對話方塊中，多次按下下列按鈕，即可循環檢視上述透明度設定。下列對話方塊均包含透明度設定：掃描設定、快速入門、時域設定、限值測試設定、時域設定、連接埠配對、自訂設定及觸發器。

或

  1. 從偏好設定對話方塊啟動透明度對話方塊（如下）。

此功能沒有可用的程式設計指令。

對話方塊透明度對話方塊說明

附註： 此單一透明度設定適用於所有支援的 VNA 對話方塊。

透明度按鈕可以改善可視性。在此對話方塊上變更透明度百分比後，使用者可以立即在顯示畫面上檢視結果。

  • 不透明 - 預設設定

  • 8% 透明度

  • 25% 透明度

  • 50% 透明度

按兩下變更透明度 - 勾選時，在允許透明度之對話方塊的任何非控制區域按兩下，即可循環檢視上述透明度設定。

備註：

  • 透明度設定會儲存為 VNA 偏好設定。

  • 此設定在 VNA 關閉和預設後仍會存在。

  • 它不會被儲存，但可透過儀器狀態呼叫。

上次修改時間：

2016 年 01 月 06 日

新增主題 (10.0)


使用說明

本主題討論以下內容：

  • VNA 文件

  • 啟動說明

  • 搜尋說明

  • 當地語系化說明

  • 文件保固

另請參閱

說明 - 關於網路分析儀

其他快速入門主題

VNA 文件

本說明檔內嵌在 VNA 中，是 VNA 的使用者指南和程式設計手冊。更新韌體時，VNA 上也會自動更新說明檔。新的 VNA 儀器只會隨附 VNA 安裝和快速入門指南。

購買 VNA 時不再提供印製的手冊。

所有 VNA 文件（包括本說明檔的最新線上 Web 說明版本，以及本說明檔的可列印 .PDF 版本）均可從以下網址取得：http://www.keysight.com/find/na。

啟動說明

您可以透過以下三種方式啟動說明系統：

  1. 透過前面板上的「說明」按鈕。

  2. 透過說明下拉式功能表

  3. 透過對話方塊說明

搜尋說明

提示： 若要在任何主題中搜尋某個關鍵字，請按下 Ctrl + F。

在 Google 上搜尋 VNA 說明的線上版本。

下列規則適用於使用全文搜尋：

  • 搜尋不區分大小寫。

  • 您可以搜尋字母 (a-z) 和數字 (0-9) 的任意組合。

  • 在搜尋過程中會忽略標點符號（句號、冒號、分號、逗號和連字號）。

  • 您可以使用雙引號或括號將搜尋文字分組。範例："response calibration" 或 (response calibration)。此要求會使得無法搜尋引號。

  • 使用萬用字元表示：

    • 若要搜尋一個未定義的字元，可使用問號 (?)。例如，搜尋 cal? 將會找到 calc 和 calf。

    • 若要搜尋多個未定義的字元，可使用星號 (*)。搜尋 Cal* 將會找到 calibration 和 calculate。

  • 使用布林運算子可定義兩個或多個搜尋文字之間的關係。

搜尋 | 範例 | 結果將會顯示包含以下內容的主題：
同一個主題中的兩個詞 | response AND calibration | 同時包含「response」和「calibration」這兩個詞。
主題中包含兩個詞中的一個 | response OR calibration | 「response」或「calibration」或兩者。
主題中包含第一個詞但不包含第二個詞 | response NOT calibration | 包含「response」這個詞，但是不包含「calibration」這個詞。
同一個主題中同時包含兩個詞，而且兩個詞的距離很近。 | response NEAR calibration | 「response」這個詞與「callibration」這個詞的距離在八個詞以內。

當地語系化說明

依預設，VNA 顯示韌體隨附的英文內建說明。韌體套件未隨附當地語系化說明。

若要啟用當地語系化說明，請執行下列步驟：

  • 從 Keysight.com VNA 支援網站下載當地語系化說明（例如，簡體中文的當地語系化說明檔命名為 vnahelp_sc.chm）

  • 將當地語系化說明 (*.chm) 複製到 D:\help 資料夾。

  • 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

  • 現在，語言按鈕已啟用。

  • 按下語言按鈕並選取當地語系化說明（例如簡體中文），然後按下「確定」。當地語系化說明現已啟用

附註：當地語系化說明將不受儀器復原（SSD 重新成像）週期的影響。

文件保固

本文件所含內容係以「現狀」提供，未來版本若有變更，恕不另行通知。 此外，在適用法律所允許之最大範圍內，Keysight 對於本手冊及其所含任何資訊不提供任何明示或默示擔保，包括（但不限於）對適售性和特定用途適用性的默示擔保。 Keysight 對於本文件中的錯誤或因提供、使用或運用本文件或其中所含任何資訊，所衍生之任何偶然或必然損害，皆不負擔責任。 若 Keysight 與使用者簽訂其他書面協議，且該等協議關於本文件所含內容的保固條款與上述條款有所牴觸，則以其他協議條款為準。


相關說明

說明 - 關於網路分析儀

按一下 [Help] > Help（說明）> About NA...（關於 NA...），然後按一下關於網路分析儀以瞭解以下有關 VNA 的資訊：

  • 型號

  • 頻率範圍

  • 序號

  • 已安裝的選件（瞭解如何安裝軟體選件）

  • 應用程式碼（韌體）版本

  • 固態硬碟版本

  • 系統 CPU 版本 - 瞭解詳細資訊

  • DSP（數位訊號處理器。）版本。這不適用於 E5080A。

  • 電腦名稱 - 瞭解詳細資訊。「LAN 狀態/LXI 合規性」對話方塊上也會提供此資訊。

上次修改時間：

2009 年 11 月 30 日

第一版


預設分析儀

預設 VNA

預設 VNA 就是將其設定為已知或預設條件。可以使用出廠預設的預設條件，也可以定義自己的使用者預設條件。

  • 預設條件

  • 使用者預設條件

請參閱其他「設定量測」主題

預設的預設條件

如何預設 VNA

提示：如果 VNA 應用程式尚未執行，可按下預設按鈕以啟動該應用程式。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Preset] > Main（主功能表）> Preset（預設）。

當 Confirm Preset（確認預設）處於關閉狀態時，

  1. 按下 [Preset]。

使用者預設條件

可將分析儀預設為出廠預設條件或使用者預設條件。

如何設定使用者預設

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Preset] > Main（主功能表） > User Preset...（使用者預設...）。

使用者預設對話方塊說明

儲存並啟用使用者預設後，對 VNA 進行預設時，將重新叫用「使用者預設」設定而非出廠預設設定。校準資料不會與使用者預設一起重新叫用。暸解有關儀器狀態設定的詳細資訊。

使用者預設啟用
勾選 - 按下「預設」按鈕時，會將 VNA 預設為使用者預設條件。
清除 - 按下「預設」按鈕時，會將 VNA 預設為預設條件。

將目前狀態儲存為使用者預設 - 按一下可將目前儀器狀態儲存為使用者預設條件。檔案儲存為 D:\UserPreset.sta。

將現有檔案作為使用者預設載入 - 按一下可擷取要用作使用者預設條件的儀器狀態。

上次修改時間：

2014 年 07 月 01 日

第一版


量測類別

量測類別是可在通道上並存的量測的種類。

  • 什麼是量測類別

請參閱其他「設定量測」主題

什麼是量測類別

下表顯示了目前可用於 VNA 的量測類別。其中的每個類別都包含許多量測。

量測類別是可在通道上並存的量測的種類。來自一個類別的量測無法存在於含有來自另一個類別之量測的通道中。例如，雜訊係數量測不能存在於目前裝載標量混合器量測的通道中。

「量測類別」對話方塊可透過以下方式進行存取：

如何將量測類別指派給通道

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Meas] > Meas Overview（量測概觀）> Measurement Class（量測類別） > Measurement Class...（量測類別...）

量測類別對話方塊說明

一個量測類別中的量測無法與其他量測類別的量測並存於同一個通道中。

針對作用中通道或新量測通道選取量測類別。

  • 標準量測類別包含 S 參數、平衡量測和接收器量測。

  • 增益壓縮量測類別包含頻率、功率和壓縮量測。

  • 所有其他量測類別通常稱為「應用程式」。

標題列 指示要將量測類別指派到的作用中通道。

顯示設定對話方塊顯示該對話方塊以設定激勵。

確認變更

  • 勾選（預設設定）後可啟動「確認量測類別變更」對話方塊。

  • 清除後可在未確認的情況下執行「確定」動作。此設定在使用「預設」和「VNA 關閉」後仍然存在。

新建通道 按一下可在新通道和新視窗中建立量測類別。系統會在通道中建立該類別的預設量測。

若要變更量測，請按一下軌跡，然後選取新量測。

選擇執行下列操作：

  • 確定 - 刪除作用中通道中的現有量測。在該通道中建立新量測類別和預設量測。

  • 取消 - 不建立新的量測類別。將舊量測（及類別）保留在該通道中，並返回「量測類別」對話方塊。

上次修改時間：

2014-06-28

第一版


量測參數

本主題包含以下資訊：

  • S 參數（預先選取的比例）

  • 平衡

  • 接收器

  • 比例 （選擇您自己的比例）

  • 無比例的功率（絕對功率）

  • 輔助

暸解有關平衡量測的資訊

請參閱其他「設定量測」主題

S 參數

S 參數（散射參數）用於描述裝置修改訊號的方式。S 參數由兩個複數之比定義，包含有關訊號之幅度和相位的資訊。

對於 2 連接埠裝置，包含四個 S 參數。 每個參數的語法透過以下各項進行描述：

S out - in

out = | 用於量測裝置訊號輸出的 VNA 連接埠號（接收器）
in = | 用於將訊號套用（入射）到裝置（來源）的 VNA 連接埠號

將滑鼠移到每個 S 參數上方可查看訊號流：

對於 2 連接埠裝置：

  • 來源進入連接埠 1 時，量測為正向。

  • 來源進入連接埠 2 時，量測為反向。

分析儀自動切換來源和接收器進行正向或反向量測。因此，分析儀可透過單一連線量測 2 連接埠裝置的所有四個 S 參數。

使用 S 參數的常見量測

反射量測
（S11 和 S22）

傳輸量測
（S21 和 S12）

  • 回波損耗

  • 駐波比 (SWR)

  • 反射係數

  • 阻抗

  • S11、S22

  • 插入損耗

  • 傳輸係數

  • 增益/損耗

  • 群組延遲

  • 線性相位偏差

  • 電延遲

  • S21、S12

接收器量測

所有 VNA 模型都具有測試連接埠接收器和參考接收器。

對於 4 連接埠模型

  • R1、R2、R3 和 R4 是參考接收器。它們用於量測離開 VNA 來源時的訊號。

    • R1 量測連接埠 1 的訊號輸出

    • R2 量測連接埠 2 的訊號輸出

    • R3 量測連接埠 3 的訊號輸出

    • R4 量測連接埠 4 的訊號輸出

  • A、B、C 和 D 是測試連接埠接收器。它們用於量測 DUT 的訊號輸出（或反射）。

    • A 量測進入 VNA 連接埠 1 的訊號

    • B 量測進入 VNA 連接埠 2 的訊號

    • C 量測進入 VNA 連接埠 3 的訊號

    • D 量測進入 VNA 連接埠 4 的訊號

也可以使用邏輯接收器標記法來指定接收器。瞭解詳情。

比例量測

比例量測允許您自行選擇 VNA 中可用的任意兩個接收器的比例。實際上，S 參數是預先定義的比例量測。例如 S11 為 A/R1。

以下是比例量測的一般使用情況：

  • 比較裝置的兩個路徑之間的相位。較為簡單的範例是功率分配器，較為複雜的範例是雙通道接收器。

  • 與提供 S 參數的分析儀相比，量測需要較高的動態範圍。

無比例（絕對功率）量測

無比例功率參數用於量測進入到 VNA 上可用的任何接收器中的絕對功率。

參考接收器在內部設定為量測特定 VNA 連接埠的來源功率。使用不同的來源連接埠來量測參考接收器的絕對功率量測將會量測非常小的功率，除非移除前面板跳線並直接將訊號套用至接收器。此類量測的範例使用連接埠 2 作為來源的 R1 量測。

  • 使用單一接收器來量測相位將產生沒有意義的資料。若要進行相位量測，必須對兩個訊號進行比較。

  • 比例參數與無比例參數的平均值計算方式有所不同。瞭解詳情。

  • 如果僅量測無比例參數，請選擇「回應校準」。如果還要量測 S 參數，「智慧型校準」將校準使用中的測試連接埠接收器。

新增軌跡/量測對話方塊說明

附註：只有位於目前指派給作用中通道的量測類別中的量測才可供使用。其他量測不相容。

若要建立除這些量測以外的量測，請先將適當的量測類別指派給新通道或現有通道。瞭解詳細資訊。

按一下標籤以建立或變更量測。

  • 建立新量測時，可以選擇多個量測。

  • 變更現有量測時，只能選擇一個量測。

標籤

S 參數 - 選取預先定義的比例量測。暸解有關 S 參數的詳細資訊。

量測類型。（僅限多連接埠 VNA）

變更 - 按一下可叫用平衡 DUT 拓撲/邏輯連接埠對應對話方塊。暸解有關平衡量測的詳細資訊。

接收器 - 選取要進行比例和無比例（絕對功率）量測的接收器。暸解有關接收器量測的詳細資訊。

比例 - 勾選啟動可建立或變更量測。為「分子」選取一個接收器，為「分母」選取另一個接收器，然後為量測選取來源連接埠。

來源連接埠始終解譯為邏輯連接埠號。

為了方便起見，在表格中填入了常用選項。

  • 暸解有關外部測試裝置和比例量測的詳細資訊。

  • 暸解有關比例量測的詳細資訊。

無比例 - 與「比例」相同，但選取 1 作為「分母」。

  • 暸解有關無比例量測的詳細資訊。

接收器標記法

也可以使用邏輯接收器標記法來選取接收器。透過此「8510-樣式」標記法，可以輕鬆地表示已將外部測試裝置連接到 VNA 的接收器。

  • aN - 邏輯連接埠 N 的參考接收器

  • bN - 邏輯連接埠 N 的測試連接埠接收器

  • AIN - 類比輔助輸入 N（1 或 2）

例如：

  • 對於比例量測：「b12/a1」是指邏輯測試連接埠 12 接收器/邏輯連接埠 1 參考接收器。

  • 對於無比例量測：「b10」是指邏輯測試連接埠 10 接收器。

  • 對於輔助量測：「AI1」是指後面板上的輔助輸入 1（類比輸入）。

新樣式標記法（A、B、R1 等）仍可用於表示 VNA 實體接收器。瞭解詳情。

但是，比例量測必須使用相同的標記法來表示兩個接收器，即實體接收器標記法（A, R1）或邏輯接收器標記法（aN, bN）。例如，不允許使用下列混合標記法：A/b3 和 a5/R2。

程式設計

使用編程指令輸入接收器字母時，邏輯或實體接收器標記法不區分大小寫。

輔助 - 在後面板上選取輔助 1 或 2 的輸入。

  • 輔助連接埠可進行 DC 量測。

  • 透過按下 [Meas] > Auxiliary（輔助）> AuxIn1 Range（輔助輸入 1 範圍）或 AuxIn2 Range（輔助輸入 2 範圍）來選取 DC 範圍（1 V 或 10 V）。

通道/視窗選項

變更現有量測時，這些選項不可用。暸解如何變更量測。

通道編號 - 針對新軌跡選取通道。

在新視窗中建立

  • 勾選後可在新視窗中建立新軌跡。

  • 清除後可在作用中視窗中建立新軌跡。達到 VNA 每個視窗限制的軌跡時，將不再新增任何軌跡。

關於量測參數（頁面頂端）

平衡 DUT 拓撲/邏輯連接埠對應 對話方塊說明

建立或編輯 DUT 拓撲和邏輯連接埠對應。

術語「邏輯連接埠」用於描述已重新對應至新連接埠號的實體 VNA 測試連接埠。

  • 將任意兩個實體 VNA 連接埠對應至一個平衡邏輯連接埠

  • 將任意一個 VNA 實體連接埠對應至一個單端邏輯連接埠。

附註：這些選項將套用至通道中的所有量測。如果裝置拓撲已變更，則通道中與新拓撲不相容的任何現有量測將自動變更為相容量測。

拓撲： 按照您希望的測試方式描述您的 DUT。下列裝置拓撲可由多連接埠 VNA 進行量測。當裝置為 2 連接埠模型時，只能選取平衡。

  • 平衡
    （1 個邏輯連接埠 - <2 個實際連接埠>）

  • 平衡/平衡
    （2 個邏輯連接埠 - <4 個實際連接埠>）

  • 單端/平衡
    （2 個邏輯連接埠 - <3 個實際連接埠>）

  • 單端 - 單端/平衡
    （3 個邏輯連接埠 - <4 個實際連接埠>）

下列拓撲可反向（<==）使用以進行量測：

  • 平衡/單端 - 單端拓撲

例如，若要量測平衡/單端拓撲，請量測單端/平衡拓撲的 S12（反向）。

  • 暸解有關使用外部測試裝置時的邏輯連接埠對應的資訊。

  • 暸解有關平衡量測的詳細資訊

  • 可將平衡參數儲存至 SNP 檔案。瞭解詳情。

上次修改時間：

2016 年 01 月 06 日

第一版


頻率範圍

頻率範圍是為進行裝置量測而指定的跨距。

  • 設定頻率範圍

  • 縮放

  • CW 頻率

  • 頻率解析度

請參閱其他「設定量測」主題

設定頻率範圍

如何設定頻率範圍

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Freq] > Main（主功能表）> Start（開始）、Stop（停止）、Center（中心）或 Span（跨距）。

  2. 輸入所需的頻率值。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下開始/停止/中心...。

設定頻率範圍的方式有兩種：

  1. 指定範圍的開始和停止頻率。

  2. 指定範圍的中心頻率和所需跨距。

請參閱所有 VNA 模型的頻率範圍。

開始、停止、中心和跨距對話方塊說明

開始 - 指定掃描量測範圍的開始頻率。

停止 - 指定掃描量測範圍的結束頻率。

中心 - 指定頻率掃描中心的值。此值可以是分析器範圍中的任何位置。

跨距 - 指定在中心頻率任意側所量測得出的頻率跨距值。

點數 - 指定量測點的數目。

步長 - 指定步長。

縮放

透過縮放，可以輕鬆地變更開始和停止頻率或功率掃描中的開始和停止功率位準。

縮放將作用於作用中軌跡以及該作用中軌跡所在通道中的所有軌跡，無論這些軌跡顯示在哪個視窗。

如何在量測視窗中縮放

  1. 按一下滑鼠左鍵或使用手指，沿著軌跡部分拖曳。

  2. 放開滑鼠硬鍵或抬起手指，隨即顯示下列功能表：

從下列項目進行選取：

    • 縮放 - 將通道激勵設定變更為縮放選項的左右邊界值。

    • 縮放 xy - 如上所述，變更通道激勵設定。此外，作用中軌跡的 Y 軸刻度會變更為縮放選項的近似刻度。

    • 完全縮小 - 將通道激勵設定變更為目前校準的完整跨距。如果沒有一個校準處於開啟狀態，則激勵設定會變更為 VNA 模型的完整跨距。

備註：

  • 作用中通道的所有軌跡的激勵設定都會變更，無論這些軌跡顯示在哪個視窗。

  • 如果標記位於所選區域，則仍會保留在原位。

  • 如果標記不在所選區域中，則會將其移至新跨距的右側邊緣或左側邊緣。選取「完全縮小」時，會將標記移回其原始位置。

縮放不適用於下列各項：

  • 史密斯圖或極座標顯示格式

  • CW 時間和區段掃描類型

  • 頻率偏移量測

CW 頻率

使用 CW 時間掃描或功率掃描的量測將在單一頻率而非整個頻率範圍上執行。

如何設定 CW 頻率

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 將掃描類型設定為 CW 時間或功率掃描。

  2. 按下 [Freq] > Main（主功能表）> CW。

  3. 輸入所需的 CW 頻率。

  1. 將掃描類型設定為 CW 時間或功率掃描。

  2. 以滑鼠右鍵按一下網格方塊下方的激勵範圍區域。

  3. 按一下 CW...。

CW 頻率對話方塊說明

CW - 輸入一個值以及尾碼的第一個字母（k、m 或 g），或使用向上和向下箭頭選取 VNA 範圍內的任何值。

頻率解析度

用於設定頻率的解析度為 1 Hz。

上次修改時間：

2016 年 01 月 06 日

第一版


功率位準

功率位準是指測試連接埠的 VNA 來源的功率。

  • 如何進行功率設定

  • 「功率」對話方塊

  • 「功率和衰減器」對話方塊

請參閱其他「設定量測」主題

功率設定

在頻率範圍內指定測試連接埠輸出功率。

如何進行功率設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Power] > Main（主功能表）> Power Level（功率位準）/Start Power（開始功率）/Stop Power（停止功率），輸入所需功率位準。

  2. 按下 [Power] >Main（主功能表）> RF Power（RF 功率），開啟或關閉 RF 功率。

  3. 按下 [Power] > Leveling & Offsets（位準和偏移）> 按一下左側的 Slope（斜率）小按鈕以開啟或關閉斜率（綠色表示斜率開啟；灰色表示斜率關閉）。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下功率...，隨即顯示功率:通道 N 對話方塊。

功率對話方塊說明

針對特定連接埠的 VNA 來源功率進行基本控制。

請參閱來源功率和衰減的進階控制。

功率開啟（所有通道）- 與 RF 功率的功能也相同。勾選後可啟用所有通道的來源功率。僅當通道功率設定為「開啟」或「自動」時，才會開啟功率。請參閱「進階功率」。

連接埠「n」- 正在設定功率的作用中來源連接埠。

連接埠功率 - 設定指定連接埠的功率位準。

  • 若要準確地設定測試連接埠後任意點的功率位準，請執行來源功率校準。

  • 請參閱 VNA 模型的指定功率範圍。

功率掃描

開始/停止功率 - 設定功率掃描的開始和停止功率值。

  • 僅當掃描類型設定為「功率掃描」時，這些設定才可用。

  • 可透過「進階功率」對話方塊設定非耦合功率的掃描功率。

  • 可以透過縮放輕鬆地變更功率掃描的開始和停止功率位準。瞭解詳細資訊。

  • 暸解有關功率掃描的詳細資訊。

功率斜率 - 有助於補償隨著頻率增加而耗損的纜線和測試固定裝置功率。

斜率 - 選取後可設定功率斜率。清除後可將功率斜率設定為「關閉」。

如何進行功率和衰減器設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Power] > Main（主功能表）> Power and Attenuators...（功率和衰減器...），隨即顯示功率和衰減器對話方塊。

功率和衰減器的詳細資料設定

  1. 按下 [Power] >Main（主功能表）> RF Power（RF 功率），開啟或關閉 RF 功率。

  2. 按下 [Power] > Port Power（連接埠功率）> Select Port x（選取連接埠 x），以啟用選取的連接埠。

  3. 按下 [Power] > Port Power（連接埠功率）> Power Level（功率位準）/Start Power（開始功率）/Stop Power（停止功率），輸入所選連接埠的所需功率位準。

  4. 按下 [Power] > Port Power（連接埠功率）> Source State（來源狀態），選擇來源狀態（「自動」、「開啟」或「關閉」）。

  5. 按下 [Power] > Port Power（連接埠功率）> Coupling（耦合），開啟或關閉「耦合的功率」。

  6. 按下 [Power] > Leveling & Offsets（位準和偏移）> 按一下左側的 Slope（斜率）小按鈕以開啟或關閉斜率（綠色表示斜率開啟；灰色表示斜率關閉）。

功率和衰減器對話方塊說明

定義和控制作用中通道的 VNA 來源功率和衰減。

可透過此對話方塊控制外部來源。瞭解詳情。

功率開啟（所有通道）- 與 RF 功率的功能也相同。勾選後可啟用所有通道的來源功率。僅當通道功率設定為「開啟」或「自動」時，才會開啟功率。

耦合的連接埠功率

  • 耦合（已勾選）- 每個測試連接埠的功率位準相同。設定任何測試連接埠的功率，並且所有測試連接埠變更為相同的功率位準。

  • 非耦合（已清除）- 針對每個測試連接埠單獨設定功率位準。例如，您希望量測高增益放大器的增益和反向隔離，則不耦合功率。放大器之輸入連接埠所需的功率遠低於輸出連接埠所需的功率。也可以使用非耦合功率執行功率掃描。

名稱 - 列出 VNA 測試連接埠。

狀態

  • 自動 - 如果量測需要，會在指定的測試連接埠開啟來源功率。這是最常見的（預設）設定。另請參閱在儲存/重新叫用、使用者預設和預設期間開啟和關閉功率。

  • 開啟 - 來源功率將始終開啟，無論進行中的量測為何。使用此設定可為始終需要功率的受測裝置連接埠（如 LO 連接埠）提供來源功率。這可能會在其他測試連接埠中關閉功率。

  • 關閉 - 來源功率從不開啟，無論量測需求為何。使用此設定可防止對敏感的受測裝置測試連接埠造成損壞。

連接埠功率 - 設定來源輸出的功率位準。

  • 若要準確地設定測試連接埠後任意點的功率位準，請執行來源功率校準。

  • 請參閱 VNA 模型的指定功率範圍。

  • 請參閱 ECal 模組壓縮級別。

開始/停止功率 - 僅當掃描類型設定為「功率掃描」時才可用。設定功率掃描的開始和停止功率值。暸解有關功率掃描的詳細資訊。

  • 可以指定在功率掃描結束時將來源功率維持在開始功率還是停止功率位準。暸解有關功率位準的詳細資訊。

  • 可以使用非耦合功率執行功率掃描。在正反兩個方向均可掃描不同的功率範圍。

位準調整模式（軟鍵中的 ALC Hardware（ALC 硬體））

  • 內部 ALC 位準調整。

通道功率斜率 - 有助於在頻率增加時對纜線和測試固定裝置的功率損耗進行補償。啟用功率斜率後，連接埠輸出功率會隨著掃描頻率的增加而增加（輸入正值）或減少（輸入負值）。

斜率 - 選取後可設定功率斜率。清除後可將功率斜率設定為「關閉」。

基於 0 GHz 而非量測開始頻率來計算和套用功率斜率。例如，對於下列量測設定：

  • 開始/停止頻率：1 GHz 至 2 GHz

  • 功率位準：0 dBm

  • 斜率：1 dB/GHz

在 1 GHz 至 2 GHz 的頻率範圍內，進入受測裝置的功率從 1 dBm 逐漸增加到 2 dBm。

偏移和限制 - 啟動功率偏移和限制對話方塊。

來源位準不正確

當測試連接埠所需的功率位準高於 VNA 可提供的位準時，螢幕上會顯示「來源位準不正確」錯誤訊息，且狀態列上會顯示字母 LVL

若要解決位準不正確狀況，請變更測試連接埠功率。如果位準不正確狀況存在於指定功率範圍內，請與技術支援聯絡。若要設定將來源位準不正確事件報告為錯誤，請參閱啟用偏好設定對話方塊。

重要附註：「來源功率校準」、「引導式功率校準」或「功率補償」也可自動調整可用功率範圍。如果未看到預期範圍，或在受測裝置上未看到正確的功率位準，請檢視「功率限制和偏移」對話方塊中的「功率偏移」欄。

接收器衰減器對話方塊說明

接收器衰減用於保護 VNA 測試連接埠接收器免受損壞或壓縮。

附註：偏好設定可以設定為以數學方式將測試連接埠接收器上所報告的功率偏移接收器衰減量（或設定為不偏移）。依預設，所有 VNA 模型都會偏移顯示畫面。

瞭解如何設定偏好設定。

注意！如果功率位準超過最大值，可能會損壞分析儀接收器。

  • 請參閱技術規格，瞭解接收器的最大輸入功率以及接收器壓縮。

  • 請參閱適用於 VNA 模型的接收器衰減值。

上次修改時間：

2016 年 01 月 06 日

第一版


掃描

掃描設定

掃描是指對一系列指定激勵值進行一系列連續資料點量測。您可以進行下列掃描設定：

  • 點數（獨立主題）

  • 掃描類型

    • 線性頻率

    • 對數頻率

    • 功率掃描

    • CW 時間

    • 區段掃描

  • 頻率範圍：開始/停止（獨立主題）

  • 功率掃描

  • 區段掃描

    • 如何進行區段掃描設定

    • 「區段表格」對話方塊

  • X 軸點間距 - 僅區段掃描

  • 任意區段掃描

  • 掃描時間

  • 掃描設定

    • 自動與步進

    • 停頓時間與掃描延遲

    • 標準

  • 偏移 LO（獨立主題）

請參閱觸發和其他「設定量測」主題

掃描類型

如何設定掃描類型

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Main（主功能表）> Sweep Type（掃描類型）。

  1. 在網格方塊下方的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...。

  3. 選取掃描類型標籤。

  4. 按一下套用以實作設定變更。

掃描類型對話方塊/[Sweep] > Main（主功能表）> Sweep Type（掃描類型）Softtab 說明

附註：掃描設定將在按下確定或套用後才會套用。

通道 - 選取「掃描類型」時的作用中通道。掃描設定將套用至此通道。

線性頻率 - 設定將顯示在包含十個相同水平分量之標準網格上的線性頻率掃描。

  • 開始 - 設定頻率掃描的開始值。

  • 停止- 設定頻率掃描的結束值。

  • 功率 - 設定選擇性連接埠的功率位準。

  • 點數 - 設定在掃描期間 VNA 量測的資料點數。

  • IF 頻寬 - 設定 IF（接收器）頻寬。

對數頻率 - 來源以對數增量步進，且資料顯示在對數 X 軸上。在點數相同的情況下，此類掃描速度通常比連續掃描慢。

  • 開始 - 設定頻率掃描的開始值。

  • 停止- 設定頻率掃描的結束值。

  • 功率 - 設定選擇性連接埠的功率位準。

  • 點數 - 設定在掃描期間 VNA 量測的資料點數。

  • IF 頻寬 - 設定 IF（接收器）頻寬。

功率掃描 - 以指定的單一頻率啟動功率掃描。暸解有關功率掃描的詳細資訊

  • 開始功率- 設定功率掃描的開始值。

  • 停止功率 - 設定功率掃描的結束值。

  • CW 頻率- 設定在量測掃描期間 VNA 保持的單一頻率。

  • 點數 - 設定在掃描期間 VNA 量測的資料點數。

  • IF 頻寬 - 設定 IF（接收器）頻寬。

CW 時間 - 將 VNA 設定為單一頻率，資料隨時間顯示。瞭解詳情。

  • CW 頻率 - 設定在量測期間 VNA 保持的頻率。

  • 功率 - 設定選擇性連接埠的功率位準。

  • 點數 - 設定在掃描期間 VNA 量測的資料點數。

  • IF 頻寬 - 設定 IF（接收器）頻寬。

區段掃描 - 將 VNA 設定為掃描使用者定義的掃描區段。 暸解如何進行這些設定。

確定 - 套用設定變更並關閉對話方塊。

取消 - 關閉對話方塊。所做的設定變更不會套用和儲存，而是保持自上次按一下「套用」按鈕之後的設定。

套用 - 套用設定變更並保持對話方塊處於開啟狀態，以進行更多的設定變更。

說明 - 顯示掃描類型對話方塊說明。

功率掃描

功率掃描將按離散步長增加或減少來源功率。功率掃描可用於透過增益壓縮等量測來描繪功能敏感型電路的特性。

在掃描類型對話方塊中，指定「開始功率」、「停止功率」、「CW 頻率」、「點數」和「IF 頻寬」。

以下是在功率掃描模式下套用的其餘功率設定：

  • 「測試連接埠功率」設定不可用。

  • 「連接埠功率」可以是耦合或非耦合功率。

  • 將忽略「功率斜率」(dB/GHz)（輸出頻率為 CW）。

  • 按下 [Sweep] > Main（主功能表）> Number of Points（點數）可變更功率掃描的步長大小。

備註：

  • 功率掃描的速度已最佳化。若要確保功率掃描期間的量測準確度最高，可能需要增加停頓時間，以便有更多的時間來確定來源。

區段掃描

「區段掃描」可啟動由頻率子掃描（稱為區段）組成的掃描。對於每個區段，可定義獨立的功率位準、IF 頻寬、每個連接埠的 IF 頻寬、掃描時間、延遲、掃描模式和偏移 LO。

針對整個掃描或所有區段執行量測校準後，可以校準一或多個區段的量測。

在區段掃描類型中，分析儀執行下列操作：

  • 以頻率增加順序對所有已定義的區段進行排序。

  • 量測每個點。

  • 顯示包含所有已獲取資料的單一軌跡。

區段掃描的限制包括：

  • 某個區段的頻率範圍不得與任何其他區段的頻率範圍重疊。

  • 區段數目僅受到掃描中所有區段的組合資料點數限制。

如何進行區段掃描設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Segment Table（區段表格）。

  1. 在 X 軸標籤或格線下的激勵顯示區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...，然後在掃描類型下方選取區段掃描。

  3. 按一下區段表格...。

區段表格對話方塊說明 /掃描 > 區段表格 Softtab 說明

新增區段 - 在最後一個區段處新增掃描區段。

插入區段 - 在所選區段前新增掃描區段。也可以按一下鍵盤上的「向下」箭頭來快速新增多個區段。

刪除區段 - 移除所選區段。

刪除所有區段 - 移除所有區段。

附註：必須至少有一個區段處於開啟狀態，否則掃描類型會自動設定為線性。

「區段表格」對話方塊

X 軸點間距 - 勾選後可將 X 軸縮放為僅包含區段。瞭解詳情。

允許任意區段 - 勾選後可允許任意頻率（重疊或反向掃描）。瞭解詳情。

顯示中心/頻距頻率 - 勾選後可顯示中心/跨距頻率。

每個區段的獨立設定

功率位準 - 設定區段的功率位準。此外，測試連接埠功率可以是非耦合功率。請參閱功率耦合。

IF 頻寬 - 設定區段的 IF 頻寬。

每個連接埠的 IF 頻寬 - 為區段的不同連接埠設定不同的頻寬。

掃描時間 - 設定區段的掃描時間。

延遲 - 設定在每個區段的擷取操作開始之前需等待的時間。

停頓 - 指定在分析儀獲取資料之前，來源在每個量測點停留的時間。

掃描模式 - 將掃描模式設定為自動或步進。

偏移 LO - 設定偏移 LO 的狀態。暸解詳細資訊。

R

儲存表格 - 儲存區段表格中的設定變更。

載入表格- 套用區段表格中的設定變更。

修改現有區段

若要使下列功能表設定可用，必須先顯示區段表格。（按下 [Sweep] > Segment Table（區段表格））

上圖所示的區段表格中，所有獨立設定皆已選取，包括耦合的來源功率（兩個功率設定）。

狀態 - 在要修改的區段上按一下該方塊。然後，使用向上/向下箭頭以開啟或關閉區段。

開始 - 設定區段的開始頻率。按一下方塊，然後輸入一個值以及尾碼的第一個字母（KHz、Mhz、GHz）。或按兩下方塊以選取值。

停止 - 設定區段的停止頻率。按一下方塊，然後輸入一個值以及尾碼的第一個字母（KHz、Mhz、GHz）。或按兩下方塊以選取值。

附註：區段表格會截斷頻率解析度。若要驗證輸入的頻率解析度，請在開始或停止頻率設定處建立一個標記。

點數 - 設定此區段的資料點數。插入一個值或按兩下方塊以選取值。

為每個區段單獨設定功率位準、IF 頻寬/每個連接埠的 IF 頻寬、掃描時間、延遲、每個連接埠的接收器衰減器、掃描模式和偏移 LO：

  1. 按下 [Sweep] > Main（主功能表）> Sweep Type（掃描類型）> Segment Sweep（區段掃描）。

  2. 按一下 Segment Table（區段表格） > Segment Table...（區段表格...）。

  3. 按一下方塊並輸入一個值，或按兩下方塊以選取一個值。

附註：如果未進行以下設定，整個掃描將使用通道 IFBW、功率和時間設定。

X 軸點間距 - 僅區段掃描

此功能影響區段軌跡在畫面上的繪製方式。

如何啟用 X 軸點間距

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Segment Table（區段表格）> Segment Table...（區段表格...）。

  2. 勾選 X 軸點間距。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...，然後在掃描類型下方選取區段掃描。

  3. 按一下區段表格...。

  4. 勾選 X 軸點間距。

  • 不使用 X 軸點間距時，多區段掃描軌跡有時可能會導致許多量測點擠入 X 軸的一個較窄部分。

  • 使用 X 軸點間距時，需要選擇每個點的 X 軸位置，以便所有量測點沿 X 軸等間距地分佈。

例如，假設有以下兩個區段：

不使用 X 軸點間距

使用 X 軸點間距

任意區段掃描

此功能允許在區段掃描表格中輸入任意頻率。使用此功能時，區段支援：

  • 重疊頻率。

  • 停止頻率小於開始頻率（反向掃描）。

但是存在以下幾個限制：

  • 掃描模式：僅限「步進」。

  • 掃描時間：執行反向掃描時，量測點之前的掃描時間和等待時間將變長。

如何啟用任意區段掃描

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Segment Table（區段表格）> Segment Table...（區段表格...）。

  2. 勾選允許任意區段掃描。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...，然後在掃描類型下方選取區段掃描。

  3. 按一下區段表格...。

  4. 勾選允許任意區段掃描。

附註：

    • 將任意掃描區段與標記、顯示、限制線、格式設定和某些校準功能一起搭配使用時，可能會發生異常結果。

    • 如果區段表格同時包含正向和反向頻率掃描，修正插補可能無法正常運作。在修正和量測時同時使用相同的區段表格設定。（即在顯示「Cor」的情況下進行量測。）

    • 當區段表格的資料數目超出其限制時，會發生錯誤。在此情況下，請減小量測資料大小（即 NOP，通道數目）。

掃描時間

在選取的量測設定下，VNA 會自動使掃描時間盡可能最短。但是，可以增加掃描時間來降低掃描速度。

如何設定掃描時間

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Sweep Timing（掃描定時）> Sweep Time（掃描時間）以變更為「手動」。

  2. 輸入所需掃描時間。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...。

  3. 選取時序標籤。

  4. 關閉自動掃描時間核取方塊。

  5. 輸入所需掃描時間。

[Sweep]> Sweep Timing（掃描定時） Softtab 說明

掃描時間 - 指定 VNA 擷取掃描資料所需的時間。VNA 的掃描時間上限取決於各種設定（例如 IFBW、停頓時間、點數等）。暸解有關影響掃描速度的其他設定的資訊。

掃描設定

如何進行掃描設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Sweep] > Sweep Timing（掃描定時）。

  1. 在 X 軸標籤或格線下的激勵範圍區域上按一下滑鼠右鍵。

  2. 按一下掃描設定...。

  3. 選取時序標籤。

掃描設定對話方塊/[Sweep] > Sweep Timing（掃描定時）Softtab 說明

時間

掃描時間- 與掃描時間 Softtab 說明相同。

停頓時間 - 指定在分析儀獲取資料之前，來源在每個量測點停留的時間。僅適用於步進掃描。最長停頓時間為 20 sec。另請參閱長纜線裝置。

掃描延遲 - 指定在每次掃描的擷取操作開始之前需等待的時間。此延遲是指停頓時間（每個點）與外部觸發延遲（如果已啟用）之和。

自動掃描時間- 自動調整掃描時間和停頓時間。勾選「自動掃描時間」時，將無法編輯掃描時間和停頓時間。

掃描模式

自動掃描 - 按一下「自動掃描模式」時，VNA 會自動選擇最快的掃描模式，即「掃描（類比掃描）」或「步進」。（S 掃描的掃描時間比步進掃描短。）模式可以隨掃描而變更。無法確定 VNA 是處於類比掃描模式還是步進掃描模式。如果您要確定目前掃描模式為何，則將其切換至「步進」。

步進掃描 - 按一下「步進掃描模式」時，VNA 來源將進行調整，然後等待指定的停頓時間，獲取回應資料並將來源調整到下一個頻率點。此掃描模式比類比掃描速度慢，但在測試長纜線裝置方面的準確度較高。

基於一些原因，會自動選取步進掃描。部分原因如下：

  • IF 頻寬等於或低於 9 kHz。

  • 來源功率修正處於開啟狀態（除非進行 CW 量測）。

  • 步進模式可以更快地獲取資料。

  • 適用於所有 FOM 量測。

掃描順序

標準掃描 - 勾選時，VNA 將依次針對每個來源連接埠掃描所有資料點。對於 2 連接埠 VNA，這意味著所有資料點將進行正向掃描，然後再進行反向掃描。即使不顯示反向參數（S22 或 S12），在對通道進行全 2 連接埠校準時也需要進行反向量測。這是預設行為。瞭解詳情。

上次修改時間：

2016 年 01 月 06 日

第一版


[Trigger]

[觸發]

觸發是促使 VNA 進行量測掃描的訊號。VNA 在設定觸發功能方面極具彈性。

檢視互動式觸發模型動畫以暸解觸發在 VNA 中的運作方式。

  • 如何設定觸發

  • 來源

  • 範圍

  • 通道設定

  • 重新啟動

  • 外部和輔助觸發（獨立主題）

請參閱其他「設定量測」主題

觸發設定

如何設定觸發

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Trigger] > Main（主功能表）> Trigger...（觸發...）。

  1. 在狀態列的觸發或量測圖示上按一下滑鼠右鍵。

  2. 選取觸發...。

附註：連續、單次和保持設定僅適用於作用中通道。這些設定可透過「觸發」功能表、「作用中項目」硬鍵和軟鍵進行存取

觸發設定對話方塊說明

檢視互動式觸發模型動畫以暸解觸發在 VNA 中的運作方式。

觸發來源

這些設定可確定所有現有通道的觸發訊號來源。僅當 VNA 未進行掃描時，才會產生有效的觸發訊號。

內部 - 上一個量測完成後，VNA 將立即傳送連續的觸發訊號。

手動 - 透過「觸發」按鈕、作用中工具列或編程指令叫用時，會傳送一個觸發訊號。

外部（使用 MEAS 觸發輸入）- 從後面板上的各種接頭向外傳送或接收觸發訊號。暸解有關外部和輔助觸發的詳細資訊。

手動觸發!- 手動將一個觸發訊號傳送至 VNA。僅當選取手動觸發時才可用。

觸發範圍

這些設定可確定觸發內容。

全域 - 觸發 將傳送至所有可觸發的通道。一個觸發將掃描所有可觸發的通道。[預設設定]

通道 - 觸發將傳送至目前通道，但在目前通道完成後，該通道會遞增至下一個可觸發通道。

作用中通道 - 觸發僅傳送至作用中通道。作用中通道不會變更。

通道觸發狀態

這些設定可確定通道將接受的觸發訊號數量。

連續 - 通道接受無限數量的觸發訊號。

群組 - 通道僅接受在「群組數目」文字方塊中指定的觸發訊號數目，然後便進入「保持」狀態。 選取群組之前，您必須先將「群組數目」文字方塊遞增至大於 1。

群組數目 - 指定通道在進入「保持」狀態之前所接受的觸發數目。若為「點掃描」，則整個掃描會視為一個群組。

首先遞增至所需數目，然後選取「群組」。

單次 - 通道接受一個觸發訊號，然後進入「保持」狀態。

觸發單次量測的另一種方法是將觸發來源設定為「手動」，然後傳送手動觸發。但是，所有通道都是單次觸發。

保持 - 通道不接受任何觸發訊號。

觸發模式

這些設定可確定每個訊號將觸發的內容。

僅當觸發來源為「手動」或「外部」且觸發範圍為「通道」時，掃描和點模式才可用。

  • 通道 - 每個觸發訊號都會致使該通道中的所有軌跡按下列指定順序進行掃描。

  • 點 - 每個「手動」或「外部」觸發訊號都會促使對一個資料點進行量測。後續觸發會移至同一個軌跡，直到它完成，然後同一個通道中的其他軌跡按下列指定順序進行掃描。 若為「群組」或「單次」觸發，則對通道中所有軌跡上的所有資料點進行量測後，計數會遞減 1。 另請參閱（點）掃描指示器和 SCPI 觸發範例，以便與「外部」搭配使用。

  • 軌跡 - 僅當選取點掃描時才可用。每個觸發訊號會導致單獨觸發兩個相同的量測 - 每個量測需要一個觸發訊號。其他觸發模式設定導致同時量測兩個相同的參數。 如果通道使用 2 連接埠（或更多）S 參數校準，則不允許觸發軌跡。

  • 掃描 - 每個「手動」或「外部」觸發訊號，都會導致共用來源連接埠的所有軌跡按下列指定順序進行掃描。若為「群組」或「單次」觸發，則對所有方向上的所有軌跡進行量測後，計數會遞減 1。

多連接埠修正處於開啟狀態時（需要從多個方向掃描），畫面上的軌跡不會進行更新，直到掃描完所有相關方向。例如，顯示所有四個 2 連接埠的 S 參數時：

    • 全 2 連接埠修正處於開啟狀態時，觸發 1 將導致任何軌跡都不進行更新；觸發 2 將導致所有 S 參數進行更新。暸解有關修正處於開啟狀態時的掃描的詳細資訊。

    • 修正處於關閉狀態時，觸發 1 將導致 S11 和 S21 進行更新；觸發 2 將導致 S22 和 S12 進行更新。

軌跡掃描順序

對於所有觸發模式，觸發訊號將繼續處於同一個通道中，直到該通道中的所有軌跡皆已完成。然後，繼續觸發未處於「保持」狀態的下一個通道。

每個通道內的軌跡始終按下列順序進行掃描：

  • 按來源連接埠順序依序掃描軌跡。例如，在具備所有四個 2 連接埠 S 參數的通道中，請先同時掃描來源連接埠 1 軌跡（S11 和 S21）。然後，同時掃描來源連接埠 2 軌跡（S22 和 S12）。

重新啟動 - （只能透過「觸發」功能表存取）處於「保持」狀態的通道將設定為單次觸發（通道接受單次觸發訊號）。所有其他設定皆不受影響，包括遞減觸發群組。

另請參閱

  • 外部和輔助觸發。

  • 互動式觸發模型動畫

上次修改時間：

2016 年 01 月 06 日

第一版


外部觸發

外部和輔助觸發

外部和輔助觸發均可用於對 VNA 與其他設備的觸發進行同步。

附註：將外部來源設定為外部裝置時，VNA 將自動控制所有觸發設定。請勿進行其他觸發設定。瞭解詳情。

  • 概觀

  • 如何進行觸發設定：

    • 量測觸發（輸入）

    • 輔助觸發

另請參閱

  • 同步外部來源

  • 觸發

概觀

就緒訊號與觸發訊號

「觸發就緒」訊號不同於觸發訊號。就緒訊號指示傳送訊號的儀器已做好量測準備。收到就緒訊號的儀器隨後傳送觸發訊號，指示將進行或已經完成的量測。通常，較慢的儀器傳送觸發訊號。

暸解有關每種觸發訊號類型的詳細資訊：

  • 量測觸發輸入 - 此訊號易於使用，但設定功能受限。

  • 輔助觸發輸出 - 接頭和訊號是高度可設定的。可將其用於與任何數目的裝置和設備同步。

量測（外部）觸發對話方塊說明

請參閱如何存取「觸發」對話方塊

Meas 觸發輸入

該觸發輸入接頭位於 VNA 後面板上。

當 VNA 與較慢的機械裝置進行通訊時，可使用這些訊號。材料處理程式非常機械化，裝卸零件所需的時間相對較長。以下將說明這些訊號如何共同運作以進行通訊：

  1. 當 VNA 準備好進行量測時，會傳送「就緒」訊號。

  2. 當外部裝置準備好進行量測時，會將觸發訊號傳送給 VNA。

  3. 其他訊號在 VNA 處理程式 I/O 上提供，用於指示 VNA 掃描已完成，可為下一個量測設定處理程式。

對話方塊設定

若要使 VNA 回應量測觸發輸入或處理程式 I/O 訊號，請在「觸發設定」標籤的「來源」設定上選取外部。

此外，在「觸發設定」標籤的「範圍」設定上，選擇一個外部觸發訊號將套用至所有通道（全域）還是套用至一個通道。將相應地套用下列設定。

主要觸發輸入

全域/通道觸發延遲 - 收到外部觸發後，掃描的開始時間將延遲該指定的時間量加任何固有延遲。

  • 當觸發範圍為「通道」時，延遲值將套用至指定通道。

  • 當觸發範圍為「全域」時，相同的延遲值將套用至所有通道。

來源 VNA 透過下列接頭接受觸發輸入訊號：

  • 量測觸發輸入 BNC：後面板上的觸發輸入

  • 處理程式 I/O 接腳 18

極性

高位準 - 當 VNA 已做好準備（觸發就緒）且選取輸入上的 TTL 訊號為「高」時，便會觸發 VNA。

低位準 - 當 VNA 已做好準備（觸發就緒）且選取輸入上的 TTL 訊號為「低」時，便會觸發 VNA。

正邊緣 - 在 VNA 做好準備後，它將在下一個正邊緣觸發。 當做好準備之前接受觸發已設定時，如果自上次資料獲取後收到正邊緣，則 VNA 會在做好準備後立即觸發。

負邊緣 - 在 VNA 做好準備後，它將在下一個負邊緣觸發。當做好準備之前接受觸發已設定時，如果自上次資料獲取後收到負邊緣，則 VNA 會在做好準備後立即觸發。

做好準備之前接受觸發 - 勾選後，當 VNA 做好準備（觸發就緒）時，如果自上次資料獲取後收到任何觸發，則 VNA 會立即觸發。VNA 只會記住一個觸發訊號。將忽略所有其他訊號。

  • 如果清除此核取方塊，則 VNA 做好準備之前收到的任何觸發訊號都將忽略。

  • 僅在選取了正邊緣或負邊緣觸發時，此功能才可用。

  • 使用 CONTrol:SIGNal (SCPI)ExternalTriggerConnectionBehavior 從遠端設定此設定。

低延遲模式：- 勾選後，對於點觸發量測，接受觸發與開始單點量測之間的延遲時間變化會減少。但是，在此模式下，不會針對每個點輸出 /READY FOR TRIGGER。

  • 點觸發：開啟，低延遲：開啟

  • 點觸發：開啟，低延遲：關閉

觸發就緒指示器（輸出）

在 VNA 上，如果已選取「觸發設定」標籤上的「外部」，則會同時啟用「量測觸發輸入」和「量測觸發就緒（輸出）」。

選擇要傳送 VNA 就緒輸出訊號的接頭：

  • 處理程式 I/O 接腳 21

選擇「就緒輸出」訊號的極性。

  • 就緒低 -「TTL 低」指示 VNA 觸發就緒（「就緒高」在 E5080A 上不可用。）

另請參閱

  • 暸解如何在校準期間進行外部觸發

輔助觸發 1 對話方塊說明

請參閱如何存取「觸發」對話方塊

附註：將外部來源設定為外部裝置時，VNA 將自動控制所有觸發設定。請勿進行其他觸發設定。瞭解詳情。

輔助觸發輸出

輔助觸發接頭位於 VNA 後面板上。

  1. VNA 會在收到來自指定觸發來源的觸發訊號時開始量測：

    • 內部 - 立即開始量測。

    • 手動 - 按下 VNA「觸發」按鈕時開始量測。

    • 外部 - 收到來自外部裝置的量測觸發輸入訊號時開始量測。必須單獨設定此項。

  2. 可將「輔助觸發輸出」訊號設定為正好在進行量測之前或量測完成之後傳送。僅與外部來源進行通訊時，應在量測完成之後傳送「輔助觸發輸出」訊號，以指示可針對下一個量測設定外部來源。

對話方塊設定

啟用 - 勾選後可使用輔助接頭將訊號輸出至外部裝置。

通道：此設定由 VNA「偏好設定」設定控制。

  • 全域 - 所有輔助觸發設定將套用至所有通道。在「觸發設定」標籤上進行「每個點」設定（請參閱以下內容），該設定也將套用至所有通道。

  • 通道 - 所有輔助觸發設定將套用至指定通道。可單獨設定每個通道。

輔助觸發輸出（至裝置）

下列設定控制從後面板「輔助觸發輸出」接頭送出之訊號的屬性：

極性

正脈衝 - 傳出脈衝為正。

負脈衝 - 傳出脈衝為負。

位置

擷取之前 - 在資料擷取開始之前立即傳送脈衝。

擷取之後 - 在資料擷取完成之後立即傳送脈衝。

每個點 - 勾選後可為每個資料點傳送觸發輸出。 清除後可為每次掃描傳送觸發輸出。

選取「輔助觸發」-「全域」VNA 偏好設定時，會在「觸發設定」標籤上進行「點」設定。然後，會套用至所有通道。如果存在多個通道，則會使用上次所做的通道設定。

脈衝持續時間 - 指定正或負輸出觸發脈衝的持續時間。

另請參閱

  • 請參閱如何使用這些接頭與外部來源同步。

附註：可在外部觸發模式下執行引導和非引導校準。執行此可選行為時，如果「觸發來源」設定為「外部」，則必須傳送觸發訊號以進行校準掃描。此行為不適用於 FCA 校準。

當 VNA 等待外部觸發訊號時，VNA 螢幕上會顯示下列對話方塊。

按一下中止可取消觸發訊號等待。

上次修改時間：

2016 年 01 月 06 日

第一版


觸發模型動畫

速度計 | 觸發來源 內部 手動
 | 觸發範圍 全域 [通道]

連續
群組
單端
保持
點

連續
群組
單端
保持
點

連續
群組
單端
保持
點

關於觸發模型

此簡化模型可協助您暸解分析儀的彈性觸發行為。通道觸發以墜落的球表示。

儘管這並非確切 VNA 模型的觸發行為，但下列差異很細微。

  • 設定回應時序與分析儀不同。例如，在分析儀中，會立即切換到手動模式。模型將等到目前掃描完成。

  • 該模型不包括外部觸發。

  • 速度計 - 用於控制動畫的速度：

請閱讀觸發行為的文字說明。

此模型不包括新的掃描觸發模式。


資料格式和縮放

資料格式

資料格式是 VNA 以圖形方式呈現量測資料的方式。挑選與要暸解的測試裝置相關資訊相對應的資料格式。

  • 顯示格式

  • 直角座標（笛卡爾）顯示格式

  • 極性

  • 史密斯圖

請參閱其他「設定量測」主題

顯示格式

如何設定顯示格式

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Format] > Format 1（格式 1）或 Format 2（格式 2）。

  1. 在網格方塊上方的軌跡狀態區域上按一下滑鼠右鍵。

  2. 按一下格式。

  3. 選取所需格式。

格式 > Format 1（格式 1）、Format 2（格式 2）SoftTab 說明

  • 對數幅度

  • 相位/展開相位

  • 群組延遲

  • 史密斯/逆向史密斯圖

  • 極性

  • 線性幅度

  • SWR

  • 實數

  • 虛數

直角座標顯示格式

九種可用資料格式中有七種使用直角座標顯示來呈現量測資料。此顯示亦稱為笛卡爾座標、X/Y 或直線形座標。若要清楚地顯示測試裝置的頻率回應資訊，直角座標顯示將很有幫助。

  • 激勵資料（頻率、功率或時間）經線性縮放後顯示在 X 軸上

  • 量測資料顯示在 Y 軸上。

對數幅度格式

  • 顯示幅度（無相位）

  • Y 軸：dB

  • 典型量測：

    • 回波損耗

    • 插入損耗或增益

相位格式

相對於校準參考平面來量測信號的相位，範圍為 +/- 180 度。

  • 顯示相位（無幅度）

  • Y 軸：相位（度）

  • 每 180 度軌跡都會「折繞」，以便於縮放。

  • 典型量測：

    • 線性相位偏差

展開相位

  • 與相位相同，但沒有 180 度折繞。

附註：透過比較一個資料點與下一個資料點的相位來展開相位。如果兩個資料點之間的相位差大於 180 度，或第一個資料點的 DC 偏移相位大於 180 度，則相位量測可能不準確。

群組延遲格式

  • 顯示信號在裝置中的傳輸（傳遞）時間

  • Y 軸：時間（秒）

  • 典型量測：

    • 群組延遲

另請參閱：

群組延遲（量測）

比較 VNA 延遲功能。

相位量測準確度

線性幅度格式

  • 僅顯示正值

  • Y 軸：無單位 (U)，適用於比例量測
    瓦特 (W)，適用於無比例量測。

  • 典型量測：

    • 反射和傳輸係數（幅度）

    • 時域轉移

SWR 格式

  • 顯示從公式 (1+r)/ (1-r)（其中 r 是反射係數）計算得出的反射量測資料。

  • 僅對反射量測有效。

  • Y 軸：無單位

  • 典型量測：

    • SWR

實數格式

  • 僅顯示量測的複數資料的實數（電阻）部分。

  • 可同時顯示正值和負值。

  • Y 軸：無單位

  • 典型量測：

    • 時域

    • 用於維修目的的輔助輸入電壓信號

虛數格式

  • 僅顯示已量測資料的虛數（電抗）部分。

  • Y 軸：無單位

  • 典型量測：

    • 用於設計相符網路的阻抗

極座標格式

極座標格式用於檢視 S11 或 S22 量測中的反射係數（G）的幅度和相位。

可使用標記顯示下列內容：

  • 線性幅度（以單位數計）或對數幅度（以 dB 為單位）

  • 相位（以度為單位）

  • 虛線圓表示反射係數。最外圈表示值為 1 的反射係數 (G)，或反射信號總計。圓心表示值為 0 的反射係數 (G)，或沒有反射信號。

  • 徑向線顯示反射信號的相位角。最右側的位置對應於零相位角（也就是說，反射信號與入射信號的相位相同）。90°、±180° 和 -90° 的相位差分別對應於極座標顯示的頂部、最左側和底部位置。

史密斯圖格式

史密斯圖是將複雜反射係數 (G) 對應至測試裝置阻抗的工具。

在史密斯圖中，直線形阻抗平面會重新塑型以形成圓形網格，可從該網格讀取系列電阻和電抗 (R + jX)。

可使用標記顯示下列內容：

  • 電阻（以歐姆為單位）

  • 作為對等電容（以法拉為單位）或電感（以亨利為單位）的電抗

逆向史密斯圖（亦稱為導納）

與標準史密斯圖相同，以下除外：

  • 圖標格線反轉為從右到左。

  • 導納（以西門子為單位）替代電阻。

解譯史密斯圖

  • 史密斯圖上的每一點都表示由實數電阻 (r) 和虛數電抗 (r+-jX) 構成的複雜阻抗

  • 水平軸（實線）表示阻抗與電阻之差的實數部分。水平軸的中心始終表示系統阻抗。最右側的值為無限大的歐姆（開路）。最左側的值為零歐姆（短路）

  • 與水平軸相交的虛線圓表示恆定電阻。

  • 與水平軸相交的虛線弧表示恆定電抗。

  • 史密斯圖上半部分是電抗分量為正值且因此產生電感的區域。

  • 下半部分是電抗分量為負值且因此產生電容的區域。

上次修改時間：

2014 年 07 月 25 日

第一版


[Scale]

刻度

刻度、參考位準和參考位置設定（以及格式）可確定資料軌跡在 VNA 畫面上的顯示方式。

  • 刻度、參考位準和位置

  • 刻度耦合

  • 放大模式和縮放偏好設定

  • 電延遲（獨立主題）

  • 幅度偏移和幅度斜率

  • 相位偏移（獨立主題）

請參閱其他「設定量測」主題

刻度、參考位準和位置

刻度、參考位準和參考位置設定（以及格式）可確定資料軌跡在 VNA 畫面上的顯示方式。

如何設定刻度、參考位準和位置

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Scale] > Main（主功能表）> Scale（刻度）/Reference Level（參考位準）/Reference Position（參考位置）。

  2. 輸入所需值。

  1. 在 Y 軸註解或網格方塊上方的軌跡狀態標籤上按一下滑鼠右鍵。

  2. 選取刻度...。

刻度對話方塊說明/[Scale] > Main（主功能表） Softtab 說明

附註：刻度設定已設為與每個視窗中的其他軌跡耦合。下列設定假設「刻度耦合」已設定為「關閉」。暸解有關刻度耦合的詳細資訊。

刻度

每個分量 - 設定直角座標顯示格式的垂直分量值。在極座標和史密斯圖格式中，刻度設定外圓周的值。範圍：0.001 dB/div 至 500 dB/div。

提示：按一下 Y 軸標籤，然後使用滑鼠滾輪按預設增量變更刻度

自動縮放 -自動設定垂直分量值和參考值，使其適合畫面網格區域內的作用中資料軌跡。激勵值和參考位置不受影響。

分析儀可確定將允許所有顯示資料出現在 80% 的垂直網格上的最小可能縮放因數。

選擇的參考值使軌跡在畫面上置中。

提示：按兩下 Y 軸標籤以自動縮放作用中軌跡。

全部自動縮放 - 自動縮放工作中視窗中的所有資料軌跡，以在垂直方向上適合畫面的網格區域。

參考

位準

在直角座標格式中設定參考行的值，在 VNA 畫面上以 [image] 表示。範圍：-500 dB 至 500 dB。

在極座標和史密斯圖格式中，參考位準不適用。

提示：按一下 Y 軸標籤，然後向上或向下拖曳可按預設增量變更參考位準。

位置

在直角座標格式中，設定參考行的位置。零為畫面底行，十為頂行。預設位置為五（中間）。

在極座標和史密斯圖格式中，參考位置不適用。

提示：按一下三角形 [image] ，然後向上或向下拖曳可按預設增量變更參考位置。

刻度耦合

啟用「刻度耦合」時，格式相同的軌跡將具有相同的刻度、參考位準和參考位置。可以選擇耦合同一視窗中軌跡的刻度、耦合所有視窗中所有軌跡的刻度，也可以選擇不耦合。

如何設定刻度耦合

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Scale] > Main（主功能表）> Scale Coupling...（刻度耦合...）。

  1. 在視窗的 Y 軸標籤上按一下滑鼠右鍵。

  2. 選取刻度耦合...。

刻度耦合對話方塊說明

允許共用相同格式的軌跡具有相同的刻度、參考位準和參考位置。

耦合方法

關閉 - 不耦合。將軌跡個別縮放。預設設定。

視窗 - 每個所選視窗中格式相同的所有軌跡都共用相同的刻度設定。

全部:在所有選取的視窗之間耦合

所有選取的視窗中格式相同的所有軌跡都共用相同的刻度設定。

  • 啟用視窗或全部耦合時，作用中軌跡的刻度設定將由格式相同的其他耦合軌跡採用。

  • 如果存在格式不同的軌跡，該格式的所有軌跡都將採用該格式中編號最小的軌跡的設定。

  • 一旦啟用，格式相同的所有耦合軌跡的刻度設定可隨任何處於作用中狀態的耦合軌跡而變更。

選取的視窗

選取視窗或全部方法時可用。選取的視窗將參與刻度耦合。依預設，會選取所有視窗。取消勾選核取方塊可停用該視窗的刻度耦合。

關於自動縮放和刻度耦合

使用耦合方法的自動縮放

- 影響作用中視窗中的作用中軌跡。耦合至此軌跡的所有軌跡都將採用作用中軌跡的新刻度設定。這可能會導致某些軌跡在畫面上不顯示。

使用耦合方法的全部自動縮放

  • 關閉 - 作用中視窗中的所有軌跡都將單獨進行自動縮放。

  • 視窗 - 每個所選視窗中的所有軌跡都將進行自動縮放，以符合一組通用的縮放因數。

  • 全部 - 所有選取的視窗中的所有軌跡都將進行自動縮放，以符合一組通用的縮放因數。

放大模式和縮放偏好設定

放大功能可讓您放大作用中視窗內的所有軌跡。它可讓您放大顯示畫面的一部分，以詳細查看回應。

如何設定放大模式

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Scale] > Main（主功能表）> Magnify（放大）> Magnify On/Magnify Off（放大開啟/放大關閉）

  1. 在顯示畫面上按一下滑鼠右鍵。

  2. 從快顯功能表中選取「放大開啟/關閉」。

設定放大模式的其他方法包括：

  • 當「縮放偏好設定」設定為「放大」時，雙指展開手勢將開啟放大模式

  • 按一下螢幕頂端的「放大」圖示

  • 啟用縮放方塊選取模式並拖曳縮放方塊以選取區域，然後在快顯功能表中選擇「放大」選項。

[Scale] > Main（主功能表）Softtab/Magnify（放大）

放大模式已開啟時：

雙指捏合顯示畫面將變更 X 和 Y 軸放大率。如果透過捏合將放大率降低至 1:1 的縮放比例，則將關閉放大模式。

單指拖曳顯示畫面會變更放大之 X 和 Y 軸的參考。

縮放偏好設定對話方塊說明

「縮放偏好設定」可讓您從下列 4 個選項中確定雙指捏合手勢的預設作業：

雙指捏合將自動開啟放大模式，以便能夠放大 X 和 Y 軸/這是預設設定。

雙指捏合將變更 Y 軸比例。

雙指捏合將變更 Y 軸比例和 X 軸激勵。

雙指捏合不起任何作用。

幅度偏移

「幅度偏移」允許按固定或斜率值（以 dB 為單位）偏移幅度（無相位）資料。如果顯示格式為「線性幅度」或「實數」（無單位），則會轉換 dB 並實作正確的偏移量。

如何設定幅度偏移

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Scale] > Constants（常數）> Mag Offset（幅度偏移）/Mag Slope（幅度斜率）。

[Scale] > Constants（常數） Softtab

幅度偏移設定僅影響作用中軌跡。

幅度偏移 - 按指定值偏移整個資料軌跡。

幅度斜率 - 按隨著頻率變更的值偏移資料軌跡。偏移斜率從 0 Hz 開始。

請參閱在資料處理鏈中執行此操作的情況。

上次修改時間：

2014 年 07 月 23 日

第一版


自訂分析儀螢幕

自訂 VNA 螢幕

可透過顯示或隱藏下列顯示元素來自訂 VNA 畫面。

  • 視窗（獨立主題）

  • 顯示標籤

    • 軌跡狀態

    • Y 軸標籤

    • X 軸標籤

  • 標記顯示（獨立主題）

  • 表

  • 工具列

    • 軟鍵

    • 硬鍵

    • 連接埠延伸

    • 變換

    • 標記

    • 校準集檢視器

    • 標題列

    • 作用中項目

    • 狀態列

    • 系統日期與時間

  • 顯示顏色（獨立主題）

  • 網格：實線|虛線

    • 格線

    • Y 軸分量

    • 顯示表格

  • 工具

  • 顏色

  • 視窗標題

  • 軌跡標題

  • 頻率/激勵

  • 應用程式縮到最小​​

另請參閱

VNA 的擴展顯示功能

VNA 上的軌跡、通道及視窗

請參閱其他「設定量測」主題

標籤

可以針對軌跡狀態、Y 軸和 X 軸標籤顯示不同的標籤。

如何顯示標籤。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Display Settings（顯示設定）> Customize Display...（自訂顯示...）。

  2. 選取標籤標籤。

或

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Display...（標記顯示...）。

  2. 選取標籤標籤。

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取標籤標籤。

「標籤」標籤對話方塊說明

顯示標籤

軌跡狀態

軌跡狀態在每個視窗上方進行標註。

反白顯示的軌跡編號指示作用中軌跡。

按一下標題可選取軌跡。

「軌跡狀態」顯示下列內容：

  • 軌跡編號 (Tr x)。此為通道的軌跡編號；不是在許多編程指令中使用的視窗軌跡編號。

  • 量測參數。此可取代為自訂軌跡標題。

  • 格式

  • 縮放因數

  • 參考位準

如何顯示/隱藏軌跡狀態。

Y 軸標籤

"Y 軸標籤" - 可讓使用者顯示或隱藏 Y 軸標籤。

如何顯示/隱藏 Y 軸標籤。

X 軸標籤

"X 軸頻率解析度" - 可讓使用者選擇頻率顯示的解析度。下拉式選項：6 位數、GHz、MHz、kHz、Hz。 它顯示 1Hz 解析度，但僅顯示有效數字。

如何顯示/隱藏 X 軸標籤。

網格

如何設定 VNA 網格並顯示表格。

每個視窗一次只能顯示一個表格。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Display Settings（顯示設定）> Customize Display...（自訂顯示...）

  2. 選取網格標籤。

或

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Display...（標記顯示...）。

  2. 選取網格標籤。

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取網格標籤。

網格對話方塊說明

格線：實線|虛線 - 設定以實線還是虛線顯示所有開啟視窗的格線。所選設定將以大寫字母顯示。一旦設定，新視窗便會透過此設定加以建立。如果已預設 VNA，格線將恢復為實線。

使用顯示顏色設定網格顏色。

如何顯示網格設定

Y 軸分量 - 設定 Y 軸所需的列數，可顯示 2 至 30 列。

顯示表格

無- 關閉表格。

標記表格

可顯示標記設定表格。這些設定包括：

  • 標記編號

  • 標記參考（用於差量量測）

  • 頻率

  • 時間和距離（用於時域量測）

  • 回應

暸解有關標記的詳細資訊

限制線表格

可以顯示、設定和修改限制測試設定的表格。這些包括：

  • 類型（最小值、最大值或關閉）

  • 開始和結束激勵值

  • 開始和結束回應值

暸解有關限制線的詳細資訊。

區段掃描表格

可以顯示、設定和修改區段掃描設定的表格。這些包括：

  • 狀態（開啟/關閉）

  • 開始和停止頻率

  • 點數

  • IF 頻寬（IF 獨立位準）

  • 功率位準（IF 獨立位準）

  • 掃描時間（IF 獨立位準）

暸解有關區段掃描的詳細資訊。

工具列

可以顯示不同的工具列，以便您輕鬆設定和修改量測。

如何顯示工具列

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Display Settings（顯示設定）> Customize Display...（自訂顯示...）

  2. 選取工具列標籤。

或

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Display...（標記顯示...）。

  2. 選取工具列標籤。

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取工具列標籤。

工具列對話方塊說明

顯示工具列

附註：對於監控誤差項，還提供了「校準集」工具列

軟鍵

軟鍵是軟鍵與 SoftTab 的組合。按下其中一個「功能」硬鍵時，軟鍵會自動開啟。此設定可讓您關閉軟鍵，以便在畫面上顯示更多量測空間。按下其他功能硬鍵時，軟鍵將再次出現。

硬鍵

這些硬鍵亦稱為「前面板硬鍵」，可執行與 VNA 前面板上的 INSTRUMENT 硬鍵、RESPONSE 硬鍵、STIMULUS 硬鍵與 UTILITY 硬鍵中的那些硬鍵等同的介面操作。瞭解詳情。

連接埠延伸工具列

「連接埠延伸」工具列可讓您在檢視量測軌跡時設定連接埠延伸。暸解有關連接埠延伸的詳細資訊。

轉換（時域）工具列

「時域」工具列可讓您執行下列操作：

  • 開啟/關閉轉換和閘限。

  • 變更「轉換」和「閘限」的開始/停止時間。

  • 更多...-啟動時域轉換對話方塊。

  • ? - 顯示說明檔。

  • X - 關閉工具列。

標記工具列

「標記」工具列可讓您設定和修改標記。它會顯示下列內容：

  • 標記編號

  • 激勵值

  • 標記功能：

    • 差量

    • 最大值/最小值

    • 開始/停止

    • 中心/跨距

提示：若要使用前面板旋鈕變更標記位置，請先按一下標記工具列的激勵欄位，然後轉動旋鈕。

暸解有關標記的詳細資訊

校準集檢視器工具列

全部關閉（不在軟鍵上）

此功能可讓您只需選取一次，即可隱藏所有工具列。軟鍵上並未提供。

其他列

主要標題

「主要標題」顯示 VNA 視窗的標題以及最小化/最大化圖示。

  • 勾選 - 顯示所有 VNA 視窗的標題列。

  • 清除 - 隱藏所有 VNA 視窗的標題列。這樣可以有更多空間來顯示量測結果。

作用中項目工具列

與軟鍵搭配使用時，此區域允許輸入設定的數值。從鍵盤輸入 G 表示千兆、M 表示兆或毫、K 表示千等等。

狀態列

兩列

啟用時，狀態列沿 VNA 畫面的底部顯示。主要狀態列顯示下列內容：

提示： 在狀態列中的下列許多項目上按一下滑鼠右鍵可快速存取設定。

  • 作用中軌跡

  • 作用中通道

  • 觸發來源

  • 通道觸發狀態（「保持」、「單次」、「連續」）

  • IF 頻寬

  • 作用中軌跡的誤差修正，選項包括基本校準、智慧型校準和校準所有通道。

    • F：連接埠全面校準，R：回應校準，-：無

  • 來源功率校準

  • 激勵

  • 服務

  • RF 功率

  • 顯示更新

  • 錯誤訊息

  • GPIB 狀態：本機 (LCL)、Remote Talker Listener（遠端資訊源接收器）(RMT) 或 System Controller（系統控制器）(CTL)。

  • 系統日期與時間 - 可設為「開啟」或「關閉」。如何顯示/隱藏 VNA 時鐘。

附註：使用外部測試裝置控制或介面控制時，會出現第二層級狀態列。

如果已預設 VNA，則狀態列狀態（「開啟」或「關閉」）將不會變更。

時鐘（系統日期與時間）

VNA 系統日期與時間可顯示在狀態列的最右端。

格式如下：年-月-日 hr:min，且無法變更。

若要隱藏時鐘，請在時鐘上按一下滑鼠右鍵，然後按一下隱藏時鐘。

暸解如何設定 VNA 時間設定。

工具

如何設定工具設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Display Settings（顯示設定）> Customize Display...（自訂顯示...）

  2. 選取工具標籤。

或

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Display...（標記顯示...）。

  2. 選取工具標籤。

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取工具標籤。

工具對話方塊說明

透過「工具」功能，可以建立要顯示在「作用中項目」或「軟鍵」工具列上的捷徑圖示。「作用中項目」上可顯示的圖示上限為 9，而「軟鍵」工具列上可顯示的圖示上限為 12。

新建視窗 - 建立新視窗。

新建通道 - 在作用中視窗上建立新通道。

新建通道和視窗 - 在新視窗上建立新軌跡和通道。

新建軌跡 - 在作用中視窗上建立新軌跡。

新建軌跡和視窗 - 在新視窗上建立新軌跡，但保留通道。

新建資料表 - 建立新資料表。

新建軌跡 + 資料表 - 在新資料表上建立新軌跡，但保留通道。

新建通道 + 資料表 - 在新資料表上建立新軌跡和通道。

首頁 - 顯示 VNA 首頁軟鍵。

我的最愛 - 設定最愛的應用程式。

說明 - 顯示說明檔。

顯示工作列 - 顯示視窗列。

偏好設定 - 顯示偏好設定對話方塊。

並排視窗

管理檔案 - 用於管理儲存在「D:\」磁碟機資料夾中的檔案。瞭解詳情。

最小化應用程式 - 還原 VNA 畫面。瞭解詳情。

關於網路分析儀 - 顯示「關於網路分析儀」對話方塊。

復原 - 復原至舊版。瞭解詳情。

重做 - 設為最新版本。瞭解詳情。

螢幕擷取畫面 - 將畫面圖表儲存至 D 磁碟機 (D:\)。

刪除 - 刪除作用中視窗。

顏色

如何設定工具設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Display Settings（顯示設定）> Customize Display...（自訂顯示...）

  2. 選取顏色標籤。

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取顏色標籤。

顏色對話方塊說明

顏色主題 - 選取顏色主題

顯示顏色... - 請參閱顯示顏色

視窗標題

可以為每個視窗建立和顯示標題。

  • 限制由顯示的視窗數目來設定。

  • 標題（視窗 1）在視窗的左上方進行標註，如下所示：

如何輸入視窗標題。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Display] > Window Setup（Window 設定）> Window Title...（視窗標題...）。

  1. 在網格中移動游標，然後按一下滑鼠右鍵。

  2. 選取標題...。

「視窗標題」對話方塊如下所示：

  1. 按一下啟用，然後輸入視窗標題。按一下鍵盤可透過滑鼠輸入。

  2. 若要移除視窗標題，請清除啟用核取方塊或從對話方塊項目中刪除文字。

軌跡標題

軌跡標題會覆寫軌跡狀態區域中的量測參數、狀態列和硬本列印。

  • 此標題的優先順序高於方程式編輯器標題。

  • 如果只有一個軌跡，則實際限制約為 70 個字元。

  • 接受空格，但不會顯示；請使用底線。

  • 標題按如下方式進行標註：

如何輸入軌跡標題。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Trace] > Trace Setup（軌跡設定）> Trace Title....（軌跡標題...）。

  1. 在網格方塊上方的軌跡狀態區域上按一下滑鼠右鍵。

  2. 按一下軌跡標題...。

「軌跡標題」對話方塊如下所示：

  1. 按一下啟用，然後輸入軌跡標題。按一下鍵盤可透過滑鼠輸入。

  2. 若要移除軌跡標題，請清除啟用核取方塊或從對話方塊項目中刪除文字。

頻率/激勵

頻率/激勵資訊顯示在畫面上每個視窗的底部。它會顯示下列內容：

  • 通道編號

  • 開始值

  • 停止值

如何顯示/隱藏頻率/激勵資訊

最小化應用程式

可將網路分析儀應用程式最小化，以顯示桌面和視窗工作列。

  1. 按一下 [System] > Main（主功能表）> Minimize Application（最小化應用程式）。

若要還原 VNA 應用程式，請按兩下桌面上的 VNA 應用程式。

上次修改時間：

2016 年 01 月 06 日

第一版


複製通道

複製通道可讓您建立量測類別相同且激勵條件與現有通道相同的重複通道。

  • 為何複製通道

  • 如何複製通道

  • 通道設定清單

附註：複製通道 CAN 可與 VNA 應用程式（如 FCA、增益壓縮或雜訊係數）搭配使用。

其他設定量測主題

為何複製通道

如果需要建立數個設定略有不同的通道，則可複製通道設定。

例如，如果您的放大器想要描繪具有數個不同輸入功率位準之頻率跨距的特性。

請執行下列步驟：

  1. 使用最佳化的通道設定建立一個量測。

  2. 將該通道複製到新通道。

  3. 變更新通道的功率位準。

如何複製通道

對於使用「複製通道」的替代方法是在新通道上建立新的預設量測。然後，根據您的新需求變更每個通道設定。此方法非常耗時，這便顯示出「複製通道」功能的優越之處。

如何複製通道

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Channel] > Channel Setup（通道設定）> Copy Channel（複製通道）。

  2. 按一下 Copy to（複製到）Active Window（作用中視窗）/Copy to New Window（複製到新視窗）/Copy Channel...（複製通道...）

複製通道對話方塊說明

將現有通道的設定複製到另一個通道。不會複製來源通道中的量測軌跡。

複製通道（亦稱為「來源」通道）： 選取要複製的通道。

到（亦稱為「目的地」通道）： 捲動以選取要將設定複製到的通道。 目前正在使用的相容通道編號將會反白顯示。您可以選取和覆寫它們。

以下是相容的目的地通道：

  • 尚不存在的通道。新通道將使用通道的預設量測加以建立。

  • 與來源的 量測類別相同的通道。目的地通道上仍會保留現有量測。

  • 不含量測之任何量測類別的通道。同樣，目的地通道將使用通道的預設量測加以建立。

備註：

  • 只能將通道設定複製到一個新通道或現有通道。重複此操作可複製到多個通道。

  • 來源通道將始終複製到作用中視窗。如果您希望目的地通道位於單獨視窗中，請先在新視窗中建立一個相容的新量測。確保該視窗為作用中視窗，然後再向其複製通道。

  • 目的地通道中的量測會變為作用中量測。

例如：

  1. 來源通道 1：標準 S21 量測

  2. 目的地新通道 2

  3. 結果：來源通道 1、S21 量測和通道 2、S11 量測。二者的激勵設定相同，且位於同一視窗中。通道 2、S11 量測為作用中量測。

如需詳細資訊，請參閱 VNA 上的軌跡、通道和視窗

通道設定清單

  • 頻率跨距

  • 功率

  • 校準集用法

  • 來源功率校準資料

  • IF 頻寬

  • 點數

  • 掃描設定

  • 平均

  • 觸發（部份設定）

上次修改時間：

2016 年 01 月 06 日

第一版


復原

復原/重做設定

如果設定不正確，可透過選取「復原」來快速復原。如果錯誤地復原某個設定，可以重做已復原的設定。

  • 「復原」和「重做」僅適用於選取的 VNA 設定。

  • 復原堆疊可記住 16 個層級的可復原設定。

如何復原或重做設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Undo] > Main（主功能表）。

  2. 按一下 Undo（復原）或 Redo（重做）。

  1. 按一下「作用中項目」或「軟鍵」工具列上的復原和重做圖示。

SCPI 編程和復原/重做：

  • 沒有用於叫用「復原」/「重做」的編程指令。

  • 編程指令不可復原。

  • 將編程指令傳送到 VNA 時，復原堆疊會被清除。

提示：

復原

重做

  • 可將「復原」/「重做」儲存至使用者硬鍵或「我的最愛」軟鍵。

  • 使用鍵盤：

    • 復原 --> Ctrl+Z

    • 重做 --> Ctrl+Y

清除復原記錄

若要清除復原堆疊，請按下 [Undo] > Main（主功能表）> Clear Undo History（清除復原記錄）。

復原及安全性

  • 若安全性層級為高和額外，則會停用「復原」/「重做」。瞭解詳情。

  • 在下列任何情況下，會刪除針對復原/重做目的而儲存的狀態檔案（例如，「預設」）：

    • VNA 安全性層級已變更

    • VNA 應用程式已啟動或關閉。

選取的可復原設定

可以復原或重做下列 VNA 設定：

附註：有幾個 VNA 設定不可復原。因此，當您嘗試復原一系列操作時，不太可能準確地重新建立原始狀態。

  • 預設

  • 檔案重新叫用

  • 頻率設定：

    • 對於標準類別：開始、停止、中心、跨距、CW

    • 對於 SMC：「混合器設定」對話方塊的「套用」

  • 關閉標記和關閉標記全部

  • 點數

  • 功率位準 - 大多數應用程式和 S 參數

  • 新增或變更量測類別

  • 關閉通道

  • 關閉視窗

  • 新建通道、新建視窗和新建軌跡

  • 刪除軌跡

  • 視窗並排

  • 移動軌跡、拖曳軌跡

  • 全部自動縮放、自動縮放

  • 刻度、參考位準、參考位置

  • 「刻度耦合」對話方塊

  • 電延遲

  • 相位偏移

  • 「量測設定」對話方塊

  • 格式

  • 掃描類型

  • 資料 -> 記憶體

  • 單一標記搜尋（最大值、最小值、目標、峰值…）

  • 多個標記搜尋（頻寬、功率飽和、一般操作 Pt）

  • 變更標記的激勵值：軟鍵、對話方塊或拖曳

  • 變更區段表格中的儲存格

  • 「機械設定」對話方塊

上次修改時間：

2016 年 01 月 06 日

第一版


動態範圍

動態範圍是分析儀接收器的最大輸入功率和最小可量測功率（雜訊底層）之間的差。若要使量測有效，輸入訊號必須在這些限制範圍內。

如果您要量測訊號幅度中較大的變化量，如濾波器帶通和抑制，增大動態範圍很重要。下圖所示的是量測範例的動態範圍。

為了協助降低量測的不確定性，分析儀動態範圍應大於 DUT 表現出來的反應。例如，當 DUT 反應比雜訊底層至少高 10 dB 時，量測準確度增加。以下方法有助於增大動態範圍。

  • 增加裝置輸入功率

  • 減少接收器雜訊底層

有關最佳化量測的其他主題

增加裝置輸入功率

增加 DUT 輸入功率，使分析儀能夠更準確地偵測和量測 DUT 輸出功率。但是要謹慎，功率太大會損壞分析儀接收器接或導致壓縮失真。

注意！測試連接埠 RF 功率輸入損壞級別：+27 dBm.

請參閱如何增加裝置的輸入功率

提示：使用外部增壓放大器增加 DUT 的輸入功率，可進一步增大動態範圍。請參閱高功率放大器量測。

減少接收器雜訊底層

您可以使用下列技術減少雜訊底層，並增大分析儀的動態範圍。

  • 量測接近雜訊底層的訊號時減少 VNA 接收器之間的串擾。請參閱接收器串擾。

  • 使用掃描平均 - 暸解有關掃描平均的詳細資訊

  • 減少 IF 頻寬 - 暸解有關 IF 頻寬的詳細資訊。

  • 在區段掃描模式中，每段可以有自己的 IF 頻寬。例如，在量測濾波器時：

    • 在通帶中，只要高位準軌雜訊保持夠小，就可以將 IF 頻寬設定的寬一些以取得更快的掃描速率。

    • 在抑制帶中，當雜訊底層是使量測誤差明顯增加的原因時，可將 IF 頻寬設定的夠低，以達到減少平均雜訊位準的目的。

上次修改時間：

2016 年 01 月 06 日 | 第一版


點數

掃描設定

資料點是表示單個激勵值處的量測值的資料樣本。您可以指定 VNA 在掃描中量測的資料點數目。(（「掃描」是對一系列激勵值進行一系列連續的資料點量測。）

VNA 掃描時間會隨著點數的變化而成比例地發生變化。如需點數和其他設定對掃描時間之影響的詳細資訊，請參閱技術規格。

如何變更資料點數

選取一個數字或按一下「自訂」以叫用對話方塊

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Sweep] > Main（主功能表）> Number of Points（點數）

點數對話方塊說明

指定分析儀在量測掃描期間收集的資料點數目。您可以指定 1 至 100,001 之間的任意數字。預設值隨 VNA 類型而異。

附註：某些量測類別的最大點數限制可能不同。

時域需要兩個資料點。

提示：

  • 若要獲得最大軌跡解析度，可使用最大資料點數。

  • 若要獲得更快的處理能力，可使用最小資料點數，因為這可以提供可接受的解析度。

  • 若要獲得最佳化點數，可在增加點數時尋找在量測中沒有顯著差異的值。

  • 若要確保量測校準精準，請使用將用於量測的相同點數來執行校準。

點數是指掃描一次所收集的資料項目的數目。您可以分別為每個通道設定此數目。

  • 若要取得對激勵值的較高軌跡解析度，請選擇較大的點數值。

  • 若要取得較高的處理能力，請在允許的軌跡解析度範圍內保持較小的點數值。

  • 若要在校準後取得較高的量測準確度，請使用與實際量測相同的點數來進行校準。

上次修改時間：

2016 年 01 月 06 日

第一版


相位準確度

相位量測準確度

使用下列 VNA 功能可以提高相位量測的準確度。

  • 電延遲

  • 相位偏移

  • 頻率點之間的間距（混疊）

另請參閱

連接埠延伸

比較 VNA 延遲功能

相位控制

相位同調量測

瞭解有關相位量測的詳細資訊

電延遲

電延遲是一種數學函數，可模擬無損傳輸線的可變長度。

使用電延遲功能可補償通過裝置的線性相位移動。使用此功能可以僅確定裝置的線性相位偏差。

您可以單獨為每條量測軌跡設定電延遲。

如何設定電延遲

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Scale] > Electrical Delay（電延遲）

電延遲對話方塊說明

電延遲 - 指定增加或移除的延遲值，以時間或距離表示。 這可以補償通過裝置的線性相位移動。您可以單獨為每條量測軌跡設定電延遲。

速度係數 - 指定套用於量測校準後插入的裝置媒體的速度係數。聚乙烯絕緣纜線的值是 0.66，PTFE 絕緣體是 0.7。對應光在真空中的速度是 1.0。

您也可以從連接埠延伸對話方塊和時域距離標記設定來設定速度係數。

軟鍵顯示 - 允許使用軟鍵和作用中項目工具列輸入以時間或距離表示的延遲。

距離單位 - 選取公尺、英吋或英尺。 變更此值時，步長不會自動變更。瞭解有關步長的詳細資訊。

媒體

同軸 - 選取增加的長度是否是同軸長度。另外還要指定同軸的速度係數。

波導 - 選取增加的長度是否是波導長度。另外還要指定波導的低截止頻率。

截止頻率 - 波導的低截止頻率。

瞭解電延遲（向上捲動）

相位偏移

相位偏移以數學方式按指定的度數（最高為 360°）調整相位量測。使用此功能的方式如下：

  • 改善相位量測的顯示。這與變更幅度量測中的參考位準的方式相同。將相位回應變更為中心，或在螢幕上對齊回應。

  • 模擬量測中的投影相位移動。例如，如果您知道您需要增加一條纜線，且纜線的長度會對量測增加一定的相位移動，那麼可以使用相位偏移增加該長度，並模擬整個裝置量測。

如何設定相位偏移

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Scale] > Constants（常數）> Phase Offset（相位偏移）

相位偏移對話方塊說明

相位偏 輸入值，或使用上下箭頭選取任何值。

瞭解相位偏移（向上捲動）

頻率點之間的間距（混疊）

分析儀對離散頻率點處的資料進行採樣，然後連接這些點以在螢幕上形成軌跡。

如果通過裝置的相位移動在相鄰頻率點之間 >180°，顯示看上去就像相位斜率反轉了一樣。這是因為資料採樣不足，而發生了混疊。

如果要量測群組延遲並反轉了相位的斜率，則群組延遲將變更跡象。例如，下圖顯示 SAW 帶通濾波器的量測。

  • 左側的量測有 51 個點，並指示群組延遲為負，這實際是不可能的。也就是說，回應在 0 秒參考線以下。

  • 右側的量測顯示增加到 201 個點，並指示群組延遲為正。也就是說，回應在 0 秒參考線以上。

提示： 若要確定量測中是否會發生混疊，可增加點數或減少頻率跨距。

上次修改時間：

2014 年 07 月 25 日

第一版


長纜線裝置

長線裝置量測

在指定的時間瞬間，從受測裝置出來的訊號的頻率可能與輸入裝置的訊號頻率不完全相同。這有時會導致量測結果不準確。您可以選擇兩種技術，來改變這種情況並提高量測準確度。

  • 裝置延遲為何會導致結果不準確

  • 提高量測準確度的解決方案

    • 降低掃描速度

有關最佳化量測的其他主題

裝置延遲為何會導致結果不準確

下圖是此情況的範例：

  • 在網路分析儀中，來源和接收器是鎖定相位在一起的，並在一個跨距的頻率範圍內同時進行掃描。

  • 通過受測裝置 (DUT) 的訊號流以不同的顏色表示不同的頻率。

  • 您可以看到激勵頻率通過 DUT，在訊號到達接收器之前分析儀調諧為新頻率。這便導致量測結果不準確。

.

如果分析儀量測長纜線，纜線末端的訊號頻率將落後於網路分析儀來源頻率。如果與網路分析儀的 IF 偵測頻寬（通常是幾個 kHz）相比頻率偏移很明顯，那麼量測的結果將由於 IF 濾波器的頻率衰減而變為存在誤差。

附註：由於沒有固定電長的裝置，這就成為一個問題。這是因為有多種變數導致量測速度不同。如果高量測準確度很重要，則可降低掃描速度，直到量測結果不再變化為止。

提高量測準確度的解決方案

選擇下列方法來補償長纜線裝置的時間延遲。

降低掃描速度

下列方法可降低掃描速度。

  • 增加掃描時間

  • 增加點數

  • 使用步進掃描

  • 設定駐留時間

上次修改時間：

2014 年 08 月 12 日

第一版


反射準確度

低損耗 2 埠裝置的反射準確度

若要對 1 埠校準進行準確的反射量測，應端接未量測的連接埠。

  • 為何要端接未量測的連接埠

  • 如何端接未量測的連接埠

  • 產生的量測不確定性

有關最佳化量測的其他主題

為何要端接未量測的連接埠

2 埠校準可修正所有 12 個誤差項。1 埠校準可修正方向性、來源匹配和頻率回應，但不修正負載匹配。因此，要取得最高準確度，必須使負載匹配誤差盡可能小。這尤其適用於低損耗雙向裝置，如濾波器通帶和纜線。如果您要量測具有高反向隔離的裝置（如放大器），則不必擔心負載匹配。

如何端接未量測的連接埠

使用下列方法之一：

  • 將高品質終端負載（例如，從校準套件）連接到裝置的未量測連接埠。此技術所產生的量測準確度接近全 SOLT 2 埠校準的準確度。

  • 將裝置的未量測連接埠直接連接到分析儀，在裝置輸出和分析儀之間插入 10 dB 精度衰減器。這可以將分析儀的有效負載匹配提高衰減器值的大約兩倍，或 20 dB。

產生的量測不確定性

下圖說明在測試裝置的輸出上端接或不端接精度 10 dB 衰減器時所產生的量測不確定性。

圖例

 | 濾波器反射
------------- | 連接衰減器時的不確定性
................ | 未連接衰減器時的不確定性

下面的計算說明高品質 10 dB 衰減器如何提高分析儀的負載匹配。

附註：對應的線性值顯示在括號中。

網路分析儀： |
負載匹配 (NALM) | = 18 dB (.126)
方向性 (NAD) | = 40 db (.010)
濾波器： |
插入損耗 (FIL) | = 1dB (.891)
回波損耗 (FRL) | = 16 dB (.158)
衰減器： |
插入損耗 (AIL) | = 10 dB (.316)
SWR (ASWR) | = 1.05 (.024) 32.26 dB 回波損耗

計算：

 | 沒有衰減器 | 有衰減器
r NA | = (F IL)*(NA LM)*(F IL) = (.891)*(.126)*(.891) =.100 | = (F IL)*(AIL)*(NA LM)*(AIL)*(F IL) = (.891)*(.316)*(.126)*(.316)*(.891) = .010
r Attenuator | NA | = (FIL)*(ASWR)*(FIL) = (.891)*(.024)*(.891) = .019
最差情況誤差 (EWC) | = r NA =.1 | = r NA + rAttn. =.01+.019 =.029
不確定性增加 | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.100)+(.010) = 11.4 dB | = -20log(FRL)+(EWC)+(NAD) = -20log(.158)+(.029)+(.010) = 14.1 dB
不確定性減去 | = -20log(FRL)-(EWC)-(NAD) =-20log(.158)-(.100)-(.010) = 26.4 dB | = -20log(FRL)-(EWC)-(NAD) = -20log(.158)-(.029)-(.010) = 18.5 dB

上次修改時間：

2014 年 12 月 15 日

第一版


量測穩定性

有許多情況會導致量測不穩定。若要確保您進行的是可重複的量測，可以使用多種方法建立穩定的量測環境。

  • 頻率漂移

  • 溫度漂移

  • 不精準的量測校準

  • 裝置連接

有關最佳化量測的其他主題

頻率漂移

分析儀頻率準確度以內部 10 MHz 頻率振盪器為基礎。如需穩定性和老化規格，請參閱技術規格。

如果量測應用需要更高的頻率準確度和穩定性，您可以覆寫內部頻率標準，並透過後面板上的 10 MHz 參考輸入接頭，提供您自己的高穩定性外部頻率來源。

溫度漂移

熱膨脹和收縮會改變下列元件的電特性：

  • 分析儀內的裝置

  • 校準套件標準

  • 測試裝置

  • 纜線

  • 配接器

若要降低溫度漂移對量測的影響，請執行以下操作。

  • 在執行量測校準或進行裝置量測之前，將分析儀開啟 1/2 小時。

  • 在執行量測校準前一小時，開啟校準套件箱，將標準從保護泡綿中取出。

  • 使用溫度控制的環境。所有規格和特性在 25 °C ±5 °C 範圍內適用（除非另有說明）。

  • 確保校準套件裝置的溫度穩定性。

  • 在校準過程中避免對校準套件裝置進行不必要的處理。

  • 確保環境溫度為量測校準溫度的 ±1°C。

不精準的量測校準

如果量測校準不精準，則不能量測受測裝置的真實反應。為確保校準準確，您應該考量使用以下做法：

  • 在連接受測裝置的位置執行量測校準，也就是參考平面。

  • 如果在執行量測校準之後將任何其他配件（纜線、轉換器、衰減器）插入測試設置中，應使用連接埠延伸功能補償增加的電長度和延遲。

  • 使用與校準過程中所用定義相符的校準標準。

  • 檢查、清潔和度量接頭。請參閱接頭維護。

如需詳細資訊，請參閱精準的量測校準。

裝置連接

可重複的量測需要較好的連接。若要協助進行較好的連接，請執行以下操作：

  • 檢查並清潔量測設定中所有元件的接頭。

  • 使用正確的連接技術。

  • 避免在量測期間移動纜線。

上次修改時間：

2016 年 01 月 06 日

第一版


軌跡雜訊

雜訊降低技術

在分析儀接收器鏈結中出現的隨機電雜訊會降低量測準確度。下列 VNA 功能有助於降低軌跡雜訊和雜訊底層，進而增大動態範圍並取得更精準的量測。

附註：微波 PNA 中的軌跡雜訊在 748 MHz 以下變得更差，在 10 MHz 和 45 MHz 之間尤為明顯。 請參閱減少 IFBW。

  • 平均

  • IF 頻寬

  • 軌跡平滑化

另請參閱

群組延遲

增加動態範圍

VNA 資料處理圖。

有關最佳化量測的其他主題

平均

平均是可降低隨機雜訊對量測的影響的功能。VNA 根據多個量測的平均值計算每個資料點。 您可以藉由設定平均係數來確定量測數目。平均係數越高，雜訊降低量就越大。

掃描平均的影響

平均和 IF 頻寬都可用於達到一般雜訊降低的相同目的。若要使非常低的雜訊降至最低，平均比減少 IF 頻寬更有效。一般來說，平均在降低雜訊時所需的時間比減少 IF 頻寬稍微長一些，特別是在需要許多平均值時。另外，在校準後變更 IF 頻寬會導致準確度不確定。

如何設定平均

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Avg] > Averaging（平均）> 輸入平均數

IF 頻寬

VNA 將收到的訊號從其來源轉換為較低的中間頻率 (IF)。IF 帶通濾波器的頻寬調整範圍是從 40 kHz（用於大多數 VNA 模型）向下至最低 1 Hz。

減少 IF 接收器頻寬會降低隨機雜訊對量測的影響。IF 頻寬每減少十倍會使雜訊底層降低 10 dB。但是，較窄的 IF 頻寬會使掃描時間變長。

  • 通道寬 - 可單獨為每個通道設定 IF 頻寬

  • 區段掃描 - 可單獨為區段掃描的每段設定 IF 頻寬。

  • 校準 - 校準後變更 IF 頻寬會導致「C-delta」修正等級，這意味著校準準確度不確定。

減少 IF 頻寬的影響

如何設定 IF 頻寬

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Avg] > IF Bandwidth（IF 頻寬）> 輸入 IF 頻寬值

  1. 以滑鼠右鍵按一下狀態列上的 BW 圖示。

  2. 選取 IF 頻寬...。

IF 頻寬對話方塊說明

IF 頻寬 指定 IF（接收器）頻寬。藉由捲動 IF 頻寬文字方塊中的可用值，選取 IF 頻寬的值。可單獨為每個通道設定 IF BW。

IF 頻寬會自動設定為等於或小於每個量測頻率的 1/5。

勾選 LF Auto BW 時，使用的實際 IF 頻寬為：

  • 53+ MHz 至 175 MHz：30,000Hz * .025 = 750 Hz（下一個更高的可選取值：1 kHz。）

  • 175+ MHz 至 250 MHz：30,000Hz * .15 = 4.5 kHz（下一個更高的可選取值：5 kHz。）

  • 250+ MHz 至 396 MHz：30,000Hz * .5 = 15 kHz

  • 396+ MHz 至停止掃描 = 30 kHz

軌跡平滑化

軌跡平滑化功能可計算一定數量的相鄰資料點的平均值，以平滑顯示的軌跡。計算其平均值的相鄰資料點的數目也稱為平滑孔徑。您可以將孔徑指定為資料點的數目，或 X 軸跨距的百分比。

軌跡平滑化可減少頻寬量測資料的峰值到峰值雜訊值。它將平滑軌跡雜訊，不會明顯增加量測時間。

因為軌跡平滑化能遵循 VNA 資料處理圖中的格式，所以將平滑格式化的資料。如果格式是極座標或史密斯圖，則將自動關閉平滑化功能。

瞭解有關資料格式類型的詳細資訊。

請參閱 VNA 資料處理圖。

提示：

  • 從較大數量的顯示點開始逐漸減少，直到確定軌跡不會產生誤導的結果為止。

  • 不要將平滑化功能用於高共振裝置或軌跡變化範圍較大的裝置。這會產生誤導資訊。

  • 可單獨為每條軌跡設定平滑化。

平滑化對軌跡的影響

如何設定軌跡平滑化

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Avg] > Smoothing（平滑化）> Smoothing ON|OFF（平滑化開啟|關閉）

平滑化 開啟時，平滑化將套用於顯示的軌跡。

平滑百分比 指定要平滑的掃描激勵範圍的百分比。例如，如果軌跡包含 100 個資料點，並指定範圍百分比 = 11%，則計算平均值的資料點數目為 11。

平滑點數 指定要計算平均值的相鄰資料點的數目。

上次修改時間：

2016 年 01 月 06 日

第一版


串擾

串擾是分析儀訊號路徑之間的能量洩漏。在進行高損耗傳輸量測時，這是個問題。儘管 VNA 的串擾規格很突出，但您可以透過執行以下操作來減少串擾的影響：

  • 執行隔離校準

有關最佳化量測的其他主題

執行隔離校準

對於傳輸量測，回應和隔離量測校準有助於減少串擾，因為分析儀會在量測校準期間測量並減去洩漏訊號。校準可以改善隔離，因此僅受雜訊底層的限制。

附註：切勿在智慧（引導式）校準上執行隔離。瞭解詳情。

一般情況下，隔離誤差低於雜訊底層。因此，在執行隔離校準時，應使用雜訊降低技術，如掃描平均或減少 IF 頻寬。

上次修改時間：

2016 年 01 月 06 日

第一版


配件的影響

組態中的配件可能會影響裝置量測的結果。您可以在降低配件影響的兩種分析儀功能之間進行選擇。

  • 使用功率斜率來補償纜線衰減

  • 使用閘控來選擇性地移除回應

有關最佳化量測的其他主題

使用功率斜率來補償纜線衰減

如果量測組態中有長纜線或其他配件，並且隨著頻率的變化而發生功率耗損，則可以套用功率斜率功能。此功能可按照您定義的速率 (dB/GHz) 增大分析儀電源功率。

  1. 按下 [Power] > Leveling & Offsets（位準調整和偏移）。

  2. 如果斜率功能尚未開啟，請按一下 Slope（斜率）旁邊的按鈕。

  3. 在 Slope（斜率）方塊中，輸入要使電源功率隨著頻率掃描的變化而增加的速率。

使用閘控來選擇性地移除回應

閘控是時域（選項 010）中的一項功能，允許分析儀以數學方式移除回應。您可以設定反射或傳輸回應的閘控，但會得到不同的結果。

  • 設定反射回應的閘控可將所需回應（如濾波器的回波損耗）從不需要的回應（如轉換器反射或接頭不符）中隔離出來。

  • 設定傳輸回應的閘控可將電長度較長的多路徑裝置中的特定路徑隔離出來。

如需詳細資訊，請參閱時域閘控。

上次修改時間：

2016 年 01 月 06 日

第一版


偏移 LO

設定偏移 LO（減少不必要的影像回應）

  • 概觀

  • 開啟偏移 LO 模式

有關最佳化量測的其他主題

概觀

使用偏移 LO 模式設定本端訊號 (LO)。一般情況下，VNA 將本端訊號 (LO) 設定為 RF+IF。但是，這會導致影像在特定的頻率產生回應。若要減少不必要的影像回應，可使用 LO 模式選取本端訊號 (LO)。

對於低於帶通濾波器中心頻率的頻率，應開啟偏移 LO 模式；對於高於帶通濾波器中心頻率的頻率，應關閉偏移 LO 模式。

  • 偏移 LO 模式開啟：LO = RF-IF

  • 偏移 LO 模式關閉：LO = RF+IF

附註：此功能不適用於低於 150 MHz 的頻率。

開啟偏移 LO 模式

  1. 按下 [Sweep] > Source Control（來源控制）> Shift LO（偏移 LO）。

  2. 輸入最高頻率。

  3. 按一下軟鍵的開關來開啟偏移 LO 功能。

附註：當偏移 LO 模式開啟時，不會考慮系統校準（調整）。校準應在量測之前執行。如果在校準之後開啟此功能，狀態列上的「C」會變更為「CΔ」。

附註：如果「區段掃描」中的「列出偏移 LO」關閉，則將使用全域設定（([Sweep] > Source Control（來源控制）> Shift LO（偏移 LO））的設定。

最大頻率

設定量測掃描的最大頻率。依據預設，最大頻率設定為裝置的最大頻率。

附註：此設定只有在偏移 LO 模式開啟時才有效。

上次修改時間：

2016 年 01 月 06 日

第一版


快速掃描速度

達到最快速的掃描

藉由調整下列設定，可以達到最快的量測掃描速度：

  • 掃描設定

  • 雜訊降低設定

  • 量測校準選擇

  • 不需要的功能

有關最佳化量測的其他主題

掃描設定

請按建議的方法考量變更下列每個設定。

  • 頻率跨距 - 僅量測裝置所需的頻率。

  • 區段掃描 - 使用區段僅限制所需位置的測試資料。

  • 關閉步進掃描 - 使用線性掃描模式在可能時減少掃描時間。

  • 自動掃描時間 - 使用此預設值盡可能快速地掃描目前設定。

  • 點數 - 使用量測所需的最少點數。

附註：在下列情況中，掃描時間可能較長。
* 顯示掃描時間項目。
* 顯示「掃描時序」或「觸發」SoftTab。

如需點數和其他設定對掃描週期時間的影響的詳細資訊，請參閱技術規格。

雜訊降低設定

使用這些設定的組合，可以減少掃描時間，同時仍然可以獲得可接受的量測結果。

  • IF 頻寬。使用最寬的 IF 頻寬，這將產生可接受的軌跡雜訊和動態範圍。

  • 平均值。減少平均係數，或關閉平均值。

量測校準選擇

針對所需的準確度層級，選擇適當的校準類型。

套用全 2 埠誤差修正時，VNA 將同時進行正向和反向掃描以收集全部 12 個誤差修正項。即使顯示單個 S11 量測時，也會發生這種情況。在執行第二次掃描時，將更新所有顯示的量測。這兩次掃描都是使用指定的掃描時間來執行的。

校準 2 個以上的連接埠時，使用下列公式來確定所需的掃描次數：

  • N * (N-1)，其中 N = 連接埠數目。

套用全 3 埠校準時，需要進行 6 次掃描；分別對每對連接埠進行正向和反向掃描。在進行全 4 埠修正時，需要進行 12 次掃描，以此類推。

若要限制量測時間，僅應執行量測所需的校準層級。例如，如果僅執行 S11 量測，則在該連接埠上執行 1 埠校準。

對於未修正的量測和使用反應校準或 1 埠校準執行的量測，掃描時間都差不多。如需詳細資訊，請參閱選取校準。

不需要的功能

分析儀必須更新所有作用中功能的資訊。若要進一步提高掃描速度，可關閉量測應用不需要的所有分析儀功能。

  • 刪除不需要的軌跡

  • 關閉不需要的標記

  • 關閉平滑化

  • 關閉限制測試

  • 關閉數學函數

分析儀掃描速度取決於不同的量測設定。可使用設定進行試驗，以取得所需的最快掃描速度和最佳量測結果。

上次修改時間：

2014 年 08 月 13 日

第一版


針對處理能力的多個量測

在多個量測之間切換

如果您需要進行多個量測來表現裝置的特性，則可以使用多種方法來提高處理能力。使用這些方法進行試驗，以找到最符合量測應用需求的方法。

  • 設定量測以提高處理能力

    • 將量測分組

    • 使用區段掃描

    • 選擇性觸發量測

  • 在量測之間自動變更

  • 快速重新叫用量測

有關最佳化量測的其他主題

設定量測以提高處理能力

若要獲得需要多個量測的裝置的最佳處理能力，瞭解 VNA 的運作方式很有用。利用這些知識可設定最適合應用的量測方案。

瞭解有關 VNA 中的軌跡、通道和視窗的詳細資訊

將量測分組

如果對量測進行分組，使完整的裝置量測組保持在一種儀器狀態中並進行儲存，那麼以後就可以透過一個重新叫用功能來重新叫用多個量測。

如需詳細資訊，請參閱預先設定的量測設定。

使用區段掃描

如果您需要變更下列設定來表現受測裝置的特性，區段掃描將很有用。

  • 頻率範圍

  • 功率位準

  • IF 頻寬

  • 點數

  • 延遲

  • 掃描模式

  • LO 偏移

使用區段掃描可以定義具有獨立屬性的一組頻率範圍。如此可讓您使用一次量測掃描來量測具有可變特性的裝置。

如需詳細資訊，請參閱區段掃描。

選擇性觸發量測

您可以使用量測觸發按下面所述設定量測：

  • 僅連續更新包含快速變化資料的量測。

  • 偶爾更新資料不常變化的量測。

例如，如果您有四個設定如下的通道：

  • 兩個通道量測用於微調濾波器的資料

  • 兩個通道量測濾波器的帶外回應的資料

您只需要經常監控用於微調濾波器的量測資料。如果您連續更新所有通道，則會降低分析儀的回應速度，以致無法有效微調濾波器。

附註：您必須手動或透過遠端介面命令來觸發不常用的量測。

選擇性觸發量測：

此程序顯示如何使用以下行為設定兩個不同的量測：

  • 通道 1 量測將連續更新資料。

  • 通道 2 量測將偶爾更新資料。

  1. 按下 [Setup] > Quick Start（快速入門）。

  2. 在快速入門對話方塊中，按一下在新通道中建立。

  3. 頻率掃描對話方塊將顯示。輸入偏好的掃描設定。

設定量測觸發以進行連續更新

  1. 按下 [Trigger] > Trigger Source（觸發來源）並選取 Internal（內部）。

  2. 按下 [Trigger] > Trigger...（觸發...）。

  3. 在觸發對話方塊的通道觸發狀態下方，選取通道 1，然後按一下連續。

設定量測觸發以進行偶爾更新

  1. 在觸發對話方塊的通道觸發狀態下方，選取通道 2，然後依序按一下單次和確定。

  2. 按下 [Trigger] > Restart（重新啟動）。

更新量測

  1. 按一下下方的視窗，使通道 2 成為作用中的通道。

  2. 在作用中項目工具列上，按一下您要設定的觸發類型。

    • 如果要將分析儀設定為每觸發一次就掃描一次，請按一下單次。

    • 如果要設定為每觸發一次就掃描多次，請按一下群組。

附註：軌跡必須處於作用中狀態，才能對該量測啟動觸發。

在量測之間自動變更

如果表現裝置特性所需的各個量測之間的差別很小，則可以使用程式設計快速變更量測設定。

快速重新叫用量測

重新叫用量測的最有效方法是將其作為一組量測（儀器狀態）進行重新叫用。

  • 重新叫用包含多個量測的儀器狀態所需的時間，只比重新叫用只包含一個量測的儀器狀態所需的時間長一點。

  • 每個重新叫用功能都有與之關聯的時間。將多個量測設定為一組以便將其作為一個整體進行重新叫用，可省去該時間。

如需詳細資訊，請參閱儲存並重新叫用檔案。

上次修改時間：

2014 年 08 月 21 日

第一版


資料傳輸速度

使用 SCPI 從遠端測試裝置時，可以使用下列方法快速地在 VNA 與遠端電腦之間傳輸資料，從而協助您實現最佳量測處理能力。

  • 使用單次掃描（觸發）模式，以確保在開始資料傳輸之前完成量測。

  • 傳輸所需的最少資料量。例如，具有數個點的軌跡，使用區段掃描而非具有眾多線性間隔點的完整軌跡。此外，使用標記而非軌跡轉移。

  • 針對自動化應用程式使用 SCPI 程式時，選擇 REAL 資料格式來提供最快傳輸速度。

  • 針對透過 SCPI 程式進行自動化的應用程式，使用 SCPI 而非 LAN。

  • 使用共用記憶體資料傳輸。瞭解詳細資訊。

有關最佳化量測的其他主題


加快 PXIe 量測速度

加快 PXIe VNA 量測速度

可以一起使用或單獨使用下列功能，以加快 VNA 量測速度：

選件 103 - 快速掃描模式。

  • 暸解有關該功能的詳細資訊。
  • 請參閱 SCPI 指令。

使用 PXI 特定的「觸發」指令

  • 用於設定索引行邏輯的 SCPI 指令。

  • 用於高效觸發多個通道的 SCPI 指令。

共用記憶體資料傳輸

  • 請參閱 SCPI 指令

另請參閱

  • 一般 VNA 量測速度方法


Using Macros

Macros are executable programs that you write, load into the analyzer, and then run from the analyzer. You can have up to 25 macros set up to run on the analyzer.

  • How to Setup Macros

  • How to Run Macros

  • Macro Example

How to Setup Macros

Using Hardkey/SoftTab/Softkey

  1. Press Macro > Key Setup > Macro Setup...

In the Macro Setup dialog box:

  1. Create an executable program and save it on the VNA hard drive. See SCPI example programs in VBscript.

  2. Use a mouse or the front-panel 'down-arrow' to select a blank line below the last entry. (There may be NO entry.)

  3. Click Edit to start the Edit Macro Setup dialog.

  4. In the Macro Title box, type a descriptive title for your macro.

  5. Click Browse...

  6. Change Files of Type.

  7. Find and select your executable file. Change Files of Type if necessary.

  8. Click OK on the Edit Macro Setup dialog.

  9. Click OK on the Macro Setup dialog.

  10. Press macro to run. It may be necessary to first Preset the VNA to see your macro in the menu.

Macro Setup dialog box help

Macro setup allows you to create up to 25 macros that can be launched from the VNA application.

An external keyboard is required to enter the Macro Title and the Run string parameters.

To add a Macro, use a mouse or the front-panel 'down arrow' (NOT the 'Down' key) to select a blank line. Then click Edit.

Macro Title Shows the titles that appear in the softkeys and menu when you press the Macro key. These titles are associated with the executable files and should be descriptive so you can easily identify them.

Macro Executable Lists the complete path to the executable file. To follow the example of launching the Keysight VNA Series Home Page, the path to the executable could be "C:/Program Files/Internet Explorer/iexplore.exe.

Macro Runstring Parameters Lists the parameters that get passed to the program that is referenced in the executable file. Again following the example of launching the VNA Series Home Page, you could assign the runstring parameters "http://www.Keysight.com/find/pna".

Edit Invokes the Macro Edit dialog box.

Delete Deletes the selected macro.

Up Allows you to reorder the macros, moving the selected macro up one line. This order determines how they appear in the VNA Menu and in the softkeys and when you press the Macro front-panel key.

Down Moves the selection down one line in the list of macros.

Macro Edit dialog box help

Macro Title Add a title that appears in the softkeys and menu.

Macro Executable Set the complete path to the macro executable file. Click Browse to navigate to the macro executable file and establish the complete path to the file.

Macro run string parameters Optionally add parameters that are passed to the program referenced in the executable file.

See Macro Setup dialog box

How to Run Macros

Using Hardkey/SoftTab/Softkey

  1. Press Macro > Macro<#>

  2. then select the macro to run

Macro Example

The following is an example Visual Basic Scripting (vbs) program that you can copy, install, and run on your VNA.

Note: Print these instructions if viewing in the analyzer. This topic will be covered by the Macro Setup dialog box.

  1. Copy the following code into a Notepad file.

  2. Save the file on the analyzer hard drive in the C:/Documents folder. Name the file FilterTest.vbs

  3. Close Notepad

  4. Setup the macro in the VNA

  5. Run the macro

Notepad is a text editor that is installed on all PCs that use a Microsoft Operating system. To launch Notepad on the analyzer:

  1. Click View, then click Title Bars

  2. Click the Start button on the windows taskbar

  3. Point to Programs, Accessories.

  4. Click Notepad

'Start copying here
'This program creates a S21 measurement
'It is written in VBscript using SCPI commands

Dim app
Dim scpi
'Create / Get the VNA application
Set app = CreateObject ("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

'Preset the Analyzer.FPREset presets the setting and deletes all traces and windows
scpi.Execute ("SYST:FPReset")
'Create and turn on window 1
scpi.Execute ("DISPlay:WINDow1:STATE ON")
'Define a measurement name, parameter
scpi.Execute ("CALCulate:PARameter:DEFine:EXT 'MyMeas', 's21'")
'Associate ("FEED") the measurement name ('MyMeas') to WINDow (1), and give the new TRACE a number (1).
scpi.Execute ("DISPlay:WINDow1:TRACe1:FEED 'MyMeas'")

'End copying here

Last Modified:

2-Sep-2014

First Release


選取校準類型

以下校準類型在 VNA 中可用。

校準類型 | 準確度 | 允許直通方法
TRL 系列 | 非常高 | 所有，未知直通除外
SOLT | 高 | 所有
增強回應 | 高 | 定義的直通或沖洗直通
QSOLT（快速 SOLT） | 中 | 定義的直通或沖洗直通
1 連接埠反射 | 高 | 不適用
開路/短路回應 | 低 | 不適用
直通回應 | 低 | 已知直通或沖洗直通

瞭解如何選取預設校準類型。

其他校準類型（單獨的主題）

  • 來源功率校準和接收器功率校準

請參閱其他校準主題

TRL 系列

應用：在沒有現成可用的校準標準時，用於精確校準任何一對連接埠。

附註：可能需要差量匹配校準。

• 瞭解有關 TRL 系列校準的詳細資訊

• 有關修改標準的詳細資訊，請參閱校準標準。

總體準確度：非常高

所需標準：直通、反射、線路或類似組合

已修正的系統誤差：

• 方向性

• 來源匹配

• 隔離（請參閱例外狀況）

• 負載匹配

• 頻率回應傳輸追蹤

• 頻率回應反射追蹤

SOLT

應用：用於精確校準任意數量的連接埠。

總體準確度：高

所需標準：（短路、開路、負載、直通）或 ECal 模組

已修正的系統誤差（在所有連接埠上）：

• 方向性

• 來源匹配

• 隔離（請參閱例外狀況）

• 負載匹配

• 頻率回應傳輸追蹤

• 頻率回應反射追蹤

增強回應

應用：僅需一個方向（正向或反向）上的量測時，用於校準兩個連接埠。由於無需二次掃描，因此量測速度更快。

• 反射標準（開路、短路或負載）連線到要校準的來源連接埠。

• 定義的直通或沖洗直通標準在連接埠對之間連線。

• 使用機械校準套件時速度比 SOLT 要快得多。也可以使用 ECal。

若要選取增強回應，請執行以下作業：

對於標準的 S 參數校準，請選取 [Cal] > Main（主值）> Basic Cal...（基本校準...） .

然後，在基本校準對話方塊中：

  1. 在「校準類型」下，選取 Enh Response 1-> 2 Enh（增強的回應 1-> 2）或 Response 2-> 1（回應 2-> 1）。

總體準確度：高

所需標準：（短路、開路、負載、定義的直通或沖洗直通）

已修正的系統誤差：

• 方向性（來源連接埠）

• 來源匹配（來源連接埠）

• 隔離（請參閱例外狀況）

• 負載匹配（接收器連接埠）- 僅用於產生傳輸追蹤項。

• 頻率回應傳輸追蹤（接收器連接埠）。

• 頻率回應反射追蹤（來源連接埠）。

QSOLT（快速 SOLT）

應用：用於快速校準任意數量的連接埠。為了與外部多連接埠測試裝置結合使用而專門開發。

附註：校準沒有專用參考接收器的測試連接埠時，需要採用差量匹配校準。

• 反射標準（開路、短路或負載）僅連接到要校準的連接埠之一。依預設，將選取連接埠號較低的連接埠進行校準。這可透過修改校準/校準類型設定進行變更。

• 定義的直通或沖洗直通標準從反射標準連接埠連線到要校準的其餘連接埠。

• 使用機械校準套件時速度比 SOLT 要快得多。

• 基於 TRL 數學運算。

總體準確度：低於 SOLT

所需標準：（短路、開路、負載、定義的直通或沖洗直通）

已修正的系統誤差：

• 方向性

• 來源匹配

• 隔離（請參閱例外狀況）

• 負載匹配

• 頻率回應傳輸追蹤

• 頻率回應反射追蹤

1 連接埠（反射）

應用：用於精確校準任何一個僅適用於反射量測的測試連接埠。

總體準確度：高

所需標準：（短路、開路、負載）或 ECal 模組

已修正的系統誤差：

• 方向性

• 來源匹配

• 頻率回應反射追蹤

開路/短路回應

應用：用於快速校準任何一個僅適用於反射量測的測試連接埠。

總體準確度：低

所需標準：開路或短路

已修正的系統誤差：

頻率回應反射追蹤

直通/傳輸回應（隔離選用）

應用：用於快速校準任何一對僅適用於傳輸量測的測試連接埠。

通常不建議使用隔離。瞭解有關隔離的詳細資訊

總體準確度：低

所需標準：直通

隔離：每個負載對應一個 VNA 測試連接埠。

已修正的系統誤差：

• 頻率回應傳輸追蹤

• 隔離

上次修改時間：

2014 年 08 月 18 日

第一版


校準精靈

使用校準精靈可選擇校準方法，然後執行校準。

  • 如何啟動校準精靈

  • 智慧型校準（引導式校準）

  • 基本校準

  • 儲存校準

其他校準主題

如何啟動校準精靈

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Other Cals（其他校準） > Smart Cal...（智慧型校準...）

校準視窗/通道

在引導式校準期間，將建立「校準視窗」，可供您在量測標準之前檢視校準標準的連接。此校準視窗使用所建立的新校準通道，並複製被校準通道中的設定。對於顯示的校準通道， 修正始終處於關閉狀態。校準完成時，將刪除校準通道和視窗。

檢視所選擇的任何 VNA 視窗組態時，可執行校準標準的量測。 校準視窗將附加至「自訂校準視窗」設定，在按下「量測」（校準標準）按鈕之前，所有視窗都是可見的，並顯示在校準精靈下方。 使用遠端指令指定校準程序中要檢視的視窗和要掃描的通道。

校準視窗設定在 FCA 通道中不適用。

智慧型校準（引導式校準）

引導式校準會自動確定校準類型，並建議使用與您的受測裝置接頭匹配的校準套件。引導式校準可以執行下列校準類型：

  • 除開路、短路和直通回應校準外的所有校準。

  • 一或多個連接埠上的 ECal。

  • TRL - 瞭解如何執行 TRL 校準

附註：智慧型校準不允許以任何順序量測校準標準。不過，您必須按一下下一步和上一步而不量測標準，直到達到要量測的標準為止。

在標準通道上執行引導式校準時，VNA 會顯示下列對話方塊。

若要瞭解應用通道的校準，請參閱應用的說明主題。

選取進行引導式校準的連接埠對話方塊說明

允許選取要校準的連接埠。

校準類型選擇 選取要校準的連接埠數目。

N 連接埠校準集態 如果不是校準所有 VNA 連接埠，請指定要校準的連接埠。

校準來源和接收器功率 勾選該方塊以執行引導式功率校準。瞭解詳情。

另請參閱：使用多個功率感應器執行引導式功率校準

上一步 返回校準精靈開始對話方塊。如果未顯示「校準精靈開始」對話方塊但想要查看它，請按一下上一步，然後清除儲存偏好設定核取方塊。

對於 4 連接埠以上的校準，請參閱外部測試裝置校準 - 選取校準類型。

選取受測裝置接頭和校準套件對話方塊說明

允許為每一個要校準的受測裝置連接埠選取接頭類型和校準套件。

接頭 若要變更選擇，請按一下每一個受測裝置連接埠的接頭欄位。

如果您的受測裝置接頭未列出，您可建立自己的接頭類型和校準套件檔案。VNA 包括下列可用作範本的範例校準套件 。如需詳細資訊，請參閱校準套件。

  • 如果使用有性別的（公和母）接頭類型，請選取類型 A 做為接頭類型。

  • 如果使用無接頭裝置（例如，晶片測試棒），請選取類型 B 做為接頭類型。

校準套件 選取要用於校準每一個測試連接埠的校準套件。各個受測裝置連接埠的清單顯示具有與受測裝置相同類型之接頭的套件。

連接了相同的 ECal 模型？ ECal 模組依序號予以區別。在遠端 SCPI 程式中有相關指示。

校準套件附註

85056K

VNA 中的 85056K 定義適用於 2.92mm 標準（2.4mm 和 2.92 配接器）。若要使用 85056K 校準套件校準 2.4 mm 接頭，請在需要滑動負載時選取 85056A 做為校準套件。否則，請選取 85056D 做為校準套件。85056A 和 85056D 套件均包含與無配接器的 85056K 校準套件完全相同的標準。

TRL

  • 若要執行 TRL 校準，請將 TRL 校準套件指派至每一個連接埠對的最低連接埠號。

  • 在需要差值匹配校準的 PNA-L 模型上選取 TRL 校準套件時，如果無法使用全域差值匹配校準，則系統會將校準類型設定為 SOLT，並在對話方塊中顯示"找不到全域差值匹配校準"訊息。如果所選的校準套件不支援 SOLT，則將無法使用下一步按鈕。此時您必須選取不同的校準套件才可繼續，或選擇取消並執行全域差值匹配校準。

修改校準 勾選該方塊，然後按一下「下一步」以修改校準（標準和直通方法）。

對於 4 連接埠以上的校準，請參閱「外部測試裝置校準 - 選取受測裝置接頭」。

錯誤對話方塊說明

目前的校準套件不涵蓋量測的目前頻率範圍。請執行下列其中一項動作以修正問題：

校準套件類類別 從 SOLT 和 TRL 中選擇。不適用於 ECal 模組。按一下編輯以修改適當的類別指派。

頻率 變更作用中通道的頻率範圍。

編輯 修改類別指派以選取不同的標準。

上一步 選取涵蓋所需頻率範圍的不同校準套件。

取消 結束校準精靈

修改校準對話方塊說明

直通 #n

列出建議在校準程序期間執行的直通連接。您可變更這些直通連接以更好地適應您的測試設定。

  • 系統會自動列出建議的直通連接。

  • 可選取其他直通連接，以取得更高的準確度。瞭解詳情。

新增直通

按一下以新增直通連接。暸解詳細資訊

移除直通

透過按一下「直通 #N」欄位或「第 1 個連接埠/第 2 個連接埠」欄位來選取直通。然後按一下「移除直通」。如果校準需要所選的直通，則該選擇不可用。

第 1 個連接埠/第 2 個連接埠

按一下以選取要包括在直通連接中的兩個連接埠。連接埠號的順序不重要。

直通校準方法

列出適用於指定連接埠對的可用直通校準方法。

瞭解直通校準方法選擇。

校準類型/標準

按一下以叫用「檢視/修改校準屬性」對話方塊。

執行定位 - 僅在選擇使用 ECal 模組時才顯示。

如果勾選此方塊（預設），VNA 會自動感測與 VNA 連接埠連接的 ECal 模組連接埠的型號和方向。如果 ECal 模組的功率過低，則會顯示為如同沒有連接 ECal 模組一樣。如果使用低功率並出現此問題，請清除該核取方塊以手動提供方向。

首先在您校準的頻率範圍中間處定位。如果未偵測到訊號，則會在範圍的最低頻率處再次嘗試。

選擇差值匹配 - 需要差值匹配校準時可用。

  • 勾選該方塊，然後按一下下一步以叫用選取差值匹配的校準集對話方塊。

  • 清除 - 校準精靈使用全域差值匹配校準（如果可用）。

檢視/偵測 ECal 特性化 - 僅在選擇使用 ECal 模組時才顯示。

按一下以叫用「檢視 ECal 模組和特性化」對話方塊。顯示連接到 VNA 的 ECal 模組清單。

檢視/修改連接埠的校準屬性...對話方塊說明

選取校準類型

變更直通方法的另一種方式。

瞭解直通校準方法選擇。

進階

選取直通對的每一個接頭適用的校準方法。

  • TRL - 僅在針對連接埠對的最低連接埠號選取了 TRL 校準套件時才可用。

  • QSOLT 僅在選取「已定義直通」或「沖洗直通」時才可用。"QSOLT 2 <= 1" 表示接收連接埠 2 和來源連接埠 1（連接反射標準的連接埠）。

  • 增強回應 僅在選取「已定義直通」或「沖洗直通」時可用。"EnhResp 2 <= 1" 表示接收連接埠 2 和來源連接埠 1。

  • 傳輸回應 僅在選取「已定義直通」或「沖洗直通」、選取「機械校準」以及校準 2 個連接埠時可用。"TransResp 2 <= 1" 表示接收連接埠 2 和來源連接埠 1。

檢視修改 按一下以叫用預覽和修改校準選擇對話方塊。

附註：透過此對話方塊對校準套件所進行的變更為暫時性的，僅對該校準有效。若要對此校準套件進行永久變更，請執行進階修改校準套件。

選取差值匹配的校準集對話方塊說明

需要差值匹配校準且選取選擇差值匹配時顯示此對話方塊。瞭解詳情。

顯示滿足差值匹配校準需求的校準集。

選取使用者校準集或全域差值匹配校準。

如果沒有適用於差值匹配校準的選擇：

  1. 按一下取消，然後再次按一下取消退出校準精靈。

  2. 執行全域差值匹配校準或 SOLT 校準，並將結果儲存於使用者校準集中。

  3. 啟動校準精靈以重新開始此校準。

  4. 選取「全域差值匹配校準」或「使用者校準集」。

校準步驟對話方塊說明

附註：從 VNA 6.0 版開始，可使用外部觸發執行校準。瞭解詳情。

顯示每一個新校準步驟提示時，將為下一個標準量測設定軌跡。此外，系統將持續觸發掃描，直至按下「量測」按鈕為止。這樣便於您檢視標準連接的完整性。

提示選擇要量測之標準。

量測 按一下以量測標準。

完成 重新量測標準以及校準的所有量測完成後按一下。

下一步 按一下以繼續執行下一個校準步驟。不量測標準。

如果未量測標準，則將顯示一條警告訊息，最後的校準步驟完成後無法使用完成。

附註：智慧型（引導式）校準允許以任何順序量測校準標準。不過，您必須按一下下一步和上一步而不量測標準，直到達到要量測的標準為止。

滑動負載量測對話方塊說明

允許量測滑動負載標準。

為確保執行準確的校準，請認真按照滑動負載隨附的指示操作。

若要量測滑動負載：

  1. 將滑動負載連接至量測連接埠。

  2. 定位滑動元素，然後按一下量測。量測完成之前請勿移動滑動元素。

  3. 若要取得最佳的準確度，應至少量測五個且最多量測七個位置的滑動負載。

附註：滑動元素的位置應涵蓋滑動的整個長度，但間隔不應相同，以降低資料點重疊的可能性。大多數滑動負載在每一個滑動位置上都有標記。

  4. 最終量測完成後，按一下完成。

  5. 從量測連接埠移除滑動負載。

  6. 量測其餘標準。

指定延遲對話方塊說明

僅在執行配接器移除或未知直通校準時才顯示此對話方塊。

將從量測中預估下列值。大多數情況下，這些值是合適的。但是，對於步階大小過大的 CW 掃描或頻率掃描，這些值的準確度還可以提高。

配接器延遲 若要提高此值，將使用密集步長量測並記錄配接器的延遲。將該值輸入到此處。所需的精準值是特性化延遲值時所需的準確度。

標稱相位偏移 （僅限於波導）。若要提高此值，請使用密集步長量測並記錄波導配接器的相位偏移。將該值輸入到此處。

一個接頭是同軸，另一個接頭是波導時，相位偏移的模糊值為 180 度。為了獲得一致性，此處提供的預估值始終在 0 到 180 度之間。您可以將此預估值變更為 -180 度到 +180 度之間的任何值。

所有標準量測完成後，將顯示校準完成對話方塊。

基本校準

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Main（主要值） > Basic Cal...（基本校準...）

其提供基本校準。基本校準的限制，其適用於：

  • 一種接頭類型

  • 一個校準套件

  • 一種校準類型

  • 不執行隔離校準

  • 不執行功率校準

基本校準對話方塊說明

N

接頭類型允許使用者選取單一接頭類型。

校準套件允許使用者選取單一校準套件。顯示的選擇選項由所選的接頭類型而定。

連接埠 允許使用者選取連接埠的性別。未連接表示沒有連接埠連接到 VNA。

校準類型允許使用者選取校準類型。顯示的選擇選項由所選的校準套件、接頭類型和性別而定。

另存為校準集...校準未完成時呈現灰色。完成校準後，按下此按鈕可儲存校準。

儲存校準

智慧型校準、ECal 和非引導式校準完成時會出現下列對話方塊：

校準已完成對話方塊說明

完成 儲存到通道的校準暫存器。

另存為使用者校準集 叫用「另存為使用者校準集」對話方塊並將其儲存到通道的校準暫存器。

取消 不套用或儲存校準。

瞭解校準暫存器。

瞭解使用者校準集

另存為使用者校準集對話方塊說明

現有校準集 - 列出在 VNA 中儲存的校準集名稱。

從清單選取校準集或在下方輸入新名稱 指定新校準集的名稱。接受建議的新名稱、輸入新名稱或從清單選取名稱以覆寫現有名稱。

編輯名稱 如果沒有鍵盤，按一下即可啟動可從 VNA 前面板使用的 VNA 輸入工具。

儲存 使用新的校準集名稱儲存校準集。

瞭解使用者校準集

上次修改時間：

2014 年 08 月 14 日

第一版


引導式功率校準

可在標準 S 參數引導式校準期間執行來源和接收器功率校準。與標準來源和接收器功率校準相比，此功率校準提供了下列增強功能：

  • 可使用單一功率感應器連接為所有 VNA 連接埠執行來源和接收器功率校準。

  • 可使用多個功率感應器覆蓋較寬頻率範圍。

  • 可自動修正接收器。

  • 也可以補償可能用於連接功率感應器的配接器。

  • 提供可選的匹配修正的功率量測。

  • 來源和接收器功率修正將與 S 參數修正一起儲存到校準集。

附註： 啟用頻率偏移模式時，引導式功率校準不準確。

深入瞭解標準來源和接收器功率校準。

如何執行引導式功率校準

  1. 在標準（S 參數）通道中，設定量測（掃描類型、頻率範圍、IFBW 等）。在 mmWave SMC 量測上有此功能的特殊版本可供使用。瞭解詳情。

  2. 使用與標準來源功率校準相同的方式連接功率表/感應器。深入瞭解。

    • 請參閱支援的功率表

    • 請參閱首次連接 USB 的重要附註。

  3. 啟動校準精靈，然後選取引導式（智慧）校準。瞭解詳細資訊。

在下列選取連接埠對話方塊中，勾選校準來源和接收器功率，然後按一下下一步。

稍後出現兩個校準精靈頁面，請完成下列對話方塊。

功率校準設定對話方塊說明

附註：當 mmWave SMC 量測處於作用中狀態時，將顯示使用功率表核取方塊（未顯示）。瞭解詳情。

功率校準位置： 選取將對其執行功率校準的來源連接埠。來源和接收器修正將傳輸到 S 參數量測所涉及到的所有其他來源和接收器。

使用多個感應器 不適用於 SMC 量測。

勾選此方塊以使用配置為 PMAR 裝置的一或多個功率感應器。多個感應器對話方塊將取代此對話方塊。請參閱下列影像。

清除「使用多個感應器」（預設設定）時，按一下功率表設定以配置功率表。

解除嵌入（功率感應器）配接器 功率感應器接頭的類型和性別與指定連接埠之受測裝置接頭的類型和性別不同時，為取得最佳準確度，需要執行額外校準步驟來量測和修正用於將功率感應器連接到參考平面的配接器。

清除該方塊不會對新增的配接器進行補償。

核取該方塊可執行額外的校準步驟來量測和修正配接器。

然後選取功率感應器的功率感應器接頭類型和性別。「忽略」不會對新增的配接器進行補償，正如清除核取方塊一樣。

如果該接頭與相同連接埠的受測裝置接頭匹配，則 VNA 會假定沒有配接器。不需要執行額外校準步驟，且校準套件選項不可用。

否則，請選取要用於校準配接器的校準套件。

請參閱下方的準確度設定。

功率校準設定 - 使用多個感應器對話方塊說明

附註

僅在標準通道及校準所有校準期間允許使用「多個感應器」。

用作「多個感應器」的功率感應器必須配置為 PMAR 裝置。

功率校準位置： 選取將對其執行功率校準的來源連接埠。來源和接收器修正將傳輸到 S 參數量測所涉及到的所有其他來源和接收器。

感應器設定 按一下以啟動「感應器設定」對話方塊，以新增/配置外部裝置。

感應器網格

感應器 選取功率感應器和關聯的開始和停止頻率範圍。

配接器 功率感應器接頭的類型和性與指定連接埠之受測裝置接頭的類型和性不相同時，為取得最佳準確度，需要執行額外校準步驟，才可量測和修正用於將功率感應器連接至參考平面的配接器。

清除該方塊不會對新增的配接器進行補償。

核取該方塊可執行額外的校準步驟來量測和修正配接器。然後指定功率感應器的功率感應器接頭類型和性。如果此接頭與相同連接埠的受測裝置接頭匹配，則無需執行額外校準步驟，且校準套件選擇不可用。否則，請選取要用於校準配接器的校準套件。

移除 按一下以從清單中移除功率感應器。

新增感應器 按一下以新增行，然後按一下向下箭頭以選取感應器。如果功率感應器未顯示在清單中，請按一下感應器設定按鈕以配置功率感應器。

準確度

公差 如果連續功率感應器讀值在彼此的該值範圍內，則將該讀值視作穩定值。

讀值的最大數目 設定功率感應器實現趨穩所需讀值的最大數目。在下列任一情況中時，每一個功率讀值都是「穩定的」：

  • 兩個連續讀值在公差值範圍內或

  • 滿足讀值的最大數目要求時。

將針對讀取的讀值計算平均值，使其成為「穩定的」讀值。

功率感應器連接步驟對話方塊說明

功率位準 設定執行來源功率校準的 功率位準。

通常，最好以 0 dBm 執行來源功率校準，因為功率感應器在該位準上進行校準。如果您的量測無法達到 0 dBm，則將其設定為具有最低量測雜訊位準的功率位準。

關閉匹配修正

引導式功率校準期間，將量測功率感應器和 VNA 來源連接埠之間的匹配。將補償來源功率修正陣列以說明所量測之不匹配的原因。此外，也將補償參考接收器量測以說明受測裝置不匹配的原因。

如何關閉匹配修正：

按一下主要，然後按一下修正方法。

修正方法對話方塊說明

依預設，引導式功率校準將匹配修正套用至接收器量測。不過，在下列情況下，您可能要關閉匹配修正：

  • 進行非傳統量測，例如高功率或多重連接埠配置時。由於新增了元件或進行了重新配置，不匹配量測可能無效。

  • 遠端程式已說明感應器的匹配效應時。

清除此方塊將不對此通道上使用的所有接收器套用匹配修正。接收器仍使用標準接收器校準進行修正。瞭解詳情。

勾選此方塊以對此通道上使用的所有接收器套用匹配修正。

上次修改時間：

2014 年 11 月 18 日

初始版本


校準所有通道

使用「校準全部」可以在單個校準工作階段中校準多個通道。 這不僅可以減少需要進行的連線數，而且還可以減少必須執行的校準標準量測的數量。

在本主題中：

  • 功能

  • 限制

  • 如何執行「校準全部通道」校準

    • 「選取通道」對話方塊

    • 「量測類別校準內容」對話方塊

    • 「校準衰減器設定」對話方塊

    • 「選取受測裝置接頭和校準套件」對話方塊

    • 「功率校準設定」對話方塊

    • 「校準步驟」對話方塊

    • 完成

    附註：安裝了一個或多個 M9377A 時，「校準全部」會停用。

其他校準主題

功能

「校準全部」為所有通道提供了最佳化的單一校準程序（有一些限制，請參見下文）。 最佳化功能包括：

  • 最大程度地減少標準的物理連線數。

  • 最大程度地減少功率表校準掃描數。

  • 使用者可設定 S 參數的功率位準以及功率校準步驟。

  • 顯示不同通道中的不同開關和衰減器設定。這可以減少特性化不同開關/衰減器設定（通道設定差異）所需的量測數目。

  • 「校準全部」所產生的校準集（誤差項）的數量和格式與一次執行一個校準所實現的數量和格式相同。

限制

  • 使用已知的延遲混頻器或相位參考校準集支援啟用了相位的 SMC+ 相位。 不支援 S2P 檔案特性化的混頻器。

  • 不支援在多連接埠模式下啟動 VNA。

  • 在一個 IFBW 上執行「校準全部」校準。

  • 校準的所有通道將強制進入步進掃描模式。

  • 要校準的所有通道必須具有相同的校準參考平面。換言之，「校準全部」不能補償在 VNA 外部產生的任何路徑變更。

如何執行「校準全部通道」校準

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal]> Call All...（校準全部...）

選定的通道對話方塊說明

  1. 核取要校準的通道。

  2. 核取要校準的連接埠。

  3. 按一下下一步>

附註： 若要對混頻器通道執行 LO 功率校準，可在混頻器設定對話方塊中將 LO 連接埠設定到 VNA 或外部來源。然後選取該對話方塊中的此連接埠。

量測類別校準內容對話方塊說明

確認或變更要校準的每個通道的下列唯一校準內容。按一下連結可瞭解這些內容。

具有（在「校準全部」中不可用）的內容在「校準全部」校準中不可用，因為它們位於獨立的校準中。

增益壓縮

  • 無唯一屬性。

SMC（未提供 VMC）

 | 程式設計
UI 設定 | 內容 | 值
啟用相位修正 | "啟用相位修正" | 「true」或「false」
相位修正方法 | "相位修正方法" | "使用混頻器延遲" "使用接收器特性化校準集"
混頻器延遲 | "混頻器延遲" | 表示延遲值的實數。
接收器特性化校準集 | "校準集" | 校準集名稱字串
特性化的混頻器（s2p 檔案） （在「校準全部」中不可用） |  |

標準通道

 | 程式設計
UI 設定 | 內容 | 值
包括功率校準 | "包括功率校準" | 「true」或「false」

只有選定的通道都不需要功率校準時，才可選用功率校準。

校準衰減器設定對話方塊說明

此對話方塊顯示「校準全部」校準的功率、衰減器和 IFBW 設定。「校準全部」工作階段的預設值是標準 S 參數通道的預設值。這些值不必與選定進行校準的通道的值相同。如果「校準全部」通道和選定通道之間的量測路徑（開關）設定不同，「校準全部」將偵測到這些差異，並對每個路徑條件進行其他量測。這些額外的量測可使「校準全部」產生適合每個選定通道的誤差項。一般情況下，應在足夠高的功率位準條件下執行「校準全部」工作階段，以避免在誤差項中產生雜訊。但是，功率增加會對 VNA 接收器造成壓縮或損壞。使用下列設定可以僅在「校準全部」工作階段中提高功率位準。

功率極限（停用）

「校準全部」會在啟用功率極限時顯示。 使用此設定可以方便地臨時停用這些極限值，以便利用「校準全部」中可用的功率設定。 如果功率極限為啟動狀態，您的受測裝置可能是一個高增益裝置，而且通道中的較高衰減器設定會導致校準參考平面的功率降低。 這個較低的訊號會使校準擷取過程中量測的噪聲變高。這正是「校準全部」要改善的目標。 透過「校準全部」，您可以對校準條件進行設定，以在校準過程中取得更高的訊號雜訊比效能，同時使受測裝置條件保持不變。如果您更希望校準超過極限允許的更高功率位準，則可以選擇清除「在校準期間停用功率極限」核取方塊。極限將在「校準全部」工作階段完成後恢復。

來源/接收器衰減器

附註：M9485A 不支援此功能

依預設，系統將在來源和接收器衰減器設定為 0 的情況下執行「校準全部」校準。在有外部硬體（如增壓放大器）時變更來源或接收器衰減器設定會導致 VNA 接收器被壓縮或損壞。

您還可能想要變更衰減器或路徑組態設定，以強制校準通道與選定通道的設定相匹配。如果將所有選定通道設定為相同的硬體設定，將這些設定套用於校準通道會更好一些。例如，如果您的所有通道都使用連接埠 1 中的 5 或 10 dB 步進衰減器，則可以選取將「校準全部」通道變更為使用相同的低衰減器設定。 這樣就會在與通道相同的路徑條件下進行校準量測，並且消除了以數學運算方式補償差異的必要。 但是，如果使用較大的衰減器值，預設「校準全部」設定可能會提高結果。

S-參數校準連接埠功率

設定執行 S 參數校準的功率位準。

功率位移

功率位移是在通道範圍內發生的。因此，您設定的位移不會自動複製到「校準全部」工作階段。 使用此設定還可以在「校準全部」工作階段期間套用功率位移。瞭解功率位移。

IF 頻寬

設定用於執行「校準全部」校準的 IFBW。預設 IFBW 設定是 1 kHz，這是適合大多數量測的標稱設定。降低 IFBW 可從校準量測中移除雜訊，但同時也會使掃描變慢。

路徑組態

附註：M9485A/E5080A 不支援此功能

除了特定於套用的校準要求外，「校準全部」還代表所有選定的通道執行 S 參數校準和功率校準。 依預設，系統使用標準通道預設硬體路徑來執行此校準：

  • 旁路開關設定為「直通」

  • 雜訊開關設定為「標準」。

將以數學運算方式移除通道和「校準全部」通道之間的路徑組態差異。

使用路徑組態對話方塊可以變更「校準全部」校準的此部分的路徑設定。

選取受測裝置接頭和校準套件對話方塊說明

對於每個受測裝置連接埠：

  • 選取（將連線校準標準）校準參考平面上的接頭。

  • 選取要使用的校準套件。

核取修改校準以變更直通方法。依預設，將執行未知直通校準。瞭解直通方法。

瞭解此對話方塊的更多資訊。

功率校準設定對話方塊說明

可在「校準全部」校準的來源連接埠上執行引導式功率校準。

將對每個來源連接埠顯示此對話方塊以接收功率校準。

若要對混頻器通道執行 LO 功率校準，可在混頻器設定對話方塊中將 LO 連接埠設定到 VNA 或外部來源。然後選取選定的通道對話方塊中的此連接埠。

  • 若要對所有功率校準使用相同的功率感測器，請勿核取「使用多個感測器」。

  • 若要使用其他功率感測器，請核取使用多個感測器。必須將感測器設定為 PMAR 裝置。瞭解操作方法。

瞭解此對話方塊。

校準全部摘要 對話方塊說明

此頁面是「校準全部」設定的摘要。確認設定，然後按一下下一步> 或 <上一步以變更設定。

校準步驟 對話方塊說明

按照提示連接每個標準。然後按一下量測。

如有需要，可按一下重新量測。

然後按一下下一步>

完成校準 對話方塊說明

按一下完成將「校準全部」工作階段結果儲存到校準寄存器。

或者按一下另存為使用者校準集，然後輸入前綴標題。量測類別和通道號將附加到此前綴，以儲存到每個校準通道的使用者校準集。

瞭解有關此對話方塊的更多資訊。

上次修改時間：

2016 年 01 月 06 日

第一版


使用校準集

  • 什麼是 VNA 校準集

  • 校準寄存器和使用者校準集

  • 如何管理和套用校準集

  • 校準集用法範例

  • 使用 .cal 檔案對校準集進行封存

另請參閱

儲存和重新叫用：儀器狀態和校準集資料

請參閱其他校準主題

什麼是 VNA 校準集

校準完成後，所有的校準資料都將儲存到校準集中。可稍後将校準集套用於與校準集具有相同激勵設定的任何通道，因此節約了執行其他校準所需的時間。下列資料將儲存到校準集中：

  • 名稱

  • 校準集說明

  • 校準集屬性 - 激勵設定、校準類型、連接埠關聯

  • 標準資料

  • 誤差項資料

  • GUID（全域唯一識別碼）

校準寄存器和使用者校準集

有兩種類型的校準集：

  • 校準寄存器（特定於通道）

  • 使用者校準集

每次校準結束時，校準資料將自動儲存到校準寄存器。您也可以選擇將校準資料儲存到使用者校準集。

校準寄存器

校準寄存器是隨 VNA 5.0 版一起推出的新應用程式，其設計目的是簡化大多數使用者的校準流程。校準完成後，資料將自動儲存到通道的校準寄存器，從而覆寫（或附加到）該寄存器中以前儲存的校準資料。此概念類似於之前的 Keysight 矢量網路分析器。

  • 每個通道都有一個專用的校準寄存器。 它們的名稱為 CHn_CALREG，其中 n 為通道號碼。不能變更此名稱。

  • 校準寄存器的易失性更強，因為每次在該通道上執行校準時都會將其覆寫（或向其附加資料）。系統總是儲存校準資料，但只是臨時的。

  • 可將校準寄存器套用到其他量測，但僅限與校準寄存器相同的通道。

使用者校準集

校準結束時，您可以選擇將校準資料儲存到現有的使用者校準集，也可以儲存到新的使用者校準集。

  • 可將使用者校準集同時套用於任意數量的通道。

  • 您可以對使用者校準集進行命名以方便識別。

  • 可以有數量不限的使用者校準集。

  • 您可以隨時複製校準寄存器資料以建立使用者校準集。請參閱校準集內容。

附註： 您可以設定喜好設定以恢復 5.0 版本之前的行為 - 校準資料將自動儲存到使用者校準集而不是校準寄存器。

在校準集中附加資料

在校準結束時，資料將儲存到通道的校準寄存器，如果您選擇，還可以儲存到使用者校準集。如果選擇儲存到現有的使用者校準集，VNA 會嘗試將新的誤差項附加到現有的使用者校準集。 將會完全覆寫現有校準集資料，除非根據以下兩條規則，新資料才能夠與現有資料共存：

  • 新資料的激勵設定必須與現有資料完全一致。

  • 新校準必須包含來自現有校準的其他連接埠。

例如：

案例 1 - 某個現有校準集包含連接埠 1 和 2 之間的全雙連接埠校準。您使用相同的激勵設定在連接埠 3 上執行了單連接埠校準。在校準結束時，您按一下另存為使用者校準集並選取現有的全雙連接埠使用者校準集。

結果：單連接埠校準將附加到雙連接埠使用者校準集。它們之間不會產生重疊。

案例 2 - 與案例 1 的情況相同，只不過會在連接埠 1 上執行單連接埠校準。

結果： 校準集將包含連接埠 1 上的單連接埠標準以及連接埠 2 上的單連接埠校準。重疊追蹤項已被刪除，這使得原始的全雙連接埠校準變為無效。

如何管理和套用校準集與校準類型

VNA 將嘗試套用校準集，並針對作用中通道上的所有量測開啟誤差修正。不可能始終可以執行此作業。例如，假設某個通道同時包含 S11（反射）和 S21（傳輸）量測。如果某個僅包含 S11 校準類型的校準集套用於該通道，則該校準集將不包含可用於修正 S21 量測的誤差項。將針對 S11 啟用誤差修正，而不對 S21 量測啟用。

可使用兩種方法將現有的校準集（校準寄存器或使用者校準集）套用於量測：

  1. 使用校準資料（.cst 檔案）重新叫用儀器狀態 - .cst 檔案包含具有所有量測屬性的儀器狀態以及指向用於校準量測的校準集的「指標」。在儲存 .cst 檔案之前，應確保將使用者校準集（不是校準寄存器）用於量測。因為在執行新校準時將自動覆寫校準寄存器，所以該校準寄存器資料將在重新叫用 .cst 檔案之前變更。

  2. 建立新量測並選取要套用於作用中通道的校準集。

附註： 不要從 Windows 檔案總管或其他應用程式複製或修改校準集。只能透過 VNA 應用程式存取校準集。

如何選取校準集並將其套用於作用中通道

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集和校準套件）> Cal Set...（校準集...）

校準選取對話方塊說明

使用此對話方塊可以管理和套用校準集。

雖然校準集的數量僅受 VNA 記憶體空間的限制，但如果現有校準集超過 10 個，或每個唯一的通道設定都有一個目前校準集，就會被認為是異常情況。必須刪除或覆寫舊校準集（包含「舊」資料）。

系統總是顯示作用中通道的校準寄存器，即使是空的也會顯示。僅在存在其他通道並且這些通道包含資料時，才會在校準集清單中顯示屬於這些通道的校準寄存器。

  • 瞭解校準寄存器。

  • 瞭解如何檢視校準集的誤差項。

若要對作用中通道套用校準集，請按一下箭頭以選取該校準集，然後按一下「套用校準」。

附註：若要套用校準集，必須從與作用中通道相同的量測類別中產生該校準集。

欄 按一下標題可按該欄進行排序

校準集名稱 用於識別校準集的名稱。

說明 使用者可設定的文字，用於進一步識別校準集。

通道 目前使用此校準集的通道號。空項目表示目前未在使用中。

標準類型/連接埠 標準集中包含的校準類型。瞭解套用適當的校準類型。

標準類型縮寫：

1P、2P、3P、4P... - 全 n 連接埠校準

+ - 表示校準集中包括功率修正

R - 回應（而不是連接埠，顯示它修正的量測類型）。

ER/x-y 增強回應，其中 x 是接收連接埠；y 是來源連接埠。

SMC 純量混頻器校準

修改日期 上次修改標準集的日期和時間。

按鈕

複製 叫用另存為使用者校準集對話方塊。輸入選定的校準集資料的副本名稱。

編輯/內容 叫用「校準集內容」對話方塊。您可以檢視所有校準集內容，並從現有的使用者校準集或校準寄存器建立重複的使用者校準集。

刪除 顯示警告提示後，如果選取「確定」，則將永久刪除校準集。

全部刪除 顯示警告提示後，如果選取「確定」，則將永久刪除列出的所有校準集和校準寄存器。

套用校準 將選定的校準集套用於作用中通道。如果校準集和通道的激勵設定不同，則必須進行選擇。

取消選取 只有在選定的校準集 由作用中通道使用時才可用。按一下以「取消套用」校準集，然後按一下關閉結束而不套用校準集。

確定 始終將選定的校準集套用於作用中通道，然後關閉對話方塊。

關閉 結束對話方塊。不執行進一步動作。

校準集內容對話方塊說明

您可以檢視所有校準集內容，並從現有的使用者校準集或校準寄存器建立重複的使用者校準集。

名稱 編輯使用者校準集名稱。不能變更校準寄存器的名稱。

說明 說明性文字，用於進一步識別校準集。

校準集內容 列出校準集的說明性資訊和激勵條件。

瞭解如何檢視校準集的誤差項。

校準集和量測之間的激勵設定不同

選取校準集 -- 選取激勵設定對話方塊說明

校準集包含在儲存校準集時儲存的通道激勵設定。當校準集通道設定與套用校準集的通道的設定不同時，將顯示此對話方塊。請選取以下選項之一：（请參見上圖）。

  • A. 保留作用中通道的激勵設定。如果可以，可執行插入。

    • 如果校準集頻率範圍大於作用中通道，則將啟動插入。瞭解有關插入精度的更多資訊

    • 如果校準集頻率範圍小於作用中通道，則該選項不可用。

  • B. 保留校準集激勵設定。將變更作用中通道激勵設定。

確定 執行變更。

取消 不會套用校準集。

校準集用法範例

以下範例顯示校準集如何在進行分析器量測時提高靈活性和速度。

  • 對多個通道使用一個使用者校準集

  • 對多個校準集使用一個量測

對多個通道使用一個使用者校準集

可以執行一次校準，然後將其套用於多個通道。

範例：

在製造過程中，您可能有多個校準的通道。您可能需要連續循環進行量測並分別檢查各個量測。有時，您可能需要重新整理校準，無需重新建立所有量測狀態檔案。

方法如下： 檢查每個通道的激勵設定。然後讓使用者校準集激勵範圍成為整個群組的超集。接著，每個通道就可以使用相同的使用者校準集。系統內將插入某些校準。附註： 確保插入已啟動。

注意，在下圖中，校準集 78 用於多個通道，在此案例中是通道 5 和 16。

通道 校準集

對多個校準集使用一個量測

將一個非常大的使用者校準集與多個儀器狀態關聯起來的缺點是，準確度度可能由於插入而降低。在此類情況下，可考慮對每個激勵設定使用一個使用者校準集。然後，可透過套用其他使用者校準集來變更通道的激勵條件。 其他設定（視窗設定、量測定義、縮放、極限、游標）不會變更。 與儲存和重新叫用每個激勵條件集的 *.cst 檔案相比，狀態變更的速度要快得多。

範例 1： 需要在多個輸入功率位準上量測放大器。在多個功率位準上進行校準，並將每個校準儲存在單獨的使用者校準集中。 然後將使用者校準集連續套用於單個量測。

範例 2： 要執行 S21 量測，您需要同時量測裝置的寬跨距和窄跨距特性。一個校準集包含寬跨距設定；另一個校準集包含窄跨距設定。

使用 .cal 或 .csa 檔案對校準集進行封存

因為可以輕鬆刪除使用者校準集，所以透過將校準儲存為 .cal 或 .csa 檔案（請參閱儲存 .cal 檔案）可提供額外的備份。

例如：

一個使用者執行了校準，對其命名，並將其儲存為使用者校準集。任何其他使用者都可以使用該校準集。第二個使用者可能會意外刪除或修改該使用者校準集，這就需要建立者重新執行校準過程。

將校準集儲存到 .cal 檔案或 .csa 檔案，可為校準資料提供安全性。以後可重新叫用該檔案並恢復原始校準。

上次修改時間：

2016 年 01 月 06 日

第一版


誤差修正與內插法

將「誤差修正」與「內插法」設定搭配使用，可為您提供可能的最高層級校準準確度。

  • 如何設定誤差修正

  • 誤差修正

  • 檢視修正等級

  • 如何設定內插法

  • 內插法準確度

請參閱其他校準主題

如何設定誤差修正

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Main（主值） > Correction（修正）>Channel Correction On|Channel Correction Off（開啟通道修正|關閉通道修正）

誤差修正

「開啟誤差修正」設定意味著校準誤差項已套用於量測。執行校準或者對某一量測套用校準集時，將開啟誤差修正。VNA 將嘗試針對作用中通道上的「所有」量測開啟誤差修正。當套用校準集時，並非始終可執行此作業。如需詳細資訊，請參閱套用校準集。

當開啟全部雙連接埠誤差修正時，需要執行正向與反向掃描才能收集所有 12 個誤差項，即使僅顯示一個反射量測亦是如此。這可能會導致量測速度超出預期。瞭解詳情。

透過按一下「修正關閉」，您始終可以為作用中的量測關閉誤差修正。當在某些條件下進行激勵變更時，VNA 將自動關閉誤差修正。若要重新開啟修正，請按一下修正開啟。然後：

  • 如果無法執行內插，將彈出一個對話方塊，詢問您是否要將激勵設定變更為已套用校準的設定。按一下「確定」或「取消」。

  • 如果可以執行內插，激勵設定將會變更且會開啟修正。

檢視修正等級

修正等級提供了與作用中的量測之準確度有關的資訊。修正等級標記顯示在狀態列上，用於表示諸如回應、全雙連接埠、TRL 或功率校準等不同校準類型。

若要檢視修正等級：

在檢視功能表中，按一下狀態列。將出現狀態列并顯示下列項目：

修正等級 |  | 準確度
C | 完全 | 最高
C* | 內插法 | 不確定
CD | 已變更 | 不確定
No Cor | 無修正 | 最低

C 完全修正

執行校準後或套用有效的校準集時，將立即顯示完全修正等級。如果您需要最佳準確度，請勿在校準後調整分析器設定，以便您的量測結果始終保持在這一層級。

C* 內插修正

當對量測進行內插時，狀態列中將會顯示「C 星號」。請參閱內插法（上述內容）與內插準確度。

CD 變更的設定

當一個或多個下列激勵設定變更時，狀態列中會顯示「C-delta」。得到的量測值準確度取決於變更的參數以及變更的程度。若要獲得最佳準確度，請使用新的設定重新校準。

  • 掃描時間

  • IF 頻寬

  • 連接埠功率

  • 步進式掃描已啟用/停用

No Cor 無修正

下列情況將導致 VNA 關閉通道的誤差修正：

  • 降低起始頻率

  • 提高停止頻率

  • 在關閉內插的情況下變更起始頻率、停止頻率或點數。

  • 變更掃描類型

如何設定內插法

使用硬鍵/SoftTab/軟鍵

  1. 按一下 [Cal] >Main（主值） > Interpolation（內插法）>ON|OF（開|關）

內插

校準內插法將調整校準誤差項，以使變更匹配您執行校準或套用校準集之後所做的下列設定。

開啟內插設定意味著對作用中量測啟用內插。這不一定意味著已內插量測。啟用（開啟）後，若由於您變更下列任意激勵設定而必須執行內插，則將會套用內插。如果在內插關閉時變更激勵設定，則不套用內插，而是關閉誤差修正。

變更下列任意設定時會進行內插（若啟用）：

  • 提高起始頻率

  • 降低停止頻率

  • 點數

附註：降低起始頻率或提高停止頻率將始終關閉修正。（例外狀況：功率校準外推至起始頻率和停止頻率。）

內插法準確度

對量測內插後，將無法預測量測的準確度。量測準確度可能會受到很大影響或根本不受影響。識別這些情況下的量測誤差必須依個別情況逐一確定。一般來說，VNA 中的幅度和相位激勵以及受測裝置中的回應必須平緩連續，才能使量測內插獲得準確的結果。

當量測點之間的相位偏移回應使變更增加超過 180 度，則將出現明顯的量測誤差。VNA 將錯誤地內插新的相位資料。如需詳細資訊，請參閱相位準確度。

一般來說，當在下列條件下內插量測時，出現明顯誤差的可能性將會增加：

  • 當量測點之間的頻率跨距變得更大時。

  • 當量測頻率高於 10 GHz 且相位變化更快時。

  • 跨頻寬交叉進行內插時。 進一步瞭解頻寬交叉。

附註： 當內插算法遇到回應幅度或相位中的突然或較大的變化時（此類情況可能會出現在頻寬交叉處），顯示資料中可能會包含較大的內插誤差。 這些誤差可視為步長或突波。 如果發生這種情況，請考慮關閉內插、變更量測參數或建立跳過頻寬交叉的掃描區段。

上次修改時間：

2016 年 01 月 06 日

第一版


使用 ECal

本主題介紹執行 ECal 的所有各個方面：

  • ECal 概觀

  • 將 ECal 模組連接至 VNA

  • 如何使用 ECal 執行校準

另請參閱：

ECal 使用者特性

使用一個 2 連接埠 ECal 模組執行 4 連接埠校準

還原 ECal 模組記憶體

請參閱其他校準主題

ECal 概觀

ECal 是全固態校準解決方案。每個 ECal 模組均包含電子標準，這些標準可在 VNA 量測校準期間自動切換位置。這些電子標準出廠時便已經過量測，資料儲存在 ECal 模組的記憶體中。VNA 使用已儲存的資料和已量測的 PNA 資料來計算量測校準的誤差項。

ECal 模組可用於 2 連接埠和 4 連接埠型號以及各種接頭類型，覆蓋各種頻率範圍。有關可用 ECal 模組和訂購的詳細資料，請參閱分析器附件。

您可以使用 ECal 執行以下校準：

  • 1 連接埠反射校準

  • 全 2 連接埠校準

  • 全 3 連接埠校準

  • 全 4 連接埠校準

使用 ECal 可信度檢查驗證機械校準或 ECal 校準的有效性。

ECal 模組的維護和操作

您可透過以下方式提高準確度和可重複性，避免高昂的設備維修費。

  • 採取正確的接頭維護措施。請參閱接頭維護。

  • 保護設備以防出現 ESD 故障。請閱讀靜電放電保護。

模組的功率位準

  • 切勿超過 ECal 模組的以下損壞級別。

  • 若要取得最佳準確度，校準時請勿超過以下 ECal 壓縮級別：

型號 | 壓縮級別 | 損壞級別
N469x 系列 | -5 dBm | +10 dBm
N4432A 系列 N4433A 系列 | -7 dBm | +20 dBm
N4431x 系列 | +7 dBm | +20 dBm
8509x 系列 | +9 dBm | +20 dBm

將 ECal 模組連接至 VNA

ECal 模組透過 USB 連線到 VNA 進行控制和供電。連接模組後，VNA 將自動識別模組類型、頻率範圍和接頭類型。

.

ECal 模組將連接到 VNA 前面板或後面板的 USB 連接埠。

  1. 連線時請佩戴接地腕帶。

  2. 將 USB 纜線類型 B 接頭連接到 ECal 模組，將 USB 纜線類型 A 接頭連接到分析儀的前面板或後面板 USB 接頭中。

備註：

  • 已完成校準、但未使用的 ECal 模組仍會與 USB 連接埠保持連線。

  • 您可在分析器執行時連線和斷開 ECal 模組。但是，當資料傳輸正在進行時，請勿連線或斷開模組。這可能會導致受損或至少損壞資料。

如何使用 ECal 執行校準

選取一個 ECal 模組，該模組的接頭與受測裝置具有相同的類型和性。如果沒有這類 ECal 模組，則可透過進階設定或使用者特性化來使用其接頭與受測裝置不同的模組。另請參閱：使用一個 2 連接埠 ECal 模組執行 4 連接埠校準

將 ECal 模組連接埠連接到 VNA 連接埠。在校準過程中，VNA 將自動偵測如何連接 ECal 模組，您也可手動執行定位。

  1. 將 ECal 模組的 USB 纜線連接到分析器 USB。請參閱將 ECal 模組 USB 連接至 VNA USB。

  2. 允許模組預熱，直到顯示準備就緒。

  3. 輸入分析器設定。請參閱設定量測。

  4. 執行以下作業之一以啟動校準精靈

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Main（主功能表）> Ecal。

  2. 在引導式校準精靈對話方塊（第 2 步）中，從「校準套件」組合方塊中選取 ECal 選項。

選取校準連接埠和 ECal 模組對話方塊說明

允許您選取校準類型和設定。

校準類型選取/組態 選取要校準的連接埠數目。 然後選取連接埠號組態。

4 連接埠 ECal 僅當使用 4 連接埠 VNA 時才可用。無需其他配置。

3 連接埠 ECal 僅當使用 4 連接埠 VNA 時才可用。

2 連接埠 ECal

1 連接埠 ECal －（反射） 「進階設定」不可用。

檢視/選取 ECal 模組 如果多個 ECal 模組連接到 VNA，請按一下選取 ECal 模組。此外，請在模組內選取使用者特性。瞭解有關使用者特性的更多資訊。

顯示進階設定 核取後，將在按一下下一步時顯示進階設定。

上一步 返回校準精靈開始對話方塊。核取後，您可清除儲存喜好設定核取方塊，在校準精靈開始時檢視「開始」頁面。

附註： VNA 不再允許執行 ECal 隔離。VNA 所固有的隔離比使用 ECal 模組進行校正後達到的隔離效果更佳。

附註：終止負載為 50 ohm 且未使用的任何 ECal 連接埠。

附註：請勿在 ECal 校準期間連接任何 USB 記憶體。

找不到 ECal 模組對話方塊說明

顯示此對話方塊時，表明 ECal 模組未連線，或網路分析器無法將其識別。

重試 檢查 USB 連線並按一下以繼續。

備註：

  • 如果未偵測到 ECal 模組，請嘗試將其拔下，並將 USB 接頭重新連接到 VNA。

  • 當 ECal 模組首次連接到網路分析器時，分析器將在大約 30 秒內識別此模組，並將其用於校準。

  • 若要取得最佳準確度，請允許 ECal 模組預熱，直到顯示「READY」（就緒）。

  • Keysight 8509x 和 N4431 ECal 模組首次連線時，比其他模組佔用的電流更多。這可能會導致 USB 在特定情況下停止執行。參閱 USB 限制。

  • 請參閱將 ECal 模組 USB 連接至 VNA USB。

選取模組和特性對話方塊說明

ECal 模組 選取連接至 VNA 的一個 ECal 模組。

偵測已連接的 ECal 按一下以重新掃描 USB 以查找 ECal 模組。

可用特性

ECal 模組記憶體 - 顯示 ECal 模組中儲存的原廠資訊和使用者特性。

VNA 磁碟記憶體 － 顯示 VNA 磁碟記憶體中儲存的使用者特性。深入瞭解 VNA 磁碟記憶體中的使用者特性。

選取要用於校準的特性資料。選取後，該特性將成為預設選取，直到 VNA 關閉並重啟為止。重啟後，原廠設定又會成為預設選取。

誤差：頻率範圍對話方塊說明

顯示此對話方塊時，表明目前校準標準（或 ECAL 模組）並未覆蓋量測的目前頻率範圍。請執行下列其中一項動作以修正問題：

校準套件類別 不可用於 ECal 模組。

頻率 變更作用中通道的頻率範圍。

編輯 不可用於 ECal 模組。

上一步 選取一個與覆蓋所需頻率範圍不同的特性。

取消 使用增加的頻率範圍重新特性化模組。

選取受測裝置接頭和校準套件對話方塊說明

如果 ECal 模組或所選使用者特性具有多個接頭類型，則將顯示以下對話方塊，允許您描述受測裝置接頭類型。否則，請按一下「下一步」繼續進行進階設定（如果已核取）或 ECal 步驟。

接頭

每個受測裝置連接埠的可用接頭均會列出。

進階設定對話方塊說明

直通 #n

列出建議在校準程序期間執行的直通連接。您可變更這些直通連接以更好地適應您的測試設定。

  • 系統會自動列出建議的直通連接。

  • 可選取其他直通連接，以取得更高的準確度。瞭解詳情。

  • 若要進行平衡量測，請瞭解要選取的直通路徑。

新增直通

按一下以新增直通連接。暸解詳細資訊

移除直通

透過按一下「直通 #N」欄位或「第 1 個連接埠/第 2 個連接埠」欄位來選取直通。然後按一下「移除直通」。如果校準需要所選的直通，則該選擇不可用。

第 1 個連接埠/第 2 個連接埠

按一下以變更直通連線中所包含的兩個連接埠。連接埠號的順序（第一或第二）並不重要。

直通校準方法

列出適用於指定連接埠對的可用直通校準方法。

瞭解 ECal 直通方法

校準類型/標準

按一下以叫用「檢視/修改校準屬性」對話方塊。

定位

核取此方塊（預設設定）後，VNA 將自動感應 ECal 模組連接埠連接至 VNA 連接埠時的型號和方向。如果 ECal 模組的功率過低，則會顯示為如同沒有連接 ECal 模組一樣。如果使用低功率並出現此問題，請清除該核取方塊以手動提供方向。

首先在您校準的頻率範圍中間處定位。如果未偵測到訊號，則會在範圍的最低頻率處再次嘗試。

選取差量匹配

僅當需要差量匹配校準時才可用。

  • 勾選該方塊，然後按一下下一步以叫用選取差值匹配的校準集對話方塊。

  • 清除 - 校準精靈使用全域差值匹配校準（如果可用）。

指定 ECal 模組的連接方式對話方塊說明

在上一個對話方塊中清除定位核取方塊時，將會顯示此對話方塊。

按一下要連接到每個 VNA 連接埠的 ECal 連接埠。

電子校準步驟對話方塊說明

附註： ECal 可以透過外部觸發執行。瞭解詳情。

顯示校準所需的每個量測的說明。

量測 量測 ECal 標準。

完成 最後一個標準量測完畢後，請按一下此選項。

儲存 ECal 校準

完成後，您可儲存新校準。瞭解詳細資訊。

上次修改時間：

2014 年 09 月 08 日

第一版


ECal 使用者特性化

  • 概觀

  • 如何執行使用者特性

  • 管理磁碟記憶體

  • 還原 ECal 模組記憶體

另請參閱

使用 ECal

使用 2 連接埠 ECal 模組執行 4 連接埠校準

其他校準主題

概觀

使用者特性化的 ECal 模組允許您將配接器新增至 ECal 模組，重新量測 ECal 模組中的標準（包括配接器），然後將此資料新增至 ECal 記憶體或將其儲存至 VNA 硬碟中。這會將參考平面從模組測試連接埠延伸至配接器。

為何執行使用者特性化？

  • 如果您需要對 ECal 模組使用配接器，則可以使用已連接的配接器對 ECal 模組進行特性化，並在單一步驟中執行後續 ECal。

  • 如果有 4 連接埠 ECal 模組，則可以使用不同接頭類型的配接器設定模組，然後執行模組的使用者特性化。如果需要模組中的一對接頭類型來測試受測裝置，則可藉由使用者特性化模組上兩個相同接頭，透過單一步驟 ECal 對 VNA 進行校準。

  • 如果要測試固定裝置中的裝置，則可以將固定裝置的特性嵌入模組的特性。為此，在使用者特性的機械校準部分過程中，可以在裝置的參考平面上進行校準，就像通常進行校準一樣。然後移除要內嵌的固定裝置，並插入要特性化的 ECal 模組。 量測 ECal 模組時，VNA 將移除固定裝置的影響，並將量測結果儲存至使用者特性化的 ECal 模組中。具有該使用者特性的後續校準也將會移除固定裝置影響。

備註：

  • 2 連接埠和 4 連接埠的 ECal 模組均支援使用者特性。

  • 使用者特性不會刪除出廠特性資料。除了使用者特性資料外，出廠資料將會儲存在 ECal 模組中。

  • ECal 資料抹除公用程式是可從模組刪除該資料的唯一方法。請造訪 http://na.tm.Keysight.com/pna/apps/applications.htm 以瞭解詳情。

  • 可在 ECal 模組的頻率範圍之外執行使用者特性。雖然允許這種做法，但使用延伸的使用者特性得到的校準正確度可能會降低。若要確定降低等級，可將透過機械校準套件校準和 ECal 延伸的使用者特性校準對使用 VNA 的多個裝置所進行的量測進行比較。

  • 一個 ECal 模組最多可儲存 12 個使用者特性。上一個版本最多儲存 5 個，因為存在記憶體限制。在執行使用者特性前，VNA 將確定使用者特性內容是否可容納在模組中。

  • 使用早於 A.08.33 版本的 VNA 來儲存新的使用者特性將會清除 5 個以上的任何使用者特性。這是因為在儲存新的使用者特性時，VNA 完全重新寫入所有 ECal 使用者特性以釋放 ECal 模組中的儲存空間。

  • 可遠端執行使用者特性。請參見程式設計命令。

可將使用者特性儲存至 VNA 磁碟記憶體。瞭解操作方法。之前，使用者特性僅可儲存至 ECal 模組記憶體中。

此功能有以下優點：

  • 使用未包含在支援接頭表格中的接頭的使用者特性無法儲存至 ECal 模組中。但是，在儲存至磁碟記憶體中時，韌體允許任何接頭類型，並可對使用者特性使用任意長度的說明。

  • 對於儲存至磁碟記憶體的使用者特性中所允許的資料點數量沒有限制。當儲存至 ECal 模組時，資料點的數量受到 VNA 韌體的限制。

  • 能夠儲存至磁碟記憶體的使用者特性的數量僅受可用磁碟空間的限制。

  • 可以在 VNA 之間隨意共用儲存至磁碟記憶體的使用者特性。

瞭解如何管理磁碟記憶體中的使用者特性。

如何執行使用者特性

摘要 （後續是詳細程序。）

1. 選取與受測裝置接頭組態匹配的模組的配接器。

2. 使用機械標準校準 VNA 或重新叫用現有的校準集。

3. 量測 ECal 模組，包括配接器，就像它是受測裝置一樣。

4. 量測結果就是特性資料，稍後可將其儲存至模組中。

備註

可使用 2 連接埠 VNA 在 4 連接埠 ECal 模組上執行使用者特性。 但是，4 連接埠 ECal 模組有 6 個不同的連接埠配對。必須對使用唯一接頭類型或性別的每一個連接埠配對重新校準 VNA。

  • 如果所有的 4 個 ECal 模組連接埠都有相同的接頭類型和性，則僅需一次 VNA 校準來量測所有的 6 個連接埠配對。

  • 如果所有的 4 個 ECal 模組連接埠有不同的接頭類型和性，則需要 6 次校準。

當使用者特性期間需要多次的 VNA 校準時，則必須使用標準校準精靈執行所有校準，將其儲存至校準集中，然後在使用者特性期間從校準集中重新叫用。

執行使用者特性的詳細步驟

  1. 使用 USB 纜線將 ECal 模組連接至網路分析器。請參閱將 ECal 模組 USB 連接至 VNA USB。

  2. 允許模組預熱，直到顯示準備就緒。

  3. 預設分析器。

  4. 設定量測。 為了取得最佳準確度，應將 IF 頻寬設定為 1 kHz 以下。

  5. 啟動並完成特性化 ECal 模組精靈：

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Cal Sets & Cal Kits（校準集與校準套件）> Ecal > Characterize Module...（特性化模組...）

選取模組和位置對話方塊說明

ECal 模組 選取連接至 VNA 的一個 ECal 模組。

偵測已連接的 ECal 按一下以重新掃描 USB 以查找 ECal 模組。

位置

  • ECal 模組記憶體 按一下「下一步」以顯示下列對話方塊。

  • VNA 磁碟記憶體 輸入特性名稱。此名稱在選取用於後續校準的使用者特性時顯示。

    • 瞭解如何管理儲存於 VNA 磁碟記憶體中的特性。

    • 請參閱將使用者特性儲存至 VNA 磁碟記憶體中的優點。

鍵盤 啟動可用於從 VNA 前面板鍵入特性名稱的鍵台。

下一步 按一下以繼續完成選取用於特性的接頭對話方塊。

請參閱關於延伸頻率使用的備註。

選取新特性的使用者編號對話方塊說明

捲動以檢視已儲存特性的所有參數。選取空白位置或選取以覆寫現有的特性。

下一步 按一下以繼續完成選取用於特性的接頭對話方塊。

請參閱關於延伸頻率使用的備註。

選取用於特性的接頭對話方塊說明

接頭備註

執行 ECal 使用者特性時，不要使用新增至此清單的自訂接頭名稱。如果需要使用自定義的接頭類型，請從每一個連接埠的接頭清單中選取「B 型」或多個不同「A 型」中的一個。

使用未包含在支援接頭表格中的接頭的使用者特性無法儲存至 ECal 模組中。但是，當儲存至磁碟記憶體中時，允許使用任何接頭類型。 瞭解有關儲存至 VNA 磁碟記憶體的更多資訊。

選取適用於 ECal 模組測試連接埠的配接器。如果連接埠上未使用配接器，請選取無配接器。

連接埠 A 列出可用於連接埠 A 的接頭類型。

連接埠 B 列出可用於連接埠 B 的接頭類型。

連接埠 C 列出可用於連接埠 C 的接頭類型（可用於 4 連接埠的 ECal 模組）。

連接埠 D 列出可用於連接埠 D 的接頭類型（可用於 4 連接埠的 ECal 模組）。

下一步 按一下以繼續完成要執行或重新叫用的校準對話方塊。

要執行或重新叫用的校準對話方塊說明

量測 ECal 模組以及必要的配接器之前，必須對 VNA 進行校準。此對話方塊顯示特性所需的機械校準的數量和類型。

立即指引我完成此校準 按一下以執行引導式校準。 每一個接頭類型均需要一個校準套件。

如果需要多個校準，則此選項不可用。請參閱備註。

允許從校準集中重新叫用此校準 按一下以選取現有的校準集。無法選取目前正在使用的校準集。瞭解有關使用校準集的更多資訊。

下一步 按一下以繼續完成選取校準套件或選取校準集對話方塊。

選取校準套件對話方塊說明

提供用於執行校準的校準套件清單。選取將用於每一個連接埠的校準套件。

啟用未知直通以特性化模組 勾選該方塊以啟用此功能。這會減少特性化直通標準所需的步驟數量。 此設定僅在每個測試連接埠有一個參考接收器的 VNA 模組上可用。

下一步 按一下以繼續完成選取校準集對話方塊。

選取校準集對話方塊說明

執行的校準將會寫入校準集中。使用此對話方塊可選取要覆寫的校準集，或者要寫入新校準集的校準集。目前的選擇顯示在選取校準集按鈕下方。

選取校準集 按一下以開啟選取校準集對話方塊。

建立新校準集 按一下以建立用於儲存校準的新校準集。清除該方塊以選擇並覆寫已儲存的校準集。

下一步 按一下以繼續完成引導式校準步驟對話方塊。

附註：記住校準集名稱以供未來參考之用。

引導式校準步驟對話方塊說明

指示您將每個校準標準連接至量測連接埠。

量測 按一下以量測標準。

上一步 按一下以重複一個或多個校準步驟。

完成 重新量測標準以及校準的所有量測完成後按一下。

下一步 按一下以繼續執行下一個校準步驟。（不量測標準。）

取消 結束校準精靈。

當完成步驟時，會出現指定標稱延遲或引導式校準已完成對話方塊。

指定標稱延遲對話方塊說明

僅在執行配接器移除或未知直通校準時才顯示此對話方塊。

將從量測中預估下列值。大多數情況下，這些值是合適的。但是，對於步階大小過大的 CW 掃描或頻率掃描，這些值的準確度還可以提高。

標稱配接器延遲 為了提高此值，將使用密集步長量測和記錄配接器的延遲。將該值輸入到此處。

標稱相位偏移 （僅限於波導）。若要提高此值，請使用密集步長量測並記錄波導配接器的相位偏移。將該值輸入到此處。

一個接頭是同軸，另一個接頭是波導時，相位偏移的模糊值為 180 度。為了獲得一致性，此處提供的預估值始終在 0 到 180 度之間。您可以將此預估值變更為 -180 度到 +180 度之間的任何值。

引導式校準已完成對話方塊說明

允許完成校準並繼續下面的特性化步驟。

不。立即結束 選取以儲存校準集資料。

是 允許選取儲存選項。

下一步 按一下以繼續完成結束以檢查校準品質對話方塊。

結束以檢查校準品質對話方塊說明

允許在繼續進行特性之前，結束使用者特性以驗證校準。

上一步 允許重複校準。

下一步 按一下以繼續完成特性化步驟對話方塊。

取消 結束校準。

若要返回到目前步驟：

  1. 啟動使用者特性。

  2. 在選取新特性的使用者編號對話方塊中，按一下下一步。

  3. 選取用於特性的接頭對話方塊中，按一下下一步。（上一步輸入的項目已經儲存在記憶體中。）

  4. 在要執行或重新叫用的校準對話方塊中，重新叫用剛剛執行的校準集。

特性步驟對話方塊說明

描述特性所需的每個量測的指示。

量測 量測 ECal 模組。

下一步 量測完成時，按一下以繼續完成新特性的資訊對話方塊。

新特性的資訊對話方塊說明

允許描述使用者特性的屬性。

接頭縮寫建議

為了儘量減少字元數量，我們建議使用下列 3 字元的代碼來描述列出的接頭。

使用未包含在此清單中的接頭的使用者特性無法儲存至 ECal 模組。但是，當儲存至磁碟記憶體中時，允許使用任何接頭類型。 瞭解有關儲存至 VNA 磁碟記憶體的更多資訊。

接頭類型 | 3 字元代碼
1.0 mm 母接頭 | 10F
1.0 mm 公接頭 | 10M
1.85 mm 母接頭 | 18F
1.85 mm 公接頭 | 18M
2.4 mm 母接頭 | 24F
2.4 mm 公接頭 | 24M
2.92 mm 母接頭 | 29F
2.92 mm 公接頭 | 29M
3.5 mm 母接頭 | 35F
3.5 mm 公接頭 | 35M
7-16 母接頭 | 16F
7-16 公接頭 | 16M
F 型母接頭 | F7F
F 型公接頭 | F7M
N50 母接頭 | N5F
N50 公接頭 | N5M
N75 母接頭 | N7F
N75 公接頭 | N7M
APC 7 | 7MM
K 頻帶波導 | KBW
P 頻帶波導 | PBW
Q 頻帶波導 | QBW
R 頻帶波導 | RBW
U 頻帶波導 | UBW
V 頻帶波導 | VBW
W 頻帶波導 | WBW
X 頻帶波導 | XBW

下一步 按一下以繼續完成將特性化資料寫入 ECal 模組對話方塊。

寫入特性化資料對話方塊說明

VNA 將使用者特性和出廠特性資料寫入 VNA 磁碟記憶體或 ECal 模組記憶體。

寫入 按一下以寫入資料。

資料儲存至模組後，新使用者特性摘要對話方塊隨即開啟。

  • 選取已具備資料的使用者特性編號時，將會覆寫現有的資料。暸解詳細資訊

  • 如需更多資訊，請參閱還原 ECal 模組記憶體。

  • ECal 資料抹除公用程式是可從模組刪除該資料的唯一方法。請造訪 http://na.tm.Keysight.com/pna/apps/applications.htm 以瞭解詳情。

新使用者特性摘要對話方塊說明

請驗證 ECal 使用者特性的狀態。

  • ECal 模組型號

  • 使用者特性的摘要

取消 按一下以結束（特性化完成）。

完成 按一下以結束（特性化完成）。

管理磁碟記憶體中的 ECal 使用者特性

通常情況下，可無限制地使用儲存於 VNA 磁碟記憶體中的使用者特性，無需進行管理。但是，此對話方塊允許備份特性以防止意外清除，或者將其儲存至可以移動到另一個 VNA 的檔案。

如何管理磁碟記憶體中的 ECal 使用者特性

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Cal Sets & Cal Kits（校準集與校準套件）> ECal > Manage Ecal Disk Memory...（管理 Ecal 磁碟記憶體...）

管理磁碟記憶體中的 ECal 使用者特性 對話方塊說明

使用此對話方塊可執行下列任一操作：

  • 將磁碟記憶體中的現有使用者特性儲存為 *.euc 檔案。

  • 載入先前已儲存的 *.euc 檔案以便用於 VNA 上指定的 ECal 模組。

瞭解有關儲存至磁碟記憶體的使用者特性的更多資訊。

ECal 模組 從清單中選取 ECal 模組，以便目前儲存於 VNA 磁碟記憶體中的使用者特性用於該模組。

另存為 將目前儲存於 VNA 磁碟記憶體中的使用者特性儲存為 *.euc 檔案。可將此檔案用作備份，以防止意外刪除封存檔案，或者允許將此檔案移動至另一個 VNA，以便用於所選取的 ECal 模組。

匯入 載入先前已儲存的 *.euc 檔案以便用於 VNA 上指定的 ECal 模組。

刪除 從 VNA 磁碟記憶體中刪除使用者特性。

還原 ECal 模組記憶體

將使用者特性資料寫入 ECal 模組中時，ECal 記憶體的整個內容（包括出廠 ECal 資料）也會寫入 VNA 硬碟中。若是 ECal 模組記憶體遺失，可將所有的 ECal 資料還原至 ECal 記憶體中。

注意：將 ECal 記憶體寫入 VNA 之後，如果執行新的出廠校準，新的出廠校準資料也會被覆寫。

附註：ECal 資料清除共用程式可依據 US DoD 5220.22-M 銷毀所有使用者資料。請造訪 http://na.tm.Keysight.com/pna/apps/applications.htm 以瞭解更多資訊。

如何還原 ECal 模組記憶體

使用硬鍵/SoftTab/軟鍵

  1. 按 [System] > Service（服務）> Restore Ecal Memory（還原 Ecal 記憶體）

此功能沒有可用的程式設計指令。

要還原的模組 對話方塊說明

請驗證要還原的模組的序號。如果兩個模組連接至 VNA，請選取要進行資料還原的那一個。

下一步 按一下以將資料寫入模組。

上次修改時間：

2014 年 09 月 08 日

第一版


使用 2 連接埠 ECal 模組執行 4 連接埠校準

使用一個 2 連接埠 ECal 模組執行 4 連接埠校準

您可以使用一個雙連接埠 ECal 模組執行四連接埠校正。如果所有 4 個 DUT 連接器的類型與性別都相同，那麼可僅使用 4 個連線即可執行校正，這與能夠使用四連接埠 ECal 模組建立的連線數量相同。

  • ECal 模組必須涵蓋量測的頻率範圍。

  • ECal 模組必須具備與 DUT 連接器相符的連接器。由於我們使用的是雙連接埠 ECal 模組，因此這意味著 DUT 必須僅具備兩種獨特的連接器類型與性別。如果 DUT 具備兩種以上的連接器類型/性別，則您可以使用智慧校正為每個連接埠選取不同的校正套件。

程序

  1. 將雙連接埠 ECal 模組連接到 VNA USB 連接埠。

  2. 依序按下校正、啟動校正與校正精靈

  3. 選取智慧校正或使用電子校正，然後按下一步。

  4. 選取四連接埠校正，然後按下一步以顯示以下對話方塊：

  5. 為每個連接埠選取 DUT 連接器。在此示例中，所有 4 個 DUT 連接器皆為 N 類型，陰性。

  6. 選取附加的 ECal 模組。我們使用的是 85092-60007 ECal 模組。

  7. 選取修改校正 (顯示 ECal 的進階設定)，然後按下一步以顯示以下對話方塊：

  8. 針對數量最少的實體連線，請選取預設連接埠指派。

    • 每個連接埠配對的第 1 個連接埠選擇是 1。

    • 針對單端（標準）量測，直通連線的數量至少為 3 個。針對平衡量測，必須建立 4 個直通連線。瞭解詳情。

    • 若要獲得更高精確度，請選取新增直通。校正精靈將新增另一個連接埠配對，如此可建立更多實體連線。

  9. 選取 ECal 直通做為未知。這是最為精確，也是最為簡單的直通校正方法。瞭解詳情。

  10. 在低功率級別上執行校正時，您可能需要清除執行定位。瞭解詳情。如此將會新增更多連線步驟。

  11. 依據提示完成校正：

    1. 將 ECal 連接到連接埠 1 和 2。按一下量測。

    2. 將 ECal 連接到連接埠 1 和 3。按一下量測。

    3. 將 ECal 連接到連接埠 1 和 4。按一下量測。

  12. 在指定延遲對話方塊中，按一下確定。這是針對 ECal 模組中的每個直通連線所量測出的延遲。瞭解詳情。

  13. 按一下另存為使用者校正集或完成。

上次修改時間：

2011 年 08 月 02 日

新主題


TRL 校準

TRL（直通、反射、線）是指量測兩個傳輸標準和一個反射標準，以確定 2　連接埠 12　項誤差係數的一系列校準技術。例如，TRM（直通、反射、匹配）、LRL（線、反射、線）、LRM（線、反射、匹配）均包含在這一系列校準技術中。

傳統的 SOLT 校準會量測一個傳輸標準 (T) 和三個反射標準 (SOL)，以確定相同的誤差係數。

  • 為何要執行 TRL 校準？

  • TRL 校準程序

  • TRL 校準套件

  • TRL 中使用的校準標準

  • 具有外部測試裝置的 TRL

請參閱其他校準主題

為何要執行 TRL 校準？

TRL 校準非常精確，在大多數情況下比 SOLT 校準更精確。不過，只有極少數校準套件包含 TRL 標準。如果要求高準確度，且在與 DUT 相同的接頭類型中沒有校準標準，則通常會執行 TRL 校準。當使用測試固定裝置，或是使用探針進行晶片量測時，通常也是如此。因此，在某些情況下，您必須在與受測裝置配置相同的媒體類型中建構並特性化標準。製造並特性化三個 TRL 標準，比製造並特性化四個 SOLT 標準來的容易。

TRL 校準的另一項優勢在於：TRL 標準的定義不必像 SOLT 標準一樣完整和精確。當 SOLT 標準完全特性化並儲存為標準定義時，TRL 標準會建模，但不會完全特性化。但是，TRL 校準準確度與 TRL 標準的品質和可重複性成正比。物理的不連續性（例如，傳輸線的彎曲及同軸結構中的圓珠）會降低 TRL 校準的品質。接頭必須保持清潔，並且可以重複連接。

若要深入瞭解校準標準的要求，請參閱 TRL 中使用的校準標準。

附註： 虛擬裝置描述校準期間的非物理（將兩個測試連接埠參考平面連接在一起）類型的連接。因此，在校準套件定義中，通常不應將多個具有相同成對接頭/性的直通標準定義為虛擬裝置。這可能會導致那些直通標準在校準期間被視為相同的物理連接步驟加以處理。特別是在 TRL 校準中，當直通標準和線路標準均量測為相同連接步驟時，這明顯是個問題。

TRL 校準程序

雖然可以使用校準精靈的非引導式校準選項來執行 TRL，但下列程序採用更簡便的智慧型校準選項。這兩種選項都會要求您已定義好 TRL 校準標準，並將其納入 VNA 校準套件中。

  1. 預設 VNA

  2. 設定量測和所需的激勵設定。

  3. 按一下 [Cal] > Other Cals（其他校準）> Smart Cal...（智慧型校準...） .

  4. 為每個連接埠選取受測裝置接頭和校準套件。每個連接埠配對的最小連接埠號必須包含 TRL 標準。TRL 顯示為校準方法。

  5. 勾選修改校準，然後根據需要檢視/修改以變更預設 TRL 選項。

  6. 依據提示完成校準。

  7. 檢查準確度（針對校準）。

TRL 校準套件

Keysight Technologies 提供兩個校準套件，其中包含執行 TRL 校準所需的標準：85050C (APC 7mm) 和 85052C (3.5mm)。這兩個套件均包含傳統的短路、開路和負載標準。（實際上並未提供直通標準，假定為零長度直通）。此外，這些套件包含了一條航線，可用作線標準。若要使用這條航線，套件必須包含航線本身、中心導體和插入/提取工具。APC 7 套件包含了配接器，可將航線連接到 APC 接頭。

TRL 中使用的校準標準

以下標準必須在 TRL 校準套件中定義：

直通

附註：TRL 校準支援所有直通校準方法，但未知直通除外。

  • 直通標準可以是零長度或非零長度。但是零長度直通更精確，因為根據定義，它的損耗為零且無反射。

  • 直通標準不能與線路標準具有相同的電氣長度。

  • 如果已妥善定義插入相位與電氣長度，則直通標準可用於設定參考平面。

  • 直通標準和線路標準的特性阻抗可定義校準的參考阻抗。

  • 如果具有正確接頭的直通標準不可用，則可執行配接器移除校準。

REFLECT（反射）

  • 只要連接到兩個 VNA 連接埠時相同，反射標準可以是具有高反射的任何物件。

  • 不需要知道實際反射幅度。

  • 反射標準的相位必須已知在 1/4 波長範圍內。

  • 如果已妥善定義反射標準的幅度和相位，則此標準可用於設定參考平面。

LINE（線路）

在校準完成之後，線路標準和直通標準會為量測建立參考阻抗。 TRL 校準受限於下列線路標準的限制：

  • 必須採用與直通標準相同的阻抗和傳遞常數。

  • 電氣長度僅需在 1/4 波長範圍內指定。

  • 長度不能與直通標準相同。

  • 涵蓋廣泛頻率範圍的 TRL 校準需要多個線標準。例如，從 2 GHz 到 26 GHz 的跨距需要兩種線標準。

  • 必須是頻率範圍的適當電氣長度：在每個頻率中，直通和線之間的相位差應大於 20 度並小於 160 度。這表示在實際應用中，單一線標準僅能用於 8:1 頻率範圍（頻率跨距/開始頻率）。因此，對於廣泛的頻率涵蓋範圍，需要多個線路標準。

  • 在低頻率中，線路標準對於實際使用而言可能會太長。線路標準的最佳長度是頻率跨距為幾何均值（f1 x f2 的平方根）時的 1/4 波長。

附註：TRL 線路標準必須具有大於 0（零）ps 的延遲。否則，校準修正計算將包含不可預期的結果。

MATCH（匹配）

如果不能設計具有適當長度或損耗的線標準，則可能使用匹配標準，而非線標準。

  • 匹配標準是一個同時連接到連接埠 1 和連接埠 2 的低反射終端。

  • 匹配標準可定義為無限長度傳輸線或 1 連接埠低反射終端（例如，負載）。

  • 當定義為無限長度傳輸線時，匹配標準必須在相同的時間終止這兩個測試連接埠。當定義為 1 連接埠負載標準時，將分別量測各個負載。負載會假設為具有相同的特性。

  • 匹配標準的阻抗會成為量測的參考阻抗。若要獲得最佳結果，請在這兩個連接埠上使用相同的負載。您可以使用資料式定義、任意阻抗定義或固定負載定義來定義負載。

另請參閱

  • 如需有關建立和修改校準套件定義的詳細資訊，請參閱修改校準套件。

具有外部測試裝置的 TRL

TRL 可在啟用外部測試裝置的情況下執行。以前，TRL 校準要求 VNA，每個測試連接埠對應一個參考接收器。使用新的 TRL 方法之後，將會先執行並套用差值匹配校準。

附註：請參閱差值匹配校準，以瞭解哪些型號需要採用這種新方法。

此 TRL 校準的準確度，絕大部分取決於差值匹配校準的準確度。使用精確的差值匹配校準時，傳統的 TRL 校準與此 TRL 校準之間的準確度差異可以忽略不計。

如何在這些情況下執行 TRL 校準

  1. 按一下 [Cal] > Other Cals（其他校準）> Smart Cal...（智慧型校準...） .

  2. 為要校準的連接埠選取 TRL 校準套件。

  3. 在校準期間，校準精靈會提示您執行有效的差值匹配校準。

上次修改時間：

2014 年 09 月 02 日

第一版


功率校準

來源功率校準和接收器功率校準共同工作，可提供極為精確的來源功率位準與 VNA 接收器功率量測。

  • 來源功率校準概觀

  • 支援的功率表和感應器

  • 如何執行來源功率校準

  • 設定

  • 來源功率校準對話方塊

  • 儲存來源功率校準

  • 減少完成來源功率校準所需的時間

  • 接收器功率校準

  • 儲存接收器校準

其他來源功率校準選擇

  • 引導式功率校準可以在 S 參數引導式校準過程中執行。瞭解詳情。

  • 接收器位準調整可以用於提供「即時」來源功率校準。瞭解詳細資訊。

  • 另請參閱：將功率表設定為接收器 (PMAR)

請參閱其他校準主題

來源功率校準概觀

如果需要 VNA 測試連接埠之間的量測路徑中某一點的精準功率位準，請執行來源功率校準。例如，您需要特性化放大器在某個頻率範圍內、在指定輸入功率下的增益。您要以放大器的輸入值進行來源功率校準，以確保放大器在頻率範圍內的功率位準是準確無誤的。

若使用來源功率校準，則校準點的功率預期在所使用的功率表和感應器的不確定性範圍內。

來源功率校準...

  • 不受量測類型的制約。無論量測中所用接收器為何，均會修正 VNA 來源。因此，它可在比例量測或非比例量測中使用。

  • 只適用於針對選定通道進行的量測，這些通道使用指定為校準來源的測試連接埠。例如，您指定通道 1 和連接埠 1 為校準的來源，則僅會修正通道 1 上使用連接埠 1 用作來源的量測。

  • 可以與其他量測校準共同使用，例如全 2 連接埠校準。為取得最高的準確度，請先執行來源校準，再執行量測校準。

  • 可以與功率掃描類型一起使用。來源功率校準將在功率掃描過程中修正所有功率位準上的功率。

  • 可以與非耦合連接埠功率一起使用。

  • 對於已開啟來源功率修正的量測，強制進入步進掃描模式。

  • 使用來源功率校準可以對外部來源進行校準。

運作方式概觀：

請參閱首次 USB 連接重要注意事項。

按一下可查看詳細程序

  1. 指定量測設定（頻率範圍、IFBW 等）。

  2. 開始來源功率校準。

附註： 使用 848X 功率感應器（無內建校準因數的感應器）時，請使用功率感應器設定對話方塊輸入校準因數，因為 VNA 會指示功率表不使用功率表內置的校準因數表。

  3. 將功率表感應器連接到希望瞭解功率位準的位置。這個位置可能是裝置的輸入點或輸出點，或者是測試連接埠之間的某個其他點。

  4. VNA 來源步進調試指定頻率範圍，功率是採用功率表測得。在每個資料點上，來源功率經過調整，直至測得的功率位於指定的準確度層級範圍內。

  5. 完成後，功率表便已經過預設。來源功率校準可以作為儀器狀態的一部分加以儲存。

  6. 將移除功率表並重新連接量測路徑。

  7. 校準會自動套用於通道。通道上使用該來源連接埠的所有量測將從來源功率校準中受益。

  8. 先執行來源功率校準，再執行 S 參數校準。S 參數校準是透過使用相關連接埠的修正激勵功率位準執行的。

使用下列程序驗證來源功率校準。

  1. 按照進行來源功率校準的方式連接功率表。

  2. 將 VNA 設定為點觸發模式。

  3. 在軌跡中觸發 VNA。讀取關於掃描指示器行為的內容。

  4. 在各個資料點上，功率表應該讀出指定公差範圍內的經修正功率位準。

支援的功率表和感應器

請查看 Keysight 功率表與感應器網頁。

USB 功率感應器

  • U848x 系列 USB 熱電偶功率感應器

    • 包括以下型號：U8481A、U8485A、U8487A、U8488A

  • U2020 X 系列 USB 峰值與平均功率感應器。

    • 包括以下型號：U2021XA、U2022XA

    • 在這些感應器中，VNA 不支援峰值模式，但是可以量測平均功率。

  • U2000 系列 USB 功率感應器。

    • 包括以下型號：U2000A、U2000B、U2000H、U2001A、U2001B、U2001H、U2002A、U2002H、U2004A

USB 附註：

  • 依據標準功率校準（本主題），只可以使用一個 USB 功率感應器來覆蓋整個頻率跨距。若要使用多個功率感應器，請執行引導式功率校準。瞭解操作方法。

  • 若要為標準功率校準選取 USB 功率感應器：

    1. 請將感應器直接連接到其中一個 VNA USB 連接埠。

    2. 從來源功率校準對話方塊中，按一下功率表組態。

    3. 在功率表設定對話方塊中，選取 USB。

  • 請參閱首次連接 USB 的重要附註。

  • 請參閱關於 USB 功率感應器歸零的附註。

  • 另請參閱：功率表作為接收器 (PMAR)

功率表

  • P 系列功率表 (N1911A、N1912A、N1921A、N1922A) 和所有支援的感應器。

  • EPM 系列功率表 (N1913A 與 N1914A) 和所有支援的感應器。

  • EPM-P 系列功率表 (E4416A 與 E4417A) 和所有支援的感應器。

  • EPM-441A 和 EPM-442A 系列功率表和所有支援的感應器。

  • E 系列功率表 (E4412A、E4413A、E4418A、E4418B、E4419A、E4419B、E9300A、E9301A、E9304A、E9304A-H18、E9304A-H20、E9300H、E9304A-H19、E9301H、E9300B 及 E9301B) 和所有支援的感應器。

  • HP 437B/438A 功率表。

  • ECP-E18A 功率表。

  • 8482A 功率表。

功率表附註：

  • N1911A、12A、13A 及 14A 功率表配備有裝置端 USB 接頭 [image] ，這些功率表與 USB 感應器完全一樣，由 VNA 進行控制。請參閱 USB 功率感應器（如上所述）。 雖然這些功率表可能配備有正面 USB 連接埠，但是 USB 功率感應器必須直接與其中一個 VNA USB 連接埠連接。

  • 使用 Keysight E930x 和 E932x 功率感應器時，來源功率校準運作較慢。

  • 某些 Keysight 功率表包含一種模式，可以模擬 437B 或 438A 功率表的指令集。VNA 不支援這種模擬模式。

  • 82357B USB/GPIB 介面可用於控制功率表。

  • 建立自訂功率表驅動程式，可與其他功率表搭配使用。

如何執行來源功率校準

附註： 引導式功率校準可以在 S 參數引導式校準過程中執行。瞭解詳情。

  1. 設定量測（掃描類型、頻率範圍、IFBW 等）。依預設，將在作用中量測的來源連接埠上執行來源功率校準。

  2. 依下圖所示，將同軸纜線、GPIB 纜線和功率感應器連接到 VNA。

此影像不適用於直接連接到 VNA USB 連接埠的 USB 功率感應器。

請參閱首次 USB 連接重要注意事項。

  3. 接通功率表電源，預留 30 分鐘預熱時間，然後開始校準。

  4. 選取來源功率校準，如下所示：

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Other Cals（其他校準）> Source Power Cal...（來源功率校準...）。

  5. 視需要完成「來源功率校準」對話方塊（下文），包括選項、損耗補償和功率感應器設定。

附註： 使用 Keysight 848X 功率感應器（無內建校準因數的感應器）時，請使用功率感應器設定對話方塊輸入校準因數，因為 VNA 會指示功率表不使用功率表內置的校準因數表。

  6. 完成時，按一下「來源功率校準」對話方塊中的執行校準掃描。

  7. 根據需要，按照提示連接感應器。

  8. 此時，可以變更來源連接埠設定，並在其他連接埠上執行來源功率校準。

  9. 校準完成後，按一下確定。然後，會對作用中通道上的相關連接埠套用並開啟修正。

  10. 移除感應器。

  11. 當來源功率修正套用至作用中量測時，狀態列中會顯示 SrcPwrCal。

  12. 執行 S 參數校準，此類校準將會對相關連接埠使用修正後的激勵功率位準。

若要關閉來源功率修正：

  • 按 [Cal] > Other Cals（其他校準）> Source Power Cal...（來源功率校準...），然後將其關閉。

  • 僅會關閉作用中量測的來源連接埠修正（無論連接埠功率耦合設定為何。）

內插或外推

如果原始激勵設定發生變更，則會套用內插或外推，且狀態列中會顯示 SrcPwrCal*。這不同於量測校準內插。例如，頻率跨距增加後，VNA 將外推新的修正值，而不是關閉修正。這是為了防止來源向測試裝置提供過高功率。如果原始設定已還原，則來源功率校準會返回到完整修正。

來源功率校準對話方塊說明

附註： 請確保功率感應器的頻率範圍覆蓋量測的頻率範圍。這不會自動發生。

功率

校準功率 在校準點上計算得出的功率（單位為 dBm）。該值是指定的 VNA 來源功率與功率偏移值之和。

功率偏移 讓您可以指定增益或損耗（單位為 dBm），藉此說明在量測的來源和參考平面之間連接的元件。這些元件在量測期間將保持不變。例如，指定 10 dB 來表示受測裝置路徑中存在 10 dB 放大器。校準之後，VNA 功率讀數會調整為該值。

考慮到元件在校準完成後將被移除，請使用損耗補償表。

通道與連接埠選取

通道 指定要在其上執行校準的通道。該設定預設為作用中的通道。

來源連接埠 指定要修正的來源連接埠。該設定預設為作用中量測的來源連接埠。

準確度

在各個資料點上，功率皆使用指定的功率表調整公差測得，然後對其進行調整，直到讀數位於準確度公差範圍內，或達到讀值的最大數目。最新功率讀數將在螢幕上依據公差限制線加以繪製。

公差 將指定校準功率位準所需的最大偏移從 0 設為 5 dB（以 0.005 dB 為增量）。

讀值的最大數目 設定要在每個資料點上取得的最大讀數數目，用於重複來源功率。輸入一個介於 1 和 1000 之間的值。

校準狀態

讓您可以開啟或關閉來源功率校準，並檢視每個連接埠的校準資料，而無論作用中量測為何。這項功能讓您可以校準並開啟或關閉內部第二來源，即使在量測中作為附帶來源使用（例如 LO）也是如此。

校準開啟 核取以對指定的來源連接埠開啟來源功率校準。

顯示的文字表示對校準套用內插的時機。

按鈕

選項 叫用來源功率校準選項對話方塊。按鈕左側的標籤顯示目前的「選項」設定。

功率表組態 叫用功率表設定對話方塊

執行校準掃描 開始來源功率校準量測。

確定 套用校準。除非按下「執行校準掃描」，否則此按鈕處於停用狀態。

取消 如果掃描在進行中，可以取消掃描。再按一次可以關閉對話方塊。

附註：功率表在 200 r/s 模式中運作。

量測過程中，某些功率表可能在螢幕上顯示這條訊息：這表示，功率表在以每秒 200 個讀數的模式運作，這是這台功率表最快的速度設定。這是正常運作情況。

通過/失敗限制

將在「來源功率校準」量測網格區域中繪製限制線。這些限制線代表「校準功率」+/-「準確度公差」的目前設定。 如果來源功率校準掃描過程中顯示「失敗」，表示 VNA 無法在準確度公差範圍內量測功率。嚴格的公差更難於在較低的校準功率位準實現。當顯示「失敗」指示時，請增加「讀值的最大數目」。如果這並未導致「通過」條件出現，則降低準確度公差值。

另請參閱

  • 詳細瞭解來源功率校準

  • 瞭解外部測試集和來源功率校準。

來源功率校準選項對話方塊說明

提供用於來源功率量測的選項。

附註：在低功率位準（小於 -30 dBm）狀態下，大多數功率表的準確度不及 VNA 接收器。

校準參考 選擇要用於量測功率的功率表或 VNA 接收器。

  • 使用功率表。 傳統來源功率校準僅使用功率表量測各個資料點的來源功率。這種方法最準確（當功率位準較高時），但是速度最慢。

附註：因為下列兩種設定均使用 VNA 接收器進行功率量測，當使用頻率偏移值時，它們無法正常工作。

  • 使用一次功率表，然後使用 VNA 參考接收器。 核取後，每個資料點的第一個讀數使用功率表來校準參考接收器。後續的讀數，如果需要因應準確度要求，可以使用參考接收器進行量測。使用這種方法量測低功率位準，比使用功率表速度更快，準確度更高。

附註：如果在功率感應器之前有表現出非線性行為的元件，例如在壓縮中使用的功率放大器，則請勿使用此設定。 使用功率表並且在多個功率位準下校準來源。

  • 使用接收器。 選擇一個 VNA 接收器或一個 PMAR（功率表作為接收器）。

VNA 接收器 - F 或最高準確度，首先進行接收器校準，方法是使用功率表進行來源功率校準，然後進行接收器校準。該接收器之後可以用於快速校準其他 VNA 來源連接埠，或者用於具有不同激勵設定的其他通道。當量測的功率位準低於功率感應器的靈敏度時，這會非常有用。使用來源功率校準，對感應器靈敏度範圍內的 VNA 接收器進行校準。然後，使用校準後的接收器在降低的功率位準執行第二次來源功率校準。

    • 使用標準接收器標記法或邏輯接收器標記法來指定 VNA 接收器。

    • 最好對要校準的來源連接埠使用參考接收器。例如，若校準來源連接埠 2，請指定「R2」或「a2」，這與使用邏輯接收器標記法的連接埠 2 參考接收器相同。

    • 為確保來源功率校準結果準確無誤，校準接收器的頻率範圍必須等於或大於「僅限接收器」的來源功率校準。

    • 所有準確度和穩定公差以及讀數設定的數目，只在進行功率表讀數時套用。

PMAR 裝置 - 功率表/感應器必須先進行設定。瞭解如何設定 PMAR 裝置。

  • 使用功率表和 VNA 參考接收器 用於透過公釐波長測試裝置和模組調整功率位準。瞭解詳情。

在多個功率位準下校準來源 主要用於公釐波長測。

當來源路徑中使用的元件（例如，助推器放大器）沒有隨著頻率的變化出現線性增益或損耗時，此功能還可以用於標準 VNA 量測。 如果這不適用於您的設定，但是您希望改善來源功率的準確度，請考慮使用接收器位準調整功能。

核取後，來源功率使用指定的「校準參考」裝置（功率表/感應器或 VNA 接收器）進行量測，並以掃描到掃描的方式重複，以構建 2 維功率表：功率輸入，功率輸出，覆蓋所有頻率。

  • 按一下功率位準以啟動「來源校準功率位準」對話方塊，設定要量測的來源功率的功率位準。

  • 來源功率校準已儲存，但是無法存取功率表。

校準 VNA 參考接收器 核取以將適當的參考接收器校準為在校準平面上量測出的功率位準。使用校準後的參考接收器進行此操作，可以獲得十分準確的量測結果。除了使用上述所示的任何一種方法進行標準來源功率校準之外，還可以執行此校準。來源功率校準量測掃描結束時，您可以選擇將參考接收器校準儲存到校準集中，以便稍後重新叫用。按一下確定按鈕即可儲存校準並關閉「來源功率校準」對話方塊。

來源校準功率位準對話方塊說明

當您按一下「來源功率校準選項」對話方塊上的功率位準時，會顯示此對話方塊。

請指定要校準來源功率的功率位準。這些值應該設定為比量測功率位準略高或略低若干 dB。

最大功率 - 要校準的最高功率位準。該值應該比量測的最高功率位準略高若干 dB。

最小功率 - 要校準的最低功率位準。 該值應該比量測的最低功率位準略低若干 dB。

功率步進 - 在「最大功率」和「最小功率」設定之間的每個增量功率位準上進行校準。

功率表設定對話方塊說明

按一下多個對話方塊中的功率表設定按鈕是時，即可顯示此對話方塊。

介面

  • GPIB/位址 選取 GPIB 功率表。然後選取功率表的位址。預設為 13。VNA 將搜尋在 VNA 上的 Keysight IO 函數庫中設定的 VISA 介面。附註： 使用 82357B USB/GPIB 介面時，請使用此選擇。

  • USB VNA 會掃描 USB 功率感應器或 N191x 裝置端 USB 功率表。請從清單中選取一個功率感應器。僅可將一個 USB 功率感應器設定為覆蓋整個校準頻率範圍。 若要使用多個功率感應器，請執行引導式功率校準。

  • LAN 指定功率表的主機名稱或 IP 位址。

  • 任意 供將來使用。

感應器 叫用功率感應器設定對話方塊。

穩定

當 VNA 接收器作為功率量測裝置時，不會套用這些穩定設定。在下列任一情況中時，每一個功率表都是「穩定的」：

  • 兩個連續表讀數在公差值範圍內或

  • 滿足讀值的最大數目要求時。

將針對讀取的讀值計算平均值，使其成為「穩定的」讀值。穩定讀數之後會與「來源功率校準」對話方塊中指定的準確度公差要求（公差與最大讀數）進行比較。

公差 如果連續功率表讀值在彼此的該值範圍內，則將該讀值視作穩定值。

讀值的最大數目 設定功率表實現趨穩所需讀值的最大數目。

感應器損耗補償

使用損耗表 選取此核取方塊後，可將損耗資料套用至來源功率校準修正（例如，對於功率感應器上的配接器）。

編輯表 叫用功率損耗補償對話方塊。

功率損耗補償對話方塊說明

請參閱「功率損耗補償」對話方塊說明。

功率感應器設定對話方塊說明

請參閱功率感應器設定對話方塊

儲存來源功率校準

由於來源功率校準的校準對象是來源硬體，所以校準資料將作為儀器狀態的一部分儲存在 .csa 或 .cst 檔案中。這項修正套用於使用校準後來源之通道中的所有量測。請參閱儲存儀器狀態。

減少完成來源功率校準所需的時間

執行來源功率校準需要的時間視乎採用的來源功率、點數和所取得的讀數數目而定。使用以下方法可以減少量測時間：

  • 在校準之前減少點數。 您可以在量測前減少點數，然後在校準完成後且修正為開啟狀態時，將點數返回到原始值。分析器將執行線性內插，儘管會損失一些準確度。

  • 使用 Keysight E 系列感應器。 在 VNA 上使用這種感應器，透過 GPIB 每秒可以獲得 40 多個讀數。

  • 增加感應器的功率。 降低功率可能會延長某些感應器的穩定時間。

  • 請核取使用參考接收器進行重複。

接收器功率校準

附註：引導式功率校準可以在 S 參數引導式校準過程中執行。瞭解詳情。

接收器功率校準將以數學運算方式準確消除指定 VNA 接收器中的頻率回應誤差，並將讀數調整為與來源功率校準位準級別相同的值或偏移值。這與進行回應校準或資料/記憶體（正常化）相同，但是資料會轉變為校準功率值。

使用接收器功率校準進行十分準確的絕對功率（幅度）量測。

接收器功率校準：

  • 只有在進行絕對功率（非等比）量測時才允許使用。

  • 如果先執行來源功率校準，則該校準準確度最高。

  • 適用於在作用中通道中使用該接收器的所有非等比量測。

  • 可以儲存在校準集中，之後重新套用到類似的量測。

內插

與其他校準類型類似，如果原始激勵設定變窄，則會套用內插，且狀態列中會顯示 C*。如果將原始激勵設定變寬，則 VNA 將關閉接收器功率修正。

如果原始設定已還原，則接收器功率校準會返回到完整修正。

如何執行接收器功率校準

  1. 執行來源功率校準。

  2. 將作用中量測設定為非等比。瞭解操作方法。

  3. 將直通線路從來源連接埠連接到接收器連接埠。

  • 當對參考接收器（來源 1 和接收器 R1）執行接收器功率校準時，不需要進行任何連接，因為接收器內部已連接到來源。

  • 當來源連接埠和接收器連接埠相同時（接收器 A、來源連接埠 1），則會連接開路或短路，讓接收器獲得最大功率。不推薦這種做法。最好對來源和接收器使用不同的連接埠。

  4. 確保為來源功率校準開啟修正，如狀態列中的 Src Pwr Cal 或 Src Pwr Cal* 所示。

  5. 啟動校準精靈

使用硬鍵/SoftTab/軟鍵

  1. 將作用中量測設定為非等比。瞭解操作方法。

  2. 按 [Cal] > Other Cals（其他校準）> Receiver Power Cal...（接收器功率校準...）。

選取進行非等比量測的校準類型對話方塊說明

校準類型選取 選取接收器功率

接收器功率設定

校準功率 指定完成時量測中要顯示的功率位準。（來源連接埠功率 + 功率偏移）。

來源連接埠功率 針對量測設定的測試連接埠功率。 瞭解如何變更測試連接埠功率

功率偏移 讓您可以在執行來源功率校準後，指定增益或損耗（單位為 dBm），藉此說明在量測的來源和參考平面之間連接的元件。校準之後，VNA 功率讀數會調整為校準功率值。

下一步 按一下以繼續執行校準精靈。

備註：

  • 當完成接收器功率校準後，「回應」將顯示在狀態列中，修正資料將套用到後續的掃描。這樣做的原因是，在儲存並套用接收器功率校準後，他們其實就變成回應校準。請參閱下方的「儲存接收器功率校準」。

  • 若要將修正關閉，請按一下 [Cal]> Main（主值）> Correction（修正）> Channel Correction OFF（通道修正關閉）。

瞭解有關接收器功率校準的詳細資訊（向上捲動）。

儲存接收器功率校準

接收器功率校準將儲存到校準寄存器中，也可以儲存到使用者校準集。可以採用與其他校準類型相同的方式，將其套用到量測。之前，接收器功率校準資料儲存為儀器狀態的一部分，而且只套用到其所執行的量測。

瞭解有關儲存 VNA 檔案類型的詳細資訊。

上次修改時間：

2016 年 01 月 06 日

第一版


固定裝置模擬器

使用下列功能可讓您在 VNA 量測中以數學運算方式新增（嵌入）或移除（解除嵌入）電路。可將數學模型套用至通道上所有量測的特定連接埠。

附註

  • 可以使用下列功能

    • 連接埠延伸

    • 2 連接埠解除嵌入

    • 連接埠匹配

    • 連接埠 Z 轉換

  • 所有其他固定裝置功能僅在標準類別中可用。

  • 啟用固定裝置時，在儲存 snp 檔案時將套用所有啟用的固定裝置功能。

另請參閱

  • 程序： 要嵌入還是要解除嵌入？

  • 特性化配接器巨集可用於從校準集建立 S2P 檔案。

  • 如需固定裝置模擬的詳細概念性資訊，請參閱「使用向量網路分析器解除嵌入和嵌入 S 參數網路」應用附註。

  • 查看範例，瞭解如何使用這些功能解除嵌入測試固定裝置的不必要效應，然後以數學運算方式將受測裝置嵌入在其中使用它的電路。

固定裝置操作的順序

首先，按照此順序處理下列單極量測功能：

  1. 連接埠延伸

  2. 2 連接埠解除嵌入

  3. 連接埠匹配電路嵌入

  4. 連接埠 Z（阻抗）轉換

  5. 4/6/8 連接埠網路（單極）嵌入/解除嵌入

然後，以此順序處理平衡量測功能：

  6. 平衡轉換

  7. 差分/共模連接埠 Z 轉換

  8. 差分匹配電路嵌入

  • 然後選擇套用來源功率補償來補償透過所有啟用的固定裝置操作彙總的損耗。

附註

  • 固定裝置操作可套用至量測結果。

  • 可使用 SCPI 指令變更操作 1 到 4 的順序： CALC:FSIM:SEND:OORD.可從 GPIB 指令處理器主控台瞭解如何傳送此指令。

  • 無法變更操作 5 到 8 的順序。

  • 在 VNA 資料處理鏈中，固定裝置模擬器功能與套用誤差項區塊同時發生。

如何選取固定裝置模擬器

關於固定裝置模擬器開啟/關閉

必須執行下列兩項操作才可開啟固定裝置選擇。

  1. 開啟 Apply Fixtures（套用固定裝置）
    連接埠延伸不受固定裝置開啟/關閉的影響。

  2. 勾選個別固定裝置選擇對話方塊中的啟用。

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal ]> Fixture Match（固定裝置匹配）> Apply Fixtures（套用固定裝置）

或

  1. 按 [Cal ]> Fixtures（固定裝置）> Apply Fixtures（套用固定裝置）

連接埠匹配對話方塊說明

此功能可指定要嵌入（新增）至量測結果的電路。 請參閱「固定裝置操作的順序」。

啟用連接埠匹配 勾選該方塊以將設定套用至量測結果。必須同時啟用 固定裝置開啟/關閉 。

連接埠 - 選取要套用模擬的連接埠。

匹配的電路模型 - 選擇其中一種電路模型以在所選的 VNA 連接埠上模擬固定裝置：

使用者 S2P 檔案 按一下以指定要在所選連接埠上嵌入的電路模型 S2P 檔案。如果所重新叫用的使用者 .S2P 檔案中標準化阻抗值與 VNA 的連接埠參考阻抗設定不同，則將使用 VNA 設定。 特性化配接器巨集可用於從校準集建立 S2P 檔案。

電路值

用作建立固定裝置模型之電路類型的特定元件的電容 (C)、電感 (L)、電阻 (R)、導電性 (G) 值。

重設 還原預設值。

2 連接埠解除嵌入對話方塊說明

已執行校準，並在之後新增固定裝置（配接器、衰減器、較長的纜線等）以連接校準參考平面和您的受測裝置後，可執行解除嵌入。 此功能可從量測結果移除元件或測試固定裝置的影響。

附註：對損耗超過 20 dB 的元件執行解除嵌入並不現實，因為無法透過此裝置準確量測受測裝置的匹配值。

解除嵌入操作會重新叫用 .s2p 檔案（Touchstone 格式），該檔案包含 2 連接埠固定裝置或裝置的電氣特性。該檔案可使用任何標準格式（實數-虛數、幅度-角度、dB-角度）。

啟用解除嵌入 勾選該方塊以將設定套用至量測結果。同時必須啟用固定裝置開啟/關閉。

啟用外推 勾選該方塊後，可在 S2P 檔案的頻率範圍比通道窄時套用簡單外推。第一個和最後一個資料點的值將以任一方向延伸，以覆蓋量測的頻率範圍。通道和 S2P 檔案的頻率範圍均顯示在對話方塊底部。

外推為必要且已啟用時，系統將顯示訊息，說明要外推的頻率範圍。外推為必要但已停用時，系統將顯示訊息，提示啟用外推。

藉由此設定也可啟用和停用 4/6/8 連接埠外推。

連接埠 套用所重新叫用之解除嵌入檔案的 VNA 連接埠。

從下拉式功能表中選取使用者定義的（S2P 檔案）。

逆向配接器連接埠 勾選該方塊以將配置在連接埠 2 的固定裝置/配接器連接至 VNA，將連接埠 1 連接至受測裝置。對話方塊中的影像反映該變更。

使用者 S2P 檔案 按一下以指定現有 .S2P 檔案。如果所重新叫用的使用者 .S2P 檔案中標準化阻抗值與 VNA 的連接埠參考阻抗設定不同，則將使用 VNA 設定。 特性化配接器巨集可用於從校準集建立 S2P 檔案。

連接埠 Z（阻抗）轉換對話方塊說明

附註：此功能適用於下列 SMC 和標準（S 參數）通道。

此功能可修正量測並顯示結果，就好像已經將量測轉換為指定的阻抗值一樣。不過，實體連接埠終端仍然約為 50 ohms。

指定的阻抗值僅適用於作用中通道上的所有量測。

請參閱「固定裝置操作的順序」。

啟用連接埠 Z 轉換 勾選該方塊以將設定套用至量測結果。同時必須啟用固定裝置開啟/關閉。

R 阻抗值的實數部分。

jX 阻抗值的虛數部分。

關閉 套用輸入的內容並關閉對話方塊

附註： 連接埠 Z（阻抗）轉換以下列優先順序使用值：

  1. 平衡（差分或共模）- 如果啟用，則始終使用這些值。

  2. 單一連接埠阻抗 - 如果啟用，則在未啟用「平衡」時使用此值。

  3. 系統阻抗 - 如果平衡和單一連接埠都未啟用，則使用此值。

4/6/8 連接埠嵌入/解除嵌入對話方塊說明

此功能指定要在量測結果中嵌入（新增）或解除嵌入（移除）的單極 4/6/8 連接埠電路（*.SnP 檔案）。運算在平衡轉換之前進行。請參閱「固定裝置操作的順序」。

在 *.SnP 檔案中，每一個連接埠都有一個標準化阻抗值。此阻抗值必須與先前連接埠 Z 設定的阻抗或 VNA 連接埠阻抗匹配。

如果讀取的資料點數目與目前 VNA 設定的不同，則 VNA 將插入。

啟用 4/6/8 連接埠嵌入/解除嵌入 勾選該方塊以將設定套用至量測結果。同時必須啟用固定裝置開啟/關閉。

啟用外推 勾選該方塊後，可在 SnP 檔案的頻率範圍比通道窄時套用簡單外推。第一個和最後一個資料點的值將以任一方向延伸，以覆蓋量測的頻率範圍。通道和 SnP 檔案的頻率範圍均顯示在對話方塊底部。

外推為必要且已啟用時，系統將顯示訊息，說明要外推的頻率範圍。外推為必要但已停用時，系統將顯示訊息，提示啟用外推。

藉由此設定也可啟用和停用 2 連接埠外推。

拓撲

選取受測裝置拓撲。請參考「4/6/8 連接埠嵌入/解除嵌入」對話方塊中的影像。

  • A - 網路 1

  • B - 網路 1/3

  • C - 網路 1/2/4

NA 連接埠 - 選取連接至每一個電路連接埠的 VNA 連接埠。

網路連接埠 選取表示 *.S4P、*.S6P 或 *.S8P 檔案組態的網路連接埠。

無、嵌入、解除嵌入 對於網路 1 和網路 2，請選取：

  • 無 - 與停用相同。

  • 嵌入 - 將指定的網路電路新增至量測結果。請參閱 2 連接埠嵌入影像。

  • 解除嵌入 - 從量測結果中移除指定的網路電路。請參閱 2 連接埠解除嵌入影像。

瀏覽 對於所有網路選項 - 網路 1、網路 2、網路 3 和網路 4，導覽以尋找要嵌入或解除嵌入的 .*S4P 檔案。

確定 套用變更並關閉對話方塊。

取消 不套用變更並關閉對話方塊。

差分阻抗轉換對話方塊說明

此功能為每一個平衡連接埠設定差分阻抗值。

R: 的預設值是構成邏輯連接埠的兩個連接埠之阻抗值的總和。如果未啟用連接埠 Z 轉換，則將兩個連接埠的系統 Z0 值相加。

請參閱「固定裝置操作的順序」。

啟用差分 Z 轉換 勾選該方塊以將設定套用至量測結果。同時必須啟用固定裝置開啟/關閉。

邏輯連接埠 選取要接收阻抗值的邏輯（平衡）連接埠。若要查看邏輯連接埠號碼，請參閱量測拓撲。

R 阻抗值的實數部分。

jX 阻抗值的虛數部分。

關閉 關閉對話方塊。

請查看有關連接埠阻抗優先順序的附註。

共模阻抗轉換對話方塊說明

此功能為每一個平衡連接埠設定共模阻抗值。

R: 的預設值計算方法如下：

(Z1 * Z2) / (Z1 + Z2)

其中連接埠 1 和 2 組成邏輯連接埠：

Z1 = 連接埠 1 的連接埠阻抗值

Z2 = 連接埠 2 的連接埠阻抗值

如果未啟用連接埠 Z 轉換，則在計算中使用連接埠 1 和 2 的系統 Z0 值。

請參閱「固定裝置操作的順序」。

啟用共模 Z 轉換 勾選該方塊以將設定套用至量測結果。同時必須啟用固定裝置開啟/關閉。

邏輯連接埠 選取要接收阻抗值的邏輯（平衡）連接埠。若要查看邏輯連接埠號碼，請參閱量測拓撲。

R 阻抗值的實數部分。

jX 阻抗值的虛數部分。

關閉 關閉對話方塊。

請查看有關連接埠阻抗優先順序的附註。

差分連接埠匹配對話方塊說明

此功能允許在一個平衡連接埠上嵌入差分匹配電路。

請參閱「固定裝置操作的順序」。

啟用差分連接埠匹配 勾選該方塊以將所選匹配電路嵌入至量測結果。同時必須啟用固定裝置開啟/關閉。

邏輯連接埠 選擇要接收所選匹配電路的邏輯受測裝置連接埠。若要查看邏輯連接埠號碼，請參閱量測拓撲。

選取電路 選取匹配電路。選擇範圍：

  • 並聯 L - 並聯 C 預先定義的電路。

電路值 選擇範圍：

    • C 電容值

    • G 電導值

    • L 電感值

    • R 電阻值

  • 使用者定義 選取表示匹配電路的 *.S2P 檔案。然後按一下瀏覽導覽至 *.S2P 檔案。

附註： 對於 *.S2P 檔案：
假定電路的連接埠 1 連接至 VNA
假定電路的連接埠 2 連接至受測裝置。

  • 無 所選連接埠上沒有嵌入的電路。

關閉 關閉對話方塊。

功率補償對話方塊說明

此功能可調整指定連接埠上的來源功率，以補償透過所有啟用固定裝置操作所導致之增益或損耗的總和。使用此功能設定受測裝置輸入的功率位準。

例如：

  • 您的受測裝置需要輸入連接埠上的固定裝置，且該連接埠連接至 VNA 連接埠 1。

  • 固定裝置說明（例如位於 2 連接埠解除嵌入功能的 S2P 檔案）表示固定裝置在整個頻率跨距上的損耗大約為 2 dB。

  • 您將來源功率設定為 0 dBm。但希望受測裝置輸入（固定裝置輸出）的功率為 0 dBm。

  • 勾選連接埠 1 上的功率補償並啟用固定裝置。

  • 功率補償會使來源功率增加約 2 dB，藉此將固定裝置輸出平面的功率維持在 0 dBm。

功率補償會影響通道中的所有量測。

啟用固定裝置以使用功率補償。

附註：套用功率補償時請謹慎。 始終在沒有受測裝置的地方測試您的設定。如果您要使用 S2P 檔案，請將您的 S2P 檔案重新叫用至 VNA 中，以便確認 S2P 檔案所說明的裝置是否是您想要的裝置。如果 S2P 檔案中的資料是手動構成的，則 很容易會使資料出錯。

固定裝置模擬器範例

下列範例顯示受測裝置和匹配電路，將在該電路使用 DUT 以實現其預期應用目的。在高容量製造環境中測試受測裝置時，通常需要多個測試固定裝置。測試受測裝置並確保不同測試固定裝置之間的量測一致性的最準確方式是，使用沒有實際匹配元素的簡單、可重複的測試固定裝置。

若要取得所需的效能資料，必須先從量測資料中移除（解除嵌入）固定裝置的寄生效應。然後必須模擬完全「虛擬」的匹配電路並以數學運算方式將其新增（嵌入）至修正的量測資料中。結果是受測裝置的準確顯示，就如使用實體匹配電路對其進行實際測試一樣，但沒有使用實際元件所產生的不確定性。

測試裝置以及將在其中使用它的電路。

電路模擬

此圖表並未提及執行這些操作的順序。

請參閱「固定裝置操作的順序」。

  1. 使用單極至平衡（SE-Bal）拓撲 建立平衡量測。包括所有相關量測設定（IFBW、點數等）。建立和校準量測後，可輕鬆變更量測參數。例如，將 Sdd22 變更為 Sds21。

  2. 在將簡單測試固定裝置連接至 VNA 時校準量測。使用準確的校準標準和定義。

  3. 移除簡單測試固定裝置的三條未校準傳輸線的影響。可通過多種不同方法執行此操作。最簡單的方法是使用手動或自動連接埠延伸將校準參考平面移動到受測裝置。這將移除固定裝置傳輸線的電氣長度和損耗，但沒有說明固定裝置不匹配的原因。另一種方法是解除嵌入先前建立之 3 條傳輸線的 *.S2p 檔案。可使用外部 ADS 建模軟體建立這些檔案。另一種替代方法是透過獨立量測測試固定裝置的全部 3 個連接埠，並將每一個量測結果儲存至 S2P 檔案，以此建立 *.S2P 檔案。

  4. 將測試固定裝置連接到 VNA 並插入受測裝置後，現在顯示的量測結果就如連接至 DUT 時所執行的校準，以及在 50-ohm 單極測試環境中測試裝置時的那樣。下列步驟將使結果反映裝置的效能，就如將裝置嵌入將在其中使用裝置的電路那樣。

  5. 裝置的連接埠 1 是單極連接埠，其來源阻抗與 VNA 系統阻抗相同，所以不需要變更。不過，如果 Rs 是除 50 ohms 以外的值，則連接埠 1 阻抗轉換將用於模擬不同的阻抗。

  6. 連接埠匹配用於模擬 L1 電感。選取任何要嵌入（新增）至量測結果的並聯 L 電路。輸入 L 和 R 的值。可將 C 值和 G 值輸入為 0（零）。

  7. 連接埠匹配用於模擬 C1 和 C2 電容。對於連接埠 2 和連接埠 3，選取任何要嵌入（新增）至量測結果的串聯 C 電路。輸入 C 和 G 的值。可將 L 值和 R 值輸入為 0（零）。

  8. 平衡轉換以數學運算方式模擬平衡模式中的量測。

  9. 差分連接埠匹配用於模擬 L2 電感。選取並聯 L- 並聯 C 並輸入電感/電阻值。可將 C 值和 G 值輸入為 0（零）。

  10. 最後，差分 Z 轉換用於模擬 200 ohms 的電路終端。如果要進行共模量測，請指定共模 Z 轉換。

上次修改時間：

2016 年 01 月 06 日

第一版


連接埠延伸

藉由連接埠延伸，您可在執行校正之後以電子方式移動量測參考平面。

附註：此功能適用於 GCA 以及標準（S 參數）通道。

  • 使用連接埠延伸的理由與方式

  • 手動連接埠延伸程序

  • [連接埠延伸] 對話方塊與工具列

  • [步長] 對話方塊

  • [自動連接埠延伸] 對話方塊

另請參閱

VNA 資料流圖

固定裝置補償功能

相位準確度

比較 VNA 延遲功能

其他校正主題

使用連接埠延伸的理由

  1. 您無法在裝置上直接執行校正，因為它位於測試固定裝置內部。請在便利的位置執行校正，然後使用連接埠延伸補償由於固定裝置導致的時間延遲（相位偏移）以及可能出現的損耗。

  2. 您已執行校正，但隨後決定您需要在量測配置中新增一段傳輸線。使用連接埠延伸「告知」分析人員您已向特定連接埠新增該長度。

重要附註：連接埠延伸與 VNA 資料流

請參閱 VNA 資料流圖表

一般而言，連接埠延伸套用於相位校正流程中的個別 S 參數，且僅套用於所顯示的 S 參數。

但是，當開啟固定裝置或執行平衡量測時，將在套用誤差項流程中套用連接埠延伸補償，該流程會影響所有的 S 參數，無論是否顯示都如此。如此可讓所有的基礎 S 參數都能套用適當的延伸。

因此，在搭配需要多個單一 S 參數（例如方程式編輯器中的 k 因數）的功能使用連接埠延伸時，請執行下列其中一項作業：

  • 啟用固定裝置 - 不需要啟用個別固定裝置功能。

  • 使用 8510 模式資料處理。

在套用誤差項流程中套用連接埠延伸補償後，若已經執行資料至記憶體作業，則針對連接埠延伸設定所做的進一步變更將不會套用到 [記憶體] 軌跡之中。

使用連接埠延伸的方式

  • 如果您知道固定裝置的電子長度或額外傳輸線的長度，請直接在時間設定中輸入值。

  • 如果您知道固定裝置的實體長度或額外傳輸線的長度，請直接在距離設定中輸入值。

  • 如果您不知道固定裝置的電子長度或實體長度，或者額外傳輸線的長度，則必須能夠將開路或短路連接到新的參考平面來替換 DUT。在大多數情況下，移除 DUT 將會在新的參考平面中留下合適的開路。

  • 接著可以手動新增連接埠延伸（如下所示），或者透過使用自動連接埠延伸加以新增。

手動連接埠延伸程序

  1. 選取經校正的 S11 量測。

  2. 選取相位格式。

  3. 當校正參考平面上有開路或短路時，請驗證跨頻率範圍的相位處於零或接近零的位置。

  4. 連接固定裝置或新增的傳輸線，並連接開路或短路來替代 DUT。在大多數情況下，移除 DUT 將會在新的參考平面中留下合適的開路。在 [連接埠延伸] 工具列或對話方塊中，增大時間或距離，直至相位響應在相關的頻率跨距上是平的。

  5. 如果您知道額外傳輸線的損耗，請使用一或兩個資料點輸入損耗補償值。

附註：大多數的開路與短路標準都有延遲。因此，使用此方法調整延遲將使得延遲等於開路或短路之延遲的兩倍。

如何存取連接埠延伸設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Port Extension（連接埠延伸）> Port Extensions...（連接埠延伸...）

[連接埠延伸] 對話方塊與工具列說明

附註：此功能適用於下列量測類別：GCA、雜訊固定裝置、NFX 以及標準（S 參數）通道。

連接埠延伸設定會影響作用中通道上與特定連接埠關聯的所有量測。

瞭解使用連接埠延伸的理由與方式（向上捲動）。

連接埠延伸 開啟或關閉所有連接埠上的連接埠延伸。

連接埠 選取 VNA 連接埠以設定延遲與損耗值。連接埠延伸設定會影響作用中通路上與特定連接埠關聯的所有量測。

顯示工具列 選中以顯示連接埠延伸工具列。藉由該工具列，您可以在顯示 VNA 畫面的更多部分時對接埠延伸進行調整。 從 VNA A.08.50 修訂版開始，此為顯示或隱藏工具列的唯一途徑。

延遲設定

藉由輸入值或按一下向上/向下箭頭，即可輸入以距離或時間表示的延遲。按一下 [image] 以啟動步長對話方塊。

時間 以時間表示的連接埠延伸延遲量。輸入正值。

距離 以物理長度表示的連接埠延伸延遲量。輸入正值。

距離單位 （僅限對話方塊）請從公尺、英吋或英尺中選擇。[步長] 設定不會自動變更。瞭解詳情。

損耗補償

藉由下列設定，可針對損耗校正整個頻率跨距。

直流損耗 依此值偏移整個頻率跨距。還必須選中「Loss1」或「Use1」。若要補償直流損耗，可輸入一個正值，讓軌跡沿著正（向上）方向位移。

頻率損耗 選中該方塊，然後輸入損耗和頻率的值。

當使用 Loss1 或 Loss1/Loss2 時，則按如下所述使用曲線擬合演算法：

僅限 Loss1：

Loss(f) = Loss1 * (f/Freq1) ^ 0.5

Loss1 和 Loss2：

將較低頻率設為 Loss1，將較高頻率設為 Loss2。

Loss(f) = Loss1 * (f/Freq1) ^ n

其中：

n = log10 [abs(Loss1/Loss2)] / log10 (Freq1/Freq2)

附註：abs = 絕對值

速度

速度因數 對於每個連接埠，設定套用於量測校正之後插入的裝置媒體的速度因數。聚乙烯絕緣纜線的值是 0.66，PTFE 絕緣體是 0.7。對應光在真空中的速度是 1.0。

耦合至系統速度因數 取消選中後，僅針對指定的連接埠以及連接埠延伸設定速度因數。 若選中，則針對所有連接埠設定速度因數。此外，變更此值還會變更電子延遲與時域距離標記功能的此設定。

媒體

對於每個連接埠，請選取新增的傳輸線或固定裝置的媒體。

同軸 若固定裝置或新增的傳輸線為同軸，則選取此對話框。另外還要指定同軸的速度係數。

波導/截止頻率 若固定裝置或新增的傳輸線為波導，則選取此對話框。另請輸入波導的截止（最低）頻率。

附註：如果使用波導校正套件，請在校正之前將系統 Z0 設為 1 ohm。

耦合至系統媒體定義。 取消選中後，僅針對指定的連接埠以及連接埠延伸設定波導截止頻率。 若選中，則針對所有連接埠設定波導截止頻率。此外，變更此值還會變更電子延遲功能的此設定。

重設 將所有連接埠延伸設定變更為預設值。連接埠延伸的開/關狀態不會受到影響。

自動延伸 啟動自動連接埠延伸對話方塊

附註：無法再設定個別接收器連接埠延伸（A、B 等）。（2004 年 9 月）

步長 對話方塊說明

變更在 [連接埠延伸] 工具列上按 [時間] 或 [距離] 向上/向下箭頭時發生的步長。可在 [連接埠延伸] 對話方塊中變更步長的單位。

自動 [步長] 設為預設值。

使用者定義 輸入步長值，然後按一下 [確定]。

變更單位後，此值仍保持不變。例如，如果在此對話方塊中輸入步長 12，然後將單位從 [英吋] 變更為 [英尺]，步長將從 12 英吋變為 12 英尺，而非 1 英尺。因此，應先變更單位，再設定步長。

瞭解連接埠延伸（向上捲動）

自動連接埠延伸對話方塊說明

自動連接埠延伸將自動執行與手動連接埠延伸相同的作業。藉由連接短路或開路，參考平面將自動移至連接標準的位置。此外，自動連接埠延伸還可選擇量測與補償額外傳輸線的損耗。

在下列情況下無法使用自動連接埠延伸：

  • [掃描類型] 設為 [功率掃描]

  • [頻率偏移] 設為 [開啟]

  • [媒體] 設為 [波導]

附註：在使用自動連接埠延伸時，應關閉作用中軌跡上可能存在的方程式。

自動連接埠延伸程序

  1. 連接新增的傳輸線或固定裝置。將開路或短路連接到新參考平面上所有受影響的連接埠。在大多數情況下，移除 DUT 將會在新的參考平面中留下合適的開路。

  2. 在 [連接埠延伸] 工具列上，按一下自動連接埠延伸。按一下顯示配置以進行其他設定。

  3. 按一下量測以執行連接埠延伸計算。所產生的延遲與損耗設定將輸入到連接埠延伸工具列中。可使用「設備儲存」儲存這些設定，您也可以手動記錄這些值，然後在需要時再次輸入。

設定

量測開路和/或短路。按下按鈕以量測反射標準。

根據最為便利的情況量測開路或短路。假設理想的開路與短路，損耗和延遲都為零。因此，精確度受標準品質的影響最為顯著。在大多數情況下，移除 DUT 將會在新的參考平面中留下合適的開路。量測開路與短路標準時，將使用兩者的平均值，如此可些微改善精確度。

選定的連接埠 指出目前已啟用自動連接埠延伸的連接埠。依預設，將啟用所有 VNA 連接埠。若要停用某個連接埠，請參閱下方的在下列連接埠號碼上量測。

附註：連接埠延伸設定會影響作用中通道上與特定連接埠關聯的所有量測。

顯示/隱藏配置 按下此按鈕可在對話方塊中顯示或隱藏下列配置設定。

在下列連接埠號碼上量測

選取要啟用或停用自動連接埠延伸的連接埠號碼。

啟用 選中該方塊可啟用指定的連接埠。在執行自動連接埠延伸後，將自動調整所有已啟用連接埠的參考平面。

包括損耗 選中該方塊可自動量測額外傳輸線中的損耗並套用補償。若要計算損耗補償，通常將頻率範圍內 1/4 與 3/4 處的頻率做為 Freq1 與 Freq2 值。深入瞭解損耗補償。

調整匹配失當 僅在選中包括損耗時才可用。匹配失當會新增漣波到 S11 與 S22 軌跡。 如果漣波較大，S11 與 S22 可能會顯示為大於 0 dB，這樣會導致在使用 S 參數時出現數值不穩定的情況。 調整匹配失當會增加固定裝置的損耗，如此一來，漣波的峰值將低於 0 dB。 雖然這樣會使得誤差增大（所有誤差皆為負值），但是在模擬器中使用 S 參數時將不會出現數值不穩定的情況。

選中 - 偏移軌跡，使得所有資料點都位於零或零以下的位置。

清除 - 曲線擬合計算最為精確的套用，但是允許正響應。

針對每個標準進行提示 選中此方塊可在按下 [量測開路或短路] 按鈕時叫用提示。提示將指出哪個標準連接到哪個連接埠。

方法

選取將用於確定相位與損耗（可選）校正值的資料點跨距。如果電流頻率跨距的某個部分沒有平坦或線性響應，則可以透過使用縮小的使用者跨距將此部分從計算中消除。

若要計算損耗補償，[電流跨距] 與 [使用者跨距] 方法通常將頻率範圍內 1/4 與 3/4 處的頻率做為 Freq1 與 Freq2 值。若要深入瞭解如何計算損耗，請參閱損耗補償。

電流跨距 使用整個頻率跨距來確定相位與損耗值。

作用中標記 僅使用作用中標記的頻率以及頻率中較高的一個資料點來計算相位與損耗值。如果標記不存在，將在頻率跨距的中心建立一個標記。

使用者跨距 使用下列使用者跨距設定來確定相位與損耗值。

使用者跨距

開始 輸入使用者跨距的開始頻率。

停止 輸入使用者跨距的停止頻率。

瞭解連接埠延伸（向上捲動）。

另請參閱比較 VNA 延遲功能

上次修改時間：

2014 年 09 月 02 日

第一版


切換配接器方法

切換配接器校準方法

雖然 VNA 韌體不包含切換配接器（亦稱為「平等切換配接器和等長配接器」）校準方法，但您仍可執行此校準。

在引入未知直通方法之前，通常使用切換配接器方法作為更繁冗之配接器移除方法的快速替代方法。在這種情況下，為了便於使用，量測準確度會有所降低。如果未將具有相同接頭類型的校準標準作為您的受測裝置，則您仍可能需要執行切換配接器。具體程序如下所示。

基於其他原因，不建議使用切換配接器方法，因為未知直通方法更方便且更精確。

切換配接器校準有多種變化形式，視要校準的連接埠數目，以及受測裝置為可插入或非可插入而定。但兩者的概念相同：使用一個準備就緒的配接器來連接並量測反射標準（開路、短路和負載），然後換成其他配接器進行直通量測。配接器必須具有相同的延遲、損耗和阻抗。配接器的匹配度愈高，量測結果就愈精確。請務必使用已校準的 VNA 來量測配接器。

程序

以下範例程序說明如何對非可插入受測裝置執行切換配接器 2 連接埠校準。受測裝置具有 2.92 mm 接頭。您沒有 2.92 mm 校準標準，但您有 2.4 mm 標準以及電氣性能與 2.92 mm 配接器相當的配接器。

配接器 A1 和 A2 = 測試連接埠連接至 2.4 mm 配接器

配接器 B1 和 B2 = 測試連接埠連接至 2.92 mm 配接器

  1. 啟動智慧型校準。 附註：VNA 不會提示您依名稱連接配接器，也不會提示何時切換配接器。

  2. 指定接頭類型和性，以及要使用的配接器的校準套件 (2.4 mm) - 而非受測裝置的接頭類型 (2.92 mm)。透過指定接頭的性，還可以指定直通方法（沖洗直通適用於可插入的 DUT，未知直通適用於非可插入的 DUT）。例如，當兩個受測裝置連接埠均有母接頭時，我們將執行未知直通校準。

  3. 當系統提示輸入連接埠 1 上的反射標準時，將開路、短路和負載標準連接到配接器 A1。

  4. 當系統提示輸入連接埠 2 上的反射標準時，將開路、短路和負載標準連接到配接器 A2。

  5. 當系統提示進行直通連接時，將配接器 A1 和 A2 換成 B1 和 B2。連接直通裝置。這可以是任何符合未知直通標準要求的裝置。對於非可插入的受測裝置，請連接 B1 和 B2。

  6. 在配接器 B1 和 B2 準備就緒的情況下進行受測裝置量測。

上次修改時間：

2014 年 09 月 02 日

第一版


校準平面管理器

校準平面管理程式 (CPM)

配接器、固定裝置和探針通常用於具有非同軸介面的受測裝置。這樣可能導致很難採用傳統的校準標準進行校準。校準平面管理程式 (CPM) 讓您能夠以數學運算方式將經過特性化的配接器、測試固定裝置或探頭從量測中移除（解除嵌入）。

在本主題中：

  • 功能

  • 使用校準平面管理程式

    • 校準平面管理器

    • 特性化配接器/固定裝置並套用

    • 校準集選取

    • 連接埠選取

    • 相位樞軸

    • 選取檔案

    • 套用解除嵌入

    • 選取要解除嵌入的通道

    • 選取要解除嵌入的校準集

  • 直接接收器校準（單獨主題）

  • 其他動作

    • 反轉連接埠順序

    • 建立僅限傳輸的 S2P 檔案

    • 重疊顯示兩個 S2P 檔案

其他校準主題

功能

  • 特性化 SnP 檔案中的配接器和固定裝置。

  • 將特征化套用至現有的校準集和通道。

  • 使用固定裝置/配接器的 S2P 檔案寫入 VNA 功率損耗表。

  • 反轉現有 S2P 檔案的連接埠順序。

  • 從現有的 S2P 檔案建立僅限順向的 S2P 檔案。

  • 重疊顯示兩個 S2P 檔案。

重要附註

  • 轉換器/固定裝置定義：任何要以數學運算方式從通道量測或校準集移除的實體雙連接埠裝置或元件。

  • 要特性化的轉換器/固定裝置必須互為倒數 (S21 = S12)。

  • 執行 CPM 特性化前，必須執行兩個第 1 層校準並儲存至校準集。

使用校準平面管理程式

如何啟動校準平面管理程式

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Fixtures（固定裝置）> Cal Plane Manager...（校準平面管理程式...）

校準平面管理程式對話方塊說明

選擇下列選項，然後按一下下一步 >：

  • 特性化轉換器/固定裝置並套用 - 如果在轉換器/固定裝置前後已經執行了校準，則將產生特性化轉換器/固定裝置的 SNP 檔案。這些檔案隨後會用於將固定裝置從通道和新校準集解除嵌入。瞭解詳細資訊。

  • 套用轉換器/固定裝置 - *.SNP 檔案已儲存。使用這些檔案從通道和新校準集解除嵌入固定裝置。

  • 直接接收器校準（單獨主題）

  • 其他動作

特性化轉換器/固定裝置並套用對話方塊說明

要求

  • 必須已在固定裝置/轉換器的輸入位置執行第 1 層校準，並在固定裝置/轉換器的輸出位置執行第 2 層校準（如上圖所示）。

  • 此外，校準必須已儲存至分析器上的校準集。

附註：CPM 第 1 層和第 2 層校準的機械開關/衰減器設定必須相同。 此外，當兩個校準層之間的跨距或點數不同時，則必須有足夠的資料點才能確保不會發生相位環繞。如果其中任何一個校準集的三角頻率小於 12/測試連接埠纜線的組合長度（以公尺計算），即可實現此目標。

應用程式

下圖顯示了第 1 層和第 2 層校準的校準平面：

晶片上的探頭 | 固定裝置上的探頭 | 波導轉換器

程序

配置 選取要特性化和解除嵌入的轉換器/固定裝置數量。

  • 當受測裝置的任意輸入或輸出中包含單個固定裝置/轉換器時，請選擇一個固定裝置。

  • 當受測裝置的輸入和輸出中均包含固定裝置/轉換器時，請選擇兩個固定裝置。

瀏覽 - 啟動以下校準集選取對話方塊。

直流相位 - 啟動相位樞軸對話方塊。

按一下下一步>

校準集選取對話方塊說明

從分析器中所列示的校準集中選擇要用於第 1 層和第 2 層校準的校準集。

  • 第 1 層校準集必須來自在轉換器/固定裝置的輸入位置上所執行的校準。

  • 第 2 層校準集必須來自在受測裝置參考平面上所執行的校準。

按一下篩選校準集以啟動以下對話方塊。

勾選啟用篩選，然後提供進階篩選要求來縮小相應校準集的搜尋範圍。

篩選選項

量測類別 - 所列類別均為在分析器上啟用的類別。

校準類型 - 用於 1P（單埠）或 2P（雙埠）校準集的濾波器。

校準集名稱包括 - 篩選以包括校準集名稱中出現的任何文字。

校準集說明包括 - 篩選以包括校準集說明中出現的任何文字。

校準連接埠 - 篩選以僅包括要解除嵌入的分析器連接埠。

使用中校準 - 篩選以僅包括目前正在分析器上使用的校準集。

上次修改期間 - 篩選以僅包括於兩個指定日期間進行上次修改的校準集。

連接埠選取對話方塊說明

在上一對話方塊中，當選取多連接埠校準集進行涉及較少連接埠的特性化時，請選取用於特性化固定裝置/轉換器的校準集中的連接埠。

相位樞軸對話方塊說明

對於大多數裝置而言，S21 在直流時的投影相位會穿過 0° 到 -180° 之間的 X 軸。

相位樞軸點會指定相位視窗的中心。一般為 1 個 Pi 寬。預設值 0° 應適合大多數配接器。

然而，當特性化長電纜線、具有明顯匹配不當的纜線或量測中的高雜訊時，相位的投影可能會大於 0°。這會導致由 CPM 計算出的結果與採用雙連接埠校準量測相同轉換器得出的結果之間出現 180° 的相位差。

在這種情況下，您可能必須變更預設值，才能擷取 S21 在直流時的投影相位。

選取檔案對話方塊說明

對於每個固定裝置（A 和 B）：

  • 按一下瀏覽，然後導覽至儲存 S2P 檔案的資料夾。

  • 輸入檔名，然後按一下 S2P 格式，然後選擇儲存資料所使用的格式。

    • 對數幅度與角度（預設）

    • 線性幅度與角度

    • 實數與虛數

按一下套用以繼續解除嵌入固定裝置。

按一下完成以結束特性化並關閉對話方塊。

套用解除嵌入對話方塊說明

如果每個固定裝置/轉換器有一個 S2P 檔案，此對話方塊將從以下任意位置移除固定裝置/轉換器的影響：

  • 一個或多個校準集

  • 或一個或多個通道。

對於每個固定裝置（A 和 B）

  1. 勾選以啟用固定裝置。

  2. 選取固定裝置所連接的 VNA 連接埠。

  3. 按一下瀏覽，然後導覽至代表固定裝置/轉換器的 S2P 檔案。

  4. 反轉連接埠 - 使用 CPM 建立的 S2P 檔案始終參考距離分析器最近一側上的固定裝置/轉換器的連接埠 1，以及裝置受測裝置一側的固定裝置/轉換器的連接埠 2（如下圖所示）。S2P 檔案的應用（此對話方塊）假設採用這一相同的方向。如果您的 S2P 檔案是使用不同（外部）應用程式建立的，請檢查方向並在必要時勾選反轉連接埠順序。

  5. 選擇下列其中一個解除嵌入選項

    • 從校準集解除嵌入 - 啟動選取要解除嵌入的校準集對話方塊。

    • 從通道解除嵌入 - 啟動以下選取要解除嵌入的通道對話方塊。

選取要解除嵌入的通道對話方塊說明

將對於分析器上的指定通道執行和套用解除嵌入。

選取分析器中目前所顯示的、要從中解除嵌入配接器/固定裝置的一個或多個通道。

選取要解除嵌入的校準集對話方塊說明

在上一對話方塊中選取從校準集解除嵌入後，將顯示此對話方塊。

將會對指定的校準集中執行和套用解除嵌入。這讓您在今後只需對任意通道套用解除嵌入的校準集，即可輕鬆地套用解除嵌入。

選取校準集： 選取要對其套用解除嵌入的校準集。

內容 檢視有關相應校準集的資訊。

屬性

  • 覆寫選取的校準集 - 將以解除嵌入的轉換器/固定裝置覆寫選取的校準集。

  • 建立新校準集 - 選取要從其中建立新校準集的校準集。

按一下選項以啟動以下對話方塊。

校準集名稱

自動名稱 - 依預設，將使用舊校準集名稱以及附加到名稱開頭的指定文字（依預設為「CPM」）來建立新校準集。 您可以變更指定的文字。

向我詢問每個名稱 - 按確定時將啟動以下對話方塊。

保留使用中的校準和通道關聯 - 如果勾選（預設），新解除嵌入的校準集將用於修正與目前校準集相同的已顯示通道。

您選取進行解除嵌入的現有校準集會顯示在左側欄中。

提議的新校準集名稱會顯示在右側欄中。

若要變更新校準集名稱，請選取並編輯該名稱。

完成後，按一下確定。

其他動作對話方塊說明

選取其中一個動作：

  • 反轉 S2P 檔案的連接埠順序。

  • 建立僅限傳輸的 S2P 檔案。

  • 重疊顯示兩個 S2P 檔案。

寫入 VNA 功率感應器損耗表。將 S2P 頻率/損耗對載入 VNA 功率損耗補償表，以補償電源功率校準期間使用該裝置將功率感應器連接至量測連接埠時所發生的損耗。

  • 啟用功率感應器損耗表

  • 然後從以下選項中進行選擇：

    • 從校準集計算固定裝置。 根據選取的校準集計算固定裝置的傳輸損耗。在選取兩個有效的校準集後，此選擇才可用。

    • 使用 S2P 檔案。 使用現有 S2P 檔案中的 S21 資料來建立 VNA 的功率損耗表。 選取並按一下瀏覽，然後導覽至 S2P 檔案，接著按一下下一步>。

附註：在 VNA 功率損耗補償表中，損耗以正數表示。CPM 會假設 S2P 檔案中任何負的 S21 值均為損耗，因此會將檔案中的 S21 值乘以 -1，以表示該值為正數。這可確保在功率校準期間正確處理偏移。

反轉連接埠順序對話方塊說明

使用 CPM 建立的 S2P 檔案始終參考距離分析器最近一側上的固定裝置/轉換器的連接埠 1，以及裝置受測裝置一側的固定裝置/轉換器的連接埠 2（如下圖所示）。

此動作會造成現有 S2P 檔案中的連接埠反轉。

  • S11 的資料將變為 S22 的資料，反之亦然。

  • S21 的資料將變為 S12 的資料，反之亦然。

將以標準 S2P 檔案格式撰寫由此產生的檔案。

  1. 原始 - 導覽至要反轉的 S2P 檔案。

  2. 已反轉 - 導覽至將要儲存新的反轉 S2P 檔案的資料夾。輸入檔名。依預設，檔案將使用該檔名儲存至同一資料夾：<舊檔名>_Reversed.s2p

  3. 按一下完成。反轉檔案會儲存至指定位置。

建立僅限傳輸的 S2P 檔案對話方塊說明

在現有的 S2P 檔案中，此功能讓您能夠將 S11、S22 或兩個資料欄歸零。將保留原始的 S21 和 S12 資料。 這對於增強回應校準/解除嵌入十分有用。

原始 - 按一下瀏覽，然後導覽至要修改的檔案。

已修改 - 按一下瀏覽，然後導覽至資料夾，輸入或變更結果 S2P 檔案的檔名。檔案選取對話方塊讓您能夠變更資料的格式。按一下格式，然後從以下選項中進行選擇。

  • 對數幅度與角度（預設）

  • 線性幅度與角度

  • 實數與虛數

修改

選擇將 S11、S22 或兩個資料欄歸零。

按一下完成。僅限傳輸的檔案將儲存至指定位置。

重疊顯示兩個 S2P 檔案對話方塊說明

此對話方塊可將兩個 S2P 檔案的損耗和相位偏移結合到單個 S2P 檔案中。

兩個輸入 S2P 檔案的激勵設定不必相同。重疊顯示的 S2P 檔案的頻率範圍將是兩個輸入檔案間共同的頻率範圍。此外，重疊顯示的 S2P 檔案將使用資料點密度更高的輸入檔案的資料點。

例如：

S2P #1:頻率範圍 = 1 GHz 至 5 GHz；201 個點。

S2P #2：頻率範圍 = 2 GHz 至 6 GHz；1001 個點。

重疊顯示的 S2P：頻率範圍 = 2 GHz 至 5 GHz，使用 S2P #2 的資料點。

S2P #1 - 按一下瀏覽，然後導覽至要重疊顯示的其中一個 S2P 檔案。

S2P #2 - 按一下瀏覽，然後導覽至另一個要重疊顯示的 S2P 檔案。

重疊顯示的 S2P - 按一下瀏覽，然後導覽至資料夾並輸入結果 S2P 檔案的檔名。

按一下完成。重疊顯示的檔案會儲存至指定位置。

上次修改時間：

2014 年 6 月 03 日

新主題


校準概觀

本主題討論以下內容：

  • 什麼是量測校準？

  • 為何需要校準？

  • 建議進行校準的條件

  • 什麼是 ECal？

請參閱其他校準主題

什麼是量測校準？

校準使用稱為誤差模型的等式來移除一個或多個系統誤差。高品質標準（例如短路、開路、負載和直通）的量測使分析器能夠解決誤差模型中的誤差項。請參閱量測誤差。

您可以根據要進行的量測以及所需的量測準確度級別來選取不同的校準類型。請參見選取校準類型。

校準量測的準確度取決於校準套件中標準的品質，以及對校準套件定義檔案中的標準進行建模（定義）的準確程度。校準套件定義檔案儲存在分析器中。若要進行準確量測，校準套件定義必須與所使用的實際校準套件相匹配。若要瞭解詳情，請參閱精確校準。

校準精靈提供在 VNA 中使用的不同校準方法。請參閱校準精靈。

您可以進行快速檢查以確保量測校準準確無誤。若要瞭解詳情，請參閱量測校準的有效性

如果您要建立自己定制的校準標準（例如，在固定裝置量測期間），則必須將校準標準特性化，並將定義輸入使用者修改的校準套件檔案。有關修改校準套件檔案的更多資訊，請參閱校準標準。

附註：儀器校準可確保分析器硬體按指定的方式工作。這與量測校準不同。

為何必須執行校準？

製造出不需要任何形式的誤差修正的完美硬體是不可能的。即使是將硬體做得足夠好，使大多數裝置不需要進行誤差修正，這樣做的成本也是極其高昂的。

網路分析器的外部因素對網路分析的準確度的影響極大。量測裝置的元件（如互連纜線和配接器）會使幅度和相位發生變化，這會掩蓋受測裝置的實際回應。

最佳平衡是將硬體做得盡可能好，使效能和成本達到平衡。校準就成了提高量測準確度的最有用的工具。

建議進行校準的條件

一般情況下，若要在下列情況下進行量測，您應該進行校準：

  • 您需要最佳準確度。

  • 您要適應不同的接頭類型或阻抗。

  • 您要在測試裝置和分析器測試連接埠之間連接纜線。

  • 您要在較寬的頻率跨距或電長裝置上進行量測。

  • 您要在測試裝置的輸入或輸出中連接衰減器或其他此類裝置。

如果您的測試裝置符合上述任何條件，則可能會影響以下系統特性：

  • 裝置輸入中的幅度

  • 頻率回應準確度

  • 方向性

  • 串擾（隔離）

  • 來源匹配

  • 負載匹配

什麼是 ECAL

ECal 是全固態校準解決方案。它使 1 連接埠（反射）、全 2 連接埠和 3 連接埠校準變得快速而容易。請參閱使用 ECal。

  • 操作員不容易出現誤差。

  • 各種標準（位於校準模組內）永遠不會磨損，因為可以使用 PIN 二極管或 FET 開關進行切換。

  • 使用 TRL 校準的網路分析器將校準模組特性化。

  • ECal 的準確度不如好的 TRL 校準那麼高。

有關訂購 ECal 模組的資訊，請參閱分析器配件或與您的Keysight 支援代表連絡。

上次修改時間：

2014 年 08 月 21 日

第一版


量測誤差

您可以透過瞭解誤差發生原因及修正方式來提高準確度。本主題探討了量測誤差的來源以及監控誤差項的方式。

  • 漂移誤差

  • 隨機誤差

  • 系統性誤差

    • 3 連接埠誤差項

    • 4 連接埠誤差項

  • 監控誤差項

請參閱其他校準主題

漂移誤差

漂移誤差是由於儀器或測試系統性能在執行校準後出現變化所致。

漂移誤差主要由測試儀器內的連接纜線的熱膨脹特性和微波頻率轉換器的轉換穩定性引起，可透過重新校準來消除。

校準保持準確的持續時閒範圍取決於測試系統在測試環境中進行漂移的速率。

提供穩定的環境溫度通常可最大限度地減少漂移情況。如需詳細資訊，請參閱量測穩定性。

隨機誤差

隨機誤差無法預測且無法透過誤差修正消除。然而，可以採取一些措施，使其對量測準確性的影響降至最低。以下說明了隨機誤差產生的三個主要來源。

儀器雜訊誤差

雜訊是分析器元件中產生的不需要的電子干擾。這些干擾包括：

  • 由接收器的寬頻雜訊底層產生的低電平雜訊。

  • 由測試儀器內部的 LO 來源的雜訊底層和相位雜訊產生的高電平雜訊或軌跡資料抖動。

您可以透過執行以下一個或多個操作減少雜訊誤差：

  • 提高量測設備的來源功率 - 僅會減少低電平雜訊。

  • 縮小 IF 頻寬 。

  • 套用數個量測掃描平均值。

開關重複性誤差

在分析器中使用的機械 RF 開關可切換來源衰減器設定。

有時啟動機械 RF 開關時，接觸點的閉合方式與其之前的啟動方式有所不同。發生這種情況時，將會對量測準確度造成負面影響。

透過在重要量測時不要切換衰減器設定，藉此可以降低開關重複性誤差的影響。

接頭重複性誤差

接頭耗損會導致電氣性能發生變化。透過執行良好的接頭維護方法，您可以減少接頭重複性誤差。請參閱接頭維護。

系統性誤差

分析器和測試裝置中的缺陷會導致系統性誤差。

  • 該誤差為可重複性誤差（因此可以預測），並假定為不隨時間改變。

  • 在校準程序期間會確定這些誤差的特性，並在量測期間以數學運算方式減少這些誤差。

  • 無法完全消除這類誤差。由於校準程序所限，始終存在一些殘餘誤差。殘餘（量測校準後）系統性誤差是由於以下原因所致：

    • 校準標準中的缺陷

    • 接頭介面

    • 連接纜線

    • 儀器

反射量測會產生以下三種系統性誤差：

  • 方向性

  • 來源匹配

  • 頻率回應反射追蹤

傳輸量測會產生以下三種系統性誤差：

  • 隔離

  • 負載匹配

  • 頻率回應傳輸追蹤

關於以下系統性誤差說明的附註：

  • 以下六個系統性誤差的圖展示了針對正向量測設定的相關硬體。對於反向量測，在分析器內部切換將使連接埠 2 變為來源，而連接埠 1 變為接收器。「A」變為傳輸的接收器，「B」變為反射的接收器，而「R2」變為了參考接收器。這六個系統性誤差乘以兩個方向，結果就導致雙連接埠裝置出現 12 個系統性誤差。

  • 為簡單起見，可以說明使用一個標準來確定每個系統性誤差。事實上，將使用所有標準確來定所有系統性誤差。

  • 以下說明 SOLT 校準。這不適用於 TRL 或其他類型的校準。

方向性誤差

所有網路分析器均使用定向耦合器或橋接器進行反射量測。

使用理想的耦合器，只有來自受測裝置的反射訊號出現在「A」接收器中。事實上，少量的入射訊號透過耦合器的正向路徑洩漏到「A」接收器。這一洩漏路徑以及允許能量不從受測裝置反射出來就到達「A」接收器的其他路徑，共同導致了方向性誤差。

分析器如何量測並減少方向性誤差。

  1. 校準期間，將負載標準連接到連接埠 1。我們假定沒有反射來自負載。

  2. 在「A」接受器測得的訊號產是通過耦合器和其他路徑洩漏的入射訊號。

  3. 將以數學運算方式消除後續反射量測中的方向性誤差。

隔離誤差

在理想情況下，只有通過受測裝置傳輸的訊號才會在「B」接收器處量測到。

事實上，少量訊號通過分析器中的各種路徑洩漏到「B」接收器中。

訊號洩露亦稱為串擾，就是隔離誤差，可以由分析器確定特性並降低。

分析器如何量測並降低隔離誤差

  1. 在校準期間，將負載標準連接到連接埠 1 和連接埠 2。

  2. 在「B」接收器處測得的訊號是通過分析器中的各種路徑洩漏的。

  3. 將以數學運算方式消除後續傳輸量測中的隔離誤差。

來源匹配誤差

理想情況下，在反射量測中，從 DUT 反射出來的所有訊號可在「A」接收器處測得。

事實上，某些訊號從受測裝置中反射出來，而分析器和受測裝置之間將發生多次內部反射。這些反射與入射訊號相結合，可在「A」接收器處測得，而不是在「R」接收器處測得。

該量測誤差稱為來源匹配誤差，可以由分析器確定特性並降低。

分析器如何量測並降低來源匹配誤差

  1. 校準過程中，所有反射標準都將連接到連接埠 1。來自標準的已知反射可在「A」接收器處測得。

  2. 將使用複雜的計算來計算來源匹配誤差。

  3. 將以數學運算方式消除後續反射和傳輸量測中的來源匹配誤差。

負載匹配誤差

理想情況下，在傳輸量測中，將通過受測裝置傳輸入射訊號並在「B」接收器處測得。

事實上，有些訊號從連接埠 2 和其他元件處反射出來，且無法在「B」接收器處測得。

該量測誤差稱為負載匹配誤差，可由分析器確定特性並降低。

分析器如何量測並降低負載匹配誤差

  1. 將連接埠 1 與連接埠 2 測試接頭連接在一起，以實現完美的零長度直通連線。如果無法實現這一連線，則將插入一個特性化的直通配接器。如此可允許已知數量的入射訊號進入連接埠 2。

  2. 在「A」接收器處測得的訊號為連接埠 2 的反射訊號。

  3. 將以數學運算方式消除後續傳輸和反射量測中生成的負載匹配誤差。

頻率回應反射追蹤誤差

通過將「A」接收器處的訊號與「R1」接收器處的訊號相比較，即可完成反射量測。這稱之為比例量測或「A 比 R1」(A/R1)。

若要獲得理想的反射量測，「A」和「R1」接收器的頻率回應應是相同的。

事實上，這兩個頻率回應是不同的，從而導致頻率回應反射追蹤誤差。這是所有測試變化的向量總計，在這些變化中，幅度和相位做為頻率的函數而變化。這包括由以下原因產生的變化：

  • 訊號分隔裝置

  • 測試纜線

  • 配接器

  • 參考訊號路徑和測試訊號路徑之間的變化

頻率回應反射追蹤誤差可由分析器確定特性並降低。

分析器如何量測並降低頻率回應反射追蹤誤差。

  1. 校準時，將使用所有反射標準來確定反射追蹤。

  2. 將「A」接收器平均回應與「R1」接收器回應進行比較。

  3. 使用複雜的數學公式計算頻率回應反射追蹤誤差（請參閱下圖）。將以數學運算方式消除後續 DUT 量測中的頻率回應反射追蹤誤差。

附註： 在反射回應校準中，僅量測單一校準標準（開路或短路），因此僅使用其對誤差修正的影響。

頻率回應傳輸追蹤誤差

通過將「B」接收器處的訊號與「R1」接收器處的訊號相比較，即可完成傳輸量測。這稱之為比例量測或「B 比 R1」(B/R1)。

若要獲得理想的傳輸量測，「B」和「R1」接收器的頻率回應應是相同的。

事實上，這兩個頻率回應是不同的，從而導致頻率回應傳輸追蹤誤差。這是所有測試變化的向量總計，在這些變化中，幅度和相位做為頻率的函數而變化。這包括由以下原因產生的變化：

    • 訊號分隔裝置

    • 測試纜線

    • 配接器

    • 參考訊號路徑和測試訊號路徑之間的變化

頻率回應傳輸追蹤誤差可由分析器確定特性並降低。

分析器如何量測並降低頻率回應傳輸追蹤誤差。

  1. 校準時，將連接埠 1 與連接埠 2 測試接頭連接在一起，以實現完美的零長度直通連線。如果無法實現這一連線，則將插入一個特性化的直通配接器。如此可允許已知數量的入射訊號進入連接埠 2。

  2. 在「B」和「R1」接收器處進行量測。

  3. 使用複雜的數學公式計算頻率回應傳輸追蹤誤差（請參閱下圖）。將以數學運算方式消除後續受測裝置量測中的頻率回應傳輸追蹤誤差。

.

3 連接埠誤差項

下列流程圖顯示了 3 連接埠誤差項模型：

其中：

E = 誤差項

DIR = 方向性

MAT = 正向來源匹配與反向負載匹配

TRK = 正向反射追蹤與反向傳輸追蹤

4 連接埠誤差項

完全 4 連接埠校準需要以下各項：

如需誤差項的說明，請瞭解連接埠編號慣例。

 |  | 來源連接埠
 |  | 1 | 2 | 3 | 4
R e c P o r t | 1 | DIR 1,1 RTRK 1,1 SRM 1,1 | LDM 1,2 TTRK 1,2 XTLK 1,2 | LDM 1,3 TTRK 1,3 XTLK 1,3 | LDM 1,4 TTRK 1,4 XTLK 1,4
 | 2 | LDM 2,1 TTRK 2,1 XTLK 2,1 | DIR 2,2 RTRK 2,2 SRM 2,2 | LDM 2,3 TTRK 2,3 XTLK 2,3 | LDM 2,4 TTRK 2,4 XTLK 2,4
 | 3 | LDM 3,1 TTRK 3,1 XTLK 3,1 | LDM 3,2 TTRK 3,2 XTLK 3,2 | DIR 3,3 RTRK 3,3 SRM 3,3 | LDM 3,4 TTRK 3,4 XTLK 3,4
 | 4 | LDM 4,1 TTRK 4,1 XTLK 4,1 | LDM 4,2 TTRK 4,2 XTLK 4,2 | LDM 4,3 TTRK 4,3 XTLK 4,3 | DIR 4,4 RTRK 4,4 SRM 4,4

反射項

  • DIR:方向性

  • RTRK:反射追蹤

  • SRM:來源匹配

傳輸項

  • LDM：負載匹配

  • TTRK:傳輸追蹤

  • XTLK:串擾

我們如何僅量測 3 個直通連線？

在 4 連接埠 VNA 上，僅量測 3 個直通連線時可以執行完全 4 連接埠校準。量測超過 3 個直通連線將可實現更高的準確度。

透過量測所有反射項及 3 個傳輸直通連線，可以得到足夠的資訊來計算其餘傳輸項。以下是對此概念的高層級說明。實際的計算更加複雜。

為方便起見，讓我們使用字母（A、B、C、D）替代上圖中的連接埠編號，以便其可以毫無混淆地結合在一起。同樣，我們假定來源匹配和方向性誤差為零。

 | A | B | C | D
A | AA | AB | AC | AD
B | BA | BB | BC | BD
C | CA | CB | CC | CD
D | DA | DB | DC | DD

  • 量測所有反射誤差（AA、BB、CC、DD）。

  • 假定我們量測連接埠 AB、AC、AD 之間的直通。同時還量測出這些直通的反方向（BA、CA、DA）。

  • 剩餘要計算的項為 BC、CB、BD、DB、CD、DC。

以下顯示了如何從 BA 和 AC 計算 BC 項：

類似情況：

  • 從 CA 和 AB 計算 CB

  • 從 BA 和 AD 計算 BD

  • 從 AB 和 DA 計算 DB

  • 從 CA 和 AD 計算 CD

  • 從 DA 和 AC 計算 DC

使用校準集檢視器監控誤差項

您可以使用校準集檢視器監控測得的資料與計算的誤差項。這將有助於確定 VNA 的健全狀況以及量測的準確度。

透過列印或儲存誤差項，您可以定期比較當前的誤差項與之前記錄的由同一 VNA、量測設定與校準套件生成的誤差項。如果之前生成的值不可用，請參閱《維修指南》之附錄 A「誤差項」中的「典型誤差項資料」。

附註：適用於您的 VNA 的維修指南位於 http://www.keysight.com/find/pna

  • 穩定的系統應在大約六個月內生成可重複的誤差項。

  • 在同一頻率範圍、功率與接收器設定下，若誤差項出現突然變動，則可能表明需要疑難排解系統元件。有關疑難排解誤差項的資訊，請參閱《維修指南》之附錄 A「誤差項」。

  • 如果誤差項出現長期細微的變動，通常表示出現漂移或者接頭和纜線磨損。解決方法很簡單，通常是清潔並評估接頭或檢查纜線。

檢視校準集資料

  • 現有量測軌跡不受校準集檢視器影響。

  • 校準集資料軌跡在作用中視窗內以最高未使用的通道號碼（通常是 32）表示。

  • 校準集資料軌跡在狀態列中標記為 S11，與誤差項或標準的類型無關。

  • 一次僅可檢視一個校準集誤差項或標準資料。然而，資料軌跡可存儲至記憶體中，然後與其他資料軌跡進行比較。

請參閱誤差項等式。

如何存取校準集檢視器

使用前面板
硬鍵 [softkey] 按鈕

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集與校準套件）> Cal Set Viewer ON|OFF（校準集檢視器開啟|關閉）

如何使用校準集檢視器

  1. 使用向下箭頭選取校準集。然後按一下：

    • 誤差項 - 計算得出的資料。

    • 標準 - 標準的原始量測資料。僅可與非引導式校準（而非 ECal 或引導式校準）結合使用。

  2. 使用向下箭頭選取要檢視的誤差項或標準。

  3. 選中啟用核取方塊以在 VNA 螢幕上檢視資料。

誤差項的連接埠編號慣例與 S 參數的慣例一樣：

誤差項（接收器、來源），但是下列狀況除外：

  • 負載匹配 (2,1) - 透過進行 S11 量測得出連接埠 2 的匹配。

  • 負載匹配 (1.2) - 透過進行 S22 量測得出連接埠 1 的匹配。

  • 傳輸追蹤 (2,1) - 相對於連接埠 1 參考的連接埠 2 接收器。（來源=連接埠 1）。

  • 傳輸追蹤 (1.2) - 相對於連接埠 2 參考的連接埠 1 接收器。（來源=連接埠 2）。

  • 多連接埠校準以此類推。

上次修改時間：

2014 年 08 月 21 日

第一版


精確校準

準確的量測校準

校準準確度會受到校準類型、校準標準品質及執行校準的細心程度等的影響。本節提供有關如何進行精確校準的其他資訊。

  • 量測參考平面

  • 使用錯誤校準標準的影響

  • 資料式校準套件與多項式校準套件

  • 內插式量測的準確度等級

  • 功率位準的影響

  • 使用連接埠延伸

  • 雙連接埠校準的隔離部分

  • 選擇直通方法

瞭解如何判斷校準的有效性。

請參閱其他校準主題

量測參考平面

多數量測設定都不允許您將受測裝置 (DUT) 直接連接至 VNA 前面板測試連接埠。您更有可能將裝置連接至與 VNA 連接的測試固定裝置、配接器或纜線。

校準過程中，將在校準標準連接處進行校準。這稱為量測參考平面（請參見下圖）。 為了獲得最高量測準確度，請將校準參考平面設為受測裝置連接處。 設定完成之後，即可測出與測試設定（在分析器連接埠和參考平面間所使用的纜線、測試固定裝置和配接器）相關的誤差，並在校準過程中消除誤差。

使用錯誤校準標準的影響

一般來說，校準是使用校準套件執行，其所包含的接頭的標準與您受測裝置的類型和性別均相同。

但是，您的校準套件接頭類型和性別可能並不會總是與裝置相同。例如，假設您的裝置配備 3.5mm 接頭，但您的校準套件則是 N 類型。如果使用轉換器將 N 類型標準連接至 3.5mm 測試連接埠，則轉換器將成為校準的一部分，而非測試設定的一部分。這將導致您的反射量測出現顯著誤差。

資料式校準套件和多項式校準套件

選取受測裝置接頭和校準套件對話方塊可為最新的高頻率校準套件提供資料式模型和多項式模型。請參閱 VNA 配件。相比多項式模型，資料式模型對於校準標準的說明更為精確。如需得到最精確的結果，建議使用資料式模型。

 | 資料式模型 | 多項式模型
該模型的準確度如何？ | 提供最高的校準準確度。消除多項式模型的近似計算可能造成的誤差。 | 提供高校準準確度。
該模型如何定義校準標準？ | 使用 S 參數量測。 | 使用傳統的四元多項式校準標準建模參數。
使用該模型時，如何手動編輯校準標準的定義？ | 使用進階修改校準套件功能。 | 使用進階修改校準套件功能。
如何搭配使用校準精靈與模型？ | 僅使用智慧校準（引導式）校準方法。 | 使用智慧校準（引導式）或非引導式機械校準方法。

瞭解「擴展式計算」功能。

功率位準的影響

為取得最精確的誤差修正，請勿在校準執行完畢後變更功率位準。但是，如果變更在執行量測校準的相同衰減器範圍內的功率時，S 參數量測的準確度可能會略有降低。如果選取不同的衰減器範圍，誤差修正的準確度則會進一步降低。

若要檢查校準的準確度，請參閱校準的有效性。

使用連接埠延伸

在校準後使用連接埠延伸功能來補償因新增纜線、配接器或固定裝置而產生的延伸量測參考平面相位偏移。

連接埠延伸是補償相位偏移、 匹配不當，以及校準參考平面與受測裝置間路徑遺失的最簡單方法。

瞭解如何套用連接埠延伸。

瞭解特性化測試固定裝置。

雙連接埠校準的隔離部分

校準的隔離部分可修正串音，這是在無裝置情況下的測試連接埠之間的訊號洩漏。執行非引導式雙連接埠校準時，您可以選擇省略校準的隔離部分。

附註：隔離只能在智慧型（引導式）校準中執行

VNA 測試連接埠間的未修正隔離屬於異常情況（通常大於 100dB）。因此，您只能在需要超過 100dB 的隔離時執行雙連接埠校準的隔離部分。在測試插入損耗較高的裝置（例如部分篩選抑制帶或處於開路位置的開關）時執行隔離校準。

當量測非常接近分析器的雜訊層時，隔離校準可能會向誤差模型新增雜訊。若要提高量測準確度，請設定較窄的 IF 頻寬。

如何執行隔離校準

在負載標準連接到 VNA 測試連接埠時，將會量測隔離。如需最佳準確度，請在每次收到連接負載標準的提示時，將負載標準連接至兩個測試連接埠。如果兩個負載都不可用，請將未經測試的 VNA 連接埠連接至將會良好匹配的任意裝置。

選擇直通方法

校準非插入式裝置時，必須選擇校準直通誤差項的方法。這可能對量測準確度造成顯著影響。深入瞭解選擇直通方法。

上次修改時間：

2016 年 01 月 06 日

第一版。


校準直通方法

  • 什麼是非可插入式裝置

  • 選擇直通方法

  • 沖洗直通

  • 配接器移除

  • 切換配接器（其他主題）

  • 已定義直通

  • 未知直通

  • ECal 直通方法選擇

其他校準主題

什麼是非可插入式裝置

若要瞭解直通方法選擇，您必須先瞭解什麼是「非可插入式裝置」。這些定義同樣適用於 ECal 模組。將「裝置」替代為「ECal 模組」。然後參閱 ECal 直通方法選擇。

非可插入式裝置是其接頭無法插在一起的裝置。它們要麼具有不同的接頭類型，要麼屬於同性。這也意味著測試連接埠纜線也無法插在一起，如下列圖表所示。

可插入裝置是其接頭可插在一起的裝置。它們的接頭類型相同，性別相反或沒有性別。這也意味著測試連接埠纜線可以插在一起，如下列圖表所示。

選擇校準的直通方法

從校準精靈選取直通方法。選取選取受測裝置接頭和校準套件對話方塊中的 修改核取方塊。

備註：

對於 ECal，下列選擇表示的含義不同。請參閱 ECal 的直通方法。

對於 4 連接埠校準，請參閱如何僅量測 3 直通連接？

可插入裝置的選擇：沖洗直通（也稱為零長度直通）

校準可插入裝置時，量測參考平面上的測試連接埠可直接連接在一起。這稱為零長度直通或沖洗直通，表示直通標準的長度為零：無延遲、無損耗、無電容，且無電感。您的校準套件可能沒有實體直通標準，因為已假設您擁有可插入裝置且將使用零長度直通。

非可插入裝置的選擇

下列方法可校準非可插入裝置：

  • 配接器移除 準確，但不方便。

  • 已定義直通

  • 未知直通校準 偏好的方法。

配接器移除校準

此方法可能非常準確。不過，其所需的眾多連接會使不準確的資料增加。

執行兩個全雙連接埠校準：一個是在將配接器連接到連接埠 1 的情況下進行，另一個是在將配接器連接到連接埠 2 的情況下進行。兩個校準的結果是一個全雙連接埠校準，其中包括準確的特性以及移除由於配接器導致的匹配不當。

執行配接器移除校準需要：

  • 直通配接器，其接頭與受測裝置上的接頭匹配。

  • 適用於兩個受測裝置接頭的校準標準。

若要在智慧型校準期間選取配接器移除，請選取選取受測裝置接頭和校準套件對話方塊中的 修改核取方塊。校準精靈將引導您完成這些步驟。

瞭解如何執行使用 ECal 執行配接器移除校準。

已定義直通 （也稱為已知直通、校準套件直通、ECal 直通、特性化直通）

已定義直通使用儲存於校準套件檔案或 ECal 模組中的直通定義。直通標準可能會隨時間而有所磨損，使其不如新的時候那樣準確。已定義直通通常比配接器移除準確，但不如未知直通方法那樣準確。

附註

  • 如果執行 ECal，這是 ECal 模組中的直通標準。

  • 如果已定義直通在智慧型校準精靈中顯示為可能的直通方法，這意味著在所選的校準套件中存在已定義直通標準。這可能是零長度直通。智慧型校準精靈會在適當的時候提示您連接所需的標準。

若要定義校準套件（不是 ECal 模組）中的直通標準：

  1. 從 VNA 功能表，按一下「校準」、進階修改校準套件。

  2. 選取校準套件

  3. 按一下「編輯套件」

  4. 按一下「新增」

  5. 選取「直通」

  6. 完成該對話方塊。

下一次執行引導式校準時，如果受測裝置接頭類型與直通標準匹配，則可使用此已定義直通標準。

未知直通校準

未知直通校準是校準 VNA 以量測非可插入裝置的偏好直通方法。

未知直通校準也稱為短路-開路-負載-互易直通 (SOLR) 校準。

  • 非常易於執行。

  • 準確度高於已定義直通，且通常也高於配接器移除。

  • 不依賴可能不再準確的現有標準定義。

  • 如果直通標準的佔用空間與受測裝置的佔用空間相同，則無需移動纜線。實際上，受測裝置通常被視作直通標準。

  • 如果未知直通和校準路徑中的損耗一共為 40 dB 或更多，則不建議使用它。這會導致沒有足夠的訊號在接收器上進行準確量測。

關於未知直通程序

智慧型校準將引導您完成此程序。雖然下列程序說明連接埠 1 和連接埠 2，但在使用多重連接埠 VNA 時，可在任何兩個連接埠上執行未知直通。

  1. 在連接埠 1 上執行單連接埠校準。

  2. 在連接埠 1 上執行單連接埠校準。

  3. 在連接埠 1 和連接埠 2 之間連接未知直通。

  4. 量測未知直通。

  5. 確認預估的延遲。如果指定頻率跨距內的頻率點過少，則這個預估值可能是錯誤的。您可單獨量測延遲值，並在對話方塊中輸入該值。

未知直通標準

  • 未知直通和校準路徑中的總損耗最多為 40 dB。

  • 必須為互易：S21=S12.

  • 必須瞭解相位回應在 1/4 波長範圍內（請參閱上述步驟 5）。

  • 如果符合這些條件，則可以是受測裝置。

未知直通限制

  • TRL 校準期間不支援未知直通。

  • 從 VNA 代碼 5.25 版開始，可使用沒有適用於每一個測試連接埠的參考接收器的 4 連接埠 PNA-L 執行未知直通。不過，在量測未知直通之前，通常需要執行差值匹配校準。

  • E8801A、E8802A 和 E8803A 上不支援未知直通。

ECal 直通方法選擇

ECal 模組接頭與受測裝置接頭完全匹配時，可以選擇下列直通方法：

ECal 直通做為未知直通 深入瞭解未知直通 。

  • 量測 ECal 模組做為未知直通的直通狀態。

  • ECal 模組接頭與受測裝置匹配時的預設方法。

  • 非常準確且容易。

  • 可能需要執行差值匹配校準。

沖洗直通（零長度直通） 深入瞭解沖洗直通

  • 需要可插入 ECal 模組/受測裝置。

  • 移除 ECal 模組並將這兩個參考平面直接連接在一起，以執行零長度直通。

  • 準確，但不如「ECal 直通做為未知直通」那樣容易。

ECal（已定義直通）

  • 量測 ECal 模組的直通狀態。

  • 非常容易，但不如「ECal 直通做為未知直通」那樣準確。

未知直通

  • 移除 ECal 模組。

  • 然後將要量測的直通配接器做為未知直通進行連接。

  • 可能需要執行差值匹配校準。

ECal 模組接頭與受測裝置接頭不完全匹配時，可以選擇下列兩種方法：

配接器移除

  • 如果 DUT 為非可插入裝置，則可用於 ECal。不過，ECal 模組必須是可插入的，且配接器接頭必須與受測裝置接頭完全匹配，如下列圖表所示。

ECal 使用者特性化

如果無法執行配接器移除，且擁有合適的配接器，將始終可以執行 ECal 使用者特性化。使用者特性化將執行一次並儲存於 ECal 模組中。不過，每一次在 ECal 模組中移除再重新連接配接器都會使準確度降低。

上次修改時間：

2014 年 08 月 21 日

第一版


校準的有效性

本節將幫助您確定校準是否有效，以及分析器如何顯示量測的修正位準資訊。

  • 校準標準的頻率回應

  • 驗證校準

  • 快速檢查

  • ECal 可信度檢查

  • 驗證套件

請參閱其他校準主題

校準標準的頻率回應

為了讓校準標準的回應在史密斯圖顯示格式中顯示為點，不能存在有關頻率的任何相位延遲。唯一表現出此種「完美」回應的標準如下：

  • 7-mm 短路（無偏移）

  • N 型陽性短路（無偏移）

有兩個原因可以解釋為何其他類型的校準標準會在校準後表現出相位延遲：

  1. 標準的參考平面透過電子方式與測試連接埠的接插平面偏移。此類裝置表現出短距離傳輸線的屬性，包括一定量的相位移動。

  2. 標準是一個開路終端，該終端依定義表現出一定量的邊緣電容並因此而產生相移動。除了因邊緣電容引起的相位移動之外，自接插平面偏移的開路終端還會因為偏移而出現相位移動。

必須記住的要點是，為了從後續裝置量測中消除系統性誤差，應對所有標準進行量測。因此，若在校準之後將具有延遲和邊緣電容的校準標準作為裝置進行量測，則這些標準不會「很理想」。這表示您的分析器經過精確校準，可正常工作。

驗證校準

校準或選取儲存的校準集完成後，驗證可以達成以下目標：

提高量測準確度 – 執行量測校準後，應該先檢查其效能，然後再進行裝置量測。有一些錯誤來源會讓校準失效：纜線損壞、校準標準由於髒污或磨損而無法再像建模標準一樣運作，以及操作員出現誤差。

驗證內插的準確度 – 如果您在測試裝置，若由於內插導致量測不確定，則您應該驗證校準。 如需詳細資訊，請參閱內插準確度。

驗證校準標準的準確度 – 若要檢查準確度，應該對已知幅度和相位回應的裝置進行量測。

快速檢查

對於這項測試，您只需要一些校準標準。使用的裝置不應該是其中一個校準標準。對這些標準中的其中一個進行量測只是為了衡量可重複性。

下列反射和傳輸快速檢查測試可以套用到所有測試連接埠。

若要驗證反射量測，請執行下列步驟：

  1. 將開路或短路標準連接到連接埠 1。S11 的幅度應該接近 0 dB（在不超過 1 dB 的範圍內）。

  2. 將負載校準標準連接到連接埠 1。S11 的幅度應該小於分析器的指定校準方向性（一般小於 -30 dB）。

若要驗證傳輸量測：

  1. 將直通纜線（或代表量測的已知裝置）從連接埠 1 連接到連接埠 2。驗證損耗特性是否與纜線或裝置的已知效能相等。

  2. 若要驗證 S21 隔離，請連接 2 個負載：一個連接到連接埠 1，另一個連接到連接埠 2。量測 S21 的幅度，確保其小於指定的隔離（一般小於 -80 dB）。

附註：若要獲得這些量測更加準確的預期值範圍，請參閱分析器的規格。

ECal 可信度檢查

ECal 可信度檢查是一種檢查方法，可以檢查使用機械標準或 ECal 模組執行的校準的準確度。可信度檢查讓您可以量測 ECal 模組的抗阻狀態（亦稱為可信度狀態），並將其與模組中儲存的原廠量測資料進行比較。

為讓這項測試有效，ECal 模組的測試連接埠必須直接連接到校準參考平面（無配接器）。

如何執行 ECal 可信度檢查：

  1. 使用 USB 纜線將 ECal 模組連接到分析器。請參閱將 ECal 模組連接至 VNA。附註： 終止負載為 50 ohm 且未使用的任何 ECAL 連接埠。

  2. 讓模組預熱 15 分鐘或直到模組顯示準備就緒。

  3. 請執行下列其中一項操作以啟動 ECal 可信度檢查

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Cal] > Cal Sets & Cal Kits（校準集與校準套件）> ECal > Confidence Check...（可信度檢查...）

在下方的 ECal 可信度檢查對話方塊中：

  2. 按一下讀取模組資料。會發生以下情況：

    • ECal 模組設為「可信度狀態」。

    • VNA 讀出並顯示儲存的資料。

    • VNA 量測並顯示「可信度狀態」。

  3. 若要檢視其他參數，請選取變更量測並選取所需參數的核取方塊。 預設為作用中的通道參數。

  4. 在「軌跡檢視選項」區塊中選取檢視選項。

  5. 比較每個量測參數的儲存資料和量測資料。

備註：

  • 結束 ECal 可信度檢查後，ECal 模組會保持相同的阻抗狀態，且原廠（或使用者特性化）資料仍然儲存在記憶體軌跡中。因此，您可以將資料和記憶體軌跡都另存為 *.csv 檔案並將其匯入試算表。瞭解詳細資訊。

  • 如果兩個軌跡顯示出過多的不同之處，可能是由於測試連接埠的連接鬆動或髒污，或者測試纜線損壞。請仔細檢查纜線和連接處。然後清潔並測試每個接頭，並視需要進行重新校準。

  • 使用者特性設定會選取使用者特性資料而不會選取原廠特性資料（當使用者特性儲存在 ECal 模組中時可用）。

ECal 可信度檢查對話方塊說明

將修正後（校準後）的資料與 ECal 模組中儲存的資料進行準確度比較。為讓檢查生效，模組測試連接埠必須直接連接到校準參考平面（無配接器）。瞭解 ECal 可信度檢查的詳細資訊。

量測

變更量測 開啟「量測」對話方塊。

使用 ECal 模組

讀取模組資料

  • 將儲存的資料從 ECal 模組複製到記憶體。

  • 將 ECal 模組的狀態變更為可信度狀態。

  • 量測並顯示可信度狀態和記憶體軌跡。

縮放 開啟「縮放」對話方塊。

顯示提示 核取以顯示連接的提醒（預設）。

軌跡檢視選項

資料與記憶體軌跡 顯示目前的量測資料與記憶體軌跡。

資料/記憶體 執行操作，用目前量測資料除以記憶體中的資料。

資料 + 記憶體 執行操作，將目前量測資料與記憶體中的資料相加。

驗證套件

量測已知裝置（而非校準標準）是一種驗證網路分析器系統運作是否正常的直接方法。驗證套件使用幅度和相位回應定義妥當且準確已知的驗證標準。這些套件包括準確度空氣線、不匹配空氣線和準確度固定衰減器。磁碟中的每個套件均隨附可追蹤量測資料，驗證套件可能會由 Keysight 重新認證。

請參閱分析器配件以取得 Keysight 驗證套件的清單。

上次修改時間：

2014 年 08 月 21 日

第一版


校準標準

下列區段說明有關校準套件檔案的一般原則和術語。若要瞭解如何修改校準套件檔案，請參閱修改校準套件。

  • 關於校準套件

  • 校準標準

  • 標準類型

  • 標準定義

  • 類別指派

請參閱其他校準主題

關於校準套件

校準套件是一組稱為標準的實體裝置。每一個標準都有一個做為頻率函數的精確已知或可預測的幅度和相位回應。

若要使用校準套件中的標準來校準分析器，必須以數學運算方式定義每一個標準的回應，並將其組織到與分析器所使用的誤差模型對應的標準類別中。

若要能使用特定校準套件，必須將套件中每一個標準的已知特性儲存至分析器記憶體中。可以使用 VNA 完成此操作。包含標準定義的所有 Keysight 校準套件儲存在 VNA 中。如需 Keysight 校準套件的清單，請參閱分析器配件。

校準標準

校準標準提供網路分析器中修正誤差量測的參考。每一個標準都具有精確已知定義，這些定義包括電延遲、阻抗和損耗。分析器儲存這些定義並將其用於計算誤差修正項。

量測校準期間，分析器量測標準，並以數學運算方式將結果與這些標準的「理想模型」進行比較。不同之處將分成多個誤差項，並於稍後誤差修正期間從裝置量測中予以移除。請參閱「系統誤差」。

標準類型

標準類型是四個基本類型之一，可定義要用於該標準的模型形式或結構。下列為四個基本標準類型：

標準

端子阻抗

短路

零歐姆

開路

無限歐姆

負載

系統阻抗，Z0

直通/線路

無端子阻抗

瞭解其他校準標準：

  • 資料式標準

  • 滑動負載

  • 偏移負載

  • 任意阻抗負載

標準定義

標準定義說明它們將要使用的標準和頻率的電特性。可從進階修改校準套件功能表選擇檢視標準定義。標準定義包括：

  • 最低頻率 指定使用標準進行校準的最低頻率。

  • 最高頻率 指定使用標準進行校準的最高頻率。

  • Z0 指定標準的特性阻抗（而非系統特性阻抗或標準的端子阻抗）。

  • 延遲 指定所定義之標準和實際校準平面之間的傳輸線的統一長度。

  • 類型 指定標準的類型（短路、開路、直通/線路、負載、任意）。

  • 損耗 指定沿著同軸纜線單向長度因趨膚效應導致的能量損耗。

損耗模型等式：

  • 損耗的值是以 1 GHz 上的 ohm/s 為單位輸入的。

  • 若要計算標準的損耗，請量測延遲（以秒為單位）和損耗（以 1 GHz 上的 dB 為單位）。然後使用下列公式：

電容模型等式：

C0、C1、C2、C3。指定開路標準的邊緣電容。

  • C = (C0) + (C1 x F) + (C2 x F²) + (C3 x F³)

  • （F 為量測頻率）。

  • 指定開路時按照如下所示定義等式中的各項：

    • C0 項是三次方多項式常數項，以法拉表示。

    • C1 項以 F/Hz（法拉/赫茲）表示。

    • C2 項以 F/Hz² 表示。

    • C3 項以 F/Hz³ 表示。

電感模型等式：

L0、L1、L2、L3。指定短路標準的殘留電感。

  • L = (L0) + (L1 x F) + (L2 x F²) + (L3 x F³)

  • （F 為量測頻率）。

  • 指定短路時按照如下所示定義等式中的各項：

    • L0 項是三次方多項式常數項，以亨利表示。

    • L1 項以 H/Hz（亨利/赫茲）表示。

    • L2 項以 H/Hz² 表示。

    • L3 項以 H/Hz³ 表示。

類別指派

特性化標準之後，必須將其指派至標準「類別」。標準類別是一組按照 VNA 誤差模型的校準組織的標準。

特定校準類型所需的類別數目等於所修正的誤差項的數目。

一個類別通常由單一標準組成，但也可能由多個標準組成。如果要取得高準確度或覆蓋較寬的頻率範圍，則需要這些標準。

例如：一個回應校準只需要一個類別，而該類別的標準可能包括開路、短路或直通。一個單連接埠校準需要三個類別。一個雙連接埠校準需要 10 個類別，不包括用於隔離的兩個類別。

對於非引導式校準，指派至指定類別的標準數目可能是 1 到 7 不等。引導式校準允許視需要使用任意數目的標準。

可在「進階修改校準套件」功能表的 SOLT 或 TRL 標籤中指派校準類別。

VNA 中使用的不同類別如下：

S11A、S11B、S11C（S22A、S22B、S22C 等）

這些是適用於連接埠 1 反射校準的三個類別（這三個類別也適用於 S22 和 S33）。它們用於單連接埠校準和全雙連接埠校準。移除方向性、來源匹配和反射追蹤誤差時需要使用它們。通常，這些類別可由每一個連接埠的開路、短路和負載標準組成。

傳輸和匹配（順向和逆向）

這些類別用於執行全雙連接埠校準。 傳輸類別主要與傳輸追蹤相關，而匹配類別則是指負載匹配。 對於這兩個類別，典型標準為直通或延遲。

隔離

隔離類別用於執行全雙連接埠和 TRL 雙連接埠校準。隔離類別適用於 VNA 誤差模型中的順向和逆向串擾項。

TRL THRU

這些類別用於執行 TRL 雙連接埠校準。TRL 直通類別應包含直通標準或短線路。 如果它包含一個非零長度直通標準，則此校準類型稱為 LRL 或 LRM。

TRL 反射

這個類別用於執行 TRL 雙連接埠校準。TRL 反射類別應包含反射係數高的標準，通常為開路或短路。 不需要知道實際反射係數，但必須正確指定其相角（± 90 度）。 在 TRL 校準程序中，必須在兩個連接埠上使用完全相同的反射標準。

TRL 線路或匹配

這些類別用於執行 TRL 雙連接埠校準。TRL 線路或匹配類別應包含線路標準、負載標準或同時包含此兩者。 如果使用線路標準，其相位偏移與 TRL 直通標準的相位偏移必須相差 20° 到 160°。 這會將可用頻率範圍限制為大約 8 到 1。 可以指定長度不同的兩個或更多線路標準來取得更寬的頻率涵蓋範圍。 通常還可以包括負載標準以涵蓋低頻率，其中線長度可以不是實際長度。 使用負載時，校準類型稱為 TRM 或 LRM。

附註： 如需詳細資訊，請閱讀指定 Keysight 向量網路分析器的校準標準和套件（應用說明 1287-11）。


修改校準套件

VNA CalKit Editor 是一個獨立的應用程式，已整合到 VNA 韌體中。

下列主題討論修改校準套件：

使用 VNA CalKit Editor

  • 「接頭」標籤

  • 「標準」標籤

  • 「SOLT」標籤

  • 「TRL」標籤

概念

  • 為何修改校準套件

  • VNA 校準套件檔案類型

  • 關於 VNA 校準套件和韌體升級

程序

  • 如何從現有校準套件建立新校準套件

  • 使用新接頭系列建立自訂校準套件

附註： 雖然使用者介面已經發生了變更，但仍可以使用現有的遠程指令修改校準套件。

如何修改校準套件

使用以下一系列對話方塊可以修改校準套件檔案的標準定義或類別指派。

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集與校準套件） > Cal Kit...（校準套件...）

編輯 VNA 校準套件

管理校準套件對話方塊說明

用於存取所有 Keysight 校準套件，並允許修改其標準定義。

VNA 校準套件和韌體升級

  • 所有 VNA 校準套件都只能透過目前或更高的韌體版本匯入。無法用過去的韌體版本匯入。透過更高韌體版本匯入校準套件後，就無法用作為其來源的先前韌體版本進行匯入。

編輯...叫用「編輯套件」對話方塊的「接頭」標籤，以修改選取的校準套件定義。

匯入... 叫用匯入套件對話方塊。

儲存...使用 .xkt、.ckt 或 .prn 檔案類型儲存選取的校準套件定義。請參閱 VNA 校準套件檔案類型主題。

插入... 叫用空白「編輯套件」對話方塊，以建立新的校準套件定義。

刪除刪除選取的校準套件檔案。

列印...將所選校準套件的內容列印到 .prn 檔案。

儲存工作區... 將 VNA 中的所有校準套件儲存到 *.xkw 或 *.wks 檔案。*.wks 格式是由舊版本的 PNA 韌體對一組校準套件定義進行封存時使用的預設格式，它不是 Excel 試算表檔案。

重新叫用工作區... 從以前的韌體升級和「另存新檔」作業開啟校準套件的封存。

還原預設值 從 VNA 硬碟重新安裝所有 Keysight 校準套件的預設原廠內容。原廠 Keysight 校準套件儲存在 VNA 硬碟上的 D:\PnaCalKits\factory 中。

已安裝的套件

如需詳細資訊，請參閱使用接頭系列建立自訂校準套件。

匯入套件對話方塊說明

附註： 對可匯入的校準套件的數量沒有限制。但是，在非引導式校準期間，只能存取機械校準套件 1 至 95。

從硬碟或其他磁碟機匯入使用多種格式儲存的校準套件定義。

檔案類型 選取校準套件的檔案類型。瞭解有關 VNA 校準套件檔案類型的詳細資訊。

檔案名稱 導覽並選取校準套件檔案。

開啟 匯入選定的檔案。套件將新增到校準套件清單末尾。

附註：請參閱「VNA 校準套件和韌體升級」

匯入除目前 VNA 系列套件以外的套件

來自 Keysight「舊版」網路分析器（上述所列）的校準套件檔案可能不包含 VNA 需要的資訊。因此，VNA 將盡力修改校準套件名稱和說明、校準標準和校準類別指派。在匯入舊版校準套件之後，您可能需要修正這些修改以便滿足您的特定要求。

  • 「舊版」校準套件檔案基於分析器測試連接埠性，而 VNA 校準套件基於受測裝置 (DUT) 接頭的性。 因此，在匯入套件時，標準標籤和說明將反轉，並註明 F-（母接頭）和 M- （公接頭）。

  • 如果在套件檔案中偵測到同軸標準，則通常會建立一對公/母接頭。

  • 作為接頭建立的波導標準沒有性。

上次修改時間：

2014 年 12 月 08 日

初始版本


為何修改校準套件

對於大多數應用，預設校準套件型號可以提供足夠的校準準確度。但是，可能還會有少數情況需要您建立自訂校準套件：

  • 使用的接頭介面與預先定義的校準套件型號中使用的不同。

  • 使用的標準（或標準組合）與預先定義的校準套件標準不同。例如，使用三個偏移短路（而不是開路、短路和負載標準）執行 1 連接埠校準。

  • 提高預先定義的套件型號的準確度。當型號描述標準的實際效能時，校準將更準確。例如：例如，7 mm 負載被確定為 50.4 Ω，而不是 50.0 Ω。

  • 在為不可插入的裝置執行校準的情況下修改直通定義。

  • 執行 TRL 校準。

上次修改時間：

2014 年 08 月 21 日

第一版


關於 VNA 校準套件和韌體升級

安裝新韌體後，將會覆寫預設的「原廠」校準套件。您的自訂校準套件（具備自訂檔名的檔案）不會遭覆寫。但是，必須將自訂校準套件匯入（按一下匯入套件）新韌體。

所有 VNA 校準套件都只能透過目前或更高的韌體版本匯入。無法用過去的韌體版本匯入。透過更高韌體版本匯入校準套件後，就無法用作為其來源的先前韌體版本進行匯入。

當韌體進行升級時，VNA 上顯示的所有原廠和自訂校準套件均會以唯一檔案名稱儲存至單一 *.wks 檔案。這些檔案並非 Excel 試算表檔案。可以用開啟按鈕來開啟這些檔案。這些檔案可用作先前韌體版本校準套件的封存檔。

上次修改時間：

2014 年 08 月 21 日

第一版


使用新接頭系列建立自訂校準套件

建立新的接頭系列

若要建立使用新接頭類型的自訂校準套件，必須首先定義接頭系列。接頭系列是校準套件的接頭類型名稱，例如：

  • APC7

  • 2.4 mm

  • N 型 (50Ω)

雖然允許有多個接頭系列，但最好將每個校準套件限制為僅一個接頭系列。

如果您使用的接頭系列有公接頭和母接頭，則包括這兩種接頭的定義。如果您使用的接頭系列沒有性（例如 APC7），僅需要一個接頭定義。

使用下列步驟建立自訂校準套件：

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集與校準套件） > Cal Kit...（校準套件...）

  2. 在管理校準套件對話方塊中，按一下編輯套件...。

  3. 在「接頭」標籤中，按一下新增以命名新的接頭系列。

  4. 輸入自訂校準套件的套件說明。

  5. 按一下對話方塊「接頭」區段中的新增。

  6. 輸入接頭系列名稱。

  7. 輸入接頭說明。

  8. 選取一個接頭的性。

  9. 輸入最低和最高頻率範圍。

  10. 輸入阻抗。

  11. 按一下向下箭頭選取媒體。

  12. 輸入截止頻率

  13. 按一下套用。

  14. 按一下確認。

  15. 如果需要新增另一個接頭的性，請在「接頭」標籤中，再按一下「接頭」區段中的新增，以新增下一個接頭的性。

  16. 如果您要新增另一個接頭的性，請重複步驟 3。

附註：如果您有公母版本的接頭系列，可能不會同時擁有「無性」版本。

輸入標準

現在已經將接頭系列新增至自訂校準套件，可以新增新的校準標準。

  1. 在「標準」標籤的標準清單下方，按一下新增。

  2. 選取標準的類型（開路、短路、負載或直通），然後按一下確認。

  3. 在對話方塊中完成所選標準資訊的輸入。請注意，對於有頻帶的標準，啟動和停止頻率可能會不同於指定接頭的頻率範圍。請視需要編輯啟動和停止頻率。如果所有設定都是正確的，請按一下確認。

  4. 如有需要，請重複步驟 2-3 以新增所有標準和定義至新的自訂校準套件。

  5. 將每個標準指派至校準級別。可透過 TRL 標籤或 SOLT 標籤來完成此作業。

  6. 儲存校準套件。

上次修改時間：

2014 年 08 月 21 日

第一版


如何從現有校準套件建立新校準套件

您可以使用現有的校準套件作為起點來建立新的自訂校準套件。

方法如下：

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集與校準套件） > Cal Kit...（校準套件...）

  2. 在管理校準套件對話方塊中，按一下另存為並變更檔案名。選取 *.xkt、*.ckt 或 *.prn 檔案類型。瞭解有關這些檔案類型的更多資訊。

  3. 根據需要對新的自訂標準套件進行修改。

  4. 按一下儲存以按慣例儲存工作。

另請參閱

關於 VNA 校準套件和韌體升級

上次修改時間：

2014 年 08 月 22 日

第一版


VNA 校準套件檔案類型

VNA 校準套件編輯器可開啟以下類型的校準套件檔案：

VNA 系列 | 檔案類型
目前的 VNA 系列校準套件 | *.xkt（預設為使用 VNA、PNA A.10.00 及以上版本） *.ckt *.ckx
舊版 VNA 系列校準套件（PNA A.07.50 之前） | *.ck1
8510 校準套件 | .CK_*
8753、8752、8719、8720 或 8722 校準套件 | *.ck
目前 FieldFox 校準套件 | *.xkt
先前 FieldFox 校準套件 | *.xml

目前版本的校準套件檔案可從以下網址下載：http://na.support.keysight.com/pna/caldefs/stddefs.html

檔案儲存（另存新檔）

VNA 校準套件編輯器可採用三種格式儲存校準套件：

  • *.xkt - 基於 XML 的格式，受多個 VNA 系列支援（預設格式）。

  • *.ckt - VNA 二進位格式，可由 VNA 和 PNA Rev. A.07.50 及更高版本讀取。格式旨在與較舊 PNA 韌體版本回溯相容，且可能不支援 *.xkt 等格式有望支援的新校準套件功能。

  • *.prn - 校準套件列印檔案。 這是一種文字檔案格式，可讀取至試算表中，但校準套件編輯器不會讀取這些檔案，僅會作為一種文件格式生成。

檔案關聯

除了 *.xml 以外，上述檔案類型還會自動與校準套件編輯器關聯（如果尚未與其他程式關聯）。這意味著執行校準套件編輯器之後，按兩下上述任一檔案類型（*.xml 除外）時，將使用校準套件編輯器開啟該檔案。

如果已將其中某一種檔案與其他程式關聯，且希望將其變更為校準套件編輯器，請執行以下作業：

  1. 在檔案上按一下滑鼠右鍵，然後按一下開啟

  2. 瀏覽至校準套件編輯器的安裝資料夾。

    • C:\Program Files (x86)\Agilent\VNA Cal Kit Editor

  3. 核取始終使用所選程式開啟此類檔案。

  4. 選取校準套件編輯器。

上次修改時間：

2014 年 08 月 25 日

第一版


「接頭」標籤

校準套件名稱 允許變更選取的校準套件的名稱。

校準套件說明 允許變更選取的校準套件的說明。

接頭系列 按一下向下箭頭以選取與校準套件關聯的接頭系列。

新增 啟動新增接頭對話方塊，以便將新的接頭類型新增至校準套件。

刪除 刪除 - 不顯示警告 - 選取的接頭系列。

附註： 若要修改接頭系列或名稱，請新增接頭，然後刪除舊接頭。

以下是出廠定義的接頭類型字串清單：

APC 3.5 母接頭

APC 3.5 公接頭

APC 2.4 母接頭

APC 2.4 公接頭

APC 7

N 型 (50) 母接頭

N 型 (50) 公接頭

N 型 (75) 母接頭

N 型 (75) 公接頭

F 型 (75) 母接頭

F 型 (75) 公接頭

A 型 (50) 母接頭

A 型 (50) 公接頭

B 型

7-16 母接頭

7-16 公接頭

2.92 mm 母接頭

2.92 mm 公接頭

1.85 mm 母接頭

1.85 mm 公接頭

1.0 mm 母接頭

1.0 mm 公接頭

X 頻帶波導

P 頻帶波導

K 頻帶波導

Q 頻帶波導

R 頻帶波導

U 頻帶波導

V 頻帶波導

W 頻帶波導

頻率範圍

最小值 允許定義使用標準進行校準的最低頻率。

最大值 允許定義使用標準進行校準的最高頻率。

性

有性 - 接頭系列既包含公接頭又包含母接頭。

無性 - 接頭系列不包含公接頭和母接頭。APC7 接頭是此接頭類型的範例。

阻抗

指定標準的阻抗。

媒體

接頭的媒體（或「幾何」）（同軸或波導）。

截止頻率 如果媒體是波導，請輸入低端截止頻率。

高寬比率 用於計算波導損耗。該值通常位於波導裝置的資料工作表中。

關於波導校準套件

如果要修改或建立波導校準套件，請務必進行以下設定。可以使用現有的出廠波導校準套件作為起點來建立自訂波導校準套件。出廠校準套件已包含這些設定。

  • 頻率範圍：最低頻率 = 截止頻率。

  • 性：無性

  • 阻抗 Z0：1 ohm

  • 媒體：波導

對於波導，請選取 TRL（直通-反射-線路）校準類型。這些校準類型比 SOLT 更準確，所需的步驟也更少。

新增接頭系列

輸入新接頭系列的名稱。然後按一下確認。

位於每個標籤的下方

另存為 - 允許使用新檔案名稱和類型儲存校準套件。

儲存 - 使用相同的檔案名稱和類型儲存校準套件。

關閉 - 關閉校準套件編輯工作階段。系統不會自動儲存此檔案。

上次修改時間：

2014 年 08 月 25 日

第一版


「標準」標籤

允許在校準套件中新增、編輯或刪除校準標準。

新增標準（開路、短路、負載、直通或資料式）

新增標準對話方塊說明

允許新增標準到校準套件檔案。

選擇範圍：

  • 開路

  • 短路

  • 負載

  • 直通

  • 資料式

  • 隔離

標準對話方塊說明

下列欄位適用於所有標準類型：

對話方塊的其他區域將依所選標準的類型而變化。

識別

標準 ID 標準清單中的編號。

標籤 標準的類型。通常出現在標準的提示中。

說明 標準的說明。

下列欄位適用於所有標準類型，但「隔離」類型除外：

接頭

指示標準的類型和性（公接頭、母接頭、無）。

直通標準和隔離標準有兩個接頭。

資料式標準可能有兩個接頭。

頻率範圍

最小值 定義使用標準進行校準的最低頻率。

最大值 定義使用標準進行校準的最高頻率。

「延遲特性」欄位適用於大多數標準類型：

延遲特性

延遲 定義從校準平面到標準的單向傳導時間（秒）。

Z0 定義標準的阻抗。

損耗定義沿著同軸纜線單向長度因趨膚效應導致的能量損耗 (Gohms)。

其他欄位為標準類型專有

選擇範圍：

  • 開路

  • 短路

  • 負載

  • 直通

  • 資料式

  • 隔離

開路標準

C0、C1、C2、C3 指定邊緣電容。

這些是對話方塊專有的欄位。請查看所有標準共有的區域。

短路標準

L0、L1、L2、L3 指定殘留電感。

負載標準

從下列項目中選擇

固定負載 將負載類型指定為「固定」。固定負載被假設為不存在反射情況的理想終端。

滑動負載

滑動負載是透過位於長傳輸線的各個標記位置上的滑動負載元素對裝置進行多次量測來定義的。假設傳輸線具有零反射，負載元素具有有限反射，可使用最小二乘圓擬合方法以數學運算方式來移除這種有限反射。

如果執行正確，滑動負載校準將非常精確。但若不使用適當的技術，滑動負載校準就會非常不準確。若要獲得精確的結果，請嚴格按照使用者手冊的指示來執行滑動負載。

任意阻抗

指定阻抗值不同於系統 Z0 的負載類型。 任意阻抗裝置類似於固定負載，不同處在於負載阻抗並不理想。VNA 系列的早期韌體版本使用固定的電阻值。已新增複數終端阻抗，可對電路板或晶片裝置進行更精確的建模。

僅當選取了「任意阻抗」，才能使用下列「複數阻抗」設定：

    • 實數 阻抗值的實數部分。

    • 虛數 阻抗值的虛數部分。

偏移負載

與寬頻負載校準相比，使用偏移負載標準可提高校準的準確度。因此，在使用其中一個修改後的校準套件定義來執行校準時，系統可能會提示您連接比此變更之前更多的標準。若要回復為使用無偏移的寬頻負載標準，請執行下列操作：

  1. 按 [Cal] > Cal Sets & Cal Kits（校準集與校準套件） > Cal Kit...（校準套件...）

  2. 在管理校準套件對話方塊中，按一下編輯套件...。

  3. 選取 SOLT 標籤。

  4. 在「校準套件類別」下方，選取 SC（負載）。

  5. 在「SC 選定標準」下方，選取寬頻負載，然後按一下上移，直到該標準移至清單的最上方。這樣可確保最先使用「寬頻負載」。

關於偏移負載

偏移負載是一個複合標準，它包含一個負載元素和兩個長度不同的已知偏移元素（傳輸線）。較短的偏移元素可以是零長度（沖洗直通）偏移。負載元素定義為 1　連接埠反射標準。當偏移元素的回應值比負載元素的回應值更精確時，將使用偏移負載標準。波導的情況也是如此。偏移負載標準的量測包含兩個量測，每個量測均包含由負載元素終止的兩個偏移元素其中之一。應設定偏移負載標準的頻率範圍，使每個量測的預期回應值之間至少有 20 度的間隔。

若要指定兩個以上的偏移元素，請定義多個偏移負載標準。如果使用兩個以上的偏移元素，將有可能擴大頻率範圍，這是因為每個頻率的內部演算法都會搜尋所有可能的偏移組合，以找出預期間隔最寬的配對，用於確定負載元素的實際回應。

僅當選取了「偏移負載」，才能使用下列「偏移負載」設定。

    • 第一個偏移標準

    • 第二個偏移標準

    • 負載標準

直通標準

接頭 - 定義直通標準兩端的接頭類型。

虛擬裝置

大多數校準套件都只有一個直通標準定義用於 SOLT 校準。對於這些情況，請使用預設選項（零長度直通為已勾選；非零長度直通則為未勾選）。

此核取方塊用於針對同一對連接埠的直通標準，以兩個不同步驟進行正向和反向量測。對於零長度（沖洗）直通標準來說，這並不常見。

如果已勾選，涉及該直通的校準提示將會省略「說明」。例如，「請將連接埠 1 連接至連接埠 2」。這是沖洗直通標準的常見提示。

如果未勾選，該直通的校準提示將會包含「說明」。例如，「連接連接埠 1 和 2 之間的 <標準說明>」。

若要針對同一對連接埠的直通標準，以兩個不同步驟進行正向和反向量測，請執行以下操作：

  1. 使用相同的設定分別為直通標準建立定義，但「標籤」和「說明」除外。不勾選這兩個定義的此核取方塊。

  2. 對於其中一個直通定義，在標籤和說明中包含「FORWARD」一詞，以提示操作員使用此標準來進行正向量測。 將此標準指派給校準套件的 SOLT「正向傳輸」和「正向匹配」類別。

  3. 對於另一個直通定義，在標籤和說明中包含「REVERSE」一詞，以提示操作員使用此標準來進行反向量測。 將此標準指派給校準套件的 SOLT「反向傳輸」和「反向匹配」類別。

  4. 使用此校準套件執行 SOLT 校準時，將以兩個單獨的連接步驟，分別對直通進行正向量測和反向量測。

資料式標準

瞭解資料式校準套件與多項式校準套件的相對準確度。

修改後的檔案稍後可上傳至 VNA。

從檔案上傳資料

按一下載入資料檔案，然後導覽至資料式校準套件隨附的 *.dat 檔案。單一 *.dat 檔案中同時提供了回應資料與準確度（不確定性）資料。

對於進階使用者

可從 *.s2p 或 *.cti 檔案載入回應資料。

可從 *.cti 檔案載入準確度資料。

虛擬裝置

當資料式校準標準定義為具有 2 個連接埠時，該標準會顯示這個核取方塊。

  • 如果不勾選（預設），該標準的校準提示將包含其「說明」。例如，「連接連接埠 1 和 2 之間的 <標準說明>」。

  • 如果勾選，該標準的校準提供將不會包含其「說明」，因此，提示的內容將與資料式標準是零長度直通連接時顯示的內容相同。例如，「請將連接埠 1 連接至連接埠 2」。

隔離標準

一對負載將視為一個標準。

兩個負載都會連接到 VNA，然後根據相同的提示進行量測。

位於每個標籤的下方

另存為 - 允許使用新檔案名稱和類型儲存校準套件。

儲存 - 使用相同的檔案名稱和類型儲存校準套件。

關閉 - 關閉校準套件編輯工作階段。系統不會自動儲存此檔案。

上次修改時間：

2014 年 08 月 25 日

第一版


「SOLT」標籤

附註：此對話方塊與檢視/修改校準嚮導對話方塊之後出現的對話方塊類似。但是，該對話方塊中的設定變更僅影響正在進行的校準。這些設定（透過「修改校準套件」存取）可變更將來使用此校準套件的所有校準的校準套件。

允許將一個或多個標準指派給 SOLT 校準類別。

按一下 TRL 標籤可將標準指派給 TRL 校準類別。

  1. 對於每一個校準套件類別，從左側清單中選取可用標準，然後按一下>> 將標準複製到校準套件。

  2. 使用上移和下移可變更標準的順序。引導式校準中使用的順序將確定涉及定義標準頻率範圍的校準中要使用該類別中的哪些標準。引導式校準將按標準在此類別清單中出現的順序涵蓋標準。如果類別清單中標準的範圍重疊，則該順序還可確定哪個標準用於重疊範圍內的頻率。 例如，假設您根據最低頻率 = 0 Hz 和最高頻率 = 999 GHz 定義寬頻短路，並且在 SB 或 TRL 反射類別中先列出該標準。然後，如果在這些相同類別中的寬頻短路下面列出具有相同接頭的頻帶短路，則引導式校準不會使用頻帶短路，因為它始終會優先考慮寬頻短路。

SOLT <校準類別>標籤

非引導式 SOLT 校準期間出現在 VNA 使用者介面中的校準標準類別標籤。

校準套件類別

對於每個校準類別，請選取可用標準，然後按一下 >> 以移動到選定標準清單。

  • SA - 開路標準

  • SB - 短路標準

  • SC - 負載標準

  • 正向/反向傳輸和匹配 - 直通標準。大多數校準套件都不包括物理直通標準，但假設將使用可插入直通標準。

  • 隔離 - 隔離標準。 對於 VNA 分析器，通常不建議使用隔離校準。在某些情況下，如果使用使用者提供的自訂測試裝置硬體，這樣做可能非常有益。

連結正向傳輸、正向匹配、反向傳輸和反向匹配 核取可自動將正向傳輸的標準定義指派給正向匹配、反向匹配和反向傳輸。清除可單獨指派正向匹配、反向匹配和反向傳輸類別（僅限 SOLT 校準）。

擴展校準

以下兩個核取方塊僅在引導式校準期間適用。對於非引導式校準，將會忽略這些核取方塊，即便顯示了多個標準的對話方塊也是如此。

量測類別中的所有耦合標準 核取此方塊可達到可能的最高準確度。例如，如果校準套件包含若干負載標準，則在校準過程中，系統將提示您量測每個標準。這可能需要較長的校準時間。選中後，也會自動核取「盡量使用擴展數學運算」方塊。

盡量使用擴展數學運算 某些套件包含多個同類型的校準標準，這些標準共同覆蓋一系列頻率範圍。（例如：多個短路或低通負載和滑動負載。）如果校準需要多個標準才能覆蓋校準頻率範圍，則量測區域可能會出現重疊。選取此核取方塊後，VAN 會自動使用「加權最小二乘擬合」演算法計算重疊區域中最精確的量測。此功能可在確保校準速度的同時提高準確度。

  • 僅當使用包含多個同類標準的校準套件時才手動選取此核取方塊。（例如：多個短路或低通負載和滑動負載。）

  • 依預設，從校準套件功能表中選取多項式模型時，會清除該核取方塊。

  • 依預設，從校準套件功能表中選取基於資料的模型 85058B 或 85058E 時，會核取該核取方塊。

位於每個標籤的下方

另存為 - 允許使用新檔案名稱和類型儲存校準套件。

儲存 - 使用相同的檔案名稱和類型儲存校準套件。

關閉 - 關閉校準套件編輯工作階段。系統不會自動儲存此檔案。

上次修改時間：

2014 年 08 月 25 日

第一版


「TRL」標籤

在下圖中，按一下設定區域可瞭解更多資訊。

允許將一個或多個標準指派給校準類別。

  1. 對於每一個校準套件類別，從左側清單中選取可用標準，然後按一下>> 將標準複製到校準套件。

  2. 使用上移和下移可變更標準的順序。引導式校準中使用的順序將確定涉及定義標準頻率範圍的校準中要使用該類別中的哪些標準。引導式校準將按標準在此類別清單中出現的順序涵蓋標準。如果類別清單中標準的範圍重疊，則該順序還可確定哪個標準用於重疊範圍內的頻率。例如，假設您根據最低頻率 = 0 Hz 和最高頻率 = 999 GHz 定義寬頻短路，並且在 SB 或 TRL 反射類別中先列出該標準。然後，如果在這些相同類別中的寬頻短路下面列出具有相同接頭的頻帶短路，則引導式校準不會使用頻帶短路，因為它始終會優先考慮寬頻短路。

附註：對於這些優先順序行為，TRL 線/匹配類別有極小的例外狀況。 線標準的優先順序通常高於匹配標準。 因此，如果線標準和匹配標準均定義為具有相同的頻率範圍，則匹配標準在類別排序中會列在線標準之上，而引導式 TRL 校準仍會優先使用線標準，而非匹配標準。

TRL <校準類別> 標籤

非引導式 TRL 校準期間出現在 VNA 使用者介面中的校準標準類別標籤。

校準套件類別

  • 對於 VNA 分析器，通常不建議使用隔離校準。在某些情況下，如果使用使用者提供的自訂測試裝置硬體，這樣做可能非常有益。

TRL THRU

附註：TRL 校準支援所有直通校準方法，但未知直通除外。

  • 直通標準可以是零長度或非零長度。但是零長度直通更精確，因為根據定義，它的損耗為零且無反射。

  • 直通標準不能與線路標準具有相同的電氣長度。

  • 如果已妥善定義插入相位與電氣長度，則直通標準可用於設定參考平面。

  • 直通標準和線標準具有相同的特性阻抗且完美匹配。它們將定義校準的參考阻抗。

  • 如果具有正確接頭的直通標準不可用，則可執行配接器移除校準。

TRL 反射

  • 只要連接到一個或多個 VNA 連接埠時相同，反射標準可以是具有高反射的任何物件。

  • 每個連接埠的反射標準均相同。

  • 不需要知道實際反射幅度。

  • 反射標準的相位必須已知在 1/4 波長範圍內。

  • 如果已妥善定義反射標準的幅度和相位，則此標準可用於設定參考平面。

TRL 線路

在校準完成之後，線路標準和直通標準會為量測建立參考阻抗。TRL 校準受限於下列線路標準的限制：

  • 必須採用與直通標準相同的阻抗和傳遞常數。

  • 電氣長度僅需在 1/4 波長範圍內指定。

  • 長度不能與直通標準相同。

  • 涵蓋廣泛頻率範圍的 TRL 校準需要多個線標準。例如，從 2 GHz 到 26 GHz 的跨距需要兩種線標準。

  • 必須是頻率範圍的適當電氣長度：在每個頻率中，直通和線之間的相位差應大於 20 度並小於 160 度。這表示在實際應用中，單一線標準僅能用於 8:1 頻率範圍（頻率跨距/開始頻率）。因此，對於廣泛的頻率涵蓋範圍，需要多個線路標準。

  • 在低頻率中，線路標準對於實際使用而言可能會太長。線路標準的最佳長度是頻率跨距為幾何均值（f1 x f2 的平方根）時的 1/4 波長。

附註：TRL 線路標準必須具有大於 0（零）ps 的延遲。否則，校準修正計算將包含不可預期的結果。

TRL 匹配

如果不能設計具有適當長度或損耗的線標準，則可能使用匹配標準，而非線標準。

  • 匹配標準是一個同時連接到連接埠 1 和連接埠 2 的低反射終端。

  • 匹配標準可定義為無限長度傳輸線或 1 連接埠低反射終端（例如，負載）。

  • 當定義為無限長度傳輸線時，匹配標準必須在相同的時間終止這兩個測試連接埠。當定義為 1 連接埠負載標準時，將分別量測各個負載。負載會假設為具有相同的特性。

  • 匹配標準的阻抗會成為量測的參考阻抗。若要獲得最佳結果，請在這兩個連接埠上使用相同的負載。您可以使用資料式定義、任意阻抗定義或固定負載定義來定義負載。

校準參考 Z0 （僅限 TRL）

系統 Z0 系統阻抗用作參考阻抗。當所需的測試連接埠阻抗與線標準的阻抗不同時，請選擇此選項。此外，當同軸線需要趨膚效應阻抗修正時，請選擇此選項。

線路 Z0 線標準的阻抗用作參考阻抗或史密斯圖的中心。線標準的任何反射均會假設為方向性誤差的一部分。

測試連接埠參考平面 （僅限 TRL）

直通標準 直通標準定義用於建立量測參考平面。如果直通標準的長度為零或非常短時，請選取此選項。

反射標準 反射標準定義用於建立量測參考平面的位置。如果直通標準不適用且反射標準的延遲已妥善定義，請選取此選項。

此外，如果由於齊平短路提供的相位參考比直通標準更精確，因此將齊平短路用於反射標準，請選取此選項。

LRL 線路自動特性化

附註：僅當正在修改 LRL 校準套件，且測試連接埠參考平面設定為直通標準，且 TRL 直通類別標準和 TRL 線路/匹配類別標準均具有相同的偏移 Z0 值和損耗時，才套用此設定。否則將忽略此設定。

  • 勾選此方塊可讓 VNA 自動修正線損耗和擴散特性。

  • 如果校準量測期間出現異常（可能針對線標準指示不同損耗和阻抗值），請不要勾選此方塊。

位於每個標籤的下方

另存為 - 允許使用新檔案名稱和類型儲存校準套件。

儲存 - 使用相同的檔案名稱和類型儲存校準套件。

關閉 - 關閉校準套件編輯工作階段。系統不會自動儲存此檔案。

上次修改時間：

2014 年 08 月 25 日

第一版


標記

標記提供所量測資料的數值讀數、特定值的搜尋功能，並且可以變更激勵設定。每個軌跡有 15 個一般標記和一個參考標記（與差量標記搭配使用）可用。本主題討論標記的各個方面。

附註：您可在自訂顯示對話方塊中開啟/關閉及自訂標記讀數。瞭解詳情。

  • 建立和移動標記

  • 標記設定

    • 耦合方法

  • 使用標記進行搜尋

    • 最大值和最小值搜尋

    • 峰值搜尋

    • 多峰值搜尋

    • 目標搜尋

    • 多目標搜尋

    • 頻寬和陷波搜尋

    • 壓縮搜尋

    • PSAT 搜尋

    • PNOP 搜尋

  • 搜尋定義域

  • 搜尋範圍指示器

  • 標記功能（變更儀器設定）

  • 標記顯示

  • 標記表格

其他分析資料主題

建立和移動標記

建立標記

如何建立標記

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Marker] > Marker 1-7（標記 1-7）/Marker 8-15（標記 8-15）/Reference（參考）。

  2. 按一下左側的 Marker N（標記 N）或 Reference（參考）小按鈕。

  1. 將游標移到軌跡上。

  2. 以滑鼠右鍵按一下軌跡，然後選取新增標記...。

移動標記

若要移動標記，請使用上面 3 種方法中的任何一種選取標記的號碼，使其成為作用中標記。作用中標記在分析儀的顯示畫面上會顯示為 Ñ。所有其他標記都是非作用中標記，並且會在分析儀的顯示畫面上顯示為 D。然後使用以下任何方法變更激勵值：

  • 鍵入值。

  • 使用向上/向下箭頭捲動至激勵值。無法變更解析度。

  • 按一下激勵方塊，然後使用前面板旋鈕。

  • 使用手指（觸控螢幕）按一下並拖曳標記，或用滑鼠左鍵按住標記符號。然後，將標記拖曳至軌跡上的任何點。此功能無法在史密斯圖或極座標顯示格式中使用，也無法與固定標記類型搭配使用。

標記設定

如何設定標記設定。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Marker] > Marker Setup（標記設定）。

  2. 針對每個軟鍵設定值或選取所需的設定。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取標記...。

標記對話方塊/[Marker] > Marker Setup（標記設定） Softtab 說明

標記 - 指定您要定義的目前（作用中）標記編號。

開啟 - 勾選後可在螢幕上顯示標記和對應的資料。

激勵值 - 指定作用中標記的 X 軸值。若要變更激勵值，請鍵入值、使用向上和向下箭頭、在文字方塊中按一下，然後使用前面板旋鈕，或在螢幕上拖曳標記。

差量標記 - 勾選後可使作用中標記顯示相對於參考 (R) 標記的資料。每個軌跡只有一個參考標記。所有其他 15 個標記可以是一般標記或差量標記。建立差量標記後，如果尚未顯示，將會自動顯示參考標記。您可從 [標記] 對話方塊或標記工具列啟用差量標記。

離散 - 勾選後將僅顯示量測資料的離散點處的值。清除後可顯示從資料點內插的值。內插的標記將會報告開始頻率和停止頻率之間任何頻率值的 Y 軸資料。

勾選固定 - 勾選後可在將標記設定為固定時，使標記根據其在軌跡上的位置具有固定的 X 軸和 Y 軸位置。它不會隨著軌跡資料幅度而移動。可透過變更標記激勵值使標記在 X 軸上左右捲動。使用此標記類型可以快速監控對測試裝置進行變更「之前和之後」的情況。例如，您可以使用固定標記來記錄調諧濾波器之前和之後的測試結果差異。

清除固定 - 清除此方塊可以建立標準標記，它具有固定的激勵位置（X 軸），並且會對資料幅度（Y 軸）中的變更做出回應。可透過變更標記激勵值使標記在 X 軸上左右捲動。將此標記類型與其中一種標記搜尋類型搭配使用可尋找所需的資料。

（標記）格式 - 以所選格式顯示標記資料。[軌跡預設] 設定具有相同的標記和網格格式。您可以選擇以下格式：

對數/相位 | 對數幅度 | 實數
線性/相位 | 線性幅度 | 虛數
實數/虛數 | 相位 |
R+jX（複數阻抗） | SWR |
G+jB（複數導納） | 延遲 |

勾選耦合標記 - 勾選此方塊可開啟軌跡耦合功能。

清除耦合標記 - 清除此方塊可關閉軌跡耦合功能。

耦合方法 - 勾選後可依標記編號耦合標記， 1 到 1、2 到 2，依此類推。 深入瞭解耦合方法。

全部關閉 - 關閉作用中軌跡上的所有標記。

耦合方法

耦合標記功能可使不同軌跡上的標記與選定軌跡上的標記保持一致。標記依標記編號進行耦合，1 到 1、2 到 2、3 到 3，依此類推。如果 X 軸定義域是相同的（例如頻率或時間），則會在某個通道或所有通道中進行耦合。不同 X 軸定義域中的軌跡標記不會進行耦合。如果選定軌跡上沒有軌跡標記要與之耦合的標記，則該標記將會保持獨立。

全部 - 一個軌跡上的標記將會耦合到所有通道、所有視窗及所有軌跡上編號相同的標記。

通道 - 一個軌跡上的標記將耦合到與原始軌跡共用相同通道號碼的軌跡上編號相同的標記。

使用標記進行搜尋

您可以根據以下軌跡條件使用標記來搜尋並傳回資料：

  • 最大值和最小值：尋找軌跡上的最高點或最低點

  • 峰值：移至其他峰值（左側、右側、下一個最高）

  • 多個峰值

  • 目標值：尋找特定的 Y 軸值

  • 多個目標值：

  • 頻寬（濾波器）

  • 陷波（濾波器）

  • 壓縮點（放大器）

  • 關於 PSAT 和 PNOP 標記

    • 功率飽和（放大器）

    • 功率正常工作點（放大器）

  • 搜尋定義域

  • 搜尋範圍指示器

如何使用標記進行搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Main（主值）/Peak（峰值）/Target（目標值）/Multi Peak & Target（多個峰值和目標值）/Bandwidth & Notch（頻寬和陷波）/Compression & Saturation（壓縮和飽和）/Normal Op Pt（正常工作點）。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋... 以顯示用於定義搜尋參數的 [標記搜尋] 對話方塊。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取所需的搜尋功能。

  4. 按下執行或勾選追蹤。瞭解詳情。

標記搜尋對話方塊/[Search] Softtab 說明

標記 - 指定您要定義的標記。不適用於部署特定標記的搜尋類型。

搜尋定義域 - 定義標記可在其中移動或進行搜尋的區域。針對全頻距，標記會在整個量測頻距內搜尋指定的值。針對使用者頻距，標記會在您定義的量測頻距內搜尋指定的值。深入瞭解搜尋定義域。

搜尋類型

附註： 您必須按下執行或勾選追蹤才能啟動所有搜尋類型。如果搜尋類型沒有有效的資料配對，標記將不會從其目前的位置移動。

  • 執行 - 按一下可使標記搜尋指定的條件。

  • 追蹤 - 勾選後可使標記在每個新掃描中搜尋指定的條件。勾選 [追蹤] 後，搜尋將會根據目前的搜尋類型和定義域資訊，從第一個掃描開始進行。因此，在使用資料之前，請確保搜尋條件處於所需的狀態。如果已針對標記選取 [追蹤]，則無法手動變更標記的激勵設定。

    追蹤作業會視偏好設定中的 [標記:使用單一標記進行標記搜尋] 設定而有所不同。啟用或停用該偏好設定時，依預設會關閉所有現有的標記搜尋並關閉追蹤。

    開啟（勾選）

    這是 E5071C 相容的模式。進階標記搜尋功能（頻寬、陷波、壓縮、飽和及正常工作點）可透過使用永遠會追蹤作用中標記的專用小型子標記來執行。在此模式中，無法將標記搜尋追蹤功能套用至壓縮搜尋以外的進階標記搜尋功能。

    關閉（取消勾選）

    這是 PNA (N52xx) 相容的模式。這些進階標記搜尋功能由標記執行。在預先設定的情況下，標記搜尋追蹤會套用至您選取的進階標記搜尋功能。如果您將標記搜尋追蹤指派給其他標記搜尋功能（例如，最大值追蹤），將會停用這些進階標記搜尋的追蹤作業。

最大值 - 標記會尋找最大（最高）的資料值。深入瞭解最大值搜尋。

最小值 - 標記會尋找最小（最低）的資料值。深入瞭解最小值搜尋。

峰值 - 標記會尋找最高峰值或最低波谷值。峰值或波谷值是否由搜尋極性決定：按下 [Search] > Peak（峰值）> Peak Polarity（峰值極性）。深入瞭解峰值搜尋。

  • 當峰值極性是正極時，標記會移至最大峰值。

  • 當峰值極性是負極時，標記會移至最小峰值。

峰值右側 - 標記將在 X 軸上尋找其開始位置右側的下一個有效峰值。

峰值左側 - 標記將在 X 軸上尋找其開始位置左側的下一個有效峰值。

下一個峰值 - 標記將尋找具有相對於其正峰值搜尋開始位置的下一個較低幅度值的峰值。將針對負峰值搜尋搜尋下一個較高的波谷值。

多個峰值 - 此功能可搜尋與多個峰值搜尋偏移值和多個峰值極性值相符的峰值。深入瞭解多個峰值搜尋。

  • 閾值 - 以 dB 表示的值。

  • 偏移值 - 以 dB 表示的值。

目標值 - 此功能可搜尋與預先定義的目標值和變換類型（正、負或兩者（正和負））相符的目標值，然後將標記移至該目標值。深入瞭解目標值搜尋。

目標值左側 - 此功能可在目前標記位置到較小激勵值的範圍內執行搜尋，並將標記移至遇到的第一個目標值。

目標值右側 - 此功能可在目前標記位置到較大激勵值的範圍內執行搜尋，並將標記移至遇到的第一個目標值。

多個目標值 - 此功能可搜尋屬於多目標值和多目標變換值的目標值。深入瞭解多個目標值搜尋。

  • 目標值 - 以 dB 表示的值。

壓縮 - 此功能可使用作用中的標記尋找指定的增益壓縮電平。深入瞭解壓縮搜尋。

  • 壓縮 - 以 dB 表示的值。

頻寬 - 此功能可根據作用中標記的位置確定軌跡的頻寬、中心頻率、截止點（高頻率一側和低頻率一側）、Q 及插入損耗。深入瞭解頻寬搜尋。

陷波 - 此功能可用於根據作用中標記的位置取得軌跡的頻寬、中心頻率、截止點（高頻率一側和低頻率一側）、Q 及插入衰減。深入瞭解陷波搜尋。

  • 電平 - 以 dB 表示的頻寬和陷波電平。

功率飽和 - 深入瞭解 PSAT 搜尋。

  • PMax 回退值 - 以 dB 表示的值。

正常工作點 - 輸入依輸入功率偏移從回退值輸入功率偏移之處的輸出功率。深入瞭解 PNOP 搜尋。

  • 回退值 - 以 dB 表示的值。

  • 輸入功率偏移 - 以 dB 表示的 X 軸值。

最大值和最小值搜尋

如何建立最大值和最小值搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Main（主值）。

  2. 按一下 Max Search（最大值搜尋）或 Min Search（最小值搜尋）。

  3. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的最大或最小電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取最大值/最小值。

  4. 按下執行或勾選追蹤。瞭解詳情。

您可以在軌跡上搜尋量測到的最大值或最小值，並將標記移至該點。

搜尋最大值（最大值搜尋） | 將作用中的標記移至在軌跡上量測到最大值的點處。
搜尋最小值（最小值搜尋） | 將作用中標記移至在軌跡上量測到最小值的點處。

附註：當資料格式為史密斯圖或極座標格式時，僅針對主回應值執行搜尋。

峰值搜尋

如何建立峰值搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Peak（峰值）。

  2. 按一下 Peak Search（峰值搜尋）以在峰值上顯示標記。

  3. 按一下 Peak Right >> Search（峰值右側 >> 搜尋）、<< Peak Left Search（<< 峰值左側搜尋）或 Next Peak Search（下一個峰值搜尋）以將標記移至峰值。

  4. 按一下 Threshold（閾值）以輸入峰值閾值的值。

  5. 按一下 Excursion（偏移值）以輸入峰值偏移值的下限值。

  6. 按一下 Peak Polarity（峰值極性）以選取峰值極性。

  7. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的峰值電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取峰值/峰值左側/峰值右側/下一個峰值。

  4. 輸入閾值和偏移值的值。

  5. 按下執行或勾選追蹤。瞭解詳情。

峰值是一個量測點，其值大於或小於其右側和左側的相鄰量測點。根據與任一側量測點的幅度差值，峰值分為以下兩種類型。

什麼是「峰值」？

可透過選取以下兩個峰值條件設定來定義分析儀認為的「峰值」：

  • 閾值 - 若要使正峰值搜尋被視為有效，峰值必須高於閾值電平。任一側的波谷值均可低於閾值電平。針對負峰值搜尋，低於閾值電平的波谷值反而會被視為是有效的。

  • 偏移值 - 兩側的峰值和波谷值之間的垂直距離 (dB)。若要被視為有效，資料值必須依偏移值從兩側的峰值下降或從波谷值上升。

峰值極性： | 定義：
正 | 量測值大於任一側量測點之量測值的峰值。 偵測大於閾值的正峰值。
負 | 量測值小於任一側量測點之量測值的峰值。 偵測小於閾值的負峰值。
兩者 | 量測值小於和大於任一側量測點之量測值的峰值。 由於不使用閾值，所以不會偵測。

關於峰值偏移值

峰值偏移值是量測值與相反極性之相鄰峰值的差值中的較小值。

執行峰值搜尋

以下 3 種方法可用於執行峰值搜尋：

下一個峰值 | 當峰值極性是 Positive（正）或 Both（兩者）時，將標記移至最大峰值。 當峰值極性為 Negative（負）時，將標記移至最小峰值。
峰值左側 | 在目前標記位置到較小激勵值的範圍內執行搜尋，並將標記移至遇到的第一個峰值。
峰值右側 | 在目前標記位置到較大激勵值的範圍內執行搜尋，並將標記移至遇到的第一個峰值。

附註：可能不會追蹤峰值右側、峰值左側及下一個峰值。如果選取這些搜尋，然後開啟追蹤功能，將會啟用峰值追蹤功能。

當資料格式為史密斯圖或極座標格式時，將會針對兩個標記回應值中的主回應值執行搜尋。

變更峰值偏移值或峰值極性的設定會導致執行新的多峰值搜尋。

例如：

閾值設定：-10dB
偏移值設定：1dB
刻度 = 1 dB/分度
將滑鼠游標置於圖形上可尋找有效的峰值。

  • 峰值 A = 有效峰值（高於閾值和偏移值設定）

  • 峰值 B = 無效峰值（低於偏移值設定）

  • 峰值 C = 無效峰值（低於閾值設定）

多峰值搜尋

如何建立多峰值搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Multi Peak & Target（多峰值和目標值）。

  2. 按一下 Multi Peak Search（多峰值搜尋）以在多個峰值上顯示標記。

  3. 按一下 Peak Threshold（峰值閾值）以輸入峰值閾值的值。

  4. 按一下 Peak Excursion（峰值偏移值）以輸入峰值偏移值的下限值。

  5. 按一下 Peak Polarity（峰值極性）以選取峰值極性。

  6. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的多峰值電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取多峰值。

  4. 輸入閾值和偏移值的值。

  5. 按下執行或勾選追蹤。瞭解詳情。

多峰值搜尋功能可讓您在軌跡上的多個峰值上顯示標記。視偵測到的峰值數而定，從開始頻率開始顯示標記 1 至 15。參考標記不受影響。

多峰值搜尋有閾值、偏移值和極性做為使用者定義的值。此搜尋可能已啟用追蹤功能。

在執行多峰值搜尋時，將會停用先前的標記搜尋和追蹤，並使用多峰值搜尋的設定。

附註：請勿使用個別標記設定或標記定義域。

將標記放在每個有效峰值上，最多使用 15 個標記。

目標值搜尋

如何建立目標值搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Target（目標值）。

  2. 按一下 Target Search（目標值搜尋）以啟用目標值搜尋。

  3. 按一下 Target Right >> Search（目標值右側 >> 搜尋）或 << Target Left Search（<< 目標值左側搜尋）將標記移至目標值。

  4. 按一下 Target Value（目標值）輸入目標值搜尋的值。

  5. 按一下 Transition（變換）選取變換類型。

  6. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的目標值電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取目標值/目標值左側/目標值右側。

  4. 輸入目標值的值。

  5. 按下執行或勾選追蹤。瞭解詳情。

目標值搜尋功能可搜尋與預先定義的目標值和變換類型（正、負或兩者（正和負））相符的目標值，然後將標記移至該目標值。

目標值變換類型

目標值是在軌跡上具有特定量測值的點。根據其變換類型，目標值可分為如下所示的 3 個群組。

變換類型： | 功能：
正 | 當目標值大於其前一個（右側）量測值時。
負 | 當目標值小於其前一個（左側）量測值時。
兩者 | 當目標值小於或大於其前一個（左右兩側）量測值時。

執行目標值搜尋

以下 2 種方法可用於執行目標值搜尋：

目標值左側 | 在目前標記位置到較小激勵值的範圍內執行搜尋，並將標記移至遇到的第一個目標值。
目標值右側 | 在目前標記位置到較大激勵值的範圍內執行搜尋，並將標記移至遇到的第一個目標值。

附註：無法對目標值右側和目標值左側啟用追蹤功能。如果目標值左側或目標值右側是選定的搜尋，然後啟用追蹤功能，將會啟用目標值追蹤。

當資料格式為史密斯圖或極座標格式時，將會針對 2 個標記回應值中的主回應值執行搜尋。

變更目標值或變換類型的設定會執行新的多目標值搜尋。

標記將移至其目前位置右側遇到的第一個目標值。隨後按下「執行」按鈕，會導致標記移至右側符合目標值的下一個值。當標記到達激勵範圍的上端時，它將會「折回」，並繼續從激勵範圍的下端（視窗左側）進行搜尋。

  • 如果離散標記為「關閉」，標記將會尋找等於目標值的內插資料點。

  • 如果離散標記處於「開啟」狀態，而且在目標值的任一側都有兩個資料點，標記將會尋找距離目標值最近的資料點。

多目標值搜尋

如何建立峰值搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Multi Peak & Target（多峰值和目標值）。

  2. 按一下 Multi Target Search（多目標值搜尋）以在多個目標值上顯示標記。

  3. 按一下 Target Value（目標值）以輸入目標值。

  4. 按一下 Transition（變換）選取變換類型。

  5. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的多目標值電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取多目標值。

  4. 輸入目標值的值。

  5. 按下執行或勾選追蹤。瞭解詳情。

多目標值搜尋功能可搜尋與預先定義的目標值和變換類型（正、負或兩者（正和負））相符的目標值，並在正在搜尋的目標值上顯示標記。

視偵測到的目標值數而定，從開始頻率顯示標記 1 至 15。參考標記不受影響。

在執行多目標值搜尋時，將會忽略標記 1 至 15 的搜尋和追蹤設定，而使用多目標值搜尋的設定。

附註：將標記放在找到的每個目標值上，最多使用十五個標記。參考標記不受影響。請勿使用個別標記設定或標記定義域。將套用搜尋範圍。

多目標值搜尋有目標值和變換類型可做為使用者定義的值。此搜尋可能已啟用追蹤功能。執行此搜尋時，將會停用先前的標記搜尋。

頻寬和陷波搜尋

將會自動部署 4 個標記，以在選定的搜尋定義域中尋找第一個負或正的帶通。

如何建立頻寬和陷波搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Bandwidth & Notch（頻寬和陷波）。

  2. 按一下左側的 Bandwidth Search（頻寬搜尋）或 Notch Search（陷波搜尋）小按鈕以將其開啟/關閉。

  3. 針對頻寬搜尋，按一下 BW Ref To（頻寬參考）> Marker（標記）或 Peak（峰值）。

  4. 針對陷波搜尋，按一下 Notch Ref To（陷波參考）> Marker（標記）或 Peak（峰值）。

  5. 從量測頻寬/陷波的峰值或波谷值指定 BW Level（頻寬電平）或 Notch Level（陷波電平）（以 dB 表示）。

  6. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的頻寬或陷波電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取頻寬或陷波。

  4. 從量測頻寬/陷波的峰值或波谷值指定電平（以 dB 表示）。

  5. 按下執行或勾選追蹤。瞭解詳情。

頻寬搜尋

頻寬搜尋功能可根據作用中標記的位置確定軌跡的頻寬、中心頻率、截止點（高頻率一側和低頻率一側）、Q 及插入衰減。透過頻寬搜尋確定的參數定義如下所示。

帶阻濾波搜尋

陷波搜尋功能可用於根據作用中標記的位置取得軌跡的頻寬、中心頻率、截止點（高頻率一側和低頻率一側）、Q 及插入衰減。陷波搜尋功能會從作用中標記位置的左側開始，在找到符合條件的點時結束。

下面的圖和表說明透過陷波搜尋功能取得的參數的定義。下圖中的陷波值必須由使用者指定。

會針對頻寬和陷波搜尋顯示下列值：

頻寬/陷波參數： | 定義：
頻寬 (BW) | 高頻率截止點和低頻率截止點之間的頻率差 (High - Low)。
中心頻率 (cent) | 低頻率截止點和高頻率截止點之間中點處的頻率。(High+ Low)/2。
低頻率截止點 (Low) | 從作用中標記的位置，依定義的頻寬/陷波值分隔的 2 個量測點中的較低頻率。
高頻率截止點 (High) | 從作用中標記的位置，依定義的頻寬/陷波值分隔的 2 個量測點中的較高頻率。
Q | 中心頻率與頻寬的比例（中心頻率/頻寬）。
插入衰減 (loss) | 執行頻寬/陷波搜尋時在中心頻率位置處的量測值。

  • 頻寬/陷波搜尋只能與對數幅度顯示格式搭配使用。

  • 若要在最大值或最小值以外的峰值或波谷值上使用頻寬搜尋，請變更搜尋定義域。

壓縮搜尋

使用作用中標記尋找指定的增益壓縮電平。

附註：僅對使用功率掃描的 S21（增益）量測有效。

如何建立壓縮搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Comp & Sat（壓縮與飽和）。

  2. 按一下 Compression Search（壓縮搜尋）以開啟/關閉。

  3. 以 dB 為單位指定 Comp Level（壓縮電平）。

  4. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的壓縮電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取壓縮。

  4. 輸入第一個點與壓縮標記之間的 Y 軸（輸出功率）差。

  5. 按下執行或勾選追蹤。瞭解詳情。

線性增益的定義為搜尋定義域（預設為全頻距）的第一個資料點的 Y 軸值（增益）。

標記 > N - X 軸值和 Y 軸值。

壓縮輸入功率 - 輸入功率（標記 X 軸值）。

壓縮輸出功率 - 輸出功率（輸入功率 + 增益）。

壓縮電平 - 找到的壓縮電平。

  • 當離散為關閉（預設設定）時，標記將會尋找內插在兩個最近資料點之間的精確指定壓縮，並計算該點的壓縮輸入功率值和壓縮輸出功率值。

  • 標記可從一個實際量測點移至另一個量測點。由於該標記是內插的，因此也可以在量測點之間的空間內移動。

  • 當離散為開啟（未內插）時，標記會留在最靠近要求的壓縮電平的資料點上。

  • 標記只會在實際量測點之間移動。將特定標記的激勵值指定為數值時，會將標記置於最靠近指定值的量測點。在離散模式關閉的情況下，置於內插點之間的標記會在離散模式開啟時自動移至最近的量測點。

未找到壓縮 - 在未找到要求的壓縮電平時顯示。

關於 PSAT 和 PNOP 搜尋

根據 Pout 和 Pin 曲線進行壓縮量測在衛星測試行業中很常見。在使用行波管 (TWT) 放大器的情況下，PSAT 標記可識別接近飽和的正常工作點，而且放大器會在功率稍微回退約 0.03 至 0.1 dB 的情況下運作。針對 TWT 放大器，飽和曲線一律會「折疊」，並產生最大輸出功率。

針對固態功率放大器 (SSPA)，則不會定義飽和。共同的參考是正常工作點，這是從最大功率回退 8 至 10 dB 的功率。在此情況下，正常工作點標記會將 Psat 取代為 PNOP 值。此外，由於回退很重要，因此將會顯示回退輸出功率 (PBO Out) 和回退輸入功率 (PBO in)，以及回退時的增益 (PBO Gain)。

功率飽和 (PSAT) 搜尋

使用標記 1、2 和 3 可快速識別放大器的輸出功率飽和參數。

回退值是一個點，在該點上，輸出功率比起飽和的輸出功率足夠低，因此受測裝置會以更線性的方式運作。

附註：僅對輸入功率和輸出功率量測有效。

如何進行輸入功率（X 軸）和輸出功率（Y 軸）量測

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Preset]。

  2. 按下 [Sweep] > Main（主功能表）> Sweep Type（掃描類型）。

  3. 選取功率掃描。

  4. 按下軌跡 > 軌跡設定> 量測...，然後將軌跡量測設定為「B」接收器。

  5. 將受測裝置輸入連接至連接埠 1。

  6. 將受測裝置輸出連接至連接埠 2。

如何建立 PSAT 搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Comp & Sat（壓縮與飽和）。

  2. 按一下左側的 Saturation Search（飽和搜尋）小按鈕以將其開啟/關閉。

  3. 針對最大功率回退值，輸入最大功率標記 (3) 和回退值標記 (2) 之間的 Y 軸（輸出功率）差。

  4. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的功率飽和電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋 > 搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取功率飽和。

  4. 針對最大功率回退值，輸入最大功率標記 (3) 和回退值標記 (2) 之間的 Y 軸（輸出功率）差。

  5. 按下執行或勾選追蹤。瞭解詳情。

此設定使用三個標記來計算和顯示 10 個值。

這三個標記為：

  • 標記 1：線性增益；掃描中的第一個資料點。

  • 標記 2：指定的從最大功率回退的輸出功率。

  • 標記 3：最大輸出功率；通常是最後一個資料點。

9 個顯示的值為：

參數 | 描述 | 從下列值計算得到...
PSat Out | 飽和點處的輸出功率。 | 標記 2 Y 軸值
PSat In | 飽和點處的輸入功率。 | 標記 2 X 軸值
Gain Sat | 飽和點處的增益。 | Psat Out - Psat In
Comp Sat | 飽和點處的壓縮。 | Gain Sat - Gain Linear
PMax Out | 最大輸出功率。 | 標記 3 Y 軸值
PMax In | 最大輸出功率處的輸入功率。 | 標記 3 X 軸值
Gain Max | 最大輸出功率處的增益。 | PMax Out - PMax In
Comp Max | 最大輸出功率處的壓縮。 | Gain Max - Gain Linear
Gain Linear | 第一個資料點處的線性增益。 | 標記 1 - Y 軸值減 X 軸值

  • 未找到壓縮會在未找到要求的回退點時顯示。

  • 未選取離散標記（預設設定）時，三個標記將會尋找兩個最近資料點之間的內插值。

  • 選取離散標記（未內插）時，三個標記都會留在最近的資料點上。

功率正常工作點 (PNOP) 搜尋

使用標記 1、2、3 和 4 可快速識別放大器的正常工作點參數。

回退值是一個點，在該點上，輸出功率比起飽和的輸出功率足夠低，因此受測裝置會以更線性的方式運作。

功率正常工作點是輸入會依輸入功率偏移從回退值輸入功率偏移的輸出功率。

附註：僅對輸入功率和輸出功率量測有效。

請參閱功率飽和，瞭解如何進行輸入功率（X 軸）和輸出功率（Y 軸）量測。

如何建立 PNOP 搜尋

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Search] > Normal Op Pt（正常工作點）。

  2. 按一下左側的 Normal OP Search（正常工作點搜尋）小按鈕以將其開啟/關閉。

  3. 針對回退值，輸入最大功率標記 (3) 和回退值標記 (2) 之間的 Y 軸（輸出功率）差。

  4. 針對輸入功率偏移，輸入回退值標記 (2) 和 PNOP 標記 (4) 之間的 X 軸（輸入功率）差。

  5. 您也可以選擇按一下 Tracking（追蹤），在每個掃描中搜尋指定的功率正常工作點電平。瞭解詳情。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取搜尋 > 搜尋...。

  3. 在 [標記搜尋] 對話方塊的搜尋類型中，選取正常工作點。

  4. 針對回退值，輸入最大功率標記 (3) 和回退值標記 (2) 之間的 Y 軸（輸出功率）差。

  5. 針對輸入功率偏移，輸入回退值標記 (2) 和 PNOP 標記 (4) 之間的 X 軸（輸入功率）差。

  6. 按下執行或勾選追蹤。瞭解詳情。

此設定使用四個標記來計算和顯示 12 個值。

這四個標記為：

  • 標記 1：線性增益；掃描中的第一個資料點。

  • 標記 2：最大輸出功率減指定的輸出（Y 軸）回退值（以 dB 表示）。

  • 標記 3：最大輸出功率；通常是掃描中的最後一個資料點。

  • 標記 4：回退值（標記 2）的 X 軸值加輸入功率偏移（X 軸）值（以 dB 表示）。

11 個顯示的值為：

參數 | 描述 | 從下列值計算得到...
Pnop Out | 功率正常工作點處的輸出功率。 | 標記 4 Y 軸值
Pnop In | 功率正常工作點處的輸入功率。 | 標記 4 X 軸值
Pnop Gain | 功率正常工作點處的增益。 | Pnop Out - Pnop In
Pnop Comp | 功率正常工作點處的壓縮。 | Pnop Gain - Linear Gain*
PMax Out | 最大輸出功率。 | 標記 3 Y 軸值
PMax In | 最大輸出功率處的輸入功率。 | 標記 3 X 軸值
Gain Max | 最大輸出功率處的增益。 | PMax Out - PMax In
Comp Max | 最大輸出功率處的壓縮。 | Gain Max - Linear Gain*
PBO Out | 回退點處的輸出功率。 | 標記 2 Y 軸
PBO In | 回退點處的輸入功率。 | 標記 2 X 軸
PBO Gain | 回退點處的增益。 | PBO Out - PBO In

*線性增益（未顯示）：標記 1 - Y 軸值減 X 軸值

  • 在未找到要求的回退電平時會顯示未找到 PNOP。

  • 未選取離散標記（預設設定）時，四個標記中的每一個都會尋找兩個最近資料點之間的內插值。

  • 選取離散標記（未內插）時，四個標記中的每一個都會留在最近的資料點上。

搜尋定義域

搜尋定義域設定會將激勵值（直角座標格式的 X 軸）限制為指定的頻距。設定這些使用者頻距的開始和停止激勵設定。如果開始值大於停止值，標記將不會移動。瞭解如何設定搜尋定義域。

  • 每個新標記的預設定義域都是「全頻距」。

  • 每個通道都有 16 個使用者定義的定義域。

  • 使用者定義的定義域可以重疊。

  • 多個標記可使用一個定義的定義域。

  • 搜尋定義域設定會與軌跡統計資料使用者範圍共用。

下圖顯示搜尋定義域的範例。

搜尋範圍指示器

搜尋範圍將會由 X 軸上的一對小空心三角形指出。雖然各個標記上可能都有多個使用中的搜尋範圍，但只會顯示目前選定的作用中標記的搜尋範圍。此規則可避免 X 軸上堆滿大量搜尋範圍三角形。即使視窗中有多個軌跡，此規則仍適用。

任何時候網格上都只會顯示一個搜尋範圍。所顯示的搜尋範圍將會對應於作用中軌跡和作用中標記。範圍指示器的顏色會與作用中軌跡的顏色相符。

範圍指示器將會在適當的時候自動顯示，而且無法停用。無法使用滑鼠或觸控螢幕「按一下並拖曳」範圍指示器的位置，因為這樣會改變搜尋範圍的定義。

標記功能 - 變更儀器設定

下列設定可將相關的 VNA 設定變更為作用中標記的位置。

如何使用標記變更儀器設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Marker] > Marker->Functions（標記->功能）。

  1. 將游標移到標記上。

  2. 以滑鼠右鍵按一下標記，然後選取功能。

  3. 選取所需的搜尋功能。

  4. 按一下功能... 以顯示 [標記功能] 對話方塊。

標記功能對話方塊說明/[Marker] > Marker Function（標記功能） Softtab 說明

標記 => 開始 - 將開始掃描設定設定為作用中標記的值。

標記 => 停止 - 將停止掃描設定設定為作用中標記的值。

標記 => 中心 - 將掃描的中心設定為作用中標記的值。

標記 => 參考電平 - 將螢幕參考電平設定為作用中標記的值。

標記 => 延遲 - 會使用作用中標記激勵位置處的相位斜率將線條長度調整為接收器輸入。如此可有效地使作用中標記周圍的相位軌跡變平。對於在量測的頻率跨距內沒有恒定群組延遲的裝置，需要進行其他電子延遲調整。您可以使用此功能量測電氣長度或與線性相位的偏差。

此功能可為相位相對於頻率的變化增加相位延遲。因此，它僅適用於成比例的量測。請參閱量測參數。

標記 => 跨距 - 將掃描跨距設定為由差量標記以及它參考的標記定義的跨距。如果沒有差量標記，則無法使用。

標記 => CW 頻率 - 將 CW 頻率設定為作用中標記的頻率。當通道處於 CW 或功率掃描模式時，則無法使用。使用此功能先將 CW 頻率設定為目前校準範圍內的值，然後將掃描類型設定為功率或 CW。

附註：某些標記功能無法與某些掃描類型中的通道搭配使用。

標記功能 | 掃描類型
 | 線性/對數頻率 | 區段 | 功率 | CW 時間
開始、停止、中心 | F |  | S |
跨距 | S |  | S |
參考位準 | F | S | S | S
延遲 | F | S | S | S
CW 頻率 | S | S |  |

F：在標準和 SMC 類別中均可用

S：僅在標準類別中可用

標記顯示

[標記顯示] 對話方塊可讓您變更標記和關聯讀數在 VNA 螢幕上的顯示方式。多個標記顯示功能也適用於統計資料顯示。

如何變更標記顯示設定

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Display...（標記顯示...）。

或

  1. 按下 [Display] > Display Settings（顯示設定） > Customize Display...（自訂顯示...）。

  2. 選取標記索引標籤。

  1. 將游標移至網格方塊右上角的標記資料區域。

  2. 以滑鼠右鍵按一下標記資料顯示區域。

  3. 選取標記顯示...。

或

  1. 在任何視窗區域上按一下滑鼠右鍵。

  2. 按一下自訂顯示...。

  3. 選取標記索引標籤。

自訂顯示對話方塊說明

下列設定適用於所有目前顯示的標記、頻寬和軌跡統計資料的讀數。

使用「預設」可將這些設定恢復為其預設值，但它們將會與儀器狀態和使用者預設儲存在一起。

一般

已勾選顯示標記讀數 - 顯示讀數資訊。

已清除顯示標記讀數 - 不顯示任何讀數資訊。

勾選大讀數 - 以較大字型顯示標記讀數，以便於讀取。不過，可能無法顯示所有讀數行。

清除大讀數 - 以標準字型顯示標記讀數。

每個軌跡的讀數數量 - 選擇要在視窗中顯示的每個軌跡的標記讀數數量。選擇此項目最多可顯示每個軌跡的 10 個讀數，每個視窗最多顯示 20 個讀數。如果存在的標記數超過了指定的讀數數量，則可以變更要顯示其讀數的標記編號，視作用中的標記編號而定。您可以針對每個視窗單獨設定每個軌跡的讀數數量。

符號 - 從下列標記符號中選擇。

三角形

旗標

直線

直線符號不適用於史密斯圖或極座標顯示格式。

您可以針對每個視窗單獨設定符號。

讀數位置 - 選擇要放置標記讀數的位置。標記讀數會在指定的 X 軸和 Y 軸位置上靠右對齊。預設位置 (10.0, 10.0) 是網格的右上角。位置 (1.0,1.0) 是左下角。您可以針對每個視窗單獨設定讀數位置。可以僅針對作用中軌跡或針對所有軌跡開啟讀數。每個軌跡也可以有自己的讀數位置。

已勾選每個軌跡的獨立位置 - 顯示相互獨立的每個軌跡讀數。

已清除每個軌跡的獨立位置 - 在同一個垂直線中顯示所有讀數。

附註： 您也可以使用滑鼠來變更讀數位置，方法是在頂部讀數上按滑鼠左鍵，然後將其拖曳至新位置。

小數位數 - 選擇要顯示的標記讀數解析度。這些值也適用於顯示在標記表中的讀數。您可以針對每個視窗單獨設定小數位數。

激勵（X 軸） - 從小數點後 2 至 6 位中選擇。預設值為 3。

回應值（Y 軸）- 從小數點後 1 至 4 位中選擇。預設值為 2。

標記顏色 - 啟動 [顯示顏色] 對話方塊，其中僅包含可用的標記顏色。瞭解詳情。

標記表

您可以顯示提供作用中軌跡之標記資料摘要的表格。標記資料會針對每個標記以指定的格式顯示。

如何檢視標記表

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Marker] > Marker Setup（標記設定）> Marker Table（標記表）。

上次修改時間：

2016 年 01 月 06 日

第一版


數學運算

使用數學/記憶體運算

您可以對作用中軌跡和記憶體軌跡執行四種類型的數學運算。此外，也可以對作用中資料軌跡計算三種統計資料（平均值、標準差和峰對峰值）並進行顯示。

  • 軌跡數學運算

  • 軌跡統計

附註：軌跡數學運算（下文會說明）可讓您使用記憶體軌跡快速套用四種數學運算中的一種。公式編輯器可讓您使用來自相同或不同通道的多種類型的軌跡來建立自訂公式。

其他分析資料主題

軌跡數學運算

若要執行任何數學運算，您必須先將軌跡儲存至記憶體。您可以使用檢視選項顯示記憶體軌跡。

會在將複數資料格式化以進行顯示之前對其執行軌跡數學運算。請參閱 VNA 資料處理圖。

在檢視記憶體軌跡時可以使用標記。

如何選取軌跡數學運算

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按下 [Math] > Memory（記憶體）。

  1. 以滑鼠右鍵按一下網格方塊上方的任何軌跡狀態區域。

  2. 選取記憶體...。

標準化只會顯示在 [記憶體] 功能表中（而不會顯示在 [計算/記憶體] 對話方塊中），它執行的功能與資料->記憶體然後資料/記憶體相同。

[Math] > Memory（記憶體） Softtab 鍵/記憶體對話方塊說明

標準化只會顯示在 [記憶體] 功能表中（而不會顯示在 [計算/記憶體] 對話方塊中），它執行的功能與資料->記憶體然後資料/記憶體相同。

資料->記憶體 - 將作用中的資料軌跡放到記憶體中。您可以針對每一個顯示的軌跡儲存一個記憶體軌跡。

附註：許多 VNA 功能不能在記憶體軌跡上執行。例如，無法將記憶體軌跡儲存為任何檔案類型（PRN、SNP、CTI、CSV、MDF）。

資料計算

會在將線性（實數和虛數）資料格式化之前對其執行所有數學運算。請參閱 VNA 資料流程（如下）。

關閉 - 不進行數學運算。

資料/記憶體 - 目前的量測資料除以記憶體中的資料。用於兩個軌跡的比值比較，例如增益或衰減的量測。瞭解詳情。

資料 – 記憶體 - 目前的量測資料減記憶體中的資料。例如，您可以使用此功能儲存量測到的向量誤差，然後從受測裝置量測中減去此誤差。瞭解詳情。

資料 + 記憶體 - 目前的量測資料加記憶體中的資料。瞭解詳情。

資料 * 記憶體 - 目前的量測資料乘以記憶體中的資料。瞭解詳情。

8510 模式 - 深入瞭解。

軌跡檢視選項

資料軌跡 - 僅顯示資料軌跡（套用選定的數學運算）。

記憶體軌跡 - 僅顯示儲存在記憶體中的軌跡。

資料和記憶體軌跡 - 同時顯示資料軌跡（套用選定的數學運算）和儲存在記憶體中的軌跡。

深入瞭解軌跡數學運算

（資料/記憶體）和（資料 - 記憶體）

會在將線性資料格式化之前對其執行（資料/記憶體）和（資料 - 記憶體）數學運算。因為經常會以對數格式檢視資料，因此應使用兩種數學運算中的哪一種並非總是很明確。請記住：除以線性資料與減去對數資料相同。下文介紹在一般情況下使用每種運算的時機。

使用資料/記憶體進行標準化，例如比較對 S21 軌跡進行變更「之前」和「之後」的差別時或量測軌跡的雜訊時。在下表中，資料/記憶體值以直覺方式顯示軌跡之間的差異。（資料 - 記憶體）所顯示的資訊並不明顯。

要比較的 S21 值 | 資料/記憶體 | 資料 - 記憶體
0.5 dB 和 0.6 dB | 0.1 dB | -39 dB
0.5 dB 和 0.7 dB | 0.2 dB | -33 dB

使用資料 - 記憶體可顯示兩個訊號之間的相對差異。用於比較非常小的訊號，例如兩個接頭的 S11 相符情況。

在下表中，資料/記憶體顯示兩對接頭都有相同的 2 dB 差異。但是，第二對接頭的 S11 效能較佳（-50 和 -52），而資料 - 記憶體值中顯示了相對重要性。

要比較的 S11 值 | 資料/記憶體 | 資料 - 記憶體
-10 dB 和 -12 dB | 2 dB | -24 dB
-50 dB 和 -52 dB | 2 dB | -64 dB

資料 * 記憶體和資料 + 記憶體

透過資料 * 記憶體和資料 + 記憶體，可以使用您自己的公式或演算法中的資料對作用中的資料軌跡執行數學運算，而不是使用量測中的資料。例如，如果要模擬以串聯方式放置在受測裝置之前的理論放大器的增益，您可以執行以下操作：

  1. 建立可以描述理論放大器頻率回應之特徵的演算法。

  2. 輸入與資料軌跡的資料點數目相對應的複數資料對。

  3. 使用 SCPI 指令將資料對載入記憶體中。分析程式會對應複數對，以對應至實際量測點處的激勵值。

  4. 使用資料 + 記憶體或資料 * 記憶體功能將頻率回應資料加或乘以作用中資料軌跡中的量測資料。

附註：在嘗試載入記憶體之前必須先設定資料軌跡。

軌跡統計資料

您可以計算和顯示作用中資料軌跡的統計資料。這些統計資料為：

  • 平均值

  • 標準差

  • 峰間值

您可以透過使用使用者範圍來計算完整激勵跨距或部分跨距的統計資料。

您最多可以為每個通道定義 16 個使用者範圍。這些使用者範圍與在同一通道中為標記搜尋指定的搜尋定義域相同。它們使用相同的記憶體暫存器，因此共用相同的激勵跨距。

通道的使用者範圍可以互相重疊。

軌跡統計資料的一個方便用法是尋找通帶漣波的峰間值，而無需分別搜尋最小值和最大值。

軌跡統計資料是根據用於顯示資料的格式計算而得。

  • 直角座標資料格式是從顯示中表示的純量資料計算而得。

  • 極座標或史密斯圖格式是從以對數幅度格式顯示的資料計算而得。

請參閱如何進行軌跡統計資料顯示設定。

如何啟用軌跡統計資料

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）> Statistics...（統計資料...）

軌跡統計資料對話方塊說明

請參閱如何進行軌跡統計資料顯示設定。

統計資料 - 勾選後可顯示作用中軌跡的平均值、標準差和峰間值。

跨距 - 指定要從其中收集資料以進行數學運算之作用中軌跡的跨距。您可以選取 [全跨距]，或使用 [開始] 和 [停止] 為每個通道定義最多 16 個使用者跨距。您也可以從 [標記搜尋] 對話方塊中的搜尋定義域選擇器定義使用者跨距。

使用者範圍

開始 - 定義使用者跨距的開始值。

停止 - 定義使用者跨距的停止值。

深入瞭解軌跡統計資料

上次修改時間：

2016 年 01 月 06 日

第一版


8510 模式

在軌跡數學運算對話方塊上，勾選 [8510 模式] 可在 Keysight 8510 資料處理鏈結與「軌跡運算」和「記憶體」相關時模擬該處理鏈結。此設定會套用到所有通道。勾選或清除該方塊時，VNA 會執行儀器預設，並在後續的儀器預設中保留其設定。

此設定可儲存為儀器狀態的一部分。但是，叫用設定後，會假定此設定僅為暫時設定。執行後續的 VNA 預設時，VNA 會恢復到叫用狀態之前的有效設定。

您可以設定偏好設定，以始終使用 8510 模式。

此影像表示資料流的相關部分。

請參閱整個 VNA 資料處理鏈結。

在上面的 VNA 資料流圖表上，記憶體操作之後發生的任何操作中的設定變更會同時變更資料軌跡和記憶體軌跡。例如，將資料軌跡儲存到記憶體後，如果變更資料軌跡的格式，記憶體軌跡的格式也會變更為相同的設定。

如何開啟/關閉 8510 模式

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Memory（記憶體）> 8510 Mode（8510 模式）。

此功能無法使用編程

上次修改時間：

2016 年 01 月 06 日

第一版


方程式編輯器

等式編輯器可讓您輸入代數等式，以數學運算方式操縱量測得到的資料。結果將顯示為資料軌跡。等式中所使用的資料可來自同一通道，也可以來自不同通道。

  • 概觀

  • 如何啟動等式編輯器

  • 使用等式編輯器

  • 等式編輯器中使用的資料

  • 軌跡設定、誤差修正和範例

  • 等式編輯器中使用的函數和常數

  • 等式編輯器中使用的運算子

  • 等式範例

  • 儲存等式編輯器資料

另請參閱

等式編輯器和 MATLAB

等式編輯器匯入函數

  • BestFit.dll

  • EqnErrorTerms.dll

  • Expansion.dll

其他「分析資料」主題

概觀

等式編輯器可讓您輸入標準數學運算子和函數的代數等式，參考 VNA 中可用的資料。在輸入並啟用有效的等式後，作用中軌跡的顯示將取代為等式結果，並在擷取新資料的同時即時更新。針對可使用等式編輯器支援的函數、運算子和資料來表示的等式，無需在單獨的程式中進行離線處理。

例如，輸入等式 S21 / (1 - S11)。所得軌跡的計算方式為，每個 S21 資料點除以一減對應的 S11 資料點。針對 201 點掃描設定，運算會重複 201 次，每個點一次。

另一個範例是，假設您想要 VNA 對 3 連接埠受測裝置進行方向性量測。這不是原生 VNA 量測，但可使用等式編輯器完成。所需結果為 LogMag 格式軌跡的和與差，表示為：S12 + S23 - S13.

由於等式編輯器對未格式化複數資料進行操作，因此所需等式為：

DIR = S12 * S23 / S13

DIR 會成為一個顯示標籤，協助您識別計算出的資料軌跡。

在等式軌跡中，將格式設為 LogMag。

如何啟動等式編輯器

如何啟動等式編輯器

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）> Equation Editor（等式編輯器）。

等式編輯器對話方塊說明

備註：

  • 按兩下或輸入函數、運算子和資料以建立等式。

  • 向下捲動以深入瞭解使用等式編輯器。

等式 - 用於內建等式的欄位。按一下右側的向下箭頭，可使用或修改以前儲存的等式。這是按下 [儲存等式] 時儲存等式的位置。

啟用等式 - 勾選該方塊可啟用目前位於 [等式] 欄位中的等式。如果使用的資料軌跡來自與等式軌跡不同的通道，則這些通道必須擁有相同的資料點數才有效。

啟用等式 - 清除該方塊可停用目前位於 [等式] 欄位中的等式。[已啟用] 方塊未勾選/不可用時，等式無效。

<- 退格鍵 - 將游標移動到左側，同時清除字元。

<- - 將游標移動到左側，但不清除字元。

-> - 將游標移動到右側，但不清除字元。

儲存等式 - 按下可儲存目前等式。若要稍後叫用等式，按一下等式右側的向下箭頭。

刪除等式 - 從下拉式清單移除目前等式。

函數 - 請參閱函數說明。

選取函數「庫」以進行檢視。依預設會顯示「內建」函數庫，其中包含等式編輯器的標準函數。此處還可以顯示您已編寫和匯入的其他函數。 瞭解詳情。

軌跡資料 - 從所有通道上所有目前顯示的軌跡中進行選取。

參數 - 僅從作用中通道（與等式軌跡相同的通道）中可用的未顯示資料中進行選取。 請參閱等式中使用的資料。

附註：啟用了外部測試裝置時，僅會列出與連接埠 1 到 4 相關的參數。但是，所有可用參數都可直接輸入到等式欄位中。

運算子 - 請參閱運算子說明。

鍵台 - 用於使用滑鼠導覽整個對話方塊。

使用簡短名稱 - 勾選此方塊時，會自動輸入某些擁有簡短名稱的函數。可交換使用完整名稱和簡短名稱。

使用簡短名稱 - 清除此方塊時，可手動輸入某些擁有簡短名稱的函數。

啟用 Matlab 在 VNA 上安裝了完整 MATLAB 版本時可用。瞭解詳情。

匯入... - 按一下可啟動匯入函數對話方塊。

使用等式編輯器

1. 選擇要在其中輸入等式的軌跡。

  • 等式編輯器會在作用中軌跡上運作。

  • 建立新的軌跡，或按一下現有軌跡上的軌跡狀態按鈕使該軌跡變為作用中軌跡。

2. 輸入等式。

啟動等式編輯器如何操作。

  • 等式文字可採用運算式 (S21)/(1-S11) 或等式 (DIR = S12 * S23 / S13) 的形式。此主題將這兩種類型均稱為等式。

  • 輸入或按兩下函數、運算子和資料以建立等式。

  • 函數和常數區分大小寫；資料名稱不區分大小寫。

  • 深入瞭解參考資料軌跡。

3. 檢查是否存在有效等式。

輸入有效等式後，[啟用] 勾選方塊將變為可用狀態以供勾選。[啟用] 方塊已勾選時：

  • 等式軌跡將變為計算出的資料。

  • 等式在軌跡狀態上可見（最多約 10 個字元）。

  • 如果等式無效且使用來自不同通道的軌跡，請確保兩個通道的資料點數目是相同的。

深入瞭解等式編輯器中使用的函數、運算子和資料。

等式編輯器中使用的資料

定義：

  • 等式軌跡 - 等式所在的軌跡。

  • 參考軌跡 - 用作等式中資料的軌跡。

例如： eq=Tr2+S11 會輸入到 Tr1。

Tr1 會變為等式軌跡。

Tr2 和 S11 均是參考軌跡，因為它們均用於等式軌跡中。

備註：

  • 將按照一次一個資料點的方式處理參考軌跡。例如，運算式 S11/S21 表示對於 S11 和 S21 中的每個資料點，將 S11 的點 N 除以 S21 的點 N。

  • 啟用等式後，不再由其原始量測參數來識別軌跡。它將變為等式軌跡。

  • 等式軌跡無法參考其自身。例如，Tr1 中的等式無法參考軌跡 Tr1。

  • 可從 S 參數、接收器資料和記憶體軌跡選取參考軌跡。

  • 請參閱有關外部測試集的注意事項。

可以使用三種方式參考軌跡：

在討論參考軌跡/資料的三種方式時，下面的差異很重要。

  • 軌跡 - VNA 畫面上所顯示之資料點的序列集合。

  • 資料 - 已獲取但未顯示的 VNA 量測。等式軌跡參考未顯示的資料時，VNA 會自動擷取資料。

1. 使用 TrX 軌跡標記法（例如，Tr2）。

建立軌跡後，勾選顯示 Tr 註解可查看該軌跡的 Tr 編號。

  • 簡單 - 永遠參考顯示的軌跡。

  • 必須用於將不同通道中的軌跡作為等式軌跡進行參考。

  • 所有軌跡設定會保留在等式軌跡中。如果您不想要軌跡設定用於等式軌跡，必須在參考軌跡中將其停用。

  • 如果參考軌跡已進行錯誤修正，則等式軌跡中的資料也會進行修正。

  • 用於參考記憶體軌跡（必須已儲存在記憶體中）。將 .MEM 附加到 TrX 軌跡識別碼中。例如，Tr2.mem 將參考為 Tr2 儲存的記憶體軌跡。

2. 使用 S 參數標記法（例如，S11/S21）。

  • 方便 - 永遠參考未顯示的資料。

  • 參考與等式位於相同通道的資料。

  • 與使用 TrX 標記法參考顯示的 S11 軌跡不同。請參閱範例。

    • 參考資料不包含軌跡設定。

    • 如果通道擁有可用的誤差修正，則可透過開啟等式軌跡的誤差修正加以套用。

3. 使用接收器標記法（例如，AB_2）；不區分大小寫。

至少需要一個接收器，後接一個底線和一個數字。

  • 底線前面的字母表示接收器。

    • 單獨的字母表示實體接收器。

    • 後面跟著數字的字母表示邏輯接收器。瞭解詳情。

    • 如果參考了兩個接收器，則會計算其比例。

  • 底線後的數字表示量測的來源連接埠。

範例：

  • AR1_2 = 實體接收器 A / 實體接收器 R1，2 是來源連接埠。

  • a3b4_1 = 連接埠 3 的參考接收器 / 連接埠 4 的測試連接埠接收器，1 是來源連接埠。

深入瞭解成比例和不成比例的接收器量測。

接收器標記法與 S 參數標記法的類似之處在於：

  • 參考未顯示和與等式位於相同通道的資料。

  • 參考資料不包含軌跡設定。

  • 如果通道擁有可用於該接收器的誤差修正，則可透過開啟等式軌跡的誤差修正加以套用。

參考不同通道中的軌跡

當等式軌跡參考不同通道上的軌跡時：

  • 軌跡必須已顯示。

  • 必須使用 TrX 標記法參考軌跡。

  • 等式軌跡和參考軌跡必須擁有相同的資料點數，否則 [已啟用] 勾選方塊將不可用。

  • 擷取相同通道中的上一參考資料時，會更新等式軌跡。因此，要避免使用「過時」資料，等式軌跡必須位於比參考軌跡編號更高的通道上。這是因為 VNA 會根據遞增的通道編號順序擷取資料，即首先是通道 1，然後是通道 2，依此類推。如果等式軌跡在通道 1 上，且參考通道 2 上的軌跡，等式軌跡會在通道 1 完成掃描後更新，從而將「舊」資料用於通道 2 軌跡。

連接埠延伸和等式編輯器

將連接埠延伸與等式搭配使用時，開啟固定裝置以確保對基礎參數正確套用連接埠延伸。

軌跡設定、誤差修正和範例

此部分主要討論參考軌跡時，使用 S 參數/接收器標記法和 TrX 標記法的不同之處。瞭解這些不同之處的關鍵是認識到 S 參數/接收器標記法永遠參考未顯示的資料。

  • 軌跡設定 - 正規化、軌跡數學運算、閘限、相位和幅度偏移、電子延遲、時域。

  • 等式編輯器 - 在誤差修正後立即在等式軌跡上進行處理。

  • 參考資料/軌跡（用於等式中）從以下位置獲取：

  • 使用 TrX 標記法時，會在格式化之前才獲取資料。這些軌跡會始終顯示且包含軌跡設定。

  • 使用 S 參數/接收器標記法時，將在誤差修正之後立即獲取資料。該資料未顯示且不包含軌跡設定（請參閱範例）。

錯誤修正和等式編輯器

使用 TrX 標記法：

  • 在等式軌跡中使用參考軌跡上的軌跡設定和誤差修正。

  • 如果誤差修正未開啟，則會在等式軌跡中使用原始、未修正的資料。

  • 若要確定誤差修正是否已開啟，將軌跡變為作用中軌跡，然後查看狀態列中的修正等級。

  • 在等式軌跡上開啟/關閉誤差修正沒有意義。等式中使用的參考資料始終是確定其修正等級的因素。

使用 S 參數和接收器標記法：

  • 由於資料未顯示，因此不會在等式軌跡中使用軌跡設定。

  • 如果修正的資料可供參考資料使用，則可以開啟/關閉修正。例外狀況：使用 S 參數和接收器標記法參考已透過回應校準或接收器校準進行校準之通道上的軌跡時，無法開啟修正，即使狀態列指示已修正亦如此。例如：Tr1 是具有回應校準的 S11 量測。Tr2 是參考 S11 的等式軌跡。不會修正 Tr2 等式軌跡，即使狀態列可能指示已修正。但是，如果 Tr2 參考 Tr1（而不是 S11），則會修正 Tr2 等式軌跡。

範例

此範例說明使用 S 參數標記法和 TrX 標記法參考軌跡的不同之處：

  • Tr1 是沒有等式、開啟轉換且開啟時域轉換的 S11 量測。

  • Tr2 是參考 Tr1 的等式軌跡。因為 Tr1 已修正，所以 Tr2 也進行了修正。因為 Tr1 已轉換，所以 Tr2 也進行了轉換。如果已針對 Tr2 開啟轉換，資料將再次進行轉換，從而導致資料「異常」。

  • Tr3 是參考 S11 的等式軌跡。這與參考 Tr1 不同。所參考的 S11 軌跡是未顯示的 S11 的其他執行個體，且沒有軌跡設定。請注意，Tr3 資料未轉換，而 Tr1 已轉換。可以開啟和關閉 Tr3 的校準，因為已對 S11 軌跡所處的通道執行了修正。

  • 附註：等式軌跡的 X 軸註解與所顯示的資料完全無關。僅使用來自參考軌跡的資料值。例如，請注意，等式軌跡 Tr2 在 X 軸上有頻率，雖然參考軌跡 Tr1 是以時間表示的。

等式編輯器中使用的函數和常數

等式編輯器中使用的所有軌跡資料是未格式化的複數資料。

將滑鼠與 VNA 搭配使用時，將滑鼠暫留在對話方塊中的函數上，以瞭解其使用方式。

在下表中，

  • 函數（純量 x）表示，在將值傳遞到函數之前，將執行從複數到其純量幅度的自動轉換。

  • 函數（複數 x）表示使用整個複數值。

  • a、b、c、d 是函數中使用的引數。

函數

描述

acos(scalar a)

返回 a 的反餘弦（以弧度表示）

asin(scalar a)

返回 a 的反正弦（以弧度表示）

atan(scalar a)

返回 a 的反正切（以弧度表示）

atan2

返回複數 a = (re,im) 的相位（以弧度表示）

具有以下兩個引數集：

  • atan2(complex a) - 返回相位（以弧度表示）

  • atan2(scalar y, scalar x)

conj(complex a)

獲取 a 並返回共軛複數

cos(complex a)

獲取 a（以弧度表示）並返回餘弦

cpx(scalar a, scalar b)

從兩個純量值返回複數值 (a+ib)

e

返回常數 =~ 2.71828...

exp(complex a)

返回 a 的指數

getNumPoints()

返回目前掃描的點數

im(complex a)

返回 a 的虛數部分作為結果的純量部分（將虛數部分歸零）

kfac(complex a, complex b, complex c, complex d )

在 EE 中輸入時：
kfac(S11,S21,S12,S22)

k 係數：

k = (1 - |a|^2 - |d|^2 + |a*d-b*c|^2 ) / (2 * |b*c|)

返回純量結果 - 複數結果的虛數部分始終為 0

ln(complex a)

返回 a 的自然對數

log10(complex a)

返回 a 以 10 為底數的對數

mag(complex a)

返回 sqrt(a.re*a.re+a.im*a.im)

max(complex a, complex b, ...)

返回值清單中具有最大幅度的複數值。

max_hold(complex a)

保持掃描的當前最大數。停用等式以重設。請參閱範例

median(complex a, complex b,...)

返回複數值清單的中間值

  • 中間值的計算方式為，依幅度對值進行排序，然後返回中間的值。

  • 如果傳遞的值的數量是偶數，則返回兩個中間值中較小的一個。

min(complex a, complex b, ...)

返回值清單中具有最小幅度的複數值。

min_hold(complex a)

保持掃描的當前最小數。停用等式以重設。請參閱範例

mrkx(a)

返回軌跡 a 上作用中標記的 x 軸值。

mrky(a)

返回軌跡 a 上作用中標記的 y 軸值。

mu1(complex a, complex b, complex c, complex d )

在 EE 中輸入時：
mu1(S11,S21,S12,S22)

mu1 = (1 - |a|^2) / ( |d - conj(a) * (a*d-b*c)| + |b*c| )

mu2( complex a, complex b, complex c, complex d )

在 EE 中輸入時：
mu1(S11,S21,S12,S22)

mu2 = (1 - |d|^2) / ( |a - conj(d) * (a*d-b*c)| + |b*c| )

對於 mu1 和 mu2（通常寫為希臘字元 μ）

  • conj 是共軛複數。對於純量 a 和 b， conj(a+ib) = (a-ib)

  • 返回純量結果 - 複數結果的虛數部分始終為 0

phase(complex a)

返回 atan2(a)（以度表示）

PI

返回數字常數 pi (3.141592)，即圓的圓周與其直徑的比率

pow(complex a,complex b)

返回 a 的 b 次冪

re(complex a)

返回 a 的純量部分（將虛數部分歸零）

sin(complex a)

獲取 a（以弧度表示）並返回正弦

sqrt(complex a)

返回 a 的平方根，相角位於半開區間 (-pi/2, pi/2]

tan(complex a)

獲取 a（以弧度表示）並返回正切

traceDataArray(complex a)

從掃描返回完整點集。函數意在用作自訂函數中的引數，可允許存取以進行資料陣列處理。

xAxisArray()

返回整個掃描的 x 軸值。

xAxisIndex()

返回掃描中的目前索引。

xAxisValue()

返回 x 軸索引的目前值。

等式編輯器中使用的運算子

運算子 | 描述
+ | 加法
- | 減法
* | 乘法
/ | 除法
( | 左括弧
) | 右括弧
, | 逗號 - 引數分隔符號（如在 S11, S22 中）
= | 等於（可選）
E | 指數（如在 23.45E6 中）

等式範例

以下範例可協助您開始使用等式編輯器。

將 Tr2 中的每個資料點按 2dB 從 Tr1 進行偏移

使用函數：pow(complex a, complex b) -- 返回 a 的 b 次冪。

20log(a) + 2 = 20log(x)
log( a ) + 2/20 = log( x ) // 全部除以 20.
x = 10^(log(a) + 2/20) // 交換兩側並取 10 的兩側乘冪
x = 10^log(a) * 10^(2/20)
x = a * 10^(2/20)

輸入 Tr2 的等式為：

Offset=Tr1*pow(10, 2/20)

按 5 dB 偏移

Offset=Tr1*pow(10, 5/20).

使用 2 連接埠 VNA 的平衡比對

SDD11 = (S11-S21-S12+S22)/2

轉換損耗

B_1/pow(10,-15/20)

  • B_1 是接收器量測；

  • -15 是輸入功率 (dBm)

三階截點（IP3 或 TOI）

TR1*sqrt(Tr1/Tr3)

  • Tr1 = 輸入訊號功率

  • Tr3 = 互調功率（兩個軌跡均使用單一接收器量測）

調和 (dBc)

B_1/Tr2

  • B_1 調整為調和頻率

  • Tr2 = 基本頻率時的功率，使用 B_1 接收器量測

PAE（功率附加效率）

Pout - Pin / Pdc

將以下等式輸入具有不成比例之量測（例如 AI1）的新軌跡。資料格式為實數：

PAE = 100 * (.001*pow(mag(Tr1),2)-(.001*pow(mag(Tr1),2)/pow(mag(Tr2),2)))/(Tr3*Tr4)

其中：

  • Tr1 - 量測不成比例之 B 接收器的軌跡。

  • Tr2 - 修正的 S21 軌跡（放大器增益）

  • Tr3 - 量測感測電阻器中 ADC 電壓 (AI1) 的軌跡。

  • Tr4 - 包含 Isupp =（Tr3 / 感測電阻器的值）的等式軌跡。

資料以實數格式顯示，單位實際上為瓦數。

1 連接埠插入損耗

如果無法將纜線兩端連接到 VNA，則可以進行 1 連接埠插入損耗量測。但是，量測所得的損耗必須除以 2，因為結果包含透過纜線送出和回送的損耗。這假定裝置以短路或開路終止，以反映所有功率。按以下方式使用等式編輯器執行「除以 2」操作（對於 dB）：

  • Tr1 - 使用對數幅度格式的 S11 軌跡。

  • Tr2 - 包含 sqrt(Tr1) 的等式軌跡。

Max Hold 和 Min Hold

這兩個函數可讓您擷取和顯示多個掃描中每個資料點的最大值或最小值。

Maxhold(S21) - 顯示重設前每個資料點的最大值。透過停用再啟用等式來重設。 此範例參考未顯示的 S21 軌跡。

儲存等式編輯器資料

可以使用以下格式將等式資料儲存到 VNA 硬碟中：

  • Citifile (.cti) - 儲存和叫用等式資料。檔案標頭表示「基礎」S 參數軌跡類型。

  • PRN - 由試算表軟體讀取。無法由 VNA 叫用。

  • CSV - 由試算表軟體讀取。無法由 VNA 叫用。

  • MDIF - 與 Keysight ADS (Advanced Design System) 相容。無法由 VNA 叫用。

  • 列印到檔案（bmp、jpg、png）- 儲存 VNA 畫面的影像。

無法將等式儲存為.SnP 檔案格式。嘗試將等式軌跡儲存為 .SnP 格式時，會儲存「基礎」S 參數資料，而非等式資料。

上次修改時間：

2016 年 01 月 06 日

第一版


參數轉換

對量測結果執行參數轉換

  • 概觀

  • 選取轉換目標參數

其他「分析資料」主題

概觀

您可以使用參數轉換功能，將 S 參數 (Sab) 的量測結果轉換為下列參數。

  • 反射量測中的等效阻抗 (Zr) 和等效導納 (Yr)

  • 傳輸量測中的等效阻抗 (Zt) 和等效導納 (Yt)

  • 逆向 S 參數 (1/Sab)

其中：

Z0a:連接埠 a 的特性阻抗

Z0b:連接埠 b 的特性阻抗

  • Z/Y 傳輸分路

  • 共軛

    共軛將量測值轉換為共軛複數。

當夾具模擬器功能和連接埠阻抗功能均處於「開啟」狀態時，將使用連接埠阻抗轉換中設定的值。在其他情況下，將使用系統 Z0（預設值：50 Ω）。

選取轉換目標參數

  1. 按下 [Meas] > Meas Overview（量測概觀） > Conversion（轉換）

  2. 選取函數。

軟鍵 | 功能
關閉 | 關閉
Z 反射 | 反射量測中的阻抗 (Zr)
Z 傳輸 | 傳輸量測中的阻抗 (Zt)
Z 傳輸-分路 | 傳輸分路中的阻抗 (Zt)
Y 反射 | 反射量測中的導納 (Yr)
Y 傳輸 | 傳輸量測中的導納 (Yt)
Y 傳輸-分路 | 傳輸分路中的導納 (Yt)
1/S | 逆向 S 參數
共軛 | 共軛複數


使用限制來測試裝置

使用限制線

使用限制線可以將量測資料與您定義的效能限制進行比較。

  • 概觀

  • 建立和編輯限制線

  • 使用限制線進行顯示和測試

  • 限值測試裝置

  • 點限制測試

  • 儲存/叫用限制表格

  • 顯示限制測試的判定結果

  • 使用足夠的資料點進行測試

其他分析資料主題

概觀

限制線是量測的指定限制在 VNA 畫面上的視覺表示形式。您可以使用限制線執行下列操作：

  • 在調校裝置時為操作員提供視覺引導。

  • 提供符合裝置規格的標準準則。

  • 顯示資料與規格的比較結果。

限制測試會將量測所得的資料與定義的限制進行比較，並提供每個所量測之資料點的可選通過或失敗資訊。

每條量測軌跡最多可以有 100 條離散線，以便測試受測裝置回應的所有層面。

限制線和限制測試不適用於史密斯圖或極座標顯示格式。如果開啟了限制線，並且變更為史密斯圖或極座標格式，分析程式將會自動停用限制線和限制測試。

建立和編輯限制線

您可以為所有量測軌跡建立限制線。限制線的顏色與量測軌跡相同。

限制線由離散線組成，並且具有四個座標：

  • 開始和結束激勵 - X 軸值。

  • 開始和結束回應 - Y 軸值。

限制表格

如何開啟/關閉限制表格

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit Table（限制表格）以開啟/關閉限制表格。

附註：若要新增限制線至表格，請將最後一條限制線變更為 MAX 或 MIN。

  1. 在限制表格的類型區域中，針對限制線 1 選取最小值或最大值。

    • 最小值會使低於此限制的量測失敗。

    • 最大值會使高於此限制的量測失敗。

  2. 針對限制區段 1 按一下開始激勵。輸入所需的值。

  3. 針對限制區段 1 按一下結束激勵。輸入所需的值。

  4. 針對限制區段 1 按一下開始回應。輸入所需的值。

  5. 針對限制區段 1 按一下結束回應。輸入所需的值。

  6. 針對每條所需的限制線重複步驟 1-5。

使用限制線進行顯示和測試

建立限制線之後，您可以選擇針對每條軌跡顯示或隱藏限制線。指定的限制會一直有效，即使未顯示限制線亦同。

無法對記憶體軌跡執行限制測試。

您可以選擇提供視覺和/或聽覺的「通過/失敗」指示。

開啟限制測試時：

  • 量測軌跡之任何失敗的部分會顯示為紅色。

  • 量測軌跡之任何通過的部分會保持不變且無提示。

顯示失敗的軌跡點或軌跡區段

您可以將限制線測試中失敗的資料點顯示為紅色點或紅色軌跡區段。可以使用 [偏好設定] 設定變更預設行為。瞭解詳細資訊。

紅色點 | 紅色軌跡區段

[通過] 是 [通過/失敗] 測試的預設模式。

只有當量測點超出限制範圍時，資料點才會 [失敗]。

  • 如果限制線設為 [關閉]，整條軌跡將為 [通過]。

  • 如果限制線激勵設定中沒有量測的資料點，該點將會 [通過]。

限制測試設定

如何設定限制測試設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit...（限制...），然後選取對話方塊中的 Limit（限制）索引標籤。

限制測試設定對話方塊說明

限制測試

限制測試開啟 - 勾選此方塊可將資料軌跡與限制進行比較，並顯示 [通過] 或 [失敗]。

限制線開啟 - 勾選此方塊可在畫面上顯示限制（即使限制不可見，仍會執行測試）。

失敗時發出警報聲 - 勾選此方塊後，當資料軌跡上的點在限制測試中失敗時，VNA 將發出嗶嗶聲。

通過/失敗位置

X - 設定 [通過] 或 [失敗] 的 X 軸位置。

Y - 設定 [通過] 或 [失敗] 的 Y 軸位置。

限值資料表

顯示表格 - 勾選此方塊可顯示表格，以便您建立並編輯限制。

載入表格 - 叫用已儲存的限制表格。瞭解詳情。

儲存表格 - 儲存限制表格。瞭解詳情。

附註：若要新增限制線至表格，請將最後一條限制線變更為 MAX 或 MIN。

全域通過/失敗

[通過/失敗] 指示器可讓您輕鬆監控所有量測的狀態。

全域通過/失敗開啟 - 勾選此方塊可顯示 [全域通過/失敗] 狀態。

原則： 選擇必須符合以下哪項要求才能使 [全域通過/失敗] 狀態顯示 [通過]：

  • 所有測試（限制測試為開啟）必須通過 - 此設定會從限制測試讀取結果。如果所有測試（限制測試為開啟）均通過，則 [全域通過/失敗] 狀態將為 [通過]。

  • 所有量測必須通過 - 除非所有量測的資料點均位於已建立的測試限制範圍內，並且限制測試為 [開啟]，否則此更嚴格的設定將顯示 [失敗]。

附註：在此模式下，如果一個量測不是限制測試開啟，則 [全域通過/失敗] 將顯示 [失敗]。

深入瞭解使用限制進行顯示和測試

儲存/叫用限制測試表格

您可以將限制測試表格儲存在檔案中，以供日後在畫面上使用。這個檔案以 csv 格式（副檔名為 *.csv）儲存，而值將儲存為帶有單位的字元字串。csv 格式的檔案也可以在針對 PC 開發的試算表軟體中重複使用。

如何儲存或載入限制測試表格

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit...（限制...），然後選取對話方塊中的 Limit（限制）索引標籤。

  3. 按一下載入表格以叫用已儲存的限制表格。

  4. 按一下儲存表格以儲存限制表格。

此功能無法使用編程

載入表格

  1. 若要叫用已儲存的限制表格，請按一下 [限制測試設定] 對話方塊中的載入表格，即會開啟 [叫用] 對話方塊。此時，已選取 CSV 檔案（副檔名為 *.csv）作為檔案類型。

  2. 指定包含該檔案的資料夾，然後選取該檔案。按一下 Recall（叫用）以在畫面上叫用已儲存的限制表格。

附註：將限制表格儲存到檔案時，可以獨立於作用中的通道和軌跡從任何通道上的某條軌跡叫用限制表格。

儲存表格

  1. 若要儲存限制表格，請按一下 [限制測試設定] 對話方塊中的儲存表格，即會開啟 [另存為] 對話方塊。此時，已選取 CSV 檔案（副檔名為 *.csv）作為檔案類型。

  2. 指定要在其中儲存檔案的任意資料夾，然後輸入檔案名稱。按一下儲存以將畫面上顯示的限制表格儲存到檔案。

限制表格會以下列格式儲存：

  • 第一行指出儀器的限制測試的類型。

  • 第二行指出限制測試的版本。

  • 第三行指出區段項目的標題，這些區段項目是從第四行開始輸出。

  • 從第四行開始，輸出區段資料。

限制表格儲存格式範例：

"# E5080 Limit Test"

"# Revision: 1.00"

TYPE, BEGIN STIMULUS, END STIMULUS, BEGIN RESPONSE, END RESPONSE

MIN, 5.600000 GHz, 7.500000 GHz, -30.000000dB, -30.000000dB

MAX, 4.700000 GHz, 5.800000 GHz, -10.000000dB, -10.000000dB

MAX, 6.200000 GHz, 8.000000 GHz, -10.000000dB, -10.000000dB

OFF, 0.000000 Hz, 0.0000000 Hz, 0.00dB

顯示限制測試的判定結果

量測點和軌跡的判定結果

失敗的量測點會在畫面上以紅色顯示。依預設，軌跡的判定結果由畫面右下方顯示的 [通過] 或 [失敗] 指示，您可以編輯該指示器的位置。

通道的判定結果

勾選（開啟）全域通過/失敗開啟時，如果通道的判定結果為失敗，該結果會顯示在 [全域通過/失敗] 對話方塊中。在任何限制測試中，如果通道中存在一或多條不符合要求的軌跡，就會判定為失敗。

如何開啟/關閉全域通過/失敗

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit...（限制...），然後選取對話方塊中的 Limit（限制）索引標籤。

  3. 勾選該方塊以開啟 [全域通過/失敗]。

  4. 清除該方塊以關閉 [全域通過/失敗]。

使用足夠的資料點進行測試

當 [System] > System Setting（系統設定）> Preference（偏好設定），限制:測試最近的量測點處於未勾選狀態時，僅在實際量測的資料點處檢查限制。因此，如果資料點密度不足，裝置有可能被視為不符合規格，而不會有限制測試失敗的指示。

下圖是使用 11 個資料點（大約每條垂直標線上有一個）的實際濾波器的資料軌跡。會使用最小限制線對濾波器進行測試（限制線以下的任何資料點皆會失敗）。

雖然資料軌跡明顯位於濾波器邊緣兩側的限制線下方，但卻指示 [通過]，因為沒有在這些頻率上量測的資料點。

下圖顯示完全相同的條件，但資料點的數量增加到了 1601 個。現在濾波器在最小限制測試中失敗，由紅色資料軌跡表示。

當 [System] > System Setting（系統設定）> Preference（偏好設定），限制:測試最近的量測點處於勾選狀態時，會將限制與最近的量測點進行比較。

特定點處的限制測試

您可以在特定的頻率點進行限制測試。此功能與 E5071C 中的功能類似。當限制測試表格中的（開始激勵 = 結束激勵）且（開始回應 = 結束回應）時，該點會定義為點限制測試，並顯示 v（代表最大值）或 ^（代表最小值）符號。

使用點限制測試時，請確認是否勾選了 [System] > System Setting（系統設定）> Preference（偏好設定），限制:測試最近的量測點。在此設定中，即使測試點（= 開始激勵 = 結束激勵）不是位於量測點，也會使用最近的量測點來判斷結果。

上次修改時間：

2016 年 01 月 06 日

第一版


使用漣波限制測試

  • 概觀

  • 漣波限制測試的概念

  • 建立和編輯漣波限制線

  • 顯示漣波限制測試結果

  • 漣波限制測試設定

  • 儲存/叫用漣波限制表格

其他「分析資料」主題

概觀

可以獨立執行漣波限制功能，不必依賴限制測試功能。您可以不依賴限制測試，而是透過設定漣波限制來評估量測結果是通過還是失敗。此功能稱為「漣波限制測試」。

在上圖中，A 大於 B。因此，A 被視為指定激勵範圍的漣波。

漣波限制功能僅評估量測點值。不會使用內插值。

漣波限制測試的概念

根據使用漣波限制表格設定的漣波限制，漣波限制測試功能可以評估結果是通過還是失敗。漣波的定義是，指定激勵範圍內最大值與最小值之間的差。您可以指定多達 12 個頻帶，而且可以對每個頻帶進行測試。

如果使用漣波限制指定的漣波值未超過軌跡上的任何量測點，漣波限制測試會將量測判定為「通過」；否則，會將量測判定為「失敗」。對於沒有指定漣波限制的激勵範圍中的量測點，測試會將量測判定為「通過」。

附註：只有量測點是進行通過/失敗評估的目標。不會評估量測點之間的內插部分。

漣波限制是以起點激勵值、終點激勵值、漣波限制值和類型（開啟/關閉）定義的。如需詳細資訊，請參閱漣波限制表格。

開啟漣波限制測試功能之後，畫面上會以紅色指出與「失敗」判定相對應的量測點，並且會顯示根據每個量測點的結果所得的軌跡測試結果（如果軌跡上存在一或多個紅色量測點，則判定為「失敗」）。如需有關如何顯示結果的資訊，請參閱漣波限制設定。您也可以確認畫面上的通道測試結果（如果通道中的限制測試、漣波限制測試或頻寬限制測試中出現一或多條失敗的軌跡，則判定為「失敗」）。

建立和編輯漣波限制線

您可以為所有量測軌跡建立漣波限制線。漣波限制線的顏色與量測軌跡相同。

漣波限制線由離散線組成，並且具有三個座標：

  • 開始激勵和結束激勵 - X 軸值。

  • 最大漣波 - Y 軸值。

漣波限制表格

您必須設定漣波限制，然後才能使用漣波限制測試功能。您可以為每條軌跡指定漣波限制表格，最多可設定 12 個漣波限制帶（頻帶）。

如何開啟/關閉漣波限制表格

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit Table（限制表格）以開啟/關閉漣波表格。

附註：若要新增頻帶至漣波限制表格，請將最後一條漣波限制線變更為「開啟」或「關閉」。

附註：依預設，漣波限制表格中不提供任何頻帶。

  1. 在漣波限制表格的類型區域中，針對漣波限制線 1 選取開啟或關閉。

    • 開啟 - 頻帶可用於漣波限制測試。

    • 關閉 - 頻帶不可用於漣波限制測試。

  2. 針對漣波限制區段 1 按一下開始激勵。輸入所需的值。

  3. 針對漣波限制區段 1 按一下結束激勵。輸入所需的值。

  4. 針對漣波限制區段 1 按一下最大漣波。輸入所需的值。

  5. 針對每條所需的漣波限制線重複步驟 1-4。

如何開啟/關閉漣波限制表格

附註：激勵值的可接受範圍：-500G 或 +500G。如果指定任何超出範圍的值，會將該值重設為範圍以內的值。

附註：即使在設定激勵值之後變更了 VNA 的掃描範圍，激勵值也不受影響。

漣波限制配置範例

  • 漣波限制測試的各個頻帶可能互相重疊；在此情況下，必須對每個頻帶執行漣波限制測試。

  • 即使 VNA 的跨距值設定為零，您也必須為 [開始激勵] 和 [結束激勵] 輸入參數。

  • 如果資料格式是史密斯圖或極座標，則會對兩個標記回應值中的主要回應值執行限制測試。

顯示漣波限制測試結果

軌跡的測試結果

軌跡的測試結果會在圖表的左上方區域中指示為 [通過] 或 [失敗]。您也可以顯示所選頻帶內的漣波值。 如果軌跡不符合要求，測試結果和漣波線會顯示為紅色。

每條軌跡的結果將顯示為 [Ripln:Pass] 或 [Ripln: Fail]，n 表示軌跡編號。漣波值緊接在 BWn 之後（如果關閉漣波顯示，則僅顯示 Bn，而不顯示漣波值）。

全域通過/失敗

[限制] 索引標籤中的 [全域通過/失敗] 設定套用至漣波限制測試。如果在任何漣波限制測試中，通道中存在一或多條不符合要求的軌跡，就會判定為失敗。

漣波限制測試設定

如何設定漣波限制測試設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Channel] 或 [Trace]，以選取要套用漣波限制測試功能的軌跡。

  2. 按下 [Math] > Analysis（分析）。

  3. 按一下 Limit...（限制...），然後選取對話方塊中的 Ripple（漣波）索引標籤。

（漣波）限制測試設定對話方塊說明

漣波測試

漣波測試開啟 - 勾選此方塊可將漣波測試設定為 [開啟] 或 [關閉]，並顯示 [通過] 或 [失敗]。

漣波線開啟 - 勾選此方塊可在畫面上顯示漣波限制線（即使未開啟漣波線，仍會執行測試）。

漣波結果

類型 - 設定顯示漣波值的方式。可用設定包括：關閉、絕對值（頻帶內最大值與最小值之間的差）顯示和餘裕（漣波絕對值與漣波限制值之間的差）顯示。

區段 - 啟用此選項可指定漣波限制表格，每條軌跡最多有 12 個激勵區段。

漣波表格

顯示表格 - 勾選此方塊可顯示表格，以便您建立並編輯限制。

載入表格 - 叫用已儲存的漣波限制表格。瞭解詳情。

儲存表格 - 儲存漣波限制表格。瞭解詳情。

儲存/叫用漣波限制表格

您可以將漣波限制表格儲存在檔案中，以供日後在畫面上使用。這個檔案以 csv 格式（副檔名為 *.csv）儲存，而值將儲存為帶有單位的字元字串。csv 格式的檔案也可以在針對 PC 開發的試算表軟體中重複使用。

如何設定漣波限制設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Math] > Analysis（分析）。

  2. 按一下 Limit...（限制...），然後選取對話方塊中的 Ripple（漣波）索引標籤。

  3. 按一下載入表格以叫用已儲存的漣波限制表格。

  4. 按一下儲存表格以儲存漣波限制表格。

此功能無法使用編程

載入表格

  1. 若要叫用已儲存的漣波限制表格，請按一下 [漣波限制測試設定] 對話方塊中的載入表格，即會開啟 [叫用] 對話方塊。此時，已選取 CSV 檔案（副檔名為 *.csv）作為檔案類型。

  2. 指定包含該檔案的資料夾，然後選取該檔案。按一下 Recall（叫用）以在畫面上叫用已儲存的漣波限制表格。

附註：將漣波限制表格儲存到檔案時，可以獨立於作用中的通道和軌跡從任何通道上的某條軌跡叫用漣波限制表格。

儲存表格

  1. 若要儲存漣波限制表格，請按一下 [漣波限制測試設定] 對話方塊中的儲存表格，即會開啟 [另存為] 對話方塊。此時，已選取 CSV 檔案（副檔名為 *.csv）作為檔案類型。

  2. 指定要在其中儲存檔案的任意資料夾，然後輸入檔案名稱。按一下儲存以將畫面上顯示的漣波限制表格儲存到檔案。

漣波限制表格會以下列格式儲存：

  • 第一行指出儀器的限制測試的類型。

  • 第二行指出限制測試的版本。

  • 第三行指出區段項目的標題，這些區段項目是從第四行開始輸出。

  • 從第四行開始，輸出區段資料。

漣波限制表格儲存格式範例：

"# E5080 Ripple Limit Test"

"# Revision: 1.00"

TYPE, BEGIN STIMULUS, END STIMULUS, MAX RIPPLE

ON, 933.0000000 MHz, 964.0000000 MHz, 1.5 dB

ON, 938.0000000 MHz, 953.0000000 MHz, 500 mdB

上次修改時間：

2016 年 01 月 06 日

第一版


使用頻寬限制測試

  • 概觀

  • 顯示頻寬限制測試結果

  • 頻寬限制測試設定

其他「分析資料」主題

概觀

頻寬限制測試功能可用於測試帶通濾波器的頻寬。

頻寬測試能找出通帶內的訊號峰值，並在低於測試設定中指定之峰值的幅度內，在通帶的每一側定位一個點。這兩點之間的頻率就是濾波器的頻寬。然後將所得的頻寬與您預先指定的最小或最大允許頻寬進行比較。

顯示頻寬限制測試結果

軌跡的測試結果

軌跡的測試結果會在圖表的左上方區域中指示為「通過」、「寬」或「窄」，緊接在 BWn 之後。"n" 表示軌跡編號。您也可以顯示頻寬值。如果軌跡不符合要求，測試結果和頻寬標記會顯示為紅色。

全域通過/失敗

[限制] 索引標籤中的 [全域通過/失敗] 會套用至頻寬限制測試。如果在任何一次頻寬測試中，通道中存在一或多條不符合要求的軌跡，就會判定為失敗。

頻寬限制測試設定

在使用頻寬限制測試功能之前，您必須設定頻寬閾值及上限和下限。您可以為每條軌跡指定閾值、上限和下限。

如何設定頻寬限制設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Channel] 或 [Trace]，以選取要套用頻寬限制測試功能的軌跡。

  2. 按下 [Math] > Analysis（分析）。

  3. 按一下 Limit... （限制...），然後選取對話方塊中的 Bandwidth（頻寬）索引標籤。

頻寬測試設定對話方塊說明

頻寬測試

頻寬測試開啟 - 勾選此方塊可將頻寬限制測試設為 [開啟] 或 [關閉]。

頻寬標記開啟 - 勾選此方塊可在畫面上顯示頻寬標記（即使未開啟頻寬標記，仍會執行測試）。

失敗時發出警報聲 - 勾選此方塊後，頻寬限制測試為 [失敗] 時將發出警報聲。

目標頻寬

N 個 dB 點 - 以 dB 為單位指定頻寬閾值。

最小頻寬 - 以 Hz 為單位輸入頻寬的下限值。

最大頻寬 - 以 Hz 為單位輸入頻寬的上限值。

附註：如果資料格式是史密斯圖或極座標，將會略過測試。

上次修改時間：

2016 年 01 月 06 日

新主題


儲存和重新叫用檔案

使用 VNA 可以在內部或外部儲存裝置中儲存和重新叫用各種格式的檔案。

  • 儲存 VNA 儀器狀態和校準檔案

  • 儲存 VNA 量測資料

  • 重新叫用檔案

  • 儀器狀態和校準檔案（.csa、.cst、.sta、.cal）

  • 量測資料檔案（.prn、.snp、.cti、.csv、.mdf）

  • 定義資料儲存

  • 在不使用滑鼠的情況下管理檔案

其他資料輸出主題

儲存 VNA 儀器狀態和校準檔案

如何儲存儀器狀態和校準檔案

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save State（儲存狀態）或 Save Other（儲存其他）。

[Save Recall] > Save State（儲存狀態）Softtab 說明

瞭解 VNA 儀器狀態檔案的所有資訊。

儲存狀態 - 立即將 VNA 狀態、可能的校準資料和連結儲存至所選的檔案名稱，實際取決於儲存類型。執行儲存時，會在儲存裝置中自動產生選取的檔案名稱。

自動儲存 - 將狀態、校準資料和連結儲存至儲存裝置。將狀態和校準資料儲存至 D: 資料夾中的內部儲存裝置。檔案名稱是使用語法「atxxx」自動產生的；其中 xxx 是自動儲存新檔案時以 1 作為遞增量的編號。檔案名稱取決於儲存類型，即以「.sta」、「.csa」或「.cst」儲存檔案。

另存狀態為... - 啟動另存新檔對話方塊。

儲存暫存器 - 立即將指定的暫存器（暫存器 1 至 8）儲存至所選的檔案名稱，實際取決於儲存類型。在選取的暫存器上執行儲存時，會在儲存裝置中自動產生選取的檔案名稱。

儲存類型

狀態 - 以 .sta 檔案名稱儲存 VNA 狀態。

狀態 + 校準資料 - 以 .csa 檔案名稱儲存 VNA 狀態和校準資料。

狀態 + 校準連結 - 以 .cst 檔案名稱儲存 VNA 狀態和校準連結。

[Save Recall] > Save Other（儲存其他）Softtab 說明

儲存校準集... 和儲存螢幕... - 啟動另存新檔對話方塊。

儲存資料... - 啟動另存資料為對話方塊。

儲存使用者預設...- 啟動使用者預設對話方塊。

另存（狀態和校準）為對話方塊說明

儲存於 - 可讓您瀏覽至用來儲存檔案的目錄。

檔案名稱 - 顯示在目錄內容方塊中輸入或按一下的檔案名稱。

附註：檔案名稱（不包括路徑名稱）可以包含不限數量的字元。

存檔類型

下列檔案類型可儲存儀器狀態和校準資料。您可以儲存目前在 VNA 中使用的所有通道的儀器設定和校準資料，並在日後重新叫用。只有 Keysight VNA 系列和分析儀能辨識這些檔案類型。

暸解有關這些檔案類型的詳細資訊。

  • *.csa - 儲存儀器狀態和實際校準集資料（校準/狀態封存）預設選取項目

  • *.cst - 儲存儀器狀態和校準集資料的連結

  • *.sta - 僅儲存儀器狀態（無校準資料）

  • *.cal - 僅儲存實際校準資料（無儀器狀態）

附註：若要將 VNA 螢幕儲存為 .bmp、.jpg 或 .png 圖形檔案類型，請按一下檔案/列印至檔案。 瞭解詳情。

儲存 - 將檔案儲存至指定的檔案名稱和目錄。

儲存 VNA 量測資料

如何儲存 VNA 量測資料

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

另存資料為 - 將目前的軌跡儲存至指定的檔案類型。

附註：此對話方塊現在包含之前從舊的定義資料儲存對話方塊選取的設定。

另存資料為對話方塊說明

附註：儲存量測資料之前，請一律觸發單一量測，然後允許 VNA 通道進入保持狀態。這樣可確保儲存整個量測軌跡。

附註： 記憶體軌跡無法儲存至任何檔案類型 (PRN、SNP、CTI、CSV、MDF)。

儲存於 - 可讓您瀏覽至用來儲存檔案的目錄。

檔案名稱 - 顯示在目錄內容方塊中輸入或按一下的檔案名稱。

附註：檔案名稱（不包括路徑名稱）可以包含不限數量的字元。

存檔類型 - 選擇下列選項：（按一下每個選項可深入瞭解每個檔案類型） *.prn、*.SNP、 *.cti (citifile)、*.csv、*.mdf。

  • 軌跡和雜訊參數 (*.snp) - 儲存雜訊係數參數和 S 參數。瞭解詳情。

範圍

決定哪些軌跡要儲存至檔案。僅適用於 *.cti、*.csv 和 *.mdf。

  • 自動

    • 修正關閉時，儲存指定的軌跡。

    • 修正開啟時，儲存與校準集中校準連接埠關聯的所有已修正的參數。

  • 單一軌跡 - 儲存作用中的軌跡。

  • 顯示的軌跡 - 儲存所有通道的所有顯示的軌跡。

  • 通道軌跡 - 儲存作用中通道的所有顯示的軌跡。

[Format]

決定資料的格式。適用於 Citifile 格式的資料 (*.cti)、CSV 格式的資料 (*.csv)、SNP、MDIF 資料 (*.mdf)

  • 自動 - 以對數幅度/角度或線性幅度/角度格式儲存資料（如果這些格式之一是目前選取的顯示格式）。如果格式為其他格式，則以實數/虛數格式儲存資料。

  • 對數幅度/角度 (dB/deg)、線性幅度/角度 (unit/deg)、實數/虛數 - 選取輸出格式。

  • 所有對數幅度和線性幅度資料的虛部都以度儲存 (dB/deg)。

  • 始終不平滑化實數/虛數資料。

  • 顯示的格式 （僅限 CSV 和 MDIF）- 資料以所顯示軌跡的格式儲存。

附註：.prn 檔案只能以所顯示的格式儲存作用中軌跡。

儲存 - 將檔案儲存至指定的檔案名稱和目錄。

取消 - 關閉對話方塊。

說明 - 顯示另存資料為對話方塊說明。

重新叫用檔案

如何重新叫用（開啟）檔案

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Recall] > Recall（重新叫用）。

[Save Recall] > Recall（重新叫用）Softtab 說明

重新叫用狀態 - 重新叫用指定的檔案名稱。

重新叫用狀態 - 從軟鍵上顯示的檔案清單進行選取。您可以按「最近用過的」或字母順序（取決於偏好設定）對清單進行排序。偏好設定顯示在要重新叫用的軟鍵清單檔案的第二頁底端或「偏好設定」對話方塊方中。

重新叫用狀態... - 啟動重新叫用對話方塊。

重新叫用暫存器 - 重新叫用暫存器（暫存器 1 至 8），它儲存在 D:\ 磁碟機中（只能重新叫用已儲存的暫存器）。

重新叫用校準集... - 啟動重新叫用對話方塊。

重新叫用資料... - 啟動重新叫用對話方塊。

重新叫用順序 - 可根據名稱或最近用過的檔案順序，排列要重新叫用的檔案清單。

重新叫用對話方塊說明

查詢 - 允許您選取包含所要重叫用的檔案的目錄。

檔案名稱 - 顯示在目錄內容方塊中輸入或按一下的檔案名稱。

檔案類型 - 允許您檢視和選取以某個文件類型的類別列出的檔案。下列類型的檔案可以重新叫用至 VNA 中：所有狀態檔案、 Citi 檔案、SNP 檔案。

重新叫用 VNA 狀態檔案

將儀器狀態檔案重新叫用至 VNA 時，儀器的目前狀態會由重新叫用的狀態所覆寫。*.cal 檔案不含儀器狀態，只包含校準資料。暸解有關儀器狀態的詳細資訊。

另請參閱儲存/重新叫用、使用者預設和預設期間的電源開啟和關閉。

將資料檔案重新叫用至 VNA

Citi 檔案和 SNP 檔案可重新叫用至 VNA 並進行檢視。

  1. 依序按一下檔案和重新叫用。

  2. 選取 Citifile 資料或 Snp。

  3. 選取要重新叫用的檔案。

  4. 按一下重新叫用。

附註：在 CW 時間掃描中儲存的 Citi 檔案無法重新叫用至 VNA

附註：無法重新叫用檔案名稱（不包括路徑名稱）超過 64 個字元的檔案。

不管檔案以何種方式儲存，一律會使用對數幅度格式在 VNA 上顯示重新叫用的資料。

通道會處於「觸發保留」狀態中。如果繼續觸發，資料將被覆寫。

SNP 檔案會作為軌跡重新叫用至單一視窗和通道中，從 VNA 中允許的最高可用通道編號開始。 對於多埠 SNP 檔案（超過 4 個連接埠），如果檔案中的 S 參數數目超過視窗中最大軌跡數目，將會建立新視窗。

Citi 檔案將重新叫用至它們儲存時的相同視窗和通道組態中。但是，新重新叫用的通道編號將以 VNA 中允許的最高通道編號開始，並隨著通道增加而遞減。

例如，儲存 citi 檔案時，兩條軌跡在視窗 1、通道 1 中，另外兩條軌跡在視窗 2、通道 2 中。當重新叫用至原廠預設條件（1 條軌跡在視窗 1、通道 1 中）時，重新叫用的前兩條軌跡將顯示在視窗 2、最高通道編號中，另外兩條軌跡則顯示在視窗 3（最高通道編號 -1）中。另請參閱 VNA 中的軌跡、通道和視窗

重新叫用 - 重新叫用顯示在檔案名稱方塊中的檔案。

儀器狀態/校準檔案

您可以儲存目前在 VNA 中使用的所有通道的儀器設定和校準資料，並在日後重新叫用。

儀器狀態包含幾乎所有的 VNA 設定。下列 VNA 設定不會與「儀器狀態」一起儲存和重新叫用：

  • GPIB 位址

  • RF 功率開啟/關閉（取決於目前的設定）

  • 測試裝置 I/O 設定

使用下列檔案類型可儲存和重新叫用儀器狀態及校準集資訊：

檔案類型

儲存的每個通道資訊

.csa | .cst |  | .sta | 儀器狀態資訊
 |  |  |  | 通道/軌跡 | 平均
 |  |  |  | Windows | 標記
 |  |  |  | 觸發 | 數學運算/記憶體
 |  |  |  | [Format] | 限制
 |  |  |  | [Scale] | 更多...
 |  |  |  | 激勵資訊：
 |  |  |  | 頻率範圍 | 替代掃描
 |  |  |  | 點數 | 連接埠功率
 |  |  |  | IF 頻寬 | 來源衰減器
 |  |  |  | 掃描類型 | 接收器衰減器
 |  |  |  | 掃描模式 | 測試裝置連接埠對應
 |  | .cal |  | 校準集資訊
 |  |  |  | GUID（全域唯一識別碼） 提供前往校準集的連結
 |  |  |  | 名稱、描述、修改日期
 |  |  |  | 激勵資訊：
 |  |  |  | 頻率範圍 | 替代掃描
 |  |  |  | 點數 | 連接埠功率
 |  |  |  | IF 頻寬 | 來源衰減器
 |  |  |  | 掃描類型 | 接收器衰減器
 |  |  |  | 掃描模式 | 測試裝置連接埠對應
 |  |  |  | 誤差項：方向性、串擾、來源匹配、負載匹配、反射追蹤、傳輸追蹤

檔案類型的說明與重新叫用

以下將說明每種檔案類型以及重新叫用檔案類型時會發生的情況。

*.sta 檔案

  • 僅包含儀器狀態資訊 - 不包含校準資料。

  • 重新叫用時，它們始終會立即取代目前的儀器狀態。

*.cst 檔案

  • 同時包含儀器狀態和前往校準集的連結。暸解有關校準集的詳細資訊。

  • 儲存和重新叫用已校準儀器狀態的最快、最彈性的方法。

  • 不需要將通道的校準資料儲存為 .cst 檔案。

  • 重新叫用時，會先載入狀態資訊。然後 VNA 將嘗試套用校準集，就像手動操作那樣。如果儀器狀態和連結的校準集之間的激勵設定不同，則顯示常用選擇（請參閱校準集）。如果連結的校準集被刪除，則會顯示訊息，但狀態資訊將保留在目前的位置。

  • 因為只儲存校準集的連結，所以可與其他量測共用校準集。

附註：在儲存 .cst 檔案之前，應確保使用使用者校準集（不是校準暫存器）進行校準。只要執行校準，就會使用新資料覆寫校準暫存器，在重新叫用 .cst 檔案時，校準資料可能不準確。暸解有關校準集的詳細資訊。

*.cal 檔案

  • 僅包含校準集資訊。

  • 重新叫用時，不會自動套用校準集。將校準資料套用至通道，就像套用任何校準集那樣。

  • 瞭解重新叫用

*.csa 檔案

  • 包含所有的儀器狀態和實際的校準集；不包含前往校準集的連結。

  • 儲存和重新叫用已校準儀器狀態的最安全方法。但是，檔案比 *cst 檔案大，儲存和重新叫用時間也較長。此外，因為儲存了實際的校準集，所以很難與其他量測共用校準資料。

  • 不需要對通道進行校準以儲存為 .cst 檔案。

  • 所儲存的校準集可以是校準暫存器或使用者校準集。

  • 瞭解重新叫用

附註：*.pcs 檔案是 VNA 用於儲存校準集的內部檔案格式。使用者不能存取或複製這些檔案。

量測資料檔案

量測資料會儲存為 ASCII 檔案類型，以方便在試算表或 CAE 程式中使用。

附註：儲存量測資料之前，請一律觸發單一量測，然後允許 VNA 通道進入保持狀態。 這樣可確保儲存整個量測軌跡。

附註： 記憶體軌跡無法儲存至任何檔案類型 (PRN、SNP、CTI、CSV、MDF)。

VNA 可以儲存下列檔案類型。

  • *.prn 檔案

  • *.snp (Touchstone)

  • *.cti (Citifile)

  • *.csv

  • *.mdf (MDIF)

*.prn 檔案

.Prn 檔案具有下列屬性：

  • 逗點分隔的資料，可由試算表軟體（如 Microsoft Exce）讀取至列和欄中。為了防止「分隔」對話方塊，可將檔案副檔名從 .prn 變更為 .csv。然後，在 Microsoft Excel 中直接開啟它。

  • 僅包含目前作用中軌跡的已格式化和修正的激勵和回應資料。

  • 僅為輸出 - 不能由 VNA 讀取。

  • 校準集檢視器資料可以儲存至 *.prn 檔案

如何儲存 PRN 軌跡資料 (*.prn)

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取 PRN 軌跡資料 (*.prn)。

例如：

.SNP 格式（*.s1p、*.s2p、*.s3p、*.s4p）

  • *.SNP 檔案格式也稱為 Touchstone 格式，是由 IBIS 指定的。請參閱 Touchstone 規格。

  • *.SNP 檔案格式由 CAE 程式（如 Keysight 的 Microwave Design System (MDS) 和 Advanced Design System (ADS)）使用。

  • *.SNP 資料是使用檔案的另存資料為對話方塊儲存的。

儲存量測資料之前，請一律觸發單一量測，然後允許 VNA 通道進入保持狀態。 這樣可確保儲存整個量測軌跡。

*.SNP 檔案和其他 VNA 設定

  • 您可以在 VNA 中重新叫用和檢視 .SNP 資料，或由 VNA 嵌入/解除嵌入功能讀取。

  • 若要在啟用外部測試裝置的情況下儲存 SNP 資料，可在「檔案」的另存新檔對話方塊中，選取 SNP 檔案(*.s*p), ，然後完成「選擇連接埠」對話方塊。

  • 如果啟用了固定裝置，會將所有啟用的資料轉換（解除嵌入、連接埠 Z 轉換等）套用至所儲存的 SNP 檔案。

  • 將平滑化套用至軌跡時，如果格式是實數、虛數 (RI)，則不會儲存平滑化。若要儲存平滑化的資料，請選取其他格式。

  • 雜訊數字參數和 S 參數可儲存至 *.s2p 檔案。瞭解詳情。

  • 可將平衡參數儲存至 *.SNP 檔案。請參閱「選擇連接埠」對話方塊。

  • 重要 - 系統使用與作用中量測相同的格式和設定（軌跡數學運算、偏移、延遲等）儲存所有的有效資料。這會導致儲存的非作用中量測資料明顯不同於所顯示的資料。例如，在儲存 S2P 檔案時，如果作用中的 S11 量測設定為資料/記憶體（資料除以記憶體），那麼將使用資料/記憶體儲存所有 4 個 S 參數。在資料/記憶體作業中使用的記憶體軌跡與在作用中 (S11) 量測中使用的軌跡相同。

儲存的內容

*.SNP 資料通常用於收集完全修正過的量測的所有 S 參數。VNA 將儲存在作用中量測的通道中可用的資料。

檔案類型 | 連接埠數目 | 儲存的 S 參數數目
*.s1p | 1 | 1 個 S 參數
*.s2p | 2 | 4 個 S 參數
*.s3p | 3 | 9 個 S 參數
*.s4p | 4 | 16 個 S 參數
... | ... | ...
*.SNP | N | N^2 個 S 參數

  • 如果套用了修正全 N 連接埠校準，將會傳回所有修正的 S 參數的有效資料。回應校準將儲存未修正的資料。

  • 如果要求的資料比可用資料少，將會顯示選擇 SNP 資料的連接埠對話方塊。

  • 如果未套用修正，VNA 將使用所選通道上的 S 參數量測傳回盡可能多的適用原始資料。無法使用的資料會用零填充。例如，如果未套用修正，作用中的量測是 S11，且通道上還有 S21 量測，則會傳回 S11 和 S21 量測的資料。S12 和 S22 的資料無法使用，因此將以實數/虛數格式的零傳回。在對數幅度/相位格式中，這會顯示為 -200 dB 和 45 度。

如何儲存 .SNP 格式（*.s1p、*.s2p、*.s3p、*.s4p）

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取軌跡（*.s1p、*.s2p、*.s3p 或*.s4p）。

.SNP 資料輸出

*.SNP 檔案包含：標頭資訊及下列逗點分隔值。.s1p、 s2p 等之間的唯一差別是所儲存的 S 參數數目。

  • 激勵資料

  • 每個 S 參數量測的資料對

附註：儘管以下顯示實數/虛數對，但格式也可能是對數幅度/相位或線性幅度/相位。

*.s1p 檔案

每筆記錄包含 1 個激勵值和 1 個 S 參數（共 3 個值）

Stim Real (Sxx) Imag(Sxx)

例如：

*.s2p 檔案

每筆記錄包含 1 個激勵值和 4 個 S 參數（共 9 個值）

Stim Real (S11) Imag(S11) Real(S21) Imag(S21) Real(S12) Imag(S12) Real(S22) Imag(S22)

例如：

*.s3p 檔案

每筆記錄包含 1 個激勵值和 9 個 S 參數（共 19 個值）

Stim Real (S11) Imag(S11) Real(S12) Imag(S12) Real(S13) Imag(S13)

Real (S21) Imag(S21) Real(S22) Imag(S22) Real(S23) Imag(S23)

Real (S31) Imag(S31) Real(S32) Imag(S32) Real(S33) Imag(S33)

例如：

*.s4p 檔案

每筆記錄包含 1 個激勵值和 16 個 S 參數（共 33 個值）

Stim Real (S11) Imag(S11) Real(S12) Imag(S12) Real(S13) Imag(S13) Real(S14) Imag(S14)

Real (S21) Imag(S21) Real(S22) Imag(S22) Real(S23) Imag(S23) Real(S24) Imag(S24)

Real (S31) Imag(S31) Real(S32) Imag(S32) Real(S33) Imag(S33) Real(S34) Imag(S34)

Real (S41) Imag(S41) Real(S42) Imag(S42) Real(S43) Imag(S43) Real(S44) Imag(S44)

例如：

選擇 SNP 檔案的連接埠對話方塊說明

使用此對話方塊可以在選取「檔案」、另存新檔、「軌跡 SNP」以及存在以下任意條件時要儲存哪些 S 參數資料：

  • 要求的資料少於可用的資料。

  • 需要 4 個連接埠以上的資料。

  • 平衡量測處於作用中時。

連接埠數目 - 選取要儲存其資料的連接埠數目。

箭頭按鈕 - 按一下 ( >> ) 可新增，按一下 ( << ) 可移除以下各欄的連接埠：

可用的連接埠 - VNA/外部測試裝置連接埠。可能沒有適用於所有這些連接埠的有效資料。瞭解詳情。

選擇連接埠 - 按一下確定時，將儲存這些連接埠的 SNP 資料。

確定 - 當選擇的連接埠數目 = 要儲存的連接埠數目時，將變成可用狀態。按一下即可儲存至 SNP 檔案。

如果連接埠數目 = 2，則儲存 .s2p 資料；如果連接埠數目 = 3，則儲存 .s3p 資料，以此類推。暸解有關 SNP 檔案的詳細資訊

.cti (Citi) 檔案

Citifile 格式與 Keysight 8510 網路分析儀及 Keysight 的 Microwave Design System (MDS) 相容。

使用 citifile 可以執行以下操作：

  • 儲存作用中的軌跡或所有軌跡。

  • 儲存格式化或未格式化的 citifile 資料。

如何儲存 Citifile 格式化的資料 (*.cti)

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取 Citifile 格式化的資料 (*cti)。

*.csv 檔案包含：

  • 標頭資訊

  • 激勵資料

  • 每個 S 參數量測的資料對

格式由 DBANGLE（對數幅度）、MAGANGLE（線性幅度）或 RI（實數、虛數 - 未顯示）識別

在資料存取對應中，會從位置 2 或 4 取得格式化資料。

如何儲存 Citifile 未格式化的資料 (*.cti)

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取 Citifile 資料（實數，虛數）(*cti)。

在資料存取對應中，會從「格式」前面的區塊中取得未格式化的資料。

可在 VNA 中重新叫用和檢視 citifile。瞭解詳情。

*.csv 檔案

附註：使用此處未顯示的其他格式將 2D 增益壓縮資料儲存為 *.csv 檔案。瞭解詳情。

CSV 檔案可由試算表程式（如 Microsoft Excel）讀取。

如何儲存 CSV 格式化的資料 (*.csv)

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取 CSV 格式化的資料 (.csv)。

*.csv 檔案包含：

  • 標頭資訊及下列逗點分隔值。

  • 激勵資料

  • 每個 S 參數量測的資料對

*.mdf 檔案

MDIF 檔案與 Keysight ADS (Advanced Design System) 相容。

如何儲存 MDIF 資料 (*.mdif)

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下Save Data...（儲存資料...），另存資料為對話方塊將顯示。

  3. 在存檔類型下方，選取 MDIF 資料 (*.mdif)。

*.mdf 檔案包含：

  • 標頭資訊和空格分隔資料。

  • 激勵資料

  • 每個 S 參數量測的實數和虛數資料對

定義資料儲存

附註：雖然仍支援這些設定，但儲存資料檔案時不再需要這些設定。另存資料為對話方塊包含這些設定。

如何選取定義資料儲存

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

  2. 選取「偏好設定」對話方塊中的資料儲存...。

定義資料儲存對話方塊說明

附註：雖然仍支援這些設定，但儲存資料檔案時不再需要這些設定。另存資料為對話方塊包含這些設定。

下列設定在儀器預設和 VNA 關閉後仍會保留。

CitiFile、CSV 和 MDIF 內容

決定要儲存至 .cti 檔案的資料。

自動 - 儲存作用中的軌跡。如果已開啟修正，則會儲存其他軌跡。對於全 2 連接埠校準，將儲存 4 條軌跡；對於全 3 連接埠校準，將儲存 9 條軌跡，以此類推。

單一軌跡 - 儲存作用中的軌跡。

顯示的軌跡 - 儲存所有通道的所有顯示的軌跡。

Citifile 和 CSV 格式

自動 - 以對數幅度或線性幅度格式儲存資料（如果這些格式之一是目前選取的顯示格式）。如果格式為其他格式，則以實數/虛數格式儲存資料。

對數幅度/角度 (dB/deg)、線性幅度/角度 (unit/deg)、實數/虛數 - 選取輸出格式。

  • 所有對數幅度和線性幅度資料的虛部都以度儲存。

  • 始終不平滑化實數/虛數資料。

SnP 格式（.s1p、.s2p、.s3p、.s4p）

暸解有關 SnP 檔案的詳細資訊。

自動 - 以對數幅度或線性幅度格式儲存資料（如果這些格式之一是目前選取的格式）。如果格式為其他格式，則以實數/虛數格式儲存資料。

對數幅度、線性幅度、實數/虛數 - 選取輸出格式。 所有對數幅度和線性幅度資料的虛部都以度輸出。

在不使用滑鼠的情況下管理檔案

如何在不使用滑鼠的情況下管理檔案

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Save Recall] > Save Other（儲存其他）。

  2. 按一下 Manage Files...（管理檔案...），將顯示 D:\ 磁碟機資料夾對話方塊。

或

  1. 按下 [System] > Main（主功能表）。

  2. 按一下 Manage Files...（管理檔案...），將顯示 D:\ 磁碟機資料夾對話方塊。

此功能沒有程式設計命令可用

「管理檔案」對話方塊設計為透過前面板使用。它的功能與 Windows 檔案總管相同，但可在不使用滑鼠或鍵盤的情況下使用。

.

上次修改時間：

2016 年 01 月 06 日

第一版


列印量測

列印顯示的量測

使用分析儀可以將顯示的量測列印至印表機或檔案。印表機可以是網路印表機，也可以是本機印表機。

  • 連接印表機

  • 列印

    • 列印書面資料

    • 頁面設定

    • 列印至檔案

其他輸出資料主題

連接印表機

您可以將印表機連接到 VNA USB 連接埠或 LAN 接頭。

新增印表機

附註：如果您嘗試從 VNA 應用程式進行列印並且顯示新增印表機精靈時，請按一下取消，然後使用下列程序新增印表機。

  1. 從 VNA 應用程式，按下 [System] > Main（主功能表）>Minimize Application（應用程式縮到最小）。

  2. 在 Windows 工作列上，按一下裝置和印表機。

  3. 按兩下新增印表機。

  4. 按照新增印表機精靈中的指示操作。

如需詳細資訊，請參閱 Microsoft Windows 說明或印表機文件。

列印

螢幕上的量測資訊可以列印至任何連接到 VNA 的本機或網路印表機。下圖顯示列印時螢幕擷取影像的顯示方式範例。您可以透過頁面設定設定，自訂量測資訊的列印格式。

列印書面資料

如何列印書面資料

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > Print（列印）。

  2. 按一下Print（列印）。

此功能沒有可用的程式設計指令。

附註：如需「列印」對話方塊中選項的資訊，請參閱 Windows 說明。

頁面設定

使用「頁面設定」對話方塊可以靈活設定要列印之量測資料的外觀。

如何選取頁面設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > Print（列印）> Page Setup...（頁面設定...）。

或

  1. 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

  2. 按一下「偏好設定」對話方塊中的 Page Setup...（頁面設定...）。

頁面設定對話方塊說明

紙張、方向和邊界

這些設定在 VNA 關閉後不會保留。

如需這些設定的資訊，請參閱 Windows 說明。

Windows

下列 VNA 特定設定在 VNA 關閉後會保留：

最小垂直大小 - 調整以變更量測視窗填充的頁面大小。調整範圍是 40 至 100%。

每頁一個視窗 - 勾選此項可在每頁上列印一個視窗。清除此項將列印所有選取的視窗而沒有強制分頁符號。

僅作用中的視窗 - 勾選此項將僅列印作用中的視窗。清除此項會列印所有視窗。

儀器標誌 - 勾選此項可在頁首中列印 Keysight 標誌。

日期和時間 - 勾選此項可在頁首中新增目前的日期和時間。

全域合格/不合格 - 勾選此項可在頁首中新增全域合格/不合格狀態。

頁碼 - 勾選此項可在頁首中新增頁碼（第 1 頁，共 n 頁）。

通道設定表

列印 - 勾選此項可列印通道設定表格。

可以不再列印區段資料。

軌跡屬性表

列印 - 勾選此項可列印軌跡屬性表格。軌跡屬性是量測類型、修正係數開啟或關閉、平滑化、選項和標記詳細資料。軌跡屬性會在每個視窗中按軌跡 ID 號碼列出。

每個軌跡 ID 號碼包含多個項目，這取決於該軌跡所關聯的標記數目。標記詳細資料包括標記編號、位置和回應。如果軌跡上有多個標記，則只會顯示第一個標記的軌跡屬性。但是，第一個標記的軌跡屬性將套用至該軌跡上的所有其他標記。

選項欄可包含一個或多個選項。D 表示延遲、M 表示標記、G 表示閘控。選取的多個選項將顯示如下：DMG.

列印標記資料 - 勾選此項可列印所有標記資料。資料量取決於所建立的標記數量。

列印至檔案

分析儀會將螢幕擷取影像儲存成下列任意格式：

  • .png（可攜式網路圖形格式）

  • .bmp（點陣圖檔案）

  • .jpg（JPEG 檔案交換格式）

分析儀會將檔案自動儲存到目前的路徑。如果先前未定義路徑，分析儀將自動選取預設路徑 D:。

與 .prn 檔案相同的是，.bmp 檔案可匯入軟體應用程式，如 Microsoft Excel、Word 或 Paint，以顯示螢幕擷取影像。

如需詳細資訊，請參閱「儲存和重新叫用檔案」。

如何列印至檔案

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > Print（列印）> Print to File...（列印至檔案...）。

上次修改時間：

2016 年 01 月 06 日

第一版


Programming Guide

Two ways to find programming commands:

1. From a User Interface (Hardkey):

Trace

Channel

Display

Setup

Meas

Format

Scale

Math

Avg BW

Calibration

Marker

Search

Save Recall

Power

Frequency

Sweep

Trigger

System

 | GPIB / SCPI
2. | Command Tree
See Also | Example Programs
 | Learning about GPIB

See Also

  • Shut Down or Restart the VNA Remotely

  • LXI and VXI Compliance

  • Using Macros

  • Code Translator App.

  • Data Access Map


SCPI Command Tree

See Also

  • Example Programs

  • See list of all SCPI Errors.

  • See Calibrating the VNA Using SCPI

  • Synchronizing the VNA and Controller

  • IEEE- 488.2 Common Commands

  • Local Lockout

ABORt

Stops all sweeps

+ CALCulate Click to hide and show CALC / CALC:MEAS branches

CORRection | Electrical Delay and Phase Offset
CONVersion | Parameter conversion function
DATA | Sends and queries data.
Equation | Equation Editor
FILTer | Time domain gating
FORMat | Display format
FSIMulator | Balanced measurements and Fixturing
FUNCtion | Trace Statistics
GDELay | Group Delay Aperture setting
LIMit | Limit lines for pass / fail testing
MARKer | Marker settings
MATH | Math / Memory
MIXer | X-axis display for FCA measurements
OFFSet | Mag and Phase offset
PARameter | Create and delete measurements
RDATa? | Queries receiver data
SMOothing | Point-to-point smoothing
TRANsform | Time domain transform
X:VALues | Returns X-Axis values for trace
CONTrol | Interface control, ECal module state control, and Rear-panel connector control.
CSET | Work with a Cal Set without having to select it into that channel.
DISPlay | Display settings
FORMat | Format for data transfer
HCOPy | Hardcopy printing
INITiate | Continuous or manual triggering
LXI | LXI communications
MMEMory | Saves and recalls instrument states
OUTPut | Turns RF power ON and OFF

+ SENSe Click to hide and show SENSe branches

AVErage | Sweep Averaging
BANDwidth | IF Bandwidth
CLASs | Returns measurement class name
CORRection | Calibration and other correction settings
COUPle | Chopped or Alternate sweep
FOM | Frequency Offset (opt 009)
FREQuency | Frequency sweep settings
MIXer | FCA measurements (opts 082 and 083)
MULTiplexer | Controls external test sets.
ROSCillator | Returns the source of the reference oscillator.
SEGMent | Segment sweep settings.
SWEep | Sweep types
VOLTage | DC Voltage Range
X:VALues | X-axis values for channel

SOURce | Source power to the DUT
STATus | Reads the VNA status registers
SYSTem | Misc VNA capabilities
TRIGger | Trigger measurements

Last Modified:

6-Jan-2016

First Release


Common Commands SCPI

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Keysight Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "+1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet with one exception: Syst:Preset does NOT reset Calc:FORMAT to ASCII. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status.

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization

Last Modified:

5-Mar-2015

First Release


Abort SCPI

About Triggering

Abort Command

ABORt

Applicable Models: E5080A, M9485A

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep. Learn about Synchronizing the VNA and Controller
Examples | ABOR abort
Query Syntax | Not applicable
Default | Not applicable

Last modified:

6-Jan-2016

First Release


Conversion

Calculate:Conversion

CALCulate:MEASure:CONVersion:

FUNCtion

CALCulate<cnum>:MEASure<nmum>:CONVersion:FUNCtion <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or gets the parameter after conversion using the parameter conversion function, for the active trace of selected channel.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Select from the following of parameter after conversion:

  • "OFF"

  • "ZREFlection" - Specifies the equivalent impedance in reflection measurement.

  • "ZTRansmit" - Specifies the equivalent impedance (series) in transmission measurement.

  • "ZTSHunt" - Specifies the equivalent impedance (shunt) in transmission measurement.

  • "YREFlection" - Specifies the equivalent admittance in reflection measurement.

  • "YTRansmit" - Specifies the equivalent admittance (series) in transmission measurement.

  • "YTSHunt" - Specifies the equivalent admittance (shunt) in transmission measurement.

  • "INVersion" - Specifies the inverse S-parameter (1/S).

  • "CONJugation" - Specifies the conjugate.

Examples

CALC:MEAS1:CONV:FUNC ZTSH
calculate2:measure1:conversion:function conjugation

Query Syntax

CALCulate<cnum>:MEASure<mnum>:CONVersion:FUNCtion?

Return Type

Character

Default

"OFF"

Last modified:

6-Jan-2016

First Release


Correction SCPI

Calculate:Correction Commands

Controls error correction functions.

CALCulate:MEASure:CORRection:

EDELay

| DISTance

| MEDium

| TIME

| UNIT

| WGCutoff

[STATe]

| INDicator?

TYPE

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Calibrating the VNA Using SCPI

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:DISTance <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the electrical delay in physical length (distance) for the selected measurement. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Electrical delay in distance. First Specify units using CALC:MCORR:EDEL:UNIT Use SENS:CORR:RVEL:COAX <num> to set Velocity factor. This parameter supports MIN and MAX as arguments. Learn more.
Examples | CALC:MEAS:CORR:EDEL:DIST 5 calculate2:measure2:correction:distance .003
Query Syntax | CALCulate<cnum>:MEASure<mnum>CORRection:EDELay:DISTance?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:MEDium <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the media used when calculating the electrical delay.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: COAX for coaxial medium, WAVEguide for waveguide medium.
Examples | CALC:MEAS:CORR:EDEL:MED COAX calculate3:measure2:correction:edelay:medium waveguide
Query Syntax | CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:MEDium?
Return Type | Character
Default | COAX

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay[:TIME] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the electrical delay for the selected measurement. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor. This parameter supports MIN and MAX as arguments. Learn more.
Examples | CALC:MEAS:CORR:EDEL:TIME 1NS calculate2:measure2:correction:edelay:time 0.5e-12
Query Syntax | CALCulate<cnum>:MEASure<mnum>CORRection:EDELay[:TIME]?
Return Type | Numeric
Default | 0 seconds

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:UNIT <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the units for specifying electrical delay in physical length (distance).

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<char>

Units for delay in distance. Choose from:

  • METer

  • FEET

  • INCH

Examples

CALC:MEAS:CORR:EDEL:UNIT MET

calculate3:measure2:correction:edelay:unit inch

Query Syntax

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:UNIT?

Return Type

Character

Default

METer

CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:WGCutoff <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the waveguide cutoff frequency used when the electrical delay media is set to WAVEguide. (See CALCulate:CORRection:EDELay:MEDium <char>.)
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Waveguide cutoff frequency used with the electrical delay calculation. This parameter supports MIN and MAX as arguments. Learn more.
Examples | CALC:MEAS:CORR:EDEL:WGC 18.067 GHz calculate3:measure2:correction:edelay:wgcutoff 14.047 ghz
Query Syntax | CALCulate<cnum>:MEASure<mnum>:CORRection:EDELay:WGCutoff?
Return Type | Numeric
Default | 45 MHz

CALCulate<cnum>:MEASure<mnum>:CORRection[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns error correction ON or OFF for the selected measurement on the specified channel. To turn error correction ON or OFF for a channel, use SENS:CORR:STATe . See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | Correction state. Choose from: OFF or 0 - Correction OFF. ON or 1 - Correction ON.
Examples | CALC:MEAS:CORR ON calculate:measure:correction:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:CORRection:STATe?
Return Type | Boolean
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:CORRection[:STATe]:INDicator?

Applicable Models: E5080A, M9485A

(Read-only) Returns the error correction state for the selected measurement on the specified channel. To turn error correction ON or OFF for a channel, use SENS:CORR:STATe. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:CORR:IND? calculate2:measure2:correction:state:indicator?
Return Type | Character NONE - No error correction. MAST (Master) - Original error correction terms. INT - Error terms are interpolated. Learn more. DELT - Delta Match calibration terms. Learn more. INV - Error terms are not valid.
Default | NONE

CALCulate<cnum>:MEASure<mnum>:CORRection:TYPE <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Cal Type for the selected measurement on the specified channel. This is used when a Cal Set is applied. Learn more about applying Cal Types.

  • Use SENS:CORR:TYPE:CAT? to list the Cal Types in the VNA.

  • Use SENS:CORR:CSET:TYPE:CAT? to list the Cal Types contained in the active Cal Set for the channel.

  • Use SENS:CORR:COLL:METH to set the Cal type to perform a new Unguided calibration,

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<string>

(String) Cal type. Case sensitive. Use one of the following:

For Full Calibrations (NO Power Cal included):

This command does not distinguish between TRL and SOLT. The same number of error terms is applied for both Cal Types.

"Full <n> Port(x,y,z...)"

where

<n> = the number of ports to calibrate

x,y,z = the port numbers to calibrate

For example:

"Full 4 Port(1,2,3,4)"

For Full Calibrations (including Power Cal):

After the Full <n> port, include the string, "with power"

For example:

"Full 4 Port with power(1,2,3,4)"

For Response Calibrations:

"Response(param)" OR

"ResponseAndIsolation(param)"

Where param =

  • S-parameter. For example"

    • "Response(S21)"

    • "ResponseAndIsolation(A/R)"

  • Single or ratioed receivers using either logical receiver notation or physical receiver notation. For example:

    • "Response(A)"

    • "ResponseAndIsolation(a3/b4)"

For Enhanced Response Calibrations:

"EnhancedResp(sourcePort, recPort)

Where:

  • sourcePort = stimulus port number

  • recPort = receiver port number

For FCA Calibrations:

Learn more about this setting.

  • "SMC_2P" (Response + Input + Output) All four sweeps required. Most accurate.

  • "SMCRsp+IN" No Output match. All four sweeps required.

  • "SMCRsp+OUT" No Output match. All four sweeps required.

  • "SMCRsp" No Input or Output match. Saves two sweeps.

For VMC, multiple Cal types are not available.

For Gain Compression Cal

where r = receive port; s = source port

  • "GCA 2P (r,s)” - full 2-port cal

  • “GCA Enh Resp (r,s)” - Enhanced Response Cal

Examples

CALC:MEAS:CORR:TYPE "Scalar Mixer Cal"

Query Syntax

CALCulate<cnum>:MEASure<mnum>:CORRection:TYPE?

Return Type

String

Default

Not Applicable

Last modified:

6-Jan-2016

First Release


Data SCPI

Calculate:Data Commands

Controls writing and reading VNA measurement data.

CALCulate:DATA:

| MFData

| MSData

CALCulate:MEASure:DATA:

| FDATa

| SDATa

| FMEMory

| SMEMory

| SNP?

| PORTs?

| SAVE

CALCulate:MEASure:

| RDATa

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Data Access Map

  • Synchronizing the Analyzer and Controller

  • To read receiver data, use CALC:RDATA?

  • To read error terms, use SENS:CORR:CSET:DATA

  • To read SnP measurement data, use CALC:DATA:SNP?

  • SCPI Command Tree

CALCulate<cnum>:DATA<data>:MFData <string>

Applicable Models: E5080A, M9485A

(Read-only) Gets the formatted data array of multiple traces (traces-n, m, .... to l) of the selected channel.

This command is allows to get several trace data with one command, while CALC:MEAS:DATA:FDAT returns only one trace with one command.

Note: If valid data is not calculated because of the invalid measurement, “1.#QNB” is read out.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<data>

Indicates the array data (formatted data array) of NOP (number of measurement points)×2×(number of specified traces). Where n is an integer between 1 and NOP.

  • Data (n×2-2) : Data (primary value) at the n-th measurement point.

  • Data (n×2-1) : Data (secondary value) at the n-th measurement point. Always 0 when the data format is not the Smith chart format or the polar format.

The output trace data is listed according to the order of the specified trace number.

The index of the array starts from 0.

Note: If there is no array data of NOP (number of measurement point)×2 when setting a formatted data array, an error occurs when executed and the object is ignored.

<string>

Trace number. "n, m, l, ..." where n, m, l are 1 to the maximum trace number.

Note: Use comma for separator of trace number.

Examples

CALC:DATA:MFD

Return Type

Not Applicable

Default

Not Applicable

CALCulate<cnum>:DATA<data>:MSData <string>

Applicable Models: E5080A, M9485A

(Read-only) Gets the corrected data array of multiple traces (traces-n, m, .... to l) of the selected channel.

This command is allows to get several corrected data with one command, while CALC:MEAS:DATA:SDAT returns only one corrected data with one command.

Note: If valid data is not calculated because of the invalid measurement, “1.#QNB” is read out.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<data>

Indicates the array data (corrected data array) of NOP (number of measurement points)×2×(number of specified traces). Where n is an integer between 1 and NOP.

  • Data(n*2-2) : Real part of the data (complex number) at the n-th measurement point.

  • Data(n*2-1) : Imaginary part of the data (complex number) at the n-th measurement point.

The output trace data is listed according to the order of the specified trace number.

The index of the array starts from 0.

Note: If there is no array data of NOP (number of measurement point)×2 when setting a corrected data array, an error occurs when executed and the object is ignored.

<string>

Trace number. "n, m, l, ..." where n, m, l are 1 to the maximum trace number.

Note: Use comma for separator of trace number.

Examples

CALC:DATA:MSD

Return Type

Not Applicable

Default

Not Applicable

(Write) CALCulate<cnum>:MEASure<mnum>:DATA:<char>,<data>

(Read) CALCulate<cnum>:MEASure<mnum>:DATA:<char>?

Reads or writes Measurement data, Memory data or Normalization Divisor data from the Data Access Map location.

  • For Measurement data, use FDATA or SDATA

  • For Memory data, use FMEM or SMEM. When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • For Normalization Divisor (Receiver Power Cal error term) data, use SDIV.

  • Use FORMat:DATA to change the data type (<REAL,32>, <REAL,64> or <ASCii,0>).

  • Use FORMat:BORDer to change the byte order. Use “NORMal” when transferring a binary block from LabView or VEE. For other programming languages, you may need to "SWAP" the byte order.

Equation Editor Notes:

  • When equation editor is active on a trace in a standard S-parameter channel, Calc:Data returns the data from the parameter on the trace that was measured last. For example, for the equation "S22 + S33 + S11”, then S33 is the last measured parameter because it uses source port 3.

  • In applications, if equation editor is active and the original parameter for the trace is not requested anywhere in the channel, then zeros are returned. If the original parameter is being measured within the channel, then data for the original parameter is returned.

  • In general, if an equation contains no measurement parameters, then data for the original parameter is returned.

Note: The Calc:Data SCORR command to read/write error terms is Superseded with SENS:CORR:CSET:DATA. SCORR commands do NOT accommodate greater than 12 error terms.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<char>

FDATA

Formatted measurement data to or from Data Access Map location. Display (access point 2).

  • Corrected data is returned when correction is ON.

  • Uncorrected data is returned when correction is OFF.

  • Returns TWO numbers per data point for Polar and Smith Chart format.

  • Returns one number per data point for all other formats.

  • Format of the read data is same as the displayed format.

SDATA

Complex measurement data.

Writes data to Data Access Map location. Raw Measurement (access point 0).

  • When writing corrected data, and correction is ON, it will be corrected again, resulting in meaningless data.

Reads data from Apply Error Terms (access point 1).

  • Returns TWO numbers per data point.

  • Corrected data is returned when correction is ON.

  • Uncorrected data is returned when correction is OFF.

FMEM

Formatted memory data to or from Data Access Map location. Memory result (access point 4).

  • Returns TWO numbers per data point for Polar and Smith Chart format.

  • Returns one number per data point for all other formats.

  • Format of the read data is same as the displayed format.

  • Returned data reflects the correction level (ON|OFF) when the data was stored into memory.

SMEM

Complex measurement data to or from Data Access Map location Memory (access point 3).

  • Returns TWO numbers per data point.

  • Returned data reflects the correction level (ON|OFF) when the data was stored into memory.

  • Returned data reflects the correction level (ON|OFF) when the data was stored into memory.

Examples | CALC:MEAS:DATA:FDATA Data(x) calculate2:measure2:data:sdata data(r,i) See another example using this command.
Return Type | Block data
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:DATA:SNP:PORTs? <"x,y,z".>

(Read-only) Reads SNP data from the selected measurement for the specified ports. Learn more about SNP data.

This command is valid ONLY with standard S-parameter measurements.

Notes:

  • This command returns SNP data without header information, and in columns, not in rows as .SnP files. This means that the data returned from this command sends all frequency data, then all Sx1 magnitude or real data, then all Sx1 phase or imaginary data, and so forth.

  • To avoid frequency rounding errors, specify FORM:DATA <Real,64> or <ASCii, 0>

  • Data that is not available is zero-filled.

  • For sweeps with a large number of data points, always follow this command with *OPC? Learn more.

  • The E5080A can not export a SNP file for multi-port over 4 ports.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<"x,y,z">

Comma or space delimited port numbers for which data is requested, enclosed in quotes.

SNP data can be output using several data formatting options. See MMEM:STOR:TRAC:FORM:SNP.

Examples

CALC:MEAS:DATA:SNP:PORTs? "1,2,4,5,7" 'read data for these ports

Return Type

Depends on FORM:DATA command

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:DATA:SNP:PORTs:SAVE <"x,y,z">,<filename>

Applicable Models: E5080A, M9485A

(Write-only) Saves SNP data from the selected measurement for the specified ports. Learn more about SNP data.

  • The Normal vs Mixed Mode selection is NOT used as it is in the Choose Ports dialog. Instead, data is returned as it is displayed on the trace. If the selected measurement is Mixed Mode (balanced), then balanced data is returned. If the selected measurement is an S-parameter, then S-parameter data is returned.

  • This command is valid ONLY with the Standard measurement class (NOT applications).

  • Data that is not available is zero-filled.

  • For sweeps with a large number of data points, always follow this command with *OPC? Learn more.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<"x,y,z">

String - Comma or space delimited port numbers for which data is requested, enclosed in quotes.

<filename>

String - Path, filename, and suffix of location to store the SNP data. The suffix is not checked for accuracy. If saving 2 ports, specify "filename.s2p"; If saving 4 ports, specify "filename.s4p.", and so forth.

SNP data can be output using several data formatting options. See MMEM:STOR:TRAC:FORM:SNP.

Examples

CALC:MEAS:DATA:SNP:PORTs:Save '1,2,4','D:\MyData.s3p';*OPC?

Return Type

Depends on FORM:DATA command

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:RDATa? <char>

Applicable Models: E5080A, M9485A

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA? Critical Note: CALCulate commands act on the selected measurement. Learn more.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from any physical receiver in the VNA. For example: "A" Also, REF - returns data for either R1 or R2 data depending on the source port of the selected measurement. See the block diagram showing the receivers in VNA. Note: Logical receiver notation is NOT allowed with this command. Learn more.
Example | INITiate:CONTinuous OFF INITiate:IMMediate;*wai CALC:MEAS:RDATA? A CALCulate:RDATA? REF
Return Type | Depends on FORM:DATA command - Two numbers per data point
Default | Not Applicable

Notes:

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Learn about Unratioed Measurements

Last modified:

6-Jan-2016

First Release


Filter SCPI

Calculate:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start/stop) or (center/span) commands.

CALCulate:MEASure:FILTer:

COUPle

TIME

| CENTer

| SHAPe

| SPAN

| STATe

| STARt

| STOP

| [TYPE]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Gating

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:COUPle:PARameters <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the time domain gating parameters to be coupled. The settings for those parameters will be copied from the selected measurement to all other measurements on the channel.

  • To enable Trace Coupling, use SENS:COUP:PAR

  • To specify Transform parameters to couple, use CALC:TRAN:COUP:PAR

Learn more about Time Domain Trace Coupling

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

(Numeric) Parameters to couple. To specify more than one parameter, add the numbers.

1 - Gating Stimulus (Start, Stop, Center, and Span TIME settings).

2 - Gating State (ON | OFF).

4 - Gating Shape (Minimum, Normal, Wide and Maximum).

8 - Gating Type (Bandpass and Notch)

Examples

'To couple all parameters:

CALC:MEAS:FILT:COUP:PAR 15

'To couple Stimulus and Type:
calculate2:measure2:filter:gate:couple:parameters 9

Query Syntax

CALCulate<cnum>:MEASure<mnum>:FILTer:GATE:COUPle:PARameters?

Return Type

Numeric

Default

13 (All parameters except 2 - Gating State)

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the gate filter center time. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:FILT:GATE:TIME:CENT -5 ns calculate2:measure2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:SHAPe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the gating filter shape when in time domain. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE NORMal MINimum - the narrowest gate filter available
Examples | CALC:MEAS:FILT:GATE:TIME:SHAP MAX calculate2:measure2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Default | NORMal

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the gate filter span time.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

Time span in seconds; Choose any number between:
0 and 2* [(number of points-1) / frequency span]

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

CALC:MEAS:FILT:GATE:TIME:SPAN 5 ns
calculate2:measure2:filter:time:span maximum

Query Syntax

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:SPAN?

Return Type

Numeric

Default

20 ns

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns gating state ON or OFF. See Critical Note Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON or 1 - turns gating ON. OFF or 0 - turns gating OFF.
Examples | CALC:MEAS:FILT:TIME:STAT ON calculate2:measure2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the gate filter start time. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:FILT:TIME:STAR 1e-8 calculate2:measure2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Numeric
Default | 10 ns

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the gate filter stop time. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:FILT:TIME:STOP -1 ns calculate2:measure2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Numeric
Default | 10 ns

CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of gate filter used. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:MEAS:FILT:TIME BPAS calculate2:measure2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Default | BPAS

Last modified:

6-Jan-2016

First Release


Format SCPI

Calculate:Format Commands

Controls format functions.

CALCulate:MEASure:FORMat:

UNIT

See Also

  • Example using this command.

  • Learn About Data Format

  • Synchronizing the VNA and Controller

CALCulate<cnum>:MEASure<mnum>:FORMat <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the display format for the measurement.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude PHASe UPHase - Unwrapped phase IMAGinary - Imaginary part (Im) REAL - Real part (Re) POLar - (Re, Im) SMITh SADMittance - Smith Admittance SWR - Standing Wave Ratio GDELay - Group Delay
Examples | CALC:MEAS:FORM MLIN calculate2:measure2:format polar
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FORMat?
Return Type | Character
Default | MLINear

CALCulate<cnum>:MEASure<mnum>:FORMat:UNIT <dataFormat>, <units>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the units for the specified data format. Measurements with display formats other than those specified are not affected.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<dataFormat>

Choose MLOG.

<units>

For unratioed measurements, choose from:

  • DBM Units are displayed in dBm. 0 dBm = 0.001 watt

  • DBMV Units are displayed in dBmV. 0 dBmV = 0.001 volt

Examples

CALC:MEAS:FORM MLOG, DBM
calculate2:measure2:format mlog, dbmv

Query Syntax

CALCulate<cnum>:MEASure<mnum>:FORMat:UNIT?

Return Type

Character

Default

DBM

Last modified:

6-Jan-2016

First Release


FSimulator

Calculate:FSimulator Commands

Specifies settings and fixturing for Balanced Measurements.

CALCulate:FSIMulator

BALun More commands

EMBed More commands

SENDed More commands

SNP:EXTRapolate

STATe

CALCulate:

DTOPology

Click a Red keyword to view the command details.

See Also

  • Example Programs

  • SCPI Command Tree

CALCulate<cnum>:FSIMulator:SNP:EXTRapolate <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON and OFF SNP file extrapolation for both 2-port and 4-port embedding/de-embedding. Learn more. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns Extrapolation ON. OFF or 0 - Turns Extrapolation OFF.
Examples | CALC:FSIM:SNP:EXTR 1 calculate2:fsimulator:snp:extrapolate 0
Query Syntax | CALCulate<cnum>:FSIMulator:SNP:EXTRapolate?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns all three fixturing functions (de-embedding, port matching, impedance conversion) ON or OFF for all ports on the specified channel. Does not affect port extensions. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns Fixturing ON. OFF or 0 - Turns Fixturing OFF.
Examples | CALC:FSIM:STAT 1 calculate2:fsimulator:state 0
Query Syntax | CALCulate<cnum>:FSIMulator:STATe?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:DTOPology <device>, <topology>

Applicable Models: E5080A, M9485A

(Write-only) Defines the device type and the topology for a balanced measurement. This command will replace the following commands: CALC:FSIM:BAL:TOP:SBAL[:PPOR] CALC:FSIM:BAL:TOP:SSB[:PPOR] CALC:FSIM:BAL:TOP:BBAL[:PPOR] CALC:FSIM:BAL:TOP:BALS[:PPOR]
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<device> | (String) Device type for the balanced measurement. ‘B’ means the Balanced port; ‘S’ means the Single-ended port. Choose from: B – 1 port balanced device (2 ports) BB – Balanced - Balanced device (4 ports) BS – Balanced - Single-ended device (3 ports) SB – Single-ended - Balanced device (3 ports) SSB – Single-ended - Single-ended - Balanced device (4 ports)
<topology> | (Int array) Physical port numbers mapped to the logical ports, separated by ‘,’. ‘B’ (Balanced) requires 2 physical port numbers: <nPos>, <nNeg>. ‘S’ (Single-ended) requires 1 physical port number.
Examples | CALC:DTOP "SB", 2, 1, 4 calculate:dtopology "SB", 2, 1, 4
Query Syntax | CALCulate<cnum>:DTOPology <device>, <topology>?
Return Type | Not Applicable
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


Function SCPI

Calculate:Function Commands

CALCulate:MEASure:FUNCtion:

DATA

DOMain

| USER

| [RANGe]

| STARt

| STOP

EXECute

STATistics

TYPE

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Trace Statistics

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:MEASure<mnum>:FUNCtion:DATA?

Applicable Models: E5080A, M9485A

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Return Type | Depends on FORM:DATA
Examples | CALC:MEAS:FUNC:DATA? calculate2:measure2:function:data?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER[:RANGe] <range>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the range used to calculate trace statistics. Each channel has 16 user ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<range> | Range number. Choose from: 0 to 16 0 is Full Span of the current x-axis range 1 to 16 are user-specified ranges
Examples | CALC:MEAS:FUNC:DOM:USER 4 calculate2:measure2:function:domain:user:range 0
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER[:RANGe]?
Return Type | Numeric
Default | Full Span

CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER To set the stop of the range, use CALC:FUNC:DOM:USER:STOP. See Critical Note Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 16
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:MEAS:FUNC:DOM:USER:STAR 1,1e9 calculate2:measure2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Numeric
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop value of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER. To set the start of the range, use CALC:FUNC:DOM:USER:START See Critical Note Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 16
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:MEAS:FUNC:DOM:USER:STOP 4,5e9 calculate2:measure2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Numeric
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:MEASure<mnum>:FUNCtion:EXECute

Applicable Models: E5080A, M9485A

(Write-only) For the active trace of specified channel, executes the statistical analysis specified by the CALC:FUNC:TYPE command. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:FUNC:EXEC calculate2:measure2:function:execute
Query Syntax | Not Applicable
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:FUNCtion:STATistics[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Displays and hides the trace statistics (peak-to-peak, mean, standard deviation) on the screen.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<bool>

ON or 1 - Displays trace statistics

OFF or 0 - Hides trace statistics

Examples

CALC:MEAS:FUNC:STAT ON
calculate2:measure2:function:statistics:state off

Query Syntax

CALCulate<cnum>:MEASure<mnum>:FUNCtion:STATistics[:STATe]?

Return Type

Boolean

Default

OFF

CALCulate<cnum>:MEASure<mnum>:FUNCtion:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Note: this command affects only the selected measurement on the specified channel. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace MIN - lowest data point on the trace MAX - highest data point on the trace
Examples | CALC:MEAS:FUNC:TYPE PTP calculate2:measure2:function:type stdev
Query Syntax | CALCulate<cnum>:MEASure<mnum>:FUNCtion:TYPE?
Return Type | Character
Default | PTPeak

Last modified:

6-Jan-2016

First Release


GCData

Calc:GCData Commands

Reads Gain Compression data from the current Gain Compression acquisition.

CALCulate:GCData:

DATA

IMAG

ITERations

REAL

Click on a Red keyword to view the command details.

Other Gain Compression commands

The calibration commands listed in this topic are supplemental to the Guided Cal commands.

  • CALC:CUSTom:DEFine - creates a gain compression measurement.

  • SENS:GCSetup - Most Gain Compression settings.

  • CALC:GCMeas:ANAL - Gain Compression Analysis settings

  • Gain compression data can also be saved to a *.csv file. Learn how.

See Also

  • Example Programs

  • Learn about Gain Compression Application

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<ch>:GCData:DATA? <param>

Applicable Models: M9485A

(Read-Only) Returns measurement data at all frequency and power data points for GCA SMART sweeps and 2D sweeps.

  • When using SMART sweep, ALL data is returned including ALL background iteration sweeps. Use CALC:GCD:ITER to determine the number of iteration sweeps. The number of data points that are returned is always going to be number of frequency points times the number of iteration sweeps.

  • When using 2D sweeps, ALL data is returned. The number of data points returned / freq may vary. Learn more.

Use Calc:Data? to return just the displayed data results (not the background sweeps).

A compression parameter must be present. Learn more.

The format of the data is the same as the format of the measurement that you select using Calc:Par:Select. If the measurement is scalar, than one number is returned per sweep per data point. If complex (such as Smith Chart format) than both real and imaginary numbers are returned.

If correction is on, corrected data are returned. Otherwise, raw data are returned.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<param>

(String) Parameter to read. NOT Case-sensitive. The specified parameter need NOT be displayed or selected. However, a compression parameter must be present. Learn more.

Choose from:

  • "pin" - (CompIn21) Input power at the compression point.

  • "pout" - (CompOut21) Output power at the compression point.

  • "gain" - (CompGain21) Device gain (S21) at the compression point.

  • "inputmatch" - (CompS11) Input match at the compression point.

  • "DeltaGain" - (DeltaGain21) Measured Gain (watts) / Ref Gain (watts). Learn more.

  • "AI1" and "AI2" - ADC measurements at the specified compression level. Learn more.

Learn more about GCA parameters.

Examples

data = CALC:GCD:DATA? "pin"

data = calculate:gcdata:data? "pout"

Return Type

Array of data

Default

Not Applicable

CALCulate<ch>:GCData:IMAG? <char>, <dpoint>, <param>

Applicable Models: M9485A

(Read-Only) For a specified data point, returns the imaginary part of the specified Gain Compression data. If correction is on, corrected data are returned. Otherwise, raw data are returned. Can be used with Smart and 2D sweeps.

  • For SMART sweep, the number of data points that are returned is always going to be the number of iteration sweeps. Use CALC:GCD:ITER to determine the number of iteration sweeps.

  • For 2D sweeps, the number of data points returned / freq may vary. Learn more.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

  • FREQuency - for the specified frequency data point, returns all of the measured data for each power stimulus.

  • POWer - for the specified power data point, returns all of the measured data for each frequency stimulus.

<dPoint>

Data point (FREQ or POWer) for which data is returned.

<param>

(String) Parameter to read. NOT Case-sensitive. The specified parameter need NOT be displayed. However, a compression parameter must be present. Learn more.

  • "pin" - (CompIn21) Input power at the compression point.

  • "pout" - (CompOut21) Output power at the compression point.

  • "gain" - (CompGain21) Device gain (S21) at the compression point.

  • "inputmatch" - (CompS11) Input match at the compression point.

  • "DeltaGain" - (DeltaGain21) Measured Gain (watts) / Ref Gain (watts). Learn more.

  • "AI1" and "AI2" - ADC measurements at the specified compression level. Learn more.

Examples

For the fifth frequency data point, returns 'Power Output' imaginary (phase) data from all power stimulus values.

For SmartSweep, if there are 30 power sweep points, 30 values are returned.

For 2D sweeps, 30 or 31 power sweep points may be returned. Learn more.

data = CALC:GCD:IMAG? FREQ,5,"pout"

Return Type

Array of data

Default

Not Applicable

CALCulate<cnum>:GCData:ITERations?

Applicable Models: M9485A

(Read-only) In a SMART sweep, returns the max number of iterations that it took for ALL frequencies to converge. Use this number to determine the size of the block data that is returned from Gain Compression SMART sweep data queries. For a 2D sweep, returns the number of power points.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | data = CALC:GCD:ITER?
Return Type | Numeric
Default | Not Applicable

CALCulate<ch>:GCData:REAL? <char>, <dpoint>, <param>

Applicable Models: M9485A

(Read-Only) For a specified data point, returns the real part of the Gain Compression data. If correction is on, corrected data are returned. Otherwise, raw data are returned. Can be used with Smart and 2D sweeps.

  • For SMART sweep, the number of data points that are returned is always going to be the number of iteration sweeps. Use CALC:GCD:ITER to determine the number of iteration sweeps.

  • For 2D sweeps, the number of data points returned / freq may vary. Learn more.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

  • FREQuency - for the specified frequency data point, returns all of the measured data for each power stimulus.

  • POWer - for the specified power data point, returns all of the measured data for each frequency stimulus.

<dPoint>

Data point (FREQ or POWer) for which data is returned.

<param>

(String) Parameter to read. NOT Case-sensitive. The specified parameter need NOT be displayed. However, a compression parameter must be present. Learn more.

  • "pin" - (CompIn21) Input power at the compression point.

  • "pout" - (CompOut21) Output power at the compression point.

  • "gain" - (CompGain21) Device gain (S21) at the compression point.

  • "inputmatch" - (CompS11) Input match at the compression point.

  • "DeltaGain" - (DeltaGain21) Measured Gain (watts) / Ref Gain (watts). Learn more.

  • "AI1" and "AI2" - ADC measurements at the specified compression level. Learn more.

Examples

For the fifth frequency data point, returns 'Power Output' real data from all power stimulus values.

For SmartSweep, if there are 30 power sweep points, 30 values are returned.

For 2D sweeps, 30 or 31 power sweep points may be returned. Learn more.

data = CALC:GCD:REAL? FREQ,5,"pout"

Return Type

Array of data

Default

Not Applicable

Last modified:

6-Jan-2016

First Release


GCMeas

Gain Compression Analysis Commands

Sets and reads Gain Compression Analysis controls.

CALCulate:GCMeas:ANALysis

CWFRequency

ENABle

ISDisfrequency

XAXis

Click on a Red keyword to view the command details.

Other Gain Compression commands

The calibration commands listed in this topic are supplemental to the Guided Cal commands.

  • CALC:CUSTom:DEFine - creates a gain compression measurement.

  • SENS:GCSetup - Most Gain Compression settings.

  • GC:DATA - Gain Compression data commands

  • Gain compression data can also be saved to a *.csv file. Learn how.

See Also

  • Example Programs

  • Learn about Compression Analysis

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:GCMeas:ANALysis:ENABle <bool>

Applicable Models: M9485A

(Read-Write) Enables and disables a compression analysis trace.
Parameters |
<cnum> | Channel number of the GCA measurement. There must be a selected measurement on that channel using Calc:Par:Sel. If unspecified, <cnum> is set to 1.
<bool> | ON (or 1) - Enable compression analysis. OFF (or 0) - Disable compression analysis.
Examples | CALC:GCM:ANAL:ENAB ON calculate2:gcmeas:analysis:enable off
Query Syntax | CALCulate<cnum>:GCMeas:ANALysis:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

CALCulate<cnum>:GCMeas:ANALysis:CWFRequency <num>

Applicable Models: M9485A

(Read-Write) Set and return the CW frequency for a compression analysis trace.
Parameters |
<cnum> | Channel number of the GCA measurement. There must be a selected measurement on that channel using Calc:Par:Sel. If unspecified, <cnum> is set to 1.
<num> | CW frequency in Hz. Choose a frequency within the range of the gain compression channel.
Examples | CALC:GCM:ANAL:CWFR 1e9 calculate2:gcmeas:analysis:cwfrequency 1e10
Query Syntax | CALCulate<cnum>:GCMeas:ANALysis:CWFRequency?
Return Type | Numeric
Default | Not Applicable

CALCulate<cnum>:GCMeas:ANALysis:ISDisfrequency <bool>

Applicable Models: M9485A

(Read-Write) Sets and returns whether the CW frequency for the compression analysis trace can be set to only the discrete frequencies or provides interpolation.
Parameters |
<cnum> | Channel number of the GCA measurement. There must be a selected measurement on that channel using Calc:Par:Sel. If unspecified, <cnum> is set to 1.
<bool> | ON (or 1) - Discrete data points only. OFF (or 0) - Interpolated data points.
Examples | CALC:GCM:ANAL:ISD ON calculate2:gcmeas:analysis:isdisfrequency off
Query Syntax | CALCulate<cnum>:GCMeas:ANALysis:ISDisfrequency?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

CALCulate<cnum>:GCMeas:ANALysis:XAXis <char>

Applicable Models: M9485A

(Read-Write) Sets and returns the type of data to display on the x-axis of a compression analysis trace.

Parameters

<cnum>

Channel number of the GCA measurement. There must be a selected measurement on that channel using Calc:Par:Sel. If unspecified, <cnum> is set to 1.

<bool>

Data to display on X-axis. Choose from:

  • PIN - Input power to the DUT.

  • PSOurce - power from the source.

Examples

CALC:GCM:ANAL:XAX PIN
calculate2:gcmeas:analysis:xaxis psource

Query Syntax

CALCulate<cnum>:GCMeas:ANALysis:XAXis?

Return Type

Character

Default

PIN

Last modified:

6-Jan-2016

First Release


GroupDelay

Group Delay Aperture Commands

Controls the Aperture setting used to make Group Delay measurements.

CALCulate:MEASure:GDELay

FREQuency

PERCent

POINts

Click on a Red keyword to view the command details.

See Also

  • Learn about Group Delay Aperture

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:GDELay:FREQuency <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets group delay aperture using a fixed frequency range. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<value> | Frequency range (in Hz) to use for the aperture setting. Choose between the equivalent of two data points and the channel frequency span.
Examples | CALC:GDEL:FREQ 1E6
Query Syntax | CALCulate<cnum>:MEASure<mnum>:GDELay:FREQuency?
Return Type | Numeric
Default | Frequency range that equates to 11 points. This can be changed to two points with a preference setting.

CALCulate<cnum>:MEASure<mnum>:GDELay:PERCent <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets group delay aperture using a percent of the channel frequency span. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<value> | Percent of frequency span to use for the aperture setting. Choose between the equivalent of two data points and 100 percent of the channel frequency span.
Examples | 'set to 25 percent of the channel frequency span CALC:GDEL:PERC 25
Query Syntax | CALCulate<cnum>:MEASure<mnum>:GDELay:PERCent?
Return Type | Numeric
Default | Percent of frequency span that equates to 11 points. This can be changed to two points with a preference setting.

CALCulate<cnum>:MEASure<mnum>:GDELay:POINts <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets group delay aperture using a fixed number of data points. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<value> | Number of data points to use for the aperture setting. Choose between two points and the number of points in the channel.
Examples | 'set to 25 data points CALC:MEAS:GDEL:POIN 25
Query Syntax | CALCulate<cnum>:MEASure<mnum>:GDELay:POINts?
Return Type | Numeric
Default | 11 points. This can be changed to two points with a preference setting.

Last modified:

6-Jan-2016

First Release


Limit SCPI

Calc:Limit Commands

Controls the limit segments used for Pass/Fail testing.

CALCulate:MEASure:LIMit:

DATA

| DELete

DISPlay

| [STATe]

FAIL?

SEGMent

| AMPLitude

| STARt

| STOP

| STIMulus

| STARt

| STOP

| TYPE

SOUNd

| [STATe]

REPort

| ALL?

| [DATA]?

| POINts?

[STATe]

CALCulate:MEASure:BLIMit:

DISPlay

| MARKer

| STATe

| BWIDth

| THReshold

FAIL

MAXimum

MINimum

REPort

| DATA

STATe

CALCulate:MEASure:RLIMit:

DATA

DISPlay

| LINE

| STATe

| RIPPle

| SELect

| TYPE

| STATe

FAIL

REPort:DATA

STATe

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Limit Lines

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:MEASure<mnum>:LIMit:DATA <block>

Applicable Models: E5080A, M9485A

(Read-Write) Sets data for limit segments.

Parameters

<cnum>

Channel number of the measurement for which limit lines are to be set. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

CALC:MEAS:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30

Query Syntax

CALCulate<cnum>:MEASure<mnum>:LIMit:DATA?

Return Type

Depends on FORM:DATA - All 100 predefined limit segments are returned.

Default

100 limit segments - all values set to 0

CALCulate<cnum>:MEASure<mnum>:LIMit:DATA:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes all limit line data for the selected measurement on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:LIM:DATA:DEL
Query Syntax | Not Applicable
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:LIMit:DISPlay[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the display of limit segments (if the data trace is turned ON).
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | Select limit segments from the following: ON or 1 - Turns the display of limit segments ON. OFF or 0 - Turns the display of limit segments OFF.
Examples | CALC:MEAS:LIM:DISP:STAT ON calculate2:measure2:limit:display:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:LIMit:FAIL?

Applicable Models: E5080A, M9485A

(Read-only) Reads the Pass/Fail status of the limit line test. Returns 1 (Fail) if any data point fails for any limit segment.

Limit display (CALC:MEAS:LIM:DISP) does NOT have to be ON.

Notes: When the limit test is set to OFF, False or OFF is always read out.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

Examples

CALC:MEAS:LIM:FAIL?

Return Type

Boolean

  • 0 is returned when Pass

  • 1 is returned when Fail

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>:AMPLitude:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500. Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:MEAS:LIM:SEGM1:AMPL:STAR 10 calculate2:measure2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>LIMit:SEGMent<snum>:AMPLitude:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500. Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:MEAS:LIM:SEGM1:AMPL:STOP 10 calculate2:measure2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>:STIMulus:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start (beginning) of the X-axis stimulus value.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:MEAS:LIM:SEGM1:STIM:STAR 10 calculate2:measure2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>:STIMulus:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop (end) of the X-axis stimulus value.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:MEAS:LIM:SEGM1:AMPL:STOP 10 calculate2:measure2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:LIMit:SEGMent<snum>:TYPE|TYPe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of limit segment.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:MEAS:LIM:SEGM:TYPE LMIN calculate2:measure2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:measure2:LIMit:SEGMent<snum>:TYPE | TYPe ?
Return Type | Character
Default | OFF

CALCulate<cnum>:MEASure<mnum>:LIMit:SOUNd[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns limit testing fail sound ON or OFF.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON or 1 - Turns limit testing ON. OFF or 0 - Turns limit testing OFF.
Examples | CALC:MEAS:LIM:SOUN ON calculate2:measure2:limit:sound:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:LIMit:REPort:ALL? <block>

Applicable Models: E5080A, M9485A

(Read-only) Reads the bandwidth test results (stimulus value, limit test result, upper limit value and lower limit value of all measurement points), for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<block> | Depends on FORM:DATA If the number of the measurement points is N, <Block> = <first stimulus>,<test result>,<upper limit>,<lower limit>, …, <Nth stimulus>,<test result>,<upper limit>,<lower limit> Where <test result>= -1: No limit, 0:Fail, 1:Pass
Examples | CALC:MEAS:LIM:REP:ALL?
Return Type | Variant
Default | Depend on the preset status

CALCulate<cnum>:MEASure<mnum>:LIMit:REPort[:DATA]? <block>

Applicable Models: E5080A, M9485A

(Read-only) Reads the stimulus values (frequency, power level or time) at all the measurement points that failed the limit test, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<block> | Depends on FORM:DATA If the number of the measurement points that failed the limit test is N, <block>=<First failed stimulus>, ..., <Nth failed stimulus>.
Examples | CALC:MEAS:LIM:REP:DATA?
Return Type | Numeric
Default | 9.91E37

CALCulate<cnum>:MEASure<mnum>:LIMit:REPort:POINts?

Applicable Models: E5080A, M9485A

(Read-only) Reads the number of the measurement points that failed the limit test, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:LIM:REP:POIN?
Query Syntax | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:LIMit[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns limit segment testing ON or OFF.

  • Use CALC:LIM:DISP to turn ON and OFF the display of limit segments.

  • If using Global Pass/Fail status, trigger the VNA AFTER turning Limit testing ON.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<bool>

ON or 1 - Turns limit testing ON.
OFF or 0 - Turns limit testing OFF.

Examples

CALC:MEAS:LIM:STAT ON
calculate2:measure2:limit:state off

Query Syntax

CALCulate<cnum>:MEASure<mnum>:LIMit:STATe?

Return Type

Boolean

Default

OFF or 0

CALCulate<cnum>:MEASure<mnum>:BLIMit:DISPlay:MARKer:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON/OFF the bandwidth value display of the bandwidth test, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON or 1 - Turns limit testing ON. OFF or 0 - Turns limit testing OFF.
Examples | CALC:BLIM:DISP:MARK:STAT ON calculate2:measure2:blimit:display:marker:state off
Query Syntax | CALCulate<cnum>:BLIMit:DISPLay:BWIDth:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:BLIMit:DISPlay:BWIDth:THReshold <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets bandwidth threshold value (attenuation from the peak) of the bandwidth test.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<value> | Bandwidth N dB points
Examples | CALC:BLIM:DISP:BWID:THR 5 calculate2:measure2:blimit:display:bwidth:threshold 5
Query Syntax | CALCulate<cnum>:BLIMit:DISPLay:BWIDth:THReshold?
Return Type | Numeric
Default | 3

CALCulate<cnum>:MEASure<mnum>:BLIMit:FAIL

Applicable Models: E5080A, M9485A

(Read-only) Get the bandwidth limit test results, for the active trace of selected channel.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<bool>

Boolean

  • 0 is returned when Pass

  • 1 is returned when Fail

Examples

CALC:BLIM:FAIL?
calculate2:blimit:fail?

Query Syntax

CALCulate<cnum>:BLIMit:FAIL?

Return Type

Boolean

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:BLIMit:MAXimum <max>

Applicable Models: E5080A, M9485A

(Read-Write) Sets/gets the upper limit value of the bandwidth test, for the selected channel).
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<max> | Maximum bandwidth
Examples | CALC:BLIM:MAX 1E6 calculate2:blimit:maximum 1E6
Query Syntax | CALCulate<cnum>:BLIMit:MAXimum?
Return Type | Numeric
Default |

CALCulate<cnum>:MEASure<mnum>:BLIMit:MINimum <min>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the lower limit value of the bandwidth test, for the selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Minl> | Minimum bandwidth
Examples | CALC:BLIM:MIN 1E6 calculate2:blimit:minimum 1E6
Query Syntax | CALCulate<cnum>:BLIMit:MINimum?
Return Type | Numeric
Default |

CALCulate<cnum>:MEASure<mnum>:BLIMit:REPort:DATA

Applicable Models: E5080A, M9485A

(Read-only) Read the bandwidth value of the bandwidth test, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<data>> |
Examples | CALC:BLIM:REP:DATA? calculate2:blimit:report:data?
Query Syntax | CALCulate<cnum>:BLIMit:REPort:DATA?
Return Type | Variant
Default | OFF

CALCulate<cnum>:MEASure<mnum>:BLIMit:STATe

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON/OFF the bandwidth test function, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON or 1 - Turns limit testing ON. OFF or 0 - Turns limit testing OFF.
Examples | CALC:MEAS:LIM:STAT ON calculate2:measure2:limit:state off
Query Syntax | CALCulate<cnum>:BLIMit:DIPLay:MARKer:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:DATA <data>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the ripple limit table for the active trace of selected channel.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<data>

Indicates the array data (for ripple line) of 1 + Num (number of limit lines)* 4. Where n is an integer between 1 and Num.

  • Data(0) :The number of limit lines you want to set. Specify an integer ranging 0 to 12. When the number of limit lines is set to 0 (clears the limit table), the variable Data is only required with Data(0).

  • Data(nx4-3) :The type of the n-th line.

Specify an integer 0 to 1 as follows.

0: OFF

1: ON

  • Data(nx4-2) :The value on the horizontal axis (frequency/power/time) of the start point of the n-th line.

  • Data(nx4-1) :The value on the horizontal axis (frequency/power/time) of the end point of the n-th line.

  • Data(nx4) :The ripple line value (dB) of the n-th line.

The index of the array starts from 0.

Examples

CALC:RLIM:DATA
calculate2:rlimit:data

Query Syntax

CALCulate<cnum>:MEASure<mnum>:RLIMit:DATA?

Return Type

Variant type Array

Default

OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPlay:LINE:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON/OFF the ripple limit line display, for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON or 1 - Turns limit testing ON. OFF or 0 - Turns limit testing OFF.
Examples | CALC:RLIM:DISP:LINE:STAT ON calculate2:rlimit:display:line:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPLay:LINE:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPlay:SELect <band>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or gets the ripple limit band for ripple value display for selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<band> | 1 to 12
Examples | CALC:RLIM:DISP:RIPP:SEL calculate2:rlimit:display:ripple:select
Query Syntax | CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPlay:SELect?
Return Type | Numeric
Default | 1

CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPlay:TYPE <typ>

Applicable Models: E5080A, M9485A

(Read-Write) Sets/gets the display type of ripple value for the active trace of selected channel.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<typ>

Select from the following:

  • "OFF": Specifies the display OFF.

  • "ABSolute": Specifies the absolute value for display type.

  • "MARgin": Specifies the margin for display type.

Examples

CALC:RLIM:DISP:TYPE
calculate2:rlimit:display:type

Query Syntax

CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPLay:TYPE?

Return Type

Boolean

Default

OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:DISPlay:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON/OFF the ripple test function for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON or 1 - Turns limit testing ON. OFF or 0 - Turns limit testing OFF.
Examples | CALC:RLIM:DISP:RIPP:STAT ON calculate2:rlimit:display:ripple:state off
Query Syntax | CALCulate<cnum>:RIMit:DISPlay:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:FAIL

Applicable Models: E5080A, M9485A

(Read-only) Read the ripple test result for the active trace.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<bool>

Boolean

  • 0 is returned when Pass

  • 1 is returned when Fail

Examples

CALC:RLIM:FAIL?
calculate2:Rlimit:FAIL?

Query Syntax

CALCulate<cnum>:MEASure<mnum>:RLIMit:FAIL?

Return Type

Boolean

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:RLIMit:REPort:DATA

Applicable Models: E5080A, M9485A

(Read-only) Reads the ripple value of the ripple test for the active trace.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<data>

{numeric 1} ... {numeric NOP×3+1}<newline><^END>

NOP is the number of measurement points.

  • {numeric 1}: Number of ripple limit line

  • {numeric n×3-1} : Number of ripple limit bands.

  • {numeric n×3} : Ripple value.

  • {numeric n×3+1} : Ripple test result (1: Fail, 0: Pass)

Examples

CALC:RLIM:REP:DATA?

calculate2:rlimit:report:data?

Query Syntax

CALCulate<cnum>:MEASure<mnum>:RLIMit:REPort:DATA?

Return Type

Variant

Default

OFF

CALCulate<cnum>:MEASure<mnum>:RLIMit:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON/OFF the ripple test function for the active trace of selected channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON (or 1) - turns limit testing ON. OFF (or 0) - turns limit testing OFF.
Examples | CALC:RLIM:STAT ON calculate2:rlimit:state off
Query Syntax | CALCulate<cnum>:RLIMit:STATe?
Return Type | Boolean
Default | OFF

Last modified:

6-Jan-2016

First Release


Marker SCPI

Calculate:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

CALCulate:MEASure:MARKer:

AOFF

BUCKet

BWIDth

| DATA?

| [STATe]

| THReshold

| REF

COMPression

| LEVel

| PIN?

| POUT?

COUPling

| METHod

| [STATe]

DELTa

DISCrete

DISTance

FORMat

FUNCtion

| APEak

| EXCursion

| THReshold

| PEAK

| EXCursion

| THReshold

| POLarity

| DOMain

| USER

| [RANGe]

| STARt

| STOP

| EXECute

| MULTi

| PEAK:EXCursion

| PEAK:POLarity

| PEAK:THReshold

| SELECT

| TARGet [VALue]

| TRACking

| TRansiton

| [SELect]

| TRACking

| TARGet [VALue]

| TRANsition

NOTch

| DATA?

| [STATe]

| THReshold

| REF

PNOP more commands (separate topic)

PSATuration more commands (separate topic)

REFerence

| [STATe]

| X

| Y

SET

[STATe]

TYPE

X

Y

Click on a Red keyword to view the command details.

See Also

  • Marker example program

  • Marker Readout number and size commands.

  • Learn about Markers

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Note: The Reference Marker is Marker Number 16

CALCulate<cnum>:MEASure<mnum>:MARKer:AOFF

Applicable Models: E5080A, M9485A

(Write-only) Turns all markers off for selected measurement. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:MARK:AOFF calculate2:measure2:marker:aoff
Query Syntax | Not Applicable
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BUCKet <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the data point (bucket) number of the trace on which the marker resides. When the markers are interpolated (non-discrete), the returned value is the nearest marker bucket position. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Marker number to move or query. The marker must already exist. If unspecified, <n> is set to 1.
<num> | Data point (bucket) number. Choose any data point between: 0 and the number of data points minus 1.
Examples | CALC:MEAS:MARK::BUCK 5 calculate2:measure1:marker2:bucket 200
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<n>:BUCKet?
Return Type | Integer
Default | The first marker is set to the middle of the span. Subsequent markers are set to the bucket number of the previously active marker.

CALCulate<cnum>:MEASure<mnum>:MARKer:BWIDth <num>

Applicable Models: E5080A, M9485A

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

To turn off the Bandwidth markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MEAS:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between :-500 and 500

Examples

CALC:MEAS:MARK:BWID -3
calculate2:measure1:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Numeric - Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Default

-3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth:DATA?

Applicable Models: E5080A, M9485A

(Read-only) Read the bandwidth search result of marker 1 to 15 and reference marker (Mkr:16), for the active trace of selected channel.

If the bandwidth search is impossible, an error occurs when executed and the object is ignored.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; If unspecified, value is set to 1.

Four Character values separated by commas => {numeric 1}, {numeric 2}, {numeric 3}, {numeric 4}

  • {numeric 1} : Bandwidth

  • {numeric 2} : Center point frequency of the 2 cutoff frequency points

  • {numeric 3} : Q value

  • {numeric 4} : Insertion loss

Examples

CALC:MEAS:MARK:BWID:DATA?
calculate2:measure1:marker:bwidth:data?

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth:DATA?

Return Type

Numeric

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the bandwidth search result display, for the active trace of selected channel . See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | Bandwidth search result display: ON or 1 - Turns ON the bandwidth search result display. OFF or 0 - Turns OFF the bandwidth search result display.
Examples | CALC:MEAS:MARK:BWID ON calculate2:measure1:marker:bwidth:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer:BWIDth[:STATe]?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth:THReshold <value><unit>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the bandwidth definition value (the value to define the pass-band of the filter) of marker 1 to 15 and reference marker (Mk:16), for the active trace of selected channel.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<value>

Bandwidth definition value (the value to define the pass band of the filter) is between -5E8 to 5E8.

<unit>

Varies depending on the data format.

  • Log magnitude (MLOG): dB (decibel)

  • Phase (PHAS), Expanded phase (UPH) or Positive phase (PPH): ° (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:BWID:THR -3
calculate2:measure1:marker:bwidth:threshold -3

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth:THReshold?

Return Type

Numeric

Default

-3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:BWIDth:REF <string>

Applicable Models: E5080A, M9485A

(Read-Write) Set the bandwidth marker function reference to either MARKer or PEAK.

If the reference is set to MARKer, the active marker is not moved; the bandwidth search is computed at the marker;s current location.

If the reference is PEAK, the active marker is moved to the maximum or minimum peak on the trace and then bandwidth search is computed.

  • If the bandwidth level is negative, the active marker is moved to the maximum peak.

  • If the bandwidth level is positive, the active marker is moved to the minimum peak.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<string>

PEAK

MARKer

Examples

CALC:MEAS:MARK:BWID:REF MARK
calculate2:measure1:marker:bwidth:ref peak

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer:BWIDth:REF?

Return Type

String

Default

MARKer

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COMPression:LEVel <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and read the marker compression level. A compression marker must already exist. Use CALC:MARK ON and CALC:MEAS:MARK:FUNC COMP to create compression markers. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Compression level. Choose any number between: -500 dB to 500 dB Standard gain compression values are positive.
Examples | CALC:MEAS:MARK:COMP:LEV 1 calculate2:measure1:marker:compression:level 1.5
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COMPression:LEVel?
Return Type | Numeric
Default | +1 dB

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COMPression:PIN?

Applicable Models: E5080A, M9485A

(Read-only) Read the input power at the marker compression level. First send CALC:MEAS:MARK:FUNC:EXEC COMP or CALC:MEAS:MARK:FUNC:TRAC ON See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:COMP:PIN? calculate2:measure1:marker:compression:pin?
Return Type | Numeric
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COMPression:POUT?

Applicable Models: E5080A, M9485A

(Read-only) Read the output power at the marker compression level. First send CALC:MEAS:MARK:FUNC:EXEC COMP or CALC:MEAS:MARK:FUNC:TRAC ON See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:COMP:POUT? calculate2:measure1:marker:compression:pout?
Return Type | Numeric
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COUPling[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the state of Coupled Markers. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | OFF or 0 - Turns Coupled Markers OFF. ON or 1 - Turns Coupled Markers ON.
Examples | CALC:MEAS:MARK:COUP ON calculate2:measure1:marker8:coupling:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:COUPling:[STATe]?
Return Type | Boolean
Default | OFF

CALCulate[:MEASure]:MARKer:COUPling:METHod <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the scope of Coupled Markers. This is a global setting that affects all markers. Learn more.

Note: This command will not take effect until Coupled Markers is turned on using CALC:MARK:COUP:STATe ON.

Note: The preset behavior of Coupled Markers depends on the setting of SYSTem:PREFerences:ITEM:MCControl, SYSTem:PREFerences:ITEM:MCMethod, and SYSTem:PREFerences:ITEM:MCPRest.

Parameters

<char>

CHANnel - Coupling is limited to traces in the same channel.

ALL - Coupling occurs across all channels.

Examples

CALC:MARK:COUP:METH CHAN

calculate:marker:coupling all

Query Syntax

CALCulate:MARKer:COUPling:METHod?

Return Type

Character

Default

ALL

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DELTa <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MEAS:MARK:REF:STATE. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | ON or 1 - Specified marker is a Delta marker OFF or 0 - Specified marker is an ABSOLUTE marker
Examples | CALC:MEAS:MARK:DELT ON calculate2:measure1:marker8:delta off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DELTa?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DISCrete <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | ON or 1 - Specified marker displays the actual data points OFF or 0 - Specified marker displays calculated data between the actual data points.
Examples | CALC:MEAS:MARK:DISC ON calculate2:measure1:marker8:discrete off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DISTance <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or query marker distance on a time domain trace. The Write command moves the marker to the specified distance value. Once moved, you can read the Y axis value or read the X-axis time value. (Distance is calculated from the X-axis time value.) The Read command reads the distance of the marker. If the marker is set as delta, the WRITE and READ data is relative to the reference marker. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any existing marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Marker distance in the unit of measure specified with CALC:TRAN:TIME:MARK:UNIT
Examples | CALC:MEAS:MARK:DIST .1 calculate2:measure1:marker8:distance 5
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:DISTance?
Return Type | Numeric
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FORMat <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MEAS:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1

<char>

Choose from:

  • DEFault - The format of the selected measurement

  • MLINear - Linear magnitude

  • MLOGarithmic - Logarithmic magnitude

  • IMPedance - (R+jX)

  • ADMittance - (G+jB)

  • PHASe - Phase

  • IMAGinary - Imaginary part (Im)

  • REAL - Real part (Re)

  • POLar - (Re, Im)

  • GDELay - Group Delay

  • LINPhase - Linear Magnitude and Phase

  • LOGPhase - Log Magnitude and Phase

  • SWR - Standing Wave Ratio

Examples

CALC:MEAS:MARK:FORMat MLIN
calculate2:measure1:marker8:format mlinear

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FORMat?

Return Type

Character

Default

DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Numeric
Default | 3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:APEak:POLarity <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns polarity of the peak search with marker 1 to 15 and reference marker (Mk:16), for the active trace of selected channel.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<char>

Polarity for peak search function to be performed. Choose from:

  • "NEGative" : Specifies the negative peak.

  • "POSitive" : Specifies the positive peak.

  • "BOTH" : Specifies both the positive peak and the negative peak.

Examples

CALC:MEAS:MARK:FUNC:APE:POL NEG
calculate2:measure1:marker6:function:apeak:polarity both

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:APEak:POLarity?

Return Type

Character

Default

"POSitive"

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Numeric
Default | -100

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:EXCursion <num><unit>

Applicable Models: E5080A, M9485A

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left).

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any existing marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Excursion value. Choose any number between -500 and 500.

Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

<unit>

Varies depending on the data format.

  • Log magnitude (MLOG): dB (decibel)

  • Phase (PHAS), Expanded phase (UPH) or Positive phase (PPH): × (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:FUNC:PEAK:EXC 10
calculate2:measure1:marker8:function:apeak:excursion maximum

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:EXCursion?

Return Type

Numeric

Default

3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:POLarity <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns polarity of the peak search with marker 1 to 15 and reference marker (Mk:16), for the active trace of selected channel.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<char>

Polarity for peak search function to be performed. Choose from:

  • "NEGative" : Specifies the negative peak.

  • "POSitive" : Specifies the positive peak.

  • "BOTH" : Specifies both the positive peak and the negative peak.

Examples

CALC:MEAS:MARK:FUNC:PEAK:POL NEG
calculate2:measure1:marker6:function:peak:polarity both

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:POLarity?

Return Type

Character

Default

"POSitive"

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:THReshold <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:MARK:FUNC:PEAK:THR -40 calculate2:measure1:marker8:function:peak:threshold -55
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:PEAK:THReshold?
Return Type | Numeric
Default | -100

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER[:RANGe] <range>

Applicable Models: E5080A, M9485A

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MEAS:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel has 16 user ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<range>

User span. Choose any Integer from 0 to 16.

0 is Full Span of the analyzer.

1 to 16 are available for user-defined x-axis span.

Examples

CALC:MEAS:MARK:FUNC:DOM:USER:RANG 1
calculate2:measure1:marker8:function:domain:user:range 1

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER:RANGe?

Return Type

Numeric

Default

0 - Full Span

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.

Use CALC:MEAS:MARK:FUNC:DOM:USER<range> to set range number.

Use CALC:MEAS:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MEAS:MARK:FUNC:DOM:USER:START 500E6
calculate2:measure1:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Numeric

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MEAS:MARK:FUNC:DOM:USER<range> to set range number. Use CALC:MEAS:MARK:FUNC:DOM:USER:STARt to set the stop value. Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span". Note: This command does the same as CALC:FUNC:DOM:USER:STOP See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<stop> | Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.
Examples | CALC:MEAS:MARK:FUNC:DOM:USER:STOP 500e6 calculate2:measure1:marker8:function:domain1:user:stop 1e12
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?
Return Type | Numeric
Default | The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:EXECute <func>

Applicable Models: E5080A, M9485A

(Write-only) Immediately executes (performs) the specified search function.

Learn more about Marker Search

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<func>

The function to be performed. Choose from:

  • MAXimum - finds the highest value.

  • MINimum - finds the lowest value.

  • RPEak - finds the next valid peak to the right.

  • LPEak - finds the next valid peak to the left.

  • NPEak - finds the next highest value among the valid peaks.

  • TARGet - finds the target value to the right, wraps around to the left.

  • LTARget - finds the next target value to the left of the marker.

  • RTARget - finds the next target value to the right of the marker.

  • COMPression - finds the compression level on a Power Swept S21 trace.

Examples

CALC:MEAS:MARK:FUNC:EXEC MAX
calculate2:measure1:marker2:function:execute maximum

Query Syntax

Not Applicable

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:EXECute <func>

Applicable Models: E5080A, M9485A

(Write-only) Immediately executes (performs) the specified multi search function.

Learn more about Marker Search

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<func>

The function to be performed. Choose from:

  • TARGet - finds the target value to the right, wraps around to the left.

  • PEAK - finds the next highest value among the valid peaks

Examples

CALC:MEAS:MARK:FUNC:EXEC MIN
calculate2:measure2:marker2:function:execute minimum

Query Syntax

Not applicable

Default

Not applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:EXCursion <num><unit>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the lower limit of peak excursion value of multi peak search, for the selected channel and selected trace.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Excursion value. Choose any number between -500 and 500.

Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

<unit>

Varies depending on the data format.

  • Log magnitude (MLOG): dB (decibel)

  • Phase (PHAS), Expanded phase (UPH) or Positive phase (PPH): ° (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:FUNC:MULT:PEAK:EXC 10
calculate2:measure2:marker8:function:multi:pexcursion maximum

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:EXCursion?

Return Type

Numeric

Default

3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:POLarity <func>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the peak polarity of the multi peak search, for the selected channel and selected trace.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<func>

Polarity for multi peak search function to be performed. Choose from:

  • "NEGative : Specifies the negative peak.

  • "POSitive" : Specifies the positive peak.

  • "BOTH" : Specifies both the positive peak and the negative peak.

Examples

CALC:MEAS:MARK:FUNC:MULT:PEAL:POL NEG
calculate2:measure1:marker6:function:multi:peak:polarity both

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:POLarity?

Return Type

Character

Default

"POSitive"

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:THReshold <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets peak threshold for the multi peak search, for the selected channel and selected trace. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:MARK:FUNC:MULT:PEAK:THR -40 calculate2:measure1:marker8:function:multi:peak:threshold -55
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:THReshold?
Return Type | Numeric
Default | -100

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:SELect

Applicable Models: E5080A, M9485A

(Read-Write) Sets the search type of the multi search.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<func>

The function to be performed. Choose from:

  • OFF: Turn OFF the multi search function.

  • PEAK: Sets the search type to the multi peak search.

  • TARGet: Sets the search type to the multi target search.

Examples

CALC:MEAS:MARK:FUNC:MULT:SEL PEAK
calculate2:measure1:marker6:function:multi:select peak

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:SELect?

Return Type

Character

Default

OFF

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:TARGet[:VALue] <num><unit>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the target value for the specified marker when doing Multi Target Search, for the selected channel and selected trace.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Target value for multi target search to search for.

The range of target value is -5E8 to 5E8.

Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

<unit>

Varies depending on the data format.

  • Log magnitude (MLOG): dB (decibel)

  • Phase (PHAS), Expanded phase (UPH) or Positive phase (PPH): ° (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:FUNC:MULT:TARG 2.5
calculate2:measure2:marker5:function:multi:target:value -10.3

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:TARGet[:VALue]?

Return Type

Numeric

Default

0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:TRACking <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the search tracking capability (function to repeat search for each sweep) of the multi search, for the selected channel and selected trace.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<bool>

ON or 1 - Turns ON the marker search tracking. The specified multi marker will "Track" (find) the selected function every sweep.

OFF or 0 - Turns OFF the marker search tracking. The specified multi marker will find the selected function only when the CALC:MEAS:MARK:FUNC:EXECute command is sent.

Examples

CALC:MEAS:MARK:FUNC:MULT:TRAC ON
calculate2:measure2:marker8:function:multi:tracking off

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:TRACking?

Return Type

Boolean

Default

OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:TARGet:TRANsition <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the transition type of the multi target search.

Learn more about Marker Search

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<char>

Transition type of multi target search function to be performed. Choose from:

  • "NEGative" : Specifies the negative transition.

  • "POSitive" : Specifies the positive transition.

  • "BOTH" : Specifies both the positive transition and the negative transition.

Examples

CALC:MEAS:MARK:FUNC:MULT:TARG:TRAN BOTH
calculate2:measure1:marker6:function:multi:target:transition both

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:MULTi:PEAK:TARGet:TRansition?

Return Type

Character

Default

"BOTH"

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the search function that the specified marker will perform when executed. Use CALC:MEAS:MARK:FUNC:TRAC ON to automatically execute the search every sweep.

Learn more about Marker Search

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

  • MAXimum - finds the highest value

  • MINimum - finds the lowest value

  • RPEak - finds the next valid peak to the right

  • LPEak - finds the next valid peak to the left

  • NPEak - finds the next highest value among the valid peaks

  • TARGet - finds the target value to the right, wraps around to the left

  • LTARget - finds the next target value to the left of the marker

  • RTARget - finds the next target value to the right of the marker

  • COMPression - finds the compression level on a power-swept S21 trace.

Examples

CALC:MEAS:MARK:FUNC MAX
calculate2:measure1:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion[:SELect]?

Return Type

Character

Default

MAXimum

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:TRACking <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the tracking search capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MEAS:MARK:FUNC:EXECute command every sweep.

Learn more about Marker Search

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<bool>

ON or 1 - Turns ON the search tracking. The specified marker will "Track" (find) the selected function every sweep.

OFF or 0 - Turns OFF the search tracking. The specified marker will find the selected function only when the CALC:MEAS:MARK:FUNC:EXECute command is sent.

Examples

CALC:MEAS:MARK:FUNC:TRAC ON
calculate2:measure1:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean

Default

OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:TARGet[:VALue] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the target value for the specified marker when doing Target Searches with CALC:MEAS:MARK:FUNC:SEL <TARGet | RTARget | LTARget>

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Target value to search for.

The range of value is between -5E8 to 5E8.

Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

<unit>

Varies depending on the data format.

  • Log magnitude (MLOG): dB (decibel)

  • Phase (PHAS), Expanded phase (UPH) or Positive phase (PPH): ° (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:FUNC:TARG 2.5
calculate2:measure1:marker8:function:target:value -10.3

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:TARGet[:VALue]?

Return Type

Numeric

Default

0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:TARGet[:VALue]:TRANsition <char>

Applicable Models: E5080A, M9485A

(Read-Write) Selects the transition type of the target search for specified marker (marker 1 to 15 and reference marker (Mk:16)) of the active trace of selected channel.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<char>

Transition type for search function to be performed. Choose from:

  • "NEGative" : Specifies the negative transition.

  • "POSitive" : Specifies the positive transition.

  • "BOTH" : Specifies both the positive transition and the negative transition.

Examples

CALC:MEAS:MARK:FUNC:TARG:TRAN POS
calculate2:measure1:marker8:function:target:value:transition both

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:FUNCtion:TARGet[:VALue]:TRANsition?

Return Type

Character

Default

"BOTH"

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:DATA?

Applicable Models: E5080A, M9485A

(Read-only) Reads the notch search result of marker 1 to 15 and reference marker (Mk:16), for the active trace of selected channel.

If the notch search is impossible, an error occurs and the command is ignored. In this case, no query response is obtained.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

Indicates 4-element array data (notch bandwidth search result). Four Character values separated by commas => {Data 1}, {Data 2}, {Data 3}, {Data 4}

  • Data(0) :The bandwidth.

  • Data(1) :Center point frequency of the 2 cutoff frequency points.

  • Data(2) :The Q value.

  • Data(3) :Insertion loss

The index of the array starts from 0.

Examples

CALC:MEAS:MARK:NOTC:DATA?
calculate2:measure1:marker:notch:data?

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:DATA?

Return Type

Variant

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the notch search result display, for the active trace of selected channel. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | Notch search result display. Choose from: ON or 1 - Turns ON the notch search result display. OFF or 0 - Turns OFF the notch search result display.
Examples | CALC:MEAS:MARK:NOTC ON calculate2:measure1:marker:notch:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh[:STATe]?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:THReshold <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the notch definition value of marker 1 to 15 and reference marker (Mk:16), for the active trace of selected channel.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

The notch definition value range is between -5E8 to 5E8.

Notes: If the specified parameter is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

<unit>

Varies depending on the data format as follows:

  • Amplitude (MLOG):dB (decibel)

  • Phase (PHAS), Expanded phase (UPH),Positive phase (PPH): ° (degree)

  • Group delay (GDEL): s (second)

  • Others: No unit

Examples

CALC:MEAS:MARK:NOTC:THR -3
calculate2:measure1:marker:notch:threshold -3

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:THReshold?

Return Type

Numeric

Default

-3

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:REF <string>

Applicable Models: E5080A, M9485A

(Read-Write) Set the notch marker reference to either MARKer or PEAK.

If the reference is set to MARKer, the active marker is not moved; the notch search is computed at the marker's current location.

If the reference is set to PEAK, the active marker is moved to the maximum or minimum peak on the trace and then notch search is computed.

  • If the notch level is negative, the active marker is moved to the maximum peak.

  • If the notch level is positive, the active marker is moved to minimum peak.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<string>

PEAK

MARKer

Examples

CALC:MEAS:MARK:NOTCh:REF
calculate2:measure1:marker:notch:ref

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:NOTCh:REF?

Return Type

String

Default

MARKer

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:REFerence[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the reference marker mode, for the active trace of selected channel. When turned OFF, existing Delta markers revert to absolute markers. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | ON or 1 - Turns reference marker mode ON. OFF or 0 - Turns reference marker mode OFF.
Examples | CALC:MEAS:MARK:REF ON calculate2:measure1:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:REFerence[:STATe]?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:REFerence:X <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the absolute x-axis value of the reference marker. See Critical Note
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | X-axis value. Choose any number within the operating domain of the reference marker.
Examples | CALC:MEAS:MARK:REF:X 1e9 calculate2:measure1:marker:reference:x 1e6
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:REFerence:X?
Return Type | Numeric
Default | If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:REFerence:Y <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the absolute Y-axis value of the reference marker (Set the reference marker Y position only when the marker is a fixed marker type). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Y-axis value. Choose any number within the operating domain of the reference marker.
Examples | CALC:MEAS:MARK:REF:Y 1e6 calculate2:measure1:marker:reference:y 1e9
Return Type | Numeric
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:SET <char>

Applicable Models: E5080A, M9485A

(Write-only) Sets the selected instrument setting to assume the value of the specified marker.

Marker Functions CENT, SPAN, STARt, and STOP do not work with channels that are in CW or Segment Sweep mode.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1

<char>

Choose from:

  • CENTer - changes center frequency to the value of the marker.

  • SPAN - changes the sweep span to the span that is defined by the delta marker and the marker that it references. Unavailable if there is no delta marker.

  • STARt - changes the start frequency to the value of the marker.

  • STOP - changes the stop frequency to the value of the marker.

  • RLEVel - changes the reference level to the value of the marker.

  • DELay - changes the line length at the receiver input to the phase slope at the active marker stimulus position.

  • CWFReq - Sets the CW frequency to the frequency of the active marker. Does NOT change sweep type. NOT available in CW or Power Sweep. Use this argument to first set the CW Frequency to a value that is known to be within the current calibrated range, THEN set Sweep:Type to POWer or CW.

Examples

CALC:MEAS:MARK:SET CENT
calculate2:measure1:marker8:set span

Query Syntax

Not Applicable

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the specified marker. Marker 16 is the Reference Marker. To turn all markers OFF, use CALC:MEAS:MARK:AOFF. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<bool> | ON or 1 - Turns marker ON. OFF or 0 - Turns marker OFF.
Examples | CALC:MEAS:MARK ON calculate2:measure1:marker8 off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:STATe?
Return Type | Boolean
Default | OFF or 0

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of the specified marker.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1

<char>

Choose from:

  • NORMal - a marker that stays on the assigned X-axis position unless moved or searching.

  • FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MEAS:MARK:TYPE NORM
calculate2:measure1:marker2:type fixed

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:TYPE?

Return Type

Character

Default

NORMal

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:X <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Any X-axis position within the measurement span of the marker.

(When the span value of the sweep range is 0, the range is from 0 to sweep time value.)

Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

<unit>

Hz (hertz), dBm or s (second)

Examples

CALC:MEAS:MARK:X 100Mhz
calculate2:measure1:marker8:x maximum

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:X?

Return Type

Numeric

Default

First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

(When the span value of the sweep range is 0, the preset value is 0.)

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:Y?

Applicable Models: E5080A, M9485A

(Read-only) Reads the marker's Y-axis value. The format of the value depends on the current CALC:MEAS:MARK:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • LINPhase and LOGPhase - (Real, Imaginary)

  • All other formats - (Value,0)

Note: To accurately read the marker Y-axis value with trace smoothing applied, the requested format must match the displayed format. Otherwise, the returned value is un-smoothed data. For example, to read the smoothed marker value when measuring group delay, both the display format and the marker format must be set to (Group) Delay.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

Examples

CALC:MEAS:MARK:Y?
calculate2:measure1:marker3:y?

Query Syntax

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:Y?

Return Type

Numeric

Default

Not Applicable

Last modified:

6-Jan-2016

First Release


Math SCPI

Calculate:Math Commands

Controls math operations on the currently selected measurement and memory.

CALCulate:MEASure:MATH:

FUNCtion

MEMorize

CALCulate:MEASure:MIXer:

XAXis (seperate topic)

CALCulate:MEASure:OFFSet:

MAGNitude (seperate topic)

| SLOPe (seperate topic)

PHASe (seperate topic)

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Math Operations

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:MATH:FUNCtion <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | The math operation to be applied. Choose from the following:
NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory
Examples | CALC:MATH:FUNC NORM calculate2:measure2:math:function subtract
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MATH:FUNCtion?
Return Type | Character
Default | NORMal

CALCulate<cnum>:MEASure<mnum>:MATH:MEMorize

Applicable Models: E5080A, M9485A

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:MATH:MEM
Query Syntax | Not applicable
Default | Not applicable

Last modified:

6-Jan-2016

First Release


Mixer

Calculate:Mixer Command

CALCulate:MEASure:MIXer:

XAXis

Click on a Red keyword to view the command details.

CALCulate<cnum>:MEASure<mnum>:MIXer:XAXis <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the swept parameter to display on the X-axis for the selected FCA measurement.

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<char>

Parameter to display on the X-axis. Choose from:

INPUT - Input frequency span

OUTPUT - Output frequency span

LO_1 - First LO frequency span

LO_2 - Second LO frequency span

Examples

CALC:MEAS:MIX:XAX INPUT
calc2:measure2:mixer:xaxis output

See an example that creates, selects, and calibrates an SMC measurement using SCPI.

Query Syntax

CALCulate<ch>:MEASure<mnum>:MIXer:XAXis?

Return Type

Character

Default

OUTPUT

Last modified:

6-Jan-2016

First Release


Offset

Calculate:Offset Commands

Allows the data trace magnitude and phase to be offset.

Click on a Red keyword to view the command details.

CALCulate:MEASure:OFFSet:

MAGNitude

| SLOPe

PHASe

See Also

  • Example Programs

  • Learn about Magnitude Offset

  • Learn about Phase Offset

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:OFFSet:MAGNitude <num>

Applicable Models: E5080A, M9485A

(Read-Write) Offsets the data trace magnitude by the specified value. To offset the data trace magnitude to a slope value that changes with frequency, use CALC:OFFS:MAGN:SLOP See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Offset value in dB.
Examples | CALC:MEAS:OFFS:MAGN:4 calculate1:measure2:offset:magnitude -2
Query Syntax | CALCulate<cnum>:MEASure<mnum>:OFFSet:MAGNitude?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:OFFSet:MAGNitude:SLOPe <num>

Applicable Models: E5080A, M9485A

(Read-Write) Offsets the data trace magnitude to a value that changes linearly with frequency. The offset slope begins at 0 Hz. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Offset slope value in dB/ 1GHz.
Examples | CALC:MEAS:OFFS:MAGN:SLOP 1 'Offset slope set to 1dB/GHz calculate1:measure2:offset:magnitude:slope -2 'Offset slope set to -2dB/GHz
Query Syntax | CALCulate<cnum>:MEASure<mnum>:OFFSet:MAGNitude:SLOPe?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEASure<mnum>:OFFSet:PHASe <num>[<char>]

Applicable Models: E5080A, M9485A

(Read-Write) Sets the phase offset for the selected measurement. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:MEAS:OFFS:PHAS 10 calculate3:measure2:offset:phase 20rad
Query Syntax | CALCulate<cnum>:MEASure<mnum>:OFFSet:PHASe?
Return Type | Numeric, returned value always in degrees
Default | 0 degrees

Last modified:

6-Jan-2016

First Release


Parameter SCPI

Calculate:Parameter Commands

Lists, creates, selects, and deletes measurements.

CALCulate:PARameter:

CATalog

| EXTended

COUNt

CALCulate:MEASure:

DEFine

PARameter

MNUMber

| [SELect]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Measurement Parameters

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:PARameter:CATalog:EXTended?

Applicable Models: E5080A, M9485A

(Read-only) Returns the names and parameters of existing measurements for the specified channel. This command lists receiver parameters with "_" such that R1,1 is reported as R1_1. This makes the returned string a true "comma-delimited" list all the time.

The returned string of this command is easily parsed and used to create measurements using the CALC:PAR:EXT command.

Parameters

<cnum>

Channel number of the measurements to be listed. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:PAR:CAT:EXT?

calculate2:parameter:catalog:extended?

Return Type

String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"

Default

"CH1_S11_1,S11"

CALCulate<cnum>:PARameter:COUNt <value>

Applicable Models: E5080A, M9485A

(Write-only) Sets or gets the number of traces of selected channel.

Parameters

<cnum>

Channel number of the measurements to be listed. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<value>

Number of traces that should be present on the selected channel. Varies depending on the upper limit setting for the channel/trace number.

Note: This command will delete measurements if the specified value is less than the current value.

Examples

CALC:PAR:COUN 1

Query Syntax

Numeric

Default

1

CALCulate<cnum>:MEASure<mnum>:DEFine <Mname>,<param>[,port]

Applicable Models: E5080A, M9485A

Note: This command is replaced with CALC:PAR:DEFine:EXTended. This command will continue to work for up to 4-port parameters.

(Write-only) Creates a measurement parameter of the selected trace, for the selected channel but does NOT display it.

There is no limit to the number of measurements that can be created. However, there is a limit to the number of measurements that can be displayed. See Traces, Channels, and Windows on the VNA.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND:TRAC:FEED to display the measurement.

You must select the measurement before making additional settings.

See Critical Note

Parameters

<cnum>

Channel number of the measurement to be listed. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<Mname>

String - Name of the measurement parameter. Any non-empty, unique string, enclosed in quotes.

<param>

For S-parameters:

Any S-parameter available in the VNA

For ratioed measurements:

Any two receivers that are available in the VNA.

For example: AR1 (this means A/R1)

For non-ratioed measurements:

Any receiver that is available in the VNA.

For example: A

Port No. | Test Receiver | Reference Reciever
1 | A | R1
2 | B | R2
3 | C | R3
4 | D | R4

For Balanced Measurements:

First create an S-parameter measurement, then change the measurement using CALC:FSIM:BAL commands.

[port]

Optional argument;

For multi-port reflection S-parameter measurements: specifies the VNA port which will provide the load for the calibration. This argument is ignored if a transmission S-parameter is specified.

For all non S-parameter measurements: specifies the source port for the measurement.

Examples

CALC4:MEAS 'ch4_S33',S33,2 'Defines an S33 measurement with a load on port2 of the analyzer'

calculate2:measure2:define 'ch1_a', a, 1 'unratioed meas'

calculate2:measure2:define 'ch1_a', ar1,1 'ratioed meas'

Query Syntax

Not Applicable; see Calc:Par:Cat?

Default

Not Applicable

CALCulate<cnum>:MEASure<mnum>:PARameter <string>

(Read-Write) To be extended to accept the balanced measurement parameters.

This extension will replace the following commands:

CALC:FSIM:BAL:PAR:SBAL[:DEF]

CALC:FSIM:BAL:PAR:SSB[:DEF]

CALC:FSIM:BAL:PAR:BBAL[:DEF]

CALC:FSIM:BAL:PAR:BALS[:DEF]

CALC:FSIM:BAL:PAR:BAL[:DEF]

See Critical Note

Parameters

<cnum>

Channel number of the measurements to be listed. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<string>

For 1 port balanced measurement, choose from:

Sdd11, Scd11, Sdc11, Scc11

For Balanced - Single-ended measurement, choose from:

Sdd11, Scd11, Sdc11, Scc11, Ssd21, Ssc21, Sds12, Scs12, Sss22, Imb, CMMR1, CMMR2

  • Imb = - S_1pos_2/S_1neg_2

  • CMMR1 = Ssd21/Ssc21

  • CMMR2 = Sds12/Scs12

For Single-ended - Balanced measurement, choose from:

Sss11, Sds21, Scs21, Ssd12, Ssc12, Sdd22, Scd22, Sdc22, Scc22, Imb, CMMR1, CMMR2

  • Imb = - S_2pos_1/S_2neg_1

  • CMMR1 = Sds21/Scs21

  • CMMR2 = Ssd12/Ssc12

For Balanced - Balanced measurement, choose from:

Sdd11, Sdd21, Sdd12, Sdd22, Scd11, Scd21, Scd12, Scd22, Sdc11, Sdc21, Sdc12, Sdc22,

Scc11, Scc21, Scc12, Scc22, Imb1, Imb2, CMMR

  • Imb1 = - (S_1pos_2pos – S_1pos_2neg)/(S_1neg_2pos – S_1neg_2neg)

  • Imb2 = - (S_2pos_1pos – S_2pos_1neg)/(S_2neg_1pos – S_2neg_1neg)

  • CMMR = - Sdd21/Scc21

For Single-ended - Single-ended - Balanced measurement, choose form:

Sss11, Sss21, Sss12, Sss22, Sds31, Scs31, Sds32, Scs32, Ssd13, Ssd23, Ssc13, Ssc23,

Sdd33, Scd33, Sdc33, Scc33, Imb1, Imb2, CMMR1, CMMR2

  • Imb1 = - (S_1pos_2pos – S_1pos_2neg)/(S_1neg_2pos – S_1neg_2neg)

  • Imb2 = - (S_2pos_1pos – S_2pos_1neg)/(S_2neg_1pos – S_2neg_1neg)

  • Imb3 = - S_3pos_1/S_3neg_1

  • Imb4 = - S_3pos_2/S_3neg_2

  • CMMR1 = Sds31/Scs31

  • CMMR2 = Sds32/Scs32

Note: The right definition for SSB imbalance is added as Imb3, 4. The definition for SSB Imb1, 2 seem a mistake, but keep it remained for backward compatibility.

Examples

CALC:MEAS:PAR "Sdd11"

calculate2:measure2:parameter "Sdd11"

Query Syntax

CALCulate<cnum>:MEASure<mnum>:PARameter?

Return Type

String

Default

"Sdd11"

CALCulate<cnum>:PARameter:MNUMber[:SELect] <n>[,fast]

(Read-Write) Sets and returns the selected measurement for the channel using the Tr#. Most CALC: commands require that this, or CALC:PAR:SEL, be sent before a setting change is made to that measurement. Each channel can have one selected measurement.
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<n> | Numeric - Measurement number. These are the same numbers you see in the “Tr1”, “Tr2” annotation next to the parameter name on the VNA screen.
[fast] | Optional. The VNA display is NOT updated. Therefore, do not use this argument when an operator is using the VNA display. Otherwise, sending this argument results in much faster sweep speeds. There is NO other reason to NOT send this argument.
Examples | CALC:PAR:MNUM 2 calculate2:parameter:mnumber:select 3,fast
Query Syntax | CALCulate<cnum>:PARameter:MNUMber[:SELect]? There is NO query available to determine if the FAST argument has been set.
Return Type | Numeric
Default | None

CALCulate<cnum>:PARameter:TAG:NEXT?

Applicable Models: E5080A, M9485A

(Read-only)
Parameters |
<cnum> | Channel number of the measurement. The selected measurement on that channel will be changed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:TAG:NEXT
Query Syntax | Not Applicable
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


Smoothing SCPI

Calculate:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

CALCulate:MEASure:SMOothing:

APERture

POINts

[STATe]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Smoothing

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

CALCulate<cnum>:MEASure<mnum>:SMOothing:APERture <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:MEAS:SMO:APER 2 calculate2:measure2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Numeric
Default | 1.5

CALCulate<cnum>:MEASure<mnum>:SMOothing:POINts <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of adjacent data points to average. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:MEAS:SMO:POIN 50 calculate2:measure2:smoothing:points 21
Query Syntax | CALCulate<cnum>:MEAsure<mnum>:SMOothing:POINts?
Return Type | Numeric
Default | 3

CALCulate<cnum>:MEASure<mnum>:SMOothing[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns data smoothing ON or OFF. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON or 1 - Turns smoothing ON. OFF or 0 - Turns smoothing OFF.
Examples | CALC:MEAS:SMO ON calculate2:measure2:smoothing:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:SMOothing[:STATe]
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

Last modified:

6-Jan-2016

First Release


Transform SCPI

Calculate:Transform Commands

Specifies the settings for time domain transform.

CALCulate:MEASure:TRANsform:

COUPle

| PARameters

TIME

| CENTer

| IMPulse

| WIDTh

| KBESsel

| LPFRequency | LPFREQuency

| MARKer

| MODE

| UNIT

| SPAN

| STARt

| STATe

| STEP

| RTIMe

| STIMulus

| STOP

| [TYPE]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Time Domain

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select.

CALCulate<cnum>:MEASure<mnum>:TRANsform:COUPle:PARameters <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the time domain transform parameters to be coupled. The settings for those parameters will be copied from the selected measurement to all other measurements on the channel.

  • To turn coupling ON and OFF, use SENS:COUP:PAR

  • To specify Gating parameters to couple, use CALC:FILT:COUP:PAR

Learn more about Time Domain Trace Coupling

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

(Numeric) Parameters to couple. To specify more than one parameter, add the numbers.

1 - Transform Stimulus (Start, Stop, Center, and Span TIME settings.)

2 - Transform State (ON / OFF)

4 - Transform Window (Kaiser Beta / Impulse Width)

8 - Transform Mode (Low Pass Impulse, Low Pass Step, Band Pass)

16 - Transform Distance Marker Units

Examples

'To couple all parameters:

CALC:MEAS:TRAN:COUP:PAR 31

'To couple Stimulus and Mode:
calculate2:measure2:transform:couple:parameters 9

Query Syntax

CALCulate<cnum>:MEASure<mnum>:TRANsform:COUPle:PARameters?

Return Type

Numeric

Default

29 (All parameters except 2 - Transform State)

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the center time for time domain measurements. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:TRAN:TIME:CENT 1e-8 calculate2:measure2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:CENTer?
Return Type | Numeric
Default | 0

CALCulate<cnum>:MEAsure<mnum>:TRANsform:TIME:IMPulse:WIDTh <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the impulse width for the transform window. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:MEAS:TRAN:TIME:IMP:WIDTh 10 calculate2:measure2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Numeric
Default | .98 / Default Span

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:KBESsel <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the parametric window for the Kaiser Bessel window. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:MEAS:TRAN:TIME:KBES 10 calculate2:measure2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:KBESsel?
Return Type | Numeric
Default | 6

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:LPFREQuency | LPFREQuency

Applicable Models: E5080A, M9485A

(Write-only) Sets the start frequencies in LowPass Mode. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:TRAN:TIME:LPFR calculate2:measure2:transform:time:lpfrequency
Query Syntax | Not Applicable
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:MARKer:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the measurement type in order to determine the correct marker distance.

  • Select Auto for S-Parameter measurements.

  • Select Reflection or Transmission for arbitrary ratio or unratioed measurements.

This setting affects the display of ALL markers for only the ACTIVE measurement.

Learn more about Distance Markers.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<char>

Choose from:

AUTO - If the active measurement is an S-Parameter, automatically chooses reflection or transmission. If non S-Parameter measurements, reflection is chosen.

REFLection - Displays the distance from the source to the receiver divided by two (to compensate for the return trip.)

TRANsmission - Displays the distance from the source to the receiver.

Examples

CALC:MEAS:TRAN:TIME:MARK:MODE REFL
calculate2:measure2:transform:time:marker:mode auto

Query Syntax

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:MARKer:MODE?

Return Type

Character

Default

AUTO

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:MARKer:UNIT <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the unit of measure for the display of marker distance values. This settings affects the display of ALL markers for only the ACTIVE measurement (unless Distance Maker Units are coupled using CALC:TRAN:COUP:PAR. Learn more about Distance Markers. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: METRs FEET INCHes
Examples | CALC:MEAS:TRAN:TIME:MARK:UNIT INCH calculate2:measure2:transform:time:marker:unit feet
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:MARKer:UNIT?
Return Type | Character
Default | METRs

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the span time for time domain measurements. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:TRAN:TIME:SPAN 1e-8 calculate2:measure2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:SPAN?
Return Type | Numeric
Default | 20 ns

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start time for time domain measurements. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:TRAN:TIME:STAR 1e-8 calculate2:measure2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STARt?
Return Type | Numeric
Default | -10 ns

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns the time domain transform capability ON or OFF. See Critical Note Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:MEAS:TRAN:TIME:STAT ON calculate2:measure2:transform:time:state off
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STEP:RTIMe <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the step rise time for the transform window. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:MEAS:TRAN:TIME:STEP:RTIM 1e-8 calculate2:measure2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Numeric
Default | .99 / Default Span

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STIMulus <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Choose from: STEP - simulates a step DUT stimulus IMPulse - simulates a pulse DUT stimulus STEP can ONLY be used when CALC:MEAS:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.) :STIM STEP will set :TYPE to LPASs :TYPE BPASs will set :STIM to IMPulse
Examples | CALC:MEAS:TRAN:TIME:STIM STEP calculate2:measure2:transform:time:stimulus impulse
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STIMulus?
Return Type | Character
Default | IMPulse

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop time for time domain measurements. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MEAS:TRAN:TIME:STOP 1e-8 calculate2:measure2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME:STOP?
Return Type | Numeric
Default | 10 ns

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of time domain measurement.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:MEAS:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:MEAS:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

:STIM STEP will set :TYPE to LPASs

:TYPE BPASs will set :STIM to IMPulse

Examples

CALC:MEAS:TRAN:TIME LPAS
calculate2:measure2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:MEASure<mnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Default

BPAS

Last modified:

6-Jan-2016

First Release


Control SCPI

Control Commands

Specifies the settings to remotely control the rear panel connectors, an external test set, and ECal Module state.

CONTrol

CHANnel:INTerface:CONTrol

| CONFig:RECall[STATe]

| [STATe]

ECAL:MODule

| PATH

| COUNt?

| STATe

HANDler - More Commands

MULTiplexer

| OUTPut

| A|B|C|D[DATA]

| A|B|C|D:VOLTage[DATA]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

  • See a pinout and detailed description of the rear panel connectors:

    • External Test Set IO connector

    • Material Handler IO connector

CONTrol:CHANnel:INTerface:CONTrol:CONFig:RECall[:STATe] <string>

Applicable Models: E5080A

(Write-only) Recalls an Interface Control configuration file. Learn more about Interface Control.
Parameters |
<string> | File name and extension (.xml) of the configuration file to recall. Files are typically stored in the default folder "D:\". To recall from a different folder, specify the full path name.
Examples | CONT:CHAN:INT:CONT:CONF:REC 'MyFile.xml' control:channel:interface:control:config:recall:state 'D:\MyFile01.xml'
Query Syntax | Not Applicable
Default | Not Applicable

CONTrol:CHANnel:INTerface:CONTrol[:STATe] <bool>

Applicable Models: E5080A

(Read-Write) Enables and disables ALL Interface Control settings. To send data, the individual interfaces must also be enabled. Learn more about Interface Control.
Parameters |
<bool> | OFF or 0 - Interface Control is disabled; NO control data is sent. ON or 1 - Interface Control is enabled.
Examples | CONT:CHAN:INT:CONT 1 control:channel:interface:control:state 0
Query Syntax | CONTrol:CHANnel:INTerface:CONTrol[:STATe]?
Return Type | Boolean
Default | OFF or 0

CONTrol:ECAL:MODule<num>:PATH:COUNt? <name>

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of unique states that exist for the specified path name on the selected ECal module.

This command performs exactly the same function as SENS:CORR:CKIT:ECAL:PATH:COUNt?

Use the CONT:ECAL:MOD:PATH:STAT command to set the module into one of those states.

Use SENS:CORR:CKIT:ECAL:PATH:DATA? to read the data for a state.

Parameters

<num>

Optional argument. USB number of the ECal module. If unspecified (only one ECal module is connected to the USB), <num> is set to 1. If two or more modules are connected, use SENS:CORR:CKIT:ECAL:LIST? to determine how many, and SENS:CORR:CKIT:ECAL:INF? to verify their identities.

<name>

Name of the path for which to read number of states. Choose from:

Reflection paths

  • A

  • B

  • C (4-port modules)

  • D (4-port modules)

Transmission paths

  • AB

  • AC (4-port modules)

  • AD (4-port modules)

  • BC (4-port modules)

  • BD (4-port modules)

  • CD (4-port modules)

Note: For each transmission path, the first of the available states is the through state, the second is the confidence (attenuator) state.

Examples

CONT:ECAL:MOD:PATH:COUNt? A

control:ecal:module2:path:count? cd

See example program

Return Type

Integer

Default

Not Applicable

CONTrol:ECAL:MODule<num>:PATH:STATe <path>, <stateNum>

Applicable Models: E5080A, M9485A

(Write-only) Sets the internal state of the selected ECAL module. This command supersedes CONT:ECAL:MOD:STAT.

  • Use CONT:ECAL:MOD:PATH:COUN? to read the number of unique states that exist for the specified path name on the module.

  • Use SENS:CORR:CKIT:ECAL:PATH:DATA? to read the data for a state (from the module memory) corresponding to the stimulus values of a channel.

Parameters

<num>

Optional argument. USB number of the ECal module. If unspecified (only one ECal module is connected to the USB), <num> is set to 1. If two or more modules are connected, use SENS:CORR:CKIT:ECAL:LIST? to determine how many, and SENS:CORR:CKIT:ECAL:INF? to verify their identities.

<path>

Path name for which to set a state.

Note: The impedance paths are not independent. For example, changing the impedance presented on path A will cause a change to the impedance on path B.

Choose from:

Reflection paths

  • A

  • B

  • C (4-port modules)

  • D (4-port modules)

Transmission paths

  • AB

  • AC (4-port modules)

  • AD (4-port modules)

  • BC (4-port modules)

  • BD (4-port modules)

  • CD (4-port modules)

<stateNum>

Number of the state to set. Refer to the following table to associate the <stateNum> with a state in your ECal module.

In addition, CONT:ECAL:MOD:PATH:COUNt? returns the number of states in the specified ECal module.

<stateNum> | N4432A and N4433A States | N4431A States | N469x States** | 8509x States
One-Port Reflection States
1 | Open | Open | Impedance 1 | Open
2 | Short | Short | Impedance 2 | Short
3 | Impedance 1 | Impedance 1 | Impedance 3 | Impedance 1
4 | Impedance 2 | Impedance 2 | Impedance 4 | Impedance 2
5 |  |  | Impedance 5 |
6 |  |  | Impedance 6 |
7 |  |  | Impedance 7 |
Two-Port Transmission States
1 | Thru | Thru | Thru | Thru
2 | Confidence | Confidence | Confidence | Confidence

** The following modules have only FOUR Impedance states (1, 2, 3, 4): N4690B ,N4691B ,N4692A ,N4696B.

Examples

CONT:ECAL:MOD:PATH:STATe A,5

control:ecal:module2:state BC,1

See example program

Query Syntax

Not Applicable

Default

Not Applicable

CONTrol:MULTiplexer<id>:OUTPut:<grp>[:DATA] <num>

Applicable Models: E5080A

(Read-Write) Sets or returns the output port data for specified group with id of the E5092A multiport test set.

Notes: This command is available only for E5092A multiport test set.

Parameters

<id>

Id of the multiport test set either 1 or 2. If unspecified, Id is assumed to be 1.

<grp>

A | B | C | D

<num>

An integer specifying the decimal value of the control line. Values are obtained by adding weights from the following table that correspond to individual lines.

The output port data range is between 0 to 255 (0=All line are turns OFF and 255 all lines are turn ON).

Line | Weight
1 | 1
2 | 2
3 | 4
4 | 8
5 | 16
6 | 32
7 | 64
8 | 128

Examples

CONT:MULT1:OUTP:B 8

Query Syntax

CONTrol:MULTiplexer<id>:OUTPut:<grp>[:DATa]?

Return Type

Numeric

Default

0

CONTrol:MULTiplexer<id>:OUTPut:<grp>VOLTage[:DATA] <volt>

Applicable Models: E5080A

(Read-Write) Sets or returns the output voltage for specified group with id of the E5092A multiport test set. Notes: This command is available only for E5092A multiport test set.
Parameters |
<id> | Id of the multiport test set either 1 or 2. If unspecified, Id is assumed to be 1.
<grp> | A | B | C | D
<volt> | Output voltage range for <grp> is between 0 to 5.2V and resolution is 10mV.
Examples | CONT:MULT1:OUTP:B:VOLT 4.2
Query Syntax | CONTrol:MULTiplexer<id>:OUTPut:<grp>:VOLtage[:DATa]?
Return Type | Numeric
Default | 0 V

Last Modified:

6-Jan-2016

First Release


CSET

CSET:Fixture Commands

Manages several aspects of Cal Sets.

CSET:

| CATalog?

| DALL

| DELete

| EXISts?

| FIXTure:

| DEEMbed

| EMBed

Click on a Red keyword to view the command details.

Note: There is no user-interface equivalent for some of these commands.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CSET:CATalog?

Applicable Models: E5080A, M9485A

This command replaces SENS:CORR:CSET:CAT? (Read-only) Returns the names of Cal Sets stored on the VNA.
Parameters | None
Examples | CSET:CAT? Returns: "CalSet_0913,CalSet_1,CalSet_2,CalSet_3,CalSet_4,CH1_CALREG,CH31_CALR EG,MyCalAll_SMC_002,MyCalAll_STD_001"
Return Type | Comma-separated string of names
Default | Not Applicable

CSET:DALL

Applicable Models: E5080A, M9485A

(Write-only) Deletes ALL Cal Sets from the VNA, including phase reference and Global Delta Match Cal Sets.
Parameters | None
Examples | CSET:DALL
Query Syntax | Not Applicable
Default | Not Applicable

CSET:DEL <string>

Applicable Models: E5080A, M9485A

This command replaces SENS:CORR:CSET:DELete

(Write-only) Deletes the specified Cal Set from the VNA.

  • If the Cal Set is currently being used by a channel, the Cal Set is deleted and correction for the channel is turned off.

  • If the Cal Set is not found, no error is returned.

Parameters

<string>

Name of the Cal Set to delete. Not case-sensitive.

Examples

CSET:DEL "MyCalSet"

Query Syntax

Not Applicable

Default

Not Applicable

CSET:EXISts? <string>

Applicable Models: E5080A, M9485A

(Read-only) Returns whether or not the specified Cal Set exists on the VNA.
Parameters |
<string> | Name or GUID of the Cal Set enclosed in quotes. The GUID must also be enclosed in curly brackets.
Examples | dim check check = CSET:EXISts? "MyCalSet" check = CSET:EXISts? "{7C4EEA5E-40D2-4D70-A048-33BFFE704163}"
Return Type | Boolean ON or 1 - Cal Set exists. OFF or 0 - Cal Set does NOT exist.
Default | Not Applicable

CSET:FIXTure:DEEMbed <cs1>,<cs2>,<s2p>,<port>, <compPwr>[,extrap]

Applicable Models: E5080A, M9485A

(Write-only) De-embeds a fixture from an existing Cal Set based on an S2P file. A new Cal Set is created with the effects of the fixture removed.

When the new Cal Set is applied to a channel, the effects of fixturing are removed from the measurement data. Do NOT enable fixturing. The effects of the fixture are removed when the new Cal Set is selected and correction is turned ON.

Parameters

<cs1>

(String) Name of an existing Cal Set which resides on the VNA.

<cs2>

(String) Name of new Cal Set which contains updated error terms with fixture de-embedded.

<s2p>

(String) Name of the S2P file which characterizes the adapter/fixture.

<port>

(Numeric) Port number from which fixture will be de-embedded.

<compPwr>

(Boolean)

ON (1) - When the Cal Set contains a power correction array for the fixture port, that array will be compensated for the fixture loss.

Warning: enabling power compensation can result in an increase in test port power and consequently, increased power to the DUT. Use with caution.

OFF (0) - Do not compensate for loss in source power through the fixture.

[extrap]

(Boolean) Optional argument.

ON (1) -Applies a simple extrapolation when the S2P file has a narrower frequency range than the Cal Set. The values for the first and last data points are extended in either direction to cover the frequency range of the Cal Set.

OFF (0) - Extrapolation is NOT performed (default setting).

Examples

CSET:FIXT:DEEM "MyCalSet","MyNewCalSet","Fixture.s2p",1,1

cset:fixture:deembed "MyCalSet","MyNewCalSet","Fixture.s2p",1,1,1 'extrapolation is performed if the s2p frequency range is narrower than that of the Cal Set.

Query Syntax

Not Applicable

Default

Not Applicable

CSET:FIXTure:EMBed <cs1>,<cs2>,<s2p>,<port>, <compPwr>[,extrap]

Applicable Models: E5080A, M9485A

(Write-only) Embeds a fixture (usually a matching network) into an existing Cal Set based on an S2P file. A new Cal Set is created with the effects of the matching network included in the correction data.

When the new Cal Set is applied to a channel, the effects of the fixture are included in the measurement data. Do NOT enable fixturing. The effects of the matching network are included when the new Cal Set is selected and correction is turned ON.

Parameters

<cs1>

(String) Name of an existing Cal Set which resides on the VNA.

<cs2>

(String) Name of new Cal Set which contains updated error terms with fixture embedded.

<s2p>

(String) Name of the S2P file which characterizes the fixture / matching network.

<port>

(Numeric) Port number to which fixture will be added.

<compPwr>

(Boolean)

ON (1) - Increase the source power to compensate for the loss through the fixture. The result is that the specified power level will be correct at the DUT input.

Warning: enabling power compensation can result in an increase in test port power and consequently, increased power to the DUT. Use with caution.

OFF (0) - Do not compensate for loss in source power through the matching network.

[extrap]

(Boolean) Optional argument.

ON (1) -Applies a simple extrapolation when the S2P file has a narrower frequency range than the Cal Set. The values for the first and last data points are extended in either direction to cover the frequency range of the Cal Set.

OFF (0) - Extrapolation is NOT performed (default setting).

Examples

CSET:FIXT:EMB "MyCalSet","MyNewCalSet","Fixture.s2p",1,1

cset:fixture:embed "MyCalSet","MyNewCalSet","Fixture.s2p",1,1,1 'extrapolation is performed if the s2p frequency range is narrower than that of the Cal Set.

Query Syntax

Not Applicable

Default

Not Applicable

Last Modified:

6-Jan-2016

First Release


Display SCPI

Display Commands

Controls the settings of the front panel screen.

DISPlay:

ANNotation

| FREQuency[STATe]

| MESSage:STATe

| [STATus]

ARRange

CATalog?

COLor More Commands

ENABle

FSIGn

MEASure

| DELete

| Feed

| MEMory

| MOVE

| SELect

| [STATe]

| TITLe:DATA

| TITLe[STATe]

| AUTO

| PDIVision

| RLEVel

| RPOSition

MEASurement

| FEED

SHEet

| ARRange

| CATalog

| STATe

| TITle

SPLit

STATus

| LOG

| CLEar

TMAX

TILE

TOOLbar

| CSET[STATe]

| ENTRy[STATe]

| MARKer[STATe]

UPDate

| IMMediate

| [STATe]

VISible

WINDow

| ANNotation

| MARKer

| COUPle

| NUMBer

| RESolution

| RESPonse

| STIMulus

| SIZe

| [STATe]

| SYMBol

| VISible

| XPOSition

| YPOSition

| TRACe[STATe]

| Y[STATe]

| CATalog?

| ENABle

| FEED

| NEXT[NUMBer]?

| SIZe

| [STATe]

| TABLe

| TITLe

| DATA

| [STATe]

| TRACe

| DELete

GRATicule:GRID:LTYPe

| TITLe

| DATA

| [STATe]

| Y[SCALe]

| COUPle

| METHod

| [STATe]

| Y[SCALe]

| Y:AUTO

Click on a Red keyword to view the command details.

See Also

  • Referring to Traces Channels Windows and Meas Using SCPI

  • See an example using some of these commands

  • Synchronizing the VNA and Controller

  • Learn about Screen Setup

  • SCPI Command Tree

DISPlay:ANNotation:FREQuency[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<bool> | ON or 1 - Turns frequency annotation ON. OFF or 0 - Turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean
Default | ON or 1

DISPlay:ANNotation:MESSage:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables error pop-up messages on the display.
Parameters |
<bool> | ON or 1 - Enables error pop-up messages OFF or 0 - Disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean
Default | ON or 1

DISPlay:ANNotation[:STATus] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<bool> | ON or 1 - Turns status bar ON. OFF or 0 - Turns status bar OFF.
Examples | DISP:ANN ON display:annotation:status off
Query Syntax | DISPlay:ANNotation[:STATus]?
Return Type | Boolean
Default | Last state that was set.

DISPlay:ARRange <char>

Applicable Models: E5080A, M9485A

(Write-only) Places EXISTING measurements into pre-configured window arrangements. Overlay, Stack(2), Split(3), and Quad(4) creates new windows.

Parameters

<char>

Window arrangement. Choose from:

  • TILE - tiles existing windows

  • CASCade - do nothing. Not supported on Nascar VNA. Exists for PNA BWCC.

  • OVERlay - all traces placed in 1 window. If there are more than 24 traces, use 2 windows. If more than 48, use 3 windows and so on.

  • STACk - 2 windows

  • SPLit - 3 windows

  • QUAD - 4 windows

  • MEASure - 1 window per measurement

  • CHANnel - 1 window per channel

Examples

DISP:ARR SPL
display:arrange overlay

Query Syntax

Not Applicable

Default

TILE

DISPlay:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the existing Window numbers. To read the window number of the selected trace, use Calc:Par:WNUM.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Default | Not Applicable

DISPlay:ENABLE <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<bool> | ON or 1 - Turns the display ON. OFF or 0 - Turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean
Default | ON or 1

DISPlay:FSIGn <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Shows or hides the window which displays global pass/fail results.
Parameters |
<bool> | ON or 1 - Displays the pass/fail dialog OFF or 0 - Hides the pass/fail dialog
Examples | DISP:FSIG ON display:fsign off
Query Syntax | DISPlay:FSIGn?
Return Type | Boolean
Default | OFF or 0

DISPlay:MEASure<mnum>:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes the trace associated with the specified measurement number. Note: The measurement is not deleted. This command does the reverse of DISP:MEAS:FEED.
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | DISP:MEAS:DEL display:measure2:delete
Query Syntax | DISPlay:MEASure<mnum>:DELete?
Return Type | Not Applicable
Default | Not Applicable

DISPlay:MEASure<mnum>:FEED

Applicable Models: E5080A, M9485A

(Write-only) This command creates a new trace in the specified window and connects the trace to measurement which results in the trace displaying the data from measurement.
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | DISP:MEAS:FEED display:measure:feed
Query Syntax | DISPlay:MEASure:FEED?
Return Type | Not Applicable
Default | Not Applicable

DISPlay:MEASure<mnum>:MEMory[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns the memory trace ON or OFF for the specified measurement. Note: DISP:MEAS:FEED must first be done to feed the measurement to a trace. This command behaves the same as DISP:WIND:TRAC:MEM[:STAT] except that it only requires the measurement number.
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON or 1 - Turns the memory trace ON. OFF or 0 - Turns the memory trace OFF.
Examples | DISP:MEAS:MEM ON display:measure:memory:state off
Query Syntax | DISPlay:MEASure<mnum>:MEMory[:STATe]?
Return Type | Boolean
Default | OFF

DISPlay:MEASure<mnum>:MOVE <toWin>

Applicable Models: E5080A, M9485A

(Write-only) Moves a trace associated with measurement number to the specified window. If the window is OFF, it will be turn ON.
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<toWin> | Number of the window to which the specified measurement is moved. If the window does not exist, it will be created.
Examples | DISP:MEAS:MOVE 2 display:measure:move 1
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:MEASure<mnum>:SELect

Applicable Models: E5080A, M9485A

(Write-only) Activates the specified measurement to be selected.
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | DISP:MEAS:SEL display:measure:select
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:MEASure<mnum>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the display of a trace associated with the specified measurement. When OFF, the measurement behind the trace is still active.

Note: A trace must first be created (via FEED), then the visibility of the trace can be affected with this command. If the trace has not been created, an error is generated: 107,Requested trace not found.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<bool>

ON or 1 - Turns the trace ON.
OFF or 0 - Turns the trace OFF.

Examples

DISP:MEAS:STAT ON
display:measure off

Query Syntax

DISPlay:MEASure<mnum>[:STATe]?

Return Type

Boolean

Default

ON or 1

DISPlay:MEASure<mnum>:TITLe:DATA <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or gets the title for the specified measurement. The trace title is embedded in the trace status field. Learn more about Trace Titles.

Newer entries replace (not append) older entries. The title is turned ON and OFF with DISP:WIND:TRAC:TITL:STAT.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<string>

Used as the title to be displayed for the measurement. Any characters (not spaces) enclosed with quotes.

Examples

DISP:MEAS:TITL:DATA 'MyNewMeas'
display:measure:title:data 'hello'

Query Syntax

DISPlay:MEASure<mnum>:TITLe:DATA?

Return Type

String

Default

Not Applicable

DISPlay:MEASure<mnum>:TITLe[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the measurement title. Note: The measurement and trace need to exist. When turned OFF, the previous trace title returns. Set a new trace title using DISP:WIND:TRAC:TITL:DATA Learn more about Trace Titles
Parameters |
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<bool> | ON or 1 - turns the title ON. OFF or 0 - turns the title OFF.
Examples | DISP:MEAS:TITL ON Display:measure:title:state off
Query Syntax | DISPlay:MEAS<mnum>:TITLe[:STATe]?
Return Type | Boolean
Default | OFF or 0

DISPlay:MEASure<mnum>:Y[:SCALe]:AUTO

Applicable Models: E5080A, M9485A

(Write-only) Performs an Autoscale on the specified trace in the specified measurement, providing the best fit display.

Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.

Autoscale behaves differently when scale coupling is enabled. How it behaves depends on the scale coupling method. Learn more.

See Also, DISPlay:WINDow:Y:AUTO which performs an Autoscale All.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

Examples

DISP:MEAS:Y:AUTO
display:measure:y:scale:auto

Query Syntax

Not Applicable

Default

Not Applicable

DISPlay:MEASure<mnum>:Y[:SCALe]:PDIVision <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Y axis Scale Per Division value of the specified trace associated with the specified measurement.

Note: The measurement and trace need to exist.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

Units / division value (Real value). The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:MEAS:Y:PDIV 1
display:measure:y:scale:pdivision maximum

Query Syntax

DISPlay:MEASure<mnum>:Y[:SCALe]:PDIVision?

Return Type

Numeric

Default

10

DISPlay:MEASure<mnum>:Y[:SCALe]:RLEVel <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Y axis Reference Level of the specified trace associated with the specified measurement.

Note: The measurement and trace need to exist.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

Reference level value (Real value). The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:MEAS:Y:RLEV 0
display:measure:y:scale:rlevel minimum

Query Syntax

DISPlay:MEASure<mnum>:Y[:SCALe]:RLEVel?

Return Type

Numeric

Default

0

DISPlay:MEASure<mnum>:Y[:SCALe]:RPOSition <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Reference Position of the specified trace associated with the specified measurement.

Note: The measurement and trace need to exist.

Parameters

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<num>

Reference position on the screen measured in horizontal graticules from the bottom (Real value). The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:MEAS:Y:RPOS 0
display:measure:y:rposition maximum

Query Syntax

DISPlay:MEASure<mnum>:Y[:SCALe]:RPOSition?

Return Type

Numeric

Default

5

DISPlay:SHEet<num>:ARRange <char>

Applicable Models: E5080A, M9485A

(Write-only) This command arranges existing windows to sheets.
Parameters |
<num> | Sheet number
<char> | Sheet arrangement. Choose from: WINDow: one sheet per window CHANnel: one sheet per channel ONE: merge all windows into one sheet
Examples | DISP:SHE:ARR CHAN display:sheet:arrange channel
Query Syntax | Not Applicable
Return Type | Not Applicable
Default | One sheet per window

DISPlay:SHEet<num>:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) This command reads and displays comma separated list of window numbers which the sheet contains.
Parameters |
<num> | Sheet number
Examples | DISP:SHE:FEED? display:sheet:feed?
Return Type | 1
Default | 1

DISPlay:SHEet<num>:STATe

Applicable Models: E5080A, M9485A

(Write-only) This command sets or gets the sheet label.
Parameters |
<num> | Sheet number
Examples | DISP:SHE:STAT ON display:sheet:state off
Query Syntax | Not Applicable
Return Type | Not Applicable
Default | OFF except for Sheet 1

DISPlay:SHEet<num>:TITle:DATA <char>

Applicable Models: E5080A, M9485A

(Read-Write) This command sets or gets the sheet label.
Parameters |
<num> | Sheet number
<char> | The label of the sheets. Default and present value is "Sheet 1"
Examples | DISP:SHE:TIT:DATA "Sheet 1" display:sheet:title:data "Sheet 1"
Query Syntax | DISPlay:SHEet:TITle:DATA?
Return Type | Character
Default | "Sheet 1"

DISPlay:SPLit <num>

Applicable Models: E5080A, M9485A

(Write-only) Destroys all existing traces, channels and windows, then creates N windows. No channels are created.
Parameters |
<num> | N is 1 or greater.
Examples | DISP:SPL display:split
Query Syntax | DISPlay:SPLit?
Return Type | Numeric
Default | Not Applicable

DISPlay:STATus:LOG:CLEar

Applicable Models: E5080A, M9485A

(Write-only) Clears the message region in the status bar.
Parameters |
Examples | DISP:STAT:LOG:CLE display:status:log:clear
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:TMAX <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Maximizes (isolates) or restores the active trace in the active window. When turned ON, the active trace is the ONLY trace on the display. All other traces are hidden. Learn more.
Parameters |
<bool> | ON or 1 - Maximize/isolates the active trace. OFF or 0 - Restores other traces to the normal window setting.
Examples | DISP:TMAX ON display:tmax 0
Query Syntax | DISPlay:TMAX?
Return Type | Boolean
Default | OFF or 0

DISPlay[:TILE | TILe]

This command is replaced by DISP:ARR

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Default | Not Applicable

DISPlay:TOOLbar:CSET[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Displays the Cal Set Viewer in the GUI. See this toolbar.
Parameters |
<bool> | ON or 1 - Toolbar ON. OFF or 0 - Toolbar OFF.
Examples | DISP:TOOL:CSET ON display:toolbar:cset:state off
Query Syntax | DISPlay:TOOLbar:CSET[:STATe]?
Return Type | Boolean
Default | OFF

DISPlay:TOOLbar:ENTRy[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to show or hide the active entry toolbar. See this toolbar.
Parameters |
<bool> | ON or 1 - Toolbar ON. OFF or 0 - Toolbar OFF.
Examples | DISP:TOOL:ENTR ON display:toolbar:entry:state off
Query Syntax | DISPlay:TOOLbar:ENTRy[:STATe]?
Return Type | Boolean
Default | ON

DISPlay:TOOLbar:MARKer[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to show or hide the marker toolbar. See this toolbar.
Parameters |
<bool> | ON or 1 - Toolbar ON. OFF or 0 - Toolbar OFF.
Examples | DISP:TOOL:MARK ON display:toolbar:marker:state off
Query Syntax | DISPlay:TOOLbar:MARKer[:STATe]?
Return Type | Boolean
Default | ON

DISPlay:UPDate:IMMediate

Applicable Models: E5080A, M9485A

(Write-only) Executes the display update once when the display update of the LCD screen is set to OFF (specifying False with the DISPlay:ENABle object).
Parameters |
Examples | DISP:UPD:IMM display:update:immediate
Query Syntax | Not Applicable
Return Type | Not Applicable
Default | Not Applicable

DISPlay:UPDate[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the display update.
Parameters |
<bool> | ON or 1 - Update is turns ON. OFF or 0 - Update is turns OFF.
Examples | DISP:UPD ON display:update:state off
Query Syntax | DISPlay:UPDate[:STATe]?
Return Type | Boolean
Default | ON

DISPlay:VISible <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Makes the VNA application visible or not visible. In the Not Visible state, the analyzer cycle time for making measurements, and especially data transfer, can be significantly faster because the display does not process data.
Parameters |
<bool> | ON (or 1) - VNA app is visible OFF (or 0) - VNA app is NOT visible
Examples | DISP:VIS ON display:visible off
Query Syntax | DISPlay:VISible?
Return Type | Boolean
Default | ON

DISPlay:WINDow<wnum>:ANNotation:LIMit:XPOSition <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the horizontal (X-axis) position where the limit line pass/fail annotation will appear in the display window. See other SCPI Limit commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<num> | X-axis position. Choose a value between 0 (far left) and 10 (far right).
Examples | DISP:WIND:ANN:LIM:XPOS 1.5 display:window:annotation:limit:xposition 5
Query Syntax | DISPlay:WINDow:ANNotation:LIMit:XPOSition?
Return Type | Numeric
Default | 7

DISPlay:WINDow<wnum>:ANNotation:LIMit:YPOSition <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the vertical (Y-axis) position where the limit line pass/fail annotation will appear in the display window. See other SCPI Limit commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<num> | Y-axis position. Choose a value between 0 (far left) and 10 (far right).
Examples | DISP:WIND:ANN:LIM:YPOS 1.5 display:window:annotation:limit:yposition 5
Query Syntax | DISPlay:WINDow:ANNotation:LIMit:YPOSition?
Return Type | Numeric
Default | 0

DISPlay:WINDow<wnum>:ANNotation:MARKer:COUPle[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the marker readouts to coupled (one combination annotation) or not coupled (one annotation per trace). This setting is per Window scope. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ON (or 1) - Marker readouts are coupled OFF (or 0) - Marker readouts are not coupled
Examples | DISP:WIND:ANN:MARK:COUP ON display:window:annotation:marker:couple on
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:COUPle?
Return Type | Boolean
Default | ON

DISPlay:WINDow<wnum>:ANNotation:MARKer:NUMBer <num>

Applicable Models: E5080A, M9485A

This command replaces DISP:WIND:ANN:MARK:SING (Read-Write) Sets the number of marker readouts to display per trace. Display up to 20 marker readouts per window. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<num> | Number of marker readouts to display. Choose a value between 1 and 10.
Examples | DISP:WIND:ANN:MARK:NUMB 7 display:window:annotation:marker:number 2
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:NUMBer?
Return Type | Numeric
Default | 5

DISPlay:WINDow<wnum>:ANNotation:MARKer:RESolution:RESPonse <num>

Applicable Models: E5080A, M9485A

(Read-Write) For the Y-axis (response), sets the number digits to display after the decimal point in marker readouts. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<num> | Number of digits to display. Choose a value between 1 and 4.
Examples | DISP:WIND:ANN:MARK:RES:RESP 1 display:window:annotation:marker:resolution:stimulus 2
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:RESolution:RESPonse?
Return Type | Numeric
Default | 2

DISPlay:WINDow<wnum>:ANNotation:MARKer:RESolution:STIMulus <num>

Applicable Models: E5080A, M9485A

(Read-Write) For the X-axis (stimulus), sets the number digits to display after the decimal point in marker readouts. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<num> | Number of digits to display. Choose a value between 2 and 6.
Examples | DISP:WIND:ANN:MARK:RES:STIM 2 display:window:annotation:marker:resolution:stimulus 4
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:RESolution:STIMulus?
Return Type | Numeric
Default | 3

DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE | SIZe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the size of the marker readout text. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<char> | Readout text size. Choose from:NORMal | LARGe
Examples | DISP:WIND:ANN:MARK:SIZ LARG display:window:annotation:marker:size normal
Query Syntax | DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE | SIZe?
Return Type | Character
Default | NORMal

DISPlay:WINDow<wnum>:ANNotation:MARKer[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to show or hide the Marker readout (when markers are ON) on the selected window. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ON or 1 - Turns marker readout ON. OFF or 0 - Turns marker readout OFF.
Examples | DISP:WIND:ANN:MARK ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer[:STATe]?
Return Type | Boolean
Default | ON

DISPlay:WINDow<wnum>:ANNotation:MARKer:SYMBol <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the symbol to display for marker position.

See other SCPI Marker commands.

Parameters

<wnum>

Any existing window number. If unspecified, value is set to 1.

<char>

Marker symbol. Choose from:

  • TRIangle

  • FLAG

  • LINE

See pictures of each

Examples

DISP:WIND:ANN:MARK:SYMB TRI

display:window:annotation:marker:symbol line

Query Syntax

DISPlay:WINDow:ANNotation:MARKer:SYMBol?

Return Type

Character

Default

TRIangle

DISPlay:WINDow<wnum>:ANNotation:MARKer:VISible <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Shows the marker readouts only for active trace or for all traces. This setting is per Window scope. See this toolbars
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ACTive - readout is turned on for active trace only. ALL - readout is turned on for all traces. OFF - readout is turned off for all traces.
Examples | DISP:WIND:ANN:MARK:VIS ACT display:windows:annotation:marker:visible all
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:VISible?
Return Type | Boolean
Default | OFF

DISPlay:WINDow<wnum>:ANNotation:MARKer:MEASure<mnum>:XPOSition <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the X-axis position of marker readouts. Readouts are right-justified at the specified position. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<mnum> | Measurement. If unspecified, value is set to 1.
<num> | X-axis position. Choose a value between 1 (far left) and 10 (far right).
Examples | DISP:WIND:ANN:MARK:MEAS:XPOS 1.5 display:window:annotation:marker:xposition 5
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:XPOSition?
Return Type | Numeric
Default | 10

DISPlay:WINDow<wnum>:ANNotation:MARKer:MEASure<mnum>:YPOSition <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Y-axis position of marker readouts. Readouts are top-justified at the specified position. See other SCPI Marker commands. Learn more about Marker readout.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<mnum> | Measurement. If unspecified, value is set to 1.
<num> | Y-axis position. Choose a value between 1 (bottom) and 10 (top).
Examples | DISP:WIND:ANN:MARK:MEAS:YPOS 1.5 display:window:annotation:marker:yposition 5
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:YPOSition?
Return Type | Numeric
Default | 10

DISPlay:WINDow<wnum>:ANNotation[:TRACe][:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the top of the display.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ON or 1 - Turns the buttons ON. OFF or 0 - Turns the buttons OFF.
Examples | DISP:WIND:ANN ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation[:TRACe][:STATe]?
Return Type | Boolean
Default | ON or 1

DISPlay:WINDow<wnum>:ANNotation: Y[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the Y-axis scale label in display window.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ON or 1 - Turns ON the Y-axis scale. OFF or 0 - Turns OFF the Y-axis scale.
Examples | DISP:WIND:ANN:Y ON display:window:annotation:y off
Query Syntax | DISPlay:WINDow:ANNotation:Y?
Return Type | Boolean
Default | ON or 1

DISPlay:WINDow<wnum>:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Return Type | String of Character values separated by commas
Default | Not Applicable

DISPlay:WINDow<wnum>:ENABle <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<bool> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean
Default | ON

DISPlay:WINDow<wnum>:FEED<snum>

Applicable Models: E5080A, M9485A

(Write-only) This command feeds a specified window to the sheet. If there is a window in the sheet, the sheet is visible. If there is no window in the sheet, the sheet is not visible. In exception to PNA BWCC: If no windows exists in the system, one empty sheet is visible.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<snum> | Sheet number
Examples | DISP:SHE:FEED display:sheet:feed
Query Syntax | Not Applicable
Return Type | Not Applicable
Default | Sheet 1

DISPlay:WINDow<wnum>:NEXT[:NUMBer]?

Applicable Models: E5080A, M9485A

(Read-only) Returns the lowest window number which has less than the maximum number of traces. Basically, returns the first window which has room for another trace. Note that the window may need to be turned on first (i.e. disp:wind:stat ON may be needed).
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
Examples | DISP:WIND:NEXT display:window1:NEXT
Query Syntax | DISPlay:WINDow<wnum>:NEXT?
Return Type |
Default |

DISPlay:WINDow<wnum>:SIZe<char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the window setting of Maximized, Minimized or Normal. To arrange all of the windows, use DISP:ARR.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1
<char> | Window size. Choose from: MAX | NORM
Examples | DISP:WIND:SIZ MAX display:window:size norm
Query Syntax | DISPlay:WINDow:SIZE?
Default | Not Applicable

DISPlay:WINDow<wnum>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) To create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between 1 and the maximum number of windows allowed in the VNA.
<bool> | ON or 1 - The window <wnum> is created. OFF or 0 - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA 'hello' display:window2:title:data 'hello'
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Default | Not Applicable

DISPlay:WINDow<wnum>:TITLe[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be re-displayed when turned back ON.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1
<bool> | ON or 1 - Turns the title string ON. OFF or 0 - Turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1. Note: This is NOT the trace number of the channel which appears as the Tr annotation on the Trace Status display. This <tnum> is the trace number within the specified window, and is used ONLY for remote programs.
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:WINDow:TRACe:GRATicule:GRID:LTYPE <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the grid line type (solid | dotted) for all open windows. Grid is returned to solid when the VNA is Preset. Learn more.
Parameters |
<value> | Line type. Choose from: SOLid - Solid lines DOTTed - Dotted lines
Examples | DISP:WIND:TRAC:GREAT:GRID:LTYPE SOL display:window:trace:graticule:grid:ltype dotted
Query Syntax | DISPlay:WINDow:TRACe:GRATicule:GRID:LTYPE?
Return Type | Character
Default | SOLID

DISPlay:WINDow:TRACe:Y[:SCALe]:COUPle:METHod <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the method of scale coupling. Learn more about Scale coupling.
Parameters |
<char> | OFF - NO scale coupling for any windows. WINDow - Scale settings are coupled for traces in each window. ALL - Scale settings are coupled for traces in ALL selected windows. Enable the selected windows using DISP:WIND:TRAC:Y:COUP ON
Examples | DISP:WIND:TRAC:Y:COUP:METH ALL Display:window2:trace:y:scale:method window
Query Syntax | DISPlay:WINDow:TRACe:Y[:SCALe]:COUPle:METHod?
Return Type | Character
Default | OFF

DISPlay:WINDow<wnum>:TRACe:Y[:SCALe]:COUPle[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables scale coupling for the specified window. Learn more about Scale coupling.
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1 Use Disp:Cat? to read the existing window numbers.
<bool> | ON or 1 - Scale coupling enabled for specified window. OFF or 0 - Scale coupling disabled for specified window.
Examples | DISP:WIND:TRAC:Y:COUP ON Display:window2:trace:y:scale:couple:state off
Query Syntax | DISPlay:WINDow<wnum>:TRACe:Y[:SCALe]:COUPle[:STATe]?
Return Type | Boolean
Default | ON or 1

DISPlay:WINDow<wnum>:Y[:SCALe]:DIVisions <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the number of divisions in all the graphs, for the selected channel
Parameters |
<wnum> | Any existing window number. If unspecified, value is set to 1 Use Disp:Cat? to read the existing window numbers.
<bool> | ON or 1 - Scale coupling enabled for specified window. OFF or 0 - Scale coupling disabled for specified window.
<num> | Number of divisions is between 4 to 30. Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:Y:DIV 12 Display:window2:y:scale:divisions 12
Query Syntax | DISPlay:WINDow<wnum>:Y[:SCALe]:DIVisions?
Return Type | Boolean
Default | 10

DISPlay:WINDow<wnum>:Y:AUTO

Applicable Models: E5080A, M9485A

(Write-only) Scales ALL of the traces to fit in the same window. This is equivalent to "Autoscale All" from the front panel.

Autoscale behaves differently when scale coupling is enabled. How it behaves depends on the scale coupling method. Learn more.

Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.

See Also, DISPlay:WINDow:TRACe:Y:AUTO which Autoscales only the specified trace.

Parameters

<wnum>

Any existing window number. If unspecified, value is set to 1.

Use Disp:Cat? to read the existing window numbers.

Examples

DISP:WIND:Y:AUTO
display:window2:y:auto

Query Syntax

Not Applicable

Default

Not Applicable

Last modified:

6-Jan-2016

First Release


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data.

FORMat:

BORDer

[DATA]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

FORMat:BORDer <char>

Applicable Models: E5080A, M9485A

(Read-Write) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.
Parameters |
<char> | Choose from: NORMal - Use when your controller is anything other than an IBM compatible computers. SWAPped - for IBM compatible computers. Note: Use NORMal if you are using VEE, LabView or T&M Tool kit.
Examples | FORM:BORD SWAP format:border normal
Query Syntax | FORMat:BORDer?
Return Type | Character
Default | Normal

FORMat[:DATA] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the data format for transferring measurement data and frequency data.

  • To transfer measurement data, use CALC:DATA.

  • To transfer Cal Set data, use SENS:CORR:CSET:DATA

  • To transfer Source Power correction data, use:

  • SOURce:POWer:CORRection:COLLect:TABLe:DATA

  • SOURce:POWer:CORRection:COLLect:TABLe:FREQuency

  • SOURce:POWer:CORRection:DATA

  • To transfer FIFO buffer data, use SYST:FIFO:DATA?

The following commands transfer frequency data. Use <REAL, 64>

  • CALC:DATA:SNP?

  • CALC:DATA:SNP:PORTS?

  • CALC:X?

  • SENS:X?

Use FORMat:BORDer to change the byte order. Use “NORMal” when transferring a binary block from LabView or VEE. For other programming languages, you may need to SWAP the byte order.

Parameters

<char>

In the VNA, measurement data is stored as 32 bit and frequencies stored as 64 bit. Therefore, use REAL,32 when getting data and REAL,64 when getting frequencies. That way you are guaranteed to avoid losing any precision as well as getting the maximum speed on the data transfer.

Choose from:

  • REAL,32 - (default value for REAL) Best for transferring large amounts of measurement data. Can cause rounding errors in frequency data.

  • REAL,64 - Slower but has more significant digits than REAL,32. REQUIRED to accurately represent frequency data. See above list for commands which transfer frequency information.

  • ASCii,0 - The easiest to implement, but very slow. Use when you have small amounts of data to transfer.

Note: The REAL,32 and REAL,64 arguments transfer data in block format as explained in Transferring Measurement Data.

Note: The default value for REAL of the E507x, E506x is REAL, 64.

Examples

FORM REAL,64
1format:data ascii

Query Syntax

FORMat:DATA?

Return Type

Character,Character

Default

ASCii,0

Syst:Preset does NOT reset this command.

However, *RST does reset this command to ASCii,0

Last Modified:

6-Jan-2016

First Release


Hardcopy SCPI

Hardcopy Command

Controls printing of the VNA screen and optional data to a printer or a file.

HCOPy:

[IMMediate]

FILE

SDUMP

| DATA?

| FORMat

Click on a Red keyword to view the command details.

See Also

  • Learn more about VNA Printing

  • Example Programs

  • Synchronizing the VNA and Controller

HCOPy[:IMMediate]

Applicable Models: E5080A, M9485A

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Default | Not Applicable

HCOPy:FILE <filename>

Applicable Models: E5080A, M9485A

(Write-only) Saves the screen image to a file. The image does NOT include the optional print data invoked by many HCOPy commands.
Parameters |
<filename> | Name of the file to save the screen to. The file is saved to the current working directory unless a valid full path name is specified. Use one of the following suffixes: .bmp - not recommended due to large file size .jpg - not recommended due to poor quality .png - recommended
Examples | HCOPY:FILE "myFile.png" hcopy:file "D:\myfile.png"
Query Syntax | Not Applicable
Default | Not Applicable

HCOPy:SDUMp:DATA?

Applicable Models: E5080A, M9485A

(Read-only) Returns the display image in a definite-length arbitrary binary block. The format of the data is PNG by default. Use HCOP:SDUM:DATA:FORM to change the format.

This command is equivalent to saving an image to the VNA (HCOPy:FILE) and then using MMEM:TRAN to transfer the file to the computer.

Examples

HCOP:SDUM?

hcopy:sdump?

Return Type

A definite-length arbitrary binary block

Default

Not Applicable

HCOPy:SDUMp:DATA:FORMat <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the graphic format for HCOPy:SDUMp:DATA?
Parameters |
<char> | Choose from: JPG | BMP | PNG
Examples | HCOP:SDUMp:DATA:FORMat BMP
Query Syntax | HCOPy:SDUMp:DATA:FORMat?
Return Type | Character
Default | PNG

Last modified:

6-Jan-2016

First Release


Initiate SCPI

Initiate Commands

Controls triggering signals

INITiate:

CONTinuous

[IMMediate]

Click on a Red keyword to view the command details.

See Also

  • Example Triggering the VNA

  • Learn about Triggering

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

INITiate:CONTinuous <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether the VNA trigger source is set to Internal (continuous) or Manual.

  • For SIMPLE, single-triggering of a single channel, use SENS:SWE:MODE SING which sets the number of trigger signals each channel will ACCEPT (Continuous, Groups, Single, or HOLD - none.)

  • This command is a subset of TRIG:SEQ:SOURce, which can also set the trigger source to External.

  • See a map of user interface to SCPI triggering commands.

  • For more information on triggering, see the VNA Trigger Model.

  • See the Example program: Triggering the VNA using SCPI.

Parameters

<bool>

ON (or 1) - Internal (continuous) trigger.

OFF (or 0) - Manual sweep. Use INIT:IMMediate to send a trigger signal

Examples

INIT:CONT ON
initiate:continuous off

Query Syntax

INITiate:CONTinuous?

Return Type

Boolean (1 = ON, 0 = OFF)

Default

ON

INITiate<cnum>[:IMMediate]

Applicable Models: E5080A, M9485A

(Write-only) Stops the current sweeps and immediately sends a trigger. (Same as Manual Trigger! in the Trigger dialog box.)

  • This command requires Trigger:Source to be set to Manual. This causes ONE trigger signal to be SENT each time INIT:IMM is issued.

  • For SIMPLE, single-triggering of a single channel, use SENS:SWE:MODE SING which sets the number of trigger signals each channel will ACCEPT (Continuous, Groups, Single, or HOLD - none.)

See the Example program: Triggering the VNA using SCPI

Note: An SMC Fixed Output measurement cannot be triggered using this command. For more information, see the example program.

To trigger ALL channels in turn:

Set ALL channels to Sens<ch>:Sweep:Mode Continuous. The <ch> argument in INIT<ch>:IMM is ignored.

Then…

  • TRIG:SCOP ALL triggers ALL channels (in sequence) each time Init:Imm is sent.

  • TRIG:SCOP CURRent triggers ONLY the NEXT channel each time Init:Imm is sent.

To trigger ONLY a specified channel:

  1. Set ALL channels to Sens<ch>:Sweep:Mode HOLD

  2. Send TRIG:SCOP CURRent

  3. Send Init<ch>:Imm where <ch> is the channel to be triggered.

Advanced Situations that require some channels to be in CONT and others in HOLD are rare. The following describes the behavior of the Init:Imm command in these situations:

When Trigger:Scope = Global:

  • If the SPECIFIED <cnum> channel is in hold mode, it is put in single trigger (accepts 1 trigger signal) and goes to the end of the queue of channels to be triggered. The other 'non-hold' channels are triggered. The next Init:Imm triggers the specified channel first.

For example: ch1 is in Hold, ch2 and ch3 are in CONT and we send INIT1:IMM

    • On the first INIT:IMM, ch2 and ch3 is triggered.

    • next INIT:IMM, ch1, ch2, ch3 is triggered.

    • next INIT:IMM, ch2 and ch3 is triggered.

    • next INIT:IMM, ch1, ch2, ch3 is triggered, and so forth.

When Trigger:Scope = Channel

  • Only ONE channel is triggered for each issued INIT<ch>:IMM command.

  • If the specified channel is in hold, it is put in single trigger (accepts 1 trigger signal) and goes the end of the queue of channels to be triggered as in the 'Global' example.

This is one of the VNA overlapped commands. Learn more.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not Applicable

Default

Not Applicable

Last modified:

6-Jan-2016

First Release


Memory SCPI

Memory Commands

The memory commands control saving and loading instrument states and measurement trace data to the hard drive. To read and write trace data in GPIB format, see CALC:DATA.

MMEMory:

CATalog?

| CORRection?

| CSARchive?

| CSTate?

| [:FILE]?

| STATe?

CDIRectory

COPY

DATE?

DELete

LOAD

| ASCFactor

| BSCFactor

| CORRection

| CSARchive

| ENR

| [:FILE]

| LIMit

| RLIMit

| SEGMent

| STATe

MDIRectory

MOVE

RDIRectory

STORe

| ASCFactor

| BSCFactor

| CORRection

| CSARchive

| CSTate

| CSV:FORMat

| DATA

| ENR

| [FILE]

| LIMit

| PLOSs

| RLIMit

| SEGMent

| SSCReen

| STATe

| TRACe

| TRACe

| FORMat

| SNP

TRANsfer

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Save/Recall and File Types

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Specifying Path Names

The MMEM commands use the following rules to specify path names:

  • The default folder is "D:\" Learn more.

  • You can change the active directory using MMEMory:CDIRectory.

  • Specify only the file name if using the active directory.

  • You can also use an absolute path name to specify the folder and file.

MMEMory:CATalog[:<char>]? [<folder>]

Applicable Models: E5080A, M9485A

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned. Learn about File Types

Parameters

<char>

The type of files to list. Choose from:

  • CORRection - Calibration Data (.cal)

  • CSARchive - Instrument state and calibration data (.csa)

  • CSTate - Instrument state and link to Calibration data (.cst)

  • [:File]

  • STATe - Instrument states (.sta)

If unspecified then ALL file types (even unknown types) are listed.

<folder>

String - Any existing folder name. See Specifying Path Names

Examples

MMEM:CAT? 'lists all files from the current folder
mmemory:catalog:correction? c:\users\public\documents\Network analyzer\Documents' 'lists .cal files from the specified folder

Default

Not Applicable

MMEMory:CDIRectory <folder>

Applicable Models: E5080A, M9485A

(Read-Write) Changes the folder name.
Parameters |
<folder> | Any drive and folder name that already exists. If the same level as the default path, then no punctuation is required. MMEM:CDIR Service If the new folder is at a different level than the default, use a slash (/) before the folder name and enclose in quotes. mmemory:cdirectory '/automation' 'changes default directory up one level. You can use an absolute path to specify the new folder. mmemory:cdirectory 'c:/automation/service'
Query Syntax | MMEMory:CDIRectory? 'Returns the current folder name
Return Type | String
Default | See Specifying Path Names

MMEMory:COPY <file1>,<file2>

Applicable Models: E5080A, M9485A

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | String - Name of the file to be copied. See Specifying Path Names
<file2> | String - Name of the file to be created from file1.
Examples | MMEM:COPY 'MyFile.cst','YourFile.cst'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:DATE? <fileName>

Applicable Models: E5080A, M9485A

(Read-only) Returns the (year, month, day) that the specified file was last saved.

To query the last date and time a cal set was modified, use CSET DATE? and CSET:TIME?

See Also

MMEM:TIME?

Parameters

<fileName>

String - File name. See Specifying Path Names

Example

MMEM:DATE? "myFile.txt"

'Returns

+2013,+4,+12

mmemory:date? "c:\users\public\documents\Network analyzer\UserCalSets\Calset_18.pcs"

'Returns

+2013,+4,+12

Return Type

Comma-separated integers

Default

Not applicable

MMEMory:DELete <file>

Applicable Models: E5080A, M9485A

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | String - Name of the file to be deleted. See Specifying Path Names
Examples | MMEM:DEL 'MyFile.cst'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:LOAD[:<char>] <file>

Applicable Models: E5080A, M9485A

(Write-only) Loads the specified file. Learn about File Types

Parameters

<char>

The type of file to load. Choose from:

  • ASCFactor

  • BSCFactor

  • CORRection - Calibration Data (.cal)

  • CSARchive - Instrument state and calibration data (.csa)

  • ENR - Excess Noise Source data (Noise Figure App only)

  • [:File]

  • SEGMent

  • STATe - Instrument states (.sta)

  • When <char> is ENR, then include CAL, - See example below.

  • *.sNp files CAN be recalled to the VNA although no <char> is used. See example below.

If <char> is unspecified, the extension must be included in the filename.

If an extension is specified in <file> that does not agree with <char> then no action is taken.

<file>

String - Name of the file to be loaded. See Specifying Path Names

Examples

MMEM:LOAD 'MyFile.cst'
mmemory:load:state 'MyInstState'

MMEM:LOAD:ENR CAL, C:/data/calset/346C_16500.enr"

MMEM:LOAD "MyFile.s2p"

Query Syntax

Not Applicable

Default

Not Applicable

MMEMory:LOAD:LIMit <file>

Applicable Models: E5080A, M9485A

(Write-only) Load limit test data from a CSV file.
Parameters |
<file> | A file path by string format. The CSV file shall have header lines and a title row as follows. "# E5080 Limit Test" "# Revision: 1.00" TYPE,BEGIN STIMULUS,END STIMULUS,BEGIN RESPONSE,END RESPONSE
Examples | MMEM:LOAD:LIM 'MyFile.csv'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:LOAD:RLIMit <file>

Applicable Models: E5080A, M9485A

(Write-only) Load ripple limit test data from a CSV file.
Parameters |
<file> | A file path by string format. The CSV file shall have header lines and a title row as follows. "# E5080 Ripple Limit Test" "# Revision: 1.00" TYPE,BEGIN STIMULUS,END STIMULUS,MAX RIPPLE
Examples | MMEM:LOAD:RLIM 'MyFile.csv'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:MDIRectory <folder>

Applicable Models: E5080A, M9485A

(Write-only) Makes a folder.
Parameters |
<folder> | String - Name of the folder to make. See Specifying Path Names
Examples | MMEM:MDIR 'MyFolder' mmemory:mdirectory 'c:/NewFolder'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:MOVE <file1>,<file2>

Applicable Models: E5080A, M9485A

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | String - Name of the file to be renamed. See Specifying Path Names
<file2> | String - Name of the new file.
Examples | MMEM:MOVE 'MyFile.cst','YourFile.cst'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:RDIRectory <folder>

Applicable Models: E5080A, M9485A

(Write-only) Removes the specified folder.
Parameters |
<folder> | String - Name of the folder to remove. See Specifying Path Names.
Examples | MMEM:RDIR 'MyFolder'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:STORe[:<char>] <file>

Applicable Models: E5080A, M9485A

(Write-only) Stores the specified file (.sta, .cal, .cst, .csa, .snp, s2px).

Learn about saving SNP files on the VNA.

Learn about saving S2Px files on the VNA.

To save other data files, use MMEM:STOR:DATA.

To save ENR files, use MMEMory:STORe:ENR

Parameters

<char>

Optional argument. The type of file to store. Choose from:

  • ASCFactor

  • BSCFactor

  • CORRection - Calibration Data (.cal)

  • CSARchive - Instrument state and calibration data (.csa)

  • CSTate - Instrument state and link to Calibration data (.cst)

  • CSV:FORMat

  • ENR

  • [:File]

  • PLOSs

  • SEGMent

  • SSCReen

  • STATe - Instrument states (.sta)

  • STATe:TRACe

  • TRACe

No <char> is specified for s1p, s2p, s2px and so forth.

Include either <char> or the file extension. If both <char> and the extension are specified, they must agree or an error is returned and no action is taken. See examples below.

Learn about File Types

<file>

String - Name of any valid file that does not already exist. See Specifying Path Names

Examples

MMEM:STOR:STAT 'myState'

mmemory:store 'c:/bin/myState.sta'

MMEM:STOR 'MyData.S2P'

Query Syntax

Not Applicable

Default

Not Applicable

MMEMory:STORe:DATA <filename>,<type>,<scope>,<format>,<selector>

Applicable Models: E5080A, M9485A

(Write-only) Stores trace data to the following file types: *.prn, *.cti, *.csv, *.mdf

To save snp files, use Calc:Data:SNP:PORTs:SAVE

To save state and calibration files, use MMEM:STORe

This command replaces the following:

  • MMEMory:STORe:CITifile:DATA

  • MMEMory:STORe:CITifile:FORMat

  • MMEMory:STORe:TRACe:CONTent:CITifile

  • MMEMory:STORe:TRACe:FORMat:CITifile

NOTE: Not all choices are valid with other arguments. See Valid parameter combinations below.

Parameters

<filename>

(String) Name and extension of the file to which data will be saved. If the extension does not agree with the file type, an error is NOT returned but the data may NOT be what you expect.

See rules for specifying a filename.

<type>

(String) File type to save. Choose from:

"PRN Trace Data" - *.prn data. Learn more.

"Citifile Data Data" - unformatted *.cti data. Learn more.

"Citifile Formatted Data" - formatted *.cti data.

"CSV Formatted Data" - formatted *.csv data. Learn more.

"MDIF Data" - *.mdf data. Learn more.

"GCA Sweep Data" - Gain compression data. Learn more. (Excepts E5080A, M9485A)

"IMD Sweep Data" - Swept IMD data. Learn more. (Excepts E5080A, M9485A)

<scope>

(String) How much data to save. Choose from:

"Trace" - only the specified measurement number is saved.

"Displayed" - all displayed measurements are saved.

"Channel" - all measurements that are in the channel in which the selected measurement reside are saved.

"Auto"

For all Standard Meas Class (S-parameter) channels:

  • When correction is OFF, the specified trace is saved.

  • When correction is ON, all corrected parameters associated with the calibrated ports in the Cal Set are saved.

For all other channels:

  • When correction is OFF or ON, the specified trace is saved.

<format>

The format in which data is saved. Choose from:

"Displayed" - the format is the same as that in which it is displayed on the VNA screen.

"RI" - Real / Imaginary

"MA" - Magnitude / Angle

"DB" - LogMag / Degrees

<selector>

(Integer) Choose from:

-1 Use when <scope> = "Displayed" (does NOT require a selected trace).

<measurement number> Use for all other <scope> selections. Use Calc:Par:MNUM? to read the measurement number of the selected trace.

The following are valid parameter combinations for ALL measurement classes:

Parameters
<type> (String) | <scope> (String) | <format> (String) | <selector> (Numeric)
"PRN Trace Data" | "Trace" | "Displayed" | Measurement number
Example: MMEMory:STORe:DATA "myData.prn","PRN Trace Data","Trace","Displayed",2
"Citifile Data Data" | "Trace" or "Auto" or "Channel" | "RI" | Measurement number
 | "Displayed" | "RI" | -1
Example: MMEMory:STORe:DATA "myData.cti","Citifile Data Data","AUTO","RI",3
"Citifile Formatted Data" | "Trace" or "Auto" | "RI" or "MA" or "DB" | Measurement number
 | "Channel" | "RI" or "MA" or "DB" or "Displayed" | Measurement number
 | "Displayed" | "RI" or "MA" or "DB" or "Displayed" | -1
Example: MMEMory:STORe:DATA "myData.cti","Citifile Formatted Data","AUTO","MA",3
"CSV Formatted Data" | "Trace" or "Auto" or "Channel" | "RI" or "MA" or "DB" or "Displayed" | Measurement number
 | "Displayed" | "RI" or "MA" or "DB" | -1
Example: MMEMory:STORe:DATA "myData.csv","CSV Formatted Data","displayed","RI",-1
"MDIF Data" | "Trace" or "Auto" | "RI" or "Displayed" or "Channel" | Measurement number
 | "Displayed" | "RI" or "Displayed" | -1
Example: MMEMory:STORe:DATA "myData.mdf","MDIF Data","displayed","displayed",-1
The following parameter combinations save *.csv files in specific formats for GCA and Swept IMD classes: (Excepts E5080A, M9485A)
Parameters
<type> (String) | <scope> (String) | <format> (String) | <selector> (Numeric)
"GCA Sweep Data" | "Auto" | "DB" | GCA channel number
Example: MMEMory:STORe:DATA "myData","gca sweep data","displayed","displayed",-1
"IMD Sweep Data" | "Auto" | "DB" | Swept IMD channel number
Example: MMEMory:STORe:DATA "myData.mdf","MDIF Data","displayed","displayed",-1
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:STORe:ENR <file>

Applicable Models: E5080A, M9485A

(Write-only) Stores an ENR (Excess Noise Source) data. (Noise Figure App only) To set and read ENR data, use SENS:CORR:ENR:CAL:TABLE:DATA.
Parameters |
<file> | String - Name of any valid file that is not already in existence. See Specifying Path Names
Examples | MMEM:STOR:ENR "C:/data/calset/346C_16500.enr"
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:STORe:LIMit <file>

Applicable Models: E5080A, M9485A

(Write-only) Saves limit test data into a CSV file.
Parameters |
<file> | A file path by string format. The CSV file shall have header lines and a title row as follows. "# E5080 Limit Test" "# Revision: 1.00" TYPE,BEGIN STIMULUS,END STIMULUS,BEGIN RESPONSE,END RESPONSE
Examples | MMEM:STOR:LIM 'MyFile.csv'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:STORe:RLIMit <file>

Applicable Models: E5080A, M9485A

(Write-only) Saves ripple limit test data into a CSV file.
Parameters |
<file> | A file path by string format. The CSV file shall have header lines and a title row as follows. "# E5080 Ripple Limit Test" "# Revision: 1.00" TYPE,BEGIN STIMULUS,END STIMULUS,MAX RIPPLE
Examples | MMEM:STOR:RLIM 'MyFile.csv'
Query Syntax | Not Applicable
Default | Not Applicable

MMEMory:STORe:TRACe:FORMat:SNP <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the format of subsequent .s1p, .s2p, .s3p; s4p save statements. Learn more. To save SNP data, use CALC:DATA:SNP:PORTs:SAVE
Parameters |
<char> | Choose from: MA - Linear Magnitude / degrees DB - Log Magnitude / degrees RI - Real / Imaginary AUTO - data is output in currently selected trace format. If other than LogMag, LinMag, or Real/Imag, then output is in Real/Imag.
Examples | MMEM:STOR:TRAC:FORM:SNP MA
Query Syntax | MMEMory:STORe:TRACe:FORMat:SNP?
Return Type | Character
Default | Auto

MMEMory:TRANsfer <fileName>,<dataBlock>

Applicable Models: E5080A, M9485A

(Read-Write) Transfers data between the VNA and an external controller. Other MMEM commands transfer data between the VNA application and the VNA hard drive. If <fileName> already exists, it will be overwritten. The file must be no larger than 20MB. To read trace data from the VNA in block format, use CALC:DATA.
Parameters |
<fileName> | String - File name. See Specifying Path Names
<dataBlock> | Block Data - The contents of the file. The data block is a block of binary data. Use the following syntax: #<num digits><byte count><data bytes><NL><END> where: <num_digits> specifies how many digits are contained in <byte_count> <byte_count> specifies how many data bytes will follow in <data bytes>
Example | See example program
Query Syntax | MMEMory:TRANsfer? <fileName> Reads block data from the specified file location.
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


Output SCPI

Output Commands

Controls output functions: RF power and Noise Source.

OUTPut:

[STATe]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

OUTPut[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns RF power from the source ON or OFF. See note about source power state with instrument state save and recall.
Parameters |
<bool> | ON (or 1) - turns RF power ON OFF (or 0) - turns RF power OFF
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

Last modified:

6-Jan-2016

First Release


Average SCPI

Sense:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

SENSe:AVERage

| CLEar

| COUNt

| MODE

| [STATe]

Click on a Red keyword to view the command details.

See Also

  • Example using some of these commands

  • Learn about Averaging

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:AVERage:CLEar

Applicable Models: E5080A, M9485A

(Write-only) Clears and restarts averaging of the measurement data. Does NOT apply to point averaging.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of measurements to combine for an average. Must also set SENS:AVER[:STAT] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurements to average. Choose any number between 1 and 65536 (2^16).
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Numeric
Default | 1

SENSe<cnum>:AVERage:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of averaging to perform: Point or Sweep.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<char>

Averaging Type. Choose from:

POINT - Averaging measurements are made on each data point before stepping to the next data point. (Not available on 'C' models).

SWEEP - Averaging measurements are made on subsequent sweeps until the required number of averaging sweeps are performed.

Examples

SENS:AVER:MODE POIN
sense2:average:mode sweep

Query Syntax

SENSe<cnum>:AVERage:MODE?

Return Type

Character

Default

Sweep

SENSe<cnum>:AVERage[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<bool> | ON or 1 - Turns averaging ON. OFF or 0 - Turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean
Default | OFF

Last modified:

6-Jan-2016

First Release


Sense Bandwidth SCPI

Sense:Bandwidth Commands

SENSe:BANDwidth | BWIDth:

[RESolution]

TRACk

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about IF Bandwidth

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. (Use either Sense:Bandwidth or Sense:Bwidth)
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the VNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number. This parameter supports MIN and MAX as arguments. Learn more.
Examples | SENS:BWID 1KHZ sense2:bandwidth:resolution 1000
Query Syntax | SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?
Return Type | Numeric
Default | Varies with VNA model.

SENSe<cnum>:BANDwidth | BWIDth:TRACk <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the state of the Reduce IF BW at Low Frequencies feature. (Use either Sense:Bandwidth:Track or Sense:Bwidth:Track).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | Choose from: ON or 1 - Reduce IF BW at Low Frequencies is set ON. OFF or 0 - Reduce IF BW at Low Frequencies is set OFF.
Examples | SENS:BWID:TRAC OFF sense2:bandwidth:track 1
Query Syntax | SENSe<cnum>:BANDwidth | BWIDth:TRACk?
Return Type | Boolean
Default | ON

Last Modified:

6-Jan-2016

First Release


Class

Sense:Class Command

SENSe:CLASs:

NAME?

Click on a Red keyword to view the command details.

See Also

  • Learn about Measurement Class

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:CLASs:NAME?

Applicable Models: E5080A, M9485A

(Read-only) Returns the measurement class name of the specified channel.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:CLAS:NAME? sense2:class:name? For a standard S-Parameter channel, returns... "Standard"
Default | Not applicable

Last Modified:

6-Jan-2016

First Release


Sense Correction SCPI

Sense:Correction Commands

Performs and applies calibration and other error correction features.

  • To perform a Guided Calibration, use ONLY the Sens:Corr Coll:GUIDed commands.

  • To perform an Unguided Calibration, do NOT use the Sens:Corr:Coll:Guided commands.

  • See the "Unguided" example programs for clarification.

SENSe:CORRection

CCHeck

| [ACQuire]

| DONE

| PARameter

CKIT - More Commands

COLLect

| [ACQuire]

| APPLy

| CKIT - More Commands

| DISPlay:WINDow

| AOFF

| [STATe]

| GUIDed - More Commands

| ISOLation:

| AVER:INCRement

| ECAL:[:STATe]

| METHod

| SAVE

| SESSion - More Commands

| SWEep:CHANnel

| AOFF

| [STATe]

CSET - More Commands

EXTension - More Commands

GCSetup

| POWer

| SENSor:

| CKIT

| CONNector

IMPedance:INPut

| MAGNitude

INTerpolate[:STATe]

ISOLation[:STATe]

METHods:MATCh

PREFerence

| CALibration

| [FOM:]RANGe

| CSET

| SAVE

| ECAL

| ORIentation

| PMAP

| TRIG:FREE

RPOWer:OFFSet

| [AMPLitude]

RVELocity

| COAX

SFOWard

| [STATe]

[STATe]

TCOLd:USER:VALue

TSTandards

| [STATe]

TYPE

| CATalog?

Click on a Red keyword to view the command details.

Red commands are superseded.

See Also

  • Example Programs

  • See Calibrating the VNA Using SCPI

  • Learn about Measurement Calibration

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:CORRection:CCHeck[:ACQuire] <mod>[,char]

Applicable Models: E5080A, M9485A

(Write-only) Reads the 'confidence data' associated with the specified ECal module and puts it into memory. The measurement is selected using SENS:CORR:CCH:PAR. This command is compatible with *OPC.

Note: A confidence check can NOT be performed remotely from User Characterizations that are stored on the VNA disk.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<mod>

ECAL Module that contains the confidence data. Choose from:

ECAL1

..through..

ECAL50

[char]

Optional argument. Specifies which characterization within the ECal module that the confidence data will be read from.

CHAR0 Factory characterization (data that was stored in the ECal module by Keysight). Default if not specified.

CHAR1 User characterization #1

CHAR2 User characterization #2

...and so forth up to:

CHAR12 User characterization #12

Examples

SENS:CORR:CCHeck ECAL2

sense2:correction:ccheck:acquire ecal1,char1

Query Syntax

Not applicable

Default

Not applicable

SENSe<cnum>:CORRection:CCHeck:DONE

Applicable Models: E5080A, M9485A

(Write-only) Concludes the Confidence Check and sets the ECal module back into the idle state.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CCH:DONE sense2:correction:ccheck:done
Query Syntax | Not applicable
Default | Not applicable

SENSe<cnum>:CORRection:CCHeck:PARameter <Mname>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies an existing measurement to be used for the Confidence Check. Note: A confidence check can NOT be performed remotely from User Characterizations that are stored on the VNA disk.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<Mname> | Name of the measurement you are selecting for the confidence check. The measurement must already exist.
Examples | SENS:CORR:CCH:PAR 'TEST' 'selects the measurement "test" on channel 1 for the confidence check sense2:correction:ccheck:parameter 'test' 'selects the measurement "test" on channel 2 for the confidence check
Query Syntax | SENSe<cnum>:CORRection:CCHeck:PARameter? Returns the name of the selected measurement on channel <cnum>.
Return Type | String
Default | Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <class>[,subclass][,sync]

Applicable Models: E5080A, M9485A

(Write-only) For UNGUIDED calibration, measures the specified standards from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

For using two sets of standards, see SENS:CORR:TST.

N ote: Before using this command you must select two items:
1. Select a calibration method using SENS:CORR:COLL:METH
2. Select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<class>

Measures the standards associated with these class labels. Choose from:

 | Label | Forward | Reverse
 | STAN1 | S11A | S22A
 | STAN2 | S11B | S22B
 | STAN3 | S11C | S22C
 | STAN4 | S21T | S12T
 | STAN5 | Generic Isolation; not associated with calibration kit definition.
 | ECAL1 through ECAL50 | ECAL modules
 | RESPonse | Same as Normalize selection in Unguided Cal. (subclass is ignored)
 | POWer | Take a receiver power cal sweep and turn correction ON
 | SLSET | Sets 'sliding load type', and increments the "number of slides" count. The total number of slides is critical to the correct calculation of the sliding load algorithm. See a sliding load cal example.
 | SLDONE | Computes the sliding load using a circle fit algorithm.
[subclass] | Optional argument. For mechanical calibration kits, choose from the following to specify the standard to be acquired from the SENS:CORR:COLL:CKIT:ORDer list. If not specified, subclass is set to SST1.
SST1 | First standard in the order list
SST2 | Second standard in the order list
SST3 | Third standard in the order list
SST4 | Fourth standard in the order list
SST5 | Fifth standard in the order list
SST6 | Sixth standard in the order list
SST7 | Seventh standard in the order list
If an ECAL module (1 through 8) is specified for <class>, choose one of the following for specifying which characterization within the ECal module will be used for the acquire. If not specified, the default is CHAR0.
 | CHAR0 | Factory characterization (data that was stored in the ECal module by Keysight)
 | CHAR1 | User characterization #1
 | CHAR2 | User characterization #2
 | ...and so forth up to:
 | CHAR12 | User characterization #12
[sync] | Optional argument. Choose from: SYNChronous - blocks SCPI commands during standard measurement (default behavior) ASYNchronous - does NOT block SCPI commands during standard measurement. Learn more about this argument
Examples | SENS:CORR:COLL STAN1 'If SENS:CORR:COLL:CKIT:ORDer2 5,3,7 was specified, the following command measures standard 3 (the second in the order list) sense1:correction:collect:acquire stan3,sst2 SENS:CORR:COLL ECAL4,ASYN; *OPC? sense2:correction:collect:acquire ecal2,char1
Query Syntax | Not applicable
Default | Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

Applicable Models: E5080A, M9485A

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

N ote: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term here

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Default

Not applicable

SENSe:CORRection:COLLect:DISPlay:WINDow:AOFF

Applicable Models: E5080A, M9485A

(Write-only) Clears the flags for windows to be shown during calibrations. To flag a window to be shown see SENS:CORR:COLL:DISP:WIND.
Examples | SENS:CORR:COLL:DISP:WIND:AOFF sense:correction:collect:display:window:aoff See an example using this command.
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:CORRection:COLLect:DISPlay:WINDow<wNum>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Write-only) Set the 'show' state of the window to be displayed during a calibration. Learn more. When this command is sent, the specified window is 'flagged' to be shown during calibration. The flag is cleared when the window is closed. A Preset or Instrument State Recall also closes the window. If the same window number is reopened, this command must be sent again to show the window during a calibration. The flag is NOT saved with an instrument state. Send this command for each additional window to show during a calibration.
Parameters |
<wNum> | Window number to show during a calibration. The calibration window will also be shown with this window. The window must already be created. Use DISPlay:CATalog? to read all existing window numbers.
<bool> | Window state. Choose from: ON (or 1) - Show the specified window during calibration. OFF (or 0) - Do NOT show the specified window during calibration.
Examples | SENS:CORR:COLL:DISP:WIND1 1 sense:correction:collect:display:window2:state off See an example using this command.
Query Syntax | Not Applicable
Default | OFF

SENSe:CORRection:COLLect:ISOLation:AVERage:INCRement <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies amount to increment (increase) the channel averaging factor during isolation measurement of the ECal module during an unguided ECal calibration.

Note: if the channel currently has averaging turned OFF and <num> is greater than 1, averaging will be turned ON only during the isolation measurements and with the averaging factor equal to <num>.

Parameters

<num>

Incremental Averaging factor. The maximum averaging factor is 65536 (2^16).

Examples

SENS:CORR:COLL:ISOL:AVER:INCR 16

sense:correction:collect:isolation:average:increment 0

Query Syntax

SENSe:CORRection:COLLect:ISOLation:AVERage:INCRement?

Return Type

Numeric

Default

8 - If this command is NOT sent, but ECal isolation is measured, then averaging will be turned ON with factor set to 8 during the isolation measurement.

SENSe<cnum>:CORRection:COLLect:ISOLation:ECAL[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not the isolation state of the ECal module will be measured as part of an unguided ECal calibration.

An unguided calibration is performed using the SENS:CORR:COLL:METH and SENS:CORR:COLL:ACQ commands.

Note: The inherent isolation of the VNA is better than that attained with this command. ONLY use this command when using an external test set, and ONLY using a 8509x ECal module.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<bool>

ON (or 1) - isolation is measured during the unguided ECal calibration.

OFF (or 0) isolation is NOT measured during the unguided ECal calibration.

Examples

SENS1:CORR:COLL:ISOL:ECAL ON

sense2:correction:collect:isolation:ecal:state 0

Query Syntax

SENSe:CORRection:COLLect:ISOLation:ECAL:STATe?

Return Type

Boolean (1 = ON, 0 = OFF)

Default

OFF

SENSe<cnum>:CORRection:COLLect:METHod <char>

Applicable Models: E5080A, M9485A

(Read-Write) For UNGUIDED calibration, sets the calibration method (also known as 'Calibration Type' on calibration dialog box.) To select a Cal Type from a Cal Set, use CALC:CORR:TYPE.

N ote: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
REFL1OPEN | Response Open
REFL1SHORT | Response Short
RESPonse | Same as Normalize selection in Unguided Cal.
Examples | SENS:CORR:COLL:METH REFL1SHORT sense2:correction:collect:method response
Query Syntax | SENSe<cnum>:CORRection:COLLect:METHod?
Return Type | Character
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

Applicable Models: E5080A, M9485A

(Write-only) For UNGUIDED calibrations ONLY. This command does the following:

  • calculates the error terms using the selected :METHod

  • applies the error terms to the selected measurement (turns error correction ON.)

  • saves the calibration error-terms to the channels Cal Register or a User Cal Set.

The Cal Register or User Cal Set is determined by the setting of the SENS:CORR:PREFerence:CSET:SAVE command.

Do NOT use this command during an ECAL. When performing an ECAL calibration using SENS:CORR:COLL:ACQuire, this SAVE operation is performed automatically before the completion of a successful ACQuire.

Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:SAVE
sense2:correction:collect:save

Query Syntax

Not applicable

Default

Not applicable

SENSe:CORRection:COLLect:SWEep:CHANnel:AOFF

Applicable Models: E5080A, M9485A

(Write-only) Clears ALL flags for channels to sweep during calibration. To flag a channel, see SENS:CORR:COLL:SWE:CHAN.
Examples | SENS:CORR:COLL:SWE:CHAN:AOFF sense:correction:collect:sweep:channel:aoff See an example using this command.
Default | Not applicable

SENSe<cnum>:CORRection:COLLect:SWEep:CHANnel<cnum2>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Write-only) Specifies the channel to sweep during a Calibration.

When this command is sent, the <cnum2> channel is 'flagged' to be swept during calibration.

The flag is cleared when the channel is deleted, if the Measurement Class is changed, or if all measurements are deleted from the channel.

If the same channel number is recreated, this command must be sent again to sweep the channel during a calibration. The flag is NOT saved with an instrument state.

A Preset or Instrument State Recall deletes the channel.

Parameters

<cnum>

The channel to be calibrated. If unspecified, value is set to 1.

<cnum2>

The channel to sweep when waiting to measure a standard.

This channel must already exist with at least one measurement in the channel. If this channel is in continuous sweep mode, it must have the same attenuator settings and path configuration (VNA only).

<bool>

Channel sweep state. Choose from:

ON (or 1) - Sweep the channel during calibration.

OFF (or 0) - Do NOT sweep the channel during calibration.

Examples

SENS:CORR:COLL:SWE:CHAN2 1

sense2:correction:collect:sweep:channel3:state off

See an example using this command.

Query Syntax

Not Applicable

Default

OFF

SENSe<ch>:CORRection:GCSetup:POWer <num>

Applicable Models: M9485A

(Read-Write) Set and read the power level at which to perform the Source Power Cal portion of a Gain Compression (Opt 086) Calibration. Learn more about this setting.
Parameters |
<num> | Power level in dB. Choose a value from +30 to (-30).
Examples | SENS:CORR:GCS:POW 0 sense:correction:gcsetup:power 5
Query Syntax | SENSe:CORRection:GCSetup:POWer?
Return Type | Numeric
Default | 0

SENSe<ch>:CORRection:GCSetup:SENSor:CKIT <string>

Applicable Models: M9485A

(Read-Write) Set and read the cal kit to be used for calibrating at the port 1 reference plane when the power sensor connector is different from the DUT port 1. Learn more.
Parameters |
<string> | Cal Kit. Use SENS:CORR:COLL:GUID:CKIT:PORT1:CAT? to return a list of valid cal kits.
Examples | SENS:CORR:GCS:SENS:CKIT "85052B"
Query Syntax | SENSe:CORRection:GCSetup:SENSor:CKIT?
Return Type | String
Default | Not Applicable

SENSe<ch>:CORRection:GCSetup:SENSor:CONNector<string>

Applicable Models: M9485A

(Read-Write) Set and read the power sensor connector type which is used to perform the Source Power Cal portion of a Gain Compression Calibration. Learn more.
Parameters |
<string> | Power sensor connector type. Use SENS:CORR:COLL:GUID:CONN:CAT? to return a list of valid connector types. Select "Ignored" to NOT compensate for the adapter.
Examples | SENS:CORR:GCS:SENS:CKIT "3.5 mm (50) male"
Query Syntax | SENSe:CORRection:GCSetup:SENSor:CKIT?
Return Type | String
Default | Not Applicable

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance:INPut:MAGNitude?
Return Type | Numeric
Default | 50

SENSe<ch>:CORRection:INTerpolate[:STATe] <ON | OFF>

Applicable Models: E5080A, M9485A

(Read-Write) Turns correction interpolation ON or OFF. N ote: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolate:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolate[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

SENSe<ch>:CORRection:METHods:MATCh <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns match-correction ON or OFF. Use this command AFTER performing an Guided Power Cal. Learn more.
Parameters |
<ch> | Channel number on which Guided Power Cal was performed. If unspecified, value is set to 1
<bool> | ON (or 1) - Turns match-correction ON OFF (or 0) - Turns match-correction OFF.
Examples | SENS:CORR:METH:MATC 0 sense2:correction:methods:match off
Query Syntax | SENSe<cnum>:CORRection:METHods:MATCh?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

SENSe:CORRection:PREFerence:CALibration[:FOM]:RANGe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the FOM frequency range to use when performing calibration.
Parameters |
<char> | Choose from: PRIMary - Used for calibrating at the mmWave frequencies when NOT using a test set. Learn more. AUTO - All other calibration situations.
Examples | SENS:CORR:PREF:CAL:RANG PRIM sense:correction:preference:calibration:fom:range auto
Query Syntax | SENSe:CORRection:PREFerence:CALibration[:FOM]:RANGe?
Return Type | Character
Default | AUTO

SENSe:CORRection:PREFerence:CSET:SAVE <char>

Applicable Models: E5080A, M9485A

Important Notes:

  • This command replaces SENS:CORR:PREF:CSET:SAVU

  • With 6.0 we implemented a change that defaults to saving completed calibrations to Cal Registers instead of User Cal Sets. To revert to the old behavior, send this command with the USER argument.

(Read-Write) Specifies the default manner in which calibrations that are performed using SCPI or COM are to be stored. Cal data is ALWAYS stored to the channel Cal Register regardless of this setting.

This setting survives instrument preset and reboot. It remains until changed by another execution of this command.

Note: Cal Set arguments used with commands such as SENS:CORR:COLL:GUID:INIT, SENS:CORR:COLL:GUID:SAVE and SENS:CORR:COLL:GUID:SAVE:CSET will override of any of these default preference settings.

Learn about Cal Registers and User Cal Sets.

Parameters

<char>

CALRegister - Each Cal is saved ONLY to the channel Cal Register. If the error terms from a new Cal can co-exist with those in the Cal Register, they are appended.

USER - Each Cal is saved to its own new User Cal Set file. The Cal Set name is automatically generated. To change the name, send SENS:CORR:CSET:NAME after the cal is complete. This reverts to pre-6.0 behavior.

REUSe - The cal is saved to the Cal Set that is currently selected on the specified channel, which could be the channel Cal Register. If the channel does not yet have a selected Cal Set, the cal will be saved to a new User Cal Set with an automatically-generated name. If the error terms from a new Cal can co-exist with those in the Cal Set, they are appended.

Examples

SENS:CORR:PREF:CSET:SAVE USER
sense:correction:preference:cset:save reuse

Query Syntax

SENSe:CORRection:PREFerence:CSET:SAVE?

Return Type

Character

Default

CALRegister

SENSe:CORRection:PREFerence:ECAL:ORIentation[:STATe] <ON|OFF>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not the VNA should perform orientation of the ECal module during calibration. Orientation is a technique by which the VNA automatically determines which ports of the module are connected to which ports of the VNA. Orientation begins to fail at very low power levels or if there is much attenuation in the path between the VNA and the ECal module. If orientation is turned OFF, the SENS:CORR:PREF:ECAL:PMAP command must be used to specify the port connections before performing a cal.

Note: For 3-port or 4-port measurements, when orientation is OFF, you are not allowed to specify how the ECAL module is connected. Instead, the VNA determines the orientation. Use SENS:CORR:COLL:GUID:DESC? to query the orientation. The VNA does not verify that you made the connection properly.

This setting remains until the VNA is restarted or this command is sent again.

Parameters

<bool>

ECAL orientation state. Choose from:

ON or 1 - VNA performs orientation of the ECal module.

OFF or 0 - VNA does NOT performs orientation of the ECal module.

Examples

SENS:CORR:PREF:ECAL:ORI OFF

sense:correction:preference:ecal:orientation:state on

Query Syntax

SENSe:CORRection:PREFerence:ECAL:ORIentation[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Default

ON (1)

SENSe:CORRection:PREFerence:ECAL:PMAP <module>,<string>

Applicable Models: E5080A, M9485A

(Read-Write) When ECal module orientation is turned OFF (SENS:CORR:PREF:ECAL:ORI), this command specifies the port mapping (which ports of the module are connected to which ports of the VNA) prior to performing ECal calibrations.

This setting remains until the VNA is restarted or this command is sent again.

Parameters

<module>

Specifies which ECal module this port map is being applied to. Choose from:

ECAL1

.through.

ECAL50

<string>

Format this parameter in the following manner:

Aw,Bx,Cy,Dz

where

  • A, B, C, and D are literal ports on the ECAL module

  • w,x,y, and z are substituted for VNA port numbers to which the ECAL module port is connected.

Ports of the module which are not used are omitted from the string.

For example, on a 4-port ECal module with

port A connected to VNA port 2

port B connected to VNA port 3

port C not connected

port D connected to VNA port 1

the string would be: A2,B3,D1

If either the receive port or source port (or load port for 2-port cal) of the CALC:PAR:SELected measurement is not in this string and orientation is OFF, an attempt to perform an ECal calibration will fail.

Examples

SENS:CORR:PREF:ECAL:PMAP ECAL2, 'A1,B2' sense:correction:preference:ecal:pmap ecal3, 'a2,b1,c3'

Query Syntax

SENSe:CORRection:PREFerence:ECAL:PMAP? <module>

Return Type

String

Default

Null string ()

SENSe:CORRection:PREFerence:TRIG:FREE <char>, <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the preference for the trigger behavior during a calibration. This setting persists until it is changed.

Note: If TRIGger:SOURce = Manual, during a calibration the VNA ALWAYS switches to Internal for one trigger, then back to Manual, regardless of this preference command.

Parameters

<char>

Character - Calibration type. Choose from:

GUIDed - preference setting pertains to a Guided calibration.

UNGuided - preference setting pertains to an Unguided calibration.

<bool>

Boolean - Choose from:

0 - OFF - The trigger behavior during the specified calibration type DOES respect the setting of the TRIGger:SOURce command. For example,when Trigger source = External, the single trigger method will wait for the External trigger signal and then allow only one sweep.

1 - ON - (Pre-6.0 behavior) The trigger behavior during the specified calibration type does NOT respect the setting of the TRIGger:SOURce command. For example, when Trigger source = External, during calibration the VNA switches to Internal sweep, responds to one trigger signal to measure the standard, then switches back to External.

Examples

SENS:CORR:PREF:TRIG:FREE GUID,1

sense:correction:preference:trig:free unguided,0

Query Syntax

SENSe:CORRection:PREFerence:TRIG:FREE? <char>

Return Type

Boolean

Default

OFF for both calibration types.

SENSe<cnum>:CORRection:RPOWer:OFFSet[:AMPLitude] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Adjusts a receiver power cal to account for components or adapters that are added between the source port and receiver while performing this cal. For more information, see Receiver Cal.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Offset Value in dB. Specify loss as a negative number; and gain as a positive number. Choose a number between -200 and 200.
Examples | SENS:CORR:RPOW:OFFS .5 sense2:correction:rpower:offset:amplitude .-5
Query Syntax | SENSe<cnum>:CORRection:RPOWer:OFFSet[:AMPLitude]?
Return Type | Numeric
Default | 0

SENSe<cnum>:CORRection:RVELocity:COAX <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between 0 and 10 (.66 polyethylene dielectric; .7 PTFE dielectric)
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Numeric
Default | 1

SENSe<cnum>:CORRection:SFORward[:STATe] <boolean>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the direction a calibration will be performed when only one set of standards is used. Use SENSe:CORRection:TSTandards[:STATe] OFF to specify that only one set of standards will be used.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<boolean> | ON (1) - FORWARD direction of a 2-port calibration will be performed OFF (0) - REVERSE direction of a 2-port calibration will be performed
Examples | SENS:CORR:SFOR 1 sense2:correction:sforward:state 0 See an example using this command
Query Syntax | SENSe<cnum>:CORRection:SFORward[:STATe]?
Return Type | Boolean
Default | ON

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

Applicable Models: E5080A, M9485A

(Read-Write) Turns error correction ON and OFF for the specified channel. N ote: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the channel. OFF (or 0) - correction is NOT applied to the channel.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]? To query the error correction state for a measurement, use CALC:CORR:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

SENSe<cnum>:CORRection:TCOLd:USER:VALue <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the temperature of the noise source connector. Learn more about Noise Figure Calibration.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<num> | Noise source temperature in Kelvin.
Examples | SENS:CORR:TCOL:USER:VAL 295 sense2:correction:tcold:user:value 298 See an example using this command
Query Syntax | SENSe<cnum>:CORRection:TCOLd:USER:VALue?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:CORRection:TSTandards[:STATe] <boolean>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the acquisition of calibration data using ONE or TWO sets of standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<boolean>

ON (1) - TWO identical sets of standards will be used to simultaneously calibrate two ports (for both Forward and Reverse parameters).

OFF (0)- ONE set of standards will be used to perform a full 2-port calibration, one port at a time.

When specifying ON (use two sets), the SENS:CORR:COLL:ACQuire command uses the same standard index for each calibration class. To specify the calibration standard gender for each port, you must first ensure that the order of calibration class accurately reflects the configuration of your DUT. For example, for a DUT with a male connector on port 1 and a female connector on port 2, order the devices within the S11 classes (A, B, and C) such that the MALE standards are first in the list. Then order the S22 classes specifying the FEMALE standards as the first in the list.

Examples

SENS:CORR:TST 1
sense2:correction:tstandard:state 0

See an example using this command

Query Syntax

SENSe<cnum>:CORRection:TSTandards[:STATe]?

Return Type

Boolean

Default

ON

SENSe:CORRection:TYPE:CATalog? <char>

Applicable Models: E5080A, M9485A

(Read only) Lists the Cal Types in the VNA by either GUID or registered name. Learn more about applying Cal Type using SCPI.

N ote: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<char>

(Optional) Specifies the type of list. Choose from:

GUID - the registered GUID of the Cal Type

NAME - the registered name of the Cal Type (Default)

Examples

SENS:CORR:TYPE:CAT? GUID

Query Syntax

SENSe<cnum>:CORRection:TYPE:CATalog? <char>

Return Type

Comma-separated string

Default

Not Applicable

Last modified:

16-Mar-2015

First Release


CorrCKIT SCPI

Sense:Correction:CKIT Commands

Manages the list of cal kits that are installed in the VNA.

SENSe:CORR:CKIT

CLEar

COUNt?

ECAL

| CHARacterize More commands

| CLISt?

| DMEMory

| CLEar

| IMPort

| EXPort

| INFormation

| KNAMe

| INFormation

| LIST?

| ORIent?

| PATH

| COUNt?

| DATA?

EXPort

IMPort

INITialize

LOAD

  • Click on a Red keyword to view the command details.

  • New See Calibrating the VNA Using SCPI

  • Learn about Modifying Cal Kits

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe:CORRection:CKIT:CLEar[:IMMediate] [ckit]

Applicable Models: E5080A, M9485A

(Write-only) Deletes installed cal kits.
Parameters |
[ckit] | Optional String. Cal Kit to delete. If not specified, all VNA Cal kits are deleted, including custom kits.
Examples | SENS:CORR:CKIT:CLE sense:correction:ckit:clear:immediate "85052B"
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:CORRection:CKIT:COUNt?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of installed cal kits.
Examples | SENS:CORR:CKIT:COUNt?
Query Syntax | SENS:CORR:CKIT:COUNt?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL<mod>:CLISt?

Applicable Models: E5080A, M9485A

(Read-only) Returns a list of characterizations stored in the specified ECal module.
Parameters |
<mod> | ECal module from which to read user characterization numbers. Choose from 1 to 50. If unspecified, value is set to 1.
Examples | Module 1 contains User Characterizations 1 and 3. SENSe:CORRection:CKIT:ECAL:CLIST? 'Returns the following (0 always indicates the factory characterization): 0,1,3
Return Type | Numeric list, separated by commas.
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL:DMEMory:CLEar <kitName>

Applicable Models: E5080A, M9485A

(Write-only) Deletes user characterizations from VNA disk memory.
Parameters |
<kitName> | Optional String argument. ECal Model, User Characterization name + " ECal", and serial number of the ECal module, separated by spaces. See examples below. If unspecified, ALL User Characterizations that are stored in VNA disk memory are deleted.
Examples | 'These examples all use "MyUserChar" as the User characterization name. 'The "My User Char" characterization is deleted from disk memory. SENS:CORR:CKIT:ECAL:DMEM:CLE "N4433A MyUserChar ECal 00001" 'All User characterizations are deleted from disk memory. SENS:CORR:CKIT:ECAL:DMEM:CLE
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL:DMEMory:IMPort <file>

Applicable Models: E5080A, M9485A

(Write-only) After the VNA disk memory is Exported to a file, use this command to Import the file into VNA disk memory, which allows the User Characterization to be used with the VNA and ECal module.

Note: An ECal confidence check can NOT be performed remotely from User Characterizations that are stored on the VNA disk.

Parameters

<file>

String. Full path and file name of file that was exported.

Examples

SENS:CORR:CKIT:ECAL:DMEM:IMP "c:\users\public\network analyzer\ECal User Characterizations/myDiskUserChar.euc"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:CKIT:ECAL:EXPort <kit>[,<file>][,<NewName>]]

Applicable Models: E5080A, M9485A

(Write-only) Saves an existing ECal characterization to a file. Use this command to archive the user characterization or to move the characterization to a different VNA for use with the specified ECal module. After exporting the user characterization, use SENS:CORR:CKIT:ECAL:DMEM:IMPort to make the user characterization available for use.
Parameters |
<kit> | String. Not case sensitive. ECal Model, User char name + " ECal", and serial number of the ECal module used for the characterization, separated by spaces. See examples below. If the model and serial number of the module is not found, an error is returned.
[<file>] | Optional String argument. Path and filename of the user characterization. If not specified, the file is saved using characterization name + ".euc". If the path is not specified, it is stored in C:/Program Files/Keysight/Network Analyzer/ECal User Characterizations/. The extension ".euc" is appended if one is not specified.
[<NewName>] | Optional String argument. This allows you to change the name for the User Characterization. When specified, the new name is saved in the file with the characterization. If unspecified, the existing user characterization name is saved. Note: If this argument is specified, the second argument (<file>) must also be specified.
Examples | 'These examples all use "MyUserChar" as the User characterization name. 'All parameters specified SENS:CORR:CKIT:ECAL:EXP "N4433A MyUserChar ECal 00001","myUserChar.euc","NewUserChar" 'First two parameters are specified sense:correction:ckit:ecal:export "N4691B MyUserChar ECal 00500","myUserChar.euc" 'Only first parameter is specified SENS:CORR:CKIT:ECAL:EXP "N4433A MyUserChar ECal 00001"
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:CORRection:CKIT:ECAL<mod>:INFormation? [<char>]

Applicable Models: E5080A, M9485A

(Read-only) Reads the identification and characterization information from the specified ECal module.

Note: To read user-characterization information that is stored in VNA disk memory, then use SENS:CORR:CKIT:ECAL:KNAM:INF?

Parameters

<mod>

ECal module from which to read characterizations. Choose from 1 through 50. If unspecified, value is set to 1.

Do NOT assume the <mod> number is the order in which ECal modules were connected.

Use SENS:CORR:CKIT:ECAL:LIST? to read a list of <mod> numbers of currently-attached ECal modules.

<char>

Optional argument. Specifies which characterization to read information from. If not specified, value is set to CHAR0.

Choose from:

  • CHAR0 Factory characterization (data that was stored in the ECal module by Keysight)

  • CHAR1 User characterization #1

  • CHAR2 User characterization #2

  • - through -

  • CHAR12 User characterization #12

Examples

SENS:CORR:CKIT:ECAL2:INFormation? char5

'Example return string:

"ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002"

Return Type

Character

Default

Not Applicable

SENSe:CORRection:CKIT:ECAL:KNAMe:INFormation? <kitName>

Applicable Models: E5080A, M9485A

(Read-only) Reads the identification and characterization information from the specified ECal module or VNA disk memory.

Learn more about User Characterization in VNA Disk Memory.

Parameters

<kitName>

String. ECal model and characterization to read information from, enclosed in quotes, in the following format:

<model> <name> ECal <serial number>

Where:

<model>: Always required

<name>:

  • For the factory characterization, do not specify.

  • For a user-characterization stored in the module, use User <n> in the string, where <n> is the user-characterization number. Not case sensitive. Separate User and <n> with a space.

  • For a user-characterization stored in VNA disk memory, use <charName> from SENS:CORR:CKIT:ECAL:CHAR:DMEM:SAVE <charName>

ECal - not case sensitive

<serial number>: Optional. Include when two or more ECal modules with same model number are attached to the VNA,

Each item is separated with a space.

Examples

'For a factory characterization in module memory:
SENS:CORR:CKIT:ECAL:KNAM:INF? "N4433A ECal"

'For user characterization in module memory with optional serial number:
SENS:CORR:CKIT:ECAL:KNAM:INF? "N4433A User 1 ECal 00028"

'For user characterization "foo" in disk memory:
SENS:CORR:CKIT:ECAL:KNAM:INF? "N4433A foo ECal 00028"

'Example return string:

"ModelNumber: N4433A, SerialNumber: 00028, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002"

Return Type

String

Default

Not Applicable

SENSe:CORRection:CKIT:ECAL:LIST?

Applicable Models: E5080A, M9485A

(Read-only) Returns a list of index numbers for ECal modules that are currently attached to the VNA. Use these numbers to refer to the ECal module using SCPI commands.
Examples | SENS:CORR:CKIT:ECAL:LIST? 'If 2 modules are attached to the VNA 'then the returned list will be: +1,+2 'If NO modules are attached to the VNA 'then the returned list will be: +0 See example program using this command.
Return Type | Numeric list, separated by commas.
Default | Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL<n>:ORIent? <vPort>[,<charN>]

Applicable Models: E5080A, M9485A

(Read-only) Returns the ECal port that is connected to the specified VNA port. A calibration does not have to be in process.

<ch>

Channel number that contains the frequency range to be calibrated.

<n>

ECal module number. Choose from 1 through 50.

If unspecified (only one ECal module is connected to the USB), <n> is set to 1. If two or more modules are connected, use SENS:CORR:CKIT:ECAL:LIST? to determine how many, and SENS:CORR:CKIT:ECAL:INF? to verify their identities.

<pnaPort>

VNA port number.

<charN>

Optional argument. If unspecified, factory data (CHAR0) is used. User Characterization number that matches the physical adapters/fixtures that are on the ECal module. This aids in determining the orientation of the ECal module.

Choose from:

  • CHAR0 Factory characterization (data that was stored in the ECal module by Keysight)

  • CHAR1 User characterization #1

  • CHAR2 User characterization #2

and so forth up to:

  • CHAR12 User characterization #12

Examples

SENS1:CORR:CKIT:ECAL1:ORI? 2

sense2:correction:ckit,ecal1:orient? 2, char2

Return Type

The returned ECal port number is a 1-based number: 1 = Port A, 2 = Port B, 3 = Port C, 4 = Port D.

Zero (0) is returned when the auto-orientation routine is unable to resolve the orientation.

Default

Not Applicable

SENSe:CORRection:CKIT:ECAL<n>:PATH:COUNt? <path>

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of unique states that exist for the specified path name on the selected ECal module.

This command performs exactly the same function as CONT:ECAL:MOD:PATH:COUNt?

Use the CONT:ECAL:MOD:PATH:STAT command to set the module into one of those states.

Use SENS:CORR:CKIT:ECAL:PATH:DATA? to read the data for a state.

Parameters

<n>

USB number of the ECal module. Choose from 1 to 50.

If unspecified (only one ECal module is connected to the USB), <n> is set to 1. If two or more modules are connected, use SENS:CORR:CKIT:ECAL:LIST? to determine how many, and SENS:CORR:CKIT:ECAL:INF? to verify their identities.

<path>

Name of the path for which to read number of states. Choose from:

Reflection paths

  • A

  • B

  • C (4-port modules)

  • D (4-port modules)

Transmission paths

  • AB

  • AC (4-port modules)

  • AD (4-port modules)

  • BC (4-port modules)

  • BD (4-port modules)

  • CD (4-port modules)

Examples

CONT:ECAL:MOD:PATH:COUNt?
control:ecal:module2:path:count?

Return Type

Integer

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL<num>:PATH:DATA? <path>, <stateNum>[,<char>]

Applicable Models: E5080A, M9485A

(Read-only) Returns the data for a state from the memory of the selected ECal module. The returned data is interpolated if necessary to have the same stimulus values as the specified channel <ch>.

  • For a reflection path state, the data is reflection S-parameter data. The number of values equals the number of stimulus points on the channel multiplied by 2 (because they are complex numbers).

  • For a transmission path state, the data is all 4 S-parameters of the state. The number of values returned is 4 times that of a reflection state.

The data is returned in the same format as CALC:DATA:SNP?

Note: This command returns SNP data without header information, and in columns, not in rows as .SnP files. This means that the data returned from this command sends all frequency data, then all Sx1 magnitude or real data, then all Sx1 phase or imaginary data, and so forth.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<num>

Optional argument. USB number of the ECal module. Choose from 1 through 50.

If unspecified (only one ECal module is connected to the USB), <num> is set to 1. If two or more modules are connected, use SENS:CORR:CKIT:ECAL:LIST? to determine how many, and SENS:CORR:CKIT:ECAL:INF? to verify their identities.

<path>

Name of the path for which to read number of states. Choose from:

Reflection paths

  • A

  • B

  • C (4-port modules)

  • D (4-port modules)

Transmission paths

  • AB

  • AC (4-port modules)

  • AD (4-port modules)

  • BC (4-port modules)

  • BD (4-port modules)

  • CD (4-port modules)

<stateNum>

Number of the state to set. Refer to the following table to associate the <stateNum> with a state in your ECal module.

In addition, CONT:ECAL:MOD:PATH:COUNt? returns the number of states in the specified ECal module.

<stateNum> | N4432A and N4433A States | N4431A States | N469x States** | 8509x States
One-Port Reflection States
1 | Open | Open | Impedance 1 | Open
2 | Short | Short | Impedance 2 | Short
3 | Impedance 1 | Impedance 1 | Impedance 3 | Impedance 1
4 | Impedance 2 | Impedance 2 | Impedance 4 | Impedance 2
5 |  |  | Impedance 5 |
6 |  |  | Impedance 6 |
7 |  |  | Impedance 7 |
Two-Port Transmission States
1 | Thru | Thru | Thru | Thru
2 | Confidence | Confidence | Confidence | Confidence

** The following modules have only FOUR Impedance states (1, 2, 3, 4): N4690B ,N4691B ,N4692A ,N4696B.

<char>

Optional argument. Specifies which characterization within the ECal module to read information from. If not specified, value is set to CHAR0.

Choose from:

  • CHAR0 Factory characterization (data that was stored in the ECal module by Keysight)

  • CHAR1 User characterization #1

  • CHAR2 User characterization #2

and so forth up to:

  • CHAR12 User characterization #12

Examples

SENS:CORR:CKIT:ECAL1:PATH:DATA? A,1

Return Type

S1P or S2P

Default

Not Applicable

SENSe:CORRection:CKIT:EXPort <kit>[,<file>]

Applicable Models: E5080A, M9485A

(Write-only) Saves an existing cal kit definitions to a file. Use this command to archive or move a user-defined or modified cal kit to a different VNA. After exporting the cal kit, use SENS:CORR:CKIT:IMPort to make the cal kit available for use on the VNA. This command provides the same behavior as the Installed Kits - Save As button on the Edit VNA Cal Kits dialog.
Parameters |
<kit> | String. Not case sensitive. Name of the cal kit to export, as seen in the Cal Kits field of the Select DUT Connectors and Cal Kits dialog of a SMART Cal.
<file> | Optional String argument. Path and filename to where the Cal Kit file is to be saved. If not specified, the file is saved using <kit> + ".ckt". If the path is not specified, it is stored in C:/Program Files/Keysight/Network Analyzer/PNACalKits/User.
Examples | 'File unspecified SENS:CORR:CKIT:EXP "MyCalKit" 'Both parameters are specified sense:correction:ckit:export "MyCalKit","C:/myBackupCalKit.ckt"
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:CORRection:CKIT:IMPort <string>

Applicable Models: E5080A, M9485A

(Write-only) Imports the specified cal kit (.ckt file) and appends the imported kit to the end of the list of kits.

Note: Although there is no limit to the number of cal kits that can be imported, during an Unguided cal, you can access ONLY mechanical cal kits #1 through #95.

Parameters

<string>

Path and cal kit name.

Examples

SENSe:CORRection:CKIT:IMPort "c:\users\public\network analyzer\documents/85033D.ckt"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:CKIT:INITialize[:IMMediate] [ckit]

Applicable Models: E5080A, M9485A

(Write-only) Restores default factory installed cal kits. This command also selects kit number 1, as you would using SENS:CORR:COLL:CKIT:SEL 1. Therefore, if you intend to work with a Cal Kit remotely, select the Cal Kit AFTER sending this command.

Note: This command can also delete all existing User-defined Cal Kits. However, if saved using Save As, these kits can be restored in the same manner as after a VNA firmware upgrade. Learn more about saving modified Cal Kits.

Parameters

[ckit]

Optional String. Cal Kit to restore. If not specified, all VNA factory Cal kits are restored.

Examples

SENS:CORR:CKIT:INITialize

sense:correction:ckit:initialize:immediate "85052B"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:CKIT:LOAD <string>

Applicable Models: E5080A, M9485A

(Write-only) Loads the specified collection of cal kits from a .wks file. You can make your own collection of cal kits from the Advanced Modify Cal Kit menu.
Parameters |
<string> | Path and file name of the cal kit collection.
Examples | sense:correction:ckit:load "C:/Program Files/Keysight/Network Analyzer/PnaCalKits/factory/wMyCalKits.wks"
Query Syntax | Not Applicable
Default | Not Applicable

Last modified:

16-Mar-2015

First Release


CorrCollCKIT SCPI

Sense:Correction:Collect:Ckit Commands

Use to change the definitions of calibration kit standards.

SENSe:CORRection:COLLect:CKIT:

| CATalog?

| CONNector

| ADD

| CATalog?

| DELete

| FNAMe

| SNAMe

| DESCription

| INFormation?

| NAME

| OLAB

| OLISt?

| ORDer

| PORT[:SELect]

| SELect

| STANdard

| CO, C1, C2, C3

| CHARacter

| DELay

| FMAX

| FMIN

| IMPedance

| LO, L1, L2, L3

| LABel

| LOSS

| REMove

| SDEScription

| [SELect]

| TYPE

| TZReal

| TZImag

| TRLoption

| IMPedance

| RPLane

Click on a blue keyword to view the command details.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL.

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • See an example program that CREATES a New Cal Kit

  • See an example program that MODIFIES an Existing Cal Kit

  • Learn about Modifying Cal Kits

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

For more information, read Specifying Calibration Standards and Kits for Keysight Vector Network Analyzers (Application Note 1287-11)

SENSe:CORRection:COLLect:CKIT:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the names of the first 50 mechanical cal kits in your VNA that can be used for unguided calibrations.
Examples | SENS:CORR:COLL:CKIT:CAT?
Return Type | A comma-separated string
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:ADD <family>,<start>,<stop>,<z0>,<gender>,<media>,<cutoff>

Applicable Models: E5080A, M9485A

(Write only) Creates a new connector. The connector is automatically added to the list of available connectors for the currently selected cal kit. If a connector includes both male and female connectors, each connector must be added separately.
Parameters |
<family> | (String) Name of connector family. Limited to 50 characters.
<start> | Start frequency
<stop> | Stop frequency
<z0> | Characteristic Impedance of the connector in ohms.
<gender> | Connector gender. Choose from: MALE FEMALE NONE
<media> | Media of the connector. Choose from: COAX - coaxial WAVE - waveguide
<cutoff> | Cutoff frequency of the connector (waveguide only).
Examples | SENS:CORR:COLL:CKIT:CONN:ADD "PSC 1.8 mm",0 HZ,999.9 GHZ,50,FEMALE,COAX,0.0 SENS:CORR:COLL:CKIT:CONN:ADD "PSC 1.8 mm",0 HZ,999.9 GHZ,50,MALE,COAX,0.0
Query Syntax | Not applicable
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns a comma-separated list of all connectors defined within the currently selected cal kit. The returned string includes the connector family name followed by the connector gender, if any. Kits may include a primary connector family name and additional connector family names.

Connector family names are case sensitive. A connector family named "PSC 2.4" is different from a connector family named "psc 2.4".

Learn more about Connector Family Name.

Examples

SENS:CORR:COLL:CKIT:CONN:CAT?

'Returned string

"Type-N (50) male, Type-N (50) female"

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes the primary connector family name from the selected kit. The VNA allows multiple connector families for each kit. If a kit includes multiple connector families, only the first listed (primary) connector family name is deleted.

Once the connector family is deleted, the connector may not be assigned to any new or existing standard within the kit.

The previously defined standards retain their association to the deleted connector name. To reassign standards to a new connector family name, use SENS:CORR:COLL:CKIT:CONN:SNAMe.

Examples

SENS:CORR:COLL:CKIT:CONN:DEL

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:FNAME <name>

Applicable Models: E5080A, M9485A

(Read-Write) Replaces the primary connector family name from the selected kit with a new connector family name. The connector family name is replaced in all standards in the kit that share that name. The VNA allows multiple connector families for each kit. If a kit includes multiple connector families, only the first listed (primary) connector family name is replaced. Use the query form of this command to return the name of the primary connector family.
Parameters |
<name> | New connector family name. Limited to 50 characters.
Examples | SENS:CORR:COLL:CKIT:CONN:FNAM 'MYPSC35' Sense:correction:collect:ckit:connector:name 'My Type N'
Query Syntax | SENSe:CORRection:COLLect:CKIT:CONNector:FNAMe?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:CONNector:SNAMe <family>,<gender>,<port>

Applicable Models: E5080A, M9485A

(Read-Write) Assigns a family name to the currently selected standard from the currently selected kit. Specify each port of a 2-port standard individually. Use the query form of this command to read the connector family name assigned to the current standard. The name is not assigned unless the connector family name is previously defined within the selected kit.
Parameters |
<family> | String. Connector family name.
<gender> | Connector gender. Choose from: MALE FEMALE NONE
<port> | Number of the connector port to be assigned the connector family name. 2-port standards such as a thru line must be assigned separately. It is not relevant which connector is port 1 or port 2. 1 Specifies a 1-port standard or the first port of a 2-port standard. 2 Specifies the second port of a 2-port standard.
Examples | SENS:CORR:COLL:CKIT:CONN:SNAMe "Type-N (50)",MALE,1
Query Syntax | SENSe:CORRection:COLLect:CKIT:CONNector:SNAMe?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:DESCription <string>

Applicable Models: E5080A, M9485A

(Read-Write) Modifies the cal kit description field of the selected kit. This description appears in the Edit VNA Cal Kit dialog box.
Parameters |
<string> | Description of the cal kit. Limited to 50 characters.
Examples | SENS:CORR:COLL:CKIT:DESC "My New CalKit"
Query Syntax | SENSe:CORRection:COLLect:CKIT:DESCription?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:INFormation? <module>[,char]

Applicable Models: E5080A, M9485A

(Read Only) Reads characterization information from an ECal module.
Parameters |
<module> | Specifies which ECal module to read from. Choose from: ECAL1 .through. ECAL50
[char] | Optional argument. Specifies which characterization within the ECal module to read information from. If this argument is not used, the default is CHAR0. CHAR1 through CHAR5 are for user characterizations that may have been written to the module by the User Characterization feature on the VNA. Choose from: CHAR0 Factory characterization (data that was stored in the ECal module by Keysight) CHAR1 User characterization #1 CHAR2 User characterization #2 - through - CHAR12 User characterization #12
Examples | SENS:CORR:COLL:CKIT:INF? ECAL4 sense:correction:collect:ckit:information? ecal2,char1
 | Example return string:
 | ModelNumber: 85092-60007, SerialNumber: 01386, ConnectorType: N5FN5F, PortAConnector: Type N (50) female, PortBConnector: Type N (50) female, MinFreq: 30000, MaxFreq: 9100000000, NumberOfPoints: 250, Calibrated: July 4 2002
Return Type | Character
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:NAME <name>

Applicable Models: E5080A, M9485A

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME 'MYAPC35' sense:correction:collect:ckit:name 'mytypen'
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLABel<class> <name>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the label for the calibration class designated by <class>. The label is used in the prompts for connecting the calibration standards associated with that <class>.
Parameters |
<class> | Number of the calibration class. Choose a number between: 1 and 18. The <class> numbers are associated with the following calibration Classes:
 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibrations
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Line standard
<name> | Label for the calibration class. Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:OLAB3 'LOADS' sense:correction:collect:ckit:olabel4 'Thru'
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLIST[class]?

Applicable Models: E5080A, M9485A

(Read-only) Returns seven values of standards that are assigned to the specified class. This command ALWAYS applies to the Cal Kit that is selected (using SENS:CORR:COLL:CKIT:SEL) when this ORDer command is sent.
Parameters |
<class> | Number of the calibration class to be queried. The <class> numbers are associated with the following calibration Classes:
 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers ONLY 4-port analyzers use S11 and S22 classes (see example program)
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibrations
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Thru standard
Examples | SENS:CORR:COLL:CKIT:OLIST8? Always returns 7 standard numbers. Unassigned standards return 0
Return Type | Numeric; returns the <class> number of the selected standard.
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <std> [,<std>] [,<std>] [,<std>] [,<std>] [,<std>] [,<std>]

Applicable Models: E5080A, M9485A

(Read-Write) Sets a standard number to a calibration class. This command does NOT set or dictate the order for measuring the standards. For more information, see Assigning Standards to a Calibration Class.

This command ALWAYS applies to the Cal Kit that is selected (using SENS:CORR:COLL:CKIT:SEL) when this ORDer command is sent.

Parameters

<class>

Number of the calibration class that is assigned to <standard>. Choose a number between: 1 and 18. The <class> numbers are associated with the following calibration Classes:

 | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru/Delay standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru/Delay standard
3-port analyzers ONLY 4-port analyzers use S11 and S22 classes (see example program)
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru/Delay standard
13 | S23T | Thru/Delay standard
14 | S31T | Thru/Delay standard
15 | S13T | Thru/Delay standard
TRL Calibration
16 | TRL "T" | Thru standard
17 | TRL "R" | Reflect standard
18 | TRL "L" | Line standard
<std> | Standard number to be assigned to the class; Choose a standard between 1 and 30. One standard is mandatory; up to six additional standards are optional.
Examples | 'Assigns standard 3 to S11A class: SENS:CORR:COLL:CKIT:ORD1 3 'Assigns standard 2 and 5 to S21T class class: sense:correction:collect:ckit:order4 2,5
Query Syntax | SENSe:CORRection:COLLect:CKIT:ORDer<class>? 'Returns only the first standard assigned to the specified class. To query the remaining standards, use SENSe:CORRection:COLLect:CKIT:OLIST[1-15]?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:CKIT:PORT<n>[:SELect] <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the name of the Cal Kit to use for Unguided cal.

This command effectively does the same task as SENS:CORR:COLL:CKIT but specifies the cal kit by name.

Note: During an Unguided cal, you can access ONLY mechanical cal kits #1 through #95. However, there is no limit to the number of cal kits that can be imported.

Parameters

<cnum>

Currently not used. The unguided cal kit selection is for all ports on all channels.

<n>

Currently not used. The unguided cal kit selection is for all ports on all channels.

<string>

Cal Kit name enclosed in quotes. Use SENS:CORR:COLL:CKIT:CAT? to read a list of all available Cal Kits in the VNA.

Examples

SENS:CORR:COLL:CKIT:PORT "85052B"
sense2:correction:collect:ckit:port:select "85052D"

Query Syntax

SENSe<cnum>:CORRection:COLLect:CKIT:PORT<n>:SELECT?

Return Type

String

Default

Last kit selected

SENSe<cnum>:CORRection:COLLect:CKIT[:SELect] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Selects (makes active) a calibration kit for performing an UNGUIDED calibration or for modifying standards. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>. Kits 1 to approximately kit 37 are factory installed Cal Kits.

Note: During an Unguided cal, you can access ONLY mechanical cal kits #1 through #95. However, there is no limit to the number of cal kits that can be imported.

This command effectively does the same task as SENS:CORR:COLL:CKIT:PORT which specifies the cal kit by name instead of this command which specifies by number.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<num>

The number of the calibration kit. Choose from:

Use SENSe:CORRection:COLLect:CKIT:RESet to restore Cal Kits to default values.

Name

1

Cal Kit 1

2

Cal Kit 2

3

Cal Kit 3

''

''

94

Cal Kit 94

95

Cal Kit 95

99

ECal module

Examples

SENS:CORR:COLL:CKIT 2
sense2:correction:collect:ckit:select 7

Query Syntax

SENSe<cnum>:CORRection:COLLect:CKIT?

Return Type

Numeric

Default

Last kit selected

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for C0 in femtofarads (1E-15)
Examples | The following commands set C0=15 femtofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for C1.
Examples | The following two commands set C1=15: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for C2.
Examples | The following two commands set C2: SENS:CORR:COLL:CKIT:STAN:C2 15 sense:correction:collect:ckit:standard:c2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for C3.
Examples | The following two commands set C3 SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | Numeric
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in picoseconds
Examples | The following two commands set delay to 50 picoseconds SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAXimum <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmaximum 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAXimum?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMINimum <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the minimum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fminimum 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMINimum?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Numeric
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for L0 in femtohenries (1E-15)
Examples | The following two commands set L0=15 femtohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for L1.
Examples | The following two commands set L1=15: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for L2.
Examples | The following two commands set L2=15: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard. For a detailed discussion of this value, search for App Note 8510-5B at www.Keysight.com.
Parameters |
<num> | Value for L3.
Examples | The following two commands set L3=15: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB 'OPEN' sense:correction:collect:ckit:standard:label 'Short2'
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Gohms / sec. (GigaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:REMove

Applicable Models: E5080A, M9485A

(Write only) Deletes the selected standard from the selected cal kit.
Examples | SENS:CORR:COLL:CKIT:STAN:REMove
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:SDEScription <string>

Applicable Models: E5080A, M9485A

(Read-Write) Modifies the description of the selected standard of the selected kit. This description appears in the edit kit dialog box.
Parameters |
<string> | Description of the standard.
Examples | SENS:CORR:COLL:CKIT:STAN:SDES "My New Standard"
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:SDEScription?
Return Type | String
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 30
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Numeric
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD SLOAD (sliding load) THRU (through) ARBI(arbitrary)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZReal <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the TZReal component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZReal in Ohms
Examples | The following commands set TZReal=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZReal 15 sense:correction:collect:ckit:standard:TZReal 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZReal?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZImag <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the TZImag component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZImag in Ohms
Examples | The following two commands set TZImag=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZImag 15 sense:correction:collect:ckit:standard:TZImag 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZImag?
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:TRLoption:IMPedance <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the reference impedance when using this TRL cal kit. Learn more.

Before sending this command, select a cal kit using SENS:CORR:COLL:CKIT:SELect.

Parameters

<char>

Choose from:

SYSTem - The system impedance is used as the reference impedance. During a Guided or Unguided Cal, the Z0 of the Cal standard's connector definition sets the System Z0.

Make this selection when the desired test port impedance differs from the impedance of the LINE standard. Also, make this selection when skin effect impedance correction is desired for coax lines.

LINE The impedance of the line standard is used as the reference impedance, or center of the Smith Chart. Any reflection from the line standard is assumed to be part of the directivity error.

Examples

SENS:CORR:COLL:CKIT:TRL:IMP SYST

sense:correction:collect:ckit:trloption:impedance line

Query Syntax

SENSe:CORRection:COLLect:CKIT:TRLoption:IMPedance?

Return Type

Character

Default

LINE

SENSe:CORRection:COLLect:CKIT:TRLoption:RPLane <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the reference impedance when using this cal kit. Learn more.

Before sending this command, select a cal kit using SENS:CORR:COLL:CKIT:SELect.

Parameters

<char>

Choose from:

THRU The THRU standard definition is used to establish the measurement reference plane. Select if the THRU standard is zero-length or very short.

REFLect The REFLECT standard definition is used to establish the position of the measurement reference plane. Select if the THRU standard is not appropriate AND the delay of the REFLECT standard is well defined. Also, select If a flush short is used for the REFLECT standard because a flush short provides a more accurate phase reference than a Thru standard.

Examples

SENS:CORR:COLL:CKIT:TRL:RPL THRU

sense:correction:collect:ckit:trloption:rplane reflect

Query Syntax

SENSe:CORRection:COLLect:CKIT:TRLoption:RPLane?

Return Type

Character

Default

THRU

Last Modified:

16-Mar-2015

First Release


CorrCset SCPI

Sense:Correction:Cset Commands

Performs actions on calibration sets.

SENSe:CORRection:CSET

ACTivate

COPY

CREate

DEACtivate

DESCription

ETERm

| CATalog?

| [DATA]

FLATten

NAME

SAVE

STANdard

STIMulus?

TSET

| ALLPorts?

| TYPE?

TYPE

| CATalog?

Click on a Red keyword to view the command details.

See Also

  • Creating Cal Sets

  • Example Programs

  • Learn about Cal Sets

  • Synchronizing the VNA and Controller

SENSe<cnum>:CORRection:CSET:ACTivate <string>, <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Selects and applies a Cal Set to the specified channel.

Use SENS:CORR:CSET:CAT? to list the Cal Sets.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

Cal Set to make active. Specify the Cal Set by GUID or Name. Use SENS:CORR:CSET:CAT? to list the available Cal Sets in either format.

<bool>

Should the Cal Set stimulus values be applied to the channel. Choose from:

ON (1) Apply the Cal Set stimulus values to the channel.

OFF (0) Do NOT apply the Cal Set stimulus values. If the Cal Set stimulus values do not match the channel stimulus values, then the following will occur:

  • If interpolation is ON, then interpolation will be attempted. This may fail if the channel frequency is outside the range of the Cal Set.

  • If interpolation is OFF, the selection will be abandoned and an error is returned:

Examples

SENS:CORR:CSET:ACT "My2Port",1

sense:correction:cset:activate? name
'returns
"My2Port"

Query Syntax

SENSe<cnum>:CORRection:CSET:ACTivate? [GUID|NAME]

Returns the name of the Cal Set that is applied to the specified channel. Choose from GUID or NAME to specify which string is returned. If unspecified, the GUID of the Cal Set is returned. If no Cal Set is applied to the specified channel, then "No Calset Selected" is returned.

Return Type

String

Default

Not Applicable

SENSe<cnum>:CORRection:CSET:COPY <string>

Applicable Models: E5080A, M9485A

(Write-only) Creates a new Cal Set and copies the current Cal Set data into it. Use this command to manipulate data on a Cal Set without corrupting the original cal data.
Parameters |
<cnum> | Channel number using the Cal Set to be copied. If unspecified, value is set to 1
<string> | Name of the new Cal Set.
Examples | SENS2:CORR:CSET:COPY 'My2Port'
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:CREate [name]

Applicable Models: E5080A, M9485A

(Write-only) Creates an empty Cal Set and attaches it to the specified channel. This command is ONLY necessary before remotely filling the Cal Set with error term data. (For Advanced Users).

A Cal Set is automatically created, applied to the channel, and saved at the completion of a guided cal according to the preference setting SENS:CORR:PREF:CSET:SAVE.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

[name]

Optional argument. Name of the Cal Set. Spaces or punctuation are NOT allowed. If unspecified, a unique name is chosen in the form "Calset_N" where N is a unique number.

Examples

SENS:CORR:CSET:CRE 'My2Port'

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:CSET:DEACtivate

Applicable Models: E5080A, M9485A

This command is replaced by CSET:DEAC. (Write-only)Clears the calibration error when the frequency offset feature is set to OFF for the selected channel.
Parameters |
<string> | Clears calibration error.
Examples | SENS:CORR:CSET:DEAC '{2B893E7A-971A-11d5-8D6C-00108334AE96}' sense2:correction:cset:deactivate 'MyCalSet'
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:DESCription <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the descriptive string assigned to the selected Cal Set. Change this string so that you can easily identify each Cal Set. Apply and select the Cal Set using SENS:CORR:CSET:ACT.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | The descriptive string associated with the currently-selected Cal Set
Examples | SENS:CORR:CSET:DESC 'MyCalSet' sense2:correction:cset:description 'thisCalSet'
Query Syntax | SENSe<cnum>:CORRection:CSET:DESCription?
Return Type | String
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:ETERm[:DATA] <string>,<r, i [r,i]...>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns error term data for all VNA measurements.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

(String) Error term to read or write. The error term is specified using the EXACT case-sensitive string displayed in the Cal Set Viewer utility. See SENS:CORR:CSET:ETER:CAT? for string.

<r,i>

(Block) Error term data. A Real / Imaginary data pair for each data point.

Format is set using FORM:DATA command.

For REAL binary formats, refer to Getting Data from the Analyzer using SCPI

Examples

SENS:CORR:CSET:ETERM "Directivity(1,1)", 0.237,-1.422, 0.513, 0.895 ' set directivity(source error term for 2 points
SENS:CORR:CSET:ETERM? "Directivity(1,1)" 'read

Query Syntax

SENSe<cnum>:CORRection:CSET:ETERm[:DATA]? <string>

Return Type

Block data

Default

Not Applicable

SENSe<cnum>:CORRection:CSET:ETERm:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns a list of error term names found in the current Cal Set that is applied to the specified channel.
Parameters |
Examples | SENS:CORR:CSET:ETER:CAT? 'For a 1-port cal, returns "Directivity(1,1),ReflectionTracking(1,1),SourceMatch(1,1)"
Return Type | String
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:FLATten <string>

Applicable Models: E5080A, M9485A

(Write-only) When a Cal Set that was produced by a calibration has been interpolated or otherwise modified (for example, by Fixturing operations) this command saves the modified Cal Set to the VNA hard drive so that it can be reused. There is no User Interface equivalent for this command.

Background

When a Cal Set is selected for use by a channel, the channel reads the Cal Set from disk (master Cal Set). If the channel aligns perfectly with the Cal Set, the master Cal Set is used directly. In this case, the active Cal Set is the master Cal Set.

When processing occurs on the error terms due to interpolation or modification due to the use of fixturing, the channel will generate a temporary "memory-resident" Cal Set. In this case, the active Cal Set is the memory-resident Cal Set. This FLATten command allows you to save the active Cal Set to disk.

Depending on the measurement conditions, this flattening of the Cal Set can improve performance, especially if the Cal Set is applied often (using multiple recall states) or used by many channels. Flattening a version of the Cal Set for each channel can avoid the interpolation or the fixturing processing that would otherwise occur when the Cal Set is selected or the instrument state is recalled.

You will have to manage the application of such a Cal Set as the VNA itself will have no way to determine what processing had been done once the flatten command is used. For example, if fixture de-embedding occurred prior to the flatten command, that Cal Set should then be applied WITHOUT fixturing on, because fixturing is already embedded in that Cal Set. It is your responsibility to apply the Cal Set properly.

If you want to repeatedly de-embed multiple networks (i.e. concatenate multiple 2-port de-embedding files) you can use the flatten command to create a new master Cal Set after each de-embed, and sequentially add additional de-embed networks.

Parameters

<cnum>

Channel number on which the modified Cal Set resides. If unspecified, value is set to 1

<string>

Name of the new Cal Set. Spaces or punctuation NOT allowed.

Examples

SENS:CORR:CSET:FLAT "MyCalSet"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<cnum>:CORRection:CSET:NAME <string>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or queries the name of the Cal Set currently applied to the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | Name of the Cal Set. Spaces or punctuation NOT allowed.
Examples | SENS:CORR:CSET:NAME 'MyCalSet' sense2:correction:cset:name 'thisCalSet'
Query Syntax | SENSe<cnum>:CORRection:CSET:NAME?
Return Type | String
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:SAVE [<char>]

Applicable Models: E5080A, M9485A

(Read Write)

Saves the channel's Cal Set to the VNA hard drive. For example, use this command after writing data to a Cal Set using SENS:CORR:CSET:DATA (For Advanced Users).

The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a Cal Set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00x.cst". For more information on the file naming syntax, see the MMEMory subsystem. Learn more about Instrument/Cal States.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

[<char>]

Optional argument. Choose from:

USER01

USER02...

and so forth, until...

USER10

If <char> is NOT specified, changes that may have been made are saved to the cal set and NOT to the *cst file.

Examples

SENS:CORR:CSET:SAVE USER03
sense2:correction:cset:save user09

'save changes to only the cal set

SENS:CORR:CSET:SAVE

Query Syntax

SENSe<cnum>:CORRection:CSET:SAVE?

Queries the last correction set saved.

Return Type

Charact er

Default

Not applicable

SENSe<cnum>:CORRection:CSET:STANdard <string>,<data>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns standard data. Standard data is available for Unguided Cals ONLY.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | (String) Cal standard to read or write. The standard is specified using the EXACT case-sensitive string displayed in the Cal Set Viewer utility. See SENS:CORR:CSET:DATA for a description of port numbers.
<data> | (Block). Acquisition data. A Real / Imaginary data pair for each data point. Format is set using FORM:DATA command. For REAL binary formats, refer to Getting Data from the Analyzer using SCPI
Examples | SENS:CORR:CSET:STAN 'S11C(1,1), 0.237,-1.422, 0.513, 0.895 ' Set acquisition data for two points. SENS:CORR:CSET:STAN? "S11C(1,1)" 'Read data
Query Syntax | SENSe<cnum>:CORRection:CSET:STANdard? (string)
Return Type | Block data
Default | Not Applicable

SENSe<ch>:CORRection:CSET:STIMulus? [num]

Applicable Models: E5080A, M9485A

(Read-only) Returns the source or response stimulus values for the Cal Set that is currently used by channel <ch>. Values are returned in the format specified by FORM:DATA (Block or ASCII).
Parameters |
<ch> | Channel number to query Cal Set stimulus values. If unspecified, value is set to 1
[num] | Optional argument. Range of frequencies to return. These values would be different when FOM (Opt 080) is enabled. 0 - returns source frequencies. Default setting if not specified. 1 - returns response frequencies. 2 - returns primary frequencies.
Examples | SENS:CORR:CSET:STIM? sense:correction:cset:stimulus 1
Return Type | Numeric
Default | Not Applicable

SENSe:CORRection:CSET:TSET:ALLPorts? <cset>

Applicable Models: E5080A, M9485A

(Read-only) Reads the port mapping used for the specified Cal Set. The returned values are the physical ports. The POSITION of the returned values corresponds to the logical ports.

For example, with an N44xx test set, if the returned string is "VNA 1,TS 2,VNA 2, TS 4" this means:

  • VNA 1 is assigned to logical port 1

  • TS 2 is assigned to logical port 2

  • VNA 2 is assigned to logical port 3

  • TS 4 is assigned to logical port 4

Parameters

<cset>

(String) Name or GUID of the Cal Set. Use SENS:CORR:CSET:CAT? to read the list of available Cal Set names or GUIDs.

Examples

SENS:CORR:CSET:TSET:ALLP? "MyCalSet"
sens:correction:cset:tset:allports? "{2B893E7A-971A-11d5-8D6C-00108334AE96}"

Return Type

String

Default

Not Applicable

SENSe:CORRection:CSET:TSET:TYPE? <cset>

Applicable Models: E5080A, M9485A

(Read-only) Reads the test set type (model) used for the specified Cal Set.
Parameters |
<cset> | (String) Name or GUID of the Cal Set. Use SENS:CORR:CSET:CAT? to read the list of available Cal Set names or GUIDs.
Examples | SENS:CORR:CSET:TSET:TYPE? "MyCalSet" 'returns "N44xx" sens:correction:cset:tset:type? "{2B893E7A-971A-11d5-8D6C-00108334AE96}"
Return Type | String
Default | Not Applicable

SENSe<ch>:CORRection:CSET:TYPE:CATalog? [format]

Applicable Models: E5080A, M9485A

(Read-only) Query the Cal Types available in the selected Cal Set. The output is a comma separated list of Guids or a Cal Type names. Learn more about applying Cal Types using SCPI. Use CALC:CORR:TYPE to apply a Cal Type.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
[format] | (Optional) Format of the output of cal types. choose from: NAME - (default) returns a list of cal type string names. GUID - returns a list of cal type GUIDs
Examples | SENS:CORR:CSET:TYPE:CAT? NAME SENS2:CORRection:CSET:TYPE:CAT?
Return Type | String
Default | Not Applicable

Last modified:

16-Mar-2015

Initial Release


CorrExtension

Sense:Correction:Extension Commands

Performs and applies Port Extensions.

SENSe:CORRection:EXTension:

AUTO

| CONFig

| DCOFfset

| LOSS

| MEAS

| PORT

| RESet

| STARt

| STOP

PORT

| DISTance

| FREQ

| INCLude

| [STATe]

| LDC

| LOSS

| MEDium

| SYSMedia

| SYSVelocity

| [TIME]

| UNIT

| VELFactor

| WGCutoff

[STATe]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Port Extensions

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:CORRection:EXTension:AUTO:CONFig <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the frequencies used to calculate Automatic Port Extension. Learn more about calculating Automatic Port Extension.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Frequencies to be used: CSPN Use current frequency span. AMKR - Use active marker frequency. USPN - Use custom user span. Use SENS:CORR:EXT:AUTO:STAR and SENS:CORR:EXT:AUTO:STOP to specify start and stop frequency.
Examples | SENS:CORR:EXT:AUTO:CONF CSPN sense2:correction:extension:auto:config amkr
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:CONFig ?
Return Type | Character
Default | CSPN

SENSe<cnum>:CORRection:EXTension:AUTO:DCOFfset <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not to include DC Offset as part of automatic port extension. Learn more about Automatic DC Offset. Only allowed when SENS:CORR:EXT:AUTO:LOSS is set to ON.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - Includes DC Offset correction. OFF (or 0) - Does NOT include DC Offset correction.
Examples | SENS:CORR:EXT:AUTO:DCOF 1 sense2:correction:extension:auto:dcoffset off
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:DCOFfset?
Return Type | Boolean
Default | ON (1)

SENSe<cnum>:CORRection:EXTension:AUTO:LOSS <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not to include loss correction as part of automatic port extension. Learn more about Loss Compensation in port extension.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - Includes Loss correction. OFF (or 0) - Does NOT include Loss correction.
Examples | SENS:CORR:EXT:AUTO:LOSS 1 sense2:correction:extension:auto:loss off
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:LOSS?
Return Type | Boolean
Default | ON (1)

SENSe<cnum>:CORRection:EXTension:AUTO:MEASure <char>

Applicable Models: E5080A, M9485A

(Write-only) Measures either an OPEN or SHORT standard. When this command is sent, the VNA acquires the measurement with which to set automatic port extensions. Learn more about which standard to measure.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Standard to be measured. Choose from: OPEN Measure OPEN standard SHORt Measure SHORT standard
Examples | SENS:CORR:EXT:AUTO:MEAS OPEN sense2:correction:extension:auto:measure short
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:CORRection:EXTension:AUTO:PORT<n> <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables automatic port extensions on the specified port.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<n> | VNA Port number to enable or disable for automatic port extensions.
<bool> | ON (or 1) - Enable OFF (or 0) - Disable
Examples | SENS:CORR:EXT:AUTO:PORT2 0 sense2:correction:extension:auto:port4 on
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:PORT<n>?
Return Type | Boolean
Default | All ports ON (enabled)

SENSe<cnum>:CORRection:EXTension:AUTO:RESet

Applicable Models: E5080A, M9485A

(Write-only) Clears old port extension delay and loss data in preparation for acquiring new data. Send this command prior to sending a new series of SENS:CORR:EXT:AUTO:MEAS. If acquiring both OPEN and SHORT standards, do not send this command between those acquisitions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:EXT:AUTO:RES sense2:correction:extension:auto:reset
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:CORRection:EXTension:AUTO:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Set the start frequency for custom user span. Learn more about User Span.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<value> | User span start value. Must be within the frequency range of the active channel and less than the value set by SENS:CORR:EXT:AUTO:STOP.
Examples | SENS:CORR:EXT:AUTO:STAR 1E9 sense2:correction:extension:auto:start 200e6
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:STARt <value>?
Return Type | Numeric
Default | Start frequency of the current active channel.

SENSe<cnum>:CORRection:EXTension:AUTO:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) Set the stop frequency for custom user span. Learn more about User Span.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<value> | User span stop value. Must be within the frequency range of the active channel and greater than the value set by SENS:CORR:EXT:AUTO:STARt
Examples | SENS:CORR:EXT:AUTO:STOP 1E9 sense2:correction:extension:auto:stop 200e6
Query Syntax | SENSe<cnum>:CORRection:EXTension:AUTO:STOP <value>?
Return Type | Numeric
Default | Stop frequency of the current active channel.

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:DISTance <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the port extension delay in physical length (distance).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<pnum> | Port Number that will receive the delay setting. If unspecified, value is set to 1.
<value> | Physical length of fixture of added transmission line. First specify units with SENS:CORR:EXT:PORT:UNIT.
Examples | SENS:CORR:EXT:PORT1:DIST 12 sense2:correction:extension:port2:distance .003
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:DISTance?
Return Type | Numeric
Default | 0

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:FREQuency<n> <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the frequency for the Freq and Loss pair number and for the specified port number. Learn about Loss Compensation values.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number that will receive the freq/loss settings. If unspecified, value is set to 1.
<n> | Freq and Loss pair number. Choose from 1 or 2. If unspecified, value is set to 1.
<value> | Frequency value. Choose a frequency within the frequency span of the VNA.
Examples | SENS:CORR:EXT:PORT1:FREQ1 10E9 sense2:correction:extension:port2:freq2 2E10
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:FREQuency<n>?
Return Type | Numeric
Default | 1 GHz

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:INCLude<n>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the ON/OFF state for the Freq and Loss pair number and for the specified port number. Learn about Loss Compensation values. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number that will receive the Freq/Loss settings. If unspecified, value is set to 1.
<n> | Freq and Loss pair. Choose from 1 or 2. If unspecified, value is set to 1.
<value> | State of Freq and Loss values for port extension. 0 or OFF Specified Freq and Loss values are OFF 1 or ON Specified Freq and Loss values are ON
Examples | SENS:CORR:EXT:PORT:INCL 0 sense2:correction:extension:port2:include2:state on
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:INCLude[:STATe]?
Return Type | Boolean
Default | OFF

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:LDC <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Port Loss at DC value for the specified port number. Learn about Loss Compensation values. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port number to receive Loss value. If unspecified, value is set to 1.
<value> | Loss in dB. Choose a value between -90 and 90
Examples | SENS:CORR:EXT:PORT:LDC 1.5 sense2:correction:extension:port2:ldc .1
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:LDC?
Return Type | Numeric
Default | 0

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:LOSS<n> <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Loss value for the specified port number. Learn about Loss Compensation values. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number that will receive the Freq/Loss settings. If unspecified, value is set to 1.
<n> | Loss "Use" number. Choose from 1 or 2. If unspecified, value is set to 1.
<value> | Loss in dB. Choose a value between -90 and 90
Examples | SENS:CORR:EXT:PORT:LOSS1 1 sense2:correction:extension:port2:loss2 .1
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:LOSS<n>?
Return Type | Numeric
Default | 0

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:MEDium <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the media type of the added fixture or transmission line.

See also SENS:CORR:EXT:PORT:SYSMedia

Note: This command affects ALL measurements on the specified channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Port Number for which media type is being set. If unspecified, value is set to 1.

<char>

Medium type. Choose from:

  • COAX

  • WAVeguide

Examples

SENS:CORR:EXT:PORT:MED COAX

sense2:correction:extension:port2:medium waveguide

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:MEDium?

Return Type

Character

Default

COAX

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:SYSMedia <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the state of coupling with the system Media type. Learn more.

Note: This command potentially affects ALL measurements on the VNA.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Port Number for which system Velocity Factor coupling is being set. If unspecified, value is set to 1.

<bool>

Coupling state. Choose from:

  • ON (or 1) - Media type is coupled with the system setting.

  • OFF (or 0) - Media type is NOT coupled with the system setting.

Examples

SENS:CORR:EXT:PORT:SYSM 1

sense2:correction:extension:port2:sysmedia off

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:SYSMedia?

Return Type

Boolean

Default

1 or ON (Coupled)

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:SYSVelocity <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the state of coupling with the system Velocity Factor value. Learn more.

Note: This command potentially affects ALL measurements on the VNA.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Port Number for which system Velocity Factor coupling is being set. If unspecified, value is set to 1.

<bool>

Coupling state. Choose from:

  • ON (or 1) - Velocity Factor is coupled with the system setting.

  • OFF (or 0) - Velocity Factor is NOT coupled with the system setting.

Examples

SENS:CORR:EXT:PORT:SYSV 1

sense2:correction:extension:port2:sysvelocity off

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:SYSVelocity?

Return Type

Boolean

Default

1 or ON (Coupled)

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the extension delay value in time at the specified port. Must also set SENS:CORR:EXT ON. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number that will receive the extension. If unspecified, value is set to 1.
<num> | The port extension in seconds; may include suffix. Choose a number between: -1E18 and 1E18
Examples | SENS:CORR:EXT:PORT 2MS sense2:correction:extension:port2 .00025
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?
Return Type | Numeric
Default | 0

SENSe<cnum>:CORRection:EXTension:PORT:UNIT <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the units for specifying port extension delay in physical length (distance).

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<char>

Units for delay in distance. Choose from:

  • METer

  • FEET

  • INCH

Examples

SENS:CORR:EXT:PORT:UNIT MET
sense2:correction:extension:port:unit inch

Query Syntax

SENSe<cnum>:CORRection:EXTension:PORT:UNIT?

Return Type

Character

Default

METer

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:VELFactor <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the velocity factor of the fixture or added transmission line.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number for which velocity factor is being set. If unspecified, value is set to 1.
<value> | Velocity Factor. Set SENS:CORR:EXT:PORT:SYSV to use the system velocity factor.
Examples | SENS:CORR:EXT:PORT:VELF .6 sense2:correction:extension:port2:velfactor 1
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:VELFactor?
Return Type | Numeric
Default | System Velocity Factor

SENSe<cnum>:CORRection:EXTension:PORT<pnum>:WGCutoff <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the cuttoff (minimum) frequency of the added waveguide fixture or transmission line.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Port Number for which media type is being set. If unspecified, value is set to 1.
<value> | Cutoff frequency in Hz. This value is ignored when SENS:CORR:EXT:PORT:MED is set to COAX for the same port.
Examples | SENS:CORR:EXT:PORT:WGC 1e8 sense2:correction:extension:port2:wgcutoff 100Mhz
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum>:WGCutoff?
Return Type | Numeric
Default | System Media Cutoff Frequency

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

Applicable Models: E5080A, M9485A

(Read-Write) Turns port extensions ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port extensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

Last Modified:

16-Mar-2015

First Release


CorrGuided SCPI

Sense:Correction:Collect:Guided Commands

Performs and applies a SmartCal (Guided) calibration and other error correction features.

To perform a Guided Calibration, use ONLY Sens:Corr:Coll:Guided commands. See the "Guided" example programs for clarification.

SENSe:CORRection:COLLect:GUIDed:

ABORt

ACQuire

ADAPter

| COUNt

| ZERO

| CREate?

| DELay

| DESCription

| PATHs

CHANnel:MODE

CKIT

| CATalog?

| PORT

| [SELect]

CONNector

| CATalog?

| PORT

| [SELect]

DESCription

ECal

| ACQ

| SEL

ETERms:LOAD

| [CSET]

INITiate

ISOLation

| AVERage

| INCRement

| PATHs

ITERations

| COUNt?

| MINimum?

| RESet

PACQuire

PATH

| CMEThod

| TMEThod

PREFerence

| SLIDingload

PSENsor - More commands

SAVE

| CSET

SMC - More commands

STEPS?

THRU

Click on a blue keyword to view the command details.

See Also

ECal Orientation commands

Examples using these commands.

Calibrating the VNA Using SCPI

Learn about Measurement Calibration

Synchronizing the VNA and Controller

SENSe<ch>:CORRection:COLLect:GUIDed:ABORt

Applicable Models: E5080A, M9485A

(Write-only) Aborts the acquiring of a guided calibration that has been INITialized but has not yet been concluded using the SAVE command. If at least one Cal standard has already been measured, and the Calibration Window is being displayed, this command also closes the Calibration Window and re-tiles the other measurement windows.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
Examples | SENS:CORR:COLL:GUID:ABOR sense2:correction:collect:guided:abort
Query Syntax | Not Applicable
Default | Not Applicable

SENSe:<ch>CORRection:COLLect:GUIDed[:ACQuire] <std>[,sync]

Applicable Models: E5080A, M9485A

(Write-only) Initiates the measurement of the specified calibration standard. Executing this command with an unnecessary standard has no affect.

The measured data is stored and used for subsequent calculations of error correction coefficients. All standards must be measured before a calibration can be completed. Any measurement can be repeated until the SENS:CORR:COLL:GUID:SAVE command is executed.

Query the user prompt description using SENS:CORR:COLL:GUID:DESC?

Query the required calibration steps using SENS:CORR:COLL:GUID:STEP?

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<std>

Choose from:STAN1, STAN2, STAN3, through STAN40

[sync]

Optional argument. Choose from:

SYNChronous - blocks SCPI commands during standard measurement (default behavior).

ASYNchronous - does NOT block SCPI commands during standard measurement.

Learn more about this argument

Examples

SENS:CORR:COLL:GUID STAN1
sense2:correction:collect:guided:acquire stan1

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ADAPter:CREate? <conn1>, <conn2>

Applicable Models: E5080A, M9485A

(Read-only) Specifies the use of a THRU adapter to be used during the Guided Cal Unknown THRU and Adapter Removal Cal. Returns an adapter index <n> which is used to refer to the adapter in several related commands. See Cal Thru Methods. While the choice of which end of the adapter is <conn1> and <conn2> is arbitrary, it is necessary to remember which will be used on each test port.

The settings for this command remain until Preset, or the command is sent using a different setting, or until the ZERO command is sent.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<conn1>

Adapter port 1 connector type. Use SENS:CORR:COLL:GUID:CONN:CAT? to return a list of valid connector types.

<conn2>

Adapter port 2 connector type.

Examples

See example using this command.

Return Type

Numeric

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ADAPter:COUNt?

Applicable Models: E5080A, M9485A

(Read-Only) Returns the number of THRU adapters that have been created for this calibration using SENS:CORR:COLL:GUID:ADAP:CREate.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
Examples | See example using this command.
Return Type | Numeric
Default | Not Applicable

SENSe:<ch>CORRection:COLLect:GUIDed:ADAPter:COUNt:ZERO

Applicable Models: E5080A, M9485A

(Write-only) Removes all adapters that have been defined for calibrations on the specified channel using SENS:CORR:COLL:GUID:ADAP:CREate.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
Examples | SENS:CORR:COLL:GUID:ADAP:COUNt:ZERO sense2:correction:collect:guided:adapter:count:zero
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ADAPter<n>:DELay <coax>, [w phase, wdelay]

Applicable Models: E5080A, M9485A

(Write-only) Specifies the adapter delay and optionally waveguide delay and optional phase offset (degrees) of adapter <n>.

The settings for this command remain until Preset, or the command is sent using a different setting, or until the ZERO command is sent.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<n>

Adapter index number that was returned from SENS:CORR:COLL:GUID:ADAP:CREate?

<coax>

Delay value of coax adapter <n> in seconds. If the adapter has no coax connector, enter 0.

<wphase>

Waveguide phase offset in degrees. If the adapter has no waveguide connector, do not enter a value.

<wdelay>

Waveguide delay in seconds. If the adapter has no waveguide connector, do not enter a value.

Examples

See example using this command.

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ADAPter<n>:DESCription <string>

Applicable Models: E5080A, M9485A

(Write-only) Specifies the adapter description for use as the guided cal connection prompts. The settings for this command remain until Preset, or the command is sent using a different setting, or until the ZERO command is sent.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<n> | Adapter index number that was returned from SENS:CORR:COLL:GUID:ADAP:CREate?
<string> | Adapter description.
Examples | See example using this command.
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ADAPter<n>:PATHs <port pairs>

Applicable Models: E5080A, M9485A

(Write-only) Specifies the port pairs for which the adapter will be used for a THRU connection.

For example, for a 3-port cal on channel 1 using ports 1,2,and 3), to use adapter 1 between the ports (1 to 2) and (1 to 3) the following command is used: SENS1:CORR:COLL:GUID:ADAP1:PATH 1,2,1,3.

The adapter must have the same DUT connectors as the ports that are already specified for these ports.

The settings for this command remain until Preset, or the command is sent using a different setting, or until the ZERO command is sent.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<n>

Adapter index number that was returned from SENS:CORR:COLL:GUID:ADAP:CREate?

<port pair>

Ports for which the adapter will be used. The orientation is not critical, as the VNA will align the connector types as necessary. The minimum number of Thru connections required is the number of ports to calibrated -1.

Examples

See example using this command.

Query Syntax

Not Applicable

Default

Not Applicable

SENSe:CORRection:COLLect:GUIDed:CHANnel:MODE <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Determines whether or not to honor the channel <ch> argument in guided calibration SCPI commands.

Parameters

<bool>

OFF (0) Honor all <ch> arguments. This means the <ch> channel is calibrated regardless of which channel is currently active.

ON (1) Legacy behavior. Behavior is specified by the following table:

<ch> channel type Std or App | Active channel type Std or App | Behavior
Std | Std | Active chan cal'd
Std | App | "Channel not found" error
App | Std | <ch> chan cal'd
App | App | <ch> chan cal'd

Learn about Standard vs Application channels.

Examples

SENS:CORR:COLL:GUID:CHAN:MODE 0

sense:correction:collect:guided:channel:mode ON

Query Syntax

SENSe:CORRection:COLLect:GUIDed:CHANnel:MODE?

Return Type

Boolean

Default

OFF

SENSe:CORRection:COLLect:GUIDed:CKIT:CATalog? <connector>

Applicable Models: E5080A, M9485A

(Read-only) This command replaces SENS:CORR:COLL:GUID:CKIT:PORT:CAT?

Returns a comma-separated list of valid kits that use the specified connector type. This includes mechanical cal kits, applicable characterizations found within ECal modules currently connected to the VNA, and all user characterizations stored in VNA disk memory. For ECal modules, the returned list includes the serial numbers. See ECal User Characterization commands.

Use items in the list to select the kit to be used with the SENS:CORR:COLL:GUID:CKIT:PORT and SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:CKIT commands.

Parameters

<conn>

String. Connector type. Use SENS:CORR:COLL:GUID:CONN:CAT? to return a list of valid connector types.

Examples

SENSe:CORR:COLL:GUID:CKIT:CAT? "Type N (50) male"

Return Type

String

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect] <kit>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the calibration kit (mechanical or ECal) for each port to be used during a guided calibration. An unused port does NOT need to have a specified Cal Kit.

  1. Specify the connector type for the port with SENS:CORR:COLL:GUID:CONN:PORT.

  2. Query the valid available kits for the connector on each port with SENS:CORR:COLL:GUID:CKIT:PORT:CAT?

  3. Specify the kit using this command.

  4. Perform a query of this command. If the <kit> parameter was incorrectly entered, an error will be returned.

When using this command to specify the cal kit for the output of a VMC calibration mixer, specify port 3. If port 3 is already used for the output of the DUT mixer, then specify port 4. Learn more.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Any existing port number. If unspecified, value is set to 1

<kit>

Calibration kit to be used for the specified port. Case-sensitive.

When using an ECal module, include the characterization name in the <kit> string. Use SENSe:CORR:COLL:GUID:CKIT:CAT? to read the list of characterizations available in the module and in VNA disk memory.

If two or more identical ECal modules are connected to the VNA, the serial number must be included to distinguish the ECal modules.

Examples

'Note: All of the following examples specify port 1 only

' Mechanical Cal kit

SENS:CORR:COLL:GUID:CKIT:PORT1 '85055A'

' Standard ECal modules

SENS:CORR:COLL:GUID:CKIT:PORT1 "N4691-60004 ECal"

' Non-factory ECal characterizations are specified as follows:

SENS:CORR:COLL:GUID:CKIT:PORT1 "N4691-60004 User 1 ECal"

' When two or more ECal modules with the same model number are

' connected, also specify the serial number as follows:

SENS:CORR:COLL:GUID:CKIT:PORT1 "N4691-60004 ECal 01234"

' When Disk Memory ECal user characterizations are used,

' specify both the User char and the serial number as follows:

SENS:CORR:COLL:GUID:CKIT:PORT1 "N4691-60004 MyDskChar ECal 01234"

Query Syntax

SENSe:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect]?

Return Type

String - If the <kit> parameter was incorrectly entered while writing, an error will be returned.

Default

Not Applicable

SENSe:CORRection:COLLect:GUIDed:CONNector:CATalog?

Applicable Models: E5080A, M9485A

(Read only) Returns a list of valid connectors based on the connector descriptions of the available cal kits. Use an item from the returned list to specify a connector for SENS:CORR:COLL:GUID:CONN:PORT

Here are the more common connector types:

W-band waveguide

V-band waveguide

U-band waveguide

R-band waveguide

Q-band waveguide

K-band waveguide

P-band waveguide

X-band waveguide

7-16 female

7-16 male

Type B

Type A (50) female

Type A (50) male

Type F (75) female

Type F (75) male

Type N (75) female

Type N (75) male

Type N (50) female

Type N (50) male

1.00 mm female

1.00 mm male

1.85 mm male

1.85 mm female

2.92 mm female

2.92 mm male

APC 2.4 female

APC 2.4 male

APC 3.5 female

APC 3.5 male

APC 7

Examples

SENS:CORR:COLL:GUID:CONN:CAT?
Returns:

Type N (50) female, Type N (50) male, APC 7 (50), 3.5 mm (50) male, 3.5 mm (50) female, User Connector A

Return Type

Comma separated string values

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect] <conn>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies a connector type for every port during the Guided Calibration procedure. Valid connector names are stored within calibration kits. Some cal kits may include both male and female connectors. Therefore, specifying connector gender may be required.

The VNA remembers previous Guided Cal settings. Therefore, for completeness, unused ports should be defined as "Not used". See Guided Cal examples.

  • A single port with a valid <conn> name indicates a 1-Port calibration will be performed.

  • Two ports with valid <conn> names indicate either a 2-Port SOLT or TRL calibration will be performed depending on the standards definition found within the cal kit and the capability of the VNA.

  • Three ports with valid <conn> names indicate a 3-Port calibration will be performed, and so forth.

Follow these steps to ensure port connectors are specified correctly:

  1. Use SENS:CORR:COLL:GUID:CONN:CAT? to query available connectors before specifying the port connector.

  2. Set a connector type for each port using this command.

  3. Perform a query of this command. If the connector type was incorrectly entered, an error will be returned.

  4. Specify the cal kit to use for each port with SENS:CORR:COLL:GUID:CKIT:PORT

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Any existing port number. If unspecified, value is set to 1.

<conn>

String - DUT connector type to connect with VNA port <pnum>. Case-sensitive.

Examples

'Specifying a 2-port cal (1 & 2) on a 4-port VNA

SENS:CORR:COLL:GUID:CONN:PORT1 'Type N (50) female'
SENS:CORR:COLL:GUID:CONN:PORT2 'Type N (50) male'
SENS:CORR:COLL:GUID:CONN:PORT3 'Not used'
SENS:CORR:COLL:GUID:CONN:PORT4 'Not used'

Query Syntax

SENSe:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect]?

Return Type

String

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:DESCription? <step>

Applicable Models: E5080A, M9485A

(Read-only) Returns the connection description for the specified calibration step.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<step> | A number from 1 to the number of steps required to complete the calibration (Use SENS:CORR:COLL:GUID:STEP? to query the number of steps )
Examples | SENS:CORR:COLL:GUID:DESC? 10 'Returns: Connect APC 7 Open to port3
Return Type | String
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ECAL:ACQ <cal method>. <port list>, [calset]

Applicable Models: E5080A, M9485A

(Write only) Execute the Ecal calibration with specified the Ecal by SENS:CORR:COLL:GUID:ECAL:SEL. If ECal module is not specified, the first Ecal in the list is used.

Parameters

<ch>

Channel to be calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<cal method>

String Calibration Method.

SOLT: using defined through

SOLR: using undefined through

ERESponse: Enhanced Response

<port list>

Array Port number to be calibrated. If enhanced response (ERESponse) is selected, the first port number is the stimulus port and the second port number is the response port.

[calset]

Optional argument. Cal Set name

If NOT specified, behavior depends on the SENS:CORR:PREFerence:CSET:SAVE setting.

If specified, choose an existing Cal Set, either by name or by GUID.

  • By Cal Set name: include quotes.

  • By Cal Set GUID in the form: "{GUID}"; including quotes and curly brackets.

  • Query all Cal Set GUIDs with SENS:CORR:CSET:CAT?

An error is reported if the Cal Set is not found.

The Cal Set is either supplemented or overwritten depending on the method, connectors, and ports selected. Learn more about Cal Sets.

Examples

' Full 2 port cal with defined through for ports 2 and 3

SENS:CORR:COLL:GUID:ECAL:ACQ SOLT,2,3

' Enhance Response Cal for ports 4 (Stimulus) and 1 (Response)

SENS:CORR:COLL:GUID:ECAL:ACQ ERES,4,1

' Full 2 port cal with calset and undefined through for ports 1 to 4

SENS:CORR:COLL:GUID:ECAL:ACQ SOLR,1,2,3,4,"MyCalSet"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ECAL[:SELect] <ecal kit>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the Ecal Kit for Ecal Calibration.

Parameters

<ch>

Channel to be calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<ecal kit>

Ecal kit to be used for the specified port. Case-sensitive.

Include the characterization name in the <kit> string. Use SENSe:CORR:COLL:GUID:CKIT:CAT? to read the list of characterizations available in the module and in VNA disk memory.

If two or more identical ECal modules are connected to the VNA, the serial number must be included to distinguish the ECal modules.

Examples

' Standard ECal modules

SENS:CORR:COLL:GUID:ECAL "N4691-60004 ECal"

' Non-factory ECal characterizations are specified as follows:

SENS:CORR:COLL:GUID:ECAL "N4691-60004 User 1 ECal"

' When two or more ECal modules with the same model number are

' connected, also specify the serial number as follows:

SENS:CORR:COLL:GUID:ECAL "N4691-60004 ECal 01234"

' When Disk Memory ECal user characterizations are used,

' specify both the User char and the serial number as follows:

SENS:CORR:COLL:GUID:ECAL "N4691-60004 MyDskChar ECal 01234"

Query Syntax

SENSe:CORRection:COLLect:GUIDed:ECAL[:SELect]?

Return Type

String - If the <kit> parameter was incorrectly entered while writing, an error will be returned.

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ETERms:LOAD[:CSET] <cset>,<calPort> [,csPort]

Applicable Models: E5080A, M9485A

(Write-only) Loads 1-port error terms from a Cal Set into the current Guided Cal sequence. When the Cal steps are recomputed, connection steps are removed due to the loading of the error terms. See example of how to use this command. NOTE: Most users do no need this command.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<cset> | String Name of User Cal Set in which the error terms reside.
<pnum> | Integer Port number of the current cal to receive error terms.
[csPort] | Integer Optional argument. Port number associated with the error terms in the Cal Set. If unspecified, the same port number as <calPort> is used.
Examples | See example
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:INITiate[:IMMediate] [string][, bool][,char]

Applicable Models: E5080A, M9485A

(Write-only) Initiates a guided calibration.

  • The VNA determines the measurements needed to perform the calibration using the settings specified from the SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.

  • After this command is executed, subsequent commands can be used to query the number of measurement steps, issue the acquisition commands, query the connection description strings, and subsequently complete a guided calibration. See example calibration programs.

Parameters

<ch>

Channel to be calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

[string]

Optional argument. Cal Set name or GUID enclosed in quotes.

If NOT specified, behavior depends on the SENS:CORR:PREFerence:CSET:SAVE setting.

If specified, choose an existing Cal Set, either by name or by GUID.

  • By Cal Set name: include quotes.

  • By Cal Set GUID in the form: "{GUID}"; including quotes and curly brackets.

  • Query all Cal Set GUIDs with SENS:CORR:CSET:CAT?

An error is reported if the Cal Set is not found.

The Cal Set is either supplemented or overwritten depending on the method, connectors, and ports selected. Learn more about Cal Sets.

[bool]

Optional argument. To set this argument, also set the first optional argument. See example below.

OFF (0) If Cal Set stimulus settings differ from the existing channel, do not change channel stimulus settings. The Cal Set is saved to the current setting of the SENS:CORR:PREF:CSET:SAVE command. This is the default setting if not specified.

ON (1) If Cal Set stimulus settings differ from the existing channel, change the channel stimulus settings to match the Cal Set settings.

[char]

Optional argument. To set this argument, also set the first two optional arguments. See example below.

SYNChronous - blocks further SCPI commands while processing this command.. (default setting).

ASYNchronous - does NOT block further SCPI commands while processing this command.

Learn more about this argument

Examples

SENS:CORR:COLL:GUID:INIT

'set first optional argument

SENS:CORR:COLL:GUID:INIT "MyCalSet"

'set two optional arguments

SENS:CORR:COLL:GUID:INIT " ",1

'set all optional arguments

SENS:CORR:COLL:GUID:INIT "MyCalSet",1,ASYN

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ISOLation:AVERage:INCRement <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies amount to increment (increase) the channels averaging factor during measurement of isolation standards in a guided calibration.

Note: If the channel has averaging turned OFF and the value of <num> is greater than 1, averaging will be turned ON only during the isolation measurements and with the averaging factor equal to <num>.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<num>

Amount to increment the averaging factor for the isolation measurement. The maximum averaging factor for the channel is 65536 (2^16).

Examples

'Measure isolation on all paths for the cal

SENS:CORR:COLL:GUID:ISOL ALL

'Remove the port pairs 1-to-2 and 1-to-3 from the list of paths on which to measure isolation

sense:correction:collect:guided:isolation:paths REMove,1,2,1,3

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:ISOLation:AVERage:INCRement?

Return Type

Numeric

Default

8 - If this command is NOT sent, but isolation is measured, then averaging will be turned ON with factor set to 8 during the isolation measurements.

SENSe<ch>:CORRection:COLLect:GUIDed:ISOLation[:PATHs] <char>[,<p1a, p1b, p2a, p2b]

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the paths (port pairs) to make isolation measurements on during a guided calibration.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<char>

ALL Measure isolation on all pairings of the ports that are to be calibrated.

NONE Do not measure isolation on any pairing of the ports to be calibrated. (Default behavior).

ADD Add one or more specific pairings of ports to the list of port pairings for which isolation will be measured.

REMove Remove one or more specific pairings of ports from the list of port pairings for which isolation will be measured. If many paths are to be measured, it may be easier to first send ALL, then REMove and specify the paths to remove.

<p1a, p2a...>

For use when <char> is ADD or REMove.

Specify Port numbers in pairs:

  • For 3-port cals, specify up to 3 pairs.

  • For 4-port cals, specify up to 6 pairs.

p1a, p1b (Path1 - port A and port B)

p2a, p2b (Path2 - port A and port B)

p3a, p3b (Path3 - port A and port B)

Examples

'Measure isolation on all paths for the cal

SENS:CORR:COLL:GUID:ISOL ALL

'Remove the port pairs 1-to-2 and 1-to-3 from the list of paths on which to measure isolation

sense:correction:collect:guided:isolation:paths REMove,1,2,1,3

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:ISOLation:PATHs?

Note: if isolation is not be measured on any of the paths, the query returns 0

Return Type

Numeric

Default

0 - Isolation not measured on any paths.

SENSe<ch>:CORRection:COLLect:GUIDed:ITERations:COUNt? <step>

Applicable Models: E5080A, M9485A

(Read-only) Designed to be used for an iterative cal standard such as a sliding load, this command returns the number of iterative measurement acquisitions that has been made for the specified step. Zero (0) is returned if the step has not yet been measured. For most cal steps that have already been measured, this command returns 1. Set SENS:CORR:COLL:GUID:PREF:SLID ITER to count acquisition steps.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<step> | Guided Cal step number for which the acquisition number will be returned. Use SENS:CORR:COLL:GUID:STEP? to query the number of steps in the calibration.
Examples | SENS:CORR:COLL:GUID:ITER:COUN? 4 'Example return: 5 See example program
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ITERations:MINimum? <step>

Applicable Models: E5080A, M9485A

(Read-only) Designed to be used for an iterative cal standard such as a sliding load, this command returns the minimum number of required iterative measurement acquisitions for the specified step.

For most connection steps this will return 1, but for an iterative cal standard such as a sliding load, it will return a number such as 5.

Set SENS:CORR:COLL:GUID:PREF:SLID ITER to count acquisition steps.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<step>

Guided Cal step number for which to return the number of iterative measurement acquisitions that have been made. Use SENS:CORR:COLL:GUID:STEP? to query the number of steps in the calibration.

Examples

SENS:CORR:COLL:GUID:ITER:MIN? 4

'Example return:

5

See example program

Return Type

Numeric

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:ITERations:RESet <step>

Applicable Models: E5080A, M9485A

(Write-only) Resets the specified guided cal connection step as unmeasured. This clears all previous measurements made for that step.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<step> | Guided Cal step number to reset. Use SENS:CORR:COLL:GUID:STEP? to query the number of steps in the calibration.
Examples | SENS:CORR:COLL:GUID:ITER:RESet? 4 See example program
Return Type | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PACQuire <std>

Applicable Models: E5080A, M9485A

(Write-only) Show the Cal Window, and optionally one or more other specific windows before acquiring a Cal standard. This command will cause the Cal Window to display the specific measurements that are to be made for that particular Cal standard. NOTE: Most users do no need this command.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<std> | Choose from:STAN1, STAN2, STAN3, through STAN40.
Examples | SENS:CORR:COLL:GUID:PACQuire STAN2 sense:correction:collect:guided:pacquire STAN5 See an example that uses this command.
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PATH:CMEThod <port1>,<port2>,<caltype1[,caltype2]>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the calibration method for each port pair.

Note: Sending this command will overwrite the PNAs SmartCal determinations for the most accurate cal method for your connector settings and Cal Kits. Send this command ONLY if you have a deliberate reason for overwriting the SmartCal logic. You can send the query form of this command to learn the cal method determined by SmartCal.

See Thru Pairs Sequence to learn how to send this and other Thru commands.

After sending this command, send the query form to be sure that the command was accepted. If not, then the chosen Cal method is not compatible with the specified Thru method. For example, if the specified Thru method is Unknown Thru, an attempt to set Enhanced Response Cal should be rejected.

Learn more about Thru Methods.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<port1>

First port of the pair to be calibrated.

<port2>

Second port of the pair to be calibrated.

<caltype1[caltype2]>

(String) Cal type for the port pair, enclosed in a single pair of quotes. NOT case-sensitive.

caltype1 Choose from:

  • TRL

  • SOLT

  • QSOLTN

  • EnhRespN

For the last two arguments, replace N with the port to be used as the source port, which MUST be one of the port pair.

caltype2 Optional argument. Use only when performing an adapter removal cal on the pair. This argument specifies the Cal type on the second port. Caltype1 then specifies the Cal type of the first port.

Choose from the same arguments as caltype1.

Examples

SENS:CORR:COLL:GUID:PATH:CMEThod 2,3,"QSOLT2"

sense:correction:collect:guided:path:cmethod 2,3,"solt,trl"

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PATH:CMEThod? <port1>,<port2>

If only one caltype is returned then its NOT adapter removal.

Return Type

String

Default

The most accurate Cal method for the current cal.

SENSe<ch>:CORRection:COLLect:GUIDed:PATH:TMEThod <port1>,<port2>,<thruType1[,thruType2]>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the calibration THRU method for each port pair.

Note: Sending this command will overwrite the VNAs SmartCal determination for the thru method. Send this command ONLY if you have a deliberate reason for overwriting the SmartCal logic. You can send the query form of this command to learn the THRU method determined by SmartCal.

See Thru Pairs Sequence to learn how to send this and other Thru commands.

Learn more about Thru methods.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<port1>

First port of the port pair to be calibrated.

<port2>

Second port of the port pair to be calibrated.

<thruType1>

(String) Thru methods for port pair, enclosed in a single pair of quotes. NOT case-sensitive.

Calibration Thru method. Choose from:

  • Defined Thru Measures a Thru for which there is a stored definition in the Cal kit of the lowest-numbered port of the pair. For example, if the port pair is 1,2, then the cal kit for port 1 MUST contain a Defined Thru.

  • Zero Thru Measures a Zero length Thru, also known as Flush-Thru.

  • Undefined Thru (Also known as Unknown Thru) A Thru type for which there is NOT a stored definition in the Cal Kit. Valid ONLY for SOLT cal type.

  • Undefined Thru using a Defined Thru (ECal modules ONLY) Measures the internal Thru as an Unknown Thru.

<thruType2>

(String) Thru methods for port pair.

Optional argument. Use ONLY when Adapter Removal Cal is specified for the pair using SENS:CORR:COLL:GUID:PATH:CMEThod. When specifying ThruType2, this is the only valid argument: "Defined Thru, Defined Thru"

Examples

SENS:CORR:COLL:GUID:PATH:TMEThod 2,3,"Zero Thru"
sense:correction:collect:guided:path:tmethod 2,3,"Defined Thru,Defined Thru"

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PATH:TMEThod? <port1>,<port2>

Always returns two parts:

If the second part of the string is empty, adapter removal is NOT being performed.

If the string is "Defined Thru, Defined Thru", adapter removal IS being performed.

If the string is set to "Zero Thru", query is returned as "Defined Thru"

Return Type

String

Default

The most accurate Thru method for the current cal.

SENSe<ch>:CORRection:COLLect:GUIDed:PREFerence:SLIDingload <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the behavior for guided cal steps that involve a sliding load in a cal that is about to be performed. Send this command BEFORE sending the Guided INIT command.

Although the term 'Preference' is used in the command, this is NOT a VNA preference. This setting does NOT survive instrument preset or reboot. It remains ONLY for the duration of the Guided Cal.

Parameters

<char>

Behavior when measurements of sliding load are acquired. Choose from:

DIALog - The Sliding load dialog box appears when the acquire command is received for a sliding load step. All slide positions are measured (with a user-interface prompt) from a single invocation of the acquire command.

ITERate - Each invocation of the acquire command for a sliding load step measures a single slide position and increments the slide position counter. No Move Sliding Load prompt is presented on the VNA screen.

Examples

SENS:CORR:COLL:GUID:PREF:SLID ITER

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PREFerence:SLIDingload?

Return Type

Character

Default

DIALog

SENSe<ch>:CORRection:COLLect:GUIDed:SAVE[:IMMediate] [bool]

Applicable Models: E5080A, M9485A

(Write-only) Completes the guided cal by computing the error correction terms, turning Correction ON, and saving the calibration to a Cal Set. If all of the required standards have not been measured, the calibration will not complete properly.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

[bool]

Optional argument. If unspecified, the default behavior is the current VNA preference setting of SENSe:CORRection:PREFerence:CSET:SAVE

OFF (0) Save cal data ONLY to a Cal Register.

ON (1) Save cal data to a Cal Register and a User Cal Set. The filename is automatically generated.

  • For application channels (Gain Compression, SMC/VMC, Noise Figure, IMD and so forth), this command saves ONLY to a Cal Register. Use SENS:CORR:CSET:COPY to copy the cal register to a named calset.

  • For a Calibrate All Channels session, this argument is ignored. Instead, use SYST:CAL:ALL:CSET:PREFix.

Examples

SENS:CORR:COLL:GUID:SAVE
sense2:correction:collect:guided:save:immediate 0

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:SAVE:CSET <cal set name or guid>

Applicable Models: E5080A, M9485A

(Write-only) Completes the guided cal by computing the error correction terms, turning Correction ON, and saving the calibration to an existing, specified Cal Set. This command performs the same function as SENSe:CORRection:COLLect:GUIDed:SAVE, except this command allows the name or GUID of the Cal Set to be specified.

Note: This command is NOT supported for application channels (Gain Compression, SMC/VMC, Noise Figure, IMD and so forth). Use SENS:CORR:COLL:GUID:SAVE and save to a cal register. You can then use SENS:CORR:CSET:COPY to copy the cal register to a named calset.

  • Use this command instead of specifying the optional name or GUID argument in SENS:CORR:COLL:GUID:INIT.

  • Use SENS:CORRection:CSET commands to get names or GUIDs of existing Cal Sets.

  • The cal data is also saved to the channel Cal Register.

  • If all of the required standards have not been measured, the calibration will not complete properly.

For Calibrate All Channels

When this command is used during a Cal All session, the <cal set name> argument sets the User Cal Set prefix. All generated Cal Sets will be preceded with this string name.

  • Cal Set prefix can also be set using SYST:CAL:ALL:CSET:PREFix. When the Cal Set prefix has already been set with SYST:CAL:ALL:CSET:PREFix, this command overwrites it.

  • When <cal set name> is an empty string, a User Cal Set will not be saved. Only Cal Registers will be saved.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<cal set name or guid>

String - Name or GUID of an existing Cal Set to be overwritten. If specifying a GUID, curly brackets must be included.

See Calibrate All Channels note (above).

Examples

SENS:CORR:COLL:GUID:SAVE:CSET "{2B893E7A-971A-11d5-8D6C-00108334AE96}"

sense:correction:collect:guided:save:cset "MyCalSet"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:STEPs?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of measurement steps required to complete the current guided calibration. This command is sent after the SENS:CORR:COLL:GUID:INIT, SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
Examples | SENS:CORR:COLL:GUID:STEP? sense2:correction:collect:guided:steps?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:THRU:PORTs <t1a, t1b, t2a, t2b, t3a, t3b...>

Applicable Models: E5080A, M9485A

(Read-Write) For calibrating more than 2-ports ONLY. Specifies the port pairs for the Thru connections of the calibration. Send the query form of this command to learn the Thru pairs determined by SmartCal.

Note: Sending this command will overwrite the PNAs SmartCal determinations for the thru ports. Send this command ONLY if you have a deliberate reason for overwriting the SmartCal logic.

See Thru Pairs Sequence to learn how to send this and other Thru commands.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<t1a,t1b...>

Always specify port numbers in pairs: For example: 1,2 or 1,2,1,3

  • For 3-port cals, specify two or three pairs.

  • For 4-port cals, specify from three up to six pairs.

Examples

SENS:CORR:COLL:GUID:THRU:PORT 1,2,1,3,1,4 '4-port measurement

sense:correction:collect:guided:thru:ports 1,2,2,3 '3-port measurement

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:THRU:PORTs?

Return Type

Numeric

Default

Port pairings that were used in the previous cal.

THRU Pairs sequence

The SmartCal logic always determines the best calibration based on your specified connectors and ports.

The following three commands overwrite the SmartCal logic. Send these commands ONLY if you have a deliberate reason for overwriting the SmartCal logic.

  • sens:corr:coll:guid:thru:ports <p1, p2>

  • sens:corr:coll:guid:path:tmet <p1,p2, thrutype>

  • sens:corr:coll:guid:path:cmet <p1,p2, calmethod>

When sending one or more of these commands, they must be sent in the following sequence with the other commands listed here.

Note: The GUID:INIT command is sent before and after these commands.

  1. sens:corr:coll:guid:conn:port(n)

  2. sens:corr:coll:guid:ckit:port (n)

  3. sens:corr:coll:guid:init

  4. sens:corr:coll:guid:thru:ports <p1, p2>

  5. sens:corr:coll:guid:path:tmet <p1,p2, thrutype>

  6. sens:corr:coll:guid:path:cmet <p1,p2, calmethod>

  7. sens:corr:coll:guid:path:cmet ? <p1,p2> (recommended)

  8. sens:corr:coll:guid:init

Last modified:

18-Mar-2015

First release


Couple SCPI

Sense:Couple Commands

SENSe:COUPle:

PARameter[STATe]

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:COUPle:PARameter[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON and OFF Time Domain Trace Coupling. All of the measurements in the specified channel are coupled.

  • To select Transform parameters to couple, use CALC:TRAN:COUP:PAR

  • To select Gating parameters to couple, use CALC:FILT:COUP:PAR

Learn more about Time Domain Trace Coupling.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<bool>

ON or 1 - Turns ON Time Domain Trace Coupling.

OFF or 0 - Turns OFF Time Domain Trace Coupling.

Examples

SENS:COUP:PAR 0
sense2:couple:parameter:state on

Query Syntax

SENSe<cnum>:COUPle:PARameter[:STATe]?

Return Type

Boolean

Default

ON or 1

Last Modified:

6-Jan-2016

First Release


FOM

Sense:FOM (Frequency Offset) Commands

Controls the frequency offset settings which cause stimulus and response frequencies to be different.

Note: These commands replace the previous FOM commands. Although the old commands will continue to work, they can NOT be mixed with these new commands.

SENSe:FOM:

CATalog?

COUNt?

DISPlay

| SELect

RNUM?

[STATe]

RANGe

| COUPled

| FREQuency

| CW

| DIVisor

| MULTiplier

| OFFSet

| STARt

| STOP

| NAME | NAMe?

| SEGMent More Commands

| SWEep:TYPE

Click on a Red keyword to view the command details.

See Also

  • FOM Example Program

  • Learn about Frequency Offset

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:FOM:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns a comma-separated list of available range names in the VNA. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number. External devices can appear in the list of range names. Learn more.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:FOM:CAT? 'returns "Primary, Source, Receivers"
Return Type | String
Default | Not Applicable

SENSe<cnum>:FOM:COUNt?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of valid range numbers in the VNA.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:FOM:COUN? sense2:fom:count?
Query Syntax | SENSe<cnum>:FOM:COUNt?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:FOM:DISPlay:SELect <string>

Applicable Models: E5080A, M9485A

(Read-Write) Select the range to be displayed on the VNA x-axis. All traces in the channel have this same x-axis scaling.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<string> | Range name. Case insensitive. Use SENSe:FOM:CAT? to see a list of available frequency range names.
Examples | SENS:FOM:DISPlay:SELect "source2" sense2:fom:display:select "source"
Query Syntax | SENSe<cnum>:FOM:DISPlay:SELect?
Return Type | String
Default | Receivers

SENSe<cnum>:FOM:RNUM? <string>

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of a specified range name.

Use SENS:FOM:CAT? to see a list of available range names.

Use SENS:FOM:COUNt? to see a list of available range numbers.

Use SENS:FOM:RANG:NAME? to see the range name for a specific number.

External devices can appear in the list of range names. Learn more.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<string>

Range name for which a number is being queried. Case insensitive.

The FOM range items are typically numbered as follows:

  1. Primary

  2. Source

  3. Receivers

  4. Source2 (if present)

Examples

SENS:FOM:RNUM? "receivers"
sense2:fom:rnum? "Source2"

Return Type

Numeric

Default

Not Applicable

SENSe<cnum>:FOM[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns Frequency Offset ON and OFF. Frequency offset settings are not enabled until this setting is ON. Send this command (FOM ON) AFTER sending other FOM settings to avoid 'out-or-range' errors.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<bool> | ON or 1 - Turns FOM ON. OFF or 0 - Turns FOM OFF.
Examples | SENS:FOM 1 sense2:fom:state on
Query Syntax | SENSe<cnum>:FOM:STATe?
Return Type | Boolean
Default | OFF

SENSe<cnum>:FOM:RANGe<n>:COUPled <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the state of coupling (ON or OFF) of the specified range to the primary range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number to couple to primary range. An error is returned when attempting to couple to the Primary range (1). Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<bool> | ON or 1 - Couple range to primary range. OFF or 0 - Do NOT couple to primary range.
Examples | SENS:FOM:RANG:COUP 1 sense2:fom:range2:coupled 0
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:COUPled?
Return Type | Boolean
Default | ON (or 1) Coupled

SENSe<cnum>:FOM:RANGe<n>:FREQuency:CW <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the CW frequency. This setting is valid for the primary range, or if the specified range is already uncoupled from the primary range and if the sweep type is CW.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | CW frequency value in Hz. Choose any frequency within the range of the VNA.
Examples | SENS:FOM:RANG:FREQ:CW 1e9 sense2:fom:range2:frequency:cw 10000000
Query Syntax | SENSe<cnum>:FOM:RANGe:<n>:FREQuency:CW?
Return Type | Numeric
Default | Center frequency of the VNA.

SENSe<cnum>:FOM:RANGe<n>:FREQuency:DIVisor <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the divisor value. This setting is valid only if the specified range is coupled to the primary range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | Divisor value (unitless).
Examples | SENS:FOM:RANG:FREQ:DIV 3 sense2:fom:range2:frequency:divisor 0
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:FREQuency:DIVisor?
Return Type | Numeric
Default | 1

SENSe<cnum>:FOM:RANGe<n>:FREQuency:MULTiplier <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the multiplier value to be used when coupling this range to the primary range. This setting is valid only if the specified range is coupled to the primary range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | Multiplier value. (Unitless)
Examples | SENS:FOM:RANG:FREQ:MULT 1 sense2:fom:range2:frequency:multiplier 2
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:FREQuency:MULTplier?
Return Type | Numeric
Default | 1

SENSe<cnum>:FOM:RANGe<n>:FREQuency:OFFSet <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the offset value to be used when coupling this range to the primary range. Learn more about offset value. This setting is valid only if the specified range is coupled to the primary range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | Offset value. (Unitless)
Examples | SENS:FOM:RANG:FREQ:OFFS 1E9 sense2:fom:range2:frequency:offset 10000000
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:FREQuency:OFFSet?
Return Type | Numeric
Default | 0

SENSe<cnum>:FOM:RANGe<n>:FREQuency:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Start value of frequency range. Also specify Stop frequency. This setting is valid for the primary range, or if the specified range is already uncoupled from the primary range and if the sweep type is LOG or LINear.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | Start value in Hz. Choose any frequency within the range of the VNA.
Examples | SENS:FOM:RANG:FREQ:STAR 1GHz sense2:fom:range2:frequency:start 100000000
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:FREQuency:STARt?
Return Type | Numeric
Default | Minimum frequency of the VNA.

SENSe<cnum>:FOM:RANGe<n>:FREQuency:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Stop value of frequency range. Also specify Start frequency. This setting is valid for the primary range, or if the specified range is already uncoupled from the primary range and if the sweep type is LOG or LINear.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<num> | Stop value in Hz. Choose any frequency within the range of the VNA.
Examples | SENS:FOM:RANG:FREQ:STOP 1e12 sense2:fom:range2:frequency:stop 10000000000
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:FREQuency:STOP?
Return Type | Numeric
Default | Maximum frequency of the VNA.

SENSe<cnum>:FOM:RANGe<n>:NAME | NAMe?

Applicable Models: E5080A, M9485A

(Read-only) Returns the name of range<n>.

The FOM range items are typically named as follows:

  1. Primary

  2. Source

  3. Receivers

  4. Source2 (if present)

Use SENS:FOM:CAT? to see a list of available range names.

Use SENS:FOM:COUNt? to see a list of available range numbers.

Use SENS:FOM:RNUM? to see the range number for a specific name.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<n>

Range number. If unspecified, value is set to 1.

Examples

SENS:FOM:RANG:NAME?
sense2:fom:range2:name?

Return Type

String

Default

Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SWEep:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the sweep type to be used with the specified range. This setting is valid only if the specified range is already uncoupled from the primary range. Learn about Unsupported Sweep Type combinations.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1. Use SENS:FOM:CAT? to see a list of available range names. Use SENS:FOM:COUNt? to see a list of available range numbers. Use SENS:FOM:RNUM? to see the range number for a specific name. Use SENS:FOM:RANG:NAME? to see the range name for a specific number.
<char> | Sweep type. Choose from: CW - Also specify CW frequency. LINear - Also specify frequency Start/Stop or Center/Span LOG - Also specify frequency Start/Stop or Center/Span PHASe - See all Phase sweep settings. POWer - Also specify power Start/Stop or Center/Span SEGMent - Also specify segment sweep settings.
Examples | SENS:FOM:RANG:SWE:TYPE LOG sense2:fom:range2:sweep:type linear:
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SWEep:TYPE?
Return Type | Character
Default | Linear

Last Modified:

6-Jan-2016

First Release


FOMSegm

Sense:FOM:Range:Segment Commands

Constructs a segment table for a specified UNCOUPLED FOM range.

Note: Do NOT use Sens:Segment commands for FOM segment sweep.

SENSe:FOM:RANGe:SEGMent:

ADD

BWIDth[RESolution]

BWIDth[RESolution]:CONTrol

COUNt?

DELete

| ALL

FREQuency

| CENTer

| SPAN

| STARt

| STOP

POWer[LEVel]

| CONTrol

[STATe]

SWEep

| POINts

| TIME

| CONTrol

Click on a Red keyword to view the command details.

See Also

  • Other SENSe:FOM Commands

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:ADD

Applicable Models: E5080A, M9485A

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. sense2:fom:range2:segment:add
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:BWIDth[:RESolution] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the IF Bandwidth for the specified segment. First set SENS:FOM:RANGe:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value. Valid either for Receiver range or for Primary range when coupled to Receiver.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number for which to set independent IF Bandwidth.
<num> | IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the VNA model. See the list of valid IFBW values. If an invalid number is specified, the analyzer will round up to the closest valid number.
Examples | SENS:FOM:RANG:SEGM:BWIDth 100 sense2:fom:range2:segment4:bwidth:resolution 1e3
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:BWIDth[:RESolution]?
Return Type | Numeric
Default | Varies with model.

SENSe<cnum>:FOM:RANGe<n>:SEGMent:BWIDth[:RESolution]:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment. When set, each segment added after this will be set to ON automatically.

Valid either for Receiver range or for Primary range. Primary range value is ignored unless Receiver is coupled to Primary.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<n>

Range number. If unspecified, value is set to 1.

<bool>

ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment

OFF (or 0) - turns Bandwidth control OFF. Use the channel IF bandwidth setting instead.

Examples

SENS:FOM:RANG:SEGM:BWIDth:CONT 0

sense2:fom:range2:segment:bwidth:resolution:control 1

Query Syntax

SENSe<cnum>:FOM:RANGe<n>:SEGMent:BWIDth[:RESolution]:CONTrol?

Return Type

Boolean

Default

OFF

SENSe<cnum>:FOM:RANGe<n>:SEGMent:COUNt?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of segments that exist for the specified range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
Examples | SENS:FOM:RANG:SEGM:COUN? sense2:fom:range2:segment:count?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes the specified sweep segment.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Number of the segment to delete. If unspecified, value is set to 1.
Examples | SENS:FOM:RANG:SEGM3:DEL sense2:fom:range2:segment4:delete
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SEGMent:DELete:ALL

Applicable Models: E5080A, M9485A

(Write-only) Deletes all sweep segments in the specified range.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
Examples | SENS:FOM:RANG:SEGM:DEL:ALL sense2:fom:range2:segment:delete:all
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the center frequency for the specified sweep segment. Also specify segment frequency span.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to modify. Choose any existing segment number.
<num> | Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.
Examples | SENS:FOM:RANG:SEGM:FREQ:CENT 1GHz sense2:fom:range2:segment4:frequency:center 1e9
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:CENTer?
Return Type | Numeric
Default | Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the span frequency for the specified sweep segment. Also specify segment center frequency.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to modify. Choose any existing segment number.
<num> | Frequency span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.
Examples | SENS:FOM:RANG:SEGM:FREQ:SPAN 1GHz sense2:fom:range2:segment4:frequency:span 1e9
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:SPAN?
Return Type | Numeric
Default | If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the start frequency for the specified sweep segment. Also specify segment stop frequency.

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<n>

Range number. If unspecified, value is set to 1.

<s>

Segment number to modify. Choose any existing segment number.

<num>

Start frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Examples

SENS:FOM:RANG:SEGM:FREQ:STAR 1GHz

sense2:fom:range2:segment4:frequency:start 1e9

Query Syntax

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:STARt?

Return Type

Numeric

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the stop frequency for the specified sweep segment. Also specify segment start frequency.

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<n>

Range number. If unspecified, value is set to 1.

<s>

Segment number to modify. Choose any existing segment number.

<num>

Stop frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Examples

SENS:FOM:RANG:SEGM:FREQ:STOP 1GHz

sense2:fom:range2:segment4:frequency:stop 1e9

Query Syntax

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:FREQuency:STOP?

Return Type

Numeric

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:POWer<p>[:LEVel] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:FOM:RANG:SEGM:POW:CONTrol ON.

When port power is Coupled, setting port power for one port will apply port power for all source ports.

All subsequent segments that are added assume the new Power Level value.

Valid either for Source ranges or for Primary range when coupled to the source.

Parameters

<cnum>

Any existing channel number; if unspecified, value is set to 1.

<n>

Range number. If unspecified, value is set to 1.

<s>

Segment number to modify. Choose any existing segment number.

<p>

Port number of the source. If unspecified, value is set to 1.

<num>

Power level in dBm.

Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, send SOUR:POW? MAX and SOUR:POW? MIN. (SOUR:POW:ATT:AUTO must be set to ON).

Actual achievable leveled power depends on frequency.

Examples

SENS:FOM:RANG:SEGM:POW -5

sense2:fom:range2:segment4:power2:level 5

Query Syntax

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:POWer<p>[:LEVel]?

Return Type

Numeric

Default

0

SENSe<cnum>:FOM:RANGe<n>:SEGMent:POWer[:LEVel]:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether Power Level is to be set independently for each segment. Valid either for Source ranges or for Primary range. Primary range value is ignored unless Source is coupled to Primary.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<bool> | ON (or 1) - Power level will be set for each segment. OFF (or 0) - Use the channel power level setting.
Examples | SENS:FOM:RANG:SEGM:POW:CONT 0 sense2:fom:range2:segment:power:control on
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean
Default | OFF (or 0)

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to be turned ON or OFF. Choose any existing segment number.
<bool> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:FOM:RANG:SEGM 0 sense2:fom:range2:segment4:state on
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>[STATe]?
Return Type | Boolean
Default | OFF (or 0)

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:SWEep:POINts <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of data points for the specified sweep segment.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to modify. Choose any existing segment number.
<num> | Number of points in the segment. The total number of points in all segments cannot exceed 20001. A segment can have as few as 1 point.
Examples | SENS:FOM:RANG:SEGM:SWE:POIN 101 sense2:fom:range2:segment4:sweep:points 201
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:SWEep:POINts?
Return Type | Numeric
Default | 21

SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:SWEep:TIME <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the time the VNA takes to sweep the specified segment. Valid ONLY for receiver ranges.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number for which to set sweep time.
<num> | Sweep time in seconds. Choose a number between 0 and 100
Examples | SENS:FOM:RANG:SEGM:SWE:TIME 1 sense2:fom:range2:segment3:sweep:time .1
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent<s>:SWEep:TIME?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:FOM:RANGe<n>:SEGMent:SWEep:TIME:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment. Valid either for Receiver ranges or for Primary range. Primary range value is ignored unless Receiver is coupled to Primary.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<bool> | ON (or 1) - Sweep time will be set for each segment. OFF (or 0) - Use the channel sweep time setting.
Examples | SENS:FOM:RANG:SEGM:SWE:TIME:CONT 1 sense2:fom:range2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:FOM:RANGe<n>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean
Default | OFF

Last Modified:

6-Jan-2016

First Release


Frequency SCPI

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

SENSe:FREQuency:

CENTer

[CW | FIXed]

SPAN

STARt

STOP

Click on a Red keyword to view the command details.

See Also

  • Example using some of these commands.

  • Learn about Frequency Sweep

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:FREQuency:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the analyzer. Units are Hz.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000

sense2:frequency:center 1mhz

sense2:frequency:center 1e6

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Numeric

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW | :FIXed] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Continuous Wave (or Fixed) frequency for the power sweep for channels 1 to 36. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the analyzer. Units are Hz.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Numeric

Default

1E5 Hz

SENSe<cnum>:FREQuency:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span in Hz. Choose any number between 0 (minimum) and the maximum frequency span of the analyzer.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Numeric

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the start frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz

If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STAR 1000000
sense2:frequency:start MIN

Query Syntax

SENSe<cnum>:FREQuency:STARt?

If Sweep type is segment, this query returns the start frequency of the first segment.

Return Type

Numeric

Default

Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between: the minimum and maximum frequency limits of the analyzer. Units are Hz.

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

If Sweep type is segment, this query returns the stop frequency of the last segment.

Return Type

Numeric

Default

Maximum frequency of the analyzer

Last Modified:

6-Jan-2016

First Release


Gain Compression

SENSe:GCSetup Commands

Controls the Gain Compression configuration.

SENSe:GCSetup:

AMODe <char>

COMPression:

| ALGorithm <char>

| BACKoff:LEVel <num>

| DELTa:X <num>

| DELTa:Y <num>

| INTerpolation <bool>

| LEVel <num>

| SATuration:LEVel

EOSoperation <string>

PMAP

| INPut?

| OUTPut?

POWer:

| LINear:INPut:LEVel <num>

| REVerse:LEVel <num>

| STARt:LEVel <num>

| STOP:LEVel <num>

SAFE:

| CPADjustment <num>

| ENABle <bool>

| FPADjustment <num>

| FTHReshold <num>

| MLIMit <num>

SFA?

SMARt:

| MITerations <num>

| SITerations <bool>

| STIMe <num>

| TOLerance <num>

SWEep:

| FREQuency:POINts <num>

| POWer:POINts <num>

See Also

Other Gain Compression commands

  • CALC:CUSTom:DEFine - creates a gain compression measurement.

  • CALC:GCMeas:ANAL - Gain Compression Analysis settings

  • GCA Calibration uses the Guided Calibration commands, except for the following:

    • Sens:Corr:GCS:Power - sets power level for Source Power Cal

GCX

  • Setup Mixer using Sense:Mixer commands

  • Calibrate using SMC commands and Guided commands

  • Example Programs

    • Create and Cal a Gain Compression Measurement

    • Create and Cal a GCX Measurement

  • Learn about Gain Compression Application

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<ch>:GCSetup:AMODe <char>

Applicable Models: M9485A

(Read-Write) Set and read the method by which gain compression data is acquired.

Parameters

<ch>

Any existing GCA channel. If unspecified, value is set to 1.

<char>

Choose from:

  • PFREQuency - 2D Power Per Frequency

  • FPOWer - 2D Frequency Per Power

  • SMARtsweep - Smart Sweep

Examples

SENS:GCS:AMOD SMAR

sense:gcsetup:amode pfrequency

Query Syntax

SENSe<ch>:GCSetup:AMODe ?

Return Type

Character

Default

SMARtsweep

SENSe<ch>:GCSetup:COMPression:ALGorithm <char>

Applicable Models: M9485A

(Read-Write) Set and read the algorithm method used to compute gain compression.

Parameters

<ch>

Any existing GCA channel. If unspecified, value is set to 1.

<char>

Algorithm method. Choose from:

  • CFLG - compression from linear gain

  • CFMG - compression from maximum gain

  • BACKoff - compression from BackOff

  • XYCOM - X/Y Compression

  • SAT - compression from saturation

Examples

SENS:GCS:COMP:ALG BACK

sense:gcsetup:compression:algorithm XYcom

Query Syntax

SENSe<ch>:GCSetup:COMPression:ALGorithm?

Return Type

Character

Default

CFLG

SENSe<ch>:GCSetup:COMPression:BACKoff:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read value for the BackOff compression algorithm.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Backoff value in dB. Choose from 30 to (-30)
Examples | SENS:GCS:COMP:BACK:LEV 10 sense:gcsetup:compression:backoff:level 5
Query Syntax | SENSe<ch>:GCSetup:COMPression:BACKoff:LEVel?
Return Type | Numeric
Default | 10

SENSe<ch>:GCSetup:COMPression:DELTa:X <num>

Applicable Models: M9485A

(Read-Write) Set and read the 'X" value in the delta X/Y compression algorithm.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | X value in dB. Choose from 30 to (-30)
Examples | SENS:GCS:COMP:DELT:X 9 sense:gcsetup:compression:delta:X 8
Query Syntax | SENSe<ch>:GCSetup:COMPression:DELTa:X?
Return Type | Numeric
Default | 10

SENSe<ch>:GCSetup:COMPression:DELTa:Y <num>

Applicable Models: M9485A

(Read-Write) Set and read the 'Y" value in the delta X/Y compression algorithm.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Y value in dB. Choose from 30 to (-30)
Examples | SENS:GCS:COMP:DELT:Y 9 sense:gcsetup:compression:delta:Y 8
Query Syntax | SENSe<ch>:GCSetup:COMPression:DELTa:Y?
Return Type | Numeric
Default | 9

SENSe<ch>:GCSetup:COMPression:INTerpolation <bool>

Applicable Models: M9485A

(Read-Write) Sets whether or not interpolation should be performed on 2D measured compression data. Applies ONLY to 2D acquisition modes.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<bool> | Choose from: ON or (1) Interpolate the results OFF or (0) Do NOT interpolate the results but return the value closest to compression.
Examples | SENS:GCS:COMP:INT 1 sense:gcsetup:compression:interpolation off
Query Syntax | SENSe<ch>:GCSetup:COMPression:INTerpolation?
Return Type | Boolean
Default | OFF

SENSe<ch>:GCSetup:COMPression:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the desired gain reduction (from reference gain). This value is used for Compression from Linear Gain and Compression from Maximum Gain. Use SENS:GCS:COMP:ALG CFLG to set this compression algorithm.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Compression level in dB. Choose a value greater than 0.1 dB.
Examples | SENS:GCS:COMP:LEV 1 sense:gcsetup:compression:level 3
Query Syntax | SENSe<ch>:GCSetup:COMPression:LEVel?
Return Type | Numeric
Default | 1

SENSe<ch>:GCSetup:COMPression:SATuration:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the deviation dB from the maximum Pout. This is the point of saturation. Use SENS:GCS:COMP:ALG CFLG to set this compression algorithm.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Saturation level in dB. Choose a value greater than 0.01 dB.
Examples | SENS:GCS:COMP:SAT:LEV 1 sense:gcsetup:compression:saturation:level 3
Query Syntax | SENSe<ch>:GCSetup:COMPressionSATuration:LEVel?
Return Type | Numeric
Default | .1 dB

SENSe<ch>:GCSetup:EOSoperation <char>

Applicable Models: M9485A

(Read-Write) Set and read the This setting is used to protect a sensitive device from too much power during the sweep retrace. Other instrument settings or channels may over-ride this setting. Learn more.

Parameters

<ch>

Any existing GCA channel. If unspecified, value is set to 1.

<char>

End Of Sweep operation. Choose from:

  • STANdard Use the default VNA method. Learn more.

  • POFF Always turn power OFF while waiting.

  • PSTArt Sweep Start power

  • PSTOp Sweep Stop power.

Examples

SENS:GCS:EOS PSTA

sense:gcsetup:eosoperation standard

Query Syntax

SENSe<ch>:GCSetup:EOSoperation?

Return Type

Character

Default

STANdard

SENSe<ch>:GCSetup:PMAP <in>,<out>

Applicable Models: M9485A

(Write-only) Set the DUT-to-PNA port mapping for the Gain Compression measurement.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<in> | VNA port which is connected to the DUT input.
<out> | VNA port which is connected to the DUT output.
Examples | SENS:GCS:PMAP 1,2 sense:gcsetup:pmap 2,1
Query Syntax | Not Applicable
Default | 1,2

SENSe<ch>:GCSetup:PMAP:INPut?

Applicable Models: M9485A

(Read-only) Read the VNA port number to be connected to the DUT Input. Use SENS:GCS:PORTMap to set the port mapping.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
Examples | SENS:GCS:PMAP:INP? sense:gcsetup:pmap:input?
Return Type | Numeric
Default | 1

SENSe<ch>:GCSetup:PMAP:OUTPut?

Applicable Models: M9485A

(Read-only) Read the VNA port number to be connected to the DUT Output.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
Examples | SENS:GCS:PMAP:OUTP? sense:gcsetup:pmap:output?
Return Type | Numeric
Default | 2

SENSe<ch>:GCSetup:POWer:LINear:INPut:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the input power at which Linear Gain and all S-parameters are measured.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Input power level in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:POW:LIN:INP:LEV 0 sense:gcsetup:power:linear:input:level -10
Query Syntax | SENSe<ch>:GCSetup:POWer:LINear:INPut:LEVel?
Return Type | Numeric
Default | -25 dBm

SENSe<ch>:GCSetup:POWer:REVerse:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the reverse power level to the DUT. This is applied to the DUT output port when making reverse measurements like S22.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Reverse power level in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:POW:REV:LEV 0 sense:gcsetup:power:reverse:level -5
Query Syntax | SENSe<ch>:GCSetup:POWer:REVerse:LEVel?
Return Type | Numeric
Default | -5

SENSe<ch>:GCSetup:POWer:STARt:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the start power level.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Start power level in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:POW:STAR:LEV 0 sense:gcsetup:power:start:level -5
Query Syntax | SENSe<ch>:GCSetup:POWer:STARt:LEVel?
Return Type | Numeric
Default | -30

SENSe<ch>:GCSetup:POWer:STOP:LEVel <num>

Applicable Models: M9485A

(Read-Write) Set and read the stop power level.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Stop power level in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:POW:STOP:LEV 0 sense:gcsetup:power:stop:level -5
Query Syntax | SENSe<ch>:GCSetup:POWer:STOP:LEVel?
Return Type | Numeric
Default | -5

SENSe<ch>:GCSetup:SAFE:CPADjustment <num>

Applicable Models: M9485A

(Read-Write) Set and read the Safe Sweep COARSE power adjustment. Learn more.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Coarse power adjustment setting in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:SAFE:CPAD 2 sense:gcsetup:safe:cpadjustment 3.5
Query Syntax | SENSe<ch>:GCSetup:SAFE:CPADjustment?
Return Type | Numeric
Default | 3.0

SENSe<ch>:GCSetup:SAFE:ENABle <bool>

Applicable Models: M9485A

(Read-Write) Set and read the (ON | OFF) state of Safe Sweep mode. Learn more
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | (Boolean) - Safe Sweep state. Choose from: OFF (or 0) - Disable Safe Sweep ON (or 1) - Enable Safe Sweep
Examples | SENS:GCS:SAFE:ENAB 0 sense:gcsetup:safe:enable 1
Query Syntax | SENSe<ch>:GCSetup:SAFE:ENABle?
Return Type | Boolean
Default | 0

SENSe<ch>:GCSetup:SAFE:FPADjustment <num>

Applicable Models: M9485A

(Read-Write) Set and read the Safe Sweep FINE power adjustment. Learn more
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Fine power adjustment setting in dBm. Choose a value from +30 to (-30).
Examples | SENS:GCS:SAFE:FPAD 2 sense:gcsetup:safe:fpadjustment .5
Query Syntax | SENSe<ch>:GCSetup:SAFE:FPADjustment?
Return Type | Numeric
Default | 1.0 dBm

SENSe<ch>:GCSetup:SAFE:FTHReshold <num>

Applicable Models: M9485A

(Read-Write) Set and read the compression level in which Safe Sweep changes from the COARSE power adjustment to the FINE power adjustment. Learn more
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Threshold setting in dB. Choose a value from +30 to (-30).
Examples | SENS:GCS:SAFE:FTHR .1 sense:gcsetup:safe:fthreshold .75
Query Syntax | SENSe<ch>:GCSetup:SAFE:FTHReshold?
Return Type | Numeric
Default | 0.5 dB

SENSe<ch>:GCSetup:SAFE:MLimit <num>

Applicable Models: M9485A

(Read-Write) When the VNA port that is connected to the DUT Output measures this value, the input power to the DUT is no longer incremented at that frequency. Safe Mode must be enabled with SENS:GCS:SAFE:ENAB ON Learn more
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Maximum power limit in dBm. Choose a value from -100 to +100
Examples | SENS:GCS:SAFE:MLIM 20 sense:gcsetup:safe:mlimit 30
Query Syntax | SENSe<ch>:GCSetup:SAFE:MLIMit?
Return Type | Numeric
Default | 30

SENSe<ch>:GCSetup:SFAilures?

Applicable Models: M9485A

(Read-only) Returns a comma-separated list of the frequency indexes that were out of tolerance for SMART Sweep mode, or at the power limit for 2D acquisition modes. Zero (0) is the first frequency data point. Must be Single triggered. Invalid results occur if the GCA channel is continuously sweeping.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
Examples | SENS:GCS:SFA? sense:gcsetup:sfailures?
Return Type | Comma-separated list of frequency indexes.
Default | Not Applicable

SENSe<ch>:GCSetup:SMARt:MITerations <num>

Applicable Models: M9485A

(Read-Write) Set and read the maximum permitted number of iterations which SMART Sweep may utilize to find the desired compression level, to within the specified tolerance.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Maximum number of iterations. Choose a value between 1 and 10e8
Examples | SENS:GCS:SMAR:MIT 5 sense:gcsetup:smart:miterations 3
Query Syntax | SENSe<ch>:GCSetup:SMARt:MITerations?
Return Type | Numeric
Default | 20

SENSe<ch>:GCSetup:SMARt:SITerations <bool>

Applicable Models: M9485A

(Read-Write) Set and read enable for showing intermediate results for each iteration of SMART Sweep
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<bool> | Choose from: ON or (1) Compression traces are updated after each iteration. OFF or (0) Compression traces are updated after ALL iterations are complete.
Examples | SENS:GCS:SMAR:SIT 1 sense:gcsetup:smart:siterations off
Query Syntax | SENSe<ch>:GCSetup:SMARt:SITerations?
Return Type | Boolean
Default | OFF

SENSe<ch>:GCSetup:SMARt:STIMe <num>

Applicable Models: M9485A

(Read-Write) Set and read the amount of time SMART Sweep will dwell at the first point where the input power changes by the Backoff or X level. Applies only to SMART Sweep when Backoff or XY compression methods are selected. Learn more.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<bool> | Settling time in seconds. Choose any positive value.
Examples | SENS:GCS:SMAR:STIM 1 sense:gcsetup:smart:stime .1
Query Syntax | SENSe<ch>:GCSetup:SMARt:STIMe?
Return Type | Numeric
Default | 0

SENSe<ch>:GCSetup:SMARt:TOLerance <num>

Applicable Models: M9485A

(Read-Write) Set and read the acceptable range SMART Sweep will allow for the measured compression level.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Tolerance level in dBm. Choose a value between .01 and 10
Examples | SENS:GCS:SMAR:TOL .1 sense:gcsetup:smart:tolerance .05
Query Syntax | SENSe<ch>:GCSetup:SMARt:TOLerance?
Return Type | Numeric
Default | .05

SENSe<ch>:GCSetup:SWEep:FREQuency:POINts <num>

Applicable Models: M9485A

(Read-Write) Set and read the number of data points in each frequency sweep. Learn more
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Frequency points. Do not exceed the max number of data points. See Data Points Limit
Examples | SENS:GCS:SWE:FREQ:POIN 201 sense:gcsetup:sweep:frequency:points 101
Query Syntax | SENSe<ch>:GCSetup:SWEep:FREQuency:POINts?
Return Type | Numeric
Default | 201

SENSe<ch>:GCSetup:SWEep:POWer:POINts <num>

Applicable Models: M9485A

(Read-Write) Set and read the number of data points in each power sweep. Applies ONLY to 2D acquisition modes.
Parameters |
<ch> | Any existing GCA channel. If unspecified, value is set to 1.
<num> | Power points. Do not exceed the max number of data points. See Data Points Limit
Examples | SENS:GCS:SWE:POW:POIN 50 sense:gcsetup:sweep:power:points 21
Query Syntax | SENSe<ch>:GCSetup:SWEep:POWer:POINts?
Return Type | Numeric
Default | 26

Last Modified:

6-Oct-2011

Added GCX notes


MIXer SCPI

Sense:Mixer Commands

Performs Mixer setup and configuration.

SENSe:MIXer:

APPLy

CALC

DISCard

IF:FREQuency

| SIDeband

| STARt

| STOP

INPut:FREQuency

| DENominator

| FIXed

| MODE

| NUMerator

| STARt

| STOP

INPut:POWer

| STARt

| STOP

| USENominal

LO:FREQuency

| DENominator

| FIXed

| ILTI

| MODE

| NUMerator

| STARt

| STOP

LO:NAME | NAMe

LO:POWer

| STARt

| STOP

LOAD

NORMalize:POINt

OUTPut:FREQuency

| FIXed

| MODE

| SIDeband

| STARt

| STOP

PMAP

| INPut?

| OUTPut?

RECalculate

REVerse

ROLE

| CATalog?

| DEVice

SAVE

SEGMent More Commands

STAGe (number of LOs)

XAXis

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about the Frequency Converter Application

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Note: If you are changing several mixer configuration settings, you can make all the changes first and then issue the Calculate and Apply commands as you would do from the user interface.

SENSe<ch>:MIXer:APPLy

Applicable Models: E5080A, M9485A

(Write only) Applies the mixer setup settings and turns the channel ON. (Performs the same function as the Apply button on the mixer setup dialog box).
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:MIX:APPL
Query Syntax | Not Applicable
Default | Not Applicable

S

SENSe<ch>:MIXer:CALCulate <char>

Applicable Models: E5080A, M9485A

(Write only) Calculates the Input, IF, or Output frequencies of the mixer setup and updates the channel settings.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<char>

Mixer port to be calculated. Choose from:

<char>

1st or only stage requires:

In addition, 2nd stage requires:

INPut

  • Output Start/Stop/Fixed frequencies

  • LO Start/Stop/Fixed frequencies

  • Output sideband (High or Low)

  • IF Start/Stop/Fixed frequencies

  • 2nd Start/Stop/Fixed frequencies

  • IF sideband (High or Low)

BOTH

NA

  • IF Start/Stop/Fixed frequencies

  • Both Start/Stop/Fixed frequencies

OUTPut

  • Input Start/Stop/Fixed frequencies

  • LO Start/Stop/Fixed frequencies

  • Output sideband (High or Low)

  • IF Start/Stop/Fixed frequencies

  • 2nd Start/Stop/Fixed frequencies

  • IF sideband (High or Low)

LO_1

  • Input Start/Stop/Fixed frequencies

  • Output Start/Stop/Fixed frequencies

  • Output sideband (High or Low)

  • IF Start/Stop/Fixed frequencies

  • 2nd Start/Stop/Fixed frequencies

  • IF sideband (High or Low)

LO_2

NA

  • Input Start/Stop/Fixed frequencies

  • 1st LO Start/Stop/Fixed frequencies

  • Output Start/Stop/Fixed frequencies

  • IF sideband(High or Low

  • Output sideband(High or Low)

Examples

SENS:MIX:CALC Output

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:MIXer:DISCard

Applicable Models: E5080A, M9485A

(Write only) Cancels changes that have been made to the Converter setup and reverts to the previously-saved setup. Same as the Cancel button on the mixer setup dialog box.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:MIX:DISC
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:SIDeband <char>

Applicable Models: E5080A, M9485A

(Read-Write) When two LO stages are used, sets or returns whether to select the sum or difference for the IF1 product. (Input + or - LO1 = IF1)

  • This setting corresponds to the [image] buttons on LO1 on the Mixer setup dialog

  • This setting is ignored when ONE LO stage is selected.

  • Also set SENS:MIX:OUTP:FREQ:SID to LOW or HIGH to determine the output frequency of the mixer.

See Note

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<char>

Sideband value. Choose from

LOW - Difference (-)

HIGH - Sum (+)

Examples

SENS:MIX:IF:FREQ:SID LOW
SENSe2:MIXer:IF:FREQ:SIDeband HIGH

Query Syntax

SENSe<ch>:MIXer:IF:FREQuency:SIDeband?

Return Type

Character

Default

LOW

SENSe<ch>:MIXer:IF:FREQuency:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the IF start frequency value of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | IF Start Frequency value
Examples | SENS:MIX:IF:FREQ:STAR 1e9 SENSe2:MIXer:IF:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:STARt?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:IF:FREQuency:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the stop frequency value of the mixer IF frequency. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<num> | IF Stop Frequency value
Examples | SENS:MIX:IF:FREQ:STOP 2e9 SENSe2:MIXer:IF:FREQ:STOP 2000000000
Query Syntax | SENSe<ch>:MIXer:IF:FREQuency:STOP?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:DENominator <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the denominator value of the Input Fractional Multiplier. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input denominator value.
Examples | SENS:MIX:INP:FREQ:DEN 5 SENS2:MIXer:INPut:FREQ:DENominator 4
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:DENominator?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:FIXed<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the fixed frequency of the input. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input frequency.
Examples | SENSe:MIXer:INPut:FREQ:FIXed 1e9 SENSe2:MIXer:INPut:FREQ:FIXed 1000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:FIXed?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Input sweep mode.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<char> | Input sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:INP:FREQ:MODE FIXED SENSe2:MIXer:INP:FREQ:MODE swept
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:MODE?
Return Type | Character
Default | Fixed

SENSe<ch>:MIXer:INPut:FREQuency:NUMerator <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the numerator value of the Input Fractional Multiplier. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input numerator value.
Examples | SENS:MIX:INP:FREQ:NUM 3 SENSe2:MIXer:INPut:FREQ:NUMerator 1
Query Syntax | SENSe<ch>:MIXer:INPut:FREQ:NUMerator?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Input start frequency value of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input Start frequency
Examples | SENS:MIX:INP:FREQ:STAR 1e9 SENSe2:MIXer:INPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:STARt?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:FREQuency:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Input stop frequency value of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input stop frequency
Examples | SENS:MIX:INP:FREQ:STOP 2e9 SENSe2:MIXer:INPut:FREQ:STOP 2000000000
Query Syntax | SENSe<ch>:MIXer:INPut:FREQuency:STOP?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:POWer <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the value of the Input Power.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input power in dBm.
Examples | SENS:MIX:INP:POW 9 SENSe2:MIXer:INPut:POWer 5
Query Syntax | SENSe<ch>:MIXer:INPut:POWer?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:POWer:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the input start power for a power sweep in a mixer channel like SMC. The value is only used when the sweep type is power sweep.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input power value in units of dBm.
Examples | SENS:MIX:INP:POW STAR 6 SENSe2:MIXer:INPut:POWer:STARt 5
Query Syntax | SENSe<ch>:MIXer:INPut:POWer:STARt?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:POWer:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the input stop power for a power sweep in a mixer channel . The value is only used when the sweep type is power sweep.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Input power value in units of dBm.
Examples | SENS:MIX:INP:POW STOP 9 SENSe2:MIXer:INPut:POWer:STOP 5
Query Syntax | SENSe<ch>:MIXer:INPut:POWer:STOP?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:INPut:POWer:USENominal <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Toggles the Use Nominal Incident Power setting ON and OFF. This setting is ONLY to be used with SMC measurements. Learn more about Nominal Incident Power.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<bool> | Nominal Incident Power State. Choose from: ON (1) - Turn nominal incident power ON OFF (0) - Turn nominal incident power OFF
Examples | SENS:MIX:INP:POW:USEN 1 SENSe2:MIXer:INPut:POWer:USENominal OFF
Query Syntax | SENSe<ch>:MIXer:INPut:POWer:USENominal?
Return Type | Boolean
Default | OFF

SENSe<ch>:MIXer:LO<n>:FREQuency:DENominator <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the denominator value of the LO Fractional Multiplier. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2.
<value> | LO denominator.
Examples | SENS:MIX:LO:FREQ:DEN 5 SENSe2:MIXer:LO2:FREQ:DENominator 4
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:DENominator?
Return Type | Numeric
Default | 1

SENSe<ch>:MIXer:LO<n>:FREQuency:FIXed <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the fixed frequency of the specified mixer LO. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO frequency.
Examples | SENS:MIX:LO:FREQ:FIX 1e9 SENSe2:MIXer:LO2:FREQ:FIXed 1000000000
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:FIXed?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:ILTI <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether to use the Input frequency that is greater than the LO or less than the LO. To learn more, see the mixer setup dialog box help.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<bool> | ON (1) - Use the Input that is Greater than the specified LO. OFF (0) - Use the Input that is Less than the specified LO.
Examples | SENS:MIX:LO1:FREQ:ILTI 1 sense2:mixer:lo2:frequency:ilti ON
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:ILTI?
Return Type | Boolean
Default | OFF

SENSe<ch>:MIXer:LO<n>:FREQuency:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the LO sweep mode.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<char> | LO sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:LO:FREQ:MODE FIXED SENSe2:MIXer:LO2:FREQ:MODE swept
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:MODE?
Return Type | Character
Default | Fixed

SENSe<ch>:MIXer:LO<n>:FREQuency:NUMerator <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the numerator value of the LO Fractional Multiplier. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Numerator.
Examples | SENS:MIX:LO:FREQ:NUM 5 SENSe2:MIXer:LO2:FREQ:NUMerator 4
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:NUMerator?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the LO start frequency value. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Start Frequency in Hertz.
Examples | SENS:MIX:LO:FREQ:STAR 5E9
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:STARt?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:FREQuency:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the LO stop frequency value. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage number. Choose 1 or 2
<value> | LO Stop Frequency in Hertz.
Examples | SENS:MIX:LO:FREQ:STOP 5E9
Query Syntax | SENSe<ch>:MIXer:LO<n>:FREQuency:STOP?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:NAME | NAMe <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the name of the VNA internal source or external source to use as the LO in a converter measurement.

Important Note: This setting is immediately send to the channel configuration. First set and apply mixer frequency settings, then send this command. Otherwise, 'invalid setting' errors may occur.

See Remotely Specifying a Source Port.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<n>

LO stage number. Choose 1 or 2.

<value>

(string) - LO Source name. Use Source:CAT? to return a list of valid source ports. An external source must be configured and selected to be valid. Learn more about external source configuration.

Examples

SENS:MIX:LO:NAME "MySource"

Query Syntax

SENSe<ch>:MIXer:LO<n>:NAME?

Return Type

String

Default

"Not Controlled"

SENSe<ch>:MIXer:LO<n>:POWer <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the LO Power fixed value.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage. Choose 1 or 2
<value> | LO Power in dBm
Examples | SENS:MIX:LO:POW 9
Query Syntax | SENSe<ch>:MIXer:LO<n>:POWer?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:LO<n>:POWer:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) For an LO power sweep, sets or returns the LO power start value.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage. Choose 1
<value> | LO start power in dBm
Examples | SENS:MIX:LO1:POW:STAR -10
Query Syntax | SENSe<ch>:MIXer:LO1:POWer:STARt?
Return Type | Numeric
Default | - 20 dBm

SENSe<ch>:MIXer:LO<n>:POWer:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) For an LO power sweep, sets or returns the LO power stop value.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | LO stage. Choose 1
<value> | LO stop power in dBm
Examples | SENS:MIX:LO1:POW:STOP 10
Query Syntax | SENSe<ch>:MIXer:LO1:POWer:STOP?
Return Type | Numeric
Default | -10 dBm

SENSe<ch>:MIXer:LOAD <name>

Applicable Models: E5080A, M9485A

(Write-only) Loads a previously-configured mixer attributes file (.mxr)
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<name> | Path and file name (including .mxr extension) to load.
Examples | SENSe:MIXer:LOAD "C:/Program Files/Keysight/Network Analyzer/Documents/Mixer/MyMixer.mxr"
Default | Not Applicable

SENSe<ch>:MIXer:NORMalize:POINt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the data point for normalizing the phase measurement. Learn more.
Parameters |
<ch> | Channel number of the SMC measurement. If unspecified, value is set to 1.
<value> | Normalization data point. Choose a data point number between 1 and the max number of data points in the sweep that has the least amount of expected noise.
Examples | SENS:MIX:NORM:POIN 101 sense2:mixer:normalize:point 50
Query Syntax | SENSe<ch>:MIXer:NORMalize:POINt?
Return Type | Numeric
Default | Middle point in the sweep

SENSe<ch>:MIXer:OUTPut:FREQuency:FIXed <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the output fixed frequency of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output fixed frequency in Hertz.
Examples | SENS:MIX:OUTP:FREQ:FIX 5e9
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:FIXed?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:OUTPut:FREQuency:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Output sweep mode.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<char> | Output sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:OUT:FREQ:MODE FIXED SENSe2:MIXer:OUTput:FREQuency:MODE swept
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:MODE?
Return Type | Character
Default | Fixed

SENSe<ch>:MIXer:OUTPut:FREQuency:SIDeband <value>

Applicable Models: E5080A, M9485A

(Read-Write) Specify whether to select the sum (High) or difference (Low) products.

  • When one LO is used: Input + or - LO1 = Output frequency

  • When two LOs are used: IF1 + or - LO2 = Output frequency

Use SENS:MIX:IF:FREQ:SID when two LOs are used to determine the IF1 frequency.

Use Sens:Mixer:Stage to set 1 or 2 LOs

See Note

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<value>

Sideband value. Choose from

LOW - Low or Difference (-)

HIGH - High or Sum (+)

Examples

SENS:MIX:OUTP:FREQ:SID LOW
SENSe2:MIXer:OUTPut:FREQ:SIDeband HIGH

Query Syntax

SENSe<ch>:MIXer:OUTPut:FREQuency:SIDeband?

Return Type

Character

Default

LOW

SENSe<ch>:MIXer:OUTPut:FREQuency:STARt <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Output start frequency of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output start frequency
Examples | SENS:MIX:OUTP:FREQ:STAR 1e9 SENSe2:MIXer:OUTPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:STARt?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:OUTPut:FREQuency:STOP <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the Output stop frequency of the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<value> | Output stop frequency
Examples | SENS:MIX:OUTP:FREQ:STOP 1e9 SENSe2:MIXer:OUTPut:FREQ:STOP 1000000000
Query Syntax | SENSe<ch>:MIXer:OUTPut:FREQuency:STOP?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:PMAP <in>,<out>

Applicable Models: E5080A, M9485A

(Write-only) Sets the VNA to DUT port map for FCA measurements. Use SENS:MIX:PMAP:INP? and SENS:MIX:PMAP:OUTP? to read these values. Learn about selectable FCA DUT ports.

Changing the ports may limit your ability to use an internal second source. If a selected port is shared by one of the sources, then that source will not be available as an LO source. Learn more about Internal second sources.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<in>

VNA port to connect to the DUT input.

  • For SMC, choose any unused VNA port.

  • For VMC, set to 1.

<out>

VNA port to connect to the DUT output. Choose any unused port for SMC and VMC.

Examples

SENS:MIX:PMAP 2,1
sense2:mixer:pmap 4,2

Query Syntax

Not Applicable

Default

1,2

SENSe<ch>:MIXer:PMAP:INPut?

Applicable Models: E5080A, M9485A

(Read-only) Returns the VNA port that is mapped to the DUT input. Use SENS:MIX:PMAP to set this value. Learn about selectable FCA DUT ports.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
Examples | SENS:MIX:PMAP:INP? sense2:mixer:pmap:input?
Default | 1

SENSe<ch>:MIXer:PMAP:OUTPut?

Applicable Models: E5080A, M9485A

(Read-only) Returns the VNA port that is mapped to the DUT output. Use SENS:MIX:PMAP to set this value. Learn about selectable FCA DUT ports.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
Examples | SENS:MIX:PMAP:OUTP? sense2:mixer:pmap:output?
Default | 2

SENSe<ch>:MIXer:RECalculate

Applicable Models: E5080A, M9485A

(Write only) Repeats the last calculation that was performed, including all ON (state) segments in segment table.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:MIX:REC
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:MIXer:REVerse <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets whether to include SC12 sweeps during measurements.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<bool> | (Boolean) Choose from: ON (1) - Include the SC12 (reverse) sweep. OFF (0) - Do NOT Include the SC12 (reverse) sweep.
Examples | SENS:MIX:REV 1 sense2:mixer:reverse ON
Query Syntax | SENSe<ch>:MIXer:REVerse?
Return Type | Boolean
Default | ON (1)

SENSe<ch>:MIXer:SAVE <name>

Applicable Models: E5080A, M9485A

(Write-only) Saves the settings for the mixer/converter test setup to a mixer attributes file.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<name> | Path and file name (including .mxrx extension) to save.
Examples | SENSe:MIXer:SAVE "C:/Program Files/Keysight/Network Analyzer/Documents/Mixer/MyMixer.mxrx"
Default | Not Applicable

SENSe<ch>:MIXer:STAGe <n>

Applicable Models: E5080A, M9485A

(Read-Write) Number of IF stages (LOs) used in the mixer. See Note
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Number of stages. Choose either 1 or 2
Examples | SENSe:MIX:STAG 2 SENSe:MIXer:STAGE 1
Query Syntax | SENSe<ch>:MIXer:STAGe?
Return Type | Numeric
Default | 1

SENSe<ch>:MIXer:XAXis <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the swept frequency range to display on the X-axis for the IMDx channel.

For FCA and GCX measurements, use CALC:MIXer:XAXis

Parameters

<ch>

Channel number of the IMDx Converter measurement. If unspecified, value is set to 1.

<char>

Frequency range to display on the X-Axis. NOT case-sensitive. Choose from:

  • INPUT - Input frequency range

  • LO_1 - LO frequency range

  • OUTPUT - Output frequency range

If the specified frequency range is not swept, the default swept range is used.

Examples

SENSe:MIXer:XAXis INPUT

sense2:mixer:xaxis LO_1

Return Type

Character

Default

Search is made in the following order until a swept range is found:

  1. OUTPUT

  2. INPUT (If the OUTPUT is fixed)

  3. Number of Points (If ALL ranges are fixed)

Last modified:

6-Jan-2016

First Release


Multiplexer

Sense:Multiplexer Commands

Controls External Test Sets (N44xx, E5091A, "Z", and "H" series).

SENSe:MULTiplexer:

ADDRess

ALLPorts

CATalog?

COUNt?

DISPlay

INCount?

LABel

OUTPut

| A|B|C|D[DATA]

| A|B|C|D:VOLTage[DATA]

| [DATA | DATa]

PORT

| CATalog?

| SELect

STATe

TSET9

| OUTPut

| PORT1

| PORT2

| PORT3

| PORT4

TYPE|TYPe

Click on a Red keyword to view the command details.

See Also

  • See an example program using these commands.

  • Learn about External Test Set Control

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe:MULTiplexer<id>:ADDRess <address>

Applicable Models: E5080A

(Read-Write) Sets and returns the address for the external test set at the specified ID. This command should be immediately preceded by the SENS:MULT:TYPE command.

Parameters

<id>

Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.

<address>

Integer The test set address.

  • For a GPIB test set (N44xx and some specials), this is the GPIB address.

  • For a test set I/O test set (some specials), it is the position of the test set in the chain (starting at 0).

  • For USB test sets (E5091A), the address is set by DIP switches on the rear panel.

Examples

SENS:MULT1:TYPE "Z5623A_K66" ' use K66 test set, and reference it through ID 1

SENS:MULT1:ADDR 0 ' first test set in sequence

' All subsequent commands using SENS:MULT1 will refer to this test set

Query Syntax

SENSe:MULTiplexer<id>:ADDRess?

Return Type

Numeric

Default

Not Applicable

SENSe<cnum>:MULTiplexer<id>:ALLPorts <string>

Applicable Models: E5080A

(Read-Write) Sets or gets the port selections for all available ports on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<id> | Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.
<string> | Comma-separated list of port selections, one for each port. Each port selection must correspond to one of the values returned by SENS:MULT:PORT:CAT?. Do NOT include + and - .
Examples | ' for channel 5 and test set 1, set port 1 to T1, ' port 2 to A, port 3 to R2+, port 4 to R3-. SENS5:MULT1:ALLP "T1,A,R2,R3 "
Query Syntax | SENSe<cnum>:MULTiplexer<id>:ALLPorts?
Return Type | STRING
Default | Not Applicable

SENSe:MULTiplexer:CATalog?

Applicable Models: E5080A

(Read-Only) Returns a comma-separated list of the external test sets models that are currently supported. Choose one of these items to send SENS:MULT:TYPE.
Examples | SENS:MULT:CAT?
Return Type | String
Default | Not Applicable

SENSe:MULTiplexer<id>:COUNt?

Applicable Models: E5080A

(Read-Only) Returns the total number of ports of the specified test set. Returns 0 if no test set is connected (GPIB test sets only).
Parameters |
<id> | Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENSe:MULT:TYPE command.
Examples | SENS:MULT1:COUN? sense:multiplexer2:count?
Return Type | Numeric
Default | Not Applicable

SENSe:MULTiplexer<id>:DISPlay[:STATe] <bool>

Applicable Models: E5080A

(Read-Write) Turns ON and OFF the display of the test set control status bar. This status bar indicates the test set that is being controlled and the current port mappings. This setting is turned ON automatically when the test set is enabled.
Parameters |
<id> | Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.
<bool> | ON or 1 - Turns ON the display. OFF or 0 - Turns OFF the display.
Examples | SENS:MULT1:DISP 1 sense:multiplexer2:display:state on
Query Syntax | SENSe:MULTiplexer<id>:DISPlay[:STATe]?
Return Type | Boolean
Default | OFF or 0

SENSe:MULTiplexer<id>:INCount?

Applicable Models: E5080A

(Read-Only) Returns the number of input ports for the specified test set.

  • For test sets such as the E5091A that do NOT use jumper cables to route the stimulus and response signals, this command returns the number of test set ports that can be connected to the VNA.

  • For test sets that DO use jumper cables to route the stimulus and response signals, such as the N44xx, the return value is not valid.

Parameters

<id>

Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.

Examples

SENS3:MULT1:INC? ' returns the number of input ports for test set 1 on channel 3

Return Type

Numeric

Default

Not Applicable

SENSe<cnum>:MULTiplexer:LABel <string>

Applicable Models: E5080A

(Read-Write) Sets and returns the display label for the test set on the specified channel. The label appears in a status bar at the bottom of the VNA display when SENS:MULT:DISP is set to ON.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<string> | Display label text.
Examples | SENS3:MULT:LAB 'High-power output'
Query Syntax | SENSe<cnum>:MULTiplexer:LABel?
Return Type | String
Default | Not Applicable

SENSe<cnum>:MULTiplexer<id>:OUTPut:<grp>[:DATA] <num>

Applicable Models: E5080A

(Read-Write) Sets or returns the output port data for specified group with id of the E5092A multiport test set.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<id>

Id of the external test set either 1 or 2. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.

<grp>

A | B | C | D

<num>

An integer specifying the decimal value of the control line. Values are obtained by adding weights from the following table that correspond to individual lines.

The output port data range is between 0 to 255 (0=All line are turns OFF and 255 all lines are turn ON).

Line | Weight
1 | 1
2 | 2
3 | 4
4 | 8
5 | 16
6 | 32
7 | 64
8 | 128

Examples

SENS3:MULT1:OUTP:B 8

Query Syntax

SENSe<cnum>:MULTiplexer<id>:OUTPut:<grp>[:DATa]?

Return Type

Numeric

Default

0

SENSe<cnum>:MULTiplexer<id>:OUTPut:<grp>:VOLTage[:DATA] <volt>

Applicable Models: E5080A

(Read-Write) Sets or returns the output voltage for specified group with id of the E5092A multiport test set.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<id> | Id of the external test set either 1 or 2. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.
<grp> | A | B | C | D
<volt> | Output voltage range for <grp> is between 0 to 5.2V and resolution is 10mV.
Examples | SENS3:MULT1:OUTP:B:VOLT 4.2
Query Syntax | SENSe<cnum>:MULTiplexer<id>:OUTPut:<grp>:VOLtage[:DATa]?
Return Type | Numeric
Default | 0 V

SENSe<cnum>:MULTiplexer<id>:OUTPut[:DATA | DATa] <num>

Applicable Models: E5080A

(Read-Write) Sets or returns the status of HIGH/LOW of all the control lines of the E5091A whose ID is 1 to 2 (id) when measuring selected channel in the measurement using the E5091A.

Note: This command is available only for E5091A multiport test set.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<id>

Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.

<num>

An integer specifying the decimal value of the control line. Values are obtained by adding weights from the following table that correspond to individual lines.

Line | Weight
1 | 1
2 | 2
3 | 4
4 | 8
5 | 16
6 | 32
7 | 64
8 | 128

Note:

  • The E5091A interprets SENS:MULT1:OUTP 0 as all lines OFF.

  • All "Z"and "H" series test sets interpret SENS:MULT1:OUTP 0 as all lines ON.

Refer to your test set documentation for setting control line values.

Examples

SENS3:MULT1:OUTP 48 'For Z5623A K64, lines 5 and 6 are OFF; all other lines are set to ON state.

Query Syntax

SENSe<cnum>:MULTiplexer<id>:OUTPut[:DATA]?

Return Type

Numeric

Default

Not Applicable

SENSe<cnum>:MULTiplexer<id>:PORT<pnum>:CATalog?

Applicable Models: E5080A

(Read-Only) Returns a comma-separated list of valid port selections for the specified port.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<id> | Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.
<pnum> | Integer - Input port number for which to return valid Output port selections. Read the number of input ports for the test set using SENS:MULT:INC?
Examples | SENS:MULT1:PORT3:CAT? ' returns the valid port selections for port 3
Return Type | String
Default | Not Applicable

SENSe<cnum>:MULTiplexer<id>:PORT<pnum>:SELect <string>

Applicable Models: E5080A

(Write-Only) Sets and returns a port mapping for a single port. If this command creates a conflict with an existing port, the VNA will resolve the conflict. Note: This command is not supported for the Z5623AK44.
Parameters |
<cnum> | Channel number of the measurement. If unspecified, value is set to 1.
<id> | Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENSe:MULT:TYPE command.
<pnum> | Integer - Logical port number.
<string> | Physical port number.
Examples | SENS:MULT1:PORT3:SEL "4" 'sets logical port 3 to physical port 4.
Return Type | String
Default | Not Applicable

SENSe:MULTiplexer<id>:STATe <bool>

Applicable Models: E5080A

(Read-Write) Enables and disables (ON/OFF) the port mapping and control line output of the specified test set.

If the specified test set is not connected or not ON, then setting State ON will report an error. All other properties can be set when the test set is not connected.

When this command is set to ON, then the display of the test set status bar (SENS:MULT:DISP) is also set to ON.

Parameters

<id>

Id of the external test set. If unspecified, Id is assumed to be 1. Must be previously set by the SENS:MULT:TYPE command.

<bool>

ON(1) Enables test set control.

OFF (0) Disables test set control.

Examples

SENS:MULT1:STAT 1
sense2:multiplexer2:state on

Query Syntax

SENSe<cnum>:MULTiplexer<id>:STATe?

Return Type

Boolean

Default

OFF (0)

SENSe:MULTiplexer<id>:TYPE | TYPe <name>

Applicable Models: E5080A

(Read-Write) Loads a configuration file for the specified type of external test set. This command should be immediately followed by the SENS:MULT:ADDR command.
Parameters |
<name> | String The name of the type of test set. Must be one of the items in the list returned by the SENS:MULT:CAT? query.
<id> | Id of the external test set. Set by this command. Use consecutive values starting at 1.
Examples | SENS:MULT1:TYPE "Z5623AK66" ' use K66 test set, and reference it through ID 1
Query Syntax | SENSe:MULTiplexer<id>:TYPe?
Return Type | String
Default | Not Applicable

Last Modified:

6-Jan-2016

First Release


Roscillator SCPI

Sense:Roscillator Command

Learn about the Reference Osc.

See the rear-panel 10 MHz connector.

SENSe:ROSCillator:SOURce?

Applicable Models: E5080A

(Read-only) Applying a 10 MHz signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked.

  • EXT is returned when a signal is present at the 10 MHz Reference Oscillator connector.

  • INT is returned when NO signal is present at the 10 MHz Reference Oscillator connector.

Examples

SENS:ROSC:SOUR?
sense:roscillator:source?

Return Type

Character

Default

Not applicable

Last Modified:

6-Jan-2016

First Release


Segment SCPI

Sense:Segment Commands

Defines the segment sweep settings.

Enable segment sweep with SENS:SWE:TYPE SEGM.

SENSe:Segment:

ADD

ARBitrary

BANDwidth | BWIDth

| [RESolution]

| CONTrol

| PORT

| [RESolution]

| CONTrol

COUNt

DELete

| ALL

FREQuency

| CENTer

| SPAN

| STARt

| STOP

LIST

[STATe]

| CONTrol

POWer

| ATTenuator

| RECeiver

| CONTrol

| REFerence

| TEST

| [LEVel]

| CONTrol

SHLO

| CONTrol

SWEep

| DELay

| CONTrol

| DWELl

| CONTrol

| GENeration

| CONTrol

| POINts

| TIME

| CONTrol

| X

| SPACing

Click on a Red keyword to view the command details.

See Also

  • Example: Upload and Download a Segment List

  • Learn about Segment Sweep

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:SEGMent<snum>:ADD

Applicable Models: E5080A, M9485A

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Default | Not Applicable

SENSe<cnum>:SEGMent:ARBitrary <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables you to setup a segment sweep with arbitrary frequencies. The start and stop frequencies of each segment can overlap other segments. Also, each segment can have a start frequency that is greater than its stop frequency which causes a reverse sweep over that segment. Learn more about Arbitrary Segment Sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<bool> | ON or 1 - Allows the setup of arbitrary segment sweep. OFF or 0 - Prevents the setup of arbitrary segment sweep.
Examples | SENS:SEGM:ARB ON sense2:segment:arbitrary off
Query Syntax | SENSe<cnum>:SEGMent:ARBitrary?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:BANDwidth | BWIDth[:RESolution] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the IF Bandwidth for the specified segment. First set SENS:SEGM:BANDwidth | BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the VNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ

sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Numeric

Default

Varies with VNA model.

SENSe<cnum>:SEGMent:BANDwidth | BWIDth[:RESolution]:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for all segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON or 1 - Turns Bandwidth control ON. Bandwidth can be independently set for each segment. OFF or 0 - Turns Bandwidth control OFF. Use the channel IF bandwidth setting SENS:BWID.
Examples | SENS:SEGM:BWID:CONT ON sense2:segment2:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:BWIDth | BANDwidth[:RESolution]:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:BANDwidth | BWIDth:PORT<pnum>[:RESolution] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment for the selected port and channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<pnum>

Individual port number of the source: Port 1 to Port 2/Port 4. If unspecified, value is set to 1.

<num>

IF Bandwidth of each segment in Hz. The list of valid IF Bandwidths is different depending on the VNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID:PORT1 1KHZ

sense2:segment2:bandwidth:PORT2:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth \ BANDwidth:PORT<pnum>[:RESolution]?

Return Type

Numeric

Default

Varies with VNA model.

SENSe<cnum>:SEGMent:BANDwidth | BWIDth:PORT<pnum>[:RESolution]:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the individual (Port 1 to Port 2/Port 4) IF Bandwidth control in the segment sweep table.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Individual port number of the source: Port 1 to Port 2/Port 4. If unspecified, value is set to 1.
<bool> | Specified the individual IFBW control, either ON or OFF. ON or 1 - Turns ON the individual port IFBW control. OFF or 0 - Turns OFF the individual port IFBW control.
Examples | SENS:SEGM:BWID:PORT1:CONT ON sense2:segment2:bandwidth:PORT2:resolution:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:BWIDth | BANDwidth:PORT<pnum>[:RESolution]:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent:COUNt?

Applicable Models: E5080A, M9485A

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Numeric
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

Applicable Models: E5080A, M9485A

(Write-only) Deletes the specified sweep segment. When ALL segments are deleted, SENS:SWE:TYPE is automatically set to Linear because there are no segments to sweep.
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Number of the segment to delete. If unspecified, value is set to 1.
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not Applicable
Default | Not applicable

SENSe<cnum>:SEGMent:DELete:ALL

Applicable Models: E5080A, M9485A

(Write-only) Deletes all sweep segments. When this command is executed, SENS:SWE:TYPE is automatically set to Linear because there are no segments to sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Numeric

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Numeric

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Start Frequency for the specified sweep segment.

Notes:

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

To return the start and stop frequency of the entire sweep (all segments), Use SENS:FREQ:STARt? and SENS:FREQ:STOP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:STAR 1MHZ
sense2:segment2:frequency:start minimum

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?

Return Type

Numeric

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Stop Frequency for the specified sweep segment.

Notes:

All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.

To return the start and stop frequency of the entire sweep (all segments), Use SENS:FREQ:STARt? and SENS:FREQ:STOP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:STOP 1MHZ
sense2:segment2:frequency:stop maximum

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?

Return Type

Numeric

Default

If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:LIST <char>,<numSegs>,<data>

Applicable Models: E5080A, M9485A

(Read-Write) Reads or writes the entire list of values in the segment sweep table.

Note: For binary data transfer, specify 64-bit instead of 32-bit using FORMat[:DATA]. This is because higher frequencies used on VNA exceed the maximum value that can be represented by a 32-bit floating point number.

When sending/receiving this data as binary (FORMat[:DATA] REAL,64), use FORMat:BORDer to specify the correct 'endianness' (byte ordering) corresponding to your programming environment / computer platform.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Any existing segment number.

<char>

Choose from:

SSTOP - Frequency values are Start and Stop for each segment.

CSPAN - Frequency values are Center and Span for each segment.

<numSegs>

Total number of sweep segments being input. This allows the VNA to determine how many values per-each-segment are in the input <data> block.

<data>

A 2-dimensional array of Segment data as a single data block. The data elements within a segment are each represented as real floating-point numbers as follows, and the data block is formed by interleaving all the segments together consecutively:

  1. Segment state (Boolean 1 for ON and 0 for OFF)

  2. Number of Points in the segment

  3. Start Freq (when <char> is SSTOP), or Center Freq (when <char> is CSPAN)

  4. Stop Freq (when <char> is SSTOP), or Freq Span (when <char> is CSPAN)

  5. IFBW (optional for the Write)

  6. Dwell Time (optional for the Write)

  7. Power (optional for the Write) - see below.

The first four data elements must always be supplied. After those values, data must be supplied for successive optional elements. For example, to set dwell time values, you must also supply IFBW values, because IFBW (#5) precedes dwell time (#6) in the array order.

The IF Bandwidth, Sweep Time and Source Power Control settings do NOT affect the order in which elements are interpreted.

The number of elements to supply for Power depends on the following two settings:

  1. Source Power Option - ON allows segments to have independent power levels.

  2. Couple Ports = Off allows different power levels for each test port.

CouplePorts

SourcePowerOption

Number of Elements

False

False

Each port has its own channel-wide power setting, which is set using SOURce:POWer[:LEVel]. Provide exactly 7 elements per segment. The last element (power) is ignored.

False

True

Provide 6 elements + total number of ports. The first 7 elements are still interpreted the same.

The remaining elements (in-order) are interpreted as the power levels to set on that segment for Ports 2 through N, where N is the total number of ports currently enabled for the VNA or for a VNA with multiport external test set.

True

False

Provide exactly 7 elements per segment. The last element (power) is ignored.

True

True

Provide exactly 7 elements per segment. The last element (power) is honored.

Examples

SENS:SEGM:LIST SSTOP,1,1,201,10E6,26.5E9,1E3,0,-10 1 segment, state ON, 201 points, 10 MHz to 26.5 GHz, 1kHz IFBW, 0 dwell time, -10 dBm (port powers coupled)

sense2:segment:list? cspan

See Upload and Download a Segment List example program

Query Syntax

SENSe<cnum>:SEGMent:LIST? [char].

If unspecified, char is set to SSTOP.

The number of data elements per segment returned will be 6 + total number of source ports, regardless of the IF Bandwidth, Sweep Time and Source Power Control settings. For the N5264A, which has no source ports, the query will return just 6 values per segment. For all other VNA models, the last elements in each segment correspond to the power level for each port.

Return Type

Returns block data in the format specified by FORMat[:DATA].

Default

Not Applicable

SENSe<cnum>:SEGMent<snum>[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the specified sweep segment . At least ONE segment must be ON or Sweep Mode is automatically set to Linear.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF.
<bool> | ON or 1 - Turns segment ON. OFF or 0 - Turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent<snum>[:STATe]?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:CONTrol <num>

Applicable Models: M9485A

(Read-Write) Turns ON or OFF the individual receiver attenuator control in the segment sweep table.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Segment number to modify. Choose any existing segment number. If unspecified, value is set to 1.
<port> | Source port number of the VNA. If unspecified, value is set to 1.
<bool> | ON or 1 - Turns ON the individual receiver attenuator control. OFF or 0 - Turns OFF the individual receiver attenuator control
Examples | SENS:SEGM:POW2:ATT:REC:REF 0 sense:segment:power:attenuator:receiver:reference 35
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:CONTrol?
Return Type | Numeric. If querying for the standard port, the return value is 0
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:REFerence <num>

Applicable Models: M9485A

(Read-Write) Sets the attenuation level for the specified reference attenuator for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Segment number to modify. Choose any existing segment number. If unspecified, value is set to 1.
<port> | Source port number of the VNA. If unspecified, value is set to 1.
<num> | Attenuation value in dB. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SENS:SEGM:POW2:ATT:REC:REF 0 sense:segment:power:attenuator:receiver:reference 35
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:REFerence?
Return Type | Numeric. If querying for the standard port, the return value is 0
Default | 35

SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:TEST <num>

Applicable Models: M9485A

(Read-Write) Sets the attenuation level for the specified reference attenuator for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Segment number to modify. Choose any existing segment number. If unspecified, value is set to 1.
<port> | Source port number of the VNA. If unspecified, value is set to 1.
<num> | Attenuation value in dB. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SENS:SEGM:POW2:ATT:REC:TEST 0 sense:segment:power:attenuator:receiver:test 35
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer<port>:ATTenuator:RECeiver:TEST?
Return Type | Numeric. If querying for the standard port, the return value is 0
Default | 35

SENSe<cnum>:SEGMent<snum>:STATe:CONTrol <bool>

Applicable Models: M9485A

(Read-Write) Turns ON or OFF the specified/individual segment state control in the segment sweep table. At least ONE segment must be ON or is automatically set to Linear.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF.
<bool> | ON or 1 - Turns ON the individual segment state control. OFF or 0 - Turns OFF the individual segment state control.
Examples | SENS:SEGM:STAT:CONT ON sense2:segment2:state:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:STATe:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON.

When port power is Coupled, setting port power for one port will apply port power for all source ports.

All subsequent segments that are added assume the new Power Level value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<port>

Port number of the source. If unspecified, value is set to 1.

<num>

Power level.

Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, send SOUR:POW? MAX and SOUR:POW? MIN. (SOUR:POW:ATT:AUTO must be set to ON).

Actual achievable leveled power depends on frequency.

Examples

SENS:SEGM:POW 0
sense2:segment2:power1:level -10

Query Syntax

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?

Return Type

Numeric

Default

0

SENSe<cnum>:SEGMent<snum>:POWer[:LEVel]:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<bool> | ON or 1 - Turns Power Level control ON. Power level can be set for each segment. OFF or 0 - Turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:SHLO

Applicable Models: E5080A

(Read-Write) Sets or returns the Shift LO state of each segment in the segment sweep table for the selected channel. Notes: The SENS:SEGM:SHLO:CONT command must first be set to ON before using this command.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
Examples | SENS:SEGM:SHLO sense2:segment2:shlo
Query Syntax | SENSe<cnum>:SEGMent<snum>:SHLO?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:SHLO:CONTrol <bool>

Applicable Models: E5080A

(Read-Write) Turns ON or OFF the individual Shift LO state control in the segment sweep table.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<bool> | ON or 1 - Turns ON the individual Shift LO state control. OFF or 0 - Turns OFF the individual Shift LO state control.
Examples | SENS:SEGM:SHLO:CONT ON sense2:segment2:shlo:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:SHLO:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:SWEep:DELay <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns the sweep delay time of selected channel. Notes: The SENS:SEGM:SWE:DEL:CONT command must first be set to ON before using this command.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Range of sweep delay time is between 0 to 1 and the resolution is 0.001. Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.
<unit> | s (second)
Examples | SENS:SEGM:SWE:DEL sense2:segment2:sweep:delay
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:DELay?
Return Type | Numeric / Double precision floating point
Default | 0

SENSe<cnum>:SEGMent<snum>:SWEep:DELay:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF the sweep delay time of selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<bool> | ON or 1 - Turns ON sweep delay time. OFF or 0 - Turns OFF sweep delay time.
Examples | SENS:SEGM:SWE:DEL:CONT ON sense2:segment2:sweep:delay:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:DELay:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:SWEep:DWELl <num>

Applicable Models: M9485A

(Read-Write) Sets or returns the sweep dwell time of selected channel. Notes: The SENS:SEGM:SWE:DWELl:CONT command must first be set to ON before using this command.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Range of sweep dwell time Notes: If the specified variable is out of the allowable setup range, the minimum value (if the lower limit of the range is not reached) or the maximum value (if the upper limit of the range is exceeded) is set.
<unit> | s (second)
Examples | SENS:SEGM:SWE:DWEL sense2:segment2:sweep:dwell
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:DWELl?
Return Type | Numeric / Double precision floating point
Default | 0

SENSe<cnum>:SEGMent<snum>:SWEep:DWELl:CONTrol <bool>

Applicable Models: M9485A

(Read-Write) Turns ON or OFF the sweep dwell time of selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<bool> | ON or 1 - Turns ON sweep dwell time. OFF or 0 - Turns OFF sweep dwell time.
Examples | SENS:SEGM:SWE:DWEL:CONT ON sense2:segment2:sweep:dwell:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:DWELl:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:SWEep:GENeration <char>

Applicable Models: E5080A

(Read-Write) Sets or returns the sweep mode of selected channel.

Notes: The SENS:SEGM:SWE:GEN:CONT command must first be set to ON before using this command.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<snum>

Any existing segment number.

<char>

Select sweep mode from either of the following:

  • "AUTO": Sets the sweep mode to the swept mode.

  • "STEPped": Sets the sweep mode to the stepped mode.

Examples

SENS:SEGM:SWE:GEN AUTO
sense2:segment2:sweep:generation stepped

Query Syntax

SENSe<cnum>:SEGMent<snum>:SWEep:GENeration?

Return Type

Character

Default

"AUTO"

SENSe<cnum>:SEGMent<snum>:SWEep:GENeration:CONTrol <bool>

Applicable Models: E5080A

(Read-Write) Turns ON or OFF the sweep mode of selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Any existing segment number.
<bool> | ON or 1 - Turn ON sweep mode. OFF or 0 - Turn OFF sweep mode.
Examples | SENS:SEGM:SWE:GEN:CONT ON sense2:segment2:sweep:generation:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:GENeration:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of data points for the specified sweep segment.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<snum>

Any existing segment number. If unspecified, value is set to 1.

<num>

Number of measurement points in the segment. The total number of points in all segments cannot exceed 20001. A segment can have as few as 2 point.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:SWE:POIN 51
sense2:segment2:sweep:points maximum

Query Syntax

SENSe<cnum>:SEGMent<snum>:S WEep:POINts?

Return Type

Numeric

Default

201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the total time (including sweep delay time) the analyzer takes to sweep the specified sweep segment, for the segment sweep table of the selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<snum> | Any existing segment number.
<num> | Sweep time in s (seconds). Choose a number between 0 and 100. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Numeric / Double precision floating point
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:SWEep:TIME:CONTrol <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<bool> | ON or 1 - Turns Sweep Time control ON. Sweep Time can be set for each segment. OFF or 0 - Turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIME:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent<snum>:SWEep:TIME:CONTrol?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SEGMent<snum>:X:SPACing <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets X-axis spacing ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<char> | LINear - turns X-axis point spacing OFF. OBASe - turns X-axis point spacing ON.
Examples | SENS:SEGM:X:SPACing LIN sense2:segment:spacing obase
Query Syntax | SENSe<cnum>:SEGMent<snum>:X:SPACing?
Return Type | Character
Default | LINear

Last Modified:

6-Jan-2016

First Release


Sweep SCPI

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

SENSe:SWEep:

DWELl

| AUTO

| SDELay

GROups

| COUNt

MODE

POINts

PULSe More commands

SLOCal

| MAXimum

| STATe

SPEed

STEP

TIME

| AUTO

TRIGger

| DELAY

| MODE

TYPE

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Example of Triggering the VNA using SCPI

  • Learn about sweeping

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<cnum>:SWEep:DWELl <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENS:SWE:GEN set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dweli min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Numeric

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

SENSe<cnum>:SWEep:DWELl:SDELay <num>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the time to wait just before acquisition begins for each sweep. This delay is in addition to Dwell Time and the following two External Trigger delays if enabled.

  • Trig:Delay (global scope)

  • Sens:Swe:Trig:Delay (channel scope)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Sweep delay in seconds.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL:SDEL .1
sense2:sweep:dwell:sdelay .5

Query Syntax

SENSe<cnum>:SWEep:DWELl:SDELay?

Return Type

Numeric

Default

0

SENSe<cnum>:SWEep:GENeration <char>

Applicable Models: E5080A

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog (Auto) - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Default

STEPped

SENSe<cnum>:SWEep:GROups:COUNt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the trigger count (groups) for the specified channel. Set trigger mode to group after setting this count.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Numeric
Default | 1

SENSe<cnum>:SWEep:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of trigger signals the specified channel will ACCEPT.

See Triggering the VNA Using SCPI.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Trigger mode. Choose from:

HOLD - channel will not trigger

CONTinuous - channel triggers indefinitely

GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>. This is one of the VNA overlapped commands. Learn more.

SINGle - channel accepts ONE trigger, then goes to HOLD.

Note: To perform simple, single-triggering, use SINGle which requires that TRIG:SOURce remain in the default (internal) setting.

Examples

SENS:SWE:MODE CONT
sense2:sweep:mode hold

Query Syntax

SENSe<cnum>:SWEep:MODE?

Return Type

Character

Default

CONTinuous

SENSe<cnum>:SWEep:POINts <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 1 and the VNA maximum number of points. This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Numeric
Default | 201

SENSe<cnum>:SWEep:SLOCal:MAXimum <num>

Applicable Models: E5080A

(Read-Write) Sets the Shift LO maximum frequency for the selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Range of shift LO maximum frequency is 1.5E8 to Maximum frequency.
Examples | SENS:SWE:SCLOC:MAX 1.5E8 sense2:sweep:slocal:maximum 1.5E8
Query Syntax | SENSe<cnum>:SWEep:SLOCal:MAXimum?
Return Type | Numeric / Double precision floating point
Default | Maximum frequency

SENSe<cnum>:SWEep:SLOCal:STATe <bool>

Applicable Models: E5080A

(Read-Write) Turns ON or OFF the Shift LO mode for the selected channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | Select shoft LO mode from either of the following: ON or 1 - Turns ON the Shift LO mode. OFF or 0 - Turns OFF the Shift LO mode.
Examples | SENS:SWE:SLOC:STAT ON sense2:sweep:slocal:state off
Query Syntax | SENSe<cnum>:SWEep:SLOCal:STATe?
Return Type | Boolean
Default | OFF or 0

SENSe<cnum>:SWEep:SPEed <char>

Applicable Models: M9485A

(Read-Write) Sets and returns the state of Fast Sweep mode. Learn more about Fast Sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Fast Sweep mode. Choose from: FAST - turns Fast Sweep Mode ON NORMal - turns Fast Sweep Mode OFF (Normal Mode).
Examples | SENS:SWE:SPE NORM sense2:sweep:speed fast
Query Syntax | SENSe<cnum>:SWEep:SPEed?
Return Type | Character
Default | NORMal

SENSe<cnum>:SWEep:STEP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the step of stimulus
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Value of step for each points in stimulus
Examples | SENS:SWE:STEP 1e3 sense2:sweep:step 1000
Query Syntax | SENSe<cnum>:SWEep:STEP?
Return Type | Numeric
Default | Not Applicable

SENSe<cnum>:SWEep:TIME <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the time the analyzer takes to complete one sweep. If sweep time accuracy is critical, use ONLY the values that are attained using the up and down arrows next to the sweep time entry box. See Sweep Time.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Sweep time in seconds.

To select the fastest sweep speed, either send MIN as an argument to this command, or send SENS:SWE:TIME:AUTO 1.

This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

The MAX value will change based on point count, IFBW, and dwell time.

Examples

SENS:SWE:TIME 1ms
sense2:sweep:time .001

Query Syntax

SENSe<cnum>:S WEep:TIME?

Return Type

Numeric

Default

Not Applicable

SENSe<cnum>:SWEep:TIME:AUTO <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

SENSe<cnum>:SWEep:TRIGger:DELay <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the trigger delay for all measurements in the specified CHANNEL. This delay is only applied while TRIG:SOURce EXTernal and TRIG:SCOP CURRent . After an external trigger is applied, the start of the sweep is delayed for the specified delay value plus any inherent latency. To apply a trigger delay for all channels (Global), use TRIG:DEL
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Trigger delay value in seconds. Range is from 0 to 107 seconds
Examples | SENS:SWE:TRIG:DELay .003 sense2:sweep:trigger:delay 1
Query Syntax | SENSe<cnum>:SWEep:TRIGger:DELay?
Return Type | Numeric
Default | 0

SENSe<cnum>:SWEep:TRIGger:MODE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the trigger mode for the specified channel. This determines what EACH signal will trigger. Learn more.

Note: Setting Point and Sweep mode forces Trigger:SCOPe = CURRent

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Trigger mode. choose from:

  • CHANnel - Each trigger signal causes ALL traces in that channel to be swept.

  • SWEep - Each Manual or External trigger signal causes ALL traces that share a source port to be swept.

  • POINt - Each Manual or External trigger signal causes one data point to be measured.

Examples

SENS:SWE:TRIG:MODE SWE
sense2:sweep:trigger:mode point

Query Syntax

SENSe<cnum>:SWEep:TRIGger:MODE?

Return Type

Character

Default

Channel

SENSe<cnum>:SWEep:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the type of analyzer sweep mode. First set sweep type, then set sweep parameters such as frequency or power settings. Note: For SweptIMD channels, use SENS:IMD:SWE:TYPE SEGMent See Also: FCA Segment Sweep commands
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | LOGarithmic | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Default | LINear

Last Modified:

6-Jan-2016

First Release


Service SCPI

Service Commands

Controls and queries settings related with Service.

SERVice:
:LOGGing:CLEAR

SERVice:LOGGing:CLEar

Applicable Models: E5080A, M9485A

(Write-only) Delete the service error log files stored in the modules and PC. See Error Log_Data.
Parameters |
Examples | SERV:LOGG:CLE service:logging:clear
Return Type | N/A
Default | Not Applicable

Last modified:

6-Jan-2016

New topic


Source SCPI

Source Commands

Controls the power delivered to the DUT.

SOURce:

CATalog?

POWer

| ALC[:MODE]

| CATalog?

| RECeiver - More commands

| ATTenuator

| RECeiver

| REFerence

| TEST

| CENTer

| CORRection - More commands

| COUPle

| [LEVel]

| [IMMediate][AMPLitude]

| SLOPe

| STATe

| MODE

| PORT

| STARt

| STOP

| SPAN

| STARt

| STOP

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Power Settings

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

  • Remotely Specifying a Source Port

SOURce<cnum>:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns a list of valid port names that can be controlled. Some ports only have string names, NOT numbers. All commands that require a port argument have provisions for specifying either a port number OR a string name. See also: Remotely Specifying a Source Port.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SOUR:CAT? source:catalog 'VNA models return "Port 1,Port 2,Port 3,Port 4, MXG"
Return Type | Comma-separated list of strings.
Default | Not Applicable

SOURce<cnum>:POWer<port>:ALC[:MODE] <char>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the ALC mode for the specified channel and port. Use SOUR:POW:ALC:MODE:CAT? to return a list of valid ALC modes for the VNA.

Learn more about ALC mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<char>

ALC Mode.

For the VNA choose from:

  • INTernal Standard ALC loop

  • OPENloop No ALC loop

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names

Examples

SOUR:POW:ALC INT

source2:power2:alc:mode openloop

source:power:alc:mode openloop,"Port 1 Src2"

Query Syntax

SOURce<cnum>:POWer<port>:ALC:MODE? [src]

Return Type

Character

Default

INTernal

SOURce<cnum>:POWer<port>:ALC[:MODE]:CATalog? [src]

Applicable Models: M9485A

(Read-only) Returns a list of valid ALC modes for the specified channel and port number. Use the returned values to set SOUR:POW:ALC:MODE.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:CAT?

source2:power2:alc:mode:catalog?

source:power:alc:mode:catalog? "Port 1 Src2"

Return Type

Comma-separated list of strings.

Default

Not applicable

SOURce<cnum>:POWer<port>:ATTenuator:RECeiver:REFerence <num>

Applicable Models: M9485A

(Read-Write) Sets the attenuation level for the specified reference attenuator.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Source port number of the VNA. If unspecified, value is set to 1.
<num> | Attenuation value in dB. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SOUR:POW2:ATT:REC:REF 0 source:power:attenuator:receiver:reference 35
Query Syntax | SOURce<cnum>:POWer<port>:ATTenuator:RECeiver:REFerence?
Return Type | Numeric. If querying for the standard port, the return value is 0
Default | 35

SOURce<cnum>:POWer<port>:ATTenuator:RECeiver:TEST <num>

Applicable Models: M9485A

(Read-Write) Sets the attenuation level for the specified test attenuator.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Source port number of the VNA. If unspecified, value is set to 1.
<num> | Attenuation value in dB. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SOUR:POW2:ATT:REC:TEST 0 source:power:attenuator:receiver:test 35
Query Syntax | SOURce<cnum>:POWer<port>:ATTenuator:RECeiver:TEST?
Return Type | Numeric. If querying for the standard port, the return value is 0
Default | 35

SOURce<cnum>:POWer<port>:CENTer <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Actual achievable leveled power depends on frequency.
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Numeric
Default | 0 dBm

SOURce<cnum>:POWer<port>:COUPle <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - turns coupling ON. The same power level is used for both source ports. OFF (or 0) - turns coupling OFF. Power level can be set individually for each source port.
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate][:AMPLitude] <num>, [src]

Applicable Models: E5080A, M9485A

(Read-Write) Sets the RF power output level.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<num>

Source power in dBm.

Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer? Max

Actual achievable leveled power depends on frequency.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW1 5
source2:power:level:immediate:amplitude maximum

sour:pow 5, "Port 1 Src2"

Query Syntax

SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]? [src]

Return Type

Numeric

Default

0 dBm

SOURce<cnum>:POWer<port>[:LEVel]:SLOPe <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the RF power slope value. Also enable the slope state using SOUR:POW:SLOP:STAT ON.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Slope value in db/GHz. Choose any value between -2 and 2 (0 is no slope).
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:SLOP .5234434 source2:power:level slope -1.345
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Numeric
Default | 0

SOURce<cnum>:POWer<port>[:LEVel]:SLOPe:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns Power Slope ON or OFF. Set the slope using SOUR:POW:SLOP.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<bool> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF

SOURce<cnum>:POWer<port>:MODE <state>, [src]

Applicable Models: E5080A, M9485A

(Read-Write) Sets the state of VNA source for the specified port.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, <port> is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<state>

Source state. Choose from:

  • AUTO Source power is turned ON when required for a measurement.

  • ON Source power is always ON regardless of the measurement.

  • OFF Source power is always OFF regardless of the measurement.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:MODE ON

source2:power4:mode OFF

sour:pow:mode on, "Port 1 Src2"

Query Syntax

SOURce<cnum>:POWer<port>:MODE? [src]

Return Type

Character

Default

Auto

SOURce<cnum>:POWer<port>:PORT:STARt <num>, [src]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the power sweep start power value for a specific port. This allows uncoupled forward and reverse power sweep ranges. Must also set SENS:SWE:TYPE POWer and SOUR:POW:COUPle OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, <port> is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<num>

Start power in dBm.

Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STARt? MIN

Actual achievable leveled power depends on frequency.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW1:PORT:STAR -15
source2:power:port:start 5, "bal port 1"

Query Syntax

SOURce<cnum>:POWer<port>:PORT:STARt? [src]

Return Type

Numeric

Default

-10 dBm

SOURce<cnum>:POWer<port>:PORT:STOP <num>, [src]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the power sweep stop power value for a specific port. This allows uncoupled forward and reverse power sweep ranges. Must also set SENS:SWE:TYPE POWer and SOUR:POW:COUPle OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Source port number of the VNA. If unspecified, <port> is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<num>

Stop power in dBm.

Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STARt? MIN

Actual achievable leveled power depends on frequency.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW1:PORT:STOP -15
source2:power:port:stop 5, "bal port 1"

Query Syntax

SOURce<cnum>:POWer<port>:PORT:STOP? [src]

Return Type

Numeric

Default

0 dBm

SOURce<cnum>:POWer<port>:SPAN <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<num>

Span power. Actual achievable leveled power depends on frequency.

<port>

If provided, this argument is ignored by the VNA.

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Numeric

Default

10 dBm

SOURce<cnum>:POWer<port>:STARt <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the power sweep start power for ALL ports being used by the specified channel. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num> . To set start power for a specific port, use SOUR:POW:PORT:STARt.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STARt? MIN Actual achievable leveled power depends on frequency.
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Numeric
Default | -10 dBm

SOURce<cnum>:POWer<port>:STOP <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the power sweep stop power for ALL ports being used by the specified channel.. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>. To set start power for a specific port, use SOUR:POW:PORT:STOP.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Note: The range of settable power values depends on the VNA model and if source attenuators are installed. To determine the range of values, perform a query using MAX, then MIN, as an argument. (SOUR:POW:ATT:AUTO must be set to ON) Example: SOURce:POWer:STOP? MAX Actual achievable leveled power depends on frequency.
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Numeric
Default | 0 dBm

Last Modified:

6-Jan-2016

First Release


SourceCorrection SCPI

Source:Power:Correction Commands

Used to perform source power calibration on internal and external sources.

Note: Only ONE Source Power Cal can be performed at a time.

SOURce:POWer:CORRection:

COLLect

| ABORt

| [ACQuire]

| AVERage

| [COUNt]

| NTOLerance

| DISPlay

| [STATe]

| FCHeck]

| [STATe]

| ITERation

| [COUNt]

| NTOLerance

| SAVE

| SENSor

| [FRANge]

| RCFactor

| SELect

| TABLe

| DATA

| FREQuency

| LOSS

| [STATe]

| POINts?

| [SELect]

DATA

| PRIor

LEVel [AMPlitude]

OFFSet

| [MAGNitude]

[STATe]

Click on a Red keyword to view the command details.

Red commands are superseded.

See Also

  • Example program using these commands.

  • Template for creating your own Power Meter Driver

  • Learn about Source Power Cal

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Note: The SOURce:POWer:CORRection:COLLect:ACQuire command, used to step the VNA and read a power meter, cannot be sent over the GPIB unless the power meter is connected to a different GPIB interface. See the alternative methods described in the command details.

SOURce<ch>:POWer<port>:CORRection:COLLect:ABORt

Applicable Models: E5080A, M9485A

(Write-only) Aborts a source power calibration sweep that is in progress. To use this ABORt command, you MUST use the ASYNchronous argument with SOUR:POW:CORR:COLL:ACQ After aborting, this message appears in the error log: +243,"Requested operation was canceled".
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
Examples | SOUR:POW:CORR:COLL:ABOR source1:power2:correction:collect:abort
Query Syntax | Not Applicable
Default | Not Applicable

SOURce<ch>:POWer<port>:CORRection:COLLect[:ACQuire] <char>,<id>[,src][,sync]

Applicable Models: E5080A, M9485A

Note: With VNA Rev. 6.2, a new "id" argument has been added to this command, replacing SOUR:POW:CORR:COLL:METH.

(Write-only) Initiates a source power cal acquisition sweep using the power sensor attached to the specified channel (A or B) on the power meter, using a USB power sensor, or using the specified VNA receiver.

For source power cal, the power meter can NOT be controlled by the VNA using the GPIB Talker/Listener interface. Instead use one of the following methods:

  • If present, use the GPIB dedicated controller port.

  • Connect the power meter to the VNA using a USB / GPIB interface (Keysight 82357B).

  • SCPI programming of the VNA using a LAN Client interface (see example).

  • Send SCPI commands through the COM interface using the SCPI String Parser object.

  • Directly control the Power Meter and VNA to step frequency; then acquire and store the Power reading. (see example).

  • Configure the Power Meter/Sensor as a PMAR Device. Learn how. See SCPI commands.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<char>

Acquisition Choose from:

  • PMETer - Power Meter is used for all readings.

  • PMReceiver - Power meter for the first iteration; then use the reference receiver for remaining readings if necessary (same as "fast iteration" box checked on dialog box)

  • RECeiver - Use VNA measurement receiver for all readings.

<id>

String (Not case sensitive). The power sensor or VNA receiver to use for measuring power.

For PMETer or PMRECeiver, choose from:

  • "ASENSOR" or "BSENSOR". For U series USB sensors, always specify "ASENSOR"

For RECeiver, choose from:

  • Any VNA receiver to acquire readings using physical or logical receiver notation.

  • Any configured PMAR device name. Learn more about PMAR Devices. See PMAR commands.

[src]

Optional argument. String. (NOT case sensitive). Source port. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

[sync]

If this argument is specified, must also specify [src].

Choose from:

  • SYNChronous - Blocks SCPI commands during standard measurement (default behavior).

  • ASYNchronous - Does NOT block SCPI commands during standard measurement.

Learn more about this argument

Examples

SOUR:POW:CORR:COLL PMET,"ASENSOR","Port 1",ASYN 'acquires power meter readings using the A sensor, source port 1, asynchronous.
source1:power2:correction:collect:acquire receiver,"a1" 'acquires source cal readings using the reference receiver for port 1.

Query Syntax

Not Applicable

Default

Not Applicable

SOURce<ch>:POWer<port>:CORRection:COLLect:AVERage[:COUNt] <num>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SOUR:POW:CORR:COLL:AVER:NTOLerance, allows for settling of the power sensor READINGS.

Sets the maximum number of acquisitions that will be used to acquire one settled reading from the power meter. These settings affect every use of the power meter (PMAR and source power cal).

When this average meets the Average:NTOLerance value or this number of readings has been made, the average is returned as the valid reading.

This setting is not necessary when using a VNA receiver (SOUR:POW:CORR:COLL REC) to make the measurement.

Learn more.

Parameters

<ch>

If provided, this argument is ignored by the VNA.

<port>

If provided, this argument is ignored by the VNA.

<num>

Maximum number of readings to make to allow for settling. Choose any number between 3 and 1000.

Examples

SOUR:POW:CORR:COLL:AVER 2
source:power:correction:collect:average:count 3

Query Syntax

SOURce:POWer:CORRection:COLLect:AVERage[:COUNt]?

Return Type

Numeric

Default

3

SOURce<ch>:POWer<port>:CORRection:COLLect:AVERage:NTOLerance <num>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SOUR:POW:CORR:COLL:AVER:COUNT, allows for settling of the power sensor READINGS.

Each power reading is averaged with the previous readings at each stimulus point. When the average meets this nominal tolerance value or the max number of readings has been made, the average is returned as the valid reading.

This setting is not necessary when using a VNA receiver (SOUR:POW:CORR:COLL REC) to make the measurement.

Learn more.

Parameters

<ch>

If provided, this argument is ignored by the VNA.

<port>

If provided, this argument is ignored by the VNA.

<num>

Power measurement settling tolerance value in dB. Choose any number between 0 and 5.

Examples

SOUR:POW:CORR:COLL:AVER:NTOL .05
source1:power2:correction:collect:average:ntolerance .003

Query Syntax

SOURce:POWer:CORRection:COLLect:AVERage:NTOLerance?

Return Type

Numeric

Default

.050 dBm

SOURce<ch>:POWer<port>:CORRection:COLLect:DISPlay[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables the display of power readings on the VNA screen. Send this command BEFORE you begin a source power cal acquisition. After the source power cal data is acquired, this setting is reset to ON.
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
<ON|OFF> | ON (1) Source power calibration dialog box is shown on the VNA screen. Power readings are plotted against the Tolerance value as limit lines. OFF (0) - Source power calibration dialog box is NOT shown on the VNA screen.
Examples | SOUR:POW:CORR:COLL:DISP ON source1:power2:correction:collect:display:state off
Query Syntax | SOURce:POWer:CORRection:COLLect:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | ON (1)

SOURce<ch>:POWer<port>:CORRection:COLLect:FCHeck[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables frequency checking of source power cal acquisition sweeps. ONLY use when you have more than one power sensor.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

If provided, this argument is ignored by the VNA.

<ON|OFF>

ON (1) turns source power cal frequency checking ON. A requested acquisition will only succeed for those frequency points which fall within a frequency range specified for the power sensor being used. An acquisition will pause in mid-sweep if the frequency is about to exceed the maximum frequency limit specified for that sensor. When the sweep is paused in this manner, a sensor connected to the other channel input of the power meter can be connected to the measurement port in place of the previous sensor, and used to complete the sweep. However, the maximum frequency specified for the second sensor would need to be sufficient for the sweep to complete. Frequency limits are specified using the SOUR:POW:CORR:COLL:SEN command.

OFF (0) - turns source power cal frequency checking OFF. An acquisition will use just one power sensor for the entire sweep, regardless of frequency.

Examples

SOUR:POW:CORR:COLL:FCH ON
source1:power2:correction:collect:fcheck:state off

Query Syntax

SOURce:POWer:CORRection:COLLect:FCHeck[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Default

OFF (0)

SOURce<ch>:POWer<port>:CORRection:COLLect:ITERation[:COUNt] <num>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SOUR:POW:CORR:COLL:ITER:NTOL describes the number of adjustments to set the power to a desired level.

These settings determine how many attempts (COUNt) the analyzer will make in an attempt to get close enough (NTOLerance) to the target power level.

Learn more.

Parameters

<ch>

If provided, this argument is ignored by the VNA.

<port>

If provided, this argument is ignored by the VNA.

<num>

Maximum number of readings. Choose any number between 1 and 1000.

Examples

SOUR:POW:CORR:COLL:ITER 2
source:power:correction:collect:iteration 3

Query Syntax

SOURce:POWer:CORRection:COLLect:ITERation[:COUNt]?

Return Type

Numeric

Default

1

SOURce<ch>:POWer<port>:CORRection:COLLect:ITERation:NTOLerance <num>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SOUR:POW:CORR:COLL:ITER:COUNT describes the number of adjustments to make to the source power.

These settings determine how many attempts (COUNt) the analyzer will make in an attempt to get close enough (NTOLerance) to the target power level.

Learn more.

Parameters

<ch>

If provided, this argument is ignored by the VNA.

<port>

If provided, this argument is ignored by the VNA.

<num>

Tolerance value in dBm. Choose any number between 0 and 5

Examples

SOUR:POW:CORR:COLL:ITER:NTOL .005
source:power:correction:collect:iteration:ntolerance .1

Query Syntax

SOURce:POWer:CORRection:COLLect:ITERation:NTOLerance?

Return Type

Numeric

Default

.05

SOURce<ch>:POWer<port>:CORRection:COLLect:<pmChan>SENsor[:FRANge] <num1>,<num2>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the frequency range over which the power sensors connected to the specified channels (A and B) of the power meter can be used (minimum frequency, maximum frequency). If the power meter has only a single channel, that channel is considered channel A.
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
<pmChan> | Power Meter channel. Choose from: A - Channel A B - Channel B
<num1> | Minimum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
<num2> | Maximum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
Examples | SOUR:POW:CORR:COLL:ASEN 100E3, 3E9 source1:power2:correction:collect:bsensor:frange 10 MHz, 18 GHz
Query Syntax | SOURce:POWer:CORRection:COLLect:ASENsor[:FRANge]? SOURce:POWer:CORRection:COLLect:BSENsor[:FRANge]?
Return Type | Numeric
Default | 0,0

SOURce<ch>:POWer<port>:CORRection:COLLect:<pmChan>SENsor:RCFactor <num>

Applicable Models: E5080A, M9485A

(Read-Write) ) Specifies the reference cal factor for the power sensor connected to channel A or B of the power meter. If the power meter has only a single channel, that channel is considered channel A.

Note: If the sensor connected to the specified channel of the power meter contains cal factors in EPROM (such as the Keysight E-series power sensors), those will be the cal factors used during the calibration sweep. The reference cal factor value associated with this command, and any cal factors entered into the VNA for that sensor channel, will not be used.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

If provided, this argument is ignored by the VNA.

<pmChan>

Power Meter channel. Choose from:

A - Channel A

B - Channel B

<num>

Reference cal factor in percent. Choose any number between 1 and 150.

Examples

SOUR:POW:CORR:COLL:ASEN:RCF 98.7
source1:power2:correction:collect:bsensor:rcfactor 105

Query Syntax

SOURce:POWer:CORRection:COLLect:ASENsor:RCFactor?

SOURce:POWer:CORRection:COLLect:BSENsor:RCFactor?

Return Type

Numeric

Default

100

SOURce<ch>:POWer<port>:CORRection:COLLect:<pmChan>SENsor:SELect

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the power sensor channel (A or B) to be used. This performs the same function as the Use this sensor only checkbox in the Power Sensor Settings dialog.

Notes:

  • This command is NOT necessary when performing a Guided Power Cal using Multiple Sensors.

  • This command can be used with Application channels.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

If provided, this argument is ignored by the VNA.

<pmChan>

Power Meter channel. Choose from:

A - Channel A

B - Channel B

Examples

SOUR:POW:CORR:COLL:<pmChan>SEN:SEL 'Write

source1:power2:correction:collect:bsensor:select? 1e9 'Read

Query Syntax

SOURce:POWer:CORRection:COLLect:ASENsor:SELect? <Frequency>

SOURce:POWer:CORRection:COLLect:BSENsor:SELect? <Frequency>

Returns a boolean 1 or 0 (ON or OFF) indicating whether the sensor is to be used at the specified frequency.

If frequency checking is OFF, then the <Frequency> parameter is ignored. The query returns if the sensor is selected for ALL frequencies.

Return Type

Numeric

Default

Not Applicable

SOURce<ch>:POWer<port>:CORRection:COLLect:TABLe:DATA <data>

Applicable Models: E5080A, M9485A

(Read-Write) Read or write data into the selected table. Use SOUR:POW:CORR:COLL:TABL:SELect to select a table.

  • When the power sensor table is selected, the data is interpreted as cal factors in percent.

  • When the loss table is selected, POSITIVE values in dB are interpreted as LOSS. To compensate for gain, use negative values.

  • Each table can contain up to 9999 segments. Values can be loaded using the Characterize Adapter macro.

  • Learn more about Power Loss Compensation.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

If provided, this argument is ignored by the VNA.

<data>

Data to write into the selected table.

Examples

SOURce:POWer:CORRection:COLLect:TABLe:DATA 0.12, 0.34, 0.56

Query Syntax

SOURce<ch>:POWer:CORRection:COLLect:TABLe:DATA?

If the selected table is currently empty, no data is returned.

Return Type

Numeric - one number per table segment.

Default

Not Applicable

SOURce<ch>:POWer<port>:CORRection:COLLect:TABLe:FREQuency <data>

Applicable Models: E5080A, M9485A

(Read-Write) Read or write frequency values for the selected table (cal factor table for a power sensor, or the loss compensation table). Use SOUR:POW:CORR:COLL:TABL:SELect to select a table.
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
<data> | Frequency data to write into the selected table.
Examples | SOURce:POWer:CORRection:COLLect:TABLe:FREQuency 10E6, 1.5E9, 9E9
Query Syntax | SOURce<ch>:POWer:CORRection:COLLect:TABLe:FREQuency? If the selected table is currently empty, no data is returned.
Return Type | Numeric - one number per table segment
Default | Not Applicable

SOURce<ch>:POWer<port>:CORRection:COLLect:TABLe:LOSS[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Indicates whether or not to adjust the power readings using the values in the loss table during a source power cal sweep. Learn more about Power Loss Compensation.
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
<bool> | ON (or 1) - turns use of the loss table ON. OFF (or 0) - turns use of the loss table OFF.
Examples | SOUR:POW:CORR:COLL:TABL:LOSS ON source1:power2:correction:collect:table:loss:state off
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe:LOSS[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Default | OFF (0)

SOURce<ch>:POWer<port>:CORRection:COLLect:TABLe:POINts?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of segments that are currently in the selected table.
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
Examples | SOUR:POW:CORR:COLL:TABL:POIN? source1:power2:correction:collect:table:points?
Return Type | Numeric
Default | 0

SOURce<ch>:POWer<port>:CORRection:COLLect:TABLe[:SELect] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Selects which table you want to write to or read from. Read or write using SOURce:POWer:CORRection:COLLect:TABLe:FREQuency and SOURce:POWer:CORRection:COLLect:TABLe:DATA
Parameters |
<ch> | Channel number of the source power cal. If unspecified, value is set to 1
<port> | If provided, this argument is ignored by the VNA.
<char> | Choose from: NONE - No table selected ASENsor - Cal Factor table for Power Sensor A BSENsor - Cal Factor table for Power Sensor B LOSS - Loss compensation table
Examples | SOUR:POW:CORR:COLL:TABL ASEN source1:power2:correction:collect:table:select bsensor
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe[:SELect]?
Return Type | Character
Default | NONE

SOURce<ch>:POWer<port>:CORRection:DATA <data>[,src]

Applicable Models: E5080A, M9485A

(Read-Write) Writes and reads source power calibration data.

The effect from this command on the channel is immediate. Do NOT send SOUR:POW:CORR:COLL:SAVE after this command as it may invalidate the uploaded data.

When querying source power calibration data, if no source power cal data exists for the specified channel and source port, then no data is returned.

If a change in the instrument state causes interpolation and/or extrapolation of the source power cal, the correction data associated with this command correspond to the new instrument state (interpolated and/or extrapolated data).

If the channel is sweeping the source backwards, then the first data point is the highest frequency value; the last data point is the lowest. Use the SENS:X:VALues? command to return the X-axis values in the displayed order.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<data>

Correction Data

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOURce1:POWer2:CORRection:DATA 0.12, -0.34, 0.56

Query Syntax

SOURce<ch>:POWer<port>:CORRection:DATA? [src]

Return Type

Depends on FORMat:DATA command

Default

Not Applicable

SOURce<ch>:POWer<port>:CORRection:DATA:PRIor <data>[,src]

Applicable Models: E5080A, M9485A

(Read-Write) Writes and reads power correction values from the previous iteration of the source power cal. Data for which the first power meter reading were within the tolerance limit, the prior correction value is 0.

In all other respects, this command is the same as SOUR:POW:CORR:DATA.

This command can be used to determine the final power reading at each point of the power cal, for a cal that did not pass tolerance limits. The formula for determining the power reading (in dB):

Power reading = Target power at the source port + specified power cal offset value + prior iteration corr value actual power corr value.

The "actual" value in this equation is returned with SOUR:POW:CORR:DATA?

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<data>

Correction Data

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOURce1:POWer2:CORRection:DATA:PRIor 0.12, -0.34, 0.56

Query Syntax

SOURce<ch>:POWer<port>:CORRection:DATA:PRIor? [src]

Return Type

Depends on FORMat:DATA command

Default

Not Applicable

SOURce<ch>:POWer<port>:CORRection:LEVel[:AMPLitude] <num>[,src]

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the power level that is expected at the desired reference plane (DUT input or output). This is not used for segment sweep with independent power levels or power sweeps.

Note: Although this command still works, it is recommended that you specify cal power by setting the test port power and offset value.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<num>

Cal power level in dBm. Because this could potentially be at the output of a device-under-test, no limits are placed on this value here. It is realistically limited by the specifications of the device (power sensor) that will be used for measuring the power. The power delivered to the VNA receiver must never exceed VNA specifications for the receiver!

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:CORR:LEV 10
source1:power2:correction:level:amplitude 0 dbm

Query Syntax

SOURce:POWer:CORRection:LEVel[:AMPLitude]? [src]

Return Type

Numeric

Default

0 dBm

SOURce<ch>:POWer<port>:CORRection:OFFSet[:MAGNitude] <num>[,src]

Applicable Models: E5080A, M9485A

(Read-Write) Sets or returns a power level offset from the VNA test port power. This can be a gain or loss value (in dB) to account for components you connect between the source and the reference plane of your measurement. For example, specify 10 dB to account for a 10 dB amplifier at the input of your DUT.

Cal power is the sum of the test port power setting and this offset value. Following the calibration, the VNA power readouts are adjusted to the cal power.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<num>

Gain or loss value in dB. Choose a value between -200 and 200

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:CORR:OFFS 10
source1:power2:correction:offset:magnitude -3

Query Syntax

SOURce:POWer:CORRection:OFFSet[:MAGNitude]? [src]

Return Type

Numeric

Default

0 dB

SOURce<ch>:POWer<port>:CORRection[:STATe] <bool>[,src]

Applicable Models: E5080A, M9485A

(Read-Write) Enables and disables source power correction for the specified port on the specified channel.

Parameters

<ch>

Channel number of the source power cal. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<bool>

ON (or 1) turns source power correction ON.

OFF (or 0) - turns source power correction OFF.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports that are not simple numbers, such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:CORR ON
source1:power2:correction:state off

Query Syntax

SOURce:POWer:CORRection[:STATe]? [src]

Return Type

Boolean (1 = ON, 0 = OFF)

Default

OFF (0)

Last Modified:

6-Jan-2016

First Release


Status SCPI

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

Note: This documentation requires familiarity with the "Standard Status Data Structure - Register Model" as defined in IEEE Std 488.2-1992. Also, first read Learn about Status Registers

STATus:

OPERation

| AVERaging

| DEVice

PRESet

QUEStionable

| INTegrity

| MEASurement

| LSUMmary

| LIMit

| BLIMit

| RLIMit

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Status Registers

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Notes:

  • Any bit not shown in the registers is not used but may be reserved for future use.

  • The SCPIStringParser can NOT be used with SCPI Status Reporting. However, the *OPC? will work.

Status Byte Register

Applicable Models: E5080A, M9485A

Summarizes the states of the other registers and monitors the VNA output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

Standard Event Status Register

Applicable Models: E5080A, M9485A

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

STATus:OPERation<keyword>

Applicable Models: E5080A, M9485A

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |
10 | 1024 | Device summary | either enabled bit in the Device summary event register is set to 1

STATus:OPERation:AVERaging<n>:<keyword>

Applicable Models: E5080A, M9485A

Monitors and summarizes the status of Averaging on traces 1 to 580. When averaging for a trace is complete, the representative bit is set to 1.

Bit 0 is used to summarize the status in the registers that follow. For example, Average Register 3, bit 0, summarizes the status from registers 4 through 42.

All enable bits are set to 1 by default.

To find the measurement number, use Calc:Par:Mnum.

<n>

Averaging Register. Choose from 1 to 42

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

 |  | Averaging Register <n> |  |  |  |  |  |  |  |  |  |  |
Bit | Weight | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | ... | 41 | 42 | Bit is set to 1 when the following conditions exist:
0 | 1 | 2-42 | 3-42 | 4-42 | 5-42 | 6-42 | 7-42 | 8-42 | 9-42 | ... | 42 | -- | Summary Bit - If any bit from that register fails, it propagates to the previous register, bit 0.
 |  | Trace Numbers |  |  |  |  |  |  |  |  |  |  |
1 | 2 | 1 | 15 | 29 | 43 | 57 | 71 | 85 | 99 | ... | 561 | 575 | Averaging on this trace is complete
2 | 4 | 2 | 16 | 30 | 44 | 58 | 72 | 86 | 100 | ... | 562 | 576 | Averaging on this trace is complete
3 | 8 | 3 | 17 | 31 | 45 | 59 | 73 | 87 | 101 | ... | 563 | 577 | Averaging on this trace is complete
4 | 16 | 4 | 18 | 32 | 46 | 60 | 74 | 88 | 102 | ... | 564 | 578 | Averaging on this trace is complete
5 | 32 | 5 | 19 | 33 | 47 | 61 | 75 | 89 | 103 | ... | 565 | 579 | Averaging on this trace is complete
6 | 64 | 6 | 20 | 34 | 48 | 62 | 76 | 90 | 104 | ... | 566 | 580 | Averaging on this trace is complete
7 | 128 | 7 | 21 | 35 | 49 | 63 | 77 | 91 | 105 | ... | 567 | -- | Averaging on this trace is complete
8 | 256 | 8 | 22 | 36 | 50 | 64 | 78 | 92 | 106 | ... | 568 | -- | Averaging on this trace is complete
9 | 512 | 9 | 23 | 37 | 51 | 65 | 79 | 93 | 107 | ... | 569 | -- | Averaging on this trace is complete
10 | 1024 | 10 | 24 | 38 | 52 | 66 | 80 | 94 | 108 | ... | 570 | -- | Averaging on this trace is complete
11 | 2048 | 11 | 25 | 39 | 53 | 67 | 81 | 95 | 109 | ... | 571 | -- | Averaging on this trace is complete
12 | 4096 | 12 | 26 | 40 | 54 | 68 | 82 | 96 | 110 | ... | 572 | -- | Averaging on this trace is complete
13 | 8192 | 13 | 27 | 41 | 55 | 69 | 83 | 97 | 111 | ... | 573 | -- | Averaging on this trace is complete
14 | 16384 | 14 | 28 | 42 | 56 | 70 | 84 | 98 | 112 | ... | 574 | -- | Averaging on this trace is complete

To determine Register, Bit number, and Weight for trace numbers between 113 and 560 (not shown in the above table) use the following calculations.

The averaging status for trace numbers higher than 580 can NOT be tracked.

The following example calculates the Register, Bit number, and Bit Weight for trace # 400:

  • To determine Register number, use ((Trace # - 1) / 14) + 1.

  • To determine Bit Number, use the remainder +1 of the above calculation.

  • ((400-1)/14) + 1 = Register# r+1Bit

    • 399/14 = 28 r7

    • 28+1= Register 29

    • 7+1= Bit number 8

  • To determine Bit Weight: Use above table. For example: Bit 8 = 256

STATus:OPERation:DEVice<keyword>

Applicable Models: E5080A, M9485A

Summarizes conditions in the OPERation:DEVice event registers.

<keyword>

Example

:CONDition?

STAT:OPER:DEV:COND?

:ENABle <bits>

STAT:OPER:DEV:ENAB 16

[:EVENt]?

STAT:OPER:DEV?

:NTRansition <bits>

STAT:OPER:DEV:NTR 16

:PTRansition <bits>

STAT:OPER:DEV:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Unused |
1 | 2 | Unused |
2 | 4 | Unused |
3 | 8 | Unused |
4 | 16 | Sweep Completed | When sweep is complete
5 | 32 | Unused |
6 | 64 | Unused |
7 | 128 | Unused |
8 | 256 | Unused |
9 | 512 | Unused |
10 | 1024 | Unused |
11 | 2048 | Unused |
12 | 4096 | Unused |
13 | 8192 | Unused |
14 | 16384 | Unused |

STATus:PRESet

Applicable Models: E5080A, M9485A

(Write-only) Initializes all the status registers.

Example

STAT:PRES

STATus:QUEStionable:<keyword>

Applicable Models: E5080A, M9485A

Summarizes conditions that monitor the quality of measurement data.

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

STATus:QUEStionable:INTegrity <keyword>

Applicable Models: E5080A, M9485A

Summarizes conditions in the Measurement Integrity register.

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
2 | 4 | Hardware Summary | any bit in the Hardware event register is set to 1

STATus:QUEStionable:INTegrity:MEASurement<n> <keyword>

Applicable Models: E5080A, M9485A

Note: This register can be used ONLY with standard S-parameter measurements.

Monitors the lag between changing a channel setting and when the data is ready to query.

When you change the channel state (start/stop freq, bandwidth, and so forth), then the questionable bit for that channel is set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next sweep is complete (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

<n>

Measurement register number. Choose from 1 to 3

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS1:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS2:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS3?

:NTRansition <bits>

STAT:QUES:INT:MEAS2:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS1:PTR 0

 |  | Measurement Register <n> |  |  |
Bit | Weight | 1 | 2 | 3 | Bit is set to 1 when the following conditions exist:
0 | 1 | 1 | Summary from Meas Reg 3 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
1 | 2 | 2 | 15 | 29 | a setting change on this channel has occurred and the data does not yet reflect that change.
2 | 4 | 3 | 16 | 30 | a setting change on this channel has occurred and the data does not yet reflect that change.
3 | 8 | 4 | 17 | 31 | a setting change on this channel has occurred and the data does not yet reflect that change.
4 | 16 | 5 | 18 | 32 | a setting change on this channel has occurred and the data does not yet reflect that change.
5 | 32 | 6 | 19 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
6 | 64 | 7 | 20 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
7 | 128 | 8 | 21 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
8 | 256 | 9 | 22 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
9 | 512 | 10 | 23 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
10 | 1024 | 11 | 24 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
11 | 2048 | 12 | 25 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
12 | 4096 | 13 | 26 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
13 | 8192 | 14 | 27 |  | a setting change on this channel has occurred and the data does not yet reflect that change.
14 | 16384 | Summary from Meas Reg 2 | 28 |  | a setting change on this channel has occurred and the data does not yet reflect that change.

STATus:QUEStionable:LSUMmary:<keyword>

Applicable Models: E5080A, M9485A

Summary register of limit test, ripple test and bandwidth test. bit 0: summary bit for the limit test. bit 1: summary bit for the ripple limit test. bit 2: summary bit for the bandwidth limit test.

<keyword>

Example

:CONDition?

STAT:QUES:LSUM:COND?

:ENABle <bits>

STAT:QUES:LSUM:ENAB 8

[:EVENt]?

STAT:QUES:LSUM?

:NTRansition <bits>

STAT:QUES:LSUM:NTR 8

:PTRansition <bits>

STAT:QUES:LSUM:PTR 0

STATus:QUEStionable:LSUMmary:BLIMit <n>:<keyword>

Applicable Models: E5080A, M9485A

Monitors and summarizes the status of ripple limit line failures. When a trace fails, the representative bit is set to 1.

Bit 0 is used to summarize failures in the registers that follow. Refer the STATus:QUEStionable:LSUMmary:LIMit for the trace number information.

All enable bits are set to 1 by default.

To find the measurement number, use Calc:Par:Mnum

<n>

Bandwidth Limit register. Choose from 1 to 42..

<keyword>

Example

:CONDition?

STAT:QUES:LSUM:BLIM:COND?

:ENABle <bits>

STAT:QUES:LSUM:BLIM:ENAB 1024

[:EVENt]?

STAT:QUES:LSUM:BLIM?

:NTRansition <bits>

STAT:QUES:LSUM:BLIM:NTR 1024

:PTRansition <bits>

STAT:QUES:LSUM:BLIM:PTR 0

STATus:QUEStionable:LSUMmary:LIMit<n>: <keyword>

Applicable Models: E5080A, M9485A

Monitors and summarizes the status of limit line failures. When a trace fails, the representative bit is set to 1.

Bit 0 is used to summarize failures in the registers that follow. For example, Limit Register 3, bit 0, summarizes the failures from registers 4 through 42.

All enable bits are set to 1 by default.

To find the measurement number, use Calc:Par:Mnum

<n>

Limit register. Choose from 1 to 42.

<keyword>

Example

:CONDition?

STAT:QUES:LSUM:LIM4:COND?

:ENABle <bits>

STAT:QUES:LSUM:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LSUM:LIM3?

:NTRansition <bits>

STAT:QUES:LSUM:LIM2:NTR 1024

:NTRansition?

STAT:QUES:LSUM:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LSUM:LIM5:PTR 0

:PTRansition?

STAT:QUES:LSUM:LIM1:PTR?

 |  | Limit Register <n> |  |  |  |  |  |  |  |  |  |  |
Bit | Weight | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | ... | 41 | 42 | Bit is set to 1 when the following conditions exist:
0 | 1 | 2-42 | 3-42 | 4-42 | 5-42 | 6-42 | 7-42 | 8-42 | 9-42 | ... | 42 | -- | Summary Bit - If any bit from that register fails, it propagates to the previous register, bit 0.
 |  | Trace Numbers |  |  |  |  |  |  |  |  |  |  |
1 | 2 | 1 | 15 | 29 | 43 | 57 | 71 | 85 | 99 | ... | 561 | 575 | any point on trace fails the limit test
2 | 4 | 2 | 16 | 30 | 44 | 58 | 72 | 86 | 100 | ... | 562 | 576 | any point on trace fails the limit test
3 | 8 | 3 | 17 | 31 | 45 | 59 | 73 | 87 | 101 | ... | 563 | 577 | any point on trace fails the limit test
4 | 16 | 4 | 18 | 32 | 46 | 60 | 74 | 88 | 102 | ... | 564 | 578 | any point on trace fails the limit test
5 | 32 | 5 | 19 | 33 | 47 | 61 | 75 | 89 | 103 | ... | 565 | 579 | any point on trace fails the limit test
6 | 64 | 6 | 20 | 34 | 48 | 62 | 76 | 90 | 104 | ... | 566 | 580 | any point on trace fails the limit test
7 | 128 | 7 | 21 | 35 | 49 | 63 | 77 | 91 | 105 | ... | 567 | -- | any point on trace fails the limit test
8 | 256 | 8 | 22 | 36 | 50 | 64 | 78 | 92 | 106 | ... | 568 | -- | any point on trace fails the limit test
9 | 512 | 9 | 23 | 37 | 51 | 65 | 79 | 93 | 107 | ... | 569 | -- | any point on trace fails the limit test
10 | 1024 | 10 | 24 | 38 | 52 | 66 | 80 | 94 | 108 | ... | 570 | -- | any point on trace fails the limit test
11 | 2048 | 11 | 25 | 39 | 53 | 67 | 81 | 95 | 109 | ... | 571 | -- | any point on trace fails the limit test
12 | 4096 | 12 | 26 | 40 | 54 | 68 | 82 | 96 | 110 | ... | 572 | -- | any point on trace fails the limit test
13 | 8192 | 13 | 27 | 41 | 55 | 69 | 83 | 97 | 111 | ... | 573 | -- | any point on trace fails the limit test
14 | 16384 | 14 | 28 | 42 | 56 | 70 | 84 | 98 | 112 | ... | 574 | -- | any point on trace fails the limit test

To determine Register, Bit number, and Weight for trace numbers between 113 and 560 (not shown in the above table) use the following calculations.

The limit status for trace numbers higher than 580 can NOT be tracked.

The following example calculates the Register, Bit number, and Bit Weight for trace # 400:

  • To determine Limit Register number, use ((Trace # - 1) / 14) + 1.

  • To determine Limit Bit Number, use the remainder +1 of the above calculation.

  • ((400-1)/14) + 1 = Register# r+1Bit

    • 399/14 = 28 r7

    • 28+1= Register 29

    • 7+1= Bit number 8

  • To determine Limit Bit Weight: Use above table. For example: Bit 8 = 256

STATus:QUEStionable:LSUMmary:RLIMit <cnum>:<keyword>

Applicable Models: E5080A, M9485A

Monitors and summarizes the status of ripple limit line failures. When a trace fails, the representative bit is set to 1.

Bit 0 is used to summarize failures in the registers that follow. Refer the STATus:QUEStionable:LSUMmary:LIMit for the trace number information.

All enable bits are set to 1 by default.

To find the measurement number, use Calc:Par:Mnum

<n>

Ripple limit channel status register. Choose from 1 to 42.

<keyword>

Example

:CONDition?

STAT:QUES:LSUM:RLIM:COND?

:ENABle <bits>

STAT:QUES:LSUM:RLIM:ENAB 1024

[:EVENt]?

STAT:QUES:LSUM:RLIM?

:NTRansition <bits>

STAT:QUES:LSUM:RLIM:NTR 1024

:PTRansition <bits>

STAT:QUES:LSUM:RLIM:PTR 0

Last modified:

6-Jan-2016

First Release


System SCPI

System Commands

Controls and queries settings that affect the VNA system.

SYSTem:

ABORt:THReshold

ACTive

| CHANnel

| MEASurement

| SHEet?

BEEPer:VOLume

BEEP:STATe

CAL:ALL More commands

CHANnels

| CATalog?

| COUPle[:STATe]

| COUPle:GROup

| COUPle:PARallel[:ENABle]

| COUPle:PARallel:STATe

| DELete

| HOLD

| RESume

CLOCk[:STATe]

COMMunicate More commands

CONFigure

| DIRectory

CONFiguration:EDEVice More commands

CORRection

| INTerpolate:LINear More commands

| WIZard[:IMMediate]

ERRor?

| COUNt?

| REPort

| SUNLeveled

FCORrection:CHANnel:COUPler[:STATe]

FPReset

ISPControl[:STATe]

MACRO:COPY

| CHANnel[:TO]

| CHANnel:STATe

| SOURce

MCLass

| CATalog?

| PARameter:CATalog?

MEASurement

| CATalog?

| NAME?

| TRACe?

| WINDow?

POFF

POWer:

| LIMit

| LOCK

| STATe

PREFerences More commands

PRESet

SECurity

| [LEVel]

SET

SHEet:CATalog?

SHORtcut

| ARGuments

| DELete

| EXECute

| PATH

| TITLe

TOUChscreen[:STATe]

UPReset

| FPANel[:STATe]

| LOAD[:FILE]

| SAVE[:STATe]

WINDows

| CATalog?

Click on a Red keyword to view the command details.

See Also

  • Referring to Traces Channels Windows and Meas Using SCPI

  • Learn about VNA Preferences

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:ABORt:THReshold <value>

Applicable Models: E5080A, M9485A

(Read-Write) When a VNA setting is made while a sweep is in progress, the sweep is immediately aborted by default. This command allows you to change that behavior by specifying a time threshold. When a setting change is made during a sweep and if the total sweep time is less than the threshold time, then the sweep is allowed to finish instead of immediately aborting.

In general, VNA setting changes that could cause an aborted sweep are changes that affect how a measurement is made, such as changes in stimulus conditions.

For example, with a threshold setting of 60 seconds:

  • Sweeps that require 60 seconds or less from start to finish will be allowed to complete if a VNA setting change is made at any time during the sweep.

  • Sweeps that require MORE than 60 seconds from start to finish will be immediately aborted when a VNA setting change is made at any time during the sweep.

Notes:

  • Preset clears this setting.

  • Save state saves this setting.

  • Sweep times are estimated.

  • This setting affects ALL channels.

Parameters

<value>

Threshold time in seconds. Set to 0 to immediately abort a sweep when a VNA setting is made.

Examples

SYST:ABOR:THR 10

'When a setting is made during a sweep, if that sweep requires less than 10 seconds more to complete, it will be allowed to finish instead of aborting.

Query Syntax

SYSTem:ABORt:THReshold?

Default

0 - No threshold time; all sweeps are immediately aborted.

SYSTem:ACTive:CHANnel?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of the active channel. The active channel is the channel number that contains the active measurement. The active measurement is the trace that has a highlighted Tr# in the Trace Status area. If there is no active channel, 0 is returned.
Examples | SYST:PRES SYST:ACT:CHAN? 'Returns 1
Return Type | Integer
Default | Not Applicable

SYSTem:ACTive:MEASurement?

Applicable Models: E5080A, M9485A

(Read-only) Returns the name of the active measurement. While looking at the VNA display, the active measurement is the trace that has a highlighted Tr# in the Trace Status area. Only displayed measurements can be active. If there is no active measurement, " " (empty string) is returned.
Examples | SYST:PRES SYST:ACT:MEAS? 'Returns "CH1_S11_1"
Return Type | String
Default | Not Applicable

SYSTem:ACTive:SHEet?

Applicable Models: E5080A

(Read-only) Returns the active sheet number.
Examples | SYST:ACT:SHE? 'Returns "1"
Return Type | String
Default | 1

SYSTem:BEEPer:VOLume <num>

Applicable Models: M9485A

(Read-Write) Sets and reads the volume of the internal speaker.
Parameters |
<num> | Relative volume of the internal speaker. Choose a volume between 0 (off) and 100.
Examples | SYST:BEEP:VOL 5 system:beeper:volume
Query Syntax | SYSTem:BEEPer:VOLume?
Default | 0

SYSTem:BEEPer:STATe <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the beeper on or off.
Parameters |
<num> | Set the beeper volume on (1) or off (0).
Examples | SYST:BEEP:STAT 1
Query Syntax | SYSTem:BEEPer:STAT?
Default | 0

SYSTem:CHANnels:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the channel numbers currently in use.
Examples | SYST:CHAN:CAT? system:channels:catalog? 'Returns: "1,2,3"
Return Type | String of comma-separated numbers
Default | Not Applicable

SYSTem:CHANnels:COUPle[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the state of channel coupling.

When set to ON, all existing S-parameter channels receive the stimulus settings of the active channel. Subsequent changes made to any coupled channel are changed on all coupled channels.

Channels with applications such as SMC are not affected.

Coupling is primarily aimed at stimulus settings (such as start, stop, points, power) but also applies to many trigger settings and to Cal Set pointers.

Parameters

<bool>

ON (or 1) Channels are coupled

OFF (or 0) Channels are NOT coupled

Examples

SYST:CHAN:COUP 1

system:channels:couple:state OFF

Query Syntax

SYSTem:CHANnels:COUPle[:STATe]?

Default

OFF

SYSTem:CHANnels:COUPle:GROup <array>

Applicable Models: M9485A

(Read-Write) Sets and reads the group of channel for the mult-DUT parallel measurement.
Parameters |
<array> | {<number of group>, <start channel No.>, <end channel No.>, ... } The first item means number or groups. Next pairs show start/end channel numbers of the group. 1 pair for 1 group. Example: {0} Global coupling (default setting) {1, 1,4} Couples channel 1-4 {2, 1,3, 5,7} Couples channel 1-3 and 5-7 independently
Examples | SYST:CHAN:COUP:GRO 2,1,3,5,7 system:channels:couple:group 1,1,4
Query Syntax | SYSTem:CHANnels:COUPle:GROup?
Default | 0

SYSTem:CHANnels:COUPle:PARallel[:ENABle] <bool>

Applicable Models: M9485A

(Read-Write) Sets and reads the Multi DUT parallel measurement state. SYST:CHAN:COUP should be also turned on when Multi DUT parallel measurement is performed.
Parameters |
<bool> | ON (or 1) Multi DUT parallel measurement are enabled OFF (or 0) Multi DUT parallel measurement are NOT enabled
Examples | SYST:CHAN:COUP:PAR 1 system:channels:couple:parallel OFF
Query Syntax | SYSTem:CHANnels:COUPle:PARallel[:ENABle]?
Default | OFF

SYSTem:CHANnels:COUPle:PARallel:STATe? <value>

Applicable Models: M9485A

(Read Only) Gets the information if the parallel measurement is executed in the last sweep, for the targeted channel..
Parameters |
<value> | Channel number
Examples | SYST:CHAN:COUP:PAR:STAT? 1 system:channels:couple:parallel:state? 2
Query Syntax | SYSTem:CHANnels:COUPle:PARallel:STATe?
Default | Not Applicable

SYSTem:CHANnels:DELete <value>

Applicable Models: E5080A, M9485A

(Write-only) Deletes the specified channel.
Parameters |
<value> | Channel number to delete
Examples | SYST:CHAN:DEL 2
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CHANnels:HOLD

Applicable Models: E5080A, M9485A

(Write-only) Places all channels in hold mode. To place a single channel in hold mode, use SENS:SWE:MODE.
Examples | SYST:CHAN:HOLD
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CHANnels:RESume

Applicable Models: E5080A, M9485A

(Write-only) Resumes the trigger mode of all channels that was in effect before sending SYSTem:CHANnels:HOLD (must be sent before SYST:CHAN:RESume).
Examples | SYST:CHAN:RES
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CLOCk[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the clock visibility state in the VNA status bar.
Parameters |
<bool> | ON (or 1) Clock is visible in the VNA status bar. OFF (or 0) Clock is NOT visible in the VNA status bar.
Examples | SYST:CLOC 1 system:clock:state OFF
Query Syntax | SYSTem:CLOCk[:STATe]?
Default | ON

SYSTem:CONFigure:DIRectory? <char>

Applicable Models: E5080A, M9485A

(Read-only) Returns the directory path location for the specified file type.

Parameters

None

<char>

Type of file. Choose from:

STATe - This is the location for the storage of state files

  • This returns: "c:\users\public\documents\network analyzer"

APPLication - This is the location of the VNA firmware executable files

  • This returns: "c:\program files (x86)\Keysight\network analyzer"

SUPPort - This is the location of private support files for the VNA firmware

  • This returns: "c:\programdata\Keysight\network analyzer"

Example

SYST:CONF:DIR? SUPP

Return Type

String

Default

Not applicable

SYSTem:CORRection:WIZard[:IMMediate] <char>

Applicable Models: E5080A, M9485A

(Write-only) Launches either the Calibration Wizard or the Version 2 Calibration Kit File Manager dialog box.

Remote operation returns immediately after the dialog is launched. This is done to avoid timeout issues with I/O protocols such as VISA. Although it is possible to send commands to the VNA while the dialog is open, this is not encouraged. Application programs should wait until the dialog is closed before resuming remote operations.

Parameters

<char>

Choose from:

MAIN - Launches the Calibration Wizard which matches the current channel, such as standard S-params, NoiseFigure, GCA, and so forth.

CKIT - Launches the Version 2 Calibration Kit File Manager dialog box.

Both display on the VNA screen.

Examples

SYST:CORR:WIZ MAIN
system:correction:wizard:immediate ckit

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:ERRor?

Applicable Models: E5080A, M9485A

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

See list of all SCPI Errors.

Examples

SYST:ERR?
system:error?

Default

Not Applicable

SYSTem:ERRor:COUNt?

Applicable Models: E5080A, M9485A

(Read-only) Returns the number of errors in the error queue. Use SYST:ERR? to read an error. See list of all SCPI Errors.
Examples | SYST:ERR:COUN? system:error:count?
Default | Not Applicable

SYSTem:ERRor:REPort:SUNLeveled <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether or not to report Source Unleveled errors to the SCPI system error buffer. This setting will revert to the default (OFF) setting on Instrument Preset.
Parameters |
<bool> | ON (or 1) Report Source Unleveled Errors. Read errors from the system error buffer using SYST:ERR? OFF (or 0) Do NOT report Source Unleveled Errors.
Examples | SYST:ERR:REP:SUNL 1 system:error:report:sunleveled ON
Query Syntax | SYSTem:ERRor:REPort:UNLeveled?
Default | OFF

SYSTem:FCORrection:CHANnel<cnum>:COUPler[:STATe] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the coupler state. This command is not effective for SMC class. Learn more about security level.
Parameters |
<char> | Choose from: OFF AUTO
Examples | SYST:FCOR:CHAN:COUP AUTO system:fcorrection:channel1:coupler OFF
Query Syntax | SYSTem:FCORrection:CHANnel<cnum>:COUPler[:STATe]?
Return Type | Character
Default | AUTO

SYSTem:FPReset

Applicable Models: E5080A, M9485A

(Write-only) Performs a standard Preset, then deletes the default trace, measurement, and window. The VNA screen becomes blank.
Examples | SYST:FPR system:fpreset
Default | Not applicable

SYSTem:ISPContol[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads turns ON/OFF or returns the status of the Initial Source Port Control feature (to switch the stimulus output in the trigger hold state to a test port).

Variable

Parameters

<bool>

ON (or 1) Source is outputted only when measurement is done .Source is not outputted during hold state.

OFF (or 0) Source is always outputted.

Examples

SYST:ISPC 1

system:ispcontrol OFF

Query Syntax

SYSTem:ISPControl[:STATe]?

Default

ON

SYSTem:MACRo:COPY:CHANnel<cnum>[:TO] <num>

Applicable Models: E5080A, M9485A

(Write-only) Copies ALL settings from <cnum> channel to <num> channel. Learn more about copy channels. Use SENS:PATH:CONF:COPY to copy ONLY mechanical switch and attenuator settings.
Parameters |
<cnum> | Channel number to copy settings from. If unspecified, value is set to 1.
<num> | Channel number to copy settings to.
Examples | SYST:MACR:COPY:CHAN1 2 system:macro:copy:channel2:to 3
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:MACRo:COPY:CHANnel<fromChannel>:STATe <toChannel>,<toWindow>,[<copyScope>]

Applicable Models: E5080A, M9485A

(Write-only) Copies settings only, or settings and measurements, traces, markers, and limit lines from an existing channel, <fromChannel>, to a new channel, <toChannel>. Traces can be copied into the Active Window, a user specified window, or a new (next available) window. .

Parameters

<fromChannel>

Channel number to copy settings from. If unspecified, value is 1.

<toChannel>

0 for next available channel, or N for channel number to copy settings to.

<toWindow>

-1 will create a new window, 0 will use the active window, and N will use the specified window N. <toWindow> is ignored when <copyScope> is "stimulus"

<copyScope>

must be "stimulus" which copies only settings, or "state" which copies settings, measurements, traces, markers, and limit lines.

Examples

SYST:MACR:COPY:CHAN1:STAT 2,0,"stimulus"

Copies only settings from channel #1 to channel #2. This is equivalent to SYST:MACR:COPY:CHAN1 2

SYST:MACR:COPY:CHAN1:STAT 2,-1,"state"

Copies settings, measurements, traces, etc. from channel #1 to channel #2. Traces are placed into a new window (next available window), and additional windows will be created as necessary so that all traces are copied.

SYST:MACR:COPY:CHAN1:STAT 0,-1

Copies settings, measurements, etc. from channel #1 to the next available channel and places traces into the next avaialble new window.

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:MACRo:COPY:CHANnel<fromChan>:SOURce <fromPort>,<toChan>,<toPort>

Applicable Models: E5080A, M9485A

(Write-only) Copies and applies an existing Source Power Calibration to another channel. Learn more about source power calibration.
Parameters |
<fromChan> | Channel number of the existing source power correction.
<fromPort> | Port number of the existing source power correction.
<toChan> | Channel number to which the source power correction will be copied.
<toPort> | Port number to which the source power correction will be applied.
Examples | SYST:MACR:COPY:CHAN1:SOUR 1,2,1 system:macro:copy:channel2:source 2,1,2
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:MCLass:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns measurement classes available on the VNA. Learn more about Measurement Classes.
Parameters | None
Examples | SYST:MCLass:CAT?
Return Type | String of comma-separated measurement class names. See the complete list of measurement class names.
Default | Not Applicable

SYSTem:MCLass:PARameter:CATalog? <name>

Applicable Models: E5080A, M9485A

(Read-only) Returns ALL parameters that are supported by the specified measurement class.
Parameters |
<name> | String. Measurement Class name. See the complete list of measurement class names.
Examples | 'Returns all parameters for Gain Compression. SYST:MCL:PAR:CAT? "Gain Compression" Return: "S11,S12,S13,S14,S21,S22,S23,S24,S31,S32,S33,S34,S41,S42,S43,S44,A,B,C,D,R,R1,R2,R3,R4"
Return Type | String of comma-separated parameters
Default | Not Applicable

SYSTem:MEASurement:CATalog? [chan]

Applicable Models: E5080A, M9485A

(Read-only) Returns ALL measurement numbers, or measurement numbers from a specified channel.
Parameters |
[chan] | Optional. Channel number to catalog. If not specified, all measurement numbers are returned.
Examples | 'Returns all measurement numbers SYST:MEAS:CAT? 'Returns the measurement numbers on channel 2 system:measurement:catalog? 2
Return Type | String of comma-separated numbers For example: "1,2"
Default | Not Applicable

SYSTem:MEASurement<n>:NAME?

Applicable Models: E5080A, M9485A

(Read-only) Returns the name of the specified measurement.
Parameters |
<n> | Measurement number for which to return the measurement name. If unspecified, value is set to 1.
Examples | 'Returns the name of measurement 2 SYST:MEAS2:NAME?
Return Type | String
Default | Not Applicable

SYSTem:MEASurement<n>:TRACe?

Applicable Models: E5080A, M9485A

(Read-only) Returns the trace number of the specified measurement number. Trace numbers restart for each window while measurement numbers are always unique.
Parameters |
<n> | Measurement number for which to return the trace number. If unspecified, value is set to 1.
Examples | 'Returns the trace number of measurement 1 SYST:MEAS1:TRAC?
Return Type | Numeric
Default | Not Applicable

SYSTem:MEASurement<n>:WINDow?

Applicable Models: E5080A, M9485A

(Read-only) Returns the window number of the specified measurement number.
Parameters |
<n> | Measurement number for which to return the window number. If unspecified, value is set to 1.
Examples | 'Returns the window number of measurement 2 SYST:MEAS2:WIND?
Return Type | Numeric
Default | Not Applicable

SYSTem:POFF

Applicable Models: E5080A, M9485A

(Write-only) Shuts down the system.
Parameters |
<n> | Shutdown or restart. Choose from: 1 - Restart. 0 - Shutdown .
Examples | 'Shuts down the system SYST:POFF
Default | 0 (Shutdown)

SYSTem:POWer<pnum>:LIMit <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the power limit for the specified port. Learn more about Power Limit.
Parameters |
<pnum> | Port number. Choose any VNA port.
<value> | Power limit in dBm
Examples | SYST:POW1:LIM 5 system:power2:limit 0
Query Syntax | SYSTem:POWer<pnum>:LIMit?
Return Type | Numeric
Default | 100 dBm

SYSTem:POWer:LIMit:LOCK <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables or disables the ability to change the power limit values through the user interface. Learn more about Power Limit.
Parameters |
<bool> | Power limit lock. Choose from: ON or 1 - Enables the ability to change the power limit values from the user interface. OFF or 0 - Disables the ability to change the power limit values from the user interface.
Examples | SYST:POW:LIM:LOCK 1 system:power:limit:lock OFF
Query Syntax | SYSTem:POWer:LIMit:LOCK?
Return Type | Boolean
Default | OFF

SYSTem:POWer<pnum>:LIMit:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Enables or disables the power limit for the specified port. Learn more about Power Limit.
Parameters |
<pnum> | Port number. Choose any VNA port.
<value> | Power limit state. Choose from: ON or 1 Enables the power limit for the port<pnum>. OFF or 0 Disables the power limit for the port<pnum>.
Examples | SYST:POW1:LIM:STAT ON system:power2:limit:state 0
Query Syntax | SYSTem:POWer<pnum>:LIMit:STATe?
Return Type | Boolean
Default | OFF

SYSTem:PRESet

Applicable Models: E5080A, M9485A

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Preset.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the VNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

If the VNA display is disabled with DISP:ENAB OFF then SYST:PRES will NOT enable the display.

This command performs the same function as *RST with one exception: Syst:Preset does NOT reset Calc:FORMAT to ASCII as does *RST.

Examples

SYST:PRES
system:preset

Default

Not applicable

SYSTem:SECurity[:LEVel] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the display of frequency information on the VNA screen and printouts.

Learn more about security level.

Parameters

<char>

Choose from:

NONE - ALL frequency information is displayed.

LOW - NO frequency information is displayed. Frequency information can be redisplayed using the Security Setting dialog box or this command.

HIGH - LOW setting plus GPIB console is disabled. Frequency information can be redisplayed ONLY by performing a Preset, recalling an instrument state with None or Low security settings, or using this command.

EXTRa - HIGH setting plus:

  • ASCII data saving is disabled. Same method to redisplay frequency information as HIGH setting.

  • Mixer setup files (*.mxr) can NOT be saved.

Examples

SYST:SEC LOW
system:security:level high

Query Syntax

SYSTem:SECurity[:LEVel]?

Return Type

Character

Default

None

SYSTem:SET <block>

Applicable Models: E5080A, M9485A

(Read-Write) Sends a definite-length binary block Instrument state and sets the VNA with those settings. This command does the same as saving a *.sta file to the VNA (MMEM:STOR STATE) and then MMEM:TRAN to transfer the file to the computer.
Parameters |
<block> | The Instrument state file as definite-length arbitrary binary block.
Examples | SYST:SET <block>
Query Syntax | SYSTem:SET? (This saves the instrument state file to the remote computer.)
Return Type | Definite-length arbitrary binary block.
Default | Not Applicable

SYSTem:SHEet:CATalog?

Applicable Models: E5080A

(Read-only) Returns comma separated list of visible sheets.
Parameters |
Examples | SYST:SHE:CAT? 'Returns: "1,2,3"
Return Type | String of comma-separated numbers
Default | 1

SYSTem:SHORtcut<n>:ARGuments<string>

Applicable Models: M9485A

(Read-Write) Reads and writes the arguments for the specified macro. On the Edit Macro Dialog, this is called the "Macro run string parameters".
Parameters |
<n> | Numeric. Number of the macro that is stored in the VNA. To find the number of a macro, either open the Macro Setup dialog and count the line number of the desired macro, or query the titles of all of the macros for the desired macro title.
<string> | Arguments for the specified macro.
Examples | SYST:SHOR1:ARG "http://na.tm.Keysight.com/pna/help/PNAWebHelp/help.htm"
Query Syntax | SYSTem:SHORtcut<n>:ARGuments?
Default | Not Applicable

SYSTem:SHORtcut<n>:DELete

Applicable Models: M9485A

(Write-only) Removes the specified macro from the list of macros in the VNA. Does not delete the macro executable file.
Parameters |
<n> | Numeric. Number of the macro that is stored in the VNA. To find the number of a macro, either open the Macro Setup dialog and count the line number of the desired macro, or query the titles of all of the macros for the desired macro title.
Examples | SYST:SHOR1:DEL
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:SHORtcut<n>:EXECute

Applicable Models: M9485A

(Write-only) Executes (runs) the specified Macro (shortcut) that is stored in the VNA.
Parameters |
<n> | Numeric. Number of the macro that is stored in the VNA. To find the number of a macro, either open the Macro Setup dialog and count the line number of the desired macro, or query the titles of all of the macros for the desired macro title.
Examples | SYST:SHOR1:EXEC
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:SHORtcut<n>:PATH <string>

Applicable Models: M9485A

(Read-Write) Defines a Macro (shortcut) by linking a path and file name to the Macro number. To be executed, the executable file must be put in the VNA at the location indicated by this command.
Parameters |
<n> | Numeric. Number of the macro to be stored in the analyzer. If the index number already exists, the existing macro is replaced with the new macro.
<string> | Full path, file name, and extension, of the existing macro "executable" file. To find the number of a macro, either open the Macro Setup dialog and count the line number of the desired macro, or query the titles of all of the macros for the desired macro title.
Examples | SYST:SHOR1:PATH "C:/Program Files/Keysight/Network Analyzer/Documents/unguideMultiple.vbs"
Query Syntax | SYSTem:SHORtcut<n>:PATH?
Default | Not Applicable

SYSTem:SHORtcut<n>:TITLe<string>

Applicable Models: M9485A

(Read-Write) Reads and writes the name of the specified macro.
Parameters |
<n> | Numeric. Number of the macro that is stored in the VNA. To find the number of a macro, either open the Macro Setup dialog and count the line number of the desired macro, or query the titles of all of the macros for the desired macro title.
<string> | The name to be assigned to the macro.
Examples | SYST:SHOR1:TITL "Guided 4-Port Cal"
Query Syntax | SYSTem:SHORtcut<n>:TITLe?
Default | Not Applicable

SYSTem:TOUChscreen[:STATe] <bool>

Applicable Models: E5080A

(Read-Write) Enables and disables the PNA-X touchscreen. This setting remains until changed again from the front-panel or remotely, or until the hard drive is changed or reformatted.
Parameters |
<bool> | Choose from: ON (1) Enables the touchscreen. OFF (0) Disables the touchscreen.
Examples | SYST:TOUC 1 system:touchscreen:state OFF
Query Syntax | SYSTem:TOUChscreen[:STATe]?
Return Type | Boolean
Default | ON when shipped from factory.

SYSTem:UPReset

Applicable Models: E5080A, M9485A

(Write-only) Performs a User Preset. There must be an active User Preset state file (see Load and Save) or an error will be returned. Learn more about User Preset.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the VNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Examples

SYST:UPReset

system:upreset

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:UPReset:FPANel[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) 'Checks' and 'clears' the enable box on the User Preset dialog box. This only affects subsequent Presets from the front panel user interface.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the VNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Parameters

<bool>

Front Panel User Preset State. Choose from:

0 User Preset OFF

1 User Preset ON

Examples

SYST:UPR:FPAN 1

system:upreset:fpanel:state 0

Query Syntax

SYSTem:UPREset:FPANel[:STATe]?

Return Type

Boolean

Default

0

SYSTem:UPReset:LOAD[:FILE] <file>

Applicable Models: E5080A, M9485A

(Write-only) Loads an existing instrument state file (.sta or .cst) to be used for User Preset. Subsequent execution of SYSTem:UPReset will cause the VNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the VNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Learn more about User Preset.

Parameters

<file>

String - Name of the file to be loaded. The default folder "C:/Program Files/Keysight/Network Analyzer/Documents" is used if unspecified. Change the default folder name using MMEMory:CDIRectory.

Examples

SYST:UPR:LOAD '1MHzto20GHzUserPreset.cst'

system:upreset:load:file 'C:/Documents and Settings/Administrator/My Documents/NewUserPreset.cst'

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:UPReset:SAVE[:STATe]

Applicable Models: E5080A, M9485A

(Write-only) Saves the current instrument settings as UserPreset.sta. Subsequent execution of SYSTem:UPReset will cause the VNA to assume this instrument state.

Regardless of the state of the User Preset Enable checkbox, the SYST:PRESet command will always preset the VNA to the factory preset settings, and SYST:UPReset will always perform a User Preset.

Learn more about User Preset.

Examples

SYST:UPR:SAVE

system:upreset:save:state

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:WINDows:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the window numbers that are currently being used.
Examples | SYST:WIND:CAT? system:windows:catalog?
Return Type | String of comma-separated numbers. For example: "1,2"
Default | Not Applicable

Last modified:

7-Jan-2015

Initial Release


SystCalAll

SYSTem:CALibrate:ALL Commands

Contains the settings to configure a "Cal All" Calibration.

Use the Guided Cal interface to perform the calibration.

SYSTem:CALibrate:ALL:

CHANnel:

| PORTs[:SELect]

CSET:

| CATalog?

| PREFix

GUIDed:

| CHANnel?

| PORTs?

IFBW

MCLass:

| PROPerty:

| NAME:CATalog?

| VALue:

| CATalog?

| [STATe]

PORT<n>:

| RECeiver:ATTen

| REFerence

| TEST

| SOURce:POWer:

| ATTen

| OFFSet

| [VALue]

RESet

SELect

Click on a blue keyword to view the command details.

See Also

  • About Calibrate All Channels

  • Example Program

  • Guided Cal commands

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:CALibrate:ALL:CHANnel<ch>:PORTs[:SELect] <value>

Applicable Models: E5080A, M9485A

(Write-Read) For each channel to be calibrated, sets and returns the ports to be calibrated. Specify port numbers ONLY for standard channels. Application channels are not necessary because they have designated input/output/LO ports.
Parameters |
<ch> | Channel number to be calibrated.
<value> | Ports to be calibrated for the specified channel. Select any of the native VNA ports (1,2,3,4).
Examples | SYST:CAL:ALL:CHAN2:PORT 1,2,3
Query Syntax | SYSTem:CALibrate:ALL:CHANnel<ch>:PORTs[:SELect]?
Return Type | Comma-separated port numbers.
Default | 1,2

SYSTem:CALibrate:ALL:CSET:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the User Cal Set or cal register names that were produced by the cal all session.
Parameters | None
Examples | SYST:CAL:ALL:CSET:CATalog? 'returns this format: "MyCalAll_STD_001, MyCalAll_SMC_002" See example program
Return Type | String of comma-separated Cal Set or cal register names
Default | Not Applicable

SYSTem:CALibrate:ALL:CSET:PREFix<value>

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the prefix to be used when saving User Cal Sets that result from the Cal All session. The Meas Class and channel number are appended to this prefix for each calibrated channel. Use SYST:CAL:ALL:CSET:CATalog? to read the saved cal set names.

  • SENS:CORR:COLL:GUID:SAVE:CSET can also be used to set the Cal Set prefix.

  • If a Cal Set prefix is NOT set using either command, the cal data for each channel will be saved only to cal registers. Learn about cal registers.

Parameters

<value>

(String) User Cal Set prefix.

Examples

SYST:CAL:ALL:CSET:PREFix "MyCalAll"

Query Syntax

SYSTem:CALibrate:ALL:CSET:PREFix?

Return Type

String

Default

" " (Empty string)

SYSTem:CALibrate:ALL:GUIDed:CHANnel?

Applicable Models: E5080A, M9485A

(Read-only) Reads the channel number of the Cal All Calibration. Use this value as the <ch> argument for the subsequent Guided:Cal commands.
Parameters | None
Examples | chan = SYST:CAL:ALL:GUID:CHAN?
Return Type | Numeric
Default | Not applicable

SYSTem:CALibrate:ALL:GUIDed:PORTs?

Applicable Models: E5080A, M9485A

(Read-only) Returns the ports to be calibrated during the Cal All Channels calibration. Specify connectors and cal kits for these ports using the Guided:Cal commands. Specify the ports to be calibrated for each channel using SYST:CAL:ALL:CHAN<ch>:PORT.
Parameters | None
Examples | ports = SYST:CAL:ALL:GUID:PORT?
Return Type | Comma-separated list of port numbers
Default | Not applicable

SYSTem:CALibrate:ALL:IFBW <value>

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the IFBW for a Cal All calibration. Learn more about this setting.
Parameters |
<value> | IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the VNA model. See the list of valid settings. If an invalid number is specified, the VNA will round up to the closest valid setting. This command supports MIN and MAX as arguments. Learn more.
Examples | SYST:CAL:ALL:IFBW 10e3
Query Syntax | SYSTem:CALibrate:ALL:IFBW?
Return Type | Numeric
Default | 1 kHz

SYSTem:CAL:ALL:MCLass:PROPerty:NAME:CATalog? [mclass]

Applicable Models: E5080A, M9485A

(Read-only) Returns the unique, settable properties for the current cal all session. See a list of valid properties and values for each measurement class.
Parameters |
[mclass] | Optional argument. String name of the measurement class for which properties are to be returned. See a list of valid measurement class Application names. The measurement class must be included in the current Cal All calibration.
Examples | SYST:CAL:ALL:MCL:PROP:NAME:CAT? 'with NFX app, returns: "Noise Cal Method,Noise Tuner,AutoOrient Tuner,Tuner In,Tuner Out,Receiver Characterization Method,ENR File,Noise Source Connector,Noise Source CalKit"
Return Type | String of comma-separated properties.
Default | Not applicable

SYSTem:CAL:ALL:MCLass:PROPerty:VALue:CATalog? <prop>

Applicable Models: E5080A, M9485A

(Read-only) Returns the valid property values for a specific property name. See a list of valid properties and values for each measurement class.
Parameters |
<prop> | (String) Property name for which valid values are to be returned.
Examples | SYST:CAL:ALL:MCL:PROP:VAL:CAT? "Noise Cal Method" 'with NFX app, returns: "Scalar,Vector"
Return Type | String of comma-separated values
Default | Not applicable

SYSTem:CALibrate:ALL:MCLass:PROPerty:VALue[:STATe] <prop>,<value>

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the property value for a specific property name. See a list of valid properties and values for each measurement class.
Parameters |
<prop> | (String) Property name for which value is to be set or returned.
<value> | Property value. To read a list of valid values, use SYST:CAL:ALL:MCL:PROP:VAL:CAT?
Examples | SYST:CAL:ALL:MCL:PROP:VAL "Noise Cal Method","Noise:Scalar" SYST:CAL:ALL:MCL:PROP:VAL? "Noise Source Connector"
Query Syntax | SYSTem:CALibrate:ALL:MCLass:PROPerty:VALue[:STATe]? <prop>
Return Type | String
Default | Varies with the property name.

SYSTem:CALibrate:ALL:PATH:CONFig:ELEMent[:STATe] <element>,<setting>

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the Path Configuration settings for a Cal All calibration. Learn more about this setting.
Parameters |
<element> | (String) Path configuration element to be set. See a list of configurable RF Path elements and settings.
<setting> | (String) Path configuration element setting.
Examples | SYST:CAL:ALL:PATH:CONFig:ELEMent "Port1NoiseTuner","Internal"
Query Syntax | SYSTem:CALibrate:ALL:PATH:CONFig:ELEMent[:STATe]? <element>
Return Type | String
Default | Not Applicable

SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen<value>[,src]

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the Receiver Attenuator setting for a Cal All calibration.

Parameters

<n>

Receiver port number.

<value>

Attenuation value in dB for a Cal All calibration. Choose a valid value for the VNA model. See valid settings.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SYST:CAL:ALL:PORT2:REC:ATT 10

Query Syntax

SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen?

Return Type

Numeric

Default

0

SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen:REFerence<num>

Applicable Models: M9485A

(Write-Read) Sets and returns the Receiver Attenuator setting for a Cal All calibration.
Parameters |
<n> | Receiver port number.
<num> | Attenuation value in dB for a Cal All calibration. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SYST:CAL:ALL:PORT2:REC:ATT:REF 0
Query Syntax | SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen:REFerence?
Return Type | Numeric
Default | 35

SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen:TEST<num>

Applicable Models: M9485A

(Write-Read) Sets and returns the Receiver Attenuator setting for a Cal All calibration.
Parameters |
<n> | Receiver port number.
<num> | Attenuation value in dB for a Cal All calibration. 0dB or 35dB. If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19dB is entered, then 0dB attenuation will be selected.
Examples | SYST:CAL:ALL:PORT2:REC:ATT:TEST 0
Query Syntax | SYSTem:CALibrate:ALL:PORT<n>:RECeiver:ATTen:TEST?
Return Type | Numeric
Default | 35

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer:ATTen<value>[,src]

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the Source Attenuator setting for the Cal All calibration.

Parameters

<n>

Source port number.

<value>

Attenuation value in dB for the Cal All calibration. Choose a valid value for the VNA model. See valid settings.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SYST:CAL:ALL:PORT2:SOUR:POW:ATT 10

Query Syntax

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer:ATTen?

Return Type

Numeric

Default

0

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer:OFFSet <value>[,src]

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the power offset value for a Cal All calibration.

Power Offset provides a method of compensating port power for added attenuation or amplification in the source path. The result is that power at the specified port reflects the added components.

Parameters

<n>

Source port number.

<value>

Power offset value in dB for a Cal All calibration.

  • For amplification, use positive offset.

  • For attenuation, use negative offset.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SYST:CAL:ALL:PORT2:SOUR:POW:OFFS 10

Query Syntax

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer:OFFSet?

Return Type

Numeric

Default

0

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer[:VALue] <value>[,src]

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the power level at which a Cal All calibration is to be performed.

Parameters

<n>

Source port number.

<value>

Power level at which the calibration is to be performed.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SYST:CAL:ALL:PORT2:SOUR:POW 0

Query Syntax

SYSTem:CALibrate:ALL:PORT<n>:SOURce:POWer[:VALue]?

Return Type

Numeric

Default

Preset power of the VNA model.

See the data sheet for the power level for each model.

SYSTem:CALibrate:ALL:RESet

Applicable Models: E5080A, M9485A

(Write-only) Resets all properties associated with the Cal All session to their default values.
Parameters | None
Examples | SYST:CAL:ALL:RES
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CALibrate:ALL:SELect <value>

Applicable Models: E5080A, M9485A

(Write-Read) Sets and returns the list of channels to be calibrated during the Cal All session.
Parameters |
<value> | Channel numbers to be calibrated. These channels must already exist.
Examples | SYST:CAL:ALL:SEL 1,2,3
Query Syntax | SYSTem:CALibrate:ALL:SELect?
Return Type | Comma-separated channel numbers.
Default | Existing channels

Last modified:

16-Mar-2015

First release


SystConfigExternalDevice

External Device Commands

Configures and makes settings for an external device.

SYST:CONF:EDEVice:

| ADD

| CAT?

| DRIVer

| DTYPe

| EXISts?

| IOConfig

| IOENable

| LOAD

| REMove

| SAVE

| STATe

| TOUT

| PMAR More commands

| PULSe More commands

| SOURce:

| DPP

| TMODe

Click on a Red keyword to view the command details.

See Also

  • Learn about: Configure an External Source

  • Learn about: Configure a PMAR Device

  • Example: Configure an External Source

  • Example: Configure a PMAR Device

  • SYST:PREF:ITEM:EDEV:DPOL - Determines whether external devices remain activated or are de-activated when the VNA is Preset or when a Instrument State is recalled.

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:CONFigure:EDEVice:ADD <name>

Applicable Models: E5080A, M9485A

(Write-only) Adds an external device to the list of configured devices. This is the same as pressing New on the Select an external device dialog.

Upon creation, all settings on the new device are set to the defaults. The device is not active until set using SYST:CONF:EDEV:STAT

Parameters

<name>

String - Model and type of the external device.

To see a list of configured external devices, use SYST:CONF:EDEV:CAT?

Examples

SYST:CONF:EDEV:ADD "myDevice"

system:configure:edevice:add "myDevice"

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:CONFigure:EDEVice:CAT?

Applicable Models: E5080A, M9485A

(Read-only) Returns a list of names of all configured devices. These are devices that appear in the external devices dialog. Use SENS:FOM:CAT? to report all active devices. Use Source:CAT? to report all active sources.
Parameters | None
Example | SYST:CONF:EDEV:CAT? system:configure:edevice:cat
Return Type | String of comma-separated devices. "Device0:Driver0, Device1:Driver1"
Default | Not applicable

SYSTem:CONFigure:EDEVice:DRIVer <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the external device driver (model).
Parameters |
<name> | String - Name of the device.
<value> | String - External device driver (model). Choose from the following: AGPM for all power meters. AGPULSEGEN for supported pulse generators. DCSource for all supported DC Sources DCMeter for all supported DC Meters See a list of supported external source drivers.
Examples | SYST:CONF:EDEV:DRIV "myDevice","AGPM" system:configure:edevice:driver "myDevice","AGESG"
Query Syntax | SYSTem:CONFigure:EDEVice:DRIVer? <name>
Return Type | String
Default | "AGGeneric"

SYSTem:CONFigure:EDEVice:DTYPE <name>,<type>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Device Type for the external device.
Parameters |
<name> | String - Name of the device to modify.
<type> | String - Device type - not case sensitive. Choose from: "Source" - external source "Power Meter" - power meter "DC Meter" - DC voltmeter "DC Source" - DC power supply "Pulse Generator" - external pulse generator
Examples | SYST:CONF:EDEV:DTYP "myDevice","Power Meter" system:configure:edevice:dtype "myDevice","Source"
Query Syntax | SYSTem:CONFigure:EDEVice:DTYPe? <name>
Return Type | String
Default | None

SYSTem:CONFigure:EDEVice:EXISts? <string>

Applicable Models: E5080A, M9485A

(Read-only) Returns whether the named device is present on the bus for which it is configured.

Parameters

<string>

Name of the external device.

Example

SYST:CONF:EDEV:EXIS? "MyPowerMeter"

Return Type

Boolean

  • 0 - The device is not in the collection or the device fails to respond and times out when communication is attempted.

  • 1 - The device responds when communication is attempted.

Default

Not applicable

SYSTem:CONFigure:EDEVice:IOConfig <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and return the configuration path for the specified external device.

Parameters

<name>

String - Name of the device.

<value>

String - Configuration path. Any valid VISA resource shown in the IO Configuration field of the external devices dialog, enclosed in quotes.

Do NOT use the ID string of a PMAR USB power sensor as the resource string. The ID string is returned by SYST:COMM:USB:PMET:CAT?

Examples

SYST:CONF:EDEV:IOC "myDevice","GPIB0::13::INSTR"

system:configure:edevice:ioconfig "myDevice","GPIB0::13::INSTR"

Query Syntax

SYSTem:CONFigure:EDEVice:IOConfig? <name>

Return Type

String

Default

" " Empty String

SYSTem:CONFigure:EDEVice:IOENable <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Enable or disable communication with an external device.

When disabled (OFF), the VNA will NOT attempt to connect to the external device regardless of the instrument state command (SYST:CONF:EDEV:STATe). Therefore, no errors will be produced if the device is not connected.

This command is useful for debugging and testing states when the external device is not connected. This command is unnecessary in ordinary operation (when the device is connected).

Parameters

<name>

String - Name of the device.

<value>

Boolean - Choose from:

OFF or 0 - Device communication disabled

ON or 1 - Device communication enabled

Examples

SYST:CONF:EDEV:IOEN "myDevice", ON

system:configure:edevice:ioenable "myDevice", 0

Query Syntax

SYSTem:CONFigure:EDEVice:IOENable? <name>

Return Type

Boolean

Default

ON

SYSTem:CONFigure:EDEVice:LOAD <file>,<name>

Applicable Models: E5080A, M9485A

(Write-only) Recalls an external device configuration file from the VNA hard drive. Currently, only DC Supply and DC Meter configuration files are supported. See more DC Device commands. Use SYST:CONF:EDEV:SAVE to save a configuration file.
Parameters |
<file> | String - Filename of the external device configuration file.
<name> | String - Name of the external device. Currently, only DC Supply and DC Meter configuration files are supported.
Examples | SYST:CONF:EDEV:LOAD "myDevice.xml","MyDCMeter"
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CONFigure:EDEVice:REMove <name>

Applicable Models: E5080A, M9485A

(Write-only) Removes the specified device from the list of configured devices. If the device is a Source and both Active and I/O Enabled is checked (ON), then the RF power state is set to OFF. Learn more.
Parameters |
<name> | String - Name of the device. Not case sensitive. Use SYST:CONF:EDEV:CAT? to return a list of configured devices.
Examples | SYST:CONF:EDEV:REM "myDevice" system:configure:edevice:remove "myDevice"
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CONFigure:EDEVice:SAVE <file>,<name>

Applicable Models: E5080A, M9485A

(Write-only) Saves an external device configuration file to the VNA hard drive. Currently, only DC Supply and DC Meter configuration files are supported. See more DC Device commands. Use SYST:CONF:EDEV:LOAD to recall a configuration file.
Parameters |
<file> | String - Filename of the external device configuration file.
<name> | String - Name of the external device. Currently, only DC Supply and DC Meter configuration files are supported.
Examples | SYST:CONF:EDEV:SAVE "myDevice.xml","MyDCSupply"
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:CONFigure:EDEVice:STATe <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the state of activation of the device. When SYST:CONF:EDEV:IOEN = ON, and this command is set to ON, the VNA will attempt communication with the external device. An error is returned if communication cannot be verified.

Send this command AFTER sending other external device settings (especially SYST:CONF:EDEV:DTYP) to avoid communicating with the device before it has been fully configured.

See Also: SYST:PREF:ITEM:EDEV:DPOL - Determines whether external devices remain activated or are de-activated when the VNA is Preset or when a Instrument State is recalled.

Parameters

<name>

String - Name of the device.

<value>

Boolean - Choose from:

OFF or 0 - Device is NOT activated

ON or 1 - Device is activated.

Examples

SYST:CONF:EDEV:STAT "myDevice", ON

system:configure:edevice:state "myDevice", 0

Query Syntax

SYSTem:CONFigure:EDEVice:STATe? <name>

Return Type

Boolean

Default

OFF - When configured using the front panel user interface, the device is ON (activated) by default.

SYSTem:CONFigure:EDEVice:TOUT <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the time out value for the specified external device. This is the time allowed for communication with the device before an error is generated.
Parameters |
<name> | String - Name of the device.
<value> | Time out value in seconds.
Examples | SYST:CONF:EDEV:TOUT "myDevice",2 system:configure:edevice:tout "myDevice",5
Query Syntax | SYSTem:CONFigure:EDEVice:TOUT? <name>
Return Type | Numeric
Default | 20

SYSTem:CONFigure:EDEVice:SOURce:DPP <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the amount of time the VNA should wait after for an external source to settle before making a measurement at each data point. This setting applies to all channels that use this external source.
Parameters |
<name> | String - Name of the device.
<value> | Dwell time in seconds.
Examples | SYST:CONF:EDEV:SOUR:DPP "myDevice",2 system:configure:edevice:source:dpp "myDevice",.1
Query Syntax | SYSTem:CONFigure:EDEVice:SOURce:DPP? <name>
Return Type | Numeric
Default | 3.114 e-3

SYSTem:CONFigure:EDEVice:SOURce:TMODe <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the trigger mode for an external source. Learn more.
Parameters |
<name> | String - Name of the device.
<value> | Trigger Mode. Choose from: CW - Software CW mode HW - Hardware list mode
Examples | SYST:CONF:EDEV:SOUR:TMOD "myDevice",CW system:configure:edevice:source:tmode "myDevice",hw
Query Syntax | SYSTem:CONFigure:EDEVice:SOURce:TMODe? "myDevice"
Return Type | Character
Default | Depends on Source and VNA Model

Last Modified:

16-Mar-2015

First Release


SystConfigExtPMAR

SYST:CONF:EDEVice:PMAR Commands

Configures and makes settings for an external Power Meter as Receiver.

SYSTem:CONFigure:EDEVice:PMAR

| CALibrate

| FLIMit

| FMAXimum

| FMINimum

| READing:

| COUNt

| NTOLerance

| SENSor

| TABLe:

| CFAC:

| DATA

| FREQuency

| LOSS:

| DATA

| FREQuency

| STATe

| RFACtor

| ZERO

Click on a blue keyword to view the command details.

See Also

  • Learn about: Configure a Power Meter As Receiver

  • See root SYST:CONF:EDEV commands

  • Learn about Configure and External Device

  • SYST:PREF:ITEM:EDEV:DPOL - Determines whether External Devices remain activated or are de-activated when the VNA is Preset or when a Instrument State is recalled.

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:CONFigure:EDEVice:PMAR:CALibrate <name>

Applicable Models: E5080A, M9485A

(Write-only) Performs a calibration of the power sensor. Calibration usually involves connecting the power sensor to the meter's 1 mW reference.

  • Keysight P-Series sensors have an internal reference so you can calibrate them using this command without connecting to the meters reference port.

  • Keysight USB power sensors do not require calibrating.

  • For other sensors, refer to the documentation to determine if it has calibration capability.

This command is always synchronous, so *OPC? is the only way to determine that the operation is complete. Set an I/O timeout of at least 20 seconds.

Parameters

<name>

String - Name of the power meter.

Examples

SYST:CONF:EDEV:PMAR:CAL "myDevice"

system:configure:edevice:pmar:calibrate "myDevice"

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:FLIMit <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Enable or disable the power meter min and max frequencies.
Parameters |
<name> | String - Name of the power meter.
<value> | Boolean. State of min and max frequency. Choose from: OFF or 0 - Min and max frequencies disabled. ON or 1 - Min and max frequencies enabled.
Examples | SYST:CONF:EDEV:PMAR:FLIM "myDevice", 0 system:configure:edevice:pmar:flimit "myDevice", ON See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:FLIMit? <name>
Return Type | Boolean
Default | OFF

SYSTem:CONFigure:EDEVice:PMAR:FMAXimum <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the maximum frequency of the power meter.
Parameters |
<name> | String - Name of the power meter.
<value> | Numeric - Max frequency in Hz.
Examples | SYST:CONF:EDEV:PMAR:FMAX "myDevice", 1e10 system:configure:edevice:pmar:fmaximum "myDevice", 3e9 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:FMAXimum? <name>
Return Type | Numeric
Default | Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:FMINimum <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the minimum frequency of the power meter.
Parameters |
<name> | String - Name of the power meter.
<value> | Numeric - Min frequency in Hz.
Examples | SYST:CONF:EDEV:PMAR:FMIN "myDevice", 1e10 system:configure:edevice:pmar:fminumum "myDevice", 3e9 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:FMAXimum? <name>
Return Type | Numeric
Default | Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:READing:COUNt <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SYST:CONF:EDEV:PMAR:READ:NTOL, allows for settling of the power sensor READINGS.

Set and return the maximum number of power readings that are taken at each stimulus point to allow for measurement settling. Each reading is averaged with the previous readings at that stimulus point.

When this average meets the Average:NTOLerance value or this number of readings has been made, the average is returned as the valid reading.

Parameters

<name>

String - Name of the power meter.

<value>

Number of readings. Choose a value between 1 and 25

Examples

SYST:CONF:EDEV:PMAR:READ:COUN "myDevice", 20

system:configure:edevice:pmar:reading:count "myDevice", 10

See example program

Query Syntax

SYSTem:CONFigure:EDEVice:PMAR:READing:COUNt? <name>

Return Type

Numeric

Default

3

SYSTem:CONFigure:EDEVice:PMAR:READing:NTOLerance <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) This command, along with SYST:CONF:EDEV:PMAR:READ:COUN, allows for settling of the power sensor READINGS.

Each power reading is averaged with the previous readings at each stimulus point. When the average meets this nominal tolerance value, or the max number of readings has been made, the average is returned as the valid reading.

Parameters

<name>

String - Name of the power meter.

<value>

Power measurement settling tolerance value in dB. Choose any number between 0 and 5.

Examples

SYST:CONF:EDEV:PMAR:READ:NTOL "myDevice", .5

system:configure:edevice:pmar:reading:ntolerance "myDevice",.01

See example program

Query Syntax

SYSTem:CONFigure:EDEVice:PMAR:READing:NTOLerance? <name>

Return Type

Numeric

Default

.05

SYSTem:CONFigure:EDEVice:PMAR:SENSor <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the power sensor channel (1 or 2) to be used. This performs the same function as the Use this sensor only checkbox.
Parameters |
<name> | String - Name of the power meter.
<value> | Power Meter channel. 1 - Channel A 2 - Channel B
Examples | SYST:CONF:EDEV:PMAR:SENS "myDevice",2 system:configure:edevice:pmar:sensor "myDevice",1 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:SENSor? <name>
Return Type | Numeric
Default | 1

SYSTem:CONFigure:EDEVice:PMAR:TABLe:CFAC:DATA <name>,<value>[,value]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the cal factor data for the power sensor.
Parameters |
<name> | String - Name of the power meter.
<value>[,value] | Cal factor data in percent. For each frequency used with SYST:CONF:EDEV:PMAR:TABL:CFAC:FREQ, enter a cal factor number between 1 and 100.
Examples | SYST:CONF:EDEV:PMAR:TABL:CFAC:DATA "myDevice", 98,99,99 system:configure:edevice:pmar:table:cfac:data "myDevice", 97,97,97 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:TABLe:CFAC:DATA? <name>
Return Type | Numeric - one number per table segment.
Default | Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:TABLe:CFAC:FREQuency <name>,<value>[,value]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the cal factor frequencies for the power sensor.
Parameters |
<name> | String - Name of the power meter.
<value>[,value] | Cal factor frequencies in Hz.
Examples | SYST:CONF:EDEV:PMAR:TABL:CFAC:FREQ "myDevice", 1e7,1e8,1e9 system:configure:edevice:pmar:table:cfac:frequency "myDevice", 5e7,5e8,5e9 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:TABLe:CFAC:FREQuency?<name>
Return Type | Numeric - one number per table segment.
Default | Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:TABLe:LOSS:DATA <name>,<value>[,value]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the power loss data for the power sensor.

Each table can contain up to 9999 segments. Values can also be loaded using the Characterize Adapter macro.

Parameters

<name>

String - Name of the power meter.

<value>[,value]

Loss data in dB. POSITIVE values in dB are interpreted as LOSS. To compensate for gain, use negative values.

For each frequency used with SYST:CONF:EDEV:PMAR:TABL:LOSS:FREQ, enter a cal factor number between 1 and 100.

Examples

SYST:CONF:EDEV:PMAR:TABL:LOSS:DATA "myDevice",.01,.02,.03

system:configure:edevice:pmar:table:loss:data "myDevice", .04,.05,.06

See example program

Query Syntax

SYSTem:CONFigure:EDEVice:PMAR:TABLe:CFAC:DATA? <name>

Return Type

Numeric - one number per table segment.

Default

Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:TABLe:LOSS:FREQuency <name>,<value>[,value]

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns frequencies for the power loss data.
Parameters |
<name> | String - Name of the power meter.
<value>[,value] | Power Loss frequencies in Hz.
Examples | SYST:CONF:EDEV:PMAR:TABL:LOSS:FREQ "myDevice",1e7,1e8,1e9 system:configure:edevice:pmar:table:loss:frequency "myDevice",5e7,5e8,5e9 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:TABLe:LOSS:FREQuency? <name>
Return Type | Numeric - one number per table segment.
Default | Not Applicable

SYSTem:CONFigure:EDEVice:PMAR:TABLe:LOSS:STATe <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns whether to use the power loss table.
Parameters |
<name> | String - Name of the power meter.
<value> | Boolean. State of the power loss table. Choose from: OFF or 0 - Power loss table not used. ON or 1 - Power loss table used.
Examples | SYST:CONF:EDEV:PMAR:TABL:LOSS:STAT "myDevice",1 system:configure:edevice:pmar:table:loss:state "myDevice",1 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:TABLe:LOSS:STATe? <name>
Return Type | Boolean
Default | OFF

SYSTem:CONFigure:EDEVice:PMAR:TABLe:RFACtor <name>,<value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the reference cal factor for the power sensor. Note: If the sensor connected to the power meter contains cal factors in EPROM (such as the Keysight E-series power sensors), those will be the cal factors used. The reference cal factor value associated with this command, and any cal factors entered into the VNA for that sensor channel, will not be used.
Parameters |
<name> | String - Name of the power meter.
<value> | Reference cal factor in percent. Choose any number between 1 and 150.
Examples | SYST:CONF:EDEV:PMAR:TABL:RFAC "myDevice", 1 system:configure:edevice:pmar:table:rfactor "myDevice", 1 See example program
Query Syntax | SYSTem:CONFigure:EDEVice:PMAR:TABLe:RFACtor? <name>
Return Type | Numeric
Default | 100

SYSTem:CONFigure:EDEVice:PMAR:ZERO <name>[,SYNC,<value>]

Applicable Models: E5080A, M9485A

(Write-only) Performs a zeroing of the PMAR device.

This command is always synchronous, so *OPC? is the only way to determine that the operation is complete. Set an I/O timeout of at least 20 seconds.

Keysight P-Series sensors do ONLY Internal zeroing. These, and Keysight USB power sensors when Internal is selected, do NOT require disconnecting from the measurement path before zeroing.

All other Keysight sensors do ONLY External zeroing.

Parameters

<name>

String - Name of the power meter.

[,SYNC,<value>]

Optional argument for use with power sensors that support both internal and external types of zeroing such as Keysight USB power sensors.

Choose from:

SYNC,INTernal - Internal zeroing. Power is automatically removed from the sensor input before zeroing occurs (Default setting).

SYNC,EXTernal - External zeroing. First remove the sensor input, then send this command. External zeroing is recommended for powers below -30 dBm with the U2000-Series sensors (-20 dBm for the H models).

Examples

SYST:CONF:EDEV:PMAR:ZERO "myDevice"

system:configure:edevice:pmar:zero "myDevice",sync,internal

Query Syntax

Not Applicable

Default

Not Applicable

Last Modified:

16-Mar-2015

First Release


SystCorrIntLinear

SYSTem:CORRection:INTerpolate:LINear Commands

Applicable Models: E5080A, M9485A

The five SYSTem:CORRection:INTerpolate:LINear commands are used as a sequence. They are not meant to be used independent of the others. The commands perform linear interpolation on a scalar data of (x,y) pairs based on a master set of x and y values to a new mapping based on a desired set of x values. The desired set of x values (or range) must fall within the master set of x values (or range) and can have a different number of points than the master data set.

Definition:

Linear interpolation operates by drawing a straight line between each two adjacent data points on the master (x,y) pairs that fall on either side of the new desired data point represented by (x’,y’). in other words if

(xi, yi) represents data pairs on the master data set and (xj’,yj’) represents a data point on the interpolated result data set then:

Xi < Xj’ < Xi+1 and Yj’ = Yi + [(Yi+1 – Yi)/(Xi+1 – Xi)] (Xj’ – Xi)

Note: The master data set must represent a function on the Cartesian coordinate system. In other words, for each x value in the master data set, there can be only one corresponding Y value.

There are five steps in the sequence:

  1. SYSTem:CORRection:INTerpolate:LINear:INPut:X - loads in the master X values

  2. SYSTem:CORRection:INTerpolate: LINear:INPut:Y - loads in the master Y values

  3. SYSTem:CORRection:INTerpolate: LINear:OUTput:X - loads in the desired interpolated X values

  4. SYSTem:CORRection:INTerpolate: LINear:CALCulate - calculates the interpolated Y values

  5. SYSTem:CORRection:INTerpolate: LINear:OUTput:Y? - reads back the interpolated Y values.

Example

The following function uses the SYSTem:CORRection:INTerpolate: LINear commands:

Function InterpolateData_Single(inputX() As Double, inputY() As Single, outputX() As Double, ByRef interpData() As Single)

x = visa_io.ag_send_binBlock64("SYST:CORR:INT:LIN:INP:X ", inputX)

x = visa_io.ag_send_binBlock("SYST:CORR:INT:LIN:INP:Y ", inputY)

x = visa_io.ag_send_binBlock64("SYST:CORR:INT:LIN:OUTP:X ", outputX)

x = visa_io.ag_send_rd("*OPC?")

x = visa_io.ag_send_wait("SYST:CORR:INT:LIN:CALC")

x = visa_io.ag_send_rd("*OPC?")

interpData = visa_io.ag_send_rd_binBlock("SYST:CORR:INT:LIN:OUTP:Y?")

CheckError

End Function

'Here is a code snippet that uses the function above.

'copy the B-Response Error term from one calset to another.

'The source calset has a super set stimulus and

'and the receiving calset has a subset stimulus

Dim BResp_freqList() As Double

Dim BResp_Re() As Single

Dim BResp_Im() As Single

GetErrorTerm_noChan BResp_Calset, "ResponseTracking(B)", BResp_freqList, BResp_Re, BResp_Im

Dim Noise_freqList() As Double

GetCalsetStimulus calsetName, Noise_freqList, 1, "Noise Figure Cold Source"

' Response Stimulus Range

Dim BResp_Re_interp() As Single

Dim BResp_Im_interp() As Single

InterpolateData_Single BResp_freqList, BResp_Re, Noise_freqList, BResp_Re_interp

InterpolateData_Single BResp_freqList, BResp_Im, Noise_freqList, BResp_Im_interp

PutErrorTerm channel, calsetName, "ResponseTracking(B)", BResp_Re_interp, BResp_Im_interp

Last Modified:

18-Mar-2015

First Release


System Preferences

System Preferences Commands

Sets and reads the VNA Preferences settings.

SYSTem:PREFerences

| DEFault

| ITEM

| EEXTrapolate

| EDEV: DPOLicy

| GDELay:TWOPoint

| MCControl

| MCMethod

| MCPreset

| MRU

| OFFSet

| RCV

| SRC

| PRESet:POWer:STATe

| PSRTrace

| RECeivers

| CERRor

| OVERload:POWer

RETRace:POWer

| RTOF

| SWITch:DEF

Click on a Red keyword to view the command details.

See Also

  • SENS:CORRection:PREFerences

  • Learn about VNA Preferences

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:PREFerences:DEFault

Applicable Models: E5080A, M9485A

(Write-only) Resets the VNA preferences to their default settings. Some default settings vary depending on the VNA Model. Learn more about VNA Preferences.
Examples | SYST:PREF:DEF system:preferences:default
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:PREFerences:ITEM:EDEV:DPOLicy <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether External Devices remain activated or are de-activated when the VNA is Preset or when a Instrument State is recalled.

This setting remains until changed again using this command, or until the hard drive is changed or reformatted.

Parameters

<bool>

Choose from:

OFF (0) External devices remain active when the VNA is Preset or when a Instrument State is recalled.

ON (1) External devices are de-activated (SYST:CONF:EDEV:STAT to OFF) when the VNA is Preset or when a Instrument State is recalled.

Examples

SYST:PREF:ITEM:EDEV:DPOL 1
system:preferences:item:edev:dpolicy OFF

Query Syntax

SYSTem:PREFerences:ITEM:EDEV:DPOLicy?

Return Type

Boolean

Default

ON or 1

SYSTem:PREFerences:ITEM:EEXTrapolate <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets whether a Swept IMD or IMDx calibration can exceed the stop frequency limit of an ECal module. Learn more.
Parameters |
<bool> | Choose from: ON (1) Allow extrapolation. OFF (0) Do NOT allow extrapolation.
Examples | SYST:PREF:ITEM:EEXT 1 system:preferences:item:eextrapolate OFF
Query Syntax | SYSTem:PREFerences:ITEM:EEXTrapolate?
Return Type | Boolean
Default | OFF

SYSTem:PREFerences:ITEM:GDELay:TWOPoint <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the default group delay aperture setting. Learn more about group delay aperture.
Parameters |
<bool> | Choose from: ON (1) Sets default group delay aperture to 2 points. OFF (0) Sets default group delay aperture to 11 points.
Examples | SYST:PREF:ITEM:GDELay:TWOPoint 1 system:preferences:item:gdelay:twopoint OFF
Query Syntax | SYSTem:PREFerences:ITEM:GDELay:TWOPoint?
Return Type | Boolean
Default | OFF

SYSTem:PREFerences:ITEM:MCControl <bool>

Applicable Models: None

(Read-Write) Set and return whether the Coupled Markers setting controls the ON|OFF state of markers that are coupled. Learn more about Coupled Markers. Refer also to CALC:MARK:COUP:STATe ON.
Parameters |
<bool> | Choose from: ON (1) – With Coupled Markers ON, when a marker is turned on, the same-numbered marker on all coupled traces will also be turned on. Likewise, turning off a marker will turn it off on all coupled traces. OFF (0) – Turning a marker on or off will have no effect on the markers on other traces.
Examples | SYST:PREF:ITEM:MCC 1 system:preferences:item:mccontrol OFF
Query Syntax | SYSTem:PREFerences:ITEM:MCControl?
Return Type | Boolean
Default | OFF (0)

SYSTem:PREFerences:ITEM:MCMethod <bool>

Applicable Models: None

(Read-Write) Set and return whether Coupled Markers is set to Channel or All after Preset. Learn more about Coupled Markers. Refer also to CALC:MARK:COUP:STATe ON and SYST:PREF:ITEM:MCPR ON.
Parameters |
<bool> | Choose from: ON (1) – Marker Coupling Method is set to Channel after Preset. OFF (0) – Marker Coupling Method is set to ALL after Preset.
Examples | SYST:PREF:ITEM:MCM 1 system:preferences:item:mcmethod OFF
Query Syntax | SYSTem:PREFerences:ITEM:MCMethod?
Return Type | Boolean
Default | OFF (0)

SYSTem:PREFerences:ITEM:MCPRest <bool>

Applicable Models: None

(Read-Write) Set and return whether Coupled Markers is set to ON or OFF after Preset. Learn more about Coupled Markers.
Parameters |
<bool> | Choose from: OFF (0) – Coupled Markers is OFF after Preset. ON (1) – Coupled Markers is ON after Preset.
Examples | SYST:PREF:ITEM:MCPR 1 system:preferences:item:mcpreset OFF
Query Syntax | SYSTem:PREFerences:ITEM:MCPReset?
Return Type | Boolean
Default | OFF (0)

SYSTem:PREFerences:ITEM:MRU <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to list files for recall on softkeys by most-recently used or alphabetically.
Parameters |
<bool> | Choose from: ON (1) – Recall softkeys show most recently-used files. OFF (0) – Recall softkeys show alphabetically-ordered files.
Examples | SYST:PREF:ITEM:MRU 1 system:preferences:item:mru OFF
Query Syntax | SYSTem:PREFerences:ITEM:MRU?
Return Type | Boolean
Default | OFF (0)

SYSTem:PREFerences:ITEM:OFFSet:RCV <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to offset the test port receivers by the amount of receiver attenuation. Learn more.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

This setting remains until changed again using this command, or until the hard drive is changed or reformatted.

Parameters

<bool>

Choose from:

ON (1) Offset the test port receivers

OFF (0) Do NOT offset the test port receivers

Examples

SYST:PREF:ITEM:OFFS:RCV 1
system:preferences:item:offset:rcv OFF

Query Syntax

SYSTem:PREFerences:ITEM:OFFSet:RCV?

Return Type

Boolean

Default

PNA-L and E836xB: OFF (does NOT offset the display).

VNA: ON (offsets the display).

SYSTem:PREFerences:ITEM:OFFSet:SRC <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to offset the reference receiver by the amount of source attenuation. Learn more.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

This setting remains until changed again using this command, or until the hard drive is changed or reformatted.

Parameters

<bool>

Choose from:

ON (1) Offset the reference receivers.

OFF (0) Do NOT Offset the reference receivers.

Examples

SYST:PREF:ITEM:OFFS:SRC 1
system:preferences:item:offset:src OFF

Query Syntax

SYSTem:PREFerences:ITEM:OFFSet:SRC?

Return Type

Boolean

Default

All models: ON (offset the display).

SYSTem:PREFerences:ITEM:PRESet:POWer[:STATe] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the Preset Power ON/OFF state. Learn more. This setting remains until changed again using this command, or until the hard drive is changed or reformatted.
Parameters |
<char> | Choose from: ON - Instrument Preset always turns RF power ON. AUTO - When the current power setting is OFF, leave power OFF after Preset. When the current power setting is ON, turn power ON after Preset.
Examples | SYST:PREF:ITEM:PRE:POW ON system:preferences:item:preset:power:state auto
Query Syntax | SYSTem:PREFerences:ITEM:PREset:POWer[:STATe]?
Return Type | Character
Default | ON

SYSTem:PREFerences:ITEM:PSRTrace <char>

Applicable Models: E5080A, M9485A

(Read-Write) At the end of a power sweep, while waiting to trigger the next sweep, maintain source power at either the start power level or at the stop power level.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

This setting remains until changed again using this command, or until the hard drive is changed or reformatted.

Parameters

<char>

Choose from:

STARt - Maintain source power at the start power level.

STOP - Maintain source power at the stop power level.

Examples

SYST:PREF:ITEM:PSRT STOP
system:preferences:item:psrtrace start

Query Syntax

SYSTem:PREFerences:ITEM:PSRTrace?

Return Type

Character

Default

STARt

SYSTem:PREFerences:ITEM:RECeivers:CERRor[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to display receiver overload warnings. Learn more.
Parameters |
<bool> | Choose from: ON (1) Display overload warnings, OFF (0) Do NOT display overload warnings.
Examples | SYST:PREF:ITEM:REC:CERR 1 system:preferences:item:receivers:cerror:state OFF
Query Syntax | SYSTem:PREFerences:ITEM:RECeivers:CERRor[:STATe]?
Return Type | Boolean
Default | ON

SYSTem:PREFerences:ITEM:RECeivers:OVERload:POWer[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to turn source power OFF when a receiver is overloaded. Learn more.
Parameters |
<bool> | Choose from: ON (1) Turn OFF source power to ALL ports when a receiver is overloaded. OFF (0) Power remains ON when a receiver is overloaded.
Examples | SYST:PREF:ITEM:REC:OVER:POW 1 system:preferences:item:receivers:overload:power:state OFF
Query Syntax | SYSTem:PREFerences:ITEM:RECeivers:OVERload:POWer[:STATe]?
Return Type | Boolean
Default | OFF (0)

SYSTem:PREFerences:ITEM:RETRace:POWer <char>

Applicable Models: E5080A, M9485A

(Read-Write) For single-band frequency or segment sweeps ONLY, specify whether to turn RF power ON or OFF during a retrace. Learn more about RF power during sweep retrace.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

This setting remains until changed using this command, or until the hard drive is changed or reformatted.

Parameters

<char>

Choose from:

AUTO: Power is left ON during retrace of single-band frequency or segment sweeps ONLY.

OFF: Power is turned OFF during retrace of single-band frequency or segment sweeps ONLY.

Examples

SYST:PREF:ITEM:RETR:POW OFF

system:preferences:item:retrace:power auto

Query Syntax

SYSTem:PREFerences:ITEM:RETRace:POWer?

Return Type

Character

Default

AUTO

SYSTem:PREFerences:ITEM:RTOF <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return whether to display limit line failures as red trace segments or red data points (dots). Learn more.
Parameters |
<bool> | Choose from: ON (1) Display failures as red trace segments. (Red Trace On Fail). OFF (0) Display failures as red data points (dots).
Examples | SYST:PREF:ITEM:RTOF 1 system:preferences:item:rtof OFF
Query Syntax | SYSTem:PREFerences:ITEM:RTOF?
Return Type | Boolean
Default | OFF

SYSTem:PREFerences:ITEM:SWITch:DEF <string>, <int>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the default setting for the Noise Tuner switch. This is the setting that occurs when a new channel is created. Learn more.

This command will return an error on VNA models with a built-in Noise tuner.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

This setting remains until changed using this command, or until the hard drive is changed or reformatted.

Parameters

<string>

Name of the switch to set. Choose from:

  • "Port1NoiseTuner"

<int>

Value to set. Choose from:

0 Sets the default (preset) to INTERNAL

1 Sets the default (preset) to EXTERNAL

Examples

SYST:PREF:ITEM:SWIT:DEF "Port1NoiseTuner" 1 'Write

system:preferences:item:switch:def? "Port1NoiseTuner" 'Read

Query Syntax

SYSTem:PREFerences:ITEM:SWITch:DEF? <switch>

Return Type

Integer

Default

1 (External)

Last Modified:

16-Mar-2015

Initial Release


PXI Shared Memory Data Transfer

The fastest way to transfer data out of a PXIe VNA is to use shared memory. Due to the nature of shared memory, these commands can ONLY be used to transfer data between your program and the VNA when your program runs locally on the same computer as the VNA.

Shared Memory Background: Usually, each process has its own memory, and anything saved in one process isn't visible to another process. With shared memory, both processes actually connect to the same memory, so what happens in one process is now visible to another process.

How to setup Shared Memory

  1. Send SYST:DATA:MEM:INITialize. This tells the VNA to prepare for the creation of shared memory.

  2. Decide which measurements to include in the shared memory. For each of those measurements, send SYST:DATA:MEM:ADD. This adds a request to copy the contents of those measurements into the shared memory. This does not start adding data.

  3. Send SYST:DATA:MEM:COMMit. This command tells the VNA to create the Windows shared memory resource and to give that shared memory resource a name.

  4. You can now create a handle to the shared memory and start reading the data from that shared memory. Once setup, the VNA remembers the setup, and the shared memory will be filled on each sweep. You do not send any more SCPI commands unless you need to change the list of requested measurements to include in the shared memory.

See C# example

SYSTem: DATA:MEMory Commands

Controls Shared Memory.

The commands are listed in order of recommended use.

SYSTem:DATA:MEMory:

INITialize

ADD

OFFSet?

NAME?

COMMit

SIZE?

DELete

RESet

Click on a keyword to view the command details.

See Also

  • SCPI Command Tree

SYSTem:DATA:MEMory:INITialize

Applicable Models: M9485A

(Write only) Initializes the shared memory setup buffers.
Parameters | None
Examples | See an example program
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:DATA:MEMory:ADD <string>

Applicable Models: M9485A

(Write only) Add a request to copy the contents of the specified measurement into shared memory. Call this command once for each measurement definition. Once the shared memory is setup, there is no need to send more SCPI commands. The shared memory is filled automatically on every sweep.

Parameters

<string>

The following elements separated with colons (:).

<Ch>:<MeasNum>:<dataFormat>:<numPoints>

where:

  • <Ch> - Channel number of the measurement to share memory. Use SYST:ACTive:CHAN to return the active channel number. Use SYST:CHAN:CAT? to return the channel numbers in use.

  • <MeasNum> - Measurement (Tr) number to share memory. Use CALC<ch>:PAR:MNUM? just after the trace is created to read the measurement number. See also: Referring to Traces, Measurements, Channels, and Windows Using SCPI.

  • <dataFormat> - Choose from:

    • SDATA - Complex measurement data.

      • Writes data to Data Access Map location Raw Measurement (access point 0). When writing corrected data, and correction is ON, it will be corrected again, resulting in meaningless data.

      • Reads data from Apply Error Terms (access point 1). Returns TWO numbers per data point. Corrected data is returned when correction is ON. Uncorrected data is returned when correction is OFF.

    • FDATA - Formatted measurement data to or from Data Access Map location Display (access point 2).

      • Corrected data is returned when correction is ON.

      • Uncorrected data is returned when correction is OFF.

      • Returns TWO numbers per data point for Polar and Smith Chart format.

      • Returns one number per data point for all other formats.

      • Format of the read data is same as the displayed format.

  • <numPoints> - Number of data points in the measurement trace.

Examples

SYSTem:DATA:MEMory:ADD "2:3:SDATA:201"

'copies the data for channel #2, measurement #3, complex data, 201 points into the shared memory buffer.

See an example program

Query Syntax

Not Applicable

Default

Not Applicable

SYSTem:DATA:MEMory:OFFSet?

Applicable Models: E5080A, M9485A

(Read only) The shared memory is a contiguous block of memory. Each measurement takes up a subset of this contiguous block. This command returns the offset into the shared memory for the most recently added parameter. The offset is a number that specifies the starting index of the data. This query can be sent after sending SYST:DATA:MEM:ADD.
Parameters | None
Examples | See an example program
Return Type | Numeric
Default | Not Applicable

SYSTem:DATA:MEMory:NAME?

Applicable Models: E5080A, M9485A

(Read only) Returns a unique, auto-generated name that can be used in the COMMIt command. By using this generated name, a client can be sure not to conflict with any other used shared memory regions.
Parameters | None
Examples | See an example program
Return Type | String
Default | Not Applicable

SYSTem:DATA:MEMory:COMMit <memName>

Applicable Models: E5080A, M9485A

(Write only) Allocates the memory mapped buffer.
Parameters |
<memName> | String. Name of the memory mapped buffer. This must be a unique name, and cannot conflict with other shared memory buffer names. Use this command in your program when connecting to the shared memory. See SYSTem:DATA:MEMory:NAME?
Examples | See an example program
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:DATA:MEMory:SIZE?

Applicable Models: E5080A, M9485A

(Read only) Returns the size of the memory mapped region. Send this immediately after SYST:DATA:MEM:COMMit. The result is the total size (in bytes) of all the measurements in the shared memory region.
Parameters | None
Examples | See an example program
Return Type | Numeric
Default | Not Applicable

SYSTem:DATA:MEMory:CATalog?

Applicable Models: E5080A, M9485A

(Read only) Returns a list of all the allocated shared memory buffers
Parameters | None
Examples | See an example program
Return Type | String
Default | Not Applicable

SYSTem:DATA:MEMory:RESet

Applicable Models: E5080A, M9485A

(Write only) Deletes all allocated shared memory buffers
Parameters | None
Examples | See an example program
Query Syntax | Not Applicable
Default | Not Applicable

SYSTem:DATA:MEMory:DELete <memName>

Applicable Models: E5080A, M9485A

(Write only) Allocates the specified memory mapped buffer.
Parameters |
<memName> | String. Name of the memory mapped buffer. This is the unique name that is used in the COMMit command.
Examples | See an example program
Query Syntax | Not Applicable
Default | Not Applicable

Example Program

static void Main(string[] args)

{

// Connect to the hislip VISA address of localhost

ResourceManager resourceManager = new ResourceManager();

FormattedIO488 formattedIO = new FormattedIO488();

formattedIO.IO = (IMessage)resourceManager.Open("TCPIP0::localhost::hislip0::INSTR");

// Destroy all measurements and add a window

formattedIO.WriteString("SYST:FPR\n");

formattedIO.WriteString("DISP:WIND:STAT 1");

// initialize memory mapped structures in VNA

formattedIO.WriteString("SYST:DATA:MEM:INIT\n");

// Create 4 SParameters

string[] parameters = new string[] { "S11", "S21", "S12", "S22" };

int[] offsets_for_complex_data = new int[parameters.Length];

int[] offsets_for_formatted_data = new int[parameters.Length];

for (int i = 0; i < parameters.Length; i++)

{

// Create a new parameter

formattedIO.WriteString("CALC:PAR:DEF '" + parameters[i] + "'," + parameters[i]);

formattedIO.WriteString("DISP:WIND:TRAC" + (i + 1).ToString() + ":FEED '" + parameters[i] + "'");

// Configure a new section of the memory map to monitor the complex data of this parameter

formattedIO.WriteString("SYST:DATA:MEM:ADD '1:" + (i + 1).ToString() + ":SDATA:201'"); // add parameter to memory mapped

formattedIO.WriteString("SYST:DATA:MEM:OFFSet?");

offsets_for_complex_data[i] = int.Parse(formattedIO.ReadString());

// Configure a new section of the memory map to monitor the formatted data of this parameter

formattedIO.WriteString("SYST:DATA:MEM:ADD '1:" + (i + 1).ToString() + ":FDATA:201'"); // add parameter to memory mapped

formattedIO.WriteString("SYST:DATA:MEM:OFFSet?");

offsets_for_formatted_data[i] = int.Parse(formattedIO.ReadString());

}

// Tell the VNA to allocate the memory map. Name it "VNA_MemoryMap"

formattedIO.WriteString("SYST:DATA:MEM:COMM 'VNA_MemoryMap'");

// Query the size of the memory map

formattedIO.WriteString("SYST:DATA:MEM:SIZE?");

int size = int.Parse(formattedIO.ReadString());

// Create the memory map in C#. This requires .NET 4.5 framework

MemoryMappedFile mappedFile = MemoryMappedFile.CreateOrOpen("VNA_MemoryMap", size);

MemoryMappedViewAccessor mappedFileView = mappedFile.CreateViewAccessor();

// Trigger a single sweep, and wait for it to complete

formattedIO.WriteString("SENS:SWE:MODE SING");

formattedIO.WriteString("*OPC?");

formattedIO.ReadString();

// Allocate buffers to hold the output data

float[][] complexData = new float[parameters.Length][];

for (int i = 0; i < complexData.Length; i++)

{

complexData[i] = new float[402];

}

float[][] formattedData = new float[parameters.Length][];

for (int i = 0; i < formattedData.Length; i++)

{

formattedData[i] = new float[201];

}

// Copy the data from the memory map into the output buffers

// These copy the data from the in-process memory map.

// This runs very fast - and is just a "memcpy" under the hood

for (int i = 0; i < parameters.Length; i++)

{

ReadBytes(mappedFileView,offsets_for_complex_data[i],402,complexData[i]);

ReadBytes(mappedFileView, offsets_for_formatted_data[i], 201, formattedData[i]);

}

// Output some data to show that it worked

System.Console.WriteLine(complexData[0][0].ToString()); // Output first point of S11 in complex

System.Console.WriteLine(formattedData[3][200].ToString()); // Output last point of S22 as formatted

}

static public unsafe void ReadBytes(MemoryMappedViewAccessor mappedFileView,

int offset, int num, float[] arr)

{

// This is equivalent to:

// //m_mappedFileView.ReadArray<float>(m_sharedMemoryOffsets[i-1], complexArray, 0, points*2);

// But, using this "unsafe" code is 30 times faster. 100usec versus 3ms

byte* ptr = (byte*)0;

mappedFileView.SafeMemoryMappedViewHandle.AcquirePointer(ref ptr);

System.Runtime.InteropServices.Marshal.Copy(IntPtr.Add(new IntPtr(ptr), offset), arr, 0, num);

mappedFileView.SafeMemoryMappedViewHandle.ReleasePointer();

}

}


Trigger SCPI

Trigger Commands

Controls External Triggering .

TRIGger:

AUX

| COUNt

CHANnel:AUX

| DURation

| [ENABle]

| INTerval

| OPOLarity

| POSition

| TYPE

DELay

PREFerence

| AIGLobal

READy:POLarity

[SEQuence]

| SCOPe

| SOURce

| SLOPe

| TYPE

Click on a Red keyword to view the command details.

See Also

  • Example program Triggering the VNA

  • See other SCPI Triggering commands

  • Learn about External / Aux Triggering

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

TRIGger:AUXiliary:COUNt?

Applicable Models: E5080A

(Read-only) Returns the number of AUX trigger output connector in the instrument.
Parameters |
Examples | TRIG:AUX:COUN? trigger:auxiliary:count?
Return Type | Numeric
Default | Not Applicable

TRIGger:CHANnel<ch>:AUXiliary<n>:DURation <num>

Applicable Models: E5080A

(Read-Write) Specifies the width of the output pulse, which is the time that the Aux trigger output will be asserted.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Rear panel connector used to send or receive signals. If unspecified, value is set to 1.
<num> | Duration value in seconds. Choose a value between 1us (1E-6) and 1.
Examples | TRIG:CHAN:AUX:DUR .1 trigger:channel2:aux:duration .01
Query Syntax | TRIGger:CHANnel<ch>:AUXiliary<n>:DURation?
Return Type | Numeric
Default | 1E-6

TRIGger:CHANnel<ch>:AUXiliary<n>[:ENABle] <bool>

Applicable Models: E5080A

(Read-Write) Turns ON / OFF the trigger output.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Rear panel connector used to send or receive signals. If unspecified, value is set to 1.
<bool> | ON or 1 - Turns trigger output ON. OFF or 0 - Turns trigger output OFF.
Examples | TRIG:CHAN:AUX 1 trigger:channel2:aux:enable off
Query Syntax | TRIGger:CHANnel<ch>:AUXiliary<n>:[ENABle]?
Return Type | Boolean
Default | OFF

TRIGger:CHANnel<ch>:AUXiliary<n>:INTerval <char>

Applicable Models: E5080A

(Read-Write) Specifies how often a trigger output signal is sent.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<n>

Rear panel connector used to send or receive signals.

If unspecified, value is set to 1.

<char>

Choose from:

  • SWEep - Trigger signal is sent once every sweep.

Examples

TRIG:CHAN:AUX:INT POI

trigger:channel2:aux:interval sweep

Query Syntax

TRIGger:CHANnel<ch>:AUXiliary<n>:INTerval?

Return Type

Character

SWEep

TRIGger:CHANnel<ch>:AUXiliary<n>:OPOLarity <char>

Applicable Models: E5080A

(Read-Write) Specifies the polarity of the Aux Output signal being supplied by the VNA.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<n>

Rear panel connector used to send or receive signals.

If unspecified, value is set to 1.

<char>

Choose from:

  • POSitive - VNA sends positive going pulse.

  • NEGative - VNA sends negative going pulse.

Examples

TRIG:CHAN:AUX:OPOL NEG

trigger:channel2:aux:opolarity positive

Query Syntax

TRIGger:CHANnel<ch>:AUXiliary<n>:OPOLarity?

Return Type

Character

Default

NEGative

TRIGger:CHANnel<ch>:AUXiliary<n>:POSition <char>

Applicable Models: E5080A

(Read-Write) Specifies whether the aux trigger out signal is sent BEFore or AFTer the acquisition.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1.

<n>

Rear panel connector used to send or receive signals.

If unspecified, value is set to 1.

<char>

Choose from:

  • BEFore - Use if the external device needs to be triggered before the data is acquired, such as a power meter.

  • AFTer - Use if the external device needs to be triggered just after data has been acquired, such as an external source. This could be more efficient since it allows the external device to get ready for the next acquisition at the same time as the VNA.

Examples

TRIG:CHAN:AUX:POS BEF

trigger:channel2:aux:position after

Query Syntax

TRIGger:CHANnel<ch>:AUXiliary<n>:POSition?

Return Type

Character

Default

AFTer

TRIGger:CHANnel<ch>:AUXiliary<n>:TYPE <char>

Applicable Models: E5080A

(Read-Write) Specifies the type of Aux input detection that the VNA will employ.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<n> | Rear panel connector used to send or receive signals. If unspecified, value is set to 1.
<char> | Choose from: EDGE - VNA responds to the leading edge of a signal. LEVel - VNA responds to the level (HIGH or LOW) of a signal.
Examples | TRIG:CHAN:AUX:TYPE EDGE trigger:channel2:aux:type level
Query Syntax | TRIGger:CHANnel<ch>:AUXiliary<n>:TYPE?
Return Type | Character
Default | EDGE

TRIGger:DELay <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and reads the trigger delay for ALL channels (globally). This delay is only applied while TRIG:SOURce = EXTernal and TRIG:SCOP = ALL After an external trigger is applied, the start of the sweep is held off for an amount of time equal to the delay setting plus any inherent latency. To apply a trigger delay for the specified channel ONLY, use SENS:SWE:TRIG:DELay
Parameters |
<num> | Delay value in seconds. Choose from 0 to 107.
Examples | TRIG:DEL .0003 Sets the trigger delay to 300 microseconds. The sweep will not start until approximately 300 microseconds after an external trigger is applied.
Query Syntax | TRIGger:DELay?
Return Type | Numeric
Default | 0

TRIGger:PREFerence:AIGLobal <bool>

Applicable Models: E5080A

(Read-Write) Sets the Trigger OUT behavior to either Global or Channel. Learn more about this setting.

This command will cause the VNA to Preset.

This setting remains until changed again using this command, or until the hard drive is changed or reformatted.

To send this command using the VNA front panel, open the GPIB Command Processor Console, then type either of the following examples at the command prompt. Then type the Query Syntax and press enter to be sure the VNA took the command.

Parameters

<bool>

Choose from:

  • ON (or 1) - Trigger properties apply to ALL channels (Global).

    • Allows use of CONT:SIGNal command to configure the external trigger properties.

    • "Per Point" trigger property is not settable. Use the channel's Point trigger setting.

  • OFF (or 0) - External Trigger properties apply to each channel independently.

    • Must use TRIG:CHAN:AUX commands to configure the external trigger properties. CONT:SIGNal will NOT work.

    • "Per Point" trigger output property is set using the channel's Point trigger setting AND TRIG:CHAN:AUX:INTerval.

Examples

TRIG:PREF:AIGL 1

trigger:preference:aiglobal 0

Query Syntax

TRIGger:PREFerence:AIGLobal?

Return Type

Boolean

Default

0

TRIGger:READy:POLarity <char>

Applicable Models: E5080A

(Read-Write) Specifies the polarity of Ready for Trigger output. All existing Ready for Trigger outputs are configured simultaneously with this command.
Parameters |
<char> | LOW - Outputs a TTL low when the VNA is ready for trigger. HIGH - Outputs a TTL high when the VNA is ready for trigger.
Examples | TRIG:READ:POL HIGH trigger:ready:polarity low
Query Syntax | TRIGger:READy:POLarity?
Return Type | Character
Default | Low

TRIGger[:SEQuence]:SCOPe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies whether a trigger signal is sent to all channels or only the current channel.

See Triggering the VNA using SCPI.

Parameters

<char>

Choose from:

  • ALL - trigger signal is sent to all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels.

  • CURRent - trigger signal is sent to only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel.

  • ACTive - trigger signal is sent to only active channel at a time.

Examples

TRIG:SCOP ALL
trigger:sequence:scope current

Query Syntax

TRIGger[:SEQuence]:SCOPe?

Return Type

Character

Default

ALL

TRIGger[:SEQuence]:SLOPe <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the polarity expected by the external trigger input circuitry. Also specify TRIG:TYPE (Level |Edge).

See Triggering the VNA using SCPI.

Parameters

<char>

Choose from:

  • POSitive (rising Edge) or High Level

  • NEGative (falling Edge) or Low Level

Examples

TRIG:SLOP NEG
trigger:sequence:slope positive

Query Syntax

TRIGger[:SEQuence]:SLOPe?

Return Type

Character

Default

POSitive

TRIGger[:SEQuence]:SOURce <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the source of the sweep trigger signal. This command is a super-set of INITiate:CONTinuous which can NOT set the source to External.

See Triggering the VNA using SCPI.

Parameters

<char>

Choose from:

  • EXTernal - external (rear panel) source.

  • IMMediate - internal source sends continuous trigger signals

  • MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.

Examples

TRIG:SOUR EXT
trigger:sequence:source immediate

Query Syntax

TRIGger[:SEQuence]:SOURce?

Return Type

Character

Default

IMMediate

TRIGger[:SEQuence]:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the type of EXTERNAL trigger input detection used to listen for signals on the Meas Trig IN connectors. Edge triggers are most commonly used.
Parameters |
<char> | Choose from: EDGE VNA responds to the rising and falling edge of a signal. LEVel VNA responds to a level (HIGH or LOW). Use TRIG:SLOPe to specify Rising or falling - High or Low.
Examples | TRIG:TYPE EDGE trigger:sequence:type level
Query Syntax | TRIGger[:SEQuence]:TYPE?
Return Type | Character
Default | LEVel

Last modified:

6-Jan-2016

First Release


Equation

Calculate:Equation Commands

Controls Equation Editor capabilities.

CALCulate:EQUation:

LIBRary

| FUNCtions

| IMPort?

| REMove

STATe

TEXT

VALid?

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Equation Editor

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate:EQUation:LIBRary:FUNCtions <string>

Applicable Models: E5080A, M9485A

(Read-only) Returns the functions in the specified DLL.
Parameters |
<string> | Full path and filename of the *.dll to be read.
Examples | functions = CALC:EQU:LIBR:FUNC “Expansion.dll”
Return Type | Comma delimited string of function names.
Default | Not Applicable

CALCulate:EQUation:LIBRary:IMPort <string>

Applicable Models: E5080A, M9485A

(Read-Write) Imports the functions in the specified DLL and returns whether the functions have been imported into the VNA.
Parameters |
<string> | Full path and filename of the *.dll.
Examples | 'Write - Imports functions CALC:EQU:LIBR:IMPort “D:\Expansion.dll” 'Read if Imported functions = CALC:EQU:LIBR:IMPort “D:\Expansion.dll”
Query Syntax | CALCulate:EQUation:LIBRary:IMPort? Returns the following: 1 - Imported 0 - NOT imported
Return Type | Boolean
Default | Not Applicable

CALCulate:EQUation:LIBRary:REMove <string>

Applicable Models: E5080A, M9485A

(Write-only) Removes an imported an Equation Editor DLL from the VNA.
Parameters |
<string> | Full path and filename of the *.dll.
Examples | CALC:EQU:LIBR:REM “D:\Expansion.dll”
Query Syntax | Not Applicable
Default | Not Applicable

CALCulate<cnum>:EQUation[:STATe] <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON and OFF the equation on selected measurement for the specified channel. If the equation is not valid, then processing is not performed. Use CALC:EQU:VAL? to ensure that the equation is valid. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | ON or 1 - turns equation ON. OFF or 0 - turns equation OFF.
Examples | CALC:EQU 1 calculate2:equation:state 0
Query Syntax | CALCulate<cnum>:EQUation[:STATe]?
Return Type | Boolean
Default | OFF (0)

CALCulate<cnum>:EQUation:TEXT <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies an equation or expression to be used on the selected measurement for the specified channel. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<string> | Any valid equation or expression. See Equation Editor.
Examples | 'Equation (includes '=') CALC:EQU:TEXT "foo=S11/S21" 'Expression calculate2:equation:text "S11/S21"
Query Syntax | CALCulate<cnum>:EQUation:TEXT?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:EQUation:VALid?

Applicable Models: E5080A, M9485A

(Read-Only) Returns a boolean value to indicate if the current equation on the selected measurement for the specified channel is valid. For equation processing to occur, the equation must be valid and ON (CALC:EQU:STAT 1). See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:EQU:VAL? calculate2:equation:valid?
Return Type | Boolean 1 - equation is valid 0 - equation is NOT valid
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


Channels, Windows, and Measurements using SCPI

SOURce and most SENSe commands act on the channel that is specified in the command. Channel 1 is default if not specified.

Most DISPlay commands act on the window and trace specified in the command. Window1 and Trace1 are default if not specified.

CALCulate:MEASure commands act on the trace in the specified channel.

  • CALCulate<channel number>:MEASure<meas number(trace number)>:xxxxxxx

The following program does the following:

  • Presets the analyzer

  • Create 2 windows

  • Create 2 Measurements

  • Change frequency ranges for channels

  • Turn marker 1 ON for each measurement

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

Example

GPIB.Write "SYSTem:PReset"

'Create two windows
GPIB.Write ":DISPlay:SPLit 2"

'Create one trace on each window
GPIB.Write ":CALCulate1:PARameter:COUNt 1"
GPIB.Write ":CALCulate2:PARameter:COUNt 1"

'Define the parameter for each trace
GPIB.Write ":CALCulate1:MEASure1:PARameter 'S21'"
GPIB.Write ":CALCulate2:MEASure2:PARameter 'S12'"

'Change each channel's frequency range
GPIB.Write "SENSe1:FREQuency:SPAN 1e9"
GPIB.Write "SENSe2:FREQuency:SPAN 2e9"

'Turn marker 1 ON for each measurement
GPIB.Write "CALCulate1:MEASure1:MARKer:STATe ON"
GPIB.Write "CALCulate2:MEASure2:MARKer:STATe ON"


Create a Measurement using SCPI

This VBScript program creates a new S21 measurement and displays it on the VNA screen.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the VNA. To do this, copy the following code into a text editor file such as Notepad and save it on the VNA hard drive as NewMeas.vbs. Learn how to setup and run the macro.

See Other SCPI Example Programs

Example

Dim app
Dim scpi
' Create / Get the VNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' A comment
'Preset the analyzer
scpi.Execute ("SYST:PREset")
'Define a measurement parameter
scpi.Execute ("CALCulate:MEASure1:PARameter 'S21'")


Getting and Putting Data using SCPI

This Excel VBA Program with VISA-COM does the following:

  • Reads data from the analyzer

  • Puts the data back into memory

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

Note: To change the read and write location of data, removing the comment from the beginning of ONE of the lines, and replace the comment in the beginning of the FDATA lines.

Sub SampleGetPutData()
'*** The variables of the resource manager and the instrument I/O are declared.
Dim ioMgr As VisaComLib.ResourceManager
Dim GPIB As VisaComLib.FormattedIO488
'*** The memory area of the resource manager and the instrument I/O are acquired.
Set ioMgr = New VisaComLib.ResourceManager
Set GPIB = New VisaComLib.FormattedIO488
'*** Open the instrument.
Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")
GPIB.IO.timeout = 10000

Dim Numpts As Long
Dim Datam As Variant

'Select the measurement
GPIB.WriteString "CALCulate1:MEASure1:PARameter 'S21'", True
'Read the number of data points
GPIB.WriteString "SENSe1:SWEep:POINts?", True
Numpts = GPIB.ReadNumber
'Turn continuous sweep off
GPIB.WriteString "INITiate:CONTinuous OFF", True
'Take a sweep
GPIB.WriteString "INITiate1:IMMediate;*WAI", True
'Ask for the Data
'PICK ONE OF THESE LOCATIONS TO READ
GPIB.WriteString "CALCulate1:MEASure1:DATA:FDATA?", True ' Formatted Meas
'GPIB.WriteString "CALCulate1:MEASure1:DATA:FMEM?", True ' Formatted Memory
'GPIB.WriteString "CALCulate1:MEASure1:DATA:SDATA?", True ' Corrected, Complex Meas
'GPIB.WriteString "CALCulate1:MEASure1:DATA:SMEM?", True ' Corrected, Complex Memory
'GPIB.WriteString "SENSe1:CORRection:CSET:ETERm:DATA? 'Directivity(1,1)'", True ' Error-Term Directivity

'Parse the data
Datam = GPIB.ReadList(ASCIIType_R8, ",")

'PUT THE DATA BACK IN
GPIB.WriteString "CALCulate1:MEASure1:DATA:FDATA ", False ' Formatted Meas
'GPIB.WriteString "CALCulate1:MEASure1:DATA:FMEM ", False ' Formatted Memory
'GPIB.WriteString "CALCulate1:MEASure1:DATA:SDATA ", False ' Corrected, Complex Meas
'GPIB.WriteString "CALCulate1:MEASure1:DATA:SMEM ", False ' Corrected, Complex Memory
'GPIB.WriteString "SENSe1:CORRection:CSET:ETERm:DATA 'Directivity(1,1)',", False ' Error-Term Directivity

GPIB.WriteList Datam, ASCIIType_R8, ",", True

'*** End procedure
GPIB.IO.Close
End Sub


Perform Guided ECal

Perform Guided ECal using SCPI

This VBScript program performs a Guided ECal Calibration. While this example is good to use as a starting point for Guided ECal, the Guided comprehensive cal example has some advanced features that are not in this program.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the VNA. To do this, copy the following code into a text editor file such as Notepad and save it on the VNA hard drive as Guided.vbs. Learn how to setup and run the macro.

Example in VBScript

' Performing a 2-port cal (Ports 1 and 2)
Dim app
Dim scpi

' Create / Get the VNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' Specify the DUT connectors
' (for each connector of your DUT, one of the ECal module's ports must have
' that same connector, or else you cannot achieve the cal using that module).
scpi.Execute "sens:corr:coll:guid:conn:port1 ""APC 3.5 female"" "
scpi.Execute "sens:corr:coll:guid:conn:port2 ""APC 3.5 male"" "

' Note: If your VNA has more than 2 ports, you would need to uncomment
' one or both of these next two lines, to explicitly specify this is
' just a 2-port cal.
'scpi.Execute "sens:corr:coll:guid:conn:port3 ""Not used"" "
'scpi.Execute "sens:corr:coll:guid:conn:port4 ""Not used"" "
MsgBox "Connectors defined for Ports 1 and 2"

' Specify ECal modules

scpi.Parse "sens:corr:coll:guid:ckit:port1 'N4691-60004 ECal'"

scpi.Parse "sens:corr:coll:guid:ckit:port2 'N4691-60004 ECal'"

' Non-factory characterizations are specified as follows:

'scpi.Parse "sens:corr:coll:guid:ckit:port2 'N4691-60004 User 1 ECal'"

' When two or more ECal modules with the same model number are connected

' also specify the serial number as follows:

'scpi.Parse "sens:corr:coll:guid:ckit:port2 'N4691-60004 ECal 01234'"

' When Disk Memory ECal user characterizations are used,

' specify both the User char and the serial number as follows:

'scpi.Parse "sens:corr:coll:guid:ckit:port2 'N4691-60004 MyDskChar ECal 01234'"

'
MsgBox "Cal kits defined for Ports 1 and 2"

' Initiate the calibration and query the number of steps
scpi.Execute "sens:corr:coll:guid:init"
numSteps = scpi.Execute("sens:corr:coll:guid:steps?")
MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards
For i = 1 To numSteps
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = scpi.Execute("sens:corr:coll:guid:desc? " + CStr(i))
MsgBox strPrompt, vbOKOnly, step
scpi.Execute "sens:corr:coll:guid:acq STAN" + CStr(i)
Next

' Conclude the calibration
scpi.Execute "sens:corr:coll:guid:save"
MsgBox "Cal is done!"

Example in Excel VBA

Sub SampleEcal()

'*** The variables of the resource manager and the instrument I/O are declared.

Dim ioMgr As VisaComLib.ResourceManager

Dim GPIB As VisaComLib.FormattedIO488

'

' *** The memory area of the resource manager and the instrument I/O are acquired.

Set ioMgr = New VisaComLib.ResourceManager

Set GPIB = New VisaComLib.FormattedIO488

'*** Open the instrument.

Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")

GPIB.IO.timeout = 10000

' Performing a 2-port cal (Ports 1 and 2)

' Specify the DUT connectors

' (for each connector of your DUT, one of the ECal module's ports must have

' that same connector, or else you cannot achieve the cal using that module).

GPIB.WriteString "sens:corr:coll:guid:conn:port1 ""APC 3.5 female""", True

GPIB.WriteString "sens:corr:coll:guid:conn:port2 ""APC 3.5 female""", True

GPIB.WriteString "sens:corr:coll:guid:conn:port3 ""Not used"""

GPIB.WriteString "sens:corr:coll:guid:conn:port4 ""Not used"""

MsgBox "Connectors defined for Ports 1 and 2"

' Specify ECal modules

' SENSe:CORR:COLL:GUID:CKIT:CAT? to read the list of available Ecal module.

GPIB.WriteString "sens:corr:coll:guid:ckit:port1 'N4431B ECal 03605'", True

GPIB.WriteString "sens:corr:coll:guid:ckit:port2 'N4431B ECal 03605'", True

'

MsgBox "Cal kits defined for Ports 1 and 2"

' Initiate the calibration and query the number of steps

GPIB.WriteString "sens:corr:coll:guid:init", True

GPIB.WriteString "sens:corr:coll:guid:steps?", True

numSteps = GPIB.ReadNumber

MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards

For i = 1 To numSteps

step = "Step " + CStr(i) + " of " + CStr(numSteps)

GPIB.WriteString "sens:corr:coll:guid:desc? " & CStr(i), True

strPrompt = GPIB.ReadString

MsgBox strPrompt, vbOKOnly, step

GPIB.WriteString "sens:corr:coll:guid:acq STAN" & CStr(i), True

Next

' Conclude the calibration

GPIB.WriteString "sens:corr:coll:guid:save", True

MsgBox "Cal is done!"

'*** End procedure

GPIB.IO.Close

End Sub

Last modified:

5-Apr-2011

edited for ECal options


Perform Guided Mechanical Cal

Perform Guided Mechanical Cal using SCPI

This sample programs perform a Guided Calibration using Mechanical standards for a 2-port cal (Ports 1 and 2).

Example in Excel VBA with VISA-COM

Sub SampleGuidedCal2Port()
'*** The variables of the resource manager and the instrument I/O are declared.
Dim ioMgr As VisaComLib.ResourceManager
Dim GPIB As VisaComLib.FormattedIO488
'*** The memory area of the resource manager and the instrument I/O are acquired.
Set ioMgr = New VisaComLib.ResourceManager
Set GPIB = New VisaComLib.FormattedIO488
'*** Open the instrument.
Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")
GPIB.IO.timeout = 10000

Dim numSteps As Integer, strPrompt As String

' Specify the DUT connectors
GPIB.WriteString "sens:corr:coll:guid:conn:port1 ""APC 3.5 female""", True

GPIB.WriteString "sens:corr:coll:guid:conn:port2 ""APC 3.5 male""", True
' Note: If your PNA has more than 2 ports, you would need to uncomment
' one or both of these next two lines, to explicitly specify this is
' just a 2-port cal.
'gpib.writestring "sens:corr:coll:guid:conn:port3 ""Not used"" ",True
'gpib.writestring "sens:corr:coll:guid:conn:port4 ""Not used"" ",True
MsgBox "Connectors defined for Ports 1 and 2"
' Select the Cal Kit for each port being calibrated.
GPIB.WriteString "sens:corr:coll:guid:ckit:port1 ""85052D""", True
GPIB.WriteString "sens:corr:coll:guid:ckit:port2 ""85052D""", True
MsgBox "Cal kits defined for Ports 1 and 2"
' Initiate the calibration and query the number of steps
GPIB.WriteString "sens:corr:coll:guid:init"
GPIB.WriteString "sens:corr:coll:guid:steps?"
numSteps = GPIB.ReadNumber
MsgBox "Number of steps is " + CStr(numSteps)
' Measure the standards
'The following series of commands shows that standards
'can be measured in any order. These steps acquire
'measurement of standards in reverse order.
'It is easiest to iterate through standards using
'a For-Next Loop.
For i = numSteps To 1 Step -1
step = "Step " + CStr(i) + " of " + CStr(numSteps)
GPIB.WriteString "sens:corr:coll:guid:desc? " + CStr(i)
strPrompt = GPIB.ReadString
MsgBox strPrompt, vbOKOnly, step
GPIB.WriteString "sens:corr:coll:guid:acq STAN" + CStr(i), True
Next
' Conclude the calibration
GPIB.WriteString "sens:corr:coll:guid:save", True
MsgBox "Cal is done!"

'*** End procedure
GPIB.IO.Close
End Sub

Example in VB script

The following example is written in VB script.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the VNA. To do this, copy the following code into a text editor file such as Notepad and save it on the VNA hard drive as Guided.vbs. Learn how to setup and run the macro.

Dim app
Dim scpi

' Create / Get the VNA application.
Set app = CreateObject("AgilentPNA835x.Application")
Set scpi = app.ScpiStringParser

' Specify the DUT connectors
scpi.Execute "sens:corr:coll:guid:conn:port1 ""APC 3.5 female"" "
scpi.Execute "sens:corr:coll:guid:conn:port2 ""APC 3.5 male"" "

' Note: If your VNA has more than 2 ports, you would need to uncomment
' one or both of these next two lines, to explicitly specify this is
' just a 2-port cal.
'scpi.Execute "sens:corr:coll:guid:conn:port3 ""Not used"" "
'scpi.Execute "sens:corr:coll:guid:conn:port4 ""Not used"" "
MsgBox "Connectors defined for Ports 1 and 2"

' Select the Cal Kit for each port being calibrated.
scpi.Execute "sens:corr:coll:guid:ckit:port1 ""85052D"" "
scpi.Execute "sens:corr:coll:guid:ckit:port2 ""85052D"" "
MsgBox "Cal kits defined for Ports 1 and 2"

' Initiate the calibration and query the number of steps
scpi.Execute "sens:corr:coll:guid:init"
numSteps = scpi.Execute("sens:corr:coll:guid:steps?")
MsgBox "Number of steps is " + CStr(numSteps)

' Measure the standards
'The following series of commands shows that standards
'can be measured in any order. These steps acquire
'measurement of standards in reverse order.
'It is easiest to iterate through standards using
'a For-Next Loop.
For i = numSteps To 1
step = "Step " + CStr(i) + " of " + CStr(numSteps)
strPrompt = scpi.Execute("sens:corr:coll:guid:desc? " + CStr(i))
MsgBox strPrompt, vbOKOnly, step
scpi.Execute "sens:corr:coll:guid:acq STAN" + CStr(i)
Next

' Conclude the calibration
scpi.Execute "sens:corr:coll:guid:save"
MsgBox "Cal is done!"

Last Modified:

20-Jan-2007

Added note about any order for steps.


Perform Response Calibration

This program performs an response calibration

Sub SampleResponseCal()
'*** The variables of the resource mGPIBger and the instrument I/O are declared.
Dim ioMgr As VisaComLib.ResourceManager
Dim GPIB As VisaComLib.FormattedIO488
'*** The memory area of the resource mGPIBger and the instrument I/O are acquired.
Set ioMgr = New VisaComLib.ResourceManager
Set GPIB = New VisaComLib.FormattedIO488
'*** Open the instrument.
Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")
GPIB.IO.timeout = 10000

GPIB.WriteString "SYSTem:PRESet", True
'Select the measurement
GPIB.WriteString "CALCulate1:MEASure1:PARameter 'S21'", True
'Set the number of trace
GPIB.WriteString "CALCulate1:PARameter:MNUMber 1", True

'Set the calibration method
GPIB.WriteString "SENSe:CORRection:COLLect:METHod RESPonse", True
'Select a cal kit
GPIB.WriteString "SENSe:CORRection:COLLect:CKIT:SELect 1", True

'Measure the thru standard
MsgBox "Connect THRU between Ports 1 and 2; then press OK"
GPIB.WriteString "SENSe:CORRection:COLLect:ACQuire stan4", True

'All standards have been measured. Save the result
GPIB.WriteString "SENS:CORR:COLL:SAVE", True

'*** End procedure
GPIB.IO.Close
End Sub.


Setup Sweep Parameters using SCPI

This Visual Basic program sets up sweep parameters on the Channel 1 measurement.

To run this program, you need:

  • An established GPIB interface connection

See Other SCPI Example Programs

GPIB.Write "SYSTem:PRESet"
'Select the measurement
GPIB.Write "CALCulate:MEASure1:PARameter 'S21'"
'Set sweep type to linear
GPIB.Write "SENSe1:SWEep:TYPE LIN"

'Set IF Bandwidth to 700 Hz
GPIB.Write "SENSe1:BANDwidth 700"

'Set Center and Span Freq's to 4 GHz
GPIB.Write "SENSe1:FREQuency:CENTer 4ghz"
GPIB.Write "SENSe1:FREQuency:SPAN 4ghz"

'Set number of points to 801
GPIB.Write "SENSe1:SWEep:POINts 801"

'Set sweep generation mode to Auto (Analog)
GPIB.Write "SENSe1:SWEep:GENeration ANAL"

'Set sweep time to Automatic
GPIB.Write "SENSe1:SWEep:TIME:AUTO ON"

'Query the sweep time
GPIB.Write "SENSe1:SWEep:TIME?
SweepTime = GPIB.Read


Triggering the VNA using SCPI

To understand how to trigger the VNA using SCPI, it is very important to understand the VNA trigger model. Here is a very simple explanation. These three separate functions control VNA triggering:

  1. Trigger:Source - Where the trigger signals originate:

    • Internal Continuous

    • Internal Manual (Single)

    • External - a trigger source that is connected to the VNA rear panel.

  2. Trigger:Scope - what gets triggered:

    • Global - each signal triggers all channels in turn.

    • Channel - each signal triggers ONE channel.

  3. Channel settings (Sense<ch>:Sweep:Mode) How many triggers will each channel accept before going into hold.

    • HOLD - channel will not trigger.

    • CONTinuous - channel triggers indefinitely.

    • GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>.

    • SINGle - channel accepts ONE trigger, then goes to HOLD.

    • Point trigger SENS1:SWE:TRIG:POINt

When controlling the VNA using SCPI, a SINGLE trigger is used to ensure that a complete sweep is taken. This example demonstrates how to Single trigger the VNA using the following two methods:

  • Simplest Triggering

    • This method uses the default Trigger Source = Internal to send a stream of trigger signals.

    • The channel is configured to ACCEPT only a single trigger signal, then HOLD (Sense<ch>:Sweep:Mode SINGle). This is the ONLY required command.

    • This method can also be used when an External trigger source sends a continuous stream of trigger signals.

  • Advanced Triggering

    • This method SENDS a single trigger from the Source, which can be from either Internal (using INIT:IMM) or External triggering.

    • Each channel is configured to accept an unlimited number of triggers. This method is the only way to perform point triggering.

    • When you require some channels to accept continuous triggers and other channels to accept single triggers, see INIT:IMM Advanced to learn how.

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the VNA. To do this, copy the following code into a text editor file such as Notepad and save it on the VNA hard drive as Trigger.vbs. Learn how to setup and run the macro.

Measurement setup example: This section of code can be used at the start of both methods. It sets up:

  • S11 traces on two channels

  • 10 data points

  • Sweep time of 2 seconds - this is slow enough to allow us to watch as each trace is triggered.

Sub SampleTrigger()

'

' *** The memory area of the resource manager and the instrument I/O are acquired.

Set ioMgr = New VisaComLib.ResourceManager

Set GPIB = New VisaComLib.FormattedIO488

'*** Open the instrument.

Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")

GPIB.IO.timeout = 10000

'Preset the analyzer

GPIB.WriteString "SYST:PReset", True

GPIB.WriteString ":DISPlay:SPLit 2", True

'Create one trace on each window

GPIB.WriteString ":CALCulate1:PARameter:COUNt 1", True

GPIB.WriteString ":CALCulate2:PARameter:COUNt 1", True

'Define the parameter for each trace

GPIB.WriteString ":CALCulate1:MEASure1:PARameter 'S11'", True

GPIB.WriteString ":CALCulate2:MEASure2:PARameter 'S22'", True

'set number of points to 10

GPIB.WriteString "SENS1:SWE:POIN 10", True

GPIB.WriteString "SENS2:SWE:POIN 10", True

'Set slow sweep so we can see

GPIB.WriteString "SENS1:SWE:TIME 2", True

GPIB.WriteString "SENS2:SWE:TIME 2", True

'================================

' Put both channels in Hold

GPIB.WriteString "SENS1:SWE:MODE HOLD", True

GPIB.WriteString "SENS2:SWE:MODE HOLD", True

'================================

'Pick Single Send or Single Accept

resp = MsgBox("Single Send? - Click No for Single Accept", vbYesNo, "VNA Trigger Demo")

If resp = vbYes Then

SingleSend

Else

SingleAccept

End If

'*** End procedure

GPIB.IO.Close

End Sub

Simple Triggering The following example sends a continuous stream of trigger signals and each VNA channel is set to ACCEPT only a signal trigger signal, then HOLD.

  • This example can be used to configure External triggering where the trigger source sends a continuous stream of trigger signals. Configure the type of trigger signal that the VNA responds to using the CONTrol:SIGNal command. The command in this example sets the VNA to respond to HIGH TTL signals at the rear-panel BNC1 trigger IN connector. This command also automatically sets Trigger Source to External Trigger.

  • The TRIG SCOPE (Global or Channel) setting is NOT necessary with a continuous stream of trigger signals. The example program directly controls when each channel is triggered.

  • Point triggering can NOT be used with a continuous stream of trigger signals because in point triggering the channel will accept as many triggers as necessary to complete ONE full sweep. Use the single SEND example for point triggering.

Sub SingleAccept()

'PNA sends continuous trigger signals

GPIB.WriteString "TRIG:SOUR IMMediate", True

'Uncomment the following to set External triggering

'gpib.writestring"CONT:SIGN BNC1,TILHIGH", true

AcceptOne

End Sub

Sub AcceptOne()

'The following command makes the channel immediately sweep

GPIB.WriteString "SENS1:SWE:MODE SINGle", True

'*OPC? allows the measurement to complete before the controller sends another command

GPIB.WriteString "*OPC?", True

Dmy = GPIB.ReadNumber

' You could do something to ch2 here before sweeping it

GPIB.WriteString "SENS2:SWE:MODE SINGle;*OPC?", True

Dmy = GPIB.ReadNumber

resp = MsgBox("Another trigger?", vbOKCancel, "VNA Trigger Demo")

If resp = vbOK Then

AcceptOne

End If

End Sub

Advanced Trigger This example section performs Single Send triggering. Here, single triggering is accomplished by SENDING one trigger signal from the Trigger source and each channel is setup to accept unlimited trigger signals. See the INIT:IMM command for more details.

  • Using this method, it is possible to change Trigger:Scope to Global or Channel. Set trigger scope to channel if there is some code to execute between channel measurements. Similarly, this method can be used to set Point triggering. Use this method if there is some code to execute between data point measurements.

  • In addition, this method can also be used to perform External triggering if the external trigger source is capable of SENDING single triggers. See the CONTrol:SIGNal command to set the type of signal to which the VNA will respond.

  • If the external source can only send a continuous stream of trigger signals, then the Single Accept section must be used.

Sub SingleSend()

'Set Source Internal - Manual Triggering

GPIB.WriteString "TRIG:SOUR MANual", True

'If using an External trigger source that is capable of

'sending SINGLE trigger signals, then uncomment the following.

'This command automatically sets trigger source to External

' gpib.writestring"CONT:SIGN BNC1,TILHIGH", true

'Setup Trigger Scope

'WHAT gets triggered

'Pick one using comments

'Set Channel triggering

' gpib.writestring"TRIG:SCOPe CURRent", true

'Set Global triggering (Default)

GPIB.WriteString "TRIG:SCOPe ALL", True

'Set Channel Settings

'The channels respond to UNLIMITED trigger signals (Default)

GPIB.WriteString "SENS1:SWE:MODE CONTinuous", True

GPIB.WriteString "SENS2:SWE:MODE CONTinuous", True

'To do Point trigger on one or more channels, uncomment the following.

'Point trigger automatically sets Trig:Scope to Current/Channel

' gpib.writestring"SENS1:SWE:TRIG:POINt ON", true

' gpib.writestring"SENS2:SWE:TRIG:POINt ON", true

IntTrig

End Sub

Sub IntTrig()

'If External triggering, replace this Sub with code

'to single trigger the External Trig Source

'*OPC? allows the measurement to complete before the controller sends another command

GPIB.WriteString "INITiate:IMMediate;*OPC?", True

Dmy = GPIB.ReadNumber

resp = MsgBox("Another trigger?", vbOKCancel, "VNA Trigger Demo")

If resp = vbOK Then

IntTrig

End If

End Sub

Last modified:

2016-01-06

First release


Upload and Download a Segment List

This program creates two segments, then uploads the segment data to the VNA.

The second part downloads the segment list from the VNA.

See all Segment SCPI commands.

Create and Upload a Segment List

Example in Excel VBA with VISA-COM

Sub SampleSegmentSetup()
'*** The variables of the resource manager and the instrument I/O are declared.
Dim ioMgr As VisaComLib.ResourceManager
Dim GPIB As VisaComLib.FormattedIO488
'
' *** The memory area of the resource manager and the instrument I/O are acquired.
Set ioMgr = New VisaComLib.ResourceManager
Set GPIB = New VisaComLib.FormattedIO488
'*** Open the instrument.
Set GPIB.IO = ioMgr.Open("GPIB0::16::INSTR")
GPIB.IO.timeout = 10000

Dim Buf As String * 100
Dim srcPortNames As Variant
Dim numberOfSrcPorts As Integer
Dim segData As Variant
Const numSegs = 2
Const Chan = 1
Const addIFBW_PWR = 0
' In case of a measurement receiver VNA like N5264A
' which has no source ports, "SOURce:CATalog?" will
' return an empty list (just a pair of quotation marks)
GPIB.WriteString "SOURce:CATalog?", True
Buf = GPIB.ReadString
srcPortNames = Split(Buf, ",")
If Left(srcPortNames(0), 2) = Chr(34) & Chr(34) Then
numberOfSrcPorts = 0
Else
numberOfSrcPorts = UBound(srcPortNames) + 1
End If
' Building up a string consisting of the sweep segment data
' we want to set up. This example will create two segments.
' Set state of first segment to be ON (1 = ON, 0 = OFF),
' 101 points, start freq of 10 MHz, stop freq of 1 GHz
segData = "1,101,10E6,1E9"
' If you want to include one or more of: IFbandwidth, Dwell Time
' or Port Power, set Const addIFBW_PWR = 1

If addIFBW_PWR = 1 Then
GPIB.WriteString "SENSe" & Chan & ":SEGMent:BWIDth:CONTrol ON"
GPIB.WriteString "SENSe" & Chan & ":SEGMent:SWEep:TIME:CONTrol ON"
GPIB.WriteString "SENSe" & Chan & ":SEGMent:POWer:CONTrol ON"
' Turning off coupling allows power to vary per each port
GPIB.WriteString "SOURce" & Chan & ":POWer:COUPle OFF"
segData = AddOptionalSettings(segData, numberOfSrcPorts)
End If

' Set state of second segment to be ON, 201 points,
' start freq of 1 GHz, stop freq of 3 GHz

segData = segData & ",1,201,1E9,3E9"

' Uncomment this line below only if you uncommented the
' AddOptionalSettings line above for the first segment.
'segData = AddOptionalSettings(segData, numberOfSrcPorts)
' Upload our segment list to the channel
GPIB.WriteString "SENSe1:SEGMent:LIST SSTOP," & numSegs & "," & segData
' Set segment sweep type on Channel 1
GPIB.WriteString "SENSe1:SWEep:TYPE SEGment"
' Having the PNA display the segment sweep table for the channel
GPIB.WriteString "DISPlay:WINDow1:TABLe SEGMent"

'*** End procedure
GPIB.IO.Close
End Sub
Function AddOptionalSettings(ByVal pStr As String, ByVal numSrcPorts As Integer) As String
Dim i

' Specifying 1 kHz IF bandwidth and Dwell Time of 0
pStr = pStr & ", 1E3, 0"
' -10 dBm power for each of the source ports
For i = 0 To numSrcPorts - 1
pStr = pStr & ",-10"
Next
AddOptionalSettings = pStr
End Function

Example in VBScript

The SCPI commands in this example are sent over a COM interface using the SCPIStringParser object. You do NOT need a GPIB connection to run this example.

This VBScript (*.vbs) program can be run as a macro in the VNA. To do this, copy the following code into a text editor file such as Notepad and save it on the VNA hard drive as Unguided.vbs. Learn how to setup and run the macro.

Option Explicit

Dim app

Set app = CreateObject("AgilentPNA835x.Application")

' Preset the VNA

app.Preset

Dim scpi

Set scpi = app.ScpiStringParser

' In case of a measurement receiver VNA like N5264A

' which has no source ports, "SOURce:CATalog?" will

' return an empty list (just a pair of quotation marks)

Dim srcPortNames

srcPortNames = Split( scpi.Execute("SOURce:CATalog?"), ",")

Dim numberOfSrcPorts

If Left( srcPortNames(0), 2 ) = Chr(34) & Chr(34) Then

numberOfSrcPorts = 0

Else

numberOfSrcPorts = UBound(srcPortNames) + 1

End If

' Building up a string consisting of the sweep segment data

' we want to set up. This example will create two segments.

Dim segData

' Set state of first segment to be ON (1 = ON, 0 = OFF),

' 101 points, start freq of 10 MHz, stop freq of 1 GHz

segData = "1,101,10E6,1E9"

' If you want to include one or more of: IFbandwidth, Dwell Time

' or Port Power, remove the comments from these next two lines

'TurnOnOptions 1 'Call the subroutine

'segData = AddOptionalSettings(segData, numberOfSrcPorts)

' Set state of second segment to be ON, 201 points,

' start freq of 1 GHz, stop freq of 3 GHz

segData = segData & ",1,201,1E9,3E9"

' Uncomment this line below only if you uncommented the

' AddOptionalSettings line above for the first segment.

'segData = AddOptionalSettings(segData, numberOfSrcPorts)

Const numSegs = 2

' Upload our segment list to the channel

scpi.Execute "SENSe1:SEGMent:LIST SSTOP," & numSegs & "," & segData

' Set segment sweep type on Channel 1

scpi.Execute "SENSe1:SWEep:TYPE SEGment"

' Having the VNA display the segment sweep table for the channel

scpi.Execute "DISPlay:WINDow1:TABLe SEGMent"

Sub TurnOnOptions(ByVal chan)

scpi.Execute "SENSe"&chan&":SEGMent:BWIDth:CONTrol ON"

scpi.Execute "SENSe"&chan&":SEGMent:SWEep:TIME:CONTrol ON"

scpi.Execute "SENSe"&chan&":SEGMent:POWer:CONTrol ON"

' Turning off coupling allows power to vary per each port

scpi.Execute "SOURce"&chan&":POWer:COUPle OFF"

End Sub

Function AddOptionalSettings(ByVal inStr, ByVal numSrcPorts)

' Specifying 1 kHz IF bandwidth and Dwell Time of 0

inStr = inStr & ",1E3,0"

' -10 dBm power for each of the source ports

Dim i

For i = 0 To numSrcPorts - 1

inStr = inStr & ",-10"

Next

AddOptionalSettings = inStr

End Function

Download a Segment List

This example assumes that the active trace is in Window 1

Option Explicit

Dim app

Set app = CreateObject("AgilentPNA835x.Application")

Dim scpi

Set scpi = app.ScpiStringParser

' Set the display-active channel's sweep type to segment sweep

' (if the VNA's currently active measurement window doesn't

' contain any traces, this querying for active channel will

' result in a SCPI error which scpi.Parse will trap and throw)

Dim chan

chan = CLng( scpi.Parse("SYSTem:ACTive:CHANnel?") )

scpi.Execute "SENSe"&chan&":SWEep:TYPE SEGment"

' Having the VNA display the segment sweep table for the channel

scpi.Execute "DISPlay:WINDow1:TABLe SEGMent"

' Get the total number of segments

Dim numSegs

numSegs = CLng( scpi.Execute("SENSe"&chan&":SEGMent:COUNt?") )

' Read the segment listing

Dim segDataStr

segDataStr = scpi.Execute("SENSe"&chan&":SEGMent:LIST?")

Dim segData

segData = Split(segDataStr, ",")

' Get upper bound of the array of data values

' (lower bound of array resulting from VB 'Split' function is 0)

Dim segArrayUB

segArrayUB = UBound(segData)

Dim numDataElementsPerSeg

numDataElementsPerSeg = (segArrayUB + 1) / numSegs

WScript.Echo "Number of segments = " & numSegs

WScript.Echo "Number of data values per segment = " & numDataElementsPerSeg

Dim segInfStr

segInfStr = "Segment 1: state = " & CBool(segData(0))

segInfStr = segInfStr & ", num points = " & CLng(segData(1))

segInfStr = segInfStr & ", start freq = " & CDbl(segData(2))

segInfStr = segInfStr & ", stop freq = " & CDbl(segData(3))

segInfStr = segInfStr & ", IFBW = " & CDbl(segData(4))

segInfStr = segInfStr & ", dwell time = " & CDbl(segData(5))

' In case of a measurement receiver VNA like N5264A

' which has no source ports, "SOURce:CATalog?" will

' return an empty list

Dim srcPortNames

srcPortNames = Split( scpi.Execute("SOURce"&chan&":CATalog?"), ",")

Dim srcPortNamesUB

srcPortNamesUB = UBound(srcPortNames)

' First source port name will be preceded by a quotation mark

' and the last name will be followed by one of those, so stripping

' those off now.

srcPortNames(0) = Right( srcPortNames(0), Len(srcPortNames(0)) - 1 )

srcPortNames(srcPortNamesUB) = Left( srcPortNames(srcPortNamesUB), InStrRev(srcPortNames(srcPortNamesUB), Chr(34)) - 1 )

Dim firstPortIndex

firstPortIndex = 6

Dim lastPortIndex

lastPortIndex = numDataElementsPerSeg - 1

Dim j

For j = firstPortIndex To lastPortIndex

segInfStr = segInfStr & ", " & srcPortNames(j - firstPortIndex) & " power = " & CDbl(segData(j))

Next

WScript.Echo segInfStr

Last Modified:

29-Apr-2009

MX New topic


GP-IB Fundamentals

The General Purpose Interface Bus (GPIB) is a system of hardware and software that allows you to control test equipment to make measurements quickly and accurately. This topic contains the following information:

  • The GPIB Hardware Components

  • The GPIB / SCPI Programming Elements

  • Specifications

  • GPIB Interface Capability Codes

Note: All of the topics related to programming assume that you already know how to program, preferably using a language that can control instruments.

Other Topics about GPIB Concepts

The GPIB Hardware Components

The system bus and its associated interface operations are defined by the IEEE 488 standard. The following sections list and describe the main pieces of hardware in a GPIB system:

Controllers

Controllers specify the instruments that will be the talker and listener in a data exchange. The controller of the bus must have a GPIB interface card to communicate on the GPIB.

  • The Active Controller is the computer or instrument that is currently controlling data exchanges.

  • The System Controller is the only computer or instrument that can take control and give up control of the GPIB to another computer or instrument, which is then called the active controller.

Talker / Listener Instruments and GPIB Addresses

  • Talkers are instruments that can be addressed to send data to the controller.

  • Listeners are instruments that can be addressed to receive a command, and then respond to the command. All devices on the bus are required to listen.

Every GPIB instrument must have its own unique address on the bus. The VNA address (default = 716) consists of two parts:

  1. The Interface select code (typically 7) indicates which GPIB port in the system controller is used to communicate with the device.

  2. The primary address (16) is set at the factory. You can change the primary address of any device on the bus to any number between 0 and 30. To change the analyzer address click System / Configure / SICL-GPIB.

A secondary address is sometimes used to allow access to individual modules in a modular instrument system, such as a VXI mainframe. The VNA does NOT have a secondary address.

Cables

GPIB Cables are the physical link connecting all of the devices on the bus. There are eight data lines in a GPIB cable that send data from one device to another. There are also eight control lines that manage traffic on the data lines and control other interface operations.

You can connect instruments to the controller in any arrangement with the following limitations:

  • Do not connect more than 15 devices on any GPIB system. This number can be extended with the use of a bus extension.

  • Do not exceed a total of 20 meters of total cable length or 2 meters per device, whichever is less.

  • Avoid stacking more than three connectors on the back panel of an instrument. This can cause unnecessary strain on the rear-panel connector.

The GPIB / SCPI Programming Elements

The following software programming elements combine to become a GPIB program:

  • GPIB / SCPI Commands

  • Programming Statements

  • Instrument Drivers

GPIB Commands

The GPIB command is the basic unit of communication in a GPIB system. The analyzer responds to three types of GPIB commands:

1. IEEE 488.1 Bus-management Commands

These commands are used primarily to tell some or all of the devices on the bus to perform certain interface operations.

All of the functions that can be accomplished with these commands can also be done with IEEE 488.2 or SCPI commands. Therefore, these commands are not documented in this Help system. For a complete list of IEEE 488.1 commands refer to the IEEE 488 standard. Examples of IEEE 488.1 Commands

  • CLEAR - Clears the bus of any pending operations

  • LOCAL - Returns instruments to local operation

2. IEEE 488.2 Common Commands

These commands are sent to instruments to perform interface operations. An IEEE 488.2 common command consists of a single mnemonic and is preceded by an asterisk ( * ). Some of the commands have a query form which adds a "?" after the command. These commands ask the instrument for the current setting. See a complete list of the Common Commands that are recognized by the analyzer. Examples of IEEE 488.2 Common Commands

  • *OPC - Operation Complete

  • *RST - Reset

  • *OPT? - Queries the option configuration

3. SCPI Commands

The Standard Commands for Programmable Instruments (SCPI) is a set of commands developed in 1990. The standardization provided in SCPI commands helps ensure that programs written for a particular SCPI instrument are easily adapted to work with a similar SCPI instrument. SCPI commands tell instruments to do device specific functions. For example, SCPI commands could tell an instrument to make a measurement and output data to a controller. Examples of SCPI Commands:

CALCULATE:AVERAGE:STATE ON

SENSE:FREQUENCY:START?

For more information on SCPI:

  • The Rules and Syntax of SCPI Commands provides more detail of the SCPI command structure.

  • SCPI Command Tree is a complete list of the SCPI commands for the analyzer

Programming Statements

SCPI commands are included with the language specific I/O statements to form program statements. The programming language determines the syntax of the programming statements. SCPI programs can be written in a variety of programming languages such as VEE, HP BASIC, or C++. Example of a Visual Basic statement:

  • GPIB.Write "SOURCE:FREQUENCY:FIXED 1000 MHz"

Note about examples

Instrument Drivers

Instrument drivers are subroutines that provide routine functionality and can be reused from program to program. GPIB industry leaders have written standards for use by programmers who develop drivers. When programmers write drivers that comply with the standards, the drivers can be used with predictable results. To comply with the standard, each instrument driver must include documentation describing its functionality and how it should be implemented.

GPIB Specifications

Interconnected devices - Up to 15 devices (maximum) on one contiguous bus.

Interconnection path - Star or linear (or mixed) bus network, up to 20 meters total transmission path length or 2 meters per device, whichever is less.

Message transfer scheme - Byte-serial, bit-parallel, asynchronous data transfer using an interlocking 3-wire handshake.

Maximum data rate - 1 megabyte per second over limited distances, 250 to 500 kilobytes per second typical maximum over a full transmission path. The devices on the bus determine the actual data rate.

Address capability - Primary addresses, 31 Talk and 31 Listen; secondary addresses, 961 Talk and 961 Listen. There can be a maximum of 1 Talker and up to 14 Listeners at a time on a single bus. See also previous section on GPIB addresses.

GPIB Interface Capability Codes

The IEEE 488.1 standard requires that all GPIB compatible instruments display their interface capabilities on the rear panel using codes. The codes on the analyzer, and their related descriptions, are listed below:

SH1 | full source handshake capability
AH1 | full acceptor handshake capability
T6 | basic talker, serial poll, no talk only, unaddress if MLA (My Listen Address)
TEO | no extended talker capability
L4 | basic listener, no listen only, unaddress if MTA (My Talk Address)
LEO | no extended listener capability
SR1 | full service request capability
RL1 | full remote / local capability
PPO | no parallel poll capability
DC1 | full device clear capability
DT1 | full device trigger capability
C1 | system controller capability
C2 | send IFC (Interface Clear) and take charge controller capability
C3 | send REN (Remote Enable) controller capability
C4 | respond to SRQ (Service Request)

Last Modified:

10-Oct-2014

First Release


The Rules and Syntax of SCPI Commands

The Rules and Syntax of SCPI

Most of the commands used for controlling instruments on the GPIB are SCPI commands. The following sections will help you learn to use SCPI commands in your programs.

  • Branches on the Command Tree

  • Command and Query

  • Multiple Commands

  • Command Abbreviation

  • Bracketed (Optional) Keywords

  • Vertical Bars (Pipes)

  • MIN and MAX Parameters

Other Topics about GPIB Concepts

Branches on the Command Tree

All major functions on the analyzer are assigned keywords which are called ROOT commands. (See GPIB Command Finder for a list of SCPI root commands). Under these root commands are branches that contain one or more keywords. The branching continues until each analyzer function is assigned to a branch. A root command and the branches below it is sometimes known as a subsystem.

For example, under SOURce:POWer are several branch commands.

Sometimes the same keyword, such as STATE, is used in several branches of the command tree. To keep track of the current branch, the analyzer's command parser uses the following rules:

  • Power On and Reset - After power is cycled or after *RST, the current path is set to the root level commands.

  • Message Terminators - A message terminator, such as a <NL> character, sets the current path to the root command level. Many programming language output statements send message terminators automatically. Message terminators are described in Sending Messages to the Analyzer.

  • Colon (:) - When a colon is between two command keywords, it moves the current path down one level in the command tree. For example, the colon in :SOURCE:POWER specifies that POWER is one level below SOURCE. When the colon is the first character of a command, it specifies that the following keyword is a root level command. For example, the colon in :SOURCE specifies that source is a root level command.

Note: You can omit the leading colon if the command is the first of a new program line. For example, the following two commands are equivalent:
SOUR:POW:ATT:AUTO
:SOUR:POW:ATT:AUTO

  • <WSP> - Whitespace characters, such as <tab> and <space>, are generally ignored. There are two important exceptions:

    • Whitespace inside a keyword, such as :CALC ULATE, is not allowed.

    • Most commands end with a parameter. You must use whitespace to separate these ending parameters from commands. Always refer to the command documentation. In the following example, there is whitespace between STATE and ON.

CALCULATE1:SMOOTHING:STATE ON

  • Comma (,) - If a command requires more than one parameter, you must separate adjacent parameters using a comma. For example, the SYSTEM:TIME command requires three values to set the analyzer clock: one for hours, one for minutes, and one for seconds. A message to set the clock to 8:45 AM would be SYSTEM:TIME 8,45,0. Commas do not affect the current path.

  • Semicolon(;) - A semicolon separates two commands in the same message without changing the current path. See Multiple Commands later in this topic.

  • IEEE 488.2 Common Commands - Common commands, such as *RST, are not part of any subsystem. An instrument interprets them in the same way, regardless of the current path setting.

Command and Query

A SCPI command can be an Event command, Query command (a command that asks the analyzer for information), or both. The following are descriptions and examples of each form of command. GPIB Command Finder lists every SCPI command that is recognized by the analyzer, and its form.

Form | Examples
Event commands - cause an action to occur inside the analyzer. | :INITIATE:IMMEDIATE
Query commands - query only; there is no associated analyzer state to set. | :SYSTem:ERRor?
Command and query - set or query an analyzer setting. The query form appends a question mark (?) to the set form | :FORMat:DATA ! Command :FORMat:DATA? ! Query

Multiple Commands

You can send multiple commands within a single program message. By separating the commands with semicolons the current path does not change. The following examples show three methods to send two commands:

  1. Two program messages:

SOURCE:POWER:START 0DBM
SOURCE:POWER:STOP 10DBM

  2. One long message. A colon follows the semicolon that separates the two commands causing the command parser to reset to the root of the command tree. As a result, the next command is only valid if it includes the entire keyword path from the root of the tree:

SOURCE:POWER:START 0DBM;:SOURCE:POWER:STOP 10DBM

  3. One short message. The command parser keeps track of the position in the command tree. Therefore, you can simplify your program messages by including only the keyword at the same level in the command tree.

SOURCE:POWER:START 0DBM;STOP 10DBM

Common Commands and SCPI Commands

You can send Common commands and SCPI commands together in the same message. (For more information on these types of commands see GP-IB Fundamentals.) As in sending multiple SCPI commands, you must separate them with a semicolon.

Example of Common command and SCPI commands together

*RST;SENSE:FREQUENCY:CENTER 5MHZ;SPAN 100KHZ

Command Abbreviation

Each command has a long form and an abbreviated short form. The syntax used in this Help system use uppercase characters to identify the short form of a particular keyword. The remainder of the keyword is lower case to complete the long form.

SOUR - Short form
SOURce - Long form

Either the complete short form or complete long form must be used for each keyword. However, the keywords used to make a complete SCPI command can be a combination of short form and long form.

The following is unacceptable - The first three keywords use neither short or long form.

SOURc:Powe:Atten:Auto on

The following is acceptable - All keywords are either short form or long form.

SOUR:POWer:ATT:AUTO on

In addition, the analyzer accepts lowercase and uppercase characters as equivalent as shown in the following equivalent commands:

source:POW:att:auto ON
Source:Pow:Att:Auto on

Optional [Bracketed] Keywords

You can omit some keywords without changing the effect of the command. These optional, or default, keywords are used in many subsystems and are identified by brackets in syntax diagrams.

Example of Optional Keywords

The HCOPy subsystem contains the optional keyword IMMediate at its first branching point. Both of the following commands are equivalent:

"HCOPY:IMMEDIATE"

"HCOPY"

The syntax in this Help system looks like this:

HCOPy[:IMMediate]

Vertical Bars | Pipes

Vertical bars, or "pipes", can be read as "or". They are used in syntax diagrams to separate alternative parameter options.

Example of Vertical Bars:

SOURce:POWer:ATTenuation:AUTO <on|off>

Either ON or OFF is a valid parameter option.

MIN and MAX Parameters

The special form parameters "MINimum" and "MAXimum" can be used with commands that specify single frequency (Hz) and time (seconds) as noted in the command documentation. Note: Also with these commands, kHZ, MHz, and GHz are accepted as suffixes/units.

The short form (min) and long form (minimum) of these two keywords are equivalent.

  • MAXimum refers to the largest value that the function can currently be set to

  • MINimum refers to the smallest value that the function can currently be set to.

For example, the following command sets the start frequency to the smallest value that is currently possible:

SENS:FREQ:START MIN

In addition, the max and min values can also be queried for these commands.

For example, the following command returns the smallest value that Start Frequency can currently be set to:

SENS:FREQ:START? MIN

An error will be returned if a numeric parameter is sent that exceeds the MAX and MIN values.

For example, the following command will return an "Out of range" error message.

SENS:FREQ:START 1khz

Last Modified:

10-Oct-2014

First Release


How to Configure for Remote Control

Configure for Remote Control

The following settings are used to configure the VNA for remote control using SCPI commands.

How to Configure for SICL / GPIB Operation

Using Hardkey/SoftTab/Softkey

  1. Press System > System Setup > Remote Interface...

SICL / GPIB /SCPI dialog box help

GPIB

Address Sets the VNA address used to send and receive GPIB/SCPI commands to the system controller (external computer).

Use the National Instruments interface or the Keysight (Agilent) Connection Expert interface to change the System Controller address. Use the VNA as the system controller of external devices. Learn about the VNA as controller.

SICL

SICL Enabled When checked, the analyzer is capable of running GPIB programs on its computer to control analyzer functions. The programs must be run from a GPIB-capable programming environment (VEE, Visual Basic). This mode does not allow control of external GPIB instruments. To uncheck this box, exit the VNA application - (Click File, then Exit). The VNA restarts with the SICL enabled box unchecked unless Automatically Enable on Startup is checked.

Learn more about Configuring for VISA and SICL.

Address Sets the VNA address.

Automatically Enable on Startup When checked, SICL Enabled is automatically selected when starting the VNA application.

LAN Sockets/Telnet

Provides ability to communicate with the VNA from a PC that uses a Windows, or non-Windows, operating system.

  • These settings are checked by default. If you have security concerns, clear these check boxes.

  • These settings remain after the VNA is shutdown and restarted.

Sockets Enabled When checked, provides the ability to control the VNA from a remote SCPI program using port number 5025. See the C# example that illustrates how this is done.

Telnet Enabled When checked, provides the ability to send single SCPI commands from a remote Windows, or non-Windows, PC to the VNA using port number 5024.

How to send single SCPI commands using Telnet:

  1. On the remote PC, click Start, then Run

  2. Type: telnet <computer name> 5024
    where <computer name> is the full computer name of the VNA. See how to find the computer name of the VNA.

  3. A Telnet window with a SCPI> prompt should appear on the remote PC screen.

  4. From the SCPI prompt:

    • Type single SCPI commands

    • If an invalid SCPI command is sent, the prompt will disappear. Press Enter or Ctrl C to recover the SCPI prompt.

    • To exit the telnet window click X in the upper-right corner.

    • To get a normal telnet prompt, press Ctrl ] (closing bracket).

    • To close the normal telnet window, type Quit and press Enter.

HiSLIP

HiSLIP has the same functionality as VXI 11 (SICL) with better performance. Therefore, it is enabled by default on the VNA.

Address 0 by default. No change is necessary for the VNA.

On the remote computer, use address string TCPIP0::<hostname>::hislip<address>. ("hislip" is case-sensitive).

SCPI Monitor / Input

Show SCPI Parse Console Launches a window that is used to send single SCPI/GPIB commands.

Note: The Status Register system can NOT be used from the GPIB Console.

  • Type a valid command, with appropriate arguments and press enter.

  • Use the arrow keys to recall previous commands.

  • The console window may launch behind the VNA application. Press Control+Tab to bring the console window to the top.

IO Monitor enables monitoring activity on the remote control.

The menu from Configure button can enable/disable this function.

Enabling the IO monitor provides the detailed error message with debug information.

Example of Error message:

  • On: -109, "Missing parameter; calc:par:def aaa<Err>

  • Off: -109, "Missing parameter"

Disabling the IO monitor makes the measurement speed faster.

Local and Remote Operation

The analyzer LCL and RMT (Local and Remote) operation labels appear in the lower right corner of the status bar.

Note: The status bar is NOT visible when the analyzer is preset. See how to make the status bar visible.

  • LCL appears when NOT under SCPI control

  • RMT appears when under SCPI control. Remote operation disables the front panel keys except for the Macro/Local key.

To return to Local (front panel) operation, press the Macro / Local key

Sending the GPIB "GTL" (go to local) command also returns the analyzer to Local operation.

Sending the GPIB "LLO" (local lockout) command disables the front panel Local button.

Last Modified:

10-Oct-2014 | First Release
5-Mar-2015 | Add PXI


Getting Data from the Analyzer using SCPI

Getting Data from the Analyzer

Data is sent from the analyzer in response to program queries. Data can be short response messages, such as analyzer settings, or large blocks of measurement data. This topic discusses how to read query responses and measurement data from the analyzer in the most efficient manner.

  • Response Message Syntax

  • Clearing the Output Queue

  • Response Data Types

  • Transferring Measurement Data

Note: Some PCs use a modification of the IEEE floating point formats with the byte order reversed. To reverse the byte order for data transfer into a PC, use the FORMat:BORDer command.

Other Topics about GPIB Concepts

Response Message Syntax

Responses sent from the analyzer contain data, appropriate punctuation, and message terminators.

<NL><^END> is always sent as a response message terminator. Most programming languages handle these terminators transparent to the programmer.

Response messages use commas and semicolons as separators in the following situations:

  • a comma separates response data items when a single query command returns multiple values

FORM:DATA? 'Query
ASC, +0 'Analyzer Response

  • a semicolon separates response data when multiple queries are sent within the same messages

SENS:FREQ:STAR?;STOP? --Example Query

+1.23000000000E+008; +7.89000000000E+008<NL><^END> 'Analyzer Response

Clearing the Output Queue

After receiving a query, the analyzer places the response message in its output queue. Your program should read the response immediately after the query is sent. This ensures that the response is not cleared before it is read. The response is cleared when one of the following conditions occur:

  • When the query is not properly terminated with an ASCII carriage return character or the GPIB <^END> message.

  • When a second program query is sent.

  • When a program message is sent that exceeds the length of the input queue

  • When a response message generates more response data than fits in the output queue.

  • When the analyzer is switched ON.

Response Data Types

The analyzer sends different response data types depending on the parameter being queried. You need to know the type of data that will be returned so that you can declare the appropriate type of variable to accept the data. For more information on declaring variables see your programming language manual. The GPIB Command Finder lists every GPIB command and the return format of data in response to a query. The analyzer returns the following types of data:

  • Numeric Data

  • Character Data

  • String Data

  • Block Data

Numeric Data

All numeric data sent over the GPIB is ASCII character data. Your programming environment may convert the character data to numeric data for you. Boolean data (1 | 0 ) is a type of numeric data.

Character Data

Character data consists of ASCII characters grouped together in mnemonics that represent specific analyzer settings. The analyzer always returns the short form of the mnemonic in upper-case alpha characters. Character data looks like string data. Therefore, refer to the GPIB Command Finder to determine the return format for every command that can be queried.

Example of Character Data

MLOG

String Data

String data consists of ASCII characters. String parameters can contain virtually any set of ASCII characters. When sending string data to the analyzer, the string must begin with a single quote ( ' ) or a double quote ( " ) and end with the same character (called the delimiter).

Note: The analyzer responds best to all special characters if the string is enclosed in single quotes. If quotes are not used, the analyzer will convert the text to uppercase. The analyzer may not respond as you expect.

The analyzer always encloses data in double quotes when it returns string data.

Example of String Data

GPIB.Write "DISP:WINDow:TITLe:DATA?"

“This is string response data.”

Block Data

Block data is used to transfer measurement data. Although the analyzer will accept either definite length blocks or indefinite length blocks, it always returns definite length block data in response to queries unless the specified format is ASCII. The following graphic shows the syntax for definite block data:

<num_digits> specifies how many digits are contained in <byte_count>

<byte_count> specifies how many data bytes will follow in <data bytes>

Example of Definite Block Data

#210ABCDE+WXYZ<nl><end>

Where:

# - always sent before definite block data

2 - specifies that the byte count is two digits (2)

10 - specifies the number of data bytes that will follow, not counting <NL><END>

ABCDE+WXYZ - 10 digits of data

<NL><END> - always sent at the end of block data

Transferring Measurement Data

Measurement data is blocks of numbers that result from an analyzer measurement. Measurement data is available from various processing arrays within the analyzer. For more information on the analyzer's data processing flow, see Accessing Data Map. Regardless of which measurement array is read, transferring measurement data is done the same.

See an example.

When transferring measurement data, the FORMat:DATA command allows you to choose from the following two data types:

  • REAL

  • ASCII

The following graphic shows the differences in transfer times between the two:

REAL Data

REAL data (also called floating-point data) types transfer faster. This is because REAL data is binary and takes about half the space of ASCII data. The disadvantage of using REAL data is that it requires a header that must be read. See definite length block data. The binary floating-point formats are defined in the IEEE 754-1985 standard. The following choices are available in REAL format:

  • REAL,32 - IEEE 32-bit format - single precision (not supported by HP BASIC)

  • REAL,64 - IEEE 64-bit format - double precision

ASCII Data

The easiest and slowest way to transfer measurement data is to use ASCII data. ASCII data is sent if the data contains both numbers and characters (the setting of FORMat:DATA is ignored). ASCII data is separated by commas.

Last Modified:

10-Oct-2014

First Release


Synchronizing the VNA and Controller

Synchronizing the VNA and Controller means to keep VNA and the controller working at approximately the same pace. In this topic:

  • The Problem and the Solution

  • VNA Queues

  • Synchronization Methods

  • When To Synchronize the Analyzer and Controller

    • Completion of a Measurement

    • Measurements with External Trigger

    • Averaged Measurements

    • During Calibration Acquire

See Also

  • Synchronize an External PSG Source

  • Triggering the VNA using SCPI

The Problem

The controller sends commands to the VNA as fast as the GPIB bus will allow. The VNA stores these commands in the VNA Input queue. However, the VNA executes those commands at a slower rate than they are accepted. If left unchecked, the VNA input buffer will contain a long list of commands waiting to be executed.

At some point, the controller will send a query command which requires a response from the VNA. The controller will not send more commands until a response is received. It will wait for a response from the VNA for the amount of time set by the Timeout setting. If the VNA is working off a long list of commands in the input buffer, if may not execute and respond to the query command until the controller has quit waiting, or "timed out".

The Solution

The easiest way to keep the controller and the VNA "synched" is to send query commands often. This stops the controller from sending more commands until the VNA executes and responds to the query. This limits the number of commands that are waiting in the VNA input queue to be processed.

Although any query will stop the controller from sending more commands, a good practice is to send *OPC? Most of the time, as soon as this query is executed, the VNA will immediately reply. The exception to this is the Overlapped command.

  • Sequential commands are executed quickly and in the order in which they are received.

  • Overlapped (also known as Asynchronous) commands take longer to execute. Therefore, they allow the VNA to execute other commands while waiting. However, the programmer may want to prevent the analyzer from processing new commands until the overlapped command has completed. If the VNA is executing an overlapped command when a *OPC? is received, it will wait until the overlapped command is complete before processing new commands.

Note: The analyzer has two overlapped commands:

  • INITitate:IMMediate

  • SENSe:SWEep:MODE GROUPS (when INIT:CONT is ON)

Several calibration commands have an optional ASYNcronous argument which allows them to behave like overlapped commands. Learn more.

Analyzer Queues

Queues are memory buffers that store messages until they can be processed. The analyzer has the following queues:

  • Input Queue

  • Output Queue

  • Error Queue

Input Queue

The controller sends statements to the analyzer without regard to the amount of time required to execute the statements. The input queue is very large (31k bytes). It temporarily stores commands and queries from the controller until they are read by the analyzer's command parser. The input queue is cleared when the analyzer is switched ON.

Output Queue

When the analyzer parses a query, the response is placed in the output queue until the controller reads it. Your program should immediately read the response or it may be cleared from the output queue. The following conditions will clear a query response:

  • When a second query is sent before reading the response to the first. This does not apply when multiple queries are sent in the same statement.

  • When a program statement is sent that exceeds the length of the input queue.

  • When a response statement generates more data than fits in the output queue.

  • When the analyzer is switched ON.

Error Queue

Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Synchronization Methods

The following common commands are used to synchronize the analyzer and controller. Examples are included that illustrate the use of each command in a program. See the SCPI command details to determine if a command is an overlapped command.

  • *WAI

  • *OPC?

  • *OPC

*WAI

The *WAI command:

  • Stops the analyzer from processing subsequent commands until all overlapped commands are completed.

  • It does NOT stop the controller from sending commands to this and other devices on the bus. This is the easiest method of synchronization.

Example of the *WAI command

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "CALCULATE:MARKER:SEARCH:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?

The following time line shows how the processing times of the three commands relate to each other:

INITIATE:IMMEDIATE is an overlapped command. It allows the immediate processing of the sequential command, CALCULATE:MARKER:SEARCH:MAXIMUM. However, the INITIATE:IMMEDIATE is not considered complete until the measurement is complete. Therefore, the marker searches for maximum amplitude before the measurement completes. The CALCULATE:MARKER:X? query could return an inaccurate value.

To solve the problem, insert a *WAI command.

GPIB.Write "ABORT;:INITIATE:IMMEDIATE" 'Restart the measurement.
GPIB.Write "*WAI" 'Wait until complete.
GPIB.Write "CALCULATE:MARKER:MAXIMUM" 'Search for max amplitude.
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency

The time line now looks like this:

The *WAI command keeps the MARKER:SEARCH:MAXIMUM from taking place until the measurement is completed. The CALCULATE:MARKER:X? query returns the correct value.

Note: Although *WAI stops the analyzer from processing subsequent commands, it does not stop the controller. The controller could send commands to other devices on the bus.

*OPC?

The *OPC? query stops the controller until all pending commands are completed.

In the following example, the Read statement following the *OPC? query will not complete until the analyzer responds, which will not happen until all pending commands have finished. Therefore, the analyzer and other devices receive no subsequent commands. A "1" is placed in the analyzer output queue when the analyzer completes processing an overlapped command. The "1" in the output queue satisfies the Read command and the program continues.

Example of the *OPC? query

This program determines which frequency contains the maximum amplitude.

GPIB.Write "ABORT; :INITIATE:IMMEDIATE"! Restart the measurement
GPIB.Write "*OPC?" 'Wait until complete
Meas_done = GPIB.Read 'Read output queue, throw away result
GPIB.Write "CALCULATE:MARKER:MAX" 'Search for max amplitude
GPIB.Write "CALCULATE:MARKER:X?" 'Which frequency?
Marker_x = GPIB.Read
PRINT "MARKER at " & Marker_x & " Hz"

*OPC

The *OPC command allows the analyzer and the controller to process commands while processing the overlapped command.

When the analyzer completes processing an overlapped command, the *OPC command sets bit 0 of the standard event register to 1 . This requires polling of status bytes or use of the service request (SRQ) capabilities of your controller. See Reading the Analyzer's Status Registers for more information about the standard event status register, generating SRQs, and handling interrupts.

Note: Be careful when sending commands to the analyzer between the time you send *OPC and the time you receive the interrupt. Some commands could jeopardize the integrity of your measurement. It also could affect how the instrument responds to the previously sent *OPC.

Example of polled bit and SRQ processes.

When To Synchronize the Analyzer and Controller

The need to synchronize depends upon the situation in which the overlapped command is executed. The following section describes situations when synchronization is required to ensure a successful operation.

  • Completion of a Measurement

  • Measurements with External Trigger

  • Averaged Measurements

Completion of a Measurement

To synchronize the analyzer and controller to the completion of a measurement, use the ABORT;INITIATE:IMMEDIATE command sequence to initiate the measurement.

This command sequence forces data collection to start (or restart) under the current measurement configuration. A restart sequence, such as ABORT;INITIATE:IMMEDIATE is an overlapped command. It is complete when all operations initiated by that restart command sequence, including the measurement, are finished. The *WAI,*OPC? and *OPC commands allow you to determine when a measurement is complete. This ensures that valid measurement data is available for further processing.

Measurements with External Trigger

See Triggering the VNA using SCPI.

External Triggering

Averaged Measurements

Averaged measurements are complete when the average count is reached. The average count is reached when the specified number of individual measurements is combined into one averaged measurement result. Use synchronization to determine when the average count has been reached.

If the analyzer continues to measure and average the results after the average count is reached, use synchronization to determine when each subsequent measurement is complete.

During Calibration Acquire

During a calibration with slow sweep speeds, such as when using a narrow IF bandwidth, you may want to have your program perform other operations, such as checking for the click event of a Cancel button.

To do this, use the optional ASYNchronous argument with the ACQuire command as shown in several calibration example programs. The VNA parser returns immediately while the cal step measurement proceeds. It does NOT block commands and wait for the measurement step to finish. You can send *ESR? or *STB? queries to monitor the status register bytes to see when the OPC (operation complete) bit gets set, which indicates the cal measurement step has finished. Learn more about status registers.

Note: Do NOT issue the *OPC? command when using the ASYN argument. If your program is using the ScpiStringParser, then you can ONLY use *OPC? to detect when the OPC bit is set, so do NOT use the ASYN argument with the calibration commands when using that parser.

When using the ASYN argument, set the timeout value in the IO settings to at least 5 seconds. There are intervals during the cal acquires when the VNA takes a several seconds to respond to additional commands, such as when the processor is calculating error terms.

The following commands have this argument:

Command | Example
SENS:CORR:COLL:GUID:ACQuire (Guided Cal) | Guided 2-Port or 4-Port Cal
SENS:CORR:COLL:ACQuire (Unguided Cal) | Perform Unguided ECAL
SOUR:POW:CORR:COLL:ACQuire (Source Power Cal) | Perform a Source and Receiver Power Cal (shows polling loop)

In addition, the SENS:CORR:COLL:GUIDed:INITialize command has this optional argument for long calibration initialization, such as a CalAll calibration.

Last Modified:

10-Oct-2014

First Release


Calibrating the VNA Using SCPI

There are several ways to calibrate the VNA using SCPI depending on your measurement needs. As from the Cal Wizard, you can perform a Guided Cal, Unguided Cal, or ECal. This topic explains the differences in these calibration choices when using SCPI commands.

  • Guided Calibrations

  • ECal

  • Creating Cal Sets

  • Applying Cal Sets and Cal Types

  • Uploading Error Terms

  • Unguided Cals and Calibration Classes

See Also

Synchronizing the VNA and Controller (During a calibration)

See SCPI Calibration Examples

Guided Calibrations

Guided versus Unguided is the style of calibration that is selected on the first page of the Calibration Wizard. A remote 'guided' cal does not present the cal wizard, but prompts for specific standards to be connected. In a remote 'Unguided', the steps must be 'hard-coded'.

  • To perform a Guided Calibration, use ONLY Sens:Corr:Coll:Guided commands.

  • These commands calibrate the ACTIVE channel. Activate a channel by selecting a measurement on the channel to be calibrated using Calc:Par:Select.

  • Full 1,2,3,4-port SOLT and TRL calibrations - No response cals.

  • All of the advanced calibration features (Thru method, specify DUT connectors and Cal kits for each port, port pairings).

  • A Cal Set is applied to the channel and saved at the completion of a guided cal according to the preference setting SENS:CORR:PREF:CSET:SAVE

Note: To perform an Unguided Calibration, use ONLY the Sens:Corr commands (NOT Guided).

ECal

From the Cal Wizard or from a SCPI program, ECal is fast, accurate, and very repeatable. Unlike from the Cal Wizard, you can use SCPI to perform ECal using either the Guided or Unguided commands. The Unguided commands are easiest to use. However, the following situations require that you use the Guided commands.

  • To maximize accuracy, all ECal calibrations on the VNA perform an Unknown Thru measurement of the ECal module Thru state IF the VNA model being used has 1 reference receiver per port. If your VNA does NOT have 1 reference receiver per port, use Guided ECal commands and specify a Thru method.

  • If your ECal module connectors do NOT match the DUT connectors, and you choose not to perform a User Characterization, use Guided ECal commands and specify the Thru method.

ECAL Notes:

  • When using either Guided or Unguided ECal commands under low power situations, use the Orientation settings. The Guided example shows the use of these commands. When using Unguided, they must appear before the Acquire command.

  • The frequency range of the measurement must be within the range of the ECal module. Otherwise, the calibration will fail.

  • You do NOT have to send the ECal module state 'switch' commands. The ECal algorithm switches ECal states automatically.

  • All of these ECal choices are listed in the Programming Command Finder function in this Help file.

See Using ECal to learn about all of the ECal features.

Creating Cal Sets

There are several ways to store guided cal data into a unique Cal Set. The following is probably the easiest. It does not require the name of an existing Cal Set and it allows you to name the Cal Set.

SENS:CORR:COLL:GUID:INIT 'start the cal with no cal set argument

'Perform the cal

SENS:CORR:COLL:GUID:SAVE 'create cal set with auto-generated name or to cal register

SENS:CORR:CSET:NAME 'MyCalSet' 'name the current cal set.

Applying Cal Sets and Cal Types

A Cal Set is applied to the channel and saved at the completion of a guided cal according to the preference setting SENS:CORR:PREF:CSET:SAVE.

When you select a Cal Set to apply to an uncalibrated channel, the VNA attempts to find the most comprehensive calibration type in the Cal Set and turn it ON. In addition, changing a measurement parameter (for example, from S11 to S21) will also initiate an attempt to apply the best Cal Type and turn correction ON.

There may be times when you do not want the most comprehensive Cal Type. For example, say there is a Full 2-port Cal Set applied, but there is only an S11 measurement displayed. If measurement speed is a concern, you can apply a Full 1-Port Cal Type from that same Cal Set and save time by not doing the extra background sweeps. Learn more about background sweeps.

If you change the measurement parameter, the VNA will reapply the Full 2-Port Cal Type.

See the SCPI and COM commands for Cal Sets and Cal Types.

Uploading Error Terms

Note: There was a method described here for WinCal 3.x that involved a preference setting. That method is no longer supported.

To upload error terms into a created or selected Cal Set:

SENS:CORR:CSET:CREAte or SENS:CORR:CSET:GUID
SENS:CORR:CSET:Data <term> <port> <port> <data>
SENS:CORR:CSET:SAVE

This method puts error terms into a Cal Set, outside of a Guided or Unguided calibration session.

The Cal Set can then be applied at any time.

See SENS:CORR:CSET commands.

Unguided Cals and Calibration Classes

  • Use Sens:Correction commands.

  • 1-port, 2-port, Response.

  • Can select 2 sets of standards.

  • TRL is NOT recommended.

The following describes how to perform an unguided calibration using SCPI. The objective here is to make clear the relationship between the physical port on which a standard is being measured, the actual device in the cal kit, and the SCPI command used to acquire the device.

Calibration standards classes are ‘categories’ of standard types. To perform a 2 port calibration, the cal wizard requires the following types of standards to be measured:

3 reflection standards on the forward port:

  • Class S11A typically an open

  • Class S11B typically a short

  • Class S11C typically a load

Likewise, 3 reflection standards are required for the reverse port:

  • Class S22A typically an open

  • Class S22B typically a short

  • Class S22C typically a load

There is also a transmission standard that is measured in both directions:

  • Class S21T typically a thru

The following illustrates the relationship between cal kit physical standards and calibration classes. Here is a list of the physical devices in my calibration kit.

Standard #1 = "3.5 mm male short"

Standard #2 = "3.5 mm male open"

Standard #3 = "3.5 mm male broadband load"

Standard #4 = "Insertable thru standard"

Standard #5 = "3.5 mm male sliding load"

Standard #6 = "3.5 mm male lowband load"

Standard #7 = "3.5 mm female short"

Standard #8 = "female to female characterized thru adapter"

Standard #9 = "0-2 Load"

Standard #10 = "Open"

Standard #11 = "Non-insertable thru"

Standard #12 = "3.5 mm female lowband load"

Standard #13 = "3.5 mm female sliding load"

Standard #14 = "3.5 mm female broadband load"

Standard #15 = "3.5 mm female open"

When you perform a calibration remotely using SCPI, you don’t specify the device number directly. Rather, you specify the class you want to measure. Each device in the calibration kit is assigned to a class. And since more than one device can be assigned to the same class, each class contains an ordered list of devices. The class assignments are set using the Advanced Modify Cal Kit dialog or the SCPI command:

SENS:CORR:COLL:CKIT:ORDer<class>, <std>, <std>, <std>, <std>,<std>,<std>,<std>

The 85052B kit used in the example program has the following standard list for each class: The list was obtained by issuing the corresponding SCPI query:

SENS:CORR:COLL:CKIT:OLIST1? S11A = +2,+15,+0,+0,+0,+0,+0

SENS:CORR:COLL:CKIT:OLIST2? S11B = +1,+7,+0,+0,+0,+0,+0

SENS:CORR:COLL:CKIT:OLIST3? S11C = +6,+5,+3,+12,+13,+14,+0

SENS:CORR:COLL:CKIT:OLIST4? S21T = +4,+8,+0,+0,+0,+0,+0

SENS:CORR:COLL:CKIT:OLIST5? S22A = +2,+15,+0,+0,+0,+0,+0

SENS:CORR:COLL:CKIT:OLIST6? S22B = +1,+7,+0,+0,+0,+0,+0

SENS:CORR:COLL:CKIT:OLIST7? S22C = +6,+5,+3,+12,+13,+14,+0

SENS:CORR:COLL:CKIT:OLIST8? S12T = +4,+8,+0,+0,+0,+0,+0

When you perform the calibration, you acquire data by issuing the ACQuire command:

SENS:CORR:COLL:ACQ <class>[, <subst> ]

For example:

SENS:CORR:COLL:SFOR 1

SENS:CORR:COLL:ACQ STANA, SST2

The SFOR command tells the wizard to make the next acquisition in the forward direction. The ACQuire command specifies that we are measuring the 2nd device in the list for STANA. Since we are measuring SFORward, then STANA refers to class #1 or S11A. The list of devices for this class are specified in the OLIST1 query above.

Alternately, you could modify the device order for the S11A class to move device #15 into the first position (SENS:CORR:COLL:CKIT:ORDER1). When the desired device is in the first position, you need not specify the order number in the ACQuire command. The default is the first device in the OLIST. This works well for two port network analyzers where the order for S11A,B,C classes is set up for port 1 and the order for S22A,B,C is set up for port 2. With the kit set up in the proper order, you eliminate the need to specify the substandard number (SST<n>).

Last Modified:

10-Oct-2014

First Release


The VNA as a USB Device

VNA can be controlled as a USB Device using SCPI. This is done through the Keysight I/O Libraries which must be installed on your remote computer.

All data types, especially Binary block data, transfer MUCH faster using USB as compared to GPIB.

To communicate with the VNA as a USB device

  1. Connect the VNA to the remote computer using the rear-panel device-side USB connector.

  2. The 'Found New Hardware' wizard is launched. Follow the prompts to install the VNA driver software.

  3. The Keysight I/O Libraries will recognize the VNA as a Test and Measurement device and show the following dialog.

Note: The VNA is not a USB Mass Storage Device. Therefore, Windows Explorer does NOT recognize it as a USB device. You can NOT use Windows Explorer to transfer files to and from the VNA. For file transfer, use the SCPI command MMEM:TRANsfer.

Alias name Change this to a name that is easy to recognize. Once configured, use the Alias name to communicate with the USB device using applications such as VISA and SICL:

  • VISA: viOpen (...,"UsbDevice1",...)

  • SICL: iopen ("UsbDevice1")

For more information, see the Connectivity Guide in the Keysight I/O libraries.

Last Modified:

10-Oct-2014

First Release


Reading the VNA Status Registers

Reading the Analyzer's Status Register

The VNA has several status registers that your program can read to know when specific events occur. There are two methods of reading the status registers in the analyzer: the Polled Bit method and the Service Request method.

  • The Status Registers

  • Setting and Reading Bits in Status Registers

  • Polled Bit Method

  • Service Request Method

See Also

IEE 482 Common commands

Example: Status Reporting

Status Commands

Other Topics about GPIB Concepts

Important Notes:

  • A new Limit Line Fail command that makes it easy to determine if Limit Line testing has failed.

  • *OPC? can be used to easily determine when a channel has completed a sweep. This requires no interaction with the Status Register system. Most VNA programming examples use *OPC?.

  • Most of the Status Register system can NOT be used with the SCPIStringParser Object. However, *OPC? can be used.

The Status Registers

Most of the status registers in the analyzer have sixteen bits. For simplicity, this topic will illustrate their use with 8-bit registers. Bits in registers represent the status of different conditions inside of the analyzer. In the following graphic, a register is represented by a row of boxes; each box represents a bit. Bit 3 is ON.

Each VNA Status Register is actually comprised of the following registers. See an image of the VNA Status registers.

  • Enable Registers - When using the SRQ method of polling, you first set bits in the enable register which tells the VNA which events to monitor. This is not necessary using the Polled Bit method, as you can only monitor a single event. A *CLS (clear status) command will not clear the enable register. The *ESE and *ESE? commands are used to set and query Enable bits, while *ESR is used to read and clear an Enable register. Learn how to set bits.

  • Condition Registers - A condition register continuously monitors events in the VNA. Bits in the condition register change real time as conditions occur. These bits are not latched, so this register is used mainly for diagnostic purposes. The registers that only summarize lower level registers do NOT have a condition register.

  • Event Registers - This is the register that is read to determine if an event has occurred. An event register latches the bits from the corresponding condition register. When an event register bit is set, subsequent changes to the corresponding condition register bit are ignored. The bit remains set until a query command such as *CLS clears the bit. Learn how to read the Event Register.

  • Positive and Negative Transition Registers - Transition registers control what type of in a condition register will set the corresponding bit in the event register.

    • Positive transitions (0 to 1) are only reported to the event register if the corresponding positive transition bit is set to 1.

    • Negative transitions (1 to 0) are only reported to the event register if the corresponding negative transition bit is set to 1.

    • Setting both transition bits to 1 causes both positive and negative transitions to be reported.

Transition registers are read-write and are unaffected by *CLS (clear status) or queries. They are reset to their default settings at power-up and after *RST and SYSTem:PRESet commands. The following are the default settings for the transition registers:

    • All Positive Transition registers = 1

    • All Negative Transition registers = 0

This means that, by default, the analyzer will latch all event registers on the negative to positive transition (0 to 1).

The following is an example of why you would set transition registers:

A critical measurement requires that you average 10 measurements and then restart averaging. You decide to poll the averaging bit. When averaging is complete, the bit makes a positive transition. After restart, you poll the bit to ensure that it is set back from 1 to 0, a negative transition. You set the negative transition bit for the averaging register.

Setting and Reading Bits in Status Registers

Both the Polled-Bit method and Service Request method require that you set and read status register bits. Most of the VNA status registers contain 16 bits, numbered 0 to 15. Each bit has a weighted value. The following example shows how to set the bits in a 8-bit status register.

8-bit register

Bit | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Weight | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128

How to set bits 4 and 5 in the Standard Event Status Enable register:

Step | Example
1. Determine the weighted bit value for these bits | weights 16 and 32 (respectively)
2. Add these values together | 16 + 32 = 48
3. Send this number as an argument in the appropriate command. (see Status Commands) | STAT:QUES:LIMIT1:ENAB 48

The Polled Bit Method

With the Polled Bit Method, your program monitors a bit in the status register that represents the condition of interest to you. When the VNA sets the bit to 1, your program sees it and responds accordingly.

  • If your program periodically monitors a bit in the status register, it is free to do other things as well. However, your program can respond only as fast as the bit is polled.

  • If your program continually monitors a bit, it can respond immediately, but will be unavailable to do anything other than poll the bit.

Advantage: This method requires very little programming.

Procedure:

  1. Decide which condition to monitor. The Status Commands topic lists all of the possible conditions that can be monitored in the analyzer.

  2. Determine the command to be used to monitor the bit.

  3. Determine how often to poll the bit until it is set.

  4. Construct the routine to respond when the bit is set.

The Service Request (SRQ) Method

Your program enables the bits in the status registers representing the condition of interest. When the condition occurs, the VNA actively interrupts your program from whatever it is doing, and an event handler in your program responds accordingly. Do this method if you have several conditions you want to monitor or the conditions are such that it is not practical to wait for the condition to occur.

Advantage: This method frees your program to do other things until the condition occurs. The program is interrupted to respond to the condition.

Disadvantage: This method can require extensive programming depending on the number and type of conditions that you want to monitor.

Procedure:

1. Decide which conditions to monitor. The Status Commands topic lists all of the possible analyzer conditions that can be monitored.

2. Set the enable bits in the summary registers and the status byte register.

Enabling is like making power available to a light. Without power available, the switch can be activated, but the light won't turn ON. In the analyzer, without first enabling a bit, the condition may occur, but the controller won't see it unless it is enabled.

The condition, and the bit in the summary registers in the reporting path, must be enabled. This is like streams (conditions) flowing into rivers (summary registers), and rivers flowing into the ocean (controller). See the diagram of status registers in Status Commands.

Bit 6 of the status byte register is the only bit that can interrupt the controller. When any representative bit in the status byte register goes ON, bit 6 is automatically switched ON.

3. Enable your program to interrupt the controller. This is done several ways depending on the programming language and GPIB interface card you use. An example program is provided showing how this is done with in Visual Basic with a National Instruments GPIB card.

4. Construct a subroutine to handle the interrupt event. If you are monitoring more than one condition in your system, your event handler must determine which condition caused the interrupt. Use the *SPE command to determine the instrument that caused the interrupt, then poll the summary registers, then poll condition registers to determine the cause of the interrupt.

Last Modified:

10-Oct-2014

First Release


Referring to Traces, Measurements, Channels, and Windows Using SCPI

Sometimes in a SCPI program you may need to refer to traces that you have not created. This can be a bit confusing in the VNA. Here are the THREE ways to refer to a specific measurement trace.

Note: The terms "Trace" and "Measurement" effectively mean the same thing in this discussion.

  1. The Trace Number is also picked by you when ‘feeding’ a newly-created measurement name to a window number using DISP:WINDow<wmun>:TRACe<tnum>:FEED. The trace number is used ONLY by SCPI and is mainly used to refer to traces in the DISPlay node. This is NOT the number that appears as Tr# on the screen. While you can assign any Trace number you want, when a measurement is created from the GUI, the VNA assigns numbers to the traces sequentially, starting with one in each window. Therefore, when there is more than one window, these numbers are not unique.

  2. The Tr# that appears on the VNA screen is the third and most visible way to refer to a trace. Since we already have a "Trace Number", we call this the Measurement Number in the VNA Help file. This number is issued sequentially by the VNA regardless of channel and window. It is therefore unique among all traces. CALC<cnum>:MEAS<mnum>:xxxxx commands specify the Channel number and Measurement Number. This command returns the name of the active measurement: SYSTem:ACTive:MEAS?

The concept of the Active measurement versus Selected Measurement is also a bit confusing. As seen on the screen, the Active measurement has the highlighted Tr# . While there can only be ONE active measurement, every channel has a selected measurement. The target measurement must first be selected before most CALC node settings can be made.

  1. Use CALC<cnum>:PAR:MNUM <measNum> which requires the channel and measurement (Tr) number.

Here are other relevant commands for referring to traces, measurements, channels, and windows:

  • CALC<cnum>:PAR:CATalog:EXTended? - Catalog the Measurement Names for the specified channel.

  • SYSTem:ACTive:CHANnel? - Returns the number of the active channel. The active channel is the channel number that contains the active measurement.

  • SYSTem:ACTive:MEAS? - Returns the name of the active measurement. As seen on the screen, the Active measurement has the highlighted Tr#.

  • SYSTem:CHANnels:CATalog? - Returns the channel numbers currently in use.

  • SYSTem:WINDows:CATalog? - Returns the window numbers that are currently being used.

  • SYSTem:MEAS:CATalog? [chan] - Returns ALL measurement numbers, or optionally measurement numbers from a specified channel.

  • SYSTem:MEAS<n>:NAME? - Returns the name of the specified measurement (Tr#) number.

  • SYSTem:MEAS<n>:TRACe? - Returns the trace number of the specified measurement number.

  • SYSTem:MEAS<n>:WINDow? - Returns the window number of the specified measurement number.

Last modified:

10-Oct-2014

First Release


Remote Control of SCPI USB Devices Connected to a VNA

The following procedure is the USB equivalent of the VNA "GPIB Pass-Through" feature. This allows you to send SCPI commands from a remote PC to a USB device (such as a USB power sensor) that is connected to the VNA.

The PC must have the Keysight (Agilent) I/O Libraries installed.

  1. On the VNA, press System, then [Configure], then [SICL/GPIB], then SICL Enabled.

  2. On your PC, start Keysight (Agilent) Connection Expert which is the wizard for I/O Libraries.

  3. In the Connection Expert dialog, click Add Interface.

  4. Click Remote USB then click Add.

  5. In the Remote USB Interface dialog (shown above), do EITHER of the following:

  • Select Hostname, then enter the Full Computer Name of the VNA.

  • Select IP address, then enter the IP address of the VNA.

On the PC, the new USB interface in Connection Expert should show the USBTMC-compliant devices (such as the U2000-Series sensors) that are connected to that VNA. In the above dialog, the VISA interface ID is USB2. Therefore, a VISA program on the PC could send commands to the sensor that is connected to the VNA at the VISA resource string beginning with USB2::<interface>.

The above image shows a portion of the ACE dialog after adding the remote USB interface.

  6. Right-click on the device you want to communicate with (U2000A in this example) then click Send Commands To This Instrument.

  7. Type a command, then click Send Command or Read Response.

Last Modified:

10-Oct-2014

First release


Configure for VISA and SICL

Configure for SCPI LAN using SICL / VISA

  • VNA Supported Interfaces

  • Keysight I/O Libraries

  • SICL / VISA Programs Running on the VNA

  • Configure the VNA for SICL / VISA

  • Configure the External Controller

Other Topics about GPIB Concepts

Note: PXI based instrument supports only HiSlip, this information is for non-PXI instrument.

VNA Supported Interfaces

The VNA supports the following interfaces for SICL / VISA communication:

  • LAN - as a remote GPIB interface. The VNA LAN is presented as a virtual GPIB interface. It does NOT support simple TCPIP-based control. Therefore, when configuring the Keysight IO libraries on your PC, add a REMOTE GPIB interface, which uses the LAN client interface.

  • GPIB - requires that your external controller have a GPIB card.

The following interfaces are NOT supported:

  • USB

  • Serial

Important Note:

To enable VISA or SICL communication over LAN, you must do the following:

  1. On the VNA, click System, point to Configure, then click SICL/GPIB.

  2. Check SICL Enabled. To automatically enable SICL when the VNA is booted, check Automatically enable on Startup.

  3. Click OK.

The VNA is now ready to be controlled over LAN.

Learn more about this dialog box.

Keysight I/O Libraries

The Keysight I/O libraries includes the drivers to allow you to communicate with Keysight test instruments. Every VNA is shipped with the Keysight I/O libraries installed. We recommend you do NOT upgrade the Keysight I/O libraries on the VNA as unexpected results may occur. If you choose to upgrade the Keysight I/O libraries on the VNA, do NOT change the default folder path in the InstallShield Wizard.

To communicate with the VNA, the Keysight I/O libraries must also be installed on your external controller. To purchase the Keysight I/O libraries, or download a free upgrade, go to www.Keysight.com and search for IO Libraries. Scroll to find Software, Firmware & Drivers.

SICL / VISA Programs Running on the VNA

You can run your SICL / VISA program on the VNA to control the VNA. Although the Keysight I/O libraries are already installed on the VNA, it is configured as the Host. You must also configure a SICL or VISA LAN Client interface on the VNA, specifying the LAN hostname of that same VNA.

If your program uses the COM interface to VISA, and is compiled on a PC with the Keysight IO Libraries Suite (version 14 or later), and the resulting executable is copied and run on the VNA, it will produce a “type mismatch error”. This is because the VNA has the ‘M’ version of Keysight I/O libraries. The following Visual Basic code is an example of how to avoid this error when communicating with the VNA from within the VNA:

Dim rm As IResourceManager
Dim fmio As IFormattedIO488
Set rm = CreateObject("AgilentRM.SRMCls")
Set fmio = CreateObject("VISA.BasicFormattedIO")
Set fmio.IO = rm.Open("GPIB0::22")
fmio.WriteString "*IDN?" & Chr(10)
MsgBox fmio.ReadString()

Controlling the VNA over LAN while controlling other instruments over GPIB

The VNA can NOT be both a controller and talker/listener on the same GPIB bus. Using SICL / VISA, you can use LAN to control the VNA, leaving the VNA free to use the rear-panel GPIB interface to control other GPIB devices.

Configure the VNA for SICL / VISA

  1. On the VNA, click System then check Windows Taskbar

  2. Click Start then point to Program Files, Keysight IO Libraries, then click IO Config

  3. Select each GPIB Interface and click Edit to verify (or make) the default settings in the following table. These settings are REQUIRED when using a 82357B USB / GPIB Interface with the VNA.

  4. When complete, click OK to close the edit dialog.

  5. Click OK to close the IO Config dialog.

VISA Interface Name | SICL Interface Name | Dialog box title | Description
GPIB0 | gpib0 | GPIB Using NI-488.2 | VNA Rear-panel GPIB connector. This GPIB interface can be used to control the VNA OR for the VNA to control external equipment. IT CAN NOT DO BOTH IN THE SAME PROGRAM. Learn more about pass-through options.
GPIB1 | hpib7 | Internal Instrument Configuration | Internal interface for programs running on the VNA to control itself.
GPIB4 | inst0 | Internal Instrument Configuration | Used for LXI compliance. Do NOT delete this interface.

Configure the External Controller

Please refer to the Keysight I/O libraries documentation to learn how to configure your controller to communicate with the VNA. These links can show you how to find the following VNA information:

  • VNA full computer name

  • GPIB Address

  • IP Address

This example program can help test your VISA configuration.

Last Modified:

10-Oct-2014

First Release


介面控制

透過介面控制功能，您可以將遠端指令和資料傳送至下列 VNA 後面板介面：GPIB、材料處理常式 I/O、測試裝置 I/O 和輔助 I/O。

  • 概觀

  • 如何存取介面控制設定

  • 介面控制對話方塊

其他系統組態主題

附註：介面控制只能與標準通道搭配使用，而不能與應用程式通道搭配使用。

概觀

透過介面控制功能，您可以傳送資料以控制外部設備，例如 GPIB 儀器、材料處理常式、測試裝置或其他設備，且無需建立遠端程式。VNA 會管理時序以及所需的介面設定。請參閱後面板導覽

  • 一組唯一的控制資料可傳送到每個通道。此外，您可以在通道掃掠開始之前以及掃掠結束之後，傳送一組唯一的控制資料。

  • 介面控制設定可透過「介面控制」對話方塊或使用儀器狀態儲存和重新叫用進行儲存和重新叫用。

  • 介面控制設定可使用複製通道複製到其他通道。

  • 控制資料只能寫入介面，而不能從介面讀取。

  • 控制資料按照下列順序傳送。此順序無法變更。

  1. GPIB 介面

  2. 駐留時間

如何存取介面控制設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Setup] > Internal Hardware（內部硬體）> Interface Control...（介面控制...）

介面控制對話方塊說明

請參閱「介面控制概觀」（向上捲動）

儀器預設時會將所有欄位重設為預設設定。

附註：如果傳送介面控制資料時遇到錯誤，則會在 VNA 畫面上顯示錯誤訊息。通道觸發狀態會設定為保持。您必須修正導致錯誤的條件，然後將通道觸發狀態變更為其原始設定。

啟用介面控制 啟用和停用所有介面控制通訊。此核取方塊清除（預設設定）後，介面控制會停用，且不會傳送任何資料。若要傳送資料，還必須啟用個別介面。

通道 為對話方塊設定指定通道編號。會個別設定每個通道。清單方塊會顯示目前具有量測的通道。若要進行設定，必須至少存在一個量測。

通道標籤 指定要在 VNA 畫面下方的狀態列上顯示的標籤（下圖中的 D）。啟用介面控制時，會自動顯示狀態列。

暸解主要狀態列。

掃掠開始之前 - 掃掠結束之後索引標籤

所有四個介面的指令/資料均可在掃掠開始之前和掃掠結束之後傳送。但是，它們在「介面控制」對話方塊的不同索引標籤上設定和啟用。例如，若要在 VNA 掃掠之前和之後傳送 GPIB 指令，則必須選取「啟用控制」核取方塊，並且在「掃掠開始之前」和「掃掠結束之後」索引標籤上輸入指令。

掃掠開始之前 在通道上第一條軌跡開始掃掠之前傳送資料。

掃掠結束之後 在通道上最後一條軌跡完成掃掠之後傳送資料。

GPIB 指令

備註：

  • GPIB 儀器可使用 USB/GPIB 配接器連接至 VNA。

  • GPIB 查詢不受支援。

啟用控制 啟用和停用在 GPIB 介面上傳送指令。

多行編輯控制 每行包含使用下列語法的 GPIB 指令：

位址 指令

其中：

位址 0 和 31 之間的編號。VNA 會搜尋所有 GPIB 介面上連接至指定位址的儀器。如果具有該位址的儀器無法辨識，則會傳回錯誤。

指令 帶或不帶引號的 GPIB 指令。所加的引號會被忽略。

位址和指令由至少一個空格分隔。

指令應由新的一行或輸入鍵符號分隔。例如：

19 ":init:cont off"
16 init:imm

使用前面板的 Enter 鍵可在欄位中插入新的一行。

可輸入的 GPIB 指令數目僅受 VNA 的可用記憶體限制。

處理常式 I/O

啟用控制 啟用和停用在處理常式 IO 接頭 (E5080A) 上傳送資料

連接埠 A、B、C、D 將值傳送至相應的處理常式 I/O 連接埠。儘管連接埠 C 和 D 通常為雙向連接埠，但使用介面控制功能時只允許使用輸出模式。無法從這些連接埠或任何其他連接埠讀取資料。

傳送指令後停頓 指定將所有指令傳送至所有介面後的等待時間（以毫秒為單位）。允許使用任何正整數。使用此功能可讓所有外部裝置在開始量測前穩定下來。如果軌跡錯誤，則可能表示需要更長的穩定時間。

全部重設 將所有通道上的所有欄位設定為預設值。

儲存和重新叫用 儲存和重新叫用此對話方塊的內容。在儀器狀態儲存期間，如果「介面控制」對話方塊填入了設定，則會使用儀器狀態設定自動重新叫用這些設定。

介面控制使用 *.xml 檔案類型。VNA 硬碟上儲存了一個範例檔案。您可以將其重新叫用到對話方塊中，也可以使用 Word Pad 等文書處理器開啟並編輯該檔案。

確定 套用設定並關閉對話方塊。

取消 不套用所做的變更，並關閉對話方塊。

上次修改時間：

2016 年 01 月 06 日

第一版


RPHandler IO Connector (E5080A)

Handler I/O Connector (E5080A)

This rectangular 36-pin female connector provides communication signals between the VNA and a handler. You can change the settings on the Handler IO connector using SCPI commands. The settings are NOT accessible through the front-panel keys or display menu.

  • Overview - Controlling a Handler I/O.

  • Pin Assignments

  • Pin Descriptions

  • Timing Diagrams

  • Input Output Electrical Characteristics

Note: On early VNAs this connector is labeled "GPIO". It is covered to indicate that the connector is not functional.

Overview - Controlling a Handler I/O

The VNA is capable of interacting with an external handler. This allows the VNA to be used in an automated test environment, where devices to be tested are inserted into a test fixture by a part handler, and sorted into pass/fail bins by the handler after testing is complete. By connecting the part handler to the VNA Handler I/O ports, the VNA and part handler can synchronize their activities in a way that makes automated testing possible.

VNA and Part Handler Preparation

  1. Define the measurements that you want to make.

  2. Define limits for each of the measurements.

  3. Configure the VNAs Material Handler port so that it is compatible with your part handler. This usually involves setting the handler logic, pass/fail logic, pass/fail scope, and pass/fail mode. These settings are made remotely using SCPI commands.

  4. Use a cable to connect the VNA to your part handler.

  5. Put the VNA in External Trigger mode.

  6. Load parts in handler per manufacturer instructions.

Text Descriptions

  1. (Optional). The VNA sends values out the Material Handler to configure external instruments. The A,B,C, and D ports of the Material Handler can be used to control devices used in testing, such as step attenuators, part handlers, or even the DUT itself. Also, the DAC1 and DAC2 lines on the Power I/O connector can be used to provide bias voltages for devices and instruments. If you wish to use the Material Handler for testing, you will need to write a program to send values out the various lines and ports, as there is no activity on these lines by default.

  2. The part handler receives a Ready for Trigger signal from the VNA. This indicates that the VNA is properly configured and ready to take a measurement.

  3. The part handler sends an External Trigger signal to the VNA. This signals that the part handler has settled, and allows the VNA to begin taking measurements.

  4. The VNA takes measurements on all triggerable channels.

  5. The Index line on the material handler goes to a Low state, which means that all required data has been collected by the VNA.

  6. The part handler removes the DUT from the test fixture, and inserts a new DUT into the fixture. This operation is often referred to as part handler indexing. The device just tested is staged (removed from the fixture and prepared for binning), and the next part to be tested is put into the fixture. The removed DUT cannot be assigned to a Pass/Fail bin yet, as the Pass/Fail status is not available.

  7. The VNA sends the Pass/Fail Status.

  8. The VNA sends the Pass/Fail Strobe meaning that the Pass/Fail status has been determined.

  9. The part handler reads the Pass/Fail Status line.

  10. The part handler bins the staged part based on the Pass/Fail Status.

  11. The test process repeats at step 1, waiting for Ready for Trigger from the VNA.

Handler IO Pin Assignments

A slash (/) symbol preceding signal names means that they are negative logic (active low).

Pin number

Signal name

Input/Output

Description

1

GND

N/A

Ground.

2

/INPUT1

Input

When this port receives a negative pulse, /OUTPUT1 and /OUTPUT2 are changed to the Low level.

3

/OUTPUT1

Output

Changes to the Low level when /INPUT1 receives a negative pulse. A command can be available for altering the Low/High level logic.

4

/OUTPUT2

Output

Changes to the Low level when /INPUT1 receives a negative pulse.A command can be available for altering the Low/High level logic.

5

/PORT A0

Output

Bit 0 of port A (8 bit parallel output port)

6

/PORT A1

Output

Bit 1 of port A.

7

/PORT A2

Output

Bit 2 of port A.

8

/PORT A3

Output

Bit 3 of port A.

9

/PORT A4

Output

Bit 4 of port A.

10

/PORT A5

Output

Bit 5 of port A.

11

/PORT A6

Output

Bit 6 of port A.

12

/PORT A7

Output

Bit 7 of port A.

13

/PORT B0

Output

Bit 0 of port B (8 bit parallel output port)

14

/PORT B1

Output

Bit 1 of port B.

15

/PORT B2

Output

Bit 2 of port B.

16

/PORT B3

Output

Bit 3 of port B.

17

/PORT B4

Output

Bit 4 of port B.

18

/EXTERNAL TRIGGER

Input

An external trigger signal. When the trigger source is set to the "External," this port generates a trigger in respond to the trailing edge of a negative pulse.

19

/PORT B5

Output

Bit 5 of port B.

20

/PORT B6

Output

Bit 6 of port B.

/INDEX

Indicates that analog measurement is complete. The /INDEX signal changes to the Low level when analog measurement (all sweeps of all channels) is complete. When the handler receives the signal, it assumes that it is ready to connect the next DUT. However, no measurement data are available until data calculation is completed.

When the point trigger function is on, it goes to the High level before staring measurement of the first measurement point and returns to the Low level after completing measurement of all measurement points.

21

/PORT B7

Output

Bit 7 of port B.

/READY FOR TRIGGER

Indicates that the instrument is ready for triggering.This signal is changed to the Low level when the instrument is ready for receiving a trigger signal.

With the point trigger function on, it goes to the Low level when the instrument is ready to accept the trigger signal for the first point and goes to the High level when the trigger signal for the first point is received. When measurement of all measurement points is completed and the instrument is ready to receive the trigger signal for the first point of the next sweep, this signal goes to the Low level again.

22

/PORT C0

Input/Output

Bit 0 of port C (4 bit parallel I/O port)

23

/PORT C1

Input/Output

Bit 1 of port C.

24

/PORT C2

Input/Output

Bit 2 of port C.

25

/PORT C3

Input/Output

Bit 3 of port C.

26

/PORT D0

Input/Output

Bit 0 of port D (4 bit parallel I/O port)

27

/PORT D1

Input/Output

Bit 1 of port D.

28

/PORT D2

Input/Output

Bit 2 of port D.

29

/PORT D3

Input/Output

Bit 3 of port D.

30

PORT C STATUS

Output

Port C status signal.This signal is changed to the High level when the port C is configured to output port. It is changed to the Low level when the port is configured to input port.

31

PORT D STATUS

Output

Port D status signal. This signal is changed to the High level when the port D is configured to output port. It is changed to the Low level when the port is configured to input port.

32

/WRITE STROBE

Output

A output port write strobe signal. When data is present (that is, output level changes) on any of the output ports, this signal provides a negative pulse.

33

/PASS FAIL

Output

Each limit test's results signal. This signal changes to the High level when limit test, bandwidth test, or ripple test results return FAIL. It changes to the Low level when all limit test results return PASS.

34

/SWEEP END

Output

A sweep completion signal. When measurement (all sweeps of all channels) and data calculation are completed, this signal provides a negative pulse.

35

+5V

Output

Provides +5V DC power supply for external instruments.

36

/PASS FAIL STROBE

Output

Each limit test's results write a strobe signal. When limit test result is present on /PASS FAIL, this signal provides a negative pulse.

Pin Descriptions

Input1

When this Input line receives a Low pulse from the material handler, data is latched on the OUTPUT1 and OUTPUT2 lines. See OUTPUT1|2 Data Output Write Timing

The Input Line activity can be read:

SCPI

COM

CONTrol:HANDler:INPut?

get_Input1 Method

Output1, Output2

See OUTPUT1|2 Data Output Write Timing

The current state of these latched TTL outputs may be set High or Low (Default setting) using the (non-user) SCPI put_Output (COM) commands.

The next state (following a negative edge on the INPUT1 line) may be pre-loaded to High or Low (Default setting) using the user commands.

For example, on the next negative pulse on the INPUT1 line, you want the OUTPUT1 line to go from 0 to 1. To do this:

CONT:HAND:OUTP1:DATA 0 'Force the OUTPUT1 line to 0
CONT:HAND:OUTP1:USER 1 'Set the OUTPUT1:USER buffer to 1, indicating the next state

SCPI

COM

Write User Data

CONT:HAND:OUTP<pin>:USER

put_Output Method

Read last value written

CONT:HAND:OUTP<pin>:USER

get_Output Method.

Write non-user data

CONT:HAND:OUTP<pin>:DATA

put_Output Method

Read last value written

CONT:HAND:OUTP<pin>:DATA

get_Output Method

Output Ports A and B

These two general purpose, 8-bit output ports are used to write data to the material handler. When any line changes state, all output lines are latched to the I/O connector as the Output Write Strobe goes Low.

The default state for data is Low.

See Data Output Write Timing Diagram

Set Port Logic:

The logic for the data lines can be set to either: Positive (1 = High) or Negative (1 = Low). This setting affects all data ports. They cannot be set independently.

SCPI

COM

CONTrol:HANDler:LOGic

PortLogic Property

Combine to read or write data to Port F:

Ports A and B can be virtually combined to write data to one 16-bit I/O port F.

SCPI

COM

CONTrol:HANDler:F <num>

put Port (F)

Input/Output Ports C and D

These two general purpose 4-bit Input/Output ports are used to write data (Output) or read data (Input). These lines could be used to write to an external device such as a step attenuator.

When any line changes state, all output lines are latched to the I/O connector as the Output Write Strobe goes Low. See Data Output Write Timing.

Set Input | Output Mode:

Each port may be independently defined as Output or Input.

SCPI

COM

CONTrol:HANDler:C:MODE

PortMode Property

CONTrol:HANDler:D:MODE

Set Port Logic:

The logic for the data lines can be set to either: Positive (1 = High) or Negative (1 = Low). This setting affects all data ports. They cannot be set independently.

SCPI

COM

CONTrol:HANDler:LOGic

PortLogic Property

Read or write data:

Ports C and D can be virtually combined to read or write data to one 8-bit I/O port E. When combined, both C and D ports must be set to either INPUT or OUTPUT mode.

SCPI

COM

CONTrol:HANDler:<port>[:DATa]>

get_Port(x)

put Port (x)

Port C Status, Port D Status

These two output lines indicate the Read / Write mode of the C and D ports.

  • A Low level indicates that the associated port is in INPUT mode (read only).

  • A High level indicates that the associated port is in OUTPUT mode (write only).

These logic of these status outputs cannot be changed.

See Input/Output Ports C and D to learn how to set I/O Mode

See Data Output Write Timing

Output Port Write Strobe

This Output line goes Low to write data from Ports A and B and Ports C and D when a change is detected on any of the data lines.

These logic of this strobe output cannot be changed.

See Data Output Write Timing

External Trigger

When trigger source is set to external, this Input line accepts a trigger signal from the material handler. This usually means that a part is in place and ready to be tested.

See Trigger Timing Diagram

Index

A Low signal on this Output line indicates to the material handler that the measurement is complete. This usually means that the handler can connect the next device. However, measurement data is not available until data is calculated. See Trigger Timing Diagram.

Set Function:

This line also serves as a data line. Set the function using the following commands:

SCPI

COM

CONTrol:HANDler:INDex:STATe

IndexState

Ready for Trigger

When this output line goes low, it indicates to the material handler that the VNA is ready for a trigger signal.

See Trigger Timing Diagram

See Pass/Fail Timing Diagram

Set Function:

This line also serves as a data line. Set the function using the following commands:

SCPI

COM

CONTrol:HANDler:RTRigger:STATe

ReadyForTriggerState

Pass/Fail State

This Output line indicates to the handler whether the limit test has passed or failed.

Pass/Fail state is valid only when the limit test function is ON and while Pass/Fail strobe line is Low. See Pass/Fail Timing Diagram

Set Pass / Fail Logic:

  • Positive Logic: High=Pass, Low=Fail. (Default setting)

  • Negative Logic: High=Fail, Low=Pass.

SCPI

COM

CONTrol:HANDler:PASSfail:LOGic

PassFailLogic Property

Set Default Conditions:

  • PASS- the line stays in PASS state. When a device fails, then the line goes to fail after the Sweep End line is asserted.

  • FAIL- the line stays in FAIL state. When a device passes, then the line goes to PASS state after the Sweep End line is asserted.

  • No Wait- the line stays in PASS state. When a device fails, then the line goes to fail IMMEDIATELY. (Default setting)

SCPI

COM

CONTrol:HANDler:PASSfail:MODE

PassFailMode Property

Set Pass/Fail Scope:

  • Channel scope: The line resets to the default state after the measurements on a channel have completed.

  • Global scope: The line resets to the default state after the measurements on all triggerable channels have completed. (Default setting)

SCPI

COM

CONTrol:HANDler:PASSfail:SCOPe

PassFailScope Property

Pass/Fail Write Strobe

A Low pulse indicates that Pass/Fail line is valid and the Pass / Fail State is output to the material handler.

The Pass/Fail Strobe is fixed in duration and timing. However, when the strobe occurs depends on the Pass/Fail Mode and Pass/Fail Scope (Channel or Global) settings. See Pass/Fail State

See Pass/Fail Timing Diagram

+5V

+5V nominal output (100mA max).

Protected by self-healing fuse.

Sweep End

This output line indicates the status of the VNA sweep. The sweep includes sweeping the source and taking data.

  • Low (falling edge) indicates that the specified sweep event has finished. This does NOT indicate that all calculations have finished.

  • High indicates that the specified sweep event is active.

See Trigger Timing Diagram

Set Sweep Event Mode:

  • Sweep: indicates that a single source sweep has finished. (Default setting)

  • Channel: indicates that a single channel has finished.

  • Global: indicates that all enabled channels have finished.

SCPI

COM

CONTrol:HANDler:SWEepend

SweepEndMode Property

Timing Diagrams

Trigger Timing

All signals are active low.

T1 = 1 ms External Trigger pulse width

T2 > 10ms Sweep End pulse width (both High and Low)

Pass / Fail Timing

T1 = 1 ms Pulse width and response time of Pass / Fail Strobe

T2 > 10 ms Ready for Trigger lag

Ports A-F Data Output Write Timing

T1 = 1 ms Write Strobe response time

T2 = 1 ms Write Strobe pulse width

OUTPUT1|2 Data Output Write Timing

The old state to new state transition can be either low to high (as shown) or high to low.

T1 = .6 ms Output1|2 response time

T2 = 1 ms Input1 Strobe pulse width

Input / Output Electrical Characteristics

All Material Handler I/O Input and Output lines are TTL compatible.

Input and Input/Output lines

Lines carrying information IN (or bidirectional) to the VNA from the material handler.

Maximum Input Voltages: | -0.5 V to 5.5 V
TTL High level: | 2.0 V to 5.0 V
TTL Low level: | 0 V to 0.5 V

VNA Input and Input/Output Circuit Diagram

To Handler I/O Port

Note: The INPUT1 line does NOT have the 10K pull up resistor.

Output Lines

Lines carrying information OUT of the VNA to the material handler.

Maximum Output Current: |  | -10 mA to 10 mA
Output Current | TTL High level: | -5 mA
 | TTL Low level: | 3 mA
Output Voltage | TTL High level: | 2.0 V to 3.3 V
 | TTL Low level: | 0 V to 0.8 V

VNA Output Circuit Diagram

To Handler I/O Port

Last modified:

6-Jan-2016

First Release


Code Translator

Code Translator Application

The VNA has code emulators that allow you to control the VNA using test programs written in the remote control commands of the 8753 and E5071C. The code emulators process each of incoming 8753/E5071C commands in real time, by first recognizing it as a valid command, and then executing the VNA’s equivalent command(s) if one exist. The 8753 command emulation is performed by the CxL Application. The E5071C command emulation is performed by the E5071C command emulation mode of the VNA firmware. You can launch these code emulators as follows;

  1. Press System > System Settings > Code Emulation.

  2. Select 8753 or 5071

See also

Code Emulator for E5071C

CxL Help from Windows Start menu,

Last Modified:

6-Jan-2016

First Release


Code Emulator for E5071C

Overview

The E5071C code emulation mode is for remote controlling the VNA with test programs written for the E5071C ENA Series network analyzer. In the E5071C command emulation mode, the VNA firmware translates the incoming E5071C SCPI commands and executes the VNA’s equivalent command(s).

Notes

  • The E5071C code emulation mode supports the majority of the E5071C’s functions. But some specific functions are not supported. Typical examples of unsupported functions are the Frequency Offset Mode for mixer and harmonic measurements, the sweep-end detection using the status byte, and so on. Refer to Unsupported Commands for more details.

  • The E5071C emulation mode is basically for the remote control using the E5071C SCPI commands. The E5080A SCPI commands cannot be used in the E5071C code emulation mode, except for the commands for performing advanced error corrections such as the unknown-thru SOLT cal and mechanical full 3/4-port SOLT cal. Refer to How to perform advanced calibrations.

  • The possible trace/channel/window layouts made by the E5071C emulation mode are limited. Refer to Trace/channel/window layouts.

  • Unlike the E5071C, the VNA’s trace numbers are numbered sequentially through all channels. If we set the number of channels to 4 and the number of traces to 4 when starting the emulation mode, the trace-1 of the E5071C’s channel-1, 2, 3, and 4 will be assigned to the trace-1, 5, 9, and 13 in the E5080A.

  • If the number of channels you set in the dialog box is greater than the number of channels actually used in your measurement, the unused channels are displayed as blank channels.

  • If the number of traces you set in the dialog box is greater than the number of traces actually used in your measurement, the measurement parameters of unused trace are default (S11). Therefore, S11 is measured in the unused traces and source signal is outputted from port 1 (LED on port 1 is blinking) .

  • The COM commands used in the E5071C’s VBA function are not supported by the E5071C code emulation mode.

How to use the code emulator

  1. Press System > System Setting > Code Emulation > 5071, then the following dialog box is displayed.

  2. Select the required number of Channel and Trace for your measurement.

  3. Specify IDN string if you want to modify it. *IDN? returns the value you set.

  4. If you want to start with Code Emulator at next VNA application start up, check "Enable Code Emulation on Start Up".

  5. Click “Start”

  6. The dialog box of "To quit the emulation mode requires to exit the NA application. Do you want to continue?" is displayed. Click Ok.

  7. The E5080A is preset, then the number of trace and channel are set.

  8. Execute your program in the E5071C commands thorough GPIB, USB or LAN.

  9. To quit the emulation mode, press System > Main > Exit.

Function Coverage

Because some functions are a completely different way than the E5071C network analyzers, not all E5071C commands have a direct E5080A equivalent. There are some not supported and partial supported commands.

Unsupported Commands

Function not supported by E5071C code emulator | Related E5071C Commands | Comments
Status reporting system (status byte) | :STATus:xxxxx | Status reporting system does not supported by the code emulator.
Indicating fixture simulator topologies | :CALCulate<ch>:FSIMulator:BALun:TOPology:PROPerty:STATe | The E5080A cannot show the Topology property on the screen. Query always returns OFF.
Indicating bandwidth limit test values | :CALCulate<ch>[:SELected]:BLIMit:DISPlay:VALue :CALCulate<ch>:TRACe<tr>:BLIMit:DISPlay:VALue | The E5080A cannot show the bandwidth limit test value. Query always returns OFF.
Setting search functions without putting markers on traces | :CALCulate<ch>[:SELected]:FUNCtion:DOMain:COUPle :CALCulate<ch>:TRACe<tr>:FUNCtion:DOMain:COUPle | Query always returns OFF.
 | :CALCulate<ch>[:SELected]:FUNCtion:PEXCursion :CALCulate<ch>:TRACe<tr>:FUNCtion:PEXCursion :CALCulate<ch>[:SELected]:FUNCtion:POINts :CALCulate<ch>:TRACe<tr>:FUNCtion:POINts | The search function without marker is not supported. Use the search function with marker.
 | :CALCulate<ch>[:SELected]:FUNCtion:PPOLarity :CALCulate<ch>:TRACe<tr>:FUNCtion:PPOLarity | Query always returns POSitive.
 | :CALCulate<ch>[:SELected]:FUNCtion:TARGet :CALCulate<ch>:TRACe<tr>:FUNCtion:TARGet | The search function without marker is not supported. Use the search function with marker.
 | :CALCulate<ch>[:SELected]:FUNCtion:TTRansition :CALCulate<ch>:TRACe<tr>:FUNCtion:TTRansition | Query always returns BOTH.
Limit offset | :CALCulate<ch>[:SELected]:LIMit:OFFSet:AMPLitude :CALCulate<ch>:TRACe<tr>:LIMit:OFFSet:AMPLitude :CALCulate<ch>[:SELected]:LIMit:OFFSet:MARKer :CALCulate<ch>:TRACe<tr>:LIMit:OFFSet:MARKer :CALCulate<ch>[:SELected]:LIMit:OFFSet:STIMulus :CALCulate<ch>:TRACe<tr>:LIMit:OFFSet:STIMulus | Limit offset is not supported. Set the offset manually.
Setting search domains without putting markers on traces | :CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain:COUPle :CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain:COUPle | Query always returns OFF.
 | :CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain:MULTiple[:STATe] :CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain:MULTiple[:STATe] | The multiple domain for search function without marker is not supported. Query always returns ON.
 | :CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain:STARt :CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain:STARt | The domain for search function without marker is not supported. Use the search function with marker.
 | :CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain[:STATe] :CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain[:STATe] | The domain for search function without marker is not supported. Use the search function with marker. Query always returns ON.
 | :CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain:STOP :CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain:STOP | The domain for search function without marker is not supported. Use the search function with marker.
Echo display | :DISPlay:ECHO:CLEar :DISPlay:ECHO[:DATA] :DISPlay:TABLe:POSition[:RECTangle] | The E5080A does not have Echo Display.
Inverting image color | :DISPlay:IMAGe | Invert image is not available for E5080A. Query always returns NORMal.
Hardcopy abort | :HCOPy:ABORt | Hard Copy Abort is not supported. Even E5071C with Windows 7 does not support this function.
Inverting image colors for printing | :HCOPy:IMAGe | Invert image for printing is not available for E5080A. Query always returns INVert.
Save ALL mode of saving state files | :MMEMory:STORe:SALL | The E5080A save the state for the displayed channels/traces only. Query always returns OFF.
Setting the trigger source for saving state files | :MMEMory:STORe:STSource:AUTO | The trigger source always remains as per user's setting at loading state file for the E5080A. Query always returns OFF.
Functions related to E5071C’s built-in VBA | :PROGram:CATalog :PROGram[:SELected]:NAME | The E5080A does not have built-in VBA.
 | :PROGram[:SELected]:STATe | Query always returns STOP.
Offset load and Sliding load calibrations | :SENSe<ch>:CORRection:COLLect[:ACQuire]:OLOad:LINE :SENSe<ch>:CORRection:COLLect[:ACQuire]:OLOad:LOAD:CLEar :SENSe<ch>:CORRection:COLLect[:ACQuire]:OLOad:LOAD:COUNt :SENSe<ch>:CORRection:COLLect[:ACQuire]:OLOad:LOAD:DONE :SENSe<ch>:CORRection:COLLect[:ACQuire]:OLOad:LOAD[:EXECute] :SENSe<ch>:CORRection:COLLect[:ACQuire]:SLOad:CLEar :SENSe<ch>:CORRection:COLLect[:ACQuire]:SLOad:COUNt :SENSe<ch>:CORRection:COLLect[:ACQuire]:SLOad:DONE :SENSe<ch>:CORRection:COLLect[:ACQuire]:SLOad:LOAD[:EXECute] :SENSe<ch>:CORRection:COLLect[:ACQuire]:SLOad:TRLLine[:EXECute] :SENSe<ch>:CORRection:COLLect[:ACQuire]:TRLLine :SENSe<ch>:CORRection:COLLect[:ACQuire]:TRLReflect :SENSe<ch>:CORRection:COLLect[:ACQuire]:TRLThru :SENSe<ch>:CORRection:COLLect:ADAPter<pt>:LENGth :SENSe<ch>:CORRection:COLLect:ADAPter<pt>:ROTate :SENSe<ch>:CORRection:COLLect:ADAPter<pt>:WAVeguide:CUToff :SENSe<ch>:CORRection:COLLect:ADAPter<pt>:WAVeguide:LENGth :SENSe<ch>:CORRection:COLLect:CLEar | These advanced calibrations are not supported by the E5071C emulation mode. To perform these calibrations, add the E5080A’s commands to your program.
Unknown thru and Adapter removal functions. | :SENSe<ch>:CORRection:COLLect:ECAL:THRU :SENSe<ch>:CORRection:COLLect:METHod:ADAPter:REMoval | Unknown thru and Adapter removal functions are not supported. To perform these calibrations, add the E5080A’s commands to your program.
Enhanced response cal, Full 3/4-port SOLT cal, TRL cal | :SENSe<ch>:CORRection:COLLect:METHod:ERESponse :SENSe<ch>:CORRection:COLLect:METHod:SOLT3 :SENSe<ch>:CORRection:COLLect:METHod:SOLT4 :SENSe<ch>:CORRection:COLLect:METHod:TRL2 :SENSe<ch>:CORRection:COLLect:METHod:TRL3 :SENSe<ch>:CORRection:COLLect:METHod:TRL4 | These advanced calibrations are not supported by the E5071C emulation mode. To perform these calibrations, add the E5080A’s commands to your program.
Partial cal overwrite | :SENSe<ch>:CORRection:COLLect:PARTial:SAVE | The E5080A does not have partial overwrite calibration function.
Simplified calibration | :SENSe<ch>:CORRection:COLLect:SIMPlified:SAVE | The E5080A does not have simplified calibration function.
The calibration functions in the Frequency Offset Mode | :SENSe<ch>:CORRection:OFFSet:CLEar :SENSe<ch>:CORRection:OFFSet:COLLect[:ACQuire]:LOAD :SENSe<ch>:CORRection:OFFSet:COLLect[:ACQuire]:OPEN :SENSe<ch>:CORRection:OFFSet:COLLect[:ACQuire]:PMETer :SENSe<ch>:CORRection:OFFSet:COLLect[:ACQuire]:SHORt :SENSe<ch>:CORRection:OFFSet:COLLect[:ACQuire]:THRU :SENSe<ch>:CORRection:OFFSet:COLLect:CLEar :SENSe<ch>:CORRection:OFFSet:COLLect:ECAL:SMIX2 :SENSe<ch>:CORRection:OFFSet:COLLect:ECAL:SOLT1 :SENSe<ch>:CORRection:OFFSet:COLLect:METHod:SMIX2 :SENSe<ch>:CORRection:OFFSet:COLLect:METHod:SOLT1 :SENSe<ch>:CORRection:OFFSet:COLLect:SAVE :SENSe<ch>:CORRection:PROPerty :SENSe<ch>:MULTiplexer<id>:OUTPut[:DATA] :SENSe<ch>:OFFSet:ASPurious | The calibration functions for Frequency Offset Mode are not supported by the E5071C emulation mode. To perform these calibrations, add the E5080A’s commands to your program.
Functions related to the Frequency Offset Mode | :CALCulate<ch>[:SELected]:MIXer:XAXis | Query always returns NORMal.
 | :CALCulate<ch>:TRACe<tr>:MIXer:XAXis | Query always returns RESPonse.
 | :CALCulate<ch>[:SELected]:OFFSet:XAXis :CALCulate<ch>:TRACe<tr>:OFFSet:XAXis :SENSe<ch>:OFFSet:LOCal:CONTrol[:STATe] :SENSe<ch>:OFFSet:LOCal[:FREQuency]:DATA :SENSe<ch>:OFFSet:LOCal[:FREQuency]:DIVisor :SENSe<ch>:OFFSet:LOCal[:FREQuency]:MULTiplier :SENSe<ch>:OFFSet:LOCal[:FREQuency]:OFFSet :SENSe<ch>:OFFSet:LOCal[:FREQuency]:STARt :SENSe<ch>:OFFSet:LOCal[:FREQuency]:STOP :SENSe<ch>:OFFSet:LOCal:POWer[:LEVel][:IMMediate][:AMPLitude] :SENSe<ch>:OFFSet:LOCal:POWer[:LEVel]:SLOPe[:DATA] :SENSe<ch>:OFFSet:LOCal:POWer[:LEVel]:SLOPe:STATe :SENSe<ch>:OFFSet:LOCal:STATe :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:DATA :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:DIVisor :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:MULTiplier :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:OFFSet :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:STARt :SENSe<ch>:OFFSet:PORT<pt>[:FREQuency]:STOP :SENSe<ch>:OFFSet[:STATe] | The calibration functions for Frequency Offset Mode are not supported by the E5071C emulation mode. To perform these functions, add the E5080A’s commands to your program.
Segment list item control | :SENSe<ch>:SEGMent:LIST:CONTrol:STATe | The segment list item is fixed for the E5080A. Query always returns RESPonse.
Backlight | :SYSTem:BACKlight | The E5080A cannot turn on/off backlight.
Signal generator control | :SYSTem:COMMunicate:GPIB:SGENerator:ADDRess :SYSTem:COMMunicate:GPIB:SGENerator:CCOMmand:FREQuency :SYSTem:COMMunicate:GPIB:SGENerator:CCOMmand:POWer :SYSTem:COMMunicate:GPIB:SGENerator:CCOMmand:PRESet :SYSTem:COMMunicate:GPIB:SGENerator:CCOMmand:RFON :SYSTem:COMMunicate:GPIB:SGENerator:DWELl :SYSTem:COMMunicate:GPIB:SGENerator:TYPE | Signal Generator control is not supported by the E5071C emulator mode.
Control functions for the E5091A multiport test set | :SENSe<ch>:MULTiplexer<id>:OUTPut[:DATA] :SENSe<ch>:MULTiplexer<id>:TSET9:OUTPut[:DATA] :SENSe<ch>:MULTiplexer<id>:TSET9:PORT1 :SENSe<ch>:MULTiplexer<id>:TSET9:PORT2 :SENSe<ch>:MULTiplexer<id>:TSET9:PORT3 :SENSe<ch>:MULTiplexer<id>:TSET9:PORT4 | The E5080A does not support the E5091A.
Keyboard lock | :SYSTem:KLOCk:KBD | The E5080A cannot turn on/off keyboard lock. Query always returns OFF.
Commands for E5070B/E5071B | :SENSe:CORRection:COLLect:ECAL:ISOLation:STATe :SYSTem:TEMPerature:HIGH :SYSTem:TEMPerature[:STATe] :SENSe<ch>:SWEep:ASPurious | These commands do nothing even in the E5071C. These commands are provided because of its command compatibility with E5070B/E5071B. Query always returns OFF.
External test set mode | :SYSTem:TSET[:EXTernal] | The E5080A does not have the external test set mode. Query always returns OFF.
RF range auto for 8 term calibration | :SERVice:ADJust:SENSe<ch>:SWEep:RF:RANGe:PORT<pt>:AUTO | The E5080A does not support the RF range auto for 8 term calibration.

Partially supported commands.

The E5080A code emulator will attempt to translate the following commands to approximate the behavior of the E5071C commands. However, the results may include important operational or behavioral differences.

Commands

Description

:CALCulate<ch>:PARameter<tr>:COUNt

Once increased, cannot be reduced

:CALCulate<ch>:PARameter<tr>:SPORt

Save/Recall/Preset are not applied

:CALCulate<ch>:PARameter<tr>:TNAMe:DATA

Save/Recall/Preset are not applied

:CALCulate<ch>:PARameter<tr>:TNAMe:SPORt

Save/Recall are not applied

:CALCulate<ch>[:SELected]:CONVersion[:STATe]

:CALCulate<ch>:TRACe<tr>:CONVersion[:STATe]

When this is turned off, then conversion type is set at default.

:CALCulate<ch>[:SELected]:FUNCtion:TYPE

:CALCulate<ch>:TRACe<tr>:FUNCtion:TYPE

PEAK, APEak, ATARget are not supported

:CALCulate<ch>[:SELected]:MARKer<mk>:BWIDth[:STATe]

:CALCulate<ch>:TRACe<tr>:MARKer<mk>:BWIDth[:STATe]

It is not possible to use both bandwidth search and notch search at the same time. When this is turned on, Notch search is turned off automatically.

:CALCulate<ch>[:SELected]:MARKer<mk>:FUNCtion:DOMain:MULTiple:RANGe

:CALCulate<ch>:TRACe<tr>:MARKer<mk>:FUNCtion:DOMain:MULTiple:RANGe

Query returns indeterminate value, if Multi state OFF

:CALCulate<ch>[:SELected]:MARKer<mk>:NOTCh[:STATe]

:CALCulate<ch>:TRACe<tr>:MARKer<mk>:NOTCh[:STATe]

It is not possible to use both bandwidth search and notch search at the same time. When this is turned on, bandwidth search is turned off automatically.

:CALCulate<ch>[:SELected]:MARKer<mk>:REFerence[:STATe]

:CALCulate<ch>:TRACe<tr>:MARKer<mk>:REFerence[:STATe]

Once turned on, this cannot be turned off

:CALCulate<ch>[:SELected]:MARKer<mk>:SET

:CALCulate<ch>:TRACe<tr>:MARKer<mk>:SET

RMARker is not supported.

:CALCulate<ch>[:SELected]:MARKer<mk>[:STATe]

:CALCulate<ch>:TRACe<tr>:MARKer<mk>[:STATe]

Once turned on, this cannot be turned off

:CALCulate<ch>[:SELected]:PLIMit:DATA

:CALCulate<ch>:TRACe<tr>:PLIMit:DATA

If there is unexpected data, query command returns error

:CALCulate<ch>[:SELected]:SMOothing:APERture

:CALCulate<ch>:TRACe<tr>:SMOothing:APERture

Approximate to the nearest NOP-based percentage

:DISPlay:FSIGn

The default value is OFF which is different from the E5071C

:DISPlay:SPLit

If D1 is selected,it is converted to channel/sheet layout .For the other parameters, the channel is separated with sheet..

:DISPlay:TABLe[:STATe]

Table types of ECHO, PLOSs, SCFactor and RLIMit are not supported. In this case, the setting of ON doesn't work. Setting OFF works for all display types.

:DISPlay:TABLe:TYPE

ECHO, PLOSs, SCFactor and RLIMit are not supported and these tables are not shown.

:DISPlay:WINDow<ch>:SPLit

If D1 is selected, it is converted to channel/window layout. For the other parameters, it is converted to trace/window layout.

:MMEMory:LOAD[:STATe]

:MMEMory:STORe:STYPe is only CDState. both the file with .sta and .csa can be used as the parameter, and are loaded as *.csa.

:MMEMory:LOAD:PLIMIt

Point limit function is not available on the E5080A. Use :MMEMory:LOAD:LIMIt

:MMEMory:STORe[:STATe]

:MMEMory:STORe:STYPe is only CDState. both the file with .sta and .csa can be used as the parameter, and are saved as *.csa.

:MMEMory:STORe:STYPe

Only CDState is available. STATe, CSTate, DSTate is ignored. Query always returns CTState.

:SENSe<ch>:CORRection:CLEar

This also clears the receiver calibration correction data.

:SENSe<ch>:CORRection:COLLect:ECAL:PATH

Only support 2 or 4 port ECal module

:SENSe<ch>:CORRection:COLLect:ECAL:UCHar

Channel number is ignored.

:SENSe<ch>:CORRection:COLLect:ECAL:UTHRu[:STATe]

Unknown Thru for Ecal is always ON for the E5080A. Query always returns ON.

:SENSe<ch>:CORRection:EXTension:PORT<pt>[:TIME]

The specified values are common for both coax and wave

:SENSe<ch>:CORRection:EXTension:PORT<pt>:WAVeguide:TIME

The specified values are common for both coax and wave

:SENSe<ch>:CORRection:RECeiver<pt>:OFFSet[:AMPLitude]

This setting is applied for all ports in the selected channel. The port number is ignored.

:SENSe<ch>:CORRection:RECeiver<pt>[:STATe]

This command executes SENS:CORR:STAT

:SENSe<ch>:CORRection:TRIGger:FREE[:STATe]

Use Internal trigger forcibly, when Manual trigger source mode

:SENSe<ch>:CORRection:TYPE<tr>

  • When ERES (enhance response) is set. the query returns ERES,x,y,0,0. for both cases of Syx and Sxy.

  • When the RESPS (response short) is set, the query returns RESPO (response open)

:SENSe<ch>:DATA:CORRdata

:SENSe<ch>:DATA:RAWData

Zero are returned, when non-corrected and non-displayed S parameters are selected

:SENSe<ch>:SEGMent:DATA

Query frequency format is always start/stop

:SENSe<ch>:SEGMent:LIST:BWIDth:PORT<pt>[:RESolution]

Shared value is used in port-coupled-IFBW and uncoupled-IFBW at Port1

:SENSe<ch>:SEGMent:LIST:POWer:PORT<pt>:STATe

:SOUR:POW:PORT:COUP is linked. When this port state is [ON/OFF], then coupling is [OFF/ON].

:SERVice:ADJust:RF:RANGe:FIxed[:STATe]

The E5071C emulation mode always detects overload while the

:SYSTem:BEEPer:COMPlete:STATe

:SYSTem:BEEPer:WARNing:STATe

The setting is coupled and have the same setting.

:SYSTem:DATE

Execution error occurs at setting time and date.

:SYSTem:ERRor

VNA SYST:ERR:NEXT? in Parser is called

:SYSTem:ISPControl:PORT

No need to set any port for Initial Source Port Control unlike E5071C

:SYSTem:KLOCk:MOUSe

Mouse is not locked by this command.

:SYSTem:TIME

Execution error occurs at setting time and date.

Modify Cal Kit

The modification of a factory default Cal Kit is partially supported.

Supported:

  • Modify a defined value of a standard.

Not supported:

  • Add a new standard.

  • Remove a standard.

  • Change an order of subclass.

Alternatively, the modification of your custom Cal Kit is completely supported.

Cal Kit ID | Description
1 to 21 | factory default Cal Kits.
22 to 36 | Are used for the code emulation. Note that if you modify a Cal Kit which is used for the code emulation, then a calibration won’t work correctly. Use SENS:CORR:COLL:CKIT:RES to restore the all Cal Kit files to their factory default definitions.
37 to 99 | No assignment. You can create a new custom Cal Kit.

The conversion of subclass order in the E5071C code emulator

Cal Kit ID in E5071C and E5071C code emulator | Cal Kit name in E5071C | Cal Kit ID in E5080A | Cal Kit name in E5080A
1 | 85033E | 9 | 85033D/E
2 | 85033D | 9 | 85033D/E
3 | 85052D | 7 | 85052D
4 | 85032F | 1 | 85032F
5 | 85032B/E | 2 | 85032B/E
6 | 85036B/E | 5 | 85036B/E
7 | 85031B | 24 | 85031B
8 | 85050C/D | 22 | 85050C
9 | 85052C | 10 | 85052C
10 | 85038A/F/M | 20 | 85038A
11 | 85054D | 4 | 85054D
12 | 85056D | 12 | 85056D
13 | 85056K | 15 | 85056K
14 | 85039B | 6 | 85039B
15 | X11644A | 27 | X11644A
16 | P11644A | 28 | P11644A
17 | K11644A | 29 | K11644A
18 | 85050B | 21 | 85050B
19 | 85052B | 8 | 85052B
20 | 85054B | 3 | 85054B
21 | 85056A | 11 | 85056A

The conversion of subclass order in the E5071C code emulator

Subclass orders of some factory default Cal Kits of the E5080A are different from the E5071C. In the E5071C code emulator, subclass orders are converted automatically. Note that subclass orders if you create a custom Cal Kit from an exist Cal Kit.

Cal Kit name in E5071C | Subclass index in E5071C and E5071C code emulator | Subclass index in E5080A
85032F, 85036B/E | OPEN 1 | OPEN 2
 | OPEN 2 | OPEN 1
 | SHORT 1 | SHORT 2
 | SHORT 2 | SHORT 1
85032B/E | OPEN 1 | OPEN 2
 | OPEN 2 | OPEN 1
 | SHORT 1 | SHORT 2
 | SHORT 2 | SHORT 1
 | LOAD 1 | LOAD 2
85052B | OPEN 5 | OPEN 2

Maximum number of Cal Kit, standard, subclass

The maximum number of calkit and subclass are different from the E5071C.

Description | E5071C | Code emulator for E5071C
Cal Kit | 30 | 99
Standard | 30 | 30
Subclass | 30 | 7

How to perform advanced calibrations

The calibrations that can be performed with the translated E5071C calibration commands are only the following ones;

  • Mechanical calibration

    • Response calibration (Open, Short and Thru)

    • Full 1 port calibration

    • 2 port SOLT calibration with defined Thru

    • Isolation calibration

  • Ecal

    • Full 1,2 port calibration with 2 port Ecal module

    • Full 1/2/3/4-port ECal with factory cal data

    • Enhance response calibration

    • Unknown Thru Calibration

    • Ecal User Characterization

    • Confidence Check

    • To turn off auto orientation

  • Source power calibration

  • Receiver power calibration (Both correction states of SOLT calibration and receiver calibrations are shared.

If you want to perform the following advanced calibrations in the E5071C code emulation mode, modify your test program to add the whole calibration routine using the E5080A calibration commands;

  • Mechanical calibration

    • Enhanced response calibration

    • 2 port SOLT calibration with unknown thru

    • 3, 4-port SOLT calibration

    • Mixed-connector cal,

    • 2, 3, 4 TRL calibration

  • Ecal

    • Full 3,4 port calibration with 2 port Ecal module

    • Thru response calibration

    • Defined Thru

Use the following E5080A commands to perform these advanced calibrations in the E5071C code emulation mode;

  • SENSe<ch>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect] <conn>

  • SENSe<ch>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect] <kit>

  • SENSe<ch>:CORRection:COLLect:GUIDed:INITiate[:IMMediate] [string][, bool][,char]

  • SENSe<ch>:CORRection:COLLect:GUIDed:STEPs?

  • SENSe<ch>:CORRection:COLLect:GUIDed:DESCription? <step>

  • SENSe<ch>:CORRection:COLLect:GUIDed[:ACQuire] <std>[,sync]

  • SENSe<ch>:CORRection:COLLect:GUIDed:SAVE[:IMMediate] [bool]

  • SENSe<ch>:CORRection:COLLect:GUIDed:PATH:CMEThod <port1>,<port2>,<caltype1[,caltype2]>

  • SENSe<ch>:CORRection:COLLect:GUIDed:PATH:TMEThod <port1>,<port2>,<thruType1[,thruType2]>

  • SENSe<ch>:CORRection:COLLect:GUIDed:THRU:PORTs <t1a, t1b, t2a, t2b, t3a, t3b...>

  • SENSe<ch>:CORRection:COLLect:GUIDed:ABORt

The following commands are operated as SYNChronous

  • :SENSe<ch>:CORRection:COLLect:GUIDed:INITiate[:IMMediate] [string][, bool][,char]

  • :SENSe<ch>:CORRection:COLLect:GUIDed[:ACQuire] <std>[,sync]

Sample Program

The following shows an example for performing the mechanical 3-port SOLT cal in the E5071C emulation mode;

  • Setup the 4 trace with the E5071C commands

  • Execute the full 3 port calibration with the E5080A commands

Sub SampleGuidedCal2Port()
'*** The variables of the resource manager and the instrument I/O are declared.
Dim ioMgr As VisaComLib.ResourceManager
Dim GPIB As VisaComLib.FormattedIO488
'*** The memory area of the resource manager and the instrument I/O are acquired.
Set ioMgr = New VisaComLib.ResourceManager
Set GPIB = New VisaComLib.FormattedIO488
'*** Open the instrument.
Set GPIB.IO = ioMgr.Open("GPIB1::16::INSTR")
GPIB.IO.timeout = 10000

Dim numSteps As Integer, strPrompt As String
'
' Setup for 4 traces with the E5071C commands
'
GPIB.WriteString ":SYST:PRES", True 'Set number of traces'

GPIB.WriteString ":CALC1:PAR:COUN 4", True 'Set number of traces
GPIB.WriteString ":DISP:SPL D1_2", True 'Set graph layout
'
GPIB.WriteString ":CALC1:PAR1:DEF S11", True 'Set measurement parameter
GPIB.WriteString ":CALC1:PAR1:SEL", True ' Make trace active
GPIB.WriteString ":CALC1:FORM SMITH", True ' Set data format
'
GPIB.WriteString ":CALC1:PAR2:DEF S21", True 'Set measurement parameter
GPIB.WriteString ":CALC1:PAR2:SEL", True ' Make trace active
GPIB.WriteString ":CALC1:FORM MLOG", True ' Set data format
'
GPIB.WriteString ":CALC1:PAR3:DEF S12", True 'Set measurement parameter
GPIB.WriteString ":CALC1:PAR3:SEL", True ' Make trace active
GPIB.WriteString ":CALC1:FORM MLOG", True ' Set data format
'
GPIB.WriteString ":CALC1:PAR4:DEF S31", True 'Set measurement parameter
GPIB.WriteString ":CALC1:PAR4:SEL", True ' Make trace active
GPIB.WriteString ":CALC1:FORM MLOG", True ' Set data format
'
' Execute the 3-port SOLT calibration with the E5080A commands
'
' Specify the DUT connectors
GPIB.WriteString ":SENS:CORR:COLL:GUID:CONN:PORT1 ""APC 3.5 female""", True
GPIB.WriteString ":SENS:CORR:COLL:GUID:CONN:PORT2 ""APC 3.5 male""", True
GPIB.WriteString ":SENS:CORR:COLL:GUID:CONN:PORT3 ""APC 3.5 male"" ", True
GPIB.WriteString ":SENS:CORR:COLL:GUID:CONN:PORT4 ""Not used"" ", True
' Select the Cal Kit for each port being calibrated.
GPIB.WriteString ":SENS:CORR:COLL:GUID:CKIT:PORT1 ""85052D""", True
GPIB.WriteString ":SENS:CORR:COLL:GUID:CKIT:PORT2 ""85052D""", True
GPIB.WriteString ":SENS:CORR:COLL:GUID:CKIT:PORT3 ""85052D""", True
MsgBox "Cal kits defined for Ports 1 to 3 "
' Initiate the calibration and query the number of steps
GPIB.WriteString ":SENS:CORR:COLL:GUID:INIT"
GPIB.WriteString ":SENS:CORR:COLL:GUID:STEPS?"
numSteps = GPIB.ReadNumber
MsgBox "Number of steps is " + CStr(numSteps)
' Measure the standards
'The following series of commands shows that standards
'can be measured in any order. These steps acquire
'measurement of standards in reverse order.
'It is easiest to iterate through standards using
'a For-Next Loop.
For i = numSteps To 1 Step -1
step = "Step " + CStr(i) + " of " + CStr(numSteps)
GPIB.WriteString ":SENS:CORR:COLL:GUID:DESC? " + CStr(i)
strPrompt = GPIB.ReadString
MsgBox strPrompt, vbOKOnly, step
GPIB.WriteString ":SENS:CORR:COLL:GUID:ACQ STAN" + CStr(i), True
Next
' Conclude the calibration
GPIB.WriteString ":SENS:CORR:COLL:GUID:save", True
MsgBox "Cal is done!"

'*** End procedure
GPIB.IO.Close
End Sub

Trace/channel/window layouts

In the E5071C code emulation mode, the possible trace/channel/window layouts are limited. The layouts depend on the E5071C commands executed in your program. The traces in one channel are all split to different windows one by one, or all plotted in the same window. The multiple channels are assigned to different tabbed sheets, or to one tabbed sheet (only when the traces in one channel are plotted to one window). The following shows some examples of how the layouts are made by the E5071C commands on the E5080A display. If necessary, modify your program to get your desired layout.

Note: If the number of channels you set in the dialog box is greater than the number of channels actually used in your measurement, the unused channels are displayed as blank channels, as described before.

Ch1: four traces, one window per trace

:DISP:SPL D1

:CALC1:PAR:COUN 4

:DISP:WIND1:SPL D1234 (or any parameters excepts for D1)

Ch1: four traces and Ch2: four traces, one window per channel

:DISP:SPL D12

:CALC1:PAR:COUN 4

:CALC2:PAR:COUN 4

(Do not execute :DISP:WINDx:SPL D1 here. If your program has this command, delete it.)

Ch1:Trace-1 to 4 and Ch2:Trace-1 to 4, one window per channel, one sheet per channel

:DISP:SPL D12

:CALC1:PAR:COUN 4

:CALC2:PAR:COUN 4

:DISP:WIND1:SPL D1

:DISP:WIND2:SPL D1

Ch1:Trace-1 to 4 and Ch2:Trace-1 to 4, one window per trace, one sheet per channel

:DISP:SPL D12

:CALC1:PAR:COUN 4

:CALC2:PAR:COUN 4

:DISP:WIND1:SPL D1234 (or any parameters excepts for D1)

:DISP:WIND2:SPL D1234


時域

時域允許您作為時間的函數檢視裝置回應。本主題討論以下內容：

  • 概觀

  • VNA 在時域中如何量測

  • 時域的校準

  • 傳輸量測

  • 量測回應解析度

  • 量測範圍和別名回應

  • 如何進行時域設定

  • 閘控

  • 視窗設定

附註：時域量測僅適用於帶有選件 010 的 VNA。請參閱 VNA 選件

請參閱更新的應用備註：使用網路分析器的時域分析。

概觀

正常作業中，VNA 作為頻率的函數測量測試裝置的特性。對於時域（選件 010），頻率資訊用來計算反向傅立葉轉換，並使用時間作為水平顯示軸顯示量測值。回應值在時間上顯示為分隔，允許從不同的角度顯示測試裝置的效能和限制。

下圖比較了頻域和時域上的相同纜線反射量測資料。纜線具有兩處彎曲。每處彎曲在線路阻抗上均導致不匹配或變更狀況。

  • 頻域 S11 量測顯示了由於纜線上的不相符導致的反射。無法確定不匹配出現在纜線中的實際位置。

  • 時域回應顯示每個不相符的位置和幅度。回應表示第二處纜線彎曲是重大不匹配的位置。此不匹配可能是門輸出，允許您檢視頻域回應，就如同不匹配不存在一般。可以使用距離標記精確定位不匹配和參考平面之間的距離。

VNA 在時域中如何量測

時域轉換模式模擬傳統的時域反射器 (TDR)，其向測試裝置中發射脈衝或步階訊號，並在 TDR 螢幕上顯示反射能量。透過分析幅度、持續時間和反射波形的形狀，您可以確定測試裝置中阻抗變化的性質。

VNA 不啟動實際入射脈衝或步階。相反，傅立葉轉換演算法用於透過頻率量測來計算時間資訊。下面顯示如何發生這種情況。

時域里的單一頻率顯示為正弦波。在下圖中，當我們新增基頻 (F0)、一次諧波 (2F0)，然後新增二次諧波 (3F0) 時，我們可以看見脈衝形狀為總波形。如果我們要新增更多的頻率元件，脈衝將變的更銳利、更窄。當 VNA 將離散頻率傳送至測試裝置時，實際上是分別發送脈衝的每條譜段以激勵測試裝置。

在 S11 反射量測期間，這些入射訊號從測試裝置反射，並在接收器 A 中進行測量。這適用於時域轉換計算結果用於一起新增單獨譜段的情況。

例如，以開路終止的較短纜線長度。將反射入射訊號中的所有功率，並且反射與入射訊號「同相」。每個頻率元件新增在一起，我們將看到與模擬入射（如上）相同的圖樣。反射幅度與阻抗不匹配相關，延遲和不匹配的距離成等比例。從上圖變更的 X 軸（時間）比例可以更好地顯示延遲。

但是，以短路終止的相同纜線也會反射所有的入射功率，但相位偏移 180 度。由於反射的頻率元件加在一起，總計相當於延時的負脈衝。

時域的校準

簡單而言，我們已經討論過測試裝置中入射訊號的不連續性。迄今為止，最常見的轉換至時域的網路分析器量測是比率化 S11 量測。 S11 反射量測不是簡單地顯示在接收器 A 測量的反射，而是顯示接收器 A 與參考接收器之間的比率（或差值）。此外，還可以校準 S11 量測以將系統性誤差從比率化量測中移除。因為量測平面（校準點）在 X 軸時間比例上變為零，這在時域中很關鍵。相對此點顯示所有的時間和距離資料。因此，幅度和時間均經過校準且很準確。

下面顯示時域轉換在 VNA 資料流程中出現的位置：（請參閱資料存取圖）

  1. 獲取原始接收器（A 和 R1）資料

  2. 執行比率 (A/R1)

  3. 套用校準

  4. 將資料轉換為時域

  5. 顯示結果

因此，即使可能會顯示時域軌跡，但是始終會執行校準，並將其套用於不會顯示的頻域量測。

傳輸量測

最常見的轉換量測類型是 S11 反射量測。但是，可以透過轉換 S21 傳輸量測的測試裝置獲取有用資訊。頻率元件通過測試裝置，並在接收器 B 進行測量。如果有多個路徑通過裝置，它們將顯示為在時間上分隔的不同脈衝。

例如，下列傳輸量測顯示在表面聲波 (SAW) 濾波器中傳播的多個路徑。最大脈衝（接近時間零點）表示通過裝置的最短路徑的擴散時間。其可能不是最大脈衝或表示所需路徑。每個後續脈衝表示從輸入到輸出的另一種可能路徑。

三次行程是一個術語，用來描述從輸出反射的訊號從輸入再次被反射，最後重新出現在輸出位置。這可以在時域 S21 量測中看到。

量測回應解析度

在上一段落中，我們已經見過使用更多的頻率元件會造成組合波形顯示更多詳細資料。這就是所謂的量測回應解析度，定義為能夠區分兩個密集回應的能力。

附註：調整轉換時間設定可以改善顯示解析度，但無法提高量測解析度。

下圖顯示了窄和寬頻率跨距對回應解析度的影響。更寬的頻率跨距可以使分析器將兩個接頭解析為單獨的不同回應。

解析度公式

對於幅度相等的回應，回應解析度相當於脈衝寬度點數的 50% (−6 dB)，或定義為 10% 至 90% 點數的步階上升時間，如下圖所示。

下表顯示了對於幅度相同的回應，頻率跨距與回應解析度相關視窗選擇之間的近似關係。

視窗 | 低通步階 （10% 至 90%） | 低通脈衝 (50%) | 帶通脈衝
最小值 | 0.45/f 跨距 | 0.60/f 跨距 | 1.20/f 跨距
一般 | 0.99/f 跨距 | 0.98/f 跨距 | 1.95/f 跨距
最大值 | 1.48/f 跨距 | 1.39/f 跨距 | 2.77/f 跨距

例如，在帶通脈衝模式下使用 10 GHz 寬頻率跨距和一般視窗時，回應解析度（時間）等於：

  • 時間解析度 = 1.95/頻率跨距

  • 時間解析度 = 1.95/10 GHz

  • 時間解析度 = 195 ps

若要計算可以解析的回應的實際距離（距離），將此值與光速 (c) 以及在實際傳輸媒體中傳播的相對速度 (Vf) 相乘。在本例中，聚乙烯絕緣介質 Vf = 0.66。

  • 距離解析度 = 195 ps x c x Vf

  • 距離解析度 = 195 ps x (2.997925 E8 m/s) x .66

  • 距離解析度 = 38 mm

對於反射量測，因為涉及雙向傳播時間，這意味著不連續性之間的最小可解析距離是此值的一半或 19 mm。

雖然更寬的頻率跨距可使得量測解析度更佳，但是量測範圍卻變得有限。此外，增加頻率範圍可能會導致量測校準無效。請務必在執行校準前調整頻率跨距。

量測範圍和別名回應

量測範圍是時間長度，可在其中可以看到真實的時域回應。量測範圍應該足夠大，才能看見整個測試裝置回應，而不會遇到重複的（別名）回應。 別名回應會隱藏真實的時域回應。

若要增加兩種模式的量測範圍，請變更這些設定中的其中一項：

  • 增加點數

  • 減小頻率跨距

備註：

  • 變更這些設定後，您可能需要調整轉換時間設定以查看新的量測範圍。

  • 減小頻率跨距會降低量測解析度。

  • 在校準前設定頻率跨距和點數。

  • 最大範圍也取決於測試裝置的損耗。如果傳回的訊號太小而無法測量，範圍受限，與頻率跨距無關。

別名回應

別名回應不是真實的裝置回應。因為每個時域波形有許多時段，隨時間重複，別名回應重複（請參閱 VNA 在時域中如何量測）。別名回應在等於 1/頻率步長的時間間隔發生。

VNA 調整轉換時間設定，您應該僅在時間零點（正和負）的每側看到一個無別名範圍。 但是，僅當工具列設定中的一項發生變更時，這些設定才會更新。

若要判定回應是否真實，請將標記放在回應上，並變更頻率跨距。真實的回應不會隨著時間移動。別名回應會移動。

例如，在上圖中，標記 1 回應發生在 14.07 英吋處。一旦頻率跨距發生變更，此回應仍保持在 14.07 英吋處。標記 2 回應將會移動。

範圍公式

您可以使用下列用於 TDR（反射）量測的公式來計算 VNA 的無別名量測範圍（以公尺為單位）：

範圍（公尺）= (1/Δf) x Vf x c

其中：

  • Δf = 頻率步長（頻率跨距/點數-1）

  • Vf = 傳輸線路中的速度因數

  • c = 光速 = 2.997925 E8 m/s

例如：對於 401 點的量測和 2.5 GHz 的跨距，使用聚乙烯纜線 (Vf = 0.66)

  • 範圍 = (1 / (2.5E9 / 400)) x 2.997925 E8 m/s x 0.66

  • 範圍 = 6.25E6 x 2.997925 E8 m/s x 0.66

  • 範圍 = 32 公尺

在此例中，實際長度範圍是 32 公尺。為防止時域回應重疊或產生別名，用於傳輸量測的測試裝置的實體長度必須是 32 公尺或更短。

若要計算反射量測的單向距離而不是來回行程距離，只需將長度除以 2。 在此例中，無別名的範圍將是 16 公尺。

如何進行時域設定

使用硬鍵/SoftTab/軟鍵

  1. 按 [Math] > Time Domain（時域）> Time Domain Setup...（時域設定...）

轉換對話方塊/ 數學 > 時域 Softtab 說明

轉換 開啟和關閉時域轉換。

時間設定

下列設定可調整顯示解析度，允許您縮小或放大回應。不會調整量測範圍或量測解析度。

這些設定會自動更新（當更新這些值中之一時），將顯示在時間零點的每一側限制為一個無別名回應。

啟動 設定顯示在 VNA 螢幕上的轉換開始時間。

附註：零 (0) 秒始終是量測參考平面。如果移動參考平面，則負值是有用的。

停止 設定顯示在 VNA 螢幕上的轉換停止時間。

中心 設定顯示在 VNA 螢幕中心的轉換中心時間。

跨距 設定分割在「中心」值任一側的轉換跨距時間。

轉換模式

轉換模式是關於如何將時域轉換演算法套用在頻域量測上的三種變化。每個方法具有唯一的應用。

模式 | 效益 - 應用 | 限制
低通脈衝 | 最高解析度。 最適合查看傳遞低頻率的裝置（例如電纜）的微小回應。 | 在兩個低通模式下，外插降至直流的頻率和負頻率。所以，當您按一下設定頻率低通時將會調整啟動頻率。 因為這將會影響校準準確度，因此請確保在完全設定您的時域量測後再進行校準。
低通步階 | 識別傳遞低頻率的裝置（例如電纜）中感應和電容不連續性的最簡單方法。
帶通脈衝 | 最容易的方法 - 可以和任何頻率掃描一起使用。 對於測量有限頻寬裝置（例如濾波器和直流封鎖纜線）最有用的方法。 | 不顯示感應式和電容式電抗 對於相同的頻率跨距和點數，帶通模式使脈衝寬度翻倍，這會隱藏間隔緊密的回應，並降低回應解析度。

下列圖表顯示了如何解釋使用低通步階和低通或帶通脈衝模式從各種不連續性阻抗得到的結果。

對量測範圍的影響

帶通模式 - 量測範圍與頻率步長成反比。

低通模式 - 按一下設定低通頻率之後，量測範圍與基本（開始）頻率成反比。

設定低通頻率 僅用於低通模式

重新計算開始頻率和步階頻率作為開始頻率的諧波。依據下列公式計算開始頻率：低通開始頻率 = 停止頻率/點數。

計算得出的值必須始終都大於或等於分析器的最小頻率。

附註： 若要計算出此值，可能需要變更點數或停止頻率。

閘控

時域轉換最有效的功能可能就是閘控功能。檢視一個裝置的時域回應時，閘控功能可用於「虛擬」移除不需要的回應。 您可以同時檢視頻域軌跡，如同不存在不需要的回應一般。這允許您在沒有外部裝置（例如接頭或配接器）影響的狀態下特性化裝置。

附註： 如果測試裝置中的不連續反射了能量，能量不會達到後續的不連續。如此會遮蔽或隱藏真實的回應，如果之前的不連續不存在，則可能會發生此回應。VNA 閘控功能不會補償此情況。

下列量測影像顯示了關於如何使用和執行閘控的一個實用例子。測試裝置是一根 10 英吋的纜線，然後是一個 6 dB 的衰減器，以短路終止。在視窗 2 中，從左到右明確顯示了下列四個不連續性：

  1. 經過校準後測試系統纜線出現的不連續。其是由 -10.74 英吋（在參考平面後）處的標記 2 識別。

  2. 參考平面之後不遠處的 10 英吋裝置纜線不連續。

  3. 最大的不連續是標記 1 顯示的 -12.67 dB（在正向和反向的 6 dB 損耗）處的衰減器和短接。

  4. 最後的不連續是裝置纜線的再反射。

我們將在衰減器回應中進行閘控輸入。將閘控輸出所有其他的回應。

視窗 1。建立原始 S11 頻域軌跡。顯示所有反射的漣波。

視窗 2。建立新的 S11 軌跡 - 相同的通道；新的視窗。開啟轉換。

視窗 3。在轉換軌跡上，開啟閘控。使大型不連續 (2.500ns) 的閘控居中。調整閘控跨距以完全覆蓋不連續。選取帶通閘控類型。

視窗 4。對於原始頻率量測，開啟閘控（轉換保持關閉）。在不受兩個不需要的不連續的影響情況下檢視量測。藍色軌跡是實際移除了不需要的不連續的 6 dB 衰減器的一個量測。視窗 4 中的兩條軌跡之間的不同是"遮蔽"的影響。

瞭解如何啟動「轉換」對話方塊

轉換閘控對話方塊說明

閘控 開啟和關閉閘控。

開始 指定閘控的開始時間。

停止 指定閘控的停止時間。

中心 指定受到閘控功能影響的區域中心的值。此值可以是分析器範圍中的任何位置。

跨距 指定受到閘控功能影響的區域的任一側的值。

閘控類型 定義將為閘控函數執行的濾波器的類型。顯示器上的閘控開始和停止旗標指向想要保留的部分軌跡。

  • 帶通 -將回應保持在閘控跨距中。

  • 帶阻濾波 - 使用閘控跨距移除回應。

閘控形狀 定義閘控函數的濾波器特性。從「最小」、「一般」、「寬度」和「最大」中選擇。

閘控形狀 | 帶通漣波 | 旁瓣位準 | 截止時間 | 最小閘控跨距
最小值 | ±0.1 dB | -48 dB | 1.4/頻率跨距 | 2.8/頻率跨距
一般 | ±0.1 dB | -68 dB | 2.8/頻率跨距 | 5.6/頻率跨距
寬度 | ±0.1 dB | -57 dB | 4.4/頻率跨距 | 8.8/頻率跨距
最大值 | ±0.01 dB | -70 dB | 12.7/頻率跨距 | 25.4/頻率跨距

截止時間--是停止時間（濾波器邊緣為 -6 dB）和第一個旁瓣峰值之間的時間。下圖顯示了整體閘控形狀並列出了每個閘控形狀的特性。

  • T1 是閘控跨距，等於停止時間減去開始時間。

  • T2 是帶通邊緣和 6 dB 點之間的時間，表示濾波器的截止率。

  • T3 是 6 dB 點和門阻帶的邊緣之間的時間。

  • 對於所有濾波器形狀，T2 等於 T3，並且在中心時間兩側的濾波器是相同的。

最小的閘控跨距-- 是截止時間的兩倍。每個閘控形狀都有建議的最低閘控跨距，以用於正確作業。這是閘控有限截止率的結果。如果您指定了小於最小跨距的閘控跨距，回應會顯示下列效果：

  • 扭曲的沒有通帶的閘控形狀

  • 扭曲的形狀

  • 錯誤顯示開始和停止時間

  • 可能增加旁瓣位準

視窗設定

在開始和停止頻率的頻域量測中存在突然轉換，導致在時域回應中出現過沖和響鈴。視窗功能有利於減輕頻域轉換的突變。這使您在時域回應中進行權衡。從下列內容中選擇：

  • 最小視窗 = 更好的回應解析度 - 解析兩個密集回應的能力。

  • 最大視窗 = 動態範圍 - 測量低層級回應的能力。

瞭解如何啟動「轉換」對話方塊

轉換 - 視窗對話方塊說明

視窗設定可平衡回應解析度和動態範圍。

  • 最小視窗 = 最佳回應解析度

  • 最大視窗 = 最佳動態範圍

下列三種方法都可以設定視窗大小。 為獲得最佳結果，進行這些設定時請檢視時域回應。

  • 最小值 - 最大值 用滑鼠移動滑桿來變更視窗大小

  • Kaiser Beta 使用 Kaiser Beta 值來變更視窗大小

  • 脈衝寬度 使用脈衝寬度值來變更視窗大小

瞭解有關視窗調整（上方）的詳細資訊

若要啟動「耦合」對話方塊，請按一下時域設定對話方塊上的耦合標籤。

軌跡耦合設定對話方塊說明

軌跡耦合可讓您變更量測上的時域參數，並使得通道上的所有其他量測發生相同的變更。

例如：

如果您同時檢視頻域量測和時域量測，

並且在此對話方塊中啟用耦合，

且在此對話方塊中核取所有的閘控參數，

還在時域量測上變更了閘控跨距參數，

然後頻域量測會自動變更以反射時域閘控跨距。

附註： 軌跡耦合僅適用於 Y 軸刻度/參考設定。軌跡耦合不會變更您的資料。

耦合開啟/關閉 核取以啟用耦合。作用中通道中的所有量測都已耦合。

下列參數適用於耦合：

轉換參數

激勵 開始、停止、中心和跨距時間設定。

狀態（開啟/關閉） 轉換開啟或關閉

視窗 Kaiser Beta /脈衝寬度

模式 低通脈衝、低通步階、帶通

閘控 參數

激勵 開始、停止、中心和跨距時間設定。

狀態（開啟/關閉） 閘控開啟或關閉

形狀 最小、一般、寬度和最大

類型 帶通和帶阻濾波

若要啟動「標記」對話方塊，請按一下時域設定對話方塊上的標記標籤。

距離標記設定 對話方塊說明

當標記出現在時域量測上時，距離會自動顯示在標記讀數、標記表和列印副本上。 若要瞭解如何在您的量測上建立標記，請參閱標記設定。

透過在低通步階模式的時域軌跡上建立一個標記或將標記格式變更為 R+jX，您可以讀出阻抗和時間的關係。瞭解操作方法。

此對話方塊可讓您自訂時域距離標記讀數。

這些設定僅影響作用中量測（除非在軌跡耦合對話方塊上對距離標記單位進行了耦合）的所有標記的顯示。

標記模式 指定量測類型以確定正確的標記距離。

自動 如果作用中量測是 S 參數，將自動選擇反射或傳輸。如果作用中量測是非 S 參數，則選擇反射。

反射 顯示從來源到接收器以及返回的距離除以二(為了補償回程）。

傳輸 顯示從來源到接收器的距離。

  • 為S 參數量測選取自動。

  • 為任意比率或非等比量測選取反射或傳輸。

單位 為標記距離值的顯示指定測量單位。

速度因數 指定適用於量測校準後插入的裝置媒體的速度因數。聚乙烯絕緣纜線的值是 0.66，PTFE 絕緣體是 0.7。對應光在真空中的速度是 1.0。這在時域中可用於正確顯示時間和距離標記。

也可以在電子延遲和連接埠延伸對話方塊中完成這些設定。

如何啟動時域工具列

使用硬鍵/SoftTab/軟鍵

  1. [Math] > Time Domain（時域）> TD Toolbar（TD 工具列）

在工具列上，按一下更多... 以啟動時域對話方塊

上次修改時間：

2016 年 01 月 06 日

第一版


頻率偏移量測首頁

頻率偏移量測

頻率偏移量測需要 VNA 來源調整為與 VNA 接收器不同的頻率。該功能以 E5080A 選件 009 的形式提供。

  • SMC

    • FCA 概觀

    • SMC 量測

    • 混頻器轉換器設定

  • 頻率偏移模式

    • 向量-混頻器校準


FCA 概觀

頻率轉換器應用

FCA 包含了純量 (SMC) 和向量 (VMC) 量測與校準。

在本主題中：

  • FCA 選件說明

  • SMC 概觀

  • 要求和限制

  • 如何進行 SMC 量測

    • 建立量測

    • 進行量測設定

      • 掃描標籤

        • 區段掃描

      • 功率標籤

      • 混頻器設定標籤（個別主題）

      • 選取 X 軸顯示

      • 儲存軌跡資料

另請參閱

  • SMC 量測和校準

  • 設定外部 LO 來源

  • 若要詳細瞭解 FCA，請參閱混頻器量測應用程式附註。

其他應用程式主題

FCA 選件說明

  • E5080A 選件 009 提供了 純量混頻器 (SMC) 和向量混頻器 (VMC) 量測。

附註： E5080A 的 VMC 由巨集提供。

SMC 概觀

純量混頻器校準

概觀

為轉換損耗/增益的量測提供最高純量準確度。

結合 SOLT 與功率表校準。

比向量混頻器校準設定還要簡單。

提供的量測

正向和反向。

可將受測裝置連接到任何 VNA 連接埠。

所需設備

功率表和感應器

適用於 SMC 的設備

  • 機械校準套件或 ECal 模組

另請參閱使用新的向量特性化技術進行混頻器特性化的比較。

要求和限制

FCA 不提供下列 VNA 功能：

  • 類比掃描（僅步進掃描模式）

  • 對數頻率掃描

  • ECal 使用者特性化（不能在 FCA 通道中建立）

  • 時域

  • 平衡量測

  • 介面控制

  • 連接埠延伸

  • 部分固定裝置功能

  • PMAR（功率表做為接收器）

如何進行 SMC 量測

下列描述了如何進行 FCA 量測的方法概觀：

  1. 決定使用 SMC 量測。請參閱這兩種量測類型的比較。

  2. 建立 SMC 量測。

  3. 設定量測。

  4. 校準您的量測。

建立 SMC 量測

  1. 按 [Meas] > Meas Overview（量測概觀）> Measurement Class（量測類別）。

  2. 選取 SMC。

  3. 顯示預設量測參數。

  4. 請參閱 SMC 量測，以瞭解每項提供的參數。

如何進行 SMC 設定

若要提供更快的存取，請使用「設定」軟鍵。瞭解操作方法。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按 [Freq] 或 [Sweep] > Main（主值）> Mixer Setup（混頻器設定）。

  1. 以滑鼠右鍵按一下網格方塊下方的激勵範圍區域。

  2. 按一下掃描設定...。

有效的混頻器設定/掃描類型組合

初次設定 SMC 對話方塊可能極為困難。 與之類似的顯示在「設定」對話方塊底部的紅色訊息將通知您設定無效。

必須固定至少一項範圍（輸入、LO 或輸出）。

下列為有效混頻器設定：

掃描類型 | 輸入 | LO | 輸出
線性 | 掃描 | 掃描 | 固定
 | 掃描 | 固定 | 掃描
 | 固定 | 掃描 | 掃描
CW 時間 功率 | 固定 | 固定 | 固定

提示

儘管您很快就可以隨心所欲地導覽這些標籤，但首先最好以下列順序完成對話方塊：

  1. 針對雙階混頻器，請選取混頻器設定設定。

  2. 選取掃描標籤設定。

  3. 選取混頻器頻率設定。

  4. 選取功率設定。

  5. 選取混頻器 (LO) 功率設定。

掃描標籤 - SMC 對話方塊說明

掃描類型

線性 掃描頻率。量測顯示在使用十等分水平劃分的標準網格中。 瞭解如何選取要顯示在 X 軸上的範圍。

CW 時間 全部範圍將設為一個固定 (CW) 頻率並以時間相對關係顯示資料。

區段掃描 掃描使用者定義的區段。瞭解詳情。

功率 掃描輸入或 LO 功率。

X 軸點間距 （僅區段掃描可用）- 瞭解此功能

點數 瞭解此功能。

IF 頻寬 瞭解此功能。

瞭解這些按鈕。

功率標籤 - SMC 對話方塊說明

附註：在「混頻器 (LO) 功率」標籤上設定 LO 功率。

設定 FCA 量測的輸入和輸出功率設定。使用「混頻器功率」標籤來設定 LO 功率。

啟動（所有通道） 核取以開啟 RF 電源，或清除以關閉所有通道的電源。

耦合連接埠功率 核取以在受測裝置輸入和輸出連接埠設定相同的功率位準。未耦合 LO 功率。清除以便為每個測試連接埠單獨設定功率位準。取消耦合功率，例如，要對反向套用比正向更多的功率 瞭解有關設定獨立接埠功率的詳細資訊

受測裝置輸入/輸出連接埠

選取連接到受測裝置輸入和輸出的 VNA 連接埠。

功率位準 設定受測裝置輸入連接埠的功率位準。若要在輸出連接埠設定功率，請清除耦合連接埠功率核取方塊。

.

受測裝置輸入和輸出連接埠功率掃描

在掃描標籤上選取功率（掃描）時可用。

輸入開始和停止功率 若要在輸出連接埠設定開始和停止功率，請清除耦合連接埠功率核取方塊。

功率點 要量測的功率點數量。

功率步進（尺寸） 從目前「開始」、「停止」和「點」設定計算值。不可直接變更此設定。

路徑組態 在 E5080A 中不可用

瞭解這些按鈕。

下列標籤由所有混頻器/轉換器應用程式共用：

  • 混頻器頻率標籤

  • 混頻器 (LO) 功率標籤

  • 混頻器設定標籤

混頻器頻率標籤 - SMC 設定 -對話方塊說明

瞭解此對話方塊

混頻器設定標籤 - SMC 設定 -對話方塊說明

瞭解此對話方塊

混頻器 (LO) 功率標籤 - SMC 設定 -對話方塊說明

瞭解此對話方塊

FCA 區段掃描

在掃描標籤上選取區段掃描，「混頻器頻率」標籤上會顯示下列設定。

混頻器頻率標籤 - 區段掃描 - SMC 對話方塊說明

如何設定分段：

  1. 按一下新增。按一下「刪除」以移除分段並對所有後續分段重新編號。

  2. 依預設，狀態為開啟。按一下關閉且該分段將不會含在此掃描中。

  3. 設定輸入、LO 和輸出範圍的頻率設定。

  • 針對每個分段，將相同的掃描需求套用為標準的（非分段）掃描。例如，至少有一個範圍必須是固定的（開始 = 停止頻率）。

  • 允許分段的輸入、輸出和 LO頻率與其他分段重疊。

  • 必須以正向（開始<停止）或反向（開始>停止）掃描所有分段。不允許混合掃描方向。

  • 可為每個分段單獨設定下列設定：

    • 點數 - 所有分段的總點數限制為 VNA 允許的最大點數。

    • IF 頻寬

    • 連接埠功率：（輸入、輸出、LO 1、LO2）。這些設定將會覆寫功率標籤上的設定。

  • 下列設定可套用於所有分段：

    • 轉換器/混頻器階段的數量（1 或 2）。

    • LO 來源選擇

    • 所有輸入和 LO 倍增器和分頻器

    • 來源和接收器衰減器設定

    • 來源位準調整

    • 標稱入射功率（僅 SMC）

    • X 軸顯示（輸入、LO1、LO2、輸出）若要使此設定可用，必須至少有兩個資料點。

    • X 軸點間距（相對對一般點間距）。

  • 混頻器區段掃描資料可以儲存到 *.S2PX 檔案中（非 *.S2P）。

  • 混頻器區段設定資訊可以儲存到 *.MXRX 檔案中。瞭解詳情。

瞭解這些按鈕

套用和內插 FCA 校準集

一般而言，校準集涵蓋的頻率範圍較通道更寬廣，VNA 將在套用時時內插校準集。瞭解詳情。 但是，對於 FCA 量測，也可將 LO 頻率範圍納入考量。

  • SMC 量測 始終忽略 LO 頻率範圍。因此，如果量測的輸入和輸出頻率範圍在校準集的頻率範圍之內，則將在必要時內插並套用校準集。例如，當輸入範圍 = VNA 頻率跨距、0 Hz LO 以及輸出範圍 + VNA 頻率跨距時，這將允許您執行一個 SMC 校準。此校準集可套用至所有的 SMC 量測。瞭解有關套用 SMC 校準集的詳細資訊。

這些相同的一般概念會套用於區段掃描。但是，如果一個分段的所有適用頻率範圍（SMC：輸入和輸出）並非位於這些量測的範圍內，則校準集不可套用於任何分段。

為 FCA 量測選取 X 軸顯示

按一下 [Sweep] > Main（主值）> X-Axis Type（X 軸類型），然後選取所需的類型。

當掃描類型 = 線性時，您可以選擇在 X 軸上顯示任何掃描參數的頻率範圍。

儲存軌跡資料

您可以多種標準格式儲存您的 FCA 量測資料。

按一下 [Save Recall] > Save Other（儲存其他）> Save Data...（儲存資料...）。

下列顯示如何儲存 CSV 和 SNP 檔案。

混頻器軌跡資料

當您選取混頻器 軌跡資料時，FCA 資料會以下列格式儲存至 CSV 檔案中：

#MIXER TRACE FILE,A.01.00

SegIndex, InputFreq, OutputFreq, LO1Freq, InputPower, LO1Power, SC21 Mag (dB), SC21 Phase (Deg)

SNP 格式

每個記錄包含 1 個激勵值和 4 個參數（總計 9 個數值），如下所示：

Stim
  Real(p1)   Imag(p1)   Real(p2)
   Imag(p2)   Real(p3)   Imag(p3)
   Real(p4)   Imag(p4)

其中 pX 是取決於量測類型的參數：

量測類型 | p1 | p2 | p3 | p4
純量 | S11 | SC21 (FWD) | SC12 (REV) | S22

  • 如果關閉修正，將僅針對作用中的參數儲存資料。為所有其他參數儲存零。

  • 如果開啟修正，將針對所有的參數儲存資料。

所有檔案包含下列標題資訊：括號 [ ] 包含參數。

!Keysight [Instrument Model Number]:[version]
!Mixer S2P File:[Mixer Measurement Type]
!Parameters:[Parameter List]
!Calibration State:[On/Off]

!# Begin Mixer Setup
![Mixer Setup parameters listed here]
![Mixer Parameter 1]
.
.
![Mixer Parameter n]
!# End Mixer Setup

# [S2P data here]

上次修改時間：

2016 年 01 月 06 日

第一版


SMC 量測

純量混頻器/轉換器量測 (SMC)

以下資訊是 SMC 特有的資訊：

  • SMC 硬體設定

  • 建立 SMC 量測

  • 提供的 SMC 參數

  • 「SMC 混頻器設定」對話方塊

  • SMC 校準

SMC 硬體設定

SMC 需要功率表/感應器、兩個來源和校準套件或 ECal 模組

  • 可將受測裝置連接到任何 VNA 連接埠。瞭解詳情。

  • 將 VNA 與內部第二個來源搭配使用時，不需要外部來源。瞭解可用於 LO 的 VNA 連接埠。

  • 將外部來源連接到 VNA GPIB 控制器連接埠。瞭解如何設定外部來源。

  • 將外部來源的 10 MHz 參考訊號連接到 VNA。

使用 GPIB 功率表或 USB 功率感應器。

如何設定兩個功率感應器以覆蓋 SMC 量測頻率範圍。

使用雙通道功率表，在連接兩個感應器的情況下：

  1. 在 SMC「選取受測裝置接頭」對話方塊中，按一下來源校準設定

  2. 在「來源校準設定」對話方塊中，按一下「功率表組態」

  3. 在 功率表設定 對話方塊中，按一下「感應器」

  4. 在 「功率感應器設定」 對話方塊中，清除兩個感應器的「僅使用此感應器...」核取方塊。

  5. 然後輸入兩個感應器的最小頻率和最大頻率。

在 SMC 校準期間，系統會在適當的時間提示您連接每個感應器。

建立 SMC 量測

  1. 按 [Meas] > Meas Overview（量測概觀）> Measurement Class（量測類別）。

  2. 選取 SMC。

  3. 將顯示 SC21 量測。

提供的 SMC 參數

若要選取其他要顯示的參數，請按一下軌跡，然後按一下新增軌跡，並從清單中選取參數。

重要附註： 將受測裝置連接到 VNA：

由於 VNA 不知道如何對受測裝置添加標籤或如何使用它，因此 FCA 中不使用 RF 和 IF 詞彙，而是使用通用詞彙「INPUT（輸入）」和「OUTPUT（輸出）」。

  • 輸入 - 使用轉換之前的頻率模擬受測裝置連接埠。

  • 輸出 - 輸出轉換後頻率的受測裝置連接埠。

使用「混頻器設定」對話方塊指定輸入和輸出頻率。

可將受測裝置輸入和輸出連接到任何 VNA 連接埠。

附註： 雖然有許多可能的組態，但以下影像和說明僅顯示連接到 VNA 連接埠 1 和 2 的受測裝置。

圖例：

黑色表示比例量測（測試連接埠/參考接收器）。

綠色表示非等比量測（測試連接埠或參考接收器）。

受測裝置輸入至 VNA 連接埠 1

受測裝置輸出至 VNA 連接埠 2

受測裝置輸入至 VNA 連接埠 2

受測裝置輸出至 VNA 連接埠 1

比例

  • SC21 （轉換損耗） 輸入處的激勵值，輸出處的回應值 (B/R1)。

  • SC12（反向隔離） 輸出處的激勵值，輸入處的回應值 (A/R2)

  • S11 （輸入匹配） 輸入處的激勵和回應值 (A/R1)

  • S22 （輸出匹配） 輸出處的激勵和回應值 (B/R2)

比例

  • SC12 （轉換損耗）輸入處的激勵值，輸出處的回應值 (A/R2)

  • SC21（反向隔離） 輸出處的激勵值，輸入處的回應值 (B/R1)

  • S11 （輸出匹配） 輸出處的激勵和回應值 (A/R1)

  • S22 （輸入匹配） 輸入處的激勵和回應值 (B/R2)

非等比 絕對值測試連接埠接收器量測。根據受測裝置組態，將自動選取接收器。

    • IPwr （入射功率）- 輸入處的激勵和回應值。

    • RevIPwr （反向入射功率）- 輸出處的激勵和回應值。

    • OPwr （輸出功率）- 輸入處的激勵值，輸出處的回應值。

    • RevOPwr （反向輸出功率）- 輸出處的激勵值，輸入處的回應值。

SMC 混頻器設定

如何啟動「SMC 混頻器設定」對話方塊

1. 確認是否在純量混頻器轉換器中設定了 [Meas] > Meas Overview（量測概觀） > Meas Class（量測類別）。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按 [Sweep] > Main（主值）> Mixer Setup...（混頻器設定...）。

  1. 以滑鼠右鍵按一下網格方塊下方的激勵範圍區域。

  2. 按一下掃描設定...。

顯示以下「SMC 混頻器設定」對話方塊標籤：

  • 掃描標籤

  • 功率標籤

  • 混頻器頻率標籤

  • 混頻器功率標籤

  • 混頻器設定標籤

套用校準集或 SMC 校準類型

您可以建立 FCA 量測並像處理任何 VNA 量測那樣套用現有的校準集。瞭解校準集。此外，在校準集中，您可以將特定 SMC 校準類型套用到現有的 SMC 量測中。

如何套用 SMC 校準類型

  1. 確認是否在純量混頻器轉換器中設定了 [Meas] > Meas Overview（量測概觀） > Meas Class（量測類別）。

  2. 校準或套用現有的 SMC 校準集，然後...

使用硬鍵/SoftTab/軟鍵

  1. 按 [Cal] > Main（主值）> Correction Method（修正方法）。

修正方法對話方塊說明

依預設，每次 SMC 校準需要四次掃描。清除這些方塊將消除掃描並加快 SMC 量測速度。使用外部 LO 來源進行固定輸入或固定輸出量測時，速度差異最為明顯。

包含輸入匹配修正 核取可執行掃描，以量測和修正輸入匹配。如果混頻器的輸入與 VNA 匹配，或您的設定不允許有效的 S11 量測，則清除該方塊。

包含輸出匹配修正 核取可執行掃描，以量測和修正輸出匹配。如果混頻器的輸出與 VNA 匹配，或您的設定不允許有效的 S22 量測，則清除該方塊。

包含 SC12 掃描 核取可執行反向掃描，以量測 SC12。

  • 核取（預設設定）時，校準的 SMC 量測將以正向 (SC21) 和反向 (SC12) 進行掃描。

  • 清除該核取方塊可消除反向掃描。這意味著不會修正以下量測：SC12、RevOPwr、RevIPwr。

修正的參數 如果目前已核取該方塊，則會列出可修正的參數。目前不會量測這些參數。

校準類型 如果目前已核取該方塊，則會顯示將套用的 SMC 校準類型。

瞭解使用標稱入射功率

可以消除多少次掃描？

設定 | 參數瞭解參數縮寫 | 掃描次數
核取所有方塊並清除使用標稱入射功率 | IPwr、OPwr、RevIPwr、RevOPwr、SC21、SC12、S11、S22 | 總共 4 次
執行該動作... | 若要移除這些參數... | 以及這些掃描
清除「包含 SC12」 | 移除 RevIPwr、RevOPwr、SC12 | 移除 1 次
清除「包含輸出匹配」 | 移除 S22 | 核取「標稱」時移除 1 次*。
清除「包含輸入匹配」 | 移除 S11 | 核取「標稱」時移除 1 次*。
核取「使用標稱入射功率」 | 移除 IPwr、RevIPwr | 最多移除 2 次*
清除所有方塊並核取「標稱入射功率」 | OPwr、SC21 | 總共 1 次

*S11 與 IPwr 共用一次掃描，S22 與 RevIPwr 共用一次掃描。因此，核取包含輸入匹配或包含輸出匹配時，核取「標稱入射功率」不會執行任何動作。

SMC 校準概觀

SMC 校準精靈將引導您完成該過程。

  1. 將功率表/感應器連接到 VNA 連接埠 1。在輸入和輸出頻率的每個步階處，VNA 將量測：

    • 功率感應器的輸入匹配

    • VNA 的電源

  2. 執行兩次全 2 連接埠校準：一個覆蓋受測裝置的輸入頻率，一個覆蓋輸出頻率。（如果您的受測裝置是一個線性裝置，則校準將僅使用輸入頻率範圍。）使用機械校準套件或 ECal 模組。

對於具有高輸出功率的混頻器/轉換器

如果未知直通和校準路徑中的損耗總共超過 40 dB，則未知直通方法無效。在這種情況下，建議使用以下校準和修正方法。

  • 在校準精靈的修改頻率頁面中，選擇「已定義直通」或「齊平直通」作為直通方法。使用 ECal 模組時，同樣在「修改頻率」頁面上，由於功率非常低而停用（清除）執行定位。

  • 校準後，在修正方法對話方塊中，清除包含輸出匹配修正和包含 SC12 掃描核取方塊。僅核取包含輸入匹配修正。

  • 若要深入瞭解高功率量測，請參閱應用附註。

SMC 校準精靈

在 SMC 校準期間會顯示以下對話方塊。

縮排的步驟是可選項。

  • 校準設定

    • 波導/固定裝置內/在片設定

  • 選取受測裝置接頭和校準套件

    • 修改頻率校準

    • 指定 ECal 模組的連接方式

  • 功率校準設定

  • SMC 校準步驟

  • 校準已完成

  • 指定配接器延遲

如何執行 SMC 校準

  1. 確認是否在純量混頻器轉換器中設定了 [Meas] > Measurement Overview（量測概觀）> Meas Class（量測類別）。

使用硬鍵/SoftTab/軟鍵

使用滑鼠

  1. 按 [Cal] > Main（主值）> CalWizard（校準精靈）。

  1. 在狀態列的校準（無修正）圖示上按一下滑鼠右鍵。

  2. 選取校準精靈。

SMC 校準設定對話方塊說明

可讓您檢閱和變更 SMC 校準的設定。

波導/固定裝置內/在片設定 按一下下一步以啟動下列「設定」對話方塊。

輸入和輸出連接埠的獨立功率校準（無直通） 如果直通標準不可用，則核取該方塊。在功率校準期間，系統會提示您先將功率感應器連接到輸入連接埠，然後再連接到輸出連接埠。

其他功率校準步驟

啟用 LO1/LO2 功率校準 當控制 LO1/LO2 時核取該方塊（在混頻器設定標籤上），可在 LO 來源上執行功率校準。

波導/固定裝置內/在片設定對話方塊說明

僅當在上一個校準設定對話方塊中核取了波導/固定裝置內/在片設定方塊時才會顯示該對話方塊。

可讓您在進行測試的混頻器的輸入和輸出中嵌入或解除嵌入電路網路。

對於網路 1（輸入）和網路 2（輸出），選取嵌入、解除嵌入或無。

瀏覽 按一下可導覽到對要嵌入或解除嵌入的網路建模的 .S2P 檔案。

反轉輸入/輸出的連接埠位置 勾選該方塊以將配置在連接埠 2 的固定裝置/配接器連接至 VNA，將連接埠 1 連接至受測裝置。將更新對話方塊中的影像以反映該變更。

啟用外推 勾選該方塊（預設設定）後，可在 S2P 檔案的頻率範圍比通道窄時套用簡單外推。第一個和最後一個資料點的值將以任一方向延伸，以覆蓋量測的頻率範圍。需要外推時，還會顯示一條警告訊息。

嵌入或解除嵌入

  • 在量測期間，如果有需要連接到校準參考平面和受測裝置之間的 2 連接埠網路，但該網路在校準期間不存在，則在校準期間，必須從相關的連接埠解除嵌入該網路。換言之，在 FCA 校準中解除嵌入會延伸校準參考平面以包含雙連接埠網路。

  • 如果您的 2 連接埠網路是校準參考平面的一部分但必須在量測期間斷開，則在校準期間，必須嵌入相關連接埠的 2 連接埠網路。換言之，在 FCA 校準中嵌入會收回校準參考平面以在量測期間排除雙連接埠網路。

附註

  • 特性化配接器巨集可用於建立 S2P 檔案。

  • 當檔案中包含的頻率超過通道中頻率，且資料點與量測的資料點不完全匹配時，會執行內插。

選取受測裝置接頭和校準套件對話方塊說明

可讓您為每個受測裝置連接埠指定接頭類型和校準套件。

連接埠 n 對於列出的每個 VNA 連接埠，指定受測裝置接頭類型和性別，以及要使用的校準套件。

附註： 如果受測裝置接頭為：

  • 波導 在執行校準前，將系統阻抗變更為 1 ohm。請參閱設定系統阻抗。

  • 未列出（陰性和陽性） 選取類型 A 做為接頭類型。類型 A 需要校準套件檔案，其中包含用於校準的標準的電氣屬性（請參閱校準套件）。

  • 未指定（如已封裝的裝置） 選取類型 B 做為接頭類型。類型 B 需要校準套件檔案，其中包含用於校準的標準的電氣屬性（請參閱校準套件）。

修改校準 核取，然後按一下下一步可啟動「修改頻率校準」對話方塊。

來源校準設定 按一下可啟動「來源校準設定」對話方塊。

修改頻率校準對話方塊說明

僅在上一個對話方塊中核取了修改校準時才會顯示該對話方塊。

直通校準方法 對於每個直通連線，請選擇直通方法。深入瞭解這些選項。

校準類型/標準 按一下可啟動「修改校準選擇」對話方塊。

僅在使用 ECal 模組時才提供下列選擇。

執行定位 如果勾選此方塊（預設），VNA 將感測與 VNA 連接埠連接的 ECal 模組連接埠的 ECal 型號和方向。如果 ECal 模組的功率過低，則會顯示為如同沒有連接 ECal 模組一樣。如果使用低功率並出現此問題，請清除該核取方塊以手動提供方向。首先在您校準的頻率範圍中間處定位。如果未偵測到訊號，則會在範圍的最低頻率處再次嘗試。

請參閱附註，瞭解使用 ECal 模組校準高輸出混頻器/轉換器的相關資訊。

檢視/偵測 ECal 特性化 僅在選擇使用 ECal 模組時才顯示。按一下以叫用「檢視 ECal 模組和特性化」對話方塊。顯示連接到 VNA 的 ECal 模組清單。

功率校準設定對話方塊說明

附註：當 mmWave SMC 量測處於作用中狀態時，將顯示使用功率表核取方塊（未顯示）。瞭解詳情。

功率校準位置： 選取將對其執行功率校準的來源連接埠。來源和接收器修正將傳輸到 S 參數量測所涉及到的所有其他來源和接收器。

使用多個感應器 （不適用於 mmWave SMC 量測。）要使用多個功率感應器覆蓋量測頻率範圍時，請核取此方塊。「多個感應器」對話方塊將取代此對話方塊（請參閱下列影像）。清除「使用多個感應器」（預設設定）時，僅將一個感應器連接到 VNA。

功率表設定 按一下可啟動標準「功率表設定」對話方塊。

解除嵌入（功率感應器）配接器 功率感應器接頭的類型和性別與指定連接埠之受測裝置接頭的類型和性別不同時，為取得最佳準確度，需要執行額外校準步驟來量測和修正用於將功率感應器連接到參考平面的配接器。

清除該方塊不會對新增的配接器進行補償。

核取該方塊可執行額外的校準步驟來量測和修正配接器。

然後選取功率感應器的功率感應器接頭類型和性別。「忽略」不會對新增的配接器進行補償，正如清除核取方塊一樣。

如果該接頭與相同連接埠的受測裝置接頭匹配，則 VNA 會假定沒有配接器。不需要執行額外校準步驟，且校準套件選項不可用。

否則，請選取要用於校準配接器的校準套件。

請參閱下方的準確度設定。

指定 ECal 模組的連接方式對話方塊說明

在上一個修改頻率對話方塊中清除執行定位核取方塊時，將會顯示該對話方塊。

按一下要連接到每個 VNA 連接埠的 ECal 連接埠。

SMC 校準步驟對話方塊說明

功率位準，執行功率校準的位準。

通常情況下，最好將功率感應器的功率位準設定為 0 dBm，因為功率感應器將在該位準上進行校準。功率位準越低，校準速度就越慢，且噪音越大。

如果在 VNA 測試連接埠和校準參考平面之間使用外部元件，則調整功率位準，使感應器的功率約為 0 dBm（如果可能）。

對話方塊中將顯示目前來源衰減值。

LO 功率校準（可選）如果啟用，則在受測裝置 LO 接頭上執行來源功率校準。必須已選取 LO。瞭解操作方法。可在「(LO) 功率」標籤上設定 LO 來源校準的功率位準。

校準已完成對話方塊說明

完成 儲存到通道的校準暫存器。

儲存為使用者校準集 啟動「儲存為使用者校準集」對話方塊並將其儲存到通道的校準暫存器。

取消 不套用或儲存校準。

瞭解校準暫存器。

瞭解使用者校準集

指定延遲對話方塊說明

僅在執行配接器移除或未知直通校準時才顯示此對話方塊。

將從量測中預估下列值。大多數情況下，這些值是合適的。但是，對於步階大小過大的 CW 掃描或頻率掃描，這些值的準確度還可以提高。

配接器延遲 若要提高此值，將使用密集步長量測並記錄配接器的延遲。將該值輸入到此處。所需的精準值是特性化延遲值時所需的準確度。

標稱相位偏移 （僅限於波導）。若要提高此值，請使用密集步長量測並記錄波導配接器的相位偏移。將該值輸入到此處。

一個接頭是同軸，另一個接頭是波導時，相位偏移的模糊值為 180 度。為了獲得一致性，此處提供的預估值始終在 0 到 180 度之間。您可以將此預估值變更為 -180 度到 +180 度之間的任何值。

對於 SMC 校準，此對話方塊將顯示兩次：一次針對輸入頻率，一次針對輸出頻率。這些值可能略有不同。

上次修改時間：

2016-01-06

第一版


混頻器/轉換器設定

  • 混頻器頻率標籤

  • 混頻器設定標籤

  • 混頻器 (LO) 功率標籤

  • 分數乘數範例

重要附註： 將混頻器/轉換器受測裝置連接到 VNA。

由於 VNA 不知道如何為受測裝置添加標籤或如何使用它，因此本主題中不使用 RF 和 IF 詞彙，而是使用通用詞彙「INPUT（輸入）」和「OUTPUT（輸出）」來說明以下 VNA 行為：

  • INPUT（輸入）- 受測裝置進行轉換前的激勵頻率。

  • OUTPUT（輸出）- 受測裝置進行轉換（「UP（向上）」或「DOWN（向下）」）後的回應頻率。使用 + 或 - 符號，為每個輸出指定「UP（向上）」或「DOWN（向下）」轉換。

「混頻器頻率」標籤說明

設定

頻率格式 選取「起始/停止（掃描）」或「固定」。對於線性掃描類型，必須至少有一項是固定的。對於 CW 或功率，則必須全部是固定的。

頻率 為每個混頻器/轉換器連接埠輸入頻率值。

混頻器產品選擇器 確定接收器是否會調整為輸入頻率和 LO 頻率的總計 (+) 或差值 (-)。

計算按鈕 根據其他混頻器設定計算頻率設定。例如，輸入 LO1 頻率範圍和輸入頻率範圍，然後按下計算輸出。 VNA 將計算並顯示輸出頻率。

輸入 > LO 或 IF1>LO2 使用「計算」按鈕確定輸入頻率時，會移除不確定性。

僅當下列三種狀況為 True 時才會使用這些核取方塊：
（如果三種狀況不全部為 True，則 VNA 不會讀取這些核取方塊）。

  1. 為相應的「計算」按鈕選取差值（低）邊帶 [image] ，並且

  2. 輸出頻率小於 LO 頻率，並且

  3. 其中一個計算按鈕用於計算輸入頻率。

設定混頻器的規則

對話方塊底部的紅色訊息表示以下一或多個設定無效：

  • 必須固定所有範圍（輸入、LO、輸出），或固定一個範圍。無法固定兩個範圍，或無法掃描三個範圍。

  • 若要使用 2 個 LO 確定有效的混頻器組態，一個固定 LO 和一個掃描相當於擁有單一階段掃描 LO。若要設定雙階段 LO，請選取轉換器階段：2（在混頻器設定標籤上）。

  • 輸入或輸出頻率不得超出 VNA 範圍。

  • 輸入和 LO 的任何組合會導致輸出掃過 0 Hz，這是不允許的。

關於混頻器組態檔（.mxr 和 *.mxrx）

儲存 將某些混頻器設定儲存到 *.mxr 或 *.mxrx 檔案中。

載入 重新叫用以前設定的混頻器 *.mxr 或 *.mxrx 檔案。

附註： 依預設，混頻器組態會儲存到 *.mxrX 檔案中，而以前會儲存到 *.mxr 檔案中。

只有 *.mxrx 檔案允許儲存區段掃描混頻器設定。

儲存了哪些混頻器設定？

  • 掃描類型、頻率和功率設定。

  • 使用區段掃描類型，會儲存所有區段設定。

轉換器應用相容性

與 FCA、NFx 和 GCx 搭配使用以與 PNA ARE 相容的混頻器設定檔案。但是，IMDx 中建立的 *.mxr(x) 檔案包含其他 *.mxr(x) 檔案未隨附的資訊。

外部來源

*.mxr(x) 檔案包含 LO 來源名稱。但不包含 LO 來源組態。

套用 將混頻器/轉換器測試設定的設定套用於量測中。混頻器設定對話方塊將保持開啟狀態。

確定 將混頻器/轉換器測試設定的設定套用於量測中。混頻器設定對話方塊將保持關閉狀態。

取消 關閉混頻器設定對話方塊且不套用這些設定。

另請參閱

如何使用嵌入式 LO 量測受測裝置

混頻器設定標籤說明

轉換器階段 選取單階段或雙階段轉換器。

硬體組態

新增來源 按一下可啟動外部裝置組態對話方塊。

路徑組態 在 E5080A 上不可用。 .

受測裝置連接埠

選取要連接到受測裝置輸入和輸出的 VNA 連接埠。

分數乘數

（分子/分母）組合可形成一個分數值，該值乘以輸入和 LO 頻率範圍。這些值用於計算轉換器輸出的 VNA 接收器的回應頻率。使用分數乘數進行以下操作：

  • 模擬諧波混頻器的動作

  • 模擬您的測試設定中可能存在的乘數和除數的動作

  • 將 VNA 接收器頻率調整為混頻器/轉換器的諧波

分數乘數的分子和分母範圍為 +1 到 +10。不允許使用負數值。

請參閱分數乘數範例。

LO1 和 LO2

選取不受控制以允許外部來源始終提供固定 LO 頻率。否則，請選取內部 VNA 來源或外部來源以用作 LO。瞭解如何設定外部裝置（來源）。

瞭解這些按鈕。

混頻器 (LO) 功率標籤說明

設定 LO 功率設定。

啟動（所有通道） 核取可立即開啟或關閉所有通道的所有 VNA 內部 RF 來源。

LO1 功率 為 LO1 設定功率位準。

LO2 功率 為 LO2 設定功率位準。

掃描功率設定 設定功率掃描設定。

路徑組態 不適用於 E5080A。

瞭解這些按鈕。

分數乘數範例

範例 1

使用 LO 分數乘數可複製第三諧波混頻器的動作，如此 VNA 就可以精確地計算接收器頻率。輸入和 LO 頻率已知。

在混頻器設定對話方塊中輸入以下設定：

  • 輸入起始頻率：30 GHz

  • 輸入停止頻率：40 GHz

  • LO 固定頻率：16 GHz

  • 混頻器產品選擇器： -（差值）

  • LO： 1

  • LO 分數乘數： 3/1

  • 輸入分數乘數： 1/1

按一下計算輸出。

結果：

  • 輸出起始頻率：18 GHz

  • 輸出停止頻率：8 GHz

範例 2

使用分數乘數可將 VNA 接收器頻率調整為混頻器 14 GHz 基本輸出的第二諧波。輸入、LO 和輸出頻率已知。

在混頻器設定對話方塊中輸入以下設定：

  • 輸入起始頻率：4 GHz

  • 輸入停止頻率：4 GHz

  • LO 固定頻率：10 GHz

  • 混頻器產品選擇器：輸入訊號 + LO 訊號（兩者之和）

  • LO： 1

  • 輸入分數乘數 = 2/1

  • LO 分數乘數 = 2/1

按一下計算輸出。

結果：

  • 輸出起始頻率：28 GHz

  • 輸出停止頻率：28 GHz

範例 3

使用 LO 分數乘數可複製混頻器套件內「除以 2」機制的動作。完成此操作後，VNA 可精確地計算接收器頻率。輸入和 LO 頻率已知。

在混頻器設定對話方塊中輸入以下設定：

  • 輸入起始頻率：45 MHz

  • 輸入停止頻率：50 MHz

  • LO 固定頻率：670 MHz

  • 混頻器產品選擇器：輸入訊號 + LO 訊號（兩者之和）

  • LO： 1

  • 輸入分數乘數 = 1/1

  • LO 分數乘數 = 1/2

按一下計算輸出。

結果：

  • 輸出起始頻率：380 MHz

  • 輸出停止頻率：385 MHz

上次修改時間：

2016 年 01 月 06 日

第一版


頻率偏移模式

頻率偏移模式 (FOM) 能夠使 VNA 來源調整為與 VNA 接收器不同（偏移）的頻率。

此主題討論與進行這些類型量測相關的 VNA 設定。如需有關進行特定裝置量測的詳細資訊，請參閱頻率轉換裝置量測。

  • 頻率偏移對話方塊

  • 設定範例

  • 測試裝置（參考開關）對話方塊

其他頻率偏移主題

如何進行頻率偏移設定

使用硬鍵/SoftTab/軟鍵

  1. 按 [Sweep] > Main（主值）> Frequency Offset...（頻率偏移...）。

頻率偏移對話方塊說明

以下是 FOM 的主要變更：

  • 「激勵和回應」現在稱為「來源和接收器」。

  • 可以透過兩種方式進行「來源和接收器」設定：

    1. 耦合至「主要（通道）」設定。這是上一版本中使用的唯一方式。

    2. 解除耦合並單獨設定「來源和接收器」值。這是新的簡化方法。

頻率偏移（開啟/關閉） 對作用中通道出現的所有量測啟用「頻率偏移模式」。

未啟用 FOM 時，所有頻率與作用中通道相同。

提示：首先在此對話方塊上進行其他設定，然後按一下頻率偏移開啟。

主要 目前的作用中通道設定。當來源或接收器耦合至「主要」設定時，其「掃描類型」與「主要」的掃描類型相同。 耦合範圍的頻率設定是使用乘數、除數和偏移值以數學運算方式從「主要」設定衍生而來。使用該方式時，僅需變更「主要」設定即可影響已耦合來源和接收器中的變更。當「頻率偏移」核取為「開啟」時，「主要通道」設定會發生變更。 請參閱使用主要和耦合設定的範例。

提示： 僅當來源和接收器已耦合時，才使用「主要」設定。通常「解除耦合」更容易，然後單獨設定來源和接收器。

接收器 通道中使用的所有接收器（包括參考接收器）均已調整為指定的頻率設定。

模式

耦合 來源和接收器設定是使用乘數、除數和偏移值以數學運算方式從「主要」設定衍生而來。瞭解詳情。

解除耦合 來源和接收器設定是單獨輸入的，未參考「主要」設定。解除耦合時，來源和接收器範圍可使用單獨的掃描類型。

掃描類型 按一下可變更每個範圍的掃描類型。僅適用於「主要」和「解除耦合」來源和接收器。

不支援的掃描類型組合

  • 「功率掃描」和「區段掃描」不得一起使用。

  • 每當來源和接收器偏移時，「解除耦合對數掃描」就會產生無效的資料。

  • 「耦合對數掃描」僅允許在下列兩種情況下使用：

    1. 偏移 = 0，乘數 = 1 且除數 = 1。

    2. 乘數 = 0

設定 若要變更設定，請按一下適當的「設定」儲存格，然後按一下編輯。

  • 如果已耦合，請叫用耦合對話方塊。

  • 如果已解除耦合或處於「主要」模式，則會叫用解除耦合設定對話方塊。

X 軸 選取要顯示在 X 軸上的設定。

X 軸點間距 僅當「區段掃描類型」選取做為 X 軸顯示時才可用。瞭解詳情。

附註： 啟用「頻率偏移」時，通道上的所有接收器（包括參考接收器）均會調整為新的偏移頻率，因此來源和參考接收器將處於不同的頻率。因此，包括參考接收器（其中包括所有 S 參數）的 FOM 量測均會顯示無效的資料。

若要同時以來源和接收器頻率量測並顯示量測值，必須使用兩個通道。使用等式編輯器可計算轉換損耗。請參閱已校準的 FOM 轉換損耗範例。

瞭解如何校準頻率偏移量測。

耦合設定對話方塊說明

耦合公式：

起始範圍 = [起始主頻率 x（乘數/除數）] + 偏移

停止範圍 = [停止主頻率 x（乘數/除數）] + 偏移

其中：

偏移 指定絕對偏移頻率 (Hz)。對於混頻器量測，這將是 LO 頻率。範圍是 +/- 1000 GHz。偏移可為正數或負數。

乘數 指定要乘以激勵的值（連同除數）。範圍是 +/- 1000。

  • 負乘數會導致激勵以減少方向掃描。對於下轉換器混頻器量測，這適用於需要輸入頻率小於 LO 頻率的設定。請參閱範例。

  • 乘數為 0（零）會使「主要」設定無效。然後，偏移值將增加為零。

除數 指定要乘以激勵的值（連同乘數）。範圍為 1 至 1000。

主要和解除耦合設定對話方塊說明

此對話方塊將視掃描類型而不同：

線性和對數頻率

附註： 每當來源和接收器偏移時，「解除耦合對數掃描」就會產生無效的資料。

選取起始/停止或中心/跨距

頻率 輸入值

點 （僅限主要）輸入掃描的資料點數。

功率

CW 頻率 輸入頻率 (Hz)。

點 （僅限主要）輸入功率掃描的資料點數。

CW 時間

CW 頻率 輸入頻率 (Hz)。

掃描時間 輸入完成一次掃描所需的時間。對於最快掃描，請輸入 0。

區段掃描 所進行的編輯與標準區段表完全相同。

對於進階使用者： 「解除耦合區段掃描」在設定量測時提供極大靈活性。在區段掃描模式中：

  • 確定按鈕不可用，除非所有分段的資料點總數與主要資料點數相符。

  • 獨立 IF 頻寬和獨立掃描時間僅在主要（通道）和解除耦合接收器中可用，在來源中不可用。

  • 獨立功率僅在主要（通道）和解除耦合來源中可用，在接收器中不可用。

設定範例

雖然「頻率偏移」設定可用於許多類型的裝置，但這些範例包含混頻器詞彙。

1.

固定 LO - 上轉換器

  • 掃描激勵（混頻器輸入）： 1000 MHz - 1200 MHz

  • 固定 LO： 1500

  • 掃描回應 （混頻器輸出）：2500 MHz 至 2700 MHz

在 FOM 對話方塊中進行以下設定

來源：解除耦合

掃描類型：線性

按一下「設定」，然後按一下「編輯」。在「來源」對話方塊中：

起始頻率 = 1000 MHz

停止頻率 = 1200 MHz

接收器：解除耦合

掃描類型：線性

按一下「設定」，然後按一下「編輯」。在「接收器」對話方塊中：

起始頻率 = 2,500 MHz

停止頻率 = 2,700 MHz

LO 設定

將外部來源設定為 CW - 1500 MHz。

2.

固定 LO - 下轉換器（輸入 < LO）

  • 掃描增加激勵 （混頻器輸入）：1,000 MHz 至 1,100 MHz

  • 固定 LO：2500 MHz

  • 掃描減少回應 （混頻器輸出） 1500 MHz 至 1400 MHz

在 FOM 對話方塊中進行以下設定

主要：未使用

來源（輸入）：解除耦合

掃描類型：線性

按一下「設定」，然後按一下「編輯」。在「來源」對話方塊中：

起始頻率 = 1000 MHz

停止頻率 = 1,100 MHz

接收器（輸出）：耦合

掃描類型：線性

按一下「設定」，然後按一下「編輯」。在「接收器」對話方塊中：

偏移：2500 MHz

乘數：-1（減去一）

LO 設定

  • 如果使用外部來源，請設定 為 CW：2500 MHz.

3.

掃描 LO - 固定輸出 - 上轉換器

在「頻率偏移模式」中進行「掃描外部 LO」量測可能非常困難。外部 LO 來源必須與掃描輸出或輸入同步（如本例中所述）。請參閱同步與外部來源控制以瞭解如何完成該操作。頻率轉換器應用程式選件 083 可輕鬆地執行這些量測。

  • 掃描激勵 （混頻器輸入）：1,000 MHz 至 1,100 MHz

  • 掃描 LO：1,500 MHz 至 1,400 MHz

  • 固定回應 （混頻器輸出）：2500 MHz

在 FOM 對話方塊中進行以下設定

來源：解除耦合

掃描類型：線性

按一下「設定」，然後按一下「編輯」。在「來源」對話方塊中：

起始頻率 = 1000 MHz

停止頻率 = 1,100 MHz

接收器：解除耦合

掃描類型：CW 時間

按一下「設定」，然後按一下「編輯」。在「接收器」對話方塊中：

CW 頻率 = 2500 MHz

LO 設定

  • 如果使用外部來源，請將掃描範圍設定為 1500 - 1400 MHz。

4.

混頻器掃描功率

若要量測混頻器的增益壓縮，需掃描混頻器的輸入功率。輸入和輸出頻率已固定，但是彼此之間偏移。

這是耦合設定的合理使用，因為可以以多個不同頻率執行相同的壓縮測試。對於耦合的來源和接收器範圍，可以從前面板輕鬆地變更主要（通道）頻率。耦合的來源和接收器頻率會相應地更新。

  • 掃描輸入功率：-10 dBm 至 0 dBm

  • 固定輸入頻率： 1500 MHz

  • 固定 LO：500 MHz

  • 固定輸出： 2000 MHz

在 FOM 對話方塊中進行以下設定

主要：

掃描類型：功率掃描

按一下「設定」，然後按一下「編輯」。在「主要」對話方塊中：

CW 頻率 = 1,500 MHz

來源：耦合

依預設，「CW 頻率」設定為：1500 MHz（與「主要」相同）

接收器： 耦合

依預設，「掃描類型」設定為：CW 時間

按一下「設定」，然後按一下「編輯」。在「接收器」對話方塊中：

偏移 = 500 MHz

LO 設定

  • 如果使用外部來源，請設定 為 CW：500 MHz。

上次修改時間：

2016 年 01 月 06 日

第一版


向量-混頻器校準

  • 概觀

  • 特性化校準混頻器（具備 IF 濾波器）

  • 執行校準混頻器的特性化

  • 特性化校準混頻器（具備 IF 濾波器），以進行平衡混頻器量測

  • 執行特性化

有關混頻器校準的其他主題

VMC（向量混頻器校準）概觀

VNA 具備向量混頻器校準功能，可用於量測頻率轉換裝置。

透過將校準標準（開路/短路/負載）和具備 IF 濾波器的校準混頻器以及 VNA 中整合的網路解除嵌入功能結合使用，向量混頻器校準可讓您量測混頻器轉換損耗的幅度、相位和群組延遲。

附註： 針對固定 RF 量測（RF：固定，LO 和 IF：掃描），無法執行向量混頻器校準，因為使用固定頻率定義的 touchstone 檔案無法匯入到 ENA 中。

附註： 針對固定 IF 量測（RF 和 LO：掃描，IF：固定），可以執行向量混頻器校準以及量測轉換損耗和回波損耗，但無法量測群組延遲，因為 IF 頻率是固定的。

附註： 針對掃描 IF 量測（RF 和 IF：掃描，LO：固定），可以執行向量混頻器校準以及量測轉換損耗、回波損耗及群組延遲。

您也可以透過使用兩個校準混頻器（每個混頻器都具備 IF 濾波器）來執行平衡混頻器量測。

向量混頻器校準是在完成全雙連接埠校準後，透過使用網路解除嵌入功能消除校準混頻器和 IF 濾波器的特性來實現的。使用向上/向下轉換方法可讓您為輸入和輸出連接埠指定相同的掃描量測頻率，從而在目標連接埠結束時啟用全雙連接埠校準。因此，在從所有量測結果中消除具備 IF 濾波器的校準混頻器的特性後，使用網路解除嵌入功能只能獲得已量測混頻器（受測裝置）的特性。

附註： 由於向上/向下轉換方法可在向量混頻器校準中使用，因此不會使用頻率偏移功能。但是，若要使用 VMC 巨集、SG 控制項等，則需要選件 009。

向量混頻器校準需要使用具備 IF 濾波器的校準混頻器的特性資料。

已量測的混頻器

已量測的混頻器（受測裝置）表示未知的量測目標混頻器。但是，滿足校準混頻器要求的已量測混頻器可用作校準混頻器。

校準混頻器（具備 IF 濾波器）

為支援向上/向下轉換的量測系統，需要使用校準混頻器。您還必須提前評估校準混頻器的頻率回應特性。向量混頻器校準方法可透過使用網路解除嵌入功能從量測結果中消除校準混頻器的特性來單獨獲取已量測混頻器的特性。您可以使用 IF 濾波器來選取任意必須的頻率轉換元件，例如：RF+LO、RF-LO 以及 LO-RF。可將校準混頻器和 IF 濾波器當作測試系統設定的一部分，就像網路分析器和測試纜線一樣。在整個校準或量測期間，它們將連接到相同位置。

附註： 頻率範圍必須等於或大於已量測混頻器的頻率範圍。如果您要透過單個設定測試多個混頻器，請選取廣泛的可覆蓋目標測試裝置所有頻率的校準混頻器。

特性化校準混頻器（具備 IF 濾波器）

在向量混頻器校準中，您必須特性化具有 IF 濾波器的校準混頻器。如下圖所示，將目標混頻器（具備 IF 濾波器）連接到網路分析器上執行了向量校準的連接埠，然後將開路、短路或負載標準連接到 IF 濾波器端以開始反射量測。在測試連接埠量測所得的訊號包含從混頻器的 RF 連接埠發出的反射訊號、先由混頻器轉換後由 IF 濾波器反射的 IF 訊號 (IF+) 以及先透過 IF 濾波器傳遞後由校準標準反射的 IF 訊號 (IF-)。

校準混頻器的特性可在單連接埠誤差模型中描述，並可根據ΓO、ΓS 和 ΓL（可在個別標準的反射量測中獲取）確定每個誤差項。

評估校準混頻器（具備 IF 濾波器）的特性

附註： 校準混頻器必須是相互的。「相互」一詞是指轉換損耗的幅度和相位在正向和反向上都相等。在 IF 連接埠上量測輸出訊號期間，在將量測訊號輸入 RF 連接埠時，會出現正向轉換損耗。相反，在 RF 連接埠上量測輸出訊號期間，在將量測訊號輸入 IF 連接埠時，會出現反向轉換損耗。

附註： 為取得精確的校準，每個方向上的轉換損耗必須小於 10 dB（結合使用校準混頻器和 IF 濾波器）。如果任一方向上的轉換損耗超過 15 dB，則會大幅降低校準準確度。

特性化校準混頻器（具備 IF 濾波器）的程序

執行校準混頻器的特性化

1. 設定激勵條件

為您要校準的通道設定激勵條件。您還必須提前設定外部訊號來源。

2. 執行巨集

附註： 如需特性化具有 IF 濾波器的校準混頻器，建議使用全雙連接埠校準（雖然單連接埠校準也可用）。這是因為，使用全雙連接埠校準可簡化評估程序。

  1. 按 [Macro] > Marco 1（巨集 1）> VMC。

3. 選取量測連接埠

選取單連接埠校準連接埠（功能表中的 1）。

4. 設定 IF 頻率

從 RF+LO、RF-LO 和 LO-RF中選取 IF 頻率（功能表中的 2），視乎校準混頻器的 IF 頻率而定。

附註： 向量混頻器特性化巨集中顯示的數字是在 VNA 中設定並從中讀取的頻率。您還必須按高於 0 kHz 的值設定最小 IF 頻率。
IF BW 必須設定為比 IF 頻率小得多的值。

5. 選取校準套件

選取校準套件（功能表中的 3）。

附註： 向量混頻器特性化巨集中顯示的機械校準套件是在 VNA 中寄存並從中讀取的頻率。如果 ECal 模組連接到 VNA，則將會自動選取 ECal。

6. 量測具有 IF 濾波器的校準混頻器（使用校準套件時）

將校準混頻器連接到完成單連接埠校準所在的測試連接埠之一（如下圖所示）。

連接校準混頻器（具備 IF 濾波器）

附註： 如果設定了全雙連接埠校準，請選取任意連接埠。

附註： 在用於散佈 LO 訊號的功率分配器連接到已量測混頻器後，我們建議特性化具備 IF 濾波器的校準混頻器。在向量混頻器校準中，如果使用向上/向下轉換方法，LO 訊號的功率將透過功率分配器散佈到校準混頻器和已量測混頻器。在評估校準混頻器的特性期間，校準混頻器的磁碟機使用的 LO 功率位準必須等於連有已量測混頻器時的 LO 功率位準。這是因為混頻器的轉換損耗和反射係數會受到 LO 訊號的功率位準的顯著影響。

  1. 選取 CalKit（校準套件）（功能表中的 3）。

  2. 從 CalKit（校準套件）功能表（功能表中的 4）中選取校準套件的類型編號。

  3. 按一下 Open（開路）按鈕（功能表中的 5）以在「開路」狀態下開始量測。

  4. 按一下 Short（短路）按鈕（功能表中的 6）以在「短路」狀態下開始量測。

  5. 按一下 Load（負載）按鈕（功能表中的 7）以在「負載」狀態下開始量測。

7. 量測具有 IF 濾波器的校準混頻器（使用 ECal 模組時）

  1. 選取 ECal（功能表中的 1）。

  2. 選取用於 ECal 模組的連接埠（功能表中的 2）。

  3. 按一下 Measure（量測）按鈕（功能表中的 3）以開始量測。

  4. 選取此屬性，然後按一下「資訊」（功能表中的 4）以查看量測。

8. 儲存特性資料並關閉巨集

  1. 按「儲存」按鈕（功能表中的 8）以開啟「儲存」畫面。

  2. 按「儲存」按鈕可為校準混頻器（具備 IF 濾波器）的特性資料指定名稱。然後將其儲存至 Touchstone 檔案中。 如果您核取「設定選項」（功能表中的 9），則會將作用中通道的指定連接埠的已儲存特性資料設定為網路解除嵌入功能的特性資料檔案，並將啟用固定裝置模擬器功能。如果未核取，則僅儲存特性資料。

  3. 按一下 Close（關閉）按鈕（功能表中的 10）以結束巨集。

特性化校準混頻器（具備 IF 濾波器），以進行平衡混頻器量測

VNA 隨附的向量混頻器特性化巨集可讓您特性化校準混頻器（具備 IF 濾波器）以用於平衡混頻器量測。為平衡混頻器量測而進行的校準混頻器（具備 IF 濾波器）特性化程序與用於正常混頻器量測的特性化程序基本相同，但進行平衡混頻器量測需要使用校準混頻器（具備 IF 濾波器）的兩個特性資料，如下圖所示。

將目標校準混頻器（具備 IF 濾波器）連接到網路分析器上執行了校準的連接埠，然後將開路、短路或負載標準連接到 IF 濾波器端以開始反射量測和特性化。針對平衡混頻器，校準混頻器（具備 IF 濾波器）之間的 LO 訊號的相位差將仍保留為誤差，因為每個校準混頻器（具備 IF 濾波器）都是獨立特性化的。因此您必須校準兩個已特性化的校準混頻器（具備 IF 濾波器）之間的相位差。

評估校準混頻器（具備 IF 濾波器）的特性以進行平衡混頻器量測

附註： 我們建議您在每個校準混頻器（具備 IF 濾波器）所連接的平衡連接埠之間使用相同產品的校準混頻器、IF 濾波器和纜線。
您應該在校準混頻器所連接的兩個連接埠之間盡可能將以下電長度保持相同 - 外部訊號來源輸出連接埠 (a) 到延伸校準平面 (b) 的電長度以及校準平面 (c) 到延伸校準平面 (b) 的電長度。如果校準混頻器所連接的兩個連接埠之間出現較大的電長度差，則會在這兩個 IF 連接埠之間出現 180 度相位值誤差，即使執行平衡混頻器校準巨集也是如此。您可以透過互換 IF 纜線連接對其進行驗證。

執行特性化

1. 特性化校準混頻器（具備 IF 濾波器）

使用任意兩個連接埠，量測每個校準混頻器（具備 IF 濾波器）的特性資料，以進行平衡混頻器量測。

為您要校準的通道設定激勵條件。您還必須提前設定外部訊號來源。

附註： 如果要特性化具有 IF 濾波器的校準混頻器，我們建議您提前執行全 4 連接埠校準，因為它可簡化評估程序。

  1. 按 [Macro] > Macro 1（巨集 1）> VMC。

  2. 選取 Port 1（連接埠 1）（功能表中的 1）來特性化具備 IF 濾波器的校準混頻器 1。在這種情況下，資料將儲存至暫存檔案 (MIXER_1.s2p)。

  3. 選取 Port 2（連接埠 2）（功能表中的 1）來特性化具備 IF 濾波器的校準混頻器 2。此時，資料也會儲存至暫存檔案 (MIXER_2.s2p)。

    附註： 如需有關特性化校準混頻器的詳細資訊，請參閱特性化校準混頻器（具備 IF 濾波器）的程序。

  4. 按一下 (Optional) Balanced Mixer（（選購）平衡混頻器）（功能表中的 2）。

  8. 在向量混頻器特性化巨集執行時，預先量測的校準混頻器（具備 IF 濾波器）的資料檔案（MIXER_1.s2p、MIXER_2.s2p）將自動讀入到此巨集中（功能表中的 1）。

附註： 如果在讀取校準混頻器（具備 IF 濾波器）的資料檔案時出現故障，則只能使用一個連接埠而不是使用兩個連接埠來完成特性化。

  1. 選取量測連接埠（功能表中的 2），然後連接校準混頻器的 IF 連接埠之間的 THRU（直通），以修正具備 IF 濾波器的校準混頻器的 LO 訊號的相位差。

  2. 按 Execute（執行）（功能表中的 3）按鈕可執行相位誤差修正並覆寫初始資料檔案上的結果。

  • 在選取量測連接埠時，如果沒有為固定裝置模擬器的網路刪除功能設定校準混頻器（具備 IF 濾波器 (*.s2p)）的資料檔案，則無法執行 Execute（執行）功能。

  • 相位誤差修正資料可反映 LO 訊號的相位差，以取得校準混頻器的資料檔案的相位資訊（這些資訊寄存在任何兩個連接埠中）。

  3. 按 Close（關閉）按鈕（功能表中的 4）以結束巨集。


MWA 簡介

MWA 軟體簡介

  • 概觀

  • 前端應用程式

  • 後端應用程式

關於量測精靈輔助的其他主題

概觀

量測精靈助手 (MWA) 是 VNA 上快速便捷地設定整個量測的軟體選項。該軟體包括兩個主要的應用程式 – 前端和後端應用程式。在 Microsoft Excel 上執行的前端應用程式建立設定檔案（「規格表」），副檔名為 .mwa，其中包括所有的量測參數。規格表然後由 VNA 上執行的應用程式的後端應用程式重新叫用。由後端應用程式在 VNA 內自動設定所有必要的參數。後端應用程式同樣提供校準精靈，並控制整個量測程序。使用 MWA 軟體可以大大降低網路分析的作業時間。

附註：有關 MWA 的詳細資訊，請參閱 www.keysight.com/find/mwa 和 "VNA 的量測精靈助手軟體"的應用程式說明。

附註： 量測精靈助手 (MWA) 僅可用於帶有選件 790 的 VNA。

前端應用程式

在 Microsoft Excel 上以 VBA 巨集的形式提供了前端應用程式，可以在安裝了該軟體的任何 PC 中執行。前端應用程式可產生 VNA 和多連接埠測試裝置的規格表 (.mwa)，其中包含量測的所有必要參數。

前端應用程式可提供以下功能：

  • 定義量測組態

  • 定義受測裝置和量測儀器之間的連線

  • 透過 GPIB 介面設定對外部周邊的指令

  • 在網路分析中設定所有量測參數

  • 建立後端應用程式的設定檔案（「規格表」）

後端應用程式

後端應用程式是在 VNA 上執行的應用程式軟體。將重新叫用由前端應用程式建立的規格表並在 VNA 中自動設定所有量測參數。後端應用程式具有校準精靈功能，提供所有量測必需的校準步驟的說明。總量測的必要程序由後端應用程式控制，量測的詳細結果儲存在 VNA 中。

後端應用程式可提供以下功能：

  • 重新叫規格表，以自動設定所有量測參數

  • 校準精靈

  • 連線資訊說明

  • 透過 GPIB 介面控制外部周邊

  • 自訂量測程序

  • 在所有量測路徑上執行極限測試

  • 報告量測的詳細結果


MWA 操作要求

操作 MWA 軟體的要求如下所示：

執行前端應用程式的 PC

  • 作業系統：Windows 7

  • Microsoft Excel 2010/2013

E5080A 網路分析器

  • 必須安裝 MWA 的後端應用程式。

附註： 只有當通道數是三個或更多（VNA 設定則為四個或更多）時才能執行 MWA。

多連接埠測試裝置

如果您想要進行多連接埠量測，MWA 支援以下多連接埠測試裝置。

  • E5092A

    • 選件 020 (E5092A-020)。

    • E5092A-020 的 MWA 支援 E5092A 13 連接埠、16 連接埠、22 連接埠和 X-10 連接埠橫向組態。

附註： 最多可以使用兩個多連接埠測試裝置。

ECal 模組

當根據 MWA 的後端應用程式的校準精靈使用 ECal 模組時，需要 VNA 支援的 4 連接埠 ECal 模組。有關由 VNA 支援的 ECal 模組的詳細資訊，請參閱 ECal。


MWA 的安裝

MWA 軟體安裝

  • 概觀

  • 安裝前端應用程式

  • 安裝後端應用程式

關於量測精靈輔助的其他主題

概觀

MWA 包括前端應用程式（在 PC 建立規格表）以及後端應用程式（可以使用 VNA 進行量測）。每一項安裝程序如下所述。

安裝前端應用程式

請按照下列程序在 PC 上安裝 MWA 的前端應用程式：

  1. 透過 http://www.keysight.com/find/mwa/ 下載 MWA 軟體評估版。

  2. 解壓縮 MWA 軟體套件。

  3. 將 mwa_xxxx.xlsm（ mwa_xxxx.xlsm 中的 x 表示修訂號。例如：mwa_0106.xlsm）複製到 PC 上的適當資料夾。

安裝後端應用程式

您的 VNA 具備選件 790 時，MWA 後端應用程式 (mwa.exe) 出廠時已經安裝在 C:\Program Files (x86)\agilent\network analyzer\applications\mwa at the factory shipment。


使用 MWA 前端應用程式建立規格表

  • 概觀

  • 啟動 MWA（前端應用程式）

  • 選取測試裝置

  • 定義受測裝置並連線至測試裝置

  • 設定受測裝置的操作模式

  • 設定每一種模式中的 GPIB 指令

  • 設定每一種模式中的量測參數

  • 產生規格表

  • 匯入匯出參數

關於量測精靈輔助的其他主題

概觀

MWA 的前端應用程式可建立名稱為「規格表」(.mwa) 的設定檔案，其用於 VNA 的後端應用程式。建立規格表的程序如下所述：

啟動 MWA（前端應用程式）

  1. 啟動 Excel，然後選取 File（檔案）> Open（開啟）。

  2. 在開啟的視窗中，選取 mwa_xxxx.xls 並按一下 Open（開啟）。

  3. 當系統詢問您是否啟用巨集時，請選取該選項以將其啟用。

附註：在 Microsoft Office Excel 2010/2013 中開啟 MWA 前端應用程式時，如「安全性警告」標籤所示，前端應用程式的巨集預設為停用。 要使用這些前端應用程式，必須啟用其巨集。若要啟用巨集，請在安全性警告標籤上按一下選項按鈕，然後在快顯的「安全性警示 – 巨集與 ActiveX」視窗上選取啟用此內容或信任來自此發佈者的所有文件。

選取測試裝置

在「多重連接埠測試裝置」資料表中選取量測組態的程序如下所述：

  1. 選取「多重連接埠測試裝置」標籤（多重連接埠測試裝置資料表中的 [1]）

  2. 按兩下測試裝置 1（多重連接埠測試裝置資料表中的 [2]）的選擇儲存格，然後選取下拉式清單中的第一個多重連接埠測試裝置。MWA 可使用下列組態：

    編號

    測試裝置

    描述

    0

    無

    僅使用 4 連接埠 VNA。

    1

    E5091A 9 連接埠

    E5080A 不支援 E5091A。

    2

    E5091A 13 連接埠

    E5080A 不支援 E5091A。

    3

    E5091A 16 連接埠

    E5080A 不支援 E5091A。

    4

    E5092A 13 連接埠

    使用 E5092A 選購件 020 (E5092A-020) 的 13 連接埠組態。

    5

    E5092A 16 連接埠

    使用 E5092A 選購件 020 (E5092A-020) 的 16 連接埠組態。

    6

    E5092A 22 連接埠

    使用 E5092A 選購件 020 (E5092A-020) 的 22 連接埠組態。

    7

    E5092A X 10 連接埠

    使用 E5092A 選購件 020 (E5092A-020) 的 10 連接埠全橫向組態。

    8

    Z5623AK64

    此為 PNA-L（N5230A 選件 245）專用的測試裝置。其無法與 VNA 搭配使用。

    9

    Z5623AK66

    此為 PNA-L（N5230A 選件 245）專用的測試裝置。其無法與 VNA 搭配使用。

E5092A 13 連接埠交換組態

E5092A 13 連接埠組態參數矩陣與前面板連線

E5092A 16 連接埠組態

E5092A 16 連接埠組態參數矩陣與前面板連線

E5092A 22 連接埠組態

E5092A 22 連接埠組態參數矩陣與前面板連線

E5092A 10 連接埠全橫向組態

E5092A 10 連接埠全橫向組態參數矩陣與前面板連線

  3. 在測試裝置 1（多重連接埠測試裝置資料表中的 (3)）的「標籤」欄的儲存格中輸入連接埠的標籤名稱。此處輸入的標籤名稱將用於前端和後端應用程式的下列程序。

附註：MWA 前端應用程式中無法使用「複製與貼上」功能。請確保輸入字元和值，或從下拉式清單中選取選項。

  4. 按兩下測試裝置 2（多重連接埠測試裝置資料表中的 (4)）的選擇儲存格，然後選取下拉式清單中的另一個多重連接埠測試裝置。下列組態（下表）可用於第二個測試裝置：

    編號

    測試裝置

    描述

    0

    無

    請勿使用第二個測試裝置。

    1

    E5091A 9 連接埠

    E5080A 不支援 E5091A。

    2

    E5091A 13 連接埠

    E5080A 不支援 E5091A。

    3

    E5091A 16 連接埠

    E5080A 不支援 E5091A。

    4

    E5092A 13 連接埠

    使用 E5092A (E5092A-020) 的 13 連接埠組態。

    5

    E5092A 16 連接埠

    使用 E5092A (E5092A-020) 的 16 連接埠組態。

    6

    E5092A 22 連接埠

    使用 E5092A (E5092A-020) 的 22 連接埠組態。

    7

    E5092A X 10 連接埠

    使用 E5092A (E5092A-020) 的 10 連接埠全橫向組態。

附註：如果將兩個多重連接埠測試裝置用於量測，則需要執行步驟 4 到步驟 6。如果僅使用一個測試裝置，請選取「無」並移至步驟 7。

  5. 在測試裝置 2（多重連接埠測試裝置資料表中的 (5)）的「標籤」欄的儲存格中輸入連接埠的標籤名稱。

  6. 在「連結」欄（多重連接埠測試裝置資料表中的 (6)）的儲存格中設定數字 1 到 4，數字對應於第二個測試裝置的連接埠 1 到 4。

  7. 完成量測組態的選擇後，會自動更新右側（多重連接埠測試裝置資料表中的 [7]）的連線矩陣。表中勾選的這些項是可量測的路徑。

多連接埠測試裝置資料表

定義受測裝置並連線至測試裝置

定義受測裝置特性及 VNA 或多重連接埠測試裝置上的連接埠連線的程序如下所述：

  1. 選取「受測裝置」標籤（受測裝置資料表 (1/3) 中的 [1]）。

  2. 在定義受測裝置和測試裝置之間連線的「受測裝置標籤」欄（受測裝置資料表 (1/3) 中的 (2)）的儲存格中輸入標籤名稱。在儲存格中輸入標籤名稱會啟用 VNA 或多重連接埠測試裝置的對應連接埠。

  3. 按兩下「受測裝置標籤」下的連接埠類型選擇儲存格（受測裝置資料表 (1/3) 中的 (3)），然後從下拉式清單中選取連接埠類型或直接輸入連接埠類型號碼 (1-3)。可使用下列類型：

    編號

    連接埠類型

    描述

    1

    單端

    將連接埠類型設定為單端連接埠。

    2

    共模

    將連接埠類型設定為共模連接埠。

    3

    差模

    將連接埠類型設定為差模連接埠。

  4. 如果您將「共模」或「差模」選取為連接埠類型，請在「子標籤」欄的儲存格（受測裝置資料表 (1/3) 中的 (4)）中輸入一個標籤名稱，連接埠連接至 VNA 或測試裝置的單端連接埠時，將使用此標籤名稱。

  5. 按兩下連接埠選擇儲存格（受測裝置資料表 (1/3) 中的 (5)），然後從下拉式清單中選取測試裝置的連接埠。可從已在多重連接埠測試裝置資料表中預先定義的連接埠中進行選擇。

受測裝置資料表 (1/3)

  6. 將連接埠類型設定為「單端」時，在 Z（單端）下的 R（針對實數部分）和 X（針對虛數部分）欄（受測裝置資料表 (2/3) 中的 [1]）的儲存格中輸入連接埠阻抗。將連接埠類型設定為「共模」或「差模」時，在 Z（平衡）下的 R 和 X 欄（受測裝置資料表 (2/3) 中的 (2)）的儲存格中輸入阻抗。

  7. 在「延伸」欄（受測裝置資料表 (2/3) 中的 (3)）的儲存格中輸入延伸時間，以在連接埠延伸時套用該值。如果您將連接埠類型設定為除「單端」之外的其他類型，請針對兩個連接埠的每一個輸入延伸時間。

附註：前端應用程式中可以使用嵌入和解除嵌入功能。由於 VNA 韌體規格，無法同時使用「嵌入」和「連接埠匹配」。

錯誤訊息畫面

受測裝置資料表 (2/3)

  8. 按兩下「連接埠匹配」（單端）下「類型」欄中的儲存格（受測裝置資料表 (3/3) 中的 (1)）以顯示設定連接埠匹配電路的對話方塊（設定連接埠匹配電路的對話方塊）。選取類型，輸入 C、G、L 和 R 的值，然後按一下 OK（確定）（設定連接埠匹配電路的對話方塊中的 (1)）。若要返回至受測裝置資料表而不設定類型和值，請按一下 Cancel（取消）（設定連接埠匹配電路的對話方塊中的 (2)）。

C、G、L 和 R 的單位分別是 F（法拉）、S（西門子）、H（亨利）和歐姆。指數可做為輸入格式。

連接埠匹配電路的類型如下：

連接埠匹配電路的類型 | 描述
無 | 未選取匹配電路。
SLPC | 選取由串聯 L 和並聯 C 組成的電路。
PCSL | 選取由並聯 C 和串聯 L 組成的電路。
PLSC | 選取由並聯 L 和串聯 C 組成的電路。
SCPL | 選取由串聯 C 和並聯 L 組成的電路。
PLPC | 選取由並聯 L 和並聯 C 組成的電路。

附註：可直接在 C、G、L 和 R 欄（受測裝置資料表 (3/3) 中的 (2)）的儲存格中輸入值，而不使用對話方塊。

  1. 請視需要重複步驟 2 至步驟 8，以設定所有必需的參數。

受測裝置資料表 (3/3)

設定連接埠匹配電路的對話方塊

SLPC

PCSL

PLPC

PLSC

SCPL

設定受測裝置的操作模式

E5092A 多重連接埠測試裝置具有直流電源，可以向受測裝置供應直流控制電壓位。透過為每一個控制位選取 L（低）或 H（高）電壓，可確定受測裝置的操作模式。在「模式」資料表中設定操作模式的程序如下所述：

  1. 選取「模式」標籤（模式資料表中的 (1)）。

  2. 開啟受測裝置操作模式狀態的每一個儲存格（模式資料表中的 (2)）。

  3. 在「模式標籤」欄的儲存格中輸入偏好的標籤名稱（模式資料表中的 (3)）。此處輸入的標籤名稱將用作產生的規格表的標籤名稱。後端應用程式也將其用作標籤。

  4. 按兩下第一個測試裝置（模式資料表中的 (4)）「控制線電壓 [TS1]」下的控制電壓（Vc1 至 Vc8）儲存格，並為每一個控制線設定 L（低）或 H（高）電壓。也可以直接輸入數字 0 或 1（0 為低，1 為高）。

  5. 使用兩個測試裝置時，可從第二個測試裝置設定控制電壓輸出。按照步驟 4 中所述的方式，設定第二個測試裝置（模式資料表中的 (5)）「控制線電壓 [TS2]」下 Vc1 至 Vc8 的儲存格。

  6. 請視需要重複步驟 2 至步驟 5，以設定所有所需的模式。

模式表

附註：僅已在多重連接埠測試裝置標籤中選取 E5092A 測試裝置時，控制線電壓群組（A 到 D）和直流電源輸出電壓選項才可用。根據 E5092A 規格的不同，直流電源輸出電壓變化範圍為 1V-5V，解析度為 0.01V。

附註：模式的最大數目為 40。

直流電源和控制線電壓圖表

設定每一種模式中的 GPIB 指令

下列程序說明在「GPIB」資料表中設定外部周邊 GPIB 指令的步驟。此功能需要將 VNA 和周邊與 GPIB 介面連線的 USB/GPIB 介面（亦即 Agilent 87357B）。

  1. 選取「GPIB」標籤（GPIB 資料表中的 (1)）。

  2. 在 GPIB 指令中，在「位址」欄（GPIB 資料表中的 (3)）的儲存格中輸入傳送 GPIB 指令所至之外部周邊的 GPIB 位址。

附註：若要將新指令列新增至模式，請按兩下「模式」欄（GPIB 資料表中的 (2)）中的儲存格。若要從模式中刪除指令列，請將游標置於要刪除的列，按一下滑鼠右鍵以顯示清單，然後選取「刪除指令」。

若要一次新增多個列，請將游標置於要新增新列的指令列，按一下滑鼠右鍵以顯示「指令計數」對話方塊，並視需要在特定模式中設定列的數目。

附註： 透過在「位址」欄的儲存格中輸入 -1，可將 GPIB 指令傳送至 VNA 本身。

  3. 在「指令」欄（GPIB 資料表中的 (4)）的儲存格中輸入要傳送的 GPIB 指令。

附註：字串參數需要單或雙引號。範例：DISP:WIND1:TITL:DATA 'Sample1'

  4. 在 GPIB 指令下的「等待 [ms]」欄（GPIB 資料表中的 (5)）中的儲存格輸入等待時間。在量測期間將查詢指令傳送至周邊時，該等待時間（以毫秒為單位）應設定為在測試系統中的 VNA 和周邊之間插入資料處理時間。

  5. 按兩下「類型」欄（GPIB 資料表中的 (6)）中的儲存格以顯示下拉式清單，並選取所需的指令類型。可使用下列選項：

編號 | 指令類型 | 描述
1 | 限制 | 此設定透過 GPIB 傳送查詢指令。後端應用程式的限制測試將使用傳回的值。
2 | 前 | 此設定在後端應用程式量測開始之前傳送 GPIB 指令。
3 | 後 | 此設定在後端應用程式量測結束之後傳送 GPIB 指令。

附註：僅可針對已在設定受測裝置的操作模式中設定的 GPIB 指令設定此指令類型。無法在 INIT 模式中設定 GPIB 指令類型。

附註：在 INIT 模式中，當後端應用程式讀取規格表時，指令僅執行一次。因為此指令在量測之前執行，設定此類指令可初始化外部周邊的狀態。

  6. 如果為指令類型選取「限制」，請分別在「最小」、「最大」和「等級」欄（GPIB 資料表中的 (7)）的儲存格中輸入下限值、上限值以及等級數。這些數字用於後端應用程式的限制測試，測試根據向周邊傳送的查詢指令所傳回的值進行。 如需有關等級的詳細資訊，請參閱設定每一種模式中的量測參數中的步驟 11。

附註：只有所選的 GPIB 指令類型為「限制」，才可以在「GPIB 限制」下的儲存格中設定下限值、上限值和等級。這不適用於前或後 GPIB 指令。也不能以 INIT 模式針對 GPIB 指令執行此設定。

  7. 請視需要重複步驟 2 至步驟 6，以設定每一個模式中的 GPIB 指令。

GPIB 表

設定每一種模式中的量測參數

下列所述程序適用於設定已在設定受測裝置的操作模式中預先定義的所有模式的量測參數。

  1. 選取「規格表」標籤（規格表 (1/2) 中的 (1)）。

  2. 按兩下「路徑」（規格表 (1/2) 中的 (3)）下的「來自」欄，然後從下拉式清單中選取連線到 VNA 來源連接埠的受測裝置連接埠。可從已在定義受測裝置並連線至測試裝置中定義的連接埠中進行選擇。

附註：若要將新列新增至量測路徑，請按兩下「模式」欄（規格表 (1/2) 中的 (2)）中的儲存格。若要刪除量測路徑的列，請將游標置於要刪除的列，按一下滑鼠右鍵以顯示清單，然後選取「刪除記錄」。

若要新增多個量測路徑，請將游標置於模式上，按一下滑鼠右鍵並在顯示的路徑計數對話方塊中選取「路徑計數...」，然後視需要設定路徑數目。

路徑計數對話方塊

  3. 如步驟 2 所示，按兩下「路徑」（規格表 (1/2) 中的 (3)）下「到」欄中的儲存格以顯示下拉式清單，然後選取連線到 VNA 接收器連接埠的受測裝置連接埠。

  4. 按兩下「類型」欄（規格表 (1/2) 中的 (4)）的儲存格以顯示下拉式清單，並選取每一個路徑的量測類型。可以選取下列類型：

    編號

    量測類型

    描述

    參數

    資料格式

    1

    IL

    執行插入損耗量測

    傳輸

    LogMag

    2

    漣波

    執行「漣波」量測

    傳輸

    LogMag

    3

    VSWR

    執行「電壓駐波比」量測

    反射

    VSWR

    4

    RL

    執行「回波損耗」量測

    反射

    LogMag

    5

    ATT

    執行「衰減」量測

    傳輸

    LogMag

    6

    隔離

    執行「隔離」量測

    傳輸

    LogMag

    7

    BalAmp

    使用平衡連接埠執行「不平衡」量測。（幅度）

    不平衡

    LogMag

    8

    BalPhase

    使用平衡連接埠執行「不平衡」量測。（相位）

    不平衡

    相位

    9

    相位

    執行「相位」量測。

    反射/傳輸

    相位

    10

    群組延遲

    執行「群組延遲」量測。

    反射/傳輸

    群組延遲

    11

    線性幅度

    執行線性幅度量測。

    反射/傳輸

    LinMag

    12

    實數

    執行實數的量測。

    反射/傳輸

    實數

    13

    虛數

    執行虛數的量測。

    反射/傳輸

    虛數

附註：後端應用程式使用規格欄中的限制值來執行限制測試。（如步驟 8 所述）。如果採用 IL、RL、ATT 或隔離量測類型，則需要變更限制測試值的符號。例如，受測裝置允許最大 -5dB 的插入損耗規格，在規格欄中的最大 (Max) 值中輸入 5 (dB)。如果您需要量測路徑中隔離至少低於 -80dB，您應在限制測試的規格欄中的最小 (Min) 值中輸入 80 (dB)。

規格表 (1/2)

  5. 在「頻率 [MHz]」下的「啟動」、「停止」和「點」欄（規格表 (1/2) 中的 (5)）的儲存格中輸入啟動頻率、停止頻率以及量測點數目。這些數字將做為由 VNA 的後端應用程式執行量測的掃描設定。

  6. 透過在「接收器頻率 [MHz]」下的「啟動」和「停止」欄（規格表 (1/2) 中的 (6)）的儲存格中輸入 VNA 接收器連接埠的啟動和停止頻率，頻率偏移模式可用於 MWA。

  7. 使用「掃描設定」下「功率」、「IFBW [Hz]」和「掃描模式」欄（規格表 (1/2) 中的 (7)）中的儲存格，設定連接埠輸出端的輸出位準、IF 頻寬和掃描模式。按兩下掃描模式儲存格以顯示下拉式清單，並選取 VNA 的掃描模式。可使用下列選項：

    編號

    掃描模式

    描述

    1

    標準階梯式

    將掃描模式設定為階梯式模式。

    2

    標準掃描

    將掃描模式設定為掃描模式。

    3

    快速階梯式

    將掃描模式設定為快速階梯式模式（此模式僅適用於 E5070B/E5071B）。

    4

    快速掃描

    將掃描模式設定為快速掃描模式（此模式僅適用於 E5070B/E5071B）。

  8. 在「規格」欄下的「最小和最大」欄（規格表 (2/2) 中的 (1)）中的儲存格中輸入量測參數的限制值。此處輸入的值將用於後端應用程式中的限制測試，以評估量測的參數。如果在儲存格中未輸入任何值，則假定最小（下限）為 -999，最大（上限）為 999。

  9. 可在後端應用程式中轉換量測的資料。在這種情況下，在「修正乘數」下的「啟動」和「停止」欄（規格表 (2/2) 中的 (2)）中的儲存格中以及「修正偏移」下的「啟動」和「停止」欄（規格表 (2/2) 中的 (3)）中的儲存格中輸入修正值。使用輸入的乘數和偏移值，對啟動頻率和停止頻率的量測資料進行修正。對兩個頻率之間的點上量測的資料執行線性插入。

  10. 透過按兩下可勾選「修正」（規格表 (2/2) 中的 (4)）下的「差異」欄中的儲存格。此儲存格中的路徑擁有一個勾選標記時，第一個路徑中的修正值與模式的其他勾選路徑之間的差異可以在後端應用程式中測試。

    透過在第一個路徑中輸入載波頻率的參數，在下一個路徑輸入諧波頻率的參數，此功能可用於諧波量測（以 dBc 為單位）。

附註：因為每一種模式中第一個路徑被自動分配為計算其他路徑差異的量測參考，因而不能勾選它。

規格表 (2/2)

  11. 在「等級」欄（規格表 (2/2) 中的 (5)）的儲存格中輸入等級數。等級可用於排定受測裝置量測路徑之測試結果的優先順序。等級數的範圍為 0 到 255，限制測試完成後，後端應用程式將最低等級數輸出至 VNA 的處理器 I/O。這表示限制測試中受測裝置量測路徑的最關鍵故障。測試結果顯示所有量測的路徑通過時，傳回的等級數為 0。

  12. 透過按兩下勾選「選取」欄（規格表 (2/2) 中的 (6)）中儲存格。在後端應用程式中執行儲存格中帶有勾選標記的路徑的量測。您可以在後端應用程式中選取是否進行選擇性量測。

  13. 將儲存格中量測路徑的標籤名稱輸入「標籤名稱」欄（規格表 (2/2) 中的 (7) 和 (8)）。使用對應的模式和路徑號碼自動分配標籤名稱的第一部分（規格表 (2/2) 中的 (7)），無法進行修改。可視需要變更名稱的第二部分（規格表 (2/2) 中的 (8)）。

  14. 請視需要重複步驟 2 至步驟 13，以設定每一個模式中的量測路徑詳細資料。

產生規格表

下列所述程序適用於驗證設定的內容，以及為後端應用程式在「輸出」資料表中產生規格表。

  1. 選取「輸出」標籤（輸出資料表中的 (1)）。VNA 上每一個量測路徑的通道和軌跡分配會自動顯示在資料表上。

附註：如果前端應用程式之前的資料表中存在無效輸入，則會顯示一個錯誤訊息對話方塊。按下對話方塊中的 Yes（是），返回至導致錯誤的部分。

  2. 在「輸出」資料表的頂部，在「最大通道」儲存格（輸出資料表中的 (4)）中輸入 VNA 的最大通道數目，在「最大軌跡」儲存格（輸出資料表中的 (5)）中輸入每一個通道的最大軌跡數目，在「最大點數」儲存格（輸出資料表中的 (6)）中輸入量測點的最大數目。

    根據此處輸入的值，系統會將所有模式中的所有量測路徑自動分配至適當的通道。

  3. 「輸出」資料表（輸出資料表中的 (2)）中顯示了所有模式和對應的通道、軌跡和區段的所有量測路徑的資訊。檢查資訊並在發現錯誤時修正對應的資料表。

  4. （輸出資料表中的 (3)）中顯示每一個通道上的詳細資訊，包括測試裝置 ID、測試裝置連線的連接埠號碼、每一個軌跡的量測參數。檢查資訊並在發現錯誤時修正對應的資料表。

  5. 如果「輸出」資料表中顯示的所有資訊都正確，按下資料表頂部的 Save Spec Sheet（儲存規格表）（輸出資料表中的 (7)）以顯示「儲存」對話方塊。選取一個資料夾並輸入偏好的檔案名稱，然後按下 Save（儲存）可產生並儲存規格表，該資料表將用於後端應用程式。

輸出資料表

匯入/匯出參數

下列所述的程序適用於透過「系統」資料表以 csv 格式匯入/匯出參數。

  1. 選取「系統」標籤（系統資料表中的 (1)）。

  2. 按下 Export（匯出）（系統資料表中的 (3)）以顯示「匯出資料」對話方塊。

  3. 輸入檔案名稱並按下 OK（確定）。在前端應用程式中輸入的所有參數將以 csv 格式匯出至檔案中。

  4. 若要從 csv 檔案匯入參數，請按下 Import（匯入）（系統資料表中的 (2)）以顯示「匯入資料」對話方塊。

  5. 選取要讀取的 csv 檔案並按下 OK（確定）。在前端應用程式中可以匯入 csv 檔案中的參數。

系統資料表

附註：因為匯出的檔案 (.csv) 不是在「輸出」資料表中產生的規格表 (.mwa)，其無法在後端應用程式中重新叫用。


在 VNA 中執行後端應用程式

  • 概觀

  • 啟動 MWA 後端應用程式

  • 視窗說明

  • 選取和清除規格表

  • 檢查連線

  • 校準程序

  • 儲存狀態檔案

  • 量測程序

  • 建立的結果檔案

  • 從外部電腦控制後端應用程式

  • 透過 MWA 操作處理常式 I/O

  • 後端應用程式中的錯誤訊息

關於量測精靈輔助的其他主題

概觀

MWA 的後端應用程式是一個在 VNA 上執行的程式。後端應用程式會讀取由 MWA 前端應用程式建立的規格表 (.mwa)，然後自動在 VNA 上設定所有量測參數。後端應用程式會根據規格表中所包含的資訊設定 VNA 多連接埠測試裝置或外部週邊設備，並執行量測程序，以產生結果的詳細分析報告。

啟動 MWA（後端應用程式）

以下說明啟動 VNA 上的 MWA 後端應用程式的方法。

  1. 按 [Macro] > Macro 1（巨集 1）> MWA。

視窗說明

MWA 的後端應用程式包含下列視窗：

  1. 主視窗

  2. 規格表設定視窗

  3. 連線資訊視窗

  4. 校準精靈視窗

  5. 所有規格表量測視窗

  6. 依規格表量測視窗

  7. 依模式驗證結果視窗

1. 主視窗

這是在啟動後顯示的第一個視窗。

在此視窗中，可以選取以下按鈕來啟用後端應用程式中的可用功能

主視窗

  • 新增規格表群組按鈕（主視窗）

顯示規格表設定視窗。

  • 清除所有規格群組按鈕（主視窗）

清除已在規格表設定視窗中讀取的群組檔案。

  • 校準精靈按鈕（主視窗）

顯示可執行自動校準程序的校準精靈視窗 (1/2)。

  • 儲存狀態按鈕（主視窗）

在 VNA 上儲存狀態檔案。由於在儲存群組檔案時或在「校準精靈」視窗中完成必要的校準時會自動在 VNA 中儲存狀態檔案，因此如果未變更 VNA 上的設定，就無需按下此按鈕。

  • 連線資訊按鈕（主視窗）

顯示可用於驗證網路分析器、多連接埠測試裝置及受測裝置的連線的連線資訊視窗。

  • 量測按鈕（主視窗）

顯示可啟動量測程序的所有規格表量測視窗。

  • 最小化按鈕（主視窗）

最小化後端應用程式的視窗。透過此功能可以輕鬆存取 VNA 的顯示畫面，以在重新叫用規格表後變更參數。

  • 規格表清單（主視窗）

重新叫用的群組檔案和規格表清單都會顯示在主視窗中，位於「規格表設定」視窗（插入的連結）中的設定後面。其中包括規格表的名稱、群組檔案的數目，以及 VNA 的配置通道號碼。您可以啟用每個群組檔案的選項按鈕，以選取量測中使用的作用中群組檔案。

如果一個群組檔案隨附多個規格表，則可以針對該群組檔案啟用第一個規格表的選項按鈕（無需選取其他規格表）。

選項按鈕上有圓形標記 (●) 的群組是目前的作用中群組。在「校準精靈」視窗中執行的校準和量測都對此作用中群組有效。作用中群組檔案的「儲存狀態」按鈕（主視窗）也可以儲存狀態檔案。

2. 規格表設定視窗

在此視窗中，可重新叫用包括 VNA 上設定的所有參數的規格。一個群組可隨附多個規格表，並在後端應用程式的以下程序中將其做為群組檔案 (.ssg) 進行處理。最多可以將 10 個不同的規格表新增到一個群組檔案中。

規格表設定視窗

  • 讀取群組檔案... 按鈕

重新叫用儲存的群組檔案 (.ssg)。

  • 當 VNA 韌體將功率值設定為不同的值時會發生錯誤。
    在前端應用程式中，可以設定的功率值解析度為 0.05 dBm。

  • 建立新群組... 按鈕（規格表設定視窗 (x)）

建立新的群組檔案 (.ssg)。

  • 瀏覽... 按鈕（規格表設定視窗 (x)）

顯示群組的狀態檔案的檔案選擇對話方塊。

  • 新增規格表... 按鈕（規格表設定視窗 (x)）

在群組檔案下新增規格表 (.mwa)。群組檔案的預設名稱會根據重新叫用的規格表命名。

  • 清除所有規格表按鈕（規格表設定視窗 (x)）

清除已在視窗中重新叫用的所有規格表。

  • 確定按鈕 （規格表設定視窗 (x)）

根據重新叫用的規格表反映 VNA 上的所有設定並返回主視窗。將會自動儲存群組的狀態檔案。

  • 取消按鈕（規格表設定視窗 (x)）

放棄設定並返回主視窗。

3. 連線資訊視窗

在主視窗中選取連線資訊時將會顯示此視窗。

此視窗會使用在前端應用程式中定義的標籤名稱，來顯示 VNA、多連接埠測試裝置及受測裝置之間的連線資訊。

連線資訊視窗

  • 關閉按鈕

關閉視窗並返回主視窗。

4. 校準精靈視窗

在主視窗中選取校準精靈時將會顯示此視窗。

此精靈會根據所重新叫用規格表的內容提供 VNA 和多連接埠測試裝置校準程序的必要步驟。

校準精靈視窗 (1/2)

  • 校準類型清單

顯示可以利用校準精靈執行的校準類型。

其中包括機械校準套件（利用機械校準套件進行校準）、4 埠 ECal（利用 4 埠 ECal 模組進行校準）、來源功率校準和接收器功率校準（接收器校準）。

  • 來源功率校準僅適用於已在前端應用程式的規格表中填寫了接收器頻率的量測路徑。

  • 校準套件清單

顯示 VNA 上可用於校準的機械校準套件的清單。選取「機械校準套件」做為校準類型時，可以選取此選項。

  • ECal 的清單

顯示在 ECal 模組中註冊的特性的清單。可以選取將 ECal 模組（使用者 1 到 5）的使用者定義的特性用於不同類型的接頭的校準。

  • 平均計數項目

設定校準期間的量測平均數。此平均數僅在校準期間使用，並且會在完成校準時恢復為在 VNA 中註冊的原始數字。

校準精靈視窗 (2/2)：已選取機械校準套件

校準精靈視窗 (2/2)：已選取 4 連接埠 ECal

  • 在校準精靈執行期間，校準精靈視窗的連接埠中的連接埠名稱或校準套件中的校準標準可能會灰顯。這表示「連接埠和校準標準之間的連線與校準程序中的步驟相同」；因此無需中斷校準量測標準的連接。

  • 量測按鈕

透過顯示的連接執行校準量測。

  • < 上一步按鈕

返回校準精靈中的上一個步驟。

  • 下一步 > 按鈕

在完成校準量測後移至校準精靈中的下一步。

  • 取消按鈕

中止校準精靈並返回主視窗。

  • 完成按鈕（取消按鈕變更）

在每個必要的連接埠上執行誤差係數修正，然後返回主視窗。

  • 校準資料會自動儲存在群組的狀態檔案 (.sta) 中。

5. 量測視窗

所有規格表量測視窗

在主視窗中選取 Measurement（量測）按鈕時，此視窗會顯示在「批量輸入」視窗中的設定後面。

規格表及其量測結果的摘要都會列在此視窗中。若要依規格表檢查結果，請選取此視窗中的每個規格表，然後按 Manual Trigger（手動觸發）。

所有規格表量測視窗

  • 規格表按鈕（所有規格表量測視窗 (x)）

顯示依規格表量測視窗。

左側有黑色三角形圖示的規格表按鈕指出要量測的下一個規格表。

  • 量測開啟/關閉核取方塊（所有規格表量測視窗 (x)）

只會量測具有勾選標記的規格表。

  • 一半按鈕

將後端應用程式的量測視窗重新調整為螢幕的一半大小。視窗位於螢幕的下半部，而 VNA 的量測結果會顯示在上半部。請參閱一半模式下的量測視窗。

  • 最小化按鈕

最小化量測視窗。請參閱最小化的視窗。

  • 手動觸發按鈕

使用視窗中已勾選規格表中的手動觸發立即進行量測。（黑色三角形圖示會顯示在規格表按鈕的左側。）

  • 略過按鈕

略過左側有黑色三角形圖示的規格表的量測。

  • 新增量測按鈕

結束目前視窗中的量測，儲存結果，然後使用新的批量名稱顯示所有規格表量測視窗。

  • 結束量測按鈕

結束目前視窗中的量測並返回主視窗。量測結果會儲存在 VNA 的指定目錄中。

依規格表量測視窗

透過選取「所有規格表量測」視窗中列出的規格表按鈕之一即可顯示此視窗。

此視窗會顯示選定規格表中的量測模式的清單。若要在檢查不同量測模式中的量測結果時進行量測，請在此視窗中按手動觸發。

依規格表量測視窗

  • 手動觸發按鈕（依規格表量測視窗 (1)）

在「所有規格表量測」視窗中勾選的規格表上使用手動觸發即可立即進行量測（與「所有規格表量測」視窗中的「手動觸發」按鈕相同的功能）。

  • 關閉按鈕（依規格表量測視窗 (1)）

返回所有規格表量測視窗。

依模式驗證結果視窗

透過選取「依規格表量測」視窗中列出的量測模式按鈕之一即可顯示此視窗。

此視窗會顯示在選定量測模式中指定的量測路徑的量測結果的清單。

依模式驗證結果視窗

  • 量測結果顯示區域

路徑：在前端應用程式中的「規格表」中定義的量測路徑的標籤名稱。

規格最小/最大：量測路徑受測裝置規格的最大和最小限制值。在前端應用程式中的「規格表」中輸入這些值。

最差值：針對每個量測點執行透過後端應用程式進行的限值測試，然後受測裝置的最差值會顯示在量測結果中。最差值的定義為距離最大和最小限制值的平均值最遠的值，該值對應於受測裝置的一般量測資料。

通過/失敗：指出量測路徑中的所有資料的限值測試結果。

排名：每個量測路徑（在前端應用程式中的規格表中指定）的排名值。您可以在失敗的所有量測路徑中為限值測試的結果排列優先順序並進行排序。後端應用程式會輸出失敗的量測路徑之間的最小排名值。例如，透過為特定量測路徑指定最小的排名值，可以在量測後使用排名值的輸出結果識別受測裝置的最差效能。

如果限值測試的結果顯示所有量測路徑都通過，則輸出排名值為「0」。

量測的通過/失敗結果的定義可以依在後端應用程式的批量輸入視窗中指定的「最大失敗排名」來分類。當排名值大於最大失敗排名值時，會將限值測試的失敗結果視為通過，並將量測路徑的對應排名值輸出到結果中。下表顯示輸出排名值的範例（將「最大失敗排名」設定為 200 時）。

路徑的排名值 | 通過/失敗 | 要輸出的排名
1 - 200 | 失敗 | 1 - 200
201 - 255 | 通過 | 201 - 255

如需量測值、最差值及通過/失敗判斷的資訊，請參閱設定每種模式中的量測參數的步驟 10。

  • 關閉按鈕

返回依規格表量測視窗。

6. 其他視窗

一半模式下的量測視窗：按下所有規格表量測視窗中的一半時會顯示此視窗。

當您想要在查看 VNA 的螢幕中顯示的量測結果時使用 MWA 時，可以使用此視窗。在此視窗中，只會顯示一個失敗的量測路徑，而您可以檢查對應的通道和軌跡，以進一步調查結果。

如果量測路徑無法顯示在一個螢幕中，<< 上一頁按鈕和下一頁 >> 按鈕即會變成有效狀態。

如果您勾選「顯示啟用」核取方塊，將會啟用 VNA 的「顯示更新」功能，以在螢幕上繪製影像。建議您停用此功能，以在真正需要快速測試時節省更新顯示畫面的時間。

一半模式下的量測視窗

批量輸入視窗

批量輸入視窗可用於量測的設定。 如需詳細資訊，請參閱量測程序（所有規格表量測視窗）。

批量輸入視窗

選取和清除規格表

以下說明在主視窗或規格表設定視窗中選取或清除規格表的程序。

選取規格表

  1. 在主視窗中按 Add Spec Sheet Group（新增規格表群組）以顯示「規格表設定」視窗。

  2. 若要建立新群組，請按下視窗中的 Create New Group...（建立新群組...），在檔案對話方塊中輸入新群組的名稱，然後按 Save（儲存）。

    若要重新叫用現有的群組，請按下視窗中的 Read Group File...（讀取群組檔案...），在檔案對話方塊中選取群組檔案，然後按 Open（開啟）。

    輸入或選取的群組檔案的完整路徑名稱會顯示在視窗中。

  3. 若要指定要與群組相關聯的狀態檔案，請按下狀態檔案框中的 Browse...（瀏覽...），選取要重新叫用的狀態檔案，然後按 Open（開啟）。

    選定狀態檔案的完整路徑名稱會顯示在視窗中。

  4. 按下視窗中的 Add Spec Sheets...（新增規格表...）。選取要在量測中使用的規格表，然後按 Open（開啟）。

選定規格表的名稱和 VNA 中的配置通道號碼將會顯示在視窗中。

  • 若要選取多個規格表，請視需要重複步驟 4，以讀取所有必要的規格表。

  • 當您選取規格表而未選取群組檔案或狀態檔案時，這些檔案的顯示名稱會與規格表的名稱相同。

  • 如果出現錯誤訊息，請參閱後端應用程式中的錯誤訊息。

  5. 選取所有必要的規格表後，請按 OK（確定）以返回主視窗。規格表的名稱和配置通道的資訊將會顯示在主視窗中。

    在後端應用程式中匯入規格表後，主視窗中的所有功能都會變成可用狀態。

  6. 未匯入任何規格表或透過 Clear All Groups（清除所有群組）清除所有規格表後，將會停用主視窗中的按鈕，其相關功能也會變成無法使用。

清除群組檔案

  1. 在規格表設定視窗中設定群組檔案後，在主視窗中選取 Clear All Groups（清除所有群組）。

  2. 將會清除所有群組檔案，而且主視窗中的所有按鈕都會變成停用狀態，相關功能也會變成無法使用。

  3. 無法個別清除每個群組檔案。

檢查連線

以下說明在連線資訊視窗中檢查量測儀器和受測裝置之間的連線的程序。

  1. 在重新叫用規格表後，在主視窗中選取 Connection Information（連線資訊）。

  2. 將顯示「連線資訊」視窗。根據螢幕上的資訊，連接 VNA、多連接埠測試裝置和受測裝置之間的纜線。

  3. 檢查連線是否正確後，按 Close（關閉）以關閉視窗並返回主視窗。

  • 在執行「校準精靈」視窗中的校準程序之前應先確認連線。也建議您在「量測」視窗中開始量測之前再次檢查連線。

校準程序

以下說明透過後端應用程式的「校準精靈」視窗執行校準程序的程序。

  1. 透過主視窗中的選項按鈕選取要校準的群組檔案。

  2. 在主視窗中選取 Cal Wizard（校準精靈）。

  3. 校準精靈會啟動，並顯示「校準精靈」視窗 (1/2)。從視窗中顯示的校準類型清單中，選取要執行的校準類型。可使用下列選項：

    校準類型

    描述

    機械校準套件

    使用校準套件執行校準。如需有關選取校準套件的資訊，請參閱步驟 4。

    4 連接埠 ECal

    使用 4 連接埠 ECal 執行校準。

    接收器校準

    在進行 FOM 量測時執行接收器校準。

  4. 如果在步驟 3 中選取了機械校準套件，視窗中會顯示可供選擇的校準套件的清單。選取要使用的適當校準套件。
    如果在步驟 3 中選取了 4 連接埠 Ecal，視窗中會顯示 ECal 模組的使用者定義的特性的清單。選取要使用的適當的 ECal 模組特性。如需更多詳細資料，請參閱使用者特性化的 ECal。

附註： 已從 VNA 韌體匯入顯示的校準套件的資訊。在 VNA 中變更校準套件的參數時，對應的資訊也會反映在後端應用程式中。

  5. 將校準量測期間的平均數目輸入「平均計數」輸入方塊。選取校準套件上的所有參數後，按 Next（下一步）以執行校準程序的下一步。

  6. 將顯示「校準精靈」視窗 (2/2)。將顯示 VNA 或多連接埠測試裝置的連接埠，以及用於校準的校準標準 。將連接埠與標準連接，然後按 Measure（量測）。在完成校準量測後，按 Next >（下一步 >）以執行下一步。

  7. 針對選定規格表的所有必要校準步驟，視需要重複步驟 6。在完成所有校準量測後，按 Done（完成）並返回主視窗。校準資料將會自動儲存在選定群組檔案的狀態檔案中。

  1. 使用 ECal 執行校準時，如果針對 VNA 韌體上的觸發範圍選取了作用中通道，MWA 後端應用程式將會顯示「執行錯誤」。因此，請針對觸發範圍選取 All Channels（所有通道）。

儲存狀態檔案

以下說明在主視窗中儲存狀態檔案的程序。

在規格表設定視窗中建立群組檔案，或在校準精靈視窗中執行校準時，將會自動儲存群組的狀態檔案。如果變更了 VNA 上的參數，但卻未使用後端應用程式的功能，則應在主視窗中手動儲存狀態檔案。

  1. 在主視窗中按 Save State（儲存狀態）。

  2. 將會更新目前作用中群組的狀態檔案 (.sta)。

量測程序（所有規格表量測視窗）

以下說明依所有規格表量測視窗中的規格表進行量測的程序。

  1. 在規格表設定視窗中設定規格表後， 在主視窗中按 Measurement（量測）。將顯示批量輸入視窗。

  2. 輸入受測裝置的批量名稱。視需要勾選量測中的選用功能，然後按 OK（確定）。

  • 輸出開始/停止值

此選項可讓您將開始和停止頻率的量測值寫入量測的結果檔案。量測後，後端應用程式會自動產生每個規格表的結果檔案。請參閱「依規格表建立量測結果」。

  • 修正（限值測試）

此選項可讓您反映在「規格表」前端應用程式中指定的量測值的修正，請參閱「設定每種模式中的量測參數」中的步驟 9。

  • 啟用手動量測

此選項可啟用所有規格表量測視窗和依規格表量測視窗中的 Manual Trigger（手動觸發）按鈕。未勾選此選項時，無法使用 Manual Trigger（手動觸發）按鈕進行手動量測。

  • 覆寫輸出檔案

此選項可讓您在結果輸出檔案已存在時覆寫或新增量測結果。勾選此選項後，將會覆寫現有的檔案。

  • 最大失敗排名 (1-255)

此選項可針對限值測試中的失敗結果設定最大排名值。例如，將「最大失敗排名」設定為 10 時，量測路徑的結果排名 1 到 10 視為失敗，而 11 到 255 則視為通過。如需詳細資訊，請參閱「量測」結果顯示區域中的排名。

按 OK（確定）按鈕時，將顯示所有規格表設定視窗。

  3. 按 Skip（略過）將黑色三角形圖示置於要進行量測的所需規格表的左側。

  4. 將黑色三角形圖示置於要在量測期間使用的規格表左側後，按 Manual Trigger（手動觸發）以執行量測。

若要針對已在前端應用程式的「規格表」中勾選的選定量測路徑進行量測，請勾選 Selected Measurement（選定量測），然後按 Manual Trigger（手動觸發）。

若要使用顯示的規格表進行連續量測，請勾選 Continuous（連續）核取方塊。

  5. 完成規格表的量測後，量測結果（「通過」或「失敗」）會顯示在每個規格表的右側。

附註： 若要檢查每個規格表的量測結果，請按下所需規格表的按鈕以顯示「依規格表量測」視窗。如需有關「依規格表量測」視窗的資訊，請參閱量測程序（依規格表量測視窗）。

量測程序（依規格表量測視窗）

以下說明在量測視窗中選取一個規格表，然後針對規格表中所包含的每種量測模式在依規格表量測視窗中進行詳細量測的程序。

  1. 在「所有規格表量測」視窗中，按下所需規格表的按鈕以顯示該規格表的「依規格表量測」視窗。

  2. 按 Manual Trigger（手動觸發）以啟動選定規格表中的每種模式的量測。

若要針對已在前端應用程式的「規格表」中勾選的選定量測路徑進行量測，請勾選 Selected Measurement（選定量測）的方塊，然後按 Manual Trigger（手動觸發）。

若要使用所有量測模式的連續掃描進行連續量測，請勾選 Continuous（連續）核取方塊。

  3. 完成量測後，字母「P」（代表「通過」）或「F」（代表「失敗」）會顯示在量測模式的右側。按 Close（關閉）以返回「所有規格表量測」視窗。

附註： 若要檢查每種量測模式的詳細量測結果，請按下所需量測模式的按鈕以顯示「依模式驗證結果」視窗。如需有關「依模式驗證結果」視窗的資訊，請參閱量測程序（依模式驗證結果視窗）。

量測程序（依模式驗證結果視窗）

以下說明選取一種量測模式並根據依模式驗證結果視窗中的量測路徑檢查結果的程序。

  1. 若要顯示「依量測模式驗證結果」視窗，請在「依規格表量測」視窗中按下所需量測模式的按鈕。

  2. 每個量測路徑的量測結果會列在「依量測模式驗證結果」視窗中。如需所列示參數的更多詳細資料，請參閱依模式驗證結果視窗中的量測結果顯示區域。

建立的結果檔案

本節說明在量測結束時建立的量測結果檔案。

  1. 依批量建立量測結果摘要

在量測結束時或透過在所有規格表量測視窗中選取「新增量測」變更批量的名稱時，將會建立此檔案。它會以 csv 格式建立，並自動儲存在 VNA 中。

所建立檔案的內容會顯示在依批量建立量測結果摘要中。

依批量建立量測結果摘要

第一行是檔案的標頭，第二行或下面的行則包含每個規格表的量測結果。結果中包含以下參數：

  • 規格表 x：用於量測中的規格表名稱。

  • 總數：受測裝置的批量量測總數。

  • 通過數目：受測裝置的批量通過結果總數。

  • 模式 x：在量測中產生失敗結果的規格表中的模式標籤名稱。

  • 模式 x 失敗數目：規格表中的模式的失敗結果總數。

  2. 依規格表建立量測結果

針對每個規格表分別建立量測結果的檔案。每個檔案會以 csv 格式（「批量名稱」-「規格表名稱」.csv）建立，並自動儲存在與 VNA 的每個規格表 (.mwa) 相同的資料夾中。所建立檔案的內容會視在批量輸入視窗中選擇的「輸出開始/停止值」核取方塊而變更。

所建立檔案的內容會顯示在「依規格表建立量測結果」中。

依規格表建立量測結果的檔案（開始/停止值：開啟）

"Index","Rank","Mode1-Path1",,,"Mode1-Path2",,,"[GPIB**Address] GPIB Command, ...,"ModeX-PathY",,

,,"Start","Stop","Worst", ...,"Meas", ...,"Start","Stop","Worst", ...

1,Output Rank,Start_Value,Stop_Value,Worst_Value, ...,GPIB_Response Value, ...,Start_Value,Stop_Value,Worst_value, ...

2,Output Rank,Start_Value,Stop_Value,Worst_Value, ...,GPIB_Response Value, ...,Start_Value,Stop_Value,Worst_Value, ...

...

N,rOutput Rank,Start_Value,Stop_Value,Worst_Value, ...,GPIB_Response Value, ...,Start_Value,Stop_Value,Worst_Value, ...

第一行和第二行是檔案的標頭，第三行或下面的行則包含規格表的所有量測結果。檔案中包含以下參數：

  • 索引：規格表的量測次數。

  • ModeX-PathY:規格表中特定模式的量測路徑標籤名稱。

  • 輸出排名：規格表的輸出排名值。如需詳細資料，請參閱排名。

  • 開始值：量測路徑的開始頻率的量測值。

  • 停止值：量測路徑的停止頻率的量測值。

  • 最差值：量測路徑的量測頻率範圍內的最差值。如需詳細資料，請參閱最差值。

  • GPIB 回應值：透過 GPIB 指令從外部週邊設備匯入的量測值。結果值會插入量測模式的結果末尾。查詢指令會顯示在包含所使用週邊設備的 GPIB 位址的標頭中。

單一受測裝置的所有量測值會總結在一行中。針對一個規格表執行多個量測時，檔案中會包含其他行中的多個量測結果。

由於開始/停止頻率的量測值不能用於「平均值」或「漣波」等量測類型，因此該路徑的開始/停止值中不會記錄任何資料。

附註： 即使透過「所有規格表量測」視窗中的「略過」按鈕略過某個規格表的量測，該結果也會記錄在檔案中。不過，輸出排名會固定為 -1，並且不會針對開始/停止或最差值記錄任何量測值。

在量測前透過批量輸入視窗停用「輸出開始/停止值」時，輸出的內容如下所示：

依規格表建立量測結果（開始/停止值：關閉）

"Index","Rank","Mode1-Path1",,,"Mode1-Path2",,,"[GPIB**Address]GPIB Command", ...,"ModeX-PathY",,

1,Output Rank,Worst_value, ...,GPIB Response Value, ...,Worst_Value, ...

2,Output Rank,Worst_value, ...,GPIB Response Value, ...,Worst_Value, ...

...

N,Output Rank,Worst_value, ...,GPIB Response Value, ...,Worst_Value, ...

從外部電腦控制後端應用程式

以下說明從外部電腦控制後端應用程式的程序。

  1. 透過 GPIB 將下列指令傳送至 VNA。

DISP:WIND1:TITL:DATA（指令參數）

以下指令參數也可用於 MWA。

指令參數

cmd_para 函數 | 引數 1 | 引數 2 | 接受該指令的視窗
cmd_read | 群組檔案名稱 (.ssg) 或規格表名稱 (.mwa) |  | 主視窗
cmd_clear | - |  | 主視窗
cmd_begin | 批量名稱 | 批量輸入視窗中的參數。如需更多詳細資料，請參閱量測程序（所有規格表量測視窗） | 主視窗、量測視窗
cmd_initiate | - |  | 量測視窗
cmd_skip | - |  | 量測視窗
cmd_settings | 修正值、手動量測 |  | 量測視窗
cmd_end | - |  | 量測視窗

每個 cmd_para 函數如下所示。

cmd_para 函數

描述

對應的按鈕

cmd_read

讀取引數 1 指定的群組檔案或規格表。如果您在沒有檔案存在或已經沒有其他檔案可以讀取時傳送此指令，將會發生錯誤。

若要指定多個規格表，請在步驟 2 中指定引數 1 時，以逗號分隔指定規格表。

主視窗

新增規格表群組

cmd_clear

清除目前讀取的所有規格表。

主視窗

清除所有群組

cmd_begin

顯示「所有規格表量測」視窗，使用引數 1 指定受測裝置的批量名稱。

引數 2 指定量測的選項（「批量輸入」視窗中的相同設定）。如需更多詳細資料，請參閱量測程序（所有規格表量測視窗）。如需每個選項的資訊，請參閱該頁面。

  • 輸出開始/停止值

與開始/停止值相同。指定 0（關閉）或 1（開啟）。

  • 修正值

與修正（限值測試）相同。指定 0（關閉）或 1（開啟）。

  • 手動量測

與啟用「手動量測」相同。指定 0（關閉）或 1（開啟）。

  • 覆寫輸出檔案

與「覆寫輸出檔案」相同。指定 0（關閉）或 1（開啟）。

  • 最大失敗排名

與最大失敗排名 (1-255) 相同。指定從 1 到 255 之間的值。

如果在顯示每個量測視窗時傳送此指令，會將結果的摘要產生為一個檔案，關閉目前的量測，而且「所有規格表量測」視窗會以新的批量名稱開啟。

主視窗

量測

所有規格表量測視窗

新量測

cmd_initiate

立即啟動量測。

所有規格表量測視窗

手動觸發

依規格表量測視窗

手動觸發

cmd_skip

略過下一個規格表的量測。

所有規格表量測視窗

略過

cmd_settings

在量測期間變更修正值和手動量測的選項。如需修正值和手動量測的資訊，請參閱 cmd_begin 的說明。

無

cmd_end

輸出結果的摘要，並返回主視窗。

所有規格表量測視窗

結束量測

  2. 如果必須設定指令的引數，則在傳送步驟 1 中的指令前需要以下指令。如果每個引數都有幾個項目，請以逗號 (,) 分隔設定所有參數。

  • 設定引數 1 的指令

DISP:WIND2:TITL:DATA 參數

  • 設定引數 2 的指令

DISP:WIND3:TITL:DATA 參數

例如，若要使用批量名稱「lot_gsm001」開始新的量測，請傳送以下指令。在以下範例中，開啟了輸出開始/停止值和覆寫輸出檔案，並將最大失敗排名設定為 100。

10 output 717;"DISP:WIND2:TITL:DATA lot_gsm001"
20 output 717;"DISP:WIND3:TITL:DATA 1,0,0,1,100"
30 output 717;"DISP:WIND1:TITL:DATA cmd_begin"

附註： 如果傳送的指令包含不正確的引數，將不會執行該指令。

當指令程序完成後，DISP:WIND1:TITL:DATA? 的傳回值會變成「cmd_done」，如果您要等待指令程序完成，請透過 DISP:WIND1:TITL:DATA? 傳回的值是否為「cmd_done」進行確認

透過 MWA 操作處理器 I/O 連接埠

透過 MWA 操作的處理器 I/O 的接腳清單如下所示。括號中的訊號符號與 VNA 的那些訊號符號相對應。如需詳細資料，請參閱 I/O 訊號接腳配置和說明。

接腳編號 | MWA 中的訊號名稱（在正常模式下的訊號名稱） | 訊號的方向 | 描述
2 | /INPUT (/INPUT1) | 輸入 | 將負脈衝施加於此接腳時，訊號 /OUTPUT1 的位準會變為「低」。
3 | /INIT (/OUTPUT1) | 輸出 | 將負脈衝施加於接腳 2 時，/OUTPUT1 的位準會變為「低」。 後端應用程式會監控 /OUTPUT1，當它變「低」時，便會開始量測。/OUTPUT1 會在量測開始時變回「高」。 此外，「CONT:HAND:OUTP1:DATA 1」指令可以用來將訊號位準設定為「低」或「高」。
5 | /RANK A0 (/PORT A0) | 輸出 | 輸出量測的最小排名值。輸出排名為 8 位元值 (0-255)，A0 為 LSB，A7 為 MSB。 /PORT A0 是輸出排名的位元 0。
6 | /RANK A1 (/PORT A1) | 輸出 | 輸出排名的位元 1。
7 | /RANK A2 (/PORT A2) | 輸出 | 輸出排名的位元 2。
8 | /RANK A3 (/PORT A3) | 輸出 | 輸出排名的位元 3。
9 | /RANK A4 (/PORT A4) | 輸出 | 輸出排名的位元 4。
10 | /RANK A5 (/PORT A5) | 輸出 | 輸出排名的位元 5。
11 | /RANK A6 (/PORT A6) | 輸出 | 輸出排名的位元 6。
12 | /RANK A7 (/PORT A7) | 輸出 | 輸出排名的位元 7。
13 | /FAIL (/PORT B0) | 輸出 | 如果限值測試失敗，/PORT B0 將會變為啟用狀態（低位準）。如果輸出排名值 (/PORT A0 - /PORT A7) 為 0（對應於所有量測的通過），/PORT B0 會變為停用狀態（高位準）。 此訊號會在輸出 /RANK（/PORT A0 到 A7）變換後變換，但變換的時間和 /INDEX (/PORT B4) 變換幾乎相同。請務必在 /INDEX 變換後經過一些延遲再檢查 /FAIL。
17 | /INDEX (/PORT B4) | 輸出 | 指出量測結束的訊號。 訊號會在輸出排名 (/PORT A0 - /PORT A7) 變換後變換。 後端應用程式會在量測開始時將 /PORT B4 設定回非作用中狀態（高位準）。
19 | /INDEX_SUB (/PORT B5) | 輸出 | 使用相同函數做為 /PORT B4 的保留訊號接腳。可以使用任一個接腳。
22 | /SKIP (/PORT C0) | 輸入/輸出 | 這是一個略過訊號。 如果在量測前啟用了 /PORT C0（低位準），將不會執行量測，而且狀態會轉換為等待下一個量測的模式。

後端應用程式中的錯誤訊息

與 MWA 搭配使用時，不當的 VNA 設定可能會導致出現錯誤訊息。本節說明各種錯誤訊息，以及可以避免這些錯誤的方法。

錯誤訊息

描述

Channel Max（通道上限）

如果規格表 (.mwa) 所需的通道總數超過了在 VNA 中設定的通道數目，就會出現此錯誤訊息。

附註： 透過提高 VNA 中的通道數目上限，即可避免此錯誤。

Configuration and test set are mismatched.（組態和測試裝置不匹配。）

如果由前端應用程式產生的規格表 (.mwa) 中指定的測試裝置的組態與連接至 VNA 的測試裝置不同，就會出現此錯誤訊息。

透過變更前端應用程式中的「多連接埠測試裝置」表的組態，即可避免此錯誤。如需詳細資訊，請參閱選取測試裝置。

在以下情況下可能會出現此錯誤：

  • 規格表中的組態適用於 E5091A (E5092A)，但將 E5092A (E5091A) 連接至 VNA。

  • 規格表中的組態是針對多連接埠測試裝置（E5091A 或 E5092A），但未將任何測試裝置連接至 VNA。

  • 規格表中的組態為「無」（沒有測試裝置），但將測試裝置連接至 VNA。

GPIB Error（GPIB 錯誤）

如果連接至 VNA 的週邊設備的 GPIB 位址與您在前端應用程式的 GPIB 表中指定的位址不同，就會出現此錯誤訊息。

Invalid number of point（點數無效）

如果規格表 (.mwa) 所需的點數上限超過在 VNA 中設定的點數，就會出現此錯誤訊息。

注意：透過提高 VNA 中的通道數目上限，即可避免此錯誤。

Invalid Trace（軌跡無效）

如果規格表 (.mwa) 所需的軌跡數上限超過在 VNA 中設定的軌跡數，就會出現此錯誤訊息。

附註： 透過提高 VNA 中的通道數目上限，即可避免此錯誤。


多連接埠交換器量測範例

  • 概觀

  • 受測裝置 (DUT)

  • 所需設備

  • 量測參數

  • 量測步驟

關於量測精靈輔助的其他主題

概觀

本節介紹了如何在 VNA 上使用 MWA 軟體對多連接埠交換器進行量測。此量測範例的量測條件適用於 SP9T 多連接埠交換器。若要量測其他受測裝置 (DUT)，請變更量測條件以適合於特定的 DUT。

受測裝置 (DUT)

此範例中使用的受測裝置是一個 SP9T 交換器範例，採用以下組態，應採用 10 連接埠全橫向組態連接到 E5092A：

受測裝置連接埠名稱 | 連接埠號 | 測試裝置
ANT | 1 | 5COM
Tx1 | 2 | 8COM
Tx2 | 3 | 6COM
TRx1 | 4 | 9COM
TRx2 | 5 | 7COM
TRx3 | 6 | 10COM
Rx1 | 7 | 1D
Rx2 | 8 | 2D
Rx3 | 9 | 4D
Rx4 | 10 | 3D

所需設備

此範例需要以下測試設備：

  • VNA（4 連接埠 VNA）

  • E5092A 可設定多連接埠測試裝置（選件 020）

  • RF 纜線（用於受測裝置和測試裝置之間的連線）

  • 控制線路纜線

量測參數

此範例中採用的範例受測裝置是一個 SP9T（單級，9-throw）10 連接埠交換器。應針對任意連接埠之間的所有傳輸路徑對此交換器傳輸進行量測，對受測裝置的所有連接埠進行反射量測。由 4 位元邏輯控制直流電壓（2.8v 為高電壓，0V 為低電壓）選擇受測裝置的輸出連接埠。

範例交換器的真值表如下所示：

 | A 群組 |  |  |  | B 群組
連接的路徑 | Vc1 | Vc2 | Vc3 | Vc4 | Vc1 | Vc2 | Vc3 | Vc4
Tx1 | H | L | L | L | H | L | L | L
Tx2 | L | H | L | L | H | L | L | L
TRx1 | H | H | L | L | H | L | L | L
TRx2 | L | L | H | L | H | L | L | L
TRx3 | H | L | H | L | H | L | L | L
Rx1 | L | H | H | L | H | L | L | L
Rx2 | H | H | H | L | H | L | L | L
Rx3 | L | L | L | H | H | L | L | L
Rx4 | H | L | L | H | H | L | L | L

量測步驟

使用 MWA 軟體的前端和後端應用程式進行範例交換器量測。量測程序是：

  1. 使用 MWA 前端應用程式產生規格表 (.mwa)。

  2. 複製 VNA 目錄上的規格表

  3. 使用 MWA 後端應用程式匯入規格表。

  4. 透過後端應用程式中的校準精靈執行必要的校準量測。

  5. 連接受測裝置與測試裝置（RF 纜線、控制線）

  6. 使用後端應用程式執行量測。

前端應用程式

前端應用程式包含六張表，將根據交換器規格輸入範例交換器的資料。此表可以在普通 PC 上執行：

1. 多連接埠測試裝置資料表

為 10 連接埠全橫向量測選取「E5092A X-10-Port」組態。

2. 受測裝置表

定義受測裝置的連接埠名稱以及與多連接埠測試裝置的連線。

3. 模式表

將控制線群組 A 的控制邏輯電壓（Vc1 到 Vc3）套用於受測裝置（邏輯 A 至 C），將 Vc4 用於受測裝置電源。

4. GPIB 表

可以將 SCPI 指令發送到透過 GPIB 連線到 VNA 的周邊。

5. 規格表

針對受測裝置的每個作業模式，在所有路徑之間執行傳輸量測。

6. 輸出資料表

透過在該表中選取「儲存規格表」按鈕產生規格表在量測通道中自動分配軌跡。

後端應用程式

後端應用程式安裝在 VNA 上，根據以下情況將 mwa 檔案中的資料匯入其中：

1. 匯入規格表

在主視窗中，選取「新增規格表群組」，在顯示的視窗中選取「新增規格表...」。

2. 執行校準

按照以下「逐步」校準精靈完成一系列校準量測。

3. 連接受測裝置和測試裝置

連線檢查視窗中顯示了受測裝置和多連接埠測試裝置之間的連線。

4. 執行量測


群組的概觀和限制

  • 群組功能概觀

  • 群組功能限制

  • 作用中群組

  • 群組檔案和狀態檔案之間的關係

  • 處理流程

關於量測精靈輔助的其他主題

群組功能概觀

後端應用程式具有「群組」功能，可使用規格檔案進行多個量測。

對於後端應用程式，將以下資訊項目作為一個群組收集在一起。

  • 多個規格檔案

  • VNA 設定（狀態檔案）

每個群組需要一個群組檔案（副檔名：ssg），它具有與每一個群組檔案關聯的檔案的連結，如下圖所示。群組檔案沒有規格檔案內容的資訊，也沒有 VNA 設定，但包含這些檔案的連結資訊。

附註：如果沒有連結的檔案，在重新叫用群組檔案的過程中會發生錯誤。

群組和連結的概念

群組功能限制

下文列出了使用群組功能的限制。

  • 一次最多可以定義 10 個群組。

因為 MWA 最多可以使用 10 個規格檔案，假設一個規格檔案指派至每個群組，則一次可以重新叫用的群組最大數目是 10。

  • 在一個群組中使用的規格檔案的檔案名不能用於其他群組的規格檔案。

MWA 無法一次重新叫用相同名稱的規格檔案，所以不能同時重新叫用包含相同名稱規格檔案的群組。

  • 每個群組的最大通道數與 VNA 的相同。

因為隨 VNA 重新叫用與群組關聯的狀態檔案，一個群組的通道最大數目限制為 VNA 的通道數目。

作用中群組

每個群組可能有完全不同的 VNA 狀態，因此需要知道目前 VNA 狀態表示哪些群組的狀態。

「目前 VNA 狀態」稱為「作用中的群組」。VNA 採用與作用中的群組相同的設定。

若要變更作用中的群組，請選取主視窗中顯示的規格檔案名稱左側的選項按鈕。

如果群組檔案包含兩個以上的規格檔案，請選取群組頂部的規格檔案。其他規格檔案將會灰顯，無法進行選取。

變更作用中的群組時，VNA 狀態也會隨之變更。這意味著透過使用 VNA 重新叫用功能重新叫用與每個群組關聯的狀態檔案。

附註： VNA 的重新叫用過程需要一定時間，變更作用中的群組也是一樣。

為作用中的群組執行校準精靈功能和狀態檔案儲存功能。當對重新叫用的多個群組執行校準精靈時，會為目前作用中的群組執行校準。當您需要校準其他群組時，請變更作用中的群組，然後再次執行校準精靈功能。也必須為狀態檔案儲存功能完成這一過程。

附註： 量測過程中的作用中的群組功能。您需要切換作用中的群組以量測其他群組。然而，當重新叫用多個群組時，如果該群組發生變更，則作用中的群組會自動變更。

群組檔案和狀態檔案之間的關係

一個狀態檔案與每個群組相關聯。為確保順利使用 MWA，請閱讀有關狀態檔案的以下資訊。

群組檔案和狀態檔案之間的關係

當按 Save State（儲存狀態）按鈕時，校準精靈功能的結果和 VNA 設定將會記錄並儲存在「與群組關聯的狀態檔案」中。當作用中的群組變更時重新叫用此狀態檔案。

附註： 會在無需確認檔案名稱的情況下重新叫用狀態檔案。此外，也將在不進行確認的情況下覆寫該檔案。

儲存和重新叫用狀態檔案的時間如下所示。為與該群組關聯的狀態檔案執行所有過程。

1. 儲存狀態檔案的時間

  • 當重新叫用該群組時（將規格檔案的內容輸入 VNA 後）。

  • 當校準精靈功能終止時

  • 當按 Save State（儲存狀態）按鈕時。

2. 重新叫用狀態檔案的時間

  • 當重新叫用該群組時（將規格檔案的內容輸入 VNA 前）。

  • 變更作用中的群組時。

狀態檔案注意事項

如果重新叫用的通道/軌跡設定與目前通道/追蹤設定不同，可能會出現錯誤。
這是因為狀態檔案會在下列過程中遭覆寫。

  1. 重新叫用該群組時重新叫用狀態檔案。

  2. 重新叫用失敗。

  3. 如果重新叫用失敗，VNA 將進入預設狀態。

  4. 重新叫用規格檔案。

  5. 根據規格檔案的內容變更 VNA 狀態。

  6. 在狀態檔案中撰寫 VNA 狀態。

例如，假定以下條件：

  • 狀態檔案的設定是正確的，但與 VNA 的通道/軌跡設定不同。

  • 將正常執行校準。

因為狀態檔案與目前 VNA 的通道/軌跡設定不同，重新叫用將失敗，然後 VNA 進入預設狀態。此時，將會放棄校準資料。

在過程 6 中，會儲存與群組相關聯的狀態檔案。然而，該檔案名與過程 1 中的原始狀態檔案名相同，因此，將使用預設狀態的內容和符合規格檔案的設定覆寫原始狀態檔案。同樣會丟失原始校準資料。

為了防止這種情況發生，過程 3 和 4 之間將顯示一個確認對話方塊。如果您無法重新叫用狀態檔案，請確認 VNA 設定。

處理流程

本節介紹了使用後端應用程式時三個狀態的處理流程。

重新叫用規格檔案時的處理流程

重新叫用規格檔案時的處理流程如下所示。當使用多個群組時，請按照群組數重複此過程。

重新叫用規格檔案時的處理流程

附註：按 OK（確定）按鈕後，在重新叫用狀態檔案過程中，如果與群組關聯的狀態檔案不存在，則過程移至下一步，「重新叫用規格表」。沒有中間過程（例如預設）變更 VNA 的設定。

量測前的處理流程

量測之前的處理流程如下所示。

量測前的處理流程

在開始量測之前需完成以下五個步驟。

  1. 重新叫用規格檔案（檔案群組）

  2. 使用 Minimize（最小化）功能設定顯示並使用 Save State（儲存狀態）按鈕儲存狀態。

  3. 檢查連線資訊畫面時，將接頭連接到校準邊緣。

  4. 使用校準精靈功能執行校準。

  5. 檢查連線資訊畫面時，將受測裝置連接到校準邊緣。

對目前作用中的群組執行顯示設定和校準。如果您使用多個群組，您需要設定顯示，並透過使用選項按鈕變更作用中的群組的方式對每個群組執行校準。

正如群組檔案和狀態檔案之間的關係和注意事項中所述，在重新叫用每個群組的規格檔案前，會重新叫用與該群組關聯的狀態檔案。因此，顯示設定和校準資料與上次相同，這樣您從下次開始可以略過此過程。

附註： 建議您每次執行校準。

量測過程中的處理流程

單個群組的處理流程如下所示。

量測過程中的處理流程（單個群組）

在此示例中，使用了三個規格檔案，但即使只有一個規格檔案，過程也是相同的。

多個群組的處理流程如下所示。下圖顯示了開始量測時曾重新叫用狀態檔案 1 的狀態，而觸發進行每次量測。

量測過程中的處理流程（多個群組）

當量測多個群組時，會在以下時間切換作用中的群組。

  • 在量測群組 1 的通道 6-9 以後，MWA 成為「等待觸發」狀態。當產生一個觸發器時，作用中的群組切換到群組 2。

  • 在量測群組 2 的通道 5-6 以後，MWA 成為「等待觸發」狀態。當產生一個觸發器時，作用中的群組切換到群組 1。

即使在量測每個群組的最後一頁後，作用中的群組也不會切換到下一群組。由於您可以在量測過程中開啟/關閉每個規格檔案，如果群組中的所有表都關閉，您不需要啟用該群組。

如果規格表 4 和 5 都關閉，則不需要移動到群組 2，可以在不重新叫用狀態檔案 2 的情況下啟動規格表 1 的量測。此過程與之前所述的量測單個群組的過程相同。


疑難排解

疑難排解 VNA

透過執行幾項檢查，您可以識別分析儀是否發生故障。在致電 Keysight Technologies 或退回儀器進行維修之前，請確保進行以下檢查。

  • 檢查基礎內容

  • 檢查誤差項

  • 查閱維修指南

  • 錯誤記錄資料

其他支援主題

檢查基礎內容

再現發生某個問題時所遵循的程序通常可以解決該問題。致電 Keysight Technologies 或退回儀器以進行維修之前，請確保進行以下檢查：

附註： VNA 應用程式的問題（緩慢或意外終止）可能由於固態硬碟 (SSD) 發生故障而導致。如需更多資訊，請參閱防止 VNA 硬碟問題及 VNA SSD 復原程序。

  1. 電源插座是否已通電？儀器是否已插上電源？

  2. 儀器是否已開啟？檢查前面板線路開關及測試連接埠週圍的至少一個 LED 環形指示燈是否閃爍綠光。這種情況指示電源已開啟。

  3. 如果您在使用前面板鍵盤或週邊設備時遇到困難，則 USB 匯流排可能已過載。移除 USB 裝置，重新啟動 VNA，然後重新連接 USB 裝置。請參閱開機。

  4. 如果有其他設備、纜線以及接頭與儀器搭配使用，請確保他們已正確連接並正常運作。

  5. 檢閱出現問題時執行量測的程序。是否所有設定都正確無誤？

  6. 如果儀器未按預期工作，請透過按下預設鍵使裝置返回到已知狀態。

  7. 量測是否正確執行以及量測結果是否如預期處於儀器的規格和功能的範圍之內？

  8. 如果您認為問題是由於韌體導致的，請先檢查儀器是否已安裝最新韌體，然後再開始疑難排解程序。

  9. 檢查量測校準是否有效。如需更多資訊，請參閱精準的量測校準。

檢查誤差項

如果按固定的間隔（每週、每月等）列印誤差項，則您可以將目前的誤差項與這些記錄進行比較。穩定的可重複系統應能在長時間間隔（例如，6 個月）內生成可重複的誤差項。如果懷疑出現輕微故障或不嚴重的效能問題，則您應將誤差項的幅度與先前透過相同儀器和校準套件產生的值進行比較。請參閱誤差項的監控程序。

  • 長期趨勢通常可反映以下問題，從而表明需要執行進一步調查和預防性維護：漂移、接頭及纜線磨損或效能逐漸下降。但是，系統可能仍符合規格。解決方案通常很簡單，如清潔和度量連接器或檢查纜線。

  • 誤差項突然改變反映系統誤差發生了突然改變，並且表明需要執行進一步的疑難排解。

進行疑難排解時，請考量以下因素：

  • 系統的所有零件（包括纜線與校準裝置）都會造成系統誤差並會影響誤差項。

  • 您必須清潔和度量接頭，並且接頭必須處於規格範圍內，這樣誤差項分析才有意義。如需有關清潔和度量接頭的資訊，請參閱《VNA 維修指南》的第 2 章。

    • 進行量測校準後，請避免不必要地彎曲纜線，以將纜線不穩定性誤差降至最低。

    • 在量測校準期間，請使用正確的連接方法。接頭接口必須可重複。有關連接方法的資訊，請參閱《VNA 維修指南》。

  • 通常，您有必要執行兩次該程序（使用兩種不同的量測校準），以確定可重複性的程度。如果結果似乎不可重複，請檢查所有接頭和纜線。

  • 使用誤差項分析來疑難排解次要輕微效能問題。如果出現明顯的故障或嚴重的量測誤差，請參閱《VNA 維修指南》的第 3 章「疑難排解」。

查閱維修指南

有關可協助確定問題的特定疑難排解程序，請參閱《VNA 維修指南》。您可以從我們的網站下載維修指南的複本：http://www.keysight.com/find/na。

錯誤記錄資料

VNA 會自動建立資料記錄，以供疑難排解。基於安全原因，如果需要刪除此資料，可以使用 :SERV:LOGG:CLE 指令來清除 VNA 所建立的記錄。

記錄檔會儲存下列相關資料：

  • 功率開啟時間

  • 功率開啟次數

  • 功率開啟測試結果

  • 超載次數

  • 事件記錄

  • 硬體驅動程式安裝/錯誤記錄

  • 連接的 USB 裝置記錄

  • 使用者校準記錄

  • 韌體錯誤記錄

  • 類比板溫度

  • 內部測試結果

上次修改時間：

10/16/06

已新增相位鎖定遺失


VNA 錯誤

VNA 錯誤訊息

  • 500 - 750 校準

  • 770 - 1000 硬體

  • 1000 - 1200 量測

  • 1281 - 1535 剖析器

  • 1536 - 1650 顯示

  • 1700 - 2000 通道

  • 2048 - 2200 一般

  • 標準 SCPI 錯誤

附註：下面列出的事件 ID 是針對 COM 編程提供的。如需詳細資訊，請參閱處理 VNA 事件

如需有關 VNA 錯誤訊息的詳細資訊，請參閱錯誤訊息。

記憶體溢位錯誤

記憶體溢位。觸發狀態已設定為「保持」。請降低 IF 頻寬，或延長停頓或掃描時間。

嚴重性：資訊

進一步說明：您目前正在進行的量測要求資料儲存速度超過資料處理速度。 客戶很少會遇到這種情況。

建議：若要限制儲存的資料量，請嘗試降低 IF 頻寬並延長掃描時間和停頓時間，或限制資料點數目。 還可以透過調整許多其他設定來解決此問題。

事件 ID：

校準錯誤

訊息： 512

「校準狀態的次要參數（功率、IFBW、掃描時間、步進模式）已變更。」

嚴重性：資訊

進一步說明：如果任何次要參數在執行校準後發生變更，則校準結果將變得不可靠。

建議：如果您需要使用新設定進行準確量測，請重複執行校準。

事件 ID：68020200（十六進位）

訊息： 513

「在量測所選校準類型的所有必要標準之前，您無法完成校準。」

嚴重性：資訊

進一步說明：您可能會收到此訊息，因為您已嘗試開啟修正，而沒有首先量測所有校準標準

建議：完成校準標準量測

事件 ID：68020201（十六進位）

訊息： 514

「您已使用先前儲存在具有不同硬體組態之分析儀上的檔案重新叫用校準集。」

嚴重性：資訊

進一步說明：

建議：

事件 ID：68020202（十六進位）

訊息： 515

「需要執行校準才能開啟修正。通道號碼為 <x>，量測為 <x>。」

嚴重性：資訊

進一步說明：指定的通道和量測沒有可套用的誤差修正項。

建議：執行或重新叫用校準

事件 ID：68020203（十六進位）

訊息： 516

「目前儀器狀態的重要參數與校準集的參數不匹配，因此，修正已關閉。儀器狀態的重要參數包括掃描類型、開始頻率、頻率跨距和點數。」

嚴重性：資訊

進一步說明：無

建議：您可以使用新設定重新校準，或重新變更為執行校準時所使用的原始設定。

事件 ID：68020204（十六進位）

訊息： 517

「內插已關閉，並且您已變更原始校準的激勵設定，因此修正已關閉。」

嚴重性：資訊

進一步說明：僅當使用原始激勵設定時，才能維持最準確的校準。

建議：如果可接受降低準確度，請將內插設定為「開啟」以允許變更激勵設定。

事件 ID：68020205（十六進位）

訊息： 518

「內插已關閉，並且您已將選取的修正設定為「開啟」。修正已還原為先前的激勵設定。」

嚴重性：資訊

進一步說明：無

建議：無

事件 ID：68020206（十六進位）

訊息： 519

「目前儀器狀態的激勵設定超過了原始校準的參數，因此修正已關閉。」

嚴重性：資訊

進一步說明：激勵設定以外的修正資料不存在。

建議：在增加點數並將內插設定為「開啟」的情況下執行寬頻校準，以將校準保持在盡可能廣泛的激勵頻率設定之上。

事件 ID：68020207（十六進位）

訊息： 520

「通道 <x>（量測 <x>）的校準類型已設定為「無」；請選取「校準」功能表或按下 [Cal] 硬鍵。」

嚴重性：資訊

進一步說明： 如果校準尚未存在或尚未選取校準類型，則無法繼續執行校準操作。如果找不到校準，將發生此錯誤。此外，如果嘗試以編程方式執行校準擷取之前未指定校準類型，也將發生此錯誤。

建議 若要尋找校準，請選取包含目前量測所需之校準的校準集。 或者先指定校準類型，然後再開始校準程序。

事件 ID：68020208（十六進位）

訊息： 521

「您設定的量測沒有對應的校準類型，因此修正已關閉或不受允許。」

嚴重性：資訊

進一步說明： 該通道的校準可能僅適用於某些 S 參數。 例如，無法將適用於 S11 的單連接埠套用至適用於 S22 的單連接埠校準。

建議：選取可套用至所有要選取之量測的校準類型，例如全 2 連接埠校準。

事件 ID：68020209（十六進位）

訊息： 522

「無法設定所選校準類型。」

嚴重性：資訊

進一步說明： 「請使用 SCPI 命令 ROUTe:PATH:DEFine:PORT <num>,<num> 進行全 2 連接埠類型的連接埠指派。」

建議：

事件 ID：6802020A（十六進位）

訊息： 523

「無法設定所選校準路徑，因為該路徑對目前量測無效。」

嚴重性：資訊

進一步說明： 「請使用 SCPI 命令 ROUTe:PATH:DEFine:PORT <num>,<num> 進行與目前量測相關聯的全 2 連接埠類型的連接埠指派。」

建議：

事件 ID：6,802,020B（十六進位）

訊息： 524

「來源功率校準已完成。」

嚴重性：資訊

進一步說明：

建議：

事件 ID：6802020C（十六進位）

訊息： 525

「您為一個或多個校準類別指定了超過 7 個標準。」

嚴重性：資訊

進一步說明：系統已將這些內容截斷為 7 個選項。

事件 ID：6802020D（十六進位）

訊息： 526

「沒有為此通道找到任何使用者校準。」

嚴重性：資訊

進一步說明： 如果校準尚未存在，則無法繼續執行校準操作。

建議： 若要尋找校準，可選取包含目前量測所需之校準的校準集。

事件 ID：6802020E（十六進位）

訊息： 527

「您不必為此校準類型擷取該標準。」

嚴重性：資訊

進一步說明：此錯誤可能是由於在校準程序期間以編程方式要求使用不需要的校準標準進行量測而導致的。

建議：檢查指定的校準類型或消除使用該標準進行量測的要求。

事件 ID：6802020F（十六進位）

訊息： 528

「無法設定電子校準系統。請檢查該模組是否已插入正確的接頭。」

嚴重性：資訊

進一步說明： 在執行 ECal 操作期間，無法建立與 ECal 模組的通訊。 在確認 ECal 模組存在之前，不會啟動校準。

建議：請確認 USB 纜線連接是否正確。先中斷連接再重新連接纜線，以確保分析儀能夠識別模組。

事件 ID：68020210（十六進位）

訊息： 529

「資料超出範圍：超過了設計限制」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020211（十六進位）

訊息： 530

「執行錯誤：無法開啟 ECal 模組記憶體備份檔案」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020212（十六進位）

訊息： 531

「執行錯誤：存取 ECal 模組記憶體備份檔案遭拒」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020213（十六進位）

訊息： 532

「執行錯誤：無法寫入 ECal 模組記憶體備份檔案」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020214（十六進位）

訊息： 533

「執行錯誤：無法從 ECal 模組記憶體備份檔案進行讀取」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020215（十六進位）

訊息： 534

「執行錯誤：陣列索引超出範圍」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020216（十六進位）

訊息： 535

「執行錯誤：陣列陣序不正確」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020217（十六進位）

訊息： 536

「執行錯誤：CPU」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020218（十六進位）

訊息： 537

「執行錯誤：無法清除模組」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020219（十六進位）

訊息： 538

「執行錯誤：無法寫入模組」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E802021A（十六進位）

訊息： 539

「執行錯誤：找不到項目」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E802021B（十六進位）

訊息： 540

「執行錯誤：命令無效，因為系統忙碌」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E802021C（十六進位）

訊息： 541

「電子校準： 無法定位 ECal 模組。請確保該模組已連接到必要的量測連接埠。」

嚴重性：錯誤

進一步說明： 在執行校準步驟期間，與 ECal 模組的 RF 連接不存在。 已嘗試進行 ECal 方向量測，但找不到訊號。

建議：透過為校準步驟指定的連接埠建立與 ECal 模組的 RF 連接。 ECal 模組通常需要至少 -18dBm 的功率位準以用於量測。如果您的量測需要比這更低的功率位準，請清除執行定位核取方塊以略過自動偵測步驟。

事件 ID：E802021D（十六進位）

訊息： 542

「執行錯誤：沒有空間可用於新校準，請刪除某個校準」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E802021E（十六進位）

訊息： 543

「執行錯誤：沒有更多空間」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E802021F（十六進位）

訊息： 544

「執行錯誤：其他陣列錯誤」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020220（十六進位）

訊息： 545

「執行錯誤：陣序不相等」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020221（十六進位）

訊息： 546

「執行錯誤：常數陣序太少」

嚴重性：錯誤

事件 ID：E8020222（十六進位）

訊息： 547

「執行錯誤：變化陣序太少」

嚴重性：錯誤

事件 ID：E8020223（十六進位）

訊息： 548

「執行錯誤：未知錯誤」

嚴重性：錯誤

事件 ID：E8020224（十六進位）

訊息： 549

「執行錯誤：ecaldrvr.dll 錯誤或模組號碼無效」

嚴重性：錯誤

事件 ID：E8020225（十六進位）

訊息： 550

「執行錯誤：來自 ecal 驅動程式的非預期錯誤代碼」

嚴重性：錯誤

事件 ID：E8020226（十六進位）

訊息： 551

「執行錯誤：非預期的內部驅動程式錯誤」

嚴重性：錯誤

事件 ID：E8020227（十六進位）

訊息： 552

「硬體錯誤：無法存取 ECal 介面模組」

嚴重性：錯誤

事件 ID：E8020228（十六進位）

訊息： 553

「硬體錯誤：無法釋放 LPT 連接埠，請重新啟動」

嚴重性：錯誤

事件 ID：E8020229（十六進位）

訊息： 554

「硬體錯誤：VNA 錯誤」

嚴重性：錯誤

事件 ID：E802022A（十六進位）

訊息： 555

「硬體錯誤：從 ECal 模組讀取的資料不足」

嚴重性：錯誤

事件 ID：E802022B（十六進位）

訊息： 556

「操作已被主機電腦中止」

嚴重性：錯誤

事件 ID：E802022C（十六進位）

訊息： 557

「操作已被使用者中止」

嚴重性：錯誤

事件 ID：E802022D（十六進位）

訊息： 558

「記憶體不足」

嚴重性：錯誤

事件 ID：E802022E（十六進位）

訊息： 559

「查詢已中斷：訊息已被放棄」

嚴重性：錯誤

事件 ID：E802022F（十六進位）

訊息： 560

「查詢未終止：程式訊息不完整」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020230（十六進位）

訊息： 561

「查詢未終止：程式訊息為空」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020231（十六進位）

訊息： 562

「佇列溢位」

嚴重性：錯誤

事件 ID：E8020232（十六進位）

訊息： 563

「設定衝突：需要其他標準」

嚴重性：錯誤

事件 ID：E8020233（十六進位）

訊息： 564

「設定衝突：無法執行配接器校準」

嚴重性：錯誤

事件 ID：E8020234（十六進位）

訊息： 565

「設定衝突：命令順序不正確」

嚴重性：錯誤

事件 ID：E8020235（十六進位）

訊息： 566

「設定衝突：校準已停止 - VNA 設定已變更」

嚴重性：錯誤

事件 ID：E8020236（十六進位）

訊息： 567

「設定衝突：校準未在進行中」

嚴重性：錯誤

事件 ID：E8020237（十六進位）

訊息： 568

「設定衝突：找不到指定的 GPIB 板」

嚴重性：錯誤

事件 ID：E8020238（十六進位）

訊息： 569

「設定衝突：找不到/無法載入 gpib32.dll」

嚴重性：錯誤

事件 ID：E8020239（十六進位）

訊息： 570

「設定衝突：找不到/無法載入 sicl32.dll」

嚴重性：錯誤

事件 ID：E802023A（十六進位）

訊息： 571

「設定衝突：無法初始化 VNA（位址不正確？）」

嚴重性：錯誤

事件 ID：E802023B（十六進位）

訊息： 572

「設定衝突：無法載入 LPT 連接埠驅動程式或 USB 驅動程式 DLL」

嚴重性：錯誤

事件 ID：E802023C（十六進位）

訊息： 573

「設定衝突：校準掃描模式無效。」

嚴重性：錯誤

事件 ID：E802023D（十六進位）

訊息： 574

「設定衝突：校準類型無效」

嚴重性：錯誤

事件 ID：E802023E（十六進位）

訊息： 575

「設定衝突：校準無效」

嚴重性：錯誤

事件 ID：E802023F（十六進位）

訊息： 576

「設定衝突：指定的 GPIB 板號無效」

嚴重性：錯誤

事件 ID：E8020240（十六進位）

訊息： 577

「設定衝突：指定的 GPIB 板類型無效」

嚴重性：錯誤

事件 ID：E8020241（十六進位）

訊息： 578

「設定衝突：模組狀態無效」

嚴重性：錯誤

事件 ID：E8020242（十六進位）

訊息： 579

「設定衝突：狀態無效」

嚴重性：錯誤

事件 ID：E8020243（十六進位）

訊息： 580

「設定衝突：LPT 連接埠必須介於 1 到 4 之間」

嚴重性：錯誤

事件 ID：E8020244（十六進位）

訊息： 581

「無法設定電子校準系統。請檢查該模組是否連接正確。」

嚴重性：錯誤

事件 ID：E8020245（十六進位）

訊息： 582

「設定衝突：指定的 LPT 連接埠不存在」

嚴重性：錯誤

事件 ID：E8020246（十六進位）

訊息： 583

「設定衝突：請使用頻域進行校準」

嚴重性：錯誤

事件 ID：E8020247（十六進位）

訊息： 584

「設定衝突：請使用步進掃描類型進行校準。」

嚴重性：錯誤

事件 ID：E8020248（十六進位）

訊息： 585

「設定衝突：VNA 位址必須介於 0 到 30 之間」

嚴重性：錯誤

事件 ID：E8020249（十六進位）

訊息： 586

「設定衝突：LPT 連接埠驅動程式或 USB 驅動程式 DLL 不正確」

嚴重性：錯誤

事件 ID：E802024A（十六進位）

訊息： 587

「語法錯誤：ECAL:DELAY 命令必須包含 2 個數字」

嚴重性：錯誤

事件 ID：E802024B（十六進位）

訊息： 588

「語法錯誤：語法不正確」

嚴重性：錯誤

事件 ID：E802024C（十六進位）

訊息： 589

「語法錯誤：未知命令」

嚴重性：錯誤

事件 ID：E802024D（十六進位）

訊息： 590

「RF 路徑中的模組連接埠不正確」

嚴重性：錯誤

事件 ID：E802024E（十六進位）

訊息： 591

「在模組中找不到使用者特性化」

嚴重性：錯誤

事件 ID：E802024F（十六進位）

訊息： 592

嚴重性：資訊

「沒有為目前量測的通道和來源連接埠找到任何來源功率校準。」

進一步說明： 您已嘗試開啟來源功率校準，但來源功率校準資料不存在。

建議：執行來源功率校準

事件 ID：68020250（十六進位）

訊息： 593

嚴重性：資訊

「未執行來源功率校準掃描，因此，沒有對目前量測的通道和來源連接埠進行修正。」

進一步說明：您已嘗試開啟來源功率校準，但來源校準資料不完整。

建議：執行完整的來源功率校準

事件 ID：68020251（十六進位）

訊息： 594

嚴重性：資訊

「無法將新軌跡新增至用於檢視來源功率校準掃描的作用中視窗，因為這樣會超過軌跡/視窗數目限制。請先從該視窗中移除軌跡，然後再繼續進行來源功率校準。」

進一步說明：來源功率校準嘗試將資料軌跡新增至作用中視窗。該作用中視窗已包含四條軌跡。

建議：使作用中視窗包含少於四條軌跡。

事件 ID：68020252（十六進位）

訊息： 595

嚴重性：資訊

「無法新增量測以用於執行來源功率校準掃描，因為已達到量測數目限制。請先移除量測，然後再繼續進行來源功率校準。」

進一步說明：來源功率校準嘗試新增量測。VNA 已達到最大量測數目。

建議：刪除某個量測。

事件 ID：68020253（十六進位）

訊息： 596

嚴重性：資訊

「與通道 %2 上連接埠 %1 的來源功率校準相關聯的校準功率值，在校準開啟的情況下已發生變更。校準未關閉，但功率值可能不再代表該校準。」

進一步說明：來源功率校準準確度有問題。

建議：如果需要較高的準確度，請執行其他來源功率校準。

事件 ID：68020254（十六進位）

訊息： 597

嚴重性：資訊

- 從功率表驅動程式傳遞的有關來源功率校準的訊息。 -

進一步說明：此錯誤由功率表驅動程式產生並透過 VNA 傳遞。

事件 ID：68020255（十六進位）

訊息： 598

「在擷取滑動負載標準期間，未正確移動滑動負載以執行圓擬合。 該標準的原始阻抗用於確定一個或多個點的方向性。」

嚴重性：資訊

進一步說明： 若要準確特性化標準，必須充分移動滑動負載以確保圍繞複數圓或史密斯圖採集足夠的樣本。 取樣不足將導致結果不準確。

建議： 若要在使用滑動負載時獲得最佳結果，請確保使用多個滑動位置，以覆蓋從插槽正面到背面的整個移動範圍。

事件 ID：68020256（十六進位）

訊息： 599

「此功能需要一個未使用的通道，但找不到任何未使用的通道。請釋放一個通道，然後再試一次。」

嚴重性：資訊

進一步說明： 您已嘗試檢視某個校準集內的項目。 但是，校準集檢視器要求在目前未使用的通道中顯示結果。 所有通道目前都在使用中。 檢視無法顯示所要求的項目。

建議： 您必須至少刪除一個目前正在使用的通道。

事件 ID：68020257（十六進位）

訊息： 600

「不允許對原始校準進行內插，因為原始校準是使用區段掃描執行的。 修正已關閉。」

嚴重性：資訊

事件 ID：68020258（十六進位）

訊息： 601

「校準偏好設定已儲存。可從「校準」功能表的「校準偏好設定」下拉式功能表中變更校準偏好設定。」

嚴重性：資訊

進一步說明： 請參閱「儲存偏好設定」

事件 ID：68020259（十六進位）

訊息： 608

「未設定校準類型。」

嚴重性：錯誤

進一步說明：如果校準尚未存在或尚未選取適當的校準類型，則無法繼續執行校準操作。

建議：如果找不到校準，將發生此錯誤。 若要尋找校準，可選取包含目前量測所需之校準的校準集。 此外，如果嘗試以編程方式執行校準擷取之前未指定校準類型，也將發生此錯誤。 請先指定校準類型，然後再開始校準程序。

事件 ID：E8020260（十六進位）

訊息： 609

「未實作要求的校準功能。」

進一步說明： 指定的校準類型可以是許多選項之一。 例如，回應校準需要單一標準，單連接埠校準需要 3 個標準，而 2 連接埠校準需要最多 12 個標準。

建議：請確保僅量測指定校準類型所需的標準。

事件 ID：E8020261（十六進位）

訊息： 610

「要求的校準類別擷取對所選校準類型無效。請選取其他擷取或校準類型。」

事件 ID：E8020262（十六進位）

訊息： 611

「找不到所選校準類型所需的校準標準資料。」

嚴重性：錯誤

進一步說明： 嘗試從原始量測緩衝區擷取指定的標準失敗。 該緩衝區應包含校準程序期間儲存的校準標準的原始量測。

建議： 請確保目前的校準類型需要所要求的標準。 並非所有校準類型都需要所有標準。

事件 ID：E8020263（十六進位）

訊息： 612

「 找不到所選校準類型所需的誤差項資料。」

嚴重性：錯誤

進一步說明：嘗試從誤差修正緩衝區擷取指定的誤差項失敗。 該緩衝區應包含目前校準的誤差修正陣列。

建議： 請確保目前的校準類型需要所要求的誤差項。 並非所有校準類型都需要所有誤差項。

事件 ID：E8020264（十六進位）

訊息： 613

找不到校準資料集。

嚴重性：錯誤

進一步說明：嘗試存取校準集失敗。 這可能指示校準集已遭刪除或損毀。

建議： 請再試一次或選取其他校準集。 如果該校準集顯示在校準集清單中，則可能需要將其刪除。

事件 ID：E8020265（十六進位）

訊息： 614

「指定的量測不具有對可信度檢查有效的校準。請選取其他量測，或重新叫用或執行其他校準類型。」

嚴重性：錯誤

進一步說明： 量測選項已遭阻止，以便校準不會關閉。 並非所有校準類型都支援所有量測。 例如，S11 上的單連接埠校準無法用於校準 S12 量測。 當選取的量測不具有可套用的校準時，將顯示一條資訊訊息，並且校準會關閉。

建議： 使用全 2 連接埠校準，以便與任何 S 參數都相容。

事件 ID：E8020266（十六進位）

訊息： 615

「 已建立新校準集。」

嚴重性：資訊訊息。

進一步說明：新建立的校準集將自動命名並加上時間戳記。 如果校準程序此時剛開始，則在校準成功完成之前，不會將校準集儲存至記憶體。 如果校準已取消或未成功完成，新的校準集會遭到刪除。

建議：資訊

事件 ID： 68020267

訊息： 617

校準集檔案<x> 似乎已損毀且無法移除。請結束應用程式並移除該檔案，然後重新啟動。

嚴重性：錯誤

建議： 校準集檔案儲存在應用程式主目錄 C:/Program Files/Keysight/Network Analyzer/PNACalSets.dat 中。 請移除此檔案，然後重新啟動應用程式。

事件 ID：E8020269（十六進位）

訊息： 634

「校準集檔案<x> 載入失敗。」

嚴重性：錯誤

進一步說明：校準集檔案包含一系列校準集。 該檔案位於硬碟上。

建議： 嘗試重新啟動應用程式。 如果故障仍然存在，您可能必須刪除校準集檔案資料並重新啟動應用程式。該校準集檔案儲存在應用程式主目錄C:/Program Files/Keysight/Network Analyzer/PNACalSets.dat 中。 請移除此檔案，然後重新啟動應用程式。

事件 ID：E802027A（十六進位）

訊息： 635

「校準集檔案<x> 儲存失敗。」

嚴重性：錯誤

進一步說明：檔案操作偵測到錯誤。 儲存操作已中止。

建議： 重試。

事件 ID：E802027B（十六進位）

訊息： 636

「已刪除校準集。」

嚴重性：資訊

進一步說明：其中一個校準集已成功從可用校準集的集合中刪除。 此錯誤可能是由於使用者要求或故意操作而導致的。

建議：無

事件 ID：6802027C（十六進位）

訊息： 637

「校準集檔案<x> 的版本與目前儀器不相容。」

嚴重性：錯誤

進一步說明：版本設定錯誤會導致校準集無法使用。 此錯誤可能是由於儀器韌體升級而導致的。

建議： 如果版本設定錯誤因韌體升級而導致的，您必須重新安裝舊版韌體以重新使用該校準集檔案。 或者，您也可以使用目前版本的韌體來重新建立校準集。

校準集檔案儲存在應用程式主目錄 C:/Program Files/Keysight/Network Analyzer/PNACalSets.dat 中。 請移除此檔案，然後重新啟動應用程式。

事件 ID：E802027D（十六進位）

訊息： 638

「找到不相容的校準集：已載入 <x> 個已儲存的校準集，共 <y> 個。」

嚴重性：錯誤

進一步說明：在儲存於校準集檔案中的部分校準集上找到了錯誤。 這些錯誤可能是由版本設定問題而導致的，版本設定問題可能會損毀多個校準集金鑰。

建議： 使用校準集檢視器查看校準集檔案的內容。 刪除已損毀的檔案。

事件 ID：6802027E（十六進位）

訊息： 639

「找不到校準集檔案<x>。 已建立新的檔案。」

嚴重性：資訊

進一步說明：校準集檔案應儲存在硬碟上。 啟動應用程式時，分析儀會執行搜尋並載入檔案（如果可以找到該檔案）。如果找不到此檔案，分析儀會建立新檔案並顯示此訊息。

建議： 無

事件 ID：6802027F（十六進位）

訊息： 640

「指定的校準集目前正在使用中。」

嚴重性：錯誤

進一步說明：這可能指示多個正在嘗試執行校準工作的校準集使用者之間發生衝突。

建議： 儲存儀器狀態。預設分析儀並重新叫用儀器狀態。 這樣可能會中止任何正在進行的程序。

事件 ID：E8020280（十六進位）

訊息： 641

「指定的校準集尚未開啟。」

嚴重性：錯誤

進一步說明：可能有多個使用者正在嘗試存取該校準集。

建議： 使多個校準集使用者登出，以便只有一個使用者可以存取該校準集。

事件 ID：E8020281（十六進位）

訊息： 642

「已達到校準集數目上限。請先刪除舊的或未使用的校準集，然後再嘗試建立新的校準集。」

嚴重性：錯誤

建議： 您也可以刪除校準集資料檔案。

該校準集檔案儲存在應用程式主目錄 C:/Program Files/Keysight/Network_Analyzer/PNACalSets.dat 中。 請移除此檔案，然後重新啟動應用程式。

事件 ID：E8020282（十六進位）

訊息： 643

找不到要求的功率損耗表區段。

嚴重性：錯誤

事件 ID：E8020283（十六進位）

訊息： 644

「需要執行有效的校準才能開啟修正。」

嚴重性：錯誤

進一步說明：這通常指示校準程序尚未執行至完成，或指示所選量測沒有從目前選取的校準集內獲取有效的校準。

建議：若要尋找校準，可選取包含目前量測所需之校準的校準集。 如果嘗試以編程方式執行校準擷取之前未指定校準類型，將發生此錯誤。 請先指定校準類型，然後再開始校準程序。

事件 ID：E8020284（十六進位）

訊息： 645

<x> 的校準資料不相容，且尚未還原。請重新校準。」

嚴重性：警告

進一步說明：無

建議：無

事件 ID：A8020285（十六進位）

訊息： 646

「校準集未載入，版本太新。」

嚴重性：錯誤

進一步說明：舊版韌體正在嘗試以新的校準集版本執行。 版本不相容。

建議： 可移除該校準集。如果要頻繁地在各個韌體版本之間移轉且要避免此錯誤，您也可以刪除校準集資料檔案。 該校準集檔案儲存在應用程式主目錄C:/Program Files/Keysight/Network Analyzer/PNACalSets.dat 中。 請移除此檔案，然後重新啟動應用程式。

事件 ID：E8020286（十六進位）

訊息： 647

「找不到自訂校準類型。」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E8020287（十六進位）

訊息： 648

「自訂修正演算法遵從用戶端的指示進行內插。」

嚴重性：資訊

事件 ID：68020288（十六進位）

訊息： 649

「自訂校準 dll 引發了異常。」

嚴重性：錯誤

事件 ID：E8020289（十六進位）

訊息： 650

「無法載入 ecal.dll 程式庫」

嚴重性：錯誤

事件 ID：E802028A（十六進位）

訊息： 656

「指定的引數不是有效的校準類型。」

嚴重性：錯誤

事件 ID：E8020290（十六進位）

訊息： 657

「函數找到了現有的內插資料」

嚴重性：資訊

事件 ID：68020291（十六進位）

訊息： 658

「函數計算了新的內插值。」

嚴重性：資訊

事件 ID：68020292（十六進位）

訊息： 659

「來源功率量測失敗。」

嚴重性：錯誤

建議： 請檢查 GPIB、功率表設定和感應器連接。

事件 ID：E8020293（十六進位）

訊息： 660

「找到重複的工作階段。 請關閉工作階段並重試。」

嚴重性：錯誤

事件 ID：E8020294（十六進位）

訊息： 661

「工作階段不存在。 請開啟工作階段並再試一次。」

嚴重性：錯誤

進一步說明：

事件 ID：E8020295（十六進位）

訊息： 662

「嘗試啟動自訂校準失敗。」

嚴重性：錯誤

進一步說明：

事件 ID：E8020296（十六進位）

訊息： 663

「要求量測某個校準標準失敗。」

嚴重性：錯誤

進一步說明：請確保您要求量測的標準是為此校準定義的。

事件 ID：E8020297（十六進位）

訊息： 664

「由於選取了電子校準套件，因此，無法變更機械校準套件參數。」

嚴重性：錯誤

進一步說明：

事件 ID：E8020298（十六進位）

訊息： 665

「作用中通道的頻率低於 ECal 模組出廠特性化的最小頻率，或高於其最大頻率。」

建議： 變更通道頻率，或選取其他 ECal 模組。

嚴重性：錯誤

事件 ID：E8020299（十六進位）

訊息： 666

「選擇用於特性化 ECal 模組連接埠 %1 的校準集不包含適用於 VNA 連接埠 %2 的校準。」

嚴重性：錯誤

建議： 返回以選取其他校準集或執行其他校準。

事件 ID：E802029A（十六進位）

訊息： 667

「ECal 模組剩餘的記憶體最多只能儲存使用者特性化 %2 中的 %1 個點。」

嚴重性：錯誤

建議： 減少點數，或選擇覆寫其他使用者特性化。

事件 ID：E802029B（十六進位）

訊息： 668

輸入值非單調。無法內插。

嚴重性：錯誤

事件 ID：E802029C（十六進位）

訊息： 669

內插目標超出範圍。無法內插。

嚴重性：錯誤

事件 ID：E802029D（十六進位）

訊息： 670

引導式校準錯誤： <>

嚴重性：錯誤

事件 ID：E802029E（十六進位）

訊息： 671

必須初始化對引導式校準介面的第一次叫用。

嚴重性：錯誤

事件 ID：E802029F（十六進位）

訊息： 672

無法識別選取的直通校準方法。

嚴重性：錯誤

事件 ID：E80202A0（十六進位）

訊息： 673

無法產生誤差項。

嚴重性：錯誤

事件 ID：E80202A1（十六進位）

訊息： 674

必須在作用中通道上執行引導式校準

嚴重性：錯誤

事件 ID：E80202A2（十六進位）

訊息： 675

成功叫用產生步驟之前，您無法開始使用校準步驟。

嚴重性：錯誤

事件 ID：E80202A3（十六進位）

訊息： 676

指定的步驟編號超出範圍。步驟編號應介於 1 到步驟數目之間。 0 不是有效的步驟編號。

嚴重性：錯誤

事件 ID：E80202A4（十六進位）

訊息： 677

為通道<n> 選取了校準集，但沒有還原激勵。

嚴重性：資訊

事件 ID：680202A5（十六進位）

訊息： 678

為通道<n> 選取了校準集，並且還原了激勵。

嚴重性：資訊

事件 ID：680202A6（十六進位）

訊息： 679

選取的校準激勵無法套用至通道。

嚴重性：資訊

事件 ID：680202A7（十六進位）

訊息： 680

您嘗試量測功率的頻率超出為指定功率感應器定義的頻率範圍。 請選取其他感應器或調整此感應器的範圍。

嚴重性：錯誤

事件 ID：E80202A8（十六進位）

訊息： 681

指定的頻率超出目前為功率表感應器定義的頻率範圍。

嚴重性：錯誤

事件 ID：E80202A9（十六進位）

訊息： 682

您需要擷取其他校準標準，以便在目前量測的整個頻率範圍內進行校準。

嚴重性：資訊

事件 ID：680202AA（十六進位）

訊息： 683

VNA 無法轉換校準套件以供非引導式校準使用。 建議的動作是還原校準套件預設值。

嚴重性：錯誤

事件 ID：E80202AB（十六進位）

訊息： 684

VNA 無法轉換校準套件以供非引導式校準使用。 校準套件預設值已還原。

嚴重性：錯誤

事件 ID：E80202AC（十六進位）

訊息： 685

功率表由已在進行的來源功率校準擷取加以保留。

嚴重性：錯誤

事件 ID：E80202AD（十六進位）

訊息： 686

尚未針對指定的通道和來源連接埠執行或上傳來源功率校準。

嚴重性：錯誤

事件 ID：E80202AE（十六進位）

訊息： 687

指定通道和來源連接埠的來源功率校準資料陣列大小與其關聯的激勵點數不相符。

嚴重性：錯誤

事件 ID：E80202AF（十六進位）

訊息： 688

通道 <n> 上連接埠 <n> 的來源功率校準已關閉，因為修正陣列不再存在。

嚴重性：錯誤

事件 ID：E80202B0（十六進位）

訊息： 689

此命令只能用於使用指定校準負載連接埠建立的量測。

嚴重性：錯誤

事件 ID：E80202B1（十六進位）

訊息： 690

內插已關閉，並且您已變更原始校準的激勵設定，因此修正已關閉。

嚴重性：錯誤

事件 ID：E80202B2（十六進位）

訊息： 691

目前儀器狀態的激勵設定超過了原始校準的參數，因此修正已關閉。

嚴重性：錯誤

事件 ID：E80202B3（十六進位）

訊息： 692

固定裝置：無法讀取要求的 S2P 檔案。 可能發生了格式設定問題。

嚴重性：錯誤

事件 ID：E80202B4（十六進位）

訊息： 693

固定裝置：無法開啟要求的 S2P 檔案。

嚴重性：錯誤

事件 ID：E80202B5（十六進位）

訊息： 694

固定裝置：無法內插要求的 S2P 檔案。 這通常是因為檔案中的頻率範圍是目前通道頻率範圍的子集。

嚴重性：錯誤

事件 ID：E80202B6（十六進位）

訊息： 695

校準暫存器只能供一個通道使用：也就是校準暫存器的名稱所傳達的通道。 該名稱無法變更。

嚴重性：錯誤

進一步說明：請參閱校準暫存器

事件 ID：E80202B7（十六進位）

訊息： 696

固定裝置：無法與回應校準一起啟用，並且已關閉。

嚴重性：錯誤

事件 ID：E80202B8（十六進位）

訊息： 697

無法針對此量測執行選取的校準。

嚴重性：錯誤

事件 ID：E80202B9（十六進位）

訊息： 698

擬合：嘗試進行擬合後，應先叫用 AddConnector，然後再叫用 RemoveAllConnectors()。

嚴重性：錯誤

事件 ID：E80202BA（十六進位）

訊息： 699

已在系統正確初始化之前嘗試擷取校準資料。

嚴重性：錯誤

事件 ID：E80202BB（十六進位）

訊息： 700

將 IGuidedCalibration 用於多連接埠校準類型。

嚴重性：錯誤

事件 ID：E80202BC（十六進位）

訊息： 701

引導式校準需要的直通量測路徑數目至少等於校準連接埠的數目減 1。

嚴重性：錯誤

事件 ID：E80202BD（十六進位）

訊息： 702

校準未指定為包含已指定的直通路徑所含有的一個連接埠。

嚴重性：錯誤

事件 ID：E80202BE（十六進位）

訊息： 703

在指定的直通路徑集內找不到一個或多個要校準的連接埠。

嚴重性：錯誤

事件 ID：E80202BF（十六進位）

硬體錯誤

訊息： 770

輸入功率太高。來源功率已關閉。

嚴重性：警告：

事件 ID：A8030302（十六進位）

訊息： 771

來源功率已還原。

嚴重性：資訊

事件 ID：68030303（十六進位）

訊息： 772

「spampnp.sys 驅動程式無法運作。請檢查系統硬體。! 資料將進行模擬。 !」

嚴重性：錯誤

進一步說明：網路分析儀應用程式找不到 DSP 板。硬體或驅動程式可能出現故障。嘗試在工作站上執行網路分析儀時，通常也會發生此錯誤。

事件 ID：E8030304（十六進位）

訊息： 773

「儀器序列匯流排無法運作。」

嚴重性：錯誤

進一步說明：儀器 EEPROM 包含的值似乎全部為一，或全部為零。序列匯流排硬體故障導致無法讀取 EEPROM。

事件 ID：E8030305（十六進位）

訊息： 784

來源 <n> 的位準不正確，超過 <n>。

嚴重性：錯誤

進一步說明：VNA 無法將連接埠 <n> 的功率設定為所需位準

訊息： 848

「相位鎖定遺失」

嚴重性：錯誤

進一步說明：儀器來源無法正確鎖定。此錯誤可能是由於硬體損壞、校準不佳或 EEPROM 值不正確所導致的。

建議：執行來源校準。按一下「系統」>「服務」>「調整」>「來源校準」

事件 ID：E8030350（十六進位）

訊息： 849

相位鎖定已還原。

嚴重性：成功

事件 ID：0x28030351（十六進位）

訊息： 850

「未知硬體錯誤。」

嚴重性：錯誤

進一步說明：硬體故障導致無法與 DSP 通訊。

事件 ID：E8030352（十六進位）

訊息： 851

DSP 通訊中斷。

嚴重性：錯誤

事件 ID：E8030353（十六進位）

訊息： 852

RF 功率已關閉。

嚴重性：錯誤

事件 ID：E8030354（十六進位）

訊息： 853

RF 功率已開啟。

嚴重性：成功

事件 ID：28030355（十六進位）

訊息： 854

硬體正常。

嚴重性：成功

事件 ID：28030356（十六進位）

訊息： 855

「來源位準不正確。」

嚴重性：錯誤

進一步說明：來源無法正確地將位準調整到所要求的功率。指示的功率可能不正確。

建議：嘗試其他功率位準。如果問題仍然存在，請重新校準來源。

事件 ID：E8030357（十六進位）

訊息： 856

來源位準已調整。

嚴重性：成功

事件 ID：28030358（十六進位）

訊息： 857

輸入已超載。

嚴重性：錯誤

事件 ID：E8030359（十六進位）

訊息： 858

輸入不再超載。

嚴重性：成功

事件 ID：2,803,035A（十六進位）

訊息： 859

「Yig 校準失敗。」

嚴重性：錯誤

進一步說明：YIG 震盪器調諧的內部自我校準失敗。

事件 ID：E803035B（十六進位）

訊息： 860

Yig 已校準。

嚴重性：成功

事件 ID：2803035C（十六進位）

訊息： 861

「類比斜波校準失敗。」

嚴重性：錯誤

進一步說明：內部類比掃描斜波校準已失敗。

事件 ID：E803035D（十六進位）

訊息： 862

類比斜波已校準。

嚴重性：成功

事件 ID：2803035E（十六進位）

訊息： 863

來源溫度較高。

嚴重性：錯誤

事件 ID：E803035F（十六進位）

訊息： 864

來源溫度正常。

嚴重性：成功

事件 ID：28030360（十六進位）

訊息： 865

「EEPROM 寫入失敗。」

嚴重性：錯誤

進一步說明：嘗試將校準資料儲存至 EEPROM 失敗。可能發生了硬體故障。

事件 ID：E8030361（十六進位）

訊息： 866

EEPROM 寫入成功。

嚴重性：成功

事件 ID：28030362（十六進位）

訊息： 867

在連接埠設定為唯讀的情況下嘗試了 I/O 寫入。

嚴重性：錯誤

進一步說明：在連接埠設定為輸入/唯讀的情況下嘗試寫入到 I/O 資料連接埠。

建議：先將資料連接埠設定為寫入/輸出，然後再嘗試寫入到連接埠。

事件 ID：E8030363（十六進位）

訊息： 868

「已嘗試從唯寫連接埠執行 I/O 讀取。

嚴重性：錯誤

進一步說明：在連接埠設定為輸出/唯寫的情況下嘗試從 I/O 資料連接埠讀取。

建議：先將資料連接埠設定為讀取/輸入，然後再嘗試從連接埠讀取。

事件 ID：E8030364（十六進位）

訊息： 869

硬體元件的識別碼無效。

嚴重性：錯誤

事件 ID：E8030365（十六進位）

訊息： 870

增益位準設定無效。

嚴重性：錯誤

事件 ID：E8030366（十六進位）

訊息： 871

裝置驅動程式無法配置足夠的記憶體。請嘗試重新啟動。

嚴重性：錯誤

事件 ID：E8030367（十六進位）

訊息： 872

DSP 錯誤。 請與 Keysight 支援聯絡。 技術資訊：DSP 類型 1

嚴重性：錯誤

事件 ID：E8030368（十六進位）

訊息： 873

DSP 錯誤。 請與 Keysight 支援聯絡。 技術資訊：DSP 類型 2

嚴重性：錯誤

事件 ID：E8030369（十六進位）

訊息： 874

DSP 錯誤。 請與 Keysight 支援聯絡。 技術資訊：DSP 類型 3

嚴重性：錯誤

事件 ID：E803036A（十六進位）

訊息： 875

DSP 錯誤。 請與 Keysight 支援聯絡。 技術資訊：DSP 類型 4

嚴重性：錯誤

事件 ID：E803036B（十六進位）

訊息： 876

DSP 錯誤。 請與 Keysight 支援聯絡。 技術資訊：DSP 類型 5

嚴重性：錯誤

事件 ID：E803036C（十六進位）

訊息： 910

韌體未將觸發連接引數識別為有效引數。

嚴重性：錯誤

事件 ID：0xE803038E（十六進位）

訊息： 911

指定的觸發連接不支援此觸發行為

嚴重性：錯誤

事件 ID：E803038F（十六進位）

訊息： 912

韌體未將指定的觸發行為識別為有效行為。

嚴重性：錯誤

事件 ID：E8030390（十六進位）

訊息： 913

指定的觸發連接實際上不存在於此網路分析儀中

嚴重性：錯誤

事件 ID：E8030391（十六進位）

訊息： 914

無法設定「做好準備之前接受觸發」，因為此硬體組態不支援邊緣觸發。

嚴重性：錯誤

事件 ID：E8030392（十六進位）

訊息： 915

無法設定「啟用觸發輸出」，因為此硬體組態不支援 BNC2。

嚴重性：錯誤

事件 ID：E8030393（十六進位）

訊息： 916

超過了最大觸發延遲。

嚴重性：錯誤

事件 ID：E8030394（十六進位）

訊息： 917

超過了最小觸發延遲。

嚴重性：錯誤

事件 ID：E8030395（十六進位）

量測錯誤

訊息： 1024

如果要顯示或使用記憶體軌跡，您必須先將資料軌跡儲存至記憶體。

嚴重性：警告：

事件 ID：A8040400（十六進位）

訊息： 1025

「量測無法正常關閉。應用程式處於損毀狀態，應先關閉再重新啟動該應用程式。」

嚴重性：錯誤

進一步說明：當 VNA 應用程式損毀時，將顯示此訊息。如果持續收到此錯誤，請致電客戶服務

事件 ID：E8040401（十六進位）

訊息： 1026

量測無法正常關閉。 更新執行緒無法正常結束。

嚴重性：警告：

事件 ID：A8040402（十六進位）

訊息： 1027

「具有 CW 時間掃描或功率掃描的群組延遲格式產生的資料無效。」

嚴重性：警告

進一步說明：群組延遲格式與單一頻率掃描不相容。產生的資料無效。

建議：忽略該資料或選擇其他格式或掃描類型。

事件 ID：A8040403（十六進位）

訊息： 1028

嚴重性：資訊

"MSG_LIMIT_FAILED"

進一步說明： 限制線測試未通過。

事件 ID：68040404（十六進位）

訊息： 1029

嚴重性：資訊

"MSG_LIMIT_PASSED"

進一步說明： 限制線測試已通過。

事件 ID：68040405（十六進位）

訊息： 1030

「超過了允許的量測數目上限。」

嚴重性：警告

進一步說明： 若要暸解有關量測上限的資訊，請參閱 VNA 上的軌跡、通道和視窗。

事件 ID：A8040406（十六進位）

訊息： 1031

「網路分析儀內部錯誤。AddNewMeasurement 發生非預期錯誤。」

嚴重性：警告

進一步說明： 如果持續收到此訊息，請與產品支援聯絡。

事件 ID：A8040407（十六進位）

訊息： 1032

「找不到任何量測，因此，無法執行選取的操作。操作未完成。」

嚴重性：警告

進一步說明：無

建議：先建立量測，再執行此操作。

事件 ID：A8040408（十六進位）

訊息： 1033

Markers All Off 命令失敗。

嚴重性：警告：

事件 ID：A8040409（十六進位）

訊息： 1034

「尚未針對選取的軌跡儲存記憶體軌跡。請先儲存記憶體軌跡，再嘗試執行軌跡數學運算操作。」

嚴重性：警告

進一步說明： 嘗試執行軌跡數學運算時，必須具有記憶體軌跡。

事件 ID：A804040A（十六進位）

訊息： 1035

"MSG_SET_AVERAGE_COMPLETE"

嚴重性：資訊

進一步說明： 有關 COM 編程的資訊。已達到平均因數。

事件 ID：6,804,040B（十六進位）

訊息： 1036

"MSG_CLEAR_AVERAGE_COMPLETE"

進一步說明： 有關 COM 編程的資訊。尚未達到平均因數。

事件 ID：6804040C（十六進位）

訊息： 1037

「時域轉換至少需要 3 個輸入點。轉換已停用。」

嚴重性：資訊

進一步說明：無

建議：增加點數。

事件 ID：6804040D（十六進位）

訊息： 1038

由於需要標量格式，因此平滑已停用。

嚴重性：資訊

事件 ID：6804040E（十六進位）

訊息： 1039

無法將此儀器狀態檔案中的接收器功率校準重新叫用至此韌體版本。

嚴重性：警告：

事件 ID：A804040F（十六進位）

訊息： 1047

無法實現目標功率。

嚴重性：錯誤

進一步說明：這指示 VNA 在校準的直通步驟期間找不到足夠高的來源功率，從而無法將連接埠 2 量測的雜訊功率提高至比雜訊底層高 6 dB。

訊息： 1104

「超過了量測數目限制。」

嚴重性：錯誤

進一步說明：如需量測限制的相關資訊，請參閱 VNA 上的軌跡、通道和視窗 。

事件 ID：E8040450（十六進位）

訊息： 1105

「參數無效。」

嚴重性：錯誤

進一步說明：以編程方式輸入的量測參數無效。

事件 ID：E8040451（十六進位）

訊息： 1106

「找不到量測。」

嚴重性：錯誤

進一步說明：此錯誤可能由以下任何原因導致：

嘗試校準，但已達到最大量測數。

嘗試執行可信度檢查，但不存在任何量測。

嘗試透過 COM 建立、啟動或更改量測，但已從前面板刪除了該量測。

嘗試透過編程來使用某個軌跡名稱，但該軌跡名稱不是唯一的。

事件 ID：E8040452（十六進位）

訊息： 1107

「沒有有效的記憶體軌跡。」

嚴重性：錯誤

進一步說明：嘗試執行軌跡數學運算時，必須具有記憶體軌跡。

建議：儲存記憶體軌跡。

事件 ID：E8040453（十六進位）

訊息： 1108

「找不到參考標記。」

嚴重性：錯誤

進一步說明：已嘗試建立差量標記，但沒有先建立參考標記（僅限 COM）。

事件 ID：E8040454（十六進位）

訊息： 1109

「資料和記憶體軌跡不再相容。軌跡數學運算已關閉。」

嚴重性：錯誤

進一步說明： 警告 - 在執行軌跡數學運算時，通道設定已變更。

建議：儲存其他記憶體軌跡並重新開啟軌跡數學運算。

事件 ID：A8040455（十六進位）

訊息： 1110

「資料和記憶體軌跡不相容。若要執行有效的軌跡數學運算操作，記憶體和資料軌跡必須具有相似的量測條件。」

嚴重性：錯誤

進一步說明： 已嘗試執行軌跡數學運算，但不存在相容的資料和記憶體軌跡。

建議：儲存其他記憶體軌跡。

事件 ID：E8040456（十六進位）

訊息： 1111

「找不到標記頻寬。」

嚴重性：錯誤

進一步說明： 找不到符合指定頻寬條件的軌跡部分。

事件 ID：E8040457（十六進位）

訊息： 1112

「找不到峰值。」

嚴重性：錯誤

進一步說明：找不到符合峰值條件的軌跡部分。

建議：查看標記峰值條件。

事件 ID：E8040458（十六進位）

訊息： 1113

「找不到目標搜尋值。」

嚴重性：錯誤

進一步說明：找不到符合搜尋值的內插資料點。

事件 ID：E8040459（十六進位）

訊息： 1114

「反射量測（例如 S11）必須提供輔助連接埠，以消除多連接埠儀器上的 2 連接埠量測。」

嚴重性：錯誤

進一步說明：

事件 ID：E804045A（十六進位）

訊息： 1115

「由於量測類型或來源連接埠已變更，因此，接收器功率校準已關閉，並且該校準不再有效。」

嚴重性：警告

進一步說明：

事件 ID：A804045B（十六進位）

訊息： 1116

「接收器功率校準需要作用中量測具有無比例功率。」

嚴重性：警告

進一步說明：

事件 ID：A804045C（十六進位）

訊息： 1117

「目前沒有任何來源功率校準與作用中量測的通道和來源連接埠相關聯。 執行接收器功率校準之前，應先執行或重新叫用來源功率校準。」

嚴重性：警告

進一步說明：

事件 ID：A804045D（十六進位）

訊息： 1118

「所嘗試的操作只能對標準量測類型執行。」

嚴重性：錯誤

進一步說明：

事件 ID：E804045E（十六進位）

訊息： 1119

「自訂量測無法載入，因為它與網路分析儀硬體不相容。」

嚴重性：錯誤

進一步說明：

建議：

事件 ID：E804045F（十六進位）

訊息： 1120

「自訂量測無法載入，因為它與網路分析儀軟體不相容。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040460（十六進位）

訊息： 1121

「自訂量測載入操作失敗，原因未指定。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040461（十六進位）

訊息： 1122

「自訂量測資料處理已產生未經處理的異常，因此將被終止。 VNA 軟體可能處於不穩定狀態，建議先關閉再重新啟動 VNA 軟體。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040462（十六進位）

訊息： 1123

「所嘗試的操作只能對自訂量測類型執行。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040463（十六進位）

訊息： 1124

「要求的自訂量測不可用。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040464（十六進位）

訊息： 1125

「找不到要求的自訂演算法。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040465（十六進位）

訊息： 1126

「無法開啟正規化，因為量測不具有有效的除數緩衝區。」

嚴重性：錯誤

進一步說明：

事件 ID：E8040466（十六進位）

訊息： 1127

「無法提供量測要求的原始資料。」

嚴重性：警告

進一步說明：

事件 ID：A8040467（十六進位）

訊息： 1128

「選取的掃描類型不允許轉換和閘限。轉換和閘限已停用。 」

嚴重性：錯誤

進一步說明：

事件 ID：E8040468（十六進位）

訊息： 1129

記憶體軌跡無法套用至此量測

嚴重性：錯誤

事件 ID：E8040469（十六進位）

訊息： 1130

正規化無法套用至此量測

嚴重性：錯誤

事件 ID：E804046A（十六進位）

訊息： 1131

提供的資料的點數無效。無法儲存該資料

嚴重性：錯誤

事件 ID：E804046B（十六進位）

訊息： 1132

在儲存/重新叫用狀態下儲存的量測的版本無效。無法載入該量測

嚴重性：錯誤

事件 ID：E804046C（十六進位）

訊息： 1133

此操作的資料格式引數必須為「naDataFormat_Polar」

嚴重性：錯誤

事件 ID：E804046D（十六進位）

訊息： 1134

此操作的資料格式引數必須為標量資料格式

嚴重性：錯誤

事件 ID：E804046E（十六進位）

訊息： 1135

記憶體軌跡對目前量測設定無效。

嚴重性：錯誤

事件 ID：E804046F（十六進位）

訊息： 1136

此量測與該通道中現有的量測不相容。選擇其他通道。

嚴重性：錯誤

事件 ID：E8040470（十六進位）

訊息： 1137

連接埠延伸修正不適用於偏移頻率量測。 連接埠延伸修正已停用。

嚴重性：錯誤

事件 ID：E8040471（十六進位）

訊息： 1138

邏輯連接埠對應的實體連接埠號指派必須是唯一的。

嚴重性：錯誤

事件 ID：E8040472（十六進位）

剖析器錯誤

訊息： 1281

「您已向分析儀傳送讀取命令，但沒有先使用適當的輸出命令要求資料。分析儀的輸出佇列中沒有可滿足要求的資料。」

嚴重性：錯誤

事件 ID：68050501（十六進位）

訊息： 1282

「您必須先從匯流排移除作用中控制器，或者該控制器必須放棄對匯流排的控制權，這樣分析儀才能進入系統控制器模式。」

嚴重性：錯誤

事件 ID：E8050502（十六進位）

訊息： 1283

「分析儀未接收到完整的資料傳輸。 這通常是由於匯流排事務中斷而導致的。」

嚴重性：錯誤

事件 ID：E8050503（十六進位）

訊息： 1284

「儀器狀態位元組已變更。」

嚴重性：資訊

事件 ID：68050504（十六進位）

訊息： 1285

「收到的 SCPI 命令導致了錯誤編號 %1： "%2".」

嚴重性：資訊

事件 ID：68050505（十六進位）

訊息： 1286

「INET LAN 伺服器已啟動，其處理程序編號為 %1。」

嚴重性：資訊

事件 ID：68050506（十六進位）

訊息： 1360

「執行 SCPI 命令失敗」

嚴重性： 錯誤

事件 ID：E8050550（十六進位）

訊息： 1361

「 INET/LAN 裝置不可存取。」

嚴重性： 錯誤

事件 ID：E8050551（十六進位）

訊息： 1362

「找不到 INET/LAN 驅動程式。 」

嚴重性： 錯誤

事件 ID：E8050552（十六進位）

訊息： 1363

「找不到 INET/LAN 驅動程式。」

嚴重性： 錯誤

事件 ID：E8050553（十六進位）

訊息： 1364

「INET/LAN 裝置無法擷取必要資源。 」

嚴重性： 錯誤

事件 ID：E8050554（十六進位）

訊息： 1365

「INET/LAN 裝置產生了一般系統錯誤。 」

嚴重性： 錯誤

事件 ID：E8050555（十六進位）

訊息： 1366

「INET/LAN 裝置的位址無效。」

嚴重性： 錯誤

事件 ID：E8050556（十六進位）

訊息： 1367

「找不到 INET I/O 程式庫。 」

嚴重性： 錯誤

事件 ID：E8050557（十六進位）

訊息： 1368

「INET 系統發生了錯誤。 」

嚴重性： 錯誤

事件 ID：E8050558（十六進位）

訊息： 1369

「存取 INET/LAN 驅動程式遭拒。 」

嚴重性： 錯誤

事件 ID：E8050559（十六進位）

訊息： 1370

「無法載入錯誤系統訊息 dll。」

嚴重性： 錯誤

事件 ID：E805055A（十六進位）

訊息： 1371

「ErrorSystemMessage.dll 未匯出正確的函數。」

嚴重性： 錯誤

事件 ID：E805055B（十六進位）

訊息： 1372

「無法結合自訂 scpi 程式庫」

嚴重性： 錯誤

事件 ID：E805055C（十六進位）

訊息： 1373

「無法結合 ErrorSystemMessage 程式庫中的 scpi 錯誤訊息」

嚴重性： 錯誤

事件 ID：E805055D（十六進位）

訊息： 1374

該命令在此軟體版本中已過時。

嚴重性：錯誤

事件 ID：E808055E（十六進位）

訊息： 1375

CALC 量測選項設定為「無」。請使用 Calc:Par:Sel

嚴重性：錯誤

事件 ID：E808055F（十六進位）

訊息： 1535

剖析器收到以下命令： %1.」

嚴重性：資訊

事件 ID：680505FF（十六進位）

顯示錯誤 1536 - 1621

訊息： 1536

「已超過每個視窗最多 4 條軌跡的限制。<x> 的軌跡不會新增至視窗 <x>。」

嚴重性：警告

進一步說明：無

建議：在其他視窗中建立軌跡。請參閱 VNA 視窗限制。

事件 ID：A8060600（十六進位）

訊息： 1537

「已超過最多 16 個資料視窗的限制。將不會建立新視窗。」

嚴重性：警告

進一步說明：無

建議：在現有視窗中建立軌跡。請參閱 VNA 視窗限制。

事件 ID：A8060601（十六進位）

訊息： 1538

「不存在任何資料視窗。無法完成操作。」

嚴重性：警告

進一步說明：遠端 SCPI 操作已嘗試建立新的量測，但此時不存在任何視窗

建議：請先建立新視窗，然後再建立量測。請參閱範例：使用 SCPI 建立量測

事件 ID：A8060602（十六進位）

訊息： 1539

「選取的視窗中不存在任何資料軌跡。操作未完成。」

嚴重性：警告

進一步說明：無

事件 ID：A8060603（十六進位）

訊息： 1540

「無法完成在 <x> 個視窗中排列現有量測的要求，因為每個視窗的軌跡限制為 <x> 條。」

嚴重性： 資訊

進一步說明：視窗排列功能無法將現有軌跡放置在所要求數目的視窗中，因為每個視窗只允許存在 4 條軌跡。請參閱「排列現有量測」

建議：建立更多視窗或刪除部分軌跡。

事件 ID：68060604（十六進位）

訊息： 1541

「無法與指定的印表機建立連接。」

嚴重性：警告

進一步說明：無

建議：請參閱印表機說明

事件 ID：A8060605（十六進位）

訊息： 1542

「列印輸出已取消。」

嚴重性：資訊

事件 ID：68060606（十六進位）

訊息： 1616

「找不到視窗。」

嚴重性：錯誤

進一步說明： 在程式中指定了不存在的視窗。

建議：先查詢視窗名稱，然後再指定視窗。

事件 ID：E8060650（十六進位）

訊息： 1617

「指定了重複的視窗 ID。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8060651（十六進位）

訊息： 1618

「超過了視窗數目限制。」

嚴重性：錯誤

進一步說明：每個畫面的視窗數目限制為 4 個。

事件 ID：E8060652（十六進位）

訊息： 1619

「超過了軌跡/視窗數目限制。」

嚴重性：錯誤

進一步說明：每個視窗的軌跡數目限制為 4 條。請參閱 VNA 上的軌跡、通道和視窗。

建議：在其他視窗中建立軌跡

事件 ID：E8060653（十六進位）

訊息： 1620

「找不到軌跡。」

嚴重性：錯誤

進一步說明：您的程式已嘗試與不存在的軌跡進行通訊。

建議：先查詢軌跡 ID，然後再寫入到該軌跡。

事件 ID：E8060654（十六進位）

訊息： 1621

「作業系統無法識別此印表機。」

嚴重性：警告

事件 ID：A8060655（十六進位）

訊息： 1622

指定了重複的軌跡 ID。

嚴重性：錯誤

事件 ID：E8060656（十六進位）

通道錯誤 1792 -1878

訊息： 1792

「掃描已完成。」

嚴重性：資訊

進一步說明：無

建議：無

事件 ID：68070700（十六進位）

訊息： 1793

「所有可觸發的擷取均已完成。」

嚴重性：資訊

進一步說明：

事件 ID：68070701（十六進位）

訊息： 1794

「上次觸發導致掃描中止。」

嚴重性：資訊

進一步說明：

事件 ID：68070702（十六進位）

訊息： 1795

「必須將區段清單調整為至少包含一個作用中區段（至少包含 1 個點），這樣才能使用區段掃描。」

嚴重性：資訊

進一步說明： 您已嘗試將掃描類型變更為區段掃描，但未定義任何區段，或者已定義的區段中不存在任何掃描點

建議：定義至少一個區段（至少包含一個量測點）。如需詳細資訊，請參閱「區段掃描」

事件 ID：68070703（十六進位）

訊息： 1796

"MSG_SET_CHANNEL_DIRTY"

嚴重性：資訊

進一步說明：當通道設定已變更，但該通道仍包含使用先前設定獲取的資料時，將出現此資訊訊息。獲取新的通道資料時，將出現下列 CLEAR 訊息。

事件 ID：68070704（十六進位）

訊息： 1797

"MSG_CLEAR_CHANNEL_DIRTY"

嚴重性：資訊

進一步說明： 當通道設定已變更，但該通道仍包含使用先前設定獲取的資料時，將出現先前的 SET 訊息。獲取新的通道資料時，將出現此 CLEAR 訊息。

事件 ID：68070705（十六進位）

訊息： 1798

掃描時間已從自動模式變更為手動模式。 如果您希望回到自動模式，請輸入為 0 的掃描時間值。

嚴重性：資訊

事件 ID：68070706（十六進位）

訊息： 1799

「設定「掃描已完成」」

嚴重性：資訊

進一步說明：當掃描及其關聯的掃描計算完成後，將出現此事件。這通常在通道的所有掃描皆完成後出現。

事件 ID：68070707（十六進位）

訊息： 1800

「清除「掃描已完成」」

嚴重性：資訊

進一步說明：此事件將在 SET SWEEP COMPLETED 事件之後立即出現。這兩個事件分別在 SCPI 裝置狀態暫存器上設定和清除「掃描已完成」位元（位元 4）。

事件 ID：68070708（十六進位）

訊息： 1801

「所有掃描皆已完成並經過處理」

嚴重性：資訊

進一步說明：當通道的所有掃描和掃描計算均完成後，將出現此事件。

事件 ID：68070709（十六進位）

訊息： 1802

低通：頻率限制已變更。

嚴重性：資訊

事件 ID：6,807,070A（十六進位）

訊息： 1803

低通：點數已變更。

嚴重性：資訊

事件 ID：6,807,070B（十六進位）

訊息： 1804

低通：頻率限制和點數已變更。

嚴重性：資訊

事件 ID：6807070C（十六進位）

訊息： 1805

「通道已建立」

嚴重性：資訊

事件 ID：6807070D（十六進位）

訊息： 1806

「通道已刪除」

嚴重性：資訊

事件 ID：6807070E（十六進位）

訊息： 1872

「找不到通道。」

嚴重性：錯誤

進一步說明：在程式控制下參考了不存在的通道。

建議：查詢通道編號，然後按該編號參考通道。

事件 ID：E8070750（十六進位）

訊息： 1873

「找不到要求的掃描區段。」

嚴重性：錯誤

進一步說明： 在程式控制下參考了不存在的掃描區段。

事件 ID：E8070751（十六進位）

訊息： 1874

「掃描區段清單為空。」

嚴重性：錯誤

進一步說明： 除非至少存在一個已定義的區段，否則無法指定區段掃描。此錯誤僅在執行遠端控制時出現。

事件 ID：E8070752（十六進位）

訊息： 1875

「作用中掃描區段清單區段中的點數為 0。」

嚴重性：錯誤

進一步說明：除非在區段中至少已指定一個資料點，否則無法指定區段掃描。此錯誤僅在執行遠端控制時出現。

事件 ID：E8070753（十六進位）

訊息： 1876

「指定的來源衰減器無效。」

嚴重性：錯誤

進一步說明： 您已嘗試為 VNA 上不具有來源衰減器的通道物件設定衰減器內容。

事件 ID：E8070754（十六進位）

訊息： 1877

「無法選取對數頻率掃描，因為目前點數太多。 請減少點數。」

嚴重性：錯誤

進一步說明：可用於對數掃描的最大點數為 401 個。

事件 ID：E8070755（十六進位）

訊息： 1878

「要求的點數超過可選取用於對數頻率掃描的點數。」

嚴重性：錯誤

進一步說明： 可用於對數掃描的最大點數為 401 個。

事件 ID：E8070756（十六進位）

訊息： 1879

「回應頻率超過了儀器範圍，因此頻率偏移已關閉。」

嚴重性：錯誤

進一步說明：只要儀器偵測到激勵掃描設定和頻率偏移設定導致計算回應頻率超過儀器限制，便會傳回此錯誤。發生此情況時，儀器會自動關閉頻率偏移以避免超出範圍條件。

建議：如果發生了這種情況，請變更激勵頻率或頻率偏移的設定，以使回應頻率處於儀器限制範圍內。完成此操作後，可再次開啟頻率偏移。

事件 ID：E8070757（十六進位）

訊息： 1880

所有指定區段的總點數超過了支援的最大點數。這些區段未變更。

嚴重性：錯誤

事件 ID：E8070758（十六進位）

訊息： 1881

未使用通道物件的此執行個體將通道置於「保持」狀態，因此，不會恢復任何通道。

嚴重性：錯誤

事件 ID：E8070759（十六進位）

訊息： 1882

連接埠號超出允許的連接埠號範圍。

嚴重性：錯誤

事件 ID：E807075A（十六進位）

訊息： 1883

存在的連接埠數量超過執行此操作所需的連接埠數量。

嚴重性：錯誤

事件 ID：E807075B（十六進位）

一般錯誤

訊息： 2048

「所要求的功能需要利用由某個選件向標準分析儀提供的功能。該選件目前尚未安裝。」

嚴重性：錯誤

進一步說明：無

建議：若要檢視分析儀上的選件，請按一下「說明」>「關於網路分析儀」。如需詳細資訊，請參閱 VNA 選件

事件 ID：68080800（十六進位）

訊息： 2049

「要求的功能在目前儀器上不可用。」

嚴重性：錯誤

進一步說明：無

事件 ID：68080801（十六進位）

訊息： 2050

「要求的功能與目前的儀器狀態不相容。」

嚴重性：錯誤

進一步說明：無

建議：無

事件 ID：68080802（十六進位）

訊息： 2051

「檔案 <x> 已儲存。」

嚴重性：資訊

進一步說明：無

事件 ID：68080803（十六進位）

訊息： 2052

「嘗試儲存 <x> 失敗。」

嚴重性：錯誤

進一步說明： 無

建議：如果使用的是磁碟片，請確保該磁碟片位於磁碟機內且磁碟未滿。檢查檔案名稱是否包含特殊字元。

事件 ID：E8080804（十六進位）

訊息： 2053

「嘗試重新叫用檔案失敗，因為找不到 <x>。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080805（十六進位）

訊息： 2054

「<x> 的標頭不正確。」

嚴重性：錯誤

進一步說明：無

建議：重新複製檔案和/或刪除檔案。

事件 ID：E8080806（十六進位）

訊息： 2056

「要求進入休眠狀態。」

進一步說明：無

事件 ID：68080808（十六進位）

訊息： 2057

「從自動休眠狀態開機。程式收到了 PBT_APMRESUMEAUTOMATIC 訊息。」

進一步說明：無

事件 ID：68080809（十六進位）

訊息： 2058

「從擱置休眠狀態開機。程式收到了 PBT_APMRESUMESUSPEND 訊息。」

進一步說明：無

事件 ID：6,808,080A（十六進位）

訊息： 2059

「從擱置休眠狀態開機。程式收到了 PBT_APMRESUMECRITICAL 訊息。」

嚴重性：警告

進一步說明：無

事件 ID：A808080B（十六進位）

訊息： 2060

「從叫用的未知休眠狀態 UI 恢復開機。程式在分配的時間內未收到 PBT 訊息，並且正在嘗試恢復。」

嚴重性：警告

進一步說明：無

事件 ID：A808080C（十六進位）

訊息： 2061

「<x> 已存在。正在覆寫檔案。」

進一步說明：僅用於遠端應用程式

事件 ID：6808080D（十六進位）

訊息： 2062

「檔案尚未儲存。」

嚴重性：錯誤

進一步說明：僅用於遠端應用程式

事件 ID：E808080E（十六進位）

訊息： 2063

「檔案 <x> 已重新叫用。」

進一步說明：僅用於遠端應用程式

事件 ID：6808080F（十六進位）

訊息： 2064

「該代碼的此版本將 <x> 中的狀態版本視為已過時。」

嚴重性：錯誤

進一步說明：您已嘗試重新叫用不再有效的檔案。

建議：您必須手動重新建立該檔案。

事件 ID：E8080810（十六進位）

訊息： 2065

「<x> 中的狀態版本高於此代碼支援的最新版本。」

嚴重性：錯誤

進一步說明：您已嘗試重新叫用由更高版本的 VNA 應用程式所建立的檔案。

建議：您必須手動重新建立該檔案。

事件 ID：E8080811（十六進位）

訊息： 2066

「讀取檔案 <x> 時發生錯誤」

嚴重性：錯誤

進一步說明：該檔案可能已毀損。

建議：嘗試重新建立該檔案。

事件 ID：E8080812（十六進位）

訊息： 2067

「Windows Shell 錯誤：<x>」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080813（十六進位）

訊息： 2068

傳送訊息逾時，傳回的錯誤如下：<x>.

嚴重性：錯誤

進一步說明：無

事件 ID：E8080814（十六進位）

訊息： 2069

「將 GPIB 模式變更為系統控制器。」

嚴重性：資訊

進一步說明：無

事件 ID：68080815（十六進位）

訊息： 2070

「將 GPIB 模式變更為 Talker Listener（資訊源接收器）。」

嚴重性：資訊

進一步說明：無

事件 ID：68080816（十六進位）

訊息： 2071

「除非 GPIB 狀態為「本機」，否則無法將網路分析儀置於 GPIB 系統控制器模式。停止任何可能正在使用網路分析儀的遠端 GPIB 程式，按下 [Macro]/[Local] 硬鍵，然後再試一次。 」

嚴重性：資訊

進一步說明：請參閱 LCL 和 RMT 操作

建議：按下 [Macro]/[Local] 硬鍵，然後再試一次。

事件 ID：68080817（十六進位）

訊息： 2120

「無法透過晚期繫結 COM 叫用來叫用此方法。」

嚴重性：錯誤

進一步說明：無

建議：使用 COM 編程文件中介紹的替代方法

事件 ID：E8080878（十六進位）

訊息： 2128

「指定的格式無效。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080850（十六進位）

訊息： 2129

「自動化層導致了 WINNT 異常。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080851（十六進位）

訊息： 2130

「連接埠規格不正確。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080852（十六進位）

訊息： 2131

「找不到印表機。」

嚴重性：錯誤

進一步說明：無

建議：請參閱連接到印表機

事件 ID：E8080853（十六進位）

訊息： 2132

「已忽略手動觸發。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080854（十六進位）

訊息： 2133

「嘗試設定觸發失敗。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080855（十六進位）

訊息： 2134

「巨集執行失敗。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080856（十六進位）

訊息： 2135

「指定的巨集定義不完整。」

嚴重性：錯誤

進一步說明：

事件 ID：E8080857（十六進位）

訊息： 2137

「區塊資料長度錯誤。」

嚴重性：錯誤

進一步說明：請參閱從分析儀獲取資料

事件 ID：E8080859（十六進位）

訊息： 2139

「找不到要求的資料。」

嚴重性：錯誤

進一步說明：無

事件 ID：E808085B（十六進位）

訊息： 2142

「提供的參數超出範圍，因此，先將該參數限制為範圍中的某個值，然後再套用至儀器。」

嚴重性：成功

進一步說明：無

建議：先檢視範圍限制，再傳送編程命令。

事件 ID：2808085E（十六進位）

訊息： 2143

提供的參數超出範圍，因此，先將該參數限制為範圍中的某個值，然後再套用至儀器。

嚴重性：錯誤

事件 ID：E808085F（十六進位）

訊息： 2144

「要求失敗。找不到所需授權。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080860（十六進位）

訊息： 2145

「對前面板的遠端叫用傳回了 hresult <x>」

嚴重性：錯誤

進一步說明：這可能指示前面板存在問題

建議：請與技術支援聯絡

事件 ID：E8080861（十六進位）

訊息： 2146

重新叫用操作失敗。

嚴重性：錯誤

進一步說明：

事件 ID：E8080862（十六進位）

訊息： 2147

嘗試儲存檔案失敗。

嚴重性：錯誤

進一步說明：

事件 ID：E8080863（十六進位）

訊息： 2148

重新叫用嘗試失敗，因為找不到該檔案。

嚴重性：錯誤

進一步說明：

事件 ID：E8080864（十六進位）

訊息： 2149

重新叫用檔案的標頭不正確。

嚴重性：錯誤

進一步說明：

事件 ID：E8080865（十六進位）

訊息： 2150

重新叫用檔案的版本已過時，並且與此儀器不再相容。

嚴重性：錯誤

進一步說明：

事件 ID：E8080866（十六進位）

訊息： 2151

重新叫用檔案包含比此儀器更高的狀態版本。對前面板的遠端叫用傳回了 hresult %1

嚴重性：錯誤

進一步說明：

事件 ID：E8080867（十六進位）

訊息 2152

「前面板 <x>

嚴重性：錯誤

進一步說明：無

事件 ID：E8080868（十六進位）

訊息 2153

「前面板訊息」

嚴重性：資訊

進一步說明：無

事件 ID：68080869（十六進位）

訊息 2154

「電源服務 <x>

嚴重性：錯誤

進一步說明：超過 1 個 powerservice 執行個體正在執行。只應 有一個執行個體正在執行。這種情況可能會在執行 install shield 後出現，尤其是在升級 CPU 板時。

建議： 嘗試重新啟動。如果這種情況仍然存在，請致電客戶支援。

事件 ID：E808086A（十六進位）

訊息 2155

「電源服務 <x>

嚴重性：資訊

進一步說明：無

事件 ID：6,808,086B（十六進位）

訊息 2156

「無法載入或卸載 Keysight Technologies GPIB 驅動程式。」

嚴重性：錯誤

進一步說明：無

建議：如果問題仍然存在，請在 VNA 桌面的「我的電腦」上按一下滑鼠右鍵。按一下「內容」，然後按一下「硬體」標籤。按一下「裝置管理員」按鈕。展開 GPIB 裝置。按一下滑鼠右鍵，然後按一下「卸載所有 GPIB 介面裝置」。重新啟動 VNA。

事件 ID：E808086C（十六進位）

訊息 2157

「無法載入或卸載 National Instruments GPIB 驅動程式。」

嚴重性：錯誤

進一步說明：無

建議：如果問題仍然存在，請在 VNA 桌面的「我的電腦」上按一下滑鼠右鍵。按一下「內容」，然後按一下「硬體」標籤。按一下「裝置管理員」按鈕。展開 GPIB 裝置。按一下滑鼠右鍵，然後按一下「卸載所有 GPIB 介面裝置」。重新啟動 VNA。

事件 ID：E808086D（十六進位）

訊息 2158

「Keysight GPIB 驅動程式已載入，但無法啟動其剖析器。」

嚴重性：錯誤

進一步說明：無

事件 ID：E808086E（十六進位）

訊息： 2159

前面板處於遠端模式。

嚴重性：警告：

事件 ID：A808086F（十六進位）

訊息： 2160

找不到指定的登錄機碼。

嚴重性：錯誤

事件 ID：E8080870（十六進位）

訊息： 2161

在插入到前面板的測試棒上偵測到了過電流條件。

嚴重性：警告：

事件 ID：A8080871（十六進位）

訊息： 2162

操作已逾時。

嚴重性：錯誤

事件 ID：E8080872（十六進位）

訊息 2163

「網路分析儀執行了預設。」

嚴重性：資訊

進一步說明：無

事件 ID：68080873（十六進位）

訊息 2164

「存取檔案遭拒。」

嚴重性：錯誤

進一步說明：這意味著系統無法開啟輸出檔案以供寫入。最可能的原因是檔案已設定寫入保護。

建議： 挑選其他檔案名稱或檔案目錄，然後檢查磁碟片和硬碟的寫入存取權限。

事件 ID：E8080874（十六進位）

訊息 2165

「檔案類型是結構化儲存體。」

嚴重性：資訊

進一步說明：無

事件 ID：68080875（十六進位）

訊息 2166

「觸發操作失敗。」

嚴重性：錯誤

進一步說明：無

事件 ID：E8080876（十六進位）

訊息 2167

「引數超出範圍錯誤。」

嚴重性：錯誤

進一步說明：無

建議：無

事件 ID：E8080877（十六進位）

訊息： 2169

指定的 COM 物件不是自訂應用程式

嚴重性：錯誤

事件 ID：E8080879（十六進位）

訊息： 2170

提供的事件 ID 未識別為有效的 VNA 事件 ID

嚴重性：錯誤

事件 ID：E808087A（十六進位）

訊息： 2171

操作已取消。

嚴重性：錯誤

事件 ID：E808087B（十六進位）

訊息： 2172

無法直接停用高安全性層級。只有透過儀器預設或重新叫用安全性層級較低的儀器狀態，才能重設此安全性層級。

嚴重性：錯誤

事件 ID：E808087C（十六進位）

訊息： 2173

本機鎖定模式已開啟。 除非透過遠端介面關閉此模式，否則 VNA 應用程式不會接受來自前面板、鍵盤或滑鼠的輸入。

嚴重性：錯誤

事件 ID：E808087D（十六進位）

訊息： 2174

SnP 要求對選取的量測無效。

嚴重性：錯誤

事件 ID：E808087E（十六進位）

訊息： 2175

當此對話方塊或精靈處於開啟狀態時，不支援進行預設。關閉此對話方塊或精靈，然後再試一次。

嚴重性：錯誤

事件 ID：E808087F（十六進位）

訊息： 2176

所要求的功能需要利用由某個選件向標準分析儀提供的功能。該選件目前尚未安裝。

嚴重性：錯誤

事件 ID：E8080880（十六進位）

訊息： 2177

重大錯誤。 在 <n> 記錄到損毀傾印

嚴重性：錯誤

事件 ID：E8080881（十六進位）

訊息： 2178

在雜訊校準的環境中，如果 VNA 無法設定調諧器 Ecal 模組的狀態，將發生此錯誤。

嚴重性：錯誤

事件 ID：E8080882（十六進位）

訊息： 2179

無法開啟 gen.lic。

嚴重性：錯誤

事件 ID：E8080883（十六進位）

上次修改時間：

2016 年 01 月 06 日

第一版


關於錯誤訊息

VNA 錯誤和作業系統錯誤在錯誤檔案中顯示並予以記錄。您可選擇 VNA 錯誤的顯示方式，也可以選擇完全不顯示 VNA 錯誤。

  • 錯誤顯示

  • 檢視錯誤記錄檔

  • VNA 錯誤清單

  • SCPI 錯誤

其他系統主題

錯誤顯示

依預設，錯誤訊息顯示在狀態列上。您可以選擇讓錯誤訊息在按一下「確定」按鈕之前一直停留在畫面上，或者也可以選擇完全不顯示錯誤訊息。 錯誤訊息停留在畫面上時，您可按一下「說明」按鈕取得進一步的協助。

如何選取錯誤訊息的顯示方式

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System]> Help（說明）> Error Display...（錯誤顯示...）

錯誤顯示對話方塊說明

執行預設時，這些設定恢復為其預設值（enabled）。

啟用訊息 勾選該方塊可在發生錯誤時顯示所有 VNA 錯誤訊息。清除該方塊可禁止顯示 VNA 錯誤訊息。您仍然可以在錯誤記錄中檢視這些錯誤訊息。

校準錯誤訊息視窗

狀態列 在狀態列上顯示錯誤訊息。這樣您便可以在錯誤記錄中檢視訊息並取得進一步的協助。

確認對話方塊 在標準對話方塊中顯示錯誤訊息。這樣您便可以選擇確定或取消關閉對話方塊，或按下「說明」取得錯誤訊息的詳細資訊。

檢視錯誤記錄

VNA 錯誤記錄是已發生事件的清單，但其中不包含 SCPI 錯誤/開機測試錯誤等。（使用 COM 對 VNA 進行編程時要使用這些事件。）VNA 錯誤是 VNA 事件的子集。只有嚴重性代碼為 ERROR 的事件才會在其發生時顯示在 VNA 畫面上。從錯誤記錄，您可透過選取錯誤並按一下「說明」來存取有關錯誤的詳細說明。

如何檢視錯誤記錄

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Sweep]> Help（說明） > View Error Log（檢視錯誤記錄）。

無編程命令

錯誤記錄對話方塊說明

僅網路分析儀錯誤 選取該方塊以僅檢視 VNA 錯誤。清除該方塊可檢視在電腦所有應用程式上發生的所有錯誤。

說明 顯示在 VNA 畫面上的錯誤訊息。

A - 事件 ID 錯誤訊息編號

B - 錯誤發生的日期

C - 錯誤發生的時間

D - 嚴重性代碼 - 所有事件具有下列其中一種嚴重性代碼：

  • SUCcess - 操作已成功完成

  • INFormational - 發生的事件不會影響量測整體性

  • WARning - 發生的事件可能會影響量測整體性

  • ERRor - 發生的事件會嚴重影響量測整體性

E - 發生錯誤的應用程式。

確定 關閉對話方塊

說明 提供所選錯誤訊息的相關詳細資訊。

清除錯誤記錄：

  1. 從 [System] > Main（主功能表）功能表，按一下 Minimize Application（最小化應用程式）

  2. 在桌面上選取開始>控制台

  3. 在「控制台」上，按一下管理工具

  4. 在「管理工具」視窗上，按一下事件檢視器

  5. 在「事件檢視器」視窗上，在應用程式上按一下滑鼠右鍵

  6. 選取清除記錄

  7. 如果要將事件記錄的內容儲存到檔案，請按一下儲存並清除。否則，請按一下清除

要還原 VNA 應用程式，請按一下畫面底部的 VNA 分析儀工作列按鈕

上次修改時間：

2016 年 01 月 06 日

第一版


分析儀配件

  • 同軸機械校準套件

  • 波導機械校準套件

  • 電子校準 (ECal)

  • 機械驗證套件

  • 配接器和配件套件

  • 測試連接埠纜線

  • USB 週邊設備

  • 接頭維護和 ESD 用品

其他支援主題

如需產品和訂單資訊：

  • 請造訪 www.keysight.com/find/accessories

  • 使用搜尋功能找到特定配件的相關資訊，或檢視整個 RF 和微波測試配件目錄。

提供的配件採用下列接頭類型：

  • 50 ohm N 型

  • 75 ohm N 型

  • 3.5 mm

  • 7 mm（APC-7）

  • 7-16

  • 2.92 mm

  • 2.4 mm

  • 1.85 mm

  • 1 mm

量測系統必須具有測試連接埠纜線和校準套件才視作完整。

將驗證套件用於驗證修正後系統的效能。

請參閱適用於各個 VNA 模型的接頭類型

同軸機械校準套件

型號 | 接頭類型 | 頻率上限
85032B | N 型 (50 Ohm) | 6 GHz
85032F | N 型 (50 Ohm) | 9 GHz
85054B | N 型 (50 Ohm) | 18 GHz
85036E | N 型 (75 Ohm) | 3 GHz
85050B | 7 mm | 18 GHz
85033D | 3.5 mm | 6 GHz
85038A | 7-16 | 7.5 GHz
85033E | 3.5 mm | 9 GHz
85052B | 3.5 mm | 26.5 GHz
85052C | 3.5 mm TRL | 26.5 GHz
85056K | 2.92 mm | 50 GHz
85056A | 2.4 mm | 50 GHz
85058B/E （資料式） | 1.85 mm | 67 GHz
85059A （資料式） | 1.00 mm | 110 GHz

波導機械校準套件

型號 | 接頭類型 | 頻率範圍
X11644A | WR-90 | 8.2-12.4 GHz
P11644A | WR-62 | 12.4-18 GHz
K11644A | WR-42 | 18-26.5 GHz
R11644A | WR-28 | 26.5-40 GHz
Q11644A | WR-22 | 33-50 GHz
U11644A | WR-19 | 40-60 GHz
V11644A | WR-15 | 50-75 GHz

電子校準 (ECal)

型號 | 接頭類型 | 頻率範圍
RF 2 連接埠
85091C | 7 mm（APC-7） | 300 kHz-9 GHz
85092C | N 型 (50 ohm) 連接埠 B 隨 3.5 mm 或 7-16a 一起提供 | 300 kHz-9 GHz
85093C | 3.5 mm 連接埠 B 隨 N 型 (50 ohm) 或 7-16a 一起提供 | 300 kHz-9 GHz
85096C | N 型 (75 ohm) | 300 kHz-3 GHz
85098C | 7-16a 連接埠 B 隨 N 型 (50 ohm) 或 3.5 mm 一起提供 | 300 kHz-7.5 GHz
85099C | F 型 | 300 kHz-3 GHz
RF 4 連接埠
N4431B | 3.5mm (f)（4 連接埠）、N 型 (f)（4 連接埠）、混合接頭類型 | 9 kHzb-13.5 GHz
N4432A 選件 020 | N 型 (f)（4 連接埠） | 300 kHz-18 GHz （自 2006 年 2 月起提供）
N4432A 選件 030 | APC 7（4 連接埠） | 300 kHz-18 GHz （自 2006 年 2 月起提供）
N4433A 選件 010 | 3.5mm (f) （4 連接埠） | 300 kHz-20 GHz （自 2006 年 2 月起提供）
微波 2 連接埠
N4690B | N 型 (50 ohm) | 300 kHz-18 GHz
N4691B | 3.5 mm | 300 kHz-26.5 GHz
N4692A | 2.92 mm | 10 MHz-40 GHz
N4693A | 2.4 mm | 10 MHz-50 GHz
N4694A | 1.85 mm | 10 MHz-67 GHz
N4696BA | 7 mm | 300 kHz-18 GHz

a 將 ECal 模組高頻率限制為 7.5 GHz。

b 9 kHz 至 300 kHz 的效能僅對 E5080A 和 E5071C ENA 網路分析儀（韌體版本為 A.09.10 或更高）有效。

驗證套件

型號 | 接頭類型 | 頻率範圍
85055A | N 型 (50 Ohm) | 300 kHz-9 GHz
85053B | 3.5 mm | 300 kHz-26.5 GHz
85057B | 2.4 mm | .045-50 GHz
R11645A | WR-28 | 26.5-40 GHz
Q11645A | WR-22 | 33-50 GHz

配接器和配件套件

型號 | 描述
11878A | N 型轉 3.5 mm 配接器套件
11525A | N 型 (m) 轉 7 mm (APC-7)
11853A | N 型配件套件
11900B | 2.4 mm (f) 轉 2.4 mm (f)
11900C | 2.4 mm (f) 轉 2.4 mm (m)
85130G | 測試連接埠配接器集，2.4 mm (f) 轉 2.4 mm (m,f)
11901B | 2.4 mm (f) 轉 3.5 mm (f)
11901D | 2.4 mm (f) 轉 3.5 mm (m)
85130F | 測試連接埠配接器集，2.4 mm (f) 轉 3.5 mm (m,f)
11902B | 2.4 mm (f) 轉 7 mm (APC-7)
11920A | 1 mm (m) 轉 1 mm (m)
11920B | 1 mm (f) 轉 1 mm (f)
11920C | 1 mm (m) 轉 1 mm (f)
11921A | 1 mm (m) 轉 1.85 mm (m)
11921B | 1 mm (f) 轉 1.85 mm (f)
11921C | 1 mm (m) 轉 1.85 mm (f)
11921D | 1 mm (f) 轉 1.85 mm (m)
11922A | 1 mm (m) 轉 2.4 mm (m)
11922B | 1 mm (f) 轉 2.4 mm (f)
11922C | 1 mm (m) 轉 2.4 mm (f)
11922D | 1 mm (f) 轉 2.4 mm (m)

測試連接埠纜線

型號 | 描述
N4697E | 1.85 mm (f) 轉 1.85 mm（凹凸 f）（彈性，單獨）
N4697F | 1.85 mm（凹凸 f，f）轉 1.85 mm（凹凸 m，凹凸 f）（彈性，成套）
N6315A | N 型 (m) 轉 N 型 (f) ，16 in.（單獨）
N6314A | N 型 (m) 轉 N 型 (m) ，24 in.（單獨）
85133D | 2.4 mm (f) 轉 2.4 mm (m,f)（半剛性，成套）
85133F | 2.4 mm (f) 轉 2.4 mm (m,f)（彈性，成套）
85134D | 2.4 mm (f) 轉 3.5 mm (m,f)（半剛性，成套）
85134F | 2.4 mm (f) 轉 3.5 mm (m,f)（彈性，成套）

USB 週邊設備

型號 | 描述
N4688A | CD RW 磁碟機 - 帶 USB 纜線。
N4689A | USB 4 連接埠集線器 - 用於連接其他 USB 週邊設備。
82357B | USB/GPIB 介面 - 用於透過 USB 控制 GPIB 裝置。暸解有關 82357B 與 VNA 搭配使用的詳細資訊

接頭和 ESD 用品

請參閱 ESD 主題

請參閱更多接頭維護用品

零件編號 | 描述
9300-1367 | 可調整抗靜電腕帶
9300-0980 | 抗靜電腕帶接地線（5 英尺）
9300-0797 | 靜電控制桌墊（2 英尺 x 4 英尺），帶接地線
9300-1126 | ESD 腳跟帶
1401-0248 | ESD 安全端蓋，N 型 (m)
1401-0247 | ESD 安全端蓋，N 型 (f)
1401-0214 | 標準安全端蓋，N 型 (m)
1401-0225 | 標準安全端蓋，N 型 (f)

上次修改時間：

2014 年 11 月 20 日

第一版


USB to GPIB Adapter

82357B USB / GPIB Interface

The Keysight 82357B is an adapter that creates a GPIB Interface from one of your unused VNA USB ports.

  • Applications

  • Configuring

  • Connecting

  • Communicating with other Equipment

Applications

The 82357B can be used to connect a GPIB device using the VNA USB for any VNA application. In addition, the 82357B can be used to connect a power meter for a source power calibration.

Configure the 82357B USB/GPIB Interface

When the 82357B is connected to the VNA USB, the following dialog box appears:

Normally, you do NOT need to edit these settings. The 82357B USB/GPIB Interface is configured automatically as the next unused VISA interface. This is usually GPIB2 unless you have already configured it for another purpose.

If the VISA Interface Name appears as GPIB0 or GPIB1, these Interfaces must be returned to their default settings for the 82357B to work properly with the VNA. See Configure for VISA / SICL to learn how.

Connecting the 82357B USB/GPIB Interface

The following diagram illustrates how to connect GPIB test equipment using the USB/GPIB Interface.

  • Plug the USB/GPIB Interface into any unused VNA USB port.

  • The driver installation and connection is performed automatically.

Communicating with Equipment Connected to the USB/GPIB Interface

  • The Frequency Converter Application will automatically find and communicate with test equipment that is connected to the USB/GPIB Interface.

  • Source power calibration: Select GPIB at the Power Meter Settings dialog and specify the GPIB address of the power meter.

  • To control other devices through your own program using the 82357B , you must include the new GPIB Interface number when addressing the devices.

Last modified:

6-Jan-2016

First Release


FW_upgrade

韌體更新

VNA 韌體更新透過自解 Install Shield 檔案免費提供。更新內容包含 VNA 應用程式、線上說明和維修公用程式。

若要在 VNA 上手動檢查韌體版本，請按一下 [System] > Help（說明）> About NA...（關於 NA...） 。

提示：使用將應用程式移至後面可使 VNA 應用程式在畫面上移至此應用程式的後面。

附註：韌體更新後...

  • 必須匯入自訂校準套件。暸解詳細資訊

  • 如果存在名稱為「網路分析儀」的不同桌面圖示，VNA 應用程式的捷徑將採用同一個圖示。在桌面上按一下滑鼠右鍵，然後按一下重新整理。

其他支援主題

更新韌體

  1. 從 http://www.keysight.com/find/e5080a 下載最新韌體。

  2. 透過按下 [System] > Main（主功能表）> Exit（結束）可終止 VNA 應用程式。

  3. 使用 LAN 或 USB 筆形磁碟機將檔案從電腦傳輸至 VNA。

  4. 按兩下 VNA 上的檔案，然後按照說明操作。

警告：可將更新檔案儲存至電腦，但請勿嘗試在電腦上安裝 VNA 應用程式。其會修改系統設定並導致系統當機。

上次修改時間：

2016 年 01 月 06 日

第一版


VNA 組態和選項

本主題介紹可用選件。

另請參閱

  • 按一下說明，然後按一下關於網路分析儀可檢視 VNA 上已安裝的選件。

其他支援主題

E5080A

測試連接埠與頻率選件

  • 頻率範圍介於 9 kHz 到 4.5 GHz 並具有偏壓 T 型接頭的 245 2 連接埠測試裝置

  • 頻率範圍介於 9 kHz 到 6.5 GHz 並具有偏壓 T 型接頭的 265 2 連接埠測試裝置

  • 頻率範圍介於 9 kHz 到 9 GHz 並具有偏壓 T 型接頭的 295 2 連接埠測試裝置

  • 頻率範圍介於 9 kHz 到 4.5 GHz 並具有偏壓 T 型接頭的 445 4 連接埠測試裝置

  • 頻率範圍介於 9 kHz 到 6.5 GHz 並具有偏壓 T 型接頭的 465 4 連接埠測試裝置

  • 頻率範圍介於 9 kHz 到 9 GHz 並具有偏壓 T 型接頭的 495 4 連接埠測試裝置

軟體選件

  • 009 頻率偏移模式

  • 010 時域分析

  • 790 量測精靈協助軟體

時間基準選件

  • UNQ 標準穩定性時基

  • 1E5 高穩定性時基

儲存選件

  • 017 可移除式固態硬碟

  • 019 標準固態硬碟

上次修改時間：

2014 年 09 月 29 日

第一版


Option_Enable

選件啟用

可使用 Keysight License Manager 來管理和升級選件。

從 Windows 功能表，按下「所有程式」>「Keysight License Manager」。

如需詳細資料，請參閱 Keysight License Manager 說明。

上次修改時間：

2016 年 01 月 06 日

第一版


儀器校準

儀器校準是量測 VNA 效能以確保其在規格範圍內操作的程序。如果任一效能參數與已發佈規格不相符，則會進行調整以使效能相符。

為何應對儀器執行校準？

分析儀中的作用中元件會隨時間而老化，且效能可能會降低或漂移。

為確保分析儀在已發佈規格範圍內操作，您應當定期執行儀器校準。

應多久對儀器執行一次校準？

由您負責確定最符合自己需求的校準週期。不過，12 至 18 個月的校準週期適用於大多數使用者。

需要考量兩個因素：效能漂移和接頭磨損。

  • 所設定的儀器規格已將 24 個月的週期內可能發生的效能漂移納入考量。因此，依照 24 個月的間隔對儀器執行校準可確保分析儀的效能保持在操作規格範圍內。如果您需要分析儀的操作效能保持較高的一致性，您可以依照比所建議之 24 個月間隔短的間隔對儀器執行校準。

  • 接頭磨損是影響更大的要素，且取決於已進行的連線數。經過 500 至 700 次的連線後，測試連接埠明顯磨損。在平均使用時間的條件下，這大概相當於 12 個月。如果連線更頻繁，則校準週期應更短。透過使用接頭節約設備並執行適當的接頭維護，您可以延長校準週期，從而節省資金。

如何對儀器執行校準？

若要對儀器執行校準，請將其寄送至其中一個 Keysight Technologies 服務中心。請參閱技術支援。

寄送至服務中心時，VNA 必須完全正常運作，否則將針對維修服務收取費用。如果 VNA 在安全環境中使用，而其中的硬碟無法隨 VNA 一起寄送，則您必須購買第二個硬碟並將其配置為在「未分類」環境中與 VNA 搭配使用，然後再將 VNA 寄送至服務中心。

若要自己執行儀器校準，您必須擁有下列必需項目：

  • 儀器校準測試設備

  • 效能測試軟體

有哪些儀器校準類型可供選擇？

初次訂購時，Keysight Technologies 提供下列儀器校準類型：

標準 | 包含一份校準憑證，該憑證說明儀器已經過校準並在已發佈的規格範圍內操作。
選件 UK6 | 僅在初次運送時提供。包含經由校準取得的測試資料和校準憑證，該憑證說明儀器已經過校準並在已發佈的規格範圍內操作。
選件 A6J | 僅在初次運送時提供。包含經由校準取得的測試資料和量測不確定性以及校準憑證，該憑證說明儀器已按照符合 ANSI Z540 標準的程序執行校準，並在已發佈的規格範圍內操作。
選件 1A7 | 僅在初次運送時提供。包含經由校準取得的測試資料和量測不確定性以及校準憑證，該憑證說明儀器已按照符合 ISO 17025 標準的程序執行校準，並在已發佈的規格範圍內操作。

Keysight Technologies 服務中心提供下列儀器校準類型：

Keysight 校準 | 包含經由校準取得的測試資料和校準憑證，該憑證說明儀器已經過校準並在已發佈的規格範圍內操作。
ANSI Z540 校準 | 包含經由校準取得的測試資料和校準憑證，該憑證說明儀器已按照符合 ANSI Z540.1 標準的程序執行校準，並在已發佈的規格範圍內操作。
ISO 17025 校準 | 包含經由校準取得的測試資料和校準憑證，該憑證說明儀器已按照符合 ISO 17025 標準的程序執行校準，並在已發佈的規格範圍內操作。

如需這些選件的詳細資訊，請造訪 www.Keysight.com/find/calibration。

上次修改時間：

2010 年 03 月 24 日

更新了選件和校準週期


其他資源

還可獲取以下網路分析資源。

文件資源

應用程式附註

您還可以透過以下 URL 存取應用程式附註：

http://www.keysight.com/find/na

協力廠商資源

如需有關測試固定裝置和零件處理器的詳細資訊，請聯絡：

Inter-Continental Microwave
www.icmicrowave.com

如需有關探查設備和配件的詳細資訊，請聯絡：

Cascade Microtech, Inc.
www.cascademicrotech.com


操作員檢查

  • 概觀

概觀

首次收到 VNA 時，以及想要確認 VNA 是否運作正常時，都應執行作業人員檢查。

附註

  • 作業人員檢查不會驗證效能是否符合規格。若要驗證 VNA 效能是否符合規格，請執行效能測試或系統驗證。

  • 在考量失敗的測試是否有效之前，讓 VNA 暖機 90 分鐘。

如何執行作業人員檢查

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > Service（服務）> Operator's Check（作業人員檢查）

  1. 按照指示繼續執行測試。

如需詳細資料，請參閱疑難排解指南

上次修改時間：

2016 年 01 月 06 日

第一版


SCPI 錯誤

SCPI 錯誤

  • -100 至 -200 命令錯誤

  • -200 至 -299 執行錯誤

  • -300 至 -399 特定於指定裝置的 SCPI 錯誤

  • -400 至 -800 查詢和系統錯誤

  • 100 至 200 特定於 VNA 的錯誤

另請參閱

VNA 錯誤訊息。

-100 至 -200 命令錯誤

命令錯誤指示測試測試裝置的 GPIB 剖析器偵測到了 IEEE 488.2 語法錯誤。當產生其中一種錯誤時，系統將在事件狀態暫存器中設定命令錯誤位元。

-100 | std_command | 命令 - 此事件位元（位元 5）指示語法錯誤或語意錯誤，或指示輸入了 GET 命令，請參閱「IEEE 488.2, 11.5.1.1.4」。
-101 | std_invalidChar | 字元無效 - 指示語法元素包含對該類型無效的字元。
-102 | std_syntax | 語法 - 指示遇到了無法識別的命令或資料類型。例如，收到了一個字串，但裝置不接受字串。
-103 | std_invalidSeparator | 分隔符號無效 - 剖析器要求輸入分隔符號，並遇到了非法字元。例如，程式訊息單元後的分號被省略。
-104 | std_wrongParamType | 資料類型 - 剖析器識別到與所允許類型不同的資料。例如，要求輸入數字或字串，但遇到了區塊資料。
-105 | std_GETNotAllowed | 不允許使用 GET - 指示已收到的程式訊息包含群組執行觸發程序。請修正程式，以便 GET 不會出現在程式碼中。
-108 | std_tooManyParameters | 不允許使用參數 - 指示標頭中收到的參數超過了預期數目。例如，*ESE 常用命令僅接受一個參數，因此不允許使用 *ESE 0,1。
-109 | std_tooFewParameters | 缺少參數 - 指示標頭中收到的參數少於所需的數目。例如，*ESE 需要一個參數，不允許使用 *ESE。
-110 | std_cmdHeader | 命令標頭 - 指示在標頭中偵測到了錯誤。當裝置無法偵測到更具體的錯誤（-111 至 -119）時，將使用此錯誤。
-111 | std_headerSeparator | 標頭分隔符號 - 指示在剖析標頭時遇到了並非合法標頭分隔符號的字元。
-112 | std_IDTooLong | 程式助憶鍵過長 - 指示標頭包含的字元超過十二個，請參閱「IEEE 488.2, 7.6.1.4.1」。
-113 | std_undefinedHeader | 未定義的標頭 - 指示標頭在語法上是正確的，但未定義用於此特定裝置。例如，*XYZ 未定義用於任何裝置。
-114 | std_suffixOutOfRange | 標頭尾碼超出範圍 - 指示附加至程式助憶鍵的標頭尾碼的值令標頭無效。
-120 | std_numericData | 數字資料 - 此錯誤及錯誤
-121 | std_invalidCharInNumber | 數字中的字元無效 - 指示遇到了對正在剖析的資料類型無效的字元。例如，在十進位數值中找到 alpha，或在六進位資料中找到「9」。
-123 | std_exponentTooLarge | 指數過大 - 指示指數的量值大於 32000，請參閱「IEEE 488.2, 7.7.2.4.1」。
-124 | std_decimalTooLong | 位數過多 - 指示除了前置的零之外，小數數值資料元素的尾數包含超過 255 位數，請參閱「IEEE 488.2, 7.7.2.4.1」。
-128 | std_numericNotAllowed | 不允許使用數值資料 - 指示收到了合法的數值資料元素，但裝置不接受在標頭的此位置使用數值。
-130 | std_suffix | 尾碼 - 此錯誤及錯誤 -131 至 -139 是在剖析尾碼時產生的。當裝置無法偵測到更具體的錯誤時，將使用此特定錯誤訊息。
-131 | std_badSuffix | 尾碼無效 - 指示尾碼未遵循「IEEE 488.2, 7.7.3.2」中所述的語法，或者該尾碼不適用於此裝置。
-134 | std_suffixTooLong | 尾碼過長 - 指示尾碼包含的字元超過 12 個，請參閱「IEEE 488.2, 7.7.3.4」。
-138 | std_suffixNotAllowed | 不允許使用尾碼 - 指示在不允許使用尾碼的數值元素後遇到了尾碼。
-140 | std_charData | 字元資料 - 此錯誤及錯誤
-141 | std_invalidCharData | 字元資料無效 - 指示字元資料元素包含無效字元，或者收到的特定元素對標頭無效。
-144 | std_charDataTooLong | 字元資料過長 - 指示字元資料元素包含的字元超過十二個，請參閱「IEEE 488.2, 7.7.1.4」。
-148 | std_charNotAllowed | 不允許使用字元資料 - 指示在裝置禁止的位置遇到了合法的字元資料元素。
-150 | std_stringData | 字串資料 - 此錯誤及錯誤
-151 | std_stringInvalid | 字串資料無效 - 指示要求使用字串資料元素，但該字串資料元素無效，請參閱「IEEE 488.2, 7.7.5.2」。例如，在後引號字元前收到了 END 訊息。
-158 | std_stringNotAllowed | 不允許使用字串資料 - 指示遇到了字串資料，但裝置在剖析的此階段不允許使用字串資料。
-160 | std_blockData | 區塊資料 - 此錯誤及錯誤 -161 至 -169 是在剖析區塊資料元素時產生的。當裝置無法偵測到更具體的錯誤時，將使用此特定錯誤訊息。
-161 | std_badBlock | 區塊資料無效 - 指示要求使用區塊資料元素，但該區塊資料元素無效，請參閱「IEEE 488.2, 7.7.6.2」。例如，在滿足結束長度前收到了 END 訊息。
-168 | std_blockNotAllowed | 不允許使用區塊資料 - 指示遇到了合法的區塊資料元素，但裝置在剖析的此階段不允許使用區塊資料元素。
-170 | std_expr | 運算式 - 此錯誤及錯誤 -171 至 -179 是在剖析運算式資料元素時產生的。當裝置無法偵測到更具體的錯誤時，將使用此特定錯誤訊息。
-171 | std_invalidExpression | 運算式無效 - 指示運算式資料元素無效，請參閱「IEEE 488.2, 7.7.7.2」。例如，括號不相符或字元不合法。
-178 | std_exprNotAllowed | 不允許使用運算式資料 - 指示遇到了合法的運算式資料，但裝置在剖析的此階段不允許使用運算式資料。
-180 | std_macro | 巨集 - 此錯誤及錯誤 -181 至 -189 是在定義或執行巨集時產生的。當裝置無法偵測到更具體的錯誤時，將使用此特定錯誤訊息。
-181 | std_validOnlyInsideMacro | 無效，超出巨集定義範圍 - 指示遇到了超出巨集定義範圍的巨集參數預留位置。
-183 | std_invalidWithinMacro | 在巨集定義範圍內無效 - 指示隨 *DDT 或 *DMC 命令傳送的程式訊息單元序列在語法上無效，請參閱「IEEE 488.2, 10.7.6.3」。
-184 | std_macroParm | 巨集參數 - 指示處於巨集定義範圍內的命令所包含的參數數目或類型錯誤。

-200 至 -299 執行錯誤

這些錯誤是在儀器於目前狀態下發生不正確事件時產生的。這些錯誤可能是由從遠端或手動介面執行的使用者動作產生的。

-200 | std_execGen | 執行 - 此事件位元（位元 4）指示跟在標頭後的程式資料元素超出合法的輸入範圍，或者與裝置的功能不一致，請參閱「IEEE 488.2, 11.5.1.1.5」。
-201 | std_invalidWhileInLocal | 在本機時無效
-202 | std_settingsLost | 由於 rtl 而使設定遺失
-203 | std_commandProtected | 命令受保護 - 指示無法執行合法且受密碼保護的程式命令或查詢，因為命令已停用。
-210 | std_trigger | [Trigger]
-211 | std_triggerIgnored | 觸發被忽略
-212 | std_armIgnored | 接通被忽略
-213 | std_initIgnored | 啟動被忽略
-214 | std_triggerDeadlock | 觸發死結
-215 | std_armDeadlock | 接通死結
-220 | std_parm | 參數 - 指示發生了與程式資料元素相關的錯誤。
-221 | std_settingsConflict | 設定衝突 - 指示剖析了合法的程式資料元素，但目前的裝置狀態導致無法執行該資料元素。
-222 | std_dataOutOfRange | 資料超出範圍 - 指示剖析了合法的程式資料元素，但由於解譯的值超出裝置所定義的合法範圍，因此無法執行該資料元素。
-223 | std_tooMuchData | 資料過多 - 指示收到了類型為區塊、運算式或字串的合法程式資料元素，但裝置的記憶體容量或相關特定於裝置的需求導致資料元素所包含的資料量超出了裝置的處理能力。
-224 | std_illegalParmValue | 參數值不合法 - 指示所選的值不是給定值清單的一部分。
-225 | std_noMemoryForOp | 記憶體不足 - 裝置的記憶體不足以執行要求的作業。
-226 | std_listLength | 清單長度不相同 - 已嘗試使用的清單結構所包含的各清單長度均不相同。
-230 | std_dataCorruptOrStale | 資料損毀或過時 - 指示資料無效，自上次存取開始已啟動了新的讀取作業，但尚未完成。
-231 | std_dataQuestionable | 資料可疑 - 指示量測準確度不可信。
-232 | std_invalidFormat | 格式無效
-233 | std_invalidVersion | 版本無效 - 指示剖析了合法的程式資料元素，但由於資料版本對該裝置來說不正確，因此無法執行該資料元素。例如，不受支援的檔案版本、不受支援的儀器版本。
-240 | std_hardware | 硬體 - 指示由於裝置存在硬體問題而無法執行合法的程式命令或查詢。
-241 | std_hardwareMissing | 缺少硬體 - 指示由於缺少裝置硬體而無法執行合法的程式命令或查詢。例如，未安裝某個選件。
-250 | std_massStorage | 大量儲存裝置 - 指示發生了大量儲存裝置錯誤。裝置無法為錯誤 -251 至 -259 偵測到描述更具體的錯誤。
-251 | std_missingMassStorage | 缺少大量儲存裝置 - 指示由於缺少大量儲存裝置而無法執行合法的程式命令或查詢。
-252 | std_missingMedia | 缺少媒體 - 指示由於缺少媒體而無法執行合法的程式命令或查詢。例如，無磁碟。
-253 | std_corruptMedia | 媒體損毀 - 指示由於媒體損毀而無法執行合法的程式命令或查詢。例如，磁碟損毀或格式錯誤。
-254 | std_mediaFull | 媒體已滿 - 指示由於媒體已滿而無法執行合法的程式命令或查詢。例如，磁碟已無可用空間。
-255 | std_directoryFull | 目錄已滿 - 指示由於目錄已滿而無法執行合法的程式命令或查詢。
-256 | std_fileNotFound | 找不到檔名 - 指示由於媒體上找不到該檔名而無法執行合法的程式命令或查詢。
-257 | std_fileName | 檔名 - 指示由於裝置媒體上的檔名錯誤而無法執行合法的程式命令或查詢。例如，已嘗試讀取或複製不存在的檔案。
-258 | std_mediaProtected | 媒體受到保護 - 指示由於媒體受到保護而無法執行合法的程式命令或查詢。例如，記憶卡上設定了寫入保護開關。
-260 | std_expression | 運算式
-261 | std_math | 運算式中的 數學運算
-270 | std_macroExecution | 巨集 - 指示發生了與巨集相關的執行錯誤。
-271 | std_macroSyntax | 巨集語法 - 指示依據「IEEE 488.2, 10.7.2」，由於巨集定義內存在語法錯誤而無法執行語法上合法的巨集程式資料序列。
-272 | std_macroExec | 巨集執行 - 指示由於巨集定義中存在某種錯誤而無法執行語法上合法的巨集程式資料序列，請參閱「IEEE 488.2, 10.7.6.3」。
-273 | std_badMacroName | 巨集標籤不合法 - 指示巨集標籤不被接受，因為其與「IEEE 488.2, 10.7.3」中的定義不符
-274 | std_macroPlaceholderMa | 巨集參數 - 指示巨集定義未正確使用巨集參數預留位置，請參閱「IEEE 488.2, 10.7.3」。
-275 | std_macroTooLong | 巨集定義過長 - 指示由於區塊內容的字串長度超過了裝置的處理能力而無法執行語法上合法的巨集程式資料序列，請參閱「IEEE 488.2, 10.7.6.1」。
-276 | std_macroRecursion | 巨集遞迴 - 指示無法執行語法上合法的巨集程式資料序列，因為該資料序列將為遞迴式，請參閱「IEEE 488.2, 10.7.6.6」。
-277 | std_cantRedefineMacro | 不允許重新定義巨集 - 指示正在重新定義現有巨集標籤，請參閱「IEEE 488.2, 10.7.6.4」。
-278 | std_macroNotFound | 找不到巨集標頭 - 指示由於先前未定義標頭而無法執行使用 *GMS? 的合法巨集標籤，請參閱「IEEE 488.2, 10.13」。
-280 | std_program | 程式
-281 | std_cantCreateProgram | 無法建立程式
-282 | std_illegalProgramName | 程式名稱不合法
-283 | std_illegalVarName | 變數名稱不合法
-284 | std_programRunning | 程式目前正在執行
-285 | std_programSyntax | 程式語法
-286 | std_programRuntime | 程式執行階段
-290 | std_memoryUse | 記憶體使用情況
-291 | std_execOutOfMemory | 記憶體不足
-292 | std_nameNotFound | 參考名稱不存在
-293 | std_nameAlreadyExists | 參考名稱已存在
-294 | std_incompatibleType | 類型不相容

-300 至 -399 特定於指定裝置的 SCPI 錯誤

特定於裝置的錯誤指示儀器偵測到了由於某些作業無法正確完成而發生的錯誤，原因可能是硬體或韌體狀況出現異常。例如，當使用者嘗試設定超出範圍的值時，將會產生特定於裝置的錯誤。當產生其中一種錯誤時，系統將在事件狀態暫存器中設定特定於裝置的錯誤位元。

-300 | std_deviceSpecific | 特定於裝置 - 此事件位元（位元 3）指示由於出現某種情況（例如超出範圍）而無法正確完成裝置作業，請參閱「IEEE 488.2, 11.5.1.1.6」。
-310 | std_system | [System]
-311 | std_memory | 記憶體 - 指示裝置記憶體發生了某種實體故障，例如同位檢查錯誤。
-312 | std_PUDmemoryLost | PUD 記憶體遺失 - 指示藉由 *PUD 命令儲存的受保護使用者資料已遺失，請參閱「IEEE 488.2, 10.27」。
-313 | std_calMemoryLost | 校準記憶體遺失 - 指示 *CAL? 命令所使用的非易失性校準資料已遺失，請參閱「IEEE 488.2, 10.2」。
-314 | std_savRclMemoryLost | 儲存/重新叫用記憶體遺失 - 指示藉由 *SAV 命令儲存的非易失性資料已遺失，請參閱「IEEE 488.2, 10.33」。
-315 | std_configMemoryLost | 組態記憶體遺失 - 指示裝置儲存的非易失性組態資料已遺失。
-320 | std_storageFault | 儲存故障 - 指示韌體在使用資料儲存時偵測到故障。這並不表示有任何大量儲存裝置元件出現了實體損壞或故障。
-321 | std_outOfMemory | 記憶體不足 - 內部作業所需的記憶體超過可用記憶體。
-330 | std_selfTestFailed | 自我測試失敗 - 指示裝置發生了特定錯誤訊息未涵蓋的問題。裝置可能需要維修。
-340 | std_calFailed | 校準失敗 - 指示在裝置校準期間發生了特定錯誤未涵蓋的問題。
-350 | std_queueOverflow | 佇列溢位 - 指示佇列中沒有空間且發生了錯誤，但未予以記錄。此代碼將輸入佇列，以取代導致錯誤的代碼。
-360 | std_comm | 通訊 - 這是裝置無法為錯誤 -361 至 -363 偵測到描述更具體的錯誤時的一般通訊錯誤。
-361 | std_parity | 程式訊息中的同位檢查 - 例如，在序列埠上收到資料時，同位檢查位元不正確。
-362 | std_framing | 程式訊息中的框架 - 例如，在序列埠上收到資料時，未偵測到停止位元（例如傳輸速率不符）。
-363 | std_inputBufferOverrun | 輸入緩衝溢位 - 序列埠上的軟體或硬體輸入緩衝區溢出了資料，這是由於步調不正確或不存在造成的。

-400 至 -800 查詢和系統錯誤

查詢錯誤的產生條件為：儀器的 GPIB 輸出佇列中的資料已遺失，或者正嘗試從輸出佇列讀取資料，而此時不存在輸出或沒有擱置的輸出。

-400 | std_queryGen | 查詢 - 此事件位元（位元 2）指示正在嘗試從輸出佇列讀取資料，而此時不存在任何輸出或沒有擱置的輸出，因為輸出佇列中的資料已遺失，請參閱「IEEE488.2, 11.5.1.1.7」。
-410 | std_interrupted | 查詢已中斷 - 指示測試裝置已被新的程式訊息中斷，未能完成回應訊息傳送，請參閱「IEEE 488.2, 6.3.2.3」。
-420 | std_unterminated | 查詢未結束 - 指示程式中的某一查詢未完成，請參閱「IEEE 488.2, 6.3.2.2」。
-430 | std_deadlocked | 查詢已死結 - 指示輸入緩衝區和輸出佇列均已滿，請參閱「IEEE 488.2, 6.3.1.7」。
-440 | std_responseNotAllowed | 查詢在無限期回應後未結束 - 指示在執行了要求無限期回應的查詢後，在同一條程式訊息中收到另一個查詢，請參閱「IEEE 488.2, 6.5.7.5」。
-500 | std_powerOn | 開啟電源
-600 | std_userRequest | 使用者要求
-700 | std_requestControl | 要求控制
-800 | std_operationComplete | 作業完成
.

特定於 VNA 的 SCPI 錯誤（正錯誤）

100 | dupWindNum | 「視窗編號重複」
101 | windNumNotFound | 「找不到視窗編號」
102 | failedWindCreate | 「建立視窗失敗」
103 | noCalcParamSelection | 「CALC 量測選取範圍已設為無」
104 | dupMeasName | 「量測名稱重複」
105 | dataNotFound | 「要求的資料不可用」
106 | measNotFound | 「找不到要求的量測」
107 | traceNotFound | 「找不到要求的軌跡」
108 | notImplemented | 「未實作助憶鍵」
109 | noDocument | 「找不到量測容器」
110 | dupTraceNum | 「軌跡編號重複」
111 | titleStrTooLong | 「標題字串超過 50 個字元」
112 | memoryNotFound | 「找不到要求的記憶體」
113 | exceedMaxTraces | 「超過了每視窗軌跡數上限」
114 | SerNumNotFound | 「找不到序號，請儲存序號。」
115 | LoadFailed | 「狀態未載入，請檢查檔名。」
116 | StoreFailed | 「狀態未儲存，請檢查檔名和路徑名。」
117 | File | 「檔案作業中發生了 ，請檢查檔名和路徑名。」
118 | measChanConflict | 「量測不屬於指定的通道。」
119 | exceedMaxWindows | 「超過了資料視窗數上限」
120 | markerNotFound | 「找不到指定的標記。」
121 | Mnemonic | 「診斷。」
122 | channelNotFound | 「找不到指定的通道。」
123 | exceedMaxMeasurements | 「超過了允許的量測數上限。」
124 | parameterOutOfRange | 「指定的值超出範圍。」
125 | userRangeNotValid | 「目前選取的使用者範圍無效。」
126 | referenceMarkerNotFound | 「參考標記不在作用中。」
127 | sweepSegmentNotFound | 「找不到指定的掃略區段。」
128 | markerNotDelta | 「指定的標記不是差異標記。」
129 | printoutFailed | 「嘗試輸出至印表機失敗。」
130 | memory_trace_not_compatible | 「記憶體不相容，未套用軌跡數學運算。」
131 | trace_math_reset | 「記憶體不相容，軌跡數學運算已關閉。」
132 | hw_read_failed | 「硬體讀取失敗。」
133 | hw_write_failed | 「硬體寫入失敗。」
134 | dsp_active | 「由於 DSP 未中斷而失敗。」
135 | secure_memory | 「嘗試存取安全的記憶體區域。」
136 | snum_protected | 「序號受到保護。」
137 | snum_format_bad | 「序號格式錯誤。」
138 | snum_already_set | 「序號已設定。」
139 | hw_setting_failed | 「硬體設定失敗。」
140 | cal_access_failed | 「校準資料存取失敗。」
141 | db_access_failed | 「資料庫存取失敗。」
142 | memory_range_exceeded | 「命令超出可用記憶體範圍。」
143 | lost_phase_lock | 「相位鎖定已遺失。」
144 | over_power | 「輸入時偵測到過多功率。」
145 | ee_wrt_failed | 「EEPROM 寫入失敗。」
146 | yig_cal_failed | 「YTO 校準失敗。」
147 | ramp_cal_failed | 「類比斜波校準失敗。」
148 | dspcom_bad | 「DSP 通訊失敗。」
149 | no_license_found | 「要求失敗。找不到所需授權。」
150 | argLimited | 「引數超出範圍
151 | markerBWNotFound | 「找不到標記頻寬。」
153 | peakNotFound | 「找不到峰值。」
154 | targetNotFound | 「找不到目標搜尋值。」
155 | calNotImpl | 「未實作要求的校準功能。」
156 | calClassNotValidForCalType | 「SENS:CORR:CCH 量測選取範圍已設為無」
158 | calNotValidForConfidenceChe | 「選定的量測不包含對可信度檢查有效的校準」
159 | invalidPort | 「指定的連接埠超出範圍」
160 | invalidPortPath | 「ROUT:PATH:DEF:PORT x, y 與量測不相符；does not match measurement;正設定為預設值」
161 | ioInvalidWrite | 「在連接埠設定為唯讀的情況下嘗試了 I/O 寫入。」
162 | ioInvalidRead | 「從唯寫連接埠嘗試了 I/O 讀取。」
163 | calsetNotFound | 「在校準集儲存中找不到要求的校準集。」
164 | noCalSetSelected | 「目前沒有為指定的通道選取校準集。」
165 | cantDeleteCalSetInUse | 「無法刪除正在使用的校準集。」
166 | calsetStimChange | 「通道激勵設定已變更為與選定的校準集相匹配。」
167 | exceedMaxCalSets | 「超過了校準集數上限。」
168 | calCouldNotTurnOn | 「需要執行有效的校準才能開啟修正。」
169 | standardMeasurementRequired | 「所嘗試的操作只能對標準量測類型執行。」
170 | noDivisorBuffer | 「需要有效的除數緩衝區，才能開啟正規化。」
171 | InvalidReceiverPowerCalParagraph | 「接收器功率校準需要量測具有無比例功率。」
172 | ecalCouldNotConfigure | 「無法設定電子校準系統。請檢查該模組是否已插入正確的接頭。」
173 | measHasNoMemoryAlg | 「此量測不支援記憶體作業」
174 | measHasNoNormalizeAlg | 「此量測不支援正規化作業。」
175 | userCharacterizationNotFound | 「在電子校準模組中找不到使用者特性化。」
176 | measInvalidBufferSize | 「提供的資料點數無效，無法儲存該資料。」

上次修改時間：

2009 年 08 月 04 日

美觀性修改


技術支援

如需有關聯絡資訊的資料，請造訪 http://www.keysight.com/find/contactus

上次修改時間：

2016 年 01 月 06 日

第一版


授權

  • 開放來源軟體授權

  • 商業軟體授權

開放來源軟體授權

JPEG 軟體套件

此軟體的一部分由 Independent JPEG Group（獨立 JPEG 小組）開發。 您可以在「c:\opensource」目錄中找到授權合約的複本。

商業軟體授權

MathWorks MATLAB Complier Runtime v7.14

MathWorks MATLAB Compiler；您（授權持有人）與 MatLab 達成的授權合約規定了 MatLab MCR 資料庫的使用權限。 您可以在「c:\thirdparty software」目錄中找到授權合約的複本。」


顯示器測試

VNA 畫面應明亮，所有註解和文字均清晰可讀。顯示測試可讓您檢查哪些像素無法正常運作及其他問題。

什麼是損壞的像素？

像素即圖片元素，合併多個圖片元素可在顯示器上建立影像。其大小相當於一個小針尖。損壞的像素可能顯示為「卡住」或「深色」。

  • 無論顯示設定為何，卡住的像素（紅色、綠色或藍色）始終會顯示，且在深色背景中可見。

  • 深色像素（始終為深色）與其自身的背景形成對比。

如何執行顯示測試

按下 [System] > Service（服務）> Display Test（顯示測試）

將顯示一個多色彩畫面。請準備好查找如下所述的症狀。按一下開始測試按鈕。請按一下正在移動的「下一個測試」按鈕繼續下一個測試。此按鈕會移動，以便您可以查看顯示的所有內容。測試完成後，顯示器會還原為網路分析儀畫面的預設值。

如何識別發生故障的顯示器

有效像素為 99.998 % 及以上。出現低於 0.002 % 的黑色、藍色、綠色或紅色固定點並不表示故障。

如果發生上述任一症狀，則將您的顯示器視為發生故障。請參閱適用於您的 VNA 模型的維修指南。


系統驗證

網路分析儀的效能透過以下兩種方式指定：系統規格及儀器規格。一般使用者有責任確定適用於其 VNA 使用的規格集。

網路分析儀量測「系統」包括分析儀、校準套件、測試纜線以及任何必要的配接器。VNA 中的系統驗證軟體用於驗證系統是否符合「系統」規格。如果結果為「通過」，則證明分析儀、測試纜線以及配接器能夠作為一個系統正確執行。但是結果並不能證明任何元件都根據其各自的規格執行。對此量測系統的任意零件進行更新，都需要對系統進行重新驗證。

儀器規格可指定網路分析儀的未修正量測連接埠特性及其輸出與輸入行為。VNA 效能測試用於驗證分析儀是否符合「儀器」規格。

系統驗證公用程式可透過以下方法驗證 VNA 系統規格：自動量測每台驗證裝置全部四個 S 參數的幅度和相位，並將量測所得的值與以下資料相較：

  • 驗證媒體上的檔案中的出廠量測資料。

  • 基於量測不確定性的限制線。

系統驗證需要使用校準套件和驗證套件，該套件已在過去 12 個月內獲得 Keysight 的認證。系統驗證不能用於執行此套件認證。

還應執行作業人員檢查，以驗證 VNA 的基本作業。

  • 在系統驗證過程中使用的設備

  • 處理空氣線時的預防措施

  • 程序的流程圖

  • 系統驗證的程序

  • 如果系統未通過驗證測試

  • 解譯驗證結果

附註

  • 雖然會量測所有 S 參數的效能，但 S 參數相位的不確定性對系統效能驗證並非那麼重要。因此，限制線不會出現在列印品上。

  • 不能在啟用了多連接埠測試的情況下執行系統驗證。

在系統驗證過程中使用的設備

支援的驗證套件：

  • 85053B，3.5 mm，300 kHz - 26.5 GHz

  • 85055A，N 型，300 kHz - 18.0 GHz

  • 85,051B，7 mm，300 kHz - 18 GHz

校準套件和驗證套件的組合

可根據下方表格使用校準套件和驗證套件的組合：

校準套件 | 接頭 | 套件類型 | 驗證套件 | 最小頻率 | 最大頻率
85033D | 3.5 mm | 機械 | 85053B 或 Anritsu 3666 | - | 6 GHz
85033E | 3.5 mm | 機械 | 85053B 或 Anritsu 3666 | - | 9 GHz
85052D | 3.5 mm | 機械 | 85053B 或 Anritsu 3666 | - | 26.5 GHz
85052C | 3.5 mm | 機械 | 85053B 或 Anritsu 3666 | - | 26.5 GHz
85093B | 3.5 mm | ECal** | 85053B 或 Anritsu 3666 | 300 kHz | 9 GHz
85093C | 3.5 mm | ECal** | 85053B 或 Anritsu 3666 | 300 kHz | 9 GHz
N4433A | 3.5 mm | ECal** | 85053B 或 Anritsu 3666 | 300 kHz | 20 GHz
N4691A | 3.5 mm | ECal** | 85053B 或 Anritsu 3666 | 10 MHz | 26.5 GHz
N4691B | 3.5 mm | ECal** | 85053B 或 Anritsu 3666 | 300 kHz | 26.6 GHz
85032B/E | N 型 | 機械 | 85055A | - | 6 GHz
85032F | N 型 | 機械 | 85055A | - | 9 GHz
85054D | N 型 | 機械 | 85055A | - | 18 GHz
85092B | N 型 | ECal** | 85055A | 300 kHz | 9 GHz
85092C | N 型 | ECal** | 85055A | 300 kHz | 9 GHz
N4432A | N 型 | ECal** | 85055A | 300 kHz | 18 GHz
N4690A | N 型 | ECal** | 85055A | 10 MHz | 18 GHz
N4690B | N 型 | ECal** | 85055A | 300 kHz | 18 GHz
85031B | APC-7mm | 機械 | 85,051B 或 Anritsu 3667 | - | 6 GHz
85050C | APC-7mm | 機械 | 85,051B 或 Anritsu 3667 | - | 18 GHz
85050D | APC-7mm | 機械 | 85,051B 或 Anritsu 3667 | - | 18 GHz
85091B | APC-7mm | ECal** | 85,051B 或 Anritsu 3667 | 300 kHz | 9 GHz
85091C | APC-7mm | ECal** | 85,051B 或 Anritsu 3667 | 300 kHz | 9 GHz
N4696A | APC-7mm | ECal** | 85,051B 或 Anritsu 3667 | 10 MHz | 18 GHz
N4696B | APC-7mm | ECal** | 85,051B 或 Anritsu 3667 | 300 kHz | 18 GHz
N4431A* | 3.5 mm | ECal** | 85053B | 300 kHz | 9 GHz
N4431B* | 3.5 mm | ECal** | 85053B | 9 kHz | 13.5 GHz
N4431A* | N 型 | ECal** | 85055A | 300 kHz | 9 GHz
N4431B* | N 型 | ECal** | 85055A | 9 kHz | 13.5 GHz

* N4431x 的連接用於直通路徑 A-B、C-D、A-D 和 B-C。

** 支援的接頭類型是「公-母」（可插入型）。對於非插入式 Ecal 模組，您可以透過 1&2 或 3&4 連接埠集從總管載入校準檔案（*.csa 或 *.cst）。

纜線替代

指定用於 VNA 的測試連接埠纜線已從以下方面進行了特性化：接頭可重複性、幅度和相位穩定性、彈性、回波損耗、插入損耗以及老化率。由於測試連接埠纜線效能是系統效能的重要影響因素，因此效能較低的纜線會提高量測的不確定性。強烈建議定期對測試連接埠纜線進行測試。

如果使用非 Keysight 纜線執行系統驗證，請確保該纜線滿足或超出指定纜線的操作規格。如需有關規格的資訊，請參閱纜線的使用者指南。

纜線彈性因數

彈性因數決定了確定限制線時應考量在內的纜線相位不確定性。

  • 當使用固定裝置將纜線固定住並且不允許纜線在校準和驗證期間移動時，請設定為 0%（零）。

  • 當允許纜線移動較大幅度時，請設定為 100%。

校準套件替代

不建議使用非 Keysight 校準套件，此類校準套件不受支援。

處理空氣線時的預防措施

在驗證套件中使用空氣線時，請遵循以下做法以確保採用合適的量測技術。

  • 請保持謹慎，不要將空氣線的中心導體或外部導體掉落。如果掉落，會導致這些裝置損壞。

  • 採用適當的靜電放電 (ESD) 程序。

  • 清潔雙手或佩戴手套，因為皮膚上的油脂會使電氣效能發生變化。

程序的流程圖

下方所示的流程圖繪製了軟體的作業流程。

系統驗證的程序

  1. 如果要列印測試輸出品，請將印表機連接至分析儀。讓分析儀暖機至少 90 分鐘。

  2. 將 VNA 驗證套件隨身碟插入 VAN USB 連接埠。

  3. 按一下 [System] > Service（服務）> System Verification（系統驗證）。此時將顯示與下方類似的「系統驗證」視窗。

系統驗證對話方塊

  4. 在校準套件方塊中，選取校準套件或正在使用的 ECal 模組。要使用的對應驗證套件會顯示於驗證套件方塊中。

  5. 在印表機輸出下，按一下以下任一選項。

    • 列印表格資料： 以表格格式列印包括量測的資料以及不確定性限制在內的驗證資料。請參閱本主題中稍後所示的表格資料範例。

    • 列印圖形： 以圖形格式列印驗證資料。圖形格式包括量測的資料軌跡、出廠提供的資料軌跡以及不確定性限制。請參閱本主題稍後所示的繪圖資料範例。

    • 檔案表格資料： 以表格格式將驗證資料寫入至 c:\users\public\network analyzer\documents 目錄中的文字檔案。

    • 檔案圖形： 以 .PNG 格式將畫面影像儲存至 c:\users\public\network analyzer\documents 目錄中。

附註： 如果要列印輸出，則假設您已安裝適用於您特定印表機的 Windows 驅動程式，並已通過測試可從網路分析儀透過該印表機進行列印。此軟體專為用於透過目前設定為預設印表機（請參閱 Windows 控制台中的印表機）的任何印表機進行列印而設計。

  6. 若要修改要驗證的連接埠的數目，或變更要量測之裝置的數目，或者要使用先前儲存的驗證校準，請按一下設定標籤，然後進行所需的選取。

    • 要使系統驗證完全適當，軟體必須在套用最新校準的情況下，量測該套件中的所有裝置。移除並重新連接任意測試連接埠纜線或配接器會讓所有先前的校準失效。

  7. 按一下執行。

  8. 按照分析儀上的指示執行系統驗證，並按提示插入驗證裝置。

對於 4 連接埠 VNA 的注意事項：
系統驗證程序會重複執行兩次。執行第一次時，連接埠 1 與 2 作為一對進行量測，然後再量測連接埠 3 與 4。

逐步程序說明

  1. 視「設定」功能表的「校準」子功能表中選取的選項，會提示使用者重新叫用先前校準的儀器狀態，或引導使用者使用選取的校準套件完成全 2 連接埠校準。對於 ECal，ECal 模組僅連接一次；當軟體正在執行校準時，會發佈待命訊息。

  2. 提示使用者連接第一個驗證裝置。

  3. 軟體從驗證套件提供的媒體讀取該裝置的出廠量測資料及該資料 (CITIfiles) 的不確定性值。

  4. 軟體將出廠量測資料、校準套件以及儀器狀態資訊傳送至不確定性計算機 DLL，後者稍後會生成特定 VNA 的不確定性值。

  5. 分析儀首先設定全部四個 S 參數的幅度量測，每個參數設定在單獨的視窗中（lin mag 用於 S11 和 S22，log mag 用於 S21 和 S12）。每個出廠量測的 S 參數都會作為記憶體軌跡提供給相應的視窗。限制線偏移計算為出廠量測資料不確定性與 DLL 報告的 VNA 不確定性的總和。上限（出廠量測資料加不確定性總和）和下限（出廠量測資料減不確定性總和）都會顯示。VNA 會進行掃描並開啟限制測試，然後在四個視窗中分別報告通過/未通過狀態。

  6. 使用者在準備好檢視相位量測時按一下某個按鈕。會更新四個視窗以顯示相位格式，相位記憶體軌跡、相位限制以及通過/未通過結果。

  7. 如果四個 S 參數（幅度和相位）中任意一個參數的限制測試指示未通過狀態，則軟體會建議疑難排解提示，並詢問使用者是要重複量測裝置還是要繼續量測下一個裝置。如果繼續量測下一個裝置，則會從 USB 記憶體讀取下一個裝置的出廠量測資料和不確定性，然後不確定性 DLL 會叫用下一組出廠量測資料，接著會更新四個量測視窗以顯示下一台裝置的幅度量測。

  8. 軟體會遵循此相同程序直到量測完所有選取的裝置為止，然後顯示摘要視窗，其中包括每台裝置全部四個參數的通過/未通過結果集。

如果系統未通過驗證測試

重要說明： 檢查所有連線。請勿從分析儀測試連接埠拔下纜線。這樣會使之前進行的校準失效。

  1. 請重複此驗證測試。以合適的扭力規格正確連線每個驗證裝置。

  2. 先中斷連接、清潔再重新連接未通過驗證測試的裝置。然後再次對該裝置進行量測。

  3. 如果分析儀仍然報告未通過測試，請檢查量測校準。

  4. 如需有關其他疑難排解步驟，請參閱下圖。

驗證失敗流程圖

解譯驗證結果

下圖顯示了在系統驗證視窗的印表機輸出區域中，選取了表格資料時的一般驗證結果範例。本主題中的下一個圖形顯示了在系統驗證視窗的印表機輸出區域中，選取了量測曲線時的一般驗證結果範例。這些列印品包括量測結果資料與可追蹤資料和相應不確定性規格的比較。使用這些列印品可確定量測而得的資料是否處於所有頻率的不確定性限制的範圍之內。

表格資料包含：

  • 資料點的頻率（以 MHz 為單位）。

  • 由總的系統不確定性規格定義的下限線。

  • 量測的結果。

  • 由總的系統不確定性規格定義的上限線。

  • 該量測點的測試狀態（通過/未通過）。

表格驗證結果的列印品

列印的圖形結果顯示以下資訊：

  • 由總的系統不確定性規格定義的上限點。

  • 由總的系統不確定性規格定義的下限點。

  • 出廠量測資料。

  • 量測的結果。

  • 量測參數名稱和格式（Lin Mag 或 Log Mag）。

  • 裝置的序號 (00810)。

  • 量測的裝置（Sys Ver 20 dB 衰減器）。

圖形驗證結果的列印品

上次修改時間：

2016 年 01 月 06 日

第一版


設定外部裝置

設定之後（如本主題所示），外部裝置便會出現在相關 VNA 對話方塊中，並可透過該對話方塊進行控制，就像是 VNA 內部裝置一樣。

  • 外部裝置組態對話方塊

下列（單獨）主題討論了如何設定這些類型裝置的內容：

  • 外部來源內容

  • 功率表作為接收器 (PMAR) 內容

  • 外部脈衝產生器屬性

外部裝置組態對話方塊

如何存取外部裝置組態對話方塊

VNA 應用程式還可透過其他方式啟動此對話方塊。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Setup] > External Hardware（外部硬體）> External Device...（外部裝置...）。

請參閱遠端指定來源連接埠

外部裝置組態對話方塊說明

重要附註：

  • 此對話方塊可用於設定下列類型的外部裝置：

    • 外部來源屬性（需要 FOM 選件）

    • 功率表作為接收器 (PMAR) 內容

    • 外部脈衝產生器屬性

  • 若要使用此對話方塊設定外部來源，VNA 必須具有 FOM 選項。如果沒有此選項，您必須手動控制外部來源。如需手動控制來源的相關說明，請參閱同步外部來源。

  • 依預設，預設 VNA 或重新叫用儀器狀態時，外部裝置會停用。使用偏好設定可變更此行為，以便該裝置在預設或重新叫用儀器狀態期間保持作用中。

  • 外部裝置內容不會儲存在儀器狀態檔案中。但是，從相關 VNA 對話方塊對外部裝置的參考會予以儲存。因此，重新叫用狀態檔案時，如果狀態檔案參考的裝置不存在，則會導致「找不到裝置組態」錯誤。

  • 同一個實體裝置的多個組態皆可處於作用中狀態。但是，對於同一個外部來源，只有一個組態可啟用 I/O。

外部裝置

目前已設定的裝置會出現在此清單中。可設定的裝置數目受指定的介面限制。

新增 - 按一下可建立新的裝置組態。預設名稱為 Device<n>，其中 <n> 是下一個裝置編號。

移除 - 按一下可從清單中移除所選裝置。

屬性

名稱 - 輸入裝置名稱，在 VNA 對話方塊中參考此裝置時會顯示該名稱。可隨時編輯名稱。但是，不允許使用重複的名稱。

  • 由於外部裝置可與 FOM 範圍搭配使用，因此，請不要將外部裝置命名為以下任何 FOM 範圍名稱：「primary」、「receivers」或「source」、「source1」、「source2」等。暸解有關 FOM 範圍的詳細資訊。

  • 請勿使用參數名稱，如「S11」或「R1」。

裝置類型 - 選取下列類型之一：

  • 功率表 (PMAR) - 深入暸解

  • 脈衝產生器 - 僅支援 Keysight 81110A 脈衝產生器。暸解詳細資訊

  • 來源 (RF) - 深入暸解

  • 無 - 設定裝置類型之前已遠端傳回。

驅動程式 - 選取要設定的適當模型。

（AG 是 Keysight 的簡稱）。

對於功率表裝置類型，驅動程式會自動選擇 AGPM。

對於來源裝置類型，請從下列清單中選擇驅動程式：

  • AG836XX（8360 和 8340）

  • AGESG (ESG)

  • AGEXG (EXG) 請參閱組態附註。

  • AGGeneric - 針對未列出但可透過 SCPI 進行控制的來源。按一下「裝置內容」，然後按一下「編輯指令」將指令傳送到這些來源。瞭解詳細資訊。

  • AGMXG (MXG) - MXG 必須至少具有 A.01.44 版本韌體，才能使 FOM 功率掃掠正常運作。

  • AGPSG (PSG)

  • HP834XX

附註：任何裝置類型都只有一個驅動程式。

作用中 - 在 UI 中顯示 - 勾選後便可在相關對話方塊中使用裝置。在裝置處於作用中狀態（已勾選）時儲存的儀器狀態會在狀態檔案中包含該裝置。否則，如果清除「作用中」方塊，裝置將不會出現在狀態檔案中。暸解有關儀器狀態檔案的詳細資訊。

裝置內容 - 按一下可針對相關裝置類型啟動「內容」對話方塊。

  • 設定外部來源

  • 將功率表設定為接收器

  • 設定外部脈衝產生器

IO 組態

介面 - 選取用於將裝置連接到 VNA 的介面。這些裝置隨後將出現在「可用」欄位中。選擇範圍：

  • GPIB - 連接到系統控制器 GPIB 連接埠的裝置。

  • USB - 連接到 VNA USB 連接埠的裝置。請參閱首次 USB 連接重要注意事項。

  • 別名 - 連接到任何介面且為其建立了別名的裝置。請參閱設定別名和 LAN 裝置。

  • LAN - 使用 LAN 連線來連線到網路的裝置。VNA 也必須連線至網路。

附註：連接到 LAN 的裝置必須先在 Keysight IO 程式庫中設定，然後才會出現在可用清單中。請參閱設定別名和 LAN 裝置。

可用 - 顯示連接到指定 IO 介面的裝置清單。

重新整理 - 按一下可重新掃描指定介面的裝置。

已選取 - 輸入 IO 組態或從找到的 IO 介面可用清單中進行選取。

啟用 I/O - 清除此方塊可停用與所選裝置的通訊。執行此操作可設定尚未連接到 VNA 的裝置。

  • 勾選啟用 I/O、勾選作用中以及按下確定時，將嘗試與裝置通訊。

  • 嘗試通訊時，系統會針對勾選了啟用 I/O 的裝置查詢選取的限制，如頻率、功率和點數。如果存在限制問題，則 VNA 會傳送錯誤並且受影響的通道將置於保持狀態。這些限制由設定它們所在的對話方塊強制執行。解決報告的限制問題，然後還原觸發。

  • 如果與裝置通訊中斷，則受影響的通道將置於保持狀態。

設定別名和 LAN 裝置

使用此程序可設定使用 LAN 介面的裝置。亦可用於想要為其設定（易於辨識的）別名的任何裝置。將別名選取作為介面時，別名會出現在「可用」欄位中。

  1. 在 VNA 上，將 VNA 應用程式最小化（[System] > Main（主要）> Minimize Application（最小化應用程式））。

  2. 在系統匣（右下角）的 IO 圖示上按一下滑鼠右鍵，然後按一下 Keysight Connection Expert。

新增 LAN 裝置：

  1. 在 Keysight Connection Expert 中，按一下 [image] 。

  2. 選取「新增 LAN 儀器 (TCPIP0) 或 USB0」，然後按一下確定。

  3. 按一下新增位址並輸入外部來源的 IP 位址。

  4. 按一下測試連線以確認通訊。

  5. 按一下確認。

為已連接的裝置建立別名：

  1. 在已連接儀器清單中，於外部來源上按一下滑鼠右鍵，然後按一下新增 VISA 別名。

  2. 輸入曾在或將在外部裝置組態對話方塊中使用的同一個裝置名稱。

上次修改時間：

2016 年 01 月 06 日

第一版


外部來源組態

設定之後，外部來源會像內部來源一樣出現在 VNA 對話方塊中。此功能需要使用頻率偏移模式 (FOM) 選項 009。

在本主題中：

  • 如何設定外部來源

  • 外部來源組態對話方塊

  • 觸發設定和實體連接圖表

  • 一般來源指令對話方塊

設定外部來源

如何設定外部來源

重要說明：依名稱建立外部來源裝置（一次性）。瞭解詳細資訊。（單獨主題）

VNA 應用程式還可透過其他方式啟動此對話方塊。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Setup] > External Hardware（外部硬體）> External Device...（外部裝置...）。

  2. 按一下裝置內容以設定外部來源。

請參閱遠端指定來源連接埠

外部來源組態對話方塊說明

此對話方塊可用於進行外部來源設定。

關於外部來源的重要附註

  • 首先依名稱建立外部來源（裝置）（一次性）。暸解方法。（單獨主題）

  • 一旦透過設定外部裝置對話方塊建立和啟動外部來源，您便可以從下列 VNA 對話方塊以及軟鍵和項目工具列使用外部來源，正如使用內部 VNA 來源一般。

使用下列對話方塊設定外部 RF 來源的狀態、頻率和功率位準：

    • 功率和衰減器對話方塊

    • FOM 對話方塊

    • 新增軌跡/接收器索引標籤對話方塊

  • 依預設，預設 VNA 或重新叫用儀器狀態時，外部來源會停用。此行為可透過偏好設定進行變更。

  • 外部 Keysight 來源通常限制為 1601 個點，而且使用清單掃掠模式。若要「解決」此限制，請將量測劃分到多個通道。例如，若要掃掠 3200 個點，請建立兩個各含 1600 個點的通道。您也可以使用支援步進掃掠模式的手動來源控制。在此模式下，外部來源最多可以具有 65,535 個點。如需手動控制來源的相關說明，請參閱同步外部來源。

  • 外部來源應始終與 VNA 共用相同的 10 MHz 參考訊號。將 BNC 纜線從 VNA 10 MHz 參考輸出連接到外部來源輸入。

  • 已預設所有新啟動的來源，並且來源功率關閉。來源功率必須在功率對話方塊中開啟。 頻率偏移必須在 FOM 對話方塊中啟用。

  • 同一個來源在同一通道中不能使用一次以上。

  • VNA 會自動控制外部來源的所有觸發設定。

  • 請參閱 EXG 來源組態附註。

來源設定

逾時（秒） - 設定來源與 VNA 聯絡所用的時間限制。如果超過此時間限制，VNA 會停止量測程序並顯示下列錯誤訊息。

執行錯誤；OPC 查詢逾時錯誤：頻率不穩定

如果出現此錯誤，請檢查 VNA 和外部來源之間的連線。

每點停頓時間 (ms) - 僅在硬體清單觸發中套用停頓。設定外部來源在擷取資料前等待的時間（以毫秒為單位）。

編輯指令 - 提供將 SCPI 指令傳送至 AGGeneric（未列出）來源的方法。

觸發設定和實體連接圖表

附註：VNA 會自動控制所有外部來源觸發設定（此對話方塊上的設定除外）。外部觸發對話方塊中的所有設定都會被忽略。

觸發模式

軟體 CW (GPIB) - 最慢方法。

  • 外部來源透過 GPIB、USB 或 LAN 接收來自 VNA 的每個 CW 頻率。不需要其他觸發纜線。儘管可以選擇觸發連接埠，但未使用此功能。

硬體清單 (BNC) - 最快方法。

  • 不適用於 AGGeneric（未列出）來源。

  • 外部來源會從 VNA 接收 CW 頻率清單，然後在適當的時候透過後面板接頭接收來自 VNA 的觸發訊號。

  • 如果用於量測的資料點數超過外部來源的容量，則 VNA 會自動切換至軟體 CW (GPIB) 觸發模式。這會顯著降低量測速度。

  • 使用菊花鏈將多個來源連接起來時，從 VNA 接收觸發訊號的來源必須是「外部裝置組態」對話方塊的已選取欄中列出的第一個來源。裝置依其建立順序列出。若要在清單中向下移動來源，您可能需要刪除再重新建立來源。

觸發連接埠 - 僅用於硬體清單觸發模式。選取要用於觸發的 VNA 後面板接頭。來源必須按如下所示進行連接：

  • 對於一個外部來源，請直接使用輔助 1 或輔助 2 觸發對連接。請參閱後面板輔助接頭。

  • 對於多個來源，請根據下列菊花鏈影像連接。

備註：

  • 接收 VNA 觸發輸出的來源 1 必須是外部裝置組態對話方塊中列出的第一個來源。裝置依其建立順序列出。若要在清單中向下移動來源，您可能需要刪除再重新建立來源。

  • 按以下方式設定/轉換 EXG 來源：

EXG 後面板標籤 | 對於 VNA：
觸發 1 | 觸發輸入
觸發 2 | 觸發輸出

一般來源指令對話方塊說明

輸入控制 AGGeneric（未列出）來源上以下功能的 SCPI 指令。未輸入 SCPI 指令的欄位會予以忽略，而且相應的功能也不會設定。

附註：無法使用 SCPI 指令控制的舊訊號來源不受支援。

若要啟動此對話方塊，請按一下外部來源內容對話方塊上的編輯指令。

操作完成 (*OPC)

預設 - 預設來源。

設定 CW 頻率 - 設定 CW 頻率。

設定 CW 掃掠模式 - 設定來源掃掠模式。

設定功率 - 設定來源功率。

設定功率狀態 - 將功率開啟或關閉。

上次修改時間：

2016 年 01 月 06 日

第一版


將功率表設定為接收器

設定功率表作為接收器 (PMAR)

如果將功率表設定為 VNA 接收器（僅在標準量測通道中），您可以

  • 擴充量測接收器的數目

  • 將功率表用作純量偵測器

  • 在量測系統中的任何位置監控功率

  • 在引導式功率校準中使用多個功率表以涵蓋廣泛的頻率範圍

  • 使用功率表在量測系統中的任何位置調節激勵功率位準

  • 將功率感應器用作 PMAR 裝置以確認來源功率校準的準確度 暸解方法

設定之後，功率表便可像任何其他 VNA 接收器一樣在下列對話方塊中使用：

  • 新增軌跡/量測對話方塊 - 用於比例和無比例量測。

  • 接收器位準調整

  • 頻率偏移模式 - 擴充 VNA 頻率範圍

另請參閱

  • 支援的功率表

  • 關於第一次 USB 連線的重要附註

如何建立和設定 PMAR 裝置

VNA 應用程式還可透過其他方式啟動此對話方塊。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > External hardware（外部硬體）> External Device..（外部裝置..）。

  2. 依名稱建立 PMAR 裝置（一次性）。

  3. 按一下裝置內容以設定功率表/感應器。

外部裝置組態對話方塊說明

此對話方塊可讓您建立和設定供 VNA 用作接收器的功率表。一旦透過此對話方塊建立和設定功率表，您便可以從 VNA 對話方塊以及軟鍵和項目工具列使用該功率表，正如使用內部 VNA 接收器一般。

  • 此對話方塊還可用於設定外部來源。瞭解詳情。

  • 若要針對來源功率校準設定單一功率表，請使用功率表設定對話方塊。

重要附註：

  • 依預設，預設 VNA 或重新叫用儀器狀態時，外部 PMAR 裝置會停用。使用偏好設定可變更此行為，以便該裝置在預設或重新叫用儀器狀態期間保持作用中。

  • PMAR 組態不會儲存在儀器狀態檔案中。因此，重新叫用涉及已移除裝置的狀態檔案或重新叫用位於不同 VNA 上的狀態檔案，會導致「找不到裝置組態」錯誤。

外部裝置

目前已設定的裝置會出現在此清單中。可設定的裝置數目受指定的介面限制。

新增 - 按一下可建立新的 PMAR 組態。預設名稱為 Device<n>，其中 <n> 是下一個裝置編號。

移除 - 按一下可從清單中移除所選裝置。

屬性

名稱 - 輸入裝置名稱，在所有 VNA 對話方塊中涉及此裝置時會顯示該名稱。可隨時編輯名稱。不允許使用重複的名稱。

備註：

  • 由於外部裝置可與 FOM 範圍搭配使用，因此，請不要將外部裝置命名為以下任何 FOM 範圍名稱：「primary」、「receivers」或「source」、「source1」、「source2」等。暸解有關 FOM 範圍的詳細資訊。

  • 請勿使用參數名稱，如「S11」或「R1」。

裝置類型 - 選取功率表。

驅動程式 - 將 AGPM 用於所有 Keysight 功率表。請參閱支援的功率表

作用中 - 勾選後可在 FOM、「新增軌跡」和「接收器調節」對話方塊中使用裝置。在裝置處於作用中狀態（已勾選）時儲存的儀器狀態會在狀態檔案中包含該裝置。否則，如果清除「作用中」方塊，裝置將不會出現在狀態檔案中。

附註：同一個實體裝置的多個 PMAR 組態皆可處於作用中和啟用狀態。

裝置內容 - 按一下可啟動設定功率感應器對話方塊。

IO 組態

介面 - 選取用於將裝置連接到 VNA 的介面。這些裝置隨後將出現在「可用」欄位中。選擇範圍：

  • GPIB - 連接到系統控制器 GPIB 連接埠的裝置。

  • USB - 連接到 VNA USB 連接埠的裝置。 請參閱首次 USB 連接重要注意事項。

  • 別名 - 連接到任何介面且為其建立了別名的裝置。請參閱設定別名和 LAN 裝置。

  • LAN - 使用 LAN 連線來連線到網路的裝置。VNA 也必須連線至網路。附註： 連接到 LAN 的裝置必須先在 Keysight IO 程式庫中設定，然後才會出現在可用清單中。請參閱設定別名和 LAN 裝置。

可用 - 顯示連接到指定 IO 介面的裝置清單。

重新整理 - 按一下可重新掃描指定介面的裝置。

已選取 - 輸入 IO 組態或從找到的 IO 介面可用清單中進行選取。

啟用 I/O - 清除此方塊可停用與所選裝置的通訊。您執行此操作可設定尚未連接到 VNA 的裝置。

  • 勾選啟用 I/O、勾選作用中以及按下確定時，將嘗試與裝置通訊。

  • 如果與裝置的通訊中斷，則受影響的通道將置於保持狀態。

  • 嘗試通訊時，系統會針對勾選了啟用 I/O 的裝置查詢頻率、功率和點數限制。如果存在限制問題，則 VNA 會傳送錯誤並且受影響的通道將置於保持狀態。這些限制由設定它們所在的對話方塊強制執行。解決報告的限制問題，然後還原觸發。

  • 在設定功率感應器對話方塊上按一下設定按鈕時也會嘗試通訊。除非勾選了啟用 I/O 和作用中且可與感應器進行通訊，否則您無法變更任何感應器設定。

設定別名和 LAN 裝置

使用此程序可設定使用 LAN 介面的裝置。亦可用於想要為其設定（易於辨識的）別名的任何裝置。將別名選取作為介面時，別名會出現在「可用」欄位中。

  1. 在 VNA 上，將 VNA 應用程式最小化。

  2. 在系統匣（右下角）的 IO 圖示上按一下滑鼠右鍵，然後按一下 Keysight Connection Expert。

新增 LAN 裝置：

  1. 在 ACE 中，按一下 [image] 。

  2. 選取「新增 LAN 儀器 (TCPIP0) 或 USB0」，然後按一下「確定」。

  3. 按一下並輸入外部來源的 IP 位址。

  4. 按一下「測試連線」以確認通訊。

  5. 按一下確認。

為已連接的裝置建立別名：

  1. 在已連接儀器清單中，於儀器上按一下滑鼠右鍵，然後按一下新增 VISA 別名。

  2. 輸入曾在或將在外部裝置組態對話方塊中使用的同一個裝置名稱。

功率感應器組態對話方塊說明

若要啟動此對話方塊，請在外部裝置組態對話方塊中已選取 PMAR 裝置的情況下，按一下裝置內容。

此對話方塊可用於設定將用作接收器的功率表/感應器。

若要針對來源功率校準設定單一功率表，請使用功率表設定對話方塊。

關於功率感應器校準

PMAR 軌跡不會使用標準 VNA 校準（包括回應修正）進行校準。

PMAR 軌跡使用適合所選感應器的方法進行校準。請按照正確的準則對使用中的感應器進行歸零或校準。檢查以確保所選感應器適合執行 PMAR 量測時所處的頻率範圍和功率位準。

VNA 不會自動提示您執行校準。

若要校準功率感應器，請在此對話方塊上按一下設定，然後按一下感應器歸零/校準。瞭解詳情。

附註：依預設，預設 VNA 或重新叫用儀器狀態時 PMAR 會停用。此行為可透過偏好設定進行變更。

感應器

對於連接到功率表的功率感應器，選取要設定的感應器。

設定 - 按一下可啟動功率感應器設定對話方塊。

按下後，即會測試與感應器的通訊。除非在「外部裝置組態」對話方塊上勾選啟用 I/O，並且感應器已正確連接和設定，否則將無法執行感應器設定。

感應器穩定

在下列任一情況中時，每一個功率表都是「穩定的」：

  • 在此公差值內出現兩個連續功率表讀值或

  • 達到最大讀值數目時。

將針對讀取的讀值計算平均值，使其成為「穩定的」讀值。

公差 - 如果連續功率表讀值都位於此值範圍內，則會將讀值視為穩定讀值。

最大讀值數目 - 設定功率表將達到穩定的最大讀值數目。

感應器「N」損耗補償

使用損耗表 - 選取此核取方塊可將損耗資料套用至來源功率校準修正（例如，針對功率感應器上的配接器）。

編輯表 - 叫用功率損耗補償對話方塊。

功率感應器設定對話方塊說明

在設定功率感應器對話方塊上按一下設定按鈕時會出現此對話方塊。

附註： 請確保功率感應器的頻率範圍覆蓋量測的頻率範圍。這不會自動發生。

感應器 A (B) - 根據感應器類型，顯示下列訊息之一。

  • 未連接 - VNA 不會偵測功率感應器。

  • 此感應器內含有校準係數 - 內部參考校準係數和校準係數資料會自動載入。下表設定不適用。

  • 感應器資料 - 允許輸入下列功率感應器資料：

    • 參考校準係數 - 指定 50 MHz 參考訊號的校準係數。

    • 校準係數表 - 指定感應器的頻率和對應的校準係數。

    • 刪除校準係數 - 刪除表中指示的列。

    • 全部刪除 - 刪除表中的所有資料。

    • 若要向表中新增一列，請按一下表中的某列，然後按下 VNA 前面板或鍵盤上的向下箭頭。此時會在表的下方新增一列。按下「確定」時，會自動按頻率對表進行排序。

載入校準係數 - 按一下可從 *.csv 檔案（您透過感應器上顯示的校準係數所建立）載入校準係數。檔案中的第一行必須是參考校準係數（通常為 100），後跟如下圖所示的頻率/校準係數對：

儲存校準係數 - 按一下可將校準係數表儲存至 *csv 檔案。

限制頻率範圍

  • 勾選後可將功率感應器限制為僅用於最小和最大頻率值內的頻率。

  • 清除後可將功率感應器用於所有量測。如果量測頻率不在最小和最大頻率值範圍內，則會將最接近的最小或最大修正資料用於量測。

最小頻率 - 指定感應器的最小頻率範圍。

最大頻率 - 指定感應器的最大頻率範圍。

功率感應器歸零和校準

若要取得最高準確度，請在量測資料之前對功率感應器進行歸零和校準。按照可能出現的提示操作。

歸零 - 如果下列設定「灰顯」，則會根據功率表/感應器模型自動選取內部或外部歸零。否則，請選取適合執行的歸零類型，然後按下歸零。

  • 內部歸零 - 功率感應器內部的開關可移除感應器的入射功率。

  • 外部歸零 - 需要您在實體上移除感應器的入射功率。

附註：對於 U2000 系列 USB 功率感應器

校準不可用。僅當要量測的功率低於指定位準時，才選取「外部歸零」。否則，U2000 系列會在需要時自動執行內部歸零。如需詳細資料，請參閱功率感應器文件。

  • U200xA - 低於 -30 dBm

  • U200xH - 低於 -20 dBm

  • U200xB - 低於 0 dBm

執行外部歸零時，如果 U2000 功率感應器「懸置」，請將功率感應器韌體升級至 A.01.02.00 或更高版本以修正此問題。

校準 - 所選感應器具有校準功能時可用。校準涉及到量測內部 1 mW 來源。

  • Keysight P 系列感應器具有內部參考，因此，無需連接到功率表的參考連接埠即可進行校準。

  • Keysight U2000 USB 功率感應器無需校準。

  • 對於其他感應器，請參考相關文件以判定其是否具有校準功能。

按下校準，然後按照提示操作。

功率損耗補償對話方塊說明

新增列 - 在列的結尾處新增一列。

刪除列 - 刪除選取的列。

若要編輯值，請在要編輯的儲存格中按兩下。

使用配接器或耦合器將功率感應器連接到量測連接埠時，會執行損耗補償。校準完成時，將移除這些元件。若要考慮量測期間將保留的元件，請使用功率偏移設定。

頻率/損耗對可定義整個頻率範圍的損耗量。例如，使用上圖對話方塊中的項目：

  • 0.5 dB 用於補償最高 1 GHz 的功率感應器量測。

  • 1 GHz 到 2 GHz 之間的每個資料點都在 0.5 dB 和 1 dB 之間線性插入。

  • 1 dB 用於 2 GHz 以上的頻率。

  • 單一頻率/損耗區段會套用至整個頻率範圍。

頻率 - 輸入一個頻率（以 Hz 為單位）。

損耗 - 輸入一個為正值的損耗（以 dB 為單位）。 若要補償增益，請使用負值。

載入表格...- 這些值可透過特性化配接器/裝置從 S2P 檔案中載入。

附註：含有一或多個功率感應器的較大區段計數，會導致 VNA 應用程式的載入和關閉時間較長。

儲存表格... - 將表格儲存至 csv 檔案中。

清除表格 - 清除所有列和資料。

預設 VNA 並關閉電源後，功率損耗補償表仍會繼續存在。若要不使用損耗補償，請在設定功率感應器對話方塊上清除「使用損耗表」核取方塊。

使用 PMAR 裝置以確認來源功率校準

暸解如何建立和設定 PMAR 裝置。

執行來源功率校準後，使用設定為 PMAR 的同一個感應器來分析校準的準確度。

  1. 使用將用於來源功率校準的功率感應器建立 PMAR 裝置。

  2. 執行來源功率校準。暸解方法。

  3. 建立使用 PMAR 裝置的無比例量測。瞭解操作方法。

  4. 在功率感應器仍連接到測試連接埠的情況下，使用最小和最大標記或峰與峰間軌跡統計資料功能來監控修正的來源功率。

上次修改時間：

2016 年 01 月 06 日

第一版


E5092 測試裝置控制

E5092A 測試裝置控制

E5092A 是一款非常熱門的 Keysight Technologies 7 連接埠/9 連接埠測試裝置。儘管該測試裝置最初設計用來與 ENA 網路分析儀搭配使用，但它也能與 VNA 很好地搭配使用。本主題介紹如何透過 VNA 控制測試裝置。如需有關測試裝置的詳細資訊，請參閱 E5092A 文件。

  • 概觀

  • 連接 E5092A

  • 如何進行 E5092A 測試裝置控制設定

  • 使用 E5092A 進行校準

其他系統組態主題

概觀

連接到 VNA 時，E5092A 測試裝置最多可提供 10 連接埠全交錯式量測或最大 22 連接埠量測功能。E5092A 可設定為針對每個 VNA 通道切換不同的測試裝置路徑。設定完所有通道之後，整個量測設定和校準可儲存至 .cst 或 .csa 檔案，以供日後重新叫用。此外，附加至量測列印複本的通道設定表格包括 E5092A 連接埠控制設定。

備註：

  • 與所有 4 連接埠 VNA 模型搭配使用。

  • E5092A 測試裝置具有最大 20 GHz 的可使用頻率。

  • E5092A 測試裝置控制可透過 SCPI 指令自動完成。

  • 啟用第二個狀態列時，該狀態列會指示測試裝置正在受到控制以及目前的切換狀態。

  • 測試裝置路徑切換正好在通道觸發前發生。如果通道觸發處於保持狀態，則不會為該通道進行切換。

  • 使用 E5092A 切換量測路徑時，VNA 掃掠速度會略微變慢。

連接和設定 E5092A

E5092A 可連接至任何一個 VNA USB 連接埠。首次安裝時，Windows 會自動啟動「新增硬體」精靈。按下一步安裝 E5092A 測試裝置。

附註：請參閱 VNA USB 連接埠的功率處理限制。

將 VNA 測試連接埠連接到 E5092A 測試連接埠。將 VNA 測試連接埠 1 與 E5092A 測試連接埠 1 匹配，以此類推。

為 E5092A 選取 ID

VNA 最多可控制兩台 E5092A 測試裝置。將儀器 ID 位元開關設定為 1 或 2。然後，系統便會自動識別測試裝置，並可透過 E5092A 後面板上的 DIP 開關設定參考測試裝置。請先變更 ID 位元開關設定，然後再連接至 VNA USB。

開啟電源

開啟電源之後，E5092A 的所有連接埠連線指示器 LED 隨即亮起。然後，在 VNA 偵測到 E5092A 之後，指示測試連接埠已連接的四個 LED 仍保持亮起。如果 VNA 電源未開啟或沒有使用 USB 纜線連接 E5092A，則所有 LED 會保持亮起。

如何進行 E5092A 測試裝置控制設定

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Setup] > External Hardware（外部硬體）> External Testset..（外部測試裝置..）。

此功能沒有可用的程式設計指令。

E5092A 測試裝置控制對話方塊說明

對話方塊的標題會顯示作用中測試裝置的型號和 ID 編號。

選取 ID 要設定的測試裝置的 ID。最多可以控制兩台 E5092A 測試裝置。按一下可變更測試裝置 ID。暸解如何設定測試裝置 ID。

啟用測試裝置控制 清除該核取方塊會停用連接埠切換和控制線設定。此選項會影響使用所選測試裝置的所有通道。

選取 | 組態
E5092_13 | 選取 E5092A 的 13 連接埠組態
E5092_16 | 選取 E5092A 的 16 連接埠組態
E5092_22 | 選取 E5092A 的 22 連接埠組態
E5092_28 | 選取在 E5092A 中執行單獨切換
E5092_X10 | 選取 E5092A 的 10 連接埠全交錯式組態

顯示測試裝置內容 勾選後會顯示下列狀態列，該狀態列會指示測試裝置正在受到控制以及目前選取的連接埠控制。例如，以下影像顯示了控制 E5092A 測試裝置時的狀態列。

  1. 已設定的通道

  2. E5092A 的連接埠控制設定

  3. Z5623A K64 的連接埠控制設定

  4. 測試裝置標籤。E5092A 控制不使用此欄位。它在介面控制和外部測試裝置控制之間共用。這兩個標籤由 / 分隔。

連接埠控制 控制實體連接埠到邏輯連接埠的對應。

  • 實體連接埠是指測試裝置前面板上標示的連接埠號碼。

  • 邏輯連接埠是指大多數 VNA 應用程式提示和對話方塊參考的連接埠號碼。

連接埠對應附註

  • 連接埠控制和控制線設定會影響作用中（已選取）量測的通道。在量測通道時執行這些設定。

  • 變更連接埠對應時，修正不會關閉。但是，校準不再有效！

控制線 指定個別控制線的值。測試裝置前面板上的這些通用控制線可用於測試設定。每個按鈕可切換控制線高和低。首次開啟時，選取會反映目前的控制線。如需有關控制線的詳細資訊，請參閱測試裝置文件。群組 A 至 D 按如下方式指派。

確定 按一下時會實作對對話方塊所做的變更，並且連接埠選取和控制值會立即傳送至指定的測試裝置。連接埠控制和控制線設定將隨其他通道資料一起儲存，並在掃掠這些通道時使用。

取消 （或 Esc 鍵）不會實作對對話方塊所做的變更，並且會恢復對話方塊開啟前的設定。

使用 E5092A 進行校準

以下是使用已連接的 E5092A 校準 VNA 的方式的一些變更：

  1. 為通道建立量測，並在「E5092A 測試裝置控制」對話方塊上設定連接埠控制（切換）。啟用顯示測試裝置內容。

  2. 若要執行校準，請啟動智慧型校準。

  3. 選取 E5092A 量測參考平面使用的受測裝置接頭。

  4. 系統提示將標準連接到 VNA 連接埠時，按測試裝置狀態列所示，將標準改為連接到 E5092A 連接埠。例如，校準精靈提示將標準連接到連接埠 1 時，如果狀態列指示 1 A，則將標準連接到 E5092A 的連接埠 A。

上次修改時間：

2014 年 08 月 27 日

第一版


顯示顏色

您可以修改用於在 VNA 畫面和顯示內容的列印複本上繪製各種元素的顏色。

  • 顯示顏色

  • 列印顏色

  • 列印預覽程序

另請參閱

列印預覽

顯示顏色

如何修改顯示顏色

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

  2. 按一下「偏好設定」對話方塊上的顯示顏色...。

此功能沒有可用的程式設計指令。

列印顏色

如何修改列印顏色

使用硬鍵/SoftTab/軟鍵

  1. [System] > Print（列印）> Print Colors...（列印顏色...）。

或

  1. 按下 [System] > System Settings（系統設定）> Preferences...（偏好設定...）。

  2. 按一下「偏好設定」對話方塊上的列印顏色...。

顯示顏色和列印顏色對話方塊說明

「顯示顏色」和「列印顏色」對話方塊的功能完全相同。請參閱下方的列印預覽程序。

畫筆

「畫筆」是用於描述各種元素的術語。每個畫筆都有唯一的顏色。

您可以變更下列畫筆的顏色：

  • 背景 - 非作用中視窗的背景顏色。

  • 作用中背景 - 作用中視窗的背景顏色。

  • 網格 - 所有視窗中所有網格的內部線條，以及非作用中視窗中的網格框。

  • 作用中標籤、網格框 - 作用中視窗中的標籤和網格框顏色。附註：選取此畫筆時，目前視窗會變為非作用中視窗。因此，將無法看到對此畫筆顏色的變更，直到按下確定。

  • 非作用中視窗標籤。

  • 失敗軌跡 - 限制線的失敗軌跡或故障指示器（點）以及「失敗」一詞。

  • 下列畫筆適用於最多 8 條軌跡：

    • 資料和限制

    • 記憶體軌跡

    • 標記

    • 記憶體標記

關於軌跡畫筆

「第一條軌跡」並非始終為 Trace1 (Tr1)。例如，視窗中的第一條軌跡可能是使用「第一條軌跡」畫筆繪製的 Tr2。

前 8 條軌跡使用定義的畫筆顏色繪製。接下來的 8 條軌跡會重複使用相同的顏色，以此類推。例如，如果所有軌跡都按序編號，第 9 條和第 17 條軌跡將使用與第一條軌跡相同的顏色繪製。

變更顏色 - 按一下按鈕或顏色樣本以啟動變更顏色對話方塊。

重設顏色 - 還原所選畫筆的預設顏色。

顏色主題

一個主題包含一整套畫筆及其對應的顏色。目前主題會持續存在，直到您對其進行變更。主題也可儲存至檔案，並在日後重新叫用。依預設，該檔案儲存在內部硬碟中的 C:\ProgramData\Agilent\Network Analyzer\Colors 資料夾，且儲存類型為 *.colors。

  • 儲存主題... - 按一下可將目前畫筆集儲存至檔案。

  • 重新叫用主題... - 按一下可重新叫用並使用已儲存的主題。

  • 重設主題... - 按一下可重新叫用預設的 VNA 顏色主題。

下列顯示元素的顏色無法變更：工具列、軟鍵、功能表、對話方塊和快顯視窗訊息。

變更顏色對話方塊說明

若要使用基本顏色，請從「基本顏色」調色盤中按一下顏色，然後按一下確定。

定義和使用自訂顏色：

  1. 按一下定義自訂顏色>> 可開啟對話方塊右側。

  2. 您也可以挑選要取代的自訂色塊。否則，系統會取代第一個色塊位置的顏色，然後繼續後續的自訂顏色定義。

  3. 按一下顏色窗格，或將十字游標拖曳至自訂顏色位置。

  4. 將箭頭拖曳至所需的自訂顏色飽和度。

  5. 按一下新增至自訂顏色。

  6. 繼續定義更多顏色，或按一下確定關閉「顏色」對話方塊。

將自訂顏色指派給 VNA 畫筆後，可以變更自訂顏色。VNA 畫筆顏色保持不變。

列印預覽程序

使用下列程序在 VNA 畫面上預覽您的列印顏色：

  1. 從「列印顏色」對話方塊中，選取重設主題和儲存主題...。將新主題命名為「MyPrintTheme.colors」。這可讓您像使用預設列印顏色一樣使用此顏色。

  2. 啟動「顯示顏色」對話方塊，選取重新叫用主題，然後選取「MyPrintTheme.colors」。此時顯示器上會顯示預設列印主題。

  3. 自訂顯示顏色。您可以預覽複本在列印後的顯示方式。

  4. 將自訂顯示顏色儲存至「MyPrintTheme.colors」。

  5. 移至「列印顏色」對話方塊並重新叫用「MyPrintTheme.colors」。

上次修改時間：

2016 年 01 月 06 日

第一版


頻率消隱

基於安全原因，您可以防止頻率資訊出現在 VNA 畫面和列印成品上。

如何設定頻率留空

使用硬鍵/SoftTab/軟鍵

  1. 按下 [System] > Main（主要）> Security...（安全性...）。

安全性設定對話方塊說明

備註：

  • 若要暸解如何在將 VNA 移出安全區域之前清除記憶體，請參閱 http://na.tm.Keysight.com/pna/security.html。

  • ECal Data Wipe Utility 可根據 US DoD 5220.22-M 損毀所有使用者資料。請造訪 http://na.tm.Keysight.com/pna/apps/applications.htm 深入暸解

  • 若安全性層級為高和額外，則會停用 VNA 的「復原」功能。瞭解詳情。

安全性層級

無 - 顯示所有頻率資訊。

低 - 不顯示任何頻率資訊。返回此對話方塊以重新啟用頻率顯示。

以下內容中的頻率資訊會留空：

  • 顯示註解

  • 校準內容

  • 所有表格

  • 所有工具列

  • 所有列印成品

  • 外部來源 - 另請參閱：在預設時停用外部裝置的偏好設定

附註：只有使用選件 006 的 Keysight MXG 來源才完全支援頻率留空功能。在未使用選件 006 的 MXG 模型和所有 PSG 模型上，視窗狀態已關閉。在來源上按一下「本機」按鈕時，頻率會重新顯示。

高- 不顯示任何頻率資訊。僅當預設或重新叫用儀器狀態時，才能重新啟用頻率顯示功能。

低安全性層級設定且：

  • GPIB 主控台處於非作用中狀態。

額外 - 頻率資訊不會顯示，也不會儲存至 ASCII 檔案類型。僅當預設或重新叫用儀器狀態時，才能重新啟用頻率顯示功能。

高安全性層級設定且：

  • 儲存所有 ASCII 資料儲存功能（.snp、.prn、.cti）且不含頻率資訊。X 軸資訊將取代為資料點數。

  • 無法儲存混頻器設定檔案 (*.mxr)。

對於所有安全性層級：

以下內容中的頻率資訊不會留空：

  • 服務調整程式。

  • SCPI 程式。

儀器狀態和校準集

將始終儲存安全性層級，且使用儀器狀態重新叫用安全性層級。但是，儀器狀態可能包含校準集或指向校準集的連結。瞭解詳情。重新叫用儀器狀態時，安全性層級可能會受到影響。

  • 在校準結束後建立新的校準集時，目前系統安全性層級會隨之儲存。

  • 變更現有校準集之安全性層級的唯一方法是將新校準寫入校準集。

  • 稍後套用至通道時，如果校準集的安全性層級高於目前系統安全性層級，則系統安全性層級會升級至校準集的安全性層級。

  • 將儀器狀態儲存至 *.csa 或 *.cst 檔案時，系統和校準集的安全性層級會單獨儲存。重新叫用時，會套用兩者中較高的安全性層級。

  • 若要檢視校準集的安全性層級，請參閱校準集內容。

重新顯示頻率資訊

  • 使用低安全性層級時，請執行以下任何操作：

    • 重新造訪此對話方塊，並選取無。

    • 執行儀器預設。

    • 重新叫用安全性層級為無的儀器狀態/校準集。

  • 使用高或額外安全性層級時，請執行以下任何操作：

    • 執行儀器預設。

    • 重新叫用安全性層級為無的儀器狀態/校準集。

上次修改時間：

2016 年 01 月 06 日

第一版


功率限制和功率偏移

  • 概觀

  • 如何存取功率限制和功率偏移設定

其他系統主題

概觀

功率限制（全域範圍）

全域功率限制會為個別 VNA 連接埠設定最大來源功率位準。此值會限制所有通道和所有應用程式的連接埠功率。嘗試超過功率限制的功率位準都會裁切為限制值。

附註

  • 新增至 RF 路徑的元件也會考慮在內，方法是在對話方塊的功率偏移區段中輸入其損耗（負值）或增益（正值）。

  • VNA 應用程式可能會變更 RF 路徑元件。例如，轉換器 IMD 可能會變更組合器路徑並為 LO 輸入新增放大器。由於不會對這些變更進行補償，連接埠功率可能會超過功率限制或連接埠功率可能受到不必要的裁切。

  • 功率限制功能不會裁切頻帶交叉期間可能會出現的功率突波。

  • 外部測試裝置連接埠也會納入功率限制範圍。

功率偏移（通道範圍）

功率偏移為來源路徑中的新增衰減或放大提供了補償連接埠功率的方法。結果是，指定連接埠、所有對話方塊和註解處的功率均會反映新增元件。

如何存取偏移和限制設定

也可以透過 VNA 偏好設定對話方塊進行存取。

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Power] > Leveling & Offset（調節與偏移）> Offset and Limits...（偏移和限制...）。

偏移和限制對話方塊說明

按一下白色儲存格可變更值。帶陰影的儲存格無法變更。

可傳送遠端指令以鎖定和解除鎖定對話方塊 (UI) 設定。

功率限制

在每個 VNA 連接埠中為所有通道限制來源功率。使用此功能可保護對輸入處過高功率非常敏感的受測裝置。指定連接埠處超過限制的功率位準會依限制裁切，並且畫面上會顯示錯誤訊息。

儀器預設後，功率限制設定會保留下來。儀器狀態為重新叫用時，會將目前的功率限制設定套用至重新叫用的狀態。

若要深入暸解，請參閱功率限制概觀（向上捲動）。

狀態/限制

  • 開啟 - 功率限制為指定來源連接埠處的相鄰值。

  • 關閉 - 功率未限制為此值，而是限制為 VNA 來源的最大功率。

功率偏移

功率偏移為來源路徑中的新增衰減或放大提供了補償連接埠功率的方法。結果是，指定連接埠、所有對話方塊和註解處的功率均會反映新增元件。

  • 對於放大，請使用正偏移。

  • 對於衰減，請使用負偏移。

重要附註：當來源功率校準、引導式功率校準或功率補償處於開啟狀態且固定裝置嵌入/解除嵌入時，系統會自動新增功率偏移。如果在受測裝置上未看到正確的功率位準，請檢視此對話方塊中的功率偏移欄，以確認偏移是否非預期。

您也可以變更來源功率或連接埠功率值，以便下列公式反映您的需求：

來源功率 + 功率偏移 = 連接埠功率

來源校準 開啟/關閉

確定 關閉對話方塊。

上次修改時間：

2014 年 10 月 24 日

初始版本


系統阻抗

設定系統阻抗

對於阻抗為 50 ohms 以外的量測裝置（例如波導裝置），可以變更系統阻抗。VNA 會以數學方式轉換和顯示量測資料，就像 VNA 連接埠具有指定阻抗值一樣。實際上，測試連接埠始終具有約 50 ohms。

如何變更系統阻抗

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Scale] > Constants（常數）> System Z0（系統 Z0）

系統 Z0 softtab 說明

允許您變更系統阻抗（預設設定為 50 ohms）。

Z0 顯示目前系統阻抗。

對於 75 ohm 裝置：

  1. 將系統 Z0 變更為 75 ohms。

  2. 在分析儀和受測裝置之間連接最小損耗轉接頭（75 ohm 阻抗），以最大限度地減少實體不匹配情況。

  3. 根據 75 ohm 校準標準執行校準。

對於波導裝置

選取具有 50 ohms 以外阻抗的校準套件（波導 = 1 ohm）時，執行校準前沒有必要再變更系統阻抗設定。校準阻抗現在衍生自校準套件「接頭」阻抗設定。

上次修改時間：

2016 年 01 月 06 日

第一版


應用說明

VNA 應用說明

存取以下連結時需要網際網路連線。

附註： 查看 VNA 多媒體示範簡報，包括「網路分析儀基礎知識」。

校準

AN1287-11 針對 Keysight 向量網路分析儀指定校準標樣和套件 (5989-4840EN)

PN8510-8A 適用於非同軸量測的 TRL 校準 (5091-3645E)

適用於固定裝置內裝置特性化的校準標樣（白皮書）(5989-3245EN)

電子與機械校準套件：校準方法和準確度（白皮書）(5988-9477EN)

使用 4 連接埠 20 GHz PNA-L 網路分析儀（N5230A 選件 240/245）進行的在片校準 (5989-2287EN)

ECal

Keysight 電子與機械校準套件：校準方法和準確度度 (5988-9477EN)

使用者特性化：電子校準功能可讓使用者根據特定需求進行自訂 (5988-9478EN)

內嵌/解除內嵌

使用向量網路分析儀解除內嵌和內嵌 S 參數網路 (5980-2784EN)

放大器量測

AN1408-7 放大器線性和增益量測 (5988-8644EN)

AN1408-8 放大器掃頻諧波量測 (5988-9473EN)

AN1408-9 放大器和 CW 掃頻互調失真量測 (5988-9474EN)

AN1408-10 使用 VNA 進行高功率量測 (5989-1349EN)

AN1408-16 附加功率效率 (PAE) 5989-7293EN

AN1408-17 使用 VNA 網路分析儀進行精確的 IMD 量測 (5989-7265EN)

AN1408-19 使用 NVNA 進行高功率放大器量測

天線量測

觸發 VNA 微波網路分析儀以進行天線量測 (5988-9518EN)

用於天線/RCS 量測的全新網路分析儀方法 (5989-1937EN)

使用 VNA 網路分析儀進行脈衝天線量測 (5989-0221EN)

天線和 RCS 配置（白皮書）(5989-0220EN)

雷達量測（應用說明）(5989-7575EN)

平衡量測（雖然以下內容指的是 ENA，但它們也與 VNA 相關。）

使用 Cascade Microtech 探測系統進行在片平衡元件量測 (5988-5886EN)

網路解除內嵌/內嵌及平衡量測 (5988-4923EN)

時域和頻域中的背板差分通道微探頭特性化（白皮書）(5989-3248EN)

混頻器量測

AN1408-1 使用頻率轉換應用程式進行混頻器傳輸量測 (5988-8642EN)

AN1408-2 混頻器轉換損耗和群延遲量測技術與比較 (5988-9619EN)

AN1408-3 使用頻率轉換器應用程式改善量測和校準準確度 (5988-9642EN)

AN1408-18 使用內嵌式本機振盪器量測頻率轉換器的群組延遲 (5989-7385EN)

使用全新向量特性化技術比較混頻器特性化 (5988-7827EN)

適用於向量混頻器特性化和混頻器測試系統向量誤差修正的全新方法 (5988-7826EN)

使用 VNA 微波網路分析儀量測多級轉換器的絕對群組延遲 (5989-0219EN)

脈衝量測

AN1408-11 精確的脈衝量測 (5989-0563EN)

AN1408-12 使用寬頻和窄頻偵測進行脈衝 RF S 參數量測

AN1408-21 使用 VNA 對脈衝作業中的工作裝置進行特性化 (5990-7781EN)

使用 VNA 網路分析儀進行脈衝天線量測 (5989-0221EN)

材料量測

量測材料的電介質屬性的基礎知識 (5989-2589EN)

對基材進行電介質量測的分離式電介質諧振器 (5989-5384EN)

其他量測

AN1287-12 使用網路分析儀進行時域分析 (5989-5723EN)

AN1408-14 使用 VNA 系列分析光波元件 (5989-3385EN)

AN1408-15 使用 VNA 進行帶狀公釐波量測 (5989-4098EN)

AN1408-19 使用 NVNA 進行高功率放大器量測 (5990-5039EN)

AN1408-20 使用 VNA 進行高準確度雜訊指數量測

公釐波網路分析儀：分析纜線長度對 VNA 系統效能的影響 (5989-1941EN)

使用 2 連接埠量測裝置進行超低阻抗量測（白皮書）(5989-5935EN)

建模

利用 TDR 和 VNA 資料開發 4 連接埠頻率相關模型（白皮書）(5989-0638EN)

對差分裝置進行高階量測和建模（白皮書）(5989-4518EN)

自動化

AN 1408-13 使用 VNA 進行應用程式開發簡介 (5980-2666EN)

適用於元件製造商的連線能力進步 (5980-2782EN)

元件製造測試「對速度的需求」(5980-2783EN)

上次修改時間：

2012 年 12 月 04 日 | 修正了 TD AN
2012 年 10 月 10 日 | 新增了 AN 編號
2012 年 05 月 04 日 | 新增了 PAE
2011 年 05 月 20 日 | 新增了脈衝
2011 年 03 月 07 日 | 新增了應用說明
2010 年 10 月 22 日 | 新增了雜訊指數
2008 年 04 月 14 日 | 新增了 IMD 及 VNA。


接頭維護

適當維護接頭對於獲得精確、可重複的量測結果至關重要。以下資訊將有助於您保持準確度並延長接頭的使用壽命，從而節省時間和金錢。

  • 接頭維護快速參考指南

  • 接頭清潔耗材

  • 安全提示

  • 關於接頭

  • 量具量測基礎知識

  • 接頭維護程序

另請參閱 http://na.support.keysight.com/pna/connectorcare/Connector_Care.htm 中的公釐波接頭維護資訊

防止測試連接埠接頭損壞

取放和保管接頭
務必 | 切勿
保持接頭潔淨 使用塑料端蓋保護接頭 保持接頭與分析儀的溫度相同 | 觸碰嚙合平面表面 將接頭觸點端倒置 將接頭散放在盒子或抽屜中
目視檢查
務必 | 切勿
使用放大鏡檢查接頭。 檢查是否有金屬碎屑、深劃痕或凹痕 | 使用中心導線彎曲或破損的接頭 使用螺紋變形的接頭
清潔接頭
務必 | 切勿
先用乾燥潔淨的壓縮空氣清潔表面 使用無絨棉籤或毛刷 使用極少量酒精 清潔外部導線嚙合表面和螺紋 | 使用高壓空氣 (>60 psi) 使用任何研磨劑 讓酒精滲入接頭支撐珠 向中心導線施加橫向力
使用量具量測接頭
務必 | 切勿
檢查並清潔量具、量具校準儀和受測裝置 使用適合的扭矩扳手 使用前將量具歸零 多次量測並記錄讀值 | 使用不在規格範圍內的接頭 使用量規固定接頭量具
連接
務必 | 切勿
先對齊接頭 僅旋轉接頭螺帽 使用適合的扭矩扳手 | 亂扣接頭的螺紋 連接時扭曲接頭本體 嚙合不同類型的接頭

接頭維護和清潔耗材

描述 | 網站
棉籤 | http://www.berkshire.com/swabs.shtml
無絨布 – 空氣除塵器 | http://www.ccrwebstore.com
異丙醇 | http://www.techspray.com
Nitrilite 手套和手指套 | http://www.techni-tool.com

安全提示

清潔接頭時：

  • 使用壓縮空氣或氮氣時，始終佩戴護目鏡。

  • 將異丙醇遠離熱源、火花和明火。使用時保持通風順暢。避免接觸到眼睛、皮膚和衣物。

  • 避免靜電放電 (ESD)。清潔裝置、纜線或測試連接埠接頭時，佩戴接地腕帶（連接 1 MW 串聯電阻器）。

  • 使用酒精清潔接頭前必須拔除儀器電源線，並在通風順暢的場所執行清潔作業。待所有殘留酒精揮發完畢且酒精氣味散盡後，再接通儀器電源。

關於接頭

  • 接頭使用壽命

  • 接頭等級和效能

  • 用來保護接頭的配接器

  • 接頭嚙合平面表面

接頭使用壽命

雖然校準標樣、纜線和測試裝置接頭都是根據最高標準設計和製造的，但所有接頭的使用壽命都有限。這意味著，在正常使用期間，接頭可能會因為磨損而出現故障。為了發揮最佳作用，所有接頭都應接受檢查和維護，以便最大限度地延長使用壽命。

每次連接時都應執行目視檢查。連接或拆開時，接頭螺紋上的金屬顆粒物往往會落到嚙合表面上。請參閱檢查程序。

清除接頭嚙合平面表面和螺紋上的污垢與污染物可延長接頭的使用壽命，並提高校準和量測品質。請參閱清潔程序。

使用量具量測接頭不僅可以確保接頭具有適當的機械公差，進而確保接頭效能，還有助於發現可能會對其他接頭造成損壞的潛在問題。請參閱使用量具量測程序。

適當的接頭維護和連接方法可以：

•

延長使用壽命

•

提高效能

•

獲得更好的可重複性

接頭等級和效能

下文列出了常用接頭系列的三個接頭等級（品質層級）。某些專用類型可能並不具有所有三個等級。

  • 生產級接頭的等級最低，價格也十分低廉。它是典型受測裝置 (DUT) 上最常用的接頭等級。由於公差較為寬鬆，它在所有接頭中的效能最低。這意味著，每次連接至分析儀之前，都要仔細檢查生產級接頭。某些生產級接頭並非用來與計量級接頭嚙合使用。

  • 儀器級是中間等級的接頭。它主要用在測試儀器、大多數纜線和配接器以及某些校準標樣中，並與這些裝置配合使用。它的使用壽命長，效能出色，且公差較嚴格。它可能具有支援電介質的介面，因而可能無法與計量級接頭完美匹配。

  • 計量級接頭在所有等級接頭中的效能最高，價格也最貴。這個等級的接頭用在校準標樣、驗證標樣和高準確度配接器上。由於它屬於高準確度接頭，可以承受多次插拔，因而在所有等級的接頭中具有最長的使用壽命。此接頭等級具有最嚴格的材料和幾何規格。接腳直徑和接腳深度都有著非常嚴格的規定。計量級接頭使用空氣電介質介面和無插槽陰觸點，藉此提供最高效能和可追蹤性。

附註：一般而言，計量級接頭不應與生產級接頭嚙合使用。

用來保護接頭的配接器

透過配接器將不同類型的接頭轉接到分析儀測試連接埠時，請務必使用高品質（儀器級或以上）的配接器。即便受測裝置與分析儀測試連接埠具有相同類型的接頭，最好也使用配接器。在上述兩種情況下，使用配接器有助於延長接頭使用壽命，並保護測試連接埠，防止損壞及代價高昂的維修。

配接器必須經過全面檢查後，才能連接至分析儀測試連接埠，並且此後要經常檢查和清潔。由於校準標樣會連接至配接器，因此，配接器應具有最高品質，能夠提供可接受的 RF 效能並最大限度地降低不匹配所帶來的影響。

接頭嚙合平面表面

RF 和微波量測中的一個重要概念是參考平面。對於網路分析儀，這是指所有量測都以其為參考的表面。校準時，參考平面的定義是量測連接埠與校準標樣的嚙合平面表面接合時所對應的平面。連接（及校準）是否良好取決於接頭在嚙合平面表面上的所有點之間是否完美貼合（如下圖所示）。

量具量測基礎知識

接頭量具是用於量測接頭中心導線接腳深度的重要工具。接頭接腳深度（凹陷或突出程度）通常是指嚙合平面與中心導線端部（或階梯狀陽接腳的中心導線肩部）之間的距離。

典型的接頭量具

凹陷

突出

凹陷和突出

如果中心導線在外部導線嚙合平面（通常稱為「參考平面」）下方凹陷，則接腳深度為負數（凹陷）。如果中心導線從接頭參考平面向上突出，則接腳深度為正數（突出）。

接腳深度

1. 陰觸點凹陷

2. 陽接腳肩部凹陷

與 N 型接頭的差異

N 型接頭的中心導線嚙合平面與接頭參考平面存在一定偏移。此情況下，對「量具校準儀」執行歸零設定時，通常會在中心導線嚙合平面與接頭參考平面之間偏移標稱距離。

何時使用量具量測接頭

  • 首次使用接頭或配接器之前。

  • 如果目視檢查發現或電氣效能表明接頭介面可能不在規格範圍內。

  • 每連接 100 次後（視使用情況而定）。

接頭量具準確度

接頭量具（隨附於校準和驗證套件）只能執行粗測。這是因為，此類量測的可重複性存在不確定性。我們必須認識到，測試連接埠接頭和校準標樣具有極其精密的機械規格。只有使用專門的量具量測流程和電氣測試（在校準實驗室中執行），才能精確驗證這些裝置的機械特性。Keysight 校準套件手冊中的接腳深度規格在所需的接腳深度準確度與量具準確度之間做了一定折衷。校準和驗證套件隨附的量具可讓您量測接頭接腳深度，並可避免超出規格的接頭造成損壞。

附註： 使用量具量測任何接頭之前，都應查看該接頭或裝置附帶的機械規格。

使用量具量測接頭

  1. 佩戴接地腕帶（連接 1 MW 串聯電阻器）。

  2. 選取適合受測裝置 (DUT) 的量具。

  3. 檢查並清潔量具、量具校準儀和受測裝置。

  4. 將接頭量具歸零。

    1. 使用量筒固定住量具，同時小心地將量具校準儀連接至量具。只用手指擰緊接頭螺帽。

    2. 使用適合的扭矩扳手進行最終連接。如果需要，使用另一個扳手防止量具校準儀（本體）轉動。輕敲量筒，使量具貼合。

    3. 量具指針應與量具上的零標記準確對齊。如果未對齊，請調整「歸零」旋鈕，直到量具指針對應的讀值為零。如果量具上配有量規鎖定螺絲和可移動量規，請擰松量規鎖定螺絲，並移動量規，直到量具指針對應的讀值為零。應將量具歸零後，才能執行一系列量測，以確保歸零設定未發生變更。

    4. 取下量具校準儀。

  5. 使用量具量測受測裝置。

    1. 使用量筒固定住量具，同時小心地將受測裝置連接至量具。只用手指擰緊接頭螺帽。

    2. 使用適合的扭矩扳手進行最終連接，如果需要，使用另一個扳手防止受測裝置（本體）轉動。輕敲量筒，使量具貼合。

    3. 讀取量具指針對應的凹陷或突出讀值，並將讀值與裝置規格進行比較。

注意： 如果量具指示接頭過於突出或凹陷，則應將接頭貼上處置標記或送去維修。

  6. 為了確保最大準確度，請至少量測裝置三次，並取讀值的平均值。每次量測後，請將量具旋轉四分之一圈，以減少量測變化。

  7. 如果懷疑量測準確度，請務必確保零件溫度已穩定下來。然後，再次執行清潔、歸零和量測程序。

接頭維護程序

  • 檢查接頭

  • 清潔接頭

  • 連接

  • 使用扭矩扳手

  • 取放和保管接頭

檢查接頭

佩戴接地腕帶（連接 1 MW 串聯電阻器）。

使用放大鏡 (>10X) 並檢查接頭是否出現以下情況：

  • 電鍍層嚴重磨損或劃痕很深

  • 螺紋變形

  • 螺紋和嚙合平面表面上存在金屬顆粒物

  • 中心導線彎曲、破損或未對齊

  • 接頭螺帽轉動不暢

注意： 如果裝置受損或超出規格，即便是第一次連接，也可能會損壞與之相連的合格接頭。具有明顯缺陷的接頭都應貼上處置標記或送去維修。

清潔接頭

  1. 佩戴接地腕帶（連接 1 MW 串聯電阻器）。

  2. 使用乾淨的低壓空氣清除嚙合平面表面和螺紋上的鬆動顆粒物。徹底檢查接頭。如需進一步清潔，請繼續執行以下步驟。

  3. 將無絨棉籤蘸點酒精（但不要將棉籤浸在酒精中）。請參閱清潔耗材，瞭解建議使用的酒精類型。

  4. 清除嚙合平面表面和螺紋上的污垢與污染物。清潔內部表面時，避免對中心導線過度施力，並避免棉籤纖維粘在陰中心導線內部。

  5. 待酒精揮發完畢後，使用壓縮空氣吹淨表面。

  6. 檢查接頭。確保無顆粒物或殘留物。

  7. 如果在清潔後仍能看到一些缺陷，則接頭本身可能已損壞，不應再使用。確定造成接頭損壞的原因後再繼續連接。

連接

  1. 佩戴接地腕帶（連接 1 MW 串聯電阻器）。

  2. 檢查、清潔和度量接頭。所有接頭都必須完好無損、乾淨且在機械規格範圍內。

  3. 仔細對齊兩部裝置的中間軸。陽接頭的中心導線接腳必須滑入陰接頭的觸頭，且二者要保持同軸。

  4. 小心地將接頭徑直推到一起，使其順利接合。旋轉接頭螺帽（而不是裝置本身），直到用手擰緊，同時小心不要亂扣螺紋。

  5. 使用扭矩扳手進行最終連接。擰緊至扭矩扳手的「中斷」點。請勿超過初始中斷點。如果需要，使用另一個扳手防止裝置本體轉動。

拔下接頭

  1. 支撐住裝置，以免任一接頭扭曲、搖擺或彎曲。

  2. 使用開口扳手，防止裝置本體轉動。

  3. 使用另一個開口扳手擰松接頭螺帽。

  4. 只轉動接頭螺帽，並用手拔下接頭。

  5. 徑直拉開接頭。

使用扭矩扳手

  1. 確保扭矩扳手的扭矩設定正確。

  2. 施力之前，將扭矩扳手和另一個扳手（用於固定裝置或纜線）在彼此成 90° 以內的角度位置。務必支撐住裝置，以免接頭承受應力。

 | 固定 |
正確 方法 | 錯誤方法 | （提起幅度過大）

  3. 在手柄末端輕輕握住扭矩扳手，然後在與扭矩扳手手柄垂直的方向施力。擰緊至扭矩扳手的「中斷」點。請勿超過初始中斷點。

扭矩方向

手柄開始屈服時停止

取放和保管接頭

  • 接頭未使用時，請安裝保護端蓋。

  • 切勿將接頭、風管或校準標樣散放在盒子中。這是導致接頭損壞的常見原因。

  • 保持接頭與分析儀的溫度相同。手握接頭或使用壓縮空氣清潔接頭可能會顯著影響溫度。請等待接頭溫度穩定下來後再進行校準或量測。

  • 請勿觸碰嚙合平面表面。皮膚上的油脂和微小的塵粒很難從這些表面上清除掉。

  • 請勿將接頭觸點端倒置放在硬質表面上。如果介面與任何硬質表面接觸，電鍍層和嚙合平面表面可能會受損。

  • 佩戴接地腕帶，並在接地的導電桌墊上工作。這有助於保護分析儀和裝置免受靜電放電 (ESD) 的損壞。


ESD 保護

靜電放電 (ESD) 保護

在網路分析儀上插拔纜線時，防範靜電放電 (ESD) 至關重要。您的身體內可能會積蓄靜電，這些靜電倘若釋放，很容易就會損壞敏感的內部電路元素。即便是那些感覺不到的微弱靜電放電也可能會導致永久性損壞。為防止儀器受損：

  • 始終在測試設備前放置一塊接地的導電桌墊。

  • 連接測試裝置時，始終佩戴接地腕帶，並將腕帶與 1 MΩ 電阻器串聯，連接至接地的導電桌墊。

  • 在地板導電的場所工作時，始終佩戴腳環。如果不確定地板是否導電，也請佩戴腳環。

  • 清潔、檢查或連接對靜電敏感的裝置或測試連接埠前，始終將身體接地。例如，您可以短暫握住測試連接埠或纜線接頭的接地外殼。

  • 將測試纜線連接至分析儀測試連接埠或其他對靜電敏感的裝置前，始終將測試纜線的中心導線接地。請按照以下步驟執行此作業：

    1. 在纜線一端連接校準套件中提供的短路線，將中心導線與外部導線短路。

    2. 佩戴接地腕帶期間，握住纜線接頭的外殼。

    3. 將纜線另一端連接至測試連接埠，然後從纜線上取下短路線。

如需 ESD 零件編號資訊，請參閱分析儀配件。


輸出功率

絕對輸出功率

絕對輸出功率量測可顯示不同頻率下的絕對功率。

  • 什麼是絕對輸出功率？

  • 為什麼要量測絕對輸出功率？

  • 準確度考量

  • 如何量測絕對輸出功率

請參閱其他的放大器參數主題

什麼是絕對輸出功率？

絕對輸出功率量測可顯示分析儀輸入連接埠處的功率。此功率是絕對的：不參考入射功率或來源功率（成比率）。當使用對數幅度格式時，與格線的垂直軸關聯的值以 dBm（參考 1 mW 量測的功率）為單位。

  • 0 dBm = 1 mW

  • -10 dBm = 100 mW

  • +10 dBm = 10 mW

當使用線性幅度格式時，與格線的垂直軸關聯的值以瓦特 (W) 為單位。

為什麼要量測絕對輸出功率？

如果必須將放大器的輸出量化為絕對功率，您應量測絕對輸出功率，而不應執行成比率相對功率量測。例如，在增益壓縮量測期間，通常還應量測絕對輸出功率。此量測可顯示放大器輸出的絕對功率，其中發生了 1-dB 壓縮。

準確度考量

應根據需要充分衰減放大器的輸出功率。輸出功率過高會導致以下結果：

    • 損壞分析儀接收器

    • 超過分析儀接收器的輸入壓縮級別，從而導致量測結果不準確。

可以使用衰減器或耦合器來實現放大器輸出功率的衰減

在不同溫度下，放大器的回應方式可能截然不同。測試工作應在放大器處於所需工作溫度時執行。

如何量測絕對功率

若要量測絕對輸出功率，請執行以下作業：

  1. 預設分析儀。

  2. 選取無比率功率量測（接收器 B）。瞭解詳細資訊。

  3. 將分析儀的來源功率設定為 0 dBm。

  4. 選取外部衰減器（如果需要），使得放大器的輸出功率充分衰減，以免導致接收器出現壓縮或分析儀的連接埠 2 受損。

  5. 按照下圖所示連接放大器，並提供直流偏壓。

  6. 選取適用於受測放大器的分析儀設定。

  7. 移除放大器，並將量測連接埠連接在一起。將資料儲存至記憶體。量測放大器時，如果要使用衰減器和纜線，請務必將其包含在測試裝置中。

  8. 將儀器狀態儲存至記憶體。

  9. 重新連接放大器。

  10. 選取資料數學函數「資料/記憶體」。

  11. 縮放顯示的量測結果，以獲得最佳檢視效果；並使用標記來量測所需頻率下的絕對輸出功率。

  12. 列印資料或將其儲存至磁碟。

上次修改時間：

2014 年 07 月 25 日

第一版


放大器參數

放大器參數參考

  • 增益

  • 增益平坦度

  • 反向隔離

  • 增益漂移與時間

  • 線性相位偏差

  • 群組延遲

  • 回波損耗（SWR，r）

  • 複數阻抗

  • 增益壓縮

  • AM 到 PM 轉換

另請參閱

  • 高增益放大器

  • 使用 VNA 進行高功率量測

增益

放大器的輸出功率（傳輸至 Z0 負載 ）與輸入功率（從 Z0 來源傳輸）之比。Z0 是 特性阻抗 ，在本例中是 50W。

對於小訊號電平，放大器的輸出功率與輸入功率成正比。小訊號增益是在此線性區域中產生的增益。

隨著輸入功率位準的增加以及放大器接近飽和，輸出功率會達到極限且增益會下降。大訊號增益是在此非線性區域中產生的增益。請參閱增益壓縮。

增益平坦度

在放大器頻率範圍內的增益變化。請參閱小訊號增益和平坦度。

反向隔離

用來衡量從輸出端到輸入端的傳輸。與增益量測類似，但會向放大器的輸出端施加激勵訊號。請參閱反向隔離。

增益漂移與時間（溫度，偏壓）

在所有其他參數保持恒定的情況下，以時間函數表示的最大增益變化。增益漂移還會隨著其他參數（如溫度、溼度或偏壓電壓）的變更而變化。

線性相位偏差

從線性相位偏移經歷的變化量。在理想情況下，通過放大器的相位偏移是頻率的線性函數。請參閱線性相位偏差。

群組延遲

用來衡量通過放大器的傳輸時間，以頻率函數表示。理想的線性相位偏移將以恒定速度隨頻率而變更，從而產生恒定的群組延遲。請參閱群組延遲。

回波損耗（SWR，r）

用來衡量放大器輸入端或輸出端相對於系統 Z0 特性阻抗的反射不匹配程度。

複數阻抗

複數阻抗 (1+G)。從放大器輸出的反射能量與其阻抗直接相關。複數阻抗包含電阻分量和電抗分量。複數阻抗從系統的特性阻抗和反射係數衍生而來。請參閱複數阻抗。

增益壓縮

請參閱增益壓縮應用。

AM 到 PM 轉換係數

由於輸入訊號發生幅度變更而導致在放大器輸出訊號中產生的相位變更量。

在給定的功率位準下，AM 到 PM 轉換係數以度/dB 為單位（通常以 P1dB 表示，這代表 1 dB 增益壓縮點）。請參閱 AM 到 PM 轉換。


平衡量測

  • 什麼是平衡裝置？

  • 差分和共模模式模型

  • 量測混合模式（平衡）S 參數

  • 量測阻抗參數

  • 量測 CMRR

  • 連接埠對應

  • 校準平衡量測

  • VNA 如何進行平衡量測

其他量測設定主題

什麼是平衡裝置？

標準單端裝置通常具有一個輸入連接埠和一個輸出連接埠。輸入和輸出連接埠上的訊號以接地為參照。

平衡裝置在輸入和/或輸出上有兩個接腳。所需訊號是兩個輸入或輸出線路的差值和平均值，不以接地為參照。

差分和共模模式模型

在平衡裝置上，所需訊號是兩個輸入或輸出線路的差值和平均值。在平衡裝置術語中，這些訊號稱為差分和共模模式。

下列模型顯示如何將兩個訊號（A 和 B）組合以建立差分和共模模式訊號：

  • 訊號 A 固定為 1V 峰值

  • 訊號 B 是可選取的

  • 差分計算方式為 A 減 B

  • 共模計算方式為取 A 和 B 的平均值

附註：按一下訊號 B 選項可查看各種差分和共模訊號。

訊號 A =1V |  |
 | 差分 (A - B) | 共模 (平均值) (A + B) / 2
訊號 B = 可選取 | 計算
單端0V | 1 - 0 = 1 | (1 + 0)/2 = .5
180° 異相.1V | 1 - (-1) = 2 | (1 + (-1))/2 = 0
180° 異相 2V | 1 - (-2) = 3 | (1 + (-2))/2 = -.5
同相 1V | 1 - 1 = 0 | (1 + 1)/2 = 1
同相 2V | 1 - 2 = -1 | (1 + 2)/2 = 1.5

附註：

  • 即使訊號 B 為 0V（類似於單端訊號），兩個個別訊號也仍有唯一的差分和共模模式表示。

  • 上述模型不會顯示 DUT。對於裝置的平衡輸入和平衡輸出，可計算兩個訊號的差值和平均值。

量測混合模式（平衡）S 參數

混合模式 S 參數將傳統的 S 參數標記法與平衡量測術語組合。

一些平衡裝置設計用於放大差分分量和抑制共模分量。這樣可以讓兩個輸入的共有雜訊幾乎可從輸出中消除。例如，平衡裝置可能會使差分訊號放大 5 倍，使共模訊號衰減 5 倍。使用傳統的 S 參數標記法時，S21 可用於對裝置輸出/裝置輸入進行比例量測。將其與平衡術語混合，我們可以檢視放大器的差分輸出訊號/差分輸入訊號。 若要在 VNA 上查看此參數，可以使用下列平衡標記法來選取 Sdd21 量測：

Sabxy -

其中

a - 裝置輸出模式

b - 裝置輸入模式

（針對 a 和 b 從下列內容進行選擇：）

    • d - 差分

    • c - 共模

    • s - 單端

x - 裝置輸出「邏輯」連接埠號

y - 裝置輸入「邏輯」連接埠號

另請參閱

邏輯連接埠對應

使用外部測試裝置的連接埠對應

量測阻抗參數

阻抗用於量測構成平衡連接埠的兩個實體連接埠的相符情況。連接埠完全平衡時，流入到兩個連接埠的能量相同，並且這兩個連接埠的比例大小為 1。

標記法與傳統的 S 參數類似。在下圖中，使用了字母 a、b、c 和 d，因為任何 VNA 連接埠皆可透過連接埠對應程序指派給任何邏輯連接埠。

例如，在下面的單端 - 平衡公式中，Sba 指示裝置輸出連接埠為邏輯連接埠 b，而輸入連接埠為邏輯連接埠 a。

量測單端 - 平衡裝置時的阻抗參數。

量測平衡 - 單端裝置時的阻抗參數。

量測平衡 - 平衡裝置時的 Imbalance1 至 Imbalance4 參數。

量測單端 - 單端 - 平衡裝置時的 Imbalance1 和 Imbalance2 參數。

量測 CMRR（共模模式抑制比）

CMRR 是平衡連接埠在差分模式和共模模式下的傳輸特性之比，作為量測參數使用。該值越高，表示共模模式越受抑制；在傳輸訊號差分部分資訊的裝置中，需要較高的值。下表顯示量測每個平衡裝置時可供選取的 CMRR 參數。

單端 - 平衡裝置 | Sds21 --------- Scs21 | 和 | Ssd12 --------- Ssc12
平衡 - 單端裝置 | Ssd21 --------- Ssc21 | 和 | Sds12 --------- Scs12
平衡 - 平衡裝置 | Sdd21 --------- Scc21 |  |
單端 - 單端 - 平衡裝置 | Sds31 --------- Scs31 | 和 | Sds32 --------- Scs32

裝置拓撲和連接埠對應

正如我們在平衡輸入和輸出上所見，所需訊號是兩個平衡輸入或平衡輸出線路的差值或平均值。同一裝置上也可以同時具有單端連接埠和平衡連接埠。兩個平衡輸入或輸出線路稱為單一「邏輯」連接埠。

在 VNA 上設定平衡量測時，請選取裝置「拓撲」。然後將每個 VNA 測試連接埠對應至 DUT 連接埠。VNA 會指派「邏輯連接埠」。請參閱如何在 VNA 中設定裝置拓撲。

下列裝置拓撲可由 4 連接埠 VNA 進行量測。

  • 平衡/平衡
    （2 個邏輯連接埠 - 4 個實體連接埠）

  • 單端/平衡
    （2 個邏輯連接埠 - 3 個實體連接埠）

  • 平衡/單端
    （2 個邏輯連接埠 - 3 個實體連接埠）

  • 單端 - 單端/平衡
    （3 個邏輯連接埠 - 4 個實體連接埠）

下列拓撲可反向（<==）使用以進行量測：

  • 平衡/單端拓撲

  • 平衡/單端 - 單端拓撲

例如，若要量測平衡/單端拓撲，請量測單端/平衡拓撲的 S12（反向）。

校準平衡量測

平衡量測的校準方式與單極（標準）量測相同。但是，若要取得最高的準確度，您必須選擇直通路徑，以便平衡量測的傳輸路徑能夠表示出來。對於平衡/平衡拓撲，這意味著應進行四個直通連線。

例如（請參閱下列影像）：

  • 平衡連接埠 1 為連接埠 1 和 3

  • 平衡連接埠 2 為連接埠 2 和 4

  • 要校準的直通路徑應為： 12, 14, 32, 34.

  • 路徑 13 和 24 不太重要。

選取直通路徑：

  1. 在「智慧型校準」的「選取 DUT 接頭和校準套件」頁面上，勾選修改校準。

  2. 按一下下一步可查看以下「校準精靈」頁面：

VNA 如何進行平衡量測

使用標準平衡量測時，VNA 不會透過激勵兩個平衡輸入並相對於彼此量測兩個輸出來提供真實的平衡量測，而是只進行單端量測。在平衡/平衡裝置上，它激勵每個輸入並個別量測每個輸出。透過輸出資料，VNA 使用與上述模型相同的數學公式來計算 DUT 的差分和共模輸出。但是，VNA 上的所有量測和計算皆使用複雜（幅度和相位）資料在頻域中執行的。然後，根據差分和共模輸入和輸出計算平衡 S 參數顯示資料。

I

上次修改時間：

2016 年 01 月 06 日

第一版


複數阻抗

對受測裝置進行 S11 或 S22 量測時，您可以檢視複數阻抗資料，例如，串聯電阻和電抗以及相位和幅度資訊。可以使用史密斯圓圖格式或極坐標格式來檢視複數阻抗資料。

  • 什麼是複數阻抗？

  • 準確度考量

  • 如何量測複數阻抗

什麼是複數阻抗？

複數阻抗資料是可以透過對受測裝置進行 S11 或 S22 量測來確定的資訊，例如：

  • 電阻

  • 電抗

  • 相位

  • 幅度

從裝置反射出去的功率量與該裝置和量測系統的阻抗直接相關。例如，只有當裝置阻抗與系統阻抗完全相同時，複數反射係數 (G) 的值才等於 0（即，從來源傳輸至負載的功率達到最大）。根據以下公式，G 的每個值都唯一對應於某個複數裝置阻抗（以頻率函數表示）：

ZL= [(1 + G) / (1 - G)] ´ Z0

其中，ZL 是測試裝置的阻抗，而 Z0 是量測系統的特性阻抗。

使用極坐標或史密斯圓圖格式檢視複數阻抗可獲得最佳效果。

準確度考量

  • 搭配使用全刻度值 (1.0) 時，史密斯圓圖最易看懂。

  • 在史密斯圓圖或極座標格式中使用標記時，請啟用離散標記模式以提高準確度。

  • 反射量測的不確定性受以下因素的影響：

    • 方向性

    • 反射追蹤

    • 來源匹配

    • 負載匹配（對於 2 連接埠裝置）

對於 2 連接埠校準，這些因素的影響會降低。如果已正確連接裝置的輸出端，則 1 連接埠校準也會提供相同的準確度。請參閱下圖，討論以下內容。

  • 如果在兩個分析儀連接埠之間連接裝置，則建議您在裝置的輸出端使用 10 dB 的轉接頭以提高量測準確度。如果採用 2 連接埠校準，則無需使用轉接頭，因為這種校準會修正負載匹配。

  • 如果僅將 2 連接埠裝置連接至一個分析儀連接埠，則建議您在裝置的輸出端使用高品質負載（例如，某個校準標樣）。

如何量測複數阻抗

  1. 按照上圖所示連接裝置。

  2. 預設分析儀。

  3. 設定、校準並執行 S11 或 S22 量測。

  4. 檢視阻抗資料：

    1. 選取史密斯圓圖格式。

    2. 縮放顯示的量測結果，以獲得最佳檢視效果。

    3. 放置標記，以讀取軌跡上任意點的複數阻抗的電阻分量和電抗分量。

    4. 列印資料或將其儲存至磁碟。

  5. 檢視反射係數的幅度和相位：

    1. 選取史密斯圓圖格式或極坐標格式。

    2. 選取線性標記格式或對數標記格式。

    3. 縮放顯示的量測結果，以獲得最佳檢視效果。

    4. 放置標記，以讀取軌跡上任意點的反射係數 (G) 的頻率、幅度和相位。

    5. 列印資料或將其儲存至磁碟。


比較 VNA「延遲」功能

VNA 具有三個延遲功能，這些功能雖然類似，但使用方式各不相同。

1. 群組延遲格式用於顯示網路的群組延遲。群組延遲的定義為：

-d(phi)/d(omega) -- 其中，phi 為弧度角，而 omega 為弧頻。

由於它由衍生值定義，因此，該值必須根據分析功能確定。但是，VNA 會進行離散量測，因此，我們會使用有限差分來估算群組延遲：

-(1/360)*delta(phi)/delta(f) -- 其中，phi 為度數角，而 f 為以 Hz 計算的頻率。1/360 會適當地將度數轉換為弧度，並將 Hz 頻率轉換為弧頻。

據此可知，如果網路的相位回應隨頻率而變，則群組延遲也必須隨之變化。 事實上，許多濾波器都是根據其群組延遲的變化而指定的。

如果我們量測無損纜線的相位回應，那麼它應該是一條直線。當然，現實情況不會這麼理想。 相位回應將具有少量雜訊。這是由於 VNA 的軌跡雜訊以及實際纜線或傳輸線的損耗所致，這些雜訊和損耗會導致隨頻率變化出現少量非線性相位變更。 因此，如果查看纜線的群組延遲，我們會發現少量變化。 此外，如果在您進行量測時，頻率間隔足夠小，則分母中的 delta(f) 會變得極小，以致於很小的雜訊就可能會導致擺幅很寬的延遲。

為了克服此問題，我們有時會對相位軌跡加上一些平滑處理，這會加寬有效 delta(f)（稱為孔徑），並提供雜訊較少的群組延遲回應。 裝置的群組延遲僅對給定的頻率孔徑有效。深入瞭解群組延遲。

2. 電延遲功能。 許多濾波器都針對「線性相位偏差」的最大值指定了通頻回應。 查看多極濾波器的通頻時，我們會發現相位變更非常劇烈。這使得我們難以確定相位回應的線性度。 電延遲功能會去除等同於上述計算得出之延遲時間值的「線性相位」。 使用此功能時，您可以調節線性延遲，以便從相位軌跡中移除恆定的相位斜率，直到相位軌跡基本變得平坦。 剩餘的變化為線性相位偏差。

為了降低此工作的繁瑣度，VNA 提供一種稱為游標 =>> 延遲的標記功能。此功能會使用 20% 的平滑孔徑，計算標記位置處的群組延遲值，然後將電延遲值變更為此值。顯然，如果相位軌跡並非理想的線性軌跡，則移動標記並重新計算延遲會得到不同的值。 電延遲功能新增的相位斜率僅適用於目前量測。也就是說，每個量測（S11、S22、S12、S21）都可以使用自己的電延遲值。深入瞭解線性相位偏差。

3. 連接埠延伸功能類似於校準。它適用於給定通道中的所有軌跡。 它會補償在校準參考平面不同於裝置量測平面時所發生的相位回應變更。

讓我們以某部受測裝置為例，此受測裝置安裝在 PCB 固定裝置上且具有 SMA 接頭。我們可以輕鬆地在 SMA 接頭處執行校準。但是，如果我們加裝固定裝置以量測安裝在基板上的裝置，則受測裝置的表觀相位會根據 PCB 固定裝置的相位發生變更。 為此，我們可以使用連接埠延伸，將一個線性相位（恆定延遲）新增至校準例程，從而將相位參考平面偏移至受測裝置的參考平面。這僅適用於固定裝置由具有線性相位回應的傳輸線組成的情況，但實踐中通常都符合此限制。 不符合此限制的主要原因是，SMA 至 PCB 介面不匹配。使用誤差修正並不能移除這種不匹配，因為它發生在 SMA 接頭之後。隨著訊號在不匹配位置與受測裝置之間來回傳輸，顯示畫面上可能會出現漣波。如果受測裝置完美匹配，則漣波影響非常小。然而，當我們使用自動連接埠延伸 (APE) 並讓固定裝置處於開啟狀態（移除了受測裝置）時，反射會很大，且會出現較大漣波。 這就是 APE 使用曲線擬合流程來消除漣波影響的原因。 為了獲得最佳效果，IF 頻寬越寬，使用曲線擬合「平滑」漣波的效果就越好。 當然，我們還要將線性相位斜率擬合到相位回應，進而僅使用單一連接埠延伸延遲值來表示相位斜率。

舊款 VNA 為實現同一功能而使用的方法是，將一個機械式線路延伸器新增至參考通道，從而從連接埠中消除固定的延遲量。連接埠延伸會為每個連接埠的傳輸提供 1 倍延遲，為反射提供 2 倍延遲，因此，它與上述電延遲的略微不同之處在於，後者的數學函數取決於執行的量測。訊號會通過固定裝置兩次，以便進行反射（發出並返回），但傳輸時僅在每個連接埠上通過一次。 對於 S21，新增的相位斜率是連接埠 1 和連接埠 2 的連接埠延遲值之和。

如果固定裝置頻寬有限（可能是由於調諧元素或偏差元素所致），則會使用「使用者範圍」APE 功能。 此情況下，固定裝置的恒定延遲模型在整個頻寬範圍內不再有效，因此，可選取較窄的「使用者頻率範圍」來計算延遲。由於孔徑較小，為連接埠延伸計算延遲時便存在更大的不確定性。 此外，如果您一直使用標記 =>> 延遲功能來估算延遲，我們為 APE 新增了「工作標記」選項，此選項的使用方式與「標記->延遲」完全相同。深入瞭解自動連接埠延伸。


線性相位偏差

線性相位偏差用來測量相位失真。分析儀的電延遲功能用於從量測結果中移除相位偏移的線性部分。如此便可用高解析度顯示相位偏移的非線性部分（線性相位偏差）。

  • 什麼是線性相位偏移？

  • 什麼是線性相位偏差？

  • 為什麼要量測線性相位偏差？

  • 使用電延遲

  • 準確度考量

另請參閱比較 VNA 延遲功能

請參閱其他教學指南

什麼是線性相位偏移？

發生相位偏移的原因是，隨著入射訊號的頻率增加，佔據裝置電長度的波長會變短。當裝置的相位回應與頻率成線性比例關係時，就會發生線性相位偏移。在分析儀上顯示時，這種理想線性相位偏移的相位與頻率量測軌跡呈一條直線。這條直線的斜率與裝置的電長度成比例關係。要想在傳輸訊號時毫無失真，線性相位偏移必不可少（平坦的幅度回應也是如此）。

什麼是線性相位偏差？

在具體實踐中，許多電氣或電子裝置在處理某些頻率時的延遲要超過其他頻率，由此導致非線性相位偏移（訊號失真由多個頻率分量構成）。透過量測線性相位偏差，我們可以量化此非線性相位偏移。

由於只是線性相位偏差導致了相位失真，因此，從量測結果中移除相位回應的線性部分是可取的。要實現這一目的，可以使用分析儀的電延遲功能，透過數學計算的方式取消受測裝置的電長度。剩下的就是線性相位偏差，即相位失真。

為什麼要量測線性相位偏差？

量測線性相位偏差可以實現以下目的：

  • 以相位為單位而不是以秒為單位（群組延遲）呈現資料。對於傳輸調變訊號的裝置，相位單位最為實用。

  • 提供比群組延遲量測具有更低雜訊水平的量測結果。

使用電延遲

電延遲功能是早期分析儀的機械式「線路延伸器」的電子版本。此功能具有以下作用：

  • 模擬可變長度的無損傳輸線，該無損傳輸線可有效新增至參考訊號路徑或從中移除。

  • 補償受測裝置的電長度。

  • 使得分析儀顯示畫面上的量測軌跡變得平坦。如此便可用高解析度檢視軌跡，以便查看相位非線性細節。

  • 提供便利的方法以檢視受測裝置的線性相位偏差。請參閱下圖。

瞭解如何設定電延遲。

準確度考量

在線性相位偏差量測中，測試裝置的頻率回應是主要的誤差因素。為了減小此誤差，請執行 2 連接埠量測校準。

如何量測線性相位偏差：

  1. 預設分析儀。

  2. 如果受測裝置是放大器，則可能需要調整分析儀的來源功率：

    • 將分析儀的來源功率設定為放大器輸出回應的線性區間中的值（通常在 1-dB 壓縮點以下 10-dB）。

    • 選取外部衰減器（如果需要），使得放大器的輸出功率充分衰減，以免導致接收器出現壓縮或分析儀的連接埠 2 受損。

  3. 按照下圖所示連接受測裝置。

  3. 選取 S21 量測。

  4. 選取適用於受測裝置的設定，包括：

    • 格式：相位

    • 縮放：自動縮放

  5. 移除裝置並執行校準。

  6. 重新連接裝置。

  7. 縮放顯示的量測結果，以獲得最佳檢視效果。

  8. 在軌跡中間建立標記。

  9. 按 [>Delay] 鍵以叫用 Marker to Electrical Delay（電延遲標記）功能。這會使相位軌跡變得平坦。

  10. 如果需要，請在縮放功能表上，按一下電延遲以微調相位軌跡的平坦度。

  11. 使用標記來量測最大峰值間線性相位偏差。

  12. 列印資料或將其儲存至磁碟。


增益和真平度

小訊號增益和平坦度

小訊號增益是在放大器的線性工作區域中產生的增益。此增益通常以在某個掃頻範圍內保持恆定的輸入功率進行量測。增益平坦度用來測量指定頻率範圍內的增益變化。

  • 什麼是增益？

  • 什麼是平坦度？

  • 為什麼要量測增益和平坦度？

  • 準確度考量

  • 如何量測增益和平坦度

請參閱其他的放大器參數主題

什麼是增益？

RF 放大器增益被定義為放大器輸出訊號功率與輸入訊號功率之差。我們假設放大器的輸入阻抗和輸出阻抗都與系統的特性阻抗相同。

  • 在 S 參數術語中，增益稱為 S21。

  • 增益用 dB-a 表示，也就是輸出功率相對於輸入功率的對數比。

  • 增益可以透過從輸出位準中減去輸入位準來計算，前提是這兩個位準都用 dBm（相當於 1 毫瓦的功率）表示。

  • 在大多數情況下，放大器增益被指定為給定頻率範圍內的最小值。部分放大器會同時指定最小增益和最大增益，以確保系統的後續各級不會欠驅動或過驅動。

什麼是平坦度？

平坦度指定了放大器增益在指定頻率範圍內的變化幅度。放大器增益的平坦度變化會導致穿過放大器的訊號失真。

為什麼要量測小訊號增益和平坦度？

目標頻寬範圍內的增益偏差會使傳輸訊號失真，因為頻率分量的放大幅度不相等。在 50-ohm 系統中，您可以使用小訊號增益來量化特定頻率下的放大器增益。在 50-ohm 系統中，您可以使用平坦度來檢視指定頻率範圍內的放大器增益偏差。

準確度考量

  • 在不同溫度下，放大器的回應方式可能截然不同。測試工作應在放大器處於所需工作溫度時執行。

  • 應根據需要充分衰減放大器的輸出功率。輸出功率過高會導致以下結果：

    • 損壞分析儀接收器

    • 超過分析儀接收器的輸入壓縮級別，從而導致量測結果不準確。

可以使用以下元件來實現放大器輸出功率的衰減：

    • 衰減器

    • 耦合器

在校準期間，必須將衰減器和耦合器的頻率回應效應及不匹配納入考量，因為這兩個元件是測試系統的組成部分。適當的誤差修正技術可降低這些效應。

  • 在小訊號增益和平坦度量測設定中，頻率回應是主要的誤差因素。執行直通回應量測校準可顯著減小此誤差。為了提高準確度，請執行 2 連接埠量測校準。

  • 減小 IF 頻寬或使用平均可提高量測的動態範圍與準確度，但代價是量測速度降低。

如何量測增益和平坦度

  1. 預設分析儀。

  2. 選取 S21 量測參數。

  3. 將分析儀的來源功率設定為放大器輸出回應的線性區間中的值（通常在 1-dB 壓縮點以下 10-dB）。

  4. 選取外部衰減器（如果需要），使得放大器的輸出功率充分衰減，以免導致接收器出現壓縮或分析儀的連接埠 2 受損。

  5. 按照下圖所示連接放大器，並提供直流偏壓。

  6. 選取適用於受測放大器的分析儀設定。

  7. 移除放大器並執行量測校準。量測放大器時，如果要使用衰減器和纜線，請務必將其包含在校準設定中。

  8. 將儀器狀態儲存至記憶體。

  9. 重新連接放大器。

  10. 縮放顯示的量測結果，以獲得最佳檢視效果；並使用標記來量測所需頻率下的小訊號增益。

  11. 透過使用標記來檢視峰值間漣波，量測某個頻率範圍內的增益平坦度。

  12. 列印資料或將其儲存至磁碟。

  13. 此類型的量測可以自動化。


群組延遲

群組延遲用來測量相位失真。群組延遲以頻率函數表示，指訊號通過受測裝置所花的實際傳輸時間。指定群組延遲時，務必要指定量測使用的孔徑。

  • 什麼是群組延遲？

  • 群組延遲與線性相位偏差

  • 什麼是孔徑？

  • 準確度考量

  • 如何量測群組延遲

另請參閱比較 VNA 延遲功能。

請參閱其他的放大器參數主題

什麼是群組延遲？

群組延遲：

  • 用來測量裝置相位失真。

  • 是訊號在不同頻率下通過裝置所花的傳輸時間。

  • 是裝置相位特性的衍生特性，而且與頻率有關。

請參閱下圖，討論以下內容：

裝置的相位特性通常包含線性和高階（線性偏差）相位偏移分量。

線性相位偏移分量： | 高階相位偏移分量：
表示訊號平均傳輸時間。 | 表示不同頻率下的傳輸時間變化。
歸因於測試裝置的電長度。 | 訊號失真源。

請參閱下圖，討論以下內容：

在群組延遲量測中：

  • 線性相位偏移分量會轉換為恆定值（表示平均延遲）。

  • 高階相位偏移分量會轉換為恆定群組延遲偏差（或群組延遲漣波）。

  • 群組延遲偏差會導致訊號失真，正如線性相位偏差會導致失真一樣。

  • 量測軌跡顯示了每個頻率的訊號穿過受測裝置所花的時間。

請參閱以下公式，瞭解有關 VNA 如何計算群組延遲的內容：

  • 使用相位資料查找相位變更 (-df)。

  • 使用指定的頻率孔徑查找頻率變更 (dw)。

  • 使用上述兩個值，計算相位隨頻率變化時的變化率近似值。

  • 此近似值表示以秒為單位的群組延遲（假設線性相位隨指定的頻率孔徑而變化）。

群組延遲與線性相位偏差

相比線性相位偏差，群組延遲通常可以更精確地指示相位失真。

線性相位偏差結果顯示在下圖中的上部區域：儘管外觀不同，但裝置 1 和裝置 2 仍具有相同值。

群組延遲結果顯示在下部區域：裝置 1 和裝置 2 具有不同的群組延遲值。這是因為，在確定群組延遲時，分析儀會計算相位漣波的斜率，而斜率與每頻率單位出現的漣波數目有關。

什麼是孔徑？

在群組延遲量測期間，VNA 會在間隔十分緊密的兩個頻率處量測相位，然後計算相位斜率。兩個相位量測點之間的頻率間隔（頻率差量）稱為孔徑。變更孔徑可能會得到不同的群組延遲值。計算出的斜率（-差量相位/差量頻率）會隨著孔徑增加而變化。因此，在比較群組延遲資料時，您必須知道量測所用的孔徑。

請參閱下圖，討論以下內容：

窄孔徑： | 寬孔徑：
提供更多的相位線性度細節。 | 提供的相位線性度細節較少，因為某些相位回應是透過計算平均值得出的或未經量測。
量測時更容易受到雜訊（訊號雜訊比較低）和 VNA 相位偵測器解析度的影響。 | 量測時不太容易受到雜訊（訊號雜訊比較高）的影響。

可以使用以下掃頻類型進行群組延遲量測：

  • 線性頻率

  • 列出掃頻段 - 群組延遲孔徑依頻率間距和點密度而異。因此，分段掃描時的孔徑並不是恆定的。在分段掃描中，可以定義額外的頻率點以確保達到所需的孔徑。

如何設定群組延遲孔徑

使用硬鍵/SoftTab/軟鍵

  1. 按 [Format] > Format 1（格式 1）> Group Delay Aperture...（群組延遲孔徑...）

或

  1. 按 [Ave] > Delay Aperture（延遲孔徑）。

  2. 按所需軟鍵並設定值。

[Ave] > Group Delay（群組延遲）/Group Delay Aperture（群組延遲孔徑）對話方塊說明

雖然群組延遲孔徑被定義為兩個資料點之間的頻率差（請參閱什麼是孔徑？），但計算群組延遲時可以取許多相鄰的資料點計算平均值，這與 VNA 平滑功能類似。相鄰資料點的數目可以使用以下任一方法進行設定：

附註：您可以使用 VNA 喜好設定將預設群組延遲孔徑變更為兩個點。瞭解詳細資訊。

點數 要計算平均值的相鄰資料點數目。預設設定為 11 個點。在 2 與通道中目前點數之間選擇一個值。

跨距百分比 對目前頻率跨距百分比內的資料點執行平均計算。在（2 個點/目前點數）與 100% 之間選擇一個值。該跨距內必須至少含有兩個資料點。

頻率 對此頻率範圍內的資料點執行平均計算。該頻率範圍內必須至少含有兩個資料點。

頻率跨距或點數減少，以致於無法獲得目前群組延遲孔徑時，孔徑會調整為新的頻率跨距或點數。

確定 套用設定變更並關閉對話方塊。

取消 關閉對話方塊。不會套用設定變更。

準確度考量

請務必將兩個相鄰量測點之間的相位差保持在 180° 以內（請參閱下圖）。否則，可能會到得到錯誤的相位和延遲資訊。量測具有較長電長度的裝置時，可能會出現取樣不足的問題。您可以透過調整以下設定，直到量測軌跡不再變更，從而確認兩個相鄰點之間測得的相位差是否小於 180°：

  • 增加點數

  • 收窄頻率跨距

電延遲也可用於補償此影響。

在群組延遲測試裝置中，頻率回應是主要的誤差因素。執行直通回應量測校準可顯著減小此誤差。為了提高準確度，請執行 2 連接埠量測校準。

尤其是量測放大器時，不同溫度下的回應可能會具有不同的變化。測試工作應在放大器處於所需工作溫度時執行。

如何量測群組延遲

  1. 預設分析儀。

  2. 如果受測裝置是放大器，則可能需要調整 VNA 來源功率：

    • 將來源功率設定為放大器輸出回應的線性區間中的值（通常在 1-dB 壓縮點以下 10-dB）。

    • 如果需要，請使用外部衰減器，使得放大器的輸出功率充分衰減，以免導致接收器出現壓縮或 VNA 連接埠 2 受損。

  3. 按照下圖所示連接受測裝置。

  4. 選取 S21 量測。

  5. 選取適用於受測裝置的設定：

    • 頻率範圍

    • 量測點數。

    • 格式：延遲

    • 縮放：自動縮放

  6. 移除受測裝置並執行量測校準。

  7. 重新連接受測裝置。

  8. 縮放顯示的量測結果，以獲得最佳檢視效果。

  9. 使用群組延遲孔徑設定來增大孔徑，從而在保持有意義的細節的同時降低軌跡上的雜訊。

  10. 在特定的目標頻率處，使用標記來量測群組延遲（以秒表示）。

  11. 列印資料或將其儲存至磁碟。

上次修改時間：

2014 年 07 月 25 日

第一版


相位量測

必須掌握幅度和相位特性知識，才能成功提高元件整合度。

  • 什麼是相位量測？

  • 為什麼要量測相位？

  • 使用分析儀的相位格式

  • 相位量測類型

請參閱其他教學指南

什麼是相位量測？

正如幅度量測一樣，量測相位時也使用 S 參數。相位量測會產生相對量測結果（比率），而不是絕對量測結果。相位量測會將進入裝置的訊號（入射訊號）相位與裝置回應訊號的相位進行比較。回應訊號可以是反射或傳輸訊號。假設已執行了精確的校準，則兩個訊號之間的相位差（稱為相位偏移）便是受測裝置電氣特性的結果。

下圖顯示了入射訊號與傳輸訊號之間的相位偏移（以時間或度為單位，可在示波器顯示畫面上看到）。

為什麼要量測相位？

量測相位是網路分析的關鍵要素。下圖列出了同時量測幅度和相位的五個原因。

在傳輸訊號的通訊系統中使用時，元件或電路不得導致訊號過度失真。此失真可能是：

  • 線性的，即在目標頻寬範圍內，無法在不同頻率下保持平坦的幅度和線性相位偏移。

  • 非線性的，例如 AM 到 PM 轉換。

務必要量測元件或電路的反射特性，以確保它能有效傳輸或吸收能量。量測天線的複數阻抗便是一個很好的範例。

使用分析儀的相位格式

分析儀的相位格式會顯示相位與頻率量測或相位與功率量測。當參考訊號與測試訊號之間的相位差超過 ±180 度時，分析儀不會顯示此結果。隨著相位值在 +180 度與 -180 度之間變動，分析儀顯示畫面會產生鋸齒狀圖案，如下圖所示。

鋸齒狀圖案並不總是能達到 +180 度和 -180 度。這是因為，量測是在離散頻率下執行的，而且在選取的掃頻中，可能不會量測 +180 度和 -180 度處的資料點。

相位量測類型

複數阻抗資料是可透過 S11 或 S22 量測確定的資訊，如電阻、電抗、相位和幅度。可以使用史密斯圓圖格式或極坐標格式來檢視複數阻抗資料。

AM 到 PM 轉換用來衡量由系統幅度變化 (AM) 導致的不需要的相位偏差 (PM) 量。AM 到 PM 轉換通常被定義為放大器輸入功率每增加 1-dB 所導致的輸出相位變更（即，1 dB 增益壓縮點）。這會表示為每 dB 度數 (°/dB)。

線性相位偏差 用來衡量由裝置導致的相位失真。在理想情況下，通過裝置的相位偏移是頻率的線性函數。由此理論上的相位偏移產生的變化量稱為線性相位偏移（也稱為相位線性度）。

群組延遲是瞭解由裝置所致相位失真的另一方式。群組延遲用來衡量特定頻率的訊號通過裝置所花的傳輸時間。分析儀會根據測得的相位回應衍生值來計算群組延遲。

線性相位偏差與群組延遲

雖然線性相位偏差與群組延遲屬於類似量測，但其目的各有不同。

以下是線性相位偏差量測的優勢：

  • 相比群組延遲，雜訊更少。

  • 能夠將傳輸相位調變訊號的裝置特性化，並顯示相位單位，而不是秒數單位。

以下是群組延遲量測的優勢：

  • 相比線性相位偏差，能夠以更易於理解的方式指示相位失真。

  • 能夠極其精確地將受測裝置特性化。這是因為，在確定群組延遲時，分析儀會計算相位漣波的斜率，而斜率與每頻率單位出現的漣波數目有關。透過比較具有相同峰值間相位漣波的兩個相位回應，具有更大相位斜率的回應會導致：

    • 更大的群組延遲變化。

    • 更大的訊號失真。

另請參閱比較 VNA 延遲功能。


反向隔離

反向隔離用來測量從輸出端到輸入端的放大器反向傳輸回應。

  • 什麼是反向隔離？

  • 為什麼要量測反向隔離？

  • 準確度考量

  • 如何量測反向隔離？

請參閱其他教學指南

什麼是反向隔離？

反向隔離用來測量施加至裝置輸出端的訊號與其輸入端的「隔離」程度。

反向隔離量測類似於正向增益量測，但有以下不同之處：

  • 會向放大器的輸出連接埠施加激勵訊號。

  • 會在放大器的輸入連接埠量測回應。

等效的 S 參數是 S12。

為什麼要量測反向隔離？

理想的放大器應具有無窮大的反向隔離，也就是說，沒有訊號會從輸出端傳回至輸入端。但是，反射訊號可以從反方向穿過放大器。這種不必要的反向傳輸會導致反射訊號干擾正向流動的必要基礎訊號。因此，量化反向隔離至關重要。

準確度考量

您可能已經在正向傳輸量測期間使用衰減來保護連接埠 2 接收器，但由於放大器在反方向通常會表現出高損耗，因此一般無需使用任何衰減。移除衰減將導致以下結果：

  • 增大動態範圍，從而提高量測準確度。

  • 需要進行新的校準才能獲得最大準確度。

您可以提高 RF 來源功率，以提供更動態的範圍和準確度。

附註： 在移除衰減並提高 RF 來源功率後，正向掃描會損壞分析儀的連接埠 2 接收器。除非正向功率設定得足夠低，否則請勿執行正向掃描或使用 2 連接埠校準，以免導致連接埠 2 接收器出現壓縮或受損。

如果受測放大器的隔離非常大，則傳輸訊號位準可能會接近接收器的本底雜訊或串擾位準。若要降低本底雜訊，請採用以下方法：

  • 使用或提高量測平均值。

  • 減小分析儀的 IF 頻寬。

附註：減小 IF 頻寬或使用平均可提高量測的動態範圍與準確度，但代價是量測速度降低。

  • 當串擾位準影響量測準確度時，請透過執行回應和隔離校準來降低串擾誤差項。執行校準的隔離部分時，請務必在校準和量測期間使用相同的平均因子和 IF 頻寬。

  • 在反向隔離量測中，測試裝置的頻率回應是主要的誤差因素。執行直通回應量測校準可顯著減小此誤差。此校準可作為回應和隔離校準的一部分執行。

  • 在不同溫度下，放大器的回應方式可能截然不同。測試工作應在放大器處於所需工作溫度時執行。

如何量測反向隔離？

  1. 按照下圖所示連接放大器。

  2. 預設分析儀。

  3. 選取 S12 量測。

  4. 選取適用於受測放大器的設定。

  5. 移除放大器並執行直通回應校準，或執行回應與隔離校準。

  6. 縮放顯示的量測結果，以獲得最佳檢視效果；並使用標記來量測所需頻率下的反向隔離。

  7. 列印資料或將其儲存至磁碟。


反射量測

反射量測是網路分析的重要組成部分。

  • 什麼是反射量測？

  • 為什麼要進行反射量測？

  • 表示反射波

    • 回波損耗

    • VSWR

    • 反射係數

    • 阻抗

    • 表示方式摘要

請參閱其他教學指南

什麼是反射量測？

若要瞭解反射量測，請從光波模擬的角度思考行波沿傳輸線移動的過程，這樣有助於理解。我們可以設想入射光照在某個光學元件（如透鏡）上。部分光線會從透鏡的表面反射回去，但大部分光線會繼續穿過透鏡。如果透鏡具有鏡面，則大部分光線會反射回去，而只有少量光線穿透或沒有任何光線穿透。

1. 入射 2.反射 3.穿透

對於 RF 能量，當兩個嚙合裝置的阻抗不同時，將出現反射。反射量測是反射訊號與入射訊號之比。網路分析儀透過 R（用於參考）通道量測入射波，透過 A 通道量測反射波。因此，反射通常表示為 A 與 R 之比 (A/R)。我們可以使用 A 和 R 通道上提供的幅度和相位資訊，將受測裝置 (DUT) 的反射特性完全量化。在 S 參數術語中，S11 是裝置連接埠 1（輸入連接埠）的反射量測；S22 是連接埠 2（輸出連接埠）的反射量測

為什麼要進行反射量測？

進行反射量測的其中一個原因就是確保高效傳輸 RF 功率。這樣做是因為：

  1. RF 能量的價格不低。當能量被反射回去時，這意味著只有較少的能量傳輸到預定位置。

  2. 如果反射能量很大，則會損壞諸如放大器等元件。

例如，在下圖中，左側的無線電台未以峰值效率工作。放大器阻抗與傳輸線不同，而傳輸線阻抗又與天線不同。這兩種情況都會導致高反射功率。這種情況會降低傳輸功率，而高反射功率會損壞放大器。

右側的無線電台正確安裝了「匹配的」傳輸線和天線。只有極少的傳輸訊號被反射回去，從而提高了廣播功率，並增加了聽眾、廣告收入和利潤。放大器、傳輸線和天線都需要進行量測，以確保最大限度地降低反射功率。

表示反射波

進行反射量測後，反射資料可以用多種方式表示，具體取決於您想學習的方法。各種表示方式均由分析儀根據相同的反射量測資料計算得出。反射資料的每種表示方法都可以顯示為一種或多種格式的圖形。如需詳細資訊，請參閱顯示格式。

回波損耗

傳達反射資料的最簡單方式就是回波損耗。回波損耗是標量數量（僅幅度），以 dB 表示。可以將回波損耗視為反射訊號低於入射訊號的絕對值或 dB。回波損耗在無窮大（對於理想阻抗匹配）到 0 dB（對於開路、短路或無損電抗）之間變化。例如，在分析儀上使用對數幅度格式時，測得的反射值可能會在畫面上顯示為 -18dB。表示回波損耗時，會忽略負號，以指示該元件的回波損耗為 18dB。

VSWR

兩條波在同一傳輸線上向相反方向移動會導致產生「駐波」。此情況可以根據電壓駐波比（VSWR，或簡稱為 SWR）量測得出。VSWR 被定義為在給定頻率下最大反射電壓與最小反射電壓之比。VSWR 是標量數量（僅幅度）。VSWR 在 1（對於理想匹配）到無窮大（對於開路、短路或無損電抗）之間變化。

反射係數

反射量測的另一種表示方式就是反射係數色差補正 (G)。色差補正包括幅度和相位。

色差補正的幅度部分稱為 rho (r)。反射係數是反射訊號電壓與入射訊號電壓之比。r 可能的值範圍在 0 到 1 之間。以特性阻抗端接的傳輸線會使所有能量傳輸到負載；沒有任何能量會反射回去，且 r = 0。當傳輸線端接至短路或開路時，所有能量都會反射回去，且 r = 1。rho 的值是無單位的。

現在討論相位資訊。在高頻率下，訊號的波長小於導體長度，最理想的情況是將反射視為向入射波的相反方向移動的波。入射波和反射波合併起來便會產生單條「駐波」，並且該駐波的電壓會隨著在傳輸線上移動的位置而變化。

當傳輸線以其特性阻抗 (Zo) 端接時，不存在反射訊號。所有入射訊號均傳輸到負載，如下圖所示。能量沿著傳輸線向一個方向流動。

 | Zo
入射 電壓 | 反射 電壓 = 0
 | （所有入射功率均吸收到負載中）

當傳輸線端接至短路終端時，所有能量都會反射回到來源處。反射波的幅度與入射波相等 (r = 1)。通過任何短路的電壓均為零伏特。因此，在抵消負載上的電壓後，反射波的電壓將偏離入射波的相位 180 度。

當傳輸線端接至開路終端時，所有能量都會反射回到來源處。反射波的幅度與入射波相等 (r = 1)。但是，沒有任何電流可以在開路中流動。因此，反射波的電壓將與入射波的電壓保持相同相位。

當傳輸線端接至 25 ohm 電阻器時，部分（而不是全部）入射能量會被吸收，而另一部分會反射回到來源處。反射波的幅度將是入射波的 1/3，並且這兩條波的電壓在負載上的相位將偏離 180 度。相位關係以距離（從負載沿著傳輸線移動的位置）函數的形式變更。駐波圖的谷值不再下降至零，並且峰值將小於開路/短路的峰值。

如需詳細資訊，請參閱相位量測。

阻抗

阻抗是反射資料的另一種表示方式。如需有關阻抗的詳細資訊，請參閱史密斯圓圖。

反射量測的表示方式摘要：


Avg

Main

  • Averaging

  • Averaging Restart

  • IF Bandwidth

  • LF Auto BW

Smoothing

  • Smoothing

  • Smooth Percent

  • Smooth Points

Delay Aperture

  • Aperture Percent

  • Aperture Points

  • Aperture Freq


Cal

Main

  • Basic Cal...

  • Other Cals

    • Cal All...

    • Smart Cal...

    • E Cal...

    • Receiver Power Cal...

    • Source Power Cal...

  • Correction

  • Interpolation

  • Correction Method

  • Property

Port Extension

  • Select

  • Port Extension

  • Time

  • Distance

  • Velocity Factor

  • DC Loss

  • Port Extensions...

  • Auto Port Extend...

Cal Sets & Cal Kits

  • Cal Set...

  • Cal Set Viewer

  • Cal Kit...

  • Ecal

    • Show Connected Module

    • Restore Module Memory..

    • Confidence Check...

    • Characterize Module...

    • Manage Ecal Disk Memory...

Fixtures

  • Apply Fixtures

  • Power Comp...

  • Fixture Setup

    • Port Match...

    • Port Z...

    • 2-port DeEmbed...

    • N-port DeEmbed...

    • Diff Port Match...

    • Differential Z...

    • Common Z...

  • Cal Plane Manager...

Cal (SMC)

Main

  • SMC Cal

  • Correction

  • Interpolation

  • Correction Method

  • Property

Other Cal

  • Cal All...

  • Source Power Cal...

Last modified:

6-Jan-2016

New topic


Channel

Channel 1-8

  • Channel 1-8

Channel Setup

  • Select

  • Meas Class...

  • Add Channel

  • Copy Channel

  • Delete Channel

Last modified:

6-Jan-2016

New topic


Display

Window 1-8

  • Windows 1-8

Window Setup

  • Select: Select the desired window.

  • Window Title...

  • Add Window

  • Delete Window

  • Window Max

Sheet Setup

  • Select

  • Sheet Title...

  • Add Sheet

  • Delete Sheet

  • Sheet Layout

Display Setup

  • Customize Display...

  • Touch screen : Enable/disable touch screen operation

  • Calibration Touchscreen... : Click Calibrate button and follow the instruction to calibrate the touchscreen positioning.

  • Display Update

Last modified:

6-Jan-2016

New topic


Format

Format 1

  • Log Mag

  • Lin Mag

  • Phase

  • Delay

  • Smith

  • Polar

  • SWR

  • Group Delay Aperture...

Format 2

  • Real

  • Imaginary

  • Unwrapped Phase

  • Positive Phase

  • Inverted Smith


Freq

Main

  • Start, Stop, Center, Span, Step

  • CW

  • Frequency Offset...

Freq (SMC)

Main

  • SMC Setup...

Last modified:

6-Jan-2016

New topic


Macro

Favorite1-3

To Add a Favorite, press and hold any softkey for three seconds and select the desired Favorite number (Favorite 1 to 3).

Macro1-3

  • MWA

  • VMC

Key Setup

  • Macro Setup...

  • Clear Favorites : Clear all favorites items


Marker

Marker 1-7

  • Marker 1 to 7

  • Reference

Marker 8-15

  • Market 8 to 15

Marker Setup

  • Delta

  • Discrete

  • Type

  • Format

  • Coupled

  • Marker Display...

  • Marker Table

  • All Off

Marker -> Functions

  • Marker -> Start

  • Marker -> Stop

  • Marker -> Center

  • Marker -> Span

  • Marker -> Ref Level

  • Marker -> Delay

  • Marker -> CW Freq


Math

Memory

  • Memory -> Data

  • Normalize

  • Data Math

  • Display

  • 8510 Mode

Analysis

  • Conversions

  • Equation Editor...

  • Statistics...

  • Limits...

  • Limit Table

Time Domain

  • Transform

  • Start Time

  • Stop Time

  • Center Time

  • Span Time

  • TD Mode

  • TD Toolbar

  • Time Domain Setup...

Time Gating

  • Gating

  • Gate Start

  • Gate Stop

  • Gate Center

  • Gate Span

  • Gate Type

  • Gate Shape

  • Gating Setup...


Meas

S-param

  • Sxy

  • Meas Class...

Balanced

  • Sssxy, Sdsxy, Ssdxy, Sddxy

  • Topology

Receivers

  • A-D/R1-4 Source Port 1-4

Waves

  • a1-4/b1-4 Source Port 1-4

Auxiliary

  • AuxIn1-2 Source Port 1-4

  • AuxIn1-2 Range

Meas Setup

  • Conversions

  • Correction

  • Trace Hold

  • Equation Editor

  • Memory

  • Time Domain

Meas (SMC)

Main

  • SC21

  • SC12

  • S11

  • S22

Power

  • IPwr

  • OPwr

  • RevIPwr

  • RevOPwr


Power

Main

  • Power Level

  • RF Power

  • Start Power

  • Stop Power

  • Power and Attenuators...

Port Power

  • Select

  • Power Level

  • Start Power

  • Stop Power

  • Source State

  • Coupling

Leveling & Offset

  • Select

  • Slope

  • Offset

  • Limit

  • Offset and Limits...

Power (SMC)

Main

  • Power Level

  • RF Power

  • Power and Attenuators...

  • Mixer Setup...


Preset

Main

  • Preset

  • User Preset ...

  • Confirm Preset

Last modified:

6-Jan-2016

New topic


Save Recall

Recall

  • Recall State

  • Recall State

  • Recall State...

  • Recall Register

  • Recall Cal Set...

  • Recall Data...

  • Recall Order

Save State

  • Save State

  • Auto Save

  • Save State...

  • Save Register

  • Save Type

  • Delete State

Save Other

  • Save Calset...

  • Save Data...

  • Save Screen...

  • Save User Preset...

  • Manage Files...

Last modified:

6-Jan-2016

New topic


Scale

Main

  • Auto Scale

  • Auto Scale All

  • Scale

  • Reference Level

  • Reference Position

  • Scale Coupling

Electrical Delay

  • Delay Time

  • Delay Distance

  • Distance Units

  • Velocity Factor

  • Media

  • Waved Cutoff

Constants

  • System Z0

  • Phase Offset

  • Mag Offset

  • Mag Slope


Search

Main

  • Max Search

  • Min Search

  • Domain

  • Domain Start

  • Domain Stop

  • Tracking

Peak

  • Peak Search

  • Peak Right >> Search

  • << Peak Left Search

  • Next Peak Search

  • Threshold

  • Excursion

  • Peak Polarity

  • Tracking

Target

  • Target Search

  • Target Right >> Search

  • << Target Left Search

  • Target Value

  • Transition

  • Tracking

Multi Peak & Target

  • Multi Peak Search

  • Peak Threshold

  • Peak Excursion

  • Peak Polarity

  • Multi Target Search

  • Target Value

  • Transition

  • Tracking

Bandwidth & Notch

  • Bandwidth Search

  • BW Ref To

  • BW Level

  • Notch Search

  • Notch Ref To

  • Notch Level

  • Tracking

Comp & Sat

  • Compression Search

  • Comp Level

  • Saturation Search

  • Pmax Backoff

  • Tracking

Normal Op Pt

  • Normal OP Search

  • Backoff

  • Pin Offset

  • Tracking


Setup

Main

  • Sweep Setup...

  • Meas Class...

  • Quick Start

Layout

  • New Trace

  • New Channel

  • New Window

  • Delete

  • Select

  • Measure

  • Meas Class...

Internal Hardware

  • Interface Control..

External Hardware

  • External Device...

  • Power Meter Settings...

  • External Testset...

Last modified:

6-Jan-2016

New topic


Sweep

Main

  • Number of Points

  • Sweep Type

  • Start (Frequency sweep, Power Sweep)

  • Stop (Frequency sweep, Power Sweep)

  • Sweep Setup...

Sweep Timing

  • Sweep Time

  • Dwell Time

  • Sweep Delay

  • Sweep Mode

Source Control

  • Frequency Offset...

  • Balanced Source...

  • Shift LO

Segment Table

  • Add Segment, Insert Segment, Delete Segment, Delete All Segment

  • Segment Table...

  • Show Table

Sweep (SMC)

Main

  • Number of Points

  • X-Axis Type: Select X-Axis from Input output, LO1 or LO2.

  • Mixer Setup...

Last modified:

6-Jan-2016

New topic


System

Main

  • Show Taskbar: Show the Windows Taskbar

  • Move App to Back

  • Minimize Application

  • Exit: Exit the VNA application

  • Security...

  • Control Panel... : Open Windows Control Panel

  • Manage Files... : Open Windows File Explore

System Setup

  • Next/Prev Keys : Select Next/Previous window/channel/trace for the selected one

  • Preferences...

  • Sound: Turn On/Off beep sound

  • Remote Interface...

  • LAN Status...

  • Code Emulation

Print

  • Print...

  • Print to File...

  • Page Setup...

  • Print Colors...

Help

  • NA Help...

  • On The Web... : Connect to the Web on the keysight.com.

  • Error Display...

  • View Error Log...

  • About NA...

Service

  • Operator's Check

  • System Verification

  • Display Test

  • Front Panel Test : Check the front panel functionality.


Trace

Trace 1-8 / 9-16

  • Trace 1-16

Trace Setup

  • Select

  • Measure

  • Trace Title...

  • Add Trace

  • Delete Trace

  • Move Trace...

  • Trace Hold

  • Trace Max

Last modified:

6-Jan-2016

New topic


Trigger

Main

  • Hold

  • Single

  • Groups

  • Continuous

  • Manual Trigger

  • Restart

  • Trigger Source

  • Trigger...

Last modified:

6-Jan-2016

New topic


Undo

Main

  • Undo

  • Redo

  • Clear Undo History


詞彙表

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

12 項誤差修正 請參閱誤差修正，12 項。

1 連接埠裝置 一種配備單個接頭或路徑用以連接裝置電路的裝置。範例包括震盪器和負載。

2 連接埠校準，全 請參閱誤差修正，12 項。

2 連接埠裝置 一種以兩個接頭或其他路徑和裝置的電路連接的裝置。範例包括濾波器、SAW 裝置、衰減器、轉接頭及放大器。

3 項誤差修正 請參閱誤差修正，3 項。

A

作用中通道 受前面板功能影響的醒目顯示通道。

作用中功能讀值 顯示螢幕的一個區域，其中顯示作用中的功能及其狀態。作用中的功能是指由最後一次選擇的硬鍵或最後一個遠端編程命令完成的功能。

作用中標記 軌跡上的標記，可透過前面板控制項或程式設計命令將其重新定位。

作用中軌跡 正在由傳入的訊號資訊掃描（更新）的軌跡。

ADC 類比/數位轉換器

位址 暫存器、儲存裝置中的位置或者任何其他資料來源或目的地的識別（以名稱、標籤或編號表示）。範例包括某個站點在通訊網路中的位置，或某個裝置在 GP-IB 上的位置。

ADM 塞取多工器

導納 (Y) 阻抗的倒數（即電流與電壓的比率）。複數導納的形式為 Y = G + jB(t)。

ALC 自動位準控制。請參閱自動增益控制。

AM 幅度調變

AM 群組延遲 一種用於量測群組延遲的技術，量測時使用的裝置會利用幅度調變 (AM) 來源。附註：調變包絡的實際延遲直接使用外部純量偵測器進行量測。無法量測會使訊號幅度失真的裝置。這些裝置包括具有自動增益控制 (AGC) 功能的放大器和受到飽和度或功率限制的裝置。

幅度調變 使載波訊號的幅度發生改變的過程或此過程的結果。所產生的調變載波包含可透過解調進行復原的資訊。另請參閱調變。

類比 一類裝置或電路的統稱，在此類裝置或電路中，輸出做為輸入的連續函數而發生變化。

註解 顯示畫面上特定資訊的標籤（例如頻率或功率）。

ANSI 美國國家標準協會：一個向製造商、組織、使用者和通訊業者開放的全國性會員制組織，該組織核准各項標準以及認可標準開發小組和認證計畫，並且代表並協調美國在非條約和非政府標準機構的利益。

孔徑 網路分析儀的頻率跨距，用於計算群組延遲。孔徑越窄，群組延遲變化的解析度就越高，但增加孔徑則可以減少雜訊。

陣列 代表任何指定功能的一組數字或字元。

ASCII 美國資訊交換標準碼

衰減 表示訊號幅度的降低。由於通過設備、線路或其他傳輸裝置時的損耗所造成的傳輸功率和接收功率之間的差；通常以分貝表示。

衰減器 用於以精確增量的方式，在訊號的整個頻率範圍內減小訊號的功率位準的 RF 或微波裝置。

自動校準系統 AutoCal：Rohde&Schwarz 網路分析儀提供的功能。

自動增益控制 (AGC) 在放大器和其他作用中裝置中使用的一種電路，以在其他參數（例如頻率）變更時使其 RF 功率位準保持恒定。同義字：自動位準控制 (ALC)

自動縮放 分析儀的一種功能，可評估波形並調整控制項，以穩定和增強顯示。

AUX 輔助；指後面板輸入接頭。

平均 一種雜訊降低技術，可根據連續掃描以及依使用者指定的平均因數進行加權來計算每個資料點。每個新掃描都會平均到軌跡中，直到掃描的總數等於平均因數為止。

B

B/R 在 B 點取樣的資料與在 R 點取樣的資料的比率。

帶通 通過裝置（例如濾波器）的頻率範圍。不在帶通範圍內的頻率將受到限制或被減弱。另請參閱截止頻率。

頻寬 (BW) 連續頻帶的頻率之間的差，在該頻帶內，裝置的效能在規格範圍內。

頻寬限制 在超過系統頻寬且訊號失真超出規格範圍時應用的條件。

頻寬選擇性 對濾波器解析幅度不相等的訊號的能力的一種量測方法。其為指定解析度濾波器 (IF) 的 60 dB 頻寬與 3 dB 頻寬的比率。頻寬選擇性可說明濾波器裙襬的陡峭程度。頻寬選擇性有時也稱為形狀因數。

二進位 一種用二進位表示數字的方法（開或關、高位準或低位準、1 或 0）。用於與分析儀之間來回傳輸資訊的壓縮快速格式。

BMP 位元對應

亮度 請參閱顏色亮度。

寬頻裝置 可在很寬的頻率範圍內運作的裝置，在該範圍內，裝置回應只會表現出很小的變化。

緩衝區 在傳輸資訊時用來彌補兩個裝置之間的資訊流速率差異的儲存裝置。

突發載波 一種定期關閉和開啟的載波。突發載波可能（也可能未）經過調變。

BUS 基本公用程式系統

匯流排 一或多個做為路徑以將傳輸的資訊從幾個來源的任何來源送至幾個目的地的任何目的地的導體。

BW 頻寬

位元組 八位元的資料，表示做為一個單位進行處理的一個字元。

C

CAD 電腦輔助設計

CAE 電腦輔助工程

校準 在 HP 儀器中，定期（通常每年一次）驗證儀器是否依規格運作的過程。驗證後將會頒發校準證明。

在網路分析儀中，是指從量測中移除系統誤差的過程。請參閱誤差修正。

校準套件 在網路分析儀中針對特定量測和/或測試裝置執行誤差修正所需的硬體和軟體。

校準，2 連接埠 請參閱誤差修正，12 項。

校準，Blackburn 使用已修正的來源配對來校準傳輸路徑，此方法涉及 15 個校準項。同義字：15 項誤差修正

校準，頻率回應 要執行的最簡單的誤差修正程序，但只會修正十二個可能的系統誤差項中的幾個誤差項。可對反射量測、傳輸量測及隔離量測進行頻率回應修正。

校準，內插法 一種使用者可選擇的網路分析儀功能，可在網路分析儀參數（例如 IF 頻寬、功率或掃描時間）發生變化時，根據現有的誤差修正項計算（插入）新項。所產生的誤差修正不像完成全 2 連接埠校準那樣準確。

校準，連接埠延伸 請參閱連接埠延伸。

校準，參考平面 請參閱參考平面。

校準，設定 Z 設定系統阻抗，通常為 50 或 75 歐姆。

校準，SOLT 使用四個已知標準進行的校準：短路-開路-負載-直通。也稱為全 2 連接埠校準和 12 項誤差修正。另請參閱誤差修正。

校準，TRL 和 LRM 用於無法將 DUT 直接連接至網路分析儀連接埠的環境（MMIC、微帶、樑式引線二極體等）的校準方法。因為還沒有已知的高品質標準，所以制定並使用穿透-反射-線 (TRL) 標準和 M（匹配）標準。表徵這些標準的要求較為寬鬆，但校準的準確度也會低於使用 S-O-L-T 標準的傳統全 2 連接埠校準。TRL、LRL、LRM 等術語可交替使用，它們指的都是同一種基本校準方法。

特性阻抗 深入無限長的無損傳輸線末端的阻抗。

顏色亮度 對顏色強度（亮度）的一種量測方法。

命令 一組轉換為儀器動作的指示。那些動作通常由結合在一起後可執行某項作業的個別步驟組成。

連續掃描模式 每次滿足觸發條件時會自動更新軌跡的分析儀狀況。

控制器 能夠指定資訊傳輸的發送方和接收方的裝置。連接至儀器以控制其操作的外部電腦。

已修正 在執行誤差修正之後進行的量測。

耦合器 請參閱定向耦合器。

CPU 中央處理器

串擾 在裝置的一個連接埠中出現的訊號受到任何其他路徑中的訊號影響。隔離是串擾的量測方法。

游標 以電子方式產生的指標，可在顯示畫面上移動以操縱控制項。

截止頻率 在濾波器中指衰減比帶通訊號位準低 3dB 的頻率，也稱為 3dB 點。

CW 連續波：單一頻率（而不是掃描頻率）。

D

DAC 數位/類比轉換器

dB 分貝：一種相對的量測單位。以 dB 表示的比率的計算方法為：10 log10 (P1/P2)，其中 P1 和 P2 是量測的功率。偏好採用 dB 而非算術比率或百分比的原因是，將元件串聯起來時，可用算術方法加減它們對功率的影響（以 dB 表示）。例如，如果將 3dB 衰減器連接至 10dB 放大器，則兩個元件的淨增益為 (-3dB + 10dB = +7dB)。

dBm 以分貝表示的絕對量測單位：0dBm = 1 mW。dB 的規則（加和減）同樣適用。

DBMS 資料庫管理系統

DC 直流電

預設值 在缺少使用者定義的條件時使用的一組已知條件。

延遲 請參閱群組延遲。

解調 從調變載波復原的過程；調變載波是以訊號形式表示的資訊，基本上具有與原始調變訊號相同的特性。調變訊號的復原由訊號偵測完成。

偵測 解調訊號載波的過程。網路分析儀中有以下兩種提供訊號偵測的基本方法：二極體偵測器（用於寬頻應用）和外差法（用於窄頻應用）。

偵測器，二極體 用於將 RF 訊號轉換為比例 DC 位準的裝置。如果訊號已經過幅度調變，則二極體會從調變中去除 RF 載波訊號。許多與純量分析儀一起使用的來源會通過 27.778 kHz 訊號進行幅度調變，然後在網路分析儀中進行偵測。在二極體偵測期間，訊號載波上的相位資訊會遺失。

線性相位偏差 線性相位是指訊號通過裝置後出現相位偏移的性質。如果相位偏移與頻率的關係圖是一條使用線性刻度的直線，相位就是線性的。線性相位偏差會導致訊號失真。

數位 與裝置或電路的類別有關，在此類裝置或電路中，輸出會以離散步階發生變化。

數位解調 表示擷取用於調變訊號的資訊的技術。將訊號從類比格式轉換為數位格式（數位化）後，會對其採用數位訊號處理演算法。

尺寸 用來指定陣列的尺寸。陣列的行數或列數。

方向性 在 3 連接埠定向耦合器中，當訊號以正向傳輸時的輔助連接埠處功率與同一訊號以反向傳輸時的輔助連接埠處功率的比率。

定向耦合器 一種 3 連接埠裝置，通常用於對傳輸線中的逆向（反射）波分別取樣。

磁碟 一種圓形的磁性儲存媒體。

顯示器/顯示 名詞：請參閱螢幕。

動詞：在顯示畫面上顯示註解和量測資料。

顯示偵測器模式 類比視訊資訊先經過處理，然後再數位化並儲存到記憶體中的方式。

顯示動態準確度 顯示動態範圍內的幅度不確定性，通常以 dB 表示。

顯示動態範圍 顯示動態準確度適用的幅度範圍，以 dB 表示。

顯示格式 用於顯示量測資料的圖形格式。這些格式包括單一通道、覆疊（多個軌跡顯示在一個網格中）、分割（每個軌跡顯示在不同的網格中）。

顯示模式 可以圖形方式顯示量測資料的方式。在網路分析儀中，可選的顯示模式包括笛卡爾/直線形（包含對數或線性幅度、相位、群組延遲、SWR、實數和虛數，以及 dBV、dBmV 和 dBuV 的 XY 圖）、極座標（幅度和角度）、幅度和相位及史密斯圖。並非所有網路分析儀上都有所有顯示模式。此外，顯示畫面可以各種軌跡組合來顯示此資訊。常用的模式包括雙模式（能夠顯示多個軌跡，通常在同一頻率範圍內）和交替模式（能夠顯示多個軌跡，每個軌跡都有不同的頻率範圍和類型）。

顯示相位動態準確度 以度為單位的量測的相位量測不確定性，通常以度表示。

顯示點 在單一量測中建立的量測點的總數。這些點的單位可以是頻率、功率或時間。點的數目往往決定了量測速度、解析度和孔徑。

顯示軌跡雜訊，幅度 由測試系統中的隨機雜訊引起的軌跡幅度不確定性，以 dB 表示。

顯示軌跡雜訊，相位 由測試系統中的隨機雜訊引起的軌跡相位不確定性，以度表示。

顯示類型 分析儀內建的顯示螢幕類型。資料可以顯示為光柵圖（類似於電腦上的點圖）或向量圖（繪製在顯示畫面上的線條）。也可以將顏色和顯示標準指定為單色（單一顏色）或彩色（兩種或多種顏色）。此外，還可以為 IBM 相容個人電腦指定格式標準，例如 VGA 或 SVGA。

失真 由於裝置或系統傳輸功能的非線性特性而導致訊號的品質變差。失真的量測方法是將裝置或系統輸出處的訊號的幅度、頻率和相位的變化組合起來與輸入處的訊號進行比較。

漂移 訊號頻率的緩慢變化。

DSP 數位訊號處理

DUT 測試中裝置

DVM 數位電壓表

動態範圍 在接收器中，能夠同時可靠地量測的訊號位準範圍（從最小值到最大值）。動態範圍允許在存在大訊號的情況下量測小訊號。來源功率和接收器壓縮通常會限制動態範圍的最大邊界。接收器殘餘回應和雜訊底層通常會限制最小功率邊界。

E

ECal 請參閱電子校準。

電子延遲 增加到接收器輸入或從接收器輸入移除的一段模擬可變長度的無損傳輸線，以補償互連纜線。等同於其他網路分析儀中的機械或模擬「拉線器」的韌體。

電子校準 (ECal) 用於對 RF 和微波向量網路分析儀進行電子校準的校準系統。電子校準系統可建立十二項、2 連接埠誤差模型，然後提供校準的確認檢查。Ecal 系統由可重複、可變阻抗、固態校準標準和主機控制單元組成，該單元與 8510、8720 系列和 8753 網路分析儀或 USB 模組相連接，而 USB 模組則與 VNA 系列網路分析儀相連接。

EMC 電磁相容性

EMI 電磁干擾：電子設備內部或外部產生的無意干擾訊號。一般來源可能是電源線瞬變、開關式電源供應器產生的雜訊和/或從震盪器產生的雜散輻射。可利用電源線濾波、屏蔽等來抑制 EMI。

採用 啟用某項功能。

輸入 輸入資訊的過程。

EPROM 電子可程式化唯讀記憶體

誤差修正 在網路分析儀中，透過從校準套件量測已知標準來移除或減少系統（可重複）量測誤差的過程。同義字：量測校準

誤差修正，3 項 用於移除有一個連接埠的裝置（例如負載）上的系統量測誤差。

誤差修正，12 項 使用以下六個參數對 2 連接埠裝置進行修正：
方向性
來源配對
負載配對
反射頻率回應
傳輸頻率回應
隔離

若要完全表徵 2 連接埠裝置，必須在正向和反向對這六個參數進行表徵，因此一共是 12 項。使用者通常可選擇從修正過程中忽略隔離。同義字：全 2 連接埠誤差修正

誤差修正，1 連接埠 針對連接埠 1 或連接埠 2 的方向性、頻率回應和來源配對誤差修正測試裝置。此過程需要三個已知的標準終端，例如，開路、短路和負載。

錯誤訊息 顯示畫面上指出發生錯誤狀況的訊息。缺少硬體或硬體發生故障、使用者操作不當或其他需要引起額外注意的狀況都會造成錯誤狀況。一般來說，只有在解決了錯誤狀況後，才能完成所要求的動作或操作。

ESD 靜電放電

乙太網路 遵循 IEEE 802.3 區域網路標準的網路。

乙太網路位址 用於識別網路上的機器的十六進位數。每台分析儀在出廠時均已指派一個唯一的乙太網路位址，該位址會儲存在分析儀的 ROM 中。

外部觸發訊號 輸入到分析儀中並啟動量測掃描或類似事件的 TTL 訊號，可使量測與外部觸發來源同步。

F

濾波器 允許某些頻率通過並使其他頻率衰減的被動裝置，視類型和規格而定。高通濾波器可使高於截止頻率的頻率通過，低通濾波器可使低於截止頻率的頻率通過，帶通濾波器則可使兩個特定頻率之間的頻率通過。

韌體 由硬體和指令碼組成的組件。硬體和指令碼整合在一起，並形成在正常操作期間無法變更的功能集。指令碼會永久安裝在儀器的電路中，並分類為 ROM（唯讀記憶體）。韌體決定了儀器或設備的操作特性。

平坦度 測試中裝置 (DUT)、訊號來源、接收器或這些裝置的組合的幅度和相位回應。另請參閱頻率回應。

FM 頻率調變

頻率 每個單位時間的週期振盪、震動或波的數量，通常以每秒週期數或赫茲 (Hz) 表示。

頻率準確度 用於指示訊號或頻譜分量的頻率的不確定性，可以絕對值或是相對於其他訊號或頻譜分量的值表示。可分別指定絕對和相對頻率準確度。

頻率範圍 在其中指定裝置或儀器效能的頻率的範圍。

頻率解析度 網路分析儀的一種功能，以間隔緊密的頻率量測裝置的特性，然後分別進行顯示。相等的幅度回應的解析度由 IF 頻寬決定。不相等的幅度回應的解析度由 IF 頻寬和頻寬選擇性決定。

頻率回應 所顯示幅度回應在指定中心頻率範圍內的峰對峰變化。頻率回應通常以 dB 的形式指定，相對於極值之間的中間值。

頻率跨距 所顯示頻率分量的幅度。跨距由顯示畫面的水平軸表示。一般來說，頻率跨距指定為完整的顯示畫面中的總跨距。某些分析儀會將頻率跨距（掃描寬度）表示為每分度值。

頻率穩定性 頻率分量的頻率或幅度在短時間或長時間內保持不變的能力。穩定性是指隨著時間變化，震盪器在特定頻率上保持固定的能力。

前面板硬鍵 位於儀器前面板上的硬鍵。硬鍵標籤可識別硬鍵活動的功能。數字鍵和步驟鍵是前面板硬鍵的兩個範例。

全 2 連接埠校準 請參閱誤差修正，12 項。

功能 特定項目預計執行或實現的動作或目的。網路分析儀包含可透過選擇前面板硬鍵或透過使用程式設計命令執行的功能。這些功能的特性由儀器中的韌體決定。在某些情況下，某個功能的 DLP（可下載程式）執行可讓您透過選擇前面板硬鍵來執行該功能。

基本頻率 任何波形中最低的頻率分量；所有其他分量都是諧波。純正弦曲線只有一個分量，即基本分量。

G

Gb 十億位元

GB 十億位元組

GHz 吉赫

GIF 圖形交換格式 - 用於儲存位元影像圖形檔案的標準圖形格式。

Giga 代表十億的首碼。

GP I/0 通用型輸入/輸出；此接頭通常位於儀器背面，可讓儀器與其他測試設備、外部測試裝置、交換機和電腦通訊，進而使得儀器能夠被觸發或觸發外部設備。其中一個範例是可使量測繼續或迴圈進行的腳踏開關，進而使得操作員能夠在測試硬體上同時使用雙手進行操作。

GPIB 通用介面匯流排 - IEEE 488 匯流排是互連匯流排和通訊協定，可讓儀器和電腦連接起來。

網格 儀器上顯示波形的封閉區域。訊框或軸上的刻度線是進行視覺量測的比例輔助。

群組延遲 對訊號通過 DUT 的傳輸時間相對於頻率的一種量測方法。群組延遲可透過對 DUT 的相對於頻率的插入-相位回應求微分算出。另請參閱 AM 群組延遲和線性相位偏差。

GUI 圖形使用者介面

H

書面 資料的書面複本。

硬鍵 前面板硬鍵，可執行單一分析儀功能或顯示單一的軟鍵功能表。

水平參考 請參閱參考位準。

水平解析度 分析儀在完全掃描時取得間隔緊密的水平資料點的能力。

主機電腦 網路上的電腦或裝置，可為一般使用者提供運算和資料庫存取之類的服務，且通常執行網路控制功能。

主機名稱 用於識別網路上的每部主機機器的唯一名稱。主機名稱與 IP 位址直接關聯，並且通常可用來取代 IP 位址。主機名稱通常由使用者或系統管理員建立。

HP Hewlett-Packard 公司

HPGL Hewlett-Packard 圖形語言

HP-IB Hewlett-Packard 介面匯流排。這是一個平行介面，可讓使用者以「菊鏈」方式將多個裝置連接到電腦或儀器上的連接埠。介面協定在 IEEE 488.2 中定義；等同於業界標準 GPIB。

HTTP 超文字傳輸通訊協定：用於傳輸全球資訊網 (WWW) 流量。

色調 一種顏色維度，指的是從紅色到黃色、綠色、藍色、黑色再回到紅色的認知範圍。它是顏色、濃淡、陰影的特定漸層。

I

I/O 輸入/輸出

I/O 路徑 輸入/輸出路徑

IEEE 美國電機電子工程師學會

IF 中頻：在混合後處理訊號的頻率。

阻抗 電路的某個連接埠的電壓與電流的比率，以歐姆表示。

初始化 將資訊位置指派到磁碟，以使磁性媒體準備接受檔案的過程。

輸入 用於將訊號放入儀器中的路徑。

大多數網路分析儀都有 3 個輸入（標示為 A、B 和 R）或 4 個輸入（標示為 A、B、R1 和 R2）。輸入與通道不同。

輸入衰減器 輸入接頭與頻譜分析儀的第一混頻器之間的衰減器（也稱為 RF 衰減器）。輸入衰減器用於將訊號位準入射調整到第一混頻器，以及防止由於高位準或寬頻訊號所造成的增益壓縮。它也可以用於設定動態範圍，方法是控制內部產生的失真程度。對於某些分析儀，變更輸入衰減器的設定會改變訊號在顯示畫面上的垂直位置，進而相應地改變參考位準。在 Keysight 微處理器控制的分析儀中，IF 增益會變更以補償輸入衰減器設定中的變更。因此，訊號在顯示畫面上會保持靜止，且參考位準不會改變。

插入衰減 在插入裝置之前和之後量測到的功率之間的差。裝置的輸入和輸出之間的衰減。

強度 亮度；發射或反射的光；光度。

介面 一種可在兩個或多個儀器之間建立通用通訊連結的連接。

互調失真 由於通過具有非線性行為的裝置（例如混頻器或放大器）的兩個或多個頻譜分量的互動而產生的不需要的頻率分量。不需要的分量與基本分量的關係表示為基本分量與各個諧波的和與差。演算法如下：f1 ±f2、2xf1 ±f2、2xf2±f1、3xf1 ±2x f2 等。

網際網路 兩個或多個不同網路之間的連線。通常使用閘道或路由器來建立連線。

插入 透過某個程序或演算法確定相鄰點之間的訊號的值。

IP 網際網路通訊協定

IP 位址 網際網路通訊協定位址：指派給要連線至 TCP/IP 網路的每部裝置的唯一號碼。在網路上使用分析儀之前，網路管理員將必須指派 IP 位址。IP 位址由 32 位元值組成，該值以十進位點符號表示：由點分隔的 4 個八位元（位元組）。

ISDN 整合式服務數位網路：一項標準的數位服務功能，具有一或多個能夠承載數位語音、資料或影像訊號的電路交換通訊通道和一個用於頻外訊號處理和控制的封包交換通道。此外，ISDN 還提供一系列可提高使用者的資訊生產力的標準和選用功能，以及比類比系統更快的網際網路存取速度。

ISO 國際標準組織

隔離 受到另一個相鄰訊號影響時，訊號所具有的抗擾性規格或措施。發生的干擾稱為串擾。

隔離器 用於在路徑和分量之間提供隔離的 RF 裝置。由 3 連接埠循環器組成，第三個連接埠以 50 歐姆負載端接。

J

K

Kilo 代表一千的首碼。

KB 千位元組

Kb/s 每秒千位元組

L

LAN 區域網路

LANS 區域網路系統

LCD 液晶顯示器

LED 發光二極體

LIF 邏輯交換格式（用於較舊的 HP 磁碟機/電腦）

限制線 由使用者輸入且與分析儀的量測資料重疊的線，以允許自動偵測超出可接受範圍的資料。可觸發通過/失敗註解、音訊警報或電子輸出，以通知操作員或線上電腦程式發生了超出限制的狀況。

限制線檔案 包含限制線表格項目的使用者記憶體檔案。

限制線表格 限制線的線段會儲存在限制線表格中。使用者可呼叫該表格以編輯那些線段，然後將其重新儲存在限制線檔案中。

線性裝置 輸出和輸入連續成比例的裝置。

LO 本機震盪器。在超外差系統中會將 LO 與收到的訊號混合，以產生等於接收器的中頻 (IF) 的和或差。

LO 饋通 當本機震盪器的第一頻率等於第一 IF 時超外差系統中的回應。

負載 用於端接其特性阻抗中的路徑的 1 連接埠微波裝置。

負載配對 對裝置的端接負載阻抗與理想的傳輸線阻抗之間接近程度的一種量測方法。通常透過量測負載的回波損耗或駐波比 (SWR) 來確定相符程度。

本機鎖定 一種狀況或命令，可防止在分析儀的前面板上進行輸入（並停用本機硬鍵）。

本機操作 從前面板手動操作。

Log 對數

對數顯示 垂直偏轉是輸入訊號幅度的對數函數的顯示模式。對數 (log) 顯示也稱為對數 (logarithmic) 顯示。顯示校準的設定方法是，選取參考位準位置的值以及每分度的比例因數（以 dB 表示）。

LRM 線路-反射-配對。請參閱校準，TRL 和 LRM。

M

幅度 以特性阻抗量測的訊號幅度，而不考慮相位。另請參閱純量。

標記 顯示軌跡旁邊的圖形符號，該符號會用該特定資料點的量測特性進行註解。

標記函數 對一或多個標記的資料進行數學或統計運算，以為操作員提供更多資訊。例如，標記差量函數可計算和顯示兩個標記之間的差。

最大輸入位準 可安全地應用至分析儀的輸入的最大訊號功率。對 Keysight 頻譜分析儀而言，最大輸入位準通常為 1 W (+30 dBm)。

MB 百萬位元組

量測不確定性 量測情況中誤差的量化表示。校準的目的是為了減少不確定性的數量。以下是導致不確定性的量測誤差的來源：

  • 系統誤差（校準標準、接頭、纜線及儀器有缺陷）

  • 隨機誤差（雜訊、接頭可重複性）

  • 漂移（來源和儀器）

Mega 代表一百萬的首碼。

記憶體 一種儲存媒體、裝置或記錄媒體，資料可以儲存在其中並保留一段時間，而使用者可以從中擷取整個原始資料。

記憶卡 形狀類似於信用卡的小型記憶體裝置，可以儲存資料或程式。

功能表 出現在顯示畫面上的分析儀功能，可透過按下前面板硬鍵來選取這些功能。這些選擇可能會叫用建立稱為功能表的群組的一系列其他相關功能。

MHz 百萬赫

milli 代表千分之一的首碼。

數據機 調變器/解調器

調變 用承載資訊的訊號使載波訊號的特性發生改變，使載波包含資訊的過程或此過程的結果。請參閱 AM 和 FM。

顯示器 任何外部顯示器。

單色 只有一種顏色（色度）。

ms 毫秒

mW 毫瓦：千分之一瓦

多頻顯示器 一種顯示器類型，可將其水平掃描同步到指定範圍內的各個頻率。

N

窄頻 在網路分析中，窄到足以解析窄頻裝置的幅度和相位特性的分析儀的接收器的頻率解析度。減小的接收器頻寬通常會減少接收器的雜訊底層，進而提供更廣的量測幅度範圍。

窄頻裝置 一種裝置，其傳輸特性的目的在於在非常窄的頻率範圍內運作，而其設計則可在該範圍內提供定義完善的幅度回應，例如帶通濾波器。

網路分析 透過將傳入裝置的訊號輸入和從裝置傳出的訊號進行比較而得到的裝置、電路或系統特性。

NIST 美國國家標準與技術研究院

Nit 明亮度（輝亮度）的單位，等於每平方公尺一燭光。

雜訊 通訊系統中來自人為和自然來源的不必要或干擾能量的隨機變化，會使訊號攜帶的資訊受到影響或失真。另請參閱訊號雜訊比。

雜訊度 (F)：對 2 連接埠裝置而言，這是以 290 度為基準量測裝置內產生的雜訊使通過該裝置的訊號的訊號雜訊比降低的水準（通常以 dB 表示）的方法。

雜訊底層 分析儀內部顯示的雜訊。雜訊位準通常會限制可以量測的訊號幅度大小。在網路分析中，量測雜訊底層時需要使用端接到負載的測試連接埠、全 2 連接埠誤差修正、10 Hz IF 頻寬、最大測試連接埠功率，而且在測試過程中不計算平均值。

非插入式裝置 在量測校準中，無法由零長度直通路徑替代的裝置。此類裝置的每個連接埠有六個相同類型的接頭，或每個連接埠有不同類型的接頭。

非揮發性記憶體 在失去 AC 電源時保留的記憶體資料。此記憶體通常由電池供電來保留資料。也稱為電池供電 RAM。

標準化 從一個軌跡中減去另一個軌跡，以消除校準資料誤差或取得相關資訊。

O

偏移 用來移動或抵銷已確定的量。在儀器中使用，以使頻率、限制、延遲、損耗、阻抗等偏移。

輸出衰減 使訊號或來源衰減以控制其功率位準的能力。

P

PC 個人電腦

PDF 可攜式文件格式（在網路上使用）

剖析器，命令 依從控制器收到程式訊息的順序從裝置的輸入佇列中讀取這些訊息。剖析器決定了分析儀應採取的動作。命令剖析器最重要的功能之一是確定程式訊息在分析儀 SCPI 命令樹中的位置。重設命令剖析器後，它收到的下一個元素應來自分析儀命令樹底部。

峰值搜尋 分析儀的一項功能，可搜尋最大回應，並在該回應上加上標記。

相位 一個週期的分數部分，振盪將通過此部分，從任意起點量測；通常以弧度或度為單位進行量測。在網路分析中，測試中裝置的相位回應是輸入激勵值與量測的回應之間的相位變化，該變化是頻率的函數。

連接埠 儀器或裝置的實體輸入或輸出連接。

連接埠延伸 將參考平面重新定義為與校準時建立的平面不同的平面。新的參考平面以測試裝置連接埠的延遲秒數定義。

正峰值 傳入訊號的最大瞬時值。

Postscript（.ps 檔案） 以封裝格式儲存點陣圖影像圖形檔案，以供 Postscript 印表機直接使用。

功率，最大輸入 規格適用的輸入功率的上限。某些規格的最大輸入位準可能不同。例如，壓縮功率最大值通常比諧波失真最大值高。

功率，安全輸入 允許使用且不會損壞儀器的輸入功率，通常以 dBm 表示。

預設 預先定義的儀器狀態（也會執行分析儀自我測試）。按下「預設」鍵時發生的動作。

通訊協定 一組規則，指定網路中資訊的格式設定和傳輸方式，以及網路中機器的通訊方式。

Q

Q 或 Q 因數 儲存的能量與諧振電路中損耗的能量的比率。高 Q 表示隨著頻率的變化而產生急劇的共振回應。

查詢 任何具有傳回回應的獨特功能的分析儀編程命令。這些命令可能以問號 (?) 結束。查詢命令會將資訊傳回電腦。

R

r + jx 複數阻抗的運算式，其中 r 代表電阻部分，x 則代表反應部分。

R 通道 參考通道

RAM 隨機存取記憶體或讀寫記憶體：允許存取其任何儲存位置的儲存區域。使用者可以將資料寫入 RAM 或從中擷取資料，但資料儲存只是暫時性的。斷電時，資訊將會消失。顯示畫面上顯示的由使用者產生的資訊是 RAM 資料。

ROM 唯讀記憶體：僅供讀取的儲存區域；使用者無法寫入資料或加以變更。儀器中包含「智慧」或操作性程式設計的儲存區域；也就是韌體。

接收器 一種電路或系統，設計用於接收和/或量測指定頻譜內的訊號。

接收器動態範圍 請參閱動態範圍。

參考位準 一種儀器功能，可讓使用者設定參考位置上的幅度值。在網路分析儀中，參考位置也是可選擇的。在某些頻譜分析儀中，參考位置會固定在顯示畫面的頂端。

參考平面 電子位置，網路分析儀假設系統接頭和固定裝置在此位置結束，而 DUT 從此位置開始。參考平面是使用校準標準和已知電氣長度設定的。參考平面距離測試中裝置 (DUT) 越近，裝置的特性就越佳，因為如此可消除測試系統的不確定性。

參考接收器 在網路分析儀中，此接收器會先量測從來源中傳出的訊號，然後再將訊號入射到測試連接埠和 DUT。這些訊號通常用於與測試連接埠接收器處的訊號比較，以確定 DUT 對訊號產生的影響。在 2 連接埠網路分析儀中，這些接收器通常名為「R1」（連接埠 1）和「R2」（連接埠 2）。請參閱 VNA 中的接收器的方塊圖。

反射 行波突然出現不連續性並返回原始媒體的現象。

反射係數 反射電壓與傳輸線或電路中的入射電壓的比率。如果傳輸線端接到其特性阻抗，則反射係數為零。如果線路短路或開路，則係數為 1。另請參閱回波損耗和 SWR。

反射量測 表徵測試中裝置 (DUT) 的輸入和/或輸出行為的量測。量測的是反射訊號與入射訊號的比率，該比率是頻率的函數。參數稱為回波損耗、反射係數、阻抗及駐波比 (SWR)，而這些參數全部都是頻率的函數。另請參閱 S 參數。

遠端 一種操作模式，在此模式下，另一部裝置（或電腦）透過 HP-IB 控制儀器，而且儀器的前面板硬鍵也會處於停用狀態。前面板操作稱為本機操作。

遠端編程 由電腦自動操作儀器，通常是透過 HP-IB、LAN 或 RS-232 連結。

解析度 接收器解析兩個訊號的能力。

解析度頻寬 頻譜分析儀以離散方式顯示相鄰回應的能力（赫茲、赫茲分貝以下）。此術語用於識別在低於最小插入衰減點（顯示畫面上的最大偏轉點）的某個位準上，頻譜分析儀的解析度頻寬濾波器的寬度。通常，指定的解析度頻寬為 3 dB，但在某些情況下，指定的解析度頻寬為 6 dB。

回波損耗 反射訊號低於入射訊號的 dB 量。如果反射零訊號，則裝置的阻抗等於傳輸系統的特性阻抗，且回波損耗是無限的。如果反射整個入射訊號，則回波損耗為零。另請參閱 S 參數、反射係數及 SWR。

反向量測 從輸出到輸入對裝置進行的量測。

RF 射頻（從大約 50 kHz 到大約 3 GHz）。通常指訊號輻射到空氣中時的情況。

ROM 唯讀記憶體

S

S/N 訊號雜訊比

取樣器 一種電子元件，能以均勻的速率擷取經過某個已知阻抗的訊號位準和相位。在網路分析儀中，若要進行準確的量測，此取樣率必須夠高並且精確定時。網路分析儀通常具有三個或四個取樣器或混頻器。

取樣器震動 網路分析儀取樣器之間的洩漏或串擾。此串擾中由洩漏的傳輸傳遞導致的延遲會使干擾出現「震動」跡象。取樣器震動會使受影響通道的雜訊位準升高，進而降低分析儀的靈敏度。

飽和 顏色純度，範圍是從白色到純色。

純量 具有幅度但沒有相位的數量。這是一種只能夠量測幅度的網路分析儀。

比例因數 顯示畫面垂直軸校準，以每分度單位數的形式表示。

SCPI 可編程儀器的標準命令

螢幕 CRT 或平板顯示器的實體表面，量測結果、設定資訊、軟鍵定義及其他儀器通訊都會顯示在此表面上。

自我測試 開機時（或在預設狀態下）執行的一組測試，目的是驗證儀器是否正常運作。

靈敏度 產生指定的輸出訊號所需的最小輸入訊號，該輸出訊號包含指定的訊號雜訊比或其他指定的條件。

通常，在最小解析度頻寬、0 dB 輸入衰減和最小視訊頻寬等最優條件下，頻譜分析儀中可觀察到的最小正弦曲線的位準。

由於調諧線圈電流發生變化而導致 YIG 分量的中心頻率中發生的標準化變化，以 MHz/mA 指定。

序號首碼 由五個字元組成的首碼，儀器的序號以此首碼開頭；用於表示已發生的韌體或硬體變更的版本。

伺服器 設定為為網路上的其他裝置提供服務（例如對檔案系統或印表機的共用存取）的裝置。

訊號雜訊比 SNR：所需訊號的幅度與雜訊訊號的幅度的比率，通常以 dB 以及脈衝雜訊的峰值和隨機雜訊的均方根值的形式表示。

單次掃描模式 當滿足觸發條件時，頻譜分析儀僅執行一次掃描。每次掃描都透過按下適當的前面板硬鍵或傳送編程命令來啟動。

小訊號增益壓縮 由於網路分析儀的輸入混頻器超載而導致測得的輸入訊號幅度低於實際位準時出現的一種情況；分析儀會以非線性方式運作。對於寬頻分析儀偵測器，與測試中訊號不同的訊號會將分析儀置入此增益壓縮模式，進而使位準更低的訊號在低於實際值的位準上出現。寬頻模式可量測所有入射到分析儀中的功率，而不僅限於相關頻率處的訊號。

史密斯圖 複數反射係數的圖形對應，對應到標準化的複數阻抗。圖上的圓圈代表恒定電阻，而與圓圈正交的輻射線則代表恒定電抗。圖的中心代表傳輸系統的特性阻抗。圖上的任何點都可定義單一複數阻抗。圖上的線條代表阻抗隨著頻率的變化而變化。

SOLT 短路-開路-負載-直通校準。另請參閱校準，SOLT。

來源 提供訊號功率的裝置；掃描震盪器或合成掃描器。

來源幅度準確度 來源功率讀數的幅度不確定性，以 dB 表示。

來源幅度平坦度 來源功率在指定的頻率範圍內的幅度平坦度，以 dB 表示。

來源頻率解析度 可設定和/或量測的最小頻率單位，以 Hz 表示。

來源頻率時基準確度 對分析儀頻率穩定性的一種量測方法，以百萬分率（ppm 或 1/10E6）為量測單位。例如，如果穩定性為 ±5.0 ppm，則意味著當分析儀量測 1 MHz 時，準確度為 ±5 x 10-6 x 10E6 Hz = +5 Hz。

來源頻率時基穩定性 對分析儀隨著時間和溫度而變化的時基準確度的一種量測方法。時基準確度通常指定為 1 年。250 C± 50 C 的一般溫度頻率穩定性為 ±10 ppm。

來源諧波 由分析儀的訊號來源從基本頻率產生的諧波的位準，以 dBc 表示。

來源配對 對訊號來源阻抗與測試系統理想的傳輸線阻抗之間接近程度的一種量測方法。通常透過量測來源的回波損耗或駐波比 (SWR) 來確定相符程度。

跨距 停止頻率減開始頻率。跨距設定決定了分析儀顯示畫面的水平軸刻度。

跨距準確度 顯示畫面上指示的任何兩個訊號的頻率間隔的不確定性。

S 參數（散射參數）一種規則，用於表徵裝置使用網路分析儀修改訊號流的方式。2 連接埠裝置有四個 S 參數：正向傳輸 (S21)、逆向傳輸 (S12)、正向反射 (S11) 及逆向反射 (S22)。

停止/開始頻率 與頻率量測範圍的停止點和開始點結合使用的術語。它們共同決定了量測範圍的跨距。

儲存狀態 任一時間可同時供儲存、編製目錄和呼叫的設定、程式、軌跡及其他參數的數量。

儲存，磁碟 用於儲存測試資料、儀器設定、IBASIC 程式及其他量測參數的內部或外部數位儲存磁碟。儲存格式包括 MS-DOS (R)、HP 標準 LIF、二進位、PCX、HP-GL 或 ASCII 資料格式。

結構回波損耗 纜線中由週期性故障（例如由纜線盤掉落或製造過程中的拉線過程導致的週期性凹陷）引起的少量回波損耗。

補充特性 一般但無保證的效能參數，表示為「一般」、「標稱」或「大約」。

掃描 來源在指定的時間週期在指定的頻率範圍內提供指定的訊號位準的能力。另請參閱掃描模式和掃描類型。

在資料處理模式下，對一系列激勵值進行的一系列連續資料點量測。

掃描模式 啟動或選取掃描的方式，例如單次、連續、交替或斷續。

掃描類型 掃描來源的方法，例如線性、對數或頻率步階。

掃描器 輸出頻率持續改變的訊號的訊號來源。

SWR 駐波比，計算公式為 (1 + p) / (1 -p)，其中 p 是反射係數。

Sync 同步或已同步

語法 語法規則，指定如何針對作業系統、編程語言或應用程式設定命令的結構。

系統動態範圍 最大接收器輸入位準和接收器雜訊底層之間的差。系統動態範圍僅適用於傳輸量測，因為反射量測受方向性限制。

T

T/R 請參閱傳輸/反射。

終端 連接至傳輸線或其他裝置的負載。

測試限制 任何指定量測的可接受結果層級。

測試連接埠 請參閱連接埠。

測試連接埠接收器 在網路分析儀中，位於測試連接埠正後方的接收器，用於在訊號從 DUT 向外反射或傳輸通過 DUT 時對訊號進行量測。此訊號通常會與參考接收器處的訊號相比較，以確定 DUT 對訊號產生的影響。在 2 連接埠網路分析儀中，這些接收器通常名為「A」（連接埠 1）和「B」（連接埠 2）。請參閱 VNA 中的接收器的 方塊圖。

測試裝置 將測試裝置輸入和輸出連接至網路分析儀的來源和接收器以進行 S 參數量測的硬體（交換機、耦合器、接頭和纜線）的排列方式。

三階截斷 TOI：輸入到非線性裝置的功率，此功率會導致同一功率位準出現三階失真。TOI 是一種量測方法，用於確定混頻器或接收器的失真特性。值越高，接收器越不易受內部失真影響。

直通 直通線：一種校準標準。請參閱校準，SOLT。

濃淡 色度；色調。

切換 切換狀態，通常將某項功能從開啟改為關閉，或從關閉改為開啟。

TOM 直通-開路-配對：一個 Rohde&Schwarz 術語，表示一種校準方法。

軌跡 包含頻率和回應資訊的一系列資料點。多個資料點系列通常稱為陣列。儀器有其特定的軌跡數。

追蹤 分析儀的接收器的功能，可在量測頻率範圍內調諧為來源頻率。追蹤不當會導致出現幅度和相位誤差，因為接收器 IF 電路會使測試中裝置輸出出現衰減和延遲。

傳輸功能 輸出訊號與激勵訊號的比率，兩個訊號都是頻率的函數。

傳輸 請參閱傳輸量測。

傳輸互調變散射 對發送器抑制互調變失真產物的產生的功能的一種量測方法。互調變散射有時稱為互調變衰減。

傳輸量測 裝置的傳輸功能的特性，即輸出訊號與入射訊號的比率。最常見的量測包括增益、插入衰減、傳輸係數、插入相位及群組延遲，這些量測全部都會隨著頻率的變化而變化。另請參閱 S 參數。

傳輸/反射 (T/R) 指由純量或向量網路分析儀進行的一套量測，以表徵裝置隨著頻率的變化而變化的行為。另請參閱 S 參數。

透明 對使用者不可見的事物。通常是在使用者未參與或不知情的情況下發生的過程。

觸發 促使儀器進行量測的訊號。使用者可以選取多個觸發選項，例如手動、連續或外部（使量測與外部來源同步）。

TRL 直通-反射-線路。請參閱校準，TRL 和 LRM。

TTL 電晶體-電晶體邏輯

2 連接埠誤差修正 請參閱誤差修正，12 項。

U

未修正 在未執行誤差修正的情況下進行量測。

非耦合通道 允許為每個通道單獨設定的激勵或接收器設定。

UNI 使用者網路介面：使用者連接至網路的點。

單位 量測數量的尺寸。單位通常指幅度數量，因為它們可以變更。在包含微處理器的分析儀中，可用的單位為 dBm（dB 相對於消散在標稱輸入阻抗中的 1 mW）、dBmV（dB 對於 1 mV）、dBW（dB 對於 1 1W）、V（伏特）、W（瓦特）。

V

變數 一種符號，其值可從程式的一個迭代變更為下一個迭代，或在程式的每個迭代之內變更。

向量 同時具有幅度和相位的數量。

這是一種能夠量測幅度和相位的網路分析儀。

VEE 視覺化工程環境（Keysight 軟體產品）

速度係數 與通過具有不同電介體的傳輸線的能量速度相關的數值（對聚乙烯為 0.66）。在進行時域量測時使用。

垂直解析度 儀器對兩個訊號之間的幅度的區分程度。

視訊 包含時序、強度（也經常包含色彩資訊）的電子訊號，此訊號可在顯示後產生視覺影像。

視訊頻寬 在頻譜分析儀中，可調整低通濾波器在視訊電路中的截止頻率（3 dB 點）。當視訊頻寬等於或小於解析度頻寬時，視訊電路無法完全回應包絡偵測器更急劇的輸出波動。對於寬頻訊號（例如在寬頻模式下檢視時的雜訊和脈衝 RF），出現的結果是軌跡平滑或峰對峰偏離減小。平均程度或平滑程度是視訊頻寬與解析度頻寬的比率的函數。

視訊濾波器 頻譜分析儀中用於執行後期偵測的低通濾波器，可確定視訊放大器的頻寬。此濾波器用於計算軌跡的平均值或使軌跡平滑。另請參閱視訊頻寬。

VNA 向量網路分析儀

W

波形 訊號的表示法，繪製了幅度與時間的關係。

無線 此術語是指眾多可為家庭或辦公室提供行動通訊的技術，以及可延伸工作區、園區或商業綜合體的行動性的「室內無線技術」。此術語也用於表示室內外行動服務的「電信通訊」。

WWW 全球資訊網

X

Y

Z

零長度直通路徑 在量測校準中，當兩條測試纜線直接連接到一起而不使用配接器或直通線時產生的路徑。另請參閱非插入式裝置。


應用程式

VNA 應用程式

E5080A

選件 | 應用程式
010 | 時域
009 | 頻率偏移
790 | 量測輔助精靈

另請參閱

  • 所有 VNA 型號和選件

上次修改時間：

2014 年 08 月 22 日

第一版


轉換壓縮

  • 什麼是轉換壓縮？

  • 為何要量測轉換壓縮？

  • 如何量測轉換壓縮

  • 量測準確度考量

瞭解其他頻率轉換裝置量測

什麼是轉換壓縮？

轉換壓縮是針對每個混波器將產生的線性操作，進行最大輸入訊號等級的測量。這非常類似於在放大器中增益壓縮的情況。

若要瞭解轉換壓縮，您必須先瞭解轉換損耗。這是混頻器輸出等級對混頻器輸入等級的比率。在特定輸入功率範圍內，此值保持不變。當輸入功率位準超過一定的最大位準，輸入功率位準和輸出功率位準間的恆定比率開始發生變化。此點位於該比率下降 1 dB 的位置，稱為 1-dB 壓縮點。如下圖所示。

為何要量測轉換壓縮？

轉換壓縮是裝置動態範圍的一項指示器。動態範圍通常定義為雜訊基準和 1-dB 壓縮點之間的差異。

如何量測轉換壓縮

用來量測轉換壓縮的設備和設定與用來量測轉換損耗的設備和設定基本上是一樣的，如下圖所示。

VNA 使用頻率偏移模式執行功率掃描，由此出現的顯示結果會將混波器輸出功率顯示為其輸入功率的函數。可以使用標記來確定 1-dB 壓縮點（或諸如 3-dB 等其他壓縮點）。

量測準確度考量

設備設定考量

  • VNA 中的耦合器具有良好的方向性。如果受測裝置回波損耗不理想，將透過 VNA 對反射的訊號進行取樣，並且可能會導致誤差。這與受測裝置增益中的誤差相關。若要提高準確度，可在 VNA 來源連接埠和受測裝置的輸入連接埠之間新增衰減器。一般 6 至 10-dB 衰減器即足夠。然而，新增此衰減器會減少受測裝置的可用驅動。

  • 透過高度驅動位準，可推動 VNA 進行壓縮，由此導致量測誤差。由於過度驅動位準，VNA 可能會受損。在受測裝置的輸出和 VNA 的接收器輸入之間新增衰減器以避免這些問題。

校準考量

  • 來源校準 可用來為量測提供高度準確性。


Conversion Loss

Conversion Loss (or Gain)

  • What is Conversion Loss?

  • Why Measure Conversion Loss?

  • How to Measure Conversion Loss

See other Frequency Converting Device Measurements

What is Conversion Loss?

Conversion loss is defined as the ratio of the power at the output frequency to the power at the input frequency with a given LO (local oscillator) power. This is illustrated in the graphic below. A specified LO power is necessary because conversion loss varies with the level of the LO, as the impedance of the mixer diode changes.

Why Measure Conversion Loss?

Conversion loss (or gain in the case of many converters and tuners) is a measure of how efficiently a mixer converts energy from the input frequency to the output frequency. If the conversion loss response of a mixer or converter is not flat over the frequency span of intended operation, valuable information may be lost from the resulting output signal.

How to Measure Conversion Loss

Conversion loss is a transmission measurement. It is measured by applying an input signal (stimulus) and an LO signal at specific known power levels, and measuring the resulting output signal level. Because the output frequency is different from the input frequency, frequency offset mode must be used for this measurement.

Note: This measurement is made much easier if your VNA has the Frequency Converter Application

Equipment Setup

Example: A calibrated Conversion Loss (Down-converter) measurement

Swept Input with Fixed LO = Swept Output

  • RF Input: 3.1 - 3.3 GHz

  • LO: 2.2 GHz

  • IF Output: 900 - 1100 MHz

VNA setup and calibrate on channel 1

  1. On channel 1 create an unratioed R measurement over the ENTIRE input and output frequency span (.9 - 3.3 GHz). This will be the base source power cal that will be copied to the R and B channel measurements.

  2. Perform a source calibration using a power meter. This makes the power level at the input of the mixer very accurate.

Setup Reference measurement on channel 2

  1. Copy channel 1 to channel 2 which will display the reference input to the mixer. The channel 1 source power cal is copied with the other channel settings.

  2. Change measurement to R1 unratioed.

  3. Change RF Input frequency to 3.1 - 3.3 GHz. The source power cal becomes interpolated.

  4. Perform receiver power cal. Do not need to make physical connections. The VNA source is internally connected to the R1 receiver. Makes the R receiver read the source power level.

Setup B measurement on channel 3

  1. Copy channel 1 to channel 3. This channel will display the output of the mixer. The channel 1 source power cal is copied with the other channel settings.

  2. Change measurement to B unratioed.

  3. Change IF Output frequency to .9 - 1.1 GHz. This causes the source power cal becomes interpolated.

  4. Connect thru line from port 1 to port 2.

  5. Perform receiver power cal. This makes the B receiver read the source power at the IF Output frequencies.

  6. Turn OFF receiver power cal. This prevents an error when changing to input frequencies (next step).

  7. Change RF Input frequency to 3.1 - 3.3 GHz. This changes the channel back to the mixer RF Input frequencies.

  8. Enable Frequency Offset.

  9. Change Offset to (-2.2 GHz). This tunes the B receiver to the IF Output frequencies .9 to 1.1 GHz. Note: The minus sign indicates a down-converter measurement.

  10. Turn ON receiver power cal.

Measure the Mixer

  1. Connect the mixer.

  2. Adjust scale to suit your needs.

  3. Enable markers to read power levels for each trace.

The display below shows:

  • Ch3 B receiver (bottom trace) absolute output power.

  • Ch2 R1 receiver measurement (top trace) absolute input power to the mixer.

With this method, the conversion loss math (B/R1) can be performed with Equation Editor (not shown). The B/R1 ratio measurement is not supported with receiver power Cal turned on. However, conversion loss (C21) measurements can be made directly and are much easier using the Frequency Converter Application, FCA (Opt 083).


Frequency Converting Device Measurements Overview

Frequency Converting Device Measurements

Many frequency offset measurements can be made using the VNA with option 080. The following is a list of some of those measurements and how they are made.

  • Conversion Loss

  • Conversion Compression

  • Return Loss and VSWR

  • Isolation

  • Harmonic Distortion

See Also: Frequency Offset Measurement Accuracy


Frequency Offset Calibration

Frequency Offset Measurement Accuracy

This topic discuss methods that can be used to make accurate frequency offset measurements.

  • Calibrations

  • Mismatch Errors

  • Accurate and Stable LO

See other Mixer Measurement topics

Calibrations

With Frequency Offset measurements, the stimulus and response frequencies are different. Standard calibration error terms are calculated using reference measurements. Therefore, traditional calibration methods such as full 2-port SOLT cannot be used with frequency offset.

Source and Receiver Power calibrations can be used to calibrate your Frequency Offset measurements.

Source Power calibration:

  • Sets accurate power level at stimulus frequencies regardless of the receiver that will be used in the measurement.

  • Can be copied to other channels with copy channels feature.

  • Can be interpolated.

Receiver Power Cal:

  • Requires a source cal to have already been performed and applied.

  • Cannot be copied to other channels.

Therefore:

  • Start by performing a source power cal over the combined stimulus and response frequencies.

  • Copy the channel to other needed channels and the source power cal is copied.

  • Change the frequency range of the copied channel to response frequencies.

  • Perform a receiver cal at the response frequencies on individual channels.

  • Change the frequency range to stimulus frequency and switch frequency offset ON.

  • On Status Bar, ensure that source and receiver cals are ON (source cal will be interpolated).

See Frequency Offset Conversion Loss Measurements to see a step-by-step example.

Mismatch Errors

Mismatch errors result when there is a connection between two ports that have different impedances. With S-parameter measurements, these mismatches are measured and mathematically removed during a full 2-port calibration. This is much more difficult with frequency offset measurements. A much easier solution is to use high-quality attenuators on the input and output of the mixer.

By adding a high-quality attenuator to a port, the effective port match can be improved by up to twice the value of the attenuation. For example, a 10-dB attenuator, with a port match of 32 dB, can transform an original port match of 10 dB into an effective match of 25 dB. However, as the match of the attenuator approaches the match of the original source, the improvement diminishes.

The larger the attenuation, the more nearly the resulting match approaches that of the attenuator, as shown in the following graphic. However, excessive attenuation is not desired because that will decrease the dynamic range of the measurement system.

Accurate and Stable LO

When using frequency offset mode, if the LO signal is not accurate and stable, the output signal will not be at the expected response frequency. As a result, the output signal can fall on the skirts of the VNA receiver IF filter, or fall completely outside of the receiver filter passband.

Also, the LO power level is critical in mixer measurements. Be sure to monitor these power levels closely.


Harmonic Distortion

  • What is Harmonic Distortion?

  • Why Measure Harmonic Distortion?

  • How to Measure Harmonic Distortion

  • Measurement and Accuracy Considerations

See other Frequency Converting Device Measurements

What is Harmonic Distortion?

Harmonics are multiples of any signal appearing at the mixer input and also multiples of the LO input. The distortion of the mixer's output characteristics caused by these harmonics is referred to as harmonic distortion. Harmonic distortion is caused by non-linearities in the device.

Harmonics are NOT signals created by two or more signals interacting (mixing); these signals are known as intermodulation products, which result in intermodulation distortion.

Why Measure Harmonic Distortion?

  • It can degrade the performance of devices connected to the output of the mixer.

  • The harmonics can also mix with other signals present in the mixer, adding to the intermodulation distortion of the mixer.

How to measure Harmonic Distortion

The harmonics can be measured using the VNA with Frequency Offset. The frequency of the LO to the mixer is set to zero and multiplier of the RF input is used to set the IF frequency (the harmonic). The equipment setup is shown below.

Since harmonics are specified in dBc, the fundamental RF and both the second and third harmonics are measured and the differences calculated. Multiple channels can be used to do this.

  1. Connect the equipment.

  2. Setup the measurement for calibration. See also Measurement and Accuracy Considerations.

Use three channels and frequency offset mode:

Channel 1 = F1 to F2

Channel 2 = F1 to 2F2 (frequency offset mode, multiplier = 1)

Channel 3 = F1 to 3F2 (frequency offset mode, multiplier = 1)

  • Perform a source power calibration and receiver power calibration over the entire frequency range. See Measurement and Accuracy Considerations.

  • Reduce the frequency span and increase the frequency offset multiplier on Channels 2 and 3:

Channel 2 = F1 to F2 (frequency offset mode, multiplier = 2)

Channel 3 = F1 to F2 (frequency offset mode, multiplier = 3)

Note: Because the frequency span has been changed from that used for calibration, the source and receiver calibrations will be interpolated.

  • Connect the DUT, make the measurement, and calculate the harmonic response:

Set up markers on Channels 1, 2 and 3, and determine the difference between the marker values to get the dBc value of each harmonic.

Channel 1 - Channel 2 = 2nd harmonic (dBc)

Channel 1 - Channel 3 = 3rd harmonic (dBc)

Note: Be sure to set the markers to the appropriate stimulus. Channel 2 markers should be set to twice the frequency of Channel 1 markers. Channel 3 markers should be set to three times the frequency of Channel 1 markers.

Measurement and Accuracy Considerations

Equipment Setup Considerations

  • A filter must be used at the input of the mixer to remove the VNA source harmonics.


Isolation

Isolation Measurements of Frequency Converting Devices

  • What is Isolation?

  • Why Measure Isolation?

  • How to Measure Isolation

See other Frequency Converting Device Measurements

What is Isolation?

Isolation is a measure of the leakage, or feedthrough, from one port to another. The more isolation a mixer provides, the lower the amount of feedthrough. Isolation is measured at the same frequency as the stimulus, not the converted or shifted frequency. Therefore, Frequency Offset capability is not necessary for these measurements.

Three main isolation terms are of interest for mixer measurements:

  • LO-to-OUT isolation (VLO)

  • LO-to-IN isolation (VLO)

  • IN-to-OUT feedthrough (VIN)

Why Measure Isolation?

Any unwanted signal "leaking" through the device will mix with the desired output signal creating intermodulation products, adding to intermodulation distortion. These unwanted signals may be difficult to filter out.

How to Measure Isolation

Use the following setups to measure the isolation of a mixer:

Note the following:

  • The Input to Output isolation is very dependent on the LO power level. Isolation should be measured with the LO power at its normal operating level.

  • Each of the ports not being tested should be terminated with an impedance typical of actual operation. This may not always be the characteristic impedance, Z0 (usually 50 or 75 ohms). For example, if the OUT port of a mixer is intended to be directly connected to a filter, then this filter should be used when measuring the LO-to-IN feedthrough.

LO-TO-IN ISOLATION

LO-TO-OUT ISOLATION

IN-TO-OUT ISOLATION

Measuring Converters vs. Mixers

Measuring IN-to-OUT feedthrough of a converter is identical to that of a mixer. The IN-to-OUT feedthrough is generally very small for a converter due to the inclusion of an IF filter in the device. Because of this, the measurement may require the VNA to have increased dynamic range.

Measuring LO leakage (LO-to-OUT and LO-to-IN) of a converter requires a different technique because the LO port is typically not accessible:

  • The VNA can be tuned to the frequency of the LO signal and either the OUT or IN port connected to the VNA receiver port. The VNA source port is not connected.

  • A spectrum analyzer can be connected to either the OUT or IN port and tuned to the frequency of the LO signal.


量測精靈助手

  • MWA 軟體簡介

  • MWA 操作要求

  • MWA 軟體安裝

  • 使用 MWA 前端應用程式建立規格表

  • 在 VNA 中執行後端應用程式

  • 多連接埠交換器量測範例

  • 群組的概觀和限制


Accessing Data

Click a box or circle to view details:

See 8510 data processing mode.

See larger Data Processing map.

Measurement - VNA receivers gather complex trace data which is ratioed if required by the parameter, such as S11 or A/B. Otherwise it is raw receiver data, such as A or B. See Measurement Parameters.

Averaging - If turned ON, data is averaged with specified number of measurement traces. See Averaging.

Data Access Point 0 - Get or Put RAW MEASUREMENT data using:

SCPI - Write data using Calc:Meas:Data:SDATA - Read data from Data Access Point 1

Formatting Note:

SCPI - you can only request data in the displayed format.

Acquired Cal Data - Calibration standards are measured. When the calibration is complete, complex data is stored in a Cal Set.

Data Access Point 6 - Get or Put RAW CAL ACQUISITION data using:

SCPI - None

Calculate Error Terms - Error terms are calculated from Acquisition data using formulas which are appropriate for the selected calibration method. Complex error terms are stored in a Cal Set. See Systematic Errors.

Data Access Point 5 - Get or Put ERROR TERM data using:

SCPI - Calc:Meas:Data Error Terms

Note: Normalization, formerly access location 5, no longer exists and was used ONLY by Receiver Power Cal. That cal type now uses Acquire Cal Data and Calculate Error Terms like all other Cals.

Apply Error Terms - If error correction is ON, error terms are applied to the raw measurement data. Otherwise, this data is identical to Raw Measurement Data.

Data Access Point 1 - Get or Put CORRECTED data using:

SCPI - Read data using Calc:Meas:Data:SDATA - Write data to Data Access Point 0

See Formatting Note

Equation Editor - Allows custom equations to perform advanced math operations between data traces. See Equation Editor

See Equation Editor Notes:

SCPI: Calc:Meas:Data

Normalization - No longer available

Data Access Point 5 - - No longer available

Trace Math - When turned ON, memory data is combined with measurement data using the selected math function. Available functions are: Data+Mem, Data-Mem, Data*Mem, and Data/Mem. See Math Operations.

Memory - Data that is stored as a result of a Data-To-Memory operation. Each measurement can have one memory trace. The memory data parallels the measurement data through the remaining processing blocks. For example, turning smoothing ON will smooth both the measurement and memory traces.

Data Access Point 3 - Get or Put MEMORY data using:

SCPI - Calc:Meas:Data:SMEM

See Formatting Note

Gating - When turned ON, Filter Gating is applied to the measurement data. Gating "virtually" removes undesired responses from selected regions of the trace. See Gating.

Phase Correction - When turned ON, applies electrical delay, phase offset, and port extensions. These are all separate features that are controlled individually.

Magnitude Offset - When entered, offset values are applied to the magnitude (real) portion of the data. See Magnitude Offset.

Time Domain - When turned ON, transforms the data from the frequency domain to the time domain. See Time Domain

Formatter - Complex data is converted into scalar data formats for screen display and remote access. For smoothed data, request the data in the same format as the displayed data. See Data Format

Smoother - When turned ON, removes discontinuities in the measurement and memory trace. See Smoothing.

Display - Displays the processed measurement, memory data, or both, in the format of your choice.

Data Access Point 2 - Get or Put MEAS RESULT data using:

SCPI - Calc:Meas:Data:FDATA

Data Access Point 4 - Get or Put MEMORY RESULT data using:

SCPI - Calc:Meas:Data:FMEM

See Formatting Note

Last Modified:

6-Jan-2016

First release


CFCal Topic

Unguided | SmartCal(Guided) | ECAL | Guided Power Cal | Cal All | Save-Recall | Cal Sets | Cal Types | Prefer's |Correction | Port Ext | Fixturing | Delta Match | Cal Kits | Standards | Multiple Sensors | Source Pwr Cal | Power Sensors | Receiver Cal | Cal Data | CalPod | Custom Cal Window

Description | SCPI See Calibrating the VNA Using SCPI See Also: Calibration commands for Apps | COM
Perform an Unguided Calibration
Launch Cal Wizard | SYST:CORR:WIZard |
Set Cal Type | SENS:CORR:COLL:METHod |
Select a Cal Kit | SENS:CORR:COLLect:CKIT |
Get a Handle to the Active Cal Kit | N/A |
Simultaneous 2-Port Calibration | SENS:CORR:TSTandards |
Acquisition Direction | SENS:CORR:SFORward |
Measure a Standard | SENS:CORR:COLLect |
Calculate Errors | SENS:CORR:COLL:SAVE |
Do Isolation | SENS:CORR:COLLect |
Perform and apply Response (Normalization) cal | SENS:CORR:COLL:METHod |

Perform a Guided Cal
Initiate a Guided Cal | SENS:CORR:COLL:GUID:INIT
List valid Connector Types for a Port | SENS:CORR:COLL:GUID:CONN:CAT?
List valid Cal Kits for a Connector type. | SENSe:CORR:COLL:GUID:CKIT:CAT?
Select a Connector Type | SENS:CORR:COLL:GUID:CONN:PORT
Select a Cal Kit | SENS:CORR:COLL:GUID:CKIT:PORT
Set cal method for each port pair. | SENS:CORR:COLL:GUID:PATH:CMET
Set Thru Method for each port pair. | SENS:CORR:COLL:GUID:PATH:TMET
Set Thru Port Pairs | SENS:CORR:COLL:GUID:THRU:PORT
Return Number of Steps in a Cal | SENS:CORR:COLL:GUID:STEPs?
Return a Description of a Cal Step | SENS:CORR:COLL:GUID:DESC?
Measure a Cal Standard in a Guided Cal | SENS:CORR:COLL:GUID:ACQuire
Save Cal | SENS:CORR:COLL:GUID:SAVE
Adapter settings for Unknown Thru or Adapter Removal
Sets use of a THRU adapter | SENS:CORR:COLL:GUID:ADAP:CREate
Set adapter delay | SENS:CORR:COLL:GUID:ADAP:DELay
Set adapter description | SENS:CORR:COLL:GUID:ADAP:DESC
Set port pairs for adapter | SENS:CORR:COLL:GUID:ADAP:PATH
Clear the settings | SENS:CORR:COLL:GUID:ADAP:COUNt:ZERO
Return number of adapters | SENS:CORR:COLL:GUID:ADAP:COUNt?

Optional Guided Cal commands
Auto-Orient ECal | SENS:CORR:PREF:ECAL:ORI
Manual orient ECAL | SENS:CORR:PREF:ECAL:PMAP
Read orientation | SENS:CORR:CKIT:ECAL:ORI?
Calculate Error Terms from a Guided Cal | SENS:CORR:COLL:GUID:SAVE
Save Cal to an existing Cal Set GUID | SENS:CORR:COLL:GUID:SAVE:CSET
Load Eterms during a cal | SENS:CORR:COLL:GUID:ETERms:LOAD
Perform Isolation | SENS:CORR:COLL:GUID:ISOL:PATHs
Increment Avg for Isolation | SENS:CORR:COLL:GUID:ISOL:AVER:INCR
Abort Guided cal | SENS:CORR:COLL:GUID:ABORt

Perform Enhanced Response Cal
Set guided Cal method | SENS:CORR:COLL:GUID:PATH:CMET
Set guided Thru method | SENS:CORR:COLL:GUID:PATH:TMET

Perform Sliding Load Acquisition
Set preference to not prompt | SENS:CORR:COLL:GUID:PREF:SLID
Read iteration step | SENS:CORR:COLL:GUID:ITER:COUNt?
Read minimum iterations | SENS:CORR:COLL:GUID:ITER:MIN?
Reset iterations | SENS:CORR:COLL:GUID:ITER:RESet

Perform an ECAL
Specify Module and Characterization | SENS:CORR:COLL:ACQ
Do ECAL 1-Port | SENS:CORR:COLL:CKIT 99
Do ECAL 2-Port | SENS:CORR:COLL:CKIT 99
Get ECAL Module Info | SENS:CORR:COLL:CKIT:INF? SENS:CORR:CKIT:ECAL:INF?
Get list of ECal Modules attached to VNA | SENS:CORR:CKIT:ECAL:LIST?
Get list of characterizations in ECal module | SENS:CORR:CKIT:ECAL:CLISt?
Perform Module Orientation during calibration | SENS:CORR:PREF:ECAL:ORI
Maps ECAL Module to VNA Ports | SENS:CORR:PREF:ECAL:PMAP
Reads ECal orientation | SENS:CORR:CKIT:ECAL:ORI?
Perform ECal Isolation | SENS:CORR:COLL:ISOL:ECAL
Increment Avg for ECal Isolation | SENS:CORR:COLL:ISOL:AVER:INCR

Perform ECal User Characterizations
Perform User ECal Characterization | All SCPI commands
Manage VNA Disk Memory Characterizations
Delete disk memory characterizations. | SENSe:CORR:CKIT:ECAL:DMEMory:CLEar
Saves a disk memory characterization to an archive file. | SENS:CORR:CKIT:ECAL:EXPort
Imports the ECal characterization from the specified archive file. | SENSe:CORR:CKIT:ECAL:DMEMory:IMPort
Reads the user-characterization info from ECal module or VNA disk memory. | SENS:CORR:CKIT:ECAL:KNAM:INF?

ECal Confidence Check
Confidence Check Parameter | SENS:CORR:CCH:PAR
Confidence Check Acquire | SENS:CORR:CCHeck
Confidence Check Done | SENS:CORR:CCH:DONE
Set/Read ECal State
Sets the state of an ECAL module | CONT:ECAL:MOD:PATH:STATe
Read ECal state data | SENS:CORR:CKIT:ECAL:PATH:DATA?
Read number of ECal states for specified path | CONT:ECAL:MOD:PATH:COUNt? SENS:CORR:CKIT:ECAL:PATH:COUNt?

Calibrate All Channels
Select the channels to be calibrated. | SYST:CAL:ALL:CHAN:SEL
Set the IFBW | SYST:CAL:ALL:IFBW
Set the power level | SYST:CAL:ALL:PORT:SOUR:POW
Set the power offset | SYST:CAL:ALL:PORT:SOUR:POW:OFFS
Set the receiver atten | SYST:CAL:ALL:PORT:SOUR:POW:REC:ATT
Set the source atten | SYST:CAL:ALL:PORT:SOUR:POW:ATT
Set the User Calset Prefix | SYST:CAL:ALL:CSET:PREFix
Set Path Configuration | SYST:CAL:ALL:PATH:CONF:ELEM
Read unique Cal properties | SYST:CAL:ALL:MCL:PROP:NAME:CAT?
Read unique property values | SYST:CAL:ALL:MCL:PROP:VAL:CAT?
Set property name/value | SYST:CAL:ALL:MCL:PROP:VAL
Read Cal channel | SYST:CAL:ALL:GUID:CHAN?
Get GuidedCal handle | N/A
For each channel, sets the ports to be calibrated. | SYST:CAL:ALL:CHAN:PORT
Returns a final list of ports to be calibrated. | SYST:CAL:ALL:GUID:PORT?
Read generated Cal Sets | SYST:CAL:ALL:CSET:CATalog?

Recall / Save / Apply a Calibration or Error Term
Recall a Calibration | SENS:CORR:CSET
Apply a Calibration to a measurement | SENS:CORR:CSET
Save a Calibration | SENS:CORR:CSET:SAVE
Save or Recall an Error Term | CALC:DATA Scorr
Read/ Write Cal Set data | SENS:CORR:CSET:DATA
Apply an Error Term after Uploading | SENS:CORR:COLLect:APPLy
Cal Sets
Create a Cal Set | SENS:CORR:CSET:CREate
Delete a Cal Set | SENS:CORR:CSET:DEL
List Cal Sets | SENS:CORR:CSET:CAT?
List Cal Sets in VNA | None
Get Cal Set Information | None
List Cal Set Error Terms | SENS:CORR:CSET:ETERM:CAT?
Return if a Cal Set exists | CSET:EXISts?
Select a Cal Set by GUID | SENS:CORR:CSET:GUID
Apply a Cal Set to a channel | SENS:CORR:CSET:ACTivate
Copy a Cal Set | SENSe:CORR:CSET:COPY
Save a Cal Set | SENS:CORR:CSET:SAVE
Save Cal Sets | None
Automatically save to User Cal Set | SENS:CORR:PREF:CSET:SAVE
Change the Description of a Cal Set | SENS:CORR:CSET:DESC
Change the Name of a Cal Set | SENS:CORR:CSET:NAME
Recall a Cal File | SENS:CORR:CSET
Save 'in-memory' Cal Set to disk. | SENS:CORR:CSET:FLATten
Create Cal Set with De-embeded fixture removed. | CSET:FIXTure:DEEMbed
Create Cal Set with Matching Network included. | CSET:FIXTure:EMBed
Adds stimulus data to a specific buffer. | None
Returns the stimulus values over which the specific error term was acquired. | None
Returns FOM stimulus values from a Calset. | SENS:CORR:CSET:STIM?
Cal Set Items
Set or get name-value pair from cal set | None
Remove name-value pair from cal set | None
Enumerate name-value pair items in the cal set. | None

Apply Cal Types
Catalog ALL Cal Types for the VNA | SENS:CORR:TYPE:CAT?
Catalog Cal Types in the Cal Set | SENS:CORR:CSET:TYPE:CAT?
Is a specific Cal Type contained in the Cal Set? | None
Set and return the measurement Cal Type | CALC:CORR:TYPE ?
Set port to measure QSOLT reflection standards. | None

Correction Settings
Turn Correction ON|OFF for a channel | SENS:CORR
Turn Correction ON|OFF for a measurement | CALC:CORR
Interpolation ON|OFF | SENS:CORR:INT
Returns the error correction state for the measurement | CALC:CORR:INDicator?

Preferences
Set default Cal Set Save behavior | SENS:CORR:PREF:CSET:SAVE
Sets behavior for simulated cal | SENS:CORR:PREF:SIMCal
External or internal trigger during cal | SENS:CORR:PREF:TRIG:FREE
Set ECal Auto-orient | SENS:CORR:PREF:ECAL:ORI
Set ECal Port Map | SENS:CORR:PREF:ECAL:PMAP
Set default Cal Type | None

Port Extensions
Extensions ON|OFF | SENS:CORR:EXT
Port 1 Extensions Value | SENS:CORR:EXT:PORT
Port 2 Extensions Value | SENS:CORR:EXT:PORT
Set Freq 1|2 | SENS:CORR:EXT:PORT:FREQ
Set Loss 1|2 | SENS:CORR:EXT:PORT:LOSS
Use 1|2 | SENS:CORR:EXT:PORT:INCL
Set Loss at DC | SENS:CORR:EXT:PORT:LDC
Relative Velocity | SENS:CORR:RVEL:COAX
Port Ext in distance | SENS:CORR:EXT:PORT:DIST
Set distance units | SENS:CORR:EXT:PORT:UNIT
Set Media per port | SENS:CORR:EXT:PORT:MEDium
Set waveguide cutoff freq per port | SENS:CORR:EXT:PORT:WGCutoff
Set Velocity Factor per port | SENS:CORR:EXT:PORT:VELF
Couple to system Velocity Factor | SENS:CORR:EXT:PORT:SYSV
Couple to system Media type | SENS:CORR:EXT:PORT:SYSM

Auto Port Extensions
Measure OPEN or SHORT for Auto Port Ext. | SENS:CORR:EXT:AUTO:MEASure
Sets the frequencies used for Auto Port Ext. calculation. | SENS:CORR:EXT:AUTO:CONFig
Include loss correction in Auto Port Ext.? | SENS:CORR:EXT:AUTO:LOSS
Include DC Offset in Auto Port Ext.? | SENS:CORR:EXT:AUTO:DCOF
Enable specified port for Auto Port Ext.. | SENS:CORR:EXT:AUTO:PORT<n>
Clears old port extension delay and loss data. | SENS:CORR:EXT:AUTO:RESet
Set user span start frequency for Auto Port Ext. | SENS:CORR:EXT:AUTO:STARt
Set user span stop frequency for Auto Port Ext. | SENS:CORR:EXT:AUTO:STOP

Fixturing Commands
Turn fixturing ON and OFF | CALC:FSIM:STAT
Change order of operations | CALC:FSIM:SEND:OORD
2and 4-port Extrapolate | CALC:FSIM:SNP:EXTR
2-Port Fixturing
Port matching ON and OFF | CALC:FSIM:SEND:PMC:STAT
Reverse ports | CALC:FSIM:SEND:DEEM:PORT<n>:SNP:REV
Sets Port Matching circuit model. | CALC:FSIM:SEND:PMC:PORT:TYPE
Sets Port Matching 'S2P' file name. | CALC:FSIM:SEND:PMC:PORT:USER:FIL
Sets Capacitance 'C' value. | CALC:FSIM:SEND:PMC:PORT:PAR:C
Sets Conductance 'G' value. | CALC:FSIM:SEND:PMC:PORT:PAR:G
Sets Inductance 'L' value. | CALC:FSIM:SEND:PMC:PORT:PAR:L
Sets Resistance 'R' value. | CALC:FSIM:SEND:PMC:PORT:PAR:R
De-embed ON and OFF | CALC:FSIM:SEND:DEEM:PORT:STAT
Sets De-embedding circuit model. | CALC:FSIM:SEND:DEEM:PORT
Sets De-embedding 'S2P' file name. | CALC:FSIM:SEND:DEEM:PORT:USER:FIL
Port Impedance ON and OFF | CALC:FSIM:SEND:ZCON:STAT
Port Z Real | CALC:FSIM:SEND:ZCON:PORT:REAL
Port Z Imag | CALC:FSIM:SEND:ZCON:PORT:IMAG
Port Z Real and Imag | CALC:FSIM:SEND:ZCON:PORT:Z0
4-Port Network Embed/De-embed commands
Specifies the VNA / DUT topology | CALC:FSIM:EMB:TYPE
Specifies the 4-port touchstone file | CALC:FSIM:EMB:NETW:FIL
Embed|De-embed? | CALC:FSIM:EMB:NETW:TYPE
Specify VNA port connections | CALC:FSIM:EMB:TOP:A:PORT CALC:FSIM:EMB:TOP:B:PORT CALC:FSIM:EMB:TOP:C:PORT
4-port remap | CALC:FSIM:EMB:NETW<n>:PMAP
Turn ON or OFF | CALC:FSIM:EMB:STAT
Differential Port Arbitrary Impedance
Sets the impedance value | CALC:FSIM:BAL:DZC:BPOR:Z0
Sets real part of impedance | CALC:FSIM:BAL:DZC:BPOR:REAL
Sets imaginary part of impedance | CALC:FSIM:BAL:DZC:BPOR:IMAG
Turn ON or OFF | CALC:FSIM:BAL:DZC:STAT
Common Mode Port Arbitrary Impedance
Sets the impedance value | CALC:FSIM:BAL:CZC:BPOR:Z0
Sets real part of impedance | CALC:FSIM:BAL:CZC:BPOR:REAL
Sets imaginary part of impedance | CALC:FSIM:BAL:CZC:BPOR:IMAG
Turn ON or OFF | CALC:FSIM:BAL:CZC:STAT
Differential Port Matching
Sets type of circuit to embed. | CALC:FSIM:BAL:DMC:BPOR
Specifies the 2-port touchstone file | CALC:FSIM:BAL:DMC:BPOR:USER:FIL
Sets Capacitance value | CALC:FSIM:BAL:DMC:BPOR:PAR:C
Sets Conductance value | CALC:FSIM:BAL:DMC:BPOR:PAR:G
Sets Inductance value | CALC:FSIM:BAL:DMC:BPOR:PAR:L
Sets Resistance value | CALC:FSIM:BAL:DMC:BPOR:PAR:R
Turns ON/OFF | CALC:FSIM:BAL:DMC:STAT
Power Compensation
Compensate source power | CALC:FSIM:SEND:POW:PORT:COMP
Remote ONLY
Create Cal Set with De-embeded fixture removed. | CSET:FIXTure:DEEMbed
Create Cal Set with Matching network included. | CSET:FIXTure:EMBed

Global Delta Match Cal
Initiate Cal | SENS:CORR:COLL:GUID:DMAT
Read ports that require Cal | SENS:CORR:COLL:GUID:DMAT:APPLy:PORT?
Apply a Cal | SENS:CORR:COLL:GUID:DMAT:APPLy

Manage and Modify Cal Kits
Set a Cal Kit Active | SENS:CORR:COLL:CKIT
Clear all Cal Kits from VNA | SENS:CORR:CKIT:CLE
Get a Handle to the Active Cal Kit |
Save All Cal Kits after Modifying |
Load collection of Kits | SENS:CORR:CKIT:LOAD
Load (Recall) All Cal Kits |
Import a specified kit. | SENS:CORR:CKIT:IMPort
Restore Cal Kit Default | SENS:CORR:COLL:CKIT:RESet
Restore ALL Cal Kits Default | SENS:CORR:CKIT:INITialize
Build a Hybrid Cal Kit |
Set the Name of a Cal Kit | SENS:CORR:COLL:CKIT:NAME
Set a description of a Cal Kit | SENS:CORR:COLL:CKIT:DESC
Get the amount of installed kits | SENS:CORR:CKIT:COUNt?
Set the Port Label of a Cal Kit |
Saves a Cal Kit to a file. | SENS:CORR:CKIT:EXP
Modify TRL Cal Kit
Set reference plane | SENS:CORR:COLL:CKIT:TRL:RPLane
Set impedance standard | SENS:CORR:COLL:CKIT:TRL:IMPedance
Set LRL auto-characterization | SENS:CORR:COLL:CKIT:TRL:LRLChar

Modify Cal Standards
Select a Cal Standard | SENS:CORR:COLL:CKIT:STAN
Delete a standard | SENS:CORR:COLL:CKIT:STAN:REM
Change description of a standard | SENS:CORR:COLL:CKIT:STAN:SDES
Assign a Class to a Standard | SENS:CORR:COLL:CKIT:ORD1
Set Standard Type | SENS:CORR:COLL:CKIT:STAN:TYPE
Add connector family name | SENS:CORR:COLL:CKIT:CONN:ADD
Delete connector family name | SENS:CORR:COLL:CKIT:CONN:DEL
List connector family names used in a Cal Kit | SENS:CORR:COLL:CKIT:CONN:CAT?
Replace connector family name. | SENS:CORR:COLL:CKIT:CONN:FNAM
Assign connector family name to a standard | SENS:CORR:COLL:CKIT:CONN:SNAMe
Set Delay | SENS:CORR:COLL:CKIT:STAN:DEL
Set Loss | SENS:CORR:COLL:CKIT:STAN:LOSS
Set Impedance | SENS:CORR:COLL:CKIT:STAN:IMP
Set Max Frequency | SENS:CORR:COLL:CKIT:STAN:FMAX
Set Min Frequency | SENS:CORR:COLL:CKIT:STAN:FMIN
Set Label | SENS:CORR:COLL:CKIT:STAN:LAB
Set Medium (coax | waveguide) | SENS:CORR:COLL:CKIT:STAN:CHAR
Set Capacitance (C0 to C3) | SENS:CORR:COLL:CKIT:STAN:C0
Set Inductance (L0 to L3) | SENS:CORR:COLL:CKIT:STAN:L0
Set Arbitrary Impedance (TZReal, TZImag) | SENS:CORR:COLL:CKIT:STAN:TZReal
Modify TRL Cal Kit
Set reference plane | SENS:CORR:COLL:CKIT:TRL:RPLane
Set impedance standard | SENS:CORR:COLL:CKIT:TRL:IMPedance
Set LRL auto-characterization | SENS:CORR:COLL:CKIT:TRL:LRLChar

Guided Power Cal Use standard Source Power commands to make advanced settings. Use Power Sensor commands to configure the power sensor.
Perform power cal | SENS:CORR:COLL:GUID:PSENsor
Power sensor connector type | SENS:CORR:COLL:GUID:PSEN:CONN
Cal Kit for power cal | SENS:CORR:COLL:GUID:PSEN:CKIT
Power Level for cal | SENS:CORR:COLL:GUID:PSEN:POWer:LEVel
Perform match-correction | SENS:CORR:METHods:MATCh

Multiple Power Sensors See commands to configure a Power Meter as Receiver (PMAR)
Enable multiple sensors | SENS:CORR:COLL:GUID:PSEN:MULT
Add sensors | SENS:CORR:COLL:GUID:PSEN:MULT:ADD
Assign power sensor name | SENS:CORR:COLL:GUID:PSEN:MULT:NAME
Remove sensors | SENS:CORR:COLL:GUID:PSEN:MULT:REM
Read the number of configured sensors | SENS:CORR:COLL:GUID:PSEN:MULT:COUNt?
Set start freq | SENS:CORR:COLL:GUID:PSEN:MULT:FREQ:STAR
Set stop freq | SENS:CORR:COLL:GUID:PSEN:MULT:FREQ:STOP
Set connector type | SENS:CORR:COLL:GUID:PSEN:MULT:CONN
Set Cal Kit | SENS:CORR:COLL:GUID:PSEN:MULT:CKIT

Source Power Calibration
Copy Source Power cal to another channel | SYST:MACR:COPY:CHAN
GPIB Power Meter Address | SYST:COMM:GPIB:PMET:ADDR
Set source power cal method | SOUR:POW:CORR:COLL:ACQ
Turn correction ON|OFF | SOUR:POW:CORR
Applies correction values after completing a source power cal acquisition sweep. Optionally do reference receiver cal. | SOUR:POW:CORR:COLL:SAVE
Returns the currently-selected power sensor channel (A or B) for use at a specific frequency. | N/A
Set power level | SOUR:POW:CORR:LEV
Set power offset | SOUR:POW:CORR:OFFS
Set settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL
Set max readings for settling | SOUR:POW:CORR:COLL:AVER:COUNt
Set accuracy tolerance | SOUR:POW:CORR:COLL:ITER:NTOL
Set max readings for accuracy | SOUR:POW:CORR:COLL:ITER:COUNt
Turn ON|OFF display of readings | SOUR:POW:CORR:COLL:DISP
Acquire receiver-only readings | SOUR:POW:CORR:COLL:ACQ:REC
Initiates a source power cal acquisition. | SOUR:POW:CORR:COLL:ACQ
Aborts a source power cal acquisition sweep that is currently in progress. | SOUR:POW:CORR:COLL:ABOR
Launches the Power Meter Settings dialog on the VNA. | None
Frequency checking (ON|OFF) | SOUR:POW:CORR:COLL:FCH
Check test port power | None
Calibrate the source at multiple power levels. | None

Power Meter/Sensor settings See commands to configure a Power Meter as Receiver (PMAR) See commands to configure multiple power sensors for guided Power Cal
Specifies the type of power sensor to be used | SYST:COMM:PSEN
Specifies the location of the power sensor to be used. | SYST:COMM:PSEN
Returns the ID string of connected USB power meters / sensors. | SYST:COMM:USB:PMET:CAT?
Pwr meter Max Readings for settling | SOUR:POW:CORR:COLL:AVER:COUNt
Pwr meter settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL
Minimum Frequency | SOUR:POW:CORR:COLL:<>SEN
Maximum Frequency | SOUR:POW:CORR:COLL:<>SEN
Power meter channel |
Set sensor cal factor | SOUR:POW:CORR:COLL:<>SEN:RCF
Set table type | SOUR:POW:CORR:COLL:TABL <>SEN
Read/Write cal data | SOUR:POW:CORR:DATA
Use Loss table? | SOUR:POW:CORR:COLL:TABL:LOSS
Cal Factor Table | SOUR:POW:CORR:COLL:TABL:SEL
Read number of segments in table | SOUR:POW:CORR:COLL:TABL:POIN?
Segment number |
Add segment |
Cal factor of the segment | SOUR:POW:CORR:COLL:TABL:DATA
Frequency of the segment | SOUR:POW:CORR:COLL:TABL:FREQ
Power Loss Table | SOUR:POW:CORR:COLL:TABL:SEL
Read number of segments in table | SOUR:POW:CORR:COLL:TABL:POIN?
Segment number |
Add segment |
Frequency | SOUR:POW:CORR:COLL:TABL:FREQ
Loss value | SOUR:POW:CORR:COLL:TABL:DATA
Receiver Cal
Set offset from test port power | SENS:CORR:RPOWer:OFFSet[:AMPLitude]
Set cal method to receiver cal | SENS:CORR:COLL:METH RPOWer
Take measurement | SENS:CORR:COLL[:ACQ] POWer
Turn receiver cal ON | OFF | SENS:CORR[:STATe] ON|OFF
Do interpolation | SENS:CORR:INT[:STATe] ON|OFF

CalPod
Command used to send other commands as arguments | CONTrol:CALPod:COMMand
Start the CalPod software | Calpod:LAUNch
Assign Calpod serial number to a port. | Calpod:ENABle
Unassign Calpod serial number from a port. | Calpod:Disable
Initialize the selected channel | Calpod:INITialize:ACTive
Initialize ALL channels | Calpod:INITialize:ALL
Recorrect the selected channel | Calpod:Recorrect:ACTive
Recorrect ALL channels | Calpod:Recorrect:ALL
Show refresh dialog | Calpod:SHOW
Hide refresh dialog | Calpod:HIDE
Sets impedance state | Calpod:STATe
Read Calpod temperature | Calpod:TEMP?

Custom Cal Window
Turn ON | OFF Custom Cal window. | SENS:CORR:COLL:DISP:WIND
Show NO Custom Cal windows. | SENS:CORR:COLL:DISP:WIND:AOFF
Specify channel to sweep before Cal acquisition. | SENS:CORR:COLL:SWE:CHAN
Sweep NO channel before Cal acquisition. | SENS:CORR:COLL:SWE:CHAN:AOFF
Preview sweep before remote Cal acquisition. | SENS:CORR:COLL:GUID:PACQuire

Retrieve and Put Calibration Data
Retrieve Cal Data from the VNA | SENS:CORR:CSET:DATA
Put Cal Data in the VNA | SENS:CORR:CSET:DATA

Last Modified:

5-Dec-2014

Initial release


Data Access Map

Raw Measurement Data Standard Acquisition Data Calibration Error Terms Memory Error Correction Trace Math Filter Gating Display Formatting Data Smoothing Display


Control Handler SCPI

Control Handler Commands

Specifies the settings to remotely control the Material Handler IO connector.

CONTrol:HANDler:

A|B|C|D|E|F|G|H[DATA]

C:MODE

D:MODE

[EXTension]

| INDex[STATe]

| RTRigger[STATe]

INPut?

LOGic

OUTPut

| [DATA]

| USER[DATA]

PASSfail

| LOGic

| MODE

| POLicy

| SCOPe

| STATus?

| SWEepend

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

  • Learn about the Handler IO port

CONTrol:HANDler:<port>[:DATA] <num>

Applicable Models: E5080A

(Read-Write) Writes and reads data on the specified port.
Parameters |
<port> | Port identifier to set bits for. Choose from: A,B,C,D,E,F,G,H
<num> | The number of the data bits to set. Refer to the following table for the maximum number for each port. The minimum number for each port is 0.
Port | Max allowable <num> | MSB...........................................LSB 23...................................................0 |
A | 255 | A7...A0 | Write-only
B | 255 | B7...B0 | Write-only
C | 15 | C3...C0 | Read-Write
D | 15 | D3...D0 | Read-Write
E | 255 | D3...D0 + C3...C0 | Read-Write
F | 65535 | B7...B0 + A7...A0 | Write-only
G | 1048575 | C3...C0 + B7...B0 + A7...A0 | Write-only
H | 16777215 | D3...D0 + C3...C0 + B7...B0 + A7...A0 | Write-only
 | Note: When writing to port G, port C must be set to output mode When writing to port H, both port C and port D must be set to output mode. Use CONT:HAND:C:MODE OUTP and CONT:HAND:D:MODE OUTP
Examples | CONT:HAND:A 254 control:handler:c:data 12
Query Syntax | CONTrol:HANDler:<port>:DATA?
Return Type | Numeric
Default | Not Applicable

CONTrol:HANDler:C:MODE <char>

Applicable Models: E5080A

(Read-Write) Sets and reads the direction of data flow for Port C.
Parameters |
<char> | Direction of flow. Choose from: INPut - Port C is used to input data OUTPut - Port C is used to output data
Examples | CONT:HAND:C:MODE INP control:handler:c:mode output
Query Syntax | CONTrol:HANDler:C:MODE?
Return Type | Character
Default | INPut

CONTrol:HANDler:D:MODE <char>

Applicable Models: E5080A

(Read-Write) Sets and reads the direction of data flow for Port D.
Parameters |
<char> | Direction of flow. Choose from: INPut - Port D is used to input data OUTPut - Port D is used to output data
Examples | CONT:HAND:D:MOD INP control:handler:d:mode output
Query Syntax | CONTrol:HANDler:D:MODe?
Return Type | Character
Default | Input

CONTrol:HANDler[:EXTension]:INDex[:STATe] <bool>

Applicable Models: E5080A

(Read-Write) Determines the control of Material Handler connector Pin 20. A "Mnemonic not implemented" error is returned if the VNA does NOT have this capability.
Parameters |
<bool> | Choose from: ON (1) - Pin 20 is controlled by the Index signal OFF (0) - Pin 20 is controlled by Output Port B6
Examples | CONT:HAND:IND 1 control:handler:extension:index:state off
Query Syntax | CONTrol:HANDler[:EXTension]:INDex[:STATe]?
Return Type | Boolean
Default | OFF

CONTrol:HANDler[:EXTension]:RTRigger[:STATe] <bool>

Applicable Models: E5080A

(Read-Write) Determines the control of Material Handler connector Pin 21. A "Mnemonic not implemented" error is returned if the VNA does NOT have this capability.
Parameters |
<bool> | Choose from: ON or 1 - Pin 21 is controlled by the Ready for Trigger signal OFF or 0 - Pin 21 is controlled by Output Port B7
Examples | CONT:HAND:RTR 1 control:handler:extension:rtrigger:state off
Query Syntax | CONTrol:HANDler[:EXTension]:RTRigger[:STATe]?
Return Type | Boolean
Default | OFF

CONTrol:HANDler:INPut?

Applicable Models: E5080A. M9485A

(Read-Only) Reads a hardware latch that captures high to low transitions on Input1 of the Material Handler IO. Reading the latch causes it to reset and is ready for the next transition. The hardware latch is only capable of capturing one transition per query. Additional transitions are ignored until after the next query. Momentarily driving Input1 high, then low, will cause a transition to be detected and latched.
Examples | CONT:HAND:INP? control:handler:input?
Return Type | Integer - Returns a value of zero or one. 0 - No transition detected since last query. 1 - Transition detected.
Default | Not Applicable

CONTrol:HANDler:LOGic <char>

Applicable Models: E5080A

(Read-Write) Sets the logic of the Data ports A-H on the Handler connector. Some of these lines are connected internally to the AuxIO.

Parameters

<char>

Choose from:
POSitive- Causes the Port lines to have positive logic (high = 1, low = 0).

NEGative- Causes the Port lines to have negative logic (high = 0, low = 1).

For ports that are in output (write) mode, a change in logic causes the output lines to change state immediately. For example, Low levels change immediately to High levels.

For ports that are in input (read) mode (C,D,E only), a change in logic will be reflected when data is read from that port. For example, if a line read 0, the next read after a logic change will read 1.

Examples

CONT:HAND:LOG POS
control:handler:logic negative

Query Syntax

CONTrol:HANDler:LOGic?

Return Type

Character

Default

NEGative

CONTrol:HANDler:OUTPut<port>[:DATA] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or reads the specified output line. Type 1 and Type 2 configurations: Returns the last value written to the selected output pin. Type 3 configuration: Returns the current state of the selected output pin. If an Input1 trigger occurs, the state may not be the same value as was written.
Parameters |
<port> | Output port. Choose from: 1 - output 1(default) 2 - output 2
<num> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1 1 control:handler:output2:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:DATA?
Return Type | Boolean
Default | 0 - Low

CONTrol:HANDler:OUTPut<port>:USER[:DATA] <num>

Applicable Models: E5080A, M9485A

(Read-Write) Sets or reads the specified USER output line. Type 1 and Type2 configurations: Returns the last value written to the selected output pin. Type3 configuration: Returns the current state of the selected output pin. If an Input1 trigger occurs, the state may not be the same value as was written. Learn about User Output.
Parameters |
<port> | USER Output port. Choose from: 1 - User output 1(default) 2 - User output port
<num> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1:USER 1 control:handler:output2:user:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:USER:DATA?
Return Type | Boolean
Default | 0 - Low

CONTrol:HANDler:PASSfail:LOGic <char>

Applicable Models: E5080A

(Read-Write) Sets the logic of the PassFail line of the Material Handler IO (pin 33).
Parameters |
<char> | Choose from: POSitive- Causes the PassFail line to have positive logic (high = pass, low = fail). NEGative- Causes the PassFail line to have negative logic (high = fail, low = pass).
Examples | CONT:HAND:PASS:LOG POS control:handler:passfail:logic negative
Query Syntax | CONTrol:HANDler:PASSfail:LOGic?
Return Type | Character
Default | POSitive

CONTrol:HANDler:PASSfail:MODE <char>

Applicable Models: E5080A

(Read-Write) Sets and reads the default logical pass/fail state. This is the state the pass/fail line stays in until a failure occurs (if the mode is NOWait), or until an end-of-sweep condition occurs (if the mode is PASS or FAIL).

The end-of-sweep condition is determined by the CONTrol:HANDler:PASSfail:SCOPe command.

Parameters

<char>

Choose from:

PASS- the line stays in PASS state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

FAIL- the line stays in FAIL state until the end-of-sweep condition occurs, at which time the pass/fail line is set, and the pass/fail strobe (line 36) is activated.

NOWait- the pass/fail line is set, and the pass/fail strobe (line 36) is activated as soon as a failure condition occurs.

Examples

CONT:HAND:PASS:MODE NOW
control:handler:passfail:mode fail

Query Syntax

CONTrol:HANDler:PASSfail:MODE?

Return Type

Character

Default

NOWait

CONTrol:HANDler:PASSfail:POLicy <char>

Applicable Models: E5080A

(Read-Write) Sets the policy used to determine how global pass/fail is computed.
Parameters |
<char> | Name of the policy to use. Choose from: ALLTests - Pass/Fail Status returns PASS if all tests on all measurements pass. ALLMeas - Pass/Fail Status returns PASS if all measurements have associated tests, and all tests pass. FAIL is returned if even one measurement has no associated limit test. Only those measurements which are not in HOLD mode contribute to the pass/fail result.
Examples | CONT:HAND:PASS:POL control:handler:passfail:policy
Query Syntax | CONTrol:HANDler:PASSfail:POLicy?
Return Type | Character
Default | ALLTests

CONTrol:HANDler:PASSfail:SCOPe <char>

Applicable Models: E5080A

(Read-Write) Sets and reads the scope of pass/fail testing. The pass/fail line on the material handler port can report the status of all measurements on each channel, or all measurements on all channels. This command selects which option to use.

Parameters

<char>

Choose from:

CHANnel - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

GLOBal - A pass/fail result is computed and written to the output pins at the end of all sweeps on a channel.

If the pass/fail mode is NOWait (as set by CONTrol:HANDler:PASSfail:MODe), the status and strobe pins are written immediately. Otherwise the pins are written as indicated above. Regardless of the mode value, the pass/fail line is returned to its default state (as set by the MODE command) at the end of channel or group of channels.

Examples

CONT:HAND:PASS:SCOP CHAN
control:handler:passfail:scope sweep

Query Syntax

CONTrol:HANDler:PASSfail:SCOPe?

Return Type

Character

Default

GLOBal

CONTrol:HANDler:PASSfail:STATus?

Applicable Models: E5080A

(Read-Only) Returns the most recent pass/fail status value. Use this command as follows:

  1. Set the VNA trigger scope to GLOBAL

  2. Set the VNA trigger source to MANUAL or EXTERNAL.

  3. Configure and enable Limit Testing.

  4. Trigger the VNA.

  5. Use the *OPC? command to determine when the sweep is complete.

  6. Use the CONT:HAND:PASS:STAT? query to obtain the global pass/fail result.

Return Type

Character - One of the following is returned:

PASS - all measurements not in HOLD mode have been swept, and all associated limit tests have passed.

FAIL - all measurements not in HOLD mode have been swept, and one or more limit tests failed according to the specified Pass/Fail policy.

NONE - status cannot be determined because measurements are in progress.

Default

Not Applicable

CONTrol:HANDler:SWEepend <char>

Applicable Models: E5080A

(Read-Write) Specifies the event that will cause the Handler Sweep End line to strobe. The strobe is at least 10ms in duration, and is activated when all calculations for the associated measurement are complete. This line is connected internally to the Sweep End line of the AUX IO connector.
Parameters |
<char> | Choose from: SWEep - the line goes low when each sweep is complete CHANnel - the line goes low when all the sweeps for each channel is complete. GLOBal - the line goes low when all sweeps for all channels are complete. The default state of the passFail line (before a measurement occurs) and after a failure occurs is set by CONTrol:HANDler:PASSfail:MODe
Examples | CONT:HAND:SWE SWE control:handler:sweepend channel
Query Syntax | CONTrol:HANDler:SWEepend?
Return Type | Character
Default | GLOBal

Last Modified:

6-Jan-2016

First Release


Display Colors

Display Color Commands

Controls the color settings of the VNA display.

DISPlay:COLor

ABACkground

IBACKground | IBACkground

GRAT1

GRAT2

ILABel

LIM1

LOAD

RESet

STORe

TRACe

| DATA

| MARKer

| MEMory

| MMARker

Click on a Red keyword to view the command details.

See Also

  • Synchronizing the VNA and Controller

  • Learn about Display and Print Colors

  • SCPI Command Tree

DISPlay:COLor<n>:ABACkground <num, num, num>

(Read-Write) Set and return the background color for the active window on the VNA display or hardcopy print.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:ABAC 10,10,10 display:color1:abackground 80,80,80
Query Syntax | DISPlay:COLor<n>:ABACkground?
Return Type | Numeric (n,n,n)
Default | Display = 0,0,24 (Black) Print = 255,255,255 (White)

DISPlay:COLor<n>:IBACKground | IBACkground <num, num, num>

(Read-Write) Set and return the background color for the inactive windows on the VNA display or hardcopy print.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:BACK 10,10,10 display:color1:background 80,80,80
Query Syntax | DISPlay:COLor<n>:IBACKground | IBACkground?
Return Type | Numeric (n,n,n)
Default | Display = 0,0,0 (Black) Print = 255,255,255 (White)

DISPlay:COLor<n>:GRAT1 <num, num, num>

(Read-Write) Set and return the labels and grid frame colors in the active window for the VNA display or hardcopy print. (Active labels, Grid frame)
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:GRAT1 10,10,10 display:color1:grat1 80,80,80
Query Syntax | DISPlay:COLor<n>:GRAT1?
Return Type | Numeric (n,n,n)
Default | Display = 175,175,175 Print = 0,0,0 (Black)

DISPlay:COLor<n>:GRAT2 <num, num, num>

(Read-Write) Set and return the inner lines of all grid in all windows, and the grid frame in inactive windows for the VNA display or hardcopy print. (GRID)
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:GRAT2 10,10,10 display:color1:grat2 80,80,80
Query Syntax | DISPlay:COLor<n>:GRAT2?
Return Type | Numeric (n,n,n)
Default | Display = 100,100,100 Print = 50,50,50

DISPlay:COLor<n>:ILABel <num, num, num>

(Read-Write) Set and return the Inactive (not selected) Window Labels for the VNA display or hardcopy print.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:ILAB 10,10,10 display:color1:ilabel 80,80,80
Query Syntax | DISPlay:COLor<n>:ILABel?
Return Type | Numeric (n,n,n)
Default | Display = 160,160,160 Print = 0,0,0 (Black)

DISPlay:COLor<n>:LIM1 <num, num, num>

(Read-Write) Set and return the limit line color of failed traces or failure indicators (dots) and the word Fail.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:LIM1 10,10,10 display:color1:lim1 80,80,80
Query Syntax | DISPlay:COLor<n>:LIM1?
Return Type | Numeric (n,n,n)
Default | Display = 255,20,20 Print = 255,20,20

DISPlay:COLor<n>:LOAD <value>

(Write-only) Load a color theme from a disc file.
Parameters |
<n> | Colors to load. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<value> | String. Filename of the stored theme. The .colors suffix is automatically appended. By default, files are stored in C:/Program Files/Keysight/Network Analyzer/Colors/. To store and load files from a different folder, specify the full path and filename.
Examples | DISP:COL:LOAD "myDisplayTheme" display:color2:load "myPrintTheme"
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:COLor<n>:RESet

(Write-only) Resets the current theme to the default VNA colors.
Parameters |
<n> | Colors to reset. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
Examples | DISP:COL:RES display:color2:reset
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:COLor<n>:STORe <value>

(Write-only) Saves the current color theme to a disc file.
Parameters |
<n> | Colors to store. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<value> | String. Filename. The .colors suffix is automatically appended. By default, files are stored in C:/Program Files/Keysight/Network Analyzer/Colors/. To store and load files from a different folder, specify the full path and filename.
Examples | DISP:COL:STOR "myDisplayTheme" display:color2:store "myPrintTheme"
Query Syntax | Not Applicable
Default | Not Applicable

DISPlay:COLor<n>:TRACe<nth>:DATA <num, num, num>

(Read-Write) Set and return the color of Data and Limit Lines for nth trace in a window.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<nth> | Numeric. Relative trace number in the window for which colors are set. This is not necessarily the trace number. Learn more. Choose from 1 to 8. If unspecified, <nth> is set to 1 (first trace).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:TRAC2:DATA 10,10,10 display:color1:trace5:data 80,80,80
Query Syntax | DISPlay:COLor<n>:TRACe<nth>:DATA?
Return Type | Numeric (n,n,n)
Default | Varies for each trace.

DISPlay:COLor<n>:TRACe<nth>:MARKer <num, num, num>

(Read-Write) Set and return the color of data trace markers for nth trace in a window.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<nth> | Numeric. Relative trace number in the window for which colors are set. This is not necessarily the trace number. Learn more. Choose from 1 to 8. If unspecified, <nth> is set to 1 (first trace).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:TRAC2:MARK 10,10,10 display:color1:trace5:marker 80,80,80
Query Syntax | DISPlay:COLor<n>:TRACe<nth>:MARKer?
Return Type | Numeric (n,n,n)
Default | Varies for each trace.

DISPlay:COLor<n>:TRACe<nth>:MEMory <num, num, num>

(Read-Write) Set and return the memory trace color for nth trace in a window.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<nth> | Numeric. Relative trace number in the window for which colors are set. This is not necessarily the trace number. Learn more. Choose from 1 to 8. If unspecified, <nth> is set to 1 (first trace).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:TRAC2:MEM 10,10,10 display:color1:trace5:memory 80,80,80
Query Syntax | DISPlay:COLor<n>:TRACe<nth>:MEMory?
Return Type | Numeric (n,n,n)
Default | Varies for each trace.

DISPlay:COLor<n>:TRACe<nth>:MMARker <num, num, num>

(Read-Write) Set and return the color of memory trace markers for nth trace in a window.
Parameters |
<n> | Colors to modify. Choose from: 1 - Display colors 2 - Print colors If unspecified, <n> is set to 1 (Display colors).
<nth> | Numeric. Relative trace number in the window for which colors are set. This is not necessarily the trace number. Learn more. Choose from 1 to 8. If unspecified, <nth> is set to 1 (first trace).
<num, num, num> | Numeric. Red, Green, and Blue (RGB values) that specify a color. To find RGB values: from the Display Colors dialog, click Change Color, then Define Custom Color.
Examples | DISP:COL:TRAC2:MMAR 10,10,10 display:color1:trace5:mmarker 80,80,80
Query Syntax | DISPlay:COLor<n>:TRACe<nth>:MMARker?
Return Type | Numeric (n,n,n)
Default | Varies for each trace.

Last modified:

6-Jan-2016

First Release


Local Lockout

Local Lockout (LLO) Message

Normally, a GPIB instrument is put in remote mode by asserting the Remote Enable (REN) GPIB line. At that time, all front panel keys (except the Local key) are locked to prevent user interaction.

Sending the LLO message over the GPIB further locks out the keyboard, mouse, and Local key during execution of your GPIB program. The syntax of the LLO message depends on the GPIB driver you are using. Consult your GPIB driver software users manual.

The VNA requires these two actions to occur in order:

  1. Controller sends the LLO (Local Lockout) message

  2. Controller asserts the REN (Remote Enable) GPIB line

The VNA will then go into remote mode with full lockout capability.

This feature is also supported using SICL over LAN.

Use the LocalLockoutState COM command when using TCPIP/LAN.

Last Modified:

6-Jan-2016

Added COM command


LXI

LXI Command

SCPI Command Tree

LXI:IDENtify[:STATe] <bool>

(Read-Write) Sets and returns the status of the LXI LAN status indicator on the LAN Status dialog.

Parameters

<bool>

Choose from:

OFF or 0 - Changes the LXI Status indicator to ‘NORMAL’ and closes the dialog if it was opened by this command.

ON or 1 - Changes the LXI Status indicator to ‘IDENTIFY’ and opens the dialog if it was not already open.

Examples

LXI:IDEN 1
lxi:identify:state off

Query Syntax

LXI:IDENtify[:STATe]?

Return Type

Boolean

Default

OFF


SourceRxLeveling

Source:POWer:ALC:MODE:RECeiver Commands

Controls Receiver Leveling.

SOUR:POW:ALC[:MODE]:RECeiver:

FAST

FTYPe

IFBW

ITERation

LSPC

OFFSet

RATio?

REFerence

SAFE

| MAX

| MIN

| STEP

TOLerance

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Receiver Leveling

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

  • Remotely Specifying a Source Port

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver <bool>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the state of Receiver Leveling for the specified source port.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<bool>

Receiver Leveling state.

ON or 1 - Receiver Leveling ON

OFF or 0 - Receiver Leveling OFF

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC 1

source2:power2:alc:mode:receiver on

source:power:alc:mode:receiver off,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver? [src]

Return Type

Boolean

Default

OFF

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:FAST <bool>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the state of a separate IFBW setting for leveling sweeps. ON allows a higher (faster) IFBW than the measurement sweep. It also causes leveling sweeps to be noisier.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<bool>

Separate IFBW setting state.

ON or 1 - Separate IFBW setting. Specify IFBW using SOUR:POW:ALC:MODE:REC:IFBW

OFF or 0 - Same IFBW as the measurement sweep. Specify IFBW using Sens:BWID

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:FAST 1

source2:power2:alc:mode:receiver:fast off

source:power:alc:mode:receiver:fast off,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:FAST? [src]

Return Type

Boolean

Default

ON

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:FTYPe <char>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the frequency range to use for receiver leveling. On the user interface, this is the "Receiver frequency is determined by:" setting.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<char>

Frequency range. Choose from:

AUTO - always uses the frequency range that is assigned to the measurement receiver.

INPut - Mixer/Converter input frequency range.

OUTPut - Mixer/Converter input frequency range.

RECeiver - FOM Receiver frequency range.

SOURce - FOM Source frequency range

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:FTYP AUTO

source2:power2:alc:mode:receiver:ftype input

source:power:alc:mode:receiver:ftype output,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:FTYPe? [src]

Return Type

Character

Default

AUTO

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:IFBW <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the IFBW to be used for leveling sweeps. Enable separate IFBW for leveling sweeps using SOUR:POW:ALC:MODE:REC:FAST 1

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling..If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

IFBW for leveling sweeps in Hz. The list of valid IF Bandwidths is different depending on the VNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number.

This parameter supports MIN and MAX as arguments. Learn more.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:IFBW 100E3

source2:power2:alc:mode:receiver:ifbw 100khz

source:power:alc:mode:receiver:ifbw 70e3,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:IFBW? [src]

Return Type

Numeric

Default

100 kHz

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:ITERation <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the maximum iterations to be used in order to achieve the tolerance setting.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Max iterations. Choose a value between 1 and 25.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:ITER 5

source2:power2:alc:mode:receiver:iteration 10

source:power:alc:mode:receiver:iteration 7,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:ITERation? [src]

Return Type

Numeric

Default

5

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:LSPC <bool>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the state of Use Last Result for Source Power Cal. When Leveling Mode is switched back to Internal, this feature turns Source Power Cal correction ON using the latest receiver leveling correction data.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<bool>

State of Use Last Result for Source Power Cal.

ON or 1 - When Leveling Mode is switched back to Internal, Source Power Cal correction is turned ON using the latest receiver leveling correction data.

OFF or 0 - When Leveling Mode is switched back to Internal, Source Power Cal correction is NOT turned ON.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:LSPC 1

source2:power2:alc:mode:receiver:lspc off

source:power:alc:mode:receiver:lspc off,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:LSPC? [src]

Return Type

Boolean

Default

OFF

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:OFFSet <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the power level offset value.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Power level offset in dB. Choose a value between +200 and -200.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:OFFS 10

source2:power2:alc:mode:receiver:offset 5

source:power:alc:mode:receiver:offset 7,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:OFFSet? [src]

Return Type

Numeric

Default

0

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:REFerence <rec>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the reference receiver to be used with Receiver Leveling.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<rec>

(String) VNA receiver. Choose the VNA physical receiver that works with the source port <port>.

For example:<port 1> = "R1"

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:REF 'r1'

source2:power2:alc:mode:receiver:reference 'r2'

source:power:alc:mode:receiver:reference "r1","Port 1 Src2"

'Read the last setting back

source:power:alc:mode:receiver:reference? "Port 1 Src2"

'Returns:

"R1,1"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:REFerence? [src]

Return Type

String - Name of the reference receiver.

Default

Not Applicable

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE <bool>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the state of Safe Mode.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<bool>

Safe mode state.

ON or 1 - Safe mode ON

OFF or 0 - Safe mode OFF

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:SAFE 1

source2:power2:alc:mode:receiver:safe on

source:power:alc:mode:receiver:safe off,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE? [src]

Return Type

Boolean

Default

OFF

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:MAX <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the maximum power level for Safe Mode.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Maximum power level in dB.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:SAFE:MAX 10

source2:power2:alc:mode:receiver:safe:max 20

source:power:alc:mode:receiver:safe:max 15,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:MAX? [src]

Return Type

Numeric

Default

30 dB

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:MIN <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the minimum power level for Safe Mode.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Minimum power level in dB.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:SAFE:MIN -50

source2:power2:alc:mode:receiver:safe:min -80

source:power:alc:mode:receiver:safe:min -40,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:MIN? [src]

Return Type

Numeric

Default

-95 dB

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:STEP <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the maximum step power level for Safe Mode.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Maximum Step power level in dB.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:SAFE:STEP 2

source2:power2:alc:mode:receiver:safe:step 1.5

source:power:alc:mode:receiver:safe:min 2,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:SAFE:STEP? [src]

Return Type

Numeric

Default

1 dB

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:TOLerance <value>, [src]

Applicable Models: M9485A

(Read-Write) Sets and returns the tolerance value for leveling sweeps.

Learn more about Receiver Leveling

Parameters

<ch>

Channel number to be receiver leveled. If unspecified, value is set to 1

<port>

Source port being used for Receiver Leveling. If unspecified, value is set to 1. To make settings for ports that are not simple numbers, use the [src] argument.

<value>

Tolerance level in dB.

[src]

String. (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2". Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

Examples

SOUR:POW:ALC:REC:TOL .01

source2:power2:alc:mode:receiver:tolerance .5

source:power:alc:mode:receiver:tolerance .2,"Port 1 Src2"

See ReceiverLeveling example

Query Syntax

SOURce<ch>:POWer<port>:ALC[:MODE]:RECeiver:TOLerance? [src]

Return Type

Numeric

Default

.1 dB

Last Modified:

6-Jan-2016

First Release


Status Keywords SCPI

Status Command Keywords

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

  • :CONDition?

  • :ENABle

  • :ENABle?

  • :EVENt?

  • :MAP

  • :NTRansition

  • :PTRansition

Learn about Status Registers

SCPI Command Tree

:CONDition?

(Read-only) Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

(Read-only) This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


SystCommunicate

SYSTem: COMMunicate Commands

Controls and queries settings that affect the VNA system.

SYSTem:COMMunicate:

ECAL:CAT

GPIB

| ADDRess

LAN:HOSTname

PSENsor

TCPip:CONTrol?

USB:PMETer:CAT?

Click on a blue keyword to view the command details.

See Also

  • Referring to Traces Channels Windows and Meas Using SCPI

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:COMMunicate:ECAL:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the ID string of ECals that are connected to the VNA USB. Use the list to select a Ecal for Ecal calibration.
Parameters |
Examples | SYST:COMM:ECAL:CAT? system:communicate:ecal:catalog?
Return Type | Comma-delimited strings.
Default | Not applicable

SYSTem:COMMunicate:LAN:HOSTname?

Applicable Models: E5080A, M9485A

(Read-only) Returns the LAN hostname that is visible in the Help, About Network Analyzer dialog box. Learn more. This is the same information that is visible on the LXI compliance dialog.
Parameters | None
Example | SYST:CONF:LAN:HOSTname?
Return Type | String
Default | Not applicable

SYSTem:COMMunicate:PSENsor <char>, <string>

Applicable Models: E5080A, M9485A

This command replaces SYST:COMM:GPIB:PMET:ADDR.

(Read-Write) Specifies the type and location of the power meter to be used in a source power calibration.

Parameters

<char>

Type of power meter/ sensor. Choose from:

  • GPIB GPIB power meter

  • USB USB power sensor or USB power sensor

  • LAN LAN enabled power meter

  • ANY Any VISA resource string or a visa alias

<string>

For GPIB, address of the power meter. Choose any integer between 0 and 30.

For USB, the ID string of the power meter or power sensor. Use SYST:COMM:USB:PMET:CAT? to see a list of ID strings of connected power meters and sensors.

For LAN, the hostname or IP address of the power meter.

For ANY, any VISA resource string or a visa alias.

Examples

SYST:COMM:PSEN gpib, "14"

system:communicate:psensor usb, "Agilent Technologies,U2000A,MY12345678"

syst:comm:psen lan, "mymeter.agilent.com"

syst:comm:psen any, "TCPIP0::mymeter.agilent.com::5025::SOCKET"

Query Syntax

SYSTem:COMMunicate:PSENsor?

Return Type

Character / String

Default

GPIB

SYSTem:COMMunicate:USB:PMETer:CATalog?

Applicable Models: E5080A, M9485A

(Read-only) Returns the ID string of power meters / sensors that are connected to the VNA USB. Use the list to select a power sensor for a source power cal.

These meter/sensor ID strings can NOT be used as the resource string for configuring a USB-based PMAR (SYST:CONF:EDEV:IOConfig).

Parameters

Examples

SYST:COMM:USB:PMET:CAT?

system:communicate:usb:pmeter:catalog?

Return Type

Comma-delimited strings. Two power sensor strings are separate by a semicolon.

Default

Not applicable

SYSTem:COMMunicate:TCPip:CONTrol?

Applicable Models: E5080A, M9485A

(Read-only) Queries the TCP/IP port number to use for opening a TCP/IP socket control connection to the VNA. The control connection is used for two purposes:

  1. To perform a Device Clear operation on the VNA

  2. To detect when a Service Request (SRQ) event occurs on the VNA.

The port number can range from 5000 to 5099. The VNA will skip over 5025 as it is being used for the primary socket connection.

To detect an SRQ, your program sends the appropriate commands via the regular socket connection to set up for a SRQ event to occur the same sequence of commands as if you were sending them via GPIB. You write your program so that while your program is doing SCPI transactions on the standard socket connection, a second thread of execution in your program detects the SRQ on the control connection and responds to the event. When the SRQ event occurs, the VNA sends a SRQ +xxx/n message on the control connection (where /n is linefeed character, ASCII value 10 decimal). The xxx value in the SRQ +xxx/n string is the IEEE 488.2 status byte at the time the SRQ was generated. So listening for that on the control connection is how your program detects the event. If for your socket communication youre using a software API that provides for asynchronous communication via a callback mechanism (for example, if youre using Microsofts winsock API, or their .NET Socket class as in the example program below), in that case your listener execution thread is created implicitly for you so your program doesnt have to create one explicitly.

Note: If this SCPI query is sent to the VNA via a SCPI parser other than a TCP/IP socket connection (for example, if sent via GPIB), the query is not applicable in that case and will return value of 0.

Parameters

None

Example

See example program

Return Type

Integer

Default

Not applicable


SystConfigExtPulseGen

SYSTem:CONF:EDEVice:PULSe Commands

Configures and makes settings for an external Keysight 81110A Pulse Generator.

SYST:CONF:EDEVice:PULSe

| CHAN

| HAMP

| LAMP

| LIMP

| MMODe

| SIMP

Click on a blue keyword to view the command details.

See Also

  • Root SYST:CONF:EDEV commands

  • All Integrated Pulse App commands

  • Learn about: Configure an External Pulse Generator

  • Learn about Configure and External Device

  • SYST:PREF:ITEM:EDEV:DPOL - Determines whether External Devices remain activated or are de-activated when the VNA is Preset or when a Instrument State is recalled.

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SYSTem:CONFigure:EDEVice:PULSe:CHAN <name>,<value>

Applicable Models: M9485A

(Read-Write) Sets and returns the output channel of the pulse generator.
Parameters |
<name> | String - Name of the external pulse generator.
<value> | Pulse Generator output port. Choose from 1 or 2.
Examples | SYST:CONF:EDEV:PULS:CHAN "81110",1 system:configure:edevice:pulse:chan "myPG",2
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:CHAN? <name>
Return Type | Numeric
Default | 1

SYSTem:CONFigure:EDEVice:PULSe:HAMP <name>,<value>

Applicable Models: M9485A

(Read-Write) Sets and returns the High amplitude (voltage) of the pulse generator.
Parameters |
<name> | String - Name of the external pulse generator.
<value> | Pulse Generator high amplitude voltage.
Examples | SYST:CONF:EDEV:PULS:HAMP "81110",3 system:configure:edevice:pulse:HAMP "myPG",4
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:HAMP? <name>
Return Type | Numeric
Default | 5

SYSTem:CONFigure:EDEVice:PULSe:LAMP <name>,<value>

Applicable Models: M9485A

(Write-only) Adds an external device to the list of configured devices. This is the same as pressing New on the Select an external device dialog.

Upon creation, all settings on the new device are set to the defaults. The device is not active until set using SYST:CONF:EDEV:STAT

Parameters

<name>

String - Model and type of the external device.

To see a list of configured external devices, use SYST:CONF:EDEV:CAT?

Examples

SYST:CONF:EDEV:ADD "myDevice"

system:configure:edevice:add "myDevice"

Query Syntax

Not Applicable

Default

Not Applicable

(Read-Write) Pulse Generator low amplitude voltage.
Parameters |
<name> | String - Name of the external pulse generator.
<value> | Pulse Generator low amplitude voltage.
Examples | SYST:CONF:EDEV:PULS:LAMP "81110",.2 system:configure:edevice:pulse:lamp "myPG",1
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:LAMP? <name>
Return Type | Numeric
Default | 0

SYSTem:CONFigure:EDEVice:PULSe:LIMP <name>,<value>

Applicable Models: M9485A

(Read-Write) Sets and returns the load impedance of the pulse generator.
Parameters |
<name> | String - Name of the external pulse generator.
<value> | Pulse generator load impedance.
Examples | SYST:CONF:EDEV:PULS:LIMP "81110",52 system:configure:edevice:pulse:limp "myPG",49
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:LIMP? <name>
Return Type | Numeric
Default | 50

SYSTem:CONFigure:EDEVice:PULSe:MMODe <name>,<bool>

Applicable Models: M9485A

(Read-Write) Sets and returns the Master (On/Off) setting of the external pulse generator. The ON setting allows the external pulse generator to set the master clock frequency for the other pulse generators.
Parameters |
<name> | String - Name of the external pulse generator.
<bool> | Master setting. Choose from: ON or 1 - Use the external pulse generator becomes the master clock frequency. OFF or 0 - Use the internal pulse generator as the master clock frequency.
Examples | SYST:CONF:EDEV:PULS:MMOD "81110",OFF system:configure:edevice:pulse:mmode "myPG",1
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:MMODe? <name>
Return Type | Boolean
Default | OFF or 0

SYSTem:CONFigure:EDEVice:PULSe:SIMP <name>,<value>

Applicable Models: M9485A

(Read-Write) Sets and returns the source impedance of the pulse generator.
Parameters |
<name> | String - Name of the external pulse generator.
<value> | Pulse generator source impedance.
Examples | SYST:CONF:EDEV:PULS:SIMP "81110",52 system:configure:edevice:pulse:simp "myPG",49
Query Syntax | SYSTem:CONFigure:EDEVice:DC:PULSe:SIMP? <name>
Return Type | Numeric
Default | 50

Last modified:

6-Jan-2016

First Release


FSimulatorBalun

Calculate:FSimulator:Balun Commands

CALCulate:FSIMulator:BALun:

BPORt

| OFFSet

| PHASe

| POWer

| SWEep

| PHASe

| STARt

| STOP

CZConversion

| BPOrt

| IMAG

| REAL

| Z0

| R

| LPOrt

| IMAG

| REAL

| Z0

| R

| STATe

DEVice

DMCircuit

| BPOrt

| PARameters

| C

| G

| L

| R

| [TYPE]

| USER

| FILename

| LPOrt

| PARameters

| C

| G

| L

| R

| [TYPE]

| USER

| FILename

| STATe

DZConversion

| BPOrt

| IMAG

| REAL

| Z0

| R

| LPOrt

| IMAG

| REAL

| Z0

| R

| STATe

PHASe

| SWEEP | SWEep

| STATe

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Balanced Measurements

  • Learn about iTMSA

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Notes:

Critical Note: CALCulate commands act on the selected measurement. You can select one measurement for each channel using Calc:Par:MNUM or Calc:Par:Select. Learn more.

  • CALC:PAR:CAT? alone can NOT be used to return a balanced measurement parameter. If a balanced measurement transform is being performed, then additional querying of the CALC:FSIM system is required to determine the balanced parameter type. See an example.

  • BPORt versus LPORt commands - For each command in this subsystem that includes a BPORt keyword, there is an LPORt equivalent. The commands are identical except for the way in which the balanced / logical port numbers are specified:

    • The BPORt commands refer to the Balanced port number. There can only be up to two balanced ports. This method is compatible with the ENA network analyzer.

    • The LPORt commands refer to the Logical port number. A balanced port can appear as either logical port 1, 2, or 3. These are the references as they appear in the front-panel user interface.

Topology | Logical Port | Balanced Port
Single-Bal | 1 | N/A
 | 2 | 1
Single-Single-Bal | 1 | N/A
 | 2 | N/A
 | 3 | 1
Bal-Bal | 1 | 1
 | 2 | 2

Learn more about logical ports.

CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:OFFSet:PHASe <value>

Applicable Models: E5080A

(Read-Write) Sets the phase offset between the two balanced stimulus ports. This command only applies when CALC:FSIM:BAL:STIM:MOD is set to a True Mode - Not Single-Ended. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2.
<value> | Phase offset value in degrees.
Examples | CALC:FSIM:BAL:BPOR:OFFS:PHAS 10 calculate2:fsimulator:balun:bport:offset:phase 300
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:OFFSet:PHASe?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:OFFSet:POWer <value>

Applicable Models: E5080A

(Read-Write) Sets the phase offset between the two balanced stimulus ports. This command only applies when CALC:FSIM:BAL:STIM:MOD is set to a True Mode - Not Single-Ended. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2.
<value> | Power offset value in dB.
Examples | CALC:FSIM:BAL:BPOR:OFFS:POW 2 calculate2:fsimulator:balun:bport:offset:power .2 See example iTMSA program
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:OFFSet:POWer?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:SWEep:PHASe:STARt <value>

Applicable Models: E5080A

(Read-Write) Sets the start value for a phase sweep. Learn more about Phase Sweep. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose any VNA port. Only one port can have phase sweep.
<value> | Phase sweep start value in degrees. Choose a value between 0 and 360.
Examples | CALC:FSIM:BAL:BPOR:SWE:PHAS:STAR 10 calculate2:fsimulator:balun:bport:sweep:phase:start 5
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:SWEep:PHASe:STARt?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:SWEep:PHASe:STOP <value>

Applicable Models: E5080A

(Read-Write) Sets the stop value for a phase sweep. Learn more about Phase Sweep. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose any VNA port. Only one port can have phase sweep.
<value> | Phase sweep stop value in degrees. Choose a value between 0 and 360.
Examples | CALC:FSIM:BAL:BPOR:SWE:PHAS:STOP 10 calculate2:fsimulator:balun:bport:sweep:phase:stop 5
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:BPORt<pnum>:SWEep:PHASe:STOP?
Return Type | Numeric
Default | 360

CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:IMAG <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the imaginary part of the impedance value for the common port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Imaginary part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:CZC:BPOR:IMAG 0 calculate2:fsimulator:balun:czconversion:bport:imag 300
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:IMAG?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:REAL <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the common port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Real part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:CZC:BPOR:REAL 25 calculate2:fsimulator:balun:czconversion:bport:real 50
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:REAL?
Return Type | Numeric
Default | 25

CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:Z0[:R] <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the common port impedance conversion function. Set either this single value or set the real and imaginary parts separately. The imaginary part is set to 0.0 using this command. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Impedance value in ohms. Choose a number between 0 to 1E7.
Examples | CALC:FSIM:BAL:CZC:BPOR:Z0 50 calculate2:fsimulator:balun:czconversion:bport:z0:r 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:BPORt<pnum>:Z0[:R]?
Return Type | Numeric
Default | See Common Mode Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:IMAG <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the imaginary part of the impedance value for the common port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2, or 3. Note: See Balanced port versus Logical port.
<value> | Imaginary part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:CZC:LPOR:IMAG 0 calculate2:fsimulator:balun:czconversion:lport:imag 300
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:IMAG?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:REAL <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the common port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2, or 3. Note: See Balanced port versus Logical port.
<value> | Real part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:CZC:LPOR:REAL 25 calculate2:fsimulator:balun:czconversion:lport:real 50
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:REAL?
Return Type | Numeric
Default | See Common Mode Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:Z0[:R] <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the common port impedance conversion function. Set either this single value or set the real and imaginary parts separately. The imaginary part is set to 0.0 using this command. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Impedance value in ohms. Choose a number between 0 to 1E7.
Examples | CALC:FSIM:BAL:CZC:LPOR:Z0 50 calculate2:fsimulator:balun:czconversion:lport:z0:r 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:LPORt<pnum>:Z0[:R]?
Return Type | Numeric
Default | See Common Mode Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:CZConversion:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the common port impedance conversion function ON/OFF. Must also set the fixture simulator function to ON using CALC:FSIM:STAT. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of common port impedance conversion function. Choose from ON or 1 - Conversion ON OFF or 0 - Conversion OFF
Examples | CALC:FSIM:BAL:CZC:STAT 1 calculate2:fsimulator:balun:czconversion:state off
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:CZConversion:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:DEVice <char>

Applicable Models: E5080A, M9485A

(Read-Write) Selects the device type for the balanced measurement. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | BBALanced - Balanced - Balanced device (4 ports). BALSended - Balanced - Single-ended device (3 ports). SBALanced - Single-ended - Balanced device (3 ports). SSBalanced - Single-ended - Single-ended - Balanced device (4 ports).
Examples | CALC:FSIM:BAL:DEV SSB calculate2:fsimulator:balun:device bbal
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DEVice?
Return Type | Character
Default | SBALanced

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:C <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Capacitance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Capacitance value in farads. Choose a number between -1E18 to 1E18
Examples | CALC:FSIM:BAL:DMC:BPOR:PARameters:C 10E-6 calculate2:fsimulator:balun:dmcircuit:bport:parameters:c 1E-9
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:C?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:G <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Conductance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Conductance value in siemens. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:BPOR:PARameters:G 1E3 calculate2:fsimulator:balun:dmcircuit:bport:parameters:g 1E-3
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:G?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:L <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Inductance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Inductance value in henries. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:BPOR:PARameters:L 3E-3 calculate2:fsimulator:balun:dmcircuit:bport:parameters:lE-10
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:L?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:R <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Resistance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Resistance value in ohms. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:BPOR:PARameters:R 100 calculate2:fsimulator:balun:dmcircuit:bport:parameters:r 4E3
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:PARameters:R?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the differential matching circuit type. To select a user-defined circuit, specify IN ADVANCE the 2-port touchstone filename with CALC:FSIM:BAL:DMC:BPOR:USER:FILename. If you do not specify the appropriate file and you select USER, an error occurs and NONE is automatically selected. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<char> | Circuit type. Choose from: NONE - Specifies no-circuit. PLPC - Specifies the circuit that consists of shunt L and shunt C. USER - Specifies the user-defined circuit.
Examples | CALC:FSIM:BAL:DMC:BPOR2 PLPC calculate2:fsimulator:balun:dmcircuit:bport1:type none
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:TYPE?
Return Type | Character
Default | PLPC

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:USER:FILename <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the 2-port touchstone file in which the information on the user-defined differential matching circuit is saved. Following this command, send CALC:FSIM:BAL:DMC:BPOR2 USER. If the specified file does not exist, an error occurs when you set the type of differential matching circuit to USER. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<string> | File name and extension (.s2P) of the differential matching circuit. Files are stored in the default folder "C:/Program Files/Keysight/Network Analyzer/Documents". To recall from a different folder, specify the full path name.
Examples | CALC:FSIM:BAL:DMC:BPOR:USER:FIL 'myfile.s2p' calculate2:fsimulator:balun:dmcircuit:bport:user:filename "C:/Program Files/Keysight/Network Analyzer/Documents/myFile.s2P"
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:BPORt<pnum>:USER:FILename?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:C <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Capacitance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Capacitance value in farads. Choose a number between -1E18 to 1E18
Examples | CALC:FSIM:BAL:DMC:LPOR:PARameters:C 10E-6 calculate2:fsimulator:balun:dmcircuit:lport:parameters:c 1E-9
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:C?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:G <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Conductance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2, or 3. Note: See Balanced port versus Logical port.
<value> | Conductance value in siemens. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:LPOR:PARameters:G 1E3 calculate2:fsimulator:balun:dmcircuit:lport:parameters:g 1E-3
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:G?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:L <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Inductance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2, or 3. Note: See Balanced port versus Logical port.
<value> | Inductance value in henries. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:LPOR:PARameters:L 3E-3 calculate2:fsimulator:balun:dmcircuit:lport:parameters:lE-10
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:L?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:R <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the Resistance value of the differential matching circuit. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Resistance value in ohms. Choose a number between -1E18 to 1E18.
Examples | CALC:FSIM:BAL:DMC:LPOR:PARameters:R 100 calculate2:fsimulator:balun:dmcircuit:lport:parameters:r 4E3
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:PARameters:R?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the differential matching circuit type. To select a user-defined circuit, specify IN ADVANCE the 2-port touchstone filename with CALC:FSIM:BAL:DMC:LPOR:USER:FILename. If you do not specify the appropriate file and you select USER, an error occurs and NONE is automatically selected. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2, or 3. Note: See Balanced port versus Logical port.
<char> | Circuit type. Choose from: NONE - Specifies no-circuit. PLPC - Specifies the circuit that consists of shunt L and shunt C. USER - Specifies the user-defined circuit.
Examples | CALC:FSIM:BAL:DMC:LPOR2 PLPC calculate2:fsimulator:balun:dmcircuit:lport1:type none
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:TYPE?
Return Type | Character
Default | PLPC

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:USER:FILename <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the 2-port touchstone file in which the information on the user-defined differential matching circuit is saved. Following this command, send CALC:FSIM:BAL:DMC:BPOR2 USER. If the specified file does not exist, an error occurs when you set the type of differential matching circuit to USER. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<string> | File name and extension (.s2P) of the differential matching circuit. Files are stored in the default folder "C:/Program Files/Keysight/Network Analyzer/Documents". To recall from a different folder, specify the full path name.
Examples | CALC:FSIM:BAL:DMC:LPOR:USER:FIL 'myfile.s2p' calculate2:fsimulator:balun:dmcircuit:lport:user:filename "C:/Program Files/Keysight/Network Analyzer/Documents/myFile.s2P"
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:LPORt<pnum>:USER:FILename?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:FSIMulator:BALun:DMCircuit:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the differential matching circuit embedding function ON/OFF. Must also set the fixture simulator function to ON using CALC:FSIM:STAT. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of differential matching circuit embedding function. Choose from OFF or 0 - Matching circuit OFF ON or 1 - Matching circuit ON
Examples | CALC:FSIM:BAL:DMC:STAT 1 calculate2:fsimulator:balun:dmcircuit:state off
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DMCircuit:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:IMAG <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the imaginary part of the impedance value for the differential port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Imaginary part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:DZC:BPOR:IMAG 0 calculate2:fsimulator:balun:dczconversion:bport:imag 300
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:IMAG?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:REAL <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the differential port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Real part of the Impedance value in Units. Choose a number between 0 and 1E18
Examples | CALC:FSIM:BAL:DZC:BPOR:REAL 50 calculate2:fsimulator:balun:dzconversion:bport:real 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:REAL?
Return Type | Numeric
Default | 100

CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:Z0[:R] <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the impedance value for the differential port impedance conversion function. Set either this single value or set the real and imaginary parts separately. The imaginary part is set to 0.0 using this command. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Balanced port number. Choose from ports 1 or 2. Note: The numbering of logical ports is different from balanced ports. This command works the same as the ENA network analyzer. If there is only one balanced port, it is Balanced Port 1, regardless of the port mapping assignment. Learn more.
<value> | Impedance value in ohms. Choose a number between 0 to 1E7
Examples | CALC:FSIM:BAL:DZC:BPOR:Z0 50 calculate2:fsimulator:balun:dzconversion:bport:z0:r 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:BPORt<pnum>:Z0[:R]?
Return Type | Numeric
Default | See Differential Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:IMAG <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the imaginary part of the impedance value for the differential port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Imaginary part of the Impedance value in Units. Choose a number between 0 and 1E18.
Examples | CALC:FSIM:BAL:DZC:LPOR:IMAG 0 calculate2:fsimulator:balun:dczconversion:lport:imag 300
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:IMAG?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:REAL <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the real part of the impedance value for the differential port impedance conversion function. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Real part of the Impedance value in Units. Choose a number between 0 and 1E18
Examples | CALC:FSIM:BAL:DZC:LPOR:REAL 50 calculate2:fsimulator:balun:dzconversion:lport:real 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:REAL?
Return Type | Numeric
Default | See Differential Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:Z0[:R] <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the impedance value for the differential port impedance conversion function. Set either this single value or set the real and imaginary parts separately. The imaginary part is set to 0.0 using this command. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<pnum> | Logical port number. Choose from logical ports 1, 2 or 3. Note: See Balanced port versus Logical port.
<value> | Impedance value in ohms. Choose a number between 0 to 1E7
Examples | CALC:FSIM:BAL:DZC:LPOR:Z0 50 calculate2:fsimulator:balun:dzconversion:lport:z0:r 75
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:LPORt<pnum>:Z0[:R]?
Return Type | Numeric
Default | See Differential Port Z Conversion Default

CALCulate<cnum>:FSIMulator:BALun:DZConversion:STATe <ON |OFF>

Applicable Models: E5080A, M9485A

(Read-Write) Sets the differential port impedance conversion function ON/OFF. Must also set the fixture simulator function to ON using CALC:FSIM:STAT. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of the differential port impedance conversion function. Choose from OFF or 0 - Differential port impedance conversion OFF ON or 1 - Differential port impedance conversion ON
Examples | CALC:FSIM:BAL:DZC:STAT 1 calculate2:fsimulator:balun:dzconversion:state off
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:DZConversion:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:FIXTure:OFFSet:PHASe <bool>

Applicable Models: E5080A

(Read-Write) Sets and reads the state of "Phase Offset - Offset as Fixture" with True Mode balanced measurements. Learn more about iTMSA phase and power offset. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected true mode balanced measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of phase Offset as Fixture. OFF or 0 - Offset is applied but is NOT included as a fixture in the output calculations. ON or 1 - Offset is applied and included as a fixture in the output calculations.
Examples | CALC:FSIM:BAL:FIXT:OFFS:PHAS 0 calculate2:fsimulator:balun:fixture:offset:phase on See example iTMSA program
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:FIXTureOFFSet:PHASe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:FIXTure:OFFSet:POWer <bool>

Applicable Models: E5080A

(Read-Write) Sets and reads the state of "Power Offset - Offset as Fixture" with True Mode balanced measurements. Learn more about iTMSA phase and power offset. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected true mode balanced measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of power Offset as Fixture. OFF or 0 - Offset is applied but is NOT included as a fixture in the output calculations. ON or 1 - Offset is applied and included as a fixture in the output calculations.
Examples | CALC:FSIM:BAL:FIXT:OFFS:POW 0 calculate2:fsimulator:balun:fixture:offset:power on See example iTMSA program
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:FIXTureOFFSet:POWer?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:FIXTure:PHASe <bool>

Applicable Models: E5080A

(Read-Write) Sets and reads the state of "Phase Sweep - Offset as Fixture" (labeling on GUI). Learn more about iTMSA Phase Sweep. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected true mode balanced measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of phase sweep offset as a fixture: OFF or 0 - Phase Sweep offset disabled. ON or 1 - Phase Sweep offset enabled.
Examples | CALC:FSIM:BAL:FIXT:PHAS 0 calculate2:fsimulator:balun:fixture:phase on
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:FIXTure:PHASe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:BALun:PHASe:SWEEP | SWEep:STATe <bool>

Applicable Models: E5080A

(Read-Write) Sets and reads the state of phase sweep. Learn more about iTMSA Phase Sweep. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected true mode balanced measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | State of phase sweep: OFF or 0 - Phase Sweep disabled. ON or 1 - Phase Sweep enabled.
Examples | CALC:FSIM:BAL:PHAS:SWE:STAT 0 calculate2:fsimulator:balun:phase:sweep:state on
Query Syntax | CALCulate<cnum>:FSIMulator:BALun:PHASe:SWEep:STATe?
Return Type | Boolean
Default | OFF

Last modified:

6-Jan-2016

First Release


FSimulatorEmbed

Calculate:FSimulator:Embed Commands

Specifies settings for embedding and de-embedding balanced (4-port) fixturing circuits.

CALCulate:FSIMulator:EMBed:

NETWork

| FILename

| PMAP

| TYPE

STATe

TOPology

| A:PORTs

| B:PORTs

| C:PORTs

TYPE

Click a Red keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:FILename <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the 4-port touchstone file (*.s4p) in which the network to embed or de-embed resides. Following this command, send CALC:FSIM:EMB:NETW:TYPE. If the specified file does not exist, an error occurs when type command is sent. Learn about 4-port network embedding.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Network position. Choose from 1 or 2.
<string> | File name and extension (.s4p) of the circuit. Files are stored in the default folder "D:\". To recall from a different folder, specify the full path name.
Examples | 10 calculate2:fsimulator:embed:network2: filename "D:\trace01.s4p" 20 calculate2:fsimulator:embed:network2:type embed
Query Syntax | CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:FILename?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:PMAP <inA>,<inB>,<outA>,<outB>

Applicable Models: E5080A, M9485A

(Read-Write) Set and return the port mapping for a 4-port SNP file to be embedded. Learn about 4-port network embedding.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Network position. Choose from 1 or 2.
<inA> <inB> <outA> <outB> | Port Mapping. Use four port numbers in any order.
Example | CALC:FSIM:EMB:NETW1:PMAP 1,3,2,4
Query Syntax | CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:PMAP?
Return Type | Comma-separated numeric
Default | 1,2,3,4

CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specify the type of processing to take place on the specified 4-port network. First specify the network filename with CALC:FSIM:EMB:NETW:FIL. Learn about 4-port network embedding.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Network position. Choose from 1 or 2.
<char> | Processing type. Choose from : NONE - The same as disabling. EMBed - Add Network circuit. DEEMbed - Remove Network circuit.
Example | 10 CALC:FSIM:EMB:NETW2:FIL 'myFile.s4p' 20 CALC:FSIM:EMB:NETW2:TYPE EMBed
Query Syntax | CALCulate<cnum>:FSIMulator:EMBed:NETWork<n>:TYPE?
Return Type | Character
Default | NONE

CALCulate<cnum>:FSIMulator:EMBed:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns ON or OFF 4-port Network Embedding/De-embedding for all ports on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns 4-port Network Embedding/De-embedding ON. OFF or 0 - Turns 4-port Network Embedding/De-embedding OFF.
Examples | CALC:FSIM:EMB:STAT 1 calculate2:fsimulator:embed:state 0
Query Syntax | CALCulate<cnum>:FSIMulator:EMBed:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:EMBed:TOPology:A:PORTs <p1>,<p2>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the VNA port connections when topology A is selected. Specify topology using CALC:FSIM:EMB:TYPE.

Topology A

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<p1>

VNA Port number assigned to a in above graphic.

<p2>

VNA Port number assigned to b in above graphic.

Examples

CALC:FSIM:EMB:TOP:A:PORT 2,1
calculate2:fsimulator:embed:topology:a:ports 1,2

Query Syntax

CALCulate<cnum>:FSIMulator:EMBed:TOPology:A:PORTs?

Return Type

Numeric

Default

1, 2

CALCulate<cnum>:FSIMulator:EMBed:TOPology:B:PORTs <p1>,<p2>,<p3>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the VNA port connections when topology B is selected. Specify topology using CALC:FSIM:EMB:TYPE.

Topology B

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<p1>

VNA Port number assigned to a in above graphic.

<p2>

VNA Port number assigned to b in above graphic.

<p3>

VNA Port number assigned to c in above graphic.

Examples

CALC:FSIM:EMB:TOP:B:PORT 2,1,4
calculate2:fsimulator:embed:topology:b:ports 1,2,3

Query Syntax

CALCulate<cnum>:FSIMulator:EMBed:TOPology:B:PORTs?

Return Type

Numeric

Default

1,2,3

CALCulate<cnum>:FSIMulator:EMBed:TOPology:C:PORTs <p1>,<p2>,<p3>,<p4>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the VNA port connections when topology C is selected. Specify topology using CALC:FSIM:EMB:TYPE.

Topology C

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<p1>

VNA Port number assigned to a in above graphic.

<p2>

VNA Port number assigned to b in above graphic.

<p3>

VNA Port number assigned to c in above graphic.

<p4>

VNA Port number assigned to d in above graphic.

Examples

CALC:FSIM:EMB:TOP:C:PORT 2,1,4,3
calculate2:fsimulator:embed:topology:c:ports 1,2,3,4

Query Syntax

CALCulate<cnum>:FSIMulator:EMBed:TOPology:C:PORTs?

Return Type

Numeric

Default

1,2,3,4

CALCulate<cnum>:FSIMulator:EMBed:TYPE <char>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the VNA / DUT topology. Learn more about these and other VNA/DUT configurations.

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

VNA / DUT topology. Choose from:

  • A - 2 VNA/DUT Ports

  • B - 3 VNA/DUT Ports

  • C - 4 VNA/DUT Ports

Click links to see topologies and port assignment commands.

Examples

CALC:FSIM:EMB:TYPE A
calculate2:fsimulator:embed:type c

Query Syntax

CALCulate<cnum>:FSIMulator:EMBed:TYPE?

Return Type

Character

Default

A

Last modified:

6-Jan-2016

First Release


FSimulatorSend

Calculate:FSimulator:Sended Commands

Specifies settings for embedding and de-embedding Single-Ended (2-port) fixturing circuits.

CALCulate:FSIMulator:SENDed:

DEEMbed

| PORT

| SNP:REVerse

| [TYPE]

| USER:FILename

| STATe

OORDer

PMCircuit

| PORT

| PARameters

| C

| G

| L

| R

| [TYPE]

| USER:FILename

| STATe

POWer:PORT:COMPensation

ZCONversion

| PORT

| IMAG

| REAL

| Z0[R]

| STATe

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about Fixturing

  • Set Port Extensions with SCPI

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Note: CALC:FSIM commands affect ALL measurements on the specified channel.

CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>:SNP:REVerse <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Set and read whether or not to reverse ports on a 2-port fixture or adapter to be de-embedded. Learn more.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | VNA port number to which SNP file is to be de-embedded.
<bool> | Choose from: ON or 1 - Reverse ports. OFF or 0 - Do NOT Reverse ports.
Examples | CALC:FSIM:SEND:DEEM:PORT1:SNP:REV 1 calculate2:fsimulator:sended:deembed:port2:snp:reverse 0
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>:SNP:REVerse?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Select whether or not to load a 2-port De-embedding circuit model for the specified port number. Circuit model USER is valid when an associated .s2p file is specified with CALC:FSIM:SEND:DEEM:PORT1:USER:FILename. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive circuit model.
<char> | Choose from: NONE - Port does not have a circuit model. USER - Circuit model for the port will be loaded from VNA drive.
Examples | CALC:FSIM:SEND:DEEM:PORT1 USER calculate2:fsimulator:sended:deembed:port2:type none
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>[:TYPE]?
Return Type | Character
Default | None

CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>:USER:FILename <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the filename of the circuit model to be used for de-embedding. Circuit model is applied when both CALC:FSIM:SEND:DEEM:PORT1 USER is selected and the filename is specified with this command. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive circuit model.
<string> | File name and extension (.s2P) of the de-embedding circuit. Files are stored in the default folder "C:/Program Files/Keysight/Network Analyzer/Documents" To recall from a different folder, specify the full path name.
Examples | CALC:FSIM:SEND:DEEM:PORT1:USER:FIL 'myFile.s2P' calculate2:fsimulator:deembed:port2:user:file "C:/Program Files/Keysight/Network Analyzer/Documents/myFile.s2P"
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:PORT<n>:USER:FILename?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns de-embedding ON or OFF for all ports on the specified channel. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns de-embedding ON. OFF or 0 - Turns de-embedding OFF.
Examples | CALC:FSIM:SEND:DEEM:STAT 1 calculate2:fsimulator:sended:deembed:state 0
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:DEEMbed:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:SENDed:OORDer <a,b,c,d>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the order in which Single-ended Fixture Operations occur. Learn more about these operations. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<a,b,c,d> | Order of operations, where: 0 - Port Extension operation 1 - 2-Port DeEmbedding operation 2 - Port Matching operation 3 - Arbitrary Impedance operation
Examples | CALC:FSIM:SEND:OORD 1,2,3,0 calculate2:fsimulator:sended:oorder 1,2,3,0
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:OORDer?
Return Type | Comma-separated values
Default | 0,1,2,3

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:C <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Capacitance, 'C' value for the specified port number. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive value.
<value> | Capacitance value in farads. Choose a value between -1E18 to 1E18.
Examples | CALC:FSIM:SEND:PMC:PORT1:PAR:C 0.00002 calculate2:fsimulator:sended:pmcircuit:port2:parameters:c 0.00003
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:C?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:G <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Conductance, 'G' value for the specified port number. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive value.
<value> | Conductance value in siemens. Choose a value between -1E18 to 1E18.
Examples | CALC:FSIM:SEND:PMC:PORT1:PAR:G 0.00002 calculate2:fsimulator:sended:pmcircuit:port2:parameters:g 0.00003
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:G?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:L <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Inductance, 'L' value for the specified port number. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive value.
<value> | Inductance value in henries. Choose a value between -1E18 to 1E18.
Examples | CALC:FSIM:SEND:PMC:PORT1:PAR:L 0.00002 calculate2:fsimulator:sended:pmcircuit:port2:parameters:l 0.00003
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:L?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:R <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Resistance, 'R' value for the specified port number. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive value.
<value> | Resistance value in ohms. Choose a value between -1E18 to 1E18.
Examples | CALC:FSIM:SEND:PMC:PORT1:PAR:R 0.00002 calculate2:fsimulator:sended:pmcircuit:port2:parameters:r 0.00003
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:PARameters:R?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>[:TYPE] <char>

Applicable Models: E5080A, M9485A

(Read-Write) Select whether of not to load a 2 port matching circuit model for the specified port number. Circuit model USER is valid when an associated .s2p file is specified with CALC:FSIM:SEND:PMC:PORT1:USER:FIL Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive circuit model.
<char> | Circuit model. Choose from NONE No circuit model SLPC Series L - Parallel C PCSL Parallel C - Series L PLSC Parallel L - Series C SCPL Series C - Parallel L PLPC Parallel L - Parallel C USER Load S2P file
Examples | CALC:FSIM:SEND:PMC:PORT1:USER calculate2:fsimulator:sended:pmcircuit:port2:type slpc
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>[:TYPE]?
Return Type | Character
Default | None - No circuit model

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:USER:FILename <string>

Applicable Models: E5080A, M9485A

(Read-Write) Specifies the filename of the circuit model to be used for port matching. Circuit model is applied when both CALC:FSIM:SEND:PMC:PORT1 USER is selected and the filename is specified with this command. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive circuit model.
<string> | File name and extension (.s2P) of the de-embedding circuit. Files are stored in the default folder "C:/Program Files/Keysight/Network Analyzer/Documents" To recall from a different folder, specify the full path name.
Examples | CALC:FSIM:SEND:PMC:PORT1:USER:FIL 'myFile.s2P' calculate2:fsimulator:pmcircuit:port2:user:file "C:/Program Files/Keysight/Network Analyzer/Documents/myFile.s2P"
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:PORT<n>:USER:FILename?
Return Type | String
Default | Not Applicable

CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns Port Matching ON or OFF for all ports on the specified channel. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns Port Matching ON. OFF or 0 - Turns Port Matching OFF.
Examples | CALC:FSIM:SEND:PMC:STAT 1 calculate2:fsimulator:sended:pmcircuit:state 0
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:PMCircuit:STATe?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:SENDed:POWer:PORT<n>:COMPensation <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Adjusts the source power at the specified port by the combined amount of loss through ALL enabled fixturing operations. Use this function to set the power level at the DUT input. Learn more. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<port> | Port number to receive power compensation.
<bool> | Choose from: ON or 1 - Compensate source power. OFF or 0 - Do NOT compensate source power.
Examples | CALC:FSIM:SEND:POW:PORT1:COMP 1 calculate2:fsimulator:power:port2:compensation off
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:POWer:PORT<n>:COMPensation?
Return Type | Boolean
Default | OFF

CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:IMAG <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Imaginary portion of the impedance value for the specified single-ended port. Use CALC:FSIM:SEND:ZCON:PORT:REAL to set the real value. Or use CALC:FSIM:SEND:ZCON:PORT:Z0 to set both values together. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Port number to receive value.
<value> | Imaginary impedance value. Choose a value between -1E18 and 1E18.
Examples | CALC:FSIM:SEND:ZCON:PORT1:IMAG 75 calculate2:fsimulator:sended:zconversion:port2:imag 150
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:IMAG?
Return Type | Numeric
Default | 0

CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:REAL <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Real portion of the impedance value for the specified single-ended port. Use CALC:FSIM:SEND:ZCON:PORT:IMAG to set the imaginary value. Or use CALC:FSIM:SEND:ZCON:PORT:Z0 to set both values together. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Port number to receive value.
<value> | Real Impedance value in ohms. Choose a value between 0 to 1E7.
Examples | CALC:FSIM:SEND:ZCON:PORT1:REAL 51 calculate2:fsimulator:sended:zconversion:port2:real 75
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:REAL?
Return Type | Numeric
Default | 50

CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:Z0[:R] <value>

Applicable Models: E5080A, M9485A

(Read-Write) Sets and returns the Real portion of the impedance value for the specified single-ended port. The imaginary portion is automatically set to 0.0. To set both values separately, use CALC:FSIM:SEND:ZCON:PORT:REAL and CALC:FSIM:SEND:ZCON:PORT:IMAG. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<n> | Port number to receive value.
<value> | Port Impedance value in ohms. Choose a value between 0 to 1E7.
Examples | CALC:FSIM:SEND:ZCON:PORT1:Z0 51 calculate2:fsimulator:sended:zconversion:port2:z0:r 75
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:PORT<n>:Z0[:R]?
Return Type | Numeric
Default | 50

CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:STATe <bool>

Applicable Models: E5080A, M9485A

(Read-Write) Turns Port Impedance ON or OFF for all ports on the specified channel. Note: This command affects ALL measurements on the specified channel.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<bool> | Choose from: ON or 1 - Turns Port Impedance ON. OFF or 0 - Turns Port Impedance OFF.
Examples | CALC:FSIM:SEND:ZCON:STAT 1 calculate2:fsimulator:sended:zconversion:state 0
Query Syntax | CALCulate<cnum>:FSIMulator:SENDed:ZCONversion:STATe?
Return Type | Boolean
Default | OFF

Last modified:

6-Jan-2016

First Release


Hold

Calculate:Hold

CALCulate:MEASURE:HOLD

CLEar

TYPE

CALCulate<cnum>:MEASure<mnum>:HOLD:CLEar

(Write only) Clears the trace for trace hold function.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
Examples | CALC:MEAS:HOLD:CLE calculate2:measure2:hold:clear
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:TYPE <char>

(Read-Write) Specify sets/gets maximum/minimum trace hold function to hold the active trace at the maximum or minimum point.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<char> | Hold type. Choose from : NONE - Turns off the trace hold function MINimum - Holds the active trace at the minimum point. MAXimum - Holds the active trace at the maximum point.
Example | CALC:MEAS:TYPE "MIN" calculate1:measure1:type "MAXimum"
Query Syntax | CALCulate<cnum>:MEASure<mnum>:HOLD:TYPE?
Return Type | Character
Default | NONE


MarkerPNOP

Calculate:Marker:PNOP Commands

Initiates a Power Normal Operating Point marker search and reads the results.

CALCulate:MEASure:MARKer:PNOP:

BACKoff

| GAIN?

| PIN?

| POUT?

COMPression?

| MAXimum?

GAIN?

| MAXimum?

PIN?

| MAXimum?

POFFset

POUT?

| MAXimum?

Click on a Red keyword to view the command details.

See Also

  • Learn about PNOP Markers

  • Other SCPI Marker commands

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:BACKoff <num>

(Read-Write) Turns on and sets markers 1, 2, 3, and 4 to calculate various PNOP parameters. Either this command, or the POFFset command, will initiate the PNOP search markers. To turn off the PNOP markers, either turn them off individually or turn them All Off. To search a User Range with the PNOP search, first activate marker 1 and set the desired User Range. Then send CALC:MARK:PNOP:BACK. The user range used with the PNOP search only applies to marker 1 searching for the linear gain value. The other markers may fall outside the user range. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Backoff value. Choose any number between :-500 and 500
Examples | CALC:MEAS:MARK:PNOP:BACK 100 calculate2:measure2:marker:pnop:backoff -300
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:BACKoff?
Return Type | Numeric
Default | 0 dB

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:BACKoff:GAIN?

(Read-only) Reads the power backoff gain value from a PNOP marker search. PBO Gain = PBO Out - PBO In Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:BACK:GAIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:BACKoff:PIN?

(Read-only) Reads the power backoff input value from a PNOP marker search. PBO In = Marker 2 X-axis Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:BACK:PIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:BACKoff:POUT?

(Read-only) Reads the power backoff output value from a PNOP marker search. PBO Out = Marker 2 Y-axis Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:BACK:POUT?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:COMPression?

(Read-only) Reads the PNOP compression value from a PNOP marker search. Pnop Comp = Pnop Gain - Linear Gain (not shown on marker readout). Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS;MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:COMP?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:COMPression:MAXimum?

(Read-only) Reads the max compression value from a PNOP marker search. Comp Max = Gain Max - Linear Gain (not shown on marker readout). Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:COMP:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:GAIN?

(Read-only) Reads the PNOP gain value from a PNOP marker search. Pnop Gain = Pnop Out - Pnop In. Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:GAIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:GAIN:MAXimum?

(Read-only) Reads the max gain from a PNOP marker search. Gain Max = PMax Out - PMax In Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:GAIN:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:PIN?

(Read-only) Reads the PNOP input value from a PNOP marker search. Pnop In = Marker 4 X-axis value Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:PIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:PIN:MAXimum?

(Read-only) Reads the max input power from a PNOP marker search. PMax In = Marker 3 X-axis value Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:PIN:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:POFFset <num>

(Read-Write) Turns on and sets markers 1, 2, 3, and 4 to calculate various PNOP parameters. Either this command, or the Backoff command, will initiate the PNOP search markers. To turn off the PNOP markers, either turn them off individually or turn them All Off. To search a User Range with the PNOP search, first activate marker 1 and set the desired User Range. Then send the CALC:MEAS:MARK:PNOP:POFF command. The user range used with the PNOP search only applies to marker 1 searching for the linear gain value. The other markers may fall outside the user range. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
<num> | Power Offset value in dB. Choose any number between :-500 and 500
Examples | CALC:MEAS:MARK:PNOP:POFF 3 calculate2:measure2:marker:pnop:poffset 10
Query Syntax | CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:POFFset?
Return Type | Numeric
Default | 0 dB

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:POUT?

(Read-only) Reads the output power value of the offset marker from a PNOP marker search. Pnop Out = Marker 4 Y-axis value Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:POUT?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PNOP:POUT:MAXimum?

(Read-only) Reads the max output power from a PNOP marker search. PMax Out = Marker 3 Y-axis value Use CALC:MEAS:MARK:PNOP:BACK or CALC:MEAS:MARK:PNOP:POFF to initiate a PNOP search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PNOP:POUT:MAX?
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


MarkerPSAT

Calculate:Marker:PSaturation Commands

Initiates a Power Saturation marker search and reads the results.

CALCulate:MEASure:MARKer:PSATuration:

BACKoff

COMPression

| MAXimum?

| SATuration?

GAIN?

| LINear?

| MAXimum?

PIN?

| MAXimum?

POUT?

| MAXimum?

Click on a Red keyword to view the command details.

See Also

  • Learn about PSAT Markers

  • Other SCPI Marker commands

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:BACKoff <num>

(Read-Write) Turns on and sets markers 1, 2, and 3 to calculate various Power Saturation parameters.

The <num> parameter sets and reads the back-off value for a Power Saturation marker search.

To turn off the Power Saturation markers, either turn them off individually or turn them All Off.

To search a User Range with the PSAT search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:PSAT:BACK command. The user range used with the PSAT search only applies to marker 1 searching for the linear gain value. The other markers may fall outside the user range.

See Critical Note

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mnum>

Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.

<mkr>

Any marker number from 1 to 15; if unspecified, value is set to 1.

<num>

Backoff value. Choose any number between :-500 and 500

Examples

CALC:MEAS:MARK:PSAT:BACK 3
calculate2:measure2:marker:psaturation:backoff 10

Query Syntax

CALCulate<cnum>:MARKer:PSATuration:BACKoff?

Return Type

Numeric

Default

0 dB

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:COMPression:MAXimum?

(Read-only) Reads the compression maximum value from a PSAT marker search. Comp Max = Gain Max - Gain Linear Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:COMP:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:COMPression:SATuration?

(Read-only) Reads the compression saturation value from a PSAT marker search. Comp Sat = Gain Sat - Gain Linear Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:COMP:SAT?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:GAIN?

(Read-only) Reads the saturation gain value from a PSAT marker search. Gain Sat = Psat Out - Psat In Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:GAIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:GAIN:LINear?

(Read-only) Reads the linear gain value from a PSAT marker search. Gain Linear = Marker 1 - Y-axis value MINUS X-axis value. Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:GAIN:LIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:GAIN:MAXimum?

(Read-only) Reads the maximum gain value from a PSAT marker search. Gain Max = PMax Out - PMax In Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:GAIN:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:PIN?

(Read-only) Reads the power saturation input value from a PSAT marker search. Psat In = Marker 2 X-axis value Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:PIN?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:PIN:MAXimum?

(Read-only) Reads the maximum input power from a PSAT marker search. PMax In = Marker 3 X-axis value Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:PIN:MAX?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:POUT?

(Read-only) Reads the back-off output power from a PSAT marker search. PSat Out = Marker 2 Y-axis value Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:POUT?
Default | Not Applicable

CALCulate<cnum>:MEASure<mnum>:MARKer<mkr>:PSATuration:POUT:MAXimum?

(Read-only) Reads the back-off output power from a PSAT marker search. PMaxOut = Marker 3 Y-axis value Use CALC:MEAS:MARK:PSAT:BACK to initiate a PSAT search. See Critical Note
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mnum> | Measurement number for each measurement. There must be a selected measurement on the trace. If unspecified, <mnum> is set to 1.
<mkr> | Any marker number from 1 to 15; if unspecified, value is set to 1.
Examples | CALC:MEAS:MARK:PSAT:POUT:MAX?
Default | Not Applicable

Last modified:

6-Jan-2016

First Release


CorrCollGuidPSens

Sense:Correction:Collect:Guided:PSensor Commands

Configures the power sensors to be used during a SmartCal (Guided) Power Calibration.

Three of these commands can be used with Applications Channels. Learn more.

SENSe:CORRection:COLLect:GUIDed:PSENsor

CKIT

CONNector

MULTiple

| ADD

| CKIT

| CONNector

| COUNt?

| FREQuency

| STARt

| STOP

| NAME

| REMove

| [STATe]

POWer

| LEVel

[STATe]

Click on a blue keyword to view the command details.

Red keywords are superseded commands.

Notes

The "multiple sensors" commands are supported ONLY on standard channels. The following THREE commands can be used with Application channels. See NFX example.

  • SENS:CORR:COLL:GUID:PSEN<n>:CKIT

  • SENS:CORR:COLL:GUID:PSEN<n>:CONN

  • SENS:CORR:COLL:GUID:PSEN<n>:POW:LEV

  • In addition, when using two sensors with a Dual Power Meter, use SOUR:POW:CORR:COLL:<pmChan>SEN:SEL to select a power sensor.

See Also

SENSe:CORRection:COLLect:GUIDed commands

Calibrating the VNA Using SCPI

Learn about Measurement Calibration

Synchronizing the VNA and Controller

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:CKIT <kit>, [src]

(Read-Write) Specifies the calibration kit to be used when an adapter is necessary to connect the power sensor to the port <pnum> during a guided calibration.

This command can also be used with Application channels. See NFX example.

When used with Guided Power Cal, first enable a power cal using SENS:CORR:COLL:GUID:PSEN ON

  1. Specify the connector type for the adapter with SENS:CORR:COLL:GUID:PSEN:CONN

  2. Query the valid available kits for the connector with SENS:CORR:COLL:GUID:CKIT:CAT? <conn>

  3. Specify the kit using this command.

  4. Perform a query of this command. If the <kit> parameter was incorrectly entered, an error will be returned.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1. For NFX cals, port number must be 1.

<kit>

Calibration kit to be used for the specified port.

When using an ECal module, include the characterization name in the <kit> string. Use SENSe:CORR:COLL:GUID:CKIT:CAT? to read the list of characterizations available in the module and in VNA disk memory.

If two or more identical ECal modules are connected to the VNA, the serial number must be included to distinguish the ECal modules.

[src]

String - (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2".

Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

See Remotely Specifying a Source Port

Examples

SENS:CORR:COLL:GUID:PSEN1:CKIT '85055A'

'The following includes a serial number when two or more ECal mods are connected

sense:correction:collect:guided:psensor2:ckit '85092-60010 ECal 10685'

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:CKIT?

Return Type

String

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:CONNector <conn>, [src]

(Read-Write) Specifies the connector type for a power sensor when a power calibration is part of the Guided Calibration process. Valid connector names are stored within calibration kits. Some cal kits may include both male and female connectors. Therefore, specifying connector gender may be required.

This command can also be used with Application channels. See NFX example.

Follow these steps to ensure port connectors are specified correctly:

When used with Guided Power Cal, first enable a power cal using SENS:CORR:COLL:GUID:PSEN ON

  1. Use SENS:CORR:COLL:GUID:CONN:CAT? to query available connectors before specifying the port connector.

  2. Set a connector type for each port using this command.

  3. Perform a query of this command. If the connector type was incorrectly entered, an error will be returned.

  4. Specify the cal kit to use for each port with SENS:CORR:COLL:GUID:PSENsor:CKIT

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<conn>

String - Power sensor connector type to connect to the specified VNA port <pnum>.

Because the default for this argument is 'Ignored", by specifying a connector type, you imply that you want to calibrate and correct for the effects of the adapter.

[src]

String - (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2".

Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

See Remotely Specifying a Source Port

Examples

SENS:CORR:COLL:GUID:PSEN1:CONN "3.5 mm (50) male"

sense:correction:collect:guided:psensor1:connector "3.5 mm (50) female"

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:CONNector?

Return Type

String

Default

"Ignored"

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple:ADD <string>

(Write-only) Adds a power sensor to be used during a Guided Power Calibration. Use when multiple power sensors are to be used to calibrate the entire frequency span. The Name argument is used to recognize the sensor in the User Interface.

An item number is automatically assigned to the sensor. Use that number to refer to the sensor. The item number of the newly-added sensor is always equal to the number returned by SENS:CORR:COLL:GUID:PSEN:MULT:COUN? after the ADD.

Note: The "multiple sensors" commands are supported ONLY on standard channels.

Learn about using multiple power sensors

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<string>

Power sensor name to add. The power sensor must be already configured as a PMAR device using this name. Learn how to remotely configure a PMAR device.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT:ADD "26GHzPwrSensor"

See example program

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:CKIT <string>

(Read-Write) Set and read the Cal Kit to be used when an adapter is necessary to connect the power sensor to the cal plane and you choose to remove its effects from the measurement. Use this command when multiple power sensors are to be used to calibrate the entire frequency span. Learn about using multiple power sensors.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<id>

Power sensor item number. This 1-based number is assigned automatically when a power sensor is added using SENS:CORR:COLL:GUID:PSEN:MULT:ADD.

Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.

<string>

Calibration kit to be used for the specified source port.

When using an ECal module, include the characterization name in the <kit> string. Use SENSe:CORR:COLL:GUID:CKIT:CAT? to read the list of characterizations available in the module and in VNA disk memory.

If two or more identical ECal modules are connected to the VNA, the serial number must be included to distinguish the ECal modules.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT2:CKIT '85055A'

'The following includes a serial number when two or more ECal mods are connected.

sense:correction:collect:guided:psensor2:multiple1:ckit '85092-60010 ECal 10685'

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:CKIT?

Return Type

String

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:CONNector <conn>

(Read-Write) Set and read the connector type of a power sensor to be used when an adapter is necessary to connect the power sensor to the cal plane and you choose to remove its effects from the measurement. Use this command when multiple power sensors are to be used to calibrate the entire frequency span. Learn about using multiple power sensors

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<id>

Power sensor item number. This 1-based number is assigned automatically when a power sensor is added using SENS:CORR:COLL:GUID:PSEN:MULT:ADD.

Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.

<conn>

String - Power sensor connector type to connect to the specified source port <pnum>.

Because the default for this argument is 'Ignored", by specifying a connector type, you imply that you want to calibrate and correct for the effects of the adapter.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT1:CONN "3.5 mm (50) male"

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:CONNector?

Return Type

String

Default

"Ignored"

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple:COUNt?

(Read-only) Returns the number of configured power sensors to be used during a Guided Power Calibration. Learn about using multiple power sensors
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<pnum> | Source port being calibrated. If unspecified, value is set to 1.
Examples | SENS:CORR:COLL:GUID:PSEN1:MULT1:COUN? See example program
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:FREQuency:STARt <num>

(Read-Write) Set and read the start frequency for the specified power sensor (port number). Use this command when multiple power sensors are to be used to calibrate the entire frequency span. Learn about using multiple power sensors

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<id>

Power sensor item number. This 1-based number is assigned automatically when a power sensor is added using SENS:CORR:COLL:GUID:PSEN:MULT:ADD.

Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.

<num>

Start frequency in Hz. Choose a value between the start frequency and stop frequency of the VNA.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT1:FREQ:STAR 1e9

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:FREQuency:STARt?

Return Type

Numeric

Default

Start frequency of the VNA

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:FREQuency:STOP <num>

(Read-Write) Set and read the stop frequency for the specified power sensor (port number). Use this command when multiple power sensors are to be used to calibrate the entire frequency span. Learn about using multiple power sensors

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<id>

Power sensor item number. This 1-based number is assigned automatically when a power sensor is added using SENS:CORR:COLL:GUID:PSEN:MULT:ADD.

Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.

<num>

Stop frequency in Hz. Choose a value between the start frequency and stop frequency of the VNA.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT1:FREQ:STOP 2e9

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:FREQuency:STOP?

Return Type

Numeric

Default

Stop frequency of the VNA

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:NAME <string>

(Read-Write) Set and read the name of the power sensor. Learn about using multiple power sensors.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1.

<id>

Power sensor item number. This 1-based number is assigned automatically when a power sensor is added using SENS:CORR:COLL:GUID:PSEN:MULT:ADD.

Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.

<string>

Sensor name. The power sensor must be already configured as a PMAR device using this name. Learn how to remotely configure a PMAR device.

Examples

SENS:CORR:COLL:GUID:PSEN1:MULT1:NAME "26GHzPwrSensor"

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:NAME?

Return Type

String

Default

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple<id>:REMove

(Write-only) Deletes a power sensor from the sensors to be used during a Guided Power Calibration.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<pnum> | Source port being calibrated. If unspecified, value is set to 1.
<id> | Power sensor item number to remove. Use SENS:CORR:COLL:GUID:PSEN:MULT:COUN? to return the number of power sensor items that are configured for use on the channel.
Examples | SENS:CORR:COLL:GUID:PSEN1:MULT1:REM See example program
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple[:STATe] <value>

(Read-Write) Enables the use of multiple power sensors to calibrate the entire frequency span of the channel. Learn about using multiple power sensors.
Parameters |
<ch> | Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.
<pnum> | Source port being calibrated. If unspecified, value is set to 1. ONLY one port may be calibrated with a Guided Power Cal.
<value> | Boolean ON (or 1) Use multiple power sensors. OFF (or 0) Do NOT use multiple power sensors.
Examples | SENS:CORR:COLL:GUID:PSEN1:MULT 0 sense:correction:collect:guided:psensor2:multiple:state ON See example program
Query Syntax | SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:MULTiple[:STATe]?
Return Type | Boolean
Default | OFF (0)

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:POWer:LEVel <value>, [src]

(Read-Write) Specifies the power level at which to perform a power calibration during a guided calibration.

This command can also be used with Application channels. See NFX example.

When used with Guided Power Cal, first enable a power cal using SENS:CORR:COLL:GUID:PSEN ON.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1. For NFX cals, port number must be 1.

<value>

Power level in dBm at which to perform the power calibration. Learn more.

[src]

String - (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2".

Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

See Remotely Specifying a Source Port

Examples

SENS:CORR:COLL:GUID:PSEN1:POW:LEV 0

sense:correction:collect:guided:psensor2:power:level -5

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>:POWer:LEVel?

Return Type

Numeric

Default

0

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>[:STATe] <value>, [src]

(Read-Write) Enables Guided Power Cal and sets the source port to be calibrated.

Parameters

<ch>

Channel being calibrated, depending on the CHAN:MODE setting. If unspecified, value is set to 1.

<pnum>

Source port being calibrated. If unspecified, value is set to 1. ONLY one port may be calibrated with a Guided Power Cal.

<value>

Boolean

ON (or 1) Perform Power Cal.

OFF (or 0) Do NOT perform Power Cal.

[src]

String - (NOT case sensitive). Source port. Optional. Use SOUR:CAT? to return a list of valid port names.

While this argument can be used to make settings for ALL ports, it is designed to access ports such as an external source, true mode balanced port, or one of the Source 2 outputs on the 2-port 2-source VNA model such as "Port 1 Src2".

Otherwise, the <port> argument performs the same function. If both arguments are specified, [src] takes priority.

See Remotely Specifying a Source Port

Examples

SENS:CORR:COLL:GUID:PSEN1 0

sense:correction:collect:guided:psensor2:state ON

See example program

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:PSENsor<pnum>[:STATe]?

Return Type

Boolean

Default

OFF (0)

Last Modified:

25-Sep-2014

First Release


CorrCollGuidSMC

Sense:Correction:Collect:Guided:SMC Commands

These commands, along with the standard Guided commands, performs a SMC calibration on a frequency converting device.

Note: These commands replace the SENSe:CORRectionCOLLect:Session:SMC commands. These commands allow the entire SMC cal to be performed from the Guided cal interface.

These commands are also used to perform a GCx Calibration. See an example.

SENSe:CORRectionCOLLect:GUIDed:SMC

FSIMulator

| NETWork

| FILename

| MODE

IMPort

LO:PCAL[:STATe]

PWRCal

| CANCel

| RECeiver

| SEParate

Click on a blue keyword to view the command details.

Red keywords are obsolete.

See Also

  • All GUIDed commands

  • Example Programs

  • Learn about SMC Calibrations

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

NOTE: To configure a power meter and sensor see SOURce:POWer: commands.

SENSe<ch>:CORRection:COLLect:GUIDed :SMC:FSIMulator:NETWork<p>:FILename <string>

(Read-Write) Specifies the S2P filename to embed or de-embed on the input or output of your mixer measurement. Learn more.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<p> | Apply network to input or output of mixer. Choose from: 1 - Input of mixer 2 - Output of mixer
<string> | Filename of the S2P used for embedding or de-embedding. Use the full path name, file name, and .S2P suffix, enclosed in quotes.
Examples | SENS:CORR:COLL:GUID:SMC:FSIM:NETW1:FIL "c:\users\public\network analyzer\documents/WaveguideAdapt.S2P"
Query Syntax | SENS<ch>:CORRection:COLLect:GUIDed:SMC:FSIMulator:NETWork<x>:FILename?
Return Type | String
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:FSIMulator:NETWork<p>:MODE <char>

(Read-Write) Allows you to embed (add) or de-embed (remove) circuit network effects on the input and output of your mixer measurement. Learn more.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<p> | Apply network to input or output of mixer. Choose from: 1 - Input of mixer 2 - Output of mixer
<char> | Choose from: NONE - Do nothing with effects of S2P file. EMBed - Add effects of S2P file from the measurement results. DEEMbed - Remove effects of S2P file from the measurement results.
Examples | SENS:CORR:COLL:GUID:SMC:FSIM:NETW1:MODE EMB
Query Syntax | SENS<ch>:CORRection:COLLect:GUIDed:SMC:FSIMulator:NETWork<x>:MODE?
Return Type | Character
Default | NONE

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:IMPort <calName>, <dataset>

(Write-only) Imports Guided Power Cal or Phase Reference Cal into the current SMC calibrations.

For the Guided Power Cal:

The port of the mixer input must have the same source attenuator setting between the SMC channel and the Guided Power Cal Set. The frequencies of the Guided Power Cal must include all the mixer frequencies. Interpolation will be applied to the Guided Power Cal frequencies if they do not exactly match.

For the Phase Reference Cal:

The port of the mixer input must have the same source attenuator setting as used in the phase reference cal. The phase reference cal must include all the mixer frequencies. Interpolation will be applied to the phase reference cal frequencies if they do not exactly match. Learn more about Phase Reference Cal.

The following error message may appear (it is not written to the VNA Error Log):

  • Interpolation target is out of range. Cannot interpolate when incompatible frequency ranges occur.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<calName>

(String) Name of existing Cal Set from which to import power data.

<dataset>

(String) Name of the data set. Choose from:

  • POWER_STEP -Iimport the Guided Power Cal data.

  • "POWER_AND_PHASE" - Import the Phase Reference + power cal data. When this command is sent, the SMC Cal Method is automatically set to Use Phase Reference Cal. Learn more. There is no other command to set this.

Examples

SENS2:CORR:COLL:GUID:SMC:IMP "MyPowerCal","POWER_STEP"

See example program

SENS:CORR:COLL:GUID:SMC:IMP "MyPhaseRefCal","POWER_AND_PHASE"

See example program

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:LO<n>:PCAL[:STATe] <bool>

(Read-Write) Sets and returns whether or not the LO power cal step is included in the cal steps when an SMC or GCx cal is performed. Learn more.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | LO Stage. Choose 1.
<bool> | LO Power Cal state. Choose from: O or OFF - Skips over the LO Power Cal when calibrating. 1 or ON - Includes a step for LO Power Cal when calibrating
Examples | SENS:CORR:COLL:GUID:SMC:LO1:PCAL 0
Query Syntax | SENSe<ch>:CORRection:COLLect:GUIDed:SMC:LO<n>:PCAL[:STATe]
Return Type | Boolean
Default | OFF or 0

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:PWRCal:CANCel

(Write-only) Aborts a power cal. This command should be sent when a power cal is running.
Parameters |
<ch> | Channel number of the SMC cal being performed. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:SMC:PWRC:CANC
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:PWRCal:RECeiver <bool>

(Read-Write) Set whether to use the reference receiver for faster iteration during power cal or use a power meter. This command should be set during calibration setup. Learn more.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1
<bool> | OFF or 0 - Use a power meter only. ON or 1 - Use a power meter for the first reading and the reference receiver for all subsequent readings.
Examples | SENS:CORR:COLL:GUID:SMC:PWRC:REC 1
Query Syntax | SENSe<ch>:CORRection:COLLect:GUIDed:SMC:PWRCal:RECeiver?
Return Type | Boolean
Default | ON or 1

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:PWRCal:SEParate <bool>

(Read-Write) Specifies whether to use a Thru standard or to use two power sensor connections during the power cal of an SMC calibration.

Note: This command must be sent immediately after SENS:CORR:COLL:GUID:INIT and before all the other calibration commands.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<bool>

OFF or 0 - Perform Cal with Thru standard.

ON or 1 - Do NOT use a Thru, but instead perform separate power cals on Input and Output reference planes.

Examples

SENS:CORR:COLL:GUID:SMC:PWRC:SEP 1

SENS:CORR:COLL:GUID:INIT "SMC"

Query Syntax

SENSe<ch>:CORRection:COLLect:GUIDed:SMC:PWRCal:SEParate?

Return Type

Boolean

Default

OFF or 0

Last Modified:

8-Jan-2015

Initial Release


ECalCharacterize

SENSe:CORR:CKIT:ECAL:CHARacterize Commands

Controls the settings used to perform an ECal User Characterization. These commands do NOT perform the calibration that is required before measuring the ECal module. An S-Parameter channel must already be calibrated. Learn more.

SENSe:CORR:CKIT:ECAL:CHARacterize:

ACQuire

CNUMber

CONNector

| CATalog?

| PORT<n>[:SELect]

DESCription

| PORT<n>[:SELect]

| [STEP]?

| USER

| VNA

DMEMory

| SAVE

ID

INITiate

SAVE

STEPs?

Click on a blue keyword to view the command details.

Notes:

These commands provide for the following:

  • Measure the ECal module with adapters, cables, or fixtures to be included in the User Characterization.

  • Allow descriptive text to be entered.

  • Save the User Characterization to the ECal module or VNA disk memory. Up to 12 User Characterizations can be stored in an ECal module. Learn more.

You can NOT perform a remote User Characterization of a 4-port ECal module using a 2-port VNA. This can only be done from the front panel user interface.

See Also

  • Example - Perform an ECal User Characterization

  • Learn about ECal User Characterization

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:ACQuire STAN<step>

(Write-only) Initiates the measurement of the ECal module. The user characterization process must have been initiated first using SENS:CORR:CKIT:ECAL:CHAR:INIT.

Currently, only ONE step is required to measure the ECal module.

Note: This command is an overlapped command. When *OPC is issued with it, the OPC bit in the VNAs Standard Event Status Register is not set until this command has completed its operation. Learn more.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1. Channel number being calibrated.

<step>

Integer User characterization step number to be measured.

Examples

SENS:CORR:CKIT:ECAL:CHAR:ACQ STAN1, *OPC

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:CNUMber <n>

(Read-Write) Sets and reads the number to which the User Characterization will be stored in the ECal module. The number must be set before sending SENS:CORR:CKIT:ECAL:CHAR:INIT or the default value (1) will be used. This command is NOT necessary when saving the User Characterization to the VNA disk memory.
Parameters |
<ch> | Channel number being calibrated. If unspecified, value is set to 1
<n> | User Characterization number. Choose a value between 1 and 12.
Examples | SENSe:CORR:CKIT:ECAL:CHAR:CNUM 2
Query Syntax | SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:CNUMber?
Return Type | Numeric
Default | 1

SENSe:CORRection:CKIT:ECAL:CHARacterize:CONNector:CATalog?

(Read-only) Returns a list of connector names that are valid for use with user-characterized ECal modules. Use an item from the returned list to specify a connector for SENS:CORR:CKIT:ECAL:CHAR:CONN:PORT.

Use only factory-defined connector types when you store a user characterization to VNA disk memory.

Parameters

None

Examples

SENS:CORR:CKIT:ECAL:CHAR:CONN:CAT?

'Example returned string: "APC 3.5 male, APC 3.5 female, Type N (50) female, Type N (50) male, APC 7, Type A (50), Type B"

Return Type

Comma-separated string

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:CONNector:PORT<n>[:SELect] <string>

(Read-Write) Specifies a connector type name for every ECal module port used during the user characterization. Valid connector names are returned using SENS:CORR:CKIT:ECAL:CHAR:CONN:CAT?

This command refers to the ECal ports by number instead of letter (1 = Port A, 2 = Port B, and so forth). The connector names should be set for the ports before sending SENS:CORR:CKIT:ECAL:CHAR:INIT.

The following steps could be followed to ensure port connectors are specified correctly:

  1. Use SENS:CORR:CKIT:ECAL:CHAR:CONN:CAT? to query available connectors before specifying the port connector.

  2. Specify a connector type using this command. If the <string> parameter was incorrectly entered, an error will be returned.

Note: Use only factory-defined connector types when you store a user characterization to VNA disk memory.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1

<n>

ECal test port number for which a connector type will be specified. Choose 1 to 2 for a 2-port ECal module, 1 through 4 for a 4-port module.

<string>

ECal connector type and gender (if applicable).

When the User Characterization is to be stored in the ECal module, then the connector type is limited to a Factory-defined connector type. See the list.

When the User Characterization is to be stored in VNA disk memory, then the connector type can also be a User-defined connector type.

Examples

SENS:CORR:CKIT:ECAL:CHAR:CONN:PORT2 "APC 3.5 female"

Query Syntax

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:CONNector:PORT<n>[:SELect]?

Return Type

String

Default

"No adapter"

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription[:STEP]? <stepN>

(Read-only) Returns the connection description for the specified step of the ECal user characterization process. The user characterization process must have been initiated first using SENS:CORR:CKIT:ECAL:CHAR:INIT.
Parameters |
<ch> | Channel number being calibrated. If unspecified, value is set to 1
<stepN> | Integer - User characterization step number for which a description will be returned. Use SENS:CORR:CKIT:ECAL:CHAR:STEP? to query the number of steps.
Examples | SENSe:CORR:CKIT:ECAL:CHAR:DESC? 2 ''Example return string: Connect ECal Module Ports A and B to VNA Ports 1 and 2
Return Type | String
Default | Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:USER <string>

(Read-Write) Sets and reads the description of the person and/or company who is producing the ECal user characterization. This description is stored with the characterization.

Set this description before sending SENS:CORR:CKIT:ECAL:CHAR:INIT or the default (empty string) will be used.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1

<string>

Descriptive text, limited to 19 characters maximum.

Examples

SENSe:CORR:CKIT:ECAL:CHAR:DESC:USER "John Doe, Acme Inc."

Query Syntax

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:USER?

Return Type

String

Default

" " (Empty String)

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:VNA <string>

(Read-Write) Sets and reads a description of the Vector Network Analyzer used to perform the User Characterization. This description is stored with the user characterization.

Set this description before sending SENS:CORR:CKIT:ECAL:CHAR:INIT or the default (empty string) will be used.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1

<string>

Descriptive text, limited to 14 characters maximum.

Examples

SENSe:CORR:CKIT:ECAL:CHAR:DESC:VNA "My VNA"

Query Syntax

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:VNA?

Return Type

String

Default

" " (Empty String)

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:PORT<n>[:SELect] <string>

(Read-Write) For each port of the ECal module that is going to be characterized, sets and reads the description of the adapters, cable, or fixture to be included in the user characterization. This command refers to the ECal ports by number instead of letter (1 = Port A, 2 = Port B, and so forth). This description is stored with the user characterization.

Set this description before sending SENS:CORR:CKIT:ECAL:CHAR:INIT or the default (empty string) will be used.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1

<n>

ECal port number. Choose 1 to 2 for a 2-port ECal module, 1 to 4 for a 4-port module.

<string>

Descriptive text, limited to 24 characters maximum.

Examples

SENSe:CORR:CKIT:ECAL:CHAR:DESC:PORT1 "3.5 mm adapter, SN 00001"

Query Syntax

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DESCription:PORT<n>[:SELect]?

Return Type

String

Default

" " (Empty String)

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:DMEMory:SAVE <charName>

(Write-only) Completes an ECal user characterization by writing the characterization data to the VNA disk. To write the characterization data to the ECal module, use SENS:CORR:CKIT:ECAL:CHAR:SAVE. A User Characterization can be saved to both VNA disk memory and ECal module memory.

Use this <charName> for performing future calibrations with this User Characterization. See SENS:CORR:CKIT:ECAL:KNAM:INF?

Note: An ECal confidence check can NOT be performed remotely from User Characterizations that are stored on the VNA disk.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1.

<charName>

String. User characterization name. Although there is no limit to the number of characters, only about 10 characters appear in the Cal Wizard dialog when selecting a user characterization for use.

Examples

SENS:CORR:CKIT:ECAL:CHAR:DMEM:SAVE "DUT1 User Char"

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:ID <model, sn>

(Read-Write) Selects the model and serial number of the ECal module to be characterized. This command does not Set the model and serial number of the ECal module.
Parameters |
<ch> | Channel number being calibrated. If unspecified, value is set to 1
<model, sn> | Model and serial number of the ECal module to be characterized.
Examples | SENSe:CORR:CKIT:ECAL:CHAR:ID "N4433A,00001"
Query Syntax | SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:ID?
Return Type | String
Default | " " (Empty String)

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:INITiate [bool]

(Write-only) Initiates an ECal User Characterization. The specified channel number must be an S-parameter measurement channel. The channel must already be calibrated using the same, or greater number of VNA ports as the ECal module. Also, the calibrated VNA ports must begin with Port 1 and use sequential port numbers.

After this command is executed, subsequent commands can be used to query the number of measurement steps, issue the acquisition commands, query the connection description strings, and subsequently complete an Ecal User characterization.

Parameters

<ch>

Channel number of a calibrated S-parameter channel. If unspecified, value is set to 1

[bool]

Optional argument. If unspecified, value is set to 1.

ON (or 1) Check ECal memory to ensure that a new characterization with the channels current number of points will fit in the module memory. Select for User Characterizations to be stored in internal ECal memory.

OFF (or 0) Skip the check. Select for User Characterizations to be stored to VNA disk memory.

Examples

SENS:CORR:CKIT:ECAL:CHAR:INIT

sense2:correction:ckit:ecal:characterize:initiate off

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:SAVE

(Write-only) Completes an ECal user characterization by writing the characterization data to the ECal module memory. To write the characterization data to VNA disk memory, use SENS:CORR:CKIT:ECAL:CHAR:DMEM:SAVE. A User Characterization can be saved to both VNA disk memory and ECal module memory.

Note: This command is an overlapped command. When *OPC is issued with it, the OPC bit in the PNAs Standard Event Status Register is not set until this command has completed its operation. Learn more.

Parameters

<ch>

Channel number being calibrated. If unspecified, value is set to 1.

Examples

SENS:CORR:CKIT:ECAL:CHAR:SAVE, *OPC

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:CORRection:CKIT:ECAL:CHARacterize:STEPs?

(Read-only) Returns the number of steps required to measure the ECal module. Currently, only ONE is required.
Parameters |
<ch> | Channel number being calibrated. If unspecified, value is set to 1
Examples | SENS:CORR:CKIT:ECAL:CHAR:STEP?
Return Type | Numeric
Default | Not Applicable

Last Modified:

24-Sep-2014

First Release


MixerSegment

SENSe:MIXer:SEGMent Commands

Configures Mixer Segments.

SENSe:MIXer:SEGMent:

ADD

BWIDth

CALCulate

COUNt?

DELete

| ALL

DWELI

IF:FREQuency

| SIDeband

INPut

| FREQuency

| FIXed

| MODE

| STARt

| STOP

| POWer

LO:FREQuency

| FIXed

| ILTI

| MODE

| STARt

| STOP

LO:POWer

OUTPut:FREQuency

| FIXed

| MODE

| SIDeband

| STARt

| STOP

OUTPut:POWer

POINts

STATe

Click on a Red keyword to view the command details.

See Also

  • Example Programs

  • Learn about the Frequency Converter Application

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Scratch vs Applied Mixer Properties

Each mixer configuration has two sets of properties:

  1. Scratch mixer contains the properties that have been set, but NOT YET applied. Send the SENSe<ch>:MIXer:APPLy command to copy these properties to the Applied mixer.

  2. Applied mixer contains the properties that makeup the current mixer configuration.

Power settings are immediately applied to both the Scratch and Applied mixer.

A successful Calculate also perform an Apply.

Note: Queries always return the Applied mixer properties. Therefore, first send SENSe<ch>:MIXer:APPLy before querying new settings.

SENSe<ch>:MIXer:SEGMent<n>:ADD <value>

(Write only) Adds the specified number of segments to the scratch mixer beginning at the last segment position. All segments are added with default settings.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Position at which to add segments. Valid range is between 1 and the current segment count +1. Using count +1 adds segments to the end of the segment table. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Optional argument. Number of segments to add. If unspecified, 1 segment is added.
Examples | SENS:MIX:SEGM1:ADD 3 'Adds 3 segments beginning at position 1. For a preset state, this results in a total of 4 segments.
Query Syntax | Not Applicable
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:SEGMent<n>:BWIDth <value>

(Read-Write) Sets and returns the IF Bandwidth for the sweep segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which IF Bandwidth is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | IF Bandwidth in Hz. The list of valid IF Bandwidths is different depending on the VNA model. (Click to see the lists.) If an invalid number is specified, the analyzer will round up to the closest valid number. This parameter supports MIN and MAX as arguments. Learn more.
Examples | SENS:MIX:SEGM1:BWID 1e3
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:BWIDth? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | 100 kHz

SENSe<ch>:MIXer:SEGMent<n>:CALCulate <char>

(Write-only) Calculates the Input, IF, or Output frequencies of the mixer setup and updates the channel settings.

Parameters

<ch>

Any existing channel number. If unspecified, value is set to 1

<n>

Existing segment to calculate. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.

<char>

Mixer port to be calculated. Choose from:

<char>

1st or only stage requires:

In addition, 2nd stage requires:

INPut

  • Output Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

BOTH

NA

  • IF Start and Stop frequencies

  • Both LO frequencies

OUTPut

  • Input Start and Stop frequencies

  • LO frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

LO_1

  • Input Start and Stop frequencies

  • Output frequency

  • Output sideband (High or Low)

  • IF Start and Stop frequencies

  • 2nd LO frequency

  • IF sideband (High or Low)

LO_2

NA
  • Input Start and stop frequencies
  • 1st LO start and stop frequencies
  • Output frequency
  • IF sideband(High or Low
  • Output sideband(High or Low)

Examples

SENS:MIX:SEGM2:CALC Output

Query Syntax

Not Applicable

Default

Not Applicable

SENSe<ch>:MIXer:SEGMent:COUNt?

(Read-only) Returns the number of segments on the Applied mixer.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
Examples | SENS:MIX:SEGM:COUN?
Return Type | Numeric
Default | Not Applicable

SENSe<ch>:MIXer:SEGMent<n>:DELete <value>

(Write-only) Removes the specified number of segments from the scratch mixer starting at the index position.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Position at which to start removing segments. Valid index range is between 1 and the current segment count. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Optional argument. Number of segments to remove. If unspecified, 1 segment is removed.
Examples | SENS:MIX:SEGM1:DEL 5 'Removes 5 segments beginning at the first position.
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:MIXer:SEGMent:DELete:ALL

(Write-only) Removes all segments from the scratch mixer.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
Examples | SENS:MIX:SEGM:DEL:ALL
Query Syntax | Not Applicable
Default | Not Applicable

SENSe<ch>:MIXer:SEGMent<n>:DWELI

(Read-Write) Sets or returns the Input sweep mode of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Input frequency mode is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
Examples | SENS:MIX:SEGM2:DWELI
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:DWELI? Send Apply before sending this query. Learn more.
Return Type | Character
Default | Swept

SENSe<ch>:MIXer:SEGMent<n>:IF:FREQuency:SIDeband <char>

(Read-Write) When two LO stages are used, sets or returns whether to select the sum or difference for the IF1 product. (Input + or - LO1 = IF1)

  • This setting corresponds to the [image] buttons on LO1 on the Mixer Setup dialog.

  • This setting is ignored when ONE LO stage is selected.

  • Also set SENS:MIX:OUTP:FREQ:SID to LOW or HIGH to set the output frequency of the mixer.

Parameters

<ch>

Channel number of the mixer measurement. If unspecified, value is set to 1.

<n>

Existing segment for which IF Sideband is to be set.

Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.

<char>

Sideband value. Choose from

LOW - Difference (-)

HIGH - Sum (+)

Examples

SENS:MIX:SEGM2:IF:FREQ:SID LOW

Query Syntax

SENSe<ch>:MIXer:SEGMent<n>:IF:FREQuency:SIDeband?

Send Apply before sending this query. Learn more.

Return Type

Character

Default

LOW

SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:FIXed <value>

(Read-Write) Sets or returns the Input fixed frequency of the segment. Also, set SENS:MIX:SEGM:INP:FREQ:MODE FIXED.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which input fixed frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Input fixed frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:INPut:FREQ:FIX 1e9
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:FIXed? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Start frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:MODE <char>

(Read-Write) Sets or returns the Input sweep mode of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Input frequency mode is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<char> | Input sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:SEGM2:INP:FREQ:MODE FIXED
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:MODE? Send Apply before sending this query. Learn more.
Return Type | Character
Default | Swept

SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:STARt <value>

(Read-Write) Sets or returns the Input start frequency value of the segment. Also, set SENS:MIX:SEGM:FREQ:MODE SWEPT.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Input start frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Input Start frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:INPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:STARt? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Start frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:STOP <value>

(Read-Write) Sets or returns the Input stop frequency value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Input stop frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Input Stop frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:INPut:FREQ:STOP 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:FREQuency:STOP? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Stop frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:INPut:POWer <value>

(Read-Write) Sets or returns the Input power value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Input power is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Input power level in dBm. Choose a value within the power range of the VNA.
Examples | SENSe2:MIXer:SEGMent2:INPut:POWer 0
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:POWer? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | -15 dBm

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:FIXed <value>

(Read-Write) Sets or returns the LO1 and LO2 fixed frequency value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which the LO1 and LO2 fixed frequency value is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number for which the fixed frequency is to be set. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<value> | The LO1 and LO2 fixed frequency value in Hz. Choose a value within the frequency range of the source.
Examples | SENSe2:MIXer:SEGMent2:LO1:FREQ:FIX 1e9
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:FIXed? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | 0 Hz

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:ILTI <bool>

(Read-Write) Specifies whether to use the Input frequency that is greater than the LO or less than the LO. To learn more, see the mixer setup dialog box help.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which the LO1 and LO2 fixed frequency value is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number for which ILT is to be set. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<bool> | ON (1) - Use the Input that is Greater than the specified LO. OFF (0) - Use the Input that is Less than the specified LO.
Examples | SENSe2:MIXer:SEGMent2:LO1:FREQ:ILTI 1
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:ILTI? Send Apply before sending this query. Learn more.
Return Type | Boolean
Default | OFF

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:MODE <char>

(Read-Write) Sets or returns the LO1 or LO2 sweep mode of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which LO frequency mode is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number for which ILT is to be set. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<char> | LO sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:SEGM2:LO1:FREQ:MODE FIXED
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:LO<n>:FREQuency:MODE? Send Apply before sending this query. Learn more.
Return Type | Character
Default | Fixed

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:STARt <value>

(Read-Write) Sets or returns the LO start frequency value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which LO start frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<value> | LO Start frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:LO1:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:STARt? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Start frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:STOP <value>

(Read-Write) Sets or returns the LO stop frequency value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which LO stop frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<value> | LO Stop frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:LO<x>:FREQ:STOP 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:LO<x>:FREQuency:STOP? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Stop frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:LO<x>:POWer <value>

(Read-Write) Sets or returns the LO power of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which LO power is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<x> | LO stage number. Choose 1 or 2. Set number of stages for the mixer using SENSe<ch>:MIXer:STAGe.
<value> | LO power level in dBm. Choose a value within the power range of the VNA.
Examples | SENSe2:MIXer:SEGMent2:INPut:POWer 0
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:INPut:POWer? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | -10 dBm

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:FIXed <value>

(Read-Write) Sets or returns the Output fixed frequency of the segment. Also, set SENS:MIX:SEGM:INP:FREQ:MODE FIXED.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Output fixed frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Output fixed frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:OUTP:FREQ:FIX 1e9
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:FIXed? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Start frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:MODE <char>

(Read-Write) Sets or returns the Output sweep mode of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Output frequency mode is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<char> | Output sweep mode. Choose either FIXED or SWEPT
Examples | SENS:MIX:SEGM2:OUTP:FREQ:MODE FIXED
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:MODE? Send Apply before sending this query. Learn more.
Return Type | Character
Default | Swept

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:SIDeband <char>

(Read-Write) When two LO stages are used, sets or returns whether to select the sum or difference for the Output product. Use for both 1 or 2 stage mixers.

  • This setting corresponds to the [image] buttons on the Output on the Mixer Frequency dialog.

  • Also set SENS:MIX:IF:FREQ:SID to LOW or HIGH to determine the IF frequency for 2-stage mixers.

Parameters

<ch>

Channel number of the mixer measurement. If unspecified, value is set to 1.

<n>

Existing segment for which Output Sideband is to be set.

Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.

<char>

Sideband value. Choose from

LOW - Difference (-)

HIGH - Sum (+)

Examples

SENS:MIX:SEGM2:OUTP:FREQ:SID LOW

Query Syntax

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:SIDeband?

Send Apply before sending this query. Learn more.

Return Type

Character

Default

LOW

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:STARt <value>

(Read-Write) Sets or returns the Output start frequency value of the segment. Also, set SENS:MIX:SEGM:FREQ:MODE SWEPT.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Output start frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Output Start frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:OUTPut:FREQ:STARt 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:STARt? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Start frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:STOP <value>

(Read-Write) Sets or returns the Output stop frequency value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Output stop frequency is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Output Stop frequency. Choose a value between the start and stop frequency of the VNA.
Examples | SENSe2:MIXer:SEGMent2:OUTPut:FREQ:STOP 1000000000
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:OUTPut:FREQuency:STOP? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | Stop frequency of the VNA.

SENSe<ch>:MIXer:SEGMent<n>:OUTPut:POWer <value>

(Read-Write) Sets or returns the Output power value of the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which Output power is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Output power level in dBm. Choose a value within the power range of the VNA.
Examples | SENSe2:MIXer:SEGMent2:OUTPut:POWer 0
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:OUTPut:POWer? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | -10 dBm

SENSe<ch>:MIXer:SEGMent<n>:POINts <value>

(Read/Write) Sets and returns the number of data points for the sweep segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment for which number of points is to be set. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<value> | Number of data points. Choose any number between 1 and the VNA maximum number of points. This parameter supports MIN and MAX as arguments. Learn more.
Examples | SENS:MIX:SEGM1:POIN 3
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:POINts? Send Apply before sending this query. Learn more.
Return Type | Numeric
Default | 21

SENSe<ch>:MIXer:SEGMent<n>:STATe <bool>

(Read/Write) Sets and returns the ON/OFF state for the segment.
Parameters |
<ch> | Channel number of the mixer measurement. If unspecified, value is set to 1.
<n> | Existing segment to be set ON or OFF. Use SENS:MIX:SEGM:COUN? to read the current count in the Applied Mixer.
<bool> | Segment state. Choose from: ON (or 1) - Turns the segment ON. OFF (or 0) - Turns the segment OFF
Examples | SENS:MIX:SEGM1:STATe 1
Query Syntax | SENSe<ch>:MIXer:SEGMent<n>:STATe? Send Apply before sending this query. Learn more.
Return Type | Boolean
Default | ON

Last modified:

6-Jan-2016

First Release


Pulse

Sense:Pulse Commands

Configures the 5 pulse generators in the VNA.

These commands can also be used to control an external Pulse Generator. Learn more.

SENSe:PULSe

| CATalog?

| DELay

| INVert

| PERiod

| STATe

| TPOLarity

| WIDTh

Click on a blue keyword to view the command details.

To make other Pulse settings, such as enabling the internal pulse modulators, use this command:

  • SENSe<ch>:PATH:CONFig:ELEMent[:STATe] <elem>, <setting>

  • At that command help topic, click the IF Configuration elements and values link to see the Pulse element and setting (in the middle box ) to configure.

See Also

  • SENS:SWEep:PULSE - configures the channel for pulse measurements

  • External Pulse Generator configuration commands

  • SENS:IF configuration commands

  • Example Programs

  • VNA Integrated Pulse Application

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

Pulse Definitions

  • D = Delay; the time before each pulse begins

  • W = Width; the time the pulse is ON

  • P = Period; one complete pulse cycle

  • Duty Cycle = W/P

Important: If D + W is greater than P, then undefined VNA behavior results. There is NO error message or warning.

SENSe:PULSe:CATalog?

Applicable Models: M9485A

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<n> | Range number. If unspecified, value is set to 1.
<s> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. sense2:fom:range2:segment:add
Query Syntax | Not Applicable
Default | Not Applicable
(Read-only) Returns the string names of internal and configured external pulse generators.
Parameters | None
Examples | SENS:PULS:CAT?
Default | Not Applicable

SENSe<ch>:PULSe<n>:DELay <value>[,<name>]

Applicable Models: M9485A

(Read-Write) Sets the pulse delay. The amount of time before a new pulse begins. See Pulse Definition diagram.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<n> | Internal pulse generator number. Choose from 0 to 4. 0 is the generator that pulses the ADC.
<value> | Delay value in seconds. Choose a value from about 33ns to about 70 seconds.
<name> | Optional. String name of the pulse generator. Required for use with external pulse generators. Use SENSe:PULSe:CAT? to return the names of configured pulse generators. If specified, <n> is ignored. If unspecified, <n> is required for internal pulse generators.
Examples | SENS:PULS1:DEL .5 SENS:PULS:DEL .5, "My81110"
Query Syntax | SENSe<ch>:PULSe<n>:DELay? [<name>]
Return Type | Numeric
Default | 0

SENSe<ch>:PULSe<n>:INVert <value>[,<name>]

Applicable Models: M9485A

(Read-Write) Sets whether to invert the polarity of the pulse.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<n> | Pulse generator number. Choose from 0 to 4. 0 is the generator that pulses the ADC.
<value> | Boolean ON (or 1) - Invert the pulse generator polarity. This causes the pulse ON time to be active low and OFF be active high. OFF (or 0) - Do NOT Invert the pulse generator polarity.
<name> | Optional. String name of the pulse generator. Required for use with external pulse generators. Use SENSe:PULSe:CAT? to return the names of configured pulse generators. If specified, <n> is ignored. If unspecified, <n> is required for internal pulse generators.
Examples | SENS:PULS1:INV 1 SENS:PULS:INV 1, "My81110"
Query Syntax | SENSe<ch>:PULSe:INVert? [<name>]
Return Type | Boolean
Default | OFF (0)

SENSe<ch>:PULSe:PERiod <value>[,<name>]

Applicable Models: M9485A

(Read-Write) Sets the pulse-period (1/PRF) for ALL pulse generators. The resolution of the period is: DSP version: 4.0 = 16.667nS. DSP version: 5.0 = 10nS Learn more about DSP version. See Pulse Definition diagram.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<value> | Pulse period in seconds. Choose a value from about 33ns to about 70 seconds.
<name> | Required for use with an external pulse generator. String name of the external pulse generator. If unspecified, the period for the internal pulse generators are set. Use SENSe:PULSe:CAT? to return the names of configured pulse generators.
Examples | SENS:PULS:PERiod .05 SENS:PULS:PER .01, "My81110"
Query Syntax | SENSe<ch>:PULSe:PERiod? [<name>]
Return Type | Numeric
Default | 1e-3 sec

SENSe<ch>:PULSe<n>[:STATe] <value>[,<name>]

Applicable Models: M9485A

(Read-Write) Turns the pulse output ON and OFF.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<n> | Pulse generator number. Choose from 0 to 4. 0 is the generator that pulses the ADC.
<value> | Boolean ON (or 1) - turns pulse output ON. OFF (or 0) - turns pulse output OFF.
<name> | Optional. String name of the pulse generator. Required for use with external pulse generators. Use SENSe:PULSe:CAT? to return the names of configured pulse generators. If specified, <n> is ignored. If unspecified, <n> is required for internal pulse generators.
Examples | SENS:PULS1 1 SENS:PULS 1, "My81110"
Query Syntax | SENSe<ch>:PULSe[:STATe]? [<name>]
Return Type | Boolean
Default | OFF

SENSe<ch>:PULSe:TPOLarity <char>

Applicable Models: M9485A

(Read-Write) Sets the polarity of the trigger signal to which the internal pulse generators will respond when being externally triggered at the PulseSyncIn pin. Learn more about the VNA pulse generators.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<char> | Pulse polarity. Choose from: POSitive - VNA responds to rising edge or HIGH level NEGative - VNA responds to falling edge or LOW level. Set Edge or Level triggering using SENS:PULS:TTYPe.
Examples | SENS:PULS:TPOL NEG
Query Syntax | SENSe<ch>:PULSe:TPOLarity?
Return Type | Character
Default | POSitive - Also the polarity used when the VNA does not have the required DSP hardware.

SENSe<ch>:PULSe<n>:WIDTh <value>[,<name>]

Applicable Models: M9485A

(Read-Write) Sets the pulse width. The amount of time that the pulse is ON. See Pulse Definition diagram.
Parameters |
<ch> | Any existing channel number; if unspecified, value is set to 1.
<n> | Pulse generator number. Choose from 0 to 4. 0 is the generator that pulses the ADC.
<value> | Pulse width in seconds. Choose a value from about 33ns to about 70 seconds.
<name> | Optional. String name of the pulse generator. Required for use with external pulse generators. Use SENSe:PULSe:CAT? to return the names of configured pulse generators. If specified, <n> is ignored. If unspecified, <n> is required for internal pulse generators.
Examples | SENS:PULS:WIDT .5 SENS:PULS:WIDT .5, "My81110"
Query Syntax | SENSe<ch>:PULSe<n>:WIDTh? [<name>]
Return Type | Numeric
Default | 1e-4 sec

Last Modified:

6-Jan-2016

New topic


Role

Sense:Role Commands

Controls the path configuration settings.

SENSe:ROLE:

| CATalog?

| DEVice

Click on a blue keyword to view the command details.

See Also

  • Example Programs

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<ch>:ROLE:CATalog?

(Read-only) Returns the roles for which sources can be used for the channel.
Parameters |
<ch> | Channel number of the measurement. If unspecified, value is set to 1.
Examples | SENS:ROLE:CAT?
Return Type | Comma-separated list of double-quoted strings.
Default | Not Applicable

SENSe<ch>:ROLE:DEVice <role>,<source>

(Read-Write) Set and return the source to be used in the specified role. For example, use this command to set a source name to be used as the RF2 tone for a Swept IMD channel.
Parameters |
<ch> | Channel number of the measurement. If unspecified, value is set to 1.
<role> | (String) Role of the source. Not context-sensitive. Use SENSe:ROLE:CATalog? to read the valid roles for the channel.
<source> | (String) Source name to be used in the specified role. Use SYSTem:CONFigure:EDEVice:CAT? to read a list of configured sources.
Examples | SENS2:ROLE:DEV "RF2","MyEsg"
Query Syntax | SENSe<ch>:ROLE:DEVice? <role>
Return Type | String
Default | Not Applicable

Last modified:

6-Jan-2016

Initial Release


SweepPulse

Sense:Sweep:Pulse Commands

Configures the channel to make pulse measurements using the Pulse Application.

SENSe:SWEep:PULSe

CWTime

DRIVe[:AUTO]

MASTer:

| FREQuency

| PERiod

| WIDTh

MODE

TIMing[:AUTO]

Click on a blue keyword to view the command details.

See Also

  • Example Program using these commands.

  • SENS:PULSe commands used to configure the pulse generators.

  • VNA IF Path Block diagram

  • SENS:IF configuration commands

  • Synchronizing the VNA and Controller

  • SCPI Command Tree

SENSe<ch>:SWEep:PULSe:CWTime[:AUTO] <bool>

Applicable Models: M9485A

(Read-Write) Sets and returns the state of automatic CW sweep time (used in Pulse Profile mode). This setting is labeled Autoselect Profile Sweep Time on the UI.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<bool> | Choose from: OFF (or O) - The Sweep Time is not changed automatically. ON (or 1) - In Pulse Profile mode, adjusts the default X-axis start time to zero and the stop time to double the Pulse Width. This allows you to see one complete pulse.
Examples | SENS:SWE:PULS:CWT 1 sense2:sweep:pulse:cwtime:auto off
Query Syntax | SENSe<ch>:SWEep:PULSe:CWTime[:AUTO]?
Return Type | Boolean
Default | ON

SENSe<ch>:SWEep:PULSe:DRIVe[:AUTO] <bool>

Applicable Models: M9485A

(Read-Write) Set the drive for the source modulation automatically or manually. This setting is labeled Autoselect Pulse Generator on the UI.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<bool> | Choose from: OFF (or O) - Manually set source modulation. ON (or 1) - Automatically set pulse gen 1 as the modulation source and pulse gen 2 as the gate source for all gates.
Examples | SENS:SWE:PULS:DRIV 1 sense2:sweep:pulse:drive:auto off
Query Syntax | SENSe<ch>:SWEep:PULSe:DRIVe[:AUTO]?
Return Type | Boolean
Default | ON

SENSe<ch>:SWEep:PULSe:MASTer:FREQuency <value>

Applicable Models: M9485A

(Read-Write) Sets and returns the master pulse measurement frequency. The frequency is 1/period, so this value can also be set using SENS:SWE:PULS:MAST:PERiod. Note: On the Pulse Setup dialog, this command is a 'Basic setting, which is intended to be used with the 'Auto' selections set to ON.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<value> | Master frequency. Choose a value between
Examples | SENS:SWE:PULS:MAST:FREQ 1e9 sense2:sweep:pulse:master:frequency 1e6
Query Syntax | SENSe<ch>:SWEep:PULSe:MASTer:FREQuency
Return Type | Value
Default | 1 kHz

SENSe<ch>:SWEep:PULSe:MASTer:PERiod <value>

Applicable Models: M9485A

(Read-Write) Sets and returns the master pulse period. The period is 1/frequency, so this value can also be set using SENS:SWE:PULS:MAST:FREQ. Note: On the Pulse Setup dialog, this command is a 'Basic' setting, which is intended to be used with the 'Auto' selections set to ON.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<value> | Master period in seconds.
Examples | SENS:SWE:PULS:MAST:PER 1e-6 sense2:sweep:pulse:master:period 1e-3
Query Syntax | SENSe<ch>:SWEep:PULSe:MASTer:PERiod?
Return Type | Value
Default | 1 msec

SENSe<ch>:SWEep:PULSe:MASTer:WIDth <value>

Applicable Models: M9485A

(Read-Write) Sets and returns the master pulse width. Note: On the Pulse Setup dialog, this command is a 'Basic' setting, which is intended to be used with the 'Auto' selections set to ON.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<value> | Master pulse width in seconds..
Examples | SENS:SWE:PULS:MAST:WIDTh sense2:sweep:pulse:master:width
Query Syntax | SENSe<ch>:SWEep:PULSe:MASTer:WIDTh?
Return Type | Value
Default | 100 microseconds

SENSe<ch>:SWEep:PULSe:MODE <char>

Applicable Models: M9485A

(Read-Write) Sets and returns the pulse measurement state for the channel.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<char> | Choose from: OFF - Turn OFF pulse measurements. STD - Turn ON standard pulse measurements. PROFILE - Turn ON pulse profile measurements.
Examples | SENS:SWE:PULS:MODE PROFILE sense2:sweep:pulse:mode off
Query Syntax | SENSe<ch>:SWEep:PULSe:MODE?
Return Type | Character
Default | OFF

SENSe<ch>:SWEep:PULSe:TIMing[:AUTO] <bool>

Applicable Models: M9485A

(Read-Write) Choose to set the delay and width automatically or manually. This setting is labeled Autoselect Width and Delay on the UI.
Parameters |
<ch> | Channel number of the pulse measurement. If unspecified, value is set to 1.
<bool> | Choose from: OFF (or O) - Manually set the delay and width for the measurement. ON (or 1) - Automatically set the delay and width for the measurement.
Examples | SENS:SWE:PULS:TIM 1 sense2:sweep:pulse:timing:auto off
Query Syntax | SENSe<ch>:SWEep:PULSe:TIMing[:AUTO]?
Return Type | Boolean
Default | ON

Last Modified:

2016-01-06

New topic


Voltage

Sense:Voltage Command

SENSe<ch>:VOLTage<Auxpt>[:DC]:RANGe[:UPPer] <value><units>

(Read-Write) Sets or gets the DC voltage range of selected channel.
Parameters |
<ch> | Any existing channel number. If unspecified, value is set to 1.
<Auxpt> | AUX port (1 or 2)
<value> | 1 to 10
<units> | Volts (V)
Examples | SENS:VOLT:RANG 8 sense:voltage:dc:range:upper 1
Query Syntax | SENSe<ch>:VOLTage<Auxpt>[:DC]:RANGe[:UPPer]?
Return Type | Numeric
Default | 10

Last modified:

6-Jan-2016

New topic


SCPI Example Programs

Setup Measurements | Environment
Create an S-parameter Measurement | VBScript
Channels, Windows, and Measurements using GPIB | Visual Basic
Setup Sweep Parameters | Visual Basic
Triggering the VNA | Visual Basic
Calibrations See Calibrating the VNA Using SCPI |
Guided ECal | Visual Basic, VBScript
Guided Mechanical Calibration | Visual Basic, VBScript
Response Cal | Visual Basic
Miscellaneous |
Getting and Putting Data | Visual Basic
Upload and Download a Segment List | Visual Basic, VBScript

Last modified:

27-Nov-2014

First release


Learning about GPIB

The following topics can help you learn more about controlling the VNA using SCPI and the GPIB.

  • COM versus SCPI

  • GPIB Fundamentals

  • The Rules and Syntax of SCPI Commands

  • Configure for SCPI / SICL over GPIB

  • Configure for VISA / SICL over LAN

  • Calibrating the VNA Using SCPI

  • Getting Data from the VNA using SCPI

  • The VNA as a USB Device

  • Remote Control of SCPI USB Devices Connected to a VNA

  • Reading the VNA Status Registers

  • Referring to Traces, Measurements, Channels, and Windows Using SCPI

  • Synchronizing the VNA and Controller

  • Shut Down the VNA Remotely


Avg BW Com Finder

Avg BW Settings: Main | Smoothing | Delay Aperture

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Averaging | ON |  | SENS:AVER[:STAT]
 | OFF |  | SENS:AVER[:STAT]
Averaging Restart |  |  | SENS:AVER:CLE
IF Bandwidth |  |  | SENS:BAND | BWID[:RES]
LF Auto BW | ON |  | SENS:BAND | BWID:TRAC
 | OFF |  | SENS:BAND | BWID:TRAC
Smoothing
Smoothing | ON | CALC:MEAS:SMO[:STAT]
 | OFF | CALC:MEAS:SMO[:STAT]
Smooth Percent |  | CALC:MEAS:SMO:APER
Smooth Points |  | CALC:MEAS:SMO:POIN
Delay Aperture
Aperture Percent | CALC:MEAS:GDEL:PERC
Aperture Points | CALC:MEAS:GDEL:POIN
Aperture Freq | CALC:MEAS:GDEL:FREQ

Last modified:

6-Jan-2016

New topic


Channel Com Finder

Channel Settings: Channel 1-8 | Channel Setup

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Channel 1-8
Channel 1 to 8 | ON |  | None
 | OFF |  | None
Channel 2 | ON |  | None
 | OFF |  | None
Channel 3 | ON |  | None
 | OFF |  | None
Channel 4 | ON |  | None
 | OFF |  | None
Channel 5 | ON |  | None
 | OFF |  | None
Channel 6 | ON |  | None
 | OFF |  | None
Channel 7 | ON |  | None
 | OFF |  | None
Channel 8 | ON |  | None
 | OFF |  | None
Channel Setup
Select | ChN |  | None
Meas Class | Standard |  | SENS:CLAS:NAME?
 | SMC |  | SENS:CLAS:NAME?
 | Measurement Class... | Standard Scalar Mixer/Converter | SENS:CLAS:NAME?
Add Channel | New Trace + Channel |  | None
 | New Trace + Channel + Window |  | None
Copy Channel | Copy to Active Window |  | None
 | Copy to New Window |  | None
 | Copy Channel... | Copy channel - To Channel Stimulus Channel State | SYST:MACR:COPY:CHAN[:TO] None None
Delete Channel | ChN |  | SYST:CHAN:DEL

Last modified:

6-Jan-2016

New topic


CFCalibration Topic

Unguided | SmartCal(Guided) | ECAL | Guided Power Cal | Cal All | Save-Recall | Cal Sets | Cal Types | Prefer's |Correction | Port Ext | Fixturing | Delta Match | Cal Kits | Standards | Multiple Sensors | Source Pwr Cal | Power Sensors | Receiver Cal | Cal Data | CalPod | Custom Cal Window

Description | SCPI See Calibrating the VNA Using SCPI | COM
Perform an Unguided Calibration
Launch Cal Wizard | SYST:CORR:WIZard |
Set Cal Type | SENS:CORR:COLL:METHod |
Select a Cal Kit | SENS:CORR:COLLect:CKIT |
Get a Handle to the Active Cal Kit | N/A |
Simultaneous 2-Port Calibration | SENS:CORR:TSTandards |
Acquisition Direction | SENS:CORR:SFORward |
Measure a Standard | SENS:CORR:COLLect |
Calculate Errors | SENS:CORR:COLL:SAVE |
Do Isolation | SENS:CORR:COLLect |
Perform and apply Response (Normalization) cal | SENS:CORR:COLL:METHod |

Perform a Guided Cal
Initiate a Guided Cal | SENS:CORR:COLL:GUID:INIT
List valid Connector Types for a Port | SENS:CORR:COLL:GUID:CONN:CAT?
List valid Cal Kits for a Connector type. | SENSe:CORR:COLL:GUID:CKIT:CAT?
Select a Connector Type | SENS:CORR:COLL:GUID:CONN:PORT
Select a Cal Kit | SENS:CORR:COLL:GUID:CKIT:PORT
Set cal method for each port pair. | SENS:CORR:COLL:GUID:PATH:CMET
Set Thru Method for each port pair. | SENS:CORR:COLL:GUID:PATH:TMET
Set Thru Port Pairs | SENS:CORR:COLL:GUID:THRU:PORT
Return Number of Steps in a Cal | SENS:CORR:COLL:GUID:STEPs?
Return a Description of a Cal Step | SENS:CORR:COLL:GUID:DESC?
Measure a Cal Standard in a Guided Cal | SENS:CORR:COLL:GUID:ACQuire
Save Cal | SENS:CORR:COLL:GUID:SAVE
Adapter settings for Unknown Thru or Adapter Removal
Sets use of a THRU adapter | SENS:CORR:COLL:GUID:ADAP:CREate
Set adapter delay | SENS:CORR:COLL:GUID:ADAP:DELay
Set adapter description | SENS:CORR:COLL:GUID:ADAP:DESC
Set port pairs for adapter | SENS:CORR:COLL:GUID:ADAP:PATH
Clear the settings | SENS:CORR:COLL:GUID:ADAP:COUNt:ZERO
Return number of adapters | SENS:CORR:COLL:GUID:ADAP:COUNt?

Optional Guided Cal commands
Auto-Orient ECal | SENS:CORR:PREF:ECAL:ORI
Manual orient ECAL | SENS:CORR:PREF:ECAL:PMAP
Read orientation | SENS:CORR:CKIT:ECAL:ORI?
Calculate Error Terms from a Guided Cal | SENS:CORR:COLL:GUID:SAVE
Save Cal to an existing Cal Set GUID | SENS:CORR:COLL:GUID:SAVE:CSET
Load Eterms during a cal | SENS:CORR:COLL:GUID:ETERms:LOAD
Perform Isolation | SENS:CORR:COLL:GUID:ISOL:PATHs
Increment Avg for Isolation | SENS:CORR:COLL:GUID:ISOL:AVER:INCR
Abort Guided cal | SENS:CORR:COLL:GUID:ABORt

Perform Enhanced Response Cal
Set guided Cal method | SENS:CORR:COLL:GUID:PATH:CMET
Set guided Thru method | SENS:CORR:COLL:GUID:PATH:TMET

Perform Sliding Load Acquisition
Set preference to not prompt | SENS:CORR:COLL:GUID:PREF:SLID
Read iteration step | SENS:CORR:COLL:GUID:ITER:COUNt?
Read minimum iterations | SENS:CORR:COLL:GUID:ITER:MIN?
Reset iterations | SENS:CORR:COLL:GUID:ITER:RESet

Perform an ECAL
Specify Module and Characterization | SENS:CORR:COLL:ACQ
Do ECAL 1-Port | SENS:CORR:COLL:CKIT:PORT
Do ECAL 2-Port | SENS:CORR:COLL:CKIT:PORT
Get ECAL Module Info | SENS:CORR:COLL:CKIT:INF? SENS:CORR:CKIT:ECAL:INF?
Get list of ECal Modules attached to VNA | SENS:CORR:CKIT:ECAL:LIST?
Get list of characterizations in ECal module | SENS:CORR:CKIT:ECAL:CLISt?
Perform Module Orientation during calibration | SENS:CORR:PREF:ECAL:ORI
Maps ECAL Module to VNA Ports | SENS:CORR:PREF:ECAL:PMAP
Reads ECal orientation | SENS:CORR:CKIT:ECAL:ORI?
Perform ECal Isolation | SENS:CORR:COLL:ISOL:ECAL
Increment Avg for ECal Isolation | SENS:CORR:COLL:ISOL:AVER:INCR

Perform ECal User Characterizations
Perform User ECal Characterization | All SCPI commands
Manage VNA Disk Memory Characterizations
Delete disk memory characterizations. | SENSe:CORR:CKIT:ECAL:DMEMory:CLEar
Saves a disk memory characterization to an archive file. | SENS:CORR:CKIT:ECAL:EXPort
Imports the ECal characterization from the specified archive file. | SENSe:CORR:CKIT:ECAL:DMEMory:IMPort

ECal Confidence Check
Confidence Check Parameter | SENS:CORR:CCH:PAR
Confidence Check Acquire | SENS:CORR:CCHeck
Confidence Check Done | SENS:CORR:CCH:DONE
Set/Read ECal State
Sets the state of an ECAL module | CONT:ECAL:MOD:PATH:STATe
Read ECal state data | SENS:CORR:CKIT:ECAL:PATH:DATA?
Read number of ECal states for specified path | CONT:ECAL:MOD:PATH:COUNt? SENS:CORR:CKIT:ECAL:PATH:COUNt?

Calibrate All Channels
Select the channels to be calibrated. | SYST:CAL:ALL:CHAN:SEL
Set the IFBW | SYST:CAL:ALL:IFBW
Set the power level | SYST:CAL:ALL:PORT:SOUR:POW
Set the power offset | SYST:CAL:ALL:PORT:SOUR:POW:OFFS
Set the receiver atten | SYST:CAL:ALL:PORT:SOUR:POW:REC:ATT
Set the source atten | SYST:CAL:ALL:PORT:SOUR:POW:ATT
Set the User Calset Prefix | SYST:CAL:ALL:CSET:PREFix
Set Path Configuration | SYST:CAL:ALL:PATH:CONF:ELEM
Read unique Cal properties | SYST:CAL:ALL:MCL:PROP:NAME:CAT?
Read unique property values | SYST:CAL:ALL:MCL:PROP:VAL:CAT?
Set property name/value | SYST:CAL:ALL:MCL:PROP:VAL
Read Cal channel | SYST:CAL:ALL:GUID:CHAN?
Get GuidedCal handle | N/A
For each channel, sets the ports to be calibrated. | SYST:CAL:ALL:CHAN:PORT
Returns a final list of ports to be calibrated. | SYST:CAL:ALL:GUID:PORT?
Read generated Cal Sets | SYST:CAL:ALL:CSET:CATalog?

Recall / Save / Apply a Calibration or Error Term
Recall a Calibration | SENS:CORR:CSET
Apply a Calibration to a measurement | SENS:CORR:CSET
Save a Calibration | SENS:CORR:CSET:SAVE
Read/ Write Cal Set data | SENS:CORR:CSET:DATA
Apply an Error Term after Uploading | SENS:CORR:COLLect:APPLy
Cal Sets
Create a Cal Set | SENS:CORR:CSET:CREate
Delete a Cal Set | SENS:CORR:CSET:DEL
List Cal Sets | SENS:CORR:CSET:CAT?
List Cal Sets in VNA | None
Get Cal Set Information | None
List Cal Set Error Terms | SENS:CORR:CSET:ETERM:CAT?
Return if a Cal Set exists | CSET:EXISts?
Select a Cal Set by GUID | SENS:CORR:CSET:GUID
Apply a Cal Set to a channel | SENS:CORR:CSET:ACTivate
Copy a Cal Set | SENSe:CORR:CSET:COPY
Save a Cal Set | SENS:CORR:CSET:SAVE
Save Cal Sets | None
Automatically save to User Cal Set | SENS:CORR:PREF:CSET:SAVE
Change the Description of a Cal Set | SENS:CORR:CSET:DESC
Change the Name of a Cal Set | SENS:CORR:CSET:NAME
Recall a Cal File | SENS:CORR:CSET
Save 'in-memory' Cal Set to disk. | SENS:CORR:CSET:FLATten
Create Cal Set with De-embeded fixture removed. | CSET:FIXTure:DEEMbed
Create Cal Set with Matching Network included. | CSET:FIXTure:EMBed
Adds stimulus data to a specific buffer. | None
Returns the stimulus values over which the specific error term was acquired. | None
Returns FOM stimulus values from a Calset. | SENS:CORR:CSET:STIM?
Cal Set Items
Set or get name-value pair from cal set | None
Remove name-value pair from cal set | None
Enumerate name-value pair items in the cal set. | None

Apply Cal Types
Catalog ALL Cal Types for the VNA | SENS:CORR:TYPE:CAT?
Catalog Cal Types in the Cal Set | SENS:CORR:CSET:TYPE:CAT?
Is a specific Cal Type contained in the Cal Set? | None
Set and return the measurement Cal Type | CALC:CORR:TYPE ?
Set port to measure QSOLT reflection standards. | None

Correction Settings
Turn Correction ON|OFF for a channel | SENS:CORR
Turn Correction ON|OFF for a measurement | CALC:CORR
Interpolation ON|OFF | SENS:CORR:INT
Returns the error correction state for the measurement | CALC:CORR:INDicator?

Preferences
Set default Cal Set Save behavior | SENS:CORR:PREF:CSET:SAVE
Sets behavior for simulated cal | SENS:CORR:PREF:SIMCal
External or internal trigger during cal | SENS:CORR:PREF:TRIG:FREE
Set ECal Auto-orient | SENS:CORR:PREF:ECAL:ORI
Set ECal Port Map | SENS:CORR:PREF:ECAL:PMAP
Set default Cal Type | None

Port Extensions
Extensions ON|OFF | SENS:CORR:EXT
Port 1 Extensions Value | SENS:CORR:EXT:PORT
Port 2 Extensions Value | SENS:CORR:EXT:PORT
Set Freq 1|2 | SENS:CORR:EXT:PORT:FREQ
Set Loss 1|2 | SENS:CORR:EXT:PORT:LOSS
Use 1|2 | SENS:CORR:EXT:PORT:INCL
Set Loss at DC | SENS:CORR:EXT:PORT:LDC
Relative Velocity | SENS:CORR:RVEL:COAX
Port Ext in distance | SENS:CORR:EXT:PORT:DIST
Set distance units | SENS:CORR:EXT:PORT:UNIT
Set Media per port | SENS:CORR:EXT:PORT:MEDium
Set waveguide cutoff freq per port | SENS:CORR:EXT:PORT:WGCutoff
Set Velocity Factor per port | SENS:CORR:EXT:PORT:VELF
Couple to system Velocity Factor | SENS:CORR:EXT:PORT:SYSV
Couple to system Media type | SENS:CORR:EXT:PORT:SYSM

Auto Port Extensions
Measure OPEN or SHORT for Auto Port Ext. | SENS:CORR:EXT:AUTO:MEASure
Sets the frequencies used for Auto Port Ext. calculation. | SENS:CORR:EXT:AUTO:CONFig
Include loss correction in Auto Port Ext.? | SENS:CORR:EXT:AUTO:LOSS
Include DC Offset in Auto Port Ext.? | SENS:CORR:EXT:AUTO:DCOF
Enable specified port for Auto Port Ext.. | SENS:CORR:EXT:AUTO:PORT<n>
Clears old port extension delay and loss data. | SENS:CORR:EXT:AUTO:RESet
Set user span start frequency for Auto Port Ext. | SENS:CORR:EXT:AUTO:STARt
Set user span stop frequency for Auto Port Ext. | SENS:CORR:EXT:AUTO:STOP

Fixturing Commands
Turn fixturing ON and OFF | CALC:FSIM:STAT
2-Port Fixturing
Port matching ON and OFF | CALC:FSIM:SEND:PMC:STAT
Reverse ports | CALC:FSIM:SEND:DEEM:PORT<n>:SNP:REV
Sets Port Matching circuit model. | CALC:FSIM:SEND:PMC:PORT:TYPE
Sets Port Matching 'S2P' file name. | CALC:FSIM:SEND:PMC:PORT:USER:FIL
Sets Capacitance 'C' value. | CALC:FSIM:SEND:PMC:PORT:PAR:C
Sets Conductance 'G' value. | CALC:FSIM:SEND:PMC:PORT:PAR:G
Sets Inductance 'L' value. | CALC:FSIM:SEND:PMC:PORT:PAR:L
Sets Resistance 'R' value. | CALC:FSIM:SEND:PMC:PORT:PAR:R
De-embed ON and OFF | CALC:FSIM:SEND:DEEM:PORT:STAT
Sets De-embedding circuit model. | CALC:FSIM:SEND:DEEM:PORT
Sets De-embedding 'S2P' file name. | CALC:FSIM:SEND:DEEM:PORT:USER:FIL
Port Impedance ON and OFF | CALC:FSIM:SEND:ZCON:STAT
Port Z Real | CALC:FSIM:SEND:ZCON:PORT:REAL
Port Z Imag | CALC:FSIM:SEND:ZCON:PORT:IMAG
Port Z Real and Imag | CALC:FSIM:SEND:ZCON:PORT:Z0
4-Port Network Embed/De-embed commands
Specifies the VNA / DUT topology | CALC:FSIM:EMB:TYPE
Specifies the 4-port touchstone file | CALC:FSIM:EMB:NETW:FIL
Embed|De-embed? | CALC:FSIM:EMB:NETW:TYPE
Specify VNA port connections | CALC:FSIM:EMB:TOP:A:PORT CALC:FSIM:EMB:TOP:B:PORT CALC:FSIM:EMB:TOP:C:PORT
4-port remap | CALC:FSIM:EMB:NETW<n>:PMAP
Turn ON or OFF | CALC:FSIM:EMB:STAT
Differential Port Arbitrary Impedance
Sets the impedance value | CALC:FSIM:BAL:DZC:BPOR:Z0
Sets real part of impedance | CALC:FSIM:BAL:DZC:BPOR:REAL
Sets imaginary part of impedance | CALC:FSIM:BAL:DZC:BPOR:IMAG
Turn ON or OFF | CALC:FSIM:BAL:DZC:STAT
Common Mode Port Arbitrary Impedance
Sets the impedance value | CALC:FSIM:BAL:CZC:BPOR:Z0
Sets real part of impedance | CALC:FSIM:BAL:CZC:BPOR:REAL
Sets imaginary part of impedance | CALC:FSIM:BAL:CZC:BPOR:IMAG
Turn ON or OFF | CALC:FSIM:BAL:CZC:STAT
Differential Port Matching
Sets type of circuit to embed. | CALC:FSIM:BAL:DMC:BPOR
Specifies the 2-port touchstone file | CALC:FSIM:BAL:DMC:BPOR:USER:FIL
Sets Capacitance value | CALC:FSIM:BAL:DMC:BPOR:PAR:C
Sets Conductance value | CALC:FSIM:BAL:DMC:BPOR:PAR:G
Sets Inductance value | CALC:FSIM:BAL:DMC:BPOR:PAR:L
Sets Resistance value | CALC:FSIM:BAL:DMC:BPOR:PAR:R
Turns ON/OFF | CALC:FSIM:BAL:DMC:STAT
Power Compensation
Compensate source power | CALC:FSIM:SEND:POW:PORT:COMP
Remote ONLY
Create Cal Set with De-embeded fixture removed. | CSET:FIXTure:DEEMbed
Create Cal Set with Matching network included. | CSET:FIXTure:EMBed

Global Delta Match Cal
Initiate Cal | SENS:CORR:COLL:GUID:DMAT
Read ports that require Cal | SENS:CORR:COLL:GUID:DMAT:APPLy:PORT?
Apply a Cal | SENS:CORR:COLL:GUID:DMAT:APPLy

Manage and Modify Cal Kits
Set a Cal Kit Active | SENS:CORR:COLL:CKIT
Clear all Cal Kits from VNA | SENS:CORR:CKIT:CLE
Get a Handle to the Active Cal Kit |
Save All Cal Kits after Modifying |
Load collection of Kits | SENS:CORR:CKIT:LOAD
Load (Recall) All Cal Kits |
Import a specified kit. | SENS:CORR:CKIT:IMPort
Restore Cal Kit Default | SENS:CORR:COLL:CKIT:RESet
Restore ALL Cal Kits Default | SENS:CORR:CKIT:INITialize
Build a Hybrid Cal Kit |
Set the Name of a Cal Kit | SENS:CORR:COLL:CKIT:NAME
Set a description of a Cal Kit | SENS:CORR:COLL:CKIT:DESC
Get the amount of installed kits | SENS:CORR:CKIT:COUNt?
Set the Port Label of a Cal Kit |
Saves a Cal Kit to a file. | SENS:CORR:CKIT:EXP
Modify TRL Cal Kit
Set reference plane | SENS:CORR:COLL:CKIT:TRL:RPLane
Set impedance standard | SENS:CORR:COLL:CKIT:TRL:IMPedance
Set LRL auto-characterization | SENS:CORR:COLL:CKIT:TRL:LRLChar

Modify Cal Standards
Select a Cal Standard | SENS:CORR:COLL:CKIT:STAN
Delete a standard | SENS:CORR:COLL:CKIT:STAN:REM
Change description of a standard | SENS:CORR:COLL:CKIT:STAN:SDES
Assign a Class to a Standard | SENS:CORR:COLL:CKIT:ORD1
Set Standard Type | SENS:CORR:COLL:CKIT:STAN:TYPE
Add connector family name | SENS:CORR:COLL:CKIT:CONN:ADD
Delete connector family name | SENS:CORR:COLL:CKIT:CONN:DEL
List connector family names used in a Cal Kit | SENS:CORR:COLL:CKIT:CONN:CAT?
Replace connector family name. | SENS:CORR:COLL:CKIT:CONN:FNAM
Assign connector family name to a standard | SENS:CORR:COLL:CKIT:CONN:SNAMe
Set Delay | SENS:CORR:COLL:CKIT:STAN:DEL
Set Loss | SENS:CORR:COLL:CKIT:STAN:LOSS
Set Impedance | SENS:CORR:COLL:CKIT:STAN:IMP
Set Max Frequency | SENS:CORR:COLL:CKIT:STAN:FMAX
Set Min Frequency | SENS:CORR:COLL:CKIT:STAN:FMIN
Set Label | SENS:CORR:COLL:CKIT:STAN:LAB
Set Medium (coax | waveguide) | SENS:CORR:COLL:CKIT:STAN:CHAR
Set Capacitance (C0 to C3) | SENS:CORR:COLL:CKIT:STAN:C0
Set Inductance (L0 to L3) | SENS:CORR:COLL:CKIT:STAN:L0
Set Arbitrary Impedance (TZReal, TZImag) | SENS:CORR:COLL:CKIT:STAN:TZReal
Modify TRL Cal Kit
Set reference plane | SENS:CORR:COLL:CKIT:TRL:RPLane
Set impedance standard | SENS:CORR:COLL:CKIT:TRL:IMPedance

Guided Power Cal Use standard Source Power commands to make advanced settings. Use Power Sensor commands to configure the power sensor.
Perform power cal | SENS:CORR:COLL:GUID:PSENsor
Power sensor connector type | SENS:CORR:COLL:GUID:PSEN:CONN
Cal Kit for power cal | SENS:CORR:COLL:GUID:PSEN:CKIT
Power Level for cal | SENS:CORR:COLL:GUID:PSEN:POWer:LEVel
Perform match-correction | SENS:CORR:METHods:MATCh

Multiple Power Sensors See commands to configure a Power Meter as Receiver (PMAR)
Enable multiple sensors | SENS:CORR:COLL:GUID:PSEN:MULT
Add sensors | SENS:CORR:COLL:GUID:PSEN:MULT:ADD
Assign power sensor name | SENS:CORR:COLL:GUID:PSEN:MULT:NAME
Remove sensors | SENS:CORR:COLL:GUID:PSEN:MULT:REM
Read the number of configured sensors | SENS:CORR:COLL:GUID:PSEN:MULT:COUNt?
Set start freq | SENS:CORR:COLL:GUID:PSEN:MULT:FREQ:STAR
Set stop freq | SENS:CORR:COLL:GUID:PSEN:MULT:FREQ:STOP
Set connector type | SENS:CORR:COLL:GUID:PSEN:MULT:CONN
Set Cal Kit | SENS:CORR:COLL:GUID:PSEN:MULT:CKIT

Source Power Calibration
Set source power cal method | SOUR:POW:CORR:COLL:ACQ
Turn correction ON|OFF | SOUR:POW:CORR
Applies correction values after completing a source power cal acquisition sweep. Optionally do reference receiver cal. | SOUR:POW:CORR:COLL:SAVE
Returns the currently-selected power sensor channel (A or B) for use at a specific frequency. | N/A
Set power level | SOUR:POW:CORR:LEV
Set power offset | SOUR:POW:CORR:OFFS
Set settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL
Set max readings for settling | SOUR:POW:CORR:COLL:AVER:COUNt
Set accuracy tolerance | SOUR:POW:CORR:COLL:ITER:NTOL
Set max readings for accuracy | SOUR:POW:CORR:COLL:ITER:COUNt
Turn ON|OFF display of readings | SOUR:POW:CORR:COLL:DISP
Acquire receiver-only readings | SOUR:POW:CORR:COLL:ACQ:REC
Initiates a source power cal acquisition. | SOUR:POW:CORR:COLL:ACQ
Aborts a source power cal acquisition sweep that is currently in progress. | SOUR:POW:CORR:COLL:ABOR
Launches the Power Meter Settings dialog on the VNA. | None
Check test port power | None
Calibrate the source at multiple power levels. | None

Power Meter/Sensor settings
Specifies the type of power sensor to be used | SYST:COMM:PSEN
Specifies the location of the power sensor to be used. | SYST:COMM:PSEN
Returns the ID string of connected USB power meters / sensors. | SYST:COMM:USB:PMET:CAT?
Pwr meter Max Readings for settling | SOUR:POW:CORR:COLL:AVER:COUNt
Pwr meter settling tolerance | SOUR:POW:CORR:COLL:AVER:NTOL
Minimum Frequency | SOUR:POW:CORR:COLL:<>SEN
Maximum Frequency | SOUR:POW:CORR:COLL:<>SEN
Power meter channel |
Set table type | SOUR:POW:CORR:COLL:TABL <>SEN
Read/Write cal data | SOUR:POW:CORR:DATA
Receiver Cal
Set offset from test port power | SENS:CORR:RPOWer:OFFSet[:AMPLitude]
Set cal method to receiver cal | SENS:CORR:COLL:METH RPOWer
Take measurement | SENS:CORR:COLL[:ACQ] POWer
Turn receiver cal ON | OFF | SENS:CORR[:STATe] ON|OFF
Do interpolation | SENS:CORR:INT[:STATe] ON|OFF

Custom Cal Window
Turn ON | OFF Custom Cal window. | SENS:CORR:COLL:DISP:WIND
Show NO Custom Cal windows. | SENS:CORR:COLL:DISP:WIND:AOFF
Specify channel to sweep before Cal acquisition. | SENS:CORR:COLL:SWE:CHAN
Sweep NO channel before Cal acquisition. | SENS:CORR:COLL:SWE:CHAN:AOFF
Preview sweep before remote Cal acquisition. | SENS:CORR:COLL:GUID:PACQuire

Retrieve and Put Calibration Data
Retrieve Cal Data from the VNA | SENS:CORR:CSET:DATA
Put Cal Data in the VNA | SENS:CORR:CSET:DATA

Last Modified:

12-Feb-2015

Initial release


Display Com Finder

Display Settings: Window 1-8 | Window Setup | Display Settings

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Window 1-8
Window 1 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 2 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 3 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 4 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 5 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 6 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 7 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window 8 | ON |  | DISP:WIND[:STAT]
 | OFF |  | DISP:WIND[:STAT]
Window Setup
Select |  |  | DISP:WIND:TRAC:SEL
Window Title... |  | Enable Title | DISP:WIND:TITL[:STAT] DISP:WIND:TITL:DATA
Add Window | New Window |  | DISP:WIND[:STAT]
 | New Trace + window |  | DISP:WIND:TRAC[:STAT]
 | New Trace + Channel + Window |  | None
Delete Window |  |  | DISP:WIND[:STAT]
Tile |  |  | DISP:ARR or DISP[:TILE]
Window Max | ON |  | DISP:WIND:SIZ
 | OFF |  | DISP:WIND:SIZ
Sheet Setup
Select... | Sheet # | None
Sheet Title... |  | DISP:SHE:TIT:DATA
Add Sheet | New Sheet New Trace + Sheet New Trace + Channel + Sheet | DISP:SHE:STAT DISP:WIND:FEED DISP:SHE:CAT
Delete Sheet | Sheet # | DISP:SHE:STAT DISP:WIND:FEED DISP:SHE:CAT
Sheet Layout | 1 Sheet 1 Trace per Sheet 1 Channel per Sheet 1 Window per sheet | DISP:ARR SYST:ACT:SHE SYST:SHE:CAT
Display Settings
Customize Display... |  | Labels Trace Status Y-axis Labels X-axis Labels Markers Marker Readouts Large Readout Readout Per Trace Symbol - Triangle, Flag and Line Decimal Places - Stimulus and Response Readout Position - X and Y Marker Colors... Grid Grid Lines - Solid | Dotted Y-axis Divisions - 2 to 30 Show Table - None, Marker, Limit, Ripple and Segment Toolbars Softkey Hardkey Port Extensions Transform Marker Cal Set Viewer Main Title Active Entry Status Bar - 2 Bars - Clock Tools Tool Active Entry Softkey Toolbar | - DISP:WIND:ANN[:TRAC][:STAT] DISP:WIND:ANN: Y[:STAT] None - DISP:WIND:ANN:MARK[:STAT] DISP:WIND:ANN:MARK:SIZE | SIZ DISP:WIND:ANN:MARK:NUMB DISP:WIN:ANN:MARK:SYMB DISP:WIND:ANN:MARK:RES:RESP DISP:WIND:ANN:MARK:RES:STIM DISP:WIND:ANN:MARK:XPOS DISP:WIND:ANN:MARK:YPOS [Refer to Display Colors...] - DISP:WIND:TRAC:GRAT:GRID:LTYPE DISP:WIND:TRAC:Y[:SCAL]:PDIV DISP:WIND:TABL - None None None None DISP:TOOL:MARK[:STAT] DISP:TOOL:CSET[:STAT] None DISP:TOOL:ENTR[:STATe] DISP:ANN[:STAT] None SYST:CLOC[:STAT] - None None None
Display Colors... |  | Pen Background Active Background Grid Active Labels, Grid frame Inactive Window Labels Failed Trace N Trace: Data and Limits N Trace: Memory N Trace: Markers N Trace: Memory Markers Change Color... Reset Color Color Theme Save Theme... Recall Theme... Reset Theme... | - DISP:COL:IBACK | IBAC DISP:COL:ABAC DISP:COL:GRAT2 DISP:COL:GRAT1 DISP:COL:ILAB DISP:COL:LIM1 DISP:COL:TRAC:DATA DISP:COL:TRAC:MEM DISP:COL:TRAC:MARK DISP:COL:TRAC:MMAR None None - DISP:COL:STOR None DISP:COL:RES
Color Theme | Default |  | None
 | Light Gray |  | None
 | Dark Gray |  | None
 | Blue |  | None
Touchscreen | ON |  | None
 | OFF |  | None
Calibrate Touchscreen... |  |  | None
Display Update | ON |  | DISP:UPD[:STAT]
 | OFF |  | DISP:UPD[:STAT]

Last modified:

6-Jan-2016

New topic


Format Com Finder

Format Settings : Format1 | Format 2

SoftTab & Softkey | Command in Dialog Box | SCPI
Format 1
Log Mag |  | CALC:MEAS:FORM
Lin Mag |  | CALC:MEAS:FORM
Phase |  | CALC:MEAS:FORM
Delay |  | CALC:MEAS:FORM
Smith |  | CALC:MEAS:FORM
Polar |  | CALC:MEAS:FORM
SWR |  | CALC:MEAS:FORM
Group Delay Aperture... | Points Percent of Span Frequency | CALC:MEAS:GDEL:POIN CALC:MEAS:GDEL:PERC CALC:MEAS:GDEL:FREQ
Format 2
Real | CALC:MEAS:FORM
Imaginary | CALC:MEAS:FORM
Unwrapped Phase | CALC:MEAS:FORM
Positive Phase | CALC:MEAS:FORM
Inverted Smith | CALC:MEAS:FORM

Last modified:

6-Jan-2016

New topic


Frequency Com Finder

Frequency Settings : Main

SoftTab & Softkey | Command in Dialog Box | SCPI
Main
Start |  | SENS:FREQ:STAR SOUR:POW:STAR
Stop |  | SENS:FREQ:STOP SOUR:POW:STOP
Center |  | SENS:FREQ:CENT SOUR:POW:CENT
Span |  | SENS:FREQ:SPAN SOUR:POW:SPAN
Step |  | SENS:SWE:STEP
CW |  | SENS:FREQ:CW
Frequency Offset... | Frequency Offset (ON/OFF) Mode - Coupled and Un-coupled Sweep Type Settings - Start and Stop Annotation - Primary, Source and Receivers X-Axis Point Spacing | SENS:FOM[:STAT] SENS:FOM:RANG:COUP SENS:FOM:RANG:SEGM SENS:FOM:RANG:FREQ:STAR SENS:FOM:RANG:FREQ:STOP SENS:FOM:RNUM?

Last modified:

6-Jan-2016

New topic


Marker Com Finder

Marker Settings : Marker 1-7 | Marker 8-15 | Marker Setup | Marker -> Functions

SoftTab & Softkey | Command in Dialog Box | SCPI
Marker 1-7
Marker 1 |  | CALC:MEAS:MARK[:STAT]
Marker 2 |  | CALC:MEAS:MARK[:STAT]
Marker 3 |  | CALC:MEAS:MARK[:STAT]
Marker 4 |  | CALC:MEAS:MARK[:STAT]
Marker 5 |  | CALC:MEAS:MARK[:STAT]
Marker 6 |  | CALC:MEAS:MARK[:STAT]
Marker 7 |  | CALC:MEAS:MARK[:STAT]
Reference |  | CALC:MEAS:MARK:REF[:STAT]
Marker 8-15
Marker 8 | CALC:MEAS:MARK[:STAT]
Marker 9 | CALC:MEAS:MARK[:STAT]
Marker 10 | CALC:MEAS:MARK[:STAT]
Marker 11 | CALC:MEAS:MARK[:STAT]
Marker 12 | CALC:MEAS:MARK[:STAT]
Marker 13 | CALC:MEAS:MARK[:STAT]
Marker 14 | CALC:MEAS:MARK[:STAT]
Marker 15 | CALC:MEAS:MARK[:STAT]
Marker Setup
Delta | ON |  | CALC:MEAS:MARK:DELT
 | OFF |  | CALC:MEAS:MARK:DELT
Discrete | ON |  | CALC:MEAS:MARK:DISC
 | OFF |  | CALC:MEAS:MARK:DISC
Type | Normal |  | CALC:MEAS:MARK:TYPE
 | Fixed |  | CALC:MEAS:MARK:TYPE
Format | Trace default |  | CALC:MEAS:MARK:FORM
 | Log / Phase |  | CALC:MEAS:MARK:FORM
 | Lin / Phase |  | CALC:MEAS:MARK:FORM
 | Re / Im |  | CALC:MEAS:MARK:FORM
 | R+jX |  | CALC:MEAS:MARK:FORM
 | G+jB |  | CALC:MEAS:MARK:FORM
 | Log Magnitude |  | CALC:MEAS:MARK:FORM
 | Linear Magnitude |  | CALC:MEAS:MARK:FORM
 | Phase |  | CALC:MEAS:MARK:FORM
 | SWR |  | CALC:MEAS:MARK:FORM
 | Delay |  | CALC:MEAS:MARK:FORM
 | Real |  | CALC:MEAS:MARK:FORM
 | Imaginary |  | CALC:MEAS:MARK:FORM
Coupled | Off |  | CALC:MEAS:MARK:COUP
 | Channel |  | CALC:MEAS:MARK:COUP
 | All |  | CALC:MEAS:MARK:COUP
Marker Display... |  | Labels Trace Status Y-axis Labels X-axis Labels Markers Marker Readouts Large Readout Readout Per Trace Symbol - Triangle, Flag and Line Decimal Places - Stimulus and Response Readout Position - X and Y Marker Colors... Grid Grid Lines - Solid | Dotted Y-axis Divisions - 2 to 30 Show Table - None, Marker, Limit, Ripple and Segment Toolbars Show Toolbar Softkey Hardkey Port Extensions Transform Marker Cal Set Viewer Other Bars Main Title Active Entry Status Bar - 2 Bars - Clock Tools Tool Active Entry Softkey Toolbar | - DISP:WIND:ANN[:TRAC][:STAT] DISP:WIND:ANN: Y[:STAT] None - DISP:WIND:ANN:MARK[:STAT] DISP:WIND:ANN:MARK:SIZE | SIZ DISP:WIND:ANN:MARK:NUMB DISP:WIN:ANN:MARK:SYMB DISP:WIND:ANN:MARK:RES:RESP DISP:WIND:ANN:MARK:RES:STIM DISP:WIND:ANN:MARK:XPOS DISP:WIND:ANN:MARK:YPOS Refer to Display Colors... - DISP:WIND:TRAC:GRAT:GRID:LTYPE DISP:WIND:TRAC:Y[:SCAL]:PDIV DISP:WIND:TABL - - None None None None DISP:TOOL:MARK[:STAT] DISP:TOOL:CSET[:STAT] - None DISP:TOOL:ENTR[:STATe] DISP:ANN[:STAT] None SYST:CLOC[:STAT] - None None None
Marker Table | ON |  | DISP:WIND:TABL
 | OFF |  | DISP:WIND:TABL
All Off |  |  | CALC:MEAS:MARK:AOFF
Marker -> Functions
Marker -> Start | CALC:MARK:SET
Marker -> Stop | CALC:MARK:SET
Marker -> Center | CALC:MARK:SET
Marker -> Span | CALC:MARK:SET
Marker -> Ref Level | CALC:MARK:SET
Marker -> Delay | CALC:MARK:SET
Marker -> CW Freq | CALC:MARK:SET

Last modified:

6-Jan-2016

New topic


Math Com Finder

Math Settings: Main | Analysis | Time Domain | Time Gating

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Data -> Memory |  |  | CALC:MATH:MEM
Normalize |  |  | None
Data Math | Off |  | CALC:MEAS:MATH:FUNC
 | Data / Memory |  | CALC:MEAS:MATH:FUNC
 | Data * Memory |  | CALC:MEAS:MATH:FUNC
 | Data - Memory |  | CALC:MEAS:MATH:FUNC
 | Data + Memory |  | CALC:MEAS:MATH:FUNC
Display | Data Trace |  | :DISP:WIND:TRAC[:STAT]
 | Memory Trace |  | DISP:WIND:TRAC:MEM[:STAT]
 | Data and Memory |  | Both of above
8510 Mode | ON |  | None
 | OFF |  | None
Analysis
Conversions | Off |  | CALC:MEAS:CONV:FUNC
Equation Editor... | ON |  | CALC:MEAS:EQU[:STAT]
 | OFF |  | CALC:MEAS:EQU[:STAT]
 |  | Equation Enable Equation Function Trace Data Parameter Store Equation Delete Equation Use Short Names Enable Matlab Import... Import Library Remove Library | CALC:EQU:TEXT CALC:MEAS:EQU[:STAT] CALC:EQU:LIBR:FUNC? None None None None None None - CALC:EQU:LIBR:IMP CALC:EQU:LIBR:REM
Statistics... | ON |  | CALC:MEAS:FUNC:STAT[:STAT]
 | OFF |  | CALC:MEAS:FUNC:STAT[:STAT]
 |  | Statistics - Mean, Standard Deviation, Peak to Peak User Range - Full Span, User 1 to 16 Start Stop | CALC:MEAS:FUNC:STAT[:STAT] CALC:MEAS:FUNC:DOM:USER[:RANG] CALC:MEAS:FUNC:DOM:USER:STAR CALC:MEAS:FUNC:DOM:USER:STOP
Limit... |  | Limit Limit Test ON Limit Line ON Sound ON Fail X Pass/Fail Position Y Pass/Fail Position Show Table Load Table Save Table Global Pass/Fail ON Ripple Ripple Test ON Ripple Line ON sound ON Fail Type - Off, Absolute or Margin Segment Show Table Load Table Save Table Bandwidth Bandwidth Test ON Bandwidth Marker ON Sound ON Fail N dB Points Min Bandwidth Max Bandwidth | - CALC:MEAS:LIM[:STAT] CALC:MEAS:LIM:DISP CALC:MEAS:LIM:SOUN[:STAT] DISP:WIND:ANN:LIM:XPOS DISP:WIND:ANN:LIM:YPOS DISP:WIND:TABL MMEM:LOAD:LIM MMEM:STOR:LIM DISP:FSIG - CALC:MEAS:RLIM:STAT CALC:MEAS:RLIM:DISP:LINE:STAT CALC:MEAS:LIM:SOUN[:STAT] CALC:MEAS:RLIM:DISP:TYPE CALC:MEAS:RLIM:DATA DISP:WIND:TABL MMEM:LOAD:RLIM MMEM:STOR:RLIM - CALC:MEAS:BLIM:STAT CALC:BLIM:DISP:MARK:STAT CALC:MEAS:LIM:SOUN[:STAT] CALC:MEAS:BLIM:BWID:THR CALC:MEAS:BLIM:MIN CALC:MEAS:BLIM:MAX
Limit Table | Off |  | DISP:WIND:TABL
 | Limit |  | DISP:WIND:TABL
 | Ripple |  | DISP:WIND:TABL
Time Domain
Transform | ON |  | CALC:MEAS:TRAN:TIME:STAT
 | OFF |  | CALC:MEAS:TRAN:TIME:STAT
Start Time |  |  | CALC:MEAS:TRAN:TIME:STAR
Stop Time |  |  | CALC:MEAS:TRAN:TIME:STOP
Center Time |  |  | CALC:MEAS:TRAN:TIME:CENT
Span Time |  |  | CALC:MEAS:TRAN:TIME:SPAN
TD Mode | Low Pass Impulse |  | CALC:MEAS:TRAN:TIME:STIM
 | Low Pass Step |  | CALC:MEAS:TRAN:TIME:STIM
 | Band Pass |  | CALC:MEAS:TRAN:TIME:TYPE
TD Toolbar | ON |  | None
 | OFF |  | None
Time Domain Setup... |  | Transform On Start Stop Center Span Transform Mode Low Pass Impulse Low Pass Step Band Pass Set Low Pass Frequencies | CALC:MEAS:TRAN:TIME:STAT CALC:MEAS:TRAN:TIME:STAR CALC:MEAS:TRAN:TIME:STOP CALC:MEAS:TRAN:TIME:CENT CALC:MEAS:TRAN:TIME:SPAN - CALC:MEAS:TRAN:TIME:STIM CALC:MEAS:TRAN:TIME:STIM CALC:MEAS:TRAN:TIME:TYPE CALC:MEAS:TRAN:TIME:LPFREQ | LPFREQ
Time Gating
Gating | ON |  | CALC:MEAS:FILT[:GATE]:TIME:STAT
 | OFF |  | CALC:MEAS:FILT[:GATE]:TIME:STAT
Gate Start |  |  | CALC:MEAS:FILT[:GATE]:TIME:STAR
Gate Stop |  |  | CALC:MEAS:FILT[:GATE]:TIME:STOP
Gate Center |  |  | CALC:MEAS:FILT[:GATE]:TIME:CENT
Gate Span |  |  | CALC:MEAS:FILT[:GATE]:TIME:SPAN
Gate Type | Band Pass |  | CALC:MEAS:FILT[:GATE]:TIME[:TYPE]
 | Notch |  | CALC:MEAS:FILT[:GATE]:TIME[:TYPE]
Gate Shape | Maximum |  | CALC:MEAS:FILT[:GATE]:TIME:SHAP
 | Wide |  | CALC:MEAS:FILT[:GATE]:TIME:SHAP
 | Normal |  | CALC:MEAS:FILT[:GATE]:TIME:SHAP
 | Minimum |  | CALC:MEAS:FILT[:GATE]:TIME:SHAP
Gating Setup... |  | Gating On Start Stop Center Span Gate Type Gate Shape | CALC:MEAS:FILT[:GATE]:TIME:STAT CALC:MEAS:FILT[:GATE]:TIME:STAR CALC:MEAS:FILT[:GATE]:TIME:STOP CALC:MEAS:FILT[:GATE]:TIME:CENT CALC:MEAS:FILT[:GATE]:TIME:SPAN CALC:MEAS:FILT[:GATE]:TIME[:TYPE] CALC:MEAS:FILT[:GATE]:TIME:SHAP

Last modified:

6-Jan-2016

New topic


Meas Com Finder

Meas Settings: S-Param | Balanced | Receivers | Waves | Auxiliary | Meas Overview

SoftTab & Softkey |  | Command in Dialog Box | SCPI
S-Param
S11 |  |  | CALC:MEAS:DEF
S21 |  |  | CALC:MEAS:DEF
S12 |  |  | CALC:MEAS:DEF
S22 |  |  | CALC:MEAS:DEF
Other | S11,S12,S13,S14, S21,S22,S23,S24, S31,S32,S33,S34, S41,S42,S43,S44, ... | S-Parameter Balanced Receivers | CALC:MEAS:DEF
Balanced
Sss11 |  |  | CALC:FSIM:BAL
Sds21 |  |  | CALC:FSIM:BAL
Ssd12 |  |  | CALC:FSIM:BAL
Sdd22 |  |  | CALC:FSIM:BAL
Other | Sss11,Ssd12,Ssc12, Sds21,Sdd22, Sdc22, Scs21,scd22,Scc22, ... | S-Parameter Balanced Receivers | CALC:FSIM:BAL:PAR:SBAL[:DEF] CALC:FSIM:BAL:PAR:SSB[:DEF] CALC:FSIM:BAL:PAR:BBAL[:DEF] CALC:FSIM:BAL:PAR:BALS[:DEF] CALC:FSIM:BAL:PAR:BAL[:DEF] CALC:MEAS:DEF CALC:MEAS:DEF CALC:MEAS:DEF
Topology... |  | SE-BAL SE-SE-BAL BAL-BAL BAL-SE BAL | CALC:DTOP CALC:FSIM:BAL:TOP:SBAL[:PPOR] CALC:FSIM:BAL:TOP:SSB[:PPOR] CALC:FSIM:BAL:TOP:BBAL[:PPOR] CALC:FSIM:BAL:TOP:BALS[:PPOR] CALC:FSIM:BAL:TOP:BAL[:PPOR]
Receivers
A Source Port 1 |  |  | CALC:MEAS:DEF
A Source Port 2 |  |  | CALC:MEAS:DEF
B Source Port 1 |  |  | CALC:MEAS:DEF
B Source Port 2 |  |  | CALC:MEAS:DEF
R2 Source Port 1 |  |  | CALC:MEAS:DEF
R2 Source Port 2 |  |  | CALC:MEAS:DEF
Other | (A,1), (A,2), (A,3), (A,4), (B,1), (B,2), (B,3), (B,4), (C,1), (C,2), (C,3), (C,4), (D,1), (D,2), (D,3), (D,4), (R1,1), (R2,2), (R3,3), (R4,4), ... | S-Parameter Balanced Receivers | CALC:MEAS:DEF
Waves
a1 Source Port 1 |  |  | CALC:MEAS:DEF
a2 Source Port 2 |  |  | CALC:MEAS:DEF
b1 Source Port 1 |  |  | CALC:MEAS:DEF
b1 Source Port 2 |  |  | CALC:MEAS:DEF
b2 Source Port 1 |  |  | CALC:MEAS:DEF
b2 Source Port 2 |  |  | CALC:MEAS:DEF
Other | (a1,1), (a2,2), (a3,3), (a4,4), (b1,1), (b1,2), (b1,3), (b1,4), (b2,1), (b2,2), (b2,3), (b2,4), (b3,1), (b3,2), (b3,3), (b3,4), (b4,1), (b4,2), (b4,3), (b4,4), ... | S-Parameter Balanced Receivers | CALC:MEAS:DEF
Auxiliary
AuxIn1 Source Port 1 |  |  | CALC:MEAS:DEF
AuxIn1 Source Port 2 |  |  | CALC:MEAS:DEF
AuxIn2 Source Port 1 |  |  | CALC:MEAS:DEF
AuxIn2 Source Port 2 |  |  | CALC:MEAS:DEF
Other | (AuxIn1,1), (AuxIn1,2), (AuxIn1,3), (AuxIn1,4), (AuxIn2,1), (AuxIn2,2), (AuxIn2,3), (AuxIn2,4), ... | S-Parameter Balanced Receivers | CALC:MEAS:DEF
AuxIn1 Range | 1 V |  | SENS:VOLT[:DC]:RANG[:UPP]
 | 10 V |  | SENS:VOLT[:DC]:RANG[:UPP]
AuxIn2 Range | 1 V |  | SENS:VOLT[:DC]:RANG[:UPP]
 | 10 V |  | SENS:VOLT[:DC]:RANG[:UPP]
Meas Overview
Meas Class | Standard |  | SENS:CLAS:NAME?
 | SMC |  | SENS:CLAS:NAME?
 | Measurement Class... | Standard Scalar Mixer/Converter | SENS:CLAS:NAME?
Conversions | Off |  | CALC[:SEL]:CONV:FUNC
Correction | Channel Correction On |  | SENS:CORR:CSET:ACT
 | Channel Correction Off |  | SENS:CORR:CSET:ACT
 | Cal Set... | Select calset from list or type new name below Delete Existing calsets Copy Apply Cal Edit Description Edit Name | SENS:CORR:CSET:CRE SENS:CORR:CSET:DEL SENS:CORR:CSET:CAT? SENS:CORR:CSET:COPY SENS:CORR:CSET:SAVE SENS:CORR:CSET:DESC SENS:CORR:CSET:NAME
 | Basic Cal... | Connector Cal Kit Port Cal Type Save as CalSet | SYST:CORR:WIZ SENS:CORR:COLL:GUID:CONN:PORT SENSe:CORR:COLL:CKIT SENS:CORR:TST SENS:CORR:COLL:METH SENS:CORR:CSET:SAVE
 | Smart Cal... | Cal Type Selection 2 Port Cal Configuration Calibrate source and receive power DUT Connections Cal Kits Modify Cal: Change Cal Method, standards Power cal at [Port #] Use Multiple Sensors De-emded adapter Power Sensor Connector Cal Kit Accuracy: Tolerance Max Number of Readings Power Meter Settings: GPIB USB LAN Any Sensors Tolerance Max Number of Readings Measure (Measure calibration standard) Port 1 Measure (Measure calibration standard) Port 2 | SENS:CORR:COLL:GUID:INIT SENS:CORR:TST SYST:CAL:ALL:PATH:CONF:ELEM SOUR:POW:CORR:COLL:ACQ SENS:CORR:COLL:METH RPOW None SENSe:CORR:COLL:CKIT None SENS:CORR:COLL:GUID:PSEN SENS:CORR:COLL:GUID:PSEN:MULT None SENS:CORR:COLL:GUID:PSEN:CONN SENSe:CORR:COLL:CKIT SOUR:POW:CORR:COLL:AVER:NTOL SOUR:POWer:CORR:COLL:AVER:COUN - None None None None SENS:CORR:COLL:GUID:PSEN:MULT:ADD SOUR:POW:CORR:COLL:AVER:NTOL SOUR:POW:CORR:COLL:AVER:COUN SENS:CORR:COLL SENS:CORR:COLL
Trace Hold | Off |  | None
 | Max |  | None
 | Min |  | None
 | Restart |  | None
Equation Editor... | ON |  | CALC:MEAS:EQU[:STAT]
 | OFF |  | CALC:MEAS:EQU[:STAT]
 |  | Equation Enable Equation Function Trace Data Parameter Store Equation Delete Equation Use Short Names Enable Matlab Import... Import Library Remove Library | CALC:EQU:TEXT CALC:MEAS:EQU[:STAT] CALC:EQU:LIBR:FUNC? None None None None None None - CALC:EQU:LIBR:IMP CALC:EQU:LIBR:REM
Memory... |  |  | See Math Hardkey
Time Domain... |  | Transform On Start Stop Center Span Transform Mode Low Pass Impulse Low Pass Step Band Pass Set Low Pass Frequencies | CALC:MEAS:TRAN:TIME:STAT CALC:MEAS:TRAN:TIME:STAR CALC:MEAS:TRAN:TIME:STOP CALC:MEAS:TRAN:TIME:CENT CALC:MEAS:TRAN:TIME:SPAN - CALC:MEAS:TRAN:TIME:STIM CALC:MEAS:TRAN:TIME:STIM CALC:MEAS:TRAN:TIME:TYPE CALC:MEAS:TRAN:TIME:LPFREQ | LPFREQ

Last modified:

6-Jan-2016

New topic


Power Com Finder

Power Settings : Main | Port Power | Leveling & Offsets

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Power Level |  |  | SOUR:POW
RF Power | ON |  | SOUR:POW:MODE
 | OFF |  | SOUR:POW:MODE
Start Power |  |  | SOUR:POW:STAR
Stop Power |  |  | SOUR:POW:STOP
Power and Attenuators... |  |  | SENS:POW:ATT
Port Power
Select | Port 1 | SENS:SWE:SRCP
 | Port 2 | SENS:SWE:SRCP
 | Port 3 | SENS:SWE:SRCP
 | Port 4 | SENS:SWE:SRCP
Power Level |  | SOUR:POW
Start Power |  | SOUR:POW:STAR
Stop Power |  | SOUR:POW:STOP
Source State | AUTO | SOUR:POWer:MODE
 | ON | SOUR:POWer:MODE
 | OFF | SOUR:POWer:MODE
Coupling | ON | SOUR:POW:COUP
 | OFF | SOUR:POW:COUP
Leveling & Offsets
Select | Port 1 |  | SENS:SWE:SRCP
 | Port 2 |  | SENS:SWE:SRCP
 | Port 3 |  | SENS:SWE:SRCP
 | Port 4 |  | SENS:SWE:SRCP
Slope | ON |  | SOUR:POW:SLOP:STAT
 | OFF |  | SOUR:POW:SLOP:STAT
Slope Value |  |  | SOUR:POW:SLOP
Offset |  |  | SOUR:POW:CORR:OFFS:MAGN
Limit | ON |  | SYST:POW:LIM:STAT
 | OFF |  | SYST:POW:LIM:STAT
Limit Value |  |  | SYST:POWer:LIM
Offsets and Limits... |  | Power Limit - State Power Limit -Limit Source Power Power Offset Port Power | SYST:POW:LIM:STAT SYST:POWer:LIM SOUR:POW SOUR:POW:CORR:OFFS:MAGN None

Last modified:

6-Jan-2016

New topic


Preset Com Finder

Preset Settings : Main

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Preset |  |  | SYST:PRES
User Preset... |  | User Preset Enable Save current state as User Preset Load existing file as User Preset | SYST:UPR:FPAN[:STAT] SYST:UPR:SAVE[:STAT] SYST:UPR:LOAD[:FILE]
Confirm Preset | ON |  | None
 | OFF |  | None

Last modified:

6-Jan-2016

New topic


Save Recall Com Finder

Save Recall Settings : Recall | Save State | Save Other

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Recall
Recall State |  |  | MMEM:LOAD:STAT
Recall State |  |  | MMEM:LOAD:STAT
Recall State... |  |  | MMEM:LOAD:STAT
Recall Register |  |  | MMEM:LOAD:STAT
Recall Calset... |  |  | MMEM:LOAD:STAT
Recall Data... |  |  | MMEM:LOAD:STAT
Recall Order | NAME |  | MMEM:LOAD:STAT
 | RECENT |  | MMEM:LOAD:STAT
Save State
Save State |  | MMEM:STOR:STAT
Auto Save |  | MMEM:STOR:STAT
Save State As... |  | MMEM:STOR:STAT
Save Register |  | MMEM:STOR:STAT
Save Type | State | MMEM:STOR:STAT
 | State + Cal Data | MMEM:STOR:STAT
 | State + Cal Link | MMEM:STOR:STAT
Delete State |  | MMEM:STOR:STAT
Save Other
Save Calset... | SENS:CORR:CSET:SAVE
Save Data... | MMEM:STOR:STAT
Save Screen... | MMEM:STOR:STAT
Save User Preset | MMEM:STOR:STAT
Manage Files... | None

Last modified:

6-Jan-2016

New topic


Scale Com Finder

Scale Settings: Main | Electrical Delay | Constants

SoftTab & Softkey | Command in Dialog Box | SCPI
Main
Autoscale |  | DISP:WIND:TRAC:Y:AUTO
Autoscale All |  | DISP:WIND:Y:AUTO
Scale |  | DISP:MEAS:Y[:SCAL]:PDIV
Reference Level |  | DISP:WIND:TRAC:Y[:SCAL]:RLEV
Reference Position |  | DISP:WIND:TRAC:Y[:SCAL]:RPOS
Scale Coupling... | Coupling Method - Off - Window - All : couple between all selected windows Selected Windows | DISP:WIND:TRAC:Y[:SCAL]:COUP:METH DISP:WIND:TRAC:SEL
Electrical Delay
Delay Time |  | CALC:MEAS:CORR:EDEL[:TIME]
Delay Distance |  | CALC:MEAS:CORR:EDELay:DIST
Distance Units | Meters | CALC:MEAS:CORR:EDEL:UNIT
 | Feet | CALC:MEAS:CORR:EDEL:UNIT
 | Inches | CALC:MEAS:CORR:EDEL:UNIT
Velocity Factor |  | SENS:CORR:RVEL:COAX
Media | COAX | CALC:MEAS:CORR:EDEL:MED
 | WAVEGD | CALC:MEAS:CORR:EDEL:MED
Waved Cutoff |  | CALC:MEAS:CORR:EDEL:WGC
Constants
System Z0 | SENS:CORR:IMP:INP:MAGN
Phase Offset | CALC:OFFS:PHAS
Mag Offset | CALC:MEAS:OFFS:MAGN
Mag Slope | CALC:MEAS:OFFS:MAGN:SLOP

Last modified:

6-Jan-2016

New topic


Search Com Finder

Search Settings : Main | Peak | Target | Multi Peak & Target | Bandwidth & Notch | Comp & Sat | Normal Op Pt

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Max Search |  |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Min Search |  |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Domain |  |  | CALC:MEAS:MARK:FUNC:DOM:USER[:RANG]
Domain Start |  |  | CALC:MEAS:MARK:FUNC:DOM:USER:STAR
Domain Stop |  |  | CALC:MEAS:MARK:FUNC:DOM:USER:STOP
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point |  | CALC:MEAS:MARK:FUNC:TRAC
Peak
Peak Search |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Peak Right Search >> |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
<< Peak Left Search |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Next Peak Search |  | CALC:MEAS:MARK:FUNC:EXEC
Threshold |  | CALC:MEAS:MARK:FUNC:APE:THR CALC:MEAS:MARK:FUNC:PEAK:THR
Excursion |  | CALC:MEAS:MARK:FUNC:APE:EXC CALC:MEAS:MARK:FUNC:PEAK:EXC
Peak Polarity | Positive | CALC:MEAS:MARK:FUNC:APE:POL
 | Negative | CALC:MEAS:MARK:FUNC:APE:POL
 | Both | CALC:MEAS:MARK:FUNC:APE:POL
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:TRAC
Target
Target Search |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Target Right Search >> |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
<< Target Left Search |  | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Target Value |  | CALC:MEAS:MARK:FUNC::TARG[:VAL]
Transition | Positive | CALC:MEAS:MARK:FUNC:TARG[:VAL]:TRAN
 | Negative | CALC:MEAS:MARK:FUNC:TARG[:VAL]:TRAN
 | Both | CALC:MEAS:MARK:FUNC:TARG[:VAL]:TRAN
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:TRAC
Multi Peak &Target
Multi Peak Search |  | CALC:MEAS:MARK:FUNC:MULT:TYPE
Peak Threshold |  | None
Peak Excursion |  | CALC:MEAS:MARK:FUNC:MULT:PEXC
Peak Polarity | Positive | CALC:MEAS:MARK:FUNC:MULT:PPOL
 | Negative | CALC:MEAS:MARK:FUNC:MULT:PPOL
 | Both | CALC:MEAS:MARK:FUNC:MULT:PPOL
Multi Target Search |  | CALC:MEAS:MARK:FUNC:MULT:TYPE
Target Value |  | CALC:MEAS:MARK:FUNC:MULT:TARG[:VAL]
Transition | Positive | CALC:MEAS:MARK:FUNC:MULT:TTRAN
 | Negative | CALC:MEAS:MARK:FUNC:MULT:TTRAN
 | Both | CALC:MEAS:MARK:FUNC:MULT:TTRAN
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:MULT:TRAC
Bandwidth & Notch
Bandwidth Search |  | CALC:MEAS:MARK:BWID[:STAT]
BW Ref To | Marker | CALC:MEAS:MARK:BWID:REF
 | Peak | CALC:MEAS:MARK:BWID:REF
BW Level |  | CALC:MEAS:MARK:BWID:THR
Notch Search | ON | CALC:MEAS:MARK:NOTC[:STAT]
 | OFF | CALC:MEAS:MARK:NOTC[:STAT]
Notch Ref To | Marker | CALC:MEAS:MARK:NOTC:REF
 | Peak | CALC:MEAS:MARK:NOTC:REF
Notch Level |  | CALC:MEAS:MARK:NOTC:THR
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:TRAC
Comp & Sat
Compression Search | ON | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
 | OFF | CALC:MEAS:MARK:FUNC[:SEL] CALC:MEAS:MARK:FUNC:EXEC
Comp Level |  | CALC:MEAS:MARK:COMP:LEV
Saturation Search | ON | CALC:MEAS:MARK:PSAT:BACK
 | OFF | CALC:MEAS:MARK:AOFF
Pmax Backoff |  | CALC:MEAS:MARK:PSAT:BACK CALC:MEAS:MARK:PSAT:PIN:MAX?
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:TRAC
Normal Op Pt
Normal OP Search | ON | CALC:MEAS:MARK:PNOP:BACK
 | OFF | CALC:MEAS:MARK:AOFF
Backoff |  | CALC:MEAS:MARK:PNOP:BACK
Pin Offset |  | CALC:MEAS:MARK:PNOP:POFF CALC:MEAS:MARK:PNOP:BACK:PIN?
Tracking | Off, Max, Min, Peak, Target, Multi Peak, Multi Target, Bandwidth, Notch, Compression, Saturation, Normal Operating Point | CALC:MEAS:MARK:FUNC:TRAC

Last modified:

6-Jan-2016

New topic


Setup Com Finder

Setup Settings: Main | Customize Meas | Internal Hardware | External Hardware

SoftTab & Softkey | Command in Dialog Box | SCPI
Main
Sweep Setup... | Sweep Type Sweep Properties Start Stop Power Points IF Bandwidth Start Power Stop Power CW Freq Segment Table... X-axis Point Spacing Allow arbitrary Segments Display Center/Span Freq Save Table Load Table Independent Settings Per Segment Power Level IF Bandwidth IF Bandwidth Per Port Sweep Time Delay Sweep Mode Shift LO Timing Sweep Time Dwell Time Sweep Delay Auto Sweep Time Sweep Mode Sweep sequence | SENS:SWE:TYPE - SENS:FREQ:STAR SENS:FREQ:STOP SOUR:POW SENS:SWE:POIN SENS:BAND | BWID[:RES] SOUR:POW:STAR SOUR:POW:STOP SENS:FREQ:CW - SENS:SEGM:X:SPAC SENS:SEGM:ARB SENS:SEGM:FREQ:CENT or SENS:SEGM:FREQ:SPAN None None - SENS:SEGM:POW[:LEV]:CONT SENS:SEGM:BAND | BWID[:RES]:CONT SENS:SEGM:BAND | BWID:PORT[:RES]:CONT SENS:SEGM:SWE:TIME:CONT SENS:SEGM:SWE:DEL:CONT SENS:SEGM:SWE:GEN:CONT SENS:SEGM:SHLO:CONT - SENS:SWE:TIME SENS:SWE:DWELI SENS:SWE:DWELl:SDEL SENS:SWE:TIME:AUTO SENS:SWE:GEN SENS:SWE:GEN:POIN
Quick Start... | S-Parameter Balanced Other | CALC:MEAS:DEF CALC:MEAS:DEF CALC:MEAS:DEF
Customize Meas
New Trace |  |  | DISP:WIND:TRAC[:STAT]
New Channel |  |  | None
New Window |  |  | DISP:WIND[:STAT]
Delete | TrN |  | DISP:WIND:TRAC:DEL
 | ChN |  | SYST:CHAN:DEL
 | WinN |  | DISP:WIND[:STAT]
Select | TrN |  | DISP:WIND:TRAC:SEL
 | ChN |  | None
 | WinN |  | DISP:WIND:TRAC:SEL
Measure... |  | S-Parameter Balanced Receivers | CALC:MEAS:DEF CALC:MEAS:DEF CALC:MEAS:DEF
Meas Class | Standard |  | SENS:CLAS:NAME?
 | SMC |  | SENS:CLAS:NAME?
 | Measurement Class... | Standard Scalar Mixer/Converter | SENS:CLAS:NAME?

Internal Hardware

Interface Control...

Enable Interface Control

Channel

Channel Control Label

Before Sweep Start

After Sweep End

Reset All

Save

Recall

CONT:CHAN:INT:CONT[:STAT]

None

None

None

None

CALC:MEAS:DEL:ALL

None

CONT:CHAN:INT:CONT:CONF:REC[:STAT]

External Hardware
External Device... | New Remove Name Device Type Driver Active - Show in UI Device Properties Interface Available Selected Enable IO | SYST:CONF:EDEV:ADD SYST:CONF:EDEV:REM SYST:CONF:EDEV:ADD SYST:CONF:EDEV:DTYP SYST:CONF:EDEV:DRIV None None None None None SYST:CONF:EDEV:IOEN
Power Meter Settings... | Interface Sensors Tolerance Max Number of Readings Use Loss Table Edit Table | None SYST:CONF:EDEV:PMAR:SENS SYST:CONF:EDEV:PMAR:READ:NTOL SYST:CONF:EDEV:PMAR:READ:COUN SYST:CONF:EDEV:PMAR:LOSS:DATA SYST:CONF:EDEV:PMAR:LOSS:DATA
External Testset... | Select ID Test Set Enable Test Set Control Show Test Set Properties Port Control Control Lines Line X DC Source | None None None None None None None SYST:CONF:EDEV:DC

Last modified:

6-Jan-2016

New topic


Sweep Com Finder

Sweep Settings : Main | Sweep Timing | Source Control | Segment Table

SoftTab & Softkey |  | Command in Dialog Box | SCPI | COM
Main
Number of points |  |  | SENS:SWE:POIN |
Sweep Type | Linear Frequency |  | SENS:SWE:TYPE |
 | Log Frequency |  | SENS:SWE:TYPE |
 | Power Sweep |  | SENS:SWE:TYPE |
 | CW Time |  | SENS:SWE:TYPE |
 | Segment Sweep |  | SENS:SWE:TYPE |
Start |  |  | SENS:FREQ:STAR |
Stop |  |  | SENS:FREQ:STOP |
Sweep Timing
Sweep Time | Auto | SENS:SWE:TIME:AUTO
 | Manual | SENS:SWE:TIME
Dwell Time |  | SENS:SWE:DWELI
Sweep Delay |  | SENS:SWE:DWELl:SDEL
Sweep Mode | Auto | SENS:SWE:GEN
 | Stepped | SENS:SWE:GEN
Source Control
Frequency Offset... |  | Frequency Offset (ON/OFF) Mode - Coupled and Un-coupled Sweep Type Settings - Start and Stop Annotation - Primary, Source and Receivers X-Axis Point Spacing | SENS:FOM[:STAT] SENS:FOM:RANG:COUP SENS:FOM:RANG:SEGM SENS:FOM:RANG:FREQ:STAR SENS:FOM:RANG:FREQ:STOP SENS:FOM:RNUM?
Shift LO | ON |  | SENS:SWE:SLOC:STAT
 | OFF |  | SENS:SWE:SLOC:STAT
 | Maximum Frequency |  | SENS:SWE:SLOC:MAX
Segment Table
Add Segment |  |  | SENS:SEGM:ADD
Insert Segment |  |  | None
Delete Segment |  |  | SENS:SEGM:DEL
Delete All Segments |  |  | SENS:SEGM:DEL:ALL
Segment Table... |  | X-axis Point Spacing Allow arbitrary Segments Display Center/Span Freq Save Table Load Table Independent Settings Per Segment Power Level IF Bandwidth IF Bandwidth Per Port Sweep Time Delay Dwell Sweep Mode Shift LO | SENS:SEGM:X:SPAC SENS:SEGM:ARB SENS:SEGM:FREQ:CENT or SENS:SEGM:FREQ:SPAN None None - SENS:SEGM:POW[:LEV]:CONT SENS:SEGM:BAND | BWID[:RES]:CONT SENS:SEGM:BAND | BWID:PORT[:RES]:CONT SENS:SEGM:SWE:TIME:CONT SENS:SEGM:SWE:DEL:CONT SENS:SEGM:SWE:DWEL:CONT SENS:SEGM:SWE:GEN:CONT SENS:SEGM:SHLO:CONT
Show Table | Auto |  | None
 | On |  | DISP:WIND:TABL

Last modified:

6-Jan-2016

New topic


System Com Finder

System:..Main | System Settings | Print | Help | Services

SoftTab & Softkey | Command in DialogBox | SCPI
Main
Show Taskbar |  | None
Move App to Back |  | None
Minimize Application |  | None
Exit |  | None
Security... | Security Level | None
Control Panel... |  | None
Manage Files... |  | None

System Settings

Next/Prev Keys

Trace

Channel

Window

None

None

None

Preferences

Avg: On Preset set two-point Group Delay Aperture

Cal: Auto-save to User Cal Set

Cal: Auto-save to current Cal Set

Cal: For Frequency Offset, use Primary frequencies

Cal: Use External Trigger, if selected, during cal

Display: Selected trace changes width briefly

Display: Selected trace is wider

Display: Touchscreen On

Ext Device: De-activate on Preset and Recall

Limit: Test the nearest measurement point

Marker: Coupling controls on|off state of markers

Marker: On Preset, Coupling Method is Channel

Marker: On Preset, Coupling Method is On

Marker: Programming treats Mkr 10 as Reference

Marker: Use single marker for marker search

Meas: Draw failed trace segments in red

Meas: Draw limit lines in red

Memory: Data Math 8510 Mode

Power: On Preset turn power on

Power: Report source unleveled events as errors

Preset: Confirm preset

Preset: On Preset show Quick Start dialog

Recall: Softkey order is most recently used

Scale: On Preset Couple Scale to Window

Sweep: On Preset set Sweep Mode to Stepped

Sweep: Use only ramp sweeps for Auto Sweep Mode

[TODO: Remove before SRR] Show Menu bar

System: Enable sound

System: Use keyboard to navigate softkeys

Data Saves...

Power Limit...

Transparency...

User Preset...

Page Setup...

Disp Colors...

Print Colors...

None

SENSe:CORRection:PREFerence:CSET:SAVE

None

SENSe:CORRection:PREFerence:CALibration:RANGe

SYSTem:CONFigure:EDEVice:SOURce:TMODe

None

None

SYSTem:TOUCh

SYSTem:PREFerence:ITEM:EDEV:DPOLicy

None

None

None

None

None

None

SYSTem:PREFerence:ITEM:RTOF

None

None

SYSTem:PREFerence:ITEM:PRESet:POWer

None

None

None

None

None

None

None

None

None

None

MMEMory:STORe:DATA

None

None

SYSTem:UPReset

Hardcopy

Refer to Print Colors...

Refer to Print Colors...

Sound

ON | OFF

SYSTem:BEEP:STATe ON|OFF

SICL/GPIB.

GPIB Address

SICL Enabled

SICL Address

Automatically Enable on Startup

Sockets Enabled

Telnet Enabled

HiSlip Enabled

HiSlip Address

Show SCPI Parser Console

Monitor GPIB Bus

None

None

None

None

None

None

None

None

None

None

Lan Status...

LAN Reset

None

Code Emulation

None

Print
Print... |  | None
Print to File... |  | None
Page Setup... |  | None
Print Colors... | Pen Background Active Background Grid Active Labels, Grid frame Inactive Window Labels Failed Trace N Trace: Data and Limits N Trace: Memory N Trace: Markers N Trace: Memory Markers Change Color... Reset Color Color Theme Save Theme... Recall Theme... Reset Theme... | DISPlay:COLor:IBACKground | IBACkground DISPlay:COLor:ABACkground DISPlay:COLor:GRAT2 DISPlay:COLor:GRAT1 DISPlay:COLor:ILABel DISPlay:COLor:LIMit1 DISPlay:COLor:TRACe:DATA DISPlay:COLor:TRACe:MEMory DISPlay:COLor:TRACe:MARKer DISPlay:COLor:TRACe:MMARker None None None DISPlay:COLor:STORe None DISPlay:COLor:RESet
Help
NA Help... |  | None
On the Web... |  | None
Error Display... | Enable Messages Status bar Display Confirmation Dialog boxes | DISPlay:ANNotation:MESSage:STATe? None None
View Error Log... |  | None
About NA... |  | None
Services
Operator's Check | None
System Verification | None
Display Test | None
Front Panel Test | None
Restore Ecal Memory | None

Last Modified:

4-Nov-2014

Initial Release


Trace Com Finder

Trace Settings: Trace 1-8 | Trace 9-16 | Trace Setup

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Trace 1-8
Trace 1 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 2 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 3 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 4 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 5 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 6 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 7 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 8 | ON |  | DISP:WIND:TRAC[:STAT]
 | OFF |  | DISP:WIND:TRAC[:STAT]
Trace 9-16
Trace 9 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 10 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 11 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 12 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 13 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 14 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 15 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace 16 | ON | DISP:WIND:TRAC[:STAT]
 | OFF | DISP:WIND:TRAC[:STAT]
Trace Setup
Select | TrN |  | DISP:WIND:TRAC:SEL
Measure... |  | S-Parameter Balanced Receivers | CALC:MEAS:DEF
Trace Title... |  | Enable (ON | OFF) Title | DISP:WIND:TRAC:TITL[:STAT] DISP:WIND:TRAC:TITL:DATA
Add Trace | New Trace |  | None
 | New Trace + Channel |  | None
 | New Trace + Window |  | DISP:WIND:TRAC[:STAT]
 | New Trace + Channel + Window |  | None
 | Create Traces... | S-Parameter Balanced Receivers | CALC:MEAS:DEF
Delete | TrN |  | DISP:WIND:TRAC:DEL DISP:MEAS:DEL
Move Trace... |  | Move Trace 1 to window | DISP:WIND:TRAC:MOVE
Trace Hold |  |  | :CALC:MEAS:HOLD:TYPE
 | Restart |  | :CALC:MEAS:HOLD:CLE
Trace Max | ON |  | DISP:TMAX
 | OFF |  | DISP:TMAX

Last modified:

6-Jan-2016

New topic


Trigger Com Finder

Trigger Settings : Main

SoftTab & Softkey |  | Command in Dialog Box | SCPI
Main
Hold |  |  | SENS:SWE:MODE
Single |  |  | SENS:SWE:MODE
Groups |  |  | SENS:SWE:MODE
Continuous |  |  | SENS:SWE:MODE
Manual Trigger |  |  | INIT[:IMM]
Restart |  |  | INIT[:IMM]
Trigger Source | Internal |  | TRIG[:SEQ]:SOUR
 | Manual |  | TRIG[:SEQ]:SOUR
 | External |  | TRIG[:SEQ]:SOUR
Trigger... |  | Trigger Source Internal Manual External (uses MEAS TRIG IN) Manual Trigger! Trigger Scope Global Channel Active Channel Channel Trigger State Trigger Mode - Point - Channel - Sweep Continuous Groups Single Hold | - TRIG[:SEQ]:SOUR TRIG[:SEQ]:SOUR TRIG[:SEQ]:SOUR INIT[:IMM] - TRIG[:SEQ]:SCOP TRIG[:SEQ]:SCOP TRIG[:SEQ]:SCOP - SENS:SWE:TRIG:MODE SENS:SWE:TRIG:MODE SENS:SWE:TRIG:MODE SENS:SWE:TRIG:MODE SENS:SWE:MODE SENS:SWE:MODE SENS:SWE:MODE SENS:SWE:MODE

Last modified:

6-Jan-2016

First Release


管理工作指南

執行管理工作

  • VNA 使用者和密碼

  • VNA 電腦屬性

  • 作業系統復原

另請參閱

Windows 注意事項


快速入門指南

快速入門

下列主題可以協助您熟悉 VNA：

  • 快速入門量測

  • 前面板概觀

  • 後面板導覽

  • 螢幕顯示概觀

  • 開啟和關閉 VNA 電源

  • 軌跡、通道及視窗

  • 基本量測順序

  • VNA 偏好設定

  • 對話方塊透明度

  • 使用說明

  • 作業系統復原

  • Windows 注意事項

  • 連接網路和連接分析儀

  • 執行管理工作

請閱讀：非常重要的注意事項：


搜尋 VNA 說明

搜尋範圍僅限於 http://na.tm.Keysight.com/pna/help/latest/

請參閱 Google 搜尋說明


設定指南

設定量測

使用下列資訊設定量測：

基本設定

  • 預設 VNA

  • 量測類別

  • 選取量測參數

  • 設定頻率範圍

  • 設定功率位準

  • 設定掃描類型

  • 設定點數

  • 設定觸發

  • 設定資料格式

  • 設定刻度

  • 自訂 VNA 螢幕

  • 復原/重做設定

進階設定

  • 複製通道

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


將應用程式移至後方

在 VNA 上執行外部程式 (例如支援程式) 時，該程式的對話方塊可能被 VNA 應用程式攔截。發生這種情況時，有幾個方式可以讓您的程式再次聚焦於 VNA 的最上方。達成此目標的簡易方法是，使 VNA 應用程式移至應用程式的後方。

這項操作必須在每次選取 VNA 應用程式時執行，以便再次將其移至其他應用程式的最上方。

如何將 VNA 應用程式移至後方

使用硬鍵/SoftTab/軟鍵

使用鍵盤

  1. 按下 [System] > Main（主功能表）> Move App to Back（將應用程式移至後方）

  1. 捷徑：Alt-f-b

此為無法程式化的設定


最佳化量測指南

最佳化量測

量測有許多相依設定。您可以修改設定以達到量測應用的目標：更快的處理能力或更高的量測準確度。

提高量測處理能力

  • 達到最快速的掃描

  • 在多個量測之間切換

  • 使用巨集

提高量測準確度

  • 增加動態範圍

  • 降低雜訊

    • 平均

    • IFBW

    • 平滑

  • 群體延遲（獨立主題）

  • 提高相位量測準確度

  • 提高長纜線裝置的準確度

  • 提高低損耗 2 埠裝置的反射準確度

  • 提高量測穩定性

  • 減少接收器串擾

  • 減少測試配件的影響

  • 減少不必要的影像回應

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


校準

校準主題

校準基本知識

  • 校準精靈

  • 選取校準

  • 使用校準集

若要瞭解校準應用程式通道，請參考應用程式的說明主題。

校準類型

  • 使用 ECal

  • 使用 2 連接埠 ECal 模組執行 4 連接埠校準

  • TRL 校準

  • 功率校準

  • 引導式功率校準

  • 校準所有通道

校準概念

  • 校準概觀

  • 有關校準標準

  • 誤差修正與內插法

  • 校準直通方法

  • 精確校準

  • 校準的有效性

進階校準主題

  • ECal 使用者特性化

  • 連接埠延伸

  • 固定裝置模擬器

  • 切換配接器方法

  • 量測誤差

  • 修改校準套件

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


分析資料指南

分析資料

  • 標記

  • 數學/記憶體運算

  • 方程式編輯器

    • 匯入函數

  • 限制線

  • 轉換

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


等式編輯器和 MATLAB®

可以將 MATLAB 與等式編輯器搭配使用：

使用 PC 上的完整版本編譯 MATLAB *.dll。然後將 *.dll 匯入到等式編輯器中。

瞭解如何將函數匯入到等式編輯器

VNA 上的 MATLAB Compile Runtime 的當前版本是 7.14，隨 R2010b (7.11) 一起提供。

如果使用該 MATLAB 版本編譯 *.dll，則不需要變更 VNA 上的 MCR 版本。

  1. 確定您要使用的 MATLAB 版本。

    • 您將需要在開發機器上安裝該 MATLAB 版本（步驟 2）。還需要 C++ 編譯器（步驟 3）。

    • 您需要在目標機器上安裝 MATLAB Compiler Runtime (MCR) 的適當版本（步驟 5）。

      • 若要查看已安裝的 MCR 版本，請檢查以下位置：

        • 在 32 位元 Windows 系統上：

          • C:\Program Files\Matlab\Matlab Compiler Runtime\

          • C:\Program Files\Matlab\Matlab Component Runtime\

        • 在 64 位元 Windows 系統上：

          • C:\Program Files (x86)\Matlab\Matlab Compiler Runtime\

          • C:\Program Files (x86)\Matlab\Matlab Component Runtime\

    • 使用下面的圖表比較 MATLAB、MCR 和編譯器版本。

  2. 在開發機器上安裝 MATLAB（32 位元）。

    • 如果您的開發系統是 64 位元，請手動導覽到安裝磁碟上的 \bin\win32\，執行 setup.exe 以使用 32 位元安裝程式。在以後版本中將移除該要求。

    • 必須使用 MATLAB Compiler 工具箱進行安裝。

  3. 在開發機器上安裝相容的 C++ 編譯器。

    • 對於 R2011b 到 R2013b，帶有 .NET 4.0 的 Windows SDK 7.1 已足夠。

      • 由於 SDK 安裝程式的問題，建議首先單獨安裝 .NET （如果還未安裝的話）。

      • 如果安裝了 Visual Studio 可轉散發套件，則目前 SDK 安裝程式也會失敗。

    • 如需相容編譯器的清單，請參閱 http://www.mathworks.com/support/compilers/。

    • 請注意，LCC 只是 C 編譯器，不是 C++，不是可接受的選項。

  4. 在 MATLAB 中，透過執行以下指令選取您已安裝的編譯器：>> mbuild -setup.

  5. 在所有目標機器上安裝正確的 MCR。這需要重新啟動，即使安裝程式沒有提示您這麼做。

建立 MATLAB DLL

  1. 透過使用者介面或使用 >> deploytool 開啟 MATLAB Compiler Deployment Tool，並選擇建立 "C++ Shared Library" 專案。

  2. 透過 [部署工具] 視窗將 DLL 中所需的任何 .m 檔案新增到您的專案中。這包括需要執行之函數的任何協助程式。

    1. 函數必須包含 0 到 32 個引數，並返回值 1 以在軌跡上使用。

    2. 返回值可以是陣列、軌跡大小或單一值。

    3. 無法從等式編輯器直接存取不相符的函數，但如果其他函數依賴這些函數，則必須包含之內。

  3. 可選：新增函數描述項。這些是單獨的函數，為其他函數提供原型（預設）引數，稱為每個函數的「myFuncdesc」。

    1. 這些函數不得包含引數，並返回單一字串，格式為：
      ‘arg1,arg2,…’ 或 ‘arg1,arg2,…;tooltip’
      其中 arg1,arg2,… 是引數清單，tooltip 是要在以後版本中使用的可選工具提示文字。

  4. 建立專案。這可能需要幾分鐘時間，如果沒有錯誤，將產生專案、src 和 distrib 資料夾。DLL 將位於 distrib 資料夾下。

    1. 產生的一些其他檔案可能會有用，但對於等式編輯器不需要。

  5. 可選：封裝所有可散發的檔案。

    1. 此套件還可包括適當的 MCR 安裝程式（大至 0.5 GB）。

    2. 一般來說不需要此步驟，僅需要產生的 DLL。

有關編寫指令碼的附註

將由等式編輯器直接存取的 MATLAB 函數必須遵循特定格式，如上所述。

  • 輸入：具有維度 [1, 掃描大小] 的 0 到 32 個向量。

    • 常數（0、e、channel() 等）將展開並作為 [1, 掃描大小] 向量傳遞。

  • 輸出：具有維度 [1, 掃描大小] 或 [1, 1] 的 1 個向量。

    • 輸出大小 [1, 1] 會自動展開至 [1, 掃描大小] 向量。

具有其他輸入/輸出集的函數不能直接從等式編輯器存取，但可包含在 DLL 中並由其他函數使用，這意味著可以使用協助程式且不會有任何風險。

不適合這些參數的現有函數可以隨包裝函數一起包含在內，這些函數可在 MATLAB 環境中轉換參數和輸出。

上次修改時間：

2016 年 01 月 06 日

第一版


等式編輯器匯入函數

匯入函數

VNA 隨附了一些其他函數。此外，您也可以建立自訂函數，這些函數會編譯到 DLL 中。匯入這些函數以供在等式編輯器中使用。

  • 如何匯入函數

  • 提供的使用者函數

    • BestFit.dll

    • EqnErrorTerms.dll

    • Expansion.dll

另請參閱

Custom Equations In VNA.pdf 詳細說明。（此連結需要網際網路連線才能開啟）

建立用於等式編輯器的自訂函數範本。（此連結需要網際網路連線才能開啟）

等式編輯器主要主題。

如何匯入函數

在等式編輯器主對話方塊中，按一下匯入...。

匯入函數對話方塊說明

匯入和移除與等式編輯器搭配使用的函數庫。函數庫是包含一或多個函數的 *.DLL 檔案。

雖然並非所有函數都適用於所有通道或資料集，但它們仍會顯示在 [函數/常數] 清單中。

匯入函數後，當 VNA 應用程式啟動時，會自動載入每個函數庫。如果找不到某個函數或在載入時發生錯誤，VNA 在啟動時將不會嘗試重新載入函數庫。

[匯入函數庫] 索引標籤

瀏覽 - 按一下此按鈕可瀏覽至 VNA 上的 .DLL 檔案。自訂等式 DLL 的建議位置是 VNA 上的「C:\Program Files (x86)\Agilent\Network Analyzer\UserFunctions」目錄。

函數庫預覽 - 列出函數庫中包含的函數。

按一下確定或套用可載入函數庫。

[移除函數庫] 索引標籤

左窗格 - 列出已匯入的函數庫。這些函數庫也會顯示在 [等式編輯器] 主對話方塊中並保留在其中，直到從 VNA 將其移除為止。

箭頭 - 按一下相關的箭頭可從 VNA 移動一些 (>) 或所有 (>>) 函數庫。

右窗格 - 列出要移除的函數庫。

按一下確定或套用可移除函數庫。

提供的使用者函數

VNA 會隨附下列函數，但必須將其匯入等式編輯器。它們位於 VNA 中的以下位置：C:\Program Files (x86)\Agilent\Network Analyzer\UserFunctions。

  • BestFit.dll

  • EqnErrorTerms.dll

  • Expansion.dll

BestFit.dll

d_best_fit_dB()

d_best_fit_dB(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM))

根據 PARAM 指定的資料繪製最佳擬合線性迴歸線。 最佳擬合線會將對數幅度格式的軌跡資料的 RSS（和的方根）最小化。迴歸線的相位恆為零。

d_channelPower()

d_channelPower(FA,FB,CHANNELNUM,xAxisIndex(),TRACETYPE,traceDataArray(PARAM))

計算指定頻率之間的指定通道號碼上指定量測的通道功率。

  • FA 和 FB 會以 Hz 為單位指定頻率的開始/停止值。

  • CHANNELNUM 是要使用的從 1 開始的通道號碼。

  • PARAM 指示要計算其通道功率的量測。

  • TRACETYPE 指示如何顯示計算所得的結果。

    • 如果 TRACETYPE=0，將會顯示一條平直線，值等於通道功率；

    • 如果 TRACETYPE=1（預設值），顯示會設定為 FA 到 FB 範圍之外的頻率的軌跡最小值。請參閱以下範例。

  • 如果 CHANNELNUM 進行 IM 頻譜量測，則使用以下公式計算通道功率：

channelPower = 10Log10(（FA 和 FB 之間的 PARAM 軌跡下方的區域）/resolutionBandwidth)

  • 對於所有其他量測類型，公式為：

channelPower = 10Log10(（FA 和 FB 之間的 PARAM 軌跡下方的區域）/IFBandwidth)

TraceType 範例 1：FA=7.75 GHz，FB=8.5 GHz，CHANNELNUM=1。TRACETYPE 為 0。計算所得的通道功率會顯示在整個頻率範圍的上方。

TraceType 範例 2：同上，但 TRACETYPE 為 1（預設值）。顯示的結果設定為指定範圍之外的軌跡最小值。

d_DFLP()

d_DFLP( FreqStart, FreqStop, xAxisIndex(), getNumPoints(), xAxisArray(), traceDataArray(PARAM))

計算與 PARAM 中指定軌跡的線性相位資料的偏差，即如果以相位格式顯示產生的軌跡，顯示的資料將是移除群組延遲斜率之後參數的殘餘相位回應。 FreqStart 和 FreqStop 引數可讓使用者指定用於此運算的通道頻距子集。 若要涵蓋通道的整個頻距，可將 FreqStart 設定為 0，並將 FreqStop 設定為非常大的數字，例如 1E100。

d_flatness_dB()

d_flatness_dB(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM))

計算 PARAM 中軌跡資料的幅度平坦度，方法是先移除任何增益斜率，然後將結果標準化為 0 dB。

d_mean()

d_mean(traceNum)

計算指定軌跡的平均值，並建立產生的軌跡，其中的實數部分是每個激勵點處的平均值。 traceNum 引數應取代為代表您要計算其平均值之軌跡的現有軌跡號碼的整數。 此函數不會對參數名稱（例如 S11）或軌跡名稱（例如 Tr1）進行計算。 此函數的結果與軌跡統計資料分析函數顯示的值相同。

d_min_max_dev()

d_min_max_dev(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM))

計算可將直線與 PARAM 指定的資料之間的最大絕對偏差最小化之直線的斜率和截距。此計算是在兩個相位中完成的。首先，將 PARAM 中的軌跡資料轉換為對數幅度，然後將最小偏差線與其擬合。接著，展開 PARAM 中的相位資料，然後將另一條最小偏差線與其擬合。然後結合幅度值和相位值起以形成複值軌跡。所顯示的軌跡代表 PARAM 中量測所得的值與最佳擬合資料之間的差量。通常在您想要量測與線性的最壞情況偏差的行為時使用此函數。

d_min_max_dev_d2()

d_min_max_dev_d2(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM))

計算可將抛物線與 PARAM 指定的資料之間的最大偏差最小化之抛物線的參數。此計算是在兩個相位中完成的。首先，將 PARAM 中的軌跡資料轉換為對數幅度，然後將最小偏差二次曲線與其擬合。接著，展開 PARAM 中的相位資料，然後將另一條最小偏差二次曲線與其擬合。然後結合幅度值和相位值起以形成複值軌跡。所顯示的軌跡代表 PARAM 中量測所得的值與最佳擬合資料之間的差量。通常在您想要量測與二次曲線行為的最壞偏差時使用此函數。

d_min_max_dev_range()

d_min_max_dev_range(FSTART,FSTOP,xAxisIndex(),getNumPoints(),xAxisArray(),traceDataArray(PARAM))

與函數 d_min_max_dev() 相同，但僅會對從 FSTART 到 FSTOP 的頻率範圍內的資料進行運算。

d_min_sum_dev()

d_min_sum_dev(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM))

計算可將直線與 PARAM 指定的資料之間的絕對偏差總和最小化之直線的斜率和截距。此計算是在兩個相位中完成的。首先，將 PARAM 中的軌跡資料轉換為對數幅度，然後將最小偏差線與其擬合。接著，展開 PARAM 中的相位資料，然後將另一條最小偏差線與其擬合。然後結合幅度值和相位值起以形成複值軌跡。顯示的軌跡代表偏差的總和。此函數對離群值的敏感度低於 d_min_max_dev()。

d_tilt_dB()

d_tilt_dB(getNumPoints(),xAxisIndex(),xAxisArray(),traceDataArray(PARAM)) – 以對數幅度格式顯示時 tilt() 函數的結果是指定軌跡或參數的最佳擬合線的總 deltaY。

d_unwrap()

d_unwrap(getNumPoints(),xAxisIndex(),traceDataArray(PARAM))

以實數格式顯示時 unwrap() 函數的結果是以度表示的指定軌跡或參數的展開相位回應。

EqnErrorTerms.dll

d_Corr1P() | d_Corr1P(chan, xAxisIndex(),rcvr, src, RAWDATA ) 計算並顯示在 RAWDATA 預留位置中提供的軌跡資料的 1 連接埠修正資料。 chan - 相關通道。 xAxisIndex() - 區間（資料點）號碼。 rcvr - 用於獲取資料之接收器的連接埠號碼。 src - 正在驅動的連接埠。 需要有 rcvr 和 src 引數才能選取在修正過程中使用的適當誤差項。 RAWDATA - 透過代入軌跡號碼或參數名稱來選取要修正的資料。
d_DIR() | d_DIR(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的方向性項。 將 chanNum 設定為所需的通道。 將 rcvr 和 src 設定為所需方向性項的連接埠號碼。
d_EnhResp() | d_EnhResp(chan,xAxisIndex(),rcvr, src,RAWMATCH,RAWGAIN) 使用增強回應修正技巧計算修正的增益。 在您想要忽略裝置的輸出配對或無法準確量測輸出配對時，此技巧將會很有用。 在這裡，將原始輸入配對和增益提供給等式（透過 RAWMATCH 和 RAWGAIN 預留位置）。 若要使用此等式，請選取要使用的軌跡 (TR n) 或參數來取代原始配對和增益項。 chan - 通道號碼 xAxisIndex() - 區間號碼（請勿修改） rcvr - 獲取資料的連接埠。 src - 正在驅動的連接埠。 需要有 src 和 rcvr 連接埠才能使用適當的誤差項來計算結果。
d_LDM() | d_LDM(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的負載配對項。 將 chanNum 設定為所需的通道。 將 rcvr 設定為負載連接埠，並將 src 設定為所需負載配對項的來源連接埠。 LDM(ch, xAxisIndex(), 2,1) 可提供在驅動連接埠 1 時由連接埠 2 表示的配對。
d_RFT() | d_RFT(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的反射追蹤項。 將 chanNum 設定為所需的通道。 將 rcvr 和 src 設定為所需反射追蹤項的連接埠號碼。
d_SRM() | d_SRM(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的來源配對項。 將 chanNum 設定為所需的通道。 將 rcvr 和 src 設定為所需來源配對項的連接埠號碼。
d_TRT() | d_TRT(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的傳輸追蹤項。 將 chanNum 設定為所需的通道。 將 rcvr 設定為接收連接埠，將 src 設定為來源連接埠，這樣 TRT(ch, xAxisIndex(), 2, 1) 便可提供連接埠 1 驅動的連接埠 2 輸入接收器的傳輸追蹤項，換句話說，就是原始 S21 追蹤項。
d_XTLK() | d_XTLK(chanNum, xAxisIndex(), rcvr, src) 顯示由通道 <chanNum> 使用的校準集中的隔離項。 將 chanNum 設定為所需的通道。 將 rcvr 設定為接收連接埠，將 src 設定為來源連接埠，這樣 XTLK(ch, xAxisIndex(), 2, 1) 便可提供在連接埠 1 開啟時的連接埠 2 輸入接收器的隔離項。

Expansion.dll

admittance(x)

Admittance(x) = 1/x

計算導納

max_hold(x)

(KEY, getNumPoints(),xAxisIndex(),PARAM)

顯示每個點的最大值

min_hold(x)

(KEY, getNumPoints(), xAxisIndex(), PARAM)

顯示每個點的最小值

PAE(B,S21,AI1,AI2,R,SCALE)

.001 * (B - (B/S21)) / ( SCALE^2*AI1(AI1 - AI2)/R )

功率附加效率。

  • B - 輸出功率

  • S21 - 修正的放大器增益

  • AI1 - DC 電源供應器

  • AI2 - DC 電源放大器

  • R - 電阻

  • SCALE - 刻度

reset(x)

x - 數字。

重設 max_hold() 或 min_hold() 函數。

若要重設指定的 max_hold() 或 min_hold() 函數，請使用相同的鍵調用重設。

SDD11(S11,S21,S12,S22)

(S11 - S21 - S12 + S22)/2

差分模式反射

SDC11(S11,S21,S12,S22)

(S11 - S21 + S12 - S22)/2

C 到 D 模式轉換反射

SCD11(S11,S21,S12,S22)

(S11 + S21 - S12 - S22)/2

D 到 C 模式轉換反射

SCC11(S11,S21,S12,S22)

(S21 + S12 + S11 + S22)/2

共模反射

使用以下兩個等式顯示阻抗與頻率的關係。

以 Z0 的值（通常為 50）取代「LOAD」。

附註：透過在時域軌跡上建立標記，然後將標記格式變更為 R+jX，可以讀出阻抗與時間的關係（不使用此函數）。瞭解操作方法。

zReflect(S11,LOAD)

LOAD*(1 + S11)/(1-S11)

zTransfer(S21,LOAD)

2 * LOAD * (1 - S21)/S21

上次修改時間：

2016 年 01 月 06 日

第一版


輸出資料指南

列印、儲存和重新叫用資料

  • 儲存和重新叫用檔案

  • 列印顯示的量測

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


規格：手動識別 VNA

規格

需要網際網路連線，才能檢視規格文件。

文件編號 | 型號
5992-0291EN | E5080A


u_curve_equations

用於產生不確定性曲線的方程式

本主題不但包含用於在 VNA 規格文件中產生不確定性曲線的量測不確定性方程式，同時也包含有關判斷系統量測不確定性的一般資訊。

附註：VNA 修訂版本 A.09.20 包含了 RSS 運算和最差情況運算

瞭解本主題中的以下子主題：

  • 量測不確定性方程式

  • 順向反射不確定性

  • 順向傳輸不確定性

  • 反向傳輸不確定性

  • 反向反射不確定性

  • 系統誤差的原因

  • 隨機誤差的原因

  • 確定預期系統效能

  • 確定纜線穩定性項（CR1、CR2、CTM1、CTM2、CTP1、CTP2）

另請參閱

  • 量測誤差

  • 什麼是量測校準？

  • 為何需要校準？

量測不確定性方程式

任何量測結果都是實際測試裝置反應與所有誤差項的向量和。每個誤差項的確切影響取決於該誤差項與實際測試裝置反應的幅度和相位關係。當誤差反應的相位未知時，會假設相位為最差情況（-l80x° 至 +180°）。

請檢視在方程式中使用的殘餘系統誤差縮寫。

請檢視在誤差模型和方程式中使用的隨機誤差縮寫。

順向反射不確定性

方程式 1：順向反射幅度不確定性（最差情況運算）

方程式 2：順向反射相位不確定性（最差情況運算）

方程式 3：順向反射幅度不確定性（RSS 運算）

方程式 4：順向反射相位不確定性（RSS 運算）

順向傳輸不確定性

方程式 5：順向傳輸幅度不確定性（最差情況運算）

方程式 6：順向傳輸相位不確定性（最差情況運算）

方程式 7：順向傳輸幅度不確定性（RSS 運算）

方程式 8：順向傳輸相位不確定性（RSS 運算）

反向傳輸不確定性

方程式 9：反向傳輸幅度不確定性（最差情況運算）

方程式 10：反向傳輸相位不確定性（最差情況運算）

方程式 11：反向傳輸幅度不確定性（RSS 運算）

方程式 12：反向傳輸相位不確定性（RSS 運算）

反向反射不確定性

方程式 13：反向反射幅度不確定性（最差情況運算）

方程式 14：反向反射信位不確定性（最差情況運算）

方程式 15：反向反射幅度不確定性（RSS 運算）

方程式 16：反向反射相位不確定性（RSS 運算）

系統誤差的原因

殘餘（在量測校準之後）系統誤差起因於校準標準的缺陷。
對於反射量測，相關的殘餘誤差為：

  • 殘餘方向性

  • 殘餘來源匹配

  • 殘餘負載匹配

  • 殘餘反射追蹤

對於傳輸量測，其他殘餘愈差為：

  • 殘餘串擾

  • 殘餘來源匹配

  • 殘餘負載匹配

  • 殘餘傳輸追蹤

下面的清單顯示用於不確定性方程式中的殘餘系統誤差的縮寫。

  • EDF = 順向殘餘方向性

  • ESF = 順向殘餘來源匹配

  • ERF = 順向殘餘反射追蹤

  • EXF = 順向串擾

  • ELF = 順向負載匹配

  • ETF = 順向傳輸追蹤

  • EDR = 反向殘餘方向性

  • ESR = 反向殘餘來源匹配

  • ERR = 反向殘餘反射追蹤

  • EXR = 反向串擾

  • ELR = 反向負載匹配

  • ETR = 反向傳輸追蹤

  • AM = 幅度動態準確度

  • AP = 相位動態準確度

所有量測均受動態準確度影響。動態準確度包括：在內部自我校準常式期間產生的誤差、微波頻率轉換器（取樣器）在高訊號位準下產生的增益壓縮、同步偵測器中產生的錯誤、IF 濾波系統中產生的局部化非線性以及 LO 洩漏到 IF 訊號路徑而產生的誤差。

隨機誤差的原因

隨機誤差的原因包括

  • 雜訊

  • 接頭可重複性

  • 互連纜線穩定性

任何量測系統都具有下列兩種類型的雜訊：

  1. 低位準雜訊（雜訊底層）

  2. 高位準雜訊（軌跡雜訊）

低位準雜訊是接收器的寬頻雜訊底層，可以藉由平均或變更 IP 頻寬來降低這類雜訊。

高位準雜訊（或稱軌跡雜訊）由接收器的雜訊底層和測試裝置內部的 LO 來源的相位雜訊產生。減少 IF 頻寬可使這類雜訊提高。使用高穩定性 10 MHz 時基可以降低高位準雜訊。

接頭可重複性是在連接一對 RF 接頭時遇到的隨機變化。反射和傳輸過程中的變化均可觀察到。

纜線穩定性取決於所使用的纜線以及校準與量測之間的纜線移動量。

下面的清單顯示用於誤差模型和不確定性方程式中的隨機誤差的縮寫。

  • NF = 雜訊底層

  • NT = 軌跡雜訊

  • CR1 = 連接埠 1 纜線反射穩定性

  • CTM1 = 連接埠 1 纜線幅度傳輸穩定性

  • CTP1 = 連接埠 1 纜線相位傳輸穩定性

  • CR2 = 連接埠 2 纜線反射穩定性

  • CTM2 = 連接埠 2 纜線幅度傳輸穩定性

  • CTP2 = 連接埠 2 纜線相位傳輸穩定性

  • RR1 = 連接埠 1 接頭反射穩定性

  • RT1 = 連接埠 1 接頭傳輸穩定性

  • RR2 = 連接埠 2 接頭反射穩定性

  • RT2 = 連接埠 2 接頭傳輸可重複性

確定預期系統效能

連接方法和接觸面不當會降低量測準確度。

正確的連接方法包括：使用具有正確扭矩限制的扭力扳手，確保接頭接腳深度符合規格，確保滑動負載的中心導體放置正確，觀察無磁珠空氣線的正確處理程序。

導致產生接觸面誤差的原因包括：清潔程序不當、刮傷、電鍍磨損和底座不平整。請檢視有關接頭維護的詳細資訊

如果觀察到的連接方法和接頭維護正確無誤，下表提供了接頭可重複性的指示。

接頭可重複性（RR1、RR2、RT1 和 RT2）
接頭類型 |  | 接頭類型
頻率範圍 | 可重複性 | 頻率範圍 | 可重複性
2.4-mm |  | 3.5-mm
0 至 2 GHz | 0.0002 | 0 至 2 GHz | 0.0001
2 至 20 GHz | 0.0004 | 2 至 8 GHz | 0.0003
20 至 36 GHz | 0.0006 | 8 至 20 GHz | 0.0006
36 至 40 GHz | 0.0008 | 20 至 26.5 GHz | 0.0010
7-mm |  | N 型
0 至 2 GHz | 0.0001 | 0 至 2 GHz | 0.0006
2 至 8 GHz | 0.0003 | 2 至 8 GHz | 0.0006
8 至 18 GHz | 0.0006 | 8 至 18 GHz | 0.0010
F 型 |  | 波導
0 至 3 GHz | 0.0006 | 0 至 40 GHz | 0.0002

確定纜線穩定性項
（CR1、CR2、CTM1、CTM2、CTP1、CTP2）

纜線穩定性取決於所使用的纜線以及校準與量測之間的纜線移動量。透過以下方法可確定纜線反射穩定性的值：將固定負載連接至纜線的自由端，並量測在特定設定的正常纜線移動範圍內使纜線彎曲後反射係數發生的變化。纜線傳輸穩定性的確定方法為：將短路連接至纜線的自由端，並量測反射係數由於纜線位置改變而產生的變化。

圖 1-3 展示了可用於確定纜線穩定性的概念。在每一種情況下，將一條纜線（零件編號 8120-4779）連接至連接埠 1，且固定負載連接至該纜線的自由端。取得參考軌跡的方法是：在自由端保持靠近連接埠 2 的情況下量測 S11，並將結果儲存在記憶體中。您需要再進行兩次 S11 量測：進行其中一次量測時，使纜線彎曲直到變直；進行另一次量測時，將纜線放回到與參考軌跡相同的位置。如圖 1 所示，彎曲位置展示了校準後移動纜線所造成的影響。可重複性軌跡展示了纜線移至原始位置時的穩定性。

圖 1

圖 1 展示了可用於確定纜線反射穩定性的概念。固定負載連接至自由端。DATA-MEM 功能可提供纜線反射穩定性的指示。圖中 60 dB 的峰值將產生估算為 10(−60/20) (或 0.001) 的反射穩定性。

圖 2

圖 2 和圖 3 展示了可用於確定纜線傳輸穩定性的概念。短路連接至自由端。DATA/MEM 功能可提供雙向纜線傳輸穩定性的指示。單向傳輸幅度穩定性可藉由將轉換為線性前的雙向幅度量測除以二來測定。圖中 0.013 dB 的峰值將產生估算為 10(0.013/40) −1 或 0.00075 的傳輸幅度穩定性。單向傳輸相位穩定性可藉由將雙向相位量測除以二來測定。

圖 3

纜線移動時對相位量測產生的影響，通常比對幅度量測產生的影響更大。

另請參閱

量測誤差

什麼是量測校準？

為何需要校準？

上次修改時間：

2010 年 03 月 03 日

新增了 RSS 不確定性


調整概觀

診斷工具

可使用下列工具來協助您讓 VNA 保持最佳效能。

診斷工具

  • 操作員檢查

  • 系統驗證

  • 顯示器測試


預防 VNA SSD 問題

預防 VNA 固態硬碟問題 - 重要

VNA 故障的主要原因是 VNA 固態硬碟 (SSD) 發生問題。這些問題通常是可以預防的，並且在很多情況下可以復原（請參閱從 VNA SSD 問題復原）。以下措施可使您的停機時間減少數週，並節省更換 VNA SSD 的成本。

切勿修改或重新設定作業系統

為提高 VNA 效能，Keysight 已經對 Microsoft Windows 作業系統進行了修改和最佳化。

  • 切勿在 VNA 上安裝標準版本的 Windows 作業系統。

  • 切勿變更進階效能設定或群組原則。

  • 切勿在 VNA 上新增或刪除任何固態硬碟分割區。

  • 切勿修改任何 Keysight 軟體登錄項目。

安裝病毒防護

發貨時，VNA 未安裝任何病毒防護。如果要將 VNA 連線到網際網路，強烈建議使用防病毒程式。

此外，使用防火墻可有助保護 VNA 免遭病毒侵害。但是，部分防火墻可能會限制 VNA 的 DCOM 連線功能。

安裝 Windows 的重要更新

VNA 出廠時始終隨附生產 VNA 時可用的最新 Service Pack 和重要更新。我們建議您自動接受並安裝來自以下 Microsoft Windows Update 網站的最新重要安全性修補程式，從而始終為 VNA 提供最新的可用保護：http://windowsupdate.microsoft.com

只有當電源按鈕為黃色時，才從 VNA 斷開電源

在電源按鈕為綠色時拔下電源線或斷開電源，可能會損壞 VNA SSD。暸解有關開啟和關閉 VNA 電源的詳細資訊。

是否有 VNA SSD 的問題？

如果您遇到可能由 VNA SSD 故障導致的問題，請參閱從 VNA SSD 問題復原。


支援概觀

產品支援概觀

瞭解 VNA

  • 規格

  • VNA 組態和選項

  • 分析儀配件

升級 VNA

  • 韌體更新

  • 選件啟用

  • 儀器校準

VNA 問題

  • VNA 疑難排解

  • 關於錯誤訊息

  • 診斷工具、公用程式和調整

適用於 VNA 的資源

  • 技術支援

  • 其他資源

提示：使用將應用程式移動至後面可使 VNA 應用程式在畫面上移至這些支援應用程式的後面。

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


顯示更新

如何設定顯示更新

使用硬鍵/SoftTab/軟鍵

  1. 按下 [Display] > Display Settings（顯示設定）> Display Update（顯示更新）（開啟顯示更新）。

  2. 按下 [Display] > Display Settings（顯示設定）> 按一下 Display Update（顯示更新）左側的小按鈕（關閉顯示更新）。

備註：

  1. 開啟/關閉顯示更新將反映在狀態列上。

  2. 更新狀態開啟/關閉是儲存/重新叫用狀態的一部分。

  3. 您可以使用軟鍵開啟/關閉更新狀態以及立即執行更新。

  4. 停用顯示更新將會顯著提升效能。對於單一通道和視窗狀態來說，由於停用更新而產生的效能提升似乎微不足道。但是，如果有大量通道、視窗和軌跡，結果將會大不相同（而是停用顯示更新將會顯著提升效能）。例如，效能存在問題，在執行具有 201 個點的 1.0GHz 至 1.2GHz 掃掠時，INDEX 線（處理常式 I/O）出現以下情況（否則套用預設條件）。為高時，對話方塊會執行掃掠。許多掃掠之間存在 20ms 的死區時間。

上次修改時間：

2016 年 01 月 06 日

第一版


系統主題

系統設定和組態

VNA 系統設定

  • 顯示顏色

  • 頻率留空（基於安全性目的）

  • 接收器溫度

  • VNA 偏好設定

  • 功率限制和功率偏移（防止受測裝置功率過高）

  • 預設分析儀

  • 系統阻抗

  • 關於錯誤訊息

外部硬體設定主題

  • 設定外部裝置

    • 設定外部 RF 來源

    • 設定功率表作為接收器 (PMAR)

  • E5092A 測試裝置控制

  • 介面控制

另請參閱

管理工作指南

連接指南

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。

上次修改時間：

2016 年 01 月 06 日

第一版


教學指南

教學課程

  • 視訊

  • 應用程式附註

  • 接頭維護

  • 靜電放電 (ESD) 保護

量測教學課程

  • 絕對輸出功率

  • 放大器參數

  • 平衡量測

  • 複數阻抗

  • 比較 VNA 延遲功能

  • 線性相位偏差

  • 增益和真平度

  • 群組延遲

  • 相位量測

  • 反向隔離

  • 反射量測

  • 時域量測

注意：避免昂貴的 VNA 維修費用。請閱讀靜電放電保護。


視訊

請透過以下網站觀看並訂閱最新的 Keysight 網路分析儀視訊：

https://www.youtube.com/user/keysightnetworkanlyz

（需要網際網路連線）